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Key Editor in Write mode

Dorico has always included a piano roll editor in Play mode, together with tools for
editing note velocities, MIDI continuous controllers, and so on. These tools, more
conventionally found in a digital audio workstation like Cubase, are increasingly
important to users of music notation and composition software like Dorico, as the
demands of sophisticated virtual instruments and sample libraries mean that a
wider range of musicians than ever before needs to be able to manipulate and
shape the virtual performance of their music.

Dorico 4 extends these tools beyond Play mode and into Write mode, allowing you
to work more fluently with the piano roll and MIDI editors directly alongside
standard music notation. These editors are now found in the lower zone in both Play
mode and Write mode, and together they are now known as the Key Editor.
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Showing the Key Editor. In both Write mode and Play mode, you can show the Key
Editor by showing the lower zone, which you can do either by clicking in the
disclosure area along the bottom of the project window or using the key command
Ctrl+8 (Windows) or Command-8 (Mac). The lower zone now accommodates a
number of different panels in each mode, but in both Write and Play modes, the Key

Editor is the rightmost button in the panel selector at the left-hand side of the lower

zone toolbar. Click = | to show the Key Editor.
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In Play mode, you can also quickly show the Key Editor by double-clicking a track in
the track overview, which will show the lower zone if it is currently hidden, and
switch to the Key Editor.

Choosing what instrument to edit. The Key Editor allows you to edit the material of
one instrument at a time. In Play mode, you specify the instrument by selecting its
track in the track overview.

In Write mode, by default the Key Editor is in linked mode, indicated by the -
button in the lower zone toolbar. When in linked mode, the instrument shown in
the Key Editor follows the selection you make in the music notation: the horizontal
zoom is adjusted to bring the music corresponding to the system where the current
selection begins, and the vertical position of the piano roll is adjusted to bring the
music into view. In this way, the same music that you can see in the notation is
shown in the piano roll, and the view is automatically updated as you move around
the layout.

You can manually deactivate linked mode by clicking the button in the lower zone
toolbar, or alternatively Dorico will automatically deactivate linked mode when you
directly manipulate the zoom level, vertical position of the piano roll, or manually
scroll the view in the piano roll. Once linked mode is deactivated, Dorico will not
automatically update the view in the piano roll, until you reactivate linked mode

once more.

Lower zone toolbar. To the right of the panel selector buttons, the lower zone toolbar
includes the following tools when the Key Editor is active:

Up-stem voice 1

1 2 3 4 5 6 7. 8. 9. 10 11

1. Select tool In Play mode, this tool has the key command S. Selects individual
notes in the piano roll, velocity bars in the velocity editor, or points in the MIDI
controller editor. When you click on multiple items in succession, the previous
item is deselected.

2. Multi-select tool. Selects multiple items in the Key Editor. Click on multiple
items in succession to add them to the selection, or click a selected item a
second time to remove it from the selection again. To make a marquee
selection, click and hold the mouse button for a moment on a blank area of the
editor; an animated rectangle will appear after a moment to show that it is now
ready to make a marquee selection. Keep the mouse button held down and drag
out a rectangle to select all enclosed items.

3. Drawtool. In Play mode, this tool has the key command D. In the piano roll, this

allows you to add new notes: simply clicking will add a note of the current
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rhythmic grid value; click and hold the mouse button for a moment and you can
drag out a note of any duration. In the velocity and MIDI controller editors, you
can sweep across a horizontal region to edit successive velocities, or drawin a
series of controller data points.

Line tool (velocity and controller editor only). In Play mode, this tool has the key
command L. The line tool allows you to edit successive velocities in a linear
fashion, increasing or decreasing them over time according to the angle of the
line you drag out between two points. In the MIDI controller editor, it creates a
line between two points, and Dorico will then generate appropriate controller
events over the course of the line to play back the changes over time.

Multi-edit tool (velocity editor only). This tool allows you to perform
transformations on a range of velocities. Click and hold the mouse button, then
drag across a range of velocities to determine the range to be transformed. The
specific transformations that can be performed are described below.

Delete. Deletes the selected notes in the piano roll or velocity editors, or the
selected controller data points in the MIDI controller editor.

Played duration / Written duration. Toggling the piano roll display between

showing played durations W and written durations i allows you to edit
either the playback data of notes without affecting the way they are shown in
the layout, or to edit the notated durations.

Rhythmic grid selector. The Key Editor has its own rhythmic grid setting shared
between Play and Write modes, independent of the rhythmic grid used by
editing the music notation directly.

Playback techniques. Hides or shows the playback techniques lane between the
piano roll and velocity editors, so you can see which playback techniques are
being used at any given moment; hover your mouse over an entry in the lane to
show a tool tip with more detailed information.

Linked mode (Write mode only). Determines whether the Key Editor follows the
selection you make in the music notation.

Voice selector. Determines the voice you are currently editing; notes in other
voices are shown in grey.

Switching between editors. When the Key Editor is first shown, the piano roll editor

is active by default. To activate the velocity or MIDI controller editors, click either in

the header area at the left-hand side, or click on any part of the editor itself. To

activate the piano roll editor again, similarly click either in the vertical piano

keyboard display at the left-hand side, or click on any part of the editor itself.

Currently, the velocity and MIDI controller editors are combined into a single area

(though we plan to make it possible to show multiple editors in addition to the piano

roll editor in a future release). The menu immediately below the Automation and
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CC heading allows you to choose between editing velocity and any MIDI controllers

for which data already exists.

If you have not yet added data for a particular MIDI controller, it will not yet appear
in the list: click the + button next to the Add Automation label to show a selector
from which you can choose the desired MIDI controller. The chosen MIDI controller

is now selected in the menu above, allowing you to add your own data.

Piano roll editor. If you are familiar with the piano roll editor in a DAW or sequencer,
you should feel at home with Dorico’s editor. One possibly unfamiliar aspect is that
you can edit either the written durations of notes, or only edit their played
durations without affecting the appearance of the notation. The notes themselves
appear different in each mode:

Written durations Played durations

When editing played durations, the written duration is shown as a thin line
immediately below the editable part of the note, which represents the note as it will
be played back.

Select a single existing note with the select tool active, or use the multi-select tool
to select multiple notes. You can then, if the editor is set to edit written durations:

= edit the pitch of the selected notes by dragging them up or down;

= edit the rhythmic position of the selected notes by dragging them left or
right, and as you drag, the notes snap to rhythmic grid positions;

» edit the written start position by dragging the left-pointing triangle at the
start of one of the selected notes;

» edit the written end position by dragging the right-pointing triangle at the
end of one of the selected notes.

If you have the editor set to edit played durations, you can still edit the pitch by
dragging the notes up and down, but editing the starts or ends of the notes will edit
their playback onset and offset properties rather than affecting the notation.

To write new notes into the piano roll, activate the draw tool, then:

» clickto add a note of the pitch that corresponds to the key shown in the
vertical piano keyboard at the left-hand side, of the current rhythmic grid

value in duration;

Dorico 4 Version History 6 Steinberg Media Technologies GmbH
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» click and hold the mouse button for a moment, then drag to the right to
increase its duration; you can also drag up or down to edit the pitch of the
note before you release the mouse button.

One other unique feature of Dorico’s piano roll editor, and new in Dorico 4, is that it
displays any tuplets that apply to the current voice immediately below the ruler.
You can drag notes in and out of tuplets freely, and Dorico will correctly scale and
unscale them as required.

By default, the piano roll is linked to the selection in the music notation view in
Write mode, but if you drag, scroll or zoom the piano roll view, it will become
unlinked. You can re-enable the link at any time simply by clicking the link button
in the lower zone toolbar.

To change the zoom level of the piano roll, you can use the floating zoom control
that appears in the bottom right-hand corner of the Key Editor:

The arrows at the left- and right-hand sides of the zoom control determine whether
the slider will affect the horizontal or vertical zoom; click the arrows that represent
the direction you want to zoom in, then drag the slider.

Alternatively, you can drag up and down in the ruler at the top of the piano roll
editor to change the horizontal zoom, or in the vertical piano keyboard at the left-
hand side to change the vertical zoom.

Velocity editor. To edit note velocities, activate the velocity editor by clicking
anywhere in the editor itself or in the header area on the left-hand side. You can
edit individual note velocities by using the select tool to select an individual note,
then click again and drag the top of the velocity bar to change its value. To edit the
velocity of an individual note in a chord, first select the note in the notation (in
Write mode) or in the piano roll. You can then click and drag the velocity bar to set
that individual note’s value.

To edit the velocities of multiple notes, you can use the draw tool to draw values
freehand over a range of notes or use the line tool to create a consistent increase or
decrease in velocity over the range. For more detailed editing, use the multi-edit
tool to select a range of notes: click the mouse button and hold for a moment to start
a marquee selection, then drag across the notes you want to edit.

Dorico 4 Version History 7 Steinberg Media Technologies GmbH
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You can click and drag on any of the tools around the edge of the selection to
transform the velocities. Moving clockwise from the bottom left-hand corner:

* Randomize. Drag up and down to randomize the selected values.

= Delta. Drag up and down to increase or decrease all the selected values by a
fixed amount.

= Tilt left. Drag up and down to tilt the values so that they gradually increase
from the start of the selection to the end.

= Tiltright. Drag up and down to tilt the values so that they gradually decrease
from the start of the selection to the end.

= Scale. Drag up and down to increase or decrease the selected values by a
scale factor, so larger values change more quickly than smaller ones.

Editing velocities with the histogram. A histogram is a chart where values are
grouped according to frequency distribution. Click the Histogram button to show
the velocities for the current instrument as a histogram; by default, All notes will be
shown, but you can alternatively show the notes only from the current Voice chosen

in the voice selector, or in the Selection.

Voice  Selection
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Itis also possible to switch between showing the values as bars, as shown above, or
showing an area chart.

In a similar fashion to the multi-edit tool, the histogram editor provides a set of
tools at the corners of the values. Moving clockwise from the bottom center:

» Scale. Increases or decreases all the values by a scale factor.

» Compress orexpand. Drag left to expand the values out to a wider range, so
the lowest values are lower and the highest values are higher, or drag right
to compress the values to a smaller range.

» Lowerlimit. Allows you to increase the lower limit, i.e. to increase the value
shown as Min in the read-out at the top left corner of the histogram.

» Delta. Allows you to add or remove a delta to all values, effectively shifting
all the values up or down by the same amount.

= Upperlimit. Allows you to decrease the upper limit, i.e. to decrease the value

shown as Max in the read-out at the top left corner of the histogram.

At the very bottom left corner of the histogram editor is the randomize tool, which
you can drag up and down to edit all the shown values by a random amount.

If you want to undo the edits you have made during the current session in which the
histogram editor is shown, click Reset in the histogram editor toolbar to return all

notes’ velocities to their prior values.

The histogram editor makes it easy to change the overall character of an
instrument’s music: you can push the overall velocity level higher or lower, expand
the range of velocities used to increase the dynamic contrast, or provide a small
degree of randomization to avoid repetitive use of the same samples at precisely
the same velocity levels throughout the music.

Further editors. Dorico 3.5 and earlier versions included a few other editors that are
not yet included in Dorico 4, including the dynamics editor and the tempo editor.
We are sorry that these editors are not included in the initial release of Dorico 4, but
they will return in new and improved form in a future free maintenance update. In
the meantime, we apologize for any inconvenience caused by their absence.

Revamped Play mode

Dorico 4 introduces a brand new user interface for Play mode, designed to
complement the changes that allow the Key Editor to be used in Write mode as well
as Play mode. If you have used Play mode in Dorico for iPad, then the new layout on
the desktop will look familiar.

9 Steinberg Media Technologies GmbH
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Interface changes since Dorico 3.5. The toolbox on the left-hand side has been
removed, with the tools moving into the toolbar in the lower zone, when the Key
Editor is shown.

The VST Instruments panel on the right-hand side has been removed, and is now
found on the left-hand side, where you can switch between showing the track
inspector and showing the VST and MIDI instruments in the rack.

The individual track headers for each instrument are now more minimal than
before, serving primarily as a means of selecting an instrument, which then
updates both the track inspector on the left and the Key Editor in the lower zone.
From the track header you can mute and solo the track, but otherwise all editing is
performed via the track inspector.

Track inspector. The controls that were previously in the track header for assigning
the endpoint (combination of plug-in, port, and channel) are now found in the

Routing section of the track inspector.

For pitched instruments (not for percussion Kits), you can click Turn on IRV in the
Routing section to enable independent voice playback, which shows a separate
track for each voice in the track overview area. Select the track associated with each

voice to change the endpoint settings in the Routing section of the track inspector.

The Insert Effects and Channel sections in the track inspector mirror the relevant

sections of the new Mixer.

Track overview. The track overview shows all the tracks in the current flow and
layout. Select a track to edit its settings in the track inspector on the left-hand side,
or to edit its musical content in the Key Editor in the lower zone.

10 Steinberg Media Technologies GmbH
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To fit more tracks into the vertical height of the window, click in the area above
the track headers to cycle between three different vertical sizes for the tracks in the

overview.

You can change the horizontal zoom of the track overview by clicking and dragging
vertically in the ruler at the top of the window. To position the playhead, simply click
intheruler.

Global tracks. The Tempo, Chords, and Markers global tracks are shown above all of
the instrument tracks in the track overview. They can be hidden or shown using the
buttons above the track headers.

For the Tempo and Chords global tracks, you can use the Routing section of the
track inspector to change the endpoint for the metronome click and the playback of
chord symbols respectively.

You can add a new marker at the playhead position by clicking the + button in the

Markers global track header.

Lower zone. You can now open the lower zone in Play mode, where it can show
either the new Mixer or the Key Editor. Like the track inspector, the Key Editor in
the lower zone follows the selection in the track overview, so to view the piano roll
and velocity editors for a particular instrument, select it in the track overview.

The lower zone can be resized by grabbing the handle at the right-hand side of the
lower zone toolbar, or anywhere along the length of the toolbar where your mouse

pointer turns into resize arrows.

The tools formerly in the Play mode toolbox on the left of the window are now
shown in the lower zone toolbar, together with a new drop-down to allow you to
specify the voice to be edited; if multiple voices are present, the active voice is
shown in the accent color for the track, and other voices are shown in grey. A button
to show the playing technique lane is also found in the lower zone toolbar, and
when shown the playing technique lane appears in between the piano roll and
velocity editors.

Further editors. Play mode in Dorico 3.5 and earlier versions included a few other
editors that are not yet included in Dorico 4, including the tempo editor and the
drum editor. We are sorry that these editors are not included in the initial release of
Dorico 4, but they will return in new and improved form in a future free
maintenance update. In the meantime, we apologize for any inconvenience caused
by their absence.
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Revamped Mixer

The Mixer has been completely rebuilt from scratch in Dorico 4. It is functionally
identical to the Mixer in previous versions, but is now more performant, more
beautiful to look at, and available in more locations in the software. It can be shown
in its own window, as before, but it is also now embedded in the lower zone, and
accessible in Write, Engrave and Play modes.

Mixer window. To show the Mixer window, click M in the toolbar, or choose

Window » Mixer, or use the key command F3.

The Mixer is split into two resizable sections, with the main fader controls in the
lower section, and the insert effects, EQ and effects send controls in the upper
section.

To add an insert effect, load it into one of the slots in the Inserts section for that
channel. Once an effect is loaded into one of the slots, hover the mouse pointer over
that effect to see the controls to bypass the effect or show its interface. To remove

the effect, choose the --- entry at the top of the list of available effects.

The EQ is enabled by clicking the circular indicator to the left of the EQ label in the

section header. Each band can then be enabled and disabled independently.

The effects send is enabled by default and can be disabled by clicking the circular
indicator to the left of the FXlabel in the section header. The fader specifies how
much signal should be sent to the Reverb channel, which has the REVerence

convolution reverb effect loaded by default.

The Mixer is now a regular window, so it is not forced in front of all windows
belonging to all applications, and it does not disappear on macOS when the
application loses focus; as a corollary, however, that means it can also disappear
behind the project window.

Lower zone Mixer. When shown in the lower zone, only the most commonly needed
sections of the Mixer are shown: main fader, pan, mute and solo controls.

Channel filters. Whether shown in the lower zone or as a separate window, you can
filter which channels are shown in the Mixer by using the filters shown in the lower
zone toolbar or in the Mixer window toolbar.

By default, the Mixer does not show unused channels, in other words those outputs
in the loaded VST plug-ins that do not have any instrument routed to them. This
minimizes the number of faders that you see in the Mixer.

12 Steinberg Media Technologies GmbH
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On-screen instruments

The lower zone in Write mode now includes three new, beautiful and useful on-
screen instruments, which are designed to assist with note input and editing: the
Keyboard panel is ideal for inputting into any pitched instrument; the Fretboard
panel allows quick and easy specification of string and fret information for notes on
fretted instruments like guitar; and the Drum Pads make it quick and easy to input
for specific instruments in a percussion kit.

Pitt mosso

Keyboard panel. To show the Keyboard panel, first show the lower zone by clicking
in the disclosure area along the bottom of the project window or using the key

command Ctrl+8 (Windows) or Command-8 (Mac), then click m

You can resize the lower zone to make the Keyboard panel larger or smaller, either

by dragging the resize handle = at the right-hand side of the lower zone toolbar, or
by dragging the top edge of the lower zone.

You can also change the width of the keys in the Keyboard panel by enlarging or
reducing the range of keys shown: the keyboard range selector immediately above
the large keys shows the keys currently visible in white, with those keys outside the
visible range shaded. You can click and drag the dark grey keys at the top and
bottom of the visible range left or right to increase or decrease the visible range,
thus changing the width of the visible keys. You can also change the visible range of
keys by clicking and dragging the white area between the two dark grey keys.

The Keyboard panel can be used both in step-time input and when recording in real
time by clicking the keys with the mouse, or, if you have a touch-enabled display
(for example, a Windows Surface computer or similar), by tapping them directly
with your fingers. If you do not have a touch-enabled display, you are unlikely to get
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satisfactory results when recording in real time clicking on the keys with the
mouse, but the option is there should you need it.

However, it can certainly be convenient to use the Keyboard panel for step-time
input: the lower zone toolbar contains the common note durations and
articulations, so most of the items you need for note entry are within easy reach
with the mouse. Similar to input with a MIDI keyboard, Dorico will choose an
appropriate enharmonic spelling for notes automatically, but if you want to adjust

the spelling of the note you have just input, use the appropriate Respell button.

Outside note input, the Keyboard panel depresses the keys corresponding to any
selected notes, which can be helpful to visualize a chord voicing or harmony. When
there is no selection, if you play on your MIDI keyboard, the corresponding keys on
the Keyboard panel will become pressed and released as you play.

Fretboard panel. To show the Fretboard panel, first show the lower zone by clicking
in the disclosure area along the bottom of the project window or using the key

command Ctrl+8 (Windows) or Command-8 (Mac), then click o

The Fretboard panel can only be used with fretted instruments, and the display

updates as appropriate for the kind of instrument you choose, with the number of
frets and strings as specified in the Edit Strings and Tuning dialog. If you define a
full or partial capo (see Capos for fretted instruments below), the capo will also be
shown in the Fretboard panel and will effectively block off the frets below the capo
on the appropriate strings.

Like the Keyboard panel, the Fretboard can be used to input notes, though only in
step-time input. When the caret is visible, simply click the string at the fret position
where you want the note to be input. If you have a touch-enabled display (for
example, a Windows Surface computer or similar), you can also input by tapping
directly with your fingers.

Outside note input, the Fretboard panel shows the fret positions for the selected
note or chord. If the notes were input directly with the Fretboard, or have otherwise
have the string on which they should be played set explicitly, for example in
tablature, they will appear at the corresponding place on the Fretboard; if, however,
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the notes were input using alphabetic input or using a MIDI keyboard, Dorico will
automatically calculate the string and fret positions.

Drum pads. To show the Drum Pads panel, first show the lower zone by clicking in
the disclosure area along the bottom of the project window or using the key

command Ctrl+8 (Windows) or Command-8 (Mac), then click A

= W o @ = Fr@J -

Snare Drum Floor tom Kick Drum Hi-hat (pedal)

Crash Cymbal i-ha Ride Cymbal Tom-tom 1 Tom-tom 2 Snare Drum Snare Drum

The Drum Pads panel can only be used with unpitched percussion instruments and
kits. The display updates to show the appropriate combination of instruments and
playing techniques when you select a note, rest or other item on a percussion kit.

The arrangement of pads shown can be edited: click k&l and the outline around each
of the pads turns orange, indicating that they can now be dragged into a new
position. Click Add Space in the lower zone toolbar to add a spacer pad that allows
you to create gaps between pads if you choose. The arrangement of the pads is
saved for the instrument or kit in the current project.

You can use the drum pads to input notes both in step-time input and when
recording in real time. When recording in real time, clicking closer to the centre of
the pad will produce a higher velocity than clicking near the edge of the pad. If you
have a touch-enabled display, you can tap the pads directly with your fingers, and
tap multiple pads simultaneously.

Smart MIDI import

MIDI files provide the most common route to transfer data between music notation
software like Dorico and sequencers and digital audio workstations like Cubase.
One of the most common workflows involves taking a mock-up produced in a DAW
written for virtual instruments and transferring it to a scoring application for
orchestration, the process of translating the composer’s intentions currently
expressed in terms of the specific sound libraries and virtual instruments in use in
the DAW into notated music that can be performed by a live ensemble.

Mock-ups are often written in large-scale DAW templates, with many tracks
- certainly dozens, frequently hundreds, and sometimes thousands. Before the
orchestration process can begin in earnest, the first step is to understand the
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structure of the template, which can itself be a time-consuming process. The music
that is ultimately intended for a single or section player might be split across many
tracks, with different playing techniques and articulations played by each track;
some of the music may be doubled up with alternative or additional sounds to
provide a richer, lusher sound in the mock-up, but resulting in tracks that can be
omitted as they duplicate material already found in other tracks; the tracks may
have cryptic names that make sense to the composer, but which require
deciphering by the orchestrator.

Even after understanding the structure of the template, the job of distributing the
music from the large number of tracks in the MIDI file to the appropriate players in
the notated score is a serious logistical undertaking, manually copying and pasting
music from staves created by the import process into the staves that form part of
the final notated score.

And since composers often use the same large-scale template for multiple cues or
pieces within the same project, a good deal of this logistical work must be repeated
for every cue, with very little help in automating any of these steps.

Dorico 4 greatly streamlines this entire process: it introduces a new workflow for
transferring MIDI data into music notation, with a great deal of assistance that
mostly automates the time-consuming busy work that precedes the real job of
preparing the music for the recording session.

The new MIDI file import workflow in Dorico 4 allows you to quickly eliminate
empty tracks, map multiple tracks representing different articulations and playing
techniques onto a single instrument, or indeed map a single track representing
multiple instruments onto multiple instruments, filter out key switches, detect
grace notes, slurs, trills and tremolos automatically, and so on — and every decision
you make is then stored in Dorico’s track memory, so you need only make it once.
Next time you open a project with the same or similar tracks, Dorico automatically
configures things the way you did before.

Opening versus importing. If you want to create a new project from your MIDI file,
use File » Open to open the MIDI file. This will allow Dorico to create all the required
players and instruments as determined by the process of mapping tracks in the
MIDI file onto players and instruments.

If, on the other hand, you already have a suitable template with the target players
and instruments created, use File » Import » MIDI to import the MIDI file into the
current project; you can still create any additional players and instruments
required as part of the import process.
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When importing into an existing project, you can choose to import into a new flow,
or to import the music into an existing flow. This is very helpful, as it makes some
advanced workflows possible: for example, if you receive an updated MIDI file from
a colleague but only some of the instruments have new music, you can re-import
the material belonging to those instruments, overwriting the previous version
while leaving the rest of the ensemble untouched; or if you discover that a single set
of quantization values don't produce ideal results for all of the tracks in the MIDI
file, you could re-import the MIDI file into the existing flow using different
quantization options and importing the music only from a subset of tracks.

To choose whether the music should be imported into a new or existing flow, set the
Destination drop-down in the top right corner of the MIDI Import Options dialog

accordingly.

Basic versus advanced editing. When the MIDI Import Options dialog opens, by
default it shows the basic editor, which primarily consists of a table showing the
tracks in the MIDI file, with a few global options in the bar at the top of the dialog.

Here you can find the option to Use track memory. If you want Dorico to remember
the choices you make for the tracks in this MIDI file so that they will be
automatically applied the next time you open this MIDI file, or another MIDI file
with identically named tracks, activate this option.

Interpret as General MIDI determines whether Dorico should use the MIDI
program changes at the beginning of each track as hints for determining the
instruments. Similarly, it gives Dorico the hint that any track set to use channel 10
will contain unpitched percussion using the General MIDI drum set. If you are not
certain that your MIDI file conforms to General MIDI conventions, you should
deactivate this option.

As arule of thumb, older MIDI files of popular works that you download from the
internet may well conform to General MIDI conventions, but newly created MIDI
files you receive from a sequencer or DAW probably do not.

If you are importing rather than opening the MIDI file, the Destination drop-down
allows you to specify whether the MIDI file should be imported into an existing flow,
or whether a new flow should be created. Re-use existing players tells Dorico
whether it should try to assign the tracks in the MIDI file to players and instruments
that already exist in the project, or whether it should create new players and
instruments for each track by default.

Once you have set these global options appropriately, you can review the tracks in
the MIDI file itself and determine which should be imported, and how they should
be mapped onto players and instruments in your project.
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Basic editing. When the basic editor is enabled, the dialog looks like this:

MIDI Import Options

Importing MIDI File: RaiderRG.MID @ Use track memory Interpretas General MIDI  Destination:  The Raider's Marchv Re-use existing players

Tracks from the MIDI file Advanced editor

Filter... Show only enabled

TR MIDI track name Instrument(s) in track Technique(s) Family Destination instrument Max sim. notes Total no. of notes.
Flutes/Piccolo Flute Woodwinds Flute1 3

Oboes/English Horn Oboe Woodwinds Oboe 1 E

Clarinets Clarinet Woodwinds Clarinet 1

Bassoons Bassoon Woodwinds Bassoon 1

French Horns. Horn Brass Homn 1

(<< T < I < I < I <

Trumpets Trumpet Brass Trumpet 1

Trombones Trombone Brass Trombone 1

(<]

Mallets Glockenspiel Pitched Perc Glockenspiel 1
Percussion Drum Set Unpitched Percussion  Drum Set1
Harp Harp Pitched Percussion  Harp1

Violin | Violin Strings Violin 1

Violin I Violin Strings Violin2

Violas Viola Strings Viola2

Cellos Violoncello Strings Violoncello 2

Basses Double Bass Strings Double Bass 2

(<]

Enable Selected  Disable Selected  Invert Selection  SelectAll

Import Options

Cancel

Immediately above the tracks table is a filter edit control, allowing you to type part
of a track name to show only those tracks that match the filter text. The toggle
buttons to the right of the filter edit control allow you to show either all tracks, or

only those that are enabled for import.

By default, all non-empty tracks are enabled for import. To disable a track for
import, deactivate its checkbox at the left of its row in the tracks table. To enable or
disable multiple tracks at once, make a multiple selection in the tracks table with

Shift+click or Ctrl+click (Windows) or Command-click (macOS) and click Enable

Selected or Disable Selected in the action bar at the bottom of the table.

The Instrument(s) in track column shows which instrument Dorico thinks is
represented by each track. If you want to change the assignment, simply double-
click the shown instrument, which opens a simple dialog containing the standard
instrument picker, allowing you to choose the desired instrument. If the track
represents multiple instruments - for example, a single horns track needs to be
mapped onto multiple horn instruments in the resulting flow — you must use the
advanced editor, described below.

The Technique(s) column shows which playing technique, if any, is represented by
this track. If the track is the normal or natural playing technique for that
instrument, you don't need to specify that: similarly, if the track contains a mixture
of normal and legato notes, you don't need to specify the legato playing technique,
as Dorico will automatically create slurs as needed. You can double-click the cell in
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the table to activate a drop-down from which you can choose one of the preset
playing technique combinations; if you require a combination that is not shown,
you must use the advanced editor, described below.

The Max. sim. notes column tells you how many notes are played simultaneously
on each track, which is helpful when determining whether the track represents a
single instrument or multiple instruments.

Finally, Total no. of notes provides a count of the notes in each track. This allows
you to see at a glance which tracks in the MIDI file contain no notes at all, and which
it may therefore be unnecessary to import.

For simple cases, checking the tracks table as described above is sufficient: you can
now click OK to import the MIDI file. If you want to explore the deeper capabilities,

read on.

Import Options. To show additional options for MIDI import, expand the Import

Options section at the bottom of the dialog. You can scroll within the dialog if

necessary to see all these options:

Import Options
Instruments Notations Players

Use GM program changes to identify instruments Import CC64 as pedal lines @ Create player group for new players

Interpret channel 10 as General MIDI percussion Snap pedal lines to previous beat Create part layouts for new players

@ Overwrite all track contents when importing into existing flow/player Sl

Detect slurs

Detect tremolos

Interpretation ;
Detect trills

Create playing techniques
split point for grand staff instruments:

Split at MIDI note number: Performance

Filter out keyswitches outside range: ~ Bbl c

@ Preserve note velocities

G Preserve note positions
uantize Options...

Instruments section:

= Use GM program changes to identify instruments specifies whether
Dorico should use the MIDI program changes on each track as a hint to
identify instruments; if this option is switched off, Dorico will use the track
name as the primary means of determining the instrument.

= Interpret channel 10 as General MIDI percussion specifies whether any
tracks set to use channel 10 should be assumed to conform to the General
MIDI drum set standard.

= Overwrite all track contents when importing into existing flow/player

determines whether existing music should be overwritten, or new music
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should be merged with the existing music. This option applies only when
importing a MIDI file into an existing flow.

Interpretation section:

= Split point for grand staff instruments determines how music imported
onto grand staff instruments should be disposed between the two staves: if
Auto is chosen, Dorico will consider musical context and normal hand span
when determining whether notes should be assigned to each staff; if Fixed
is chosen, the value of Split at MIDI note number will be used.

* Filter out key switches outside range allows you to specify the playable
range for the tracks in the MIDI file, omitting any notes that are required to
trigger specific articulations or playing techniques in the sound library or
virtual instrument used in the original sequence. Any notes lower than the
low note name and octave, and any notes higher than the high note name
and octave, will be omitted during import.

The options in the Notation section are the same as those found in the Recording
section of the Play page of Preferences, and the options in the Performance section
are the same as those found in the Quantization section - see Polyphonic MIDI

transcription below for further discussion of these options.
Players section:

= Create player group for new players creates a player group to contain all
the players added as part of the import process: if you already have an
existing ensemble of players in your project, it can be helpful to group newly
added players together so that you can find them easily.

= Create part layouts for new players specifies whether players added as
part of the import process should have part layouts created for them; if you
know you are going to remove these players later after moving their music
to existing instruments, it may be helpful not to see part layouts for these
temporary players in the interim.

Dorico remembers the state of all these options, so they will be set the same way for
each MIDI file that you import.

Advanced editing. For complex MIDI files, you may require greater control than
provided by the basic editor. Activating the Advanced editor toggle button shows
two additional sections, Track settings and Players in Dorico project, that together
provide detailed control over how each track is mapped to one or more players in

the resulting flow.
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The Track settings section updates based on the selection in the tracks table on the
left-hand side of the dialog. It shows the full details of how the track will be
interpreted during import:

Track settings Players in Dorico project

Instruments in track: . U MITl ok nines

Horn
Horn
Horn

+8 7 L]
Player type: Section
Transpose 0

Playing Tech.:

Start:

Articulations:

. Staccato . Tenuto

. Staccatissimo . Tremolo

. Accent . Half-tone trill
. Marcato . Whole-tone trill

Horn 2
0

Horn 3
=
Voice Separation Mode:

The Instruments in track list at the top of the section shows the instruments
required by the track. If you have, for example, a Horns track that shows 4 under
Max. sim. notes, you may well want to specify four horn instruments in the
Instruments in track list, so that each individual horn line will end up in its own
instrument. When you select an instrument in the Instruments in track list, a
corresponding selection is made in the Players in Dorico project list to the right. If
the track requires more instruments than exist at present, new players will be
added to the Players in Dorico projectlist to accommodate the required
instruments. Players that are going to be added show + in their icon kil to

differentiate them from players already present in the project.

Player type allows you to specify whether the players required for the instruments

in this track should be Single or Section players.

Transpose specifies the number of half-steps (semitones) by which the music in the
track should be transposed; some sample libraries and virtual instruments
transpose instruments by one or more octaves to bring them into a more useful
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playable range on a MIDI keyboard. To transpose by an octave, specify 12 to

transpose up or -12 to transpose down.

Playing tech. specifies the pair of playing techniques represented by this track.
When preparing templates in a sequencer or DAW, composers often create
multiple tracks for a single instrument, so that it's easy to access different playing
techniques and articulations simply by moving notes to a different track, which is in
turn set to trigger a particular sound in the sample library or virtual instrument in
use. Dorico can combine multiple tracks, each representing a different playing
technique or articulation, into a single instrument. The first in the pair of playing
techniques specifies the playing technique that is used when music from this track
appears, and the second in the pair specifies the technique that is used when music
from this track ends.

For example, if music for a violin instrument is split across two tracks, one using the
normal or natural playing technique and the other using pizzicato, you would
choose Pizzicato/Arco for the pizzicato track. Dorico will then automatically create
the required pizz. playing technique at the start of the music notated from the
pizzicato track, and arco at the start of the music notated from the natural track.

If you need a combination of playing techniques that is not listed, you can choose
Custom from the Playing tech. drop-down, then set the Start and End playing

techniques using the dedicated menus immediately below.

Similarly, the Articulations section specifies which articulation is represented by

this track. If you choose, say, Staccato, then all notes from this track will be notated

staccato in the resulting flow.

Voice separation mode specifies how Dorico will handle chords, if the destination
for atrack is a single instrument. If you have mapped a single track to multiple
instruments, Dorico will automatically distribute the notes to each of the
destination instruments, and this option will be disabled.

When mapping a track to a single instrument, Dorico will choose an appropriate
voice separation mode: for example, for a harp or piano it will choose 4 voice

keyboard (auto). However, you may wish to adjust this setting yourself, in which

case the options are:

» 1 voice will notate all music in the track in a single voice

» 2 voice (auto) is the most appropriate choice for a track that contains music
for two instruments but which you want to be notated on a single staff,
rather than assigning it to two instruments (which is recommended)
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= 2 voice (fixed split point) is suitable for grand staff instruments, and uses
the value of Split at MIDI note number in the Import Options section to
determine which notes should be distributed to the upper and lower staves

»= 2 voice (explode) will create two voices throughout, and is appropriate for
notating a single staff

» 4 voice keyboard (auto) is the most appropriate choice for a track for a
grand staff instrument, and can automatically detect common keyboard
textures, such as bass and melody with inner chords; for more details, see
Polyphonic MIDI transcription below.

Percussion. When importing a drum set using General MIDI percussion, if the
incoming track uses instruments that are not already defined in the target
percussion kit, Dorico will now automatically add the missing instruments during

import, assigning noteheads and staff positions that can later by edited in the Edit

Percussion Kit dialog after the import is complete.

Polyphonic MIDI transcription

Dorico 4 includes a suite of significant improvements to the transcription of MIDI
music, whether it is recorded into Dorico in real time or imported via a MIDI file.
These improvements include the ability to automatically transcribe keyboard
textures with multiple moving parts cleanly into separate voices, transcription of
slurs, grace notes, trills, tremolos, and smarter transcription of pedal lines.

The result is that music entered into Dorico via MIDI import or real-time recording
is automatically transcribed much more cleanly, bringing you closer to your desired
final result much more quickly.

Transcription options. Dorico uses a common set of options for transcribing music
in real time and importing MIDI files, but they are shown in different locations: for

information about setting transcription options when importing MIDI, see Smart

MIDI import above.

To set the options for real time recording, go to the Play page of Preferences. The
options under Quantization determine the minimum note value Dorico will use
when interpreting your input, and you can specify whether tuplets and grace notes
should be detected, as well as specifying whether Dorico should Fill gaps, which

automatically extends durations to prevent short rests appearing between notes.

The options under Recording specify further specific behaviors for handling

particular notations during real time recording.

Slurs. Dorico now detects slurs when importing MIDI data and creates them
automatically for notes that overlap by a small amount. If you would prefer Dorico
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not to do this, switch off Detect slurs in the Import Options section of MIDI Import

Options, or in the Recording section of the Play page of Preferences.

Grace notes. Dorico now detects slashed grace notes (acciaccaturas) during MIDI
import and retains the original played durations and dynamics. To prevent Dorico

from doing this, click Quantize Options in MIDI Import Options, and in the dialog
that appears, switch off Detect grace notes. This option is also found in the

Quantization section of the Play page of Preferences.

Trills and tremolos. Dorico can now detect trills and tremolos during MIDI import
and real time recording, and replace the original MIDI performance of the trill or
tremolo with a notated trill or tremolo that will subsequently be performed using
Dorico’s automatic playback features. To prevent Dorico from doing this, switch off

Detect tremolos and Detect trills in the Import Options section of MIDI Import

Options, or in the Recording section of the Play page of Preferences.

Pedal lines. When creating pedal lines, Dorico now merges abutting pedal lines into
a single pedal line with retakes at the appropriate positions. When piano pedaling is
performed in real-time, the sustain pedal is usually suppressed after the notes that
should be sustained have been played, but it is conventional for the start of the
pedal line to be notated at the same rhythmic position as the notes that should be
sustained. The new option Snap pedal lines to previous beat enables Dorico to do
this by default.

If you would prefer Dorico not to create pedal lines at all, switch off Import CC64 as
pedal lines in the Import Options section of MIDI Import Options dialog, or in the

Recording section of the Play page of Preferences.

Key signatures. When importing MIDI files, by default Dorico will attempt to choose
the most appropriate key signature for the imported music if none is specified in
the MIDI file. Dorico will only create a single key signature at the start of the flow, so
this will work best with music with a strong tonal center and without modulation.
To disable this, deactivate Detect key signature if missing in the Import Options

section of the MIDI Import Options dialog.

Starting recording. Dorico now shows a helpful message if it is unable to start
recording because there is no valid location to record from.

Insert mode

Insert mode is one of Dorico’s most powerful and unique features, but in practice it
can be difficult to handle. Dorico 4 introduces several significant improvements to
Insert mode to make it even more powerful, but crucially also more practical: firstly,
you can specify a stop position beyond which edits will have no effect, so that you
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can be sure that there will be no unwanted changes later in the flow; and secondly,
it is now possible to specify the scope for Insert mode, allowing you to insert or
remove time not only in the current voice, but in the whole player, and the whole
ensemble.

Stop position. To set the stop position in a flow, either show the caret, or select a
note, rest or other item at the desired position, then choose Write » Insert Mode
Scope » Set Edit Stop Position, or type the shortcut Shift+Alt+l. Alternatively, if the

system track is visible, you can click the % “no entry” icon to set the stop position at
that barline.

The stop position appears as a translucent red line that spans all of the staves in the
flow. You can move the stop position to a new position by choosing Set Edit Stop
Position again, or by dragging it with the mouse: the top of the line has a handle that
you can click and drag. By default, the stop position snaps to barlines; hold the Alt
key to drag the stop position by the rhythmic grid value instead.

To remove the stop position altogether, you can drag it off the start or end of the
flow: when the stop position becomes dotted, when you release the mouse button,
the stop position will be removed.

When you perform an edit that crosses the stop position, such as copying and
pasting, repeating material, or pushing material along by entering new notes in
Insert mode, the edit will not allow any changes after the stop position.

In general, the stop position will not be moved automatically, but in a couple of
situations, such as when you are lengthening or shortening a bar in Insert mode,
Dorico will adjust the stop position automatically such that it still makes sense.

Insert mode scope. In a major expansion of the capabilities of Insert mode, you can
now choose the scope that will be affected by your Insert mode edits from the new

Write » Insert Scope submenu, or cycle through the four options by typing Alt+l.

The four different scopes are:

* Voice: familiar from previous versions of Dorico, only notes, rests, tuplets
and other items in the current voice are affected

» Player: affects all voices belonging to the current player, and all non-voice-
attached items, such as dynamics

* Global: affects all players in the flow

» Global Adjustment of Current Bar: affects all players in the flow, but if note
input is active, it additionally changes the length of the current bar rather
than pushing or pulling items across barlines.
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If the caret is shown, the appearance of the caret is modified according to the
chosen scope:

Voice Player Global

The current scope is also shown in the Notes toolbox on the left-hand side in Write
mode. You can additionally click and hold, or right-click, the Insert toolbox button
to choose the desired scope.

Percussion kits. When working with unpitched percussion kits set to be displayed
using the five-line staff or grid presentation types, Dorico automatically uses Player
scope when Insert mode is active. Using Player scope ensures that all the

instruments in the kit will be affected correctly, rather than only those that happen
to be notated in the same voice.

Global adjustment of the current bar. The ability to dynamically lengthen or shorten
the current bar is very useful when working with unmetered music, such as chant
or psalmody, or for special cases such as cadenzas. Depending on the situation, you
may or may not find it helpful for Dorico to insert a new time signature in the
affected bar. An option to control this, When inserting with Global Adjustment of

Current Bar, can be found on the new Insert Mode page of Note Input Options.

Melodic and rhythmic transformations

Dorico 4 introduces a powerful new suite of tools for transforming melodic and
rhythmic material. They can all be found in the Write » Transform submenu, or

they can be invoked from the Shift+l popover.
Write » Transform » Pitches:

* Invert Pitches changes the melodic contour such that a rising interval
becomes a falling one of the same size.

» Reverse Pitches takes the pitches of a series of notes and reverse their
order, so that the first pitch becomes the last, the second becomes the
penultimate, and so on; this is also known as retrograde.
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»= Reverse and Invert Pitches performs what is also known as a retrograde
inversion, where the melodic contour is inverted the order of pitches is
reversed.

* Rotate Pitches shifts the pitches by a specified number of notes in a circular
fashion; rotating a single note will, for example, take the pitch of the last
selected note and apply that pitch to the first selected note, with the pitch of
every subsequent note being shifted to the right by one note.

» Map Pitches provides a specific mapping from one pitch to another, so that
all notes with a particular pitch will have their pitches changed to another
particular pitch.

» Map Scale provides a mapping from one scale to another, adjusting the
pitches of all notes according to a source and destination scale.

= Repeat Pitches applies the pitches of the first n selected notes in turn to

each of the remainder of the selected notes.
Write » Transform » Rhythm:

»= Reverse Rhythms reverses the order of the durations of the selected notes,
so the duration of the first note is applied to the final note, the duration of
the second note is applied to the penultimate note, and so on.

* Rotate Rhythms shifts the durations by a specified number of notes in a

circular fashion.
Write » Transform » Both:

= Reverse Pitches and Rhythms reverses the order of both the durations and
pitches of the selected notes.

= Reverse and Invert Pitches and Reverse Rhythms reverses the order of
both the durations and pitches of the selected notes, additionally inverting
the pitches (such that a rising interval becomes a falling one of the same
size).

* Rotate Pitches and Rhythms effectively shuffles the selected notes by a

specified number of notes in a circular fashion.

All these melodic and rhythmic transformations apply not only to notes, but also to
all other selected material, including playing techniques, lyrics, dynamics, slurs,
and so on. They can be applied not only to pitched material, but also to unpitched
material written for percussion instruments.

Inversion. Choosing Write » Transform » Pitches » Invert Pitches shows the

following dialog:
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Invert Pitches

Invert using specifies the behavior of the inversion operation:

= Outermost pitches retains the highest and lowest pitches in the selected
passage, and transposes the other notes chromatically within the range
described by those outermost pitches. It is not possible to choose the
Diatonic inversion type when retaining the outermost pitches.

= Specific pitch allows you to specify the pitch around which the inversion
should take place using the controls that appear below. You can choose in
this case whether to perform a Diatonic or Chromatic inversion.

= Root uses the root note of the key signature, or C in the case of an
open/atonal or no key signature, as the pitch around which the inversion
should take place. You can additionally choose whether to perform a
Diatonic or Chromatic inversion.

= First note uses the pitch of the first selected note as the pivot point for the
inversion, and in case the first selected note is actually a chord, you can
furthermore choose whether to use the highest or lowest note of the chord
as the pivot point. You can additionally choose whether to perform a

Diatonic or Chromatic inversion.

The same dialog appears when you choose Write » Transform » Pitches » Reverse
and Invert Pitches and Write » Transform » Pitches » Reverse and Invert Pitches

and Reverse Rhythms, so that you can specify the inversion behavior in each case.

To specify the inversion transformation when using the Shift+l popover, type

inversion, invert, mirror or inv. In addition:

*= Add anote name and octave to specify the pitch around which the inversion
should pivot, e.g. inve4 will invert around middle C (C4), or invEb5 will invert
around Eb5.

* Youcan also specify the pitch in terms of divisions of the octave: for
example, if you are using a 24-EDO tonality system, typing inv D1/24 4 will
invert around D quarter-sharp 4.

= Addrootinstead of a note name to specify that the inversion should be

around the root of the key.
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= Adddiatonic or diat to specify diatonic inversion, or chromatic or chrom to
specify chromatic inversion.
= Toinvert around the pitch of the first note, specify top or bottom to choose

between using the highest or lowest pitch if the first note is a chord.

Retrograde. Using the Shift+| popover you can reverse either or both the pitches and

rhythms of the selected music:

= Typeretrograde, ret, reverse or rev to perform a complete retrograde of
both pitches and rhythms of the selected notes.

= Toreverse only the pitches, add pitches or pt, e.g. rev pitches.

= Toreverse only the rhythms, add rhythms orrm, e.g. ret rm.

= Toinvert the pitches as well as reverse them, add invert or inv, along with
any additional instructions for the inversion operation, as described above.

= To specify that Dorico should additionally include items that are not in the
selected voice, but instead belong to the player as a whole, add player.

= Conversely, to specify that only items in the same voice as the selected

notes should be affected, add voice.

Rotation. Choosing Write » Transform » Pitches » Rotate Pitches, Write »
Transform » Rhythm » Rotate Rhythms, or Write » Transform » Both » Rotate

Pitches and Rhythms shows the following dialog:

Rotate Pitches

Enter the number of steps by which to rotate.

Number of steps:

Direction: Backwards

Cancel OK

You can specify the Number of steps, and the Direction of rotation. Forwards
means that things are shifted to the right, so that the pitch or rhythm of the last note
becomes the pitch or rhythm of the first note; Backwards means that things are
shifted to the left, so that the pitch or rhythm of the first note becomes the pitch of
rhythm of the last note.

To specify rotation via the Shift+l popover:
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= Torotate both rhythms and pitches, type rotate or rot.
= Torotate only pitches, add pitches or pit, e.g. rot pit.
= Torotate only rhythms, add rhythm, rhy, or rm, e.g. rot rhy.

= To specify the number of steps, use a positive number to specify a number
of forwards steps, or use a negative number to specify a number of

backwards steps, e.g. rot pit 3 or rot rhy -2. If you prefer, you can also

specify backwards rotation using backwards, bw, or prev.

Pitch mapping. Choosing Write » Transform » Pitches » Map Pitches shows the

following dialog:

Map Pitches

Map pitch: D v Natural v .Spedfyoctave:

Include enharmonic equivalents

F v Natural v Transform:  Up Down Specific octave

Add mapping Delete mapping

Every C natural (incl. enharmonic equivs.) to closest B flat

Every D natural (incl. enharmonic equivs.) to closest F natural

Cancel OK

You can specify one or more mappings for pitches: set the source pitch using the
controls next to Map pitch, and the destination pitch using the controls next to To.
Specify whether the destination pitch should be specifically higher or lower than
the source pitch, closest in pitch, or in a specific octave, then click Add Mapping. If
you want to remove a mapping that you have set up, select it in the list of defined
mappings, and click Delete Mapping. When you have set up all of the required

mappings, click OK to apply the transformation.
To specify pitch mapping via the Shift+l popover:

= Type the source and destination pitches, separated by an equals sign, and
each pair of mapped pitches with a comma, e.g. ¢4 = b3, d#5 = f#

= Usethe note name on its own if you don’t want to specify a particular
octave, or add the octave number after the note name if you do.
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* Add * (asterisk) after the note name and optional octave to specify that you
want notes enharmonically equivalent to the chosen source note to be
included.

= Add up or down to specify that the destination pitch should by higher or

lower than the source pitch.

Scale mapping. Choosing Write » Transform » Pitches » Map Scale shows the

following dialog:

Map Scale
. Use source root
. Use destination root
Source scale pattern:  lonian (Major)

Destination scale pattern: ~ Harmonic Minor

Source scale overrides:
Destination scale overrides:

Direction: Up Down

. Snap all pitches to destination scale

. Treat enharmonic equivalents as matching source scale
harmonic equi alents to fit destination scale

. Keep relative offsets from source scale

Scale mapping works by mapping each selected note to a source scale, so that it
knows the equivalent scale degree for each note, and then mapping that source
scale to a destination scale, so that each note is assigned to the corresponding
degree of the destination scale, thus transforming the melodic contour.

Dorico provides 18 preset types of scales, but if you want to specify a custom scale as
either the source or destination, you can describe the scale by choosing the closest

available preset, then entering any differing pitches in the Source scale overrides

or Destination scale overrides edit controls.

By default, Dorico will perform the transformation using the scale root implied by
the prevailing key signature, but if you want to specify a different root note for

either the source or destination scales, you can do so using the Use source root and

Use destination root controls at the top of the dialog.
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Choose the Source scale pattern and Destination scale pattern, apply any

overrides to either scale, specify the Direction for notes to be snapped, and click OK

to apply the transformation.

You may also want to set one or more of the additional options at the bottom of the

dialog:

Snap all pitches to destination scale determines what Dorico should do
with non-scale tones in the selected music; if you activate this option, notes
outside the scale will be snapped to the nearest pitch in the destination
scale.

Treat enharmonic equivalents as matching source scale determines
whether notes that have the same sounding pitch as notes in the source
scale should be considered as matching the source scale, and as such
whether they should be mapped to the destination scale.

If Treat enharmonic equivalents as matching source scale is activated,
you can additionally activate Respell enharmonic equivalents to fit
destination scale, which will cause those notes to be respelled.

Keep relative offsets from source scale is subtle. When Dorico transforms
material from one scale to another, it begins by transposing all the music by
the interval between the roots of the source and destination scales. For
example, if you write Bbin C major, and transform C major to D Aeolian, the
interval between the roots of the scales is a major second. The interval
between Bb and B natural, the nearest scale tone, is a diminished unison, so
the Bb could end up as a Cb, but C natural is a more likely note in the
destination scale. If you would prefer to maintain the offsets between the
notes at the expense of less likely scale tones after transformation, activate

Keep relative offsets from source scale.

To specify scale mapping via the Shift+l popover, you type in the form source to

destination, where the source and destination scales should be written in the form

of the note name of the root followed by the kind of scale:

Ionian or major: ion, maj, M

Harmonic minor: harm, har, hmc, min, m
Melodic minor ascending: me, mdc, min, m
Dorian: dor, drn

Phrygian: phryg, phry, phr

Lydian: lyd

Lydian dominant: lyd dom

Mixolydian: mixlyd, mlyd, mixo, mix, ml
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= Aeolian or natural minor: aeol, aeo, aln, nat, min, m

» Locrian:loc

= Super Locrian (altered scale): super loc, sup loc, spr loc

» Major pentatonic: maj, M, pent, 5tonic, 5ton

» Minor pentatonic: min, m pent, 5tonic, 5ton

» Major blues: maj, M, blue, bls

= Minorblues: min, m blue, bls

» Half-whole diminished or octatonic: half whole, halfwhole, hw, half-tone,
half tone, halftone, htone, hton, half, ht, dimin, octa, dim, oct

»  Whole-half diminished or octatonic: whole half, wholehalf, wh, whole-
tone, whole tone, wholetone, wtone, wton, whole, wt, dimin, octa, dim, oct

=  Whole tone: whole-tone, wholetone, wtone, wton, whole, wt

» Locrianbb7 or harmonic major mode 7: loc, harm, maj, M, mode7, mod 7,
mod7

= Superlocrian bb7 or harmonic minor mode 7: sup, spr, loc, harm, min, m,

mode7, mod 7, mod7.

All the above popover terms are case-insensitive, apart from M and m, which
represent major and minor respectively. To map from C major to C minor, for

example, you could type ¢ M to c m.

You can also specify alterations to any of the scales by including the degree to be
modified: for example, to raise the fourth degree of the major scale, you could type

maj #4.

To activate the Snap all pitches to destination scale option, include the word snap
in your popover input. You can also specify the direction in which Dorico should
move notes that have to be adjusted to match the new scale; by default, it will always
use the smallest interval, but if you want to enforce a specific direction, you can add

up, higher, down or lower to your input.

Finally, you can also use scale mapping to manipulate the spelling of notes without
applying a new scale, or to snap non-scale tones to a particular scale. To respell the

selected notes in a passage according to a particular scale, type (say) spell C maj. To
snap non-scale tones, type (say) snap F min. You can even combine these two
operations, so if you have managed to end up with, for example, both an Fb and an Ab
in music nominally in C major, typing spell snap C maj will both respell the Fb as Ef,
and snap the Abto Ak
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Repeat pitches. The transformation to repeat pitches takes the specified number of
pitches from the beginning of the selection, and then repeats those pitches in

sequence across the remaining selected notes. Choosing Write » Transform »

Pitches » Repeat Pitches shows the following dialog:

Repeat Pitches

Number of pitches to repeat:

Cancel OK

Simply specify the Number of pitches to repeat and click OK to confirm the dialog.

To repeat pitches using the Shift+l popover, type repeat n pitches, or for short rep n

pit, where n is the number of pitches to be repeated.

Note Input Options. A new Musical Transformations page has been added to the
Note Input Options dialog. Detailed explanations for each of the options are
provided in the dialog itself, but it is worth dwelling on the first two options.

Some transformation operations can cause the overall duration of the selection to
change; by default, Dorico will clip any notes that exceed the original selected
duration, but if you prefer, you can specify that Dorico should instead not carry out
the transformation at all.

Similarly, in complex situations involving tuplets, it is possible for notes that were
not previously contained in a tuplet to be moved into one, or vice versa. By default,
Dorico will scale notes as necessary to allow them to enter or leave a tuplet, but if
you prefer, you can specify that the transformation should not be carried out.

Instrument filters

When working on layouts with many instruments, it can be useful to see just one or
a few staves that you want to focus on for a while. Dorico 4 introduces new
instrument filters for galley view that make it quick and easy to show a subset of the
instruments in the layout.

Instrument filter overlay. When you switch to galley view, by default Dorico will show
the instrument filter overlay in the top left corner of the view.

ﬁ Vin1.2,Vla, V..»v
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If you don't want to see the overlay, you can switch it off by deactivating View »

Instrument Filter Overlay.

The filter button at the left-hand side of the overlay activates or deactivates the
filter shown in the menu in the middle of the control. You can also activate or

deactivate the current filter by choosing Write » Instrument Visibility » Use

Instrument Filter.

The + button in the overlay is enabled when you have a selection in the music, and
allows you to create a new instrument filter by selecting items in one or more
instruments in the music. You can also use Write » Instrument Visibility » Create

Preset From Selection to perform the same action.

Finally, the ... button at the right-hand side of the overlay opens the Manage
Instrument Filters dialog, which allows you to create, edit and delete instrument
filters. You can also access this dialog by choosing Write » Instrument Visibility »

Edit Instrument Filter Presets.

Manage Instrument Filters dialog. The Manage Instrument Filters dialog looks like
this:

Managing instrument presets for: Full score

# Woodwinds Instruments in filter:
Picc1.2,Fl11-3,0b 1-4,C. A 1.2, CL. (E Flat), CL. (D), Cl. (B Flat) 1-3, Cl. (A) 1-3, Bsn 1-4, Cbsn 1.2
@ contrabassoon 1

@ contrabassoon 2

Pitched Percussion French Homn (F) 1
Timp 1.2, Hp French Horn (F) 2
Unpitched Percussion French Horn (F) 3

Si. Dr, B. Dr, Cl. Cym French Horn (F) 4

Strings

Trumpet (D)
VIn1.2,Vla, Ve, D. B

Trumpet (B Flat) 1
Trumpet (B Flat) 2
Trumpet (B Flat) 3
Trombone 1
Trombone 2

Tramhana 2

Instrument filters are specific to a particular layout in your project (since each
layout can, and usually does, contain different players and their respective
instruments), so the dialog reminds you of the layout for which you are managing
presets.
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The presets are shown in the large list that occupies most of the dialog. When you
select a preset, the Instruments in filter list on the right-hand side shows which
instruments are currently included, and allows you to add or remove instruments
from the filter by activating or deactivating the relevant checkbox.

Dorico generates names for each preset based on the short names of the
instruments included in the filter, but you can edit the names by clicking the pencil
icon at the left-hand side of each list entry. The name shown in bold in the first row
of the entry is the name that will appear in the instrument filter overlay, and in the

Write » Instrument Visibility submenu.

The number at the right-hand side of the list entry indicates the index of the preset,
corresponding to the numbers that appear in the Key Commands page of
Preferences - see below. To change the index of a selected preset, use the arrows in
the action bar below the list to move it up or down in the list.

To quickly generate a useful set of presets, you can click the Add Presets from
Instrument Families button, which as its name suggests will create presets for each

instrument family represented in the layout.

Key commands for instrument filters. To make it quick and easy to recall instrument
filters, it is possible to define custom key commands for up to 10 presets. On the Key
Commands page of Preferences, expand the Edit category and you will find 10
commands from Instrument Filter Preset 1 through Instrument Filter Preset 10.
Remember that instrument filters are specific to a particular layout, so the key
command for (say) Instrument Filter Preset 1 will recall a completely different

preset in two different layouts within the same project, or in a different project.

Working with instrument filters. When an instrument filter is active, Dorico draws a
dashed line at the point in the system where one or more instruments is hidden.
You cannot select music belonging to instruments that are hidden by an instrument
filter, and nor can you paste into instruments hidden by an instrument filter.

User-defined project templates

Dorico 4 makes it possible to save any project as a template for future projects. This
allows you to create future projects for the same ensemble of players and
instruments, using your own preferred options, page templates, playback template,
and so on.

Save as Project Template. To save your current project as a project template, choose
File » Save As Project Template, which shows a simple dialog in which you can

specify the category in which the template should appear and its name. If you save a
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template with the same name as an existing factory-supplied template in the same
category, your template will take precedence over the factory template.

You can choose whether to retain the existing flows in the project (so that they will
appear in a new project you create based on the template) and whether to retain the

current Project Info values in the template.

Using the project template. Any project templates you create will appear both in the
Create New page in the Hub, and in the File » New From Project Template

submenu.

When you use the Create New page in the Hub to start a new project based on your
user-defined template, you can use options on the right-hand side to set various
defaults for the newly created project. The Page size, orientation and Rastral size
options are disabled, however, so that the new project always uses the values from
the template.

When you choose your user-defined project template from the File » New From
Project Template submenu, none of these options in the Hub will be applied, and
the project will be created containing either an empty flow of a single quarter
(crotchet) in length, or whatever flow you chose to keep when you saved your
project as a template.

Deleting a template. You can delete a user-defined project template by clicking the
menu button B in the top right-hand corner of the template’s card in the Create
New page in the Hub and choosing Delete Project Template from the menu. You

will be prompted to confirm the deletion: if you proceed, the project template will be
deleted and will no longer appear in the application.

Revamped ensemble picker

Dorico 4 provides a new, efficient way to add multiple players to your project, and
save your own combinations of instruments for later recall, via the revamped
ensemble picker. As in previous versions, the ensemble picker can be opened by

choosing Setup » Add Ensemble or by clicking the B button in the action bar in the
Players panel. New in Dorico 4, you can also now open it via the new default key

command Shift+E.

The ensemble builder has two modes of operation, Build and Choose, which are

accessed using the toggle buttons at the top of the picker.

Choosing an ensemble. To simply choose one of the preset ensembles, as in previous

versions of Dorico, click Choose. All the default ensembles appear, organized as
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before into categories, and any user-defined ensembles that you save in the Build

page will appear here too.

Building your own ensemble. To add any combination of instruments to your project,
you can use the new Build page. You can type full or abbreviated instrument names
- for example fl or flute - optionally prefixed with a number - for example 4 hn to
add four horns in F. Each instrument must be separated with a comma: for example,
you could type 2 fl, picc, 2 ob, 2 clar. If you omit the commas, Dorico will attempt to

parse the entire input text as an instruction for a single instrument.

As you type into the edit control at the top of the Build page, the instruments that
Dorico has detected from your input are shown in the list below, but if you delete
any of the existing text from the edit control, the corresponding instruments will be
removed from the list. To confirm to Dorico that the instruments shown so far

should definitely be added, hit Tab to commit the current instruments shown in the

list below, clearing the edit control and allowing you to type further instruments.

You can also use orchestral shorthand for woodwind and brass instruments, for
example 2picc.2.2.1 / 4.3.3.1 for two flutes, one piccolo, two clarinets, two oboes,
one bassoon, four horns, three trumpets, three trombones, and one tuba. The
woodwind shorthand describes the number of flutes (plus optional piccolo,
specified by adding picc after the number of flutes), clarinets, oboes and bassoons.

The brass shorthand describes the number of horns, trumpets, trombones and
tubas.

If you provide only one set of shorthand digits, Dorico will assume it is specifying
woodwind instruments. To specify only brass, prefix the shorthand with br, for

example br4221.

You do not have to separate the digits for each instrument with a period or any
other separator, though you can if you wish. Dorico expects there to be a maximum
of nine instruments in any section - you cannot add (say) 12 horns by typing

br12.3.3.1.

Finally, you can also type the name of any preset ensemble into the edit control on

the Build page to add those instruments to the list to be added to the project.

To toggle the type of player to be added between single and section players, simply
double-click the relevant row in the ensemble builder.

When you are happy with the players and instruments shown in the list in the Build

page, click Add to add them to the project.
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To save your own ensemble preset for future use, add the desired players and
instruments to the list, then click Save to specify the name and category for the new
preset ensemble. This preset will then be available in Setup mode in all projects, and

will appear in the Choose page of the ensemble picker in the specified category.

Automatic score order and soloists

When adding new players and instruments, Dorico now automatically sorts the
instruments according to the conventional orchestral score order. It is also possible
to designate a particular player as a soloist, which will move them to the traditional
position in the score order, namely above the strings, and automatically name and
bracket them appropriately.

Enabling automatic score order in existing projects. To avoid making unexpected or
unwanted changes to your existing projects, automatic score ordering is only
enabled by default in new projects you create in Dorico 4.

To enable automatic score ordering, click and hold or right-click the new Sort
Players button Bl in the action bar in the Players panel in Setup mode: a menu will
appear in which you can choose between None, which disables automatic score
ordering, and Orchestral, which specifies the standard orchestral instrument
order. This choice specifies the order that will be applied when you click Sort
Players or when adding new instruments, so having chosen Orchestral, if you then

click Sort Players, the standard orchestral score order will be applied.

Soloists. If you have a player that should be designated as a soloist in your project,
right-click that player in the Players panel, and choose Soloist from the context

menu.

This causes the instrument to move in the score order to the conventional position
for a soloist (for example, in a concerto), directly above the strings. In addition:

* Any instruments held by that player will no longer be considered for
numbering with other similar instruments in the same player group

» Provided the full and short names for the instrument are the same as the
default full and short names for the instrument, Dorico will prepend Solo to
the instrument name (and hence staff label), using the language chosen for
instrument names in Engraving Options.

» Soloists will also not be bracketed with instruments in the same family if
they are adjacent, so if for example you have a solo violin directly above
Violin 1(and both are the same player type, however unlikely that may be),
then soloist will not be bracketed with the strings.
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All these things are reversed if you choose Soloist again from the context menu to

say that a player should no longer be considered a soloist.

System items for soloists. You can choose whether system-attached items such as
tempos and rehearsal marks should appear above the first soloist staff by activating

the Soloist checkbox in the Show system objects above the first bracket for the

given instrument families list on the Players page of Layout Options.

Bracketing for soloists. If you have the Bracketed groups with only one instrument
option on the Brackets and Braces page of Layout Options set to Use bracket, then
the soloist will now get a bracket; if there are two or more soloists, then they will
now be joined by a bracket regardless of whether they are from the same
instrument family.

Layouts. By default, part layouts in the Layouts panel will also be sorted in the same
order as the players, but if you prefer, you can specify that layouts should instead be
sorted by layout number; click and hold on the Sort Layouts button to choose

between these two sorting approaches.

Single players. To disambiguate soloists, what were previously known as solo
players in earlier versions of Dorico are now called single players.

Library Manager

In Dorico, the term library refers to the complete set of options in the five primary
options dialogs (Engraving Options, Layout Options, Notation Options, Note Input
Options and Playback Options) and all the collections of items whose appearance
and semantic meaning you can edit or define, including (but not limited to) font
styles, paragraph styles, playing techniques, notehead sets, music symbols,
expression and percussion maps, and so on.

To reinforce the concept of the library, Dorico 4 includes a new Library menu,
which brings together all the main options dialogs and all the dialogs in which you
can edit or define the items used in your project. Full details of these changes can be

found under User interface on page 81.

Dorico is almost endlessly configurable, with hundreds of user-selectable options
and the ability to customize the appearance of practically every item in your project.
Managing these options even within a single project is challenging and being able to
maintain a consistent appearance and set of options across multiple projects was
impractical in previous versions of the software.

Dorico 4 aims to change that, with the introduction of the new Library Manager. The
Library Manager allows you to examine the library of the current project in detail,
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and compare it with the library in another project, or the factory library (Dorico’s
default settings), or your user library (which is a combination of the factory library
and the changes you have made to it and then saved as defaults for use in future
projects).

Itis then easy to import settings or items from the source library - either the library
from another project, or the factory library, or your user library - into the target
library, which is the library of the project you are currently editing. You can import
individual settings within individual classes of options, or you can import
everything from the source library. Everything is completely within your control.

Opening the Library Manager. To open the Library Manager, choose Library »
Library Manager. This dialog opens:

Options —
is project Compareto: Factorysettings  User library
Engraving Options

% arcadelt-il-bianco-e-dolce-cigno.dorico Drop .dorico

Notation Options project file here
Note Input Options Layout: = Full score ~ Layout: Fullscore ~

Playback Options
Show: Differences  Notin this project Search:

Collections Bar Numbers All options match

Accidental Definitions
Brackets and Braces All options match
Accidental Systems

Character Styles Chord Symbols and Diagrams All options match
Chord Diagrams

Markers and Timecode All options match

Chord Symbol Appearance Components

Chord Symbol Appearances Note Spacing

Page Setup

Players

Staves and Systems

Some options differ

Some options differ

All options match

Some options differ

Font Styles
Staff Labels
Fretted Instrument Data

Glyph Prim Staff labels on first system: Full
Staff labels on subsequent systems: ~ Abbreviated

Divisi labels show section names on fi true

At the top of the right-hand side of the dialog, you can specify the source library:
you can drag and drop the Dorico project containing the source library into the drop
area; or you can click the document icon to show a file chooser to browse to the

Dorico project containing the source library. Alternatively, click Factory settings or

User library to choose the factory library or your user library.

Once you have specified the source library, you can see how the target library
differs from the source. On the left-hand side of the dialog, the library contents are

separated into two lists: Options, and Collections.

Filtering and searching. To quickly see only the differences between the source and

target libraries, use the provided filters: click Differences to see only those option
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values and collection items that differ between the source and target libraries, or
click Not in this project to see only collection items that exist only in the source

library and not in the target library.

All i =4[5 Not in this project

At the right-hand side is a Search box, which searches within the currently selected

set of options or collection type.

Comparing and importing options. To compare a specific set of options in the source
library with the target library, first click the desired set of options in the left-hand
list. You can then navigate through the categories of options within that set on the
right-hand side. If all the options have identical values between the source and

target libraries, the category will show a checkmark B 2nd the words Al options
match. If one or more of the options have differing values, however, the category

will show an inequality sign B and the words some options differ.

Staves and Systems Some options differ <

Time Signatures All options match <

To set all the options in the target library to the values from the source library,
simply click the inequality sign. The inequality sign will be replaced by a left-

pointing arrow Bl to indicate that the differing values have been updated.

If you change your mind and decide you do not wish to import those values after all,
simply click the left-pointing arrow again; when you hover your mouse over the

arrow, it will become a cross . that you can click to revert those changes.

If you prefer to examine individual option values within a category, expand the
section by clicking the disclosure arrow at the right-hand side. Each option in that
category is shown, with the value in the project’s library (the target) on the left and
the source library on the right. In the same way as with whole categories, you can
click the inequality sign between the target and source values to apply the source
library’s value to the target library.

Layout- and flow-specific options. Layout Options can have different values for each
layout in a project, while Notation Options can differ for each flow.

When you choose to examine Layout Options in the Library Manager, you can
specify for both the target library (the project currently being edited) and the source
library (the project or library from which you want to import options values and
collection items) which layout should be used to provide the values. It is generally
advisable to compare the options for similar layouts, for example full score layouts
with full score layouts, and part layouts with part layouts.
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Similarly, when you choose to examine Notation Options in the Library Manager,
you can choose which flow in the target library and the source library to compare.

Comparing and importing collections. As you examine the various collections of
items in the source and target libraries, bear in mind that any individual Dorico
project is unlikely to contain every item in every collection in the library: only those
items that are actually used in the project, or which have been edited or defined by
you, are included in the library. When you compare the libraries of two Dorico
projects, then, you should not expect to see every item in every collection shown in
the Library Manager; indeed, it is quite unlikely that the two libraries will even
contain the same items as each other within any given collection.

When you select a particular collection, Dorico will display the items that exist in
that collection in the respective libraries. All items have a detailed text description
that provides information about the properties of that item, and many items
provide a graphical preview when selected, so that you can compare the items in
the source and target libraries graphically.

Once you have decided to import an item, click the inequality sign . which will be

replaced by a left-pointing arrow Bl to indicate that a new item will be imported or
an existing item updated. If you change your mind and decide you do not wish to
import an item after all, simply click the left-pointing arrow again; when you hover

your mouse over the arrow, it will become a cross . that you can click to revert the
change.

Dependent items. It is especially useful to be able to import collection items that are
not present at all in the target library, for example to bring in custom expression
maps, percussion maps, playing techniques and playback techniques that you have
defined in one project into another. When an item is not present at all in the target
library, and you choose to import it, it will be added, along with any other items that
the chosen item depends upon.

For example, a playing technique may depend on either a specific font style (if it is
shown as text), or on a particular music symbol, in which case it will depend on at
least one font style, and possibly more, or perhaps even a graphic file embedded in
the source project. When you choose to import that playing technique, the
dependent items are also imported. Exactly what happens to those dependent
items depends on the state of the target library:

» Any collection items that already exist in the target library and which are
identical to those in the source library are not imported, provided all of their
dependencies similarly exist and are identical.

» Ifany of those dependent items in the target library have different internal
identifiers to the entities in the source library (which they will if they have
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been user-defined), the parent items will be updated with the new target
library identifiers, so that they remain correctly linked together.

= Ifany of the dependent items that are being imported from the source
library have the same name as an item already in the target library, each of
those items is given a new unique name upon import (for example, by
appending a number to the end of its name).

= Ifany of the dependent items that are being imported have the same
internal identifier as any items already in the target library, each imported
item is given a new internal identifier, references to which are updated in
each parent item that requires that item.

In summary, to ensure that imported items have the same appearance and
behavior in the target library as they had in the source library, any dependent items
are imported without overwriting any corresponding items in the target library, to
avoid existing items that already use (say) a dependent font style changing
appearance after import.

Applying the changes. Any change you make in either the Options or Collections

sections will not be applied until you click the Apply button. If you need to import
options or collection items from multiple different source libraries within the same

session, you must click Apply before you select a new source library.

Jump bar

The jump bar is a new user interface element that allows you to quickly run
commands, and to efficiently navigate through your music by going to specific
flows, rehearsal marks, bars, or pages.

Showing the jump bar. The jump bar is invoked by hitting ] and appears in the center
of the project window:

Commands Go To

Engraving Options...|

Reverse Pitches

System Break

Transpose...

Flip

Jump bar modes. It has two modes: Command and Go To. By default, it opens in
command mode. You can switch between the two modes either by clicking the
buttons in the jump bar, or:
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*  On Windows, type Alt+C for command mode and Alt+G for go to mode.

* OnMac, type Control-1 for command mode and Control-2 for go to mode.

The jump bar remembers which mode it was last in, so reopens in that mode. At the
start of each new session, the jump bar will always default to command mode.

Command mode. In command mode, when the jump bar first opens, the last-used
command is shown in the text field, and the text is selected. You can simply hit

Return to execute that command again, or you can type to choose another

command, or you can use 1/, to open the pop-up below the text field to choose
from your most frequently used commands.

Each time you execute a command via the jump bar, Dorico updates its persistent
cache of the frequency with which you use each command, so as you use the jump
bar it will learn which commands you use most often.

The five most frequently used commands are shown in the pop-up by default, so
you can use the up/down keys to choose one of them. If the last command you
executed is not among the five most frequently used commands, it is nevertheless
also added to the pop-up so that it can be chosen by default.

Commands can only be chosen via the jump bar if they can be executed given the
current window mode, selection state, and so on. For example, if one of your five

most frequently used commands is, say, System Break, this won't appear unless

you are in Engrave mode and there is a valid selection.

If you want to execute an arbitrary command, you can type to search for one. All
valid commands that can be executed without special parameters being specified
will appear.

Dorico also helpfully adds special commands for each of the pages of each of the
five main multi-page options dialogs, so you can type e.g. bar numbers and you will
see separate entries for the Bar Numbers pages of Engraving Options, Layout

Options, and Notation Options.

Jump bar aliases. You can also set aliases for commands in the jump bar, which are
special sequences of characters that you can use to trigger a particular command as

quickly as possible. Let's say you want to create an alias of st for the View » System
Track command. You would do this by typing system track=st into the jump bar.
The characters following the equals sign will be set as the alias for that command,
which allows you to then quickly execute that command by typing J (to show the

jump bar) st (to choose the alias) Return (to confirm the jump bar).
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Jump bar aliases appear in the jump bar’s pop-up, just to the left of the key
command for that command, if it has one. Aliases can also be edited on the Key
Commands page of Preferences: search for the command in the main tree view,
and any defined jump bar alias will appear in the Jump Bar Alias section in the

bottom right-hand corner, allowing you to update or delete the alias. You can also
set a new alias from here if you wish.

To set a new alias via the jump bar without executing the command, hold Alt when

you hit Return to confirm the jump bar: that will set the alias, but not execute the

command.
Go to mode. In go to mode, you can type the following:

= ffollowed by a number, e.g. f3, to go to that flow (equivalent to clicking that
flow's card in the Flows panel in Setup mode)

= fnto goto the next flow, or fp to go to the previous flow

= b followed by anumber, e.g. b24, to go to that bar in the current flow
(equivalent to Edit » Go To » Go To Bar)

» fand b canbe combined, e.g. f2b14, to go to a particular bar in a specific flow
in the layout

= pfollowed by a number, e.g. p13, to go to that page (equivalent to Edit » Go
To » Go To Page)

» rfollowed by aletter or anumber, e.g. rc or r13, to go to that rehearsal mark

(equivalent to Edit » Go To » Go To Rehearsal Mark).

Beware that the current flow is the flow in which you either currently have items
selected, or it was the flow in which you most recently had items selected; it is not
necessarily the flow that is currently in the view.

Capos for fretted instruments

A capois a device that is applied to the neck of a fretted instrument, typically a
guitar, that depresses some, but more typically all, of the strings at a particular fret,
thus raising their open pitch. Capos are normally used to make it possible to play in
a particular sounding key while using the same fingerings that would normally be
used when playing open, or in other words without a capo.

Dorico 4 introduces comprehensive support for capos for fretted instruments,
allowing you to define a full or partial capo for your instrument, and specify the
effect this should have on the staff notation, chord symbols and diagrams, and the
tablature itself.
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Defining a capo. Capos are defined in the Edit Strings and Tuning dialog. To open
the dialog, expand the card for the player holding the guitar or other fretted
instrument in the Players panel in Setup mode, then click the ... menu button at the
right-hand side of the label for the instrument that is revealed in the expanded
card, and finally choose Edit Strings and Tuning. To define the capo, click Capo at

the bottom of the dialog, which shows the following simple dialog:

Capo: None Full Capo

~ -
Fromstring: 1

If you choose Full Capo, you need only specify the Fret at which the capo should be
placed; if you choose Partial Capo, you specify not only the Fret but also which
strings to which the capo should apply. When you confirm your choice, a graphical

representation of the capo appears on the neck in Edit Strings and Tuning.

You may want to show the notation transposed into the sounding key, in which case
set Transposition interval for staff notation to the desired value. Because a capo at

the, say, second fret might suggest a root of either F4 or Gb, it is important to be able
to specify the interval in terms of a note name rather than simply applying a
transposition by a number of half-steps or semitones.

Having specified a transposition interval for staff notation, this will only take effect
if the new Use fretted instrument transposition for notation option is set for this
specific instrument in the Fretted Instruments section of the Players page of

Layout Options, and if the layout is currently shown at transposed pitch.

Chord symbols. Because chord symbols in Dorico are global by default and therefore
apply to all the instruments in the flow, the chord symbols shown above a given
player do not consider a capo defined for any particular instrument in your
ensemble. Instead, you can specify the transposition interval to be used for the
notional capo for each player if you wish.

To specify the transposition interval, right-click the player above whose staff the
capo chord symbols should appear in the Players panel in Setup mode, and from the

Chord Symbols submenu of the contextual menu, choose Capo Chord Symbol

Transposition for Player. This shows a dialog in which you can specify the interval
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by which the chord symbol should be transposed, in the same manner as in the Edit

Strings and Tuning dialog.

Once the capo transposition has been specified, there are several options for how
the chord symbols themselves should appear for the player, all of which can be

similarly chosen from the Chord Symbols submenu of the player’s contextual

menu:

= Show Main Chord Symbol for Capo shows only the main chord symbol, and
does not show the transposed capo chord symbol

» Show Transposed Chord Symbol for Capo shows only the transposed capo
chord symbol, and does not show the main chord symbol

= Show Capo Chord Symbol Above Main shows both the capo and main
chord symbols, with the transposed chord symbol above the main chord
symbol

= Show Capo Chord Symbol Below Main shows both the capo and main
chord symbols, with the transposed chord symbol below the main chord
symbol

When showing capo chord symbols together with main chord symbols, it can be
helpful to visually differentiate the two kinds of chord symbols, and Dorico can
either display capo chord symbols in italics, or in parentheses. To change this,

modify Capo chord symbol appearance in the new Capo section of the Chord
Symbols page of Engraving Options. You can also here change the vertical gap

between the capo and main chord symbols if necessary.

If you wish, you can also override whether the capo or main chord symbol is shown
for a selected item by activating the new Show only property in the Chord Symbols
group in the Properties panel and choosing either Capo Chord or Main Chord as

you prefer.

Chord diagrams. If a capo transposition is defined for a particular player and a
fretted instrument tuning is chosen from the Chord Diagrams submenu of the
player’s context menu in the Players panel in Setup mode, the chord diagram
shown for each chord symbol will take the capo into account.

If you have Show chord diagrams used at start of flow activated on the Chord
Symbols and Diagrams page of Layout Options, if you want to show chord diagrams

that take a specific capo transposition into account (because, for example, one of
the instruments in your ensemble has a capo defined), you must provide the

appropriate transposition here too, by setting Use capo with transposition to the

appropriate pitch.
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Fretboard panel. If the selected instrument has a full or partial capo defined, the
Fretboard panel in the lower zone in Write mode will display the capo. For more

information about the Fretboard panel, see On-screen instruments above.

Numbered bar regions

When preparing instrumental parts, it is usually very helpful to number bars of
repeated material to help the performer keep their place through the passage.
Dorico 4 makes this easy with the introduction of numbered bar regions, which
build on the functionality of the existing feature for bar repeat regions. For more
information about bar repeats, please refer to the Operation Manual.

Visibility of numbered bar regions. By default, numbered bar regions appear only in
part layouts, though you can create them in any kind of layout. It is recommended
to create numbered bar regions in part layouts, but if you would prefer to create

them in the full score layout, you will find it useful to activate Show bar count in
numbered bar regions in the Numbered Bar Regions section of the Players page of

Layout Options for the full score layout.

Creating a numbered bar region. To create a numbered bar region, select the bars
that should be numbered, then choose Write » Create Numbered Bar Region, or
type Shift+R to open the repeats popover, and enter numbars (or number bars,
num, or nb) followed by Return to confirm the popover. Be aware that if numbered

bar regions are not set to be visible in the current layout, you will see only the
handles of the region, and even they will disappear once you change the selection.

Numbered bar region highlights. When numbered bars regions are visible, a
translucent blue highlight is shown in the bars contained in the region. To switch

this off, choose View » Highlight Bar Repeat Regions. The same option controls the

display of the highlights for both numbered bar regions and bar repeat regions.

Extended or shortening the region. In Write mode, select any of the bar count
numbers shown in the region to select the whole region and show the circular
handles at the start and end of the range. Drag these handles to change the bars

included in the region. Alternatively, you can use Alt+</- to move the entire region
left or right a bar at a time, or Shift+Alt+</- to lengthen or shorten the region a bar

atatime.

Bar count. By default, Dorico will number every bar in the bar repeat region, and if
the region is longer than four bars, it will also indicate the total length of the region
by adding the range of the region to the bar count on the first bar: for example, for

an eight-bar region, the first bar will show 1(-8) by default.
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The default bar count frequency can be set using the options in the Numbered Bar
Regions section of the Bar Repeats page of Engraving Options. You can also specify
whether the bar count should be shown in parentheses, whether it should be shown
above or below the staff, and whether Dorico should align the numbers at the same
vertical position across the width of the system, or instead allow individual
numbers to move vertically to conserve vertical space.

Further options are provided for the appearance of the range on the first bar of the
region, and for additionally numbering the final bar in each system and the final bar
in the region if the chosen frequency would not otherwise cause a number to be
shown there.

You can override these defaults using the properties found in the Bar Repeat

Regions section of the Properties panel.

Engrave mode. You can adjust the position of individual bar count numbers in the
region by selecting them and either dragging them with the mouse, nudging them

with the arrow keys while holding Alt, or adjusting the value of the Number offset

property.

Appearance. The bar count is drawn using the Bar Repeat Count font style, which

you can edit in Library » Font Styles. The same font style is shared between

numbered bar regions and bar repeat regions.

SuperVision

Dorico 4 now includes SuperVision, a professional tool suite for monitoring and
analyzing your audio. The plug-in comes with several different modules for level,

spectral, phase, or waveform analysis.
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You can insert SuperVision on any channel in the Mixer, but perhaps the most
useful place to insert it is in the Inserts section for the master stereo output, where

it will allow you to get an overview of the overall sound.

Please refer to the dedicated SuperVision documentation for more information.

VST Amp Rack and VST Bass Amp

Dorico 4 now includes two powerful new plug-ins for shaping guitar sounds. VST
Amp Rack and VST Bass Amp are powerful guitar amp simulators, each offering a
choice of amplifiers and speaker cabinets that can be combined with stomp box
effects.

Amplifiers Cabinets Post-Effects Microphones Configuration

PRESENCE MASTER

Q© steinberg vst amp rack

To use either of these effects, use the Inserts section of the Mixer for the channel on
which you want the effect to appear, and choose either VST Amp Rack or VST Bass

Rack from the menu of effects.

Please refer to the dedicated VST Amp Rack and VST Bass Amp documentation for

more information.

Universal app on macOS

Dorico 4 is now a Universal app, which means that it runs natively on both Intel-
powered Macs, and on the latest Apple silicon Macs, such as the M1 MacBook Pro,
iMac and Mac mini. If you have an Apple silicon Mac, Dorico will run as a native
application by default.

VST plug-ins. When running natively on Apple silicon, Dorico can only load VST
plug-ins that can run natively as well: it is not possible for Dorico running natively
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toload VST plug-ins running under Rosetta 2, the technology that allows software
built for Intel-powered Macs to run on Apple silicon Macs.

In addition, there is no support for VST 2 plug-ins on Apple silicon, so when running
natively on Apple silicon, only native VST 3 plug-ins will appear.

If you still rely on one or more VST 2 plug-ins, orif a VST 3 plug-in you rely on is not
yet available in Universal format, you can force Dorico to run under Rosetta, which
will allow VST 2 and Intel-native plug-ins to be loaded, though at the expense of
slower overall performance.

To force Dorico to run under Rosetta:

*  Quit the application if it is running.
= Locate Dorico 4 in your Applications folder.
= Select the icon and type Command-I1to open the info panel.

= Activate the Open using Rosetta checkbox.

When you next start Dorico, it will run under Rosetta.

Steinberg Licensing

Dorico 4 is the first product to use the new Steinberg Licensing system, replacing
the eLicenser system that has been used by all previous versions of Dorico, and
indeed by all of Steinberg’s software products.

Steinberg Licensing uses your registered Steinberg ID as the means to identify you
and determine your eligibility to run the software.

Running for the first time. When you run Dorico 4 for the first time, a separate
application called Steinberg Activation Manager will launch. You may be prompted

to sign in, in which case clicking Sign In will open your default web browser.

If you are not currently signed in, you will be prompted to enter your Steinberg ID
email address and password. If your browser is already signed in with your
Steinberg ID, you will not be asked to sign in again.

Once you are signed in, you will be prompted to authorize Steinberg Activation
Manager to use your credentials: depending on your browser, click Allow or Open

(and, if you wish, activate the option to remember this choice in future).

You will then be returned to Steinberg Activation Manager, which should report
that your software has been activated successfully. You can close Steinberg
Activation Manager and use Dorico as normal.
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How activation works. Once your license is activated on a computer, Dorico 4 no
longer needs to contact the Steinberg Licensing server for the purposes of

activation.

You must remain signed in with your Steinberg ID to keep running your software: if
you sign out of Steinberg Activation Manager, your Dorico 4 license will be
deactivated on that computer.

Activating on another computer. With the introduction of Steinberg Licensing, your
single-user Dorico 4 license allows you to use the software on up to three
computers, with the intention that the software is used only by you.

To activate Dorico 4 on another computer, simply install the software on the second
computer as normal. When you run the software, you will be prompted to sign into
Steinberg Activation Manager with your Steinberg ID. Provided you have not
already activated Dorico 4 on three computers, you will be told that activation has
been successful.

If you are told that Dorico 4 has already been activated on the maximum number of
computers, you will need to deactivate the software on one of the computers on
which it is currently activated. To do this, run Steinberg Activation Manager on that

computer, and click the Deactivate button corresponding to your Dorico 4 license.

If you do not currently have access to the computer on which you need to deactivate
your license, you can contact Steinberg support to ask them to deactivate the
license for you.

You can freely deactivate and reactivate Dorico on your computers without limits,
but the software can only be activated on three computers simultaneously.

Remote control support

Dorico 4 introduces a new remote control API that allows richer control from
external applications such as the Elgato Stream Deck or Metasystem’s Metagrid
apps fori0OS and Android. This API allows software to connect to Dorico using
WebSockets, then to send commands, update properties, read the state of the
application, and so on.

If you are a software developer who would be interested in finding out more about
Dorico’s remote control API, please contact us.
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Improvements

Dorico 4 Version History

Accidentals

Respelling accidentals. A good deal of additional flexibility has been added for
managing the spelling of accidentals between different layouts.

By default, when you change the spelling of a note in the full score layout, that
change will be applied to all part layouts in which that note appears; conversely,
when you change the spelling of a note in a part layout, that change is local to the
part and is not reflected in the score.

Dorico 4 introduces powerful new commands that allow you to reset the spelling,
either to the spelling used in the full score or to an automatically determined new
default spelling, or to propagate the spelling in one layout to all other layouts.

Four new commands have been added to the Write » Respell submenu:

* Propagate Note Spellings applies the spelling of the selected notes in the
current layout and applies it to all layouts where those notes appear; this is
useful if you have respelled notes in a part layout but now want to propagate
those changes to the full score.

» Reset Note Spellings in Current Layout resets the spelling of the selected notes
in the current layout to the spelling used in the full score layout; this is useful if
you have respelled notes in a part layout but want to return to the default
spelling used in the full score.

» Reset Note Spellings in All Layouts resets the spelling of the selected notes in all
layouts in which they appear to the spelling used in the full score layout.

* Respell Notes Automatically allows you to recalculate the spelling of the
selected notes based on an analysis of the musical content. The following dialog
appears:

Respell Notes Automatically

Additional context at start:

None Previousbar  Previous notes

Number of additional notes: 1

Additional context at end:

None Next bar Following notes

If there are multiple accidentals with the same effect on pitch:

Prefer accidentals used most in this flow

Preserve accidentals on unchanged pitches

Cancel
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The options Additional context at start and Additional context at end allow you to
specify how much of the music either before or after the notes you have selected to
consider when Dorico analyses the music to determine its tonal center.

The two options at the bottom of the dialog - Prefer accidentals used most in this

flow and Preserve accidentals on unchanged pitches - take effect only if your
project uses a tonality system in which multiple accidentals are defined that have
the same effect on the pitch of the note. When respelling notes in such a project,
Dorico can be told to prefer to use the accidental that is most often used throughout
the flow.

Spelling in atonal key signatures. When writing atonal music, it may be preferable to
spell accidentals as simply as possible, without considering what would in tonal
music be the harmonic and intervallic relationships between notes in the same
chord or successive notes. Dorico 4 introduces new options to determine how it
chooses enharmonic spellings when you are writing in an open or atonal key

signature. The following new options are found in the Note Spelling section on the

MIDI Input page of Note Input Options:

* Note spelling for remote accidentals in atonal key signatures specifies
whether you should Allow remote accidentals, like F flat, B sharp, or any
double or triple accidental, or Disallow remote accidentals, in which case
such remote accidentals will not be chosen.

= Preferred accidentals in atonal key signature specifies whether Dorico
should try to favour only flats, only sharps, or allow a mixture.

= Exceptional cases when spelling chords in atonal key signatures specifies

how Dorico should handle the spelling of notes in chords, taking into
account your choices for the preceding two options. For example, if

Preferred accidentals in atonal key signature is set to Flats only, and you
input a dyad of G sharp and B natural, this would spell the G sharp as A flat
and leave the B natural unchanged, producing an interval of an augmented
second. In this situation, choosing Avoid remote spellings would spell the
dyad G sharp and B natural, while choosing Avoid contradiction of
accidental preference would spell the dyad A flat and C natural, in each
case producing a more legible minor third. Dorico will not make any
adjustments for exceptional cases if you choose No exceptions.

= For notes in atonal key signatures that could be spelled using double or
triple accidentals allows you to specify that, depending on the other choices

made for these options, you may still nevertheless prefer Dorico not to use
double or triple accidentals, even if you have specified that it should, for
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example, prefer sharps. For example, if you input a G#m(maj7) chord,
having set Sharps only and Avoid remote spellings, the root note of the
chord would be spelled as G sharp when Allow double and triple
accidentals is chosen. When Disallow double and triple accidentals is

chosen, however, it will instead spell the chord on an A flat to eliminate the
F double-sharp, even though the alternative still contains a C flat as its third.

These options have no effect when you are writing in any other key signature,
whether it is a minor or major key signature, or a custom key signature.

Independent scale factor. It is now possible to scale accidentals independently of
notes. In Engrave mode, select the notehead to which the accidental belongs, then
activate the new Accidental scale property in the Notes and Rests group in the

Properties panel.

Gaps between accidentals and following notes. Additional control over the gap
between the rightmost flat and an unshortened ledger line when note is in a space
or on a line has been provided, with new options on the Accidentals page of

Engraving Options.

Accidentals for 24-EDO tonality system. In response to user feedback, Dorico now
employs the Stein-Zimmermann accidentals in its default 24-EDO tonality system,
rather than the accidentals with arrows recommended by Elaine Gould in Behind
Bars.

Articulations

Pasting articulations independently of notes. A new Edit » Paste Special » Paste

Articulations command has been added. Copy a passage of notes to the clipboard,
then select the note from which you want the articulations to be pasted, then
choose the new command; the articulations in the copied passage will be pasted.

Audio export

FLAC support. It is now possible to export audio in FLAC format. FLAC is a lossless
compression format, so unlike MP3 there is no effect on the quality of the sound
itself. FLAC typically compresses by around 50% compared to WAV, but it is not
universally supported by all playback software. When exporting in FLAC format,
you can choose between exporting at 16- or 24-bit depth.

Bit depth. When exporting in WAV format, you can now specify the bit depth of the
exported audio, with a choice between 16-bit, 24-bit or 32-bit.
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Bar numbers

Bar number changes. Bar number changes can omit the primary number, so you can
easily make sequences such as1, 2,3, a, b, ¢, 4, which are sometimes required for
inserts in musical theatre scores.

Position relative to clef at start of system. New options have been added to the Bar
Numbers page of Engraving Options specifying the minimum distance above or
below treble G, treble G with 8 below and tenor C clefs bar numbers at the start of
the system should appear. This allows you to specify a smaller gap above or below
the staff for bar numbers shown at other positions along the system and still have
bar numbers avoid clefs at the start of the system.

Ranges of bar numbers on multi-bar rests. When Show ranges of bar numbers
under multi-bar rests and consolidated bar repeats is activated on the Bar
Numbers page of Layout Options, Dorico will now only show those bar number

ranges on the staves on which bar numbers would normally appear, rather than on
every staff on which the multi-bar rest appears.

Local versus global bar numbers. When Dorico draws bar numbers, it uses the bar
numbers calculated for the staff on which the bar numbers are drawn. This can be
useful in polymetric music where the bar numbering may vary between
instruments, but in cases where local time signatures have only been used to do
things like change default beam grouping for a passage, it can be less helpful.

A new Bar Numbers page has been added to Notation Options, with the new option
Bar number calculations, allowing you to choose whether the bar number

calculations for each flow should Use global bar count or Use local bar count.

Bar repeats

Numbering the final bar of a bar repeat region. A new option Appearance of bar
repeat count for the last bar in the region has been added to the Bar Repeats page
of Engraving Options, allowing you to specify that the last bar in a bar repeat region
should always be numbered, even if it would not normally be numbered according
to the chosen interval for bar numbering in the region.

Beaming

Centered beams. A centered beam, sometimes called a “kneed beam”, describes a
beam that is positioned between notes on the same staff, both above and below the
beam. By default, Dorico will only show a centered beam if the natural stem
directions of the notes in the beamed group specify that both up- and down-stems
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would be required if the notes were unbeamed; in practice, this means that only
beam groups that straddle the middle staff line can show centered beams.

To provide additional flexibility for centered beams, you can now select the notes in
a beamed group and choose Edit » Notations » Stem » Custom Centered Beam,
which will show a simple dialog in which you can specify the desired stem direction
for each note. When you confirm the dialog, if the combination of stem directions
you have chosen should give rise to a centered beam, one will be created.

Notes on the middle line of the staff. When notes on the middle line of the staff are
given a default direction instead of a contextual direction (because Stem direction
for notes on the middle line of the staffis set to Use default direction), such notes
can govern the overall stem direction for a beamed group, which is sometimes
undesirable. A new option, Notes on the middle line of the staff in beamed
groups, has been added to the Stems section of the Notes page of Engraving
Options, allowing you to change this behavior: choose Ignore for stem direction,

and only the notes either side of the middle line of the staff will govern the overall
stem direction for the group.

Stem direction calculation for beamed groups. By default, Dorico considers the
number of notes or chords above or below the middle of the staff when determining
the stem direction for a beamed group of notes, and uses the note furthest from the
middle of the staff in the event of an equal number of notes above and below the
middle of the staff. If you prefer to consider only the note furthest from the middle
of the staff, you can now set the new Stem direction for beamed groups option in
the Stems section of the Notes page of Engraving Options to Consider only furthest

note from middle of staff.

Beam thickness. It is now possible to override the thickness of and separation
between beam lines in Engrave mode, using new Thickness and Separation

properties in the Beaming group in Properties.

Breaks

Moving bars between systems. A pair of new commands have been added that make
it quick and easy to change the casting-off of your music. In Engrave mode, you can

select anote orindeed any item in a bar, and then use either Engrave » Format
Systems » Move Bar to Previous System or Move Bar to Next System to move that
bar to the previous or next system, leaving all other systems in the layout
untouched. These menu items have the default key commands, (comma) and .

(period or full stop) for quick access.
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When you move a bar to the previous or next system, Dorico creates appropriate
breaks to ensure that the right bars are on each system. For example, if you have
two systems, the first with four bars and the second with three, and you decide that
the first system would look better with only three bars, you can select any item in
the last bar of the first system and type . to move that bar to the next system. Dorico
ensures there is a break at the start of the first system, then creates a new system
break at the start of the bar in which you made your selection, so that bar becomes
the first bar of the second system. It sets the Wait for next system break property
on the original first system to ensure that the first system keeps the three bars it
already had. By default, Dorico does not force the layout of the second system;
instead it simply ensures that it begins with the bar that you moved from the first
system.

If you have previously used Finale, these commands will be familiar to you. If you
have not used Finale, you may be finding the purpose of these commands a little
abstract. Rest assured that they are much easier to understand by experimentation
than by reading about them: open an existing project, switch to Engrave mode,

select something and type, or. to see for yourself what happens.

In Finale, however, the equivalent commands work a little differently: to continue
the example described above, Finale would force the contents of the second system
so that even after adding one or more bars from the first system, all of the bars that
were previously on the second system should remain there, which could make it
more cramped. If you would like Dorico to behave exactly like Finale in this regard,
you can do so: activate Lock source and destination systems when moving bars to
previous or next system on the Note Input and Editing page of Preferences. When
this option is enabled, Dorico will create a further system break at the end of the
second system, and set the Wait for next system break property on the new break
at the start of the second system, effectively locking the contents of both the first
and second systems.

Break locations. A new option, Snap system and frame breaks to barlines when

creating, has been added to the Note Input and Editing page of Preferences. This

option is switched on by default.

You can create a system or frame break at any rhythmic position, including in the
middle of a bar, but by default breaks will snap to barlines. When creating a single
system or frame break, the break will be created at the start of the bar in which the
earliest item is selected. When using Make Into System or Make Into Frame, the
first break will be created at the start of the bar in which the earliest item is
selected, and the second break will be created at the end of the bar in which the
latestitem is selected.
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This makes it much quicker to create breaks and perform casting off in your
layouts, because you no longer need to worry about making a selection at a precise
rhythmic position before you create a break.

Retaining properties on breaks. Dorico now always maintains Wait for next
system/frame break properties, staff size overrides and hide empty staves
overrides for breaks at the same positions as new breaks being created as part of
Make Into System/Frame or Lock System/Frame operations. This prevents

unexpected changes in casting off if you return to the same passage to perform
more formatting.

Lock and Reset Layout. It is now possible to lock the formatting of the current layout,
inserting suitable system and frame breaks on every page, by choosing Engrave »
Format Music Frames » Lock Layout. This is equivalent to selecting an item in each

frame in turn and clicking Lock Frame, but you do not have to select anything in

advance.

The converse operation is also now available: to remove all system formatting from
your layout by deleting all system and frame breaks, choose Engrave » Format

Music Frames » Reset Layout.

Chord diagrams

Fingering numbers. It is now possible to show fingerings on chord diagrams, either
as numbers within the dots, or at the ends of the strings. To show fingerings,

activate Show fingerings in chord diagrams on the Chord Symbols and Diagrams
page of Layout Options. Use Fingerings position to choose between showing the

fingerings Inside dot or At end of string.

Dorico will show default fingerings for all the chord shapes in the factory library,
but you can edit them if you choose, either for an individual chord diagram by

double-clicking it in Engrave mode, or for the whole project via Library » Chord
Diagrams. Fingerings will only appear in the chord diagram editor if they are shown
in the current layout, so be sure to activate Show fingerings in chord diagrams

before you try to edit them.

To edit a fingering, double-click it in the Edit Chord Diagram dialog, then type the
finger number. If you type a finger number that is already used on another string,
Dorico will attempt to reallocate the other strings sensibly. If, however, you need to

reset to the default fingering, choose Edit » Notations » Chord Symbols and

Diagrams » Reset Chord Diagram Finger Numbering.
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Chord symbols

Creating chord symbols from selected notes. Dorico can now create chord symbols
based on the harmonies described by a selection of notes. First, select the music
from which you would like to generate chord symbols, which can be any size of
selection from a single chord on a single instrument to an extended passage of
music spanning multiple instruments. Once you have made your selection, choose

Edit » Notations » Chord Symbols and Diagrams » Generate Chord Symbols From

Selection. The following dialog appears:

Generate Chord Symbols From Notes

Harmonic rhythm: ~ Every bar Every beat
Minimum duration of single notes following chords to include inanalysis:
Minimum duration of chords eligible for chord symbols: I v
Only use downbeats when creating chord symbols from notes at multiple positions
Detect inversions: ~ Always Never 3 v
. Only create chord symbols from horizontal passages when unambiguous
Try to detect and handle passing notes
Use vamp detection

Minimum length for chords in vamp: I v

Maximum rhythmic separation between chordsinvamp: ~ '~

Advanced Options
Allow creation of open fifths
. Allow creation of major and minor thirds

Ignore omitted fifths: =~ Never In major/minor triads Always

Cancel OK

= Harmonic rhythm specifies the interval at which Dorico should create new
chord symbols, examining the selected music chunk by chunk. Dorico
automatically chooses a useful value for this option based on the music you
have selected.

= Minimum duration of single notes following chords to include in analysis
allows you to exclude passing notes from the analysis. Set this option to the
shortest note value you typically want to be considered as part of the
analysis; any shorter note values will be ignored.

*= Minimum duration of chords eligible for chord symbols similarly allows
you to exclude transitory chords from the analysis. Set this to the shortest
note value you typically want to be considered as a distinct chord; any
chords with shorter note values will be ignored.
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* Only use downbeats when creating chord symbols from notes at
multiple positions considers the metrical structure of the bars containing
the selected music, and if switched on, it will only consider the notes that
start on strong beats in its analysis.

» Detect inversions specifies whether Dorico should consider inversions
when analyzing the music; you may want to set this to Never when selecting
music from multiple instruments. When you are working with music from a
single instrument, you may want to either Always consider inversions, or
help Dorico to identify the bass notes in the chord by specifying a specific
pitch below which it should consider notes as describing inversions.

* Only create chord symbols from horizontal passages when unambiguous
is switched off by default; if you switch it on, it will limit Dorico to looking for
simpler chord symbols, particularly when notes at different rhythmic
positions are considered together as forming a single chord.

= Try to detect and handle passing notes enables heuristics that try to
determine which notes in the selection are passing notes and therefore not
critical to the analysis of the prevailing harmony.

»= Use vamp detection enables heuristics that try to identify rhythmic
patterns and textures often used when vamping, which are then taken into
consideration during the analysis. The two following options, Minimum
length for chords in vamp and Maximum rhythmic separation between
chords in vamp, can be adjusted based on the specific rhythmic patterns
used in the selection to help guide Dorico’s vamp detection.

= Allow creation of open fifths determines whether Dorico will detect open
fifths (i.e. dyads a fifth apart, with no kind of third between them).

= Allow creation of major and minor thirds determines whether Dorico will
allow dyads that have no fifth or higher scale degrees to be interpreted as
major or minor triads for the purposes of analysis.

* Ignore omitted fifths determines how Dorico should handle chords that

would typically include a fifth, but in which the fifth is omitted.

Once you are satisfied with the options, click OK and Dorico will create chord
symbols in the selected passage. All instruments from which music was selected
will show chord symbols.

Parenthesizing chord symbols. It is now possible to enclose a chord symbol in
parentheses by activating the new Parenthesized property in the Chord Symbols
group in the Properties panel. When inputting a chord symbol via the Shift+Q

popover, you can also surround the chord symbol with parentheses, e.g. (Cm7), and

the resulting chord symbol will be parenthesized.
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If you want to indicate that a sequence of chord symbols is optional or an
alternative set of changes, you can show only the opening (left) parenthesis for one
chord symbol, and then the closing (right) parenthesis for another chord symbol,

using the new Parenthesis to show property.

Depending on the size and shape of the chord symbol, you may want to change the
type of parenthesis used; different parenthesis characters are provided that are
used for chord symbols of different heights, and you can choose between these by

activating the new Parenthesis style property. Further fine-tuning of the size of the

parenthesis can be achieved by altering the Parenthesis scale property.

If a chord symbol already includes parentheses, for example surrounding
alterations, then surrounding the entire chord symbol with a larger set of

parentheses can appear fussy or cluttered; as such, a new Suppress parentheses
around alterations option has been added to the new Parentheses section of the
Chord Symbols page of Engraving Options. This allows you to choose whether the

parentheses around alterations in chord symbols should appear, and under what

circumstances.

The Parentheses section of the Chord Symbols page of Engraving Options also
includes options for the gap between the parentheses and the chord symbol, and
the scale factor for parentheses; by default, the parentheses are scaled slightly large
relative to the chord symbols themselves, so that they extend a little way above and
below the chord symbol, making them more conspicuous.

Placement. A new option, Position of chord symbols relative to single staff
instruments, has been added to the Position section of the Chord Symbols page of

Engraving Options. This option allows you to specify whether chord symbols should
appear above the staff (the default), or below the staff.

You can also change the placement of an individual chord symbol by activating the

new Placement property in the Chord Symbols group in the Properties panel.

Erase background. When chord symbols are shown between the two staves of a
grand staff instrument, or otherwise above a staff that is joined to the staff above by
a barline, it may not always be possible to avoid the chord symbol colliding with a
barline. A new Erase background property has been added to the Chord Symbols
group in Properties; when activated, barlines and staff lines will be covered. The
padding for the erasure is determined by a new option in the Design section of the

Chord Symbols page of Engraving Options.

Chord symbol visibility regions. It is now possible to create a chord symbol visibility

region by typing reg into the Shift+Q popover.
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Showing either chord symbols or diagrams. A new Show only property has been

added to the Chord Symbols group of the Properties panel, allowing you to specify

that either the chord symbol or chord diagram component should be hidden.

Chord symbols with altered bass notes. You can now override the default
arrangement for altered bass notes, as specified in the Altered Bass Notes section
of the Chord Symbols page of Engraving Options, by activating the new Compound

chord arrangement property in the Chord Symbols group of the Properties panel.

Disabling MIDI input for chord symbols. If you do not ever want to input chord
symbols using your MIDI keyboard, you can set the new Chord symbol input via
MIDI keyboard option on the MIDI Input page of Note Input Options to Disallow
MIDI input.

Clearing played pitches. When you input chord symbols using your MIDI keyboard,
Dorico remembers the voicing you used for the chord, and that voicing will be
reproduced when you subsequently play back the chord symbols via the Chords
track in Play mode. If you later decide that you would like to restore the default
voicing for a chord symbol, select it and choose Edit » Notations » Chord Symbols

and Diagrams » Clear Chord Symbol Played Pitches.

Chord symbol region highlights. When View » Highlight Chord Symbol Regions is
switched off, Dorico now also hides the purple bar drawn for making it possible to
select chord symbol regions.

Flat 10 alteration. It is now possible to create a b10 alteration: simply type b10 into

the Shift+Q popover.

Clefs

Lead sheet style. A new option Clefs at start of systems following first system has

been added to the Clefs page in Notation Options, allowing you to hide clefs on
systems following the first. This is a convention sometimes followed in hand-copied
lead sheets, and a corresponding option has been added for key signatures.

Octave shifts. It is now possible to specify an octave shift for the clef to be created in
the Shift+C popover: for example, typing g+2 will create a treble G clef with an

Octave shift value of 2, or f-1 will create a bass F clef with an Octave shift value of -1.

Comments

Comments from all flows. The Comments panel in the right zone in Write mode now
shows comments from all flows assigned to the current layout, rather than only the

current flow, as in previous versions.
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Condensing

Tempo signposts. Signposts for hidden tempo items above condensed staves can
now be selected in Write mode.

Cues

Fermatas. It is now possible to specify whether fermatas should be included in cues,
both via a new option on the Cues page of Engraving Options, and on a per-cue

basis via the new Show fermatas property in the Cues group in the Properties

panel.

Cues on unpitched percussion. It is now possible to create a rhythmic cue from a
pitched instrument on an unpitched percussion instrument or kit.

Popover input. It is no longer necessary to hit Return twice to confirm input of the

Shift+U popover.

Cues at instrument changes. A new option Show instrument change label after
cue, if cue precedes first note in new instrument has been added to the Players
page of Layout Options allowing you to specify that when an instrument change
occurs at the same point as a cue, the label showing where the new instrument
starts playing should be positioned at the end of the cue, rather than at the start.
The new option is disabled in existing projects by default to avoid changing their
appearance unexpectedly, but enabled in new projects.

Dynamics

Dynamics in tight spacing. The behavior of dynamics in tight situations - either
when note spacing is very narrow, or when wide dynamics are covering short
rhythmic durations - has been improved.

The way Dorico allocates additional space for gradual dynamics has been improved,
and the way messa di voce hairpins are handled has been overhauled: if a messa di
voce hairpin needs to be shortened to accommodate an immediate dynamic or
barline at either end, the amount to be shortened is now distributed over both
segments of the hairpin, rather than only the second, which looks much better.

In the specific case that a messa di voce hairpin is written over a single note or
chord, and ends at a barline position, Dorico will now evenly distribute the two
segments of the hairpin to improve its appearance. Options to control this new

behavior can be found in the Advanced Options section of the Gradual Dynamics

section of the Dynamics page in Engraving Options.
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Engrave mode

Crosshairs. Most items that are positioned outside the staff now show a pair of
crosshairs in Engrave mode when they are selected and when they are dragged
with the mouse. Although the implementation is very simple - there are no rulers,
and no snapping of items as they are dragged - the crosshairs are nevertheless
helpful when positioning items manually in Engrave mode, allowing you to see the
horizontal and vertical alignment of items immediately.

The following types of items show crosshairs when selected or dragged in Engrave
mode:

» Immediate and gradual dynamics
» Staff- and system-attached text

= Octavelines

= Slurs

»  Guitar bends

» Immediate and gradual tempo changes
= Playing techniques

» Rehearsal marks

» Lyrics

» Ornaments and trills

= Pauses

» Pedallines

= Arpeggiolines

= Chord symbols

= Repeat endings

= Percussion legends

= Repeat markers

» Harp pedal changes

» Horizontal and vertical lines

» Figured bass

If you would prefer not to see crosshairs in Engrave mode, you can deactivate Show

When Selected or Show When Dragging in the new Engrave » Crosshairs

submenu.

Switching to Engrave mode. By default, Dorico remembers which of the tools in the
toolbox was last active when you return to Engrave mode, but you might find it
helpful to always have the graphical editing tool active when you return to Engrave

mode. If so, activate the new option When switching to Engrave mode, activate the

Graphical Editing tool in the Window section of the General page of Preferences.
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Nudging frames and handles. You can now use all of the combinations of modifiers
with the arrow keys used for nudging in graphical editing mode when nudging
selected frames, vertical spacing handles, and note spacing handles to nudge by
different amounts.

Figured bass

Bracketing. Dorico 4 introduces comprehensive support for adding parentheses or
square brackets to figured bass in your score. Whole stacks of figures, individual
figures, or even individual accidentals can all be flexibly bracketed.

To specify brackets when inputting figures using the Shift+G popover, simply type
parentheses around the figures, figure or accidental that you want to be bracketed.
For example, typing (#643) will bracket the entire stack of figures; typing #6(4)3 will
bracket only the figure 4; and typing (#)643 will bracket only the sharp accidental to
the left of the figure 6.

You may want to show an opening bracket on one stack of figures, and then a
closing bracket on a later stack of figures, for example to denote that a passage of
figures has been added by the editor or could be played optionally. In this case,

bracket both stacks of figures as normal, then in Engrave mode, activate the Hide
single bracket property in the Figured Bass section of the Properties panel, then

specify whether it is the Start or End bracket that should be hidden.

By default, Dorico uses square brackets, but you can use round brackets (or
parentheses) instead: set Bracket style to Round brackets in the Design section of
the Figured Bass page of Engraving Options. In this section you will also find a

comprehensive set of options for the design, size and positioning of the brackets.

Tasto solo. It is now possible to add a tasto solo indication, telling the continuo
player that the following passage should be played without harmony, using the

Shift+G popover: simply enter tasto or ts into the popover. The wording and case of
the tasto solo indication is controlled by the new Tasto solo appearance option in
the Design section of the Figured Bass page of Engraving Options. To change the
font or size of the indication, edit the new Figured bass tasto solo paragraph style

in Library » Paragraph Styles.

MusicXML import. When importing figured bass from MusicXML files, you can
activate the new Figured bass appearance option on the MusicXML Import page of
Preferences if you want to retain the precise appearances of figured bass as stated
in the MusicXML file. By default, Dorico will use the default appearance options as
specified in Engraving Options and default interpretation options as specified in
Note Input Options to determine how the figured should be imported.
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MusicXML export. Figured bass is now included when exporting MusicXML.

Filters

Quick filters. New quick filters for Repeat Markers and Repeat Endings have been

added to the Edit » Filter submenu.

Fingering
Fingering shifts. It is now possible to specify fingering shifts directly in the Shift+F

popover by appending / after the finger number; for example, 3/.

Grace notes
Converting to and from rhythmic notes. It is now possible to convert the selected
notes to and from grace notes by clicking the grace note button in the Notes toolbox
when the caret is not visible. This is particularly useful when editing music that was
input using real-time recording, or was automatically transcribed from a MIDI file.

To convert one or more selected rhythmic notes into grace notes, simply type the
key command / or click the grace note button in the Notes toolbox. To choose
between slashed (acciaccatura) or unslashed (appoggiatura) grace notes, press and
hold, or right-click, the grace note button to open a pop-up menu from which you
can make the choice between the two types.

When converting rhythmic notes into grace notes, by default Dorico snaps slashed
grace notes rightwards, so that they abut the next rhythmic position, and snaps
unslashed grace notes leftwards, so that they precede the rhythmic position at
which the first selected rhythmic note was previously located. If you want to change

this behavior, you can adjust Direction of rhythmic movement when converting to

grace notes on the Note Input and Editing page of Preferences.

To convert one or more selected grace notes into rhythmic notes, the procedure is
the same: simply type / or click the grace note button in the Notes toolbox. The new
rhythmic notes will begin at the primary rhythmic position the grace notes
formerly preceded, overwriting the following notes. If you want to prevent the grace
notes from overwriting the following notes, ensure Insert mode is active before you
convert them.

Harp pedaling

Scale and color. Harp pedal change items now respond to the Scale, Custom scale

and Color properties in the Common group in the Properties panel.
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Hub

The Hub window has been redesigned for Dorico 4. It is now split into three pages,

Open Recent, Create New, and Learn.

Open Recent page. Recently opened projects are listed in the reverse order in which
you last opened them. Projects saved in Dorico 4 or Dorico for iPad show a
thumbnail of the first page of the last layout that was shown when the project was
open; projects last saved in an earlier version of Dorico, or files in other formats
(such as MIDI or MusicXML) will not show a thumbnail. Click the menu button in the
top right-hand corner of each project card to open a contextual menu from which
you can choose to remove the project from the Hub or open the folder where the
projectis located.

Create New page. Template categories are listed on the left, and choosing one shows
the templates in that category in the grid in the middle of the page. New options on
the right-hand side allow you to make some initial choices about your project,
including specifying the title, composer, music and text fonts, starting key and time
signature, and (if specifying a time signature) an initial number of bars. Project will
use multiple flows determines whether flow headings should be shown by default.

All these initial decisions can of course be changed later.

Learn page. In addition to showing the latest videos from the Dorico YouTube
channel and the latest posts from the Dorico blog, the Learn page also includes a set
of hands-on tutorials that are designed to introduce important note input and
editing concepts to new users.

Instrument changes

Instrument change labels. If the Instrument change paragraph style is set touse a

border, instrument change labels are now shown with a border.

Instrument types

Sketch instruments. A new Sketch family of instruments has been added, containing
generic treble, bass and grand staff instruments, and grand staff instruments for
woodwind, brass and strings.

These can be useful when importing MIDI data from your DAW or sequencer if the
original project uses sectional sounds on a single track, since a grand staff sketch
instrument is easier to read than a single staff with notes on many ledger lines
either above or below.
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They can also be useful when building up an arrangement from scratch in Dorico,
using a section sound while experimenting with texture, before splitting the music
out onto individual instruments in the family.

Key signatures

Lead sheet style. A new option Key signatures at start of systems following first
system has been added to a new Key Signatures page in Notation Options, allowing
you to hide key signatures on systems following the first. This is a convention
sometimes followed in hand-copied lead sheets, and a corresponding option has
been added for clefs.

Filter for accidentals. The Edit Tonality System dialog now contains a field into
which you can type to filter accidentals, helpful in tonality systems with many
accidentals defined.

Layouts

Duplicate Layout. It is now possible to duplicate an existing layout in your project,
making an exact copy that retains all the edits you have made, including
adjustments to Layout Options, page templates, flow headings, properties, clef and
transposition overrides, vertical spacing adjustments, note spacing adjustments,
lyric vertical position adjustments, custom staff sizes, graphics frames, and so on.

To duplicate a layout, select it in the Layouts panel in Setup mode, then either right-
click and choose Duplicate Layout from the context menu, or choose Setup »

Duplicate Layout.

Propagate Part Formatting. The layout options related to page numbers are now

propagated to part layouts when using Propagate Part Formatting.

Sorting layouts. It is now possible to sort layouts either according to their layout
number (which can be edited by expanding each layout’s card) or by following the
instrument score order. Click and hold, or right-click, the Sort Layouts button in the
action bar at the bottom of the Layouts panel in Setup mode to choose whether to

sort by Layout Number or Instrument Score Order.

Counterpart Layout. Window » Counterpart Layout now works correctly with a rest
selected, as well as with a note or other type of item. Relatedly, it is now possible to
use Window » Counterpart Layout to switch back from a part layout to the full
score layout with nothing selected. (The converse is not possible, as without any
selection, Dorico cannot determine which part layout to switch to.)
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Lyrics

Lyric hyphens at the start of the system. When a word is split into multiple syllables
across a system break, with a new syllable on the note at the start of the new
system, some publishers will show a hyphen both at the end of the preceding
system and at the start of the new one, while others will show a hyphen only at the
end of the preceding system. This latter convention is now possible to achieve in
Dorico by setting the new Lyric hyphens before the first note of the system option

on the Lyrics page of Engraving Options to Do not show.

Retain properties when edited. When editing existing lyrics, any properties set on
those lyrics are now preserved.

Nudging lyric lines. It is now possible to adjust lyric baselines by a tiny amount in

Engrave mode using Ctrl+Shift+Alt+1/{.

Multi-bar rests

Hidden time signatures. Hidden time signatures no longer cause multi-bar rests to
be split.

Horizontal position of H-bars. Additional control over the width and position of H-
bar symbols used for multi-bar rests has been added.

Two new options, Items before barline at the end of multi-bar rest and Items
after barline at the start of multi-bar rest, have been added to the Rests page of
Engraving Options, allowing you to specify whether items that appear to the left
(such as clefs) or right (such as time and key signatures) of barlines should be
considered when determining the position of H-bars. By default, both options are
set to Consider width of items, but if you would prefer H-bars to always be
centered between barlines regardless of the widths of any intruding items, choose

Ignore width of items.

Furthermore, you can also now adjust the horizontal position of a selected H-bar
using the new H-bar X offset property in the Multi-bar Rests group in the

Properties panel.

Music fonts

Music symbol substitution. When using a music font other than Bravura, any
symbols that are required by the music but not provided by the chosen font will now
automatically be drawn using Bravura. If you want to specify a different fallback

music font, you can do so by adding a font to the new Substitutions list for the

relevant font style in Library » Music Fonts.
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User interface improvements. The list of fonts in Library » Music Fonts is now sorted

alphabetically. It is now possible to confirm the choice in the Music Fonts dialog by

double-clicking an entry in the list.

MusicXML export

Partial beams. Partial beams are now correctly exported to MusicXML.

MusicXML import

Clefs. The “none” clef type in MusicXML files is now interpreted as a treble G clef, as
recommended.

Tablature import. When importing MusicXML files containing staff notation and
tablature written as separate parts, Dorico will try to determine whether the two
parts are separate representations of the same music and should be interpreted as
a single instrument showing both staff notation and tablature. You can control

whether and how Dorico does this by changing the new When notation and
tablature are both encoded as separate parts option in the Advanced Options

section at the bottom of the MusicXML Import page of Preferences.

Notation Options

Note grouping in irregular meter. New When splitting notes at beat subdivisions

option in the Time signatures with irregular meter section of the Note Grouping
page of Notation Options, allowing you to specify whether Dorico should split notes
at all subdivisions or only at subdivisions of different length.

Note input

Notes toolbox. The Notes toolbox in the left zone in Write mode includes several
new buttons. Several buttons - including those for Insert mode, adding or cycling
through voices, specifying rhythm dots, grace notes, and tuplets - now show a
menu if you click and hold the button for a moment.

P8 Start Note Input. Click this to show or hide the caret; equivalent to typing Shift+N. If
there is no selection, Dorico will show the caret at the start of the bar closest to the
top left corner of the current view.

J()] Insert for current voice. Equivalent to having Insert mode active in earlier versions
of Dorico: adds or removes time from the selected voice, or the voice set in the
caret. This button can be held down to show a menu allowing you to choose a
different Insert mode scope.

Insert for current instrument. Adds or removes time from all voices in the selected
instrument, and also includes items that are not in a particular voice but are

instead attached to the staff, such as dynamics and lyrics.
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I Insert for all instruments. Adds or removes time from all instruments in the
ensemble. This shifts music forwards and backwards while retaining the existing
time signatures.

)] Insert for all instruments and extend current bar. Adds or removes time from all
instruments in the ensemble, but also increases or decreases the duration of the
current bar.

J Add new voice. Primes the caret to start inputting in a new voice; equivalent to
typing Shift+V. This button can be held down to show a menu allowing you to
choose between adding a new slash voice, or cycling between the currently active

voices (equivalent to typing V on its own, without Shift).

The changes to the Notes toolbox are intended to make more of Dorico’s note input
tools more readily available using the mouse.

Notations toolbox. The Notations toolbox in the right zone in Write mode has been
revamped, and it now contains a pair of buttons at the top of the toolbox that allow
you to switch between showing panels and opening popovers:

. Panels
Popovers

When Panels is active, clicking a button will show or hide the relevant panel in the
right zone; when Popovers is active, clicking a button will open the relevant

popover. The buttons shown in the toolbox differ, since not all panels have an
equivalent popover, and vice versa.

Starting note input. You can now start note input and real-time recording without
first making a selection: choosing Write » Note Input (shortcut Shift+N) or Play »

Record (shortcut Ctrl+R on Windows, Command-R on Mac) will now show the caret
on or start recording in the first visible bar in the first visible staff in the current

view.

Changing the voice of existing notes. It has always been possible to change the voice
of existing notes using the commands in the Edit » Notations » Voices submenu,
but Dorico 4 introduces an additional, very natural method to do this, using the
same key commands that are used during step-time input: V to cycle between the

voices already present on the staff, or Shift+V to move the notes to a new voice.

Note spacing

Minimum gap after rhythm dot. A new Gap after last rhythm dot option has been
added to the Rhythm Dots section of the Notes page of Engraving Options, which

defines the amount of space Dorico should enforce following the rightmost column
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of rhythm dots, so that in tightly-spaced music it is no longer possible for the
leftmost note at the next rhythmic position to appear closer to the rhythm dot to its
left than that rhythm dot appears to the note to its left to which it actually belongs.
In existing projects, this option has a value of 0 spaces, to avoid changing the
appearance of those projects; the default in new projects is half a space.

Percussion

Rests. It is now possible to edit rests in music written for percussion kits when
displayed using the five-line staff and grid presentation types. As far as is possible,
rests now behave the same way in percussion kits as they do in pitched
instruments. It is possible to change the vertical position of rests in the staff using

the Rest pos. property, it is possible to hide them using Edit » Remove Rests, and

you can also manually hide and show them using the Starts voice and Ends voice

properties.

Be aware that if you save a project in Dorico 4 that makes use of these new
capabilities for editing rests, those edits will not be predictably preserved if the
project is opened in Dorico 3.5 or an earlier version.

Inputting tuplets. The handling of tuplets during note input onto percussion kits has
been thoroughly overhauled, and now feels much more natural. Whenever you
create a tuplet in an unpitched percussion kit, the tuplet is added to all of the kit
components that share the same notated voice in the kit presentation type, so that
any notes you subsequently add to other instruments in the kit in the range of the
tuplet will be correctly notated.

Removing instruments from kits. A new command, Remove All Instruments From

Kit, has been added to the instrument context menu, accessed from an expanded
player card. This command removes all instruments from the kit, leaving the kit
empty, and showing each instrument that was previously included in the kit as an
individual instrument assigned to the player.

Playback

Project activation. When working with multiple projects at the same time, only one
project can be active for playback. In previous versions, Dorico has always activated
a project when one of its windows becomes active, and depending on the playback
template in use, you may experience a delay of multiple seconds (or longer, in the
case of very large and complex playback templates) before you can work in the
newly activated project.

In Dorico 4, however, the default behavior is now different: the first project you
open is automatically activated for playback, as before, but if you open a second
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project without closing the first, a dialog will appear asking you whether you want
to activate this project, deactivating the first.

If you choose not to activate the new project, then you will not be able to play back in

that project until you manually activate it by clicking the B8 button on the toolbar.

On the Play page of Preferences, you will find two new options that control the

project activation behavior when opening projects.

Transport window. The Transport window has been redesigned to share the same
look and feel as the mini Transport in the toolbar.

Transport

26.1.1.000 00:00:50:00

4 <« > B D B

The Transport window now includes the Activate Project button, and it is now
possible to change the tempo value in fixed tempo mode in the Transport window
(previously this was only possible using the mini Transport in the toolbar).

Viewing items suppressed in playback. A new option, View » Note and Rest Colors »
Suppressed Playback, has been added, which when activated causes any items that

have been muted by way of the Suppress playback property to be shown in gray, so

that they are easier to spot. This option is switched on by default.

Rhythmic feel. Notes that have manual offsets applied to their duration (in other
words, affecting their end position) can now have swing rhythmic feels applied, if
appropriate.

Metronome click. The default metronome click in new projects is now Click, rather

than Beep. You can change this on the Click page of Playback Options.

Ghost notes. A new option Bracketed noteheads (ghost notes) for unpitched
percussion has been added to the Dynamics page of Playback Options. This allows
you to specify the amount of reduction in dynamic level that arises from a ghost
note. This can also be overridden in the Playback Options Overrides section of the
Expression Maps dialog if needed. The reduction is expressed in terms of steps in

dynamic level; 1.0 is the difference between, say, £ and ff .

Repeats playback. If Dorico detects during project loading that the repeat structure
is malformed and will lead to infinite repeats, it automatically switches off the Play

repeats option on the Repeats page of Playback Options.
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Play button behavior. A new preference has been added to the Play page of
Preferences that determines whether the Play button in the mini transport on the
toolbar plays from the playhead position (the default behavior) or from the
selection.

Playback templates

Moving projects between iPad and Mac or Windows. If you edit the same project in
Dorico for iPad and in Dorico 4 for Mac or Windows, the playback configuration for
each platform will now be preserved, so that changes you make to sounds and
effects on one platform will not cause the saved configuration for the other
platform to be lost.

Warning about missing playback templates. The warning that appears when
opening a project that uses a playback template that is not present on your
computer can now be suppressed so it no longer appears.

Playing techniques

Pedal lines. All the commands in the Edit » Notations » Pedal Lines submenu that
make sense to be able to operate at multiple rhythmic positions within the span of a
pedal line - such as adding or removing retakes, or changing to a different pedal
level - now take effect at all selected rhythmic positions if multiple notes are
selected within the length of the pedal line. If the caret is visible, then the edit will
take effect at the location of the caret instead.

Popoverinput. It is no longer necessary to hit Return twice to confirm input of the
Shift+P popover. Furthermore, when creating a playing technique with an existing

playing technique selected (for example, by hitting Return and editing it in the
popover), the original playing technique is now replaced, rather than a new playing
technique appearing in addition to the original one.

Hiding empty staves. Hidden playing techniques no longer cause staves that would
otherwise be allowed to be hidden as empty staves to appear.

Print mode

Transposition warning. When determining whether you should be warned that the
part layout about to be printed is in concert rather than transposing pitch, Dorico
now considers whether the layout contains any transposing instruments, and will
only show the warning in the event that it does (so, for example, a part layout
containing a piano set to concert pitch will no longer trigger the warning to appear).

76 Steinberg Media Technologies GmbH



Dorico 4 Version History

@ steinberg

Slurs

Collision avoidance. The property formerly called Disable auto curve adjustmentis

now called Avoid collisions, and can be set to force Dorico to adjust the curve of the
slur to avoid collisions with items under its arc as well as to disable collision

avoidance.

Staff labels

Player group labels. Dorico can now display labels in the left margin corresponding
to player groups as defined in the Players panel in Setup mode. For example, you
may wish to identify two separate mixed voice choirs as “Choir 1" and “Choir 2" in
your ensemble, or identify an off-stage group of performers, or perhaps identify
groups that can play the same music in a piece written for a flexible ensemble.
Player group labels are rotated through 90 degrees, and are written vertically up the
page, positioned to the left of staff labels for individual instruments.

In new projects created in Dorico 4, player group labels will appear by default as
soon as you create a player group in the Players panel, but in existing projects they
do not appear by default to avoid changing the appearance of those projects. To
show player group labels in your layout, activate the new Show player group
names option in the Staff Labels section of the Staves and Systems page of Layout

Options.

To control the font, style and size of player group labels, you can edit the new Player
Group Labels paragraph style in Library » Paragraph Styles. By default, player
group labels are drawn centered on a vertical bracket that spans the staves
belonging to the instruments included in the group; if you prefer not to show a
bracket, or to show the group label inside the bracket rather than centered on the

bracket, you can adjust the options in the new Player Group Labels section of the

Staff Labels page of Engraving Options.

If there is insufficient room to show the full group name, Dorico will show the
group’s short name instead. To edit the full and short names for a player group,
select the group (rather than any of the players contained within) in the Players
panel in Setup mode, right-click, and choose Rename Player Group from the

context menu.

Using player names as staff labels. It is sometimes required that the staff label in the
margin should reflect the player's name and number, rather than the names and
numbers of the instruments held by that player; for example, in the case of
percussionists with multiple instruments, it may be preferable for the staff label to
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appear simply as “Percussion 2" rather than listing all of the instruments played by
that player.

To accommodate this, a new section, Show player name instead of instrument
names, has been added to the Staves and Systems page of Layout Options, allowing

you to specify which players in the layout should use their name as their staff label.

Players can now therefore have different full and short names. To edit a player’s
names, right-click the player in the Players panel in Setup mode and choose

Rename Player, which shows a simple dialog in which you can specify the full and

short names for the player.

Instrument name language. A new option Default language for instrument names
has been added to the General page of Preferences, allowing you to specify the
language that should be used for instrument names in new projects. This sets the

Instrument names language option on the Language page of Engraving Options.

When you change the language used for instrument names in Engraving Options,
the existing instrument names in the project are now automatically updated. If you

don't want to change the names in your project, deactivate Reset instrument

names when changing language on the Language page.

Furthermore, Dorico is now much more consistent in the way it handles instrument
name languages: the instrument picker in Setup mode now always follows the
language chosen for the user interface of the application (either your operating

system’s language, or the language explicitly chosen on the General page of
Preferences); default player and layout names shown in Setup mode always follow
the Instrument names language defined in Engraving Options; and staff labels
likewise follow the Instrument names language option, including using this

language for the note names used to describe instrument transpositions.

To better handle instrument transpositions in languages other than English, new
options have been added to the Language page of Engraving Options, allowing you

to specify the case for note names, the approach to be taken for accidentals in
German, and whether the note C should be described as “Do” or “Ut” in French.

Instrument transposition in staff labels. Greater flexibility for how the transposition
of an instrument appears as part of its staff label has been introduced, thanks to

new options on the Staves and Systems page of Layout Options. In addition to the
existing Position of instrument pitch in full staff labels option, that allows you to
choose between “Bb Clarinet 1” (Start) or “Clarinet in Bb1” (End), three further new

options have been added:
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Show on separate line Clarinet1

Bb
Show in parentheses Clarinet (Bb) 1
Show instrument number before Clarinet 1in Bb
transposition

These options can be combined in various ways, and it should now be possible to
achieve any of the standard conventions for formatting instrument transpositions.

The {@staffLabelsFull@} token has also been updated to take the state of these

options into account, and produce a similar result to the current Layout Options.

Stacking player numbers for condensed staves. If the option Player numbers for
condensed players on the Staff Labels page of Engraving Options is set to Stack
horizontally, the option When stacking player numbers for condensed players
vertically no longer unexpectedly takes effect, i.e. the option to Ignore stem

allocation no longer causes the player numbers to be stacked vertically.

Furthermore, adjacent section players can now use vertically stacked labels if
desired.

Grouping for adjacent section players. A new Staff labels for identical adjacent
instruments held by section players option has been added to the Staff Labels

page of Engraving Options. Choose Group between staves to show a single
instrument name between the staves, and the individual player numbers on each
staff.

Vertical position for grouped solo instruments. In some jazz and big band scores, it is
customary to show the full instrument name only on the staff corresponding to the
first chair for that instrument. For example, Trumpet 1would show both the
instrument name and its number, while Trumpet 2 would show only its number.

This convention is now easily achieved in Dorico, first by setting Staff labels for
identical adjacent instruments held by single players to Group between staves,
and then setting the new Position of instrument names for grouped staff labels to
Align instrument name with first staff. These options are both found on the Staff

Labels page of Engraving Options.

Tacets

Paragraph style. In previous versions of Dorico, the Tacets page of Engraving
Options contained options related entirely to the appearance of the tacet indication
that is shown: whether it should have a border; the thickness of the border; and the
padding to the left or right of the text within the border.
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Since all these properties are also part of the Tacet paragraph style used to
determine the font, style and size of the text, Dorico 4 now uses the properties for
border, thickness and padding defined in the Tacet paragraph style, allowing
greater flexibility (particularly for padding), and the Tacet page of Engraving

Options has now been removed.

When opening an existing project created in an earlier version of Dorico, the values
that were previously defined on the Tacets page of Engraving Options are used to
modify the Tacet paragraph style, so that the appearance of your existing project is

maintained as far as possible.

Tempo

Metronome mark order. A new option Order of metronome mark relative to tempo
instruction has been added to the Tempo page of Engraving Options, allowing you

to specify that the metronome mark should appear Before tempo instruction by

default, as it is preferred by some publishers.

You can also override this on a per-item basis using the new Metronome mark

order property in the Tempo group in the Properties panel.

Text

Adding music symbols. To make it quicker and easier to add musical symbols both to
Shift+X text items and to text frames, a new Insert Music Symbol dialog has been

added, accessible from the right-click context menu when editing text:

Music Text
Search...

Recently used

b 4

metNote8thUp (U+ECA7) Eighth note (quaver) stem up

Cancel OK

By default, the dialog shows a handful of useful characters, but it also remembers

each symbol you choose and shows this selection of Recently used characters when
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the dialog opens. These choices are remembered between sessions, so if you
habitually need the same symbols in multiple projects, they will always be available
by default.

You can otherwise search for a symbol by name, using its SMuFL name, or you can
browse through the symbols by SMuFL range, choosing the desired range from the
drop-down menu.

Once you have found the symbol you want to insert, simply select it and click OK or

hit Return to confirm the dialog.

Selection after editing. When you finish editing a text item after you have either
created or edited it, the text item will now remain selected.

Ties

Tie end and middle thickness. It is now possible to override the thickness of the ends
and middles of individual ties via the Properties panel.

Localization

Date and time formatting. When using tokens that show the current date or time, or
using the option to print the current date and time as an annotation, Dorico can
now show the date and time in the correct localized format. A new option Date and
time tokens language has been added to the Language page of Engraving Options
to determine which language will be used. If you are running Dorico in a language
other than English, this will be set automatically to the language in which you are
running Dorico when starting a new project.

Changing application language. When you choose a new application language on
the General page of Preferences, it is no longer necessary to quit and restart Dorico

for the change of language to take effect.

User interface

Library menu. A new Library menu has been added, available from all modes. This
new menu includes all five of the main options dialogs, in addition to the new
Library Manager dialog. It also contains all the dialogs that edit library items in your
project, in other words those items whose appearance you can customize.

The new menu draws together items that were previously found in other menus

(most often the Engrave menu), as follows:

Menu item Previous menu
Music Fonts... Engrave
Font Styles... Engrave
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Menu item Previous menu
Paragraph Styles... Engrave
Character Styles... Engrave
Chord Diagrams... Engrave
Chord Symbols... Not applicable
Music Symbols... Engrave
Notehead Sets... Engrave
Playing Techniques... Engrave
Lines... Engrave

Line Bodies... Engrave

Line Annotations... Engrave
Repeatable Symbols... Engrave
Expression Maps... Play
Percussion Maps... Play
Playback Techniques... Play
Engraving Options... Engrave
Layout Options... Setup
Notation Options... Write

Note Input Options... Write
Playback Options... Play

Library Manager... New in Dorico 4

Context menu. The menu that appears when you right-click (Windows) or Control-
click (Mac) has been improved, and now changes its contents based on the selected
items, so it is truly now a context menu. All the items in the context menu can be

found in the main menu bar, mostly in the Edit menu. Many of the notation-specific
submenus in the Edit menu have now been moved into a new Notations submenu

to reduce the overall length of the top-level Edit menu.

Keyboard access. It is now possible to choose between different options shown as
buttons with music examples on them in the various multi-page options dialogs,
such as Engraving Options and Notation Options. It is now possible to move the
focus to these sets of buttons with Tab or Shift+Tab, then use «/- to toggle the
buttons in the group. On macOS, this requires Use keyboard navigation to move
focus between controls to be activated in the Shortcuts tab of the Keyboard pane

of System Preferences.

Tab bar. A new preference has been added to the View section of the General page
of Preferences, controlling whether the tab bar should appear by default in new
projects, switched off by default.

82 Steinberg Media Technologies GmbH



Dorico 4 Version History

@ steinberg

Hand tool. When the hand tool is active, you can now trigger a marquee selection
using only the mouse by clicking and holding the mouse pointer for a moment;
when you see an animated rectangle appear for a moment, dragging will now
create a marquee rather than dragging the score as it normally would.

Switching mode and view. When switching between page view and galley view, or
when switching between Write mode in galley view and Engrave mode in page
view, Dorico now does a much better job of keeping the selected items in view. If
there is nothing selected, Dorico will try to keep the bar that was closest to the
center of the view in view after changing view type.

Dorico also now retains information about the view type (galley or page view), zoom
level, and which page or bar was in view when you switch between different layouts
within the same tab, or when the tab bar is not shown at all.

Furthermore, a new Center Selection command has been added, which can be
assigned to a keyboard shortcut via the Key Commands page of Preferences and
which allows you to bring the selection into view. This can be useful not only after
switching view, but also simply after having scrolled to a different part of the
current layout.

In addition, a new Toggle View Type command has been added, which switches
back and forth between galley view and page view. You can assign a keyboard

shortcut to this if you wish, on the Key Commands page of Preferences.

Switching between windows or tabs. If you have opened multiple windows on the

same project, or if you have multiple tabs open within the same window, when you
switch from one window or tab to another, if you have one or more items selected,
you may want to bring the selection into view automatically: to do this, activate the

new When switching tab or window, bring selection into view option in the View

section of the General page of Preferences.

Overscroll. When you scroll through the pages of your layout, Dorico does not
permit you to drag very far beyond the first or last page of the layout. Some users
have found this frustrating, as they want to be able to position, say, the top left-hand
corner of the first page in the center of their workspace, but Dorico does not allow
this much overscroll.

To address this, a new Overscroll amount option has been added to the View

section of the General page of Preferences, allowing you to configure the amount of
overscroll that Dorico will allow when scrolling off the start or end of the layout. By

default, this is set to Small; if you set it to Large, you can drag the pages almost
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completely out of view, while Medium is, as you might expect, somewhere between

the other two.

Taskbar buttons on Windows. The buttons for Dorico project windows, dialogs, and
the VST audio engine are now all grouped together on Windows; previously, the
audio engine buttons (for plug-in windows, for example) were grouped separately.

Application icon. For the first time since its initial release in 2016, Dorico 4 now
sports a new application icon, part of a new unified set of application icons for
Steinberg software products.

Options dialogs. The buttons in each of the five main options dialogs for saving
defaults, removing saved defaults, resetting to the saved defaults and resetting to
the factory defaults have been reworked so that it is no longer necessary to hold a
modifier key to access all of their functions.

In the Layout Options dialog, the menu in the bottom left-hand corner of the dialog
for specifying the layout type to which the options to save and restore defaults
should apply has been removed. Dorico now determines which layout type the save
or restore defaults operation should apply to automatically, based on the layouts

selected in the Layouts panel on the right-hand side of the dialog.

Preferences dialog. A new Reset to Factory button has been added to the
Preferences dialog, allowing you to restore the factory defaults for application
preferences if necessary.

On the Play page, the options for enabling and disabling MIDI input devices and
determining the default quantization settings for real-time recording are now
embedded directly in the Preferences dialog, instead of requiring you to open
subsidiary dialogs.

Missing Fonts dialog. The Missing Fonts dialog, which can appear when opening a
project, has been improved such that the widths of the columns in the table in the
dialog can be resized, and the chosen sizes will be saved and recalled in future.

Endpoint Setup dialog. The Endpoint Setup dialog, which allows you to specify the
expression and percussion maps assigned to each channel in your playback
devices, has similarly been improved such that the widths of the columns in the
table in the dialog can be resized, and the chosen sizes will be saved and recalled in

future.

Transpose dialog. It is no longer possible to choose an interval of diminished unison
in the Write » Transpose dialog; instead, to transpose from (say) C to C flat, you

transpose down by an augmented unison.
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Percussion Maps dialog. If you have unsaved changes to one or more percussion
maps, hitting Esc will now show a prompt giving you the chance to confirm that you

want to discard your changes and close the Percussion Maps dialog, rather than

closing the dialog right away.

Underline access key shortcut. The underline access key shortcut for the Write menu

has been changed from Alt+ to Alt+R (Windows only).

Renaming projects. If you rename a project in the Finder while it is open in Dorico,
the project’s name will automatically be updated in Dorico, so that subsequent save
operations continue to update the current project, rather than unexpectedly
causing it to be saved again under its old name (Mac only).

Project thumbnails. When you save your project, Dorico now saves two preview
images inside the project, based on the layout that is active at the time the project is
saved. One thumbnail consists of a PNG graphic of the first page of the project, and
is displayed in the Open Recent page of the Hub, while the other consists of a PDF
graphic of the entire layout, and is not currently displayed anywhere, but it is
planned to be used in the future to allow for Quick Look support on macOS.

Although it normally adds only a negligible amount of time to the save operation,
and increases the file size of the project by a similarly modest amount, you may find
that in very large and complex projects, saving thumbnails imposes a performance

penalty that you want to avoid. In such cases, you can deactivate the Generate

preview thumbnails when saving checkbox in File » Project Info.

Regardless of the state of this checkbox, Dorico does not save thumbnails when

auto-saving: only when you explicitly invoke the Save or Save As command.

Installation

Improved installation process. It is recommended to use Steinberg Download
Assistant to download and install Dorico 4. When you run Steinberg Download
Assistant you will be prompted to sign in with your Steinberg ID. You should then
click Enter your Download Access Code in the top left-hand corner of the
Steinberg Download Assistant window, and enter the code that you received from
the Steinberg online shop or on the license redemption card in your Dorico 4
package.

Click My Products in the left-hand panel, where you should see the appropriate
Dorico 4 product listed. Click its icon to select this product. Finally, on the right-
hand side, you should see a button Install All at the top of the list of application
components. Click this, and all the required components will be downloaded and
installed with no further intervention.
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When you first run Dorico 4, Steinberg Activation Manager will be launched
automatically to activate your license. You may be prompted to sign in with your
Steinberg ID to complete the activation process.

System requirements

Minimum supported operating system versions. On macOS, Dorico now requires Mac
0S X 10.14 Mojave or later. Dorico 4 cannot even be installed on earlier versions of
macOS. Dorico 4 is supported on Mac OS X 10.14 Mojave, Mac OS X 10.15 Catalina,
macOS 11 Big Sur and macOS 12 Monterey.

On Windows, Dorico 4 is supported on 64-bit Windows 10 update 21H2 (or later),
and 64-bit Windows 11 update 21H2 (or later).

Dorico Elements

The feature set of Dorico Elements has been expanded in version 4, with the
following changes over previous versions:

Increased maximum player count. You can now create projects with up to 24 players
in Dorico Elements, making it possible to write for ensembles like big bands,
medium-sized orchestras, and small concert and wind bands.

Engrave mode with graphical editing. You can now adjust the fine graphical
placement of every item in your project with the inclusion of the graphical editing
toolin Dorico Elements.

Notation Options. Dorico Elements now includes the Notation Options dialog (in the
Library menu), providing access to all of the options for note, beam and rest

grouping, accidental duration, and barline handling, which were previously only
included in Dorico Pro.

Project Language. Anew Library » Project Language dialog allows you to change

the language used for staff labels at any time in your project.

Customizable chord symbols. A new Library » Chord Symbols dialog provides access

to the options from the Chord Symbols page of Engraving Options in Dorico Pro,
making it easy to choose from any of the provided presets or adjust individual
aspects of chord symbols.
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Issues resolved

Component Issue

Accidentals Deleting a trill now correctly recalculates the accidentals for following notes in the bar.

Accidentals Any text-based symbols added to the music symbols used for custom accidentals are now
correctly imported when importing a tonality system.

Accidentals In transposing layouts where the key signature has been simplified, modifying the accidental
for a selected grace note could lead to the wrong accidental appearing; this has now been
fixed.

Accidentals If you create a key signature in a project using a user-defined tonality system that is present in

your user library, Dorico now always ensures that the tonality system itself is added to the

project.

Audio export

Dorico no longer incorrectly sends MIDI controller messages that are destined for channels

that are not included when exporting audio for a particular layout.

Audio export

When exporting audio, Dorico now prepends the flow number before the name of the flow, so

that identically named flows don't overwrite each other as they are exported.

Auto-save Auto-save location is no longer incorrectly migrated when migrating settings from previous
version.

Auto-save Under some circumstances, the combination of a short auto-save interval and a very long-
running operation could cause Dorico to hang indefinitely; this has now been fixed.

Barlines Selecting multiple adjacent barlines and deleting them now works as expected.

Barlines If a barline type other than the single barline is chosen as the default barline for the flow in
Notation Options, selecting a default barline in the flow now shows the appropriate barline
highlighted in the Create Barline section of the Bars and Barlines panel.

Barrepeats Under some circumstances, the end handle for a bar repeat or numbered bar region could
draw before the start handle when selected in Write mode; this has now been fixed.

Beams Fixed the incorrect option images and descriptions for Horizontal eighth note (quaver)
beams within the staff option for Ted Ross-style straddle-hang (but not sit) beams.

Bracketing Under some circumstances, changing an instrument held by a player to one in a different
instrument family could cause the bracketing to be calculated incorrectly; this has now been
fixed.

Bracketing A problem whereby the width of bracket line, rather than the distance of the bracket from the

systemic barline, was being used to determine the additional width for the horizontal lines for

sub-brackets set to reach the systemic barline has been fixed.
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Component Issue

Bracketing It is now possible to create bracketing changes on condensed divisi staves.

Bracketing Bracket and barline change signposts can now be selected when they are shown on a
condensed staff.

Chord diagrams Changing the Show barre using slur option on the Chord Diagrams page of Engraving
Options now works as expected.

Chord diagrams Chord diagrams saved by the user no longer prevent identical chord shapes from the default
library from appearing at other positions up the neck.

Chord diagrams Chord diagrams with explicitly excluded strings can now be transposed up the neck of the
guitar as expected.

Chord diagrams Edit » Reset Appearance now works as expected on selected chord diagrams.

Chord diagrams Under some circumstances, a barre slur shown in a chord diagram in the frame of used chord
diagrams at the start of the flow could be drawn incorrectly; this has now been fixed.

Chord diagrams Chord symbols shown above chord diagrams in the grid of used chords at the start of the flow
now correctly take the complete height of the chord symbol into account, avoiding collisions.

Chord diagrams Under some circumstances, Dorico could display multiple chord diagrams with the same
appearance when cycling through diagrams, which would prevent further cycling; this has
now been fixed.

Chord symbols Saving multiple project default chord symbols no longer sometimes results in the font styles
used by chord symbols being duplicated in the project.

Chord symbols Copying and pasting a chord symbol with an overridden appearance no longer causes the
pasted chord symbol not to draw.

Chord symbols Under certain circumstances, editing the appearance of stacke