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Dorico 6.2 
6 March 2026 

Highlights 

Repeats 
Cautionary and restorative items at repeats. Dorico can now display cautionary and 

restorative clefs, key signatures, and time signatures at repeat barlines, repeat 

endings, and repeat jumps. 

For example, if jumping back at a first ending to an earlier point in the flow, if there 

has been an intervening change of clef, Dorico can show the clef at the bar the 

repeat ending jumps back to, so that the performer has early warning of the change 

of clef; similarly, when jumping forward to the final ending in a repeat ending, if a 
cautionary clef is shown for the preceding ending, it may be necessary to show a 

restorative clef at the beginning of the final ending to remind the performer that 

the intervening clef change still takes effect. 

Dorico shows cautionary and restorative items at repeats by default in new projects. 

For existing projects, it is necessary to set the new Clefs and key signatures in 

repeat structures option on the new Repeats page of Notation Options to Track: 

Dorico can only show these items when it is tracking changes of clef, key signature, 

and time signature through repeat structures in the flow. This option is set to Do 

not track in existing projects to preserve their appearance. 

On the new Repeats page of Layout Options, you can choose whether cautionary 
and restorative items at repeats should be shown in parentheses. Options for the 

design of the parentheses can be found in the Repeats section of the Barlines page 

of Engraving Options, and options for the gaps around and inside these parentheses 

can be found on the Spacing Gaps page of Engraving Options. 

Guitar tablature 
There is considerable variation in the way guitar techniques such as bends, tapping, 

vibrato bar dips, harmonics, and so on are notated in tablature. There are perhaps 

two or three sets of conventions more widely used than others: from the US, the 

publications of Hal Leonard and Guitar World magazine represent two distinct 

styles; from Europe, Guitar Techniques and Guitarist magazine represent a third 
style. This latter style is also used in the popular Trinity/Rock School guitar syllabus, 

so it is becoming more widely used and understood by players. 

Dorico 6.2 introduces new features to support the essential characteristics of the 

European style, among them: 
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§ Showing bends as slurs in staff notation (rather than as angled lines), and as 

BU (bend up) and BD (bend down) text in tablature 

§ Showing harmonics with enclosures around fret numbers in tablature, with 

dashed lines showing the extent of a series of consecutive harmonics; for 

artificial harmonics, showing the touched fret above tablature, and in staff 

notation showing the sounding pitch with a diamond notehead 
§ Showing left- and right-hand tapping with enclosures around noteheads in 

staff notation and around fret numbers in tablature 

§ Showing vibrato bar scoops/dips as curved arrows 

§ Showing tied-to notes in square brackets in tablature 

These are all now supported in Dorico 6.2, described in detail below. 

Bends. A new Bend appearance option has been added to the Staff Notation section of 

the Guitar Bends page of Engraving Options, allowing you to specify that guitar 

bends should be drawn in staff notation using slurs rather than angled lines. A 

corresponding Bend appearance option has been added to the Tablature section, 

providing the choice between using a curved arrow or showing the bent-to note in 
parentheses and indicating either BU or BD above the tablature to indicate the bend 

direction. 

The BU and BD markings used on tablature to show bends when Bend appearance 

is set to BU or BD text are vertically positioned relative to fret numbers, so they can 

appear between strings as well as above the top string. The markings are centered 

horizontally between the bent-from and bent-to fret numbers. 

Dedicated positioning options for PB markings, for pre-bends, are found in the 

Position section of the Guitar Bends page of Engraving Options. 

In Engrave mode, it is now possible to make graphical adjustments to guitar bends 

and pre-bends both in staff notation and tablature using the keyboard (e.g. holding 

Alt and using the arrow keys). 

Re-pick indications. In the European convention, re-picking a bent note shows the 

indication RP followed by a dashed line. This is now supported by Dorico when Bend 

appearance is set to BU or BD text. 

Harmonics. To support the appearance of natural and pinch harmonics where fret 

numbers are shown in diamond and triangle enclosures, new options have been 
added to the Harmonics page of Engraving Options. To use this appearance, set 

Natural harmonics in tablature to Diamond enclosure and Pinch harmonics in 

tablature to Triangular enclosure. 
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When using these enclosures, harmonics are also normally indicated by showing 

NH or AH above the tablature. Options to add these markings automatically are 

found in the Tablature section of the Harmonics page of Engraving Options. 

Tapping for fretted instruments. In European convention, pick-hand tapping is indicated 

by a circular enclosure around the fret number in tablature and around the 

notehead in staff notation; fret-hand tapping is similarly indicated by a square 

enclosure. This can be enabled by choosing Enclosure for the Tapping appearance 

option in the Tapping section of the Guitar Techniques page of Engraving Options. 

The thickness of the line used for the enclosure, and values for the padding of these 

enclosures in tablature and staff notation, can be found in the new Enclosures 

section of the Notes page of Engraving Options. 

Vibrato bar scoops/dips. To use the curved arrow appearance common in the European 
convention, set Scoop appearance in the Vibrato Bar section of the Guitar 

Techniques page of Engraving Options to Curved. This produces a curved arrow 

positioned above the note. (This option was added in Dorico 6.1.) 

Tied notes. To show tied-to notes in square brackets, set Tied notes in tablature either to 

Hide fret numbers, tied notes with attachments in square brackets, per string or 

Hide fret numbers, tied notes with attachments in square brackets, grouped in 

the Ties section of the Tablature page of Engraving Options. (These choices were 

added in Dorico 6.1.) 

Stems. A new option Horizontal alignment of stems relative to rhythmic slashes has 

been added to the Rhythmic Slashes section of the Stems section of the Tablature 
page of Engraving Options, allowing you to specify whether stems on rhythmic 

slashes should be shown at the Edge of slash, so that they are positioned on the left-

hand edge for stem-down voices and at the right-hand edge for stem-up voices, or 

Centered regardless of stem direction. 

Enclosures on tablature. When fret numbers are surrounded by enclosures (for 

harmonics and left- and right-hand tapping), the enclosures now overprint the 

strings. In addition, rectangular enclosures are now always at least as wide as they 

are tall, so they are normally square, unless the fret number is especially wide. 
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Improvements 

Audio export 
MP3 high quality mode. A new High quality (slower) checkbox has been added to the File 

▶ Export ▶ Audio dialog, allowing you to specify that Dorico should use the high 
quality encoding method for MP3 export. This affects the resampling of the audio 

input signal, and achieves optimum sound quality at the given bit rate. At present, 

MP3 files exported from Dorico always use a 256kBit/s bit rate. 

Barlines 
Start repeat barlines. A new option Changes of time and key signature at start repeat 

barlines has been added to the Repeats section of the Barlines page of Engraving 

Options, allowing you to specify whether changes of key and time signature that 

coincide with start repeats should appear to the left or right of the barline. 

Beams 
Beam line thickness. A new Advanced Options section has been added to the 

Appearance section of the Beams page in Engraving Options, containing options to 

set the default beam line thickness and gap between beam lines. 

Dorico will not adjust the vertical placement of beams to account for unusual values 

for these options, so it is strongly recommended that the sum of the beam thickness 

and gap values should be 3/4 space. If the sum of these values differs, Dorico shows 

a warning label to alert you to the likelihood that beam placement will be poor. If the 
beam thickness is less than 3/4 space, an Adjust Gap button appears that will 

automatically set the gap value to the remainder so that the two together add up to 

3/4 space. 

Fingering 
Erase background. A new Erase background behind fingerings outside the staff option 

has been added to the Advanced Options section of the Design section of the 

Fingering page of Engraving Options. When activated, fingerings will erase staff 

lines, barlines, and slurs. Slurs are now also erased by other items with erased 

backgrounds, such as dynamics. 

Fonts 
Text font updates. Splentino has been updated to version 1.2, bringing improvements to 

diacritic characters, and font metadata for Windows font family grouping; this 

update also fixes incorrect line height in the italic weight. A new bold condensed 

weight of Splentino is also now included. This can work particularly well for tempo 

marks and even staff labels. 
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Nepomuk has been updated to version 2.7, with improved font metadata for 

Windows font family grouping, minor kerning improvements, tweaks to characters 

with umlauts, and improved spacing for French guillemets (quotation marks). 

Music font updates. Sebastian has been updated to version 1.3, which fixes slur 

positioning against up-stem flags. Some improvements have also been made to 

both Sebastian and Sebastian Text for use as character styles in Dorico, e.g. 

accidentals in staff labels, and notes in metronome marks. 

Golden Age has been updated to version 1.6, which improves its rhythmic slash 

noteheads. 

Harmonics 
Popover input. It is now possible to create harmonics using the playing techniques 

popover, shortcut Shift+P. Start your input with harm, harmonic or harmonics. 

After the initial prefix, add further instructions separated by spaces: 

harm [type] [partial] [node] [style] [string] [flags...] 

These additional instructions can appear in any order. 

Input Result 

Type 

nat or natural Natural harmonic 

art or artificial Artificial harmonic 

Partial 

pn or p=n or partial=n Set the partial for the harmonic 

Node 

nn or n=n or node=n Set the node for the harmonic 

Style 

circle or circleabove Shows the circle above the staff for a 
natural harmonic 

diamond, diamondnotehead, sounding Shows the diamond notehead instead of the 
regular notehead for a natural harmonic 

white, whitediamond, 

whitediamondnotehead, touched 

Shows a white diamond at the touched 
pitch for a natural harmonic 

normal Shows a white diamond at the touched 
pitch for an artificial harmonic 

pinch Pinch artificial harmonic 

singlesounding, sounding Shows a white diamond at the sounding 
pitch for an artificial harmonic 

singlestopped, stopped Shows a white diamond at the stopped 
pitch for an artificial harmonic 

String 
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sn, s=n or string=n By index, where 1 is the highest string on 
the instrument 

spitch, s=pitch or string=pitch By pitch, e.g. D3 for the D string of the cello 

Open string display 

open, noopen Show or hide open string pitch 

paren, noparen Show or hide parenthesized sounding pitch 

Here are a few examples: 

§ Basic natural harmonic: harm 

§ Natural harmonic, explicit partial/node/style, specific string index: harm 

nat p4 n1 style=diamond s1 

§ Artificial pinch harmonic, parenthesized sounding pitch, string 3: harm art 

p4 n2 style=pinch s3 paren 

§ Natural white-diamond harmonic, show open string, string by note name: 

harm nat style=white open s=e4 

For a few common cases, you can use a shorter form of the popover input. 

Long form Shortcut 

harm nat nh or hh (for “harp harmonics”) 

harm art ah 

harm art style=pinch ph 

To remove a harmonic, enter noharm into the popover. 

Playback. Dorico now plays back the correct pitch for natural harmonics on fretted 

instruments. 

Natural harmonics for stringed instruments. When writing natural harmonics for 

stringed instruments, it may be useful to be able to show both the pitch of the open 

string and the touched pitch required to produce the desired harmonic. The open 

string pitch is shown as a parenthesized black notehead, and the touched pitch is 

normally shown as a white diamond notehead. 

To enable this appearance, set the new optionNatural harmonics on stringed 

instruments showing touched pitch on the Harmonics page of Engraving Options 

to Show open string. The Style property in the Harmonics group in the Properties 

panel should then be set to Diamond notehead (touched). 

Artificial harmonics for stringed instruments. When writing artificial harmonics for 

stringed instruments, in addition to showing the stopped pitch as a normal 

notehead, and the touched pitch, normally as a diamond notehead, it can be useful 

to show the sounding pitch, normally as a parenthesized notehead, and sometimes 

with an octave line to reduce the number of ledger lines required. 
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To enable this appearance, activate the new Show sounding pitch property in the 

Harmonics group in the Properties panel. Dorico will not add an octave line 

automatically, so if you want an octave line to be shown, create one in the normal 

way, then activate the new Artificial harmonic sounding pitches only property in 

the Octave Lines group to specify that the octave line should only transpose the 

parenthesized sounding pitch notehead, leaving the stopped and touched pitches 

untransposed. 

Notehead sets for harmonics. New options have been added to the Harmonics page of 
Engraving Options, allowing you to specify the default notehead set that should be 

used for the touched, stopped, and sounding pitches for natural, artificial, and pinch 

harmonics on staff notation and in tablature. 

Harp pedaling 
Note names. When harp pedal changes are set to show using note names, it is now 

possible to choose between two types of accidentals by changing the new 

Accidentals style option on the Harp Pedals page of Engraving Options: Notation 

uses the same appearance as accidentals in the music, while Text uses the same 

appearance as used in chord symbols, which have proportions designed to look 

better next to upper case letters. 

Using new options in the Advanced Options section of the Harp Pedals page, it's 

also now possible to change the Accidental scale factor and Accidental baseline 

shift to further adjust the look of the chosen accidental appearance. 

Note input and editing 
Selecting with the mouse. To make click targets easier to hit, Dorico pads the click target 

for each item at low zoom levels; as you zoom in, this padding gets proportionally 
smaller, and once you are at a sufficiently high zoom level, the click target is not 

padded at all. 

However, this can make it difficult to select individual noteheads in chords at low 

zoom levels, because the click targets for notes may overlap, and, crucially, the click 

target for the chord’s stem is also padded, meaning that if you click a notehead in a 

chord close to its stem, you will select all the notes on the stem, rather than the 

notehead you were trying to select. Similarly, the click targets for beams are also 

padded, so you may find yourself selecting all the notes under the beam instead of a 

single notehead if you inadvertently click close to the beam. 

To address this, a new Selection priority when clicking option has been added to 
the Editing section of the Note Input and Editing page of Preferences. This allows 

you to choose whether Dorico should Prioritize noteheads, in which case the click 

targets for beams and stems will not be padded at low zoom levels, or Prioritize 
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beams and stems, in which case the click targets for beams and stems will be 

padded. 

The default behavior is Prioritize beams and stems, which matches the behavior in 

previous versions of Dorico. Be aware that after changing this preference, the click 

targets will only be updated after the project is next edited. 

Notes 
Rhythm dots. A new Hide rhythm dot property has been added to the Notes and Rests 

group in Properties in Engrave mode, allowing you to specify that the rhythm dot 

associated with a notehead should be hidden. However, note that in chords with 

multiple notes at adjacent or close staff positions – either in a single voice, or in 

multiple voices – it is possible for a displayed rhythm dot to correspond to multiple 

noteheads in the chord, in which case the property must be set for each notehead 

that contributes to the displayed rhythm dot for it to be hidden. 

Split stems. A new Split stem X offset property has been added to the Note Spacing 
group in Properties in Engrave mode, allowing you to adjust the precise horizontal 

position of the notes on a split stem of an altered unison relative to the main stem. 

Pedal lines 
Position of pedal lift. A new option Position of end of pedal line relative to notehead 

has been added to the Horizontal Position section of the Pedal Lines page of 

Engraving Options, allowing you to choose between center- or left-aligning the 

pedal lift hook when ending at the position of a note or chord. 

Percussion 
Percussion legends. A new command Edit ▶ Notations ▶ Percussion ▶ Legend for 

Selected Instruments has been added, allowing you to create a percussion legend 

showing the names of the instruments in which one or more notes is selected. 

If you subsequently edit the percussion kit to change or remove all the instruments 

that were previously included in the percussion legend, the percussion legend 

appears as a signpost instead of a text label. To resolve this, you must delete and 

recreate the percussion legend using a new selection of instruments. To help you 

find any such places where such a signpost may appear, a new Percussion legends 
category has been added to the Proofreading panel, and if proofreading is enabled, 

Dorico will identify affected percussion legends in the panel. 

Playback 
Missing playback templates. When opening a project that uses a playback template that 

is not available on your system, Dorico now offers to apply the Auto playback 

template. Click Use Auto Playback Template to ensure that the project plays back 
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with the best available factory-supplied sounds; if you click Continue, no changes 

will be made to the playback configuration of the project. 

Similarly, if you have chosen Auto as the default playback template on the Play page 

of Preferences, when you open a project that uses a different factory playback 

template, Dorico will offer to apply the Auto playback template for you. 

Auto playback template. When using the Auto playback template, Dorico will now 

automatically use the full Etude Grand Piano instrument if it is installed, in 

preference to the Etude Elements instrument included free with Dorico Pro and 

Dorico Elements. 

In addition, if the Navia Harp Free instrument is available, Dorico will automatically 

use this for harp instruments in your project. If you prefer to continue using, say, 

the harp patch from Iconica Sketch, choose Play ▶Playback Template, edit the Auto 
playback template, and move Navia Harp Free to the bottom of the priority list of 

content packs. 

Print mode 
Transparent items. When exporting graphics or printing in Mono, an item set to be 

transparent via the Color property would be excluded from the resulting printed 

page or graphics file only if it is completely transparent; as of Dorico 6.2, it will also 

be excluded if it is very nearly transparent (i.e. if its alpha channel value, in the 

range 0–255, is 1 or 0). 

Proofreading 
Two-note tremolos. Dorico now considers the playability of two-note tremolos written 

for violin, viola, cello, double bass, flute, oboe, clarinet, bassoon, saxophone, horn 

and trumpet. 

Horn techniques. Dorico now warns if the horn player is expected to both mute and 

hand-stop the instrument at the same time, as this is not generally possible. 

 

Cautionary items at repeats. The proofreading checks for clefs, key signatures, and time 

signatures at repeat endings and repeat jumps now consider the new options for 

the automatic display of cautionary items at repeats. 

Rehearsal marks 
Enclosures. It is now possible to set the enclosure type for each type of rehearsal mark 

sequence (letters, numbers, and bar numbers) independently, using the options in 

the Enclosure section of the Rehearsal Marks page of Engraving Options. 

Handling multiple sequences. In the rare case that two simultaneous sequences of 

rehearsal marks are needed, one (say) using bar numbers and another using letters, 
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you can now use dedicated commands to create a rehearsal mark of a specific 

sequence type. These commands have been added to the Note Input category in the 

Key Commands page of Preferences, allowing you to assign your own keyboard 

shortcut, or can be triggered via the jump bar. 

Rhythmic slashes 
Ledger lines. A new Ledger lines in slash regions option has been added to the Rhythmic 

Slashes section of the Notes page of Engraving Options, allowing you to determine 

whether slash voices or rhythmic slash regions should show ledger lines when the 

slashes are positioned outside the staff. In new projects, ledger lines are hidden by 

default; in existing projects, they are shown by default to preserve their existing 

appearance. 

Tablature. A new Show slash regions in tablature when staff notation also shown 
option has been added to the Rhythmic Slashes section of the Notes page of 

Engraving Options. Deactivate this option to hide rhythmic slash regions in 

tablature when both staff notation and tablature are shown. 

Tempo 
Edit Font. Choosing Edit Font from the context menu after selecting an immediate 

tempo item showing a metronome mark now selects the Tempo (metronome 

mark) paragraph style in Library ▶ Paragraph Styles. 

Text 
Inserting spaces. Three new commands have been added to the Text Editor category in 

Key Commands, allowing you to define key commands to insert non-breaking 

spaces (U+00A0), thin spaces (U+2009), and hair spaces (U+200A) into the text 

editor. 

User interface 
Players showing player names. Select All and Select None buttons have been added to 

the Show player name instead of instrument names list on the Staves and 

Systems page of Layout Options, allowing you to quickly select or deselect all 

players. 

Change Paragraph Style dialog. The Change Paragraph Style dialog now uses a filtered 

menu, allowing you to more quickly find the paragraph style you’re looking for by 

typing part of the target style’s name. 

Voices 
Hidden stems. When notes have stems hidden using the Hide stem property, they can 

now be assigned to the same voice column as other notes, even if they would 

ordinarily be assigned to another voice column to avoid collisions caused by their 

stems. 



 

 
Dorico 6.2 14 Dorico 6 Version History 

Localization 
Default key commands in German. A few minor changes have been made to default key 

commands when using the German keyboard language: 

§ In addition to Y and X, you can now zoom in and out with 

Ctrl++/Command>++ and Ctrl+-/Command+-. 

§ The MIDI trigger region popover is now invoked with =. 

§ Hide invisibles is now invoked with Ctrl+^/ Command+^. 
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Issues resolved 
Component Issue 

Bar numbers The commands to select bar numbers or add them to the current selection now work more 
reliably in Engrave mode. 

Bar numbers Dorico no longer incorrectly shows a range of bar numbers below a multi-bar rest for a single 
subordinate bar number. 

Bar repeats When bar repeat regions are highlighted, Dorico would sometimes incorrectly highlight the 
wrong divisi section; this has now been fixed. 

Bar repeats Dorico now always correctly respects the engraving option for the appearance of the bar 
count on the final bar of a bar repeat or numbered bar region. 

Barlines Under some circumstances, Dorico could space double barlines at the start or end of the 
system incorrectly; this has now been fixed. 

Chord diagrams Under some circumstances, deleting a player could fail if it was showing local chord symbols 
with chord diagrams; this has now been fixed. 

Chord symbols It is now possible to edit the kerning of each alteration in a vertical stack of alterations in the 
chord symbol kerning pairs editor. 

Chord symbols The Distance from chord symbol option on the Chord Diagrams page of Engraving Options 

now once again takes effect. 

Condensing Rests with the Color property set now appear with the expected color when condensed. 

Cues Divisi staves on grand staff instruments can now correctly be used as sources for a cue via the 
cues popover. 

Cues The extra noteheads that show the touched or sounding pitch for harmonics are now correctly 
shown at cue size in cues. 

Dynamics The behavior of editing existing dynamics via the popover has been greatly improved, with 
Dorico no longer unexpectedly producing duplicate dynamics. 

Dynamics Under some circumstances, linking or unlinking dynamics could fail when slurs or lyrics were 
also selected; this has now been fixed. 

Engrave mode Navigating to rehearsal marks in Engrave mode now works correctly, and brings the expected 
rehearsal mark into view. 

Engrave mode Engrave ▶ Edit Flow Heading now works correctly once more (Dorico Elements only). 

Engrave mode Under rare circumstances, creating a layout-specific music frame could crash if certain 
figured bass items are present; this has now been fixed. 
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Component Issue 

Graphics export When using one of the export commands in the Print category of the Key Commands page of 

Preferences, if the saved path for export is unavailable, Dorico will now export to the same 
folder as the project file, instead of failing to export. 

Guitar bends Pre-bend lines that cross system breaks are now drawn correctly. 

Guitar bends Under some circumstances, editing note durations could cause guitar bends to snap 
incorrectly to nearby notes; this has now been fixed. 

Harmonics Edit ▶ Reset Appearance now correctly resets the Show open string property. 

Instruments If two or more fretted instruments with modified tunings are present in the project, under 
some circumstances, capo information for one of the instruments could be lost when the 
project is reopened; this has now been fixed. 

Key Editor Clearing MIDI controller data in the Key Editor for the selection now always works correctly, 
regardless of the number of selected voices. 

Lines If a line has an overridden color, line annotations using music symbols now correctly print 
with the overridden color. 

Lyrics When aligning lyrics ignoring the width of hanging punctuation, the width of whitespace 
following leading punctuation and preceding trailing punctuation is now correctly 
considered. 

MIDI export When exporting MIDI files, Dorico no longer incorrectly excludes players that have been 
deselected when exporting MusicXML files. 

MIDI import Combining MIDI tracks into a single player during import no longer fails to import tuplets at 
the end of the combined material. 

Multi-bar rests Single multi-bar rests no longer incorrectly show a bar number range if the bar is numbered 
with a subordinate bar number. 

Music symbols It is no longer possible to create glyph components in the music symbols editor consisting of 
whitespace characters. 

MusicXML export Single bar rests are no longer incorrectly exported to MusicXML as a multi-bar rest if they do 
not show a bar count. 

MusicXML export Pick-up bars are no longer incorrectly exported to MusicXML as bar rests. 

MusicXML import Import of multiple verses of lyrics in MusicXML files exported by Sibelius has been improved. 

Note input Adding an articulation to a chord no longer sometimes fails if the chord is followed 
immediately by a grace note. 
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Component Issue 

Note input It is now possible to navigate from a grace note to a slur at the same position using Tab. 

Note input Under some circumstances, the sound used for auditioning during note input would 
unexpectedly change to the sound of the first staff in the system; this has now been fixed. 

Note input For popovers that show auto-complete lists (tempo, cues, playing techniques), hitting Tab now 

correctly accepts the first item in the list. 

Note input When auditioning the shadow note during pitch before duration input, the prevailing key 
signature is now correctly considered. 

Note input When copying and pasting, or moving items between staves, in page view, Dorico no longer 
incorrectly considers the instrument filter active in galley view. 

Note spacing Under some circumstances, Dorico could erroneously leave space for a change of clef at the 
end of the system; this has now been fixed. 

Percussion Importing a percussion kit that was exported from a project that started life from importing a 
MusicXML file now works as expected. 

Play mode When switching to Play mode, the selection in the track overview is now always correctly 
populated. 

Playback A note longer than a half-beat starting  on a half-beat preceded by a rest now swings correctly, 
if appropriate. 

Playback Dorico no longer incorrectly leaves the project activated for playback unable to play back after 
opening a second project or importing MIDI, MusicXML or flows into the active project. 

Playback Custom key commands to start playback from the left or right locator (Play ▶ Start or Stop 

Playback ▶ Left Cycle Locator or Right Cycle Locator in the Key Commands page of 

Preferences) now work as expected. 

Playback The fallback for the requested combination of playback techniques where one or more add-on 
switches provide one of the playback techniques was incorrectly ignoring the add-on 
switches; this has now been fixed. 

Playback Triangle rolls now correctly respond to gradual dynamics when using Iconica Sketch for 
playback. 

Playback The Increase written dynamic by option for marcatos on the Dynamics page of Playback 

Options now works correctly once more. 

Playing techniques Dorico now correctly preserves parentheses on noteheads for harmonic noteheads when 
condensed. 
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Component Issue 

Project files If duplicate automation points are found, Dorico removes all duplicates when loading the 
project. 

Project files Under rare circumstances, Dorico could crash when attempting to import flows into an 
existing project when attempting to merge players, and compatible instruments are found in 
both players, but one player uses a percussion kit and the other does not. 

Project templates When starting a new project, Dorico now replaces flow title with project title in all page 
template sets. 

Proofreading Under some circumstances, Dorico could show a spurious warning about an ambiguous 
instrument change at a repeat jump; this has now been fixed. 

Proofreading Pitch names shown in the Proofreading panel now reflect the current layout transposition. 

Proofreading Dorico now more reliably considers whether instrument change warnings are shown, or 
whether multiple instruments held by the same player are shown simultaneously, when 
warning about instrument changes. 

Proofreading Dorico now correctly handles dynamics like poco f when considering ambiguous dynamics. 

Proofreading Warnings about contradictory harp pedal settings no longer incorrectly appear for the lowest 
strings of the instrument, which are not affected by the pedals. 

Proofreading Dorico no longer incorrectly warns about hand stretch in certain chords that are easy to play 
on the electric guitar. 

Proofreading When Dorico reports on notes outside the playable range of the instrument, it now correctly 
considers harmonics, so it does not report that some harmonics are outside the playable 
range. 

Proofreading Dorico no longer reports that straight and cup mutes cannot be used with brass instruments 
with which they are sometimes used. 

Properties When the final barline of the flow is selected, the Properties panel no longer incorrectly shows 
properties that cannot be set. 

Slurs Under some circumstances, changing the option for slur placement relative to tied notes 
could cause slurs to be deleted unexpectedly when multiple layouts are open; this has now 
been fixed. 

Staff labels Player group labels are now always immediately updated after editing the relevant paragraph 
style. 

Tempo Right-clicking a tempo item and choosing Edit Font now always chooses the appropriate 

paragraph style, considering the options for which style should be used for gradual and 
relative tempo changes. 
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Component Issue 

Tempo Under some circumstances, a tempo equation over the final barline of the system could move 
vertically unexpectedly when editing the music; this has now been fixed. 

Text The Letter spacing before accidental option on the Text page of Engraving Options now 

always takes effect when expected. 

Text Dorico now correctly handles full-width Latin apostrophes and quotation marks written in 
Japanese or other east Asian languages when smartening quotes. 

Text Quotes in all text in text frames are now correctly smartened, instead of only quotes inside 
tokens. 

User interface The position of attachment points and axes/grid lines in the music symbols editor at high 
zoom levels has been improved. 

User interface Holding and releasing Alt in popovers no longer unexpectedly causes the popover to be closed 

(Windows only). 

User interface The buttons for clearing filtered categories and flows in the Proofreading panel now appear 
correctly (French-language only). 

User interface The lists of clefs in Library ▶ Instruments are now shown in the correct application language. 

User interface Under some circumstances, hitting Tab in the Graphic Slices panel in Engrave mode could 

cause a crash; this has now been fixed. 

User interface Instrument names in the galley view margin no longer incorrectly appear when temporarily 

hiding invisibles by holding `. 

User interface If the shortcut for hide invisibles uses multiple keys, it was previously possible for invisibles to 
remain hidden when releasing one of the keys in the shortcut before the others; this has now 
been fixed. 

Vertical spacing Changes of key signature and time signature are now considered when determining 
placement of items outside the staff, so, for example, repeat markers no longer collide with 
cautionary key signature accidentals at repeat jumps. 
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Dorico 6.1.10 
9 October 2025 

Improvements 

Lyrics 
Disabling smart quotes. A new Smarten quotes property has been added for lyrics, 

allowing you to disable the automatic smartening of quotation marks for a selected 

lyric. 

Pedal lines 
Legacy vertical positioning option. In response to feedback following the release of 

Dorico 6.1, a new option Use legacy pedal line vertical positioning has been added 

to the new Advanced Options section of the Vertical Position section of the Pedal 

Lines page of Engraving Options. This option is activated in projects created in older 

versions of Dorico when opened in Dorico 6.1.10 for the first time, to preserve their 

appearance. 

When this option is activated, it is not possible to activate Align pedal lines across 

width of system, and nor is it possible to specify a value for Minimum distance 

from protruding items. 

Change of default setting. In new projects, the option Align pedal lines across width of 

system in the Vertical Position section of the Pedal Lines page of Engraving 

Options is now deactivated by default. If you want pedal lines to be aligned across 

the width of the system, activate this option. 
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Issues resolved 
Component Issue 

Key Editor Playing technique regions now always appear with the correct name in the piano roll. 

MusicXML export Dorico no longer sometimes crashes when exporting MusicXML from a condensed layout. 

Note input Specifying parentheses in popovers for dynamics and playing techniques now once again 
correctly results in the created or edited item becoming parenthesized. 

Pedal lines It is once again possible to adjust the vertical position of pedal lines in Engrave mode, whether 
they are aligned across the width of the system. 

Pedal lines Pedal lines with a horizontal offset applied to the start or end once again appear correctly. 

Percussion Some percussion sounds, for example pedal hi-hat in a drum set, would not play back 
correctly; this has now been fixed. 

Playback Glissando playback for NotePerformer has been corrected. 

Proofreading Under some circumstances, Dorico could crash when proofreading certain projects; this has 
now been fixed. 

Text Text that has its color overridden via the Color property now once again prints or exports to 

graphics using the expected color. 
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Dorico 6.1 
26 September 2025 

Highlights 

Automatic playback template 
As further new sound content is added to Dorico, the number of factory playback 

templates needed to accommodate various combinations of content has continued 

to grow to the point that it is often difficult to determine which playback template 

you should choose. To make this simpler, Dorico 6.1 introduces a new automatic 

playback template, which uses all the factory content installed on the system, 
following a recommended priority such that each instrument you add to your 

project uses the best available sound. 

When you first run Dorico 6.1, if the Default playback template setting on the Play 

page of Preferences is set to use one of the existing factory playback templates, you 

will be asked during start-up whether you want to switch to using the new 

automatic playback template. If you click Use Auto Playback Template, Dorico will 

adjust the Default playback template setting for you. If you are using another 

playback template by default – for example, NotePerformer or another third-party 
sound library – Dorico will not prompt you to use the new automatic playback 

template by default. You can make this change yourself on the Play page of 

Preferences. 

To apply the automatic playback template to an existing project, choose Play ▶ 

Playback Template, choose Auto, and click Apply and Close. 

You will notice that by default most of the factory playback templates you will be 

familiar with from previous versions are no longer listed: you can show them by 

clicking the Show All Factory button in the action bar in the Apply Playback 

Template dialog. 

As further sound content is added in future versions of Dorico, or if you choose to 

install existing content that you had previously chosen not to install, the automatic 

playback template will be updated to make optimal use of it. 

To see which content sets are currently used in the automatic playback template on 

your system, or to change the relative priority of those content sets (which 
influences how Dorico assigns sounds to instruments), select Auto from the list in 

the Apply Playback Template dialog, and click the Edit button. 

Condensing 
Rests on condensed staves. It is now possible to set certain properties on rests in 

condensed staves. Until now, it has been impossible to influence the appearance 
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and position of rests in condensed music, but this limitation has now largely been 

addressed – though there are some things to watch out for. 

By default, rests in Dorico are implicit: they are created automatically by the 

software to fill in the gaps between notes. Rests only exist as real items – known as 

explicit rests – once you edit them, for example when you set properties to change 

their staff position, or force their duration. When you edit a rest in a condensed 

staff, that rest becomes explicit, and it is will affect the notation of the instrument to 

which it belongs. 

When you, say, set the Rest pos. property on a condensed rest to adjust its vertical 

position, the property value itself will apply only to the condensed staff, as you 
would expect, but in order for that property to be saved, the rest needs to be made 

explicit, and it has to be stored in the musical data belonging to the instrument. 

Normally this will create no problems: in most cases, the rest that you see in the 

condensed music corresponds exactly to an existing implicit or explicit rest in one 

or more of the source instruments whose music is notated on the condensed staff: 

the rest in the source instrument has the same duration, so adjusting its position 

has no visible effect on the uncondensed music, which appears in the part layout, or 

in the full score when condensing is disabled. 

However, in some circumstances, the rest that appears in the condensed staff may 

not match an existing implicit or explicit rest in the uncondensed source material. 
If you adjust the vertical position of such a rest, it becomes explicit, and will now 

appear in the uncondensed source music with that duration – though the 

adjustment to its vertical position will only take effect in the condensed music. 

Instrument change warnings and labels. It is now possible to interact with instrument 

change warnings and labels on condensed staves, in the same way as for 

instrument changes on regular, uncondensed staves. 

Etude Elements 
Now included at no extra charge to Dorico Pro 6 and Dorico Elements 6 users, Etude 

Elements is an entry-level version of Etude, Steinberg’s deeply-sampled Yamaha 

C3X grand piano library for HALion and HALion Sonic. Carefully reduced in scope 

from the full 18GB Etude library, Etude Elements provides a beautiful and 

expressive set of grand piano patches that provide a significant increase in sound 
quality and timbre over the standard Yamaha S90 Piano patch used by default in 

previous versions of Dorico. 

If you are using the new automatic playback template, Dorico will use the Concert 

Grand Elements patch from Etude Elements for piano instruments in newly-

created projects. To use Etude Elements in an existing project, either apply the 
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automatic playback template, or manually load one of the Etude Elements patches 

into HALion Sonic in Play mode. 

Proofreading 
Instrument ranges. A new category of issue has been added to the Proofreading panel: 

Instrument ranges. When this category is enabled, Dorico will identify notes in any 

instrument that are outside its standard and advanced ranges: these are the notes 

that are colored bright or dark red if View ▶ Note and Rest Colors ▶ Notes Out of 

Range is activated. However, proofreading also checks for some additional special 

cases: 

§ For flute, the B below middle C (B3) will show a warning: not all flutes have a 

foot key that enables them to play this pitch. 

§ For tenor trombone: 
o the pitches C2 to Eb2 require the instrument to have an F 

attachment, otherwise they can only be played as false tones. This is 

possible, but not particularly easy, and the stability and tuning of the 

notes will be poor. (An F attachment is common on classical 

instruments, but less so on jazz instruments.) 

o Dorico will warn that the pitch B2 is not playable at all unless the 
instrument has an F attachment. 

o Dorico will warn that the pitches E1 to Bb2 are only playable as pedal 

notes. Similar to the false tones, this is possible, but not particularly 

easy, also affecting the stability, tuning and tone of the notes. 

§ For harp: 

o Dorico will warn about notes that contradict the prevailing pedal 
settings. These notes are not technically out of range, but are 

nevertheless also shown in the score in bright red if Notes Out of 

Range is enabled. 

o Dorico will warn if a very low B is written. The three possible notes 

when written for the very lowest string can only be C flat, C natural 

or C sharp. Enharmonic equivalents are not possible. 
o Dorico will warn if conflicting pitches on the bottom two lowest 

strings (C and D) or the highest string (G) are found. Unlike all the 

other strings on the instrument, these strings are not attached to 

pedals, so cannot be easily retuned. They are tunable, but only using 

a tuning key. 

§ For organ, Dorico will warn if a note has been written above the written G 

below middle C, for the pedals only. 

Dorico also considers the notes described by trills, and will warn if a trill will result 
in out of range notes. Dorico also checks whether trills are playable on flute, 
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recorder, oboe, saxophone, bassoon, and trumpet, and will warn about any 

problematic cases; where good information was readily available about difficulties 

with two-note tremolos, Dorico will similarly warn about them. 

Repeat structures. Dorico's checks for invalid or ambiguous repeat structures has been 

significantly expanded, and now checks for the following: 

§ Duplicate markers of the same appearance. For example, if two or more 

segno markers with the same appearance (i.e. with the same marker index) 

are present in the same flow, either at the same or different rhythmic 

positions. 

§ Repeat markers in a dubious order. For example, if there are two segno 
markers, one would expect the first marker (i.e. the one with a marker index 

of 1) to occur before the second segno (i.e. the one with a marker index of 2). 

If their relative order is the wrong way round, Dorico will flag this. 

§ Missing associated jump repeat markers. For example, a segno marker is 

present in the flow, but an associated D.S. marker is nowhere to be found. 

§ Missing “intermediate” repeat markers. For example, if a coda is specified, 
but there is no marking that specifies where the jump to the coda should 

occur. 

§ Missing associated section repeat markers. For example, a D.S. marker is 

present in the flow, but an associated segno marker is nowhere to be found. 

§ Missing “until” (or “al”) markers. For example, if D.C. al coda is present but 

there is no associated coda, Dorico will flag this. 

Dorico will also report the following issues: 

§ Repeat markers that don’t coincide with a barline. 

§ Passages that will never be played. (For example, if you position “D.S.” before 

a segno marker, Dorico will jump forwards, skipping any bars in between.) 
§ Any end repeat barlines that are missing from all but the last section of any 

repeat ending structure. 

§ Any end repeat barline that is present within the final section of any repeat 

ending structure (as this results in an infinite repeat), unless it is also 

preceded by a start repeat barline within the same final repeat ending 

section. 
§ Any start repeat barlines that are missing an associated end repeat barline. 

§ Rhythmically-mismatched repeat barlines. (For example, if your score is in 

4/4 and starts with a crotchet up-beat, placing an end repeat barline such 

that it naturally coincides with a barline would cause an additional, 

unexpected beat to be played when the player goes back to the start. It’s 

more likely that a start repeat barline should be placed on the barline 
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following the upbeat, or the end repeat barline should have been created 

one beat earlier.) 

Category filter. A new Categories section has been added to the Proofreading page of 

Preferences, allowing you to specify which categories of proofreading results 

should be shown by default in the Proofreading panel when starting a new project, 

or opening a project last saved in Dorico 6.0 or earlier. Once you save your project in 

Dorico 6.1, the current state of the Categories filter in the panel will take 

precedence over the initial defaults specified in Preferences, so your choice of 
which issue categories to show is persisted in the project and will be restored when 

you next open it. 

Improvements 

Arpeggio signs 
Minimum length for slash voices. On the Arpeggio Signs page of Library ▶ Engraving 

Options, it is possible to specify whether arpeggio signs should appear on slash 

voices. A new Minimum length option has been added to the Rhythmic Slashes 

section, allowing you to specify the minimum length in spaces of the arpeggio sign. 
By default in new projects this is set to three spaces, but to preserve the appearance 

of existing projects, it is set to zero in existing projects. 

Articulations 
Staccatissimo design. A new Staccatissimo design property has been added to the 

Articulations group in the Properties panel, allowing you to override the 

appearance of a staccatissimo articulation for a single note or chord, choosing 

between Normal, Wedge, and Stroke. 

Staccatissimo positioning inside the staff. A new option Position staccatissimo on 

closest staff line for notes in a space has been added to the Advanced Options 

section of the Vertical Position section of the Articulations page of Engraving 

Options. When articulations are inside the staff it is usually desirable to ensure a 

clear space between the articulation and the notehead or stem end. With this option 

turned on, staccatissimo articulations will be allowed closer than this. 

Audio engine 
Detecting changes in available devices. If an audio device is connected or disconnected 

while Dorico is running, the list of available devices in Edit ▶ Device Setup will 
reflect the current set of available devices, so you do not need to restart the 

application to switch to a newly connected device. 

Barlines 
Repeat barlines. A new option Changes of time and key signature at coincident repeat 

barlines has been added to the Repeats section of the Barlines page of Engraving 
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Options. This allows you to determine whether changes of clef, key and time 

signature should appear between the end and start repeat barlines, as has always 

been the default in Dorico, or to instead place them to the right of the combined 

end-start repeat barline. 

Double barlines at the start of single-staff systems. When Barline at start of system with 

double barline at end of previous system is set to Double barline on the Barlines 

page of Notation Options, Dorico will now show a double barline at the start of a 

system if the previous system ends with an end repeat barline. 

Bar numbers 
Selecting bar numbers. Two new commands have been added to the Edit category in the 

Key Commands page of Preferences to make it easier to select bar numbers. These 

commands can have custom shortcuts assigned to them, or can be invoked via the 

jump bar. 

Particularly when showing bar numbers on every bar, or at intervals of 5 or 10 bars, 
it may be necessary to adjust the positions of bar numbers relative to items in the 

middle of the bar or at barlines. However, selecting bar numbers to adjust their 

positions in Engrave mode can be tricky, because items like slurs and ties can have 

click areas for their control handles that overlap with bar numbers. So to quickly 

select bar numbers, you can now make a selection in the range where you want to 

select bar numbers, then invoke Select Bar Numbers. This clears the existing 

selection, and selects all bar numbers in the originally selected range. 

In a similar vein, Add Bar Numbers to Selection simply adds any bar numbers in 

the selected range to the selection, without first clearing it. 

Chord diagrams 
Choice of chord diagrams. When Dorico chooses a specific chord diagram fingering for a 

chord symbol, it draws from its library of chord shapes. Instead of having fixed 
shapes for specific chords, Dorico instead has a database of all reasonable 

combinations of fret positions across fretted strings, considering the physical 

capabilities of the human hand. This can mean that if you have a specific shape in 

mind for a particular chord, it might not be the first shape that Dorico chooses, and 

indeed Dorico might make choices that you would prefer not to see at all – for 

example, because you are focusing on student players who may not have mastered 
more complex fingerings. You have always been able to define your own chord 

shapes in Library ▶ Chord Diagrams, and Dorico will prefer user-defined chord 

shapes when they apply, but it has not been possible to exclude any of Dorico's 

default shapes such that they are never chosen. 

In Library ▶ Chord Diagrams, you can now adjust this for each chord shape: if you 

want to exclude a shape from consideration altogether, simply deactivate the 
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Match slide switch. Any chord shape that has Match deactivated will never be 

shown as a candidate chord diagram. You can alternatively influence how Dorico 

uses a particular shape: with Match activated, you can either choose to match All 

chord notes, or Some chord notes. 

When All chord notes is selected, the chord shape will only be chosen by Dorico if 

all the notes in the requested chord are represented by the chord diagram, and no 

extra notes are present. The settings on the Chord Diagrams page of Library ▶ Note 

Input Options are still considered, so for example they might allow the root to be 
omitted, or not always the lowest notes, as well as allowing some notes to be 

omitted in extended chords. 

When Some chord notes is selected, this allows the chord diagram to be chosen by 

Dorico when only a subset of the notes in the requested chord are represented by 

the chord diagram. This is the default setting for user-defined chord shapes. 

Finally, a new filter button has been added to the list of chord diagrams on the left of 

the dialog. When the filter is activated, all chord shapes where Match has been 

deactivated will be removed from the list. 

Library management. It is now possible to export the chord shapes from your project so 

that you can import them into other projects, or create multiple chord diagram 

libraries for different uses. 

In Library ▶ Chord Diagrams, click Export Library to export a library file containing 

all the chord diagrams used in the project, all chord diagrams saved as defaults, and 

any changes to factory chord diagrams (for example, whether Match is activated or 

deactivated). 

To import a library of chord shapes into another project, open the project, choose 
Library ▶ Chord Diagrams, and click Import Library to choose the library file to 

import. 

Root notes on instruments with fewer than five strings. When fretted instruments have 

fewer than five strings, it can be impossible to find chords with the root on the 

lowest string, especially if there is a desire to keep chords clustered around a 

specific fret position, rather than moving up and down the neck a lot. This 

restriction is easier to satisfy when the instrument has more strings, but with 

ukulele, for example, it can result in some chord symbols being unable to show a 

valid chord diagram. 

To address this, a new option For instruments with fewer than five strings, if root 

is included in chord has been added to the Chord Diagrams page of Library ▶ Note 

Input Options. In new projects, this is set to May be anywhere in chord, which 



 

 
Dorico 6.1 29 Dorico 6 Version History 

relaxes this restriction and makes it easier for Dorico to find an appropriate chord 

shape. 

Chord symbols 
Editing alterations. For chord symbols with stacked alterations, like b9 #11, it was 

previously difficult to edit the appearance of the individual alterations in the stack, 

for example to change the accidental glyph used. When editing a chord symbol 

appearance – either by double-clicking a chord symbol in Engrave mode, or using 

Library ▶ Chord Symbols – it’s now possible to double-click the alteration stack to 

edit it, and furthermore to edit an individual alteration within the stack in order to 

edit the accidental and interval components individually. 

Dynamics 
Edit Font. When right-clicking a dynamic and choosing Edit Font from the context 

menu, Dorico now edits the Dynamic Text Font or Dynamic Music Text Font font 

style as appropriate. 

Engrave mode 
Lock Layout. A new option Create system breaks when using Lock Layout has been 

added to the Note Input and Editing page of Preferences. This preference is 

activated by default. 

When using the Lock Layout command in Engrave mode, you may prefer Dorico to 

completely lock the system formatting, such that a frame break is created at the 
start of each frame, and a system break is created at the start of each system. If you 

want to make it easier to subsequently change the system formatting within a 

frame, you may prefer only to create frame breaks, in which case deactivate this 

preference. 

Guitar techniques 
Vibrato bar scoops. A new option Scoop appearance has been added to the Vibrato Bar 

section of the Guitar Techniques page of Engraving Options, allowing you to choose 

between two appearances for scoops: Straight produces a scoop that looks like a 

tick or checkmark, positioned to the left of the note; Curved produces a curved 

arrow positioned above the note. Further options in the same section allow you to 

tweak the default placement of scoops using the new curved appearance. 

In addition, new properties have been added to allow the adjustment of the position 
of individual vibrato bar scoops, and these properties apply both to straight and 

curved scoops. 
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Harmonics 
Artificial harmonics. The Node property in the Harmonics group in the Properties panel 

is now dependent on the Partial property. Only valid nodes will now appear for the 

chosen partial. 

For stringed instruments, the Node property now also affects the notation of 

harmonics on notation staves; previously, artificical harmonics for stringed 

instruments would always be notated as if the first node was used, regardless of the 

state of the Node property. In addition, the playback of natural harmonics using the 

White diamond notehead style is now correct regarding the choice of node. 

Lines 
Tapered curve line bodies. It is now possible to specify dashed, half-dashed and dotted 

tapered curve line bodies in Library ▶ Line Bodies. 

Music fonts 
Bravura. Bravura has been updated to version 1.455, and includes new characters for 

editorial tuplet brackets, and new symbols for curved guitar vibrato bar scoops. 

Using Sonata Std with Dorico. Sonata Std is the OpenType version of Adobe's venerable 

Sonata font. It is the only known font to encode its glyphs using the code points in 

the Unicode Musical Symbols range, U+1D100–U+1D1FF. This range lies in the 

Supplementary Multilingual Plane of the Unicode standard, and glyphs in this range 
have not previously been properly supported by Dorico. It is now possible to specify 

these code points in Dorico's music symbols editor and for them to appear properly 

in the software. 

MusicXML export 
Graphical information. Dorico's MusicXML export has been enriched with more 

graphical and positioning information. The following information is now exported: 

§ Stem lengths (the default-y attribute on the note element) 

§ Horizontal note positioning (default-x on note) 

§ Bar width (width on measure) 

§ Slur and tie positioning (default-x and default-y for end point positioning, 

bezier-x and bezier-y for control point positioning on slur and tied) 

§ Brackets and braces (part-group in part-list, together with group-barline 
for barline joins) 

§ Tempo and metronome mark export now includes font information and 

default-y for words and metronome directions 

§ Fermatas (default-x, default-y, relative-x and relative-y) 

§ Staff-attached text items (default-x, default-y, relative-x and relative-y) 

§ Default line widths, note scale factors etc. (appearance element) 
§ Precise horizontal placement of grace notes (default-x on note with grace) 



 

 
Dorico 6.1 31 Dorico 6 Version History 

§ Vertical placement of rests and bar rests (display-step and display-octave 

on rest) 

§ Precise horizontal and vertical placement of ornaments and trills (default-x, 

default-y, relative-x and relative-y) 

Buzz rolls. Buzz roll (z on stem) tremolos are now correctly exported to MusicXML. 

Tempo. When exporting tempo and metronome marks to MusicXML, the engraving 

option for the relative order of tempo and metronome mark is now respected. 

Margins. When exporting the system-margins element to MusicXML, Dorico now 

correctly accounts for any system indent applied to the right-hand side of the 

system, and similarly handles an unjustified final system in the flow correctly. 

Pedal lines 
Alignment across the system. A new option Align pedal lines across width of system has 

been added to the Vertical Position section of the Pedal Lines page of Engraving 

Options, activated in newly-created projects but deactivated in existing projects. 

When activated, Dorico aligns all pedal lines on the system at the same vertical 

position across the whole system. 

As a result of the implementation of this new behavior, you may see changes in the 

appearance of existing projects where pedal lines of different types (for example, 
but sustain and sostenuto or una corda pedals) overlap. In previous versions, Dorico 

would nest a pedal line that both starts and ends within the span of an existing 

pedal line inside that pedal line, closer to the staff. Now, Dorico always orders pedal 

lines into rows, with a new pedal line starting later than an ongoing pedal line 

positioned outside, further from the staff. If pedal lines begin at the same position, 

the sustain pedal will be positioned closest to the staff, with sostenuto or una corda 

pedal lines positioned further from the staff. 

If the option to align pedal lines across the width of the system is deactivated, 
Dorico will nevertheless resolve groups of overlapping pedal lines within the 

system and position them together, to avoid them colliding or overprinting. This is 

always the behavior in galley view, regardless of whether the option to align pedal 

lines is activated. 

Alignment of pedal lifts. A new option Position of end of pedal line if coincident with 

barline has been added to the Horizontal Position section of the Pedal Lines page of 

Engraving Options, allowing you to specify that when a pedal line ends at a barline, 

the lift should stop at the barline, or should align with the left-hand side of the note 

or chord following the barline. 
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Percussion 
Grid group names. It is now possible for group names for percussion kits using the grid 

presentation type to use rich text formatting, like other staff labels. 

Platform support 
iPadOS 26. The latest version of iPadOS features significant changes to the way app 

windows are handled. It now requires a double-tap on the project title in the toolbar 

on Dorico for iPad to open the Project Info dialog. This allows you to tap and hold on 

that part of the toolbar to move the project window around the iPad display. 

Playback 
Per-switch delay. By default, the Delay value defined for a base switch in an expression 

map applies to the note onset (start), offset (end), and any MIDI controllers required 

to trigger the switch. 

However, some users prefer that note offsets and MIDI controllers are not affected 

by the delay. To accommodate this, it is now possible in Library ▶ Expression Maps 

to determine whether the delay should apply to End offsets and Controllers 

independently. 

Tremolo playback on percussion. A new option Apply accent to all notes for unpitched 

percussion measured tremolo has been added to the Dynamics page of Playback 

Options. When activated, Dorico will apply an accent written on a single-note 
tremolo to all notes in the tremolo, but only on unpitched percussion instruments; 

on pitched instruments, an accent still applies only to the initial note in the tremolo. 

Project files 
Revert. A new File ▶ Revert command has been added. When you invoke this command, 

Dorico will warn you that unsaved changes will be lost, and if you proceed, Dorico 

will close the project without saving it and then reopen it. 

Selections 
Select More. When using Edit ▶ Select More starting from a single selected system or 

frame break, Dorico will now select only breaks of the same type. 

Tablature 
Enclosures around tab numbers. When Enclosures for notes and chords longer than a 

quarter note (crotchet) is set to either Ellipse or Rounded rectangle in the 
Enclosures section of the Tablature page of Engraving Options, it is now possible to 

control the padding between the tablature numbers and their enclosure, with 

independent horizontal and vertical control for rounded rectangles, and diameter 

control for ellipses. 
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Stems in tablature. A new Inner stem adj. property has been added, allowing the 

adjustment of the vertical position of the end of the stem closest to the tablature 

number. 

Tied notes. Two new choices have been added to the Tied notes in tablature option in 

the Ties section of the Tablature page of Engraving Options, which allow Dorico to 

support the conventions for tied notes popularized by Total Guitar, Guitar 

Techniques and Guitarist magazines from the UK, and which are now also followed 

by the Trinity/Rock School electric guitar syllabus. 

By convention, only the starting note of the tie chain is shown in tablature, with no 

tie shown, and no indication of the tied-to note or notes. The exception, however, is 
if something is attached to the tied-to note – for example, a bend, slide, or similar. 

When something is attached to the tied-to note, it is displayed inside square 

brackets. 

To use this convention, choose Hide fret numbers, tied notes with attachments in 

square brackets, per string. If you prefer a single square bracket that encloses fret 

numbers on adjacent strings, choose Hide fret numbers, tied notes with 

attachments in square brackets, grouped. 

The further new options Square bracket thickness and Square bracket hook 

length provide control over the appearance of the square brackets themselves. 

Text 
Smart quotes. A new Smarten quotation marks option has been added to the Text page 

of Engraving Options. When activated, Dorico will automatically convert straight 

quotes into appropriate smart quotes for text everywhere it appears in the project; 

however, even when it is deactivated, quotes will still be smartened in text frames, 

lyrics, and staff labels, as these have always used smart quotes. 

In addition, a new Quotation marks style option has been added, allowing you to 
choose between three different conventions for quotation marks, as most 

commonly used in English, French, and German. 

Character styles in Project Info. It is now possible to specify changes of character style in 

the fields in File ▶ Project Info, providing greater flexibility in formatting subsets of 

the text that appears in text frames when using tokens corresponding to these 

fields. 

The special pair of tokens {@style:All Caps@} and {@/style@} are used to enclose 

the text that should apply the character style. In this example, the name of the All 

Caps character style is used, but of course you should substitute the name of 

whichever character style you want to use. 
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Crimson Pro font family. The Crimson font family – a recreation of old-style serif 

typefaces like Garamond – has been included with Dorico since version 1.0. 

However, Crimson has now been succeeded by a redesigned evolution of the 

original family, Crimson Pro, and that updated family is now included with Dorico in 

preference to the original Crimson family. Crimson Pro offers eight weights, has 

expanded language and script support, and provides improved legibility and optical 

refinement. 

Ties 
Ties over system breaks. A new option Minimum length for ties at the start of the 

system has been added to the Length section of the Ties page of Engraving Options. 
In new projects, this is set to 1.5 spaces, and ensures that ties into the first note or 

chord at the start of a new system are not so short that they look distorted; in 

existing projects, this is set to zero, to avoid changing their appearance on loading. 

Tuplets 
Bracketed tuplet digits. A new Ratio bracket type property has been added to the Tuplets 

group in the Properties panel. When activated, Dorico draws parentheses (curved 

brackets) or square brackets around the tuplet digit or ratio. You can choose 

whether the brackets should be italic or roman. 

When Tuplet digit style is set to Bold weight or Regular weight, brackets will only 

appear correctly when the Tuplet Font font style is set to use Bravura. No other 

music font has the required bracket symbols. However, when Plain font is chosen, 

Dorico will use the parentheses and brackets from the font specified by the Tuplet 

Plain Font font style.  

User interface 
Alphabetic ordering in lists. Where possible, Dorico now uses natural sort order for 

alphabetically sorted lists, instead of the default lexicographical sort order. 

Standard lexicographical sort order compares characters strictly by their Unicode 

or ASCII values, so it would sort the same list as file1.txt, file10.txt, file2.txt, because 
1 comes before 2 in character-by-character comparison. Similarly, in handling 

accented characters, é would be sorted far from e because they have different code 

points. 

By contrast, natural sort order arranges items in the way a human would typically 

expect, especially when numbers are involved. For example, it sorts file1.txt, 

file2.txt, file10.txt in that order. Natural sort order treats accented characters like é, 

è, or ö as variants of their base letters (e, o) to group similar items together in a way 

that feels intuitive. 
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Status bar summary. When multiple implicit rests are selected, the time duration of the 

selection is now displayed as expected. When a staff- or system-attached text item 

is selected, Dorico now displays the name of the paragraph style used by the text 

item, together with the font family and style names. If the text item has a local 

override to the font or style, an asterisk is appended. 

Expression map switch names. In Library ▶ Expression Maps, if the name for a base or 

add-on switch contradicts the combination of playback techniques it is set to 

produce, the names of the playback techniques are automatically appended to the 

name of the switch in the dialog. 

Counterpart layout. Using Window ▶ Counterpart Layout to toggle between full score 
and part layouts in Engrave mode now maintains the selection, resulting in the 

selection being kept in view correctly in the new layout. 

Graphic slices. Selecting a graphic slice in the panel in Engrave mode now navigates to 

the location of that frame in the current layout. 

Proofreading panel. The size of the Ignore button in the Proofreading panel has been 

increased, to make it easier to click on. 

Video 
Warning about synchronization. When Pre-roll before flow is set to a non-zero value on 

the Timing page of Library ▶ Playback Options, attached videos will not play in sync 

as expected. Dorico now shows a warning to that effect if you change this setting 

when a video is attached to one or more flows in the project.  
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Issues resolved 
Component Issue 

Chord diagrams Editing a chord diagram in Library ▶ Chord Diagrams no longer causes it to appear twice in 

the list of alternative chord diagrams. 

Chord symbols When de-synchronizing a roman and italic chord symbol appearance that applies to all roots, 
Dorico now correctly ensures that independent components are created for each component 
in the appearance. 

Chord symbols It incorrectly appeared to be possible to delete the factory chord symbol kerning pairs; this has 
now been fixed. 

Chord symbols Properties on chord symbols on staves other than the top staff in the score layout now once 
again propagate correctly to part layouts. 

Chord symbols Dorico could crash when drawing a chord symbol containing a component drawn using SVG; 
this has now been fixed. 

Condensing Enabling and disabling condensing no longer causes markers that appear above a condensed 
staff to temporarily disappear. 

Condensing When multiple instruments of the same type are assigned to the same player, Dorico no 
longer incorrectly fails to draw the music when condensing is enabled. 

Dynamics Under some circumstances, deleting a dynamic group containing immediate dynamics with a 
hidden intensity marking would result in the dynamic signpost remaining visible; this has 
now been fixed. 

Flows When importing flows from another project, Dorico will now only allow players to be merged 
if their type (i.e. single vs. section) matches. 

Flows The list of flows in Edit ▶ Go To now always uses the same number that appears in the Flows 

panel in Setup mode; previously these numbers would differ if the current layout does not 
include all flows. 

Holds and pauses When a breath mark appears at the end of the system, it could sometimes be incorrectly 
displaced by items to the left of the first note or chord on the following system; this has now 
been fixed. 

Key Editor Under some circumstances, edits in the music could be missed by the Key Editor if they occur 
in the dead time before Dorico recalculates playback; this has now been fixed. 

Localization When running Dorico in Chinese or Japanese, English note names are now used instead of 
solfège note names in signposts for key signatures. 

MIDI export Notes produced by the chord track in Play mode are once more correctly included when 
exporting MIDI. 
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Component Issue 

Music symbols Under some circumstances, Dorico would incorrectly choose a font style with a different size 
to that used to display a glyph in the music symbols editor; this has now been fixed. 

MusicXML export Lyrics on chords are now exported to MusicXML in such a way that improves compatibility 
with importing into Sibelius. 

MusicXML import When running Dorico in Japanese or Chinese, it was possible for Dorico to crash when 
importing a MusicXML file that requires a custom clef definition; this has now been fixed. 

Note input Inputting using the on-screen Fretboard panel no longer incorrectly modifies the pitch of the 
input notes according to the accidentals in the key signature. 

Note input Under some circumstances, pasting material into another flow could leave it apparently 
linked to the original flow; this has now been fixed. 

Note input Under some circumstances, pasting multiple copies of note-attached lines attached to 
different voices at their starts and ends would cause subsequent lines to become attached 
incorrectly; this has now been fixed. 

Ornaments Under some circumstances, the placement of trills relative to the staff could be unstable when 
editing music in their vicinity; this has now been fixed. 

Platform support It is once again possible for Dorico to be installed on ARM-based Windows systems; however, 
Dorico is still x86-only (Windows only). 

Playback D.C. al Segno now correctly interprets the segno mark as fine in playback. 

Playback The delay produced by the Delayed start option or property for glissando playback is now the 

same for glissandos played back via pitch bend and those played back by discrete notes. 

Playback Harmonics indicated by the circle above the note are now played at the correct pitch on harp. 

Playback Under some circumstances, the gap following a fermata would not be played correctly in 
repeated passages; this has now been fixed. 

Playback When exporting expression maps via Library ▶ Expression Maps, Dorico now correctly 

includes any playback techniques referenced by switches in the expression map in the 
exported library file. 

Playing techniques Under some circumstances, bracketing a playing technique could result in multiple sets of 
parentheses surrounding symbol and text parts of the playing technique; this has now been 
fixed. 

Print mode Empty text frames with filled, colored backgrounds now once more appear correctly when 
printed or exported to graphics. 
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Component Issue 

Print mode Rehearsal marks with their color overridden via properties now print or export to graphics 
correctly. 

Project files The instrumentation in the factory brass quartet template has been adjusted to the more 
traditional combination of two trumpets, horn, and trombone. 

Project files Importing a flow containing a percussion kit that includes a user-defined instrument no 
longer causes Dorico to crash. 

Proofreading Some issues that only apply to tenor trombones were additionally being reported for bass 
trombones; this has now been fixed. 

Proofreading Dorico no longer warns about the playability of the bottom E flat (written pitch) on bass 
clarinet. 

Proofreading Instruments with empty names are now handled more gracefully in the Proofreading panel. 

Proofreading The whistle tone playing technique is now correctly handled both for flute and voice. 

Proofreading In situations where a harmonic (of any type) could be played with either the left hand or the 
right hand, and one of them was easier than the other, Dorico would sometimes give the 
warning for the more difficult type; this has now been fixed. 

Proofreading Some low-level bugs in the way hand positions were calculated were fixed, particularly 
involving barrés. 

Proofreading The warnings about duplicate or conflicting playing techniques between main and ossia 
staves have been further refined. 

Proofreading Proofreading issues related to stringed instruments are now calculated more quickly in 
general. 

Proofreading Dorico no longer redundantly warns about dynamics on opposite sides of the same staff in 
keyboard music, provided they neither duplicate or contradict each other. 

Proofreading Dorico no longer sometimes redundantly warns about clefs that coincide with repeat barlines. 

Proofreading In large projects, Dorico could hang when proofreading playing techniques; this has now been 
fixed. 

Proofreading Dorico no longer warns when natural harmonics are written for wind instruments, if they are 
valid and can be played. 

Proofreading Dorico now correctly reports ambiguous playing techniques at changes of divisi. 

Tablature The color defined for Unplayable in tablature on the Colors page of Preferences is now 

correctly used. 
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Component Issue 

Tablature Several subtle problems involving the relative placement of tablature notes and stems in 
multiple voice contexts have been fixed. 

Tablature In some situations, tied notes were not correctly displayed at the ends of runs of bends; this 
has now been fixed. 

Text System-attached text whose style is set to align to the systemic barline now correctly updates 
its horizontal alignment when the casting off changes. 

Ties The behavior of the Consider 'Hide stem' property when positioning tie endpoints option 

has been improved, and now applies in more situations. 

Tremolos Tremolo beams can now be centered between double whole notes (breve) noteheads as well as 
whole note (semibreve) noteheads, if the appropriate option is set. 

User interface The rhythmic grid selector in the Key Editor toolbar now shows a tool tip when hovered. 

User interface The key commands for interacting with issues in the Proofreading panel now appear in a new 

Proofreading category in the Key Commands page of Preferences, rather than (confusingly) 

under Setup. 
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Dorico 6.0.22 
8 July 2025 

Issues resolved 
Component Issue 

Chord symbols Chord symbols no longer unexpectedly move vertically when inputting and editing in galley 
view. 

Chord symbols Propagating properties from chord symbols on staves other than the top staff now works as 
expected once more. 

File import Dorico no longer often crashes either during or immediately after importing a flow, MusicXML 
or MIDI file into an existing project. 

Key Editor The Dynamics editor is now always correctly populated after opening a project. 

Proofreading Ignoring proofreading issues now works correctly in Dorico Elements and Dorico SE. 

Text Text frames that contain no visible text but which have an overridden background color are 
once again correctly shown when printing and exporting graphics. 
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Dorico 6.0.20 
29 June 2025 

Highlights 

Proofreading 
Ignoring issues by location. It is now possible to mark issues in the Proofreading panel as 

ignored, which temporarily stops them from appearing in the list. When you hover 

the cursor over an issue, a small eye icon appears in the bottom right-hand corner: 

click this to ignore the issue and temporarily remove it from the list. 

To see all the issues you have ignored, activate the Show ignored checkbox 

immediately above the list. Ignored issues then appear in the list in a dimmed color. 

To un-ignore an ignored issue, click the eye icon again. 

To un-ignore all ignored issues, click the Clear button immediately to the right of 

the Show ignored checkbox. If there are no ignored issues in your project, the Show 

ignored checkbox is disabled. The list of ignored issue locations is saved in the 

project, so ignored issues will not reappear when you next open the project. 

It’s important to understand how this mechanism works, since due to the dynamic 

nature of Dorico’s proofreading feature, when you mark an issue as ignored, you 

are not ignoring a specific issue, but rather ignoring the combination of the location 

where the issue has been identified and the type of reported issue. 

For proofreading, the location is the combination of flow, instrument, and rhythmic 

position (or range of rhythmic positions) where the issue is found. 

Each of the proofreaders that combine to produce the many categories of issues 

shown by Dorico report many different types of issues. Broadly speaking, each 

different textual description in the panel corresponds to a different issue type. 

Ignoring an issue will not prevent issues of other types being reported at that same 

location, but it will prevent another issue of the same type being reported there. 

Every time you edit the score, Dorico runs all the proofreading steps again, and 
there is no connection between the issues discovered on this check and the 

previous one. Dorico filters out combinations of locations and issue types that have 

previously been ignored, so it is possible for a new issue of the same type to be 

discovered but for it not to appear in the list, because it is at a location that has 

previously been ignored. 

This also means that large-scale edits to the musical content or structure of the 

project – for example, adding or removing bars – can result in previously ignored 

issues reappearing, because the relevant music now appears at a new location. 
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Conversely, issues that previously appeared may disappear from the list because 

they now fall at previously ignored locations. 

It is therefore advisable to ignore issues only when you are towards the end of the 

preparation process for your project. If you make large-scale changes to the flow, 

consider clearing ignored issues to make sure you don’t miss details that arise 

because of those changes. 

Keyboard navigation. New commands have been added to the Setup category in the Key 

Commands page of Preferences to allow you to interact with the Proofreading 

panel using the keyboard. Commands for navigating to the previous and next 

issues, ignoring an issue (or un-ignoring it, if ignored issues are shown), and 

clearing ignored issues are provided. 

Cantai support 
Dorico 6.0.20 provides initial support for the Cantai vocal synthesis plug-in in 

development by Turing Opera Workshop. To use the Cantai plug-in, add one 
instance to the VST and MIDI panel in Play mode for each voice instrument you 

want to be played by Cantai. In the Track Inspector panel, use the controls in the 

Routing section to connect each Cantai instance to the appropriate voice. The final 

step is to open the Cantai interface by clicking the Show Instrument button (which 

looks like a lowercase e) and choosing the appropriate instrument from the drop-

down in the plug-in interface. 

When you edit the music or lyrics on an instrument assigned to Cantai, Dorico 

updates a data file in the shared location that is automatically read by Cantai, and 

which then updates the vocal synthesis. 

For more information about Cantai, visit its web site at cantai.app. 

Improvements 

Barlines 
Wings on repeats. A new Show wings property has been added for repeat barlines, 

allowing you to override on a per-barline basis whether wings should appear. 

Bar numbers 
Bar number ranges below multi-bar rests. Bar number ranges below multi-bar rests are 

by default positioned below the staff using the Bar number range distance below 

staff option on the Rests page of Engraving Options. If you want to show bar 

number ranges at the same position relative to the staff as bar numbers shown on 

every bar, this presents a problem, as of course engraving options are global and 

apply to all layouts. 
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To address this, a new Distance for bar number range below staff option has been 

added to the Multi-bar Rests section of the Rests page of Engraving Options. This 

can now be set to Layout Options, which means that Dorico will then position bar 

number ranges using the Minimum distance from staff option on the Bar 

Numbers page of Layout Options. 

Position relative to clef. A new option Minimum gap above treble G clef with 8 above n 

spaces has been added to the Clefs section of the Bar Numbers page of Engraving 

Options. This option also applies to a treble G clef with 15 above. Relatedly, the 
existing option Minimum gap below treble G clef with 8 below n spaces now also 

applies to a treble clef with 15 below. 

Chord diagrams 
Ukulele chord diagrams. The default chord shapes for chord diagrams for the standard 

ukulele tuning now more closely match the recommendations of the Ukulele 

Society of Great Britain for commonly used chords. 

Editing chord diagrams. In previous versions of Dorico, editing an existing factory chord 

shape would always add a whole new chord shape to the project’s library, which 

could quickly lead to a very large number of diagrams in the library. Now, when you 

edit a factory chord shape, Dorico effectively replaces the factory shape with your 

edited shape, so you will see your preferred version instead of the factory one. You 

can revert to the factory shape by clicking the Revert to Factory button in the action 

bar in Library ▶ Chord Diagrams. 

Chord symbols 
Capo chord symbols. A new option Scale factor for capo chord symbols n% has been 

added to the Capo section of the Chord Symbols page of Engraving Options. This 
allows you to specify that capo chord symbols should be made smaller than the 

corresponding main chord symbols. It is also now possible to specify that capo 

chord symbols should be neither shown in italics nor shown in parentheses if 

desired. 

Alignment and collision avoidance. With the addition of multiple lines of chord symbols, 

and chord symbols themselves being able to show extender lines, it was necessary 

to revamp collision avoidance for chord symbols and chord diagrams in this 

release. 

Chord symbols and their extender are now treated as a single unit – previously, it 

was possible for extender lines to become detached from the chord symbols to 
which they belong – and when Align chord symbols across the width of the 

system is activated, Dorico aligns all lines of chord symbols across the width of the 

system together. When alignment across the system is not activated, Dorico instead 
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performs collision avoidance for chord symbols at the same rhythmic position, and 

at any other rhythmic positions affected by chord symbols’ extender lines. 

A new Avoid collisions option has been added to the Position section of the Chord 

Symbols page of Engraving Options, allowing you to determine whether chord 

symbols should avoid collisions with the staff and objects protruding from the staff 

by default; this can be overridden for individual chord symbols using the 

corresponding Avoid collisions property. 

Crosshair. The position of the crosshair for a selected chord symbol in Engrave mode has 

been improved. It is now correctly aligned with the baseline of the lower chord 

symbol (or the bottom of the chord diagram, if one is shown). This makes it easier to 

check the alignment of chord symbols across the width of the system. 

Vertical placement of extender line. When main and transposed chord symbols are 
shown, extender lines appear only once, on whichever chord symbol is closest to 

the staff. Similarly, when a chord diagram is shown, the extender line is centered 

vertically on the chord symbol immediately outside the extender line. 

Resetting kerning edits. In Library ▶ Chord Symbol Kerning Pairs, the Reset and Delete 

buttons now show a warning before carrying out the expected actions. 

Cues 
Ornaments. Jazz articulations and glissando lines are now included or excluded in cues 

according to the engraving option and property for the inclusion of ornaments in 

cues. 

Filters 
Filtering by pitch. A new Edit ▶ Filter ▶ Notes by Pitch submenu has been added, where 

the existing Notes by Pitch dialog is now called Specific Pitches. Additional 

commands for filtering notes expressed as triple sharps, double sharps, double 

flats, and triple flats have been added alongside the existing filters for all sharp and 

flat notes.  

Fonts 
Updated font families. Splentino version 1.1 and Nepomuk version 2.6 both now include 

tabular figures, which can be enabled via OpenType features. 

Lyrics 
Custom hanging punctuation. A new option Extra punctuation to ignore has been added 

to the Spacing section of the Lyrics page of Engraving Options. This allows you to 

specify additional characters that Dorico should treat as punctuation when aligning 

lyrics. 
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Note input 
Multi-paste. When the caret is extended across multiple staves, Dorico now pastes 

across all the staves within the span of the caret; previously, material would be 

pasted only on the top staff. 

Pedal lines 
Offset of Ped. text. A new Offset for start of pedal line with text n spaces option has 

been added to the Advanced Options section of the Horizontal Position section of 

the Pedal Lines page of Engraving Options. This allows you to specify a horizontal 

offset for the Ped. text at the start of a pedal line, to allow fine positioning of the 

vertical stroke of the initial P, analogous to the existing option for offsetting the 

ornate P. 

Playback 
Playback updates. After each edit that changes the musical content of the flow, Dorico 

recalculates the playback information for the affected instrument or instruments. 

This normally takes only a fraction of a second, but in long flows, or flows with many 
changes of playback technique, or when your playback template uses complex 

expression maps with many switches, it can take a little longer. This can result in 

Dorico feeling a little less responsive when inputting and editing in such projects. 

To address this, Dorico now delays the recalculation of playback information until 

the application is idle for a moment, reducing the impact on the responsiveness of 

the application. 

Project templates 
Barbershop quartet template. The Barbershop quartet project template in the Choir 

category on the Create New page of the Hub has been improved to more closely 

match the notation guidelines published by the Barbershop Harmony Society 
(BHS), the leading organization for the promotion of barbershop singing in the US. 

The template now uses the expected two-staff short score instead of an open score 

written on four staves, and follows as closely as possible the recommendations for 

frequency of bar numbers, choices of fonts, and so on. 

Choral templates. All templates in the Choir category in the Hub now create projects 

with only a full score layout, and no part layouts, since these are normally not 

required. If you want to create part layouts in such a project, use Setup ▶ Create 

Default Part Layouts. 
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Issues resolved 
Component Issue 

Accidentals The positioning of natural accidentals to the left of unshortened ledger lines has been further 
improved. 

Bar numbers Bar number ranges consisting of a single bar no longer incorrectly appear below multi-bar 
rests. 

Bar numbers Adding a clef change now immediately updates the vertical position of bar numbers shown 
above or below the clef at the start of following systems. 

Chord diagrams Dorico no longer incorrectly resets the chord diagram back to the nut when editing it. 

Chord diagrams Sometimes, when adding a chord diagram to the project, its fingering could be incorrectly 
updated; this has now been fixed. 

Chord symbols When Apply to All Roots is set for an existing customized chord symbol appearance, Dorico 

now removes any changes made to the root accidental appearance, as this will no longer 
apply. 

Chord symbols Dorico no longer incorrectly considers chord symbols in different lines when determining 
how much horizontal space is required. 

Chord symbols When cycling through roots for a chord symbol appearance that applies to all roots, if root 
accidentals have superscript or subscript positions, the remaining appearance is no longer 
incorrectly vertically offset. 

Chord symbols Chord symbols with extender lines that span more than one system break now appear 
correctly on all systems. 

Chord symbols Chord symbol extender lines no longer incorrectly cause cutaways to end. 

Chord symbols It is now possible to edit the kerning of chord symbols using Nashville root appearances. 

Chord symbols Adjustments to the position of sub-components in chord symbols set to apply to all roots are 
no longer unexpectedly lost when cycling through roots. 

Comments Under rare circumstances, Dorico could crash when selecting a comment; this has now been 
fixed. 

Comments Dorico now correctly sanitizes project and layout names that are used when building the file 
name for exported comments, to ensure the file is exported correctly. 

Coordination lines Coordination lines are now correctly erased when Erase background is set on a text item or 

dynamic. 

Dynamics Editing an mfz dynamic in the popover no longer incorrectly shows mfzz as the popover text. 
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Component Issue 

Dynamics Combined dynamics that start or end with mf or mp now have the correct effect in playback. 

Engrave mode It is now possible to assign key commands to toggle rulers and grids in Engrave mode so that 
those shortcuts can also be correctly assigned in other modes. 

Engrave mode Drag handles for gradual dynamics are now the correct size while dragging in Engrave mode. 

Graphics export Adding file name ingredients in the Export File Names dialog no longer sometimes incorrectly 
adds a separator. 

Jump bar Options that show a choice of language no longer show languages not currently available in 
Dorico. 

Library Manager Sometimes, Dorico would crash when closing a project with the Library Manager open; this 
has now been fixed (Windows only). 

Library Manager Applying layout options to all layouts, or notation options to all flows, from a library file (rather 
than a project file) in the Library Manager now works correctly. 

Library Manager Dorico now correctly prevents you from using an already open project as the source project in 
the Library Manager. 

Lines The Rotation option for music symbol-based line annotations is now correctly saved and 

loaded. 

Localization The translations of token placeholders and key signature signposts have been improved in 
Italian. 

Localization The {@dateDMY@} token now correctly shows a period (full stop) after the day number in 

German. 

Localization The order in which categories are listed in Dorico’s main options dialog now correctly 
considers accented characters. 

MIDI export Controller changes are no longer exported on a different channel to their corresponding notes 
for channel 10 and above. 

Music symbols Under some circumstances, adding a glyph to a music symbol would incorrectly use a font 

other than the one chosen in the Glyph panel on the right-hand side, due to a problem with 

matching up existing font styles; this has now been fixed. 

Music symbols Glyphs are no longer sometimes incorrectly offset in the music symbols editor. 

Music symbols When opening projects created in earlier versions, the scale factor for existing components is 
now always shown correctly in the editor. 

MusicXML import Circled noteheads are now correctly imported from MusicXML files. 
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Component Issue 

Note input Under some circumstances, it was possible for Dorico to hang indefinitely when confirming 

the Shift+I note tools popover; this has now been fixed. 

Note input Dorico no longer allows you to paste staff count change signposts onto instruments where 
they would be invalid. 

Note input Retrospective Record now always adds the recorded music in the correct position, regardless 
of any existing selection in the flow. 

Note input When advancing the popover quickly in chord symbol, lyric, fingering, or figured bass input, 
Dorico would sometimes crash; this has now been fixed. 

Ossias Activating Show ossia staves on the Staves and Systems page of Layout Options now 

correctly immediately updates the layout. 

Percussion It is no longer possible to add slash instruments to a percussion kit using the Add Instrument 

to Kit button that shows the regular picker; instead, slash instruments must be added using 

the dedicated buttons in the action bar. 

Percussion The Grace notes follow default stem direction option in the Single-line Percussion section of 

the Percussion page of Engraving Options now works correctly for beamed groups of grace 

notes. 

Playback Switch actions defined in expression maps are now correctly played when the first note of the 
flow has a start offset. 

Playback The Pre-roll before flow value on the Timing page of Playback Options is now always correctly 

applied immediately after a project is opened. 

Playing techniques If the standard appearance of a playing technique is parenthesized, Dorico no longer 

incorrectly adds a second set of parentheses when the Parenthesized property is activated. 

Playing techniques Overrides to the color of an individual glyph or text item within a playing technique are now 
respected. 

Project files Under some circumstances, existing projects would be marked dirty immediately after 
opening them; this has now been fixed. 

Proofreading Dorico has a more nuanced understanding of how artificial harmonics can be played on 
fretted instruments, and no longer incorrectly warns about stretches that are too great. 

Proofreading Dorico no longer sometimes incorrectly identifies otherwise identical clefs as differing by 
their octave indicator. 

Proofreading Dorico no longer sometimes incorrectly identifies chords where the hand is forced up the 
neck of a stringed instrument. 
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Component Issue 

Proofreading Dorico no longer sometimes incorrectly complains about combined dynamics that end in mf 
or mp. 

Proofreading Dorico now flags up playing techniques with a duration that do not coincide with a note onset 
position. 

Proofreading The handling of playing techniques that use the underlying Natural playback technique has 

been significantly improved, leading fewer false positives. 

Proofreading Dorico now correctly considers the repeat structure when deciding whether to warn about 
missing dynamics at an instrument’s new entry. 

Proofreading Dorico would not always navigate to the correct position when clicking a result in the 
Proofreading panel, if staves are hidden; this has now been fixed. 

Proofreading Dorico no longer incorrectly warns about duplicated playing techniques when the same 
playing technique is also written in an ossia. 

Properties The subheadings for articulations of duration, force, and stress now once again appear 
correctly in the Properties panel. 

Repeat endings Creating a repeat ending from a selection consisting of a mixture of notes, rests, and either 
bar repeat or slash regions now works as expected. 

Staff labels The Period (full stop) after abbreviated instrument names option on the Staff Labels page of 

Engraving Options no longer adds spurious periods (full stops) to staff labels using short 
player names. 

Tempo The gap between a tempo mark and its associated metronome mark no longer depends on the 
space size of the staff on which it appears. 

Tempo Gradual tempo changes that cross instrument changes appear correctly once more. 

Text The Insert Music Text dialog now once again shows the All ranges choice at the top of the list 

of glyph ranges. 

Text Text token placeholders on the same line as regular text no longer incorrectly appear even 
when the option to show them is deactivated. 

Text When exporting text from the project in CSV format, tempo and metronome marks now 
correctly reflect how parentheses appear in the score itself. 

Tuplets The Scale factor for digits/notes in tuplet ratio options in the Number and Ratio section of 

the Tuplets page of Engraving Options now work as expected once more. 
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Component Issue 

User interface It is no longer necessary to manually type U+ in the From and To edit controls in the Glyph tab 

of the music symbols editor. 

User interface Dorico no longer crashes when opening some dialogs when Full Keyboard Access is enabled 
in System Settings (Mac only). 

User interface Under some circumstances, Dorico could crash when triggering a script whose commands 
contain internal identifiers to specific projects or windows; such scripts should instead have 
no effect. 

User interface The Font Styles, Playing Techniques, Lines, and Line Annotations dialogs in the Library menu 

can now all be resized to a smaller size than their initial dimensions. 

User interface Under some circumstances, Dorico could crash when pressing a key while the help overlay is 
shown; this has now been fixed. 

User interface Under some circumstances, the wrong bar number would appear in the status bar; this has 
now been fixed. 

User interface The Graphic Slices panel in Engrave mode is no longer too wide when running Dorico in 
French. 

User interface Any previously entered text in the Project title and Composer fields in the Create New page of 

the Hub is now always removed, to avoid inadvertently creating a project with the same name 
as the previous one. 

User interface It is once again possible to apply formatting to selected text in the Edit Instrument Names, 
Edit Single Lyric, and Change Divisi dialogs. 

User interface The Click button in the Transport window now shows the correct state when the window is 

opened. 

Voices Notes in voice column 1 or higher no longer sometimes collide with noteheads in voice 
column 0 if the noteheads in voice column 0 are not all the same size. 
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Dorico 6.0.10 
26 May 2025 

Improvements 

Arpeggio signs 
Position relative to accidentals. A new option, Gap between arpeggio line and chord 

with accidental, has been added to the Gaps section of the Arpeggio Signs page of 

Engraving Options. 

Barlines 
Double barline at start of first system. A new option, Barline at start of first system, if 

shown, has been added to the Barlines page of Notation Options, allowing you to 

specify that the first system should begin with a double barline if desired. 

Chord diagrams 
Barres and fingering. Dorico no longer attempts to automatically fill in the fingering 

numbers for chord diagrams as you edit the shape. While this was often helpful, it 

also resulted in limitations in the placement of barres, as Dorico will only show 

barres for strings played by the same finger, and it would sometimes refuse to allow 

non-contiguous strings to be played by the same finger. As a famous uncle once 

said, with great power comes great responsibility: it is now therefore possible to 

create invalid fingerings if you are not careful. 

However, this greater flexibility in specifying fingering results in greater flexibility 
in the placement of barres. Clicking a dot will only produce a barre if there are other 

dots on the same fret with the same assigned (or no) fingering, and that aren’t 

separated by a fingered note between them on a lower fret, or an open string. A 

muted string in the middle of a barre is permitted. Any dots without finger 

numbering that are incorporated into a barre will automatically be assigned the 

fingering used in the rest of the barre. 

As a result, it is possible to create more than one barre on the same fret if they both 

have different finger numbers. It is also possible to combine barres and adjacent (or 
non-adjacent) single fingerings along the same fret, again determined by the 

assigned fingerings. 

If a dot inside a barre is moved to a different fret, or assigned a different fingering, 

the barre contracts, or disappears altogether if no longer viable. If a dot is moved 

adjacent to an existing barre, then the barre expands to include this dot if it has the 

same assigned (or no) fingering. 
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Creating a lower-fingered dot or an open string within a barre breaks it. If the barre 

crosses sufficient strings such that it can be broken into two separate barres, the 

fingering is updated so that the two barres don’t have the same fingerings. Any un-

barred dots that use the same fingering as any barres will have their fingering reset 

(but you a free to reinstate the “wrong” fingering if you wish). 

Filters 
Suppressed playback. A new quick filter Edit ▶ Filter ▶ Suppressed Playback has been 

added, allowing you to select or deselect items that are suppressed in playback. 

Fingering 
Placement of alternative fingerings. The Placement for alternative fingerings option on 

the Fingering page of Engraving Options now includes a new setting, Above, which 

allows you to specify that alternative fingerings should be placed above main 

fingerings. 

MIDI import 
Preferences. The Add articulations to notes option now appears in the Recording 

section of the Play page of Preferences, as well as in the MIDI Import Options dialog. 

MusicXML import 
Chord symbols. If multiple chord symbols appear at the same rhythmic position with 

different vertical positions relative to the staff, Dorico now attempts to import them 

into multiple rows. 

MusicXML export 
Arranger. If the Arranger field in File ▶ Project Info is filled out, this information is now 

included in the <creator> element in exported MusicXML. 

Note input 
Select following notes of same pitch. If you hold Shift and double-click a note in the score, 

Dorico will now select all following notes of the same pitch in that voice. 

Octave lines 
Rhythm dots. A new option Right-hand position of octave line relative to rhythm dots 

on final note has been added to the Advanced Options section of the Horizontal 

Position section of the Octave Lines page of Engraving Options, allowing you to 

specify whether the width of rhythm dots should be considered when placing the 

right-hand end of the octave line relative to the note or chord at its end position. In 

new projects, this is set to After rhythm dots, but in existing projects it is set to 

Before rhythm dots to maintain their appearance. 
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Pedal lines 
Continuation symbol. The Text or symbol appearance at start of subsequent systems 

option in the Design section of the Pedal Lines page of Engraving Options now 

includes a new setting, No sign, which allows you to specify that a pedal line should 

show no sign when continuing onto a new system. 

Playback 
Dynamic curve. The graph illustrating the effect of the Dynamic curve power setting on 

the Dynamics page of Library ▶ Playback Options now shows the actual value for 

each dynamic level, and updates as you change the setting. 

The curve calculation has also been tweaked to remove a discontinuity that could 

occur around level 0, and to allow the mid-point of the curve to be shifted away 

from 0 if the Minimum dynamic level and Maximum dynamic level values are set 

asymmetrically. 

Proofreading 
Playing techniques. When checking playing techniques, Dorico now looks for text events 

denoting music written on a single staff belonging to a section player that should be 

played divisi. This prevents Dorico from showing warnings about duplicated playing 

techniques when they are written for each desk or subdivision. 

Damp techniques. Dorico no longer warns about damp techniques coinciding with rests, 

since this is how they are typically written, e.g. for harp. 

Ossias. Dorico no longer warns about duplicated playing techniques if they appear in an 

ossia. 

Instrument changes. Material written for marching percussion kits no longer generates 
warnings that the material cannot be played by a single player, since these kits are 

typically played by multiple musicians. 

Rulers and grid 
Changing units. You can now double-click the label showing the unit currently used for 

rulers to cycle through the available unit types. 

Label precision. The labels in the ruler showing the mouse cursor position now shows 

the measurements to a higher degree of precision. 

User interface 
Status bar. The information read-out on the status bar has been revised such that it 

takes up less horizontal space, and will not force the project window to be wider 
when the read-out is updated. Because the window can now be made narrower 

than the minimum width required to accommodate the complete read-out, 

hovering over the read-out will now show its complete text in a tool tip. 
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Key commands. It is now possible to specify key commands for the commands in the 

View ▶ Pages submenu in the Key Commands page of Preferences. 

Text editor in dialogs. Text editor controls in dialogs – Edit Instrument Names, Edit 

Single Lyric, Change Divisi – now show a focus ring when the keyboard focus is in 

the text editor, to make it clear when you can type into the text editor. In the Edit 

Instrument Names and Edit Single Lyrics dialogs, the text in the editor is 

automatically selected when the editor gains focus, making it easier to type to 

replace it. 
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Issues resolved 
Component Issue 

Accidentals The placement of flat accidentals on the bottom line of the staff above a note with an 
unshortened ledger line has been improved. 

Bar numbers Ranges of bar numbers now draw below multi-bar rests as expected once more. 

Chord diagrams Dorico no longer crashes when choosing Library ▶ Chord Symbols with a chord symbol 

selected for an instrument with no chord diagram tuning chosen. 

Chord symbols Transposing chord symbols no longer incorrectly causes chord symbols beyond the first row 
to be removed. 

Chord symbols Adding parentheses to a custom chord symbol now works correctly. 

Chord symbols Center-aligned chord symbols no longer cause instability in rhythmic spacing. 

Chord symbols The placement of intervals and alterations relative to roots for chord symbol appearances set 
to apply to all roots when root accidentals use superscript positioning has been corrected. 

Chord symbols Chord symbols with altered bass notes now correctly use an overridden appearance if 
necessary. 

Chord symbols The alignment of chord symbols with overridden appearances with altered bass notes relative 
to other chord symbols on the system is now correct. 

Chord symbols Under some circumstances, chord symbol components could overprint each other 
unexpectedly; this has now been fixed (macOS only). 

Chord symbols Engrave mode editing of chord symbols with extender lines has been significantly improved. 
Some problems with collision avoidance for extender lines still remain to be resolved. 

Chord symbols The vertical position of the altered bass slash in a diagonal arrangement is now set relative to 
the baseline of the previous component, rather than the bottom of its bounding box; this may 
cause the horizontal position of the slash to move in existing projects. 

Clefs Restorative clefs no longer have octave shift properties set, unless an octave shift is actually 
required to restore the previous clef. 

Condensing Editing dynamics in one layout no longer sometimes causes unexpected changes in 
condensing in another layout. 

Condensing Dorico no longer sometimes leaves space for the wrong transposing key signature for 
condensed players with multiple instruments of different transpositions, which can result in 
an unnecessarily large gap at the end of the system and a cautionary time signature 
overlapping the page margin. 
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Component Issue 

Cues Under some circumstances, confirming a chosen instrument name from the cue popover 
would result in no cue being created; this has now been fixed. 

Fill view When the same layout is shown in multiple windows or splits within the same window in fill 
view, changing zoom level in one fill view no longer incorrectly affects the other view. 

Fill view Under some circumstances, Dorico could incorrectly show the music in fill view when 
switching to Engrave mode; this has now been fixed. 

Flows Write ▶ Split Flow now correctly handles splitting a flow at a barline position where the 

prevailing time signature has a pick-up; the new flow no longer incorrectly starts with a 
corresponding pick-up. 

Jump bar It is once again possible to trigger commands correctly in the jump bar when running Dorico 
in Japanese and Chinese. 

Library Manager Dorico now shows a warning if you attempt to load the open project as the secondary project 
in the Library Manager. 

Music fonts Under rare circumstances, changing the music font in a project could result in a crash; this 
has now been fixed. 

Note input After confirming a popover when editing an existing item, it is now possible to use Tab to cycle 

the selection to other items at the same position without clicking in the music area again to 
restore focus. 

Notes Note name and Figurenotes noteheads now appear correctly once more. 

Numbered bar 
regions 

The Show bar count in numbered bar regions option is no longer incorrectly deactivated 

when loading existing projects. 

Playback In rare circumstances, deactivating independent voice playback could cause a crash; this has 
now been fixed. 

Playback Changes of playing technique at the very start of the flow for a note with a positive offset now 
play back correctly. 

Playback Clicking Save as Stage Template or Save as Space Template in the Live Stage and Live Space 

windows no longer causes a crash. 

Project files Dorico no longer crashes when saving a project with no players. 

Project files Under some circumstances, Dorico could hang when saving a project file; this has now been 
fixed (macOS only). 

Proofreading Projects with some user-defined playing techniques no longer cause Dorico to crash after 
opening. 
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Component Issue 

Proofreading User-defined percussion kits are now handled correctly when checking instrument changes. 

Proofreading Dorico no longer warns about multiple instruments being played by a single player for 
marching percussion instruments and kits. 

Proofreading Warnings for pick-up bars where the pick-up is longer than half the duration of the prevailing 
time signature have been improved. 

Proofreading The detection of coincident or overlapping playing techniques on ossia staves has been 
improved. 

Proofreading The detection of dynamics both above and below the staff but where only a single voice is 
active has been improved. 

Repeat markers The horizontal positioning of To Coda marks has been corrected. 

Slurs It is now always possible to lengthen or shorten slurs to the next or previous note, even for 
long tied notes. 

Staff labels Player group labels now always correctly cover divisi staves that show no staff label, if 
required. 

Tempo Tempo marks are once again correctly shown in gray when playback is suppressed. 

Tempo Under some circumstances, changes on the Brackets and Braces page of Layout Options 

would not cause tempos to appear or disappear immediately at the expected system-attached 
item positions; this has now been fixed. 

Tempo When opening projects last saved in Dorico 5 or earlier, the notes in metronome marks are 
now always drawn at the correct size. 

Tempo Under some circumstances, edits to a tempo item could cause instability in the positioning of 
rehearsal marks at the same position; this has now been fixed. 

Tempo Tempo items created directly in the Tempo editor in the Key Editor no longer appear in the 

Used in This Flow section of the Tempo panel. 

Tempo When exporting text from the project, Dorico now correctly exports the visible abbreviated 
text for gradual tempos, if necessary. 

Text In a text frame with multiple paragraphs of text in different styles, if a paragraph ends up 
completely empty, the vertical space occupied by the paragraph would be incorrect, using the 
size of the following non-empty paragraph; this has now been fixed. 

Text Double-clicking a text frame after suppressing the dialog that allows you to choose what to do 
now correctly either opens Project Info or edits the frame as expected. 



 

 
Dorico 6.0.10 58 Dorico 6 Version History 

Component Issue 

Text Empty text frames showing borders but containing no text once again appear correctly when 
printing and exporting graphics. 

Text The minimum actual size for a text item is now clamped to 0.5pt; this prevents text items from 
snapping to a larger size when scaling them to very small sizes. 

Text Capsule and angled end rectangle borders are now positioned correctly for right-aligned text 
in frames. 

Text Under some circumstances, the preview in the Paragraph Styles dialog would not correctly 
show the inherited OpenType font features for the current style; this has now been fixed. 

Text Under rare circumstances, Dorico could remove text from text items that are updated to 
replace a missing font; this has now been fixed. 

Text If a paragraph style uses a non-default Case setting, token placeholders in that paragraph 

style could unexpectedly be included when printing or exporting graphics; this has now been 
fixed. 

Ties Under some circumstances when multiple voices are active, ties set to start after rhythm dots 
could instead start from the left-hand side of the notes in the first voice column; this has now 
been fixed. 

Time signatures Under rare circumstances, Dorico could crash when creating or deleting a time signature in a 
passage using interchangeable or alternating time signatures; this has now been fixed. 

Tuplets When a tuplet ends with a rest, but the rest is not shown because it is consolidated with a rest 
in a tuplet in another voice, the end position of the tuplet bracket is now correct. 

User interface The appearance of the controls in the Manual placement section of the Time Signatures page 

of Layout Options has been improved. 

User interface Dorico no longer sometimes crashes when scrolling through a layout containing divisi in 
galley view. 

User interface The information read-out in the status bar now shows the bar number of the selected item in 
more circumstances. 

User interface Clicking in the display area in the Edit Accidentals dialog no longer causes the accidental to 
disappear. 

User interface Interacting with the Key Signature and Accidentals panel after changing the application 

language in Preferences no longer causes a crash. 

User interface The list of flows shown in Override Flow Headings no longer includes flows that are not 
attached to the current layout. 
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Component Issue 

User interface The width of spin controls in the Properties panel has been improved (Windows only). 

Video Connecting or disconnecting an external display could cause a crash when a video file is 
attached; this has now been fixed (macOS only). 
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Dorico 6.0 
28 April 2025 

Highlights 

Proofreading 
We like to say that working in Dorico is like having an 

intelligent assistant at your side, taking care of many of the 

laborious details of producing a beautiful score, so you can 

focus on being creative. With the new proofreading features 

in Dorico 6, we are taking this further than ever. 

We have introduced an entirely new framework that allows 

Dorico to check your project for dozens of potential issues 
and report them to you in the new Proofreading panel in 

Write mode. These checks are run in the background when 

you are not actively working, so they have no impact on the 

performance of the application. 

The goal is to help identify possible issues that could cost you 

time when your music is rehearsed and performed by other 

people. Dorico can check for many common – and quite a few 

uncommon – situations and prompt you to consider making 

changes to address them. 

In this release, Dorico reports on the following categories of 

issues: 

§ Metrical problems, including irregular bars that don’t 
match the prevailing time signature, hidden time 

signatures, repeated time signatures, etc.; 

§ Superfluous or repeated markings, including key signatures, clefs, 

dynamics, and playing techniques 

§ Problems with instrument changes, including changes that are too quick to 

be practical 

§ Playability problems in music written for stringed instruments 

We plan to continue to expand on these checks in future updates and have many 
ideas for how to help make your music more successful in rehearsal and 

performance. 

Proofreading panel. The Proofreading panel is found in the toolbox on the right-

hand side in Write mode. The number of issues that Dorico is reporting for 

the categories and flows for which you have chosen to see results is shown in a red 
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badge at the bottom of its button. Click the button or choose Write ▶ Panels ▶ 

Proofreading to open the panel. 

At the top of the panel, the Categories list allows you to choose which types of 

results you want to see. To quickly find a category, type into the Filter field; click 

Select All or Select None to quickly include or exclude results from all categories. 

Click the Clear Filter button  to reset the filter and show results from all 

categories. 

The Flows list similarly allows you to choose from which flows you want to see 

results: click the Edit Flows button  to open a drop-down from which you can 

choose which flows to include. 

At the bottom of the panel, a label shows Proofreading complete if the results 

shown in the panel are up to date, or shows n categories pending if Dorico is 
waiting for you to stop working for a moment so it can run its checks in the 

background. 

Navigating through issues. Simply click a result in the Proofreading panel, and Dorico 

brings that area into view. If it can highlight a specific item or bar, it shows an 

animated purple rectangle for a second or so to draw your eye: click the result again 

to run the animation again if you didn’t catch it the first time. If the result is instead 

reporting on the absence of something (for example, a missing time signature or 

dynamic), Dorico instead shows an animated purple arrow pointing at the relevant 

position. 

Resolving issues. To resolve an issue shown in the Proofreading panel, edit the score to 
address the reported issue. If you decide not to act, simply ignore the issue: you 

cannot manually dismiss a result, because as you continue to edit the music, Dorico 

will check it again, and the result could reappear. You can hide entire categories of 

results using the Categories filter. 

Disabling proofreading. If you prefer Dorico not to run its proofreading checks on your 

projects at all, you can disable them altogether. Either deactivate Enable 

proofreading on the Proofreading page of Preferences, or click the small power 

button icon in the indicator at the bottom of the Proofreading panel that reports 
whether proofreading is complete or tasks are pending. You can re-enable 

proofreading by clicking again on the indicator when it reads Enable Proofreading. 

Proofreading for meter. When Dorico checks your project for potential issues concerning 

meter and time signatures, this is what it is looking for: 

§ Hidden time signatures. For example, in a passage where 4/4 is the 

prevailing time signature, there are multiple bars of 3/4, because a time 

signature change has been created but has been hidden. Dorico won’t 
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report a hidden time signature that has the same duration and 

denominator as the prevailing time signature. 

§ Repeated time signatures. For example, if the prevailing time signature is 

4/4, but suddenly another 4/4 time signature appears. 

§ Irregular bars. For example, if the bar immediately preceding a change of 

time signature is shorter than the prevailing time signature, as can happen 
in Dorico when you create a new time signature earlier in the flow without 

activating Insert mode; or if a bar is too long, because a barline has been 

inadvertently deleted. Dorico is careful not to report pick-up bars, since 

they are expected to be irregular. 

§ Misaligned repeat structures. For example, if local time signatures are in use, 

and conflicting repeat barlines appear in both the global and local contexts. 
§ Missing double barlines. Pick-ups at the ends of phrases are often marked by 

a mid-bar double barline, so a bar in the prevailing time signature may be 

split into two irregular bars. If Dorico finds a mid-bar pick-up that has a 

single barline, rather than a double barline, it suggests you add a double 

barline to aid legibility. 

§ Jumps to different time signatures. Although Dorico cannot yet automatically 
display cautionary time signatures in repeat structures to show that you are 

jumping back to a different meter, it can nevertheless report these 

situations to you so you can decide whether to make manual adjustments. 

Proofreading for repeated key signatures. Dorico will report any of the following 

situations as suspect: 

§ a duplicated key signature with the same semantics and accidentals as the 

one that preceded it: for example, a G major key signature following another 

G major signature; 

§ a duplicated key signature with the same accidentals but different 

semantics: for example, an E minor key signature following a G major key 
signature; 

§ a jump to a different key signature that isn’t qualified at the location of the 

jump. For example, in a passage of D major, and following a start repeat 

barline there is a change to A major; at the end repeat barline, you are 

repeating back to D major, but without a cautionary key signature at the end 

repeat, you would be unsure whether to continue playing G sharp. Dorico 
will not, however, warn when there is a key change coinciding with the start 

repeat, or when the start repeat coincides with the start of a system, where 

a key signature will be shown anyway; 

§ as above, but where the jump back is to a key signature with the same 

accidentals but different semantics, e.g. a jump from D major to B minor. 



 

 
Dorico 6.0 63 Dorico 6 Version History 

Proofreading for repeated clefs. Dorico checks for the following situations: 

§ a duplicated clef: for example, a treble G clef following another treble G clef; 
§ a jump to a different clef: for example, a start repeat barline occurs after a 

change to the alto clef, and before the end repeat barline, a further change to 

the treble G clef occurs. When you jump back to the start repeat barline, you 

are once again reading the alto clef, but without a clef coinciding with the 

start of the repeat region, this is ambiguous. Dorico won’t warn where a clef 

change coincides with the start repeat, or when the start repeat coincides 
with the start of a system, in which case the clef will be shown anyway; 

§ a clef is showing an octave indication that contradicts the transposition of the 

instrument on which it’s been used: for example, using the treble G clef with 8 

above on the oboe makes little sense as the oboe doesn’t transpose, nor does 

it make sense for guitar, which is written an octave higher than it sounds, but 

it would be fine (if redundant) on piccolo; 
§ a clef is showing an octave indication that makes sense for the instrument, 

but a clef appeared earlier on without that qualification, or vice versa: for 

example, a piccolo part starts with a simple treble G clef, but later on, a treble 

G clef with 8 above is used; 

§ a clef has been explicitly hidden via the Hide clef property; 

§ a suspicious clef has been used for the instrument in question: for example, a 
percussion clef being used on a pitched instrument, a tab clef being used on a 

non-fretted instrument, etc. 

§ a clef has a custom octave shift via the Octave shift property; this is unusual 

enough that Dorico will always warn about it. 

Proofreading for repeated dynamics. Dorico checks for the following situations: 

§ a dynamic is present at a position at which no note is present, or gradual 

dynamics that begin or end at positions where no notes are present; 

§ two (or more) dynamics that coincide with or overlap each other; 

§ needlessly repeated dynamics: for example,   followed by another , though 

Dorico is careful not to report repeated hairpins in the same direction, or 
repeated force dynamics such as , , etc.; 

§ ambiguous dynamics at the start of repeat regions; 

§ truncated gradual dynamics and hairpins: for example, a hairpin that lasts for 

two bars, but is truncated halfway through the second bar by the presence of 

an immediate dynamic; 

§ suspicious dynamics at the ends of hairpins: for example, a diminuendo 
hairpin ending in a louder dynamic than the previous prevailing dynamic 

level that is not qualified with subito; 
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§ a hairpin beginning or ending niente with another contradictory dynamic: for 

example, if a crescendo is marked both  and dal niente at its start, the  is 

redundant; 

§ no dynamic coinciding with the player’s first note or chord, unless the player’s 

music is completely devoid of dynamics, in which case the warning will not 

appear; 
§ no dynamic coinciding with the first note following an instrument change, 

unless (as above) the player’s part is completely devoid of dynamics; 

§ there are four or more empty bars preceding a new entry, and no dynamic 

marking is shown; 

§ a passage following a diminuendo to niente is missing a dynamic marking; 

§ a dynamic marking is present part-way through a note, not coinciding clearly 
with its onset. In such situations, it may be difficult to tell exactly where the 

change of dynamic should take effect; 

§ a gradual dynamic or hairpin ends at a rhythmic position that does not 

coincide with the end of note; 

§ either of the hairpins within a messa di voce has zero duration. 

Proofreading for repeated playing techniques. Dorico checks for the following situations: 

§ two identical playing techniques at the same position: for example, arco and 

arco; 

§ two contradictory playing techniques at the same position: for example, 

arco and pizz.; 
§ two synonymous playing techniques at the same position: for example, con 

sord. and with mute; 

§ two identical playing techniques, at least one of which has a duration, 

overlapping: for example, sul pont. and sul pont.; 

§ two contradictory playing techniques overlapping: for example, sul pont. 

and sul tasto; 
§ two synonymous playing techniques overlapping: for example, con sord. 

and with mute; 

§ a playing technique has a duration but shows no continuation line; 

§ a persistent playing technique is needlessly repeated: for example, arco 

followed by arco; 

§ a persistent playing technique is needlessly repeated as a synonym: for 
example, arco followed by nat. on violin; 

§ a persistent playing technique is repeated with less detail than its 

predecessor: for example, cup mute followed by con sord. on trumpet; 

§ the default playing technique for the instrument is stated at the start 

unnecessarily: for example, arco for violin. Dorico will look at the prevailing 
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playing technique at the end of the previous flow, if any, to decide whether 

to show this warning; 

§ if the prevailing playing technique at the end of the previous flow was not 

the default for the instrument, in which case Dorico will recommend adding 

the default playing technique at the start of the new flow; 

§ a playing technique has been used that is likely incompatible with the 
current instrument: for example, writing arco on flute; 

§ an ambiguous playing technique at the start of a repeat region: for example, 

a violinist might be playing arco before reaching a repeat region, then after 

the start repeat barline comes a change to pizz. After the jump back, it may 

not be clear whether they should now play arco or pizz.; 

§ an instantaneous technique is present at a position that doesn’t coincide 
with a note onset; for example, snap pizzicato; 

§ either the start, end, or the entirety of a playing technique with a duration 

does not coincide with a note onset, note end, or both, respectively; 

§ the technique to use at a change of divisi is ambiguous: for example, at the 

start of the flow, the violins are split into two sections, with one marked pizz. 

and the other marked arco. When the players return to playing in unison, it 

may not be clear whether they should all now play arco or pizz. 

Proofreading for instrument changes. When examining instrument changes, Dorico is 
looking for impractical or impossible instrument changes. It considers factors such 

as the size and portability of the instruments held by each player: for example, it 

takes less time for a player to place their flute on their lap in order to pick up their 

piccolo than it takes a double bass player to lay their instrument on the floor or rest 

it on a stand; similarly, when an instrument is stationary and the player is moving 

between them, such as a pianist moving to celeste, or a percussionist moving from 

marimba to glockenspiel. 

Dorico reports if the time between the end of the last note on the old instrument 
and the first note on the new instrument is likely to be too short for a comfortable 

change, or if in the worst case there is no time at all. 

Dorico also considers whether the two instruments in question could be played 

simultaneously and considers how many hands and feet the instrument requires to 

be played – not forgetting, of course, whether it needs to be blown. 

Finally, Dorico also warns if there is ambiguity about which instrument should be 

played after a repeat that jumps back to an earlier point in the flow. 

Proofreading for stringed instruments. This is the most complex of the categories, and 

involves detailed knowledge not only of human anatomy but also the physical 

properties of the instruments. It is difficult to calculate what kinds of chords will 

require painful or impossible stretches of the hand, considering the different 
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combinations of strings on which a chord may be played, and the different fingers 

that can be used to stop them. Dorico only has this most detailed level of knowledge 

for a handful of the most common instruments, including violin, viola, cello, double 

bass, various guitars and bass guitars, mandolin, ukulele, and banjo. 

We have consulted with professional string players to verify our research, asked 

them to play all manner of difficult chords, and have listened to their feedback. 

The result is that Dorico can provide warnings about many situations that 

otherwise would require consultation with an experienced player of that 

instrument. The warnings should be considered only as advisory, and if you are 

unsure about anything, consult your own friendly neighborhood string or guitar 

player to ask their advice. 

With all that said, Dorico checks for the following situations: 

§ Impossible stretch: the chord requires the fingers to be contorted or 

stretched into a shape that isn’t viable. 
§ Impossible stretch using specified string(s): as above, but the chord is 

playable, just not on the string(s) specified via properties. 

§ Questionable stretch: the chord might be stretchable, but it’s at the verge of 

playability. 

§ Two or more notes require the same string: for example, imagine a chord of 

G3 and B3 written for violin; both these notes can only be played on the G 
string, so it’s impossible. 

§ Two or more notes require the same string using the specified string(s): as 

above, but the notes would be playable on other strings; the strings specified 

via properties make this impossible. 

§ Too many pitches in chord: for example, writing a five-note chord for violin. 

§ Impossible harmonic: the written harmonic can’t be produced on the 
instrument: for example, asking a violinist to play middle C as a harmonic. 

§ Impossible harmonic using specified string(s): as above, but the harmonic 

would be playable on another string; the string(s) specified via properties 

make this impossible. 

§ Dubious number of natural harmonics present: this is specific to the 

harmonic circle shown above the chord, and warns when the number of 
harmonic circles doesn’t match the number of notes in a chord; this 

warning only considers harmonics created by setting the Harmonic 

property, not those created as explicit playing techniques. 

§ Impossible fingered tremolo: although it is a little crude, this considers all the 

pitches in the tremolo as if they were a single chord and warns if the chord 

requires too many fingers or an impossible stretch. 
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§ Requires use of thumb: on cello and double bass only, Dorico allows the use 

of the thumb on the left hand, but warns about it, as it’s not something the 

player can do without preparation and time to reposition their hand. 

§ Requires use of thumb with questionable stretch: as above, but the stretch 

between the thumb and other finger is extreme. As such, the chord might be 

stretchable, but if it is, it’s at the verge of playability. 
§ Cannot play snap pizzicato with other techniques: a warning that one or more 

notes are to be played snap pizzicato, but there are others in the same chord 

that require other techniques. 

§ Difficult to play dyads using snap pizzicato: a warning that snap pizzicato is 

possible on two adjacent strings, but it’s not particularly easy. 

§ Cannot play snap pizzicato on more than two strings: a chord is written with 
snap pizzicato comprising more than two pitches; this is not playable. 

§ Cannot play snap pizzicato on non-adjacent strings: a dyad is to be played 

snap pizzicato, but the two strings required to play the dyad aren’t adjacent; 

this is not playable. 

§ Cannot play snap pizzicato on specified non-adjacent strings: as above, but 

the dyad would be playable on another two strings; the strings specified via 
properties make this impossible. 

§ No finger left to perform left hand pizzicato: the chord requires the use of all 

four fingers on the left hand, but in addition a left-hand pizzicato marking is 

present; this is not playable, as there are no spare fingers left to do this. 

Cutaways 
Cutaway scores – also sometimes called scrapbook scores, or sparse scores – arose 

out of the avant garde musical practices of the 1950s and 1960s. There is some 

debate as to where the practice was first used, but Witold Lutosławski’s Jeux 

Vénetiens (1961) is one of the earliest examples. The practice was adopted by many 

composers around this time, including Ligeti, Berio, Penderecki, Xenakis, and 
Stravinsky. The following are the opening bars of the latter composer’s Requiem 

Canticles (1966): 

 

  
più che gli altri Vlns.


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The defining feature of a cutaway score is that when instruments are silent, their 

staves are not shown: they are literally cut away, leaving only white space, and 

creating a fragmented appearance. Proponents of the practice believe that it 

improves the readability of scores for large ensembles, especially in music with 

discontinuous or pointillistic texture, making it easier to focus on the key musical 

gestures and interactions – though there is debate about this, with other significant 
figures in the avant garde movement, including Pierre Boulez and Elliott Carter, 

being critical of their use. Some composers even use these approaches even in 

music for soloists, such as Iannis Xenakis’s Evryali for solo piano. 

This approach is certainly not suitable for every kind of score, but it has undeniably 

been influential over the past more than half a century, and Dorico 6 now includes 

comprehensive and sophisticated tools to produce cutaway scores. 

Enabling cutaways. Dorico can produce cutaway scores completely automatically, 

providing a good appearance by activating a single option. Of course, you can exert 

complete control over every aspect of the score’s appearance, but to get started, 

simply activate Automatically cut staves away in empty bars in the new Cutaways 

section of the Staves and Systems page of Layout Options. 

When this is activated, the following option Minimum number of empty bars 

before cutting away takes effect: the default value is 1, which means that Dorico 

will cut a staff away at the barline at the start of the first empty bar in an instrument. 

By default, Dorico will only cut away an instrument when all its staves contain bar 

rests: if you want to allow a grand staff instrument, such as a piano, to be cut away 

when only one of its staves has a bar rest, activate Allow each staff of grand staff 

instruments to be cut away independently. 

Cutaways are only visible in page view: in galley view and fill view, they are not 

shown. 

Automatic cutaways can not be used in layouts where multi-bar rests are visible. 

Editing music in a cutaway score. When a staff is cut away, it is still possible to input 

music there, which will cause the automatic cutaway points to be recalculated. By 

default, Dorico shows gray staff lines in cutaways, to show you where the staves are 

vertically on the page, and allowing you to double-click to show the caret and input 

music. 

These gray staff lines do not print and will be hidden when you hold down ~ to hide 

all invisible items. To hide them altogether, deactivate View ▶ Cutaway Staff Lines. 

Creating manual cutaways. You can create cutaways manually, regardless of whether 

Automatically cut away staves in empty bars is activated. By default, and 
matching most published examples, Dorico only automatically cuts away a staff at a 
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barline, so if you want a staff to be cut away in the middle of a bar, this requires 

manual intervention. 

Similarly, if you want a staff to be cut away at the same position as another 

instrument, for example one in the same family, but material in each staff starts or 

stops in different bars, you will need to create manual cutaways to make them 

match. 

You can create both a manual cutaway start, which defines the position at which a 

staff becomes cut away, and a manual cutaway end, defining the position at which a 

staff reappears. 

To create both a manual cutaway start and end, first select an item at the position 

where you want the staff to stop, and another item at the position where you want 

the staff to reappear, then right-click to show the context menu, and from the Staff 

submenu choose Create Manual Cutaway. 

To create a manual cutaway start or end only, select an item at the relevant position 
on one or more staves, right-click, and from the Staff submenu in the context 

menu, choose Create Start Cutaway or Create End Cutaway. Manual cutaways are 

represented by signposts, which you can copy and paste, move to different 

positions, and delete. 

If you create a cutaway end before a staff that is cut away due to automatic behavior 

would reappear, the staff will reappear at your chosen cutaway end position. 

To override this behavior, such that the staff will either remain cut away or shown 

until the next manual cutaway, ignoring any automatic points at which Dorico 

would otherwise have cut away the staff or shown it again, select the cutaway 

signpost and activate Applies until next manual cutaway change in the Cutaways 

group in the Properties panel. 

By default, manual cutaways apply to all staves of an instrument: change this by 

deactivating the Applies to all staves property. 

Be aware that if automatic cutaways are disabled, when you create a cutaway start, 
the rest of the staff will be cut away, and you will need to create a cutaway end to 

make it reappear. 

If you want to quickly select and delete all manual cutaways in your project, you can 

use the dedicated quick filter, Edit ▶ Filter ▶ Cutaways. 

Staff line protrusion. By default, Dorico extends the staff lines beyond the cutaway start 

point by 1 space. You can adjust this via the Staff line protrusion at start of 

cutaway n spaces option on the new Cutaways page of Engraving Options. 
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If you prefer Dorico to also extend the staff lines to the left of the cutaway end point, 

you can adjust Staff line protrusion at end of cutaway n spaces. 

A new Staff line protrusion property has been added, allowing you to override the 

amount by which staff lines protrude at manual cutaway starts and ends. Select the 

cutaway signpost in Engrave mode to find the property in the Cutaways group. 

Appearance at the start of the system. In some cutaway scores, the so-called preamble 

for each instrument (its staff label, clef, etc.) is shown even if the staff is cut away at 

the start of the system; in others, only those staves that are playing at the start of 

the system show their preamble. 

Use the Starts of systems with cutaways option on the Cutaways page of 

Engraving Options to choose between these different approaches: 

 
Both With brackets and solid systemic barline shows a preamble for every staff, so 

that all staff labels and clefs can be found at the left-hand margin. 

When any of the other three options is chosen, when a staff is cut away at the start 
of the system, its preamble is shifted to its first appearance on the system. These 

preambles do not take up rhythmic space, and protrude into the rhythmic space of 

the preceding cutaway. 

System items and cutaways. System items, such as tempo, rehearsal marks, time 

signatures shown above the staff, etc., will by default appear above the first visible 

staff if the staff above which they would ordinarily appear is cut away. 

You might prefer to keep such items at a consistent vertical position across the full 

width of the system, regardless of cutaways, in which case you should activate 

Show system-attached items above cutaways in the Cutaways section of the 

Staves and Systems page of Layout Options. 

Similarly, if you are showing bar numbers at positions other than the start of the 

system, you might find it helpful to see them at the same vertical position across the 

full width of the system: if so, activate Show bar numbers above cutaways. 

Staff labels. When staff labels are shown at the first appearance of an instrument in the 
middle of the system, there may be no bracket shown at that position, in which case 

the staff label should be positioned closer to the left-hand end of the staff. To 
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accommodate this, the options on the Staff Labels page of Engraving Options for 

the gaps between outer and inner staff labels and the systemic barline now have 

separate values for With brackets and Without brackets. 

In new projects, the Without brackets option is set to a smaller value than With 

brackets, but to preserve the appearance of existing projects, the values are set 

identically when opening projects last saved in a previous version. 

Player group labels. If players are grouped in the Players panel in Setup mode, and player 

group labels are shown, Dorico will try to consolidate group labels for players in the 

same group, even if they first appear on a system at different positions. Provided 

the cutaways end within less than half the width of the system, Dorico will prefer to 
create a player group label at the earliest possible position on the system, even if 

one or more of the players in the group does not appear at that position. 

Coordination lines 
Coordination lines – sometimes also called synchronization lines, or time 
alignment lines – are vertical lines that indicate the alignment of musical events 

happening in different instrumental parts. They are often, though not exclusively, 

used in cutaway scores, such as in Stravinsky’s Requiem Canticles (1966): 
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Dorico can display coordination lines between any pair of staves, and they can be 

positioned either relative to notes at any rhythmic position, or at barlines, where 

they can be aligned either to the barline itself, the time signature if present, or the 

note, chord, or rest at the start of the bar.  

Creating a coordination line. Coordination lines are created in Engrave mode, because 

they are specific not only to the layout in which they are created, but also the frame 

chain. In addition, it’s common for coordination lines to be aligned with barlines, 

and it is only possible to select individual barline sections that span different staves 

in Engrave mode. 

Select a note or barline on the staff where the top of the coordination line should 
appear and click Create Coordination Line in the left-hand panel in Engrave mode, 

or right-click and choose Staff ▶ Create Coordination Line. You can also use the 

jump bar. 

The new coordination line is drawn from the selected staff to the next visible staff. 

To adjust which staves are joined by the coordination line, switch to Write mode: 

the coordination line has circular handles at each end, and these can be dragged to 

the staff above or below. 

Changing the appearance of coordination lines. By default, coordination lines are drawn 

using a dashed line. You can choose which line style is used on the new 

Coordination Lines page of Engraving Options. 

Because coordination lines are often drawn at barline positions, by default 

whichever line style you choose will have its width adjusted to match the Thin 

barline thickness value on the Barlines page of Engraving Options. If you want to 

disable this width adjustment, deactivate Use barline width if applicable on the 

Coordination Lines page. (This does not apply to lines drawn with repeatable 

symbols or tapered curves.) 

Coordination lines are sometimes drawn with arrowheads at either or both ends. If 

you choose a line style with an arrowhead or other terminal symbol, and find that it 

appears at the wrong end of the coordination line, activate the Reverse checkbox. 

You can also override the appearance of any selected coordination line via the 

Properties panel: activate the Line style property to choose a different line style, 

and again you can Reverse it if necessary. 

Alignment of coordination lines. By default, when a coordination line is at a barline 

position, it is centered on the barline. On the Coordination Lines page of Engraving 
Options, you can specify whether coordination lines should be drawn on the barline 

or on the first note, chord, or rest in the bar; if drawn at the barline, whether it 

should be aligned with the barline itself, or with a time signature, if one is present; 
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and if drawn at a note position, whether it should be left- or center-aligned with the 

notehead. 

Each of these alignment options can also be overridden using corresponding 

properties in the Coordination Lines group in the Properties panel. 

Graphical adjustments in Engrave mode. In Engrave mode, you can nudge a selected 

coordination line left or right to change its horizontal position, and square handles 

appear at each end, inset slightly to avoid colliding with the handles on barlines, 

allow you to make fine adjustments to the position of each end of the line. 

Coordination lines always remain vertical, so it is not possible to adjust the 

horizontal position of either end independently. 

Multiple lines of chord symbols 
It is sometimes necessary to show more than one line of chord symbols, for 

example to show alternate harmonies, as seen here in the first few bars of Joseph 

Kosma’s Autumn Leaves: 

 
Dorico 6 now makes it easy to create multiple lines of chord symbols. In the Shift+Q 

popover, press ↑/↓ to set the line number, which is indicated in the label at the left-

hand side. 

Changing the line for a chord symbol. If necessary, you can also change the line of an 
existing chord symbol, either by changing Chord symbol line in the Chord Symbols 

group in the Properties panel, or by right-clicking and choosing the target line from 

the Chord Symbols and Diagrams submenu in the context menu. 

Distance between lines. The default distance between lines of chord symbols can be 

adjusted by changing Distance between adjacent lines of chord symbols in the 

Position section of the Chord Symbols page of Engraving Options. 

Playback. Only the first line, closest to the staff, appears in the Chords track in Play mode 

and will play back. 

Chord symbol extender lines 
Chord symbols can now have their duration edited, either by clicking immediately 

to the right of the chord symbol in Write mode to reveal a circular handle that can 

be dragged to show a extender line; or lengthened or shortened using 

Shift+Alt+←/→. 



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Chord symbol extender lines extend from the right-hand side of the chord symbol 

and are truncated by the next chord symbol in the same line. 

By default, a solid line with an inward hook is used, but this can be changed in the 

Extender Lines section of the Chord Symbols page of Engraving Options, and it can 

also be overridden for an individual chord symbol via the new Extender line style 

property. 

Further properties are provided in Engrave mode for adjusting the vertical position 

of the extender line relative to the chord symbol, and for fine positioning of the end 

of the extender line. 

Editing chord symbol appearances 
Dorico provides dozens of options to tweak the appearance of chord symbols via the 

Chord Symbols page of Library ▶ Engraving Options. Nevertheless, it is sometimes 

necessary to adjust specific chord symbols to achieve a particular appearance. 

Dorico 6 introduces powerful new features for customizing existing chord symbols 

and even creating your own entirely new custom chord symbols. But before we 

describe these new features in detail, because Dorico now provides so many ways 
to edit chord symbol appearances it is worth summarizing the recommended way 

to work with these interlocking features. 

As you learn about these features, you may find it helpful to create a simple scratch 

project that contains a representative set of chord symbols so you can see how your 

edits take effect. We also recommend that you decide at the outset which text and 

music fonts you want to use for your chord symbols. Before you make further 

customizations, use Library ▶ Font Styles and edit the Chord Symbols Font and 

Chord Symbols Music Text Font font styles. 

Once you have created a project that includes a range of chord symbols and in 

which you have chosen your preferred fonts, we recommend working in this order: 

§ Choose the Chord symbol preset at the top of the Chord Symbols page of 

Engraving Options that gets closest to your preferred appearance. 
§ Carefully examine the individual options on the Chord Symbols page to 

bring specific chord symbols as close as possible to your preferred 

appearance. 

§ Check the Design section of the Chord Symbols page to adjust the offsets 

and scale factors for various components, as these can have a dramatic 

impact on the overall appearance of chord symbols, particularly when using 
different fonts. 

§ After you have exhausted the possibilities of the Engraving Options dialog, 

if you are unhappy with the precise horizontal spacing of individual 
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components, use the Library ▶ Chord Symbol Kerning Pairs dialog (new in 

Dorico Pro 6) to adjust these kerning pairs – see Chord symbol kerning 
pairs below. 

§ Next, use Library ▶ Chord Symbols to adjust the appearance of whole chord 

symbol appearances, or individual components. There are new features in 

Dorico 6 to make this more powerful, described below. 
§ Finally, if you want to adjust the appearance of an individual chord symbol 

for a specific context – for example, where you need a narrower, more 

compact chord symbol in a series of rapid changes – double-click the chord 

symbol in Engrave mode to override the appearance of that single instance. 

If you discover that there is a specific type of chord symbol that you cannot create at 

all, Dorico 6 introduces a new way to create completely custom chord symbols – see 

Custom chord symbols below. 

Editing default chord symbol components. Library ▶ Chord Symbols allows you to edit the 

appearance of individual components within chord symbols, and entire chord 

symbols. A component is a single element of a chord symbol, such as the root note 

name, chord symbol quality, interval, individual alteration, parenthesis, and so on. 

To edit an individual component, enter a chord symbol that contains the 
component in the field at the top of the dialog, or choose one of the existing saved 

default chord symbols from the list on the left. In the main editing area, select the 

relevant component: it is highlighted in the row of compatible components below 

the editing area. Click the Edit Component button  in the action bar to open the 

symbol editor: any changes you make in this editor will be reflected in all chord 

symbols where that component is used. 

If you know you want to edit the component in a way that does not affect any other 

chord symbols, click Add Component  to create a new component based on the 
selected one. This new component will be saved to the project library, but will not be 

used in any chord symbols by default, unless you explicitly choose it from the row of 

compatible components when editing another chord symbol. 

Editing default chord symbol appearances. Editing an entire chord symbol appearance 

normally involves two aspects: choosing which components should be used; and 

determining how they should be positioned and scaled relative to one another. 

To choose which components are used, select each component in the editing area 

in turn: the row of compatible components below the editing area shows 

alternatives, and you can simply select another component from the row to replace 

the current one, editing it if necessary, or create a new one. 
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To adjust the overall appearance of the chord symbol, select each component in the 

editing area and adjust its relative position and scale either with the mouse, or 

using the X offset, Y offset, and Scale controls at the bottom of the dialog. 

By default, any change you make in this dialog affects only the specific chord 

symbol you are looking at: for example, if you are editing “Gmaj7”, any changes you 

make will not apply to, say, “G♭maj7” or “Amaj7”. This is where Dorico 6’s new chord 

symbol appearances for all roots come into their own. 

Chord symbol appearances for all roots. To make the changes you have made to the 

appearance of a chord symbol in Library ▶ Chord Symbols apply to every root note, 

click Apply to All Roots in the action bar at the bottom of the list on the left-hand 
side of the dialog. You will be warned that this operation cannot be undone: if you 

choose to proceed, the root note in the editing area turns gray and can no longer be 

selected. Two new buttons, Prev root and Next root, appear at the top of the dialog, 

allowing you to cycle through different root notes, to check how your custom 

appearance looks on a variety of roots. 

Once you are satisfied with your chord symbol appearance for all roots, click OK to 

confirm the dialog. All chord symbols of the same type, on any root, is updated to 

use your new appearance, unless that chord symbol has already been individually 

overridden. 

Italic appearances. Chord symbols may be shown in italics if Capo chord symbol 

appearance is set to In italics on the Chord Symbols page of Engraving Options. 

Library ▶ Chord Symbols now allows you to view these different appearances by 

choosing them from the new Appearance toggle buttons above the editing area: 

 
If you want to tweak the italic appearance independently of the normal appearance, 

deactivate the Synchronize with normal appearance checkbox, and the chord 

symbol becomes editable in the editing area below. 

It is not possible to edit the placement of the parentheses relative to the chord 
symbol appearance: the size and position of the parentheses is always determined 

by the relevant settings in Engraving Options. 

Custom chord symbols 
Dorico’s approach to chord symbols, in common with its approach to all other 
aspects of music notation, is semantic. It is concerned not only with how the chord 

symbol should appear, but also its musical content and meaning: the intervallic 

relationship between the notes, and their function. This allows Dorico to choose an 

appropriate chord diagram for every fretted instrument, to play back the chord 

symbol, and to use the chord symbol as the basis for generating musical material. 
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One consequence of this semantic approach, however, is that it is not possible to 

paint outside the lines of Dorico’s understanding of the function and structure of 

chord symbols, and given the almost infinite variety of chord symbols in use (as the 

saying goes, the wonderful thing about standards is that there are so many of them), 

some chord symbols were hard to create. 

To address this, Dorico 6 introduces the ability to define a custom chord symbol: 

specify a pattern of intervals relative to a root, define its graphical appearance, and 

specify the text you need to enter in the Shift+Q popover to create it. 

Defining a custom chord symbol. To get started, choose Library ▶ Chord Symbols. In the 

Enter a chord symbol field in the top left, type the chord symbol you want to edit, in 
the way you would specify it in the Shift+Q popover: there’s a good chance that what 

you type will map onto an existing chord symbol that Dorico already supports, in 

which case that is what you will see. If, however, you type something that Dorico 

doesn’t recognize, it will prompt you to create a custom chord symbol: click OK, and 

the Create Custom Chord Symbol dialog appears: 

 
In the Chord Symbol Name section, specify the Name for your new custom chord 

symbol; this is the name that will appear in the list in Library ▶ Chord Symbols. 

Popover text defines what you must type into the popover to create this chord 

symbol: what you specify here does not include the root. So, for example, if you are 
creating a “sus6” chord (whatever such a fantastical beast might be), Popover text 

might be sus6, and in the popover you would type, say, C#sus6 to create a “sus6” 

chord on a root of C♯. 
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To define the intervals in the chord symbol, you can either specify them from 

scratch or start from an existing chord symbol. When starting from an existing 

chord symbol, you can specify any root you like: the custom chord symbol you 

define here can be expressed relative to any root, and you can transpose the whole 

chord symbol up or down using the buttons in the action bar at the bottom of the 

dialog. 

To add an interval to the custom chord symbol: 

§ Choose the interval from the two drop-downs above the keyboard display, 

and click Add Interval; or 

§ Click on keys in the keyboard display to add or remove that note from the 
chord symbol; or 

§ Click MIDI Listen and then play a chord on your MIDI keyboard. 

In the keyboard display, the root of the chord is indicated with a red dot; the other 

notes are then expressed as intervals above that root. Each interval is also shown in 

the list on the right-hand side, and you can cycle through the different ways of 

expressing the interval enharmonically by clicking the button  in the action bar at 

the bottom of the list. 

When you confirm the Create Custom Chord Symbol dialog, you are returned to 

the Library ▶ Chord Symbols dialog, where you can edit the appearance of your new 

custom chord symbol. 

Chord symbol kerning pairs 
Kerning is the adjustment of space between individual letters to improve readability 

and visual balance in typography. Digital fonts include tables that specify kerning 

pairs, the precise horizontal position between a pair of two characters when they 

appear next to each other in text. 

In Dorico, chord symbols also employ kerning, but with the twist that adjacent 
characters in a chord symbol may come from different fonts. Chord symbols are 

drawn using characters from two font styles: Chord Symbols Font specifies the font 

used for the text parts of chord symbols, such as the root note (C, D, E), quality (min, 

maj, aug), interval and alteration numbers, etc.; Chord Symbols Music Text Font 

specifies the font used for the symbol parts, such as accidentals, the triangle 

sometimes used for major sevenths, the circle and slashed circle used for 

diminished and half-diminished chords, etc. 

Because two adjacent characters in a chord symbol may come from different fonts, 
and because the characters may also have unusual placement (the character on the 

right may be offset vertically, or scaled to a different size, or both), using the built-in 
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kerning tables in fonts is insufficient to provide the fine control required to produce 

chord symbols with perfect kerning. 

Dorico therefore uses its own special kerning table to define the kerning between 

pairs of components used in chord symbols, but this kerning table was built with a 

single pair of fonts in mind: Academico for the text parts of chord symbols, and 

Bravura Text for the symbol parts. As such, when you use different fonts for chord 

symbols, the fixed values from Dorico’s built-in kerning table will often produce 

less optimal results. 

To address this, Dorico 6 introduces a new editor for chord symbol kerning pairs, 

allowing you to define your own kerning tables for any pair of fonts, and make fine 

adjustments to the horizontal positioning of any pair of chord symbol components. 

To get started, double-click a chord symbol in Engrave mode; this now opens the 
kerning pairs editor by default, instead of the chord symbol appearance editor. To 

change this default, set Double-click on a chord symbol in Engrave mode opens to 

Appearance Editor on the Note Input and Editing page of Preferences. 

Alternatively, choose Library ▶ Chord Symbol Kerning Pairs. This dialog appears: 

 
Defining a new kerning table. The list on the left of the dialog shows the kerning tables 

that are available. To create a new table for a new combination, select one of the 

existing kerning tables from the list, and click + in the action bar. A simple dialog 

appears in which you can choose the family and style for the Text font and Music 

font: 
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The new kerning table will include all the pairs defined in the existing kerning table 

and provides a starting point for further editing. 

Choosing kerning pairs to edit. Type a full or partial chord symbol into the edit control at 

the top of the dialog: the chord symbol appears in the editing area below. 

In the editing area, two components of the chord symbols are shown with a light 

blue background, and the right-hand shaded component additionally has a blue 

outline. This indicates the component that will be moved if you use the key 

commands Alt+←/→. You can alternatively drag the component left and right with 

the mouse or enter a numeric value into the spin control below the editing area. To 
reset the kerning value for the selected pair, click Reset in the bottom right of the 

dialog. 

Three small preview panels below the editing area show how the chord symbol 

appears at different sizes, providing feedback on the impact of the kerning changes 

you are making. 

The three sets of paddles at the top right of the dialog allow you to cycle through 

different chord symbol components, so you can quickly check the kerning between, 

say, different roots and the “m” component for a minor chord: 

§ Root (shortcut ↑/↓) changes the root note 

§ Quality (shortcut Alt+↑/↓) cycles between major, minor, diminished, 

augmented, dominant seventh, etc. 

§ Interval (shortcut Ctrl+↑/↓ (Windows) or Command+↑/↓ (macOS)) cycles 

between seventh, ninth, eleventh, thirteenth, etc. 

Editing the kerning for stacked components. When a chord symbol contains stacked 
components – for example, a polychord, or a chord symbol with stacked alterations 

– hit I or double-click a component in the editing area to edit it in more detail. For 

stacked alterations, you can further double-click each alteration individually to edit 

the kerning between the accidental and the digits. 

Above the editing area, you will see a “breadcrumb trail”: 
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Hit O or click any of the buttons in the trail to move back up through the hierarchy 

of components. 

Using chord symbol kerning pair tables. Dorico looks for a chord symbol kerning pair 

table that matches the font family and style defined for the Chord Symbol Text Font 

and Chord Symbol Music Text Font font styles currently in use. If it cannot find a 

matching table, it falls back on the default table for Academico and Bravura Text. 

Separate tables are provided for italic fonts, which are typically only used if capo 

chord symbols are set to be drawn using italics. 

Saving chord symbol kerning pair tables as defaults. To save changes to one of the default 

tables, or to make your own custom table available in all future projects, click the 

star button  in the action bar: when the star is filled, the selected table is saved in 

the user library; when it is shown as an outline, the selected table is not saved in the 

user library. 

You can also update the chord symbol kerning pair tables in an existing project 

using the Library ▶ Library Manager dialog. 

Condensing 
Players holding multiple instruments. In previous versions of Dorico, only one 

instrument held by each player could be condensed; normally, this was the first 
instrument held by the first player in the condensing group, and then the matching 

instruments held by other players in the group, whether or not it is the first 

instrument held by subsequent players. 

Now, however, Dorico will allow other instruments held by each player to 

participate in condensing. For example, if two clarinet players each hold 

instruments in B♭ and in A, Dorico will allow both pairs of clarinets to be condensed, 

provided the matching instruments are played by each player at the same time: a B♭ 

clarinet will only condense with another B♭ clarinet. Of course, the music will only 

condense if all the other conditions for condensing are met. 

To enable this new functionality, activate the new Allow instrument changes on 

condensed staves option in the Condensing section of the Players page of Layout 

Options. This option is activated by default in new projects, but deactivated in 

existing projects to preserve their appearance. 

Transposition only labels. A new Show only the change of transposition when 

instruments match option has been added to the Instrument Changes section of 

the Players page of Layout Options. When activated, if a player changes instrument 

to a similar instrument with a different transposition ‒ for example, clarinet in B flat 

to clarinet in A ‒ then the instrument change label will read simply “in A” or “in B♭”, 

omitting “Clarinet.” 
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Cycle playback 
Cycle playback allows you to loop a section of one of the flows in your project during 

playback. 

Cycle locators. The section that will loop during playback is defined by the cycle locators, 

which are shown when View ▶ Cycle Locators is activated. By default, the cycle 

locators are set to the start of the flow, and are colored gray when cycle playback is 

disabled: 

 
You can click and drag the triangle handle at the top of each locator to move it. 

Alternatively, you can set the locator positions using commands in the Play ▶ 

Locators submenu: 

§ Set Cycle Locators From Selection sets the left locator at the position of the 

earliest selected item, and the right locator at the end of the latest selected 
item. 

§ Set Left Cycle Locator sets the left locator at the position of the earliest 

selected item. 

§ Set Right Cycle Locator sets the right locator at the position of the latest 

selected item. 

§ Clear Cycle Locators resets both the left and right locators back to the start 

of the flow. 

Each of these commands can also be triggered via the jump bar and can have 
custom shortcuts assigned via the Key Commands page of Preferences. If cycle 

locators were not already shown, setting the position of either or both locators will 

activate View ▶ Cycle Locators. 

When cycle playback is enabled, the locators are colored purple: 
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You can adjust the active and inactive colors for cycle locators on the Colors page of 

Preferences if required. 

Cycle locators are also shown in the ruler in the Key Editor in the lower zone in 

Write and Play modes, and in the track overview in Play mode. You can drag the 

locators left and right in the ruler in the same way you can drag them in the score. 

Activating cycle playback. To activate cycle playback, choose Play ▶ Cycle, or click 

the Cycle button (shown on the right) in the mini transport on the toolbar, or 

in the Transport window if it is shown. 

During playback, you can edit the music in the section between the locators, and 

you will hear the edits on the next cycle. 

Limitations. There are some limitations with cycle playback in this release: 

§ If your flow has an attached video, the video soundtrack will not cycle 

correctly. 

§ If you are using Groove Agent SE or another plug-in that relies on the 

synchronization of playback position and tempo, the playback from that 

plug-in will not cycle correctly. 
§ If you record while cycling is enabled, the music you record will be inserted 

into the flow ignoring the cycle locators. 

We plan to address these limitations in future versions. 

Fill view 
Dorico 6 introduces a new type of view to accompany page view and galley view, 

called fill view. While page view shows the music laid out on pages exactly as it will 
be printed, and galley view shows the music on a single, continuous system, fill view 

(as its name suggests) shows the music in multiple systems sized to the width of the 

music area, allowing you to scroll vertically to proceed through the flows. 

Fill view is best for layouts with up to a few instruments, and for those kinds of 

ensembles, it can make more efficient use of the available space on your display. 

The settings on the Vertical Spacing page of Layout Options for the minimum gaps 

between staves within the system are used in fill view. A new option Inter-system 

gap in fill view determines the distance between systems in fill view. 

Because fill view, like galley view, does not use the real dimensions of the page size 

defined for the layout, condensing is not displayed. However, empty staves will be 

automatically hidden in fill view, following the settings on the Vertical Spacing page 

of Layout Options. 

Like galley view, fill view can only be used in Setup and Write modes; when you 

switch to Engrave mode, Dorico will automatically switch to page view. 
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To switch to fill view, you can do any of the following: 

§ Choose View ▶ Fill View 
§ Use the default shortcut Ctrl+Alt+3 (Windows) or Command-Alt-3 (macOS) 

§ Click the Fill View toggle button towards the right-hand end of the status 

bar at the bottom of the project window. 

Bar numbers. A new command View ▶ Bar Numbers ▶ Fill View has been added, allowing 

you to choose whether bar numbers should be shown on every bar in fill view. 

Cycling or toggling between view types. With the addition of fill view, the Toggle View 

Type command from previous versions has been replaced by three new commands: 

§ Cycle View Type cycles through page view, galley view, and fill view 

§ Toggle Page and Galley View toggles between page view and galley view 

§ Toggle Page and Fill View toggles between page view and fill view 

These commands can all be found in the View category in the Key Commands page 

of Preferences, and can be triggered via the jump bar. 

Default view type. It is now possible to specify fill view as the default view type on the 

General page of Preferences. 

System-attached items 
By default, system-attached items – including tempos, system-attached text, 

rehearsal marks, repeat ending lines and repeat markers – appear above the top 

staff of the system, and optionally above the staff corresponding to the first 

instrument in the first bracket for the specified instrument family. 

If you require greater flexibility in determining where system-attached items 

appear, Dorico 6 now allows you to specify which types of system-attached item 

should appear above the first staff belonging to specific players. 

A new Show system-attached items above option has been added to the System-

attached Items section of the Staves and Systems page of Layout Options. For the 
default behavior, choose Families, and to enable the new behavior, choose Specific 

Players. 

When Specific Players is chosen, in place of the list of families above which system-

attached items should appear, a table is shown with a row for each player in the 

layout, and columns for each type of system-attached item. Simply activate the 

checkbox for each type of system-attached item for the players above which you 

want them to appear. 

If no staves belonging to the player above whom a type of system-attached item is 

set to appear are visible, Dorico will instead show that type of system item above the 
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next player in the score order, unless there isn’t one, in which case it will show them 

above the previous player in the score order. 

Large time signatures 
Dorico can display large time signatures either above particular staves in the 
system – as defined by the System-attached Items section of the Staves and 

Systems page of Layout Options (see System-attached items above) – or crossing 

multiple staves. For the former, on the Time Signatures page of Layout Options, set 

Time signature position and size to Show above staves, and for the latter, choose 

Show once per bracket. 

When using Show once per bracket, Dorico has in the past not provided any 

further options to influence where the time signatures appear. In Dorico 6, it is now 

possible to exercise complete control over the placement of large time signatures. 

To use Dorico’s default behavior, where a large time signature is added to the first 

bracket belonging to each instrument family, set Large time signature behavior to 

Automatic. To configure the placement of large time signatures, choose Manual. 

 
When you first click Manual, Dorico will automatically populate the Large time 

signature groups list based on the brackets shown in the layout. A large time 

signature will be shown for each group. The Time Signatures column shows the 

first and last instruments in each group, while the Vertical alignment column 

shows whether the time signature will be aligned with the top, center, or bottom of 
the group. To edit the vertical alignment, double-click the alignment field for each 

row, and choose the desired alignment from the drop-down menu. 

To change the automatically created groups, select them in the right-hand list and 

click the Delete button in the action bar to return them to the Players list. Select 

players in the Players list and click the + button in the action bar to create a new 

group, which removes them from the list. 

Rulers and grid 
Rulers. Dorico 6 now includes rulers in Engrave mode, enabled via Engrave ▶ Rulers. The 

rulers follow the preferred measurement unit as defined on the General page of 
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Preferences. As you move the mouse pointer over the page, the distance from the 

top left corner of the page is shown in a live label on the ruler, allowing you to 

determine the precise placement of each item on the page. 

The origin for the ruler is now reset at the start of each new page. Activate Continue 

ruler across spreads in the View section of the General page of Preferences, if you 

prefer the ruler to continue across both pages of a spread. 

Grid. Dorico 6 now also includes a grid in Engrave mode, enabled via Engrave ▶ Grid. By 

default, Dorico uses a 5mm grid, with bold lines at 25mm intervals, and you can use 

Engrave ▶ Grid Options to edit the grid to your preferences. Several preset grid 

configurations are provided; additionally, you can specify whether and how often 
bold grid lines should be used, and choose whether only horizontal or vertical grid 

lines should be shown. 

Although you cannot save your own grid presets, your preferred grid settings are 

included when you use Save as Default in View ▶ View Options, and are therefore 

available in new projects, or can be recalled in existing projects by clicking Reset to 

Saved Defaults. 

The colors used for the grid can be set on the Colors page of Preferences. You can 

also change the color and thickness of the crosshair drawn for the selected item in 

Engrave mode, which allows you to achieve greater contrast between the grid and 

crosshair if needed. 

OpenType features 
It is now possible to selectively enable or disable glyph positioning and glyph 

substitution features in OpenType fonts for paragraph, character, and font styles, 

greatly expanding the typographical possibilities of text in Dorico. Previously, 
certain font features were always enabled by default (for example, kerning and 

standard ligatures), but it was not possible to disable these features, or to enable 

other features. 

Supported features. Only features in the gpos (glyph positioning) and gsub (glyph 

substitution) tables are configurable in this release. This includes kerning, standard 

ligatures (e.g. “fi” and “fl”), contextual ligatures (based on surrounding text), 

discretionary ligatures (typically used for fancy typographical features), fractions, 

old-style and lining figures, small capitals, stylistic sets, and case-sensitive forms 
(often used to position punctuation differently depending on whether they are 

adjacent to lower-case or upper-case letters), among others. 

Enabling or disabling features in paragraph styles. In Library ▶ Paragraph Styles, a new 

OpenType features section can be found at the bottom of the scrollable right-hand 

pane. Click + to show a menu listing the features supported by the chosen font; if the 
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button is disabled, the chosen font includes no OpenType features. Choose a feature 

from the menu and it is added to the table of features. By default, each feature you 

add is enabled, but you can disable it by deactivating its checkbox. 

When you change the font family used by the paragraph style, any chosen features 

that are not supported by the new font will be automatically removed from the list. 

In common with other properties of paragraph styles, OpenType features can be 

inherited by dependent styles or overridden in each style. 

Enabling or disabling features in character styles. To change the features that are enabled 

or disabled within a single run of text, apply a character style with the desired 

combination of enabled and disabled features. The same OpenType features list 

appears in Library ▶ Character Styles, though unless you have explicitly overridden 

the font family in your character style, the list of features that appears when you 
click + will list all glyph substitution and positioning features, since it is not known 

which font the character style will eventually be applied to. 

Note that due to the complexities of font shaping, you may find that certain features 

do not appear as expected when you apply a character style to part of a run of text in 

the text editor, but when you leave the editor, the feature will be correctly applied. 

For example, disabling standard ligatures (liga) may not appear correctly in the 

editor, while setting small caps (smcp) appears identically both in the editor and 

when the text is rendered in the score. 

Enabling or disabling features in font styles. Font styles are typically used for notations 

and not long runs of text; nevertheless, you may from time to time find it useful to 
enable OpenType features for some font styles. For example, you might want to use 

lining numbers for intervals and alterations in chord symbols, or when using a plain 

font for figured bass. 

As with paragraph and character styles, Library ▶ Font Styles now includes a new 

OpenType features list, allowing you to specify which features should be enabled or 

disabled for the current font style. 

Splentino font family 
Dorico 6 now includes a new text font family called Splentino, created by Ben 

Byram-Wigfield. Splentino is a new digital recreation of the Plantin typeface, 

designed by Frank Pierpont and Fritz Stelzer for Monotype in 1913 after a visit to the 

Plantin-Moretus Museum in Antwerp and inspired by a typeface by the 16th century 

typographer and printer Robert Granjon they had seen there. 

The digital version of Plantin created by Monotype has upper case characters 

around 10% wider than the original metal type version, and this additional width 
makes it less suitable for music typesetting, where horizontal space is at a 
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premium. (The lower case characters are only fractionally wider then the metal 

type version in most cases, though some letters – including m – are noticeably 

wider.) 

Splentino has been created with reference to the original metal type of Plantin, 

including original specimen sheets from the Monotype Drawing Office, now held in 

the collection of the Science Museum in London, and Letraset dry transfer sheets. 

The typeface has been meticulously created in four weights – Regular, Italic, Bold, 

and Bold Italic – and small details of the original letterforms have been modified to 

improve consistency and balance. 

 

The counters (enclosed circles) of b, d, p and q have been made consistent, in their 

various orientations. The counters of a and e have been enlarged for greater 
legibility. (Type historians have pointed out that the letter a which Pierpont saw in 

the museum was an 18th-century design, rather than a 16th-century one.) A slight 

chamfer (diagonal cut) has been added to the top of lowercase vertical stems. 

Flow heading overrides 
Flow headings can be automatically inserted before the first system of each new 

flow in your project. They are enabled by the Show flow headings option in the 

Flows section of the Page Setup page of Layout Options. When flow headings are 

enabled, the default flow heading in the page template set used by the layout is 

inserted for each flow, according to whether you have chosen to insert them for all 

flows, or only for flows after the first. 

It is also possible to create a flow heading change in Engrave mode, specifying that 

on only the chosen page, or from that chosen page until the next flow heading 
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change, a different flow heading should be used for flows whose first system 

appears on those pages. 

However, in projects where multiple short flows may appear on the same page, it 

was previously impossible to specify a different flow heading for one or more of the 

flows on that page. 

With Dorico 6, we have now introduced flow heading overrides, which allow you to 

specify the flow heading that should be used for each flow in a layout, providing 

complete flexibility over the choice of flow heading and how much space should be 

added above and below each one. 

Creating a flow heading override. In Setup mode, select the layout in the right-hand 

Layouts panel where you want to create a flow heading override, then right-click to 

show the context menu, and choose Flow Heading Overrides. This dialog appears: 

 
To add a flow heading override for a flow, click + in the action bar to show a menu 

listing the flows that do not yet have an override defined: click the target flow, and it 

is added to the left-hand list in the dialog. 

Once the target flow is selected, set Use flow heading to the flow heading you want 

to appear before the first system of this flow; you can also specify (none) if you want 

no flow heading to appear for this flow. Set Heading top margin and Heading 

bottom margin if desired to alter the amount of space Dorico leaves above and 

below the flow heading. 

To remove a flow heading override, select the target flow in the left-hand list and 

click the Delete button in the action bar. 
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The Flow Heading Overrides dialog is non-modal and can be left open while you 

work. Click Apply to apply the current changes to the edited layout and leave the 

dialog open so you can continue to make further changes. The dialog always applies 

to the layout that was chosen in the Layouts panel in Setup mode, or the current 

layout if invoked outside Setup mode. If you switch to another layout and want to 

edit the flow heading overrides for that layout, you must close and reopen the 
dialog. The name of the layout to which the changes will apply is shown in the 

caption of the dialog. 

Propagate part formatting. Flow heading overrides can now optionally be propagated 

from one part layout to one or more other part layouts using Setup ▶ Propagate 

Part Formatting. 

Importing and exporting user settings 
Your single-user license for Dorico allows you to run the software on up to three 

computers for your own personal, non-simultaneous use. You may therefore want 

to set Dorico up in the same way on each of the computers on which you use it. 

Dorico 6 introduces a new feature to import and export user settings, making it 

easy to transfer your preferences to another computer. 

To get started, choose File ▶ Export User Settings. You are prompted to choose the 

folder where the exported user settings will be saved. A zip archive whose name 

begins Dorico User Settings (and includes today’s date and time) is exported to the 

chosen folder. Copy this zip archive to your other computer. 

To import these settings on your other computer, run Dorico, and choose File ▶ 
Import User Settings. In the picker that appears the Dorico User Settings archive 

you exported from your other computer. This dialog appears: 

 
Activate the checkboxes for the settings you want to import. Only those checkboxes 
corresponding to data that was present in the archive you exported from your other 
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computer will be enabled. Clicking Import All or Import None activates or 

deactivates all enabled checkboxes. 

Backup existing settings is activated by default. When you click OK to confirm 

which settings you want to import, if Backup existing settings is activated, Dorico 

exports a Dorico User Settings archive of your current settings on this computer, so 

you have a backup if you inadvertently overwrite specific settings that you wanted 

to retain. 

Be aware that only user-specific settings are imported and exported. For example, if 

you have manually added library files to the system-wide DefaultLibraryAdditions 

location, these are not handled. 

View Options dialog 
A new View ▶ View Options dialog has been added, with default shortcut 

Ctrl+Shift+V (Windows) or Shift-Command-V (macOS), allowing central access to 

(almost) all the options in the View menu from a single dialog, and making it easy to 

save your preferred combination of options as a default for new projects. 

Saving default view options. Either set your preferred view options directly using the 
commands in the View menu, or using the new View Options dialog, then click Save 

as Default in View ▶ View Options. These options will then be applied to future new 

projects. 

Applying saved view options to an existing project. When you open a project created in an 

earlier version of Dorico, or sent to you by somebody else, the default state of new 

options (for example, to show cycle locators or token placeholders) may not match 

your saved defaults. To apply your defaults to the current project, simply choose 

View ▶ View Options and click Reset to Saved Defaults. 

Resetting to factory defaults. To reset the view options in the current project to the 

factory defaults, choose View ▶ View Options and click Reset to Factory. You can 
also click Remove Saved Defaults to remove your saved default view options, so 

projects you subsequently create will instead use the factory default view options. 

System track. The option Show system track in new projects in the Files section of the 

General page of Preferences has been removed, since it is now possible to control 

this via the new View Options dialog. 

View options selector. In addition to the new View Options dialog, a new selector has 

been added to the toolbar, replacing the show/hide tab bar button. 
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When clicked, a selector appears in which you can activate or deactivate the system 

track, signposts, and cycle locators, as well as hiding or showing the tab bar. In 

Engrave mode, the selector allows you to activate or deactivate rulers and the grid. 

Jump bar 
First introduced in Dorico 4 as a way of quickly finding and executing commands 

and navigating through the project, the jump bar has been significantly enhanced 

in Dorico 6, and now allows you to search for and execute individual options from 

the Engraving Options, Layout Options, Notation Options, Note Input Options, and 

Playback Options dialogs. 

Finding and setting options. When you type into the jump bar in Commands mode, 

individual options that match your search string will be shown; if both commands 

and options match your search string, commands will be listed first, followed by 
options. Options show not only the name but also the dialog, page, and section in 

which they can be found; this extended description is also matched against your 

search string. 

After selecting an option, hit Return to edit it. The settings for that option appear 

immediately below the jump bar, and you can use the keyboard to directly set the 

option. Use Space to activate or deactivate a switch; use ←/→ to toggle between 

grouped buttons; use ↑/↓ to increase or decrease numeric values, or simply type 

the new value directly; hit Space to open a drop-down menu, and ↑/↓ to change the 
selected item. Hit Return again to confirm your choice and close the jump bar, 

which sets the option accordingly. 

You can alternatively hit Alt+Return to be taken to the relevant page in the 

appropriate options dialog to edit the option there. 

There are some limitations concerning options in the jump bar: 

§ Not all options appear in the jump bar. Options that use special, complex 
controls do not appear: only those that use standard controls (switches, toggle 

buttons, spin boxes, drop-down menus) can be set via the jump bar. 

§ Some options are naturally paired or grouped with other options in the dialogs, 

but all options appear singly in the jump bar. For example, on the Staves and 

Systems page of Layout Options, the option to enable a fixed number of bars per 

system is paired with the option that specifies the number of bars; these are 
separate options, and so have to be found and set individually via the jump bar. 

§ You cannot currently specify a jump bar alias for an individual command. We 

hope to relax this limitation in future. 

§ When you reopen the jump bar after editing an option, the same option does 

not reappear prepopulated in the jump bar by default. Again, we hope to relax 

this limitation in future. 
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Marching Percussion Basics 
Dorico 6 includes a new set of sounds for marching percussion, produced in 

partnership with Tapspace, developers of the acclaimed Virtual Drumline sound 

library. Marching Percussion Basics includes four patches, addressing the four 

main instruments of the drumline: 

§ Marching Basses: six bass drums, with left and right hits, rim hits, and roll; plus 

unison with all six drums playing. 

§ Marching Cymbals: flat crash, choke, sizzle, and crunch. 

§ Marching Snares: left and right hits, rim hits, and rim shots, plus roll. 
§ Marching Tenors: four tenor drums plus two smaller spocks, with left and right 

hits and rim hits, plus roll. 

To use these new sounds, choose a factory playback template with Marching Perc. 

in its name. If you always want these sounds available in new projects, change 

Default playback template on the Play page of Preferences. 
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Other improvements 

Accidentals 
Viewing contradictory accidentals. When you have notes of the same name at different 

octaves with different accidentals in the same instrument – for example, C3 in the 
left-hand staff of a piano and C♯5 in the right-hand staff –these are considered 

contradictory accidentals. Depending on musical context, you might find it 

unnecessary to show the natural on one or more of the notes. 

To help to locate these places, a new View ▶ Note and Rest Colors ▶ Contradictory 

Accidentals option has been added, complementing the existing Cautionary 

Accidentals and Forced Accidentals options. When activated, contradictory 

accidentals will be shown in a purple color: the color can be customized on the 

Colors page of Preferences if required. 

Audio engine 
Quitting Dorico. When quitting Dorico, Dorico now waits up to 10 seconds for the audio 

engine to exit completely before it exits. This should prevent you from attempting 

to restart Dorico before the audio engine has cleanly exited. 

Barlines 
Showing a double barline at the start of the system. A new option Barline at start of 

system with double barline at end of previous system has been added to the 

Barlines page of Notation Options: when Double barline is chosen, a double barline 
at the end of the system will also be shown as the systemic barline at the start of the 

next system. 

Bar numbers 
Bar numbers at the start of the system. It is now possible to specify that bar numbers 

shown at the start of the system should be center aligned. On the Bar Numbers 

page of Layout Options, set Alignment at start of system to Centered on barline. 

Selecting bar numbers. When bar numbers are shown at positions other than the start of 

the system, making a marquee selection will no longer include bar numbers, unless 

the bar number represents an explicit bar number change. In previous versions, 

when such bar numbers were included, copying and pasting that material could 

result in unexpected results, because the material would be pasted at an offset 

determined by the number of bars between the first selected bar number and the 

prevailing time signature. 

Beaming 
Beam positions relative to accidentals on beamed notes. When Dorico determines the 

vertical position of a beam, it snaps the beam to a legal sit/straddle/hang position 
relative to a staff line. This will often mean snapping the beam inwards, such that 
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the length of one or more of the stems in the beamed groups is shortened. In 

previous versions, this could result in the beam colliding with an accidental 

belonging to a notehead in the beamed group. 

Dorico now avoids such collisions by default in new projects. If you want to enable 

this improvement in existing projects, activate the new option Strictly enforce 

minimum stem lengths and space for accidentals when snapping inwards in the 

Advanced Options section of the Vertical Position section of the Beams page of 

Engraving Options. 

Beaming across beat boundaries when ties are present. A new option Notes joined by ties 

in simple time signatures has been added to the Time Signatures With or Without 

a Half-bar section of the Note Grouping page of Notation Options. 

 
By default, Dorico breaks beams between tied noteheads that would otherwise be 

joined if they were separate notes; however, this is not a universal practice, so if you 

would prefer such tied noteheads not to break beams, choose Allow to cross beats. 

Chord symbols 
Selecting chord symbols. Because chord symbols are system-attached items, they are not 

included in selections made by clicking on a blank part of the staff, or when 

extending the selection with Shift+click. They can be selected by clicking on them 
and using Edit ▶ Select More, or selected along with material on all staves using the 

system track, but these selection methods require that you at least start the 

selection using the mouse. 

To make it possible to select chord symbols using only the keyboard, two new 

commands have been added that can be triggered via the jump bar, or to which you 

can assign your own custom shortcuts on the Key Commands page of Preferences. 

The first command, Select Chord Symbols, selects the chord symbols in the range 

described by the earliest and latest selected items: it clears the existing selection, 

and selects the chord symbols within that range. 

The second command, Add Chord Symbols to Selection, selects the chord symbols 

in the range described by the earliest and latest selected items, but without clearing 

the existing selection, so that the chord symbols are added to the selection. 
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In addition, it is now possible to select a range of chord symbols by selecting one 

chord symbol, then holding Shift and clicking another chord symbol: all the 

intervening chord symbols are selected. 

Similarly, if you select one chord symbol and then select a later chord symbol using 

Ctrl+click (Windows) or Command-click (macOS), then use Edit ▶ Select More, 

Dorico will select all the intervening chord symbols. 

Vertical alignment of chord symbols. When some chord symbols on the system are 

presented as a single line, and others – such as polychords, or chords with altered 

bass notes using a stacked appearance – are presented as two lines, you can now 

specify their relative vertical alignment. A new option Alignment of multi-line 

chord symbols relative to single-line chord symbols has been added to the 

Position section of the Chord Symbols page of Engraving Options: 

 
 

Root notes. In German-speaking countries there are different conventions for how the 

pitches B♮ and B♭ should be named: very often, B♮ is named H and B♭ is named B. In 
chord symbols where B♭ is shown as B♭, some prefer the natural sign to be shown 

explicitly for B♮ to make clear that B does not mean B♭. (“Oh, that was easy,” says 

Man, and for an encore goes on to prove that black is white and gets killed on the 

next zebra crossing.) 

To use this convention, set Appearance of B and B flat to B natural and Bb in the 

Root section of the Chord Symbols page of Engraving Options. 

6/9 chord appearance. Two new options have been added to the Appearance of 6/9 

option in the Intervals section of the Chord Symbols page of Engraving Options: as 

their names suggest, 6 over 9 without line and 9 over 6 without line use stacked 

numerals with no line between them. 

Major seventh appearance. Some major publishers use a variation of the appearance for 

major seventh chords where “maj” is shown on the baseline and “7” is superscript. 
This can now be achieved in Dorico by setting the new Position of interval number 

when using baseline vertical position option in the Intervals section of the Chord 

Symbols page of Engraving Options. 
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Minor seventh chords versus sixth chords in inversion. When interpreting chords played 

on a MIDI keyboard as a chord symbol, some collections of notes can be interpreted 

as several chords that are each common. For example, E,G,B,D could potentially be 

either Em7 or G6. Dorico prefers chords in root position, so E in the bass gives Em7 

and G gives G6; however, if D is in the bass Dorico prefers G6/D, whereas you might 

prefer Em7/D. 

To accommodate this choice, a new option Preference for sixth or minor seventh 

chords when in inversion has been added to the Chord Symbols page of Note Input 

Options. 

Boston preset. The Boston preset for chord symbols, as chosen on the Chord Symbols 
page of Engraving Options, has been updated to hew a little closer to the 

conventions taught at Berklee College of Music. 

Clefs 
Deleting initial clefs. When importing MusicXML files, it’s common for instruments to 

have explicit clef changes at the very start of the flow. A new Delete Initial Clefs 

command has been added: this removes all explicit clef changes at the start of every 

flow in the project. The command can be triggered via the jump bar, or you can 

assign a custom key command via the Key Commands page of Preferences. 

Dynamics 
Dynamics with hidden intensity markings. When a dynamic’s intensity marking is 

hidden, any remaining prefix/suffix should ideally be left-aligned on the note, 

rather than falling back on center alignment. A new option Alignment of text 

dynamics with intensity mark hidden has been added to the Horizontal Position 

section of the Dynamics page of Engraving Options allows you to enable or disable 
this behavior; by default, such dynamics will be left-aligned in new projects, but 

center-aligned in existing projects to preserve their appearance. 

Graphic slices 
Default graphic slice settings. You can now specify the default properties for graphic 

slices: create a slice, set the format, color depth, and resolution using the controls in 

the Graphic Slices panel in Engrave mode, then click Save as Default to save those 

choices for all future graphic slices in all projects. 

Natural sort order. Graphic slices are now listed in the panel according to natural sort 

order, rather than lexicographical sort order. 

Slice names. After creating a new slice, the name field in the panel is automatically 

opened for editing, so you can immediately type the name of the new slice. 
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Guitar tablature 
Moving notes between strings. If you have notation and tablature shown, you can move a 

note from one string to another by selecting it in the tab and typing N or M. 

However, there is no way to move the selection from the notation to the tab at the 

same rhythmic position without using the mouse, so you must click on the other 

representation to move the focus there. 

To address this, two new commands, Move to String Above and Move to String 

Below, have been added. When triggered, these commands move the selected note 

to the string above or below, regardless of whether the selection is in the tablature 
or the notation. If you edit a lot of music that includes tablature, you may find it 

helpful to assign custom key commands to these new commands via the Key 

Commands page of Preferences. 

Harmonics 
Harmonics on tied notes. A new option Natural harmonics on noteheads in tied notes 

has been added to a new Harmonics page in Engraving Options, allowing you to 

choose whether the natural harmonic symbol should be shown on all noteheads in 

the tie chain, or shown only on the first notehead. 

 

Harp pedaling 
Order of left and right pedals. By default, Dorico shows the pedals played by the right foot 

(EFGA) above the pedals played by the left foot (DCB). However, this convention is 
not universally followed so a new Vertical order of pedals option has been added to 

the Harp Pedals page of Engraving Options, allowing you to show the left pedals 

above the right if you prefer. 

Instrument editor 
Instrument name formatting. When editing the full and short instrument names for an 

instrument type in Library ▶ Instruments, any rich text formatting you specify in 

the Edit Instrument Names dialog will now be correctly preserved when the 

instrument is saved to your user library. 

Instrument types 
Fretted instrument tunings. It is now possible to specify a custom name for a modified or 

new fretted instrument tuning in the Edit Strings and Tuning dialog. After you 
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modify the current tuning, the new Edit Name button becomes enabled: click this to 

specify a name for the tuning. 

The custom name is used wherever tunings are listed, including in the Chord 

Diagrams submenu for the context menu in the Players panel in Setup mode. 

Library Manager 
Import into all flows and layouts. It is now possible to import layout and notation options 

into all layouts and flows in the project respectively using the Library Manager. 

When you select Layout Options in the Options section of the left-hand list, a new 
button appears at the bottom left-hand corner of the window. The button reflects 

the type of the layout chosen in the Layout drop-down in the This project section at 

the top of the window. If you have a full score layout selected, the button reads Copy 

to All Full Score Layouts; if a part layout is selected, it reads Copy to All Part 

Layouts; and if a custom score is selected, it reads Copy to All Custom Score 

Layouts. 

When you select Notation Options in the Options section, the button reads Copy to 

All Flows. 

When you click this button, you are asked to confirm that you want to proceed, and 

all the layout or notation options are applied from the source library or project to all 
the layouts of the shown type, or to all flows. The changes are applied immediately, 

and the Library Manager updates right away. As with all changes made in the 

Library Manager, you can close the window and undo if you want to roll them back. 

Lines 
Tapered curve lines. It is now possible to create horizontal and vertical lines that are 

drawn using curves, and a couple of preset lines have been added to the panel. 

In the Horizontal section of the Lines panel, upward and downward curved lines 

with arrowheads are provided: these are sometimes used in teaching materials to 

indicate a harmonic resolution: 

 
In the Vertical section of the Lines panel, left- and right-pointing brace lines are 

provided. These are drawn using a pair of mirrored curved lines, rather than fixed 
symbols from the current music font. These are sometimes used in lyrics to indicate 

where lyrics for a refrain or repeated passage are the same on each repetition: 

F F7 B
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To create your own line styles that use curves, choose Library ▶ Line Bodies and 

choose Tapered Curve from the Category drop-down in the top left corner. 

 
The Start/End control point and Y offset values are expressed as normalized values 

between 0 and 1, where 1 = 100% of the length of the line, and 0 = 0% of the length of 
the line. A threshold at 20 spaces prevents the control points and the Y offsets from 

growing any bigger: this is intended to stop the curve becoming excessively loopy as 

it gets longer. 

You can choose between four approaches for determining the thickness of the line 

using the Thickness type drop-down: 

§ Constant uses the input values without any adjustment, regardless of the 

length of the line. 

§ Proportional scales the values with the length of the line, which are 

clamped by default to prevent the line becoming either very thin at short 

lengths or very thick at long lengths. 
§ Threshold clamps the values to the specified thickness values at or below 

the Min length (expressed in spaces), then interpolates to 1.5× the specified 

values at or above the Max length. 

§ Exponential uses an exponential growth function, which means that it will 

move more quickly from the input thickness to the maximum thickness as 

the line grows longer. The Damping factor controls the rate at which the 
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thickness scales in response to the curve length: higher values cause the 

thickness to increase more rapidly. 

Once you have designed one or more tapered curve line bodies, you can use these 

in Library ▶ Lines to design horizontal or vertical lines that appear in the Lines 

panel. 

It is not possible to set annotations in horizontal or vertical line styles that use 

tapered curve bodies. Vertical lines that use tapered curve bodies do not avoid 

collisions. 

Collision avoidance. Horizontal lines placed outside the staff can now be excluded from 

collision avoidance by activating the new Avoid collisions property in the 

Horizontal Lines group in the Properties panel. This property is not available for 

note-attached lines. 

Lyrics 
Editing lyric durations. In situations where you’re adding lyrics to music in multiple 

voices, or between a pair of staves (e.g. for barbershop music written in short score), 

you may need to show an extender line for a lyric even though the specific voice 
against which the lyric has been input doesn’t show a melisma, because another 

voice on the same or another staff that is nominally sharing the same lyric does. 

To allow this, it is now possible to edit the duration of a lyric using Shift+Alt+←/→: a 

lyric that shows no extender line can be lengthened to show one, and a lyric with an 

extender line can be shortened such that the extender line no longer appears. 

Moving lyrics in Write mode. Alt+←/→ now moves lyrics to the previous/next note rather 

than to the previous/next rhythmic grid position, as in earlier versions; use 

Ctrl+Alt+←/→ (Windows) or Opt-Command-←/→ (macOS) to move by the grid. It is 

also now possible to drag lyrics left and right in Write mode, which moves them 

between notes (the equivalent of Alt+←/→). 

Markers 
Choosing which time components appear. The Show in timecode options on the Markers 

page of Engraving Options now apply to the timecode shown in markers as well as 

to timecode shown at the start of the system or on the timecode staff. 

MIDI import and export 
Lyrics. Dorico now imports lyrics when importing MIDI files, and includes lyrics when 

exporting MIDI. There is no universally agreed standard for how lyrics should be 

encoded in MIDI files, so it’s not always possible to determine the correct syllable 
type for every lyric: imported lyrics can be edited in the usual way to correct them, 

either directly via the popover, or using the Properties panel. 
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When exporting lyrics, Dorico does its best to assign lyrics belonging to separate 

lines to repeated passages if possible; if there are multiple lines of lyrics but no 

repeats, only the first line of lyrics is exported. 

Music fonts 
Font updates. Academico has been updated to version 0.905, which includes improved 

kerning for numerals. Petaluma has been updated to version 1.065, and Petaluma 

Text to version 1.066. These are very minor updates, adding the left- and right-

pointing arrows for tempo equations, and revising the width of the space character 

in Petaluma Text. 

Golden Age has been updated to version 1.05, Sebastian to version 1.21, and 

Nepomuk to version 2.52. 

Music symbol editor 
The music symbols editor is used in several places in Dorico – for example, when 

double-clicking a chord symbol in Engrave mode; Library ▶ Music Symbols, Library 

▶ Playing Techniques, Library ▶ Chord Symbols, etc. – and has been revised to 

make it easier to use. 

Better defaults. Depending on the context in which it appears, Dorico now chooses a 

different default SMuFL range on the Glyphs tab, font style on the Text tab, and 

composite category on the Composites tab. 

Information read-out. A read-out has been added to the Component panel below the 
main editor, showing information about the text content, font style and font for text 

components, the name of composite components, and the glyph name, codepoint, 

font style and font name for glyph components. 

Scaling components. In the panel of controls below the preview, a single Scale spin box 

now appears, unless the selected component type is a graphic; only graphics can be 

scaled by different amounts in the horizontal and vertical dimensions. 

Filtering long lists. Filter line edits have been added to the Glyph, Text and Composite 

tabs, allowing you to type in a search term to narrow down the results in the 

lists/grids below. 

Furthermore, the SMuFL range menu on the Glyph tab now itself contains a filter 

line edit, allowing you to search within the list of ranges by name to narrow down 

your search. 

Deleting graphic components. On the Graphics tab, Dorico now allows you to delete a 

graphic that is not used by any music symbol. This operation is carried out 

immediately, and cannot be undone, so use it with caution. 
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Improved previews. The appearance of the items in the Text, Graphics and Composites 

tabs has been thoroughly reworked; in particular, the previews on the Graphics and 

Composites tabs are now much more useful than before. 

MusicXML export 
Instruments showing both notation and tablature. When a fretted instrument shows both 

staff notation and tablature, when exporting MusicXML, Dorico now treats these 

representations independently, exporting each one as a separate instrument (or 

part, in MusicXML’s terminology). 

Transposing instruments. Applications vary in their interpretation of instrument 

transpositions, especially for octave transposing instruments, in MusicXML files. 

We have reviewed in detail Dorico’s behavior both when importing and exporting 

transposing instruments, and it is exporting transpositions and pitches correctly. 
You may nevertheless encounter notes appearing an octave too high or low when 

you import files exported from Dorico into Finale or MuseScore Studio, due to 

issues in their interpretation of clefs with octave indicators. 

Font information for lyrics. Basic information about the fonts used for lyrics is now 

exported to MusicXML. 

Finer positioning of items with duration. Dorico now specifies information about the 

graphical positions of the starts and ends of non-note items with rhythmic 

durations, including gradual dynamics and octave lines. 

Different applications interpret this information differently, so if you are planning 

to import the MusicXML exported from Dorico in a specific application, you may 

wish to adjust the options in the new Export section of the MusicXML page in 

Preferences. 

For exporting to Sibelius, deactivate all three options (Include suppressed system 

and frame breaks, Split ongoing items at system and frame breaks, and Items at 

the end of the bar naturally relative to barline). 

For exporting to Finale, activate all three options. 

For exporting to Noteflight, deactivate Split ongoing items at system and frame 

breaks. 

Note input 
Popovers. Popovers have been tweaked to make some of their hidden superpowers more 

visible. 

Several popovers – including bars and barlines, chord symbols, figured bass, key 

signatures, and time signatures – normally create items that apply to all staves, but 

if you hold Alt when confirming the popover, the created item will instead apply 
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only to the current staff. (The dynamics popover is similar, but a little different: 

when you hold Alt, the dynamic is created in the current voice as specified by the 

caret, rather than applying to all voices.) 

To make this more obvious, these popovers now show an additional button to the 

right of the text field: as you hold Alt it becomes activated. You can also click the 

button, and then confirm the popover in the usual way (for example, by hitting 

Return, or for popovers that can advance, by pressing Space, Tab, or →). 

The chord symbols and lyrics popovers allow you to input items on multiple lines 

above or below the staff. The line number is now shown in a spin control to the right 

of the text field. It’s read-only, so you can’t type into it, but you can click the paddles 
to move to the next or previous line, and you can of course use ↑/↓ to change line, 

as before. 

The lyrics and fingering popovers can also show an extra information label to the 

right of the text field or spin control. For lyrics, this indicates whether you are 

inputting lyrics above or below the staff; for fingering, if you are writing on a fretted 

instrument, it shows whether you are inputting right- or left-hand fingering. Click 

the label to swap between these states. 

Instrument filters. When working in galley view with an active instrument filter, Dorico 

now ignores the instruments hidden by the filter when inputting and editing notes. 

For example, when you extend the caret with Shift+↑/↓, notes will no longer be 
input on instruments that are hidden by the filter; similarly, multi-paste, explode, 

moving or duplicating notes to the staff above or below, and so on. 

MIDI input in the background. When Dorico is in the background, by default it continues 

to receive MIDI input from your connected MIDI devices. This is helpful if you are, 

for example, copying material from a PDF or transcribing audio played in another 

application, and need to temporarily have that other application in focus. 

However, if you are working with multiple applications that receive MIDI input, or if 

you like to noodle on your keyboard at other times, if you left note input active in 

Dorico before switching to another application, you may be surprised to find 

unwanted music has been input when you switch back to Dorico. 

To avoid this, a new Suspend when in background option has been added to the 

Play page in Preferences. Activate this if you want Dorico to receive MIDI input only 

when it is the active foreground application. 

Pitch before duration input. When using pitch before duration input, and the option 
Specify accidental, rhythm dot and articulations is set to After inputting note, it is 

now possible to add multiple notes at the same rhythmic position to build chords by 

moving the shadow note with Alt+↑/↓, then typing the duration key again. 
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Numbered bar regions 
Options precedence. The behavior of the options and properties for numbered bar 

regions has been tweaked to make the relationship between the options on the Bar 

Repeats page of Engraving Options and the properties that override them clearer. 

The appearance for bar count numbers that appear due to the specified interval 

(Number every n bars), i.e. whether they should be parenthesized, now take 

precedence over the options for the appearance of the bar count at the end of the 

system and at the end of the region. If a bar would be numbered naturally due to its 

interval from the start of the region, the Appearance of bar count option always 
takes precedence; only if the bar would not naturally show a number will the 

options for the appearance of the bar count at the end of the system or the end of 

the region be applied. The Properties now always act as overrides, as expected. 

Percussion 
Percussion legends. A new option Show percussion legends on grids has been added to 

the Percussion section of the Players page of Layout Options. When activated, 

percussion legends will appear when created on percussion kits shown using the 

grid presentation type. This may be useful if, for example, you choose not to show 

staff labels at the start of each system. 

Percussion Maps dialog. The Library ▶ Percussion Maps dialog has been updated to 

make it a little easier to work with. 

It is now possible to use the standard shortcuts for copy and paste to duplicate the 

selected row in the Drum Kit Note Map section; you can also now hit Delete to clear 

the selected row. 

It is no longer necessary to click Apply in the Edit Drum Kit Note section when 

editing a selected row: the edits you make are now reflected as soon as you make 

them. 

Playback 
Navigating between flows. The commands that move between flows – for example, Edit ▶ 

Go To ▶ Go To Previous/Next Flow, or using the Go To mode in the jump bar – now 

also move the playhead to the start of the target flow. 

Tenuto articulations. In some musical idioms, the tenuto articulation is expected to 
produce an increase in dynamic in addition to, or perhaps instead of, an extension 

of the played duration of the note. A new option has been added to the Dynamics 

page of Playback Options to specify by how much a tenuto articulation should 

increase the dynamic level; by default, this is set to 0. This can also be overridden in 

an expression map using the corresponding setting in the Playback Options 

Overrides section of Library ▶ Expression Maps. 
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Humanize note end positions. Dorico has always made tiny random adjustments to the 

start positions of notes to simulate the natural irregularities of human performers, 

but the end positions of notes were always precisely metronomic. 

To address this, a new Humanize end positions of notes by n% option has been 

added to the Timing page of Playback Options. This is set to 30% in new projects, but 

0% in existing projects to avoid changing their playback unexpectedly. 

Starting playback. The Play ▶ Start or Stop Playback command in the Key Commands 

page of Preferences now includes the left and right locators. You can assign a 

custom shortcut to start playback from either locator if you wish. 

Play mode 
Hiding all VST plug-in windows. A new command Hide All VST Plug-in Windows has 

been added to the Play category in the Key Commands page in Preferences. You 

can assign a custom shortcut to this command or access it via the jump bar. As its 

name suggests, it will close all open VST plug-in windows that belong to the active 

project. 

Playing techniques 
Glyph playing techniques and tied notes. A new option Repeat signs on every notehead 

in tie chain has been added to the Continuation tab in Library ▶ Playing 

Techniques, enabled only when glyph playing techniques have Continuation type 

set to Repeat the signs. This setting can also be overridden for an individual playing 

technique via the Properties panel. 

Parenthesized playing techniques. A new Parenthesized property has been added. When 

activated, the selected playing technique will be enclosed in parentheses. 

To specify via the Shift+P popover that the playing technique you are creating 

should be parenthesized, simply enclose the popover text in parentheses: for 

example, type (pizz.) to create a parenthesized pizz. playing technique. 

In previous versions, using parentheses in the popover would result in the playing 

technique being hidden: to create a hidden playing technique in Dorico 6, enclose 

the popover text in square brackets: for example, [pizz.] will create a hidden pizz. 

playing technique. 

Assigning key commands. It is now possible to assign key commands to individual 

playing techniques, which you might find quicker than using the Shift+P popover 

for those playing techniques you create most often. 

On the Key Commands page of Preferences, navigate to Note Input ▶ Create 

Playing Technique, and all the playing techniques from the factory library and your 

own custom playing techniques saved to your user library are listed. 
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If you do not see a playing technique that you expect to be there, go to Library ▶ 

Playing Techniques and ensure that the playing technique in question is saved as a 

default. 

Playing techniques in slash regions. In previous versions, playing techniques are only 

shown in rhythmic slash regions when the Show other voices property is active. To 

provide greater flexibility, a new option has been added to the Rhythmic Slashes 

section of the Playing Techniques page of Engraving Options. 

 
You can now set Playing techniques in rhythmic slash regions such that playing 

techniques in slash regions will Never show, Always show, or Show when other 

voices shown. 

This choice can be overridden for an individual slash region by activating the new 

Show playing techniques property in the Slash Regions group in the Properties 

panel. 

Project files 
Default file name. When you first save a newly created project, the default suggested file 

name is now based on the project title as specified in File ▶ Project Info. 

Properties 
Keyboard access to Properties filter. In Dorico 3.5, it was possible to set the keyboard 

focus in the Search field in the Properties toolbar by typing Alt+8. When the lower 

zone was expanded in Dorico 4, this functionality was removed, but it has finally 

been restored. Type Alt+8 to move the focus to the Search field, and type to filter the 

Properties panel. 

One useful tip is that you can type any part of a properties group name (for example, 

Fingering, Harmonics, Beaming, etc.) to show only that group. 

Improved property groups for selected notes and chords. If you use Edit ▶ Filter ▶ Notes 

and Chords, your selection may include notes, grace notes, rests, and tuplets in any 

combination. With one or more tuplets selected, the set of properties available in 
the panel was previously limited to only the Common group. Now, the properties 

common to notes, grace notes, and rests will additionally appear, allowing you to 

edit the playback offset and velocity properties, and to set some beaming 

properties. 
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Showing all properties for selected items. By default, the Properties panel shows only the 

properties that are common to all the selected items: this typically means only the 

Common group, and for other specific combinations of items, a handful of other 

properties may appear. This helps to keep the number of Properties you see at any 

given moment manageable – but it has the disadvantage that you must reselect 

different types of items to access their properties. 

Dorico 6 makes it possible to see all properties for the selected items, regardless of 

the number of different types of items in the selection. To enable this, set When 

selecting multiple items of different types to Show all properties on the Note 

Input and Editing page of Preferences. 

For selections with many types of items, this will make a very large number of 

Properties available in the panel, so you would be well advised to use the filter field 

in the Properties panel toolbar to find the specific properties you are looking for. 

Setup mode 
Creating default part layouts. Setup ▶ Create Default Part Layouts now creates a part 

layout for any player that does not have its own individual part layout; previously, 

any player that was present in at least one part layout, even in combination with 

another player, would not have an individual part layout created. 

Staff labels 
Staff labels and page margins. By default, the total width of the system including its staff 

labels can never exceed the width of the music frame: Dorico calculates the 

maximum width required for the widest staff label on the system, and subtracts 

that from the frame width to determine the width of the system. 

This has the advantage of ensuring that staff labels are never printed closer to the 

edge of the page than the left-hand edge of the music frame, but it also has the 

consequence that the width of each system can vary – for example, when empty 
staves are hidden, or when the condensing differs from one system to the next, 

resulting in a different maximum width for staff labels. 

Some publishers prefer the width of each system to be precisely the same, even if 

the staff labels differ. To achieve this, a new option has been added to the Staves 

and Systems page of Layout Options: set Position staff labels to Outside music 

frame. 

In addition to changing this option, you need to edit the page templates you are 

using, since by default the music frames in factory page templates fill the whole 

width of the page between the defined left and right page margins. For this new 

approach to work acceptably, you need to decide for yourself how much room to 
allow for staff labels and adjust the width of the music frame on each page template 
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accordingly. You might, for example, want to make the music frame narrower on 

the First page template to allow for full staff labels on the first page of each flow, and 

then slightly wider on the Default page template to allow for short staff labels on 

subsequent pages. 

Editing staff labels. It is now possible to select staff labels and hit Return (or double-click 

the staff label) to open the Edit Instrument Name dialog to edit the name of the 

instrument that contributes to that staff label. 

If the staff label is using the player name, rather than the name of an instrument 

held by the player, double-clicking the staff label will instead open the Edit Player 

Name dialog. 

For condensed staves that show separate inner labels for each instrument 

appearing on the staff, double-clicking the inner label (typically the instrument 
number) will edit the name for that instrument. For divisi staves, double-clicking a 

label will edit the name for the instrument, not the individual divisi section label: to 

edit the prevailing divisi group labels, find the previous divisi signpost and double-

click that, or select it and hit Return. 

Editing player group labels. It is also now possible to select player group labels and hit 

Return (or double-click the player group label) to open the Rename Player Group 

dialog. 

Players with custom staff size. Sometimes one or more of the instruments in a layout will 

use a smaller staff size than the default for the layout – for example, showing a solo 

instrument in a layout for a piano accompanist – which is achieved by choosing a 

staff size scale factor from the Edit ▶ Notation ▶ Staff Size submenu. 

In previous versions of Dorico, the staff labels for any staff using a custom scale 
factor were always drawn at the same size as those on staves using the default staff 

size. To instead scale the staff label for an instrument by the same scale factor used 

for the staff, set Staff labels on staves with custom staff size to Scale with staff 

size in the new Scale section of the Staff Labels page of Engraving Options. 

Showing player group labels when staff labels are not shown. In previous versions of 

Dorico, player group labels are only shown when staff labels are shown for a system. 

Sometimes it may be preferable for player group labels to be shown even when 

there are no staff labels. To enable this behavior, on the Staves and Systems page of 
Layout Options set Show player group labels to Always; by default, this option is set 

to When staff labels shown. 

A new Gap between player group labels and systemic barline option has been 

added to the Staff Labels page of Engraving Options, used when a player group label 

is shown but no staff labels are visible. 
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Player group labels at breaks. It is now possible to choose whether player group labels 

appear for a particular system by creating a system or frame break, then overriding 

the new Show player group labels property on the break. 

Using the property, you can either prevent the player group label from appearing 

on one system when it would otherwise be shown on all systems, or that it should 

appear on a system when it would otherwise not be shown on any system. 

Staff spacing 
Calculating staff gaps relative to default space size. By default, Dorico calculates the gap 

between a pair of staves relative to the scale factor of the upper of the two staves. 

When a player’s staff size is scaled to a value other than 100% – for example, when a 

cue staff showing a solo instrument in a layout for solo instrument and piano is 

shown at 60% the size of the piano staves – the gap between that staff and the staff 

below is scaled proportionately. 

If you would prefer the gaps between staves to be calculated according to the 
default space size, ignoring custom staff scaling, set the new Gap values are 

relative to option on the Vertical Spacing page of Layout Options to Default staff 

size. 

Tempo 
Paragraph styles. Tempo markings are now drawn using paragraph styles, rather than 

font styles. Paragraph styles allow you to define a different size for full score and 

part layouts, which is important if the full score uses a smaller staff size than the 

parts and you want the tempo to be proportionally larger relative to the staff size in 

the score than in the parts. 

Immediate, relative and reset tempos are now drawn using the Tempo (immediate) 

paragraph style, gradual tempos are drawn using the Tempo (gradual) style, and 

metronome marks are drawn using the Tempo (metronome mark) style. 

A new Metronome Mark Music Text character style has been added, used for the 

notes and rhythm dots in metronome marks. This allows independent control of the 
appearance of metronome marks, without affecting music symbols drawn using 

the existing Music Text character style. 

When you first open an existing project, Dorico will set up the new paragraph and 

character styles to match as closely as possible the corresponding legacy font styles 

that were used in previous versions. 

When you save your project, Dorico will also update the legacy font styles to match 

the current paragraph style settings, so that, as far as possible, tempo marks will 

look the same when your project is opened in previous versions of the software. If 

you specify a different size in parts for any of the new paragraph styles, that will not 
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be preserved when the project is opened in a previous version, as font styles do not 

allow different sizes in score and part layouts. 

Due to small differences in how text drawn using font styles and paragraph styles is 

measured, you may find that tempo marks in existing projects appear slightly 

further away from the staff than in previous versions; however, we have done our 

best to minimize these differences as far as possible. 

Relative tempo changes and a tempo. Some published scores show relative tempo 

changes (e.g. meno mosso) and a tempo instructions using the same appearance as 

gradual tempo changes (e.g. accel.). 

To enable this, set Paragraph style for relative changes and ‘a tempo’ markings to 

Tempo (gradual) in the new Relative Changes section of the Tempo page of 

Engraving Options. 

Circa in metronome marks. A new Circa text style option has been added to the Absolute 

Changes section of the Tempo page of Engraving Options, allowing you to choose 

whether they should be shown in roman or italic type. 

Popover syntax changes. To create a hidden tempo via the Shift+T popover, you should 
now enclose the input string in square brackets, e.g. [Andante]. This change allows 

Dorico to preserve the parentheses on metronome marks when editing existing 

tempos. 

Text 
Default placement and position. It is now possible to specify in each paragraph style the 

default placement above or below the staff, the default vertical distance from the 

staff, and a default horizontal offset relative to the rhythmic position at which a text 

item using that paragraph style appears. It is also possible to specify whether text in 

that paragraph style should avoid collisions by default. 

Because of these changes, the Default distance from staff option on the Text page 

of Engraving Options has been removed, since each paragraph style now specifies 

its own value. When opening an existing project in Dorico 6, all paragraph styles are 
updated to use the value of this engraving option by default, to preserve their 

appearance. 

In a similar vein, the Placement property, which was previously always set for every 

text item, can now be deactivated, allowing a text item’s placement to be 

determined by the default value in the paragraph style itself. When opening an 

existing project in Dorico 6, all text items have the existing placement set as a global 

property, again to preserve their appearance. 

Default case. A new Case option has been added to Library ▶ Paragraph Styles, allowing 

you to specify whether text in that paragraph style should automatically have its 
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case transformed, e.g. to all upper case, all lower case, sentence case (where the 

first letter of the first word is capitalized), or title case (where the first letter of every 

word is capitalized). 

Note that if you want to use small capitals, this can be specified for fonts that 

support this typographical feature by activating the Small Capitals font feature 

instead of using the Case drop-down. 

Dorico’s implementation of title case capitalizes the first letter of each word based 

on locale and Unicode word boundaries, but it does not follow style-guide rules for 

title casing, so it will capitalize small words like “the” or “of” regardless of context. It 

provides linguistic casing, but does not support stylistic conventions like those in 

APA or Chicago Manual of Style. 

It is also possible to specify a case transformation in a character style if needed. 

Extended font family support on Windows. In previous versions of Dorico, font families 

with multiple weights were handled quite differently between macOS and 
Windows. A family like Minion Pro with multiple weights, such as Bold, Semibold, 

Condensed, Bold Condensed, and so on, would appear as a single family Minion Pro 

on macOS, with each of the weights listed as separate styles. On Windows, however, 

styles were limited to four standard values: Regular, Italic, Bold, and Bold Italic, so 

font families with multiple weights would instead be listed as multiple families: 

Minion Pro, Minion Pro Semibold, Minion Pro Condensed, and so on. In Dorico 6, 
this limitation has been removed, and font families appear in the same way on 

Windows as they always have done on macOS. 

One consequence of this is that when you open existing projects for the first time in 

Dorico 6, any extended weights in use in your project will be reported as missing in 

the Missing Fonts dialog that appears during project opening. This dialog has been 

enhanced such that each choice you make in the dialog will be remembered and 

automatically populated when opening future projects, so you need make the 

mapping from the old font name to the new once. 

Editing text frames. When you double-click a text frame to edit its contents, if that frame 

uses a token to show information from the File ▶ Project Info dialog – such as the 
project or flow title, composer, lyricist, or copyright – Dorico now asks whether you 

want to edit the contents of the text frame directly, or rather go to the Project Info 

dialog to edit the field used by the token. 

If possible, you should avoid editing the contents of text frames directly in the 

layout, because this will always create a page template override. In general, it is 

better either to edit the field in Project Info to change the text that appears in the 

frame, or to edit the page template itself in Engrave mode (in Dorico Pro only). 
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If a text frame uses a token that shows information from Project Info, but that field 

is empty, Dorico now shows the name of the field as a placeholder in the frame in 

light gray. This placeholder is not printed or included when you export graphics, but 

it is helpful to show where text frames are, and what fields they are using. 

A new View ▶ Token Placeholders command has been added, allowing you to 

choose whether these placeholders appear. 

Letter spacing for accidentals in text tokens. Side bearings are the left and right margins 

for a glyph in a font, and determine how tight the spacing is between neighboring 

characters. The side bearings for the accidental symbols in Bravura Text and other 

SMuFL-compliant fonts are, per the specification, as small as possible. This means 
that, for example, an accidental following a note name, as they appear in staff labels, 

layout names, and harp pedal changes, can look too tight by default. 

To address this, a new Letter spacing before accidental option has been added to 

the Text page of Engraving Options. To preserve appearance, it is set to 0pt in 

existing projects, but in new projects it is set to 0.75pt. This value is only applied in 

the places where Dorico adds the accidental itself, typically in tokens. 

Instrument list tokens. {@instrumentNames@} and {@instrumentList@} tokens have 

been added, allowing you to create a comma- or newline-separated list of the 

instruments in the layout. This is most useful in part layouts, allowing you to create 

an automatic list of the instruments held by the player for that part. Percussion kits 
are handled specially: standard drum kits are always listed using the name of the 

overall kit instrument, while non-drum set kits will list the instruments in the kit, 

unless the player is also holding other instruments, in which case only the name of 

the kit will be listed. 

Filter by paragraph style. A new Edit ▶ Filter ▶ Text Using Paragraph Style dialog has 

been added, allowing you to quickly select or deselect all text items use a specific 

paragraph style. This is helpful if you then want to, for example, use Change 

Paragraph Style, or the following new feature. 

Converting staff-attached to system-attached text. To convert staff-attached text created 

via Shift+X to system-attached text created via Shift+Alt+X, select one or more text 
items, and either choose Text ▶ Change Text to System Text from the context 

menu, or use the jump bar to execute Change Text to System Text. 

Choosing a new font style for a paragraph style. If you have specified that a paragraph 

style uses a font family with a particular set of styles, and then change the family, 

Dorico tries to maintain the same style name for the newly chosen family, but if an 

identically named style isn’t available, it now tries to find a fallback style that is as 

close as possible to the original style. 
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If the new family has an identically named style, that is of course chosen. But if the 

style names differ, Dorico tries to find italic or roman style with the same or the 

closest weight; if it can’t find one with the same weight, it will choose the one with 

the smallest difference in weight, and if two styles are available with equal 

difference in weight, Dorico prefers the lighter one. This fallback procedure applies 

not only to the edited paragraph style, but also any child paragraph styles. 

This fallback procedure also applies when editing a font style, but for font styles, 

this is limited only to the edited font styles, and not any child font styles. 

Missing font substitution. When you specify a replacement font family and style in the 

Missing Fonts dialog when opening a project, Dorico now ensures that both the font 
family and style are correctly overridden in the paragraph or font style as 

appropriate, ensuring that both the chosen family and style will be used. 

Text export. File ▶ Export ▶ Text now includes an extra field that shows whether the text, 

tempo or playing technique item is hidden. In addition, quotation marks in text 

items are now correctly escaped in the output comma-separated values file. 

Crosshair. System-attached text now shows a crosshair when selected in Engrave mode. 

Ties 
Tie endpoint positioning for stemless notes. A new option Consider ‘Hide stem’ property 

when positioning tie endpoints has been added to the Advanced Options section 

of the Avoiding Collisions section of the Ties page of Engraving Options. When 

activated, Dorico will allow ties to be positioned on notes that would normally show 

stems, but which are hidden via the Hide stem property, in the same way that they 

are positioned on naturally stemless notes, i.e. whole notes (breves or longer. 

Time signatures 
Time signatures shown above the staff. Large time signatures shown above the staff now 

respect both the Cautionary time signature at end of system option on the Time 

Signatures page of Notation Options, and the similarly-named property in the Time 

Signatures group of the Properties panel. 

When Position of time signatures relative to coincident tempo and rehearsal 

marks is set to Below on the Time Signatures page of Engraving Options, a time 
signature shown above the staff will now be positioned outside all staff-attached 

items, and inside other system-attached items like system-attached text, tempos, 

and so on. 

Trills 
Horizontal offset for trill mark. A new option Horizontal offset for trill when aligned 

with notehead has been added to the Trills section of the Ornaments page of 
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Engraving Options, allowing you to specify the precise horizontal placement of the 

tr mark relative to the notehead. 

Signposts. If a trill shows neither its tr mark nor its wiggly extender line, it will now show 

a signpost if View ▶ Signposts ▶ Trills is activated. 

Tuplets 
Placement. In the Placement section of the Tuplets page of Engraving Options, the 

existing option to specify that tuplets should always be placed above notes on vocal 

instruments has been extended to allow tuplets to be placed above notes for all 

instruments. 

Horizontal position of number or ratio. A new Number x offset property has been added 

to the Tuplets group in Engrave mode, allowing you to adjust the horizontal position 

of the tuplet number or ratio relative to its bracket. 

Nudging in Engrave mode. It is now possible to nudge a selected tuplet bracket or 

number horizontally with Alt+←/→ in Engrave mode. 

User interface 
Popover vertical position. Popovers now show a small handle at the left-hand side, 

allowing you to adjust their vertical position relative to the staff. Dorico remembers 

any vertical adjustment independently for each popover, and these adjustments are 

persistent between sessions. 

Popovers now also show an attachment line, so you can tell precisely at which 

rhythmic position you are creating an item if the caret is not shown. 

Editing font settings for selected items. Many items shown in your score are drawn using 

text fonts, but it is not obvious whether an item uses a font style, which can be 

edited in Library ▶ Font Styles, or a paragraph style, edited in Library ▶ Paragraph 

Styles. 

To make it easy to change the appearance of such items, you can now right-click a 
selected item and choose Edit Font from the context menu to be taken directly to 

edit the font or paragraph style used by that item. 

This is supported for chord symbols, divisi, dynamics, figured bass, glissando lines, 

harp pedaling, lyrics, markers, percussion legends, player group labels, playing 

techniques, rehearsal marks, repeat endings, repeat markers, staff labels, text 

items, time signatures, and tuplets. 

Text editor in dialogs. In dialogs where Dorico’s rich text editor appears – for example, 

Edit Single Lyric, Edit Instrument Names, Change Divisi – the standard shortcuts 

that work when editing text directly in the score (for bold, italic, underline, 
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increasing/decreasing the font size, and Alt+X to convert to and from Unicode 

codepoints) are all now operational. 

Handles and frames. The appearance of circular handles in Write mode and square 

handles in Engrave mode has been refined, such that they are proportionally 

smaller at higher zoom levels. Handles are also more translucent at higher zoom 

levels, and are drawn using lines that are similarly thinner at higher zoom levels. 

This means that doing fine work at high zoom levels is easier, because the handles 

obscure the items you are editing. 

In a similar vein, music, text, graphics and graphic slice frames are also drawn 

using lines that are thinner at high zoom levels. 

In Write mode, the bar numbers shown by the options in the View ▶ Bar Numbers 

submenu, and the instrument names shown above each staff in galley view, are also 
proportionally smaller at high zoom levels, so they obscure less of the music you are 

editing. 

Status bar information. The informational read-out at the left-hand side of the status bar 

has been expanded to provide more information. In addition to the information 

about the selected item and the bar in which it appears, in page view Dorico now 

shows the number of the page, or range of pages, on which the selection appears; 

and it also displays the timecode position of a single item, or the time range for a 

multiple selection. For a multiple selection, Dorico also shows the duration between 
the first and last selected items in minutes and seconds (though repeats are not 

considered). 

Refreshed appearance. Multiple list view and grid view controls across the application 

have been visually redesigned to reduce their intensity and prominence. This is 

most immediately obvious on the Open Recent and Create New pages of the Hub. 

List, table and tree views across Dorico have been similarly updated, including in 

the sidebars of the library and options dialogs. 

Hub. A new What’s New page has been added to the Hub window, which is populated 

with information about new features and capabilities added in the current version. 

This data is downloaded from the Internet, so the page will only appear if you have 

an active connection, and if there is relevant information available. 

Zoom recent project thumbnails. When mousing over a recent project in the Hub’s grid 
view, a new control appears that, while pressed, will magnify the top portion of the 

selected project’s thumbnail. This helps discern between otherwise similar looking 

items. 

Follow operating system theme. The Theme drop-down in the Window section of the 

General page of Preferences now has a new Auto value. When set to Auto, Dorico 
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will automatically switch between using its dark or light appearance according to 

the overall setting for dark or light appearance in macOS and Windows. 

Showing suppressed warnings. Some warning messages that appear when using Dorico 

have a checkbox allowing you to tell Dorico not to show them again. To clear the 

history of messages you have suppressed so that Dorico is free to show them to you 

again, click Reset Warnings in the Suppressed Messages section of the General 

page of Preferences. 

Instrument filters. If you have shortcuts assigned to the commands to activate 

instrument filters and use one of those shortcuts when in page view, Dorico shows a 

message informing you that you must be in galley view to use instrument filters, 
and asking if you want to switch to galley view and activate the instrument filter. 

This message now includes a Don’t say this again checkbox, so you can decide 

whether Dorico should always switch to galley view, or never switch. 

User settings. In previous versions, some user settings – for things like jump bar aliases, 

recently-used music symbols, and saved dialog and window positions – were saved 

in property list files in the user-level Preferences folder (macOS) or in the Windows 

Registry (Windows). All user settings are now saved in the Dorico 6 folder in the 

user-level application data folder on both platforms, which makes them easier to 

manage. 

Confirming modal dialogs. It is now possible to confirm all modal dialogs by typing 
Ctrl+Return (Windows) or Command-Return (macOS). Modal dialogs typically have 

OK and Cancel buttons and prevent you from interacting with any other part of the 

application until you confirm or cancel the dialog. 

Export File Names dialog. The behavior of inserting filename ingredients in the Export 

File Names dialog has been improved: the ingredient is now inserted at the current 

cursor position. 

Selected chord symbols. The Keyboard panel will show the pitches represented by a 

selected chord symbol; these pitches are also now shown in the information read-

out in the status bar. 

Changed terminology. The term “system object”, meaning items like tempos, rehearsal 

marks, repeat markers and endings, etc., has been removed from the application, 

replaced by “system-attached item.” 

Font selectors. The menus used to choose font families, for example in Library ▶ 

Paragraph Styles, and in the text editing controls, now use a menu with embedded 
filter, allowing you to type part of the name of the font you want to choose, quickly 

narrowing down the long list of available fonts. 
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Go To Bar dialog. The Edit ▶ Go To Bar dialog now only lists flows attached to the current 

layout, rather than all flows in the project. 

Missing Fonts dialog. When moving your mouse over the column header row in the table 

in the Missing Fonts dialog (and other similar dialogs), the pointer now changes 

shape to indicate that you can resize the columns. You can also now double-click a 

column heading to resize that column to the size of the longest item in that column. 

Furthermore, Dorico now shows a visual indicator in cells in the table that will show 

a drop-down menu when clicked. 

Video 
Improved color management. Dorico’s support for attached video files has been 

improved. Video resolutions up to 8K are now supported, though playback of 8K 

video is computationally expensive. HDR video files now have improved color 

reproduction when displayed on non-HDR sRGB displays. 
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Issues resolved 
Component Issue 

Accidentals When ledger line shortening is disabled, sharp and natural accidentals could in some 
circumstances be positioned such that they abut the ledger line; this has now been fixed. 

Audio engine Some VST plug-ins built on the JUCE framework crashed as the audio engine is shut down 
when you quit Dorico; this has now been fixed. 

Bar numbers When no clef is shown at the start of a single-staff system because Clefs at start of systems 

following first system is set to Hide clefs, the offset to avoid the prevailing clef specified on 

the Bar Numbers page of Engraving Options is no longer applied. 

Chord diagrams When the option to align chord symbols across the width of the system is disabled, the grid of 
used chord diagrams at the start of the flow could be poorly aligned; this is now fixed. 

Chord symbols When selecting music on multiple instruments with a mixture of local and global chord 

symbols, trying to use Generate Notes from Chord Symbols in Selection will now always 

show the expected warning if the chord progression differs on the selected instruments. 

Clefs Creating or deleting a clef change preceding a run of grace notes with a clef interspersed 
between grace notes, or to the right of all grace notes, now correctly updates the staff position 
of the grace notes preceding the next clef change. 

Comments The Comments panel now only shows comments belonging to instruments directly assigned 
to a layout; comments belonging to instruments that are present in the layout only because 
they are cued are now excluded. 

Condensing The option to consolidate consecutive player numbers into a range on the Condensing page of 

Engraving Options now applies to Roman numerals as well as Arabic ones. 

Cues Hidden tuplets that show neither bracket nor ratio in cues no longer incorrectly show a 
signpost. 

Dynamics Under some circumstances, editing music within the span of a gradual dynamic that shows no 
continuation line could cause other items within that range to move unexpectedly; this has 
now been fixed. 

Dynamics When Position end of hairpin relative to note or chord is set to Right side of note on main 

stem, Dorico will nevertheless stop the hairpin at the left of the last note if the hairpin ends 

niente. 

Engrave mode Dragging or nudging beams in Engrave mode in condensed music where mid-phrase unisons 
are prevented now works as expected. 

Flows Write ▶ Split Flow no longer incorrectly applies layout-specific items like breaks and note 

spacing changes from other layouts into the current layout. 
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Component Issue 

Grace notes In rare circumstances, crossing a grace note to the staff above or below could cause a crash; 
this has now been fixed. 

Guitar notation When editing notes that show bends such that they overlap or end up at the same position, 
any affected guitar bends are now correctly removed. 

Guitar tablature Under some circumstances, re-choosing one of the default fretted instrument tunings from 

the drop-down in Edit Strings and Tuning after editing one or more strings in the current 

tuning could crash; this has now been fixed. 

Holds and pauses When creating a breath mark on a tied note, Dorico now snaps the breath mark forward to the 
position of the final notehead in the tie chain; this prevents the breath mark from 
unexpectedly disappearing if the tied note is split over a system break. 

Instrument families Adding a new family based on an existing family in Library ▶ Instrument Families no longer 

unexpectedly causes the list of families to be sorted alphabetically. 

Instrument filters A long-standing unreliability that could cause some instruments that should be hidden by an 
instrument filter to nevertheless appear has been fixed. 

Instrument score 
orders 

Alto trombone is now correctly positioned before tenor trombone in the factory default 
instrument score orders. 

Instrument types After saving a custom tuning to the user library as a default for future projects, you can now 

correctly choose that custom tuning in the Edit Strings and Tuning dialog for a different 

fretted instrument. 

Jump bar Under some circumstances, Dorico could trigger the most frequently used command instead 
of the command shown in the jump bar when reopened; this has now been fixed. 

Key Editor Changing the start and end offsets of notes using the commands Decrease Playback End 

Offset and Increase Playback End Offset now correctly immediately updates the display in 

the piano roll. 

Library Manager When importing library items using the Library Manager, Dorico would incorrectly omit some 
dependent items, resulting in imported items sometimes not having the expected 
appearance; this has now been fixed. 

Library Manager Under some circumstances, changing the Layout or Flow drop-down in the Library Manager 

would not result in the correct status being shown for options or collections; this has now 
been fixed. 

Lines Hyphenated text annotations are now drawn with the correct rotation for vertical lines. 
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Component Issue 

Lyrics If the Lyrics (Verse Numbers) paragraph style is a different size to the Lyrics paragraph style, 

verse numbers would be incorrectly vertically aligned relative to the lyrics to their right; this 
has now been fixed. 

Lyrics When inputting Latin alphabetic lyrics when the Korean IME is active, it is now possible to 
create hyphens, as expected. 

Lyrics When exporting lyrics to a text file, they are now always correctly exported in line order. 

MusicXML export Dorico no longer incorrectly treats numbered bar regions like bar repeat regions in MusicXML 
export. 

MusicXML import In rare circumstances, Dorico could create paragraph styles with no specified font during 
MusicXML import, which could lead to instability when working with the project; this has now 
been fixed. 

Navigation When navigating to rehearsal marks via the jump bar or the Go To dialog, Dorico now better 

handles rehearsal mark sequences with an overridden starting index. 

Note input Some note input commands, such as specifying a new duration in duration before pitch input, 
were unnecessarily triggering Dorico to recalculate playback information, which was 
noticeable in larger projects; this has now been fixed. 

Note input Step-time note input from MIDI devices that produce copious MIDI CC data, such as wind 
controllers, now works more reliably. 

Note input When adding bars using the Shift+B popover, Dorico now correctly accounts for the total 

length of aggregate time signatures. 

Note input Moving the caret up and down between staves when multiple windows are open on the same 
project now works reliably. 

Percussion When saving a percussion instrument to your user library, Dorico now ensures that the 
percussion playing technique data for each saved instrument is correctly saved 
independently; previously it was possible for the playing technique data for one instrument to 
be overwritten by the data for another. 

Percussion Under some circumstances, inputting a grace note inside a tuplet in a percussion kit using the 
five-line staff presentation type could fail, or result in unwanted rests being created in other 
voices; this has now been fixed. 

Platform support Dorico will now start correctly if it is installed in a path containing one or more characters 
with diacritics (Windows only). 

Platform support When Dorico is set to quit after the last project window is closed, and the Mixer is open, the 
application no longer crashes on exit (Windows only). 
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Component Issue 

Playback Under some circumstances, a fermata following an a tempo marking could play excessively 
long, if a hidden tempo preceded the a tempo; this has now been fixed. 

Playback A hidden tempo at the start of the flow is now correctly considered when working out the 
restorative tempo after a fermata. 

Playback Under some circumstances, Dorico could hang indefinitely when calculating polyphonic voice 
balancing; this has now been fixed. 

Playing techniques When editing an existing hidden or parenthesized playing technique via the Shift+P popover, 

the populated text now shows parentheses and/or brackets as appropriate. 

Playing techniques Clicking a playing technique into the score from the panel could erroneously also create a 
second playing technique on the following note; this has now been fixed. 

Playing techniques Creating multiple piano pedal lines in succession from a loaded mouse pointer now works 
reliably. 

Playing techniques Playing techniques now appear correctly on grace note runs in percussion kits shown in the 
five-line staff or grid presentation types. 

Playing techniques Under some circumstances, deleting a playing technique and then undoing its deletion would 
result in the playing technique initially reappearing at the wrong vertical position; this has 
now been fixed. 

Print mode If auto-save is triggered while Dorico is preparing layouts for printing or exporting in Print 
mode, Dorico could crash; this has now been fixed. 

Rehearsal marks Under some circumstances, changing the Instrument transition position option on the 

Players page of Layout Options could cause rehearsal marks at the transition position to 

temporarily disappear; this has now been fixed. 

Selections Making a block selection with Shift+click on a staff now reliably selects any material that is 

played by other instruments held by the player and shown due to instrument changes. 

Selections Under some circumstances, Dorico could crash when using Edit ▶ Select More; this has now 

been fixed. 

Text The calculation of missing fonts when opening an existing project has been improved, and 
correctly handles font and paragraph styles with overridden styles but inherited families. 

Text The {@staffLabelsFull@} and {@staffLabelsShort@} tokens now correctly inherit an 

overridden font, if set in the text editor. 

Time signatures Using the Pick-up bar of option in the Create Time Signature section of the Time Signatures 

panel now works more reliably. 
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Component Issue 

Time signatures The Cautionary time signature at end of system option on the Time Signatures page of 

Notation Options no longer incorrectly takes effect in galley view. 

Time signatures In rare circumstances, music could be rebarred differently after re-opening a saved project, 
because Dorico was discarding which of the aggregate time signatures in a set should be used 
at e.g. a special barline; this has now been fixed. 

User interface Under some circumstances, the gradient previews in the Colors page of Preferences did not 

always update immediately after choosing a preset gradient; this has now been fixed. 

User interface In some dialogs, inputting floating point values into spin boxes did not work correctly; this has 
now been fixed. 

User interface Menu items in the Write menu that trigger popovers are now correctly disabled if nothing is 

selected and/or the caret is not visible. 

User interface Right-clicking on a player, layout, or flow now ensures that the list item is correctly selected 
before the context menu appears, so all menu items are appropriately enabled or disabled. 

User interface It is now possible to use Return/Enter to open the highlighted project on the Open Recent 

page of the Hub, when either the grid or list view is shown. 

User interface Flow names that include characters that could be interpreted as an ordered or unordered list 
in Markdown now appear correctly in the project window title bar. 

User interface Selecting a line with a hyphenated text annotation in Library ▶ Lines now correctly updates 

the annotation controls on the right-hand side of the dialog. 

User interface Zoom commands now include the word “zoom” in their names in the jump bar. 

User interface Hide All VST Plug-in Windows can now be used in any mode, not only in Play mode. 

User interface The Paragraph Styles and Character Styles dialog now independently remember their size 

and position. 

User interface Move View to Next Page/Spread now work reliably in all circumstances. 

User interface Navigating to a specific page now always works correctly at all zoom levels; previously, in long 
projects at zoom levels around 100% it was possible for Dorico to overshoot the target page. 

User interface All the library editing dialogs in the Library menu now correctly save and restore their size 

and position independently of each other. 

User interface Under some circumstances, hopping the selection left when out of view to the right, or 
hopping the selection right when out of view to the left, would not cause the new selection to 
be brought into view; this has now been fixed. 
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