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Dorico 2.2.20 

23 April 2019 

Improvements 

Key commands 

Printing. New commands have been added to which keyboard shortcuts can be 
assigned to print the current page, layout, or all layouts without switching to Print 
mode. Look in the Print category on the Key Commands page of Preferences, 
where you will find the following new commands: 

§ Export All Layouts as PDF 
§ Export Current Layout as PDF 
§ Export Current Page as PDF 
§ Print Current Layout 
§ Print Current Page 

When you print or export using any of these commands, the current print options 
as specified in Print mode for the relevant layout will be used. 

Print preview. It is now possible to go to the first page in the print preview by 
pressing Home, and to go to the final page in the print preview by pressing End. 

Note input 

Auditioning whole chords. A new option Play all notes in chord when any is 
selected has been added to the Auditioning section of the Note Input and 
Editing page of the Preferences dialog. When this option is switched on, when you 
select any note in a chord – for example, by clicking on it or by navigating to it 
using the arrow keys – all notes in that chord will be auditioned. 

Maintaining selection after deletion. When you delete one or more selected items, 
Dorico will now attempt to select another item nearby to the rhythmic position of 
the first deleted item, so that you do not have to pick up the mouse and click back 
in that area or otherwise manually reselect something in order to continue editing 
the music. 

If you delete a note, Dorico will first select another note in the same voice at the 
same rhythmic position, and failing that select a note in the same voice at an earlier 
rhythmic position (up to four quarter note beats earlier). If you delete a non-note 
voice-specific item, Dorico will select a note in that voice at or near that rhythmic 
position, if possible. If you delete a non-voice-specific item (such as a slur, pedal 
line, or dynamic), Dorico will select a note in the first voice on the top staff 
belonging to that instrument at or near that rhythmic position. If you delete a 
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system-attached item (such as a tempo, chord symbol, or repeat ending), Dorico 
will select a note in the first voice on the top staff in the system at or near that 
rhythmic position. All of these selection operations may result in the viewport being 
moved to bring the newly-selected item into view, with a greater likelihood of 
movement when deleting a system-attached item. 

Tempo track import 

A new option Show border around system text markers has been added to the 
Import Tempo Track dialog. It is only enabled when the option to import markers 
as system-attached text is chosen. Deactivate this option to import markers as text 
with no border around them. 

Issues resolved 
ID # Component Issue 

STEAM-9198 Barlines 
Barlines and bar numbers can now be copied and pasted as part of the same operation as 
copying and pasting a time signature. 

STEAM-9305 Dynamics 
Under certain circumstances, replacing a dynamic with an SVG graphic in the Music 
Symbols dialog could cause parts of the music not to draw; this has now been resolved. 

STEAM-9189 Flows 
Clicking on a card in the Flows panel in Setup mode now correctly navigates to that flow 
even if the first bar in that flow is not numbered 1. 

STEAM-7952 Grace notes Grace notes on percussion kits now play back correctly once more. 

STEAM-7831 
Graphics 
export 

The size and position of text in exported SVG graphics is now correct (Windows only). 

STEAM-9229 
Key 
signatures 

Custom key signatures with octave position overrides for particular clefs now appear with 
accidentals in the correct octaves in the preamble at the start of the system. 

STEAM-9212 MIDI export 
Under some circumstances, some of the notes from a trill late in a flow could erroneously 
appear at the start of the exported MIDI file. This problem has now been resolved. 

STEAM-9195 
Multi-bar 
rests 

An immediate dynamic that coincides with the start of a multi-bar rest will no longer cause 
the multi-bar rest to be broken. 

STEAM-9213 
Multi-bar 
rests 

Dorico no longer crashes when attempting to exclude single bar multi-bar rests from 
spacing in the presence of multiple local time signatures. 

STEAM-9197 Note input 
When pasting a selection that extends the flow, Dorico now correctly adds an extra bar if 
necessary to ensure that any item at the end of the selection is shown. 

 Noteheads The stem attachment positions for the wide diamond notehead have been improved. 

STEAM-9239 Page layout 
System and frame breaks at tacet flows are now considered correctly when determining 
whether to wait for the next system or frame break. 

STEAM-9288 Playback 
Under certain circumstances, starting playback from midway through a flow could cause 
notes prior to the start position to be played back; this has now been resolved. 
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ID # Component Issue 

STEAM-9290 
Playing 
techniques 

Changing the global space size at a system break now correctly causes playing techniques 
following the break to redraw at the correct size right away. 

 Project files 
Dorico will no longer crash on start-up if it encounters files other than Dorico projects in 
the AutoSave folder. 

STEAM-9122 Project files 
Dorico no longer crashes when saving a backup project if the project filename contains an 
unmatched opening or closing parenthesis. 

STEAM-9270 
Rhythm 
slashes 

Dorico will no longer sometimes crash when extending a rhythm slash region into a bar 
with an open meter. 

STEAM-9193 
Time 
signatures 

Selecting a barline belonging to an open time signature and hitting Return to open the 
Shift+B popover no longer sometimes causes a crash. 

STEAM-9140 Tremolos 
Resetting the beaming of notes with single-stem tremolos no longer incorrectly prevents 
them from playing back as tremolos. 

STEAM-9178 Tremolos 
Resetting the beaming of notes with multi-note tremolos now correctly immediately 
removes their tremolo effect in playback. 

STEAM-9245 Tremolos 
Activating the Single-stem tremolo property for a note in a tie chain no longer sometimes 
causes the rhythmic splits earlier in the tie chain to change. 

 User interface 
The keys [ and ] are no longer bound to the buttons to show the information for the next or 
previous flow in the Project Info dialog. 

 User interface 
It is now possible to specify Pitch of A4 to three decimal places on the Tuning page of 
Playback Options. 

 User interface 
The step size when incrementing or decrementing the value via the paddle arrows in the 
multi-unit spin box used for measurements is now more appropriate for each unit type. 

 User interface 
The space size and page dimension read-outs in the expanded cards in the Layouts panel 
in Setup mode now use an appropriate level of precision for each measurement unit. 

STEAM-9105 User interface 
The Delete Layout button in the Layouts panel in Setup mode now works correctly and no 
longer sometimes results in the application crashing when it is clicked. 

STEAM-9113 User interface 
The display of the current layout transposition (i.e. concert or transposed pitch) in the 
status bar is now always updated correctly when switching layouts. 

STEAM-9194 User interface 
The rhythm dot buttons for the left- and right-hand side durations in the Tempo Equation 
section of the Tempo panel now update correctly. 

STEAM-9207 User interface 
Home and End always move left and right by a screenful in galley view, rather than 
sometimes incorrectly using the width of the first flow to determine the increment. 

 Video 
It is now possible to set a very large video attachment position (9999 beats) in the Video 
Properties dialog. 
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Dorico 2.2.10 

31 January 2019 

New features 

Flipping items 

A new Edit ▸ Flip command has been added, with the default key command of F. 
This command will flip the placement of all items that can be positioned above or 
below the staff (such as text items, lyrics, articulations, etc.) and will flip the 
direction of items such as stems, slurs, and ties. 

Some items – including ties and articulations – can only be selected individually in 
Engrave mode, and hence can only be flipped in Engrave mode. 

You cannot flip the selected item during note input in Write mode, because the key 
command F will instead input a note with the pitch F. If you want to be able to flip 

the selected item during note input, you can reassign Edit ▸ Flip to another key 
combination in the Key Commands page of Preferences. 

When you flip an item, the appropriate Placement or Direction property is set. To 
undo the effect of having flipped an item, either deactivate the appropriate property 
in the Properties panel, or choose Edit ▸ Reset Position. 

Slurs with multiple segments (e.g. S-shaped cross-staff slurs) and tuplet brackets 
on cross-staff notes whose hooks point in opposite directions are handled 
specially: if you have multiple slurs or tuplets selected, unless all of them have 
compatible directions set, they will flip simply to above or below. 

Auto-save 

While you are working on a project, Dorico will periodically save a copy of the 
project into a folder called AutoSave located inside your Dorico Projects folder 
(inside your user account’s Documents folder by default). Even if you do not save 
your project at all, Dorico will update the auto-saved project every few minutes, so 
that in the unlikely event that Dorico crashes, when it next starts up, you will be 
given the chance to recover the latest auto-saved version of your project, thus 
minimizing the amount of work you may lose. 

Recovering auto-saved projects. When you restart Dorico after it has crashed, if 
there are any auto-saved projects to recover, after the splash screen disappears 
Dorico will display the following dialog: 
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By default, Dorico will offer to recover all auto-saved projects, but if you want to 
recover only some of those listed, deactivate the checkboxes of those projects you 
do not want to recover, then click Recover Selected Projects. If, on the other 
hand, you know you do not need to recover any of the listed projects, you can click 
Discard All: be warned that all auto-saved projects will be deleted immediately 
after you click the button, and recovery after that point is impossible. 

After a project is recovered, choose File ▸ Save to save it permanently: you will be 
prompted to provide the appropriate filename and location to save the project at 
that point. 

Changing the auto-save interval. By default, Dorico saves the active project every 
five minutes. To change the interval, set Auto-save every n minutes in the Files 
section of the General page of Preferences to the desired auto-save interval. If you 
wish to disable auto-save altogether, deactivate the Auto-save every n minutes 
checkbox instead. 

Changing the auto-save location. If you want to specify that Dorico uses a different 
folder for auto-save than the default, click the Choose button beside the Auto-
save folder read-out in the Files section of the General page of Preferences, and 
choose a new location. If the folder specified here does not exist, Dorico will try to 
create it when it starts up. If Dorico is unable to write to the specified folder, auto-
save will not work, and you will not be warned, so if you change the default 
location, be sure it is a location into which your user account can successfully save 
files. 

Auto-save with multiple open projects. Because Dorico can only keep a single 
project active for playback at any given time, if you have multiple projects open, 
only the active project, i.e. the one you are working on at the moment the auto-save 
interval is reached, will be auto-saved. If you are switching back and forth between 
multiple projects, you may wish to consider setting a smaller auto-save interval. 
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When Dorico performs an auto-save, depending on the size of the project, you may 
notice the program become less responsive for a moment while the project is 
saved. 

Removal of auto-saved projects. When you close a project, its auto-save file is 
deleted right away. Likewise, when you quit Dorico, all auto-save files are deleted 
when the application closes. 

Remember that if you need to get back to an earlier version of a project, by default 
Dorico saves a snapshot of the project each time you explicitly save it inside an 
appropriately-named folder inside the Backup Projects folder inside the Dorico 
Projects folder in your user’s Documents folder. 

Improvements 

Barlines 

Systemic barlines for single-staff systems. A new option Barline at start of 
systems following first system has been added to the Barlines page of Notation 
Options, allowing you to show a systemic barline for a single-staff system after the 
first system. This convention was used in hand-copied lead sheets, normally when 
the clef is excluded at the start of systems after the first. 

Graphics export 

Export Filenames. A new Export Filenames dialog has been added, allowing you 
to define a recipe for how the filenames for exported graphics should be 
determined. The dialog can be accessed via the Files page of Preferences, or by 
clicking Export Filenames in the right-hand panel in Print mode when Destination 
is set to Graphics. 

 



 

 
Dorico 2 Version History Page 10 Steinberg Media Technologies GmbH 

The dialog allows you to set a different recipe for each supported graphics format. 
Choose the format whose recipe you want to edit from the Filenames for drop-
down at the top of the dialog. The Filename recipe edit box allows you to add or 
change the ingredients in the recipe directly, or you can click any of the Filename 
ingredients buttons below to add that ingredient to the end of the current recipe. 
The ingredients will be appended and/or prepended with the text shown in the 
Default separator edit box as appropriate. 

If a project is active when the dialog is opened, a Preview line will appear showing 
an example of what the resulting filename will look like using the current recipe. 

To reset a recipe back to its factory default, click Reset to Factory. To copy the 
current recipe to all other export formats, click Copy to All. Note that PDF is a 
multi-page format, so the $p token for page number can not be resolved 
intelligently for that format. 

The settings chosen in the Export Filenames dialog are saved in Dorico’s 
preferences and will apply to all projects. 

Export folder. The folder into which graphics files are exported is saved along with 
each project. If you move a project to another computer, or receive a project from 
another person (particularly if that person is using Dorico on a different operating 
system), then the destination saved in the project may not be accessible or 
possible to recreate on the computer on which the project is later opened. If Dorico 
determines this to be the case, it automatically now updates the folder to the folder 
from which the project itself is being opened. This avoids you seeing a confusing 
error when attempting to export graphics from a project that was last saved on 
another computer. 

Layouts 

Renumbering layouts. A new Setup ▸ Renumber Layouts command has been 
added to set the layout number according to the order the layouts of that type are 
listed in the Layouts panel. The quickest way to renumber layouts is therefore to 
drag them into the desired numerical order in the Layouts panel, then choose 
Setup ▸ Renumber Layouts. 

Propagate Part Formatting. Settings related to flow headings and tacet flows are 

now propagated when using Setup ▸ Propagate Part Formatting when the 
Propagate layout options checkbox is activated. 

MIDI recording 

Fill gaps. A new Fill gaps option has been added to the Quantization Options 

dialog, and to the Edit ▸ Requantize dialog, allowing you to determine whether or 
not Dorico should fill in the gaps between short notes for music input via MIDI 
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recording or importing a MIDI file. If you are importing music that is already 
precisely quantized, then you may prefer to switch Fill gaps off, to ensure that note 
and rest durations are notated exactly as quantized. 

Piano pedaling. A new Import CC64 as pedal lines option has been added to the 
Recording section of the Play page of Preferences, allowing you to choose 
whether or not Dorico should interpret sustain pedal controllers in MIDI recording 
and when importing a MIDI file as pedal lines. A further dependent option, Snap 
pedal lines to previous beat, snaps the start position of a created pedal line back 
to the start of the beat as it would normally be notated (even though the point at 
which the pedal is depressed follows the onset of the note or chord). 

Input pitch. The current setting chosen in the Write ▸ Input Pitch submenu is now 
respected during MIDI recording, so you can record in written or sounding pitch. 
Furthermore, octave-transposing instruments (such as piccolo, guitar and double 
bass) now sound at the correct octave in MIDI input. 

Multi-bar rests 

Staff-attached text. Text items that coincide with the start of a bar no longer cause 
that bar to be completely separated from an ongoing multi-bar rest. An ongoing 
multi-bar rest will be broken by the text item, but provided the text item coincides 
with the start of the bar, the bar itself can then be consolidated into the following 
multi-bar rest. 

Tacets. Where a player is assigned to a flow but has no music, a “tacet” multi-bar 
rest will appear (as distinct from a tacet flow, where no staff appears at all). When 
a flow is only a few bars in length, for example in a musical theatre show, you may 
prefer to show the number of bars in the flow instead of simply showing the word 
“tacet” so that your players can see at a glance that the cue is short. To 
accommodate this, a new Minimum number of bars in flow to show ‘Tacet’ 
option has been added to the Rests page of Engraving Options. By default, a flow 
shorter than 16 bars will show the number of bars in the flow, and longer flows will 
show the word “tacet.” 

Width of single bar rests. In layouts where multi-bar rests are shown, when Bar 
count for single bar rests on the Rests page of Engraving Options is set to No 
bar count, single bar rests are now spaced as normal bars, rather than as multi-bar 
rests; only if this option is set to Show bar count will they be spaced according to 
the options under Spacing below. This improvement may slightly change the 
appearance of existing projects when opened in Dorico 2.2.10. 
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Playback 

Playing techniques. Playback playing techniques that are defined as Attributes 
rather than Directions, that is those that apply only to the note or chord on which 
they are written (e.g. snap pizzicato, written as a symbol above the note or chord) 
as opposed to those that are ongoing until they are countermanded by a further 
instruction (e.g. pizzicato, written as the text pizz. and later countermanded by the 
text arco), are now handled correctly during playback. 

Dorico now correctly takes into account the duration of the note or chord that 
coincides with the playing technique, and restores the previous playing technique 
again at the end of that note or chord. This allows playing techniques such as 
harmonics for guitar, snap pizzicato for strings, and so on, to be played back 
correctly (provided they are defined in the VST Expression Map). 

Mute/open. Changes of mute, common for brass instruments, are now handled 
correctly in playback. Previously, instructions such as open or mute off would not 
correctly remove a previous mute, and changing from one mute to another – for 
example, moving from straight mute to cup mute – would also not work correctly. 
Now these techniques are all handled correctly (provided they are defined in the 
VST Expression Map). 

Gradual dynamics. If a gradual dynamic is followed by an immediate dynamic that 
is contrary to the direction of the gradual dynamic – for example, a diminuendo 
from  followed by  – the gradual dynamic now plays the expected direction. 
Previously, the direction of the gradual dynamic would be overridden by the 
immediate dynamic at its end, so dim. followed by  would play back as a 
crescendo. 

Printing 

Transposition warning. When one or more of the part layouts selected for printing 
or graphics export is set to display in concert pitch, when you click Print or Export 
in Print mode, Dorico will show a warning dialog reminding you that some layouts 
are currently set to display in concert pitch, and offering to automatically set them 
to transposed pitch for you: 
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If you simply click Change Transposition, all of the listed layouts will be changed 
to transposed pitch, and then the print or export operation will be carried out; if you 
click Proceed Anyway, Dorico will carry out the print or export operation but leave 
those layouts in concert pitch; if you click Cancel, the operation will be cancelled 
altogether. To change the transposition of only some of the layouts, simply 
deactivate the relevant checkboxes before you click Change Transposition. 

Custom paper sizes. For layouts using unusual page sizes, such as 9”x12” for 
parts, if this paper size is not supported by default on the selected printer, but the 
printer supports paper of this or larger dimensions, as long as the chosen page 
size matches a standard paper size, it will appear in the list of sizes shown in Print 
mode. Whether or not it will actually print successfully depends on the capabilities 
of your printer. 

Repeat markers 

Repeat count. A new Repeat Count paragraph style has been added, allowing you 
to change the appearance of the e.g. Play 4 times text that appears at the end of a 
repeated section independently from the appearance of staff labels. 

Automatic double barline. A new Barline coinciding with repeat jump before 
coda option has been added to the Repeats section of the Barlines page of 
Engraving Options, allowing you to specify that Dorico should automatically show a 
double barline at the end of the bar immediately preceding a coda. 

Rhythmic notation 

Slash and bar repeat regions. It is now possible to create a slash region or a bar 
repeat region from the position of the caret; previously it required a note or rest to 
be selected. 

Text 

Flow numbers. New {@flowNumberRomanLower@} and 
{@flowNumberRomanUpper@} tokens have been added to show the flow 
number as a lower case (e.g. i, iv, x) or upper case (e.g. I, IV, X) Roman numerals. 

Time signatures 

Pick-up bars. A new Group first bar as pick-up property has been added to the 
Time Signatures group in the Properties panel. This allows you to override the 
rhythmic grouping in the irregular bar immediately following a time signature. Pick-
up bars are rhythmically grouped as if they count backwards from the end of a bar, 
rather than counting forward from the start of the bar, and Dorico uses heuristics to 
determine whether a given irregular bar should be considered as a pick-up bar. 

In the event that these heuristics do not give the desired result, it is possible to 
force a bar that Dorico has identified as a pick-up bar to be grouped as a normal 
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irregular bar, or indeed to force a bar that Dorico has identified as a normal 
irregular bar to be grouped as a pick-up bar, by activating the Group first bar as 
pick-up property and setting it as appropriate. 

Trills 

Trill extension lines. A new choice has been added to the Extension line for trills 
option in the Trills section of the Ornaments page of Engraving Options: choose 
Show on tied notes to automatically show an extension line when a trill spans 
multiple tied noteheads and show only the  symbol when the trilled note is written 
as a single notehead. 

Auxiliary notes. It is now possible to use any notehead set for the auxiliary note 
displayed for a trill, allowing you to indicate that the trilled-to note should be played 
as, say, a harmonic. To change the notehead used for the auxiliary note, select the 

trill or the auxiliary note and choose the desired notehead set from the Edit ▸ 
Noteheads menu. 

Furthermore, auxiliary notes are automatically hidden for trills whose trill interval is 
set to unison, except in the case that the notehead set is overridden, in which case 
the auxiliary note will appear. 

User interface 

System track. The system track now correctly shows ruler subdivisions for long, 
open metered bars.  

Playback templates. You can now confirm your choice in Play ▸ Playback 
Template by simply double-clicking the item in the list. 

Percussion maps. The last chosen percussion map, the state of Show all / Show 
MIDI notes in use, and the size of the dialog is now saved and restored when 
returning to Play ▸ Percussion Maps during the same session. 

New key commands. Some new commands have been added to the Key 
Commands page of Preferences, allowing you to set keyboard shortcuts for a 
number of operations that can otherwise only be performed using the Properties 
panel: 

§ Toggle Accidental Visibility: for a selected note or grace note, cycles 
through forcing its accidental to be hidden, shown, or shown in 
parentheses. 

§ Hide Accidental: for a selected note or grace note, forces its accidental to 
be hidden. 

§ Show Accidental: for a selected note or grace note, forces its accidental 
to be shown. 



 

 
Dorico 2 Version History Page 15 Steinberg Media Technologies GmbH 

§ Show Accidental in Parentheses: for a selected note or grace note, 
forces its accidental to be shown in parentheses. 

§ Toggle Laissez Vibrer Tie: for a selected note or grace note, toggles 
whether it should show a laissez vibrer tie.   
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Issues resolved 
ID # Component Issue 

STEAM-4241 Accidentals 
Changing the pitch of a grace note before the barline no longer incorrectly considers the 
state of the accidentals in the following bar. 

STEAM-8900 Accidentals 
A number of problems related to the appearance and disappearance of accidentals when 
using the Modernist accidental duration rule have been fixed. 

STEAM-9075 Accidentals 
Under some circumstances, accidentals on altered unisons could appear or disappear 
when editing surrounding music; this problem has now been fixed.  

STEAM-8916 Audio export 
Audio export no longer fails with an error if the project or flow title contains a carriage 
return. 

STEAM-8944 Bar repeats 
When using fixed casting off, bar repeat regions now correctly respect the desired number 
of bars per system. 

STEAM-8974 Barlines 
Under some circumstances, adding a special barline could cause a crash; this problem has 
now been resolved. 

STEAM-8889 
Brackets and 
braces 

Nudging the handle on the top or bottom end of a barline in Engrave mode no longer 
sometimes ends up reselecting the wrong handle. 

STEAM-8917 
Brackets and 
braces 

Creating a bracketing change at the same position as an existing bracketing change now 
correctly overwrites the existing change. 

STEAM-8991 Divisi 
Under some circumstances, nudging a long octave line in Engrave mode on an instrument 
with divisi staves could cause a crash; this problem has now been resolved. 

STEAM-9003 
Engrave 
mode 

It is now possible to set the constraint properties for frames to zero in Engrave mode. 

STEAM-8913 Fingering 
Fingerings for guitar in projects created in Dorico 2.1.10 or earlier no longer unexpectedly 
disappear when opening them in the current version. 

STEAM-8931 Flows 
When adding a player to multiple flows, the player is now correctly added to any flows that 
it was not previously attached to, rather than not being added to any of them. 

STEAM-8955 Instruments 
Changing the instrument held by a player to an instrument with fewer staves than the 
original instrument no longer fails if the top staff of the original instrument had no music. 

STEAM-8996 
Key 
signatures 

Under some circumstances, editing the current tonality system could cause some or all of 
the music in the flow to appear to be deleted; this has now been resolved. 

STEAM-9020 Licensing 
On some Macs running macOS 10.14 Mojave, Dorico could intermittently hang during 
start-up. This problem has now been resolved. 

STEAM-8928 MIDI import 
Importing a MIDI file whose track names or other metadata use unexpected text encodings 
no longer causes Dorico to crash. 

STEAM-8894 
MIDI 
recording 

The first note input via MIDI recording is no longer spelled as if the key signature at the 
start of the flow were active rather than the prevailing one at the recording position. 

STEAM-8920 
STEAM-8952 

MIDI 
recording 

MIDI recording now correctly takes repeats into account. 

STEAM-8921 
MIDI 
recording 

Edit ▸Requantize now works correctly in irregular bars and all kinds of compound time 
signatures. 
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ID # Component Issue 

STEAM-8924 
MIDI 
recording 

MIDI recording now correctly takes into account the current setting for Write ▸ Input 
Pitch, allowing you to record in either written or sounding pitch. 

STEAM-8929 
MIDI 
recording 

Edit ▸Requantize now always correctly applies the specified minimum note durations 
when quantizing. 

STEAM-8948 
MIDI 
recording 

The transcription of tuplets in irregular meters has been improved. 

STEAM-8972 
MIDI 
recording 

Recording onto one of the instruments belonging to a player holding multiple instruments 
in galley view now always records into the correct instrument. 

STEAM-8998 
MIDI 
recording 

The metronome click now plays back correctly in irregular bars that are longer than the 
prevailing time signature. 

STEAM-9062 
MIDI 
recording 

When recording into a flow other than the first in a project, the correct key and time 
signatures are now used for notating the recorded music. 

STEAM-9068 
MIDI 
recording 

When recording into a flow other than the first in a project, the first note recorded is no 
longer sometimes dropped. 

STEAM-9076 
MIDI 
recording 

When recording into an instrument that has extra staves added, pedal lines created by 
recording sustain pedal changes now correctly appear below the bottom staff. 

STEAM-8914 Mixer 
Changing mode with the Mixer open no longer causes EQ, sends and inserts sections for 
each fader to be hidden if they were shown. 

STEAM-8943 Mixer 
The mute/solo state of the video fader is now correctly reset when a new playback 
template is applied via Play ▸ Playback Template. 

STEAM-9051 
Multi-bar 
rests 

Single-bar multi-bar rests now use the double whole (breve) rest instead of the whole 
(semibreve) rest if the option to show bar rests in long bars is set appropriately. 

STEAM-9056 
Multi-bar 
rests 

Multi-bar rests now appear correctly where a grace note appears at the start of the flow. 

STEAM-8075 
Music 
symbols 

When using an imported graphic in place of a music symbol, when printed there is no 
longer a slightly blurry image for that item. 

STEAM-8912 
MusicXML 
import 

Under some circumstances, gradual dynamics with large offsets could be imported from 
MusicXML files with incorrect durations; this has now been fixed. 

STEAM-8988 
MusicXML 
import 

Under some circumstances, gradual dynamics can be exported from Cubase with 
excessively large offsets; these are now truncated to prevent absurdly long hairpins. 

STEAM-5290 Note input 
When using step-time or MIDI recording for octave transposing instruments, the pitch you 
hear is now always in the correct octave. 

STEAM-8905 Note input 
Under some circumstances, doubling or halving note duration with the caret visible could 
cause the caret to advance too far; this problem has now been resolved. 

STEAM-8982 Note input 
Pasting material copied from an unpitched percussion kit onto a pitched instrument now 
correctly overwrites the existing material on the pitched instrument. 

STEAM-8956 Ossias 
A redundant clef no longer appears at the position of an instrument change between two 
instruments using the same clef if an ossia staff is present on one of the instruments. 
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ID # Component Issue 

STEAM-8995 Ossias 
When using Split Flow, music on ossia staves following the point at which the flow is split 
is no longer lost. 

STEAM-9001 Ossias 
Empty ossia staves no longer appear or disappear incorrectly based on the layout option to 
show extra staves across the whole width of the system. 

STEAM-9027 Ossias 
Showing a mid-system preamble on an ossia staff belonging to an instrument held by a 
section player now works correctly. 

STEAM-9031 Ossias 
Under some circumstances, an ossia staff could be made to appear when the main staff 
associated with it is hidden; this problem has now been fixed. 

STEAM-8902 Page layout Dorico no longer crashes if a flow overflows the end of a layout-specific music frame chain. 

STEAM-8910 Page layout 
Using Any flow starting at top of page option to use the First master page no longer 
sometimes causes music to disappear when at least one flow is tacet. 

STEAM-8911 Page layout 
Time signatures could sometimes appear incorrectly at the end of a system involving 
transitions between instruments with differing number of staves; this is now fixed. 

STEAM-8922 Page layout 
Break signposts on tacet flows now correctly respect the View options checkbox in the 
Annotations section of the right-hand panel in Print mode. 

STEAM-9039 Page layout 
Adding extra staves before the first existing position at which an extra staff is added no 
longer creates an additional staff, instead correctly reusing the existing extra staff. 

STEAM-9057 Page layout 
When leaving the master page editor and choosing to discard the changes, the warning 
about losing those changes now appears only once. 

STEAM-9060 Page layout 
Under some circumstances, flow headings might not be updated correctly when they end 
up being moved to another page by casting off changes; this has now been resolved. 

STEAM-9013 Pedal lines 
Under rare circumstances, a pedal line of a very particular length could cause Dorico to 
crash when printing or exporting graphics; this problem has now been fixed. 

STEAM-9058 Percussion 
Note input onto a percussion kit will no longer incorrectly duplicate existing articulations on 
other voices in the kit to the newly-input notes. 

STEAM-8741 Performance 
Some of the panels in Write mode were unnecessarily recalculated every time the 
selection changes; this has now been resolved. 

STEAM-8976 Performance 
The system track has been optimized and now has considerably less impact on the speed 
of editing in both page and galley view when it is shown. 

STEAM-8981 Performance 
Dorico now breaks alignment in large dynamic groups with gaps of 12 quarter notes 
(crotchets) or longer in galley view to improve redraw performance. 

STEAM-8984 Performance 
The speed of opening large projects with many playing techniques, and of preparing for 
playback after making changes to the music, has been significantly improved. 

STEAM-8990 Performance 
Double-clicking to edit an item or show the caret now works reliably in larger projects, in 
both page and galley view, whether or not the system track is shown. 

STEAM-9032 Play mode 
Switching layout in Play mode now correctly ensures that the tracks for all players in the 
newly-chosen layout appear populated. 
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ID # Component Issue 

STEAM-8754 Playback 
The playback of microtonal dyads has been improved; both notes are now played correctly 
under a much greater number of circumstances. 

STEAM-8896 Playback 
The score is now always moved to keep the playhead in view; previously it could go wrong 
if the number of systems in the flow changed since the project was opened. 

STEAM-8906 Playback 
Playing techniques on the first note of the flow now play back correctly when multiple 
voices are active. 

STEAM-8954 Print mode 
Under some circumstances, print options set in projects last saved in Dorico 2.1.10 or 
earlier were lost when opening in the current version; this problem has now been fixed. 

STEAM-8933 
Repeat 
markers 

Changes made to the Repeat Marker Sections and Repeat Marker Jumps paragraph 
styles are now correctly shown in the layout immediately. 

STEAM-8915 Selection 
Shift+clicking in an empty part of the staff no longer extends the selection to the wrong 
staves if the bar contains a fermata. 

STEAM-8965 Text In Dorico Elements, it now possible to edit the text in a frame more than once. 

STEAM-9014 Ties Tie endpoints now correctly avoid rhythm dots on unison notes in opposing voices. 

STEAM-8966 
Time 
signatures 

The Ends interchangeable property is no longer sometimes incorrectly deactivated or 
reactivated when undoing the deletion of a time signature in the interchangeable set. 

STEAM-8967 
Time 
signatures 

Flows that begin with an interchangeable time signature where the first bar uses a time 
signature other than the first in the set no longer change appearance after reloading. 

STEAM-8930 Trills 
Under some circumstances, a trill interval of a diminished fifth played back incorrectly in the 
lower octave rather than the octave above the written note; this problem is now resolved. 

STEAM-8620 User interface The positioning of the score when switching between modes is now more stable. 

STEAM-8840 User interface The correct tempo value is now shown immediately when activating fixed tempo mode. 

STEAM-8880 User interface 
Creating or deleting a tempo no longer causes the tempos filtered by the slider in the 
Absolute Tempo section of the Tempo panel to be reset unexpectedly. 

STEAM-8918 User interface 
Changing the selected layout in the right-hand panel in Layout Options now correctly 
causes all of the other options in the dialog to be updated immediately. 

STEAM-8980 User interface 
MIDI triggers for key commands that require multiple notes to be played are now correctly 
loaded when Dorico is restarted. 

STEAM-9078 User interface 
Opening a project whose filename includes words like setup, config, options, or 
preferences no longer prevents the Preferences dialog from being opened. 

STEAM-8415 
STEAM-9037 

Video 
Incrementing or decrementing the values in the timecode spin box now always works 
correctly for drop frame rates. 
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Dorico 2.2 

23 November 2018 

This version contains the following new features, improvements and issue 
resolutions. 

New features 

MIDI recording 

Dorico 2.2 introduces support for real-time MIDI recording. 

Initial setup. Ensure your MIDI keyboard is connected to your computer and is 
powered on before you run Dorico: at present, Dorico will not detect changes in 
connected MIDI devices while it is running. 

We also recommend that you try inputting a simple rhythm against the click to 
check the latency of your system before you do any serious input: for example, start 
a new project, add a player, and add a few bars of 4/4. Select the initial rest and 
start recording, then try to play quarter notes (crotchets) exactly in time with the 
click. 

You may discover that the quarter notes are notated fractionally ahead of the beat: 
if so, try setting the new MIDI input latency compensation option in the 
Recording section of the Play page of Preferences to a value like 50ms, then try 
again. 

If, by contrast, you discover that the quarter notes are notated behind the beat, try 

reducing the buffer size in Edit ▸ Device Setup: you should choose the lowest 
value that still produces stable playback with no drop-outs. If your computer runs 
Windows and you are using the computer’s built-in audio device, you may find that 
you cannot achieve sufficiently low latency for reliable real-time input: if this is the 
case, we recommend that you purchase an external USB audio interface with ASIO 
support. It is not necessary for you to connect your MIDI keyboard directly to the 
USB audio interface: connecting your MIDI keyboard to your computer via USB is 
sufficient, provided the audio subsystem of your computer has sufficiently low 
latency. The Steinberg UR range of USB audio interfaces is recommended for use 
with Dorico, but any audio interface with good-quality ASIO drivers will be 
acceptable. 

Disabling specific MIDI input devices. By default, Dorico will accept MIDI input 
from any MIDI device connected to your computer, including any virtual MIDI 
cables or inter-application buses you are running. To disable a particular MIDI 
device so that Dorico does not accept any input from it, click the MIDI Input 
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Devices button on the Play page of Preferences, and in the dialog that appears, 
deactivate any unwanted devices by unchecking the relevant checkbox. 

Click settings. Before you record, you may wish to review the metronome click 
settings on the new Click page of Playback Options. There is a choice of two click 
sounds: a pitched beep, and an unpitched click in the style of a vintage digital 
metronome. By default, Dorico uses the beep, and will produce a higher pitched 
tone for the first beat of the bar, then a lower and quieter tone for subsequent 
beats of the bar; if the beat is further subdivided, a tone lower still is used for each 
subdivision. You can edit the pitch and velocity of each of these three tones here. 

By default, Dorico does not subdivide the beat in simple time signatures, but does 
for compound time signatures: the options Subdivide beats in simple time 
signatures and Subdivide beats in compound time signatures control this 
behaviour. 

Dorico will always play a click during MIDI recording, but you can also 
hear the click during playback: simply click the appropriate button in the 
mini transport on the toolbar. 

The click is played by a dedicated tone generator called DoricoBeep. If you want to 
change the device to be used for the click, you can manually route the click to any 
VST instrument of your choosing using the controls in the track header for the Time 
track in Play mode. Be aware that if you provide manual routing for the click, this 
will require you to provide manual routing for any new instruments you 
subsequently add to your project. If you want to return to Dorico routing 

instruments automatically, choose one of the default playback templates via Play ▸ 
Playback Template. 

Count-in. By default, Dorico provides one bar of count-in before you start 
recording, which can be adjusted by changing Number of bars count-in on the 
Click page of Playback Options. If you start recording after the start of the flow, 
you will hear any existing music in the bar prior to the recording start position along 
with the count-in, to help you orientate yourself in the music. 

Quantization settings. Depending on the kind of material you are going to play, set 
the quantization settings appropriately. For example, if you know the note values 
you are going to play are rarely going to be any shorter than eighth notes (quavers), 
you should set the quantization unit to eighth notes as well. To change 
quantization, click Quantization Options on the Play page of Preferences. 

Separate quantization options are provided for regular rhythmic notes and notes 
within tuplets. If you know that you will not play any tuplets, switch off Detect 
tuplets to prevent Dorico from interpreting anything you play as a tuplet. 
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Starting recording. Dorico will not create any additional bars or rhythmic time 
during recording, so ensure that sufficient bars or empty rhythmic space already 
exists before you start recording. You can quickly add multiple bars, provided your 
music has a prevailing time signature, by typing Shift+B to open the bars and 
barlines popover, entering the number of bars to add, and hitting Return. 

To start recording, select a note or rest in the staff into which you want to record; 
Dorico will record into the first available voice on that staff. When recording into a 
grand staff instrument, such as piano, it is not necessary to select a note or rest in 
both the right- and left-hand staves: Dorico will assume that you want to record 
into both staves, and will automatically split the music between the staves based 
on pitch. 

To tell Dorico that you want to record into a specific voice, or that you want to 
record into only one staff of a grand staff instrument, show the caret at the position 
at which you want recording to begin and ensure that the desired voice is chosen 
by way of the indicator to the left of the caret; type V to cycle through the existing 
voices on the staff, or type Shift+V to prime a new voice of the appropriate 
direction. 

By default, Dorico will overwrite any existing music in the voice you choose to 
record into. If you would prefer the music to be merged with the existing music in 
that voice, activate chord mode (by typing Q) before you start recording. 

Once you have made an appropriate selection, choose Play ▸ Record, or type 
Ctrl+R (Windows) or Command-R (Mac), to start recording. 

To change the number of bars count-in before recording starts, set Number of 
bars count-in on the Click page of Playback Options. 

During recording, the red playhead moves through the bars, but no music appears 
in Write mode, but if you are recording in Play mode you will see notes appear in 
the piano roll for the target instrument. When you stop recording, the music is 
notated and appears in Write mode. 

Retrospective recording. During playback, you can play notes on your MIDI 
keyboard and hear the notes echoed back to you without inputting them into the 
score. If you subsequently find that you wished you had recorded the music you 
played during playback, you can use retrospective recording to insert it into the 
score. 

After playing on your keyboard during playback, stop playback and select a note or 
rest on the staff in which you want the music you played to be input, at the position 

at which you want it to appear, and choose Play ▸ Retrospective Record, or type 
Ctrl+Alt+R (Windows) or Opt-Command-R (Mac). 
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The retrospective recording buffer is cleared each time you start playback, so you 
cannot recover music you played earlier than the last time playback was invoked. 

Recording unpitched percussion. When recording onto an unpitched percussion 
kit instrument, Dorico respects the Input onto kit or grid option on the Note Input 
and Editing page of Preferences, allowing you to choose between using the staff 
position of the notes to be input (relative to the treble G or bass F clef) or the 
pitches specified by the percussion map used by the kit. Dorico will also follow the 
voicing rules specified in the Edit Percussion Kit dialog when determining which 
voice to use for each instrument. 

Fixed tempo mode. By default, Dorico will follow the tempo markings in the flow 
during MIDI recording. If you would prefer to record at a different tempo, switch on 

Play ▸ Fixed Tempo Mode, which makes Dorico ignore the written tempo 
markings during recording and playback. You can also enable or disable fixed 
tempo mode by clicking on the note value representing the beat unit in the mini-
transport on the toolbar: 

 
Follow tempo 

 
Fixed tempo 

When fixed tempo mode is active, you can adjust the playback and recording 
tempo by clicking and dragging up or down on the numeric read-out. 

You cannot change the tempo used by fixed tempo mode during playback, nor can 
you switch between fixed tempo and following tempo during playback. 

Requantize. To requantize music you have recorded (or imported via MIDI), select 

the music to be requantized, then choose Edit ▸ Requantize. A dialog showing 
the same options as those accessible from Preferences to determine the 
quantization settings for MIDI recording will appear: simply choose the new 
settings and click OK. The music will be instantly requantized. 

Repeat markers 

Building on the improved playback of repeat barlines and repeat endings in version 
2.0, Dorico 2.2 introduces comprehensive support for complex repeat structures 
involving D.C./D.S./Coda jumps. Repeat markers can be added via the Repeat 
Structures panel in Write mode or the Shift+R popover, with options for 
placement and appearance for the various markings provided in both Layout 
Options and Engraving Options. 

Dorico divides repeat markers into two categories: repeat jumps specify the place 
from which playback must jump under certain conditions (for example, D.C. al 
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Coda), while repeat sections specify the destinations for the jumps (e.g. a segno or 
a coda), or where the music should end (e.g. Fine). 

Creating repeat jumps. Repeat jumps are right-aligned, so to add a repeat jump at 
the end of a bar, select the barline with which the right-hand end of the jump 
instruction should be aligned, or select the note or rest at the start of the following 
bar, and either click the desired repeat jump from the Repeat Structures panel in 
Write mode, or type Shift+R to open the repeats popover. 

The popover syntax is intended to be as flexible as possible, so you can type the 
jump instruction in full or abbreviate it. The following are examples of the kinds of 
things you can type into the popover: 

§ D.C. al Fine: dcalf, DC al Fine, D.C. al Fine 
§ D.C. al Coda: dcalc, DC al Coda, D.C. al Coda 
§ D.C.: dc, D.C., da capo 
§ D.S.: ds, D.S., dal segno 
§ D.S. al Fine: dsalf, DS al Fine, D.S. al Fine 
§ D.S. al Coda: dsalc, DS al Coda, D.S. al Coda 
§ To Coda: toc, tc, to coda, To Coda 

Creating repeat sections. Repeat sections are left-aligned, so to add a repeat 
section at the start of a bar, select the barline with which the left-hand end of the 
section marker should be aligned, or select the note or rest at the start of the bar, 
and either click the desired repeat jump from the Repeat Structures panel in Write 
mode, or type Shift+R to open the repeats popover. 

The popover syntax is designed to be flexible and to accept any reasonable way of 
describing the section, so the following are examples of the kinds of things you can 
type: 

§ Segno: s, seg, segno 
§ Fine: f, fin, fine 
§ Coda: c, co, coda 

Mid-system gaps. When you create a coda section, Dorico automatically inserts a 
gap in the system to visually separate the coda from the music that comes before 
it. The default size of the gap can be adjusted by changing the value of Default 
gap before mid-system coda section on the Repeat Markers page of Engraving 
Options. To adjust the size of an individual mid-system gap, switch to Engrave 
mode and activate the Note Spacing tool: a large square handle appears at the 
start of the coda section, which can be nudged left and right by typing 
Alt+left/right (add Ctrl or Command to move in larger steps). 
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The default position of the coda marker relative to the mid-system gap can also be 
adjusted – aligning it either with the start of the staff lines following the gap, or 
instead at the start of rhythmic space after the restated clef and key signature – by 
changing the Position of coda marker at start of system option in the 
Horizontal Position section of the Repeat Markers page of Engraving Options. 

You may want the bar number to be shown at the start of the coda section, in 
which case activate Show bar numbers at start of codas on the Bar Numbers 
page of Layout Options. 

In common with how Dorico currently handles other bars that are played in a 
different sequence to their printed order, items that are ongoing at the point of 
transition are not specially treated, so beware of clefs, key signatures, time 
signatures and so on that may be different between the bar immediately before the 
coda and the first bar of the coda. Dorico will not display any cautionary key or time 
signatures immediately preceding the coda. A future version of Dorico will 
introduce further new functionality to manage items that are ongoing at the point at 
which a repeat jump occurs. 

Appearance of repeat markers. Many options to control the appearance of repeat 
markers can be found on the new Repeat Markers page of Engraving Options. 
Two presets are provided, which can be chosen via the Repeat marker 
appearance preset menu at the top of the page: 

§ Standard produces an appearance based on the most commonly-used 
conventions in current rock/pop sheet music publishing. 

§ Gould produces an appearance based on the recommendations made in 
Elaine Gould’s book Behind Bars, which is better suited for classical and 
concert music. 

The main difference between the two presets is that Standard results in 
instructions that are more abbreviated or shorthand, while Gould results in wordier, 
more explicit instructions. Gould also recommends that repeat markers should be 
positioned below the staff, while it is more common in current rock/pop sheet 
music publishing for these instructions to be placed above the staff. 

After choosing one of the two presets, you are free to adjust any of the options on 
the Repeat Markers page, in which case the preset menu will show Custom as 
the current preset. 

To change the size of the segno and coda symbols relative to the surrounding text, 
adjust the Scale factor for music symbols option in the Design section. You can 
control the font, style, weight and size for repeat jumps and sections independently 
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by editing the Repeat marker jumps and Repeat marker sections paragraph 
styles in Engrave ▸ Paragraph Styles. 

Default placement. Repeat jumps and sections appear above the staff by default. 
Gould recommends that repeat jumps and Fine sections should appear below the 
staff, which can be achieved by changing Default placement for repeat jumps 
and Fine on the Staves and Systems page of Layout Options to Below staff. 

In some kinds of music, for example German posaunenchor church brass music, 
both repeat jumps and sections are shown both above the staff and additionally 
below the bottom staff of the system. This convention can be followed by setting 
Default placement for repeat jumps and Fine to Above and below staff. 

Word wrap. Some repeat jump instructions can be very verbose, particularly when 
following the classical conventions recommended by Gould. As such, with very 
long repeat instructions it can help to reduce ambiguity concerning where such 
instructions take effect for them to be wrapped onto two lines. To wrap long repeat 
jumps on two lines, set Word wrapping for repeat markers to Show on two 
lines on the Staves and Systems page of Layout Options. 

Moving repeat markers in Write mode. Repeat jumps and sections can be moved 
in Write mode in the usual way, either by dragging them left and right with the 
mouse, or by typing Alt+left/right. 

Nudging repeat markers in Engrave mode. Repeat jumps and sections can be 
nudged graphically in Engrave mode, either by dragging them with the mouse or by 
typing Alt+arrow keys. To reset the repeat marker back to its default position, 
choose Edit ▸ Reset Position. 

Overriding text for repeat markers. You should be able to obtain any commonly-
used convention for repeat markers using the options on the Repeat Markers 
page of Engraving Options, but if you have need of specifying an unusual or non-
standard instruction, you can activate the Custom text property in the Repeat 
Markers group of the Properties panel to override the text of any repeat marker. 

Multiple codas and segnos. In pieces with complex repeat structures, it may be 
necessary to specify multiple codas or segnos (though we urge you to consider 
writing the music out in a longer, unwound form rather than subjecting your 
performers to a repeat structure that requires a map and compass to understand). 

To achieve this, Dorico allows you to specify the Marker index property for a 
repeat section and the ‘Jump to’ index property for a repeat jump, assigning a 
numeric index to the pair of repeat instructions. 
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Options are provided on the Repeat Markers page of Engraving Options for how 
multiple segnos and codas should be indicated to the performer. 

End repeat barlines. In addition to the playback of repeat jumps and sections, it is 
now possible to specify that an end repeat barline should be repeated more than 
once. To increase the number of times a repeated section should be played, select 
the end repeat barline, then activate the Play n times property in the Time 
Signatures group of the Properties panel. 

When Play n times is set to more than two, Dorico will display text above the 
repeat barline to inform the players that the music is repeated more than once. 
Options to control exactly what text should appear, and whether it should be 
aligned with the start, end or both start and end of the repeated section, are found 
in the Repeat Count section of the Repeat Markers page of Engraving Options. 

Playback of repeats. Dorico plays back complex repeat structures automatically. 
You can specify whether repeat endings and barlines should be respected after a 
backwards jump (either a D.C. or D.S. jump) by setting the Play repeats after 
D.S./D.C. jump option on the Repeats page of Playback Options. 

This option can be overridden on a per-repeat marker basis by activating Replay 
repeats in the Repeat Markers group in the Properties panel. 

Jazz articulations 

Broadening the support for notations used in jazz added in version 2.0, such as bar 
repeats and rhythm slashes, Dorico 2.2 brings comprehensive support for the 
notation of idiomatic ornamentations typical of brass writing in jazz (though not 
limited to brass instruments). Although they are colloquially known as jazz 
articulations, these techniques are closer to ornamentation than articulation in the 
strictest sense, so they are found in Dorico in the Ornaments panel and can be 
input using the Shift+O popover. 

Each note can have a maximum of one jazz articulation to each side: on the left, a 
plop, scoop or lift; on the right, a doit or fall. The terminology for these techniques 
is not universally agreed, so for the avoidance of doubt: a plop approaches the 
written note from above; a scoop or a lift approaches the written note from below; 
a doit rises from the written note; while a fall falls from the written note. 

These articulations are sometimes written with a curved line that looks a little like a 
slur, which Dorico calls a “bend”, and sometimes written with a straight line, which 
may be drawn using a solid, dashed, or wavy line, which Dorico calls “smooth”.  

There is currently no playback support for jazz articulations, since they are too 
complex to approximate using crude techniques like MIDI pitch bend, and in the 
handful of virtual instruments in which sampled versions are available, triggering 
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them requires complex addition and removal release of multiple notes at precise 
times. Playback of jazz articulations may be added in a future release. 

Adding jazz articulations. Jazz articulations are added to the selected note or chord 
by clicking the desired technique in the Jazz section of the Ornaments panel on 
the right-hand side in Write mode, or by typing into the Shift+O popover: 

§ Plop: plop for a bend plop, plopsmooth for a smooth plop 
§ Scoop: scoop for a bend scoop, scoopsmooth for a smooth scoop 
§ Lift: lift 
§ Doit: doit for a bend doit, doitsmooth for a smooth doit 
§ Fall: fall for a bend fall, fallsmooth for a smooth fall 

Removing jazz articulations. Because jazz articulations are part of the note to 
which they apply, they cannot be removed by hitting Delete (as this will delete the 
note in its entirety): instead, they are removed by selecting the note and clicking 
the Remove button in the Jazz section of the Ornaments panel. 

Positioning jazz articulations. Dorico positions jazz articulations automatically 
relative to the noteheads to which they apply, considering the presence and 
position of rhythm dots, accidentals, back notes, and so on. When jazz articulations 
are present on multiple notes of a chord, Dorico has sophisticated behaviours for 
determining when they should be aligned horizontally based on how close to each 
notehead they can be positioned versus how ragged jazz articulations at different 
horizontal positions will appear. Dorico will also allow a maximum of one jazz 
articulation per space, so if you have a cluster chord, not every notehead in the 
chord may be able to show an articulation. 

You can adjust the horizontal threshold for alignment and the approach Dorico 
should take to lining up multiple jazz articulations on the same chord on the new 
Jazz Articulations page of Engraving Options. 

Smooth jazz articulations. When you choose to create a smooth lift, plop, doit, or 
fall, the default length and angle of the line is determined by options on the Jazz 
Articulations page of Engraving Options. You can adjust the position of each end 
of the line in Engrave mode, allowing you to freely change the length and angle of 
the line. Select the line and then hit Tab to cycle between each end of the line, 
then nudge it with Alt+arrow keys. You can reset the position of the line to its 
default by choosing Edit ▸ Reset Position. 

The default line style (solid, dashed, or wavy) for a smooth jazz articulation is also 
specified on the Jazz Articulations page of Engraving Options. Jazz articulations 
created via the Shift+O popover will use the default line style, while those created 
from the panel will be created with the line style set explicitly, according to the 
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button in the panel you choose. To reset the line style of a jazz articulation back to 
the default, choose Edit ▸ Reset Appearance. 

Other jazz ornaments. Four other idiomatic jazz techniques – flip, smear, jazz turn 
(or shake), and bend – can also be created from the new Jazz section of the 
Ornaments panel, or by entering flip, smear, shake, jazzturn or bend into the 
Shift+O popover. 

In earlier versions of Dorico, these symbols could be found in the Brass section of 
the Playing Techniques panel, and when you open a project created in an earlier 
version, these playing techniques will automatically be converted into the 
appropriate ornaments. 

There is currently no automatic playback for these additional jazz ornaments. 

Tempo track import/export 

When scoring for films, TV and games it is common for an updated edit to be sent 
to the composer or orchestrator, resulting in some changes to the musical 
structure of the cue or project becoming necessary. Dorico 2.2 introduces features 
to import the tempo track from a MIDI file, or to export a tempo track from the 
current project. 

The term tempo track in fact refers not only to the tempo information from a MIDI 
file, but also to other global timing-related information, including the SMPTE offset, 
time signatures, and markers. Dorico allows you to import some or all of these 
elements from a MIDI file, replacing the existing ones in the flow but retaining all the 
rest of the music and reflowing it accordingly. 

To import a tempo track into the current flow, choose File ▸ Import ▸ Tempo 
Track. After choosing the MIDI file containing the tempo track, the following dialog 
appears: 
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Choose the destination flow from the list at the top of the dialog, and then choose 
which types of items you want to import: 

§ Timecode display offset sets the initial timecode position at the start of 
the flow 

§ Tempo changes replaces all immediate and gradual tempo changes in the 
flow with the tempo changes from the MIDI file 

§ Time signatures replaces all time signatures in the flow with the time 
signatures from the MIDI file 

§ Finally, you can choose to import the markers in the MIDI file either as 
Markers or as System Text. If you import them as markers, any existing 
markers in the flow will be replaced; but if you import them as system text, 
existing system text will not be removed (as Dorico doesn’t know which 
items can be safely replaced without removing other text that you might 
want to keep). 

Click OK, and the chosen items will be imported into the selected flow. 

To export a tempo track, choose File ▸ Export ▸ Tempo Track. You will be 
prompted for a file name for the MIDI file to be exported, and this file can then be 
imported into Cubase or another DAW to transfer the flow’s timing into a 
corresponding project. 

Flow headings 

In projects including multiple flows, it may be necessary for a new flow to start 
midway through a page; this is particularly likely in instrumental parts for multi-
movement works, where it is common for the start of a new movement to be 
printed immediately following the end of the previous one. Until now, although 
Dorico has made it easy to show multiple flows in the same music frame, it was left 
to you to add any necessary heading (such as the title, composer, etc.) manually, 
which required you to add text frames, producing page overrides in the layout. 

Dorico 2.2’s new flow headings feature removes the need for any manual 
intervention beyond determining what material should appear before each flow. 
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Enabling flow headings. Flow headings are enabled by default in new projects: the 
First master page in both the Default Full Score and Default Part master page 
sets now uses tokens from the project info, and a flow heading is inserted before 
the first flow. If you intend to have only a single flow in your project, you may wish 
to switch off flow headings. 

The new option Show flow headings in the Flows section of the Page Setup 
page of Layout Options determines when flow headings will appear: 

§ Never: flow headings are disabled, and will not appear automatically. 
§ Not for first flow: flow headings will appear for all flows after the first flow 

in the layout; this setting is useful if you are using a master page set that 
includes an automatic First page pair, and that First page pair shows the 
flow title rather than the project title; this avoids duplicating the flow title 
before the first flow. 

§ For all flows: flow headings will appear for all flows. 

The default margin to be added above and below a flow heading is also specified 
here: the top margin will not normally be used, as the flow heading is normally 
positioned in the gap between systems, but the bottom margin is always used. If 
the bottom margin is zero, the bottom edge of the bottommost frame in the flow 
heading will touch the top staff line of the uppermost staff in the first system of the 
flow directly below. 

A new option Use ‘First’ master page has also been added, allowing you to 
specify whether the First master page should be used at the start of the layout 
(First flow only), for any flow after the first that starts at the top of a page (Any 
flow starting at top of page), or not at all (Never). 
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Editing flow headings. Flow headings are part of a master page set, and each 
master page set can have its own set of flow headings. The Default full score and 
Default part master page sets include a single flow heading, which has the same 
information as shown at the top of the First master page pair, i.e. the flow title 
(using the {@flowTitle@} token), the flow composer (using {@flowComposer@}) 
and flow lyricist (using {@flowLyricist@}), resolving these tokens using the 
information specified for the flow in File ▸ Project Info. 

A new Flow Headings section has been added to the right-hand panel in Engrave 
mode, showing the flow headings designed for the master page set chosen in the 
Master Pages section above. 

To edit a flow heading, simply double-click it in the Flow Headings section, and 
the flow heading editor will open. This editor is essentially the same as the master 
page editor, though is shows a different colour background to reinforce that there 
are some differences. The main differences are that flow headings do not differ 
when shown on left- and right-hand pages, so only a single page is shown; and 
that you cannot create a music frame as part of a flow heading. 

It doesn’t matter where in the page you position the frames in your flow heading: 
Dorico will use the top of the uppermost frame and the bottom of the bottommost 
frame to determine the dimensions of the flow heading that will be inserted into the 
frame. You should attempt to keep the overall height of the flow heading to a 
minimum, to avoid unduly reducing the amount of music that will fit in the frame. 

Flow headings are inserted relative to the music frame and will automatically move 
vertically relative to the first system of the flow to which they apply. As such, frames 
in flow headings cannot have vertical constraints, i.e. they cannot be locked to the 
top or bottom of the page: instead, they can be constrained to either or both the 
left and right edges of the page. 

Flow heading changes. You can define multiple flow headings within a master 
page set. Only one flow heading can be designated the default, which can be 
changed by creating a new flow heading based on an existing one and setting 
Type to Default in the New Flow Heading dialog. 

To use a flow heading other than the default, you can insert a flow heading change 
on any page in the layout, specifying that for that page only or for all subsequent 
pages, Dorico should use a specific flow heading. Right-click a page in the Pages 
panel to show the context menu, and choose Insert Flow Heading Change to 
show this dialog: 
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Choose the desired flow heading from the master page set from the Use flow 
heading menu and specify whether or not the change should take effect for the 
Current Page Only or From This Page Onwards. You can also override the top 
and bottom margin to be used by the new flow heading; if you do not specify an 
override here, the margins defined in Layout Options will be used instead. 

Moving flow headings. When a flow heading is added to the layout, its frames are 
drawn with dashed lines to make it clear that they are a different kind of frame. As 
the music reflows, flow headings move automatically with the first system of the 
flow to which they apply. If you move the top system of a flow using the staff 
spacing tool, the flow heading will also follow the top system: you must use the 
large square handle for the whole system rather than the small square handle for 
the top staff only if you want the flow heading to move. 

You can also simply move the frames in the flow heading yourself in the usual way 
in Engrave mode, but doing so will introduce a page override and prevent Dorico 
from making any further automatic changes to the layout of the frames on that 
page. 

Flow headings at the top of the page. When a flow heading falls at the top of a 
page, the margin above flow headings, as defined in Layout Options or in the 
prevailing flow heading change, will not apply: the flow heading will be positioned 
at the top of the music frame with no margin above. 

Furthermore, in a new project, any running header and page number at the top of 
the page is also automatically suppressed when a flow header falls at the top of a 
page, following common publishing practice for the start of a new chapter or 
section in a book. Options to control this behaviour are found on the Page Setup 
page of Layout Options, allowing you to specify whether each of these elements 
should be hidden. 
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Flow headings in existing projects. Flow headings are enabled by default in newly-
created projects but are disabled in existing projects in order to avoid causing 
them to change appearance when opened in Dorico 2.2. However, the default 
master flow heading template is automatically added to all master page sets in an 
existing project when it is opened in the new version, so you can simply enable 
flow headings in Layout Options. 

Converting an existing project to use automatic flow headings instead of manual 
text frames added in an earlier version will also require you to remove overrides 
from pages in your layouts, and may require you to lay out the music again, as 
Dorico’s determination about how much music will fit in each system once 
automatic flow headings are taken into account will almost certainly differ from your 
choices made when setting up flow headings manually. 

Tacets 

Complementing flow headings, Dorico 2.2 also introduces support for handling 
flows in which all of the players in the layout are tacet. If a player is assigned to a 
flow (and to a layout), but has no music, then Dorico will display multi-bar rests 
appropriate for the whole flow, showing tempo changes, rehearsal marks, and so 
on. As of Dorico 2.2, a layout can have a flow assigned but have no players 
assigned to that flow, and display a flow heading followed by the text Tacet 
instead. 

To ensure that a tacet will appear, ensure that the flow is attached to the layout, but 
that none of the players in that layout are attached to that flow. 

Showing tacets. The options for enabling tacets are found in the new Tacets 
section of the Players page of Layout Options. In newly-created projects, tacets 
are enabled by default, but to enable them in existing projects, activate Show tacet 
for flows where no players are assigned. Although it is possible to activate this 
option without also choosing to use flow headings, it is recommended to use the 
two features in conjunction, so that each tacet is properly contextualised by the title 
of the flow to which it corresponds. 

You can specify the text to appear when all players in a flow are tacet: by default, 
the word Tacet appears, in a new dedicated paragraph style Tacet, which can be 

edited in Engrave ▸ Paragraph Styles. By default, the Tacet text is enclosed in a 
border to help it stand out from the flow headings surrounding it; options for the 
amount of padding to the left and right of the text and the thickness of the line, as 
well as the option not to use a border, can be found on the new Tacets page of 
Engraving Options. 

The gap between the tacet text and the flow heading above is determined by the 
Margin above tacet option (and the Flow heading bottom margin value is not 
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used in this situation), while the gap between the tacet and the following flow 
heading is determined by the Margin below tacet option. 

Staff spacing. When editing staff spacing in Engrave mode, a tacet is treated as a 
system in its own right, and shows a large square handle allowing you to move it up 
or down on the page, bringing its associated flow heading with it. 

However, it is worth bearing in mind that some staff spacing operations do not 
make sense with tacets, such as using Alt+drag to proportionally change the 
distance between all staves above or below the top or bottom selected staff. 
Because tacets do not have staves, they are not moved by Alt+drag. 

Frame breaks. To ensure that a tacet appears at the start of a frame, select the 

Tacet text itself in Engrave mode and type Shift+F or choose Engrave ▸ Format 

Music Frames ▸ Frame Break to create a frame break before the tacet. 

Trills 

Trills have been completely overhauled in Dorico 2.2. In previous versions, Dorico 
could display an accidental above the trill as a means of indicating the trill interval, 
but this was purely cosmetic: the accidental did not take the current key into 
account, and it could not be displayed as a different accidental if need be in 
another layout for a transposing instrument. Trills in Dorico 2.2 have much greater 
musical intelligence, can reflect and indeed affect the accidental state in the 
current bar, and can display the trill interval in several ways. 

 

Trill intervals. When you create a trill without specifying a particular interval, Dorico 
calculates the interval using the top note in the voice to which the trill belongs, 
considering the current key and any accidentals earlier in the bar: for example, in C 
major, a trill on an E natural will produce an interval of a half-step (semitone) or a 
minor second to F natural, unless there has been, say, a sharp introduced on the F 
in that octave earlier in the bar, in which case the trill interval will be a whole step 
(tone) or a major second to F sharp. You can specify a trill’s interval via the 
Shift+O popover or activating the Interval property in the Trills group of the 
Properties panel. To specify an interval in the popover, use similar syntax to that 
used for specifying an interval in the Shift+I popover: 

§ To specify a minor interval, use lower-case m: e.g. m2 produces a minor 
second; to specify a major interval, use upper-case M, e.g. M2 produces a 
major second. 
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§ To specify a perfect interval, use p: e.g. p5 produces a perfect fifth. 
§ To specify an augmented interval, use aug: e.g. aug4 produces an 

augmented fourth; to specify a diminished interval, use dim: e.g. dim5 
produces a diminished fifth. 

A trill’s interval can change over time, at any notehead position within a tie chain. 
To change the interval, start note input with Shift+N or by hitting Return to show 
the caret, position the caret at the same position as a notehead under the trill, and 
type Shift+O for the ornaments popover: simply enter the desired interval. The 
change in interval will be indicated by the appearance of an accidental, Hollywood-
style interval or auxiliary note to the right of the notehead at the caret position. 

When you first activate the Interval property to override a trill’s interval, the 
property is set to the trill’s current automatically-determined interval, which makes it 
easier to be sure you are adjusting it in the appropriate direction. 

Trill interval appearance. By default, the trill interval is shown as an accidental 
positioned above the  symbol, but it can alternatively be shown using the 
Hollywood convention of using H.T. for a half-step (semitone) and W.T. for a whole 
step (tone). If the interval is greater than a minor or major second, then it will 
instead appear as an auxiliary note: this is a small, parenthesized stemless black 
notehead shown immediately to the right of the note to which the trill applies. 

Options to control the appearance of trill intervals are found in the new Interval 
group (formerly called the Accidentals group) of the Ornaments page of 
Engraving Options. You can specify whether the accidental or Hollywood-style 
interval should be shown above, below or to the right of the  symbol, and choose 
between a number of specific conventions for the appearance of H.T. and W.T. 
Options for the appearance of the auxiliary note – including its scale factor, 
whether or not it should be parenthesized, and various gap values for different 
accidentals – are also to be found in the same place. 

If the first notehead of a trill has a very short duration, e.g. if it is a 16th note 
(semiquaver) or shorter, then it may be preferable to show the auxiliary note not 
after the first notehead in the tie chain, but instead after the first note with a longer 
duration, in order to avoid distorting the rhythmic spacing. You can specify the 
duration threshold for the auxiliary note to be shifted to a later notehead in the tie 
chain on the Ornaments page of Engraving Options. 

Hiding trill accidentals. It is possible to override Dorico’s decision about whether or 
not to show a trill interval by activating the Accidental property in the Trills group 
of the Properties panel and setting either Hide or Show as appropriate. 
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If a trill is currently showing an appearance other than an accidental for an interval, 
i.e. an auxiliary note or a Hollywood-style H.T./W.T. marking, you can hide this by 
first activating the Appearance property in the Trills group to set the interval to 
appear as an accidental, then hide the accidental using the Accidental property as 
described above. 

If a trill extends over multiple pitches, the interval will be restated above the trill line 
at every new pitch; if the interval remains unchanged over multiple notes, you can 
use the Identical trill intervals on successive notes to hide a Hollywood-style trill 
interval if need be, though accidentals or auxiliary notes will always appear. 

Trills and accidentals. Dorico considers the upper note of the trill when determining 
which accidentals should appear in the bar: by default, the trill itself will show the 
interval unless the upper note is modified by an accidental in the key signature. If 
the upper note has been modified by an accidental earlier in the bar, then the trill 
will always show the interval, and indeed if the trill itself modifies a pitch that has a 
sharp or flat in the key signature, any subsequent notes of that pitch will show the 
appropriate accidental. Furthermore, the upper note of a trill behaves the same way 
as an explicit note with regard to ensuring that cautionary accidentals appear on 
other pitches in the current and following bars. 

Microtonal trill intervals. When writing in a tonality system other than the default 
12-EDO system, you can specify the trill interval in terms of the number of diatonic 
steps and the total number of divisions from the written note; in 24-EDO you can 
usually still describe the interval in terms of its quality (major, minor, etc.) but in 
tonality systems with a greater number of divisions, or an unequal number of 
divisions between each diatonic step, these quality descriptors are inadequate, so 
the interval must be described in terms of divisions of the octave. (STEAM-8622) 

Trill continuation. A new option Label for start of system has been added to the 
Ornaments page of Engraving Options, controlling how a trill that spans a system 
break should appear: the  symbol can appear as normal, in parentheses, or be 
hidden altogether. 

The  mark can also be hidden at the start of a trill by activating the new Show trill 
mark property in the Trills group of Properties, and clearing the checkbox.	

Trill playback. Dorico automatically interprets trills in playback, and can use a 
combination of sampled trills, where available, and simulating a trill by triggering 
multiple notes. Options for trill playback are to be found on the new Trills page of 
Playback Options. 

Dorico can now automatically play back sampled half-step (semitone) and whole-
step (tone) trills if these playing techniques are defined in the VST expression map. 
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They are defined by default for a number of instruments in HALion Symphonic 
Orchestra, and these are now played back appropriately. For sound libraries that 
do not provide sampled trills, or for intervals beyond a whole step, Dorico will 
instead simulate a trill. If your music contains a mixture of trill intervals that cannot 
be handled solely by sampled trills, you may prefer to disable the use of sampled 
trills and use simulated trills throughout. To do this, set Playback approach for 
trills to Generated trills only. 

If you are using NotePerformer for playback, you are likewise recommended to set 
Playback approach for trills to Generated trills only. This allows Dorico to 
always send the correct notes and controllers to cause NotePerformer to produce 
its most realistic trill playback. 

Because sampled trills are recorded, looped samples, they typically offer no 
parameters allowing any kind of variation in the trill interpretation, such as trilling at 
different speeds, or incorporating grace notes or termination notes into the pattern 
of trilled notes. By contrast, generated trills can provide greater flexibility, at the 
expense of verisimilitude, and the remaining options on the Trills page allow 
adjustment of the interpretation of generated trills. 

Dorico seamlessly incorporates grace notes immediately before the trill and at the 
end of the trill when playing generated trills. A single unslashed grace note on the 
note where the trill begins will result in an appoggiatura, a lengthened initial upper 
note, while multiple grace notes on the initial note will be included in the trill 
pattern. Grace notes on the note immediately following the trill, such as a turn or 
other form of trill termination pattern, will also be included in the trill pattern. 

If a trill has variable speed by way of the Start speed and End speed properties, 
when generating trills for playback Dorico can respect this, using the values for 
Slow trill speed, Normal trill speed and Fast trill speed to determine the curve 
over which the trilled notes will speed up or slow down. These values can also be 
overridden on a per-trill basis by activating the corresponding properties in the 
Trills group of the Properties panel. If you want to override the played speed of a 
trill, but not show the change in speed in the way the trill line is drawn, you can also 
activate the new Suppress drawing speed changes property, which will draw the 
trill line  

In contemporary performance practice, trills are usually performed starting on the 
written note, while in historical performance practice of music of the Baroque and 
classical eras, trills are usually performed starting on the upper (trilled-to) note. You 
can control this behavior by setting Starting pitch for generated trills to Upper 
note or Lower note as desired. This, too, can be overridden on a per-trill basis by 
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activating the Start on upper note property in the Trills group of the Properties 
panel. 

Another common performance practice, in particular for Romantic piano music, is 
to perform all trills with an acceleration, starting more slowly and then faster as the 
trill proceeds. To achieve this, set Default playback of generated trills to 
Accelerating from normal to fast speed. With this setting, all trills that do not 
have their playback speed overridden via properties will play back starting at the 
number of notes per second defined for Normal trill speed, accelerating to Fast 
trill speed by the end. Dorico ensures that an appropriate number of notes will 
always be played and will only produce a change in trill speed for a note of 
sufficient length. 

Editable instrument grouping 

Dorico provides a number of different approaches for determining how the 
instruments in your layouts should be bracketed and braced together, together with 
options for the design and appearance of brackets and braces. These options are 
found on the Brackets and Braces page of Engraving Options, and for most 
works, one of the default bracketing approaches produces the desired, 
conventional result. However, if you find that your work has special requirements 
for bracketing, Dorico 2.2 introduces tools to allow you to fully customize 
instrument grouping. 

Because of the complexities of score layout, where staves can appear and 
disappear from system to system due to instrument changes, changes in divisi, 
adding or removing staves from instruments, and hiding empty staves, for best 
results, it is recommended that you complete all of the score setup tasks so that all 
players and instruments are present before you start customizing brackets and 
braces. 

It is also recommended that, if possible, you customize the brackets and braces at 
the very beginning of the flow, and that you ensure that Hide empty staves is set 
to Never (on the Vertical Spacing page of Layout Options) so that all staves 
appear in the first system – you can of course hide empty staves once you have set 
up the instrument groupings to your taste. Similarly, if you need to change the 
instrument groupings later in the flow, work from the beginning of the flow to the 
end; each new bracket and barline change is based on the prevailing grouping, so 
working backwards from the end of the flow to the start is not advisable. 
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Bracketing section. With the graphic editing tool chosen in 
Engrave mode, the left-hand panel contains a new Bracketing 
section, in which you will find buttons that allow you to create 
new instrument groups. The buttons are as follows, from left to 
right, top row then bottom row: 

§ Bracket: the primary (innermost) level of grouping; a 
thick line, normally used to join instruments of the same 
family. Brackets cannot overlap, either with themselves, or with braces, 
which are also positioned directly against the systemic barline. 

§ Sub-bracket: secondary level of grouping; a thin line, normally used to link 
instruments of the same type within a family (e.g. two flutes). Sub-brackets 
cannot extend beyond their containing bracket. Sub-brackets can also be 
drawn using braces, though this is uncommon in contemporary scores. 

§ Sub-sub-bracket: tertiary level of grouping; identical in appearance to 
sub-bracket, normally used to link instruments within the same section (e.g. 
two divisi staves of a violin section in a passage where the leader of the 
section has a solo). Sub-sub-brackets cannot extend beyond their 
containing sub-bracket. Sub-sub-brackets will not be drawn if sub-
brackets are set to draw using braces. 

§ Brace: also used for primary grouping; a curved brace, normally used to 
join grand staff instruments (e.g. piano or harp). Braces cannot overlap, 
either with themselves, or with brackets. Staves joined with a brace as their 
primary group cannot show sub- or sub-sub-brackets. 

§ Barline joins: by default, barline joins follow primary grouping, i.e. barlines 
extend through the staves that are joined by the innermost bracket or 
brace, with the exception of staves belonging to singers, in which case the 
barline is broken regardless of the bracketing to avoid collisions with lyrics. 

Creating a new group. To create a new bracket, brace, or sub-bracket, select an 
item on the staff that should begin the group, then select an item on the staff that 
should end the group, and click the appropriate button in the Bracketing section 
of the left-hand panel in Engrave mode: the specified bracket, brace or sub-bracket 
will be created. If necessary, any existing instrument groupings will be adjusted to 
accommodate the new group. 

Editing an existing group. When you select a bracket, brace, or barline in Engrave 
mode, handles appear at the top and bottom. You can move the selected end of 
the item up or down by typing Alt+up/down arrow. Brackets cannot overlap, so as 
you move the end of a bracket upwards, any bracket or brace above will be 
shortened; a bracket having been shortened, moving the intruding bracket back 
again will not restore the original length of the shortened bracket. 
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It is also possible to drag the top or bottom of a bracket, brace, sub-bracket or 
sub-sub-bracket using the mouse to change the staves enclosed; barlines, 
however, can only be lengthened or shortened using key commands. 

Signpost. When the new group is created, a Bracket and Barline Change 
signpost appears at the start of the system. The change in grouping will take effect 
from the current system if the signpost is positioned at the start of the system, but 
if the signpost appears midway through a system, the change will take effect from 
the following system. 

Barline joins. Creating a new barline join is identical to creating a new bracket or 
brace: select an item on the staff that should begin the barline group, then select 
an item on the staff that should end the group and click the barline join button in 
the Bracketing section of the left-hand panel in Engrave mode. 

To quickly separate an existing barline section so that each staff has its own 
independent barline, simply select the barline and hit Delete in Engrave mode. (In 
Write mode, deleting a barline will merge the bars to either side into a single, 
longer bar, so it’s important to be sure you are in the correct mode.) 

Resetting brackets and barlines. To remove any custom instrument groupings 
altogether, simply delete the bracket and barline change signposts. 

To return to the default instrument groupings as specified in Engraving Options 
after a passage where custom instrument groupings have been used, select the 
position at which the return to the default groupings should occur and choose 

Engrave ▸ Reset Bracketing; this creates a signpost at the selected rhythmic 
position, though the reset will only take effect at the start of the following system. 

It is also possible to reset either the bracketing or the barlines independently: 
select the signpost and open the Properties panel. In the new Bracket and 
Barline Changes group, you can set Change bracketing to Auto to remove any 
custom brackets and braces and do likewise for Change barlines to remove any 
custom barline joins.  

Music symbols editor 

The new Engrave ▸ Music Symbols dialog allows you to edit the appearance of 
every symbol used in your project that is not already editable via another dialog (i.e. 
chord symbols, accidentals, playing techniques, noteheads). 
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The symbols are organized into categories, which you can choose from the 
selector at the top left-hand corner of the dialog. To help narrow down the choice 
of symbols, you can also enter a search string in the field directly below the 
category selector. (A useful tip is to set the Category selector to All Categories, 
then search within the entire set of symbols using the search field.) 

If you create a new music symbol in this dialog, it will not be used by Dorico 
directly: only the default built-in music symbols will be used by the built-in features 
to draw notes, dynamics, clefs, time signatures, tuplets, and so on. 

To make a change to a built-in music symbol such that it will use the edited 
appearance in every new project you create thereafter, edit the symbol and then 
click Save as Default. 
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Improvements 

Accidentals 

Designing accidentals. When designing custom accidentals, it is common to 
require the positioning of multiple glyphs relative to one another. When adding a 
new glyph to an accidental, each glyph is now aligned relative to the baseline of 
each glyph, rather than the bottom corner, which reduces the amount of 
adjustment required. (STEAM-8658) 

Articulations 

The positioning of staccatissimo articulations relative to staff lines when allowed 
inside the staff has been improved. (STEAM-8484) 

Bar numbers 

Repeats. Bar numbers can now optionally take repeats into account and increment 
the bar count each time a bar is played. This is controlled by the new option Bar 
numbering for repeated sections option on the Bar Numbers page of Engraving 
Options, which applies to all layouts and all flows in the project: this is set to Do 
not count repeats by default, in which case repeats will have no effect on bar 
numbering; set Count repeats to take repeats into account. 

How bar numbers that include repeats are displayed in each layout is determined 
by new options on the Bar Numbers page of Layout Options. Set Count repeats 
to All repeats to show the bar number of each pass one after the other: for 
example, the second bar of an initial eight-bar phrase that is played twice will be 
numbered 2 (9) by default. Change Prefix and Suffix to determine how the bar 
numbers are separated (for example, changing Prefix to , and clearing Suffix 
would produce 2,9 instead). 

Set First repeat only if you want to see only a single bar number each time it 
appears, but for the count to increment taking repeats into account. For example, 
the bar immediately following an initial eight-bar phrase that is played twice will be 
numbered 17 rather than 9 when using this option. 

Set Last repeat only if you instead want to see the latest rather than earliest bar 
number for each bar. For example, the first bar of an initial eight-bar phrase that is 
played twice will be numbered 9 instead of 1 when using this option. 

View bar numbers. The View ▸ Bar Numbers option has been improved such that 
bar numbers now appear on all staves, rather than only above the top staff of the 
system. (STEAM-8229) 

Bars split between systems. A new option Show bar number at start of system 
for bar split over break has been added to the Bar Numbers page of Layout 
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Options, switched on by default. Switching this option off tells Dorico not to 
display the number of the bar split across the system break in square brackets, 
which may be useful in music in open meter. (STEAM-8499) 

Layout Options. The Bar Numbers page of Layout Options has been reorganized 
to make the relationships between groups of options clearer, including consistently 
using Show… for all options, thus inverting three options that were previously 
using Hide… instead. (STEAM-8507) 

Beams 

Beam corners. A new option Position for secondary beam groups in beams 
with opposing outer stems has been added to the Vertical Position section of 
the Beams page of Engraving Options, allowing you to choose whether all 
secondary beam groups should be shown on the same side of the primary beam to 
make the rhythmic grouping clearer, at the expense of introducing beam corners for 
the beam on the opposite side of the primary beam than its outer stem would 
normally dictate, or whether secondary beam groups should go on opposite sides 
of the primary beam, eliminating the beam corners but perhaps making the rhythmic 
grouping less clear. 

Partial beam length. A new option Partial beam length has been added to the 
Appearance section of the Beams page of Engraving Options. 

Clefs 

Clefs for divisi and extra staves. Clefs on divisi staves, and on extra staves added 
above or below the default staves for an instrument, are now drawn full size, 
instead of being drawn at the size more appropriate for a mid-system clef change. 
(STEAM-8550) 

Divisi 

Staff labels. The existing option for showing divisi sections in staff labels on the 
Staves and Systems page of Layout Options has been split into two options: 
Show section names on first system, and Show section names on 
subsequent systems. By splitting these options, you can now choose to show 
divisi section names only on the first system of a divisi passage, provided the divisi 
change occurs at the start of the system. (STEAM-8405) 

Vertical justification. A new option Gap to use for divisi staves has been added 
to the Vertical Spacing page of Layout Options, allowing you to choose between 
using the Staff to staff gap (the default for newly-created projects) or the Braced 
staff to braced staff gap (which was the default in Dorico 2.1.10 and earlier). 
Divisi staves are justified in accordance with the gap used to separate them: just as  
the gap between braced staves is not justified, so too is the gap between divisi 
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staves not justified when Braced staff to braced staff is chosen; when Staff to 
staff is chosen, the gap between divisi staves is subject to vertical justification. 
(STEAM-8682) 

Dynamics 

Aligning dynamics. Dorico automatically aligns dynamics that are in the same 
group relative to the staff, and abutting dynamics are automatically grouped by 
default. However, it may also be necessary to align dynamics that are not abutting, 
and because the music will typically be laid out differently between the full score 
and the instrumental parts, it is often not desirable to group dynamics in order to 
achieve alignment, because this can cause unwanted alignment in one or other of 

the layouts. To solve this, a new command Edit ▸ Dynamics ▸ Align Dynamics 
has been added, making it easy to align dynamics across the width of a system 
without grouping them. 

This command can only be used in Engrave mode, so first switch to Engrave mode, 
and then select the dynamics you want to align; a convenient way to do this is to 

use the new Edit ▸ Select More command (see Selections below). When you 
choose Align Dynamics, all of the selected dynamics will be positioned at the 
vertical position of the selected dynamic furthest from the staff. All of the dynamics 
remain selected after alignment, so you can nudge them all up or down afterwards 
in the usual way with Alt+up/down arrow. 

To reset aligned dynamics back to their original positions, select the dynamics and 
choose Edit ▸ Reset Position. (STEAM-8661) 

Creating dynamics on multiple staves. It is now possible to create dynamics on 
multiple staves in a single operation. Select the staves on which you want the 
dynamics to appear before you type Shift+D to open the dynamics popover, and 
when the popover is confirmed, dynamics will be created on all selected staves. 
(STEAM-7451) 

Fingering 

Advancing the popover. The Shift+F popover for fingering can now be advanced 
using the arrow keys, Space, and Tab. Fingering can only be added to selected 
notes, so when you advance the popover, Dorico will automatically select the 
appropriate note or chord in the current voice; if you need to add fingerings to a 
note or chord in another voice, or to notes or chords in multiple voices at once, you 
will need to manually select the notes or chords yourself before you type Shift+F. 
The left and right arrow keys navigate to the previous or next note or chord in the 
current voice; Space navigates to the next note or chord in the current voice 
(unless the last character you typed into the popover was a comma, so that you 
can naturally type a list of fingerings separated by commas and spaces, e.g. 1, 2, 
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5); Tab navigates to the first note or chord in the current voice in the next bar, while 
Shift+Tab navigates to the first note or chord in the current voice in the previous 
bar. (STEAM-8659) 

Graphics export 

1200dpi export. It is now possible to export bitmap graphics in TIFF or PNG format 
at 1200dpi resolution. (STEAM-8590) 

Instruments 

New ensembles. A number of new default ensembles are now available in Setup 
mode, including clarinet choir, pop horns, big band horns, and various rhythm 
sections. (STEAM-8546) 

Instrument changes. When a percussion player is switching back and forth 
between unpitched and pitched instruments, Dorico now shows the prevailing key 
signature as well as the prevailing clef when switching from an unpitched 
instrument to a pitched instrument. (STEAM-8751) 

Layouts 

Layout numbers. Some publishers use a numbering of scheme for each 
publication, with a catalogue or work number used to identify a specific work, and 
then each score or (more typically) part associated with that publication uses the 
catalogue number in conjunction with a number that uniquely identifies each part. 
For example, the full score might use catalogue number 23512, and the parts may 
then use numbers of the form 23512-01, 23512-02, and so on. 

To make this easier to manage, each layout can now have a number associated 
with it, unique to the layout type (i.e. full scores, parts, and custom scores are all 
numbered independently). To see or change the layout number for a layout, expand 
its card in the Layouts panel in Setup mode, where it can be edited. 

To print the layout number on the layout itself, use the token {@layoutNumber@} 
in a text frame; this will be substituted with the number of the layout in which it 
appears. 

The layout number is also prepended to the filename Dorico creates when 

exporting graphics in Print mode, or when exporting via File ▸ Export ▸ Flows. 
(STEAM-8742) 

Page and staff size read-out. When expanding a layout card in the Layouts panel 
in Setup mode, the page and staff size are now displayed in the preferred 
measurement unit as specified in Preferences, and if the page dimensions 
correspond to one of the preset page sizes, the name of the page preset is now 
displayed. (STEAM-8734, STEAM-8733) 
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Lyrics 

Lyric hyphens. A new option Lyric hyphen character has been added to the 
Hyphens section of the Lyrics page of Engraving Options, allowing you to override 
the default hyphen character used for hyphens between lyrics. (STEAM-8652) 

Markers 

Timecode in markers. A new option Timecode in markers has been added to the 
Markers page of Engraving Options, allowing you to choose whether or not 
timecode should be displayed in markers. (STEAM-8486) 

MIDI export 

Key signatures. Simple Western key signatures (of up to seven sharps and flats) 
are now exported in MIDI files. (STEAM-8370) 

Time signatures. If the flow to be exported contains repeats, time signatures are 
now exported correctly taking the repeats into account. (STEAM-8535) 

MIDI import 

Markers. Dorico now imports markers from MIDI files. If the SMPTE Offset value is 
defined for the MIDI file, Dorico also now imports that, and uses it to set the 
timecode position for the start of the flow. Markers are also now exported when 
exporting MIDI. (STEAM-8316) 

Tempo changes. To avoid cluttering up the score with many metronome marks, 
Dorico now imports small changes in tempo as signposts, with only jumps in tempo 
of at least 10bpm resulting in a visible metronome mark. (STEAM-8471) 

Default page setup. Dorico now attempts to set a sensible default page and staff 
size when importing a MIDI file with many tracks. (STEAM-8442) 

Enharmonic spelling. A new algorithm for producing correct enharmonic spelling 
when importing MIDI files or using MIDI recording has been implemented, greatly 
reducing the amount of manual respelling required after import or input. (STEAM-
6582)  

Pedal lines. Sustain pedal lines are now imported by interpreting MIDI controller 64 
data in imported MIDI files, or indeed during live MIDI recording. 

Player groups. When importing a MIDI file as a source for further arrangement or 
orchestration, it may be useful to demarcate the players in the final ensemble and 
the players introduced by the imported MIDI file. Switch on the new option Create 
player group for new players in the Import MIDI File dialog to place all of the 
players created for the tracks in the MIDI file into their own group, which can later 
be deleted if necessary. (STEAM-8487) 
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Part layouts. In a similar vein, you may prefer Dorico not to create part layouts for all 
of the players added when importing a MIDI file. If so, switch off the new option 
Create part layouts for new players in the Import MIDI File dialog. 

Mixer 

Hiding unused outputs. Different VST instruments provide a variety of output 
configurations, and depending on the way the plug-in is configured, you may find 
that some of the outputs that appear in the Mixer end up unused, making the Mixer 
more unwieldy than necessary. A new option Number of audio outputs to show 
in Mixer has been added to the Endpoint Setup dialog, allowing you to limit the 
outputs shown in the Mixer. (STEAM-8679) 

Multi-bar rests 

Split multi-bar rests. A new command to split a multi-bar rest at a specific barline 
has been added. This may be useful if you need to split a multi-bar rest into two or 
more rests that would otherwise be shown as a single one, perhaps to make it 
easier by revealing the phrase structure of the music and to allow a cue to be 
written in during a rehearsal or session. 

In Engrave mode, select the barline at which you want the multi-bar rest to be split, 

then choose Engrave ▸ Split Multi-bar Rest. A signpost containing the word 
SPLIT will appear, and any ongoing multi-bar rests at that barline will be split in all 
instrumental parts. To remove the split, simply select the signpost and delete it. 

Music fonts 

Changing text fonts. A new option Update text fonts when changing music 

fonts has been added to the Engrave ▸ Music Fonts dialog, allowing you to 
determine whether Dorico should additionally reset text fonts when you change 
music font. By default, this option is switched on, which means that when 
switching to Petaluma, the default text font will be set to Petaluma Script, and 
when switching to Bravura, the default text font will be set to Academico. (STEAM-
8662) 

MusicXML import 

Default page setup. If the MusicXML file to be imported specifies the page size and 
margins of the document, Dorico now respects this value, and also imports the 
staff size, if specified. If the page and staff size are not specified in the MusicXML 
file, Dorico now sets sensible defaults for these values, based on the number of 
instruments in the ensemble. 

Note input 

Popovers. Typing Return or double-clicking a single item in Write mode now 
opens the appropriate popover, populated with the input that would produce that 



 

 
Dorico 2 Version History Page 49 Steinberg Media Technologies GmbH 

item. This was previously the case for lyrics and chord symbols and is now 
extended to all types of item for which a popover is used. This includes tempo, 
dynamics, clefs, octave lines, key signatures, time signatures, playing techniques, 
holds and pauses, pedal lines, rhythmic feel, cues, arpeggio signs, glissandos, 
ornaments, and trills. 

This means that many items that would previously cause the caret to appear at that 
rhythmic position if you selected them and hit Return will now cause the popover 
to appear instead: to show the caret you should select a note, chord, rest, beam, or 
barline before you hit Return or type Shift+N. 

Swap the contents of two staves. A new command Edit ▸ Paste Special ▸ Swap 
has been added, making it very quick to try out alternative voicings or instrumental 
colors. In particular, if you find that Explode produces a voicing that you want to 
change, selecting the music in two staves in the affected passage and choosing 
Swap provides a fast way to try another voicing. (STEAM-7846) 

Force Duration. It is now possible to set and unset Force Duration on existing 
notes and rests, rather than it only being possible to set Force Duration when a 
note or rest is first input. When you select a note or rest that was input with Force 
Duration, the corresponding button in the toolbox will now be illuminated; to 
remove Force Duration, simply click the toolbox button or use the key command O. 
Conversely, you can select a note and force its duration such that if you, say, 
lengthen or shorten it, the way the note is currently split up will be preserved: to 
force the duration of an existing note or rest, simply select it and click the toolbox 
button or type O. If you tie two or more existing notes that have had Force Duration 
set on them, Dorico attempts to retain the forced duration of the final note in the 
chain of ties. (STEAM-8427) 

Linked slurs and dynamics. A new option Link dynamics and slurs to existing 
items when pasting has been added to the Editing section of the General page 
of Preferences, switched on by default. If you would prefer Dorico not to create 
links between dynamics and slurs on different staves when you paste a group of 
dynamics or a slur at the same rhythmic position as dynamics or slurs with identical 
durations, switch this option off. (STEAM-8570) 

Inserting beats or other non-bar durations. Using the Shift+B popover, you can 
now insert any amount of rhythmic space rather than only inserting one or more 
bars’ worth of space. You can specify the multiple of units to add using a number, 
and then the unit itself either using the number that corresponds to that rhythmic 
duration (e.g. 6 for quarter, 5 for eighth, 7 for half, etc.) or a letter (e.g. q for quarter, 
e for eighth, h for half, x for 16th, etc.). Rhythm dots can be represented using the 
full stop or period character. If using numbers for both the multiple and the unit, the 
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two values must be separated by either a space or a hyphen, but if using letters for 
the value there is no need to separate them. By way of example, 4q, 1w, 4-6, 2 7 
would all insert four quarters’ worth of time. 

You can alternatively enter the same kind of string used to represent a time 
signature in the Shift+M popover: for example, entering 4/4 would also insert four 
quarters’ worth of time. (STEAM-8579) 

Inserting bars before time signature changes. In previous versions of Dorico, if you 
selected a time signature and invoked the Shift+B popover to add bars, those bars 
would always be added immediately following the time signature, i.e. the same 
behavior as if you had selected the note or rest at the start of the bar and inserted 
bars. In Dorico 2.2, you can now insert bars using the previous or prevailing time 
signature, thus moving the time signature along with the other musical material to 
its right: select the time signature itself and type Shift+B. (STEAM-8580) 

Key commands. It is now possible to assign key commands to various commands 
from the Edit menu, including filtering notes by position in chord, filtering notes by 
voice, and changing the voice of selected notes. (STEAM-7847) 

Rhythmic grid. It is now possible to assign key commands to set the rhythmic grid 
to a specific note duration, in addition to the existing key commands that increase 
or decrease the current grid value. (STEAM-8660) 

Lengthening and shortening notes. New commands to lengthen and shorten notes 
by a specific note duration have been added and can have key commands 
assigned, complementing the existing commands to lengthen and shorten by the 
current rhythmic grid. These commands can be found in the Key Commands page 
of Preferences by searching for Shorten duration by and Lengthen duration by. 
(STEAM-4605) 

Using existing voices when pasting. When pasting material consisting of a single 
voice, Dorico will now re-use an existing voice in the destination instrument that 
shares the same nominal stem direction as the voice used by the copied material 
when possible, instead of always creating a new voice. (STEAM-8758) 

Notes 

Rhythm dots for unisons. The options for how rhythm dots should appear for 
unisons in opposing voices have been further adjusted: the new Rhythm dots on 
unisons in opposing voices option in the Rhythm Dots section of the Notes 
page of Engraving Options allows you to specify whether each note should show 
its own rhythm dot always, never, or only when the unison notes are on a staff line 
(in which case one dot can appear symmetrically in the spaces above and below 
the note). (STEAM-8604) 
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Playback 

Playback pre-roll. If one or more of the flows in your project begins with grace 
notes before the first primary beat of the first bar, you can specify a small amount of 
pre-roll on the Timing page of Playback Options so that Dorico will start playback 
just before the first beat of the first bar. Set Pre-roll before flow to a suitable 
value; for a single grace note, even a value as small as 0.25 seconds should be 
sufficient. 

Multi-port VST plug-ins. Some VST instruments, such as HALion 6 and Vienna 
Ensemble Pro, provide multiple banks of 16 MIDI channels, and these additional 
banks can now be addressed by Dorico. An additional drop-down menu has been 
added to the track header, allowing you to choose between the ports provided by 
the plug-in; the first bank of channels uses port A, the second port B, the third port 
C, and so on. The Endpoint Setup dialog has also been expanded to allow the 
specification of VST expression maps and percussion maps for each channel in 
banks beyond the first. (STEAM-5152) 

Printing 

SVG graphics. Instead of rasterizing SVG graphics when drawing them on screen, 
exporting graphics or printing, Dorico now renders them directly using primitive 
drawing instructions, which results in both smaller file sizes and superior 
appearance in exported PDF files and printed pages. (STEAM-8404) 

Booklet printing. Depending on the paper path of your printer, when printing 
booklets using manual duplexing (i.e. where you have to flip the paper after the first 
side has been printed and feed it back into the printer for the second side to be 
printed), you may find that the order of pages is incorrect when printing the inward 
pages. A new Reverse order of outward pages option has been provided in the 
right-hand panel in Print mode, which will cause Dorico to output the first set of 
pages in the opposite order, necessary for some printers so that you do not have to 
reverse sort the pages manually before returning them to the printer to print the 
other sides. (STEAM-8440) 

Manual duplexing. It is now possible to specify manual duplexing for all job types, 
in addition to booklet printing. (STEAM-5544) 

Enhanced page ranges. It is now possible to specify arbitrary ranges of pages for 
printing. The previous From and To spin controls have been replaced by an edit 
control allowing free input of multiple page ranges. Each page range is separated 
by a comma, and uses a hyphen to specify a continuous range of pages. For 
example, you can type 1,3,5-7 to print pages 1, 3, 5, 6, and 7. Reverse ranges are 
supported, and will print pages in reverse order if requested. (STEAM-8746) 
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Rhythmic feel 

Swing for unequally divided beats. If a quarter (crotchet) beat is divided as eighth-
16th-16th, Dorico will now play this beat swung, with the initial eighth lengthened 
and the two 16th notes shortened to fit into the shortened second half of the beat. 
(STEAM-8318) 

Selections (STEAM-8476) 

Select More. A new Edit ▸ Select More command has been added, with the 
default key command Ctrl+Shift+A (Windows) or Shift-Command-A (Mac). 
When invoked, it examines the current selection to determine which event type or 
types should be selected, and which streams it should examine. It can operate on 
any number of event types and voices at once, so the selection can span multiple 
staves and include system-attached as well as staff-attached objects. 

Select More can be repeatedly invoked to continue expanding the selection. First, 
it expands to the boundaries of the current bar, both left and right; next, if you are in 
page view, it expands to the boundaries of the current system, both left and right 
(except in galley view, which has only a single system); finally, it expands to the 
entire flow. 

The expansion of the selection is always in the horizontal dimension: it will not 
select items in streams that are not part of the initial selection. So, for example, if 
you select notes in an up-stem voice on a single staff and invoke Select More, it 
will not select notes in a down-stem voice on the same staff, or indeed in an up-
stem voice in another staff. 

If attempting to select more items at the current extent does not succeed in 
growing the selection (e.g. you select a semibreve in 4/4 and invoke Select More, 
and this will not manage to select any more notes in the bar because the selected 
note already fills the bar), then Dorico automatically advances the extent (to the bar, 
system, then flow) until the selection is grown (unless, of course, it cannot be 
grown because there are no further similar items to select). 

When items start in one bar or system and end in the next, they will become 
selected when Dorico expands the range to the bar or system boundary (e.g. a 
hairpin that crosses a system break will become selected when you select 
dynamics on the first system). 

Select More can be used in both Write mode and Engrave mode. This is helpful 
because it allows you to e.g. quickly select the dynamics in a group and then 
nudge them up and down without switching to Write mode and back to Engrave 
mode. 
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There are several special cases that will be triggered if there is only a single item 
selected when Select More is invoked: 

§ Lyrics: if you select a lyric, Dorico will record the line number, placement, 
and line type of that lyric, and invoking Select More will select only lyrics 
whose line number, placement and line type match the originally selected 
lyric. 

§ Dynamics: if you select a dynamic and invoke Select More, Dorico will 
select all of the other dynamics in that group on that staff in one step (in 
page view, provided they are on the same system). As you continue 
invoking Select More, it will then continue to select other dynamics in other 
groups in the range of interest. 

§ Playing techniques: if you select a single playing technique, when invoking 
Select More only playing techniques of the same category will be selected. 
As a further special case, if you select either an up bow or down bow 
playing technique, invoking Select More will select all up bow and down 
bow playing techniques in the range of interest, but no other kinds of 
playing techniques. 

Hiding or showing selected items. A new Hide/Show Item command has been 
added; though it does not appear in the menus it can be assigned a key command 
on the Key Commands page of Preferences. This command operates on the three 
types of item that have dedicated properties to hide them: chord symbols, playing 
techniques, and time signatures. When the command is invoked, Dorico examines 
the selection to determine whether any of the items can be hidden. If the selected 
items are a mixture of hidden and shown, the first invocation will hide all items; the 
next invocation will show them all again. 

When hiding time signatures, be aware that they will be hidden in all layouts in 
which they appear; chord symbols and playing techniques, by contrast, will be 
hidden only in the layout in which the command is invoked. (STEAM-8544) 

Slurs 

Editorial slurs. The stroke for editorial slurs now draws perpendicular to the angle 
of the slur, rather than always being drawn vertical regardless of the slur’s angle. 
(STEAM-8402) 

Bisecting naturals. A new option When slur curvature passes close to the stem 
of a natural has been added to the Avoiding Collisions section of the Slurs page 
of Engraving Options, allowing you to choose whether slurs should be allowed to 
skim the vertical stems of natural accidentals, or whether they should never be 
allowed to touch them. (STEAM-8618) 
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System items 

Placement relative to ossias. Since ossia staves were introduced in Dorico 2.0, 
system items – such as tempos, rehearsal marks, and so on – were always 
positioned above the main staff, and below any ossia staff above the main staff. A 
new option Position of system objects relative to ossia above staff has been 
added to the Staves and Systems page of Layout Options that makes it possible 
to specify that system items should be positioned above the ossia staff if desired. 
(STEAM-8509) 

Tempo 

Tempo equations. Simple tempo equations of the form  =  can now be created 
via the Shift+T popover, or using the new Tempo Equation section of the Tempo 
panel in Write mode. To specify the note values to be used on either side of the 
equation, use the following letters: 

§ Whole note (semibreve): w 
§ Half note (minim): h 
§ Quarter note (crotchet): q 
§ Eighth note (quaver): e 
§ 16th note (semiquaver): x 

You can also add up to two rhythm dots to the note values on either side of the 
equation using . (full stop or period). 

Tempo equations normally take effect at a barline, so if you create a tempo 
equation at the start of a bar, Dorico will automatically center it over the barline at 
which it takes effect. In the unusual circumstance where the relationship of the 
tempo changes without a change of a time signature, and where the barline at 
which the change occurs ends a system, you may need to adjust the horizontal 
position of the equation in Engrave mode. 

Tempo equations are taken into account in playback. 

Find tempo by tapping. A new Tap Tempo section has been added to the Tempo 
panel in Write mode, allowing you to create an immediate tempo change by 
clicking the large Tap button a few times. As you click, the tempo implied by the 
time between each click is calculated and displayed in the spin box below. Choose 
the note value you want to use for the tempo, and click Create to either create the 
tempo mark at the position of the selection, or load the mouse pointer so that you 
can click to place the tempo in the flow. 

Text 

Creating text using a specific paragraph style. It is now possible to assign a key 
command to start inputting staff- or system-attached text in a particular paragraph 
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style. On the Key Commands page of Preferences, find the desired paragraph 
style within the Create Text or Create System Text categories, and assign the 
desired shortcut. 

Furthermore, all of the paragraph styles in the current project are now listed in the 

new Write ▸ Create Text and Create System Text submenus, making it possible 
to choose to create a text item using a specific style with the mouse as well. 
(STEAM-8545) 

Paragraph styles dialog. If a staff- or system-attached text item is selected when 

Engrave ▸ Paragraph Styles is invoked, the paragraph style of the first paragraph 
in the text item will be selected for editing in the dialog when it opens. If no text 
item is selected, however, the dialog will instead select the last paragraph style 
chosen for editing, making it more convenient to try out a series of adjustments to a 
particular paragraph style. (STEAM-8765) 

Font styles. The previous selection in the Engrave ▸ Font Styles dialog is now 
remembered within the current editing session, making it more convenient to make 
several edits to the same font style if needed. (STEAM-8561) 

Time signatures 

Deleting time signatures. When deleting a time signature, subsequent time 
signatures are not moved rhythmically, which can mean that if the rhythmic space 
between the deleted time signature and the following meter change is not an exact 
multiple of the bar length of the prior prevailing time signature, an irregular bar will 
exist before the next meter change. To avoid this, engage Insert mode (key 
command I) before you delete the time signature: in common with inserting a time 
signature, Dorico will if necessary shift the following meter change in order to avoid 
an irregular bar. (STEAM-8508) 

Gap between numerator and denominator. In some house styles, there may be 
found a small gap between the numerator and the denominator of a time signature. 
Dorico now provides separate options for the gap between numerator and 
denominator for normal-sized, large, and outside staff time signatures, in the Gaps 
section of the Time Signatures page of Engraving Options. (STEAM-8438) 

Tokens 

New tokens. The following new tokens have been added: 

§ {@flowNumber@} corresponds to the number of the flow as shown in the 
bottom right-hand corner of the flow’s card in the Flows panel in Setup 
mode. 

§ {@flowDuration@} and {@flownDuration@} show the duration of the 
current flow or a specific flow respectively, formatted as m’s”, e.g. 4’33”. 
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§ {@layoutNumber@} corresponds to the number of the layout, as specified 
in the Layouts panel in Setup mode. 

Resolving non-indexed tokens. In earlier versions of Dorico, a non-indexed token 
(e.g. {@flowTitle@} rather than {@flow3Title@}) would always use the flow 
located nearest the top left-hand corner of the page to determine which flow 
should be used to resolve the token and fetch the relevant data. In Dorico 2.2, this 
behavior has changed: non-indexed tokens now use the flow of the system 
immediately beneath them (or, if a token is present in a text frame at the very 
bottom of a page, the flow of the system immediately above). This means that it is 
now possible to use the same non-indexed token in multiple positions on a single 
page and the resolved text may come from a different flow. 

User interface 

View notes out of range. A new command View ▸ Note and Rest Colors ▸ 
Notes Out of Range has been added, switched on by default in new projects. 
When this option is switched on, any note that is outside the playable range of the 
instrument will be colored red when it is not selected. Many instruments have two 
ranges defined: a standard range, and an advanced range, which includes notes 
that can be played either by more skilled players or using instruments with special 
extensions. Notes outside the standard range but within the advanced range 
appear in a darker shade of red, while notes outside both playable ranges are 
colored a bright red. 

Engrave mode toolbox. A new toolbox has been added on the left-hand 
side of Engrave mode, replacing the single panel that has been used in 
previous versions. The switches in the headers in the previous panel that 
activate and deactivate the three special editing tools in Engrave mode 
– for editing frames, vertical spacing, and note spacing – have been 
removed, and the buttons in the toolbox now perform those functions. 
From top to bottom, the buttons are: 

§ Graphic editing 
§ Frames 
§ Vertical spacing 
§ Note spacing 

No panel appears when the vertical spacing or note spacing editing tools are 
active. The Copy Staff Spacing dialog, which used to be accessed from a button 
in the Staff Spacing section of the left-hand Engrave mode panel, is now 

accessed via the Engrave menu: choose Engrave ▸ Staff Spacing ▸ Copy Staff 
Spacing. (STEAM-8783) 
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Status bar summary. A summary of useful information has been added to the 
bottom left-hand corner of the document window. This shows three kinds of 
information: firstly, the transposition of the current layout (i.e. either Concert Pitch 
or Transposed Pitch); secondly, the range of bars of the current selection, if there 
is one; and thirdly, a summary of the current selection. When a note is selected, the 
sounding pitch of the note is shown; if multiple notes at the same rhythmic position 
are selected, then a text description of the implied chord symbol is shown. 

Options dialogs. The Layout Options and Notation Options dialogs have been 
redesigned such that the list of layouts and flows respectively now appears on the 
right-hand side of each dialog, allowing the drop-down menu listing the pages of 
each dialog to be presented as a list on the left-hand side, which is both consistent 
with the other options dialogs and also makes it easier to see which categories of 
options are available at a glance. 

Furthermore, if the current page has multiple sections, the 
names of these sections now appear as subheadings below 
the name of the selected page: click a subheading to instantly 
scroll the page to the top of that section. 

In addition to remembering which page you were last looking 
at when recalling one of the options dialogs, Dorico now also 
scrolls the page to the section of the page you were last looking at. 

Tempo read-out. The current tempo at the playhead position is now shown in the 
mini transport on the toolbar and in the Transport window. 

Zoom. When there is no selection, Dorico now zooms in and out relative to 
whatever is currently in the center of the viewport, instead of trying to focus on a 
particular page of interest, with the result that the position of the score is more 
stable when zooming in and out. (STEAM-8552) 

Score positioning. When extending the selection, Dorico now records the direction 
in which the selection is being extended, and ensures that the end of the selection 
that is changing is brought into view if necessary, preventing unexpected shifts to 
the start of the selection instead. (STEAM-8553) 

Library functions in dialogs. Those dialogs that preset a consistent set of options 
for managing user-created or edited items – Playing Techniques, Notehead 
Sets, Paragraph Styles, Character Styles, Music Symbols, etc. – now all 
present a consistent set of icons for operations like creating a new item, saving it 
as a default for future projects, or reverting an edited item back to its factory 
default. (STEAM-8521) 



 

 
Dorico 2 Version History Page 58 Steinberg Media Technologies GmbH 

Tool tips in Key Commands editor. In some languages, the descriptions for 
commands in the Key Commands page of Preferences are wider than the width of 
the tree control in which they appear; hovering over a truncated entry in the list will 
now show the complete item name in a tool tip. (STEAM-8588) 

Minimum window width. The minimum width of the Dorico project window has 
been reduced by automatically replacing the five mode buttons with a single menu 
button when the window is made sufficiently narrow. This makes it somewhat more 
practical to use Dorico on displays with smaller resolutions, though we recommend 
that your display has a minimum horizontal resolution of 1280 logical units if 
possible. (STEAM-8657) 

Write mode panels. The panels on the right-hand side of Write mode can now be 
closed, as well as opened, by clicking their respective icons in the toolbox. 
(STEAM-8656) 
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Issues resolved 
ID # Component Issue 

STEAM-8802 Accidentals 
A problem whereby setting a microtonal accidental with a very large pitch delta can cause 
the note to jump up an octave has been fixed. 

STEAM-8722 
Arpeggio 
signs 

Arpeggio signs are spaced correctly relative to notes on cross-staff chords where extra 
staves have been added below the top staff of a piano. 

STEAM-8445 Bar numbers 
Changing the size of the chosen paragraph style for bar numbers now correctly updates all 
bar numbers throughout the current layout immediately. 

STEAM-8505 Bar numbers 
If bar numbers are shown every bar, when a player changes instruments with different 
numbers of staves, bar numbers no longer collide with the staff at the change point. 

STEAM-8651 Bar numbers Bar numbers no longer sometimes disappear when making an edit to another staff. 

STEAM-8603 Bar repeats 
Using Alt+up/down to nudge the bar count for bar repeat regions in Engrave mode now 
works correctly. 

STEAM-8642 Bar repeats 
Nudging or dragging bar counts for bar repeat regions in Engrave mode now works 
correctly. 

STEAM-8456 Barlines 
Key signatures at ends of systems no longer collide with the double barline shown for a 
start repeat at the start of the new system if single barlines normally shown for key changes. 

STEAM-8510 Barlines Start repeat barlines no longer collide with large time signatures shown in the staff. 

STEAM-8527 Barlines 
When a system begins with a grace note, Dorico would sometimes incorrectly use the 
barline sections from the previous system; this has now been resolved. 

STEAM-8520 Beams 
Under some circumstances, crossing beamed notes between staves could cause items to 
incorrectly avoid the beam once it was no longer between staves; this is now fixed. 

STEAM-8595 Beams 
Beams crossing barlines no longer incorrectly attempt to avoid time signatures if they are 
drawn above the staff rather than within the staff. 

STEAM-8403 
Brackets and 
braces 

The position of wings on brackets now correctly takes the value of Additional vertical 
protrusion beyond top or bottom of staff into account. 

STEAM-8399 
Chord 
symbols 

Hidden chord symbols no longer cause multi-bar rests to be split if they are shown above 
the top staff of the system rather than above specific players. 

STEAM-8644 
Chord 
symbols 

Setting or unsetting a property on a chord symbol with the chord symbol popover open 
could cause Dorico to crash; this is now resolved. 

STEAM-8406 Clefs Moving a clef before a dashed barline in an aggregate time signature now works correctly. 

STEAM-8426 Cues 
When showing the divisi section name or number in a cue label, the player number is now 
shown before the divisi section name or number, rather than after. 

STEAM-8431 Cues 
Rests in rhythmic cues are no longer forced an unnecessarily long distance away from the 
staff. 

STEAM-8607 Cues 
Under rare circumstances, changing the clef of an instrument that is cued in another 
instrument did not update the clef in the cue; this problem is now resolved. 
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ID # Component Issue 

STEAM-8264 Divisi Restorative clefs no longer incorrectly appear on the wrong divisi staff. 

STEAM-8444 Divisi 
If verse numbers are shown for lyrics in a passage of divisi music, the lyric verse numbers 
now appear only on the correct divisi staves. 

STEAM-8743 Divisi Cue labels and clefs no longer incorrectly appear in divisi staves. 

STEAM-8714 Dynamics 
Creating multiple dynamics with a run of grace notes selected now handles groups of up 
to three dynamics correctly. 

STEAM-8696 
Engrave 
mode 

When editing the text in a frame on a master page or flow heading, the text editor no longer 
sometimes appears in the wrong place. 

STEAM-7603 Fingering 
Under some circumstances, setting and unsetting fingering on one note could cause 
fingering on another note to move up or down unexpectedly; this is now resolved. 

STEAM-8420 Flows 
When exporting flows, Dorico now ensures that each exported flow is attached to at least 
one layout in the resulting project file. 

STEAM-8408 Graphics files 
It is now possible to set the anchor position for a graphic in a frame to a negative value, so 
it is possible (in a roundabout way) to show any part of the image in the frame. 

STEAM-8792 
Graphics 
import 

Importing a graphic file from a path including accented or other special characters now 
works correctly (Windows only). 

STEAM-8479 
Key 
signatures 

Creating a key signature that references a custom tonality system now always works 
correctly. 

STEAM-8529 
Key 
signatures 

When selecting items in a flow using multiple tonality systems, the panel now immediately 
updates to show the correct tonality system and custom key signatures and accidentals. 

STEAM-8585 
Key 
signatures 

In some projects, creating a key signature in the 24-EDO tonality system would cause a 
crash; this is now resolved. 

STEAM-8634 Localization 
The key command for starting tuplet input was incorrectly disabled outside note input in 
non-English-language versions of Dorico; this is now resolved. 

STEAM-8609 Lyrics 
When typing lyrics very quickly, it was possible for the last character of one lyric or the first 
character of the next to be dropped; this problem is now resolved. 

STEAM-7408 MIDI import 
If a note cannot be quantized into a tuplet correctly, it no longer causes subsequent notes 
in that voice not to be imported. 

STEAM-8186 MIDI import 
Step-wise MIDI controller data (e.g. controller 64 for sustain pedal) now imports correctly 
from MIDI files. 

STEAM-8428 MIDI import 
Quantization for notes in tuplets now removes overlaps in the same manner as notes 
outside tuplets. 

STEAM-8518 MIDI import 
Under some circumstances, the option for where the split point between the staves of a 
grand staff instrument should occur was being ignored; this has now been resolved. 

STEAM-8665 MIDI import 
MIDI controller data is now correctly imported when importing a MIDI file into an existing 
project. 
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ID # Component Issue 

STEAM-8551 
Multi-bar 
rests 

Mid-bar changes of key signature now correctly cause multi-bar rests to be split. 

 Music fonts 
The size of chord symbol accidentals and the vertical position of notes for metronome 
marks and tempo equations in Petaluma have been improved, 

STEAM-8576 
MusicXML 
import 

Lyric extender lines on the first line of lyrics in MusicXML files exported from Finale no 
longer end one note too early. 

STEAM-8681 
MusicXML 
import 

When importing transposing instruments from MusicXML files, Dorico is now much more 
likely to choose the correct transposition. 

STEAM-7949 Note input 
Pasting lyrics from notes within a tuplet into another similar tuplet now pastes the lyrics to 
the correct positions in similar tuplets without requiring chord mode to be enabled. 

STEAM-8336 Note input 
Changing the duration of a tied note split by Force Duration no longer causes the duration 
to be changed in irregular, non-notatable ways. 

STEAM-8421 Note input 
When copying and pasting notes spanning tuplet boundaries, Force Duration splits are no 
longer lost. 

STEAM-8434 Note input 
Typing R when note input is active now correctly repeats the note or chord immediately to 
the left of the caret, instead of the note at the caret position. 

STEAM-8461 Note input It is now possible to use R to repeat an implicit rest to the left of the caret. 

STEAM-8468 Note input 
It is now possible to delete tuplets with a 1:1 ratio that have lyrics on the notes within the 
tuplet. 

STEAM-8477 Note input Rests, like notes, are now selected after they have been created during note input. 

STEAM-8582 Note input 
Selecting multiple notes of the same pitch on instruments held by different players and 
adding ties with T now works correctly, even for notes of the same pitch. 

STEAM-8621 Note input 
Pasting music from a multi-staff instrument where some notes have been crossed to 
another staff to a single-staff instrument now resets back to the original staff. 

STEAM-8750 Note input 
When the caret is positioned between grid positions, moving it left no longer incorrectly 
moves the caret to the start of the bar. 

STEAM-8808 Note input 
Moving the caret up or down between staves belonging to different instruments held by the 
same player could sometimes fail; this has now been resolved. 

STEAM-8860 Note input 
Copying and pasting a local time or key signature to another staff at the same rhythmic 
position no longer incorrectly links them together. 

STEAM-8861 Note input 
Using Force Duration to set the duration of implicit rests on multiple staves now works 
correctly. 

STEAM-8425 Noteheads 
Clicking Revert to Factory in the notehead set editor for a notehead set no longer 
incorrectly also reverts changes made to the notehead types referenced by the set. 

STEAM-6650 Notes 
Under some circumstances, dotted chords in opposing voices would be positioned further 
apart than necessary when accidentals are present; this has now been resolved. 
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ID # Component Issue 

STEAM-8469 Octave lines 
The illustrations and labels for octave line continuation options on the Octave Lines page 
of Engraving Options have been clarified. 

STEAM-8454 Page layout 
Closely-positioned text events in galley view no longer sometimes cause items like 
dynamics to move further away from the staff. 

STEAM-8462 Page layout 
Adding a key signature in a flow containing explicit system breaks now correctly causes all 
systems to be cast off again. 

STEAM-8504 Page layout 
Under some circumstances, moving unrelated items (e.g. arpeggio signs) could cause 
dynamics to move further away from the staff; this has now been resolved. 

STEAM-8528 Page layout 
Under some circumstances involving instrument changes, allowing empty staves to be 
hidden could cause all staves in a system to be hidden; this has now been resolved. 

STEAM-8539 Page layout 
Changing the staff size at a system break at the start of the flow now correctly causes all 
systems to be cast off again. 

STEAM-8683 Page layout 
Staves containing bar repeat or slash regions, or completely empty staves with bar rests 
hidden, are now adjusted correctly during vertical justification. 

STEAM-8686 Page layout It is no longer incorrectly possible to remove all of the staves belonging to an instrument. 

STEAM-8749 Page layout 
When two projects are open with multiple windows open for each, opening the master 
page editor in Engrave mode no longer sometimes opens it in the wrong project window. 

STEAM-8571 Percussion 
Slash instruments in percussion kits now correctly use slash noteheads after importing 
them from a library file. 

STEAM-8777 Percussion 
The playback playing technique for the chosen percussion playing technique is no longer 
incorrectly removed from the list in the Edit Playing Technique dialog. 

STEAM-8560 Performance The speed of editing in galley view for large projects with many cues has been improved. 

STEAM-8851 Performance The performance of Duplicate Flow has been improved. 

STEAM-8872 Performance 
The performance of inputting music in a part that is used as a cue earlier in the flow has 
been improved. 

STEAM-8873 Performance 
The performance of inputting music in scores with divisi where a fermata is used following 
a divisi change has been improved. 

STEAM-8457 
Piano 
pedaling 

Pedal lines no longer become misaligned after an ossia or extra staff is added to the piano 
instrument to which they are attached. 

STEAM-8435 Play mode 
The e button that shows whether a VST plug-in window is open is now correctly updated 
when changing playback template. 

STEAM-8629 Play mode 
A tempo markings now correctly ignore any tempo changes added in the Timing 
automation lane in Play mode. 

STEAM-8633 Play mode 
Tempo changes that reset to an earlier tempo now appear correctly in the Timing 
automation lane in Play mode. 
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ID # Component Issue 

STEAM-8701 Play mode 
A problem whereby changing the audio device in Edit ▸ Device Setup could intermittently 
cause no audio device to be mapped has been resolved (Mac only). 

STEAM-8724 Play mode 
Changing the VST instrument, MIDI device or MIDI channel of an instrument in Play mode 
no longer causes the view to jump back to the top of the track list. 

STEAM-8850 Playback A hairpin on a grace note will no longer result in the following note becoming silent. 

STEAM-8494 
Playing 
techniques 

Creating a new glyph-based playing technique with differing above/below appearances 
based on an existing one now correctly makes the below appearances independent. 

STEAM-8599 Print mode 
Instead of printing in solid black, when printing or exporting graphics in monochrome, 
watermarks are now excluded. 

STEAM-8458 Project files 
Opening project files that contain a lot of MIDI controller and other automation data is now 
considerably faster. 

STEAM-8396 Properties Edit ▸ Propagate Properties now propagates the placement properties for dynamics. 

STEAM-8611 
Rhythm 
slashes 

Under some circumstances, shortening a rhythm slash region might leave it in a state in 
which its length will become incorrect after further edits; this is now resolved. 

STEAM-8648 
Rhythm 
slashes 

Moving or changing the duration of a slash region with an overridden staff position could 
cause the slashes to change position unexpectedly; this is now resolved. 

STEAM-5759 Selections 
Extending a selection with Shift+click no longer sometimes moves the view to the start of 
the selection. 

STEAM-8430 Selections 
Selecting the contents of a bar including a system-attached item such as a tempo or chord 
symbol and then using Shift+click to extend the selection now works as expected. 

STEAM-8464 Selections 
Using Shift+click to extend the selection now works as expected if the selection begins 
with an implicit rest. 

STEAM-8531 Setup mode 
Dorico no longer crashes when you detach and then attempt to re-attach a player to a 
layout whose music contains a slash region. 

STEAM-8532 Slurs 
In the unlikely event that a project contains slurs with negative durations, these are now 
cleaned up when the project is loaded, and Dorico will not hang trying to open it. 

STEAM-5548 Tempo 
When a gradual tempo item crosses a system break and the top visible staff in the system 
is different following the break, the tempo now appears correctly as it should. 

STEAM-6547 Tempo 
Under some circumstances, a gradual tempo item would not appear if it ended at the same 
rhythmic position as another system item, like a chord symbol; this is now resolved. 

STEAM-8498 Tempo 
Under some circumstances, changing the line style of a gradual tempo marking could 
cause it to move further away from the staff; this has now been resolved. 

STEAM-8653 Tempo 
Under some circumstances, a tempo marking immediately preceding a rehearsal mark 
could cause vertical spacing to change unexpectedly; this is now resolved. 

STEAM-8387 Text 
Italic fonts are no longer clipped at the left-hand edge of a text frame, and optical 
overshoots are no longer clipped at the top edge of a text frame. 
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ID # Component Issue 

STEAM-8395 Text Baseline shift now scales correctly as the font size of a paragraph style is changed. 

STEAM-8480 Text 
Changing the weight or italic/Roman style of a font used by a paragraph style now 
correctly immediately updates the score. 

STEAM-8565 
Time 
signatures 

The positioning of time signatures shown outside the staff at system object positions 
relative to different types of barline has been improved. 

STEAM-8698 
Time 
signatures 

Adjusting staff spacing now correctly adjusts the vertical position of large time signatures 
centered on instrument brackets. 

STEAM-8414 User interface 
Creating a new window from a project window that has the tab bar hidden now works 
correctly. 

STEAM-8493 User interface 
Window ▸ Counterpart Layout has been improved so that it can be used from Engrave 
mode, though the selection cannot necessarily be retained. 

STEAM-8534 User interface 
Opening a new project could under some circumstances switch the layout shown in an 
already-open project’s window; this has now been resolved. 

STEAM-8567 User interface 
Opening the same file repeatedly from a network location will no longer cause other 
projects to be removed from the list of recent projects (Windows only). 

STEAM-8593 User interface 
Switching between Write and Engrave modes with multiple tabs open now correctly sets 
all tabs to the appropriate view type for the current mode. 

STEAM-8601 User interface The appearance and position of the Cancel button in progress dialogs has been improved. 

STEAM-8615 User interface 
The list of open project windows at the bottom of the Window menu now always lists the 
correct number of items. 

STEAM-8755 User interface 
When switching between page and galley view, Dorico now uses the bar in the middle of 
the view to set the position in the new view, rather than returning to the start of the layout. 

STEAM-8868 User interface 
New project windows created by right-clicking a tab and choosing Move Tab to New 
Window are now created at the correct default size. 
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Dorico 2.1.10 

14 September 2018 

This version contains the following issue resolutions. 

Issues resolved 
ID # Component Issue 

AD-355 Audio engine 
A problem whereby the length of the first note in the flow could be truncated in exported 
audio files has been resolved. 

AD-356 Audio engine 
Under some circumstances, Dorico could crash when waking the computer from sleep. 
This problem has now been resolved (Mac only). 

STEAM-8538 Audio export 
Exporting audio would hang or export an empty file if the name of the flow to be exported 
ended in a trailing space or multiple full stops; this has now been fixed (Windows only). 

STEAM-8454 Dynamics 
Editing unrelated items no longer sometimes causes dynamics to move incorrectly 
vertically in galley view. 

STEAM-8223 
Key 
signatures 

Key signatures for transposing instruments in divisi staves now appear correctly. 

STEAM-8479 
Key 
signatures 

Key signatures created using a custom tonality system no longer sometimes reference the 
wrong system of accidentals and set of octave divisions. 

STEAM-8502 Localization 
When running Dorico in a language where comma is used as the decimal separator, spin 
boxes that use decimal values now work correctly. 

STEAM-8455 Mixer 
Outputs for plug-ins added in the VST Instruments panel in Play mode now appear 
correctly in Dorico’s Mixer once more. 

STEAM-8516 Percussion 
Percussion playing techniques now play back correctly in the event that one or more 
instruments in the kit cannot be mapped to entries in the chosen percussion map. 

STEAM-8398 Performance 
Deleting notes at the end of a flow that has explicit bar rests near the start is now much 
faster. 

STEAM-8417 Performance 
Inputting notes in scores with large numbers of players is now much faster, at the expense 
of reducing the automatic balancing of bars per system at the end of the flow. 

STEAM-8447 Performance 
Showing the system track in galley view no longer causes editing and redraw to be 
significantly slower. 

STEAM-8458 Performance 
Opening project files with many MIDI controller automation events is now significantly 
faster. 

STEAM-8418 Play mode 
Dorico no longer crashes if you do Play ▸ Reset Playback Overrides with items other 
than notes selected. 

STEAM-8435 Play mode 
The e button that shows whether a VST plug-in window is open now always correctly 
reflects the current state. 

STEAM-8432 Print mode 
Exporting a PDF of a 2-up document using a non-European page size now produces a 
PDF of the correct dimensions. 
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ID # Component Issue 

STEAM-8429 Project files 
Under rare circumstances in projects with divisi and local time signatures, Dorico could 
hang when attempting to re-open an existing project; this has now been resolved. 

STEAM-8475 Project files 
Under rare circumstances, Dorico could crash when attempting to save a project. This 
problem has now been resolved. 

STEAM-8419 Rhythmic feel 
Dorico no longer crashes if you type a character not included in any of the rhythmic feel 
names into the filter control in the Edit Rhythmic Feel dialog. 

STEAM-8423 Text 
Under some circumstances, moving a text item on one staff could cause a text item on 
another staff to move unexpectedly. This problem has now been resolved. 
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Dorico 2.1 

10 August 2018 

This version contains the following new features, improvements and issue 
resolutions. 

New features 

Swing playback 

Dorico 2 now includes support for swing playback. It is possible to set up a 
project-wide default swing pattern, or to change the amount of swing (or indeed to 
switch between straight and swing) at any point in the music, and it is also possible 
for different players to play different swing patterns at the same time. 

Based on academic research into how swing is actually rendered by real musicians 
by authors Anders Friberg and Andreas Sundström, Dorico’s swing patterns are 
tempo-dependent, with the swing feel more pronounced at lower tempos, and 
trending towards a straight feel at higher tempos. Swing feels that produce the 
same ratio at all tempos are also included, and it’s possible to define your own 
swing patterns. 

Project-wide swing. To enable swing for your whole project, open Play ▸ 
Playback Options and choose the Timing page. Choose the desired swing 
pattern from the Default rhythmic feel menu: 

§ 2:1 swing (fixed) – sometimes called triplet swing, this elongates the first 
eighth (quaver) in a pair of eighths to be twice as long as the second, 
creating a strict triplet 2:1 ratio; this ratio is maintained regardless of the 
tempo. 

§ 3:1 swing (fixed) – this elongates the first eighth in a pair of eighths to be 
three times as long as the second, creating a dotted eighth-16th (dotted 
quaver-semiquaver) ratio; this ratio is maintained regardless of the tempo. 

§ Heavy swing – this produces a tempo-dependent swing ratio of between 
3:1 at low tempo and 1.5:1 at high tempo. 

§ Light swing – this produces a tempo-dependent swing ratio of between 
1.5:1 at low tempo and 1:1 (i.e. straight) at high tempo. 

§ Medium swing – this produces a tempo-dependent swing ratio of 
between 2:1 at low tempo and 1.5:1 at high tempo. 

§ Straight (no swing) – this produces even eighth notes in the ratio 1:1 at 
all tempos. 
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Changing swing mid-flow. To change the swing pattern for a particular section of 
the project, select a note, rest or other item at the location where you want to 
change the swing pattern, then type Shift+T for the tempo popover. Type the 
beginning of the name of the swing pattern you want to use, e.g. typing med will 
show Medium swing in the list of suggestions: use down arrow to select it, then 
hit Return to confirm your choice. A signpost will appear on the top staff in the 
system, showing the name of the rhythmic feel. 

To change the swing pattern used by just one of the players in the ensemble, first 
select a note, rest or other item on the staff in question, or position the caret there, 
then use the Shift+T popover to select the swing pattern using the down arrow 
key. Finally, type Alt+Return to confirm the popover: now a signpost appears on 
the chosen staff, showing the name of the rhythmic feel. 

Changes in rhythmic feel only take effect from the start of a bar, so if you create a 
change of rhythmic feel in the middle of a bar, it will take effect from the start of the 
following bar. 

To delete a change of swing pattern, simply select the corresponding signpost and 
hit Delete. You can choose whether or not rhythmic feel signposts should be 
shown via View ▸ Signposts ▸ Rhythmic Feel. 

Editing swing patterns. To edit one of the default swing patterns or define your 

own, first open the Timing page of Play ▸ Playback Options, then click the Edit 
button in the Rhythmic Feel section to open the Edit Rhythmic Feel dialog: 

 

The rhythmic feel definitions in the project are listed on the left. Click New to 
create a new default rhythmic feel; click New from Selection to create a copy of 
the currently-selected rhythmic feel; click Save as Default to save the currently-
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selected rhythmic feel into your user library so that it will be available in every new 
project you subsequently create. 

On the right-hand side of the dialog are some simple controls to define the swing 
pattern: 

§ Depends on tempo determines whether or not the swing pattern should 
use the same ratio at all tempos; when switched off, the Low tempo and 
High tempo controls are disabled, and a single swing ratio slider is shown. 

§ Low tempo specifies the tempo (in quarters per minute) at and below 
which the swing ratio for the slider to the right should be used. 

§ High tempo specifies the tempo at and above which the swing ratio for the 
slider to the right should be used. 

§ The swing ratio sliders cover a range from 1:1 (straight) to 5:1 (sextuplet, 
with the first eighth occupying five divisions, and the second eighth 
occupying the final division), and display both the ratio and a swing 
percentage to its right. 

When Depends on tempo is activated, the swing ratio defined for Low tempo is 
used at and below that tempo; as the tempo increases, Dorico interpolates the 
swing value towards the swing ratio defined for High tempo, until that tempo is 
reached. If Depends on tempo is not activated, then the swing ratio defined by the 
single slider is used at all tempos. 

Notehead set editor 

A new Engrave ▸ Notehead Sets dialog has been added, which allows you to 
modify the built-in notehead sets and design your own. 

A notehead set is a collection of related noteheads: it is important to know that the 
same notehead can appear in more than one notehead set, which means that if you 
edit a notehead within one notehead set, it will be edited in all notehead sets that 
contain that notehead. 

A normal notehead set typically contains at least four noteheads: the black 
notehead for notes up to a quarter (crotchet) in duration; the white notehead for 
half notes (minims); the wider white notehead for whole notes (semibreves); and 
the wider white notehead with one or two vertical strokes at either side, or a square 
white notehead, for double whole notes (breves). Dorico also supports two other 
types of notehead sets: pitched, where the notehead chosen will be different 
depending on the pitch of the note; and scale degree, where the notehead chosen 
will be different depending on the scale degree of the note, relative to the current 
key signature. The most common kind of pitched notehead set is the Note names 
notehead set, which shows the letter name (and accidental, if applicable) of the 
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current note within the shape of the notehead; an example of a scale degree 
notehead set is the Aikin 7-shape set for sacred harp or shape note singing. 

A notehead set of a particular type – normal, pitched, or scale degree – can only 
contain noteheads of the same type. It is not possible to use, say, a normal 
notehead within a pitched notehead set, so you cannot change the type of an 
existing notehead set or an existing notehead. 

The Engrave ▸ Notehead Sets dialog is split into three areas: 

 

On the left, you can choose which category to work with: the categories here 

correspond to the submenus in the Edit ▸ Notehead menu. You can change 
which noteheads appear in which submenu by selecting the notehead set in the list 
on the left, then changing the Category drop-down in the Notehead Set section at 
the top-right. 

Below the list on the left are the buttons to create and delete notehead sets: 

§ New creates an empty notehead of the Normal type, in the Common 
category. 

§ New from Selection creates a copy of the currently-selected notehead 
set, of the same type and in the current category. Be aware that the 
noteheads contained in the new set are the same as the ones in the set the 
new set is based on: if you want to make changes to the noteheads only in 
the new set, be sure to also create new noteheads based on the ones 
currently in the set. 

§ Save as Default saves the selected notehead set into your user library, so 
that it will be available in all new projects that you subsequently create. 
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§ Revert to Factory is only enabled for built-in notehead sets; if you have 
made any changes to a built-in set, this reverts it to its default state. 

§ Delete allows you to delete custom notehead sets, provided they are not 
currently being used by any notes in the project; built-in notehead sets 
cannot be deleted. 

The Notehead Set section at the top-right shows the noteheads in the current set. 

Click  to add an existing notehead to the current set: a menu listing all of the 
noteheads of the same type as the current set appears. To remove a notehead 
from the current set, click , which is only enabled when the notehead is not in 
use in the project. To specify the category in which this notehead set should 
appear, choose the desired entry from the Category list. The Default notehead 
specifies which notehead within the set Dorico should use if it is unable to find a 
notehead that exactly matches the requirements of a note (for example, if you have 
a note longer than a whole note, but no notehead of a suitable duration defined in 
the set, the default notehead will be used instead). 

You cannot change the Type of a notehead set: if you want to create a pitched or 
scale degree notehead set, select an existing notehead set of the desired type and 
use New from Selection to create a new notehead set based on it. 

The Notehead section at the bottom-right shows the properties for the notehead 
currently selected in the grid control in the Notehead Set section above. You can 
edit the following properties of each notehead: 

§ Name: the name of the notehead as it will appear in the menu in the action 
bar for the grid control above. 

§ Duration: the primary rhythmic duration for which the notehead is intended 
to be used. For most notehead appearances, the same notehead is used 
for notes of a quarter (crotchet) and shorter in duration: it is sufficient to 
choose 1/4 note for that notehead, then set Use for durations shorter 
than and equal directly below. 

§ Use for durations shorter than and equal specifies that this notehead 
should be used not only for the Duration specified above, but also for 
shorter notes. 

§ Use for durations longer than and equal specifies that this notehead 
should be used not only for the Duration specified above, but also for 
longer notes. 

§ Stem direction allows you to specify that this notehead should be used 
specifically for up-stem or down-stem notes. (For example, in shape note 
systems, the triangular notehead points in opposite directions for up-stem 
and down-stem noteheads.) 
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§ Double whole note allows you to specify that this note is nominally a 
Round or Square notehead, which determines which will appear 
depending on whether Round or Square is set for Appearance of double 
whole note (breve) notehead on the Notes page of Engraving Options. 

§ Pitch (only for noteheads of Pitched type) specifies the note name and 
accidental for which this notehead should be used. 

§ Degree (only for noteheads of Scale Degree type) specifies the scale 
degree (an integer from 1 to 7) for which this notehead should be used. 

In the action bar at the bottom of the Notehead section are found the following 
buttons: 

§ New Notehead creates a new notehead of the Normal type, based on the 
default black notehead. 

§ New from Selection creates a new notehead of the same type and 
appearance as the notehead selected in the grid control in the Notehead 
Set section above. 

§ Edit Notehead opens the notehead editor, allowing you to change the 
appearance of the notehead itself; see below. 

§ Save as Default saves the selected notehead into your user library, so that 
it will be available in all new projects that you subsequently create. 

§ Revert to Factory is only enabled for built-in noteheads; if you have made 
any changes to a built-in notehead, this reverts it to its default state. 

Clicking Edit Notehead opens the notehead editor: 
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On the right-hand side, choose between the different types of components that 
can be added to the notehead design: 

§ Glyph allows you to add a character from any font installed on your 
computer; if you choose a SMuFL-compliant font such as Bravura, the 
Range list will show all of the SMuFL character ranges, making it easier to 
find the character you’re looking for. 

§ Text allows you to add one or more characters using any of the font styles 

defined in Engrave ▸ Font Styles. This would be an unusual choice for a 
notehead, but the option is provided nevertheless. 

§ Graphic allows you to add a graphic in PNG, JPG or SVG format. It is 
recommended that you use a vector format like SVG so that it will appear 
high-resolution at any size. 

§ Composite allows you to add any other symbol that is already defined in 
the project, though at present you will need to know its name, as no 
graphical preview is currently available. 

When you have chosen the component you wish to add, click the Add button at 
the bottom of the current panel to add the component to the display. 

You should position the notehead design such that the left-hand edge is aligned 
with the slightly thicker vertical grid line that represents the horizontal origin (you 
can think of this as a nominal stem on a stem-down note), and such that the middle 
is aligned with the slightly thicker horizontal gridline that represents the vertical 
origin (you can think of this as a nominal staff line, with the notehead sitting on the 
staff line). 

You can specify exactly where the stem should join the notehead on the right-hand 
side for a stem-up note and on the left-hand side for a stem-down note; you can 
also specify additional attachment points for stems that join the note diagonally 
when the notehead is used for a split stem altered unison. Click the Stem button 
below the main notehead display to add or delete stem attachment points. For 
more information about stem attachment, please consult the SMuFL specification: 

https://w3c.github.io/smufl/gitbook/specification/glyphswithanchors.html 
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Improvements 

Audio export 

It is now possible to export individual flows to separate audio files, and to export 
individual players to separate audio files as well, with audio files for each flow being 
exported to separate folders. This makes it very quick and easy to export “stems” 
suitable for dragging and dropping into Cubase or another DAW for further mixing 
and mastering. (STEAM-8128) 

Accidentals 

Cut-outs for accidental tucking. The Edit Accidental dialog now allows the editing 
of cut-outs in each of the four corners of the symbol, to instruct Dorico how it can 
tuck or kern the accidentals in adjacent columns. (STEAM-8113) 

 

To edit the cut-outs for an accidental, click the Cut-outs tab in the lower area of 
the dialog, and click the Create button for the corner of interest (NW = north-west, 
SW = south-west, NE = north-east, SE = south-east), then click the handle on the 
inner corner of the shaded green area to change the size of the cut-out. To remove 
a cut-out, click the Delete button for the corner of interest. 

For more information about cut-outs, consult the SMuFL specification at: 
https://w3c.github.io/smufl/gitbook/specification/bbox-cut-outs.html  

Accidentals and ledger lines. It is now possible to specify that Dorico should not 
shorten the left-hand side of ledger lines when an accidental is present: set 
Ledger lines on notes with accidentals to Do not adjust ledger lines on the 
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Notes page of Engraving Options to enable this behavior. Ledger lines will then 
use their default length as defined by Ledger lines protrude beyond noteheads 
by n spaces instead of the value defined by Ledger lines protrude left of 
notehead with accidental by n spaces. Furthermore, the default gap between the 
rightmost accidental and a default ledger line is determined by the new Gap to 
right of rightmost accidental, if to left of unshortened ledger line option on the 
Accidentals page of Engraving Options. (STEAM-8179) 

Tucking accidentals on back notes. A new option Gap to right of rightmost 
accidental, if to left of back note n spaces has been added to the Gaps section 
of the Accidentals page of Engraving Options. Normally accidentals are allowed to 
encroach on the usual margin when a back note is present, and this value specifies 
the minimum gap that must be present. (STEAM-6902) 

Arpeggio signs 

A new option Arpeggio signs on slash voices has been added to the Arpeggio 
Signs page of Engraving Options, controlling whether or not arpeggio signs 
should be shown in slash voices. By default, an arpeggio sign shown on a slash 
voice will be very short, but its length can be adjusted in Engrave mode. (STEAM-
8180) 

Barlines 

Collision avoidance. Dorico now consistently takes barlines than protrude above 
and below the staff (e.g. for single-line percussion instruments) and wings on 
repeat barlines, if shown, into account when determining the placement of items 
above the staff. (STEAM-5752, STEAM-7413) 

Thin-thin repeat barlines. Building on the support for hymnal-style barlines 
introduced in Dorico 2.0, a new option Start repeat at start of system has been 
added to the Repeats section of the Barlines page of Engraving Options: this 
option allows you to choose whether or not both the chosen barline type and the 
repeat dots or only the repeat dots should appear for a start repeat at the start of 
the system. (STEAM-7668) 

Triple barline. Sometimes used in musicological analysis to demarcate structural 
units larger than a single bar, it is now possible to create a triple single barline by 
typing triple into the Shift+B popover. (STEAM-8139) 

Chord symbols 

A new option Position of accidental relative to alteration has been added to the 
Alterations section of the Chord Symbols page of Engraving Options. This allows 
you to follow the recommendations in Russell Garcia’s book series The 
Professional Arranger Composer: Garcia advocates the use of minus and plus 
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instead of accidentals in intervals and alterations in chord symbols, because they 
occupy less horizontal space. However, when using these symbols, it is important 
to reverse their usual order relative to the scale degree, i.e. to show 9- instead of  
-9, as having the minus or plus precede the degree can cause ambiguity in case 
the player expects - to be used to denote a minor quality, or indeed + for an 
augmented triad. Therefore, the new option allows you to specify that the 
accidental should follow the scale degree if required. (STEAM-8326) 

Cues 

Rhythmic cues. When creating a rhythmic cue, no octave transposition is now 
shown in the cue label by default, even when cueing onto an octave transposing 
instrument. (STEAM-8339) 

Divisi 

Mid-system divisi labels. A new Show divisi change labels above staves option 
has been added to the Staves and Systems page of Layout Options. When 
switched on, the staff label defined for each divisi soloist or section will appear 
above each divisi staff at the point at which the divisi begins, and a corresponding 
tutti label will appear above each divisi staff at the point at which the divisi ends. 

New options on the Divisi page of Engraving Options allow you to determine the 
default distance above the staff for these mid-system divisi change labels. The 
labels can also be nudged or dragged freely in Engrave mode. It is also possible to 
override the content of an individual divisi change label in Engrave mode by way of 
the new Custom text property in the Divisi group of the Properties panel. 
(STEAM-8007) 

Creating divisi at the caret. You can now create a divisi change when note input is 
active: instead of being created at the start of the selection, the divisi change will 
be created at the caret’s location. (STEAM-8002) 

Tutti signposts. When using Restore Tutti to end a divisi region, the resulting 
signpost is now labeled Tutti to differentiate from the start of a divisi range. 
(STEAM-8091) 

Filters 

Filtering slash voices. You can now filter for slash voices by choosing Edit ▸ Filter 

▸ Voices ▸ All Slash Voices, or by choosing the specific up-stem, down-stem or 
stemless slash voice from the list in the submenu. (STEAM-8078) 

Flows 

Trim flow. Type trim into the Shift+B popover to execute Write ▸ Trim Flow. 
(STEAM-7453) 
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Layouts 

Default part layouts. In the event that you have inadvertently deleted the part 

layouts for your project, the new Setup ▸ Create Default Part Layouts command 
provides a quick way of recreating a default set of part layouts: one part layout for 
each player, with each flow attached. (STEAM-8226) 

Multi-bar rests 

Fixed width H-bar. A new H-bar width option has been added to the Multi-bar 
Rests section of the Rests page of Engraving Options. When set to Fixed width, 
the H-bar will be drawn using the value of Fixed H-bar width instead of being 
inset from the barline at either side of the multi-bar rest. (STEAM-8240) 

Bar count on grand staff instruments. In published music it is usual for the bar 
count for a multi-bar rest to appear only between the two staves of a grand staff 
instrument such as piano, but in parts for recording sessions in Hollywood it is 
usual to show the bar count above both staves. It is now possible to choose 
between these two conventions by way of the new Bar count on grand staff 
instruments option in the Multi-bar Rests section of the Rests page of Engraving 
Options. (STEAM-8342) 

Threshold for “tacet al fine”. A new option Minimum number of bars’ rest at end 
of flow to show tacet al fine has been added to the Rests page of Engraving 
Options, defaulting to 4 bars in new projects, and defaulting to 1 bar in projects 
created in versions of Dorico earlier than 2.1 to preserve their appearance. This 
allows you to specify that Dorico should now show “tacet al fine” for very short 
multi-bar rests at the end of a flow. (STEAM-8238) 

Hidden tempo items. Tempo items that do not appear in Write mode, for example 
those that are created in the tempo track in Play mode, are no longer considered 
for the purposes of splitting multi-bar rests. (STEAM-8151) 

MusicXML import 

Text items. A new Text items option has been added to the MusicXML Import 
page of Preferences, switched off by default. When switched on, all text items in 
the MusicXML file will be imported as Shift+X text items; you will very likely find 
that these text items duplicate other items that have been imported using as 
tempos, dynamics, etc. (STEAM-8221) 

Rhythm slashes. Dorico now imports rhythm slash regions and slash voices as 
appropriate from MusicXML files, for both pitched and unpitched instruments. 
(STEAM-8212, STEAM-8166) 

Bar repeat regions. Dorico now imports one-, two- and four-bar repeat regions 
from MusicXML files. (STEAM-7780) 
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Notes 

Rhythm dot consolidation. The Rhythm dot consolidation option in the Rhythm 
Dots section of the Notes page of Engraving Options has been revamped, both to 
make the behavior clearer and to provide a separate option to specify how rhythm 
dots should be handled for unisons in opposing voices. 

Rhythm dot consolidation describes how Dorico handles situations whereby dotted 
notes of similar pitches in adjacent voice columns can be positioned together, with 
their rhythm dots appearing in a single column to the right of both voice columns. 
This makes efficient use of horizontal space, but can introduce ambiguity when 
reading the music at sight. Dorico provides three settings for rhythm dot 
consolidation: 

§ Do not consolidate means that rhythm dots should always be shown 
immediately to the right of the note or chord to which they apply. 

§ Notes of the same duration allows Dorico to consolidate rhythm dots for 
notes in adjacent columns, provided they have the same duration (e.g. 
provided both are dotted quarters, but not if one is a dotted eighth and the 
other is a dotted quarter). 

§ Notes of any duration allows consolidation for any combination of note 
values (e.g. an up-stem quarter note and a down-stem half note), which 
provides the most compact arrangement, but could be considered 
ambiguous. 

In addition to this, a separate Rhythm dots on unisons in opposing voices 
option has been added, which allows you to determine whether two notes of the 
same duration and pitch in opposing voices should show a single rhythm dot, or 
one rhythm dot per voice. (STEAM-8228) 

Horizontal position of rhythm dots. A new Rhythm dot X property has been added 
to the Notes and Rests group of the Properties panel, allowing you to adjust the 
horizontal position of rhythm dots in Engrave mode. When there are multiple notes 
at the same rhythmic position, be aware that the property applies to the whole 
group of rhythm dots; the group may have contributing notes from more than one 
voice. (STEAM-8214) 

Hiding ledger lines. A new Hide ledger line property has been added to the 
Notes and Rests group of the Properties panel. This property appears only in 
Engrave mode, and when activated all ledger lines associated with a note are 
hidden. (STEAM-8137) 

Page layout 

A new command Propagate Part Formatting dialog has been added, which 
copies page formatting and layout options from a source layout to one or more 
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destination layouts. The dialog can be invoked either by right-clicking a layout in 
the Layouts panel in Setup mode (which initializes the selected layout as the 
source layout in the dialog) or from the Setup menu. This dialog appears: 

  

Simply choose the source layout in the left-hand list, then select one or more 
layouts in the right-hand list. The two checkboxes below the lists determine the 
behavior when you confirm the dialog: 

§ Include layout options specifies whether key layout options, including 
page size and margins, default master page set, space size, vertical 
spacing, note spacing, casting off, multi-bar rest behavior, staff label 
options, should be copied from the source layout to the destination layouts. 

§ Include system formatting specifies whether Dorico should ensure that 
the same number of bars should appear on each system, and the same 
number of systems should appear in each frame, in the destination layouts 
as in the source layout; this is done by creating system and frame breaks at 
the start of each system in each destination layout as appropriate. Any 
existing system and frame breaks in the destination layouts are removed. 
Likewise, note spacing changes are copied from the source layout to all 
destination layouts (and any existing note spacing changes in the 
destination layouts are removed). 

If the source layout’s system formatting is largely un-edited or relies on the Casting 
Off settings from Layout Options, you may not need to use the Include system 
formatting option, as it is quite likely that using Include layout options will 
produce an identical or very similar layout without the use of breaks on every 
system. 
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Complex part layouts that use multiple music frame chains are not suitable as 
either source or destination layouts for the Propagate Part Formatting dialog; 
Dorico will make the best possible automatic determination of the primary chain of 
music frame in both the source and destination layouts, but if the setup of the 
source and destination layouts differs greatly, you may get unexpected results. In 
particular, page overrides made in Engrave mode are not propagated. 

However, you should find that for many cases, checking the layout of the first 
instrument in a family or section and then using Propagate Part Formatting to 
quickly apply those changes to the remainder of the layouts saves a lot of time in 
the process of formatting instrumental parts. (STEAM-8315) 

Playback 

Background sound loading. Dorico now loads sounds into HALion Sonic SE in the 
background without locking up the user interface, which makes many operations 
feel much faster. For example, starting a new project and adding players is now 
much faster because the sounds required for each new player are loaded in the 
background, rather than making you wait for them to be loaded before you can add 
another player; when opening an existing project, you can start input and editing 
right away, without waiting for all of the sounds to be loaded; and when switching 
between projects, you can input or edit in the new project right away as the sounds 
are loaded in the background. (STEAM-6471) 

Playback of bar repeats. Bar repeats now play back automatically. The bar (for a 
single bar repeat) or bars (for a two- or four-bar repeat) immediately preceding the 
bar repeat region will be played back for the duration of the bar repeat region. 
Dorico will follow the dynamics written in the bar repeat region, rather than 
repeating any dynamics in the source bars. (STEAM-7916) 

Playback of non-standard tonality systems. Building on the playback of microtonal 
accidentals introduced in Dorico 2.0, Dorico 2.1 now supports full microtonal 
playback of tonality systems beyond 12-EDO or 24-EDO. Using VST3 Note 
Expression for HALion family virtual instruments (including the bundled HALion 
Sonic SE 3), and the VST2.x detune parameter for other instruments (including 
NotePerformer), Dorico now calculates the appropriate pitch delta for every note, 
regardless of whether the note is written with an accidental. In addition, it is now 
possible to specify the reference pitch for playback, defaulted to 440Hz, on the 
new Tuning page of Playback Options. (STEAM-7952) 

Phrasing gradual dynamics. Dorico now interprets a series of gradual dynamics of 
the same direction in close proximity as phrasing dynamics, resetting to the 
prevailing dynamic level at the start of each gradual dynamic, rather than getting 
continuously louder or quieter. (STEAM-8220) 
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Choice of stereo output. A new Stereo Output control has been added to the Edit 

▸ Device Setup dialog, allowing you to choose which pair of outputs on your 
audio interface should be used for Dorico’s playback. (STEAM-5176) 

App Nap. App Nap is a power-saving feature on macOS that automatically reduces 
the amount of processor time available to an application once it goes into the 
background in order to reduce its energy usage. For Dorico, this could have the 
result of causing playback to stutter or even stop altogether after putting Dorico 
into the background during playback. Dorico now signals to macOS that it should 
not use App Nap if it is playing back, which means that playback can continue 
unimpeded when Dorico is put into the background. (STEAM-8034) 

Play mode 

Restoration of state. The state of which tracks are expanded, the vertical sizes of 
lanes, and which MIDI controllers are currently set for each automation lane are 
now all saved and restored, so switching away from Play mode and then back 
again will retain all of those settings. (STEAM-8100, STEAM-8153) 

Special tracks. A new Play ▸ Tracks submenu allows you to choose which of the 
four special tracks that can appear above the first player track in Play mode should 
appear: Time, Chords, Video, and Markers can now be individually hidden or 
shown. When a video is attached to a flow in the project, the Video and Markers 
tracks are automatically shown. (STEAM-8149) 

Fine control of automation. It is now possible to hold the Alt key while dragging a 
point in the tempo or MIDI automation lanes in Play mode to move the point by a 
smaller amount, allowing finer adjustment. (STEAM-8124) 

Increase/decrease track size. New commands to change the height of the selected 
track in Play mode have been added, with the default key commands Shift+G and 
Shift+H. (STEAM-8197) 

Silence playback template. If you want to prevent Dorico from loading any sounds 
in your current project, you can choose the new Silence playback template from 

Play ▸ Playback Template. To make a project play back again, simply reopen this 
dialog and apply one of the other playback templates. (STEAM-8194) 

Choosing which sound to use for MIDI thru. Clicking on a track header in Play 
mode now sets the end point that will be used to echo notes played from your MIDI 
keyboard when note input is not active. It is also possible to change the sound by 
making a selection on a staff in Write mode. (STEAM-8201) 
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Playing techniques 

Playing techniques that use imported graphics now show an orange outline when 
selected, to make their selection state easier to see. (STEAM-8075) 

Project files 

When opening a project that was last saved in an earlier version of Dorico, an 
informational message box appears, informing you of the version of Dorico in which 
it was saved (if that can be determined), and alerting you to the fact that opening it 
in a later version will automatically update it. The project is opened “clean”, i.e. it 
will not prompt you to save if you try to close it immediately after opening it in the 
current version, because all of the updates that have been carried out can be 
carried out in the same way if you subsequently reopen the project in this later 
version. If you don’t want to see this message, it can be disabled by switching off 
Warn when opening projects last saved in an earlier or later version in the 
Files section of the General page of Preferences. 

If you want to guard against inadvertently overwriting a project last saved in an 
earlier version of Dorico after opening it in the current version, you can switch on 
Prompt to save projects from an earlier or later version to a new location, 
found in the same location in Preferences. When this option is switched on, Dorico 

will not automatically overwrite the project if you choose File ▸ Save or type 
Ctrl+S (Windows) or Command-S (Mac): instead, you will see the standard file 
picker dialog and be prompted to choose a new name and save location for the 
project. You can of course choose to overwrite the existing project file at this point 
if you wish. (STEAM-8193) 

Properties 

A new command Edit ▸ Propagate Properties has been added, which copies the 
properties of the selected item or items from the current layout to all other layouts 
in which they appear. When invoked from Write mode, only the properties that 
appear in the Properties panel in Write mode will be propagated to other layouts; 
when invoked from Engrave mode, the properties that appear in the Properties 
panel in both Write and Engrave mode will be propagated. 

In general, properties that appear in Write mode (which may apply to all layouts, or 
which can vary by layout, but not by chain of music frames) tend to be more 
semantic in nature, while properties that appear only in Engrave mode (which can 
typically vary not only by layout, but also by chain of music frames) tend to be more 
concerned with fine graphical appearance and positioning. 

By way of example, slur placement and design (solid, dashed, etc.) are properties 
that appear in Write mode and will be applied if Propagate Properties is invoked 
from Write mode, while the precise position of slur end and control points are 
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properties that appear only in Engrave mode and will only be applied if Propagate 
Properties is invoked from Engrave mode. In this way, you can choose whether all 
properties should be propagated, or only those that typically can apply regardless 
of the specifics of the way each layout is formatted. (STEAM-8314) 

Rhythm slashes 

Hiding music behind slash regions. By default, slash regions now cause any 
existing music in other voices under their span to be hidden: this allows you to 
write, say, a possible solo realization for the purposes of playback, and still show 
only the slashes in the score and part. If, however, you require other voices to 
appear during a slash region, you can activate the Show other voices property in 
the Slash Region group of the Properties panel. (STEAM-8138) 

Bar count for slash regions. New options to display bar count numbers on rhythm 
slash regions have been added via a new Count section on the Notes page of 
Engraving Options: 

§ Show slash region bar count every n bars specifies the interval at which 
the bar count should appear; setting this to 1 will cause the bar count to 
be displayed on every bar. 

§ Appearance of slash region bar count specifies whether the count 
should be shown With parentheses, Without parentheses, or not at all 
(Do not show). 

§ Placement of slash region bar count determines whether the count 
should be shown above or below the staff. 

§ Bar count distance outside staff n spaces specifies the distance 
between the top or bottom staff line and the bar count number. 

If necessary, bar count numbers can be nudged and dragged in Engrave mode. 
(STEAM-8114) 

Staff labels 

Rich text for staff labels. The Edit Instrument Names dialog now provides 
additional controls to allow more complex formatting of staff labels. To edit the staff 
label that appears in the margin for a given instrument, expand the card of the 
player holding the instrument in the Players panel in Setup mode, hover over the 
name of the instrument so that the chevron > appears, then click and choose Edit 
Names from the context menu. This dialog appears: 
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The text entered in this dialog is used not only for the staff label that appears to the 
left of the staff in the margin, but also for labelling changes of instrument above the 
staff, in which case any line or paragraph breaks will be removed, and the label 
reduced to a single line. Furthermore, the alignment specified in the dialog is 
ignored: instead, the alignment of the paragraph style will always be used. This is 
to ensure that you can achieve a consistent alignment of staff labels from the top of 
the system to the bottom. 

To restore an instrument’s labels back to the defaults, click Reset to Default. 
(STEAM-8273) 

Staff group labels. A new option Staff labels for identical adjacent solo 
instruments has been added to the Staff Labels page of Engraving Options. 
Setting this to Group between staves will center the name of the instrument 
between all of the adjacent staves belonging to identical instruments: for example, 
two flutes will show a label “Flute” centered between the two staves, with the 
upper staff being labeled “1” and the lower one “2”. 

The group label is centered on the staves belonging to the identical instruments: 
for an odd number of staves, the group label is centered on the middle staff line of 
the middle staff; for an even number of staves, the group label is centered on the 
gap between the two central staves. 

A new paragraph style Staff labels (inner) is used for the instrument numbers and 
for divisi sections, while the existing Staff labels style is used for instruments with 
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no grouping, for the group labels, and for divisi group or player labels. This 
illustration shows which kinds of labels use which paragraph style: 

 

The distances for inner and outer staff labels from the systemic barline are 
determined using the options under Start of System on the Staff Labels page of 
Engraving Options. (STEAM-8324) 

Labels at the start of the flow. When a player holds multiple instruments, it is 
important that the player knows which instrument he or she should be playing at 
the start of each movement. In a full score layout, there will normally be a staff label 
to the left of the first system, but in a part layout, this is not normally shown. A new 
Show instrument change label at start of flow option has been added to the 
Instrument Changes section of the Players page of Layout Options, switched on 
by default in part layouts in new projects, but switched off in projects created in 
Dorico 2.0 or earlier in order to preserve their appearance. When switched on, an 
instrument change label will appear at the start of the first bar, reinforcing for the 
player which instrument should be played. (STEAM-8242) 

Divisi group labels. The Show player or group name option in the Change Divisi 
dialog now takes precedence over the options on the Staves and Systems page 
of Layout Options: the default instrument name shown as an outer staff label for a 
divided system is the group name for the divisi if no groups are defined; otherwise, 
the divisi group name is shown. (STEAM-8070) 
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System dividers 

It is now possible to specify that system dividers should appear only between 
systems of differing numbers of staves (rather than when a flow contains at least a 
certain number of staves), a convention that is followed in parts prepared for 
recording sessions in Hollywood. To enable this behavior, set Show system 
dividers to When number of staves differs in the System Dividers section of the 
Staves and Systems page of Layout Options. The previous default behavior is 
obtained by instead choosing When minimum number of players present. 
(STEAM-8349) 

Time signatures 

Large time signatures. The option to show a single time signature for unpitched 
percussion and keyboard instruments has been refined: now, any and all 
instruments in any family between brass and strings will be grouped together and a 
single large time signature will be shown. To reflect this change, the option is now 
described as Instruments between brass and strings: Treat separately or Treat 
as single bracket. (STEAM-7726) 

Open meter. Type open into the Shift+M popover to create an open meter that 
shows no symbol. (STEAM-8150) 

Tuplets 

Choice of font for tuplet digits. A new Plain font choice has been added to the 
Tuplet digit style option on the Tuplets page of Engraving Options. When this 
option is chosen, instead of using the traditional bold or light digits from the current 
music font (Bravura, by default), the text font specified for Tuplet plain font in 
Engrave ▸ Font Styles will be used instead. (STEAM-8218) 

Positioning of tuplet bracket hooks. Two new Engraving Options have been added 
under the heading Offsets for Start and End of Bracket in the Horizontal 
Position section of the Tuplets page to provide default values for the left and right 
delta for tuplet brackets. The Additional offset for start of bracket on stem-
down tuplets value is only used when the tuplet bracket is shown and the stems 
are down, while the Additional offset for end of brackets on stem-up tuplets 
value is only used when the tuplet bracket is shown and the stems are up. The 
values are set to zero in existing projects to avoid changing their appearance, and 
to 1/4 spaces for new projects. (STEAM-8087) 

User interface 

Key commands. Three new commands in the Edit category in the Key Commands 
page of Preferences have been added, to allow some reasonably common layout-
related operations to be performed directly via keyboard shortcut without opening a 
menu or dialog: 
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§ Change Bar Consolidation allows you to set a specific key command for 
each of the three states for displaying multi-bar repeats (no consolidation; 
multi-bar rests only; multi-bar rests plus bar repeats). 

§ Toggle Bar Consolidation can have a single key command assigned, and 
which cycles through the three states when repeatedly invoked. 

§ Toggle Layout Transposition can have a single key command assigned, 

and toggles between Edit ▸ Transposing Pitch and Edit ▸ Concert 
Pitch when repeatedly invoked. (STEAM-8239) 

Transport display. Clicking on the time display in the mini transport in the toolbar 
now cycles between bar.beat.tick, elapsed time, and timecode read-outs. In the 
main Transport window, clicking on the right-hand time display toggles between 
elapsed time and timecode. (STEAM-8115) 

Restoring window sizes and positions. Dorico now more reliably restores the 
saved sizes and positions of windows when reopening previously-saved projects. 
(STEAM-3213) 

Video 

Locating missing video files. When opening a project with an attached video, if the 
video cannot be found at the original location specified in the project, Dorico will 
now look for the video file in the folder alongside the Dorico project itself and 
automatically re-attach it if it is located there. (STEAM-7897) 

Apple ProRes videos. Videos that use Apple’s ProRes codec will now play back 
correctly as the ProRes codec is now distributed with Dorico (required on 
Windows only; ProRes files play on Mac without requiring a separate codec). 
(STEAM-8177) 
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Issues resolved 
ID # Component Issue 

STEAM-5341 Accidentals 
Changing the enharmonic spelling of a note with a microtonal accidental now works 
reliably. 

STEAM-7506 Accidentals 
A number of problems relating to the choice of specific accidental in note input when 
multiple accidentals in the tonality system have the same pitch delta have been resolved. 

STEAM-8133 Accidentals 
It is once again possible to select the symbols in the Edit Accidental dialog with the 
mouse. 

STEAM-7673 Articulations Staccato articulations are now positioned correctly under slurs on beamed grace notes. 

STEAM-8174 Audio engine 
Switching away from Dorico while it is starting up with the Suspend audio engine in 
background preference enabled no longer sometimes causes it to hang (Mac only). 

STEAM-8162 Audio export 
Attempting to switch to another open project while exporting audio from the first no longer 
causes a crash. 

STEAM-8227 Barlines 
Start repeat barlines now appear correctly at the start of the system if they coincide with a 
time signature that is set to appear above the staff. 

STEAM-8143 Bars 
When deleting bars at the end of the project, Dorico now ensures that tempos, rehearsal 
marks, note spacing changes and breaks in the deleted range are correctly removed. 

STEAM-5767 Beaming 
Further improvements have been made to Dorico’s algorithms for avoiding “beam corners” 
when beaming between notes on different staves. 

STEAM-8148 Beaming 
Under some circumstances, stems on notes crossed between staves could appear on the 
wrong side of the notehead when reopening an existing project; this is now fixed. 

STEAM-5767 Beams 
A problem that caused beam corners (where a partial beam is positioned on the wrong 
side of a between-staves beam) to appear for some rhythmic patterns has been fixed. 

STEAM-8204 Beams 
A problem whereby noteheads could draw on the wrong side of notes when crossed to 
other staves when first opening an existing project has been fixed. 

STEAM-8156 Breaks 
Moving a system or frame break signpost with Alt+left/right no longer causes the signpost 
to be removed altogether. 

STEAM-8098 
Chord 
symbols 

Chord symbols no longer incorrectly appear on extra staves added to instruments. 

STEAM-8213 
Chord 
symbols 

Chord symbols now correctly cause multi-bar rests to split on grand staff instruments 
where one staff is hidden because it is empty. 

STEAM-8022 Clefs 
A problem whereby redundant clefs appear in extra staves belonging to an instrument has 
been fixed. 

STEAM-8069 Clefs 
Dorico no longer shows restorative clefs and key signatures at the end of a tutti passage at 
the end of a system belonging to the divisi staves that were present earlier in the system. 

STEAM-8023 Divisi 
Staves in galley view will no longer be spaced sufficiently far apart to make room for all 
divisi staves, when the last divisi change has been deleted from a section player. 

STEAM-8071 Divisi 
Time signatures at the end of a system that coincides with the end of a tutti range 
(following the end of a divisi section on that system) now appear reliably in all staves. 
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ID # Component Issue 

STEAM-8085 Divisi 
Changes of key signature in unison ranges before or after a divisi change on a system no 
longer collide with the double barline after reopening the project. 

STEAM-8223 Divisi 
Key signatures on divided transposing instruments in the preamble at the start of the 
system now always show the correct transposition. 

STEAM-8284 Divisi 
Disabling instrument changes for a given layout no longer causes the staff labels for divisi 
staves to stop appearing correctly. 

STEAM-8288 Divisi 
Pasting a divisi event that references a custom paragraph style into another project no 
longer causes a crash. 

STEAM-8322 Divisi 
Under some circumstances, pasting a divisi signpost could cause Dorico to crash; this is 
now fixed. 

STEAM-7942 Dynamics 
Dynamics will no longer sometimes be positioned incorrectly in galley view after editing 
them, e.g. changing their placement. 

STEAM-8254 Dynamics 
The cresc./dim. gradual dynamics in the Dynamics panel are no longer incorrectly shown 
as hairpins in additional windows opened for a project. 

STEAM-8325 Dynamics 
Under some circumstances, edits to notes on one system could cause dynamics on the 
previous system to change position incorrectly; this has now been fixed. 

STEAM-8068 Flows Playback is now always initialised correctly when importing flows into an empty project. 

STEAM-8095 Flows 
Splitting an existing flow no longer causes notes on the left-hand staff of a piano 
instrument to be moved incorrectly to the right-hand staff in the new flow. 

STEAM-8103 Flows 
Layouts that contain only a subset of flows now play back correctly, and can be exported 
as audio correctly. 

STEAM-8282 Flows 
Improvements to the handling of players with multiple identical instruments when importing 
flows. 

STEAM-7482 
Graphics 
import 

Graphics files imported from OneDrive using the “on-demand files” feature now appear 
correctly (Windows only). 

STEAM-8183 
Holds and 
pauses 

Caesuras that are not positioned immediately before a note, rest or barline no longer cause 
an unexpected spacing distortion at the following barline. 

STEAM-8183 
Holds and 
pauses 

A caesura positioned at an arbitrary rhythmic position within a bar no longer causes the 
spacing of a time signature at the start of the following bar to be incorrect. 

STEAM-8085 
Key 
signatures 

Key signatures no longer incorrectly collide with double barlines to their left when they 
appear within a tutti range preceding or following a divisi change. 

STEAM-8208 
Key 
signatures 

Under rare circumstances, defining a tonality system with specific combinations of 
divisions could cause a crash; this has now been resolved. 

STEAM-8223 
Key 
signatures 

Key signatures in divisi staves are now always correctly transposed if required in a 
transposing layout. 

STEAM-8279 Layouts 
Reset to Factory in Layout Options now restores staff label options to the correct values 
for parts in part layouts; previously it was incorrectly using the defaults for full scores. 
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ID # Component Issue 

STEAM-8267 MIDI import 
A problem whereby shorter notes contained entirely within the duration of longer notes on 
the same instrument would be omitted when importing MIDI files has been fixed. 

STEAM-8296 MIDI import 
The last note in a MIDI file is no longer sometimes incorrectly omitted if its duration is 
shorter than a quarter note (crotchet). 

STEAM-8178 Mixer 
For some projects, the initial displayed position of the Video fader in the Mixer did not 
match its actual output level when first opened; this problem has now been resolved. 

STEAM-8083 
Multi-bar 
rests 

Edits to grace notes close to divisi change events no longer sometimes result in multi-bar 
rests being split incorrectly. 

STEAM-8121 
Multi-bar 
rests 

Multi-bar rests no longer disappear at transitions between instruments when the player has 
local time signature changes. 

STEAM-8144 
Multi-bar 
rests 

Creating a system break following a divisi change no longer incorrectly causes multi-bar 
rests to be split. 

STEAM-8164 
Multi-bar 
rests 

Divisi changes belonging to players who are cued into the current layout no longer 
incorrectly cause multi-bar rests to be split. 

STEAM-5809 
MusicXML 
import 

Transposing instruments created via MusicXML import are now correctly numbered, taking 
their transposition into account. 

STEAM-7884 
MusicXML 
import 

Switching off the Beam groups option on the MusicXML Import page of Preferences 
now correctly takes effect for all noteheads within a tie chain. 

STEAM-8122 
MusicXML 
import 

Some specific combinations of coincident tuplets in MusicXML files exported from Finale 
could cause Dorico to crash; this has now been fixed. 

STEAM-8203 
MusicXML 
import 

Importing a MusicXML file into an existing empty project no longer results in some of the 
required default notehead types being missing from the project. 

STEAM-8256 
MusicXML 
import 

Under some circumstances, the import of nested tuplets in MusicXML files could fail. This 
problem has now been fixed. 

STEAM-5625 Note input 
The default enharmonic spelling chosen for grace notes now matches the spelling chosen 
for normal notes. 

STEAM-7113 Note input 
It is no longer possible to input notes on a staff not currently visible (e.g. an extra staff, 
ossia, or divisi staff, or a staff belonging to another instrument held by the same player.) 

STEAM-7493 Note input 
It is now possible to lengthen or shorten the duration of an implicit rest repeatedly without 
needing to reselect the rest after each edit. 

STEAM-7506 Note input 
The input of accidentals with equivalent pitch deltas in tonality systems that define multiple 
such accidentals has been substantially improved. 

STEAM-7585 Note input Multi-paste now works reliably when copying material crossed from one staff to another. 

STEAM-7585 
STEAM-8167 

Note input 
Under some circumstances, cross-staff notes could be pasted onto the wrong staff; this 
problem has now been resolved. 

STEAM-7852 Note input 
After using Edit ▸ Paste Special ▸ Move to Staff Above/Below, rests that were moved 
as part of the selection now correctly remain selected. 
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ID # Component Issue 

STEAM-8021 Note input 
Slurs that end at tuplet positions are no longer incorrectly unscaled when using Edit ▸ 
Paste Special ▸ Reduce. 

STEAM-8066 Note input 
Copying and pasting material between instruments with differing numbers of staves now 
works correctly. 

STEAM-8082 Note input 
Attempting to change existing notes into a slash voice no longer sometimes causes Dorico 
to crash. 

STEAM-8086 Note input 
Copying and pasting between instruments with different numbers of staves, or between 
divisi staves and regular staves, now works as expected. 

STEAM-8105 Note input 
Copying and pasting an ossia or extra staff signpost from one instrument to another now 
correctly creates additional staves if necessary. 

STEAM-8134 Note input Grace notes are now handled correctly by Edit ▸ Paste Special ▸ Explode. 

STEAM-8147 Note input 
Edit ▸ Paste Special ▸ Explode now works correctly if invoked on a staff that contains 
both notes and dynamics. 

STEAM-8249 Note input 
The enharmonic spellings chosen for octave-transposing instruments no longer 
unexpectedly differ for non-octave-transposing instruments. 

STEAM-8262 Note input 
It is no longer possible to use N/M to cause notes to disappear because they have been 
crossed to an ossia or extra staff that is not visible at the selected rhythmic position.  

STEAM-8263 Note input 
Inputting notes via MIDI keyboard into a new voice now always produces the expected 
enharmonic spelling. 

STEAM-8270 Note input 
The notes input on one instrument no longer incorrectly affect the enharmonic spellings 
chosen for notes input on another instrument during the same input session. 

STEAM-8289 Note input Divisi, ossia and extra staff signposts are now excluded from block selection. 

STEAM-8297 Note input 
Using Alt+N/M to move items to the staff above or below no longer incorrectly attempts to 
move pedal lines or divisi/ossia/extra staff signposts. 

STEAM-8298 Note input 
Setting articulations and accidentals before specifying the pitch of the grace note to be 
input now works correctly. 

STEAM-8319 Note input 
Edit ▸ Paste Special ▸ Move to Staff Below (Alt+M) now correctly always moves to the 
next staff when the selection being moved is not on the first staff of an instrument. 

STEAM-8329 Note input 
Starting note input via the mouse by clicking the Lock Duration button in the note input 
toolbox now works correctly. 

STEAM-6975 Notes 
Under some circumstances, it was possible for a note’s rhythm dot to be shown twice 
when the note is consolidated with a voice column to its left; this is now fixed. 

STEAM-7665 Ornaments 
Under some circumstances, single-stem tremolo slashes could collide with noteheads 
because the stem was insufficiently lengthened; this has now been fixed (Windows only). 

STEAM-8206 Ossias 
When an ossia is active on a grand staff instrument, only one of the main staves can be 
hidden if empty, rather than allowing all regular staves of the instrument to be hidden. 
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ID # Component Issue 

STEAM-8063 Page layout 
A problem whereby editing the position of a tempo mark could cause the vertical spacing 
to change unexpectedly has been resolved. 

STEAM-8092 Page layout 
Hiding empty staves now once again works correctly for players holding multiple 
instruments in layouts in which instrument changes are disabled. 

STEAM-8165 Page layout 
Spurious additional clefs and key signatures no longer sometimes appear in the middle of 
the system when extra staves are set via layout options to start at system breaks. 

STEAM-8200 Page layout 
Changes made to staff spacing for extra staves belonging to an instrument are now 
persisted correctly when saving and reopening a project. 

STEAM-8243 Page layout 
Under some circumstances, moving a rehearsal mark in Engrave mode could cause a 
tempo mark on another system to move; this is now fixed. 

STEAM-8277 Page layout 
Under some circumstances, repitching music could incorrectly cause lyrics above the staff 
to move further away from the staff; this is now fixed. 

STEAM-8278 Page layout 
Under some circumstances, editing or inputting notes directly before a multi-bar rest could 
cause the bar count number to move incorrectly away from the staff; this is now fixed. 

STEAM-8287 Page layout 
It is now possible to select the staff spacing handles for multiple instruments held by the 
same player independently when instrument changes are not shown for a layout. 

STEAM-8312 Page layout 
A series of fermatas positioned on adjacent barlines no longer sometimes move incorrectly 
when one of the fermatas is nudged in Engrave mode. 

STEAM-8251 Percussion 
Under rare circumstances it was possible for Dorico to crash when editing the names of 
instruments in a percussion kit from the Edit Percussion Kit dialog. This is now fixed. 

STEAM-8157 Performance 
The speed of inputting notes in projects that include changes in the number of staves for 
an instrument has been improved. 

STEAM-8246 Performance 
The speed of inputting and editing music in larger projects with percussion kits shown 
using the grid presentation type has been improved. 

STEAM-8268 Performance The speed of note input in larger projects with instrument changes has been improved. 

STEAM-8103 Play mode 
A problem whereby layouts that do not have all flows attached could play back with long 
periods of silence has been resolved. 

STEAM-8174 Play mode 
A problem that could cause Dorico to hang during start-up if the Suspend audio device 
in background preference was set has been fixed (Mac only). 

STEAM-8285 Play mode 
The correct VST Expression Map is now chosen by default when creating a solo double 
bass player when using the HALion Symphonic Orchestra playback template. 

STEAM-7989 
Playing 
techniques 

Adding an ossia staff above the right-hand staff of a piano no longer incorrectly causes 
pedal lines to stop drawing. 

STEAM-8224 
Playing 
techniques 

Under some circumstances, pedal lines would draw on the top staff in the system in galley 
view; this is now fixed. 

STEAM-8327 
Playing 
techniques 

Editing the default placement of a playing technique in Engrave ▸ Playing Techniques 
now correctly updates any existing playing techniques in the score right away. 
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ID # Component Issue 

STEAM-8136 Print mode 
Lyrics colored by View ▸ Notes and Rests ▸ Voice Colors are no longer incorrectly 
displayed in color in Print mode. 

STEAM-8198 Print mode 
Commands from the Edit menu that can edit the score are now correctly disabled in Print 
mode. 

STEAM-7482 Project files 
Importing a graphic located in OneDrive when using the files on-demand setting now 
works correctly (Windows only). 

STEAM-8195 Project files 
Improvements have been made to the way that Dorico determines the filename to be used 
when exporting multiple flows to a new project. 

STEAM-2812 Setup mode 
Under certain circumstances, dragging an instrument from one player to another in the 
Players panel could cause a crash; this is now fixed. 

STEAM-8269 Setup mode 
Changing the instrument held by a player from one kind to another no longer incorrectly 
changes any slash voices in that instrument’s music into regular voices. 

STEAM-7501 Slurs 
Creating a slur with a single note selected now always correctly advances the slur to the 
next note of a different pitch, instead of ending at the end of the current note if it is tied. 

STEAM-7674 Slurs The positioning of slurs on grace notes in multiple voice contexts has been improved. 

STEAM-8241 Slurs 
Attempting to create and extend a slur with the mouse when more than one window is 
open on the project no longer causes an error message to appear. 

STEAM-8155 System track The appearance of the system track in music in open meter has been improved. 

STEAM-8190 System track The system track now draws correctly for bars that span more than one system break. 

STEAM-8271 Text 
The values for the default distance of text items from the staff were incorrect by half a 
space; this has now been corrected. 

STEAM-8320 Text 
Clicking Revert to Factory for one of default paragraph styles in Engrave ▸ Paragraph 
Styles, no longer causes problems displaying items in the score or even a crash. 

STEAM-8033 
Time 
signatures 

Time signatures local to a single staff now draw correctly when global time signatures are 
set to draw outside the staff. 

STEAM-8227 
Time 
signatures 

Start repeat barlines now appear correctly at the start of the system when they coincide 
with a time signature change, and the time signature is shown outside the staff. 

STEAM-8110 User interface 
It is once again possible to define shortcuts for commands nested two levels deep in the 
Key Commands editor, e.g. for articulations, note durations, and so on. 

STEAM-8129 User interface 
The state of the various buttons in the user interface concerning the Video window now 
always correctly stay in sync. 

STEAM-8185 User interface 
Navigating through the entries in the drum map with the arrow keys now correctly updates 
the selection in the panel at the bottom of the Percussion Maps dialog. 

STEAM-8219 User interface 
Some list controls in Dorico incorrectly caused the Input Method Editor for CJK text input 
to become activated; this has now been fixed (Windows only). 
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ID # Component Issue 

STEAM-8260 User interface 
Under some circumstances, the instrument labels in expanded player cards in the Players 
panel in Setup mode would stop drawing; this is now fixed. 

STEAM-8332 User interface 
The Stereo output and Sample rate controls in Edit ▸ Device Setup no longer flicker 
when changing values. 

STEAM-8090 Video There is no longer a limit on the length of the path of an attached video file. 

STEAM-8093 Video 
Changing the project frame rate via the Video Properties dialog now always correctly sets 
timecode offsets for the current flow. 

STEAM-8132 Video 
Advancing the playhead position frame by frame now always displays the correct timecode 
in a newly-created project. 

STEAM-8178 Video 
The position of the video fader in the Mixer is now always correct when opening an existing 
project. 

STEAM-8235 Video Dorico now always correctly detects the framerate of a video at 23.976fps. 

STEAM-8101 Views 
The presence of a timecode staff no longer causes staves to become misaligned in galley 
view in projects in which instruments have a variable number of staves. 

STEAM-8171 Views 
Staff labels shown in the margin in galley view no longer disappear for a moment at certain 
points when scrolling music left and right. 

STEAM-8176 Views 
When multiple windows are open on the same project, only the window in focus will follow 
changes of selection. 
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Dorico 2.0 

30 May 2018 

This version contains the following new features, improvements and issue 
resolutions. 

New features 

Video, markers and timecode 

Dorico 2 now includes the same high-performance video engine as Cubase and 
Nuendo, providing many new possibilities for composing to picture, together with a 
suite of features for managing timecode, markers and tempo. 

 

Supported video formats. The Cubase/Nuendo video engine was introduced last 
year to replace the old 32-bit QuickTime-based engine, and currently supports the 
most commonly-used video formats, with support for more formats planned for the 
future. 

H263 and H264 video is supported in both MOV and MP4 containers, while Apple 
ProRes, DV/DVCPro and Avid DNxHR codecs are supported in MOV containers. 
DV/DVCPro and MJPEG/PhotoJPEG are supported in AVI containers. Videos with 
variable frame rates are not supported, but all the common frame rates (including 
23.976, 24, 24.975, 25, 29.97, and 30 frames per second) are fully supported. 

For more information about precisely which formats are supported, and for 
information about how to determine the format of a video and transcode it to a 
supported format, please consult the Steinberg support site: 
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https://helpcenter.steinberg.de/hc/en-us/articles/115000808250-Video-support-
in-Cubase-and-Nuendo 

Attaching a video. You can attach a video to each flow in your project; if you a 
working with a longer video (for example, a complete reel of a film), you can attach 
the same video to multiple flows, and work with different sections of the video with 
each flow. There are two ways to attach a video: 

§ In Setup mode, right-click the flow in the Flows panel to which you want to 

attach a video, and choose Video ▸ Attach Video from the context menu. A file 
chooser dialog appears, allowing you to choose the video to be attached: click 
Open and the video will be attached to the project. 

§ In Play mode, drag the video file from the folder where it is located and drop it 
on the timeline at the position where you want the video to be attached. 

When you attach a video in Setup mode, the Video Properties dialog opens, with 
the following options: 

 

§ The read-only fields for Video file and Video frame rate report the complete 
path to the attached video file, and the frame rate detected by the video engine. 

§ Project frame rate specifies the frame rate that Dorico will use to determine the 
timecode displayed in markers and in the Transport window; click Use video 
frame rate to set this to the frame rate detected by the video engine. See 
below for more information about the available frame rates. 

§ Flow attachment position specifies the point in the flow at which the video will 
start playing: you specify this as a multiple of beats of the specified unit. For 
example, if you want two bars free at the start of a 4/4 flow, you would specify 8 
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in the Beat count field and choose the quarter note (crotchet) from the Beat 
unit control. 

§ Video start offset specifies the frame of the video that will appear at the Flow 
attachment position. For example, it may be a requirement that no sound is 
played until the sixth frame of the video, so entering 00:00:00:06 in this field 
specifies that when the video starts, it will start from the sixth frame. 

§ Timecode start specifies what timecode should appear at the start of the video. 
For example, each reel of a film is by convention given a timecode position 
starting at a new hour, with the first reel often starting at 01:00:00:00 or 
sometimes even at 10:00:00:00, with the second starting at 02:00:00:00 or 
11:00:00:00, and so on.  

When you have set the properties as needed, click OK. 

If you attach the video in Play mode, the Video Properties dialog does not open 
automatically, but it can be opened either via right-clicking the flow’s card in Setup 

mode and choosing Video ▸ Properties from the context menu, or by clicking the 
Video Properties button at the top of the Markers panel in Write mode. 

Once a video is attached, a film reel icon appears in the 
bottom left-hand corner of the flow’s card in the Flows panel 
in Setup mode, together with the timecode of the first frame 
of the video, as specified in the Video Properties dialog. 

The Video window will also appear as soon as a video has been attached: the 
window may appear black at first, but as soon as playback starts, the video will 
appear.  

Locating attached video files. Attached video files are not embedded in your 
Dorico project: if you need to send your project to somebody else and they also 
need access to the video, you will need to send the video file or files separately.  

When you open a project that has an attached video and 
the video cannot be located, the flow’s card in the Flows 
panel shows a warning triangle icon in place of the film reel 
icon. To restore the video to the project, simply re-attach 

the same video file by right-clicking and choosing Video ▸ Attach: the video’s 
existing properties will be preserved. 

Working without an attached video. All of Dorico’s features for composing to 
picture – including markers, timecode and finding tempo – can be used even if you 
don’t have a video attached. You can specify a frame rate and initial timecode value 
using the Video Properties dialog without attaching a video simply by right-clicking 
the flow’s card and choosing Video ▸ Properties. 
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Video window. The Video window can be hidden or shown by choosing Window 

▸ Video, or using the default key command F4. The window’s size and position are 
saved in the application’s preferences, rather than on a per-project basis. 

Frame rates and timecode. Dorico supports a wide range of frame rates used in 
professional film and TV production, from 23.976fps to 60fps, and includes 
supports for drop frame timecode. NTSC video, used in US and Canadian 
broadcast, has a frame rate of 29.97fps, and this requires the use of a drop frame 
timecode. In non-drop frame timecode, each frame is simply numbered sequentially 
from the preceding one; but in drop frame timecode, timecode numbers are 
periodically skipped to compensate for the 0.03fps difference between 29.97fps 
and 30fps. In every minute except every tenth minute, two timecode numbers are 
dropped from the frame count. The same principle applies to the distinction 
between 59.94fps and 60fps, a difference of 0.06fps. 

In Dorico, non-drop frame timecodes are labeled with the suffix fps, while drop 
frame timecodes are labeled with the suffix dfps. 

Timecode is displayed in the format hh:mm:ss:ff, i.e. two-digit hours, minutes, 
seconds, and frames. Drop frame timecode uses a semicolon separator between 
the seconds and frames parts of the timecode rather than a colon, so 00:00:01:05 
would be for a non-drop frame timecode, while 00:00:01;05 would be for a drop 
frame timecode. 

Timecode can be displayed in the Transport window (key command F2) instead of 
regular elapsed time: to enable this, set Time display to Timecode on the 
Timecode page of Playback Options. 

Video soundtrack. The soundtrack of the attached video is played back in sync with 
score playback. To control the relative volume of the video’s soundtrack, open the 
Mixer (key command F3) and click the Video filter button in the Mixer’s toolbar to 
show the video fader, which appears at the right-hand side of the list of faders, 
immediately before the Reverb and Output faders. You can of course mute the 
video’s soundtrack by muting the video fader. 

Advancing through the video. The frame of video displayed in the Video window 
always matches the playhead’s current position. If you find that you cannot see the 
green playhead line when Dorico is not playing back, activate the Show playhead 
when stopped checkbox in the Play section of the General page of Preferences. 

The playhead can be moved by clicking the fast-forward and rewind buttons in the 
Transport window, or using the + and - keys on your keyboard’s numeric keypad, if 
it has one. If your keyboard does not have a numeric keypad, you can use F7 to 
rewind and F9 to fast-forward; add Ctrl (Windows) or Command (Mac) to move 
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by a single frame, rather than by a whole second. On Mac, you may also need to 
add the Fn key, as by default the row of function keys is reserved by the system to 
provide features like volume control, screen brightness, and media playback. 

Markers. Markers are labels locked to a particular timecode in the video, typically 
indicating an important moment that should be given some musical prominence. 
Markers can be added at the playhead’s current position by choosing Write ▸ 
Create Marker or using the default key command Shift+Alt+M. The marker 
appears in the score at the appropriate position, and the label in the marker (which 
says Marker by default) can be edited either via the Marker text property in the 
Markers group of the Properties panel, or via the Markers panel in Write mode. 

Markers panel. Markers can also be added directly in the 
Markers panel in Write mode by clicking the + button at 
the bottom of the table that lists the markers in the current 
flow. This can be useful if you have already, for example, 
completed a spotting session and so already know the 
timecode for each marker in the cue. You can edit both 
the timecode and text for each marker directly in-line in 
the table in the Markers panel simply by double-clicking 
the field you need to edit. 

The third column in the table in the Markers panel is 
labeled Imp., which is an abbreviation for Important: 
important markers are the ones it is most crucial to call 
attention to musical terms, and play a vital role in Dorico’s Find Tempo feature. To 
designate a marker as important, simply activate its checkbox in the Imp. column. 

Marker design. Options for the design of markers can be found on the new 
Markers page in Engraving Options, allowing you to determine whether the 
timecode or the label should be positioned first, adjust the border thickness and 
padding. To adjust the font family, weight or point size, edit the Marker text font or 
Marker timecode font in Engrave ▸ Font Styles. 

Choosing where markers appear. By default, markers appear above the top staff of 
the full score layout, and do not appear in part layouts. To change this, set Vertical 
position to Above system or Below system as appropriate, or alternatively you 
can choose to display markers on a dedicated timecode staff. 

Displaying timecode in the score. Dorico can display timecode in the score on a 
special timecode staff. To show the timecode staff, choose the Markers page of 
Layout Options and set Vertical position to Timecode staff, then set Position 
timecode staff above bracket to the instrument family above which you want the 
timecode staff to appear. Finally, you can choose whether you want timecode to 
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appear on every bar, every system, or never (in which case only markers will appear 
on the timecode staff), by setting Timecode frequency on timecode staff as 
desired. 

Dragging markers in Write mode. Markers have a fixed timecode position, and are 
effectively locked to a specific frame in the attached video. In order to adjust the 
position in the music where a marker appears, you can drag it left or right in Write 
mode: to accommodate the desired position for the marker, this adjusts the 
immediate tempo preceding the marker (or at the start of the flow, whichever is the 
later) and clears any gradual tempo changes between that immediate tempo and 
the marker. Dragging a marker to the right increases the tempo, while dragging it to 
the left decreases the tempo. This is a simple tool: it is not currently possible, for 
example, to drag one marker but lock the position of all previous markers, so that a 
tempo change takes effect only after a specific marker. For these kinds of more 
sophisticated edits, you can edit the time track in Play mode. 

Editing the time track in Play mode. The new time track in Play mode allows fine 
graphical control over the tempo changes in the flow. When a video is attached, 
tracks for markers and the attached video also appear at the top of the event 
display in Play mode. When editing the tempo in the time track, the position of the 
markers is updated in real-time, making it easy to adjust the position of each 
marker relative to the music by inserting tempo changes at key points. 

Find Tempo. Dorico can also help you identify an appropriate tempo for the whole 
flow using the new Find Tempo window, which can be opened by clicking the 
Find Tempo button in the Markers panel in Write mode: 
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The Find Tempo window can only be used if at least one of the markers is 
designated as important (Imp.) in the Markers panel. The window allows you to find 
the tempo that is the best fit for the important markers in the flow, such that the 
important markers fall as close as possible to beats. 

Choose the desired Beat unit from the control on the left, then choose the lower 
and upper bounds of the tempos that can be found using the Tempo range slider 
on the right. As you adjust the beat unit and tempo range, the Tempos found list 
on the left is updated. The found tempos are listed in descending order of average 
“frames off” for important markers, i.e. the average number of frames by which the 
markers miss being aligned to beats. 

The abbreviations IFO, NFO and AFO are for the average number of frames off for 
important markers (IFO), non-important markers (NFO), and all markers (AFO). 

The Markers list on the right provides a more detailed view of the tempo selected 
from the Tempos found list: the list shows each marker, and then, assuming the 
selected tempo is used, the number of frames off the beat (Fr. Off), the time 
difference between the marker’s position and the beat expressed in fractions of a 
second (Time Diff.), and the notated difference between the marker’s position and 
the beat expressed in fractions of a whole note (Not. Diff.). 

When you have chosen the most appropriate tempo, select it in the Tempos 
found list and click the Apply button below the list, which adds the chosen tempo 
at the start of the flow, clearing all other tempo markings from the flow. 

Time signatures 

Dorico 2 introduces new features for the display of time signatures, with two new 
placement options, and three new design options. As alternatives to their usual 
placement within each staff, time signatures can now be displayed above the same 
staves as system items like tempo and rehearsal marks, or a single large time 
signature can be centered on each bracket. Both of these options can help to draw 
attention to time signatures in music with frequent changes of meter. 

Choosing time signature placement. To choose one of the new placement options 
for time signatures, open the new Time Signatures page in Layout Options: 
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Choose the appropriate type of placement for the type of layout whose options you 
are editing: typically Show once per bracket and Show at system object 
positions would be used only in score layouts, with the exception that in some part 
layouts destined for the recording studio, you may choose to use Show once per 
bracket in order to use larger time signatures than normal. 

Time signatures shown once per bracket. Large time signatures shown on 
brackets occupy horizontal space, and as they are often significantly larger than 
normal time signatures, they can occupy significantly more horizontal space. For 
this reason, it is usually advisable to choose one of the other design options for 
time signatures, which are also found on the new Time Signatures page of Layout 
Options: 

 

The Narrow, serif option uses narrow versions of the traditional time signature 
numerals, and is similar in look to those used in editions of works by Britten, 
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Birtwistle, and other composers around the middle of the 20th century. The 
Narrow, sans serif option uses sans serif numerals comparable in appearance to 
Helvetica or other grotesque fonts, and is similar in look to those used in music 
prepared for film, TV and game recording sessions. You can alternatively choose 
the Plain font option, which will use the font defined by the Time signature plain 
font style (editable in Engrave ▸ Font Styles), but it is advisable to choose a 
narrow or condensed style. 

A single time signature will appear on every bracket in the ensemble, by default 
centered vertically on the bracket: single, unbracketed staves will show a time 
signature, though by default it is larger than a normal time signature; pairs of 
braced staves will likewise show a time signature on each staff, larger than a 
normal time signature. If instead of showing a single time signature for each 
bracket you would prefer Dorico to consider the brackets for unpitched percussion, 
pitched percussion and keyboard instruments as a single group that should 
together receive only one time signature, open Engraving Options, go to the Time 
Signatures page, and set Brackets for percussion and keyboards to Treat as 
single bracket. 

In score preparation for film, TV and game recording sessions, time signatures are 
sometimes aligned with the top of the bracket rather than the middle: to achieve 
this, open Engraving Options, go to the Time Signatures page, and set Vertical 
alignment relative to bracket to Top. 

On the Time Signatures page of Engraving Options, you can also specify the 
scale factor for brackets with varying numbers of staves, relative to a normal time 
signature on a single staff when using the default Show on every staff option. 
Separate scale factors are provided for time signatures on single staves (1 1/4, or 
125%), on brackets of two or three staves (4 or 400%), and on brackets of four or 
more staves (10 or 1000%). 

Time signatures at system object positions. Time signatures shown above the top 
staff and, optionally, other staves above which system items such as tempo and 
rehearsal marks appear have the advantage of occupying no horizontal or rhythmic 
space, at the expense of occupying more vertical space. This type of placement for 
time signatures has become increasingly popular in art music through the course of 
the 20th century, with editions of works by composers including Carter and Henze 
making use of it. 

The staves above which the time signatures will appear are the same as those 
above which rehearsal marks, tempos, repeat endings, etc. will appear, which can 
be controlled using the options in the System Objects section of the Staves and 
Systems page of Layout Options. 
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By default, time signatures above the staff are shown at twice the size of normal 
time signatures, and this can be changed via the Scale factor for time signatures 
shown at system object positions option on the Time Signatures page of 
Engraving Options. 

Because time signatures above the staff do not occupy any rhythmic space, it is 
not crucial to use one of the narrower time signature designs, but it is worth 
considering that when a time signature coincides with a rehearsal mark or a tempo 
instruction, by default the time signature will force any such items to the right, so 
using one of the narrower designs will reduce the distance by which these items 
are displaced. If you would prefer tempo and rehearsal marks to be positioned 
above time signatures instead, change Position of time signatures relative to 
coincident tempo and rehearsal marks to Position below on the Time 
Signatures page of Engraving Options. 

If a time signature above the staff coincides with a bar number, the bar number can 
optionally be hidden by activating Hide bar numbers at time signatures at 
system object positions on the Bar Numbers page of Layout Options. 

Time signatures above the staff can optionally be centered over the barline or left-
aligned; time signatures announcing a change of meter at the end of a system will 
be right-aligned with the end of the system unless there is also a change of key of 
sufficient width that the time signature’s chosen alignment can be used. Alignment 
is determined by the Alignment relative to barlines option on the Time 
Signatures page of Engraving Options. 

When the time signature’s denominator is shown as a note value, it is displayed to 
the right of the numerator rather than below, and using an up-stem note. You can 
adjust the scale factor of the denominator note independently from the scale factor 
of the numerator by changing Scale factor for denominator when shown as 
note duration on the Time Signatures page of Engraving Options. 

Each time signature can be nudged independently in Engrave mode using 
Alt+arrow keys or by dragging it with the mouse. Use Edit ▸ Reset Position to 
remove the offset. 
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System track 

The system track is a new user interface element that makes it easier to add and 
delete bars and to select music on all staves in the system. 

 

The system track is shown by default in new projects, and can be hidden or shown 
by choosing View ▸ System Track. When shown, the system track appears above 
the top staff of the system, and is translucent until you move the mouse pointer 
over the track, at which point it becomes opaque. The system track only appears in 
Write mode. 

If you would prefer the system track not to be shown by default, switch off Show 
system track in new projects in the View section of the General page of 
Preferences. 

Clicking in the system track makes a selection in the system track: hold Shift and 
click in the system track above another bar and the selection is extended. Once 
there is a selection in the system track, additional buttons appear in and above the 
system track: at the left-hand extent of the selection is a delete button; at the right-
hand extent is a button to select the music on all instruments in the range specified 
by the selection on the system track; and a button to insert a bar between the last 
bar selected in the system track and the following bar. 

If you hold down Alt while the system track is visible, grid lines conforming to the 
current rhythmic grid value are drawn on the system track, allowing you to make 
partial bar selections by clicking and dragging across the system track. As with 
selections of complete bars, when the selection is complete, buttons appear at the 
left- and right-hand extents of the selection to delete or select the music 
respectively. 

Selections on the system track are transitory: they are intended to persist only as 
long as needed to perform another action, such as inserting a bar or selecting all of 
the music in the system track selection range on all instruments. As such, the 
system track selection is cleared whenever you make any other kind of selection, or 
when you switch layout, but it is retained when switching between page and galley 
view. 
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Automation 

Dorico 2 includes new tools for fine control over tempo and continuous MIDI 
controllers, expanding the capabilities of Play mode and showing the path for future 
developments in this area. 

 

Time track. The time track at the top of the event display in Play mode allows you to 
edit the tempo of your project. Immediate tempo changes appear as step changes 
in the tempo profile, while gradual tempo changes appear as a slope between two 
points. You can click and drag any handle to adjust the tempo at that point, and a 
small read-out next to the mouse pointer provides visual feedback as to the tempo 
at that point. 

It is also possible to create new tempo changes in the time track: use the draw tool 
to click new tempo changes onto the track; you can keep the mouse button held 
down and sweep it across to draw in multiple tempo changes at once. The 
frequency of the tempo changes created is determined by the rhythmic grid 
setting: the smaller the rhythmic grid value, the greater the number of tempo 
changes that will be created as you sweep the mouse across the track. 

To create a smoother, linear gradual change, use the line tool: click the point at 
which the change should begin, then drag to the position where the gradual 
change should end. 

Tempo changes inserted with the draw or line tools in Play mode appear as 
signposts in Write mode by default, so as to avoid changing the appearance of the 
printed score. If you want these tempos to be printed, you can select them in Write 
mode and then set the Text property in the Tempo group in the Properties panel 
to make them appear. 
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To delete tempo changes in Play mode, use the erase tool: simply click on each 
point in the time track to delete that tempo change. 

MIDI controller tracks. Each instrument can now display a lane for editing MIDI 
controller data. Although only a single lane can currently be displayed, it is possible 
to create data for multiple MIDI controllers. 

To show the MIDI controller lane, click the new button in the track header for the 
instrument for which you want to create automation data:   The lane appears 
directly below the instrument to which it belongs. Choose the MIDI controller for 
which you want to create data from the menu in the controller lane’s track header: 
all 127 MIDI continuous controllers are listed. Any controller for which data already 
exists is annotated in the menu with an asterisk (*). 

Creating automation data for MIDI controllers uses the same tools as creating 
tempo change data in the time track: the draw tool creates individual points and 
can be used to click and drag across the range, drawing discrete points at each 
division of the rhythmic grid; the line tool creates smooth, linear transitions between 
two values; and the erase tool can be used to clear any existing points by clicking 
on them. 

MIDI export. All automation events drawn in the time and MIDI controller tracks are 
included when exporting MIDI files. 

Divisi 

Divisi – from the Italian “to divide” – is a common technique in orchestral string 
writing, especially though not exclusively for violins, and occasionally used in other 
instruments outside the string section, for example in choirs. By splitting a single 
section into multiple smaller sections, each written on its own staff, greater 
sonority, color or counterpoint is possible. 

 

Working with divisi passages has historically been quite awkward in music notation 
software, but Dorico 2’s unique new features for divisi change that for the better. 

In simple terms, you create a divisi in the instrument that will divide, specifying how 
many staves should be used, and how each of those staves should be labeled. 
Dorico then takes care of managing those staves for you automatically: there is no 
need for you to arrange for a change in divisi sections to occur at a system or 
frame break, as Dorico will automatically show unison music in each divisi staff as 
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required if a divisi either starts or ends in the middle of a system. When the divisi 
section ends, you simply create an instruction to restore tutti, and again Dorico 
manages the removal of the additional staves completely automatically. 

Creating divisi. Divisi can only be created for instruments held by section players: 
because a solo player represents only a single person, it’s not possible for that 
instrument to be divided, but a section player represents multiple people all holding 
the same instrument, so that can be divided. To create a new divisi, select the point 
at which the divisi should begin, and choose Edit ▸ Staff ▸ Change Divisi. The 
following dialog appears: 

 

The list at the top of the dialog shows the current divisions: when creating a new 
divisi, only a single division labeled Tutti is present. The action bar below the list of 
divisions allows you to create new divisions of two types: soloists, and sections. To 
add a soloist, click the Add Solo Division button ( ), and to add a section, click 
the Add Section Division button ( ). Each soloist or section you add corresponds 
to an additional staff in the score. There is no limit on the number of soloists and 
sections you can create: to make things as simple and flexible as possible, Dorico 
doesn’t keep count of the total number of players involved, and simply trusts that 
you know what you’re doing. 

To change the label shown for a division, select the division from the list at the top 
of the dialog, and then edit the text in the Staff labels section below. The section 
label, which is normally simply number or possibly a letter to denote which desks or 
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players should play this music, appears directly to the left of that section’s staff at 
the beginning of every system. 

You can additionally group sections together, by selecting multiple adjacent 
divisions in the list of divisions at the top of the dialog and clicking the Add Group 
button ( ). The group label appears centered on all of the staves belonging to the 
divisions in the group, and will appear in place of the instrument name. When 
editing the group label, you can edit the Full Name and Short Name 
independently, using the buttons that appear directly above the editor. 

Finally, the Show player or group name and Show section numbers options at 
the bottom of the Change Divisi dialog allow you to specify whether or not the 
labels defined for this particular divisi should follow the default options for whether 
or not staff and divisi labels should appear as specified on the Staves and 
Systems page of Layout Options (Follow Options), or whether they should be 
explicitly overridden such that they always appear (Show), or are always hidden 
(Hide).  

When all the settings have been made to your satisfaction, click OK and the divisi 
change will be created. A signpost appears, and this can be dragged with the 
mouse or moved with Alt+left/right in Write mode to move the rhythmic position at 
which the divisi change occurs. The additional staves specified by the soloists and 
sections defined in the divisi change appear from the start of the system, with the 
appropriate labels to the left of the system, and if there are any whole or partial 
bars of unison music prior to the divisi change, that music is automatically shown in 
all of the new divisi staves until the divisi change. You can then simply input music 
into the new divisi staves as if they were any other kind of staff. 

Editing an existing divisi change. To edit an existing divisi change, simply double-
click the Divisi signpost, and the Change Divisi dialog will open, allowing you to 
make changes. If you remove a divisi section, be aware that the music that was 
previously on that staff is not removed, so it will continue to play back: you may 
want to delete any music from a divisi staff that you plan to remove before you 
remove the section. Conversely, if you subsequently recreate a divisi section that 
previously existed, all of its music will be restored. 

Changing divisions. If a divisi passage becomes further divided, or indeed if some 
but not all divisions come to an end, you can create a further divisi change in the 
same way as described above at the appropriate point. Note that the staves that 
appear on a system are those defined by only the first divisi change; any further 
divisi change on the same system will take effect at the start of the following 
system. 
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Ending a divisi passage. When the divisi passage has come to an end, select a 
note or rest in the main staff at that position, and choose Edit ▸ Staff ▸ Restore 
Tutti. This creates a default divisi change with a single tutti section, without 
showing the dialog. If this change occurs before the end of the system, unison 
music will automatically be shown on the divisi staves for any whole or partial bars 
between the divisi change and the end of the system. 

Unison passages. When you select unison music on a divisi staff, you will notice 
that the same items are selected on the main staff and indeed on all other divisi 
staves: the music cannot be edited independently, so any changes made on a divisi 
staff will be reflected on all other staves with that music. 

To make it clear where unison passages occur, you can switch on View ▸ Note 
and Rest Colors ▸ Divisi Unison Ranges. This will show the notes and rests in 
unison passages in mid-gray, to help differentiate them from the actual divisi 
material. 

Due to the complexity of showing the same source music on multiple staves, there 
are some modest limitations in what kinds of material Dorico can handle when it 
automatically shows unison music on divisi staves, either at the start of the system 
before a divisi passage begins or at the end of the system after a divisi passage 
ends. The primary limitation is with slurs: any slur that is ongoing at the point that 
the divisi passage begins will not be shown on the divisi staves. To work around 
this, move the start of the divisi passage to the beginning of the slur, and then 
manually copy and paste that music onto the divisi staves. Similar issues exist with 
lyrics, and octave lines will only apply on the main staff, though gradual dynamics 
(such as hairpins) are handled correctly. 

If a divisi staff uses a different clef to the main staff at the point at which it returns 
to playing unison material, Dorico automatically creates the appropriate clef on that 
staff, but it may sometimes be spaced too close to the note immediately before it. If 
possible, try inserting an appropriate clef change somewhere before the end of the 
divisi passage to restore the same clef as the main staff. 

Divisi and staff labels. Two new options have been added to the Staff Labels 
section of the Staves and Systems page of Layout Options: 

§ Show group names is only enabled when either or both full and abbreviated 
staff labels are set to appear in the current layout; when switched on, the divisi 
group label will appear instead of the instrument name. 

§ Show section names can be set independently of whether either divisi group 
names or the instrument’s name is shown; a typical scenario where divisi 
section names should be shown but regular staff labels should not is in part 
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layouts, where it is already known that all of the staves should be played by (say) 
Violin I, and so showing the staff label adds no further useful information. 

These options can be overridden on a per-divisi change basis by the Show player 
or group name and Show section numbers options in the Change Divisi dialog. 

Playback of divisi. In this release, all divisi material – including material for soloists 
– is played on a single channel, so only limited differentiation between the different 
sections is possible. In a future release, Dorico will make it possible to assign each 
soloist and section within a divisi passage to a separate channel, in order to 
provide fully flexible playback of divisi passages. 

Divisi on vocal staves. When using divisi on a vocal section player, Dorico will 
automatically show choral divide arrows at the end of the system prior to the start 
of the divisi passage: 

 

It will show corresponding arrows on each of the divisi staves directing the singers 
back to a single staff at the end of the system where the divisi passage ends. 

To control this behavior, change the Indicate divisi at end of system on vocal 
staves option on the Divisi page of Engraving Options. 

Ossias 

Ossias show alternative passages that can be played instead of the original 
passage; sometimes they are used to show editorial recommendations for realizing 
ornaments, or deviations between different sources, or to show an easier version. 
Dorico 2 introduces comprehensive features for handling ossia passages. 

 

Adding an ossia. To add an ossia, select the range over which you want the ossia 
staff to appear, then choose Edit ▸ Staff ▸ Create Ossia Above or Create Ossia 
Below. If you are writing for piano or another grand staff instrument, and require an 
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ossia that shows both staves, select material on both the right- and left-hand 
staves before you choose Create Ossia Above or Create Ossia Below. 

You can create an ossia for an instrument held by a solo or section player, with the 
exception that you cannot create an ossia for a percussion kit instrument. An 
instrument can show an ossia both above and below if necessary, but only one 
ossia on the same side of the staff at once. 

A signpost appears at the start of the ossia passage, and another at the end where 
the ossia staff disappears again. You can select these signposts and move them by 
dragging them in Write mode or nudging them with Alt+left/right, which will also 
move the start and end rhythmic position of the ossia. 

Removing an ossia. To remove an ossia passage, you can simply delete the 
signpost at each end of the ossia passage, or select any note or rest in the ossia 
passage and choose Edit ▸ Staff ▸ Remove Staff. 

Be aware that when you delete an ossia, unless you first deleted the music within 
the ossia, that music still exists but is simply not shown: if you recreate an ossia at 
the same position later on, that music will reappear. 

Scale factor. By default, ossia staves are scaled to two thirds the size of a regular 
staff, and this can be adjusted via the Ossia scale factor option on the Staves 
page of Engraving Options. 

Deciding where ossias appear. By default, ossia staves will appear in all layouts, 
but it may be more appropriate for ossias to appear only in the part layout for an 
individual performer, or possibly only in the score. To choose whether ossias 
appear in a layout, activate or deactivate Show ossias in the Ossias and Extra 
Staves section of the Staves and Systems page of Layout Options as 
appropriate. 

Barline joins. There are several conventions in use in published music for how 
barlines in ossias should be joined to the main staff to which they correspond: 
assuming an ossia both starts and ends at whole bar positions, some publishers 
join the ossia to the main staff both at the start and the end; others join the ossia 
only at the end; and still others do not join the ossia to the main staff at all. 

When an ossia is joined to the main staff, some publishers use the same kind of 
barline as used for the other staves (typically a single barline), but others instead 
join the ossia with a dashed barline. 

Dorico provides options to accommodate all of these conventions in the Ossias 
section of the Barlines page of Engraving Options. 



 

 
Dorico 2 Version History Page 113 Steinberg Media Technologies GmbH 

When an ossia appears between the main staves of an instrument – for example, 
an ossia below the right-hand staff of a piano – then it will always be joined by the 
same barline as the main staves, regardless of the options chosen on the Barlines 
page of Engraving Options. 

Ossia labels. To label the beginning of an ossia staff with the word “ossia”, activate 
Show label before ossia in the Ossias and Extra Staves section of the Staves 
and Systems page of Layout Options. If you would prefer to use a custom label, 
set Ossia label to Custom and then provide the desired text in the Custom ossia 
label field. 

The ossia label is drawn in the staff labels paragraph style, and is positioned 
according to the distances defined in the Ossias section of the Staves page of 
Engraving Options, with separate options for labels before single and braced pairs 
of ossia staves. 

Ossias beginning or ending mid-bar. If an ossia begins or ends in the middle of the 
bar, Dorico pads the staff lines to the left and to the right of the musical material to 
ensure that notes, accidentals, rhythm dots and other items do not directly abut the 
ends of the ossia staff. To adjust the amount of padding to the left and to the right, 
change Extend staff lines at start of ossia and Extend staff lines at end of 
ossia in the Ossias section of the Staves page of Engraving Options. 

Ossias crossing breaks. When an ossia starts on one system and then ends on the 
next, you may want to see the ossia’s clef and key signature restated at the start of 
the system, as it is for a regular staff; alternatively, to make it clear that the ossia is 
not an additional instrument, you may prefer that the ossia should restart following 
the fixed preamble of clef and key signature at the start of the system. 

Dorico can accommodate either approach: set Ossias crossing a system break 
to Include in preamble or Exclude from preamble in the Ossias and Extra 
Staves section of the Staves and Systems page of Layout Options. 

Vertical spacing. The default distance of an ossia from the main staff to which it 
corresponds is determined via the new Ossia staff to staff value on the Vertical 
Spacing page of Layout Options. This distance is not subject to vertical 
justification. 

You can adjust the distance between an individual ossia staff and its main staff 
using the staff spacing tools in Engrave mode in the usual way: instead of the 
handle appearing at the left-hand side of the system, the handle for the ossia will 
appear at the start of the ossia staff on that system. 

Ossias and playback. Music on ossia staves is never played back. 
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Changing the number of staves for an instrument 

Dorico 2 now makes it easy to add or remove staves from an instrument at different 
points in the flow, allowing for example the notation of complex works for piano 
where three or sometimes more staves are required. 

Adding an extra staff. To add an extra staff to an instrument, select a note or rest 
on the staff above or below which you want the extra staff to appear, at the 
rhythmic position at which you want the extra staff to begin, and choose Edit ▸ 
Staff ▸ Add Staff Above or Add Staff Below. The extra staff is added from that 
position, and a signpost appears, labeled with the number of staves that have been 
added (or removed). 

The instrument must belong to a solo player: you cannot change the number of 
staves of instruments held by section players. It is also not possible to add 
additional staves to a percussion kit instrument. 

Removing an extra staff. To remove an extra staff, either select the signpost that 
corresponds to the point at which the extra staff appears, or select the note or rest 
on the staff you want to remove at the point at which you want it to be removed, 
and choose Edit ▸ Staff ▸ Remove Staff. This can also be used to remove one of 
the primary staves of an instrument, for example either the right- or left-hand staff of 
the piano (though of course you cannot remove all of the staves belonging to an 
instrument: at least one will always appear). 

Choosing when an extra staff should begin. When a staff starts or stops in the 
middle of a system, you may want that staff to appear or disappear exactly at that 
point, or you may prefer for that system to appear for the whole of that system. This 
is controlled by way of the new Show extra staves across full system when 
starting or stopping checkbox in the Ossias and Extra Staves section of the 
Staves and Systems page of Layout Options. 

Hiding empty staves. When extra staves are added to an instrument, it will no 
longer be affected by the Allow individual staves of multi-staff instruments to 
be hidden option on the Vertical Spacing page of Layout Options. 

Rhythmic slashes 

Rhythmic slashes are used to indicate that a performer should play something, but 
without being especially specific about exactly what they should play: slashes 
without stems are generally interpreted as giving the performer complete freedom 
to play whatever he or she likes; slashes with stems are generally interpreted as 
dictating the rhythm to be played, but without being specific about the pitches. The 
former is sometimes called slash notation, while the latter is sometimes called 
rhythmic notation. Dorico 2 introduces sophisticated support for both kinds of 
rhythmic slashes. 
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Slash regions. The quickest way to add rhythmic slashes is to use a slash region, 
which allows you to fill a range of bars with slashes, where the rhythm of the 
slashes is automatically determined by the prevailing time signature: for example, in 
bars of 4/4, four quarter note slashes will be shown, while in 6/8, two dotted 
quarter note slashes will be shown. Changing the time signature causes the 
durations of the slashes in the region to be updated automatically. 

Slash regions are created by selecting one or more bars and choosing Write ▸ 
Create Slash Region, or by opening the new Shift+R popover, typing slash and 
hitting Return to confirm the popover. The slash region is created to the duration of 
the selection, and by default shows a green highlight behind the slashes to show 
that the slashes are part of a region (to disable this, switch off View ▸ Highlight 
Slash Regions). Handles at the start and end of the slash region allow you to 
extend the region at either end; you can also use Alt+left/right to move the start of 
the slash range, and Shift+Alt+left/right to increase or decrease the duration of 
the slash region. 

Cutting a slash region. You may find that you need to cut a slash region in two, for 
example because you want to write some more specific notation in the middle of 
the region. To achieve this, select the slash at the position at which you want to 
split the slash region, then click the scissors tool in the notes toolbox, or type U. 
The slash region is split in two at that location, and you can then, for example, drag 
the start handle of the second half of the region right to make room for whatever 
you need to write. 

Rhythm dots for slash regions. In compound time signatures, there are different 
conventions for whether or not rhythm dots should be shown on slashes; by 
default, Dorico will show rhythm dots on slashes of the duration of a compound 
beat, but this can be changed via the Slash regions in compound time 
signatures option in the Rhythmic Slashes section of the Notes page of 
Engraving Options. 

Appearance of slashes. Dorico provides several different appearances for rhythmic 
slashes, and you can choose between any of the provided designs by setting 
Slashes with stems and Slashes without stems to the desired appearance in 
the Rhythmic Slashes section of the Notes page of Engraving Options. 

Slash voices. When you want to write more specific rhythmic notation than is 
provided by a slash region, you can write rhythmic notation using a slash voice. 
Input using a slash voice is exactly the same as when using a regular voice, except 
that whatever pitch you specify will be overridden, and instead of the note or chord 
you input, a single slash will appear on the middle line of the staff by default. You 
can convert an existing voice to and from a slash voice, so the underlying pitches of 
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the notes and chords are retained and will be restored if you change the voice 
back to a regular voice. 

To start a new slash voice in note input, choose Write ▸ Create Slash Voice, or 
type the default command Shift+Alt+V; this is analogous to the default Shift+V 
command to add a new regular voice. 

 

Typing Shift+Alt+V repeatedly cycles through the types of slash voice that can be 
added: slashes with stems, stem up; slashes with stems, stem down; and slashes 
without stems. As with a regular voice, the indicator to the left of the caret shows 
what kind of voice you are about to add. 

Once you have input some slashes, the slash voice is available for reuse anywhere 
else on that instrument, and when cycling through the voices with V, the slash 
voice will be included. 

Changing slash voice type. If after inputting rhythmic notation in a slash voice you 
want to, say, switch to slashes without stems, you can do so by selecting one of 
the slashes and choosing the desired voice type from Edit ▸ Voices ▸ Rhythmic 
Slashes: if you choose Normal Notes from this submenu, the voice will be 
converted to a regular voice, and the original pitches of the notes and chords as 
they were first input will be restored. 

For slash regions, you can toggle between slashes with and without stems by 
selecting any slash in the region or either the start or end handle, then activating 
the Stemless property in the Slash Region group of Properties. 

Changing stem direction. For slashes with stems, you can specify whether the 
default stem direction for the slash voice should be up or down in the same way as 
for a regular voice: choose Edit ▸ Voices ▸ Default Stems Up or Default Stems 
Down as desired. 

For slash regions, you can specify stem direction by selecting any slash in the 
region or either the start or end handle, then activating the Voice direction 
property in the Slash Region group of Properties. 

Changing staff position. By default, slash regions and slash voices both show 
slashes on the middle line of the staff. The staff position can be changed in the 
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same way: activate the Slash pos. property in the Slash Region or Notes and 
Rests groups respectively, and then set the desired value. A value of 0 
corresponds to the middle staff line, with positive numbers moving slashes 
upwards, and negative numbers moving them downwards. 

Rests before and after slash regions. If a slash region starts or ends in the middle 
of the bar, you may or may not want the remainder of that bar to be padded with 
rests, depending on whether any other music is going on at the same time in that 
staff. By default, slash regions will pad incomplete bars with rests at either end, but 
you can suppress these rests by activating the Hide rests before start and Hide 
rests after end properties in the Slash Region group in Properties. 

Opposing slash voices. In the event that you have a slash voice opposing either 
another slash voice or a regular voice, Dorico will override the default staff position 
for the slash voice in order to reduce the likelihood of collisions between the 
voices. The amount by which the slash voice is offset is determined by the options 
in the Rhythmic Slash Voices group of the Voices page of Notation Options. 

Slashes and unpitched percussion. To use slashes on a percussion kit, open the 
Edit Percussion Kit dialog (expand the card for the percussion player in the 
Players panel in Setup mode, and open the dialog from the instrument’s context 
menu). You can add slashes with or without stems to the percussion kit using 
either of the Slashes buttons in the action bar below the 5-line Staff editor. More 
than one set of slashes can be added to a percussion kit and positioned at 
different staff positions.  

In note input, moving between the different instruments in the kit using the arrow 
keys will include any slashes you have added to the kit, and you can input slashes 
just as you would input any other music on a percussion kit. 

Slashes in percussion kits only appear when using the five-line staff presentation 
type: if you switch to the grid or individual instrument presentation types, the 
slashes will not appear. 

Bar repeats 

Bar repeats indicate to the performer that the material in the preceding one, two or 
four bars should be repeated exactly: this notational shorthand can be very helpful 
to the performer as it is easier to read a bar repeat and understand that the music 
is to be repeated exactly than to read multiple bars of written-out music, trying to 
spot whether or not it is actually repeated exactly. 
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Bar repeat regions. After you have input the music that is to be repeated, make a 
selection beginning in the following bar and extending as far as you would like bar 
repeats to be shown (though you can of course change this later), and choose 
Write ▸ Create Bar Repeat Region. This creates a bar repeat region that shows 
the 1-bar repeat sign for the extent of the selection. You can alternatively type 
Shift+R to open the new repeats popover, then enter % to repeat the last bar, %2 
to repeat the last two bars, or %4 to repeat the last four bars. 

To change the number of bars to be repeated after you have created a bar repeat 
region, select any of the repeat bar symbols or the circular handle at the start or 
end of the region, and change the value of the No. bars property in the Bar 
Repeat Region group in the Properties panel. 

By default, a light blue highlight appears behind bar repeat regions to help them 

stand out: to toggle the visibility of this highlight, choose View ▸ Highlight Bar 
Repeat Regions. 

Counting bar repeats. Dorico automatically shows a count of the number of 
repetitions at intervals above the bar repeat region. By default, it shows the count 
every four bars, with the bar or bars of music being counted as “one”; so, for 
example, if you have a single bar of music followed by a bar repeat region covering 
three bars, the third bar repeat will be counted as “four.” To change the default 
count interval, set Show bar repeat count every n bars on the Bar Repeats page 
of Engraving Options. To prevent the count from appearing altogether, set 
Appearance of bar repeat count to Do not show. 

These defaults can be overridden for an individual bar repeat region: activate the 
Count frequency or Count appearance in the Bar Repeat Region group of 
Properties. You can also specify the number that Dorico should count from by 
activating the Count from property. 

To change the font, size or style of the bar repeat count, edit the Bar repeat count 
font style in Engrave ▸ Font Styles. 

The precise position of the numbers above bar repeats can be adjusted in Engrave 
mode with the mouse or by nudging with Alt and the arrow keys.  

Grouping bar repeats. In music with a very regular phrase structure it may be 
desirable to show that structure by grouping bar repeats. For example, in music 
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with a regular four-bar structure, you could choose to show two identical phrases 
of four bars like this: 

 

Or you could choose to group at four-bar intervals, like this: 

 

Although it is even less conventional, it is also possible to show the first four-bar 
phrase using a three-bar repeat, like this: 

 

To enable grouping, select any bar repeat symbol or the handle at either end of the 
bar repeat range, then set the Group every property to the desired number of bars. 
To show a three-bar repeat when completing a four-bar phrase, set Appearance 
for three-bar remainder of group to Use 3-bar repeat on the Bar Repeats page 
of Engraving Options. 

It is also possible to specify grouping when creating a bar repeat region using the 
Shift+R popover: %1,4 will produce a one-bar repeat grouped every four bars, 
while %2,4 will produce a two-bar repeat grouped every four bars, and so on. It is 
only possible to specify grouping at one, two or four bars, but if Dorico determines 
that the requested combination of settings is invalid, it will default to no grouping. 
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It must be noted that grouping bar repeats should be exercised with caution, as it 
can introduce ambiguity. 

The range of bar numbers encompassed by a consolidated bar repeat region can 
be shown beneath the consolidated bar repeat by activating the Show ranges of 
bar numbers under multi-bar rests and consolidated bar repeats option on the 
Bar Numbers page of Layout Options. 

New arranging tools 

Dorico 2 introduces a number of new note editing tools to assist with common 
tasks during arranging, including multi-paste, explode and reduce, and moving and 
copying material to the staff above or below. 

Multi-paste. When pasting copied material, Dorico can now paste multiple copies 
both horizontally and vertically to fill the range described by the extent of the 
selection: if only a single item is selected, then pasting works exactly as before, but 
if multiple items are selected, Dorico considers the nominal rectangle described by 
the contiguous range of instruments on which items are selected, the rhythmic 
position of the first selected item on the top instrument and the rhythmic position of 
the last selected item on any of the selected instruments, and then fills that 
rectangle with as many complete copies of the material as fit within it. 

If there is a discontiguous selection of instruments, then Dorico will consider each 
contiguous range of instruments as separate regions for pasting: this allows you to 
(for example) copy dynamics from one instrument and then multi-paste them to 
several instruments, but omitting one or two instruments in the middle of the range. 

Even if the rhythmic extent of the selection is shorter than the length of the copied 
material, Dorico will paste one complete copy of the material onto each instrument 
in the region, but if the selection is longer than the copied material, Dorico will 
paste as many complete copies of the material after each other as fit without 
overflowing the selected region. (STEAM-7450) 

Moving music to the staff above or below. Two new commands have been added 
to the new Edit ▸ Paste Special submenu: Move to Staff Above and Move to 
Staff Below, which have the default key commands Alt+N and Alt+M (by analogy 
with Edit ▸ Cross Staff ▸ Cross to Staff Above and Cross to Staff Below, which 
have the default key commands N and M). 

These commands cut the selected notes and other items from their current staff, 
and then paste them on the staff above or below in a single operation. This is very 
useful in a variety of situations: for example, after importing a keyboard part from a 
MIDI file, you may want to move individual notes from the right-hand staff to the 
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left-hand staff, or vice versa; after using the new explode or reduce features, you 
may want to make adjustments to individual voicings; and so on. 

When moving notes within tuplets to the staff above or below, beware that unless 
the tuplet number/bracket (or signpost) itself is selected, the tuplet will not be 
moved to the staff above or below, so the notes will be unscaled and no longer 
part of a tuplet. 

Duplicating music to the staff above or below. The new Duplicate to Staff Above 
and Duplicate to Staff Below commands in the Edit ▸ Paste Special submenu 
work similarly to Move to Staff Above and Move to Staff Below, except that 
instead of cutting and pasting, these commands copy and paste, so the selected 
material remains on the original staff and is duplicated on the staff above or below. 

Reduce. Reduction is the process of taking music for more than one instrument 
and assigning it to fewer instruments (or even a single instrument, in the case of a 
keyboard reduction). The new Edit ▸ Paste Special ▸ Reduce command aims to 
partially automate this demanding task. 

First, copy the material to be reduced to the clipboard using Edit ▸ Copy. Then 
select the instrument or instruments into which the copied material should be 
reduced, and choose Edit ▸ Paste Special ▸ Reduce. 

Dorico pastes the copied material, and performs some transformations as it does 
so: if the rhythms match, it merges the material into a single voice; it removes 
unison notes, so that only a single note of the same pitch is pasted at a given 
rhythmic position; and it strips out clef changes, octave lines, and cues. 

The disposition of the copied material onto the selected instruments for pasting is 
determined automatically, and will ensure that every destination instrument receives 
at least one instrument’s music, duplicating that instrument’s music if necessary: 
for example, if you copy material from four instruments and reduce into two 
instruments, the material will be split equally between the two instruments, from the 
top downwards in instrument order; if you copy material from five instruments and 
reduce into three, the first instrument will be assigned music from the first two 
instruments, the second will be assigned music from the third and fourth 
instruments, the third will be assigned music from the fifth instrument. 

Explode. Exploding is the charming colloquial term for taking music written on a 
certain number of instruments (typically one or two) and pasting it onto a larger 
number of instruments, and this can now be performed by choosing Edit ▸ Paste 

Special ▸ Explode. 
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First, copy the material to explode to the clipboard using Edit ▸ Copy. Then select 
the instrument or instruments into which the copied material should be exploded, 
and choose Edit ▸ Paste Special ▸ Explode. 

Dorico ensures that each destination instrument receives one of the notes in the 
source chords, allocated from top to bottom: if the number of notes in the chord 
matches the number of destination instruments, then each instrument will receive 
one note; if the number of notes in the chord is less than the number of destination 
instruments, then the same note will be allocated to more than one instrument. 
Non-note items such as slurs and dynamics will also be duplicated to each 
destination instrument. 

Playing techniques editor 

It is now possible to edit existing playing techniques and create your own, with the 
new Engrave ▸ Playing Techniques dialog. 

 

Editing an existing playing technique. To edit an existing playing technique, choose 
the appropriate category from the Playing Technique Category menu at the top 
left-hand corner of the dialog; this corresponds to the categories shown in the 
Playing Techniques panel in Write mode. The playing techniques in the chosen 
category are displayed in the list directly below the menu: the selected playing 
technique is then shown in the main editor that occupies the right-hand side of the 
dialog. 
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The editor will look different depending on the Type of playing technique chosen: 
Text playing techniques show the text to be displayed in the score; Glyph playing 
techniques show the graphical symbol (usually one or more characters from the 
music font, but this can in fact be any combination of glyphs from music fonts, 
characters from text fonts, and even graphics files). 

Editing a Text playing technique is done directly in this dialog: simply change the 
displayed text by editing the Text field, and specify which font style should be used 
by choosing it from the menu immediately to the right of the Text field; by default, 
the font style used is Playing technique font. 

Editing a Glyph playing technique involves opening a secondary dialog: depending 
on whether the playing technique uses the same or a different appearance when 
shown above or below the staff, there will either be a single pencil icon in the 
action bar in the large preview in the top half of the dialog, or one pencil icon for 
each appearance. Click the pencil icon, and the secondary editor opens: 

 

To add a new component to the playing technique, select it from the panel on the 
right-hand side of the dialog: you can choose any character from any font in the 
Glyph tab, write one or more words in any font style in the Text tab, import a 
graphic in SVG, PNG, or JPG format via the Graphic tab, or add any of the existing 
other musical symbols that are used throughout the project from the Composite 
tab. 
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Once you have added a component, you can move it either by dragging it with the 
mouse or by using Alt with the arrow keys. Each component can be scaled, either 
by clicking and dragging on one of the handles, or using the X scale and Y scale 
spin controls; graphics components can be scaled independently in the horizontal 
and vertical dimensions, while glyphs, text and composite components must be 
scaled a uniform amount in both dimensions. 

If you have multiple overlapping components, you can determine which should 
draw in front and behind each other using the Z order buttons to move the 
selected component towards the front or the back. 

Once you have designed the playing technique to your satisfaction, click OK to 
close the secondary editor and return to the main dialog. 

The other options below the main preview panel are as follows: 

§ Category: the choice of category determines which section of the Playing 
Techniques panel the playing technique appears in. 

§ Default placement: specifies whether the playing technique should appear 
Above or Below the staff by default. 

§ Appearance only applies to glyph-type playing techniques; Same above and 
below means that the same symbol will be used when the playing technique is 
shown above or below the staff, and Different above and below allows you to 
specify a different symbol for each side of the staff. 

§ Popover text: the text that can be typed into the Shift+P popover to create this 
playing technique; the editor will warn you if the text you specify is already 
assigned to another playing technique. 

§ Playing technique: the playing technique that will actually be produced in 
playback; see below. 

§ Duration: this currently has little effect, since Dorico does not yet provide all of 
the planned options for showing the continuation of a playing technique (which 
will eventually include solid and dashed lines and arrows of various kinds in 
addition to the current repeated glyph appearance), but for future development 
this allows you to specify whether this playing technique should show a 
continuation by default (Has duration) or should instead apply only to a single 
rhythmic position (Has no duration). 

§ Shown in cues: determines whether or not this playing technique will appear in 
a cue, assuming the cue is set to include playing techniques from the source 
instrument. 

Playback playing techniques. The playing techniques whose appearance you edit 

in the Engrave ▸ Playing Techniques dialog are all bound to a playback playing 
technique, which can be chosen from the Playing technique menu when editing a 
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playing technique appearance. You can also edit existing playback playing 
techniques and define your own by clicking the Edit button to the right of the 
Playing technique menu, which shows the following dialog: 

 

The Playing Technique Group menu at the top left-hand corner allows you to 
choose which group of playback playing techniques to edit. These groups are 
defined in the VST Expression Maps format and specify the type of behavior that 
will be produced during playback: 

§ Techniques: playing techniques that affect the overall quality of the sound. 
§ Dynamics: playing techniques that affect the volume or attack of the sound. 
§ Lengths: playing techniques that affect the played duration of notes, and 

qualities such as legato and détaché. 
§ Ornaments: playing techniques that include additional or different notes to the 

written pitch, or changes to the pitch or vibrato of the note. 

The Name on the right-hand side determines how this playing technique will 
appear in the lists in the Engrave ▸ Playing Techniques, Play ▸ Expression Maps 
and Play ▸ Percussion Maps dialogs. The values that can be set for each 
playback playing technique are as follows: 

§ Alias for: specifies another playback playing technique, with which the present 
one is equivalent. 

§ Group: specifies which group this playback playing technique appears in. 
§ Fallback: specifies another playback playing technique that can be used if the 

present playing technique is not available. 
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§ Articulation type: specifies the duration over which the playback playing 
technique takes effect; Attribute applies only to the note at the rhythmic 
position where the playing technique is found (for example, a staccato 
articulation), while Direction applies to all following notes until it is 
countermanded by another playing technique (for example, a pizzicato 
instruction). 

Once you have made the necessary changes, click OK. The edited or new 
playback playing technique will now be available in this project. 

Making edited playing techniques available to other projects. All of the edits made 

in Engrave ▸ Playing Techniques apply only to the current project by default. To 
make a new or edited playing technique available in all future projects, select the 
playing technique from the list on the left-hand side of the dialog and click Save as 
Default: this new or edited technique will then be reflected in every new project 
created subsequently. 

To revert an edit made to one of the default playing techniques, select the playing 
technique from the list on the left-hand side of the dialog and click Revert to 
Factory. 

Petaluma handwritten music font 

A new handwritten music font family called Petaluma is included with Dorico 2. The 
family consists of three fonts: Petaluma, Petaluma Text, and Petaluma Script. 
Petaluma is the main font used for all of the musical symbols in the score; Petaluma 
Text is used for musical symbols drawn in text-like items like metronome marks, 
chord symbols, dynamics, and so on; Petaluma Script is a script font suitable for 
use for all other text in the score. 

 

The Petaluma family is loosely based on the hand copying style of a popular series 
of books containing jazz standards, although it contains a repertoire of more than 
1350 musical symbols and 500 letter forms, a far greater variety of symbols than 
are found in any single set of publications. 

To use Petaluma in your project, choose Engrave ▸ Music Fonts, choose 
Petaluma from the list of available music fonts, and click OK. Doing so will also set 
Petaluma Script as the default text font for the project: if you want to use another 
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text font, edit Default text font style in Engrave ▸ Font Styles and Default text in 
Engrave ▸ Paragraph Styles. 

Petaluma is a SMuFL-compatible music font, and is licensed under the SIL Open 
Font License, which means that it can be freely used, modified and distributed, 
provided any modifications are also released under the OFL. The Reserved Font 
Name for this family is “Petaluma”, and any derivative fonts may not use this name. 
Finally, neither the Petaluma font family nor any derivative fonts can be sold 
separately, though they can be distributed as part of a package that is sold 
commercially. 

Support for NotePerformer 3 

Dorico 2 also introduces support for NotePerformer 3 from Wallander Instruments. 
NotePerformer is a virtual instrument specifically designed to produce playback 
from music notation software. 

 

NotePerformer 3 is not included with Dorico 2, but is available for separate 
purchase from www.noteperformer.com, from where you can also download a 30-
day trial version. 

After you have purchased and installed NotePerformer 3, to use it in Dorico, open 
the project you would like to play back using NotePerformer and choose Play ▸ 
Playback Templates. Choose NotePerformer from the list of playback templates, 
and click OK. 

If you would like to use NotePerformer for every new project, set Default playback 
template to NotePerformer in the Play section of the General page of 
Preferences. 
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Improvements 

Accidentals 

Microtonal accidentals now play back correctly via HALion Sonic SE or other VST 
Note Expression-capable VST 3 instruments, both during playback and when 
auditioned when notes are selected in the music. 

Audio export 

A progress dialog now appears during audio export on both Windows and Mac, 
and more accurately depicts the actual progress of the operation. (STEAM-5293) 

Barlines 

Hymnal-style repeat barlines. In some hymnals, such as The New English Hymnal, 
repeat barlines are drawn in a particular way: the dots are shown in each space, 
and instead of showing some combination of thin and thick barlines, repeats are 
indicated by two thin barlines, except at the start of a system, where no barlines are 
shown, and only the four dots are shown. This convention can now be followed in 
Dorico by setting Coincident repeat barline appearance to Double thin 
barlines, and setting Repeat dot frequency to All spaces in the staff, on the 
Barlines page of Engraving Options. (STEAM-7668) 

Bar numbers 

Ranges of bar numbers on multi-bar rests. Dorico can now display the bar 
numbers included in a multi-bar rest directly as a range directly below the multi-bar 
rest. To enable this, activate Show ranges of bar numbers under multi-bar rests 
on the Bar Numbers page of Layout Options. 

New options on the Rests page of Engraving Options allow you to change the 
default distance below the staff for the range of bar numbers, and specify the 
separator to use between the first and last bar numbers in the range. (STEAM-
7791) 

Appearance of bar numbers in different layouts. A new Paragraph style option has 
been added to the Bar Numbers page of Layout Options, allowing you to choose 
which paragraph style should be used for each layout in your project. In new 
projects, full and custom score layouts use the Bar numbers (score) paragraph 
style, while part layouts use the Bar numbers (parts) paragraph styles; in existing 
projects, both score and part layouts use the Bar numbers (score) paragraph 
style, which is updated to match the appearance of the bar numbers font style 
used in Dorico 1.x, to ensure that the appearance of bar numbers does not change 
when these projects are opened in Dorico 2. 

By default, both the Bar numbers (score) and Bar numbers (parts) paragraph 
styles look the same, but having separate styles makes it easy to change the font, 
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size or style of bar numbers in, say, the part layouts without affecting the full score. 
(STEAM-7813) 

Chord symbols 

Color. Chord symbols now respect the Color property in the Common group in 
Properties. (STEAM-6493) 

Clefs 

Specifying the clef to be used in concert and transposing pitch. Several of Dorico’s 
preset instrument types use a different clef when displaying the music in concert 
and transposed pitch, and it is now possible for you to specify this directly for each 

clef in the flow if necessary. In the Edit ▸ Clef submenu there are now two new 
submenus, Concert Pitch and Transposed Pitch, from which you can choose any 
of the clefs available from the Clefs panel in Write mode. (STEAM-7676) 

Dynamics 

Erasing the background behind dynamics. When an immediate dynamic with a 
prefix or suffix or a text-based gradual dynamic crosses a barline, or in rare 
circumstances when a dynamic must be positioned within the staff, allowing the 
dynamic to blank out part of the barline or staff lines can make the dynamic 
considerably easier to read. 

A new Erase background property has been added to the Dynamics group of the 
Properties panel, which appears only in Engrave mode. When activated, a small 
area around the dynamic is erased. The default amount of padding around the 
dynamic is determined by the new Padding around dynamic with erased 
background value on the Dynamics page of Engraving Options, and can be 
overridden by activating the new Erasure padding properties, also found in the 
Dynamics group of the Properties panel. 

When determining the shape of the area to be padded, Dorico considers the prefix 
and suffix separately from the bold italic characters that indicate the dynamic level, 
which means that, for example, when padding a dynamic such as  risoluto, the 
padding will be taller for  than for risoluto. The padding by default takes into 
account any ascenders and descenders in the text, so depending on the exact 
position at which the dynamic crosses the barline, it may appear that the area of 
erasure is larger than it need to be; for example, if a dynamic has the suffix 
espressivo, but it crosses the barline at “s” rather than “p”, the padding may appear 
too large below the dynamic. To resolve this, you can override the amount of 
padding on any of the four sides of the nominal bounding box that surrounds the 
dynamic, so you could reduce the bottom padding such that it no longer pads 
outside the descender, and thus make the area of erasure appear symmetrical both 
above and below the characters. 
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The padded area of erasure is considered part of the dynamic’s bounding shape 
for the purposes of collision avoidance. (STEAM-7656) 

Hairpins with flared ends. A hairpin with a flared open end is used by some 
composers to indicate a rapid increase or decrease in dynamic level, sometimes 
colloquially referred to as an “exponential hairpin.” To make a hairpin show a flared 
end, select it and activate the new Flared end property; this property is only 
available for gradual dynamics drawn as hairpins, and only for hairpins drawn with a 
solid line. 

The default size of the flared end can be specified by changing the options in the 
new Flared end design group in the Gradual Dynamics section of the Dynamics 
page of Engraving Options. The size of the flared end for an individual hairpin can 
also be adjusted in Engrave mode by changing the new Flare size W (width) and 
H (height) properties. (STEAM-7778) 

Filters 

New filters for markers, bar repeat regions and rhythm slash regions have been 

added to the Edit ▸ Filter menu. The Filter menu is now also included in the right-
click context menu for easier access. 

Fingering 

Custom scale factor. A new Scale property has been added to the Fingering 
group of the Properties panel, which appears only in Engrave mode, and which 
allows the scale factor of a fingering to be changed independently from the scale 
factor of the note to which it applies. (STEAM-7346) 

Appearance of cautionary fingerings. It is now possible to override the appearance 
of individual cautionary fingerings via the new Cautionary property in the Fingering 
group of the Properties panel, which appears only when a note (and not a 
fingering) is selected, and only in Engrave mode. The property can only be 
activated for a note that has a cautionary fingering: it will otherwise be deactivated 
automatically. When the property is activated, you can choose between the 
following values: (STEAM-7345) 

§ Default: uses the appearance for cautionary fingerings defined in Engraving 
Options. 

§ No parentheses: show the fingering without parentheses. 
§ With parentheses: show the fingering enclosed in parentheses. 
§ Suppress: hide the cautionary fingering altogether. 

Circled or underlined fingerings. It is now possible to specify that a fingering 
should either be enclosed in a circle, or underlined; these adornments are 
sometimes used for accordion fingering to indicate that a finger is playing in a help 
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row. To enable this, select a fingering number and activate the new Decoration 
property in the Fingering group of the Properties panel, which appears only in 
Engrave mode. A number of options for the size of the circular enclosure, the 
thickness of the line, and so on, can be found by disclosing the Advanced Options 
subsection of the Design section of the Fingering page of Engraving Options. 
(STEAM-7308) 

Galley view 

The size and position of the staff labels in the margin and the bar numbers above 
the top staff has been improved. 

HALion Sonic SE (STEAM-7672) 

Dorico 2 now includes HALion Sonic SE 3. For an updated Operation Manual for 
the new version, please visit: 

https://steinberg.help/vst-manuals/halion/halion-sonic-se-3/ 

Mixer 

You can now Ctrl+click (Windows) or Command-click (Mac) on a volume fader or 
pan control to reset the value back to its default. (STEAM-8046) 

Notes 

Stemless notes. A new Hide stem property has been added to the Notes and 
Rests group of the Properties panel, only appearing in Engrave mode. When 
activated, the stem of the selected note will not be drawn; any flag will also be 
hidden. If the selected note is part of a beamed group, then the stem will be 
hidden, but the beam will continue to be shown as normal, unless every note in the 
beamed group has the Hide stem property set, at which point the beam will also 
be hidden. (STEAM-7494) 

Note input 

Scale existing notes into a tuplet. It is now possible to scale a selection of existing 
notes into one or more tuplets: select the notes that should be made into tuplets, 
and type ; (semicolon). The tuplet popover opens, with a suggested ratio based on 
the number and durations of the selected notes already filled in; you can either 
accept the suggested ratio by hitting Return, or type the desired ratio, then hit 
Return to confirm the popover. If the selected notes fit into a single tuplet of the 
specified ratio, then only one tuplet will be created, but if the specified ratio is 
insufficient to scale all of the selected notes, further tuplets will be created until all 
of the selected notes are contained within a tuplet. 

It is now possible to specify the beat unit of the tuplet directly into the tuplet 
popover by appending either the letter that corresponds to a note duration (2h = 
double whole, w = whole, h = half, q = quarter, e = eighth, etc.) or the number 
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that corresponds to the default key command for that duration in note input (9 = 
double whole, 8 = whole, 7 = half, 6 = quarter, 5 = eighth, etc.), and then 
appending one or more full stop (period) characters to specify a dotted beat unit. 
When using a number to specify the duration, you must separate the beat unit from 
the number of beats either using a space or a hyphen. By way of example, 5:4q. 
means “5 in the time of 4 dotted quarters”, while 3:2-2w means “3 in the time of 2 
double whole notes”. (STEAM-4129) 

Note spacing 

Opposing stems. Stem tips are now padded a little such that opposing stems on 
adjacent staves cannot abut: instead, the staves are forced further apart. (STEAM-
7490) 

Percussion 

Percussion legends. Percussion legends are now positioned inside rehearsal 
marks and tempo text. (STEAM-7602) 

Playback templates (STEAM-7760) 

Playback templates describe the rules that Dorico uses to allocate sounds from 
VST instruments or MIDI devices to instruments in your project. Until now, there 
has been only a single default playback template, which uses instances of HALion 
Sonic SE and the included HALion Symphonic Orchestra and HALion Sonic SE 
library content to play back your projects. It has been possible to override the use 
of this default playback template by making your own assignment of sounds or VST 
instruments; thereafter, Dorico would no longer assign sounds on its own, until you 
instructed it to apply the default playback template. 

Default playback templates. The new entry-level Dorico Elements product does not 
include the HALion Symphonic Orchestra sounds, and hence relies entirely on the 
HALion Sonic SE library content for default playback. As such, Dorico Pro now 
provides two default playback templates: HSSE + HSO (Pro) and HSSE only 
(Elements). The former is equivalent to the default playback template in Dorico 1.x; 
the latter does not use any sounds from HALion Symphonic Orchestra, and is 
equivalent to the default playback template in Dorico Elements. 

To specify which playback template Dorico should use for newly-created projects, 
a new Default playback template option has been added to the Play section of 
the General page of Preferences. 

To choose a different playback template for the current project, or to apply one of 

the default playback templates, choose Play ▸ Playback Template, and choose 
the desired playback template from the list. 
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Adding further playback templates. Dorico will load data for further playback 
templates from subfolders within folders called PluginPresetLibraries and 
PlaybackTemplateGenerators in system-wide or user-specific application data 
folders, i.e. 

§ Windows: %PROGRAMDATA%\Steinberg\Dorico 2 (system-wide) 
or %APPDATA%\Steinberg\Dorico 2 (user-specific) 

§ macOS: /Library/Application Support/Steinberg/Dorico 2 (system-wide) or 
~/Library/Application Support/Steinberg/Dorico 2 (user-specific) 

The name of each subfolder within these folders determines the name of the 
playback template as it will appear in Dorico. 

The two files loaded from the named subfolder within PluginPresetLibraries are: 

§ presets.xml: a list of all of the presets or patches in a virtual instrument’s library, 
defining for each the name of its corresponding expression map or percussion 
map. 

§ presets_for_instruments.xml: a list of all of the default instrument types that 
can be created in Dorico and the preset that should be loaded by default for 
that instrument. 

The named subfolder within PlaybackTemplateGenerators must contain a file 
called playbacktemplategen.xml, which specifies the UID of the VST instrument 
to load, the PluginPresetLibraries data to use, and some other parameters (such 
as the number of MIDI channels provided by the instrument, the number of audio 
outputs, and default send levels for the effects channel). The subfolder may also 
optionally contain a .pluginstate file that should be loaded into the VST instrument 
when it is instantiated. 

It is not intended that end users should need to create their own playback 
templates using these data files: this information is provided for the benefit of third 
party VST instrument and sound library developers. 

Playback 

Note shortening. The Play as % of written duration option on the Timing page of 
Playback Options has been constrained so that longer notes, or music played at a 
slow tempo, are not excessively shortened. A note will be shortened to the 
specified amount if it is a quarter note (crotchet) or shorter in duration; if it is longer 
than a quarter note, then only the final quarter note portion of the note will be 
shortened. This quarter note portion also takes the prevailing tempo into account, 
so the maximum amount by which a note can be shortened is the defined 
percentage of a quarter note at 120 quarters per minute. (STEAM-7984) 
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Move playhead to selection. A new default key command, Alt+P, has been added 
to move the playhead to the position of the first selected item. This is very useful 
when working with attached video, as it allows you to see which frame 
corresponds to a specific rhythmic position. (STEAM-5811) 

Playing techniques 

Hiding playing techniques. It is sometimes desirable to hide playing techniques, for 
example to avoid unnecessary repetition. To hide a playing technique, select it and 
activate the new Hidden property in the Playing Techniques group in Properties. 
A signpost will appear, which can itself be hidden from view if desired by choosing 
View ▸ Signposts ▸ Playing Techniques. (STEAM-7646) 

Erasing the background behind text-based playing techniques. When a playing 
technique crosses a barline, it can be useful to erase the background around the 
playing technique to make it easier to read. To allow this, a new Erase 
background property has been added to the Playing Techniques group in the 
Properties panel, which appears only in Engrave mode. The default amount of 
padding around the playing technique is determined by the new Padding around 
playing technique with erased background option on the Playing Techniques 
page of Engraving Options, and can be overridden for an individual playing 
technique by activating the Erasure padding properties. (STEAM-7669) 

Horizontal offset for text-based techniques. A new option Horizontal offset for text 
playing techniques has been added to the Playing Techniques page of Engraving 
Options. This is set to zero spaces by default, but if for example you want text-
based playing techniques to appear slightly to the left of the note or chord to which 
they apply, set this new option to a small negative value. (STEAM-7709) 

Repeats 

Repeats playback. Dorico now has limited support for playback of repeat 
structures: repeat endings and repeat barlines are now played back. The bar/beat 
and time display in the Transport reflects the current position in the repeat 
structure. Audio and MIDI export both also include repeats. (STEAM-3910) 

Shift+R popover. A new popover has been added with the default key command 
Shift+R for the creation of repeat endings, single- and multi-stem tremolos, 
rhythmic slash regions and bar repeat regions. The terms that can be input into the 
popover are as follows: (STEAM-7636) 

Single-stem tremolos 
/ \ 1 One stroke 
// \\ 2 Two strokes 
/// \\\ 3 Three strokes 
//// \\\\ 4 Four strokes 
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z zonstem  Z on stem 
0 clear  Remove tremolo 

Multi-stem tremolos 
/ \ 1 One stroke 
// \\ 2 Two strokes 
/// \\\ 3 Three strokes 
//// \\\\ 4 Four strokes 
0 clear  Remove tremolo 
Repeat endings 
end ending  New repeat ending 
add   Add segment to existing repeat ending 
Rhythmic slash region 
slash   New rhythmic slash region 
Bar repeat region 
% %1  Repeat last bar 
%2   Repeat last two bars 
%4   Repeat last four bars 
%1,2   Repeat last bar, group in twos 
%1,4   Repeat last bar, group in fours 

Tempo 

Editing the beat unit of existing tempos. A new Beat unit property has been added 
to the Tempo group of the Properties panel, allowing you to edit the beat unit of a 
selected tempo item: for example, to change the note value shown in a metronome 
mark from a quarter note (crotchet) to a dotted quarter note, simply select the 
tempo item, then activate the rhythm dot button shown in the row of buttons. 
(STEAM-7462) 

Tempo range separator. By default, Dorico uses an en dash to separate the lower 
and upper numbers shown for a tempo range. If you would prefer to use a different 
separator, you can set the new Separator for tempo range option on the Tempo 
page of Engraving Options to Custom separator, and then specify exactly which 
characters should be used. (STEAM-7708) 

Metronome marks. The spacing of rhythm dots relative to notes in metronome 
marks has been improved. (STEAM-7473) 

Text 

Borders. A new Border property has been added to the Text group in the 
Properties panel. When activated, a border will be drawn around the text item, with 
the default thickness of the border determined by the new Border thickness 
option on the Text page of Engraving Options. The thickness of the border can 
also be overridden for an individual text item by activating the new Border 
thickness property, which appears only in Engrave mode. The default padding 
between the text and its border is determined by the Padding around text with 
erased background value on the Text page of Engraving Options, and can be 
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overridden by setting the Erasure padding properties in the Text group of the 
Properties panel. (STEAM-7658) 

Collision avoidance. A new Avoid collisions property has been added to the Text 
group in the Properties panel, allowing you to override the default setting for 
collision avoidance as specified on the Text page of Engraving Options. When the 
property is unset, text is drawn at its default vertical position above or below the 
staff, and no other item will avoid colliding with it: you can tweak its position in 
Engrave mode in the usual manner. (STEAM-7670) 

Furthermore, a new Minimum distance from protruding items option has been 
added to the Text page of Engraving Options, allowing you to specify how much 
padding should be left between a text item and another item (such as a note or 
slur) that protrudes from the staff; previously, the text item would have been 
allowed to touch the protruding item. (STEAM-7696) 

Tokens for page numbers. The following new tokens have been added in Dorico 2, 
and can be entered in text frames: 

§ {@pageCount@} – the total number of pages in the layout 
§ {@flowPage@} – the number of this page within the current flow, counting from 

1 for the first page of the flow (i.e. not the displayed page number) 
§ {@flowPageCount@} – the total number of pages in the current flow 
§ {@flownFirstPage@} – the displayed page number of the page on which flow n 

begins; insert the number of the flow as shown in the Flows panel in Setup 
mode in place of n, e.g. {@flow5FirstPage@}. 

The {@flowPage@} and {@flowPageCount@} tokens only consider the flow that 
is active at the beginning of the first system of the music frame closest to the top 
left-hand corner of the page on which the tokens are used. (STEAM-7755, 
STEAM-7766) 

Paragraph Styles dialog. The default selection in the Engrave ▸ Paragraph Styles 
dialog is initialized from the first selected text item, if any. (STEAM-7972) 

User interface 

Visual refresh. The look and feel of the Dorico project window has been subtly 
updated, reducing the width and height of panels by a small amount where 
possible to ensure that the maximum amount of space is available for the music 
area. The Hub window has also been redesigned: more space is devoted to the list 
of recent projects, and the lists of blog posts and videos, of which only one was 
previously visible at once, are now both shown in order to make it easier to see 
when new content is available. 
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Multiple selections in the Players and Layouts panels. When you need to perform 
an operation on multiple selected players or layouts, for example to assign multiple 
players to a flow, when clicking on a checkbox to include or exclude the player or 
layout, you can then hold Shift and click on another checkbox, which will include or 
exclude all players or layouts in the range between the first and second click. 
(STEAM-7287) 

Multiple selections in the Edit Percussion Kit dialog. A number of operations in the 
Edit Percussion Kit dialog can now operate on multiple selected instruments in 
the dialog, including changing voice direction and index, setting the size of gaps 
between instruments on adjacent grid lines, removing or deleting instruments from 
the kit, and changing the order of instruments in the kit. (STEAM-7289) 

Undo and redo. Edit ▸ Undo and Redo now bring the selection into view if 
necessary. A new preference, Follow selection on undo and redo, has been 
added to the Editing section of the General page of Preferences, which can be 
switched off to restore the behavior to that of Dorico 1.2.10. (STEAM-7564, 
STEAM-8026) 

Updating from Dorico 1.x 

When you first run Dorico Pro 2, your existing user data and preferences from 
Dorico 1.x are automatically migrated to the new update. This includes: key 
commands; preferences; the list of recent projects; saved default layout, notation, 
engraving, playback and note input options; and any saved default tonality systems, 
paragraph styles, and character styles. Furthermore, any VST 2.x plug-ins that you 
added to the vst2whitelist.txt file for Dorico 1.x will automatically be added to the 
whitelist for Dorico 2. (STEAM-7664) 
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Issues resolved 
ID # Component Issue 

STEAM-4241 
STEAM-4294 

Accidentals 
Changing the pitch of a grace note before a barline no longer incorrectly considers the 
accidental state of the following bar. 

STEAM-5539 Accidentals 
When using the Second Viennese School accidental system, grace notes are now 
considered correctly when determining whether or not to repeat an accidental. 

STEAM-7472 Accidentals 
Under some rare circumstances, it was not possible to change the pitch of a note that had 
been respelled in a part layout; this problem has now been resolved. 

STEAM-7910 Accidentals The enharmonic spelling of rising chromatic passages in minor keys has been improved. 

STEAM-7905 Audio export 
A progress dialog now appears during audio export on both Windows and Mac, and 
accurately reflects the actual progress through the operation. 

STEAM-7047 Barlines 
Dashed barlines to show subdivisions in additive time signatures no longer fail to appear if 
the bar is split across a break. 

STEAM-7077 Barlines 
Creating a time signature change at a dashed subdivision no longer causes previous 
dashed subdivisions to appear in the wrong place. 

STEAM-7134 Barlines 
Repeat barlines no longer draw incorrectly at the end of a system if they coincide with a 
key change to a key with no accidentals. 

STEAM-7301 Barlines 
Inserting a barline at the same rhythmic position as an existing dashed subdivision in an 
aggregate time signature now works correctly. 

STEAM-4846 Beaming 
Dragging the end of a stemlet now works correctly when the stemlet belongs to an implicit 
rest. 

STEAM-7562 
Chord 
symbols 

Toggling the Show as mode property on and back off again for a diminished half/whole 
scale chord symbol no longer results in the chord symbol showing as a different chord. 

STEAM-7504 
Collision 
avoidance 

Mysterious problems where deleting an item can cause an item in another bar to move 
vertically in galley view have been resolved. 

STEAM-7716 
Collision 
avoidance 

The extent of items is now always correctly considered for collision avoidance when editing 
an item that is graphically wider than its rhythmic position and duration. 

STEAM-7018 Cues If a cue abuts the end of a flow, a redundant restorative clef change is no longer created. 

STEAM-7029 Cues Cues are now automatically removed if they are invalid under more circumstances. 

STEAM-7505 Cues 
Edits that affect where instrument changes occur no longer sometimes cause system 
objects to disappear if a cue is located within the range affected by the edit. 

STEAM-5064 Dynamics Edit ▸ Reset Appearance and Reset Position now work correctly on dynamics. 

STEAM-6385 Dynamics 
If a dynamic has a color set via Properties, it now shows correctly in the blue linked color 
rather than the orange selection color when another dynamic in the group is selected. 

STEAM-6651 Dynamics 
A series of gradual dynamics interspersed with immediate dynamics and shown as a single 
hairpin no longer draws incorrectly in galley view. 
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ID # Component Issue 

STEAM-7328 Dynamics 
Under rare circumstances, edits that affect the vertical placement of gradual dynamics 
would not be propagated to all music frame chains; this has now been resolved. 

STEAM-7742 Dynamics 
Adding an immediate dynamic to the end of an existing group of dynamics now correctly 
extends the length of the flow if required. 

STEAM-7782 Dynamics Hairpins that extend precisely to the end of the flow now draw correctly in galley view. 

STEAM-7257 Fingering 
The Indicate shift to next note and Shift direction properties for string fingering shift 
indications are now correctly reset when pasting notes onto non-string instruments. 

STEAM-7384 Fingering 
Deferred fingering substitution now works correctly on notes and chords that are tied 
between different voices. 

STEAM-7409 Fingering 
Under some circumstances, fingering substitutions could fail to draw as slurs, despite the 
options or properties; this problem has been resolved.  

STEAM-7217 Flows 
Duplicate Flow and Split Flow now correctly copy the flow info for the original flow into 
the new one. 

STEAM-7697 
Graphics 
export 

Imported graphics are now exported at a much higher resolution when exporting PDF files. 

STEAM-7767 
Graphics 
export 

It is no longer possible to change focus to another project in the middle of a graphics 
export operation, which could cause graphics from the wrong project to be exported. 

STEAM-7848 
Holds and 
pauses 

In some circumstances, a fermata on a bar rest could be incorrectly positioned at the start 
of the bar, rather than over the bar rest; this has now been resolved. 

STEAM-4826 
Key 
signatures 

Adding a clef change at the same location as a key change now always correctly updates 
the cancellation naturals, if shown. 

STEAM-7618 
Key 
signatures 

Changing the current tonality system in the Tonality System section of the Key 
Signatures panel now always takes effect correctly. 

STEAM-7628 
Key 
signatures 

Creating a key signature from the Used in this flow section now always uses the tonality 
system selected in the Tonality System section of the Key Signatures panel. 

STEAM-7796 
Key 
signatures 

The tonality system shown in the panel in Write mode is now always used when creating a 
key signature. 

STEAM-7374 Localization 
Changing the keyboard language on the Key Commands page of Preferences now works 
correctly when there are unsaved changes to the key commands in the current language. 

STEAM-7563 Localization 
The default key command for Write ▸ Respell ▸ Respell Using Note Above now works 
correctly in the German-language version (Windows only). 

STEAM-7361 Lyrics 
Using the left or right arrow key to navigate off the first or last lyric no longer incorrectly 
loses any edit made to that lyric. 

STEAM-6243 
Multi-bar 
rests 

Multi-bar rests are now broken by both the starts and ends of repeat ending segments. 

STEAM-7065 
Multi-bar 
rests 

The presence of a system break no longer sometimes causes the width of a multi-bar rest 
at the end of the previous system to change. 
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ID # Component Issue 

STEAM-7423 
MusicXML 
export 

Exporting with Export layouts as separate files switched off now correctly finds and uses 
the most appropriate full score layout for the selected flow. 

STEAM-6118 
MusicXML 
import 

Imported MusicXML and MIDI files now respect the Default text font family preference. 

STEAM-7391 
MusicXML 
import 

A problem that could cause Dorico to crash when importing MusicXML files from 
PDFtoMusic Pro has been resolved. 

STEAM-7957 Navigation 
Moving the selection between non-note items with the arrow keys no longer sometimes 
causes the selection to jump unexpectedly to the start of the previous system in page view 
or backwards several bars in galley view. 

STEAM-7487 
Notation 
options 

The Overlapping notes in the same voice in a kit or grid presentation option on the 
Percussion page of Notation Options now works correctly for chords split by a barline. 

STEAM-5499 Note input Inputting the first note in a new voice between rhythmic grid positions now works correctly. 

STEAM-5555 Note input 

Under some circumstances, extending the duration of a note that ends within a tuplet in 
Insert mode could cause other later notes in the same voice to be deleted; this problem 
has now been resolved. 

STEAM-6546 Note input 
Changing the voice of a selection of notes no longer sometimes causes the notes to be 
moved to a different rhythmic position if items already exist in the destination voice. 

STEAM-7411 Note input 
Pasting a selection beginning with implicit rests immediately followed by a tuplet no longer 
causes some non-note items to be offset incorrectly. 

STEAM-7411 Note input 
Pasting a selection that begins with implicit rests followed by a tuplet no longer results in 
non-note items being pasted into incorrect rhythmic positions. 

STEAM-7425 Note input 
Pasting a selection including tuplets into an existing passage with identical tuplets with 
chord mode active no longer sometimes results in some of the material being offset. 

STEAM-7449 Note input 
Pasting material of the same duration as an existing tuplet will now remove the tuplet, 
instead of pasting the material into the tuplet. 

STEAM-7561 Note input 
Undoing the creation of a tuplet no longer sometimes fails if a non-note item is located 
within the range of the added tuplet. 

STEAM-7609 Note input 
Making a selection on a percussion kit using the five-line staff presentation type now 
correctly uses the extent of the selection from all components, rather than only the first. 

STEAM-7657 Note input 
Copy and paste for instruments within a percussion kit using the single-line instruments 
presentation type now works more reliably. 

STEAM-7748 Note input 
Dorico no longer hangs when attempting to shorten with Shift+Alt+left arrow a note or 
rest of the minimum valid duration (1024th note). 

STEAM-7880 Note input 
Moving the caret after priming a new voice no longer causes a voice with the wrong 
direction to be created. 

STEAM-7939 Note input 
When multiple items are selected, hitting Return now starts note input, rather than 
attempting to edit the first selected item. 

STEAM-7490 Notes 
Stems in opposing directions on adjacent staves are padded by a small amount to prevent 
them from becoming so close they may appear to touch. 
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ID # Component Issue 

STEAM-7508 Notes 
Rhythm dots on stemless notes– i.e. a whole note (semibreve) or longer – in down-stem 
voices are no longer incorrectly snapped to spaces in the wrong direction. 

STEAM-7436 Ornaments 
Glissandos between invalid note positions (for example, two notes of the same pitch tied 
together) are now correctly automatically removed. 

STEAM-7568 Pedal lines 
Making a selection on the lower or left-hand staff of a piano instrument and then pasting 
the pedal line now works correctly. 

STEAM-7684 Pedal lines 
Pedal lines that span multiple systems no longer sometimes disappear when making 
unrelated edits. 

STEAM-7487 Percussion 
The notation option to remove overlaps for percussion kits did not always work correctly for 
a chord split across a barline; this problem has now been resolved. 

STEAM-7568 
Piano 
pedaling 

Pasting piano pedal lines now works correctly when selecting something in the left-hand 
staff of the piano. 

STEAM-7516 Players 
It is no longer incorrectly possible to use the Shift+I key command to add an additional 
instrument to a section player. 

STEAM-7290 Print mode 
The chosen page range for printing is correctly preserved when leaving and re-entering 
Print mode. 

STEAM-7323 Print mode 
Choosing a page range that does not include the first page of the layout, then switching 
back to All pages now updates the print preview correctly. 

STEAM-7764 Print mode Cancelling a print or graphics export operation no longer sometimes causes a crash 

STEAM-7199 
Repeat 
endings 

It is now possible to create a repeat ending when an explicit bar rest is selected. 

STEAM-6760 Rests 
Setting a property on an implicit rest no longer causes all other selected items to be 
removed from the selection. 

STEAM-7012 Rests 
The Bar rest design in long time signatures option on the Rests page of Notation 
Options now works correctly when adding bars to the end of the flow. 

STEAM-7545 Rests 
The presence of local time signatures on one staff no longer prevents multi-bar rests from 
appearing in the other staff if they line up with the bars of the global time signature. 

STEAM-5501 Setup mode 
Expanding a group in the Players panel will no longer cause the cards for the players within 
the group to be truncated incorrectly when the group is partially scrolled out of view. 

STEAM-5817 Tempo 
Tempo items with dx/dy offsets are no longer sometimes positioned inconsistently in 
relation to other items. 

STEAM-7473 Tempo 
The spacing of rhythm dots in metronome marks has been improved, particularly for 
durations shorter than a quarter note (crotchet). 

STEAM-7706 Tempo 
When the font style for gradual tempo items is set to absolute rather than staff-relative size, 
the dashed or dotted continuation line is now correctly drawn at absolute size too. 

STEAM-7723 Tempo 
Gradual tempo items with no drawn continuation line now draw a handle and attachment 
line at the right-hand end in Write mode. 
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STEAM-6777 Text 
System-attached text can now be edited correctly if the top staff of the system is hidden 
because it is empty. 

STEAM-7536 Text Right-aligned text is no longer sometimes slightly truncated within a text frame. 

STEAM-7578 Ties 
When considering ties for the purposes of collision avoidance, the inside of the tie was 
incorrectly being considered instead of the outside. This problem has now been resolved. 

STEAM-7075 
Time 
signatures 

Under rare circumstances, notes and rests could be grouped incorrectly in irregular time 
signatures within an aggregate time signature; this problem has been resolved. 

STEAM-7587 
Time 
signatures 

Undoing the addition of a local time signature to an individual instrument now always 
correctly reinstates the previous global time signature. 

STEAM-7561 Tuplets 
Undoing the creation of a tuplet where a non-note item’s position overlaps with the new 
tuplet will no longer go wrong. 

STEAM-3656 User interface 
Drop-down menus in dialogs and panels no longer sometimes appear on the wrong 
display when running Dorico with multiple displays (Windows only). 

STEAM-7510 User interface 
Focus no longer gets lost after clicking the buttons in the note input toolbox, resulting in 
key commands not working until you click in the score (Windows only). 

STEAM-7637 User interface 
It is now possible to assign key commands to both File ▸Import ▸Flows and File 
▸Export ▸Flows. 

STEAM-7647 User interface 
The various annotations that appear at the top and bottom of the caret are now correctly 
scaled relative to the current staff size. 

STEAM-7663 User interface 
Maximizing the document window while a modeless dialog was open could in rare 
circumstances lead to Dorico hanging; this has now been resolved (Mac only). 
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Known issues and solutions 

Frequently asked questions 
Answers to frequently asked questions about Dorico can be found online in the 
Dorico forum. 

Knowledge base 
For the latest information about issues and solutions you may encounter when 
running Dorico, please consult the Knowledge Base. 

Entering the eLicenser Activation Code (Mac only) 
When you first run Dorico and are prompted to enter your Activation Code, you 
may find that after you have successfully activated your Soft-eLicenser, you must 
quit and restart Dorico for the application to detect that it is fully licensed. 

Key commands to transpose notes by an octave (Windows only) 
The Intel Graphics Adaptor drivers used by many Windows computers define a 
default key command to flip the screen by 90, 180 and 270 degrees via a shortcut 
Ctrl+Alt+up/down/left/right arrows. 

Ctrl+Alt+up/down option conflicts with the key commands in Dorico note input for 
transposing notes by an octave. 

For information about how to disable the default Intel Graphics Adaptor key 
command, consult the Knowledge Base. 


