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Introduction

Thank you very much for purchasing Dorico.
We are delighted that you have chosen Steinberg's scoring application and hope that you will
enjoy using it for years to come.
Dorico is a next-generation application for producing beautiful sheet music, whether you are a
composer, arranger, music engraver, publisher, instrumentalist, teacher, or student. Whether
you want to print your music or share it in a digital format, Dorico is the most sophisticated
program available.
Like all of Steinberg's products, Dorico has been designed from the ground up by a team of
musicians who understand your needs and who are dedicated to producing a tool that is both
easy to learn and use, but also capable of results of the highest quality. Dorico also integrates
with your existing workflow and can import and export files in a variety of formats.
Dorico thinks about music the same way a human musician does and has a deeper
understanding of the elements of music and musical performance than other scoring
applications. Its unique design allows an unprecedented degree of flexibility, in music input and
editing, in score layout, in rhythmic freedom, and many other areas besides.
Most sincerely yours,
Your Steinberg Dorico Team

Platform-Independent Documentation
The documentation applies to the operating systems Windows and macOS.
Features and settings that are specific to one of these platforms are clearly indicated. In all other
cases, the descriptions and procedures in the documentation are valid for Windows and macOS.
Some points to consider:
●

The screenshots are taken from Windows.

●

Some functions that are available on the File menu on Windows can be found in the
program name menu on macOS.

Usage of musical terms
This documentation uses American terminology for musical items throughout the
documentation.
The following table lists all the notes and notations that have different names in American and
British English:
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American Name

British Name

Double whole note

Breve

Whole note

Semibreve

Half note

Minim

Quarter note

Crotchet

Eighth note

Quaver

Sixteenth note

Semiquaver

Thirty-second note

Demisemiquaver

Sixty-fourth note

Hemidemisemiquaver

Hundred twenty-eighth note

Semihemidemisemiquaver

Two hundred fifty-sixth note

Demisemihemidemisemiquaver

Staff

Stave

Bar/Measure

Bar

NOTE
This documentation only uses “bar”.

Conventions
In our documentation, we use typographical and markup elements to structure information.

Typographical Elements
The following typographical elements mark the following purposes.
PREREQUISITE
Requires you to complete an action or to fulfill a condition before starting a
procedure.
PROCEDURE
Lists the steps that you must take to achieve a specific result.
IMPORTANT
Informs you about issues that might affect the system, the connected hardware, or
that might bring a risk of data loss.
NOTE
Informs you about issues that you should consider.
EXAMPLE
Provides you with an example.
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RESULT
Shows the result of the procedure.
AFTER COMPLETING THIS TASK
Informs you about actions or tasks that you can perform after completing the
procedure.
RELATED LINKS
Lists related topics that you can find in this documentation.

Markup
Elements of the user interface are highlighted throughout the documentation.
Names of menus, options, functions, dialogs, windows, and so on, are highlighted in bold.
EXAMPLE
To open Notation Options in Write mode, choose Write > Notation Options.
If bold text is separated by a greater-than symbol, this indicates a sequence of different menus
to open.
EXAMPLE
Choose Engrave > Engraving Options.
File names and folder paths are highlighted in Courier typeface.

Key Commands
Many of the default key commands, also known as keyboard shortcuts, use modifier keys, some
of which are different depending on the operating system.
For example, the default key command for Undo is Ctrl-Z on Windows and Cmd-Z on macOS.
When key commands with modifier keys are described in this manual, they are shown with the
Windows modifier key first, in the following way:
●

Windows modifier key/macOS modifier key-key

EXAMPLE
Ctrl/Cmd-Z means: press Ctrl on Windows or Cmd on macOS, then press Z.

Key commands in Dorico
The default key commands in Dorico depend on your keyboard layout.
If you move the mouse over a tool or a function, the information in brackets shows the key
command that is used to activate or deactivate a tool or a function.
You can also do one of the following:
●

Open the Dorico Key Commands window that provides an overview of all available key
commands.

●

Search for key commands of specific functions or menu items in the Preferences dialog. In
this dialog, you can also assign new key commands or change default key commands.

RELATED LINKS
Accessing the interactive Dorico key commands map on page 11
Searching for the key commands of functions on page 11
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Accessing the interactive Dorico key commands map
The Dorico Key Commands map shows a virtual computer keyboard. Depending on the selected
keyboard layout that you have selected in the Preferences dialog, it highlights the keys that
have been assigned key commands. Below the virtual computer keyboard, all key commands are
listed, divided into global and mode-specific groups.
To access the Dorico Key Commands map, do one of the following:
●

Select Help > Key Commands.

●

Select Edit > Preferences, and in the Preferences dialog, in the Key Commands section,
click Print Summary.

The Dorico Key Commands map opens in a web browser. You have the following options:
●

To see the available key commands, select a context. The context of a key command is the
mode in which it can be used. Key commands that have a global context work in all modes.

●

To highlight the keys that you can press in combination with the modifier key to form a key
command, press a modifier key on your computer keyboard, such as Shift. You can also
press more than one modifier key. The virtual computer keyboard shows the highlighted
keys and displays on each key to which functions it is assigned.
NOTE
You can also use the mouse to select a modifier key on the virtual computer keyboard.

●

To search for a specific key command, enter one or multiple words in the search input
field.

●

To get an overview of all available key commands, browse the key commands that are
listed below the virtual keyboard. The key commands are listed according to the context in
which they can be used.

Searching for the key commands of functions
You can search for key commands that are assigned to functions or menu items in Dorico.
NOTE
You can also search for functions in the Dorico Key Commands window.

PROCEDURE
1.

Select Edit > Preferences.

2.

In the Key Commands section, in the Search field, enter the name of a function.
The entries that are listed below are filtered according to the words that you enter.

3.

Expand an entry and select the function for which you want to see the key command.

RESULT
If the function has a key command, it is shown in the Assigned key commands display.
RELATED LINKS
Accessing the interactive Dorico key commands map on page 11
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Changing the keyboard layout
You can change the keyboard layout in Dorico. This allows you to use the pre-defined key
commands for your language.
PROCEDURE
1.

Open Preferences by choosing Edit > Preferences.

2.

Select a different keyboard layout from the Keyboard language menu in the Key
Commands section.

3.

Click Apply.

RESULT
You can immediately use the available key commands for your language.

Assigning key commands
You can assign key commands to Dorico functions that have no key commands assigned. You
can also change existing key commands.
PROCEDURE
1.

Select Edit > Preferences.

2.

In the Key Commands section, search for the name of a function and select it.

3.

Optional: Press Remove Key Command if the function is already assigned a key
command.
NOTE
If you assign a new key command without removing an existing one, you can use either
key command.

4.

Click in the New key command input field.

5.

On your computer keyboard, press the key command that you want to assign.

6.

Click Add Key Command.
The key command is shown in the Assigned key commands display.

7.

Click Apply.

RESULT
You can immediately use the assigned key command.
RELATED LINKS
Searching for the key commands of functions on page 11
Resetting key commands on page 13

Removing key commands
You can remove assigned key commands from a function.
PROCEDURE
1.

Select Edit > Preferences.

2.

In the Key Commands section, search for the name of a function and select it.

3.

Click Remove Key Command.

4.

Click Apply.
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RESULT
The key command is removed from the selected function.
RELATED LINKS
Searching for the key commands of functions on page 11
Resetting key commands on page 13

Resetting key commands
You can reset all key commands to their defaults.
PROCEDURE
1.

Select Edit > Preferences.

2.

In the Key Commands section, click Reset Key Commands.

3.

Click OK.

RESULT
All custom key commands are deleted and the default key commands are reinstated.

How you can reach us
On the Help menu you find items linking to additional information.
The menu contains links to various Steinberg web pages. Selecting one of these menu items
automatically launches your web browser and opens the page. On these pages, you can find
support and compatibility information, answers to frequently asked questions, information about
updates and other Steinberg products, etc.
This requires that you have a web browser installed on your computer and a working Internet
connection.
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This chapter helps you to get started with Dorico.
When you start Dorico for the first time, we recommend that you open one of the templates first
to have a look at the user interface and the functions that Dorico provides before you start your
own projects. You are welcome to skip this part and explore the program for yourself.
The following sections inform you about the following topics:
●

Overview of the most important workspaces

●

Setting up a new project

●

Writing your music and adding notation items to your score

●

Laying out and formatting pages

●

Playing back what you created

●

Printing and exporting

Getting around
The following sections give you an overview of the user interface and introduce you to how
Dorico is structured.

Opening a template
Before you start your own project, we recommend that you familiarize yourself with the user
interface of Dorico. To prepare for this, open one of the templates that are provided with the
program.
PREREQUISITE
You have started Dorico. The Hub is open.
PROCEDURE
1.

In the Hub, select one of the listed template groups, for example the Choral and Vocal
templates.

2.

Select one of the listed templates.
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3.

Click New from Template.

RESULT
The template opens.
AFTER COMPLETING THIS TASK
Proceed to the following sections that provide a quick overview of the user interface and that
introduce you to the main functions of the program.
RELATED LINKS
Hub on page 33

Quick tour of the user interface
The user interface of Dorico consists of different modes that represent different phases in the
workflow of preparing a score.
The user interface has a structure that is the same in each of the application’s modes. There is
always a large area for editing your music in the center of the project window. In every mode,
there are collapsible panels on the left, right, and bottom of the project window, depending on
which mode you are using. The contents of these panels change according to the selected mode.
When you open the template, the first view shows the project window in Write mode:

15

First steps
Getting around

The project window contains the following areas:

Toolbar
The toolbar is located at the top of the project window.

On the left side of the toolbar, the modes are displayed. By activating a mode, you change the
workspace and the available panels. The active mode is highlighted in a different color. In the
middle of the toolbar, layout options allow you to switch between the different layouts in your
project and to show/hide panels and tabs. On the right side of the toolbar, you can open a Mixer
and activate basic transport controls that, among other functions, allow you to play back and
record your music.

Music Area
The music area is the main part of the project window in Setup, Write, and Engrave modes where
you set up, input, edit and format your music. In Play mode, this area is called event display, in
which every note is displayed as an event. In Print mode, this area is called print preview area,
which shows a preview of what is going to be printed or exported as a graphic.
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The music area displays the scores or the instrumental parts that you create. On top of the
music area you can activate several layouts in tabs and switch between them. Layouts in Dorico
allow you to show different presentations of your music. If you have a full score with different
instrumental parts, such as a violin part and a bassoon part, you can switch between the full
score layout and the layouts of each part. To save space on the screen or to focus on a specific
layout, you can hide the tabs.

Toolboxes
In Write mode, there are additional columns at the left and right edges of the project window.
These are called toolboxes.

Notes toolbox in Write mode

Notations toolbox in Write mode
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The notes toolbox on the left allows you to activate or deactivate various note input tools. The
notations toolbox on the right provides tools that allow you to create and edit other notations,
such as clefs, key signatures, time signatures, etc.

Panels
Dorico provides panels with various functions in all modes. When you open the template, there is
a panel on the left of the music area. This is the notes panel in Write mode.

Notes panel in Write mode

The notes panel contains all the durations, accidentals, slurs, and articulations that are most
commonly used when inputting notes.

Status Bar
At the bottom of the project window, a status bar allows you to select different views and page
arrangements for the music area.

RELATED LINKS
Functions of the modes on page 18
User interface on page 33

Functions of the modes
Modes represent different phases in the workflow of preparing a score.
By activating a mode, you change the workspace and the available panels.

Setup Mode
In Setup mode, you can create players, groups of players, and assign instruments to them.
You can define different layouts for your project that you can print or export independently.
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For example, you can print or export a layout for the full score and separate layouts for each
instrumental part.

Write Mode
In Write mode, you can input your music. The available toolboxes and panels allow you to input
all the notes and notation items that are most commonly used.

Engrave Mode
In Engrave mode, you can make fine adjustments to the music that you input in Write mode and
determine how the pages of your project are laid out.

Play Mode
In Play mode, you can assign virtual instruments and effects for playback to instruments and
playing techniques. You can make adjustments to how individual notes are played back in order
to produce a more realistic performance.

Print Mode
In Print mode, you can print your layouts or export them as graphic files.

Hiding/restoring panels
You can hide and show individual or multiple panels. This is useful if you want to see more of the
music area, for example.
PROCEDURE
●

Do one of the following:
●

To show/hide the left panel, click its disclosure arrow or select Window > Show Left
Panel.

●

To show/hide the right panel, click its disclosure arrow or select Window > Show
Right Panel.

●

To show/hide the bottom panel, click its disclosure arrow or select Window > Show
Bottom Panel.

●

To show/hide all panels, click Hide/Restore Panels
Restore Panels.

or select Window > Hide/

RESULT
If you hide all active panels, the button changes its look and displays which panels are hidden.
For example, the following button indicates that all panels were active and are now hidden:

.

Working with tabs and windows
Dorico enables you to set up your workspace according to your working style.
Dorico allows you to open multiple tabs to display multiple layouts in the same project within the
same window. You can also open the same project in several windows.
RELATED LINKS
Setting up your workspace on page 46

Opening a new tab
You can open a new tab to display a different view or layout within the same project window.
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Each tab can contain a separate layout or an additional view of a layout that is already open in
another tab or window. Whenever you open a new tab, you are prompted to select a layout that
you want to display in the tab.
You can find the tabs at the top of the music area, below the toolbar. If you do not see the tabs,
click Show Tabs

in the toolbar.

PROCEDURE
●

To open a new tab, do one of the following:
●

Press Ctrl/Cmd-T.

●

To the right of the tabs, click New Tab

.

RESULT
A new tab opens that shows several icons at the top and a list of layouts at the bottom.

AFTER COMPLETING THIS TASK
You can click one of the icons or select a layout from the list at the bottom. Alternatively, you can
click Select Layout on the toolbar and choose one of the layouts from the menu. The layout that
you choose opens in the active tab.

Opening a new window
You can open another window for the same project.
This may be useful if you want to see and work on multiple layouts at the same time. You can
also open multiple project windows to show different modes of the same project.
PROCEDURE
●

Do one of the following:
●

Press Ctrl/Cmd-Shift-T.

●

Select Window > New Window.

RESULT
A duplicate of the window opens. It contains the same tabs and the same view options as the
original window.

20

First steps
Starting a new project
RELATED LINKS
Opening multiple project windows on page 49

Starting a new project
After getting a first impression of the Dorico user interface you may want to get started with
inputting your own music. In this section, you learn how to set up a new project.
PREREQUISITE
NOTE
All inputs that are made and the images that are used to accompany the steps in this chapter
are intended merely to be helpful examples. Therefore, there is no need to make the exact same
entries in order to get the depicted results.
Close the template without saving. The Hub reopens.
PROCEDURE
●

Do one of the following:
●

Select New Empty Project.

●

Press Ctrl/Cmd-N.

RESULT
A new project window opens.

Whenever you start a new project without selecting a specific project template, Setup mode is
activated. This allows you to specify players and assign instruments right from the start. The
area in the middle, the project start area, which becomes the music area once you have added a
player, allows you to start your project with different types of players. On the right, the Layouts
panel shows a Full score entry. This entry is available in every new project. At the bottom of the
window is the Flows panel where you can specify separate spans of music for your project.
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AFTER COMPLETING THIS TASK
Start your project by adding an individual player or by adding a section player and assign an
instrument. You are free to assign any kind of instrument. In this chapter, only one piano player
is added as an example.
RELATED LINKS
Windows on page 36
Flows on page 32

Adding a solo player
In this section, you learn how to add a player and assign an instrument.
PREREQUISITE
You have started a new project. You are in Setup mode.
PROCEDURE
1.

Click Add Solo Player.

This adds an empty-handed player on the Players panel.
2.

In the popover, select an instrument.
NOTE
For this example, select the piano player.
TIP

3.

●

You can use the search field of the popover and start entering the name of the
instrument. The list automatically filters the names while you type.

●

You can also open the popover by clicking the plus symbol
to the right of the
added empty-handed player. Alternatively, you can right-click the player and select
Add Instrument to Player.

Click Add.

RESULT
You have added your first player. In the music area, the required piano staves including their
respective clefs are displayed.
AFTER COMPLETING THIS TASK
Save your project.
NOTE
You can save your project at any time.
Optionally, you can now edit the project title or add more players.
The following sections help you to create flows and layouts. If you want to start composing, you
can skip those sections.
RELATED LINKS
Writing music on page 24

22

First steps
Starting a new project
Adding solo players on page 59

Creating a flow
Flows are separate spans of music within your project, for example, movements or songs. In this
section, you learn how to create a flow.
PREREQUISITE
You have added at least one player. You are in Setup mode.
Every project contains at least one flow, and by default, every layout includes the music from
every flow in your project. If you create a new flow in Dorico, the following happens:
PROCEDURE
●

On the Flows panel, click Add Flow

.

RESULT
All existing players are assigned to the new flow. The new flow is automatically added to all
existing full score and part layouts.
AFTER COMPLETING THIS TASK
Rename the flow if required.
Optionally, deactivate the checkboxes of the players that you want to exclude from the flow in
the Players panel.
Optionally, deactivate the checkboxes of the layouts from which you want to exclude the flow in
the Layouts panel.
RELATED LINKS
Renaming flows in Setup mode on page 81
Creating flows on page 80
Creating a layout on page 23

Creating a layout
Layouts define how music for one or more players in one or more flows is presented, including
page size, margins, staff size, etc. In this section, you learn how to create a new layout.
PREREQUISITE
You have added at least one player and one flow. You are in Setup mode.
Several layouts are often used in ensembles with multiple players, where each player may
require a layout of the individual instrumental part. Dorico automatically creates a full score
layout that contains all players and all flows as well as individual part layouts that each contain
one player and all flows. If you require a different combination of players and flows, for example,
a part containing the music for two players, you can create your own layouts, as follows:
PROCEDURE
●

On the Layouts panel, click Add Instrumental Part Layout

RESULT
An empty part is created on the Layouts panel.
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AFTER COMPLETING THIS TASK
Double-click the empty part to give it a name. Optionally, select the flows that you want to assign
to the layout in the Flows panel. Activate the checkboxes of the players that you want to assign
to the layout in the Players panel.
RELATED LINKS
Creating layouts on page 83

Writing music
Once you have set up your project, you can start writing music.
In Write mode, you can input notes and insert other notations into your score.
TIP
Throughout Dorico, most tasks can be accomplished using only your computer's keyboard. You
do not need to use the mouse or touchpad. Learning key commands allows you to use Dorico
most efficiently. The fastest way to input music is using a MIDI keyboard. If you do not have a
MIDI keyboard, you can use your computer's keyboard. Of course, you can still use the mouse or
touchpad if you want.
In the following sections, you learn how to input notes and notation items.

Inputting your first notes
In this section, you learn how to input notes. You can start inputting notes without having to first
add a time signature or key signature.
PREREQUISITE
●

You have set up your MIDI keyboard.
NOTE
If you have not set up a MIDI keyboard yet, you can start inputting notes with the
computer keyboard.

●

You have added a piano player in Setup mode.

●

Write mode is active.

PROCEDURE
1.

Select the rest that was automatically inserted next to the clef when you added a solo
player.

2.

Do one of the following:
●

Press Shift-N or Return to activate note input.

●

Double-click the rest.

The caret is displayed.
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3.

Select one of the durations on the notes panel.
NOTE
By default, Dorico selects a quarter note for you.

4.

Start playing notes on the MIDI keyboard, or press A, B, C, D, E, F, G on the computer
keyboard to input the corresponding pitches.
If you want higher or lower pitch for the note that Dorico inputs for you, you can force the
octave above by pressing the respective key command.

RESULT
The following is an example of input notes:

RELATED LINKS
Key commands in Dorico on page 10

Adding a time signature
In this section, you learn how to add a time signature at the beginning of the staff. You can add a
time signature before or after inputting a melody.
PREREQUISITE
Press Esc to deactivate the caret.
PROCEDURE
1.

Select the first note on the staff.

2.

Press Shift-M.
This opens a small popover on top of the staff.

3.

Enter a typical time signature, such as 3/4.
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4.

Press Enter.

RESULT

The time signature is automatically inserted to the left of the note, and the required bar lines are
automatically inserted at the correct positions. If you want to insert a key signature, proceed to
the next section.

Adding a key signature
In this section, you learn how to add a key signature. You can add a key signature at any
rhythmic position on the staff.
When you start a new project from scratch, by default, there is no key signature shown.
Dependent on the kind of music you are writing, the key signature might be taken to mean C
major or an open key with no specific tonal center. In any case, you can change key anywhere
on the staff. To add a different key signature at the beginning of the staff, for example, D major,
proceed as follows:
PROCEDURE
1.

Select the first note on the staff.

2.

Press Shift-K.
This opens a small popover on top of the staff.

3.

Enter a key signature. If you want to enter D major, enter an uppercase D.
For D minor, enter a lowercase d.

4.

Press Enter.
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RESULT

The key signature is inserted between the clef and the time signature. Dorico automatically adds
accidentals where necessary.

Inputting your first chord
In this section, you learn how to input a chord with the computer keyboard, using chord mode. If
you want to use a MIDI keyboard instead, you can input the chord with your keyboard, and you
do not need to use chord mode. Dorico automatically inputs the correct notes for you.
PREREQUISITE
Select the last note or rest on the staff, and press Return. This shows the caret.
PROCEDURE
1.

Do one of the following:
●

Press Q.

●

In the notes toolbox, activate Chords .

The caret now shows a plus sign at the top:

2.

Optional: Select one of the durations on the notes panel.

3.

Input the notes that should form a chord by pressing keys from A to G, one after the other.
For example, for a C major chord, press C, E, and G.
By default, Dorico adds each new note above the previous note. You can change the
octave by pressing the respective key command.
The following example shows a possible result:

4.

Press Space to advance the caret to the next note position and continue with the next
chord.
Dorico expects further chord input until you deactivate it.

5.

Optional: To deactivate chord input, press Q or deactivate Chords.
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RELATED LINKS
Key commands in Dorico on page 10
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The following sections give you an overview of the design philosophy as well as concepts on
which Dorico is based.
We recommend that you familiarize yourself with these concepts as these are often returned to
throughout the documentation.

Design philosophy
If you are experienced with other scoring applications and are interested in learning more
about deep design considerations for scoring programs, you may find the following discussion
illuminating, but everybody can safely skip it.
Dorico has a forward-thinking design that is led by musical concepts rather than computational
convenience, and this provides many benefits.

Higher-level concepts
In most graphically-orientated scoring applications, the highest-level concept is the staff or the
instrument definition that creates a staff or staves. When setting up your full score, you start
by adding the correct number of staves, and you are immediately forced into making decisions
about the layout. This means that you must know in advance whether two flutes share a staff
or have their own individual staves, or whether there should be two trumpets or three. Many
of these decisions have significant effects throughout the process of inputting, editing, and
producing individual instrumental parts.
Typically, every system of a score must contain the same number of staves, even if some are
hidden on particular systems. This requires the user to manage common conventions for
themselves, such as multiple players of the same instrument sharing staves. This can be timeconsuming and is naturally error-prone.
Dorico is designed to conform more closely to how music is performed in the real world and to
make the score a flexible expression of the practical choices that go into a musical performance,
rather than to make the musical performance subservient to the way the score was initially
prepared.
To that end, the highest-level concept of Dorico is the group of human musicians that performs
a score. A score can be written for one or more groups, for example, a double choir or an
orchestra plus off-stage chamber ensemble, etc. Each group includes one or more players which
correspond to the humans who play one or more instruments. Players may either be individuals
who can play more than one instrument, for example, an oboist doubling cor anglais, or groups
in which everyone plays only one instrument, for example, eight desks of violinists.
The actual music that is played by the group in your score belongs to one or more flows. A flow
is any span of music that stands alone, for example, a whole song, a movement of a sonata or
symphony, a number in a musical show, or even a short scale or exercise. Players may or may
not have any music to play in a given flow. For example, all the brass players may be omitted
from the slow movement of a classical symphony, or certain players may have nothing to do
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in some cues in a movie score. This is no problem as you can combine players in flows in any
combination.
Dorico provides several benefits. Chief among them is its ability to produce different score
layouts that share the same musical content. For example, you can create a conductor's score
with as many instruments as possible condensed onto a smaller number of staves, a full score
with each player's music on separate staves, and an instrumental part containing only the music
belonging to a specific player.
One crucial difference between Dorico and other scoring applications is that the musical content
exists independently of the score layout in which it is viewed.

Key musical concepts
In order to work efficiently with Dorico, it is important to understand the conceptual model of the
program.
The model is closely based on the practical considerations of how music is written and performed
by real humans.

Projects
A project is an individual document that you create within Dorico.
A project may contain many separate pieces of music, from very short to very long, written for
any combination of instruments and in different layouts.

Modes
Modes represent different phases in the workflow of preparing a score.
In the project window, the following modes are available:
Setup
In this mode, you can set up the players and instruments that are played in the
project. You can create and manage flows and set up layouts.
Write
In this mode, you can write your music. You can insert notes and rests, key
signatures, time signatures, and idiomatic notations.
Engrave
In this mode, you have access to fine-grain controls that allow you to manipulate and
modify every item in the project. You can also manage pages, master pages, layouts,
and formats.
Play
In this mode, you can set up your project for playback. You can assign VST
instruments, adjust the mix, apply automation, and optimize note data.
Print
In this mode, you can define different print jobs, such as printing full conductors
scores, study scores, individual parts, etc. For every print job, you can specify options
for page size and duplex printing. You can also manage other output, such as
exports to various file types, such as PNG.
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Instruments
In Dorico, an instrument is an individual musical instrument, such as a piano, a flute, or a violin.
Dorico has a database of information about properties of each instrument. These include
the playable range, common and uncommon playing techniques, notational conventions,
transposition properties, tunings, clef, number of staves, type of staff, etc. You can edit and
extend these properties according to your needs.
NOTE
Similar instruments, such as guitars with different tunings, horns in different transpositions, or
the instruments in the strings family can share common properties. This enables you to edit the
data for many instruments at the same time.

RELATED LINKS
Instruments on page 68

Players
In Dorico, a player can be an individual musician or several musicians.
In detail, a player may represent the following:
●

A solo player, which is an individual musician who can play one or more instruments, for
example, a clarinettist who doubles on alto saxophone or a percussionist who plays bass
drum, clash cymbals, and triangle.

●

A section player, which represents multiple musicians who all play the same instrument,
for example, eight desks of violins or the soprano section in a mixed voice choir.

NOTE
Section players cannot double on different instruments, but they can play divisi. This means that
they can be divided into smaller units, which is commonly required for strings.

Groups
A group represents a collection of musicians that should be considered together, such as a choir,
orchestra, or a chamber ensemble.
In a typical project, there may be only one group that contains all of the defined players, but in
order to allow easy separation of forces in larger-scale works, you can define as many groups as
needed. It may also be necessary to assign players to these groups for the purposes of, among
other things, properly bracketing and labeling their staves in the conductor's score.
EXAMPLE
A work for double choir and organ can define the two choirs as separate groups. This allows each
choir to have its own label in addition to the labels for each sectional player (soprano, alto, tenor,
bass) within the choir.
In a complex work, such as Elliott Carter's “A Symphony of Three Orchestras”, each of the
orchestras can be defined as a separate group.
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Flows
Flows are separate spans of music that are completely independent in musical content.
A flow can be, for example, a song, a movement in a sonata or symphony, a number in a stage
musical, or a short scale or sight-reading exercise of only a few bars in length. A single project
can contain one or more flows.
A flow may contain music for any combination of players. For example, in a Classical-period
symphony, it is not uncommon for the brass players to be tacet in the second, slow movement,
so the flow for the second movement would simply not contain any brass players. In a set of cues
for a movie, for example, specific players may not be required in particular cues, and so each
flow would contain only those players who have anything to play.
NOTE
Correct assignment of players to flows allows Dorico, for example, to generate tacet sheets
automatically for individual instrumental parts.

Layouts
Layouts define how music for one or more players in one or more flows is presented, including
page size, margins, staff size, etc.
Layouts combine musical content that is represented by flows with rules for page layout and
music engraving. You can have layouts for one or more players drawn from one or more flows.
You can use the layouts to produce paginated music notation that can be printed or exported in
various formats.
A typical project for an ensemble of multiple players contains several layouts. For example, a
work for string quartet in three movements contains four solo players – two violins, one viola,
and one cello – and three flows, one for each movement. Such a project may require five layouts:
●

Four layouts each containing the music from all three flows for one of the solo players,
that is, the individual instrumental parts

●

One layout containing the music from all three flows and all four players, that is, the full
score

Each layout provides independent control over practically every aspect of the visual appearance
of the music, including independent staff size, note spacing, and system formatting.
Each layout may also have independent page layout properties, such as page size, margins,
running headers, and footers. These can be defined as master pages and then be applied freely
to left- or right-hand pages or to specific pages in a layout, for example, the first or last page.
Flow frames define where music appears on each page. To each flow frame, one or more flows
is assigned in a manner analogous to how flows of text are assigned to text frames in desktop
publishing applications. Dorico also provides for text frames, which allow the presentation of
blocks of text, such as prefatory material, critical commentary, block lyrics, and so on.
NOTE
The page layout features of Dorico allow you to have multiple flow frames and text frames on the
same page. This enables you to combine music from multiple flows on the same page.
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The user interface of Dorico is designed to be as unobtrusive as possible while keeping all of the
important tools at your fingertips.
You can explore the interface without doing any damage to your project. You can always undo
any inadvertent edits or close your project without saving it.

Hub
When you start Dorico, the Hub opens. The Hub keeps you up-to-date with the latest information
and assists you with organizing your projects. It consists of the News section and the Projects
section.

News
Displays Steinberg news.
Read More
Links you to a page on the Steinberg website with more detailed information about
the news and tutorials topic that you selected.
User Forum
Links you to the user forum on the Steinberg website.
Downloads
Links you to the download page on the Steinberg website.
Knowledge Base
Links you to the Knowledge Base on the Steinberg website.
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Recent Projects
Shows a list of the projects that you worked on last. You can scroll through the list
with the Up Arrow/Down Arrow keys or with the mouse.
Orchestral, Band, Chamber, Choral and Vocal, Solo
Allow you to choose between different categories of project templates.
New Empty Project
Starts a new project.
Open Other
Allows you to open any other project file in your file system.
Open Selected Project
Opens the file that you selected in the Recent Projects list. Alternatively, you can
double-click the file name or select the file and press Enter.
Project Templates only: New from Template
Creates a new project from the project template that you selected in the list of a
project template category.

Starting new projects
Dorico provides several ways to start new projects.
PROCEDURE
●

Do one of the following:
●

In the Hub, select New Empty Project.

●

Press Ctrl/Cmd-N.
NOTE
This option is also available in the project window.

●

Select File > New.
NOTE
This option is also available in the project window.

RESULT
A new project window opens.

Starting new projects from project templates
Dorico provides multiple project templates that you can use to start a new project.
PROCEDURE
1.

2.

In the Hub, select one of the project template categories:
●

Orchestral

●

Band

●

Chamber

●

Choral and Vocal

●

Solo

From the listed project templates of the selected category, select a project template.
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3.

Click New from Template.

RESULT
The project template opens in a new project window.
NOTE
Alternatively, you can also select File > New from Template. Then select a project template from
the listed project template categories.

Selecting recent projects
You can open a project on which you recently worked.
PROCEDURE
●

Do one the following:
●

In the Recent Projects list, select a file name and press the Up Arrow and Down
Arrow keys to scroll through the list of file names. To open a file, press Enter.

●

In the Recent Projects list, double-click a project file name.

●

In the Recent Projects list, select a project file name and click Open Selected
Project.

●

Click File > Open Recent and select one of the project file names.
NOTE
This option is also available in the project window.

Opening other files
You can open other Dorico projects that are not listed in the Recent Projects list, or you can
import MusicXML or MIDI files.
PROCEDURE
1.

Click Open Other.
NOTE
Alternatively, you can also select File > Open > Button > anotherbutton.

2.

In the dialog that opens, browse for the file that you want to open.
TIP
To open several files at the same time, press Ctrl/Cmd and select the files, or press Shift
and select a range of files.

3.

Click Open.

RESULT
If you import a MusicXML or a MIDI file, Dorico creates a new project file from the MusicXML or
MIDI content. You can save this file as a default Dorico project.
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Windows
Dorico provides a project window and floating windows.

Project Window
You can open multiple project windows for the same or for different projects. The project window
consists of several areas.

Project window

1

Toolbar
Allows you to access the modes, the workspace options, the Mixer, and the basic transport
options.

2

Tab bar
Shows the tabs that are open in Setup, Write, and Engrave mode. If you split the music
area and open several tabs, tab groups are shown.

3

Project start area/music area/event display/print preview area
When you set up a new empty project, this area in Setup, Write, and Engrave mode shows
the project start area that allows you to add your first players. Once you have added a
player or an ensemble, this area becomes the music area that shows the score or parts of
the score that you set up, write, edit, and format. In Play mode, this area contains an event
display that shows the effects of manipulating the playback of your score. In Print mode,
the print preview area shows a preview of how your project is going to be printed onto
paper or exported into a graphic file format.

4

Panel
The panels provide notes and notations that you need to create and edit your music.

5

Toolbox
Write mode only: Provides access to various notation items that you can use for your
music.

6

Status bar
Allows you to choose a different view and page arrangement of the music area.
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Floating Windows
Dorico allows you to open floating windows, such as the Mixer and the Transport windows.
These can be hidden and shown independent of the mode that is selected in the main window.
The following options open floating windows:
Show Mixer
Opens the Mixer window.
Show Transport Bar
Opens the Transport window.
RELATED LINKS
Opening multiple project windows on page 49

Toolbar
The toolbar allows you to access the modes and workspace options as well as the Mixer and the
transport options.
The toolbar is always available independent of the mode or tool that you are using. If you must
hide the toolbar for a specific reason, click the disclosure arrow on top of the toolbar.
The toolbar consists of the following items:

1

Modes
Selectable workspaces in the project window that represent different phases in the
workflow of preparing a score.

2

Workspace options
Provide options that allow you to select different layouts and to change the working
environment.

3

Show Mixer

button

Opens/Closes the Mixer window.
4

Basic transport options
Allow to you quickly access the main transport functions.

RELATED LINKS
Workspace options on page 37
Basic transport options on page 38

Workspace options
The workspace options in the middle of the toolbar provide options that allow you to select
different layouts and to change the working environment.
Select Layout

Allows you to switch back and forth between layouts.
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Show Tabs
Shows/Hides the tab bar above the music area.
Hide/Restore Panels
Shows/Hides all open panels.

Basic transport options
The transport options to the right of the toolbar provide the main transport functions of Dorico.
Show Transport Bar
Opens the Transport window.
Time display

Shows the position of the playhead in the score. The time display shows the units in
the following order: bars, beats, 16th notes, 120ths of a 16th note.
Rewind to Beginning
Sets the playhead to the beginning of your score.
Play
Starts/Stops playback.
Activate Project
Shows which project is activated for playback.

Tab bar
The tab bar in Dorico allows you to display different layouts within the same project window.
Each tab may contain a separate layout, or an additional view of a layout that is already open in
another tab or window. Each tab is labeled with the name of the selected layout.
You find the tabs aligned on the tab bar at the top of the music area, directly below the toolbar.
If the tabs are not visible, click Show Tabs on the toolbar. If Show Tabs is activated, the tabs are
always displayed, even if only a single tab is open.
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Project start area
In Setup, Write, and Engrave mode, the project start area is displayed in the middle of the project
window when you set up a new empty project.

The project start area shows cards that allow you to add your first players. To add players, click
one of the cards:
Add Solo Player
Adds an individual player to whom you can assign one or more instruments.
Add Section Player
Adds a player that represents multiple players who all play the same instrument.
Add Ensemble
Adds multiple players who play different instruments. The ensembles that you can
add represent standard combinations of musicians.
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Music area
In Setup, Write, and Engrave mode, the music area shows the editable score.

Music area showing a sample of a score

The music area can be displayed in several views. The music area tab bar allows you to open
several layouts from your project and switch between them. The scroll bars to the right and to
the bottom of the music area allow you to scroll within the layout.
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Print preview area
The print preview area in Print mode shows a preview of what is going to be printed or exported
as a graphic.

Print preview area displaying a score as a booklet

In the print preview area, you can scroll through the pages that are shown, but you cannot edit
your layouts. If you want to make changes, you must switch to Setup, Write, or Engrave mode.
If you select multiple layouts to be printed as part of the same print job, the print preview area
only displays the first layout. If you want to show the expected page arrangement for each layout
in the print preview, you must check each layout individually before you start printing.
RELATED LINKS
Project window in Print mode on page 175
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Panels
The panels in the project window provide the notes, notations, and functions that you need to set
up, write, edit, and format your music.

Notes panel (left), Notations panel (right), and properties panel (bottom) in Write mode.

Every mode in Dorico has its own particular panels.
Modes and their panels
Mode

Left Panel

Right Panel

Bottom Panel

Setup

Players

Layouts

Flows

Write

Notes

Notations

Properties

Engrave

Formatting

Pages

Properties

Play

Tracks

VST Instruments

n/a

Print

Layouts

Print options

n/a

Some panels are displayed by default. You can hide and show each panel individually or all of
them at the same time. For a full description of each panel, refer to the documentation of the
individual modes.
RELATED LINKS
Modes on page 30
Hiding panels on page 49
Hiding individual panels on page 50
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Toolboxes
Toolboxes are available in Write mode. They provide the tools that allow you to input and modify
notes and notation items and to determine what notation items are shown in the Notations
panel.
RELATED LINKS
Notes toolbox on page 88
Notations toolbox on page 91

Status bar
The status bar at the bottom of the project window allows you to choose a different view and
page arrangement in the music area.
NOTE
The status bar is only available in Setup, Write, and Engrave modes. Not all options are available
in all modes.

Status bar in Write and Setup mode

1

Rhythmic Grid Resolution selector
Allows you to change the resolution of the rhythmic grid, which is used for inserting notes
and notations in Write mode.

2

Disclosure arrow
Allows you to show/hide the bottom panel in Setup, Write, and Engrave mode.

3

Selection tools
Allow you to switch between using the Marquee Tool and the Hand Tool in Write, and
Engrave mode.

4

View type selector
Allows you to select one of the provided view types for the music area in Setup and Write
mode.

5

Page arrangement options
Allow you to choose between different horizontal and vertical arrangements of either
individual pages or pairs of pages, which are called spreads.

6

Zoom options
Allow you to change the zoom factor of the music area and its musical contents.

RELATED LINKS
Rhythmic grid on page 99
View types on page 44
Selection tools on page 44
Page arrangements for page view on page 45
Zoom options on page 45
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Selection tools
Dorico allows you to choose a selection tool that you can use to select or move items within the
music area.
Pressing Shift in combination with the chosen selection tool allows you to instantly use the other
tool.
You can use the following tools:
Marquee Tool
Allows you to click and drag a rectangle to select multiple notes and notations.
Hand Tool
Allows you to click and move the view within the music area.
RELATED LINKS
Selecting multiple notes and notations on page 44
Moving the view on page 44

Selecting multiple notes and notations
You can select notes and notations using the Marquee Tool.
PROCEDURE
1.

In the status bar, activate Marquee Tool

2.

In the music area, click at the position where you want the selection to start and keep the
mouse button pressed.

3.

Drag to the position where you want the selection to end.

.

A gray rectangle is shown to indicate which notes and notations will be selected.
4.

Release the mouse button.

RESULT
All notes and notations that you marked are selected.

Moving the view
You can move the view within the music area in Write mode and in Engrave mode.
PROCEDURE
1.

On the status bar, activate Hand Tool

2.

Click anywhere within the view and keep the mouse button pressed.

.

Once you move the mouse pointer, it changes into a hand symbol.
3.

Move the view.

4.

Release the mouse button.

View types
Dorico provides different ways to view your layouts.
Dorico saves your chosen view type for each layout, so you only need to set it once. You can
change the default view types for new projects in the preferences.
The following view types are available:
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Galley View
Lays out your music on a single continuous system. It also shows all of the
instruments that are included in the active layout and flow.
This view type is most useful during the process of inputting the music as it allows
you to focus on the musical content of your project.
NOTE
Note spacing in galley view is unjustified, which means that it is neither expanded
nor contracted to fit the width of a page or a music frame. However, changes that
are made to note spacing in galley view also apply to page view.
Page View
Displays your layout paginated exactly as it appears when you print or export it.
This view type is useful if you want to view spreads or single pages. Spreads allow
you to work out page turns, because the performer only needs to turn the page at
the end of the right-hand page of a pair. Viewing single pages may be helpful if you
want to print the layout as a series of single pages. This may be necessary if you are
using, for example, a fan-fold or concertina approach, in which case the distinction
between left- and right-hand pages is insignificant.
RELATED LINKS
Preferences on page 51
Changing the view type of the music area on page 50
Page arrangements for page view on page 45

Page arrangements for page view
You can change the way pages are arranged for display in the music area.
Spreads Horizontally
Displays pages in pairs as two-page spreads, with each pair laid out from left to right
in a row.
Spreads Vertically
Displays pages in pairs as two-page spreads, with each pair laid out from top to
bottom in a column.
Single Pages Horizontally
Displays individual pages laid out from left to right.
Single Pages Vertically
Displays individual pages laid out from top to bottom.

Zoom options
You can change the size of notes and notations in the music area.
Zoom Out
Decreases the size of notes and notations in the music area.
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Set Zoom
Allows you to select one of the available zoom scaling factors. You can set a
permanent zoom factor in the preferences.
Zoom In
Increases the size of notes and notations in the music area.
RELATED LINKS
Preferences on page 51

Setting up your workspace
Dorico enables you to set up your workspace according to your working style.
Dorico allows you to open multiple tabs to display multiple layouts in the same project within the
same window. You can also open the same project in several windows.

Opening different views or layouts by using tabs
You can use tabs in order to display different views or layouts within the same project window.
Each tab can contain a separate layout or an additional view of a layout that is already open in
another tab or window. Whenever you open a new tab, you are prompted to select a layout that
you want to display in the tab.
You can find the tabs at the top of the music area, below the toolbar. If you do not see the tabs,
click Show Tabs

in the toolbar.

PROCEDURE
1.

Do one of the following:
●

Press Ctrl/Cmd-T.

●

To the right of the tabs, click New Tab

●

Select Window > New Tab.

.

A new tab opens that shows several icons at the top and a list of layouts at the bottom.

2.

Do one of the following:
●

Click one of the icons.

●

Select a layout from the list at the bottom.
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●

Click Select Layout on the toolbar and choose one of the layouts from the pop-up
menu.

RESULT
The layout that you choose opens in the active tab.

Creating tab groups
You can create tab groups that are vertically or horizontally split. This allows you to display
different layouts side by side or above one another.
You can also use this function to see an individual layout with a different view.
PROCEDURE
●

Select the tab of the layout that you want to move to a new tab group.
●

To create a new tab group that is vertically split from the original tab group and that
shows the layouts side by side, select Window > Vertical Split.

●

To create a new tab group that is horizontally split from the original tab group and
that shows the layouts above one another, select Window > Horizontal Split.

RESULT
The selected tab is moved to the new tab group.
RELATED LINKS
Moving tabs to another tab group on page 48

Closing individual tabs
You can close individual tabs of layouts that you no longer need.
PROCEDURE
●

To close individual tabs, do one of the following:
●

Select the tab of the layout that you want to close and press Ctrl/Cmd-W.

●

Hover the mouse over the tab and click the x icon.

●

Right-click the tab and from the context menu, select Close Tab.

NOTE
You cannot close the last tab in a window. If only one tab is open and you no longer want
to see the tabs, deactivate Show Tabs in the main toolbar. The tab is no longer displayed,
but the corresponding layout is still shown.

Closing multiple tabs
You can close all tabs but the selected tab.
PROCEDURE
1.

Right-click a tab.

2.

From the context menu, select Close Other Tabs.
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RESULT
The tabs and the corresponding layouts are closed.

Switching tabs
You can switch between different tabs to show different layouts in the music area.
PROCEDURE
●

To switch tabs, do one of the following:
●

Click the tab to which you want to switch.

●

Press Ctrl/Cmd-Tab to cycle through all open tabs in turn. Press Ctrl/Cmd-Shift-Tab
to cycle through all open tabs in reverse order.

●

Select Window > Next Tab/Previous Tab.

Changing the order of tabs
You can move tabs to a different position on the tab bar.
PROCEDURE
1.

Click and drag a tab to the new position.
The other tabs move to show where the dragged tab will be positioned.

2.

Release the mouse button.

Moving tabs to another tab group
You can move tabs to other tab groups.
NOTE
You can only move tabs to other tab groups if you have opened at least two tabs.

PROCEDURE
1.

Choose the tab that you want to move.

2.

Click and drag the tab to a blank space next to the target tab group and release the mouse
button.

Moving tabs to other windows
You can move tabs to another open window of the same project to show the corresponding
layouts in a new window.
NOTE
●

The layouts must belong to the same project. If you attempt to move a tab to a window of
a different project, a new window is created for the project to which the layout belongs.

●

You can only move tabs to other windows if you have opened at least two tabs.

PROCEDURE
●

Do one of the following:
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●

To create a new window of the same project with the tab inserted, click and drag a
tab horizontally to the left or right, away from the tab bar and release it.

●

To insert the tab into the tab bar of another window of the same project, click and
drag a tab onto the tab bar.

●

Select and right-click a tab and from the context menu, select Move Tab to New
Window.

●

Select a tab and click Window > Move Tab to New Window.

Opening multiple project windows
You can open multiple project windows for the same project.
This may be useful if you want to see and work on multiple layouts at the same time. You can
also open multiple project windows to show different modes of the same project.
Each window in a project is completely independent, so you can, for example, have one window
in Write mode and another in Engrave mode. During playback, all windows that belong to the
same project show the playback line and move the view to follow the playback.
PROCEDURE
●

Do one of the following:
●

Press Ctrl/Cmd-Shift-T.

●

Select Window > New Window.

RESULT
A duplicate of the window opens. It contains the same tabs and the same view options as the
original window.

Changing to full screen mode
To maximize the amount of screen estate available for your music, you can make any project
window cover the whole screen, hiding the desktop elements provided by your operating system,
for example, the task bar in Windows or the system menu bar and Dock in Mac OS.
PROCEDURE
●

Select View > Full Screen.

AFTER COMPLETING THIS TASK
To return to the default view, select View > Full Screen again.

Hiding panels
To be able to see more of your layouts, you can hide all of the surrounding panels from the main
window completely.
PROCEDURE
●

Do one of the following:
●

On the toolbar, click Hide/Restore Panels

●

Select Window > Hide/Restore Panels.
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RESULT
If you hide all active panels, the button changes its look and displays which panels are hidden.
For example, the following button indicates that all panels were active and are now hidden:

Hiding individual panels
To be able to see more of your layouts, you can hide individual panels from the main window.
NOTE
This applies equally to all modes.

PROCEDURE
●

Do one of the following:
●

To hide the left panel, click its disclosure arrow or select Window > Show Left
Panel.

●

To hide the right panel, click its disclosure arrow or select Window > Show Right
Panel.

●

To hide the bottom panel, click its disclosure arrow or select Window > Show
Bottom Panel.

Changing the view type of the music area
You can switch between several view types of the music area.
PROCEDURE
1.

In the status bar, click the view selector.

2.

Choose one of the view types from the list.

3.

●

Galley View

●

Page View

If you selected Page View, you can change the page arrangement using the page
arrangement controls:
●

Spreads Horizontally

●

Spreads Vertically

●

Single Pages Horizontally

●

Single Pages Vertically

RELATED LINKS
View types on page 44
Page arrangements for page view on page 45
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Preferences
In the Preferences dialog, you can make permanent settings for your workspace and define key
commands.
You can open the Preferences dialog in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Dorico > Preferences (OS X).

●

Choose Edit > Preferences (Windows).

RELATED LINKS
View types on page 44
Zoom options on page 45
Selection tools on page 44
Layout Options on page 85
Key Commands on page 10

General Preferences
General
Language
Allows you to select the language that is used for text in the user interface.
Preferred unit of measurement
Helps you to convert between the internal units and points that are used in Dorico
and your own preferred units. For example, the information box to the right of Space
size in the Page Setup section of the Layout Options dialog uses your selected unit
to help you determine the staff size.

Window
Theme
Allows you to switch to different program colors.
Open new windows maximized
If you activate this option and open a new window, the window is maximized to fit
the screen. This does not affect windows that are already open.
When the last window is closed
Allows you to specify what happens when you close the last project window.

View
Default zoom
Allows you to determine the zoom scaling factor that is used when you create a new
project.
Default view type
Allows you to select the view type for new projects.

Files
Show complete path for recent files
If you activate this option, the paths for recently used files are displayed in the Hub
and on the File menu together with the file names.
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Editing
Enable note input using the mouse
If you activate this option, the Select tool in the notes toolbox is activated when
you open a saved or new project. This allows you to use the mouse to input notes.
You can override this option temporarily by deactivating the Select tool.
Default click-drag behavior
Allows you to select the selection tool that you want to use by default in your
projects.

Play
Audio Device Setup
Opens the Device Setup dialog.
Open VST plug-in windows when opening projects
If you activate this option, the VST plug-in that you selected for your project opens in
a separate window when you open your project.
Suspend audio device in background
Allows other applications to play back via your audio hardware even though Dorico is
running. If you activate this option, the audio device that you use is suspended when
Dorico loses focus so that other applications may use it.
NOTE
Make sure that other audio applications accessing the audio hardware are set to
release the audio driver.
Enable MIDI input
If you activate this option, you can input notes using any MIDI input device, such as a
MIDI keyboard that is connected to your computer.
Play notes during note input and selection
If you activate this option, notes are played back in the following circumstances:
●

Selecting notes

●

Inputting notes

●

Navigating through selections using the arrow keys

●

Clicking the noteheads of individual notes or a stem in a chord

Follow playhead during playback
If you activate this option, the event display in Play mode advances when the
playhead reaches the right-hand side of the display. This keeps the music being
played in view.
Show playhead when stopped
If you activate this option, the playhead is displayed during playback and when
stopped. If you deactivate this option, the playhead is only displayed during
playback.
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Key Commands
Most of the main menus in Dorico have key commands for certain menu items. In addition, there
are numerous other Dorico functions that can be performed by pressings.
In the Key Commands section of the Preferences dialog, you can customize existing key
commands according to your needs and also add commands for many menu items and functions
that have no key command assigned.
Search
Allows you to search for menu items and functions to view, change, or add key
commands.
Assigned key commands
Shows if the selected menu item or function has a key command.
Keyboard language
Allows you to select the language of your keyboard.
New key command
Allows you to input a new key command by pressing the respective keys on your
computer keyboard.
Remove Key Command
Removes a key command from the selected menu item or function.
Add Key Command
Activates a key command that you have input for a function.
Reset Key Commands
Returns to the default key commands provided by Dorico.
Print Summary
Opens the Dorico Key Commands tool which shows the available key commands for
your keyboard layout.
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In Setup mode, you can determine the players and instruments for your project. You can also
create and manage flows and set up layouts.

Project window in setup mode
The project window in Setup mode contains the default toolbar, the music area, and the status
bar. It provides panels with all the tools and functions that allow you to create players and assign
instruments as well as to specify the layouts and flows for your score.
You can open Setup mode in the following ways:
●

Click Setup on the toolbar

●

Choose Window > Setup

●

Press Ctrl/Cmd-1

Panels in Setup mode

The following panels are available:
1

Players
Lists the players, instruments, and groups in your project.

2

Flows
Shows the flows that are created for your project.
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3

Layouts
Lists the layouts that are created for players.

If you select or edit items on a panel, the panel and the selected item are highlighted in a
different color. On each of the panels, you can activate/deactivate each player, layout, or flow to
flexibly determine the following:
●

The players that take part in a flow
IMPORTANT
If you exclude a player from a flow, any notes you have already input for that player in that
flow are deleted.

●

The players that you want to show or print in an instrumental part or a full score layout

●

The flows that you want to show or print in instrumental parts or full score layouts

To verify that all the players and flows that you selected are shown in a layout, select the layout in
the layout selector.

Players panel
The Players panel lists the players, instruments, and groups in your project.
If the Players panel is not visible, do one of the following:
●

Click the disclosure button on the left edge of the main window.

●

Select Window > Show Left Panel.

Players panel in Setup mode

The Players panel lists all the groups, players, and ensembles in your project as cards. Each
player card shows the following:

1

Disclosure arrow
Expands/Collapses the player card.

2

Player type
Shows if the player is a solo player

3

or a section player

.

Player name
Shows the name of the player. Dorico automatically adds the names of the assigned
instruments to the player name. If required, you can rename the player.
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4

Add instruments icon
Opens a popover from which you can select an instrument for the player.

5

Instrument list
If the player card is expanded, this shows all instruments that are assigned to the player.
If you move the mouse over an instrument name, an arrow
open a context menu with further options.

appears that allows you to

At the bottom of the Players panel, the following options are available:
Add Solo Player
Adds an individual player to your project.
NOTE
For each solo player that you add, Dorico automatically adds an instrumental part
layout to the Layouts panel.
Add Section Player
Adds a player to your project that represents multiple players who all play the same
instrument.
NOTE
For each section player that you add, Dorico automatically adds an instrumental part
layout to the Layouts panel.
Add Ensemble
Adds multiple players to your project that represent standard combinations of
musical instruments.
NOTE
If you add an ensemble, Dorico automatically adds instrumental part layouts for each
player in the ensemble to the Layouts panel.
Add Group
Adds a group to your project to which you can assign all types of players.
Delete Player
Deletes selected players or groups from the Players panel.
The order in which the players are listed is the default order in which they appear in a layout.
You can change the player order for each individual layout in the layout options. In the Layout
Options dialog, select the Players category, and in the Players subcategory, activate Uses
custom player order and change the order of the listed players.
RELATED LINKS
Players on page 59
Layouts panel on page 57
Layout Options on page 85
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Layouts panel
The Layouts panel lists all the layouts for full score and instrumental parts.
If the Layouts panel is not visible, do one of the following:
●

Click the disclosure button on the right edge of the main window.

●

Select Window > Show Right Panel.

The Layouts panel lists the default full score layout and all the layouts that you created for your
project as cards. Each layout card shows the following:

1

Disclosure arrow
Expands/Collapses the layout card.

2

Layout type
Shows if the layout is a full score layout
score layout

3

, an instrumental part layout

, or a custom

.

Layout name
Shows the name of the layout. Dorico automatically adds default names depending on the
name of the instrument that is assigned to a player and on the type of layout that is added.
For example, if you assign a flute to a player, the instrumental part layout automatically
gets the same name. If you add an empty instrumental part layout, the layout name shows
Empty part and an incremental number if you add several empty part layouts.

4

Space size
Shows the space size between two staff lines in points.
NOTE
You can change the space size in the layout options.

5

Page size and orientation
Shows the width and height of the pages of a layout and their orientation (portrait or
landscape).

At the bottom of the Layouts panel, the following options are available:
Add Full Score Layout
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Adds a full score layout to your project. By default, every player and flow is
automatically included in the layout.
Add Instrumental Part Layout
Adds an empty instrumental part layout to your project. You can then add one or
multiple players to the layout. By default, a part layout contains all flows that are
created in your project.
Add Custom Score Layout
Adds a custom score layout that initially without players or flows.
Sort Layouts
Sorts all layouts on the Layouts panel according to their type in the following order:
full score layouts, instrumental part layouts, custom score layouts.
Layout Options
Opens the Layout Options dialog for one or multiple selected layouts.
Delete Layout
Deletes selected layouts from the Layouts panel.
RELATED LINKS
Layouts on page 83
Layout Options on page 85

Flows panel
The Flows panel shows all the flows that are created for your project.
If the Flows panel is not visible, do one of the following:
●

Click the disclosure button at the bottom of the main window.

●

Select Window > Show Bottom Panel.

The Flows panel shows the default flow and all the flows that you created for your project as
cards. Each flow card shows the following:
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1

Flow name
Shows the name of the flow. If you create multiple flows without renaming them, each
flow name shows a number that increments with each new flow that you create. The
number also indicates the position of the flow in a layout.

2

Flow number
Shows the number of the flow. The number increments with each new flow that you
create. The number also indicates the position of the flow in a layout.

To the right of the Flows panel, the following options are available:
Add Flow
Adds a new flow to your project. By default, every new flow is automatically included
in all layouts, and every player is added to the new flow.
Notation Options
Opens the Notation Options dialog that provides multiple options that allow you to
make changes that affect the way music is notated for each flow.
Delete Flow
Deletes one or multiple selected flows.
RELATED LINKS
Flows on page 80
Notation Options on page 119

Players
Before you start writing music, you must specify the players that are playing one or multiple
instruments.
A player may be a solo player, which represents a single human being who can play one or more
instruments. For example, a clarinettist may double alto saxophone or bass clarinet. A player
may also be a sectional player, which represents multiple human beings, each of whom plays the
same instrument. For example, a violin section or the soprano section of a choir.
Dorico uses this knowledge about players and their instruments to assist you in producing a
practical score efficiently, for example, by making it very easy to handle instrument doubling,
divisi, and condensing music for multiple players onto a smaller number of staves.
If you add a player in Dorico, the following happens automatically:
●

An instrumental part layout is created

●

The player is added to any full score layouts that already exist. If no full score layouts
exists, a new full score layout is created

●

The player is included in all existing flows

Adding solo players
PREREQUISITE
The Players panel must be open.
PROCEDURE
1.

Do one of the following:
●

If you have started a new project, click Add Solo Player in the project start area.
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●

On the Players panel at the bottom, click Add Solo Player

.

This adds an empty-handed player on the Players panel.
2.

In the popover that opens, select an instrument:
●

In the search field, enter the first letters of the instrument to be played by the
player, then select it from the filtered list, and click Add.

●

Scroll through the popover list, select an instrument, and click Add.

●

Use Tab/Shift-Tab and the arrow keys on your computer keyboard to scroll through
the popover list. To select an instrument, press Enter.

TIP
If the popover is unavailable, click the plus symbol
to the right of the added emptyhanded player. Alternatively, you can right-click the player and select Add Instrument to
Player.

RESULT
The solo player is automatically named after the selected instrument.
RELATED LINKS
Player and instrument names on page 62
Changing player names on page 64
Project start area on page 39

Adding section players
PREREQUISITE
The Players panel must be open.
PROCEDURE
1.

Do one of the following:
●

If you have started a new project, click Add Section Player in the project start area.

●

On the Players panel at the bottom, click Add Section Player

.

This adds an empty-handed player on the Players panel.
2.

In the popover that opens, select an instrument:
●

In the search field, enter the first letters of the instrument to be played by the
player, then select it from the filtered list, and click Add.

●

Scroll through the popover list, select an instrument, and click Add.

●

Use Tab/Shift-Tab and the arrow keys on your computer keyboard to scroll through
the popover list. To select an instrument, press Enter.
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TIP
If the popover is unavailable, click the plus symbol
to the right of the added emptyhanded player. Alternatively, you can right-click the player and select Add Instrument to
Player.

RESULT
The section player is automatically named after the selected instrument.
RELATED LINKS
Player and instrument names on page 62
Changing player names on page 64
Project start area on page 39

Duplicating players
You can duplicate players. This adds another player of the same type.
PROCEDURE
1.

Right-click the player in the Players panel.

2.

Choose Duplicate Player from the context menu.

RESULT
A new player is added, with the same instrument as the original player. The original and new
players are automatically numbered to ensure their names are unique.
RELATED LINKS
Player and instrument names on page 62
Changing player names on page 64
Numbering instruments on page 61

Numbering instruments
According to convention, when there are multiple instruments of the same type in the same
score, they are each given a number so they can be identified.
For example, if there is only one flute in a score it is simply called Flute, but if there are three
flutes, they are called Flute 1, Flute 2, and Flute 3.
Dorico automatically numbers instruments when there are multiple instruments of the same
type in your project.

One violin with no number

Adding a second violin automatically generates
numbers for both violins
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NOTE
Instrument numbers are automatically generated for players if the following criteria are met:
●

Players are the same type: solo or section

●

Players have at least one instrument in common

●

Players are in the same group

●

Instrument names are the same

For example, if you have two flutes in your project, but one flute is a section player and the other
flute is a solo player, they are not numbered automatically.

RELATED LINKS
Player and instrument names on page 62
Changing instrument names on page 65

Player and instrument names
In Dorico, you can use three different names to refer to the same player in different contexts.
This allows you to show relevant information in different places in the score.
The three different names that relate to players and instruments are:
●

Player name

●

Layout name

●

Instrument name

You can change all of these names for individual players independently of other instruments of
the same type.
Each name is used in different places.
Player name
The player name is the name given to players in the Players panel. It is not used
in the score, instead you can use the player name as part of your own workflow,
independently of what instruments and players are called in staff labels and layout
names.
Player names are automatically generated when you add instruments.
Layout name
The layout name is the name for each layout in the Layouts panel. They are used at
the top of individual part layouts.
Layout names are automatically generated when you add instruments.
Layout names are linked to the player name until you change the layout name.
Instrument names
Instrument names are the names used in staff labels. This means that the
instrument label on each staff is relevant to the instrument currently being played by
that player, rather than listing all instruments that player is playing in the flow.
For example, if a clarinettist is doubling bass clarinet, the staff label where they
are playing clarinet automatically shows Clarinet, and the staff label automatically
shows Bass Clarinet where they are playing bass clarinet.
All instruments in Dorico come with a set of instrument names that you can change if
you want.
You can change the instrument names for individual instruments independently,
even if other players in the project are playing the same instrument.
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You can choose to save your changes to instrument names as default, so your names
are used whenever you add that instrument again in the project.
NOTE
Changing the default instruments names does not change the instrument names of
existing instruments of that type.

RELATED LINKS
Numbering instruments on page 61
Edit Instrument Names dialog on page 63

Edit Instrument Names dialog
You can change the instrument names used in staff labels in the Edit Instrument Names
dialog. You can specify singular and plural full instrument names, and singular and plural short
instrument names for each instrument.
The Edit Instrument Names dialog includes the following options:
Singular full name
The name shown in staff labels whenever full instrument names are shown, and the
staff contains a single player.
Singular short name
The name shown in staff labels whenever short instrument names are shown, and
the staff contains a single player.
Plural full name
The name shown in staff labels whenever full instrument names are shown, and the
staff contains multiple players.
Plural short name
The name shown in staff labels whenever short instrument names are shown, and
the staff contains multiple players.
Show transposition
It is common to see the transposition included in the name of transposing
instruments, such as Clarinet in B♭. You can choose when the transposition is shown
for the selected instrument from the following options:
●

Always

●

Follow Layout Options

●

Never

Save as default for instrument
Check the box to save your changes in the dialog as the default for any new
instruments of that type you add to the project.
RELATED LINKS
Changing instrument names on page 65

63

Setup mode
Players

Changing player names
You can change the player names of players, and reset renamed players to their default name.
NOTE
Player names are not used for staff labels in the score or for naming layouts, instead they are for
your own reference in Setup mode.
Staff labels use the name set for each instrument in the Edit Instrument Names dialog.

PROCEDURE
1.

Select the name of the player whose player name you want to change in the Players panel.

2.

Open the player name field in any of the following ways:
●

Double-click anywhere in the player card

●

Right-click in the player card and choose Rename from the context menu

3.

Enter a new name, or click Reset to Default to revert the name to the default name:

4.

Save your changes in any of the following ways:
●

Press Enter

●

Click anywhere outside of the layout name field

RESULT
The player name of the selected player is changed.
NOTE
This does not change the staff label that appears in the score. You can change the name used for
staff labels in the Edit Instrument Names dialog, and change the layout name for the names at
the top of parts.

RELATED LINKS
Edit Instrument Names dialog on page 63

Changing layout names
Layout names are used to identify individual layouts, for example, as the name at the top of
parts. You can change the layout names of players, and reset renamed players to their default
name.
NOTE
Layout names are not used for staff labels. Staff labels use the name set for each instrument in
the Edit Instrument Names dialog.

PROCEDURE
1.

Select the name of the player whose layout name you want to change in the Layouts
panel.

2.

Open the layout name field in any of the following ways:

3.

●

Double-click anywhere in the layout card

●

Right-click in the layout card and choose Rename from the context menu

Enter a new name, or click Reset to Default to revert the name to the player name:
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4.

Save your changes in any of the following ways:
●

Press Enter

●

Click anywhere outside of the layout name field

RESULT
The layout name of the selected player is changed, or reverted to the default name.
NOTE
This does not change the staff label that appears in the score. You can change the name used for
staff labels in the Edit Instrument Names dialog, and change the layout name for the names at
the top of parts.

RELATED LINKS
Edit Instrument Names dialog on page 63

Changing instrument names
Instrument names are used in staff labels. You can change the different instrument names used
for each instrument.
NOTE
Changing instrument names does not change the name shown at the top of part layouts. If you
want to change the name used at the top of part layouts, change the layout name.

PROCEDURE
1.

Click the disclosure arrow in the player card containing the instrument whose names you
want to change in the Players panel.
This expands the card to show the instruments held by the player.

2.

Hover the mouse pointer over the instrument whose names you want to change.
An arrow is shown at the right end of the instrument name.

3.

Click the arrow at the right end of the instrument name, and choose Edit Names from the
context menu.
The Edit Instrument Names dialog opens.

4.

5.

6.

Enter new names in any of the following instrument name fields in the Edit Instrument
Names dialog:
●

Singular full name

●

Singular short name

●

Plural full name

●

Plural short name

Optional: If you are changing the instrument names of a transposing instrument, choose
when the transposition is shown from the following options:
●

Always

●

Follow Layout Options

●

Never

Optional: Check the box beside Save as default for instrument to save your changes as
the new default for the selected instrument type.
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7.

Click OK.

RESULT
The instrument names for the selected instrument are changed.
If you did not save your changes as default, only the names of the selected instrument are
changed. Any instruments of the same type added later use the original default names.
If you saved your changes as default, any instruments of the same type added later use your new
instrument names. The instrument names of any other instruments of the same type already in
your score are not changed.
RELATED LINKS
Edit Instrument Names dialog on page 63
Changing layout names on page 64

Changing the orchestral order of players
You can change the order in which players appear in the score in the Players panel.
PROCEDURE
1.

In the Players panel, select the player card of the player whose position in the score you
want to change.

2.

Click and drag the player card to a different position in the panel.

3.

Release the mouse button to insert the player at the selected position.

Deleting players
You can delete players.
PROCEDURE
1.

Select the player that you want to delete.

2.

Click Delete Player

.

You can also right-click the player and choose Delete Player from the context menu.
3.

Click one of the following options in the warning message that opens:
●

Delete Player Only
Deletes the player and the music that you created for the instruments belonging to
that player.

●

Delete Player and Part Layouts
Deletes the player, the music, and all part layouts to which the player is assigned.
NOTE
The part layout cannot be deleted if it contains more than the deleted player.

Excluding players from full score layouts
By default, every player that you add is added to existing full score layouts. You can exclude
players that you do not want to show in a full score layout.
PROCEDURE
1.

On the Layouts panel, select the full score layout.
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2.

On the Players panel, deactivate the checkbox of the player card for the player that you
want to exclude.

RESULT
The player is excluded from the layout.

Including players in instrumental part layouts
You can include one or multiple players in existing instrumental part layouts.
PROCEDURE
1.

On the Layouts panel, select the instrumental part layout.

2.

On the Players panel, activate the checkbox of the player card for the player that you want
to include.

RESULT
The name of the included player is added to the layout name.

Excluding players from flows
If you create a new flow, all players are automatically added to the flow. You can exclude players
from the flow.
IMPORTANT
If you exclude a player from a flow, any notes you have already input for that player in that flow
are deleted.

PROCEDURE
1.

On the Flows panel, select the flow.

2.

On the Players panel, deactivate the checkbox of the player card for the player that you
want to exclude.

RESULT
The player is excluded from the flow.

Ensembles
If you add an ensemble in Dorico, multiple players are added to your project at the same time.
Dorico provides a set of predefined ensembles that you can use. Adding an ensemble is one of
the ways to achieve building up an instrumentation quickly. The predefined ensembles that you
can create with Dorico follow standard patterns, such as double woodwind which refers to two
flutes, two oboes, two clarinets, and two bassoons.

Adding ensembles
PREREQUISITE
The Players panel must be open.
PROCEDURE
1.

Do one of the following:
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2.

●

If you have started a new project, click Add Ensemble in the project start area.

●

On the Players panel at the bottom, click Add Ensemble

.

In the popover that opens, select an ensemble:
●

In the search field, enter the first letters of the ensemble, then select it from the
filtered list, and click Add Ensemble to Score.

●

Scroll through the popover list, select an ensemble, and click Add Ensemble to
Score.

●

Use Tab/Shift-Tab and the arrow keys on your computer keyboard to scroll through
the popover list. To select an ensemble, press Enter.

RESULT
The ensemble players are added to the Players panel, either as solo or as section players.
RELATED LINKS
Changing player names on page 64
Project start area on page 39

Instruments
You can assign instruments to solo and section players as well as to ensembles.
In the real world, instruments are played by humans, and this is also reflected in Dorico. Before
you can assign instruments, you must add players or ensembles, which may in turn also be
assigned to groups if needed. If you add ensembles, it is by default not necessary to add any
instruments, since these are already included when you select the type of ensemble. However,
you can add further instruments to ensembles.
You can always change the initial specification and add or delete instruments.

Adding instruments to players
You can add instruments to solo players or section players.
PREREQUISITE
You have added a solo player or section player.
PROCEDURE
1.

2.

In the Players panel, open the instrument picker in any of the following:
●

Select the solo or section player and press Shift-I.

●

Click the plus symbol to the right of the added empty-handed player:

●

Right-click the player and choose Add Instrument to Player from the context
menu.

In the popover that opens, select an instrument:
●

In the search field, enter the first letters of the instrument to be played by the
player, then select it from the filtered list, and click Add.

●

Scroll through the popover list, select an instrument, and click Add.
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●

Use Tab/Shift-Tab and the arrow keys on your computer keyboard to scroll through
the popover list. To select an instrument, press Enter.

RESULT
The selected instrument is added to the player. If you selected multiple players, the instrument is
only added to the first player on the Players panel.

Adding multiple instruments to solo players
You can add multiple instruments to solo players.
PREREQUISITE
You have added a solo player that has already been assigned an instrument, or you have added
an ensemble with several solo players.
PROCEDURE
1.

2.

In the Players panel, open the instrument picker in any of the following:
●

Select the player and press Shift-I.

●

Click the plus symbol

●

Right-click the player and select Add Instrument to Player.

to the right of the added empty-handed player.

In the popover that opens, select an instrument:
●

In the search field, enter the first letters of the instrument to be played by the
player, then select it from the filtered list, and click Add.

●

Scroll through the popover list, select an instrument, and click Add.

●

Use Tab/Shift-Tab and the arrow keys on your computer keyboard to scroll through
the popover list. To select an instrument, press Enter.

RESULT
The selected instrument is added to the player.

Adding empty percussion kits to players
PROCEDURE
1.

2.

In the Players panel, open the Edit Percussion Kit dialog in any of the following ways:
●

Select a solo or section player and press Shift-I and click Create Empty Kit in the
instrument picker.

●

Click the plus symbol
to the right of an added empty-handed player and click
Create Empty Kit in the instrument picker.

●

Right-click a player and choose Create Empty Kit from the context menu.

Add the percussion instruments you want to the kit in the Edit Percussion Kit dialog.
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Combining individual percussion instruments into kits
If a player is holding one or more individual percussion instruments, you can combine them into
a percussion kit.
PROCEDURE
1.

Right-click the card of the player whose percussion instruments you want to combine into
a kit.

2.

Choose Combine Instruments into Kit from the context menu.

3.

Edit the kit as required in the Edit Percussion Kit dialog that opens immediately. For
example, you can change the order in which the instruments appear in a grid or on a fiveline staff.

RESULT
A new kit is created containing all the instruments held by the player.
NOTE
If the player was already holding one or more kit instruments, all individual instruments and any
other kits are combined into the first kit.

Changing instruments
You can change the instruments held by players. You can change the instruments of pitched
instruments and individual unpitched percussion instruments, but you cannot change the
instrument of percussion kits.
NOTE
Only unpitched percussion instruments are shown in the instrument picker when you choose
Change Instrument for an unpitched percussion instrument.

PROCEDURE
1.

Expand the card of the player whose instrument you want to change in the Players panel.
The card lists the instruments of the player.

2.

Hover your mouse pointer over the instrument you want to change and click the arrow:

3.

Choose Change Instrument from the context menu.

4.

Select a new instrument from the instrument picker in any of the following ways:
●

Enter the first few letters of the instrument name you want, then select it from the
filtered list.

●

Click an instrument family and then an instrument.

●

Use the Up Arrow and Down Arrow keys to select an instrument family, then press
Tab to switch to the instrument column.
Press Up Arrow and Down Arrow to select an instrument.
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NOTE
An enclosure line shows you which instrument family or instrument is selected when
using the keyboard to navigate

RESULT
The selected instrument is changed, without affecting any music on its staff.
NOTE
Where appropriate new clefs are input, meaning notes may appear differently so they are
notated correctly according to the new clef.

Moving instruments between players
You can move individual instruments between players, as each player can hold multiple
instruments, in the following ways:
1

Click and drag instruments individually and release them over the player card to which you
want to move them.

2

Click the arrow in the instrument name when you hover the mouse over it, choose Move
Instrument to Player from the context menu, then select the player you want from the
players available.

Deleting instruments
You can delete instruments from players.
IMPORTANT
If you delete an instrument from a player, any music that you have created for this instrument is
also deleted.

PROCEDURE
1.

Open the player card by clicking the disclosure arrow to the left of the player name.

2.

Move the mouse over the instrument name and click the disclosure arrow to the right of
the instrument name.

3.

Choose Delete Instrument from the context menu.

4.

Click OK.

RESULT
The instrument is deleted from the player.

Edit Percussion Kit dialog
You can make changes to percussion kits in the Edit Percussion Kit dialog, which opens
automatically when you create empty kits or combine existing instruments into a kit.
You can open the Edit Percussion Kit dialog to edit existing percussion kit instruments by
expanding the player card of the player holding the percussion kit in the Players panel in Setup
mode. Then click the arrow in its label and choose Edit Percussion Kit from the context menu.
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NOTE
Percussion kit instrument labels are green in the Players panel in Setup mode.

The Edit Percussion Kit dialog

At the top of the dialog, you can set the full name and abbreviated name for the kit instrument.
These names are used as staff labels for percussion kits that use the five-line staff presentation
type.
The main editing area of the dialog has three tabs, allowing you to edit how the kit will appear in
each of the presentation types:
5-line staff
Kit instruments are shown on a five-line staff. You can determine which instruments
are shown on each line and in each space of the staff. A single staff label containing
the name of the kit is shown.
Grid
Kit instruments are shown on a grid, with each instrument on its own line. However,
you can customize how large the gaps between each line are. Staff labels are shown
for each instrument in a smaller font than normal staff labels.
Single-line instruments
Kit instruments are shown as individual instruments with their own lines. Normalsized staff labels are shown for each instrument.
You can change the names of individual instruments within percussion kits. Click Edit Names
below the action bar to open the Edit Instrument Names dialog.
NOTE
This changes the appearance of percussion instrument names in all presentations.
Staff labels use different information, depending on the kit presentations.
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The action bar at the bottom of the dialog provide other operations that apply to all presentation
types.

The Edit Percussion Kit dialog action bar, left to right: Add new instrument, Add existing instrument from
player, Remove instrument from kit, Change instrument, and Delete instrument

Add new instrument
Opens the instrument picker, allowing you to choose a new unpitched percussion
instrument to be added to the kit.
Add existing instrument from player
Shows a menu listing the other players in your project that are holding individual
percussion instruments not in kits. You can select a percussion instrument from
another player to move to this kit, bringing its music with it.
Remove instrument from kit
Removes the selected instrument from the kit, so it appears as an individual
instrument. Individual instruments can be moved to other players or into other kit
instruments.
Change instrument
Shows the instrument picker, allowing you to choose a new unpitched instrument to
replace the selected instrument, while retaining its music.
Delete instrument
Deletes the instrument from the kit, including its music.
RELATED LINKS
Staff labels for percussion kits on page 595
Percussion kit presentation types on page 687

Adding instruments to percussion kits
You can add new instruments to percussion kits within the Edit Percussion Kit dialog.
PROCEDURE
1.

Expand the card of the player holding the kit to which you want to add instruments in the
Players panel.

2.

Click the arrow in the kit instrument label and choose Edit Percussion Kit from the context
menu to open the Edit Percussion Kit dialog.

3.

Click Add New Instrument:

4.

Select a percussion instrument in the instrument picker in any of the following ways:
●

Enter the first few letters of the instrument name you want, then select it from the
filtered list.

●

Click an instrument family and then an instrument.

●

Use the Up Arrow and Down Arrow keys to select an instrument family, then press
Tab to switch to the instrument column. Use the Up Arrow and Down Arrow keys
to select an instrument.
NOTE
An enclosure line shows you which instrument family or instrument is selected when
using the keyboard to navigate
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5.

6.

Add the selected instrument in any of the following ways:
●

Press Return.

●

Click Add.

Click Close to close the kit editor.

RESULT
The selected instrument is added to the percussion kit.

Changing instruments in percussion kits
You can change existing instruments in percussion kits while retaining any existing music for that
instrument.
PROCEDURE
1.

Expand the card of the player holding the kit to which you want to add instruments in the
Players panel.

2.

Click the arrow in the kit instrument label and choose Edit Percussion Kit from the context
menu to open the Edit Percussion Kit dialog.

3.

Click the instrument you want to change.

4.

Click Change Instrument in the action bar:

5.

Select a percussion instrument in the instrument picker in any of the following ways:
●

Enter the first few letters of the instrument name you want, then select it from the
filtered list.

●

Click an instrument family and then an instrument.

●

Use the Up Arrow and Down Arrow keys to select an instrument family, then press
Tab to switch to the instrument column. Use the Up Arrow and Down Arrow keys
to select an instrument.
NOTE
An enclosure line shows you which instrument family or instrument is selected when
using the keyboard to navigate

6.

7.

Change to the selected instrument in any of the following ways:
●

Press Return.

●

Click Change.

Click Close.

RESULT
The instrument is changed to the one selected in the instrument picker. Any music input for the
previous instrument is retained.
NOTE
Playing techniques expressed using playing technique-specific noteheads are not retained.
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Creating groups of instruments within grid presentation percussion kits
You can create groups of instruments within percussion kits that use the grid presentation type.
In grid presentation percussion kit, the name of each individual instrument is shown in the staff
label. You may want to simplify the staff label of grid presentation percussion kits by creating
groups, for example, to show Wood Blocks instead of Wood Block (High), Wood Block (Medium),
and Wood Block (Low)
PROCEDURE
1.

Open the Edit Percussion Kit dialog by clicking the arrow in the instrument name when
you hover the mouse over it, and choosing Edit Percussion Kit from the context menu.

2.

Click Grid at the top of the dialog.

3.

Click the first instrument you want to include in the group.

4.

Hold down Shift.

5.

Click the last instrument you want to include in the group.
NOTE
You can only include adjacent instruments in groups.

6.

Click Add:

RESULT
A group is created containing the selected instruments. The group is given a default name that
you can change.

Changing the names of groups in grid presentation percussion kits
Group names are shown as instrument labels. You can change the names of groups in
percussion kits using grid presentation.
PROCEDURE
1.

Open the Edit Percussion Kit dialog by clicking the arrow in the instrument name when
you hover the mouse over it, and choosing Edit Percussion Kit from the context menu.

2.

Click Grid at the top of the dialog.

3.

Open the Edit Percussion Grid Group Names dialog in any of the following ways:
●

Double-click the group.

●

Click the group, then click Edit:

Groups are shown as colored blocks in the column to the left of the list of percussion kit
instruments.
4.

5.

Enter the names you want to give the group in the following fields in the Edit Percussion
Grid Group Names dialog:
●

Full Name

●

Short Name

Click OK to close the dialog and save your changes.

RESULT
The name of the group is changed. This also changes the staff label for the group.
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NOTE
Staff labels for groups in grid presentation percussion kits use a different paragraph style to the
staff labels for non-grouped instruments in grid presentation percussion kits.
EXAMPLE

Ungrouped grid presentation percussion kit

Grid presentation percussion kit with wood blocks
grouped

RELATED LINKS
Staff labels for percussion kits on page 595

Deleting groups within grid presentation percussion kits
You can delete groups in percussion kits using grid presentation, without deleting the
instruments within the group.
PROCEDURE
1.

Open the Edit Percussion Kit dialog by clicking the arrow in the instrument name when
you hover the mouse over it, and choosing Edit Percussion Kit from the context menu.

2.

Click Grid at the top of the dialog.

3.

Click the group you want to delete.
Groups are shown as colored blocks in the column to the left of the list of percussion kit
instruments.

4.

Click Delete:

RESULT
The group is deleted. The individual staff labels for each instrument in the group are restored.

Changing the positions of instruments within percussion kits
You can change the positions of instruments within percussion kits of all presentation types to
change the order in which the instruments appear in the score and parts.
PROCEDURE
1.

Open the Edit Percussion Kit dialog.
You can do this by clicking the arrow in the instrument name of the percussion kit whose
instrument positions you want to change and choosing Edit Percussion Kit from the
context menu.
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2.

Click the kit presentation type in which you want to change the order of instruments.
For example, click Grid to change the order of instruments when the kit uses the grid
presentation type.

3.

Click a percussion instrument in the kit whose position you want to change.

4.

Change the position of the selected instrument in any of the following ways:

5.

●

Click the up arrow Move button to move it upwards.

●

Click the down arrow Move button to move it downwards.

●

Click and drag the instrument to the position you want (5-line staff presentation
only).

Optional: Repeat these steps for other instruments in the percussion kit, and for other kit
presentation types for the same percussion kit.

RESULT
The position of the selected instrument within the kit is changed. Multiple instruments can share
the same staff position, but it is advisable to ensure that they use different noteheads so that the
player can tell them apart.

Changing the size of gaps between lines in percussion grids
You can change the size of gaps between lines in percussion kits using the grid presentation
type.
PROCEDURE
1.

Open the Edit Percussion Kit dialog.
You can do this by clicking the arrow in the instrument name of the percussion kit whose
instrument positions you want to change and choosing Edit Percussion Kit from the
context menu.

2.

Click the Grid presentation type.

3.

Click the instrument below which you want to change the gap size.

4.

Change the value in the Gap field in any of the following ways:
●

Enter a value into the value field and press Return.

●

Click the arrows beside the value field.

RESULT
The size of the gap below the selected instrument is changed.

Removing individual instruments from percussion kits
You can remove individual instruments from percussion kits, for example, if you want to move
individual instruments in percussion kits to other players.
PROCEDURE
1.

Open the Edit Percussion Kit dialog by clicking the arrow in the instrument name when
you hover the mouse over it, and choosing Edit Percussion Kit from the context menu.

2.

Click the instrument you want to remove from the kit.

3.

Click Remove Instrument From Kit in the action bar:

4.

Click Close to close the kit editor.
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RESULT
The selected instrument appears as an individual instrument belonging to the player, separately
from the percussion kit.
You can then move the instrument to other players if required.
RELATED LINKS
Moving instruments between players on page 71

Groups
A group is a collection of players.
In most scores, there is a single group, for example a choir, an orchestra, or a band. In some
works for large forces, there may be multiple groups, for example, in Britten's “War Requiem”,
which has three distinct groups, or Walton's “Belshazzar's Feast” which requires two separate
off-stage brass groups. These make it necessary to be able to assign players to these groups
for the purposes of, among other things, properly bracketing and labeling their staves in the
conductor's score.

Adding groups
You can organize players in groups.
PREREQUISITE
The Players panel must be open.
PROCEDURE
1.

Optional: Select the players that you want to include in the group.

2.

On the Players panel at the bottom, click Add Group

.

RESULT
If you selected one or more players, they are added to the group. If no player was selected, an
empty group is added to the Players panel.
RELATED LINKS
Adding players to groups on page 79

Renaming groups
You can change the name of a group.
PROCEDURE
1.

On the Players panel, double-click the name of the group.

2.

Enter the new name.

3.

Press Enter.
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Deleting groups
You can delete groups of players.
NOTE
If you delete a group, you can keep the players that you added to the group.

PROCEDURE
1.

On the Players panel, select the group that you want to delete.

2.

Do one of the following:

3.

●

Click Delete

●

Press Delete.

Do one of the following:
●

To keep the players, click Keep Players.

●

To delete the group including the players, click Delete Players.

Adding players to groups
You can add existing or new players to groups.
PREREQUISITE
You have added at least one player, one ensemble, or one group.
PROCEDURE
●

On the Players panel, do one of the following:
●

Select one or more players and click Add Group.

●

Select a group, and click Add Solo Player, Add Section Player, or Add Ensemble.

RESULT
If you clicked Add Group, a new group is added for the selected players. If you clicked Add Solo
Player, Add Section Player or Add Ensemble, a new player or ensemble is added to the selected
group.
RELATED LINKS
Adding groups on page 78
Adding solo players on page 59
Adding section players on page 60

Moving players between groups
You can move players from one group to another.
PROCEDURE
1.

Select the players that you want to move to another group in the Players panel.

2.

Click and drag the selected players into the other group.

3.

Release the mouse at the position where you want to add the players.
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RESULT
The players are moved to the other group.

Removing players from groups
You can remove players from groups.
PROCEDURE
1.

On the Players panel, select the players that you want to remove from a group.

2.

Click and drag the selected players out of the group and release the mouse button.

Flows
Flows are separate spans of music within your project, for example, movements or songs.
Every project contains at least one flow, and by default, every layout includes the music from
every flow in your project. If you create a new flow in Dorico, the following happens:
●

All music that you write for the new flow is automatically included in the existing full score
and instrumental part layouts. You can exclude any flow from any layout by deactivating
the respective flow card.

●

All players are added to the new flow. You can exclude players from the flow by
deactivating the respective player card.
IMPORTANT
If you exclude a player from a flow, the notes that you may have already input for that
player in that flow are deleted.

RELATED LINKS
Flows on page 32
Flows panel on page 58

Creating flows
If you need more than one flow in your project, you can create a new flow.
PROCEDURE
●

On the Flows panel, click Add Flow

.

RESULT
All existing players are assigned to the new flow. The new flow is automatically added to all
existing full score and part layouts.

Flow names and flow titles
Whenever you add a flow to project, the default name of a flow is Flow plus an incremental
number. You can rename flows in the Project Info dialog and in the Flows panel in Setup mode.
When you enter names for flows in the Flows panel in Setup mode, those names are
automatically added in the Title field for the appropriate flow File > Project Info dialog. If you
change the name in the Flows panel again later, the flow title is updated in the Project Info
dialog.
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Titles shown in scores and parts in the music area are linked to the Title field for each flow in the
Project Info dialog.
This link is maintained until you change the names of flows in the Project Info dialog. Once you
change flow titles in the Project Info dialog, changing flow names in the Flows panel no longer
updates the Title field for that flow in the Project Info dialog.
This allows you to organize flows in Setup mode with different names to their official title.

Renaming flows in Setup mode
PROCEDURE
1.

Do one of the following:
●

Double-click the name of the flow

●

Right-click the name of the flow and choose Rename from the context menu

2.

Enter a new name for the flow.

3.

Press Enter.

RESULT
The name of the flow is changed. If you have not entered a different title for the flow in the
Project Info dialog, the title shown in the music area is updated to match the new flow name.

Changing flow titles in the Project Info dialog
PROCEDURE
1.

Choose File > Project Info.

2.

Select the flow whose title you want to change from the menu. Alternatively, use the arrow
buttons beside the menu to choose the flow.

3.

Enter the new title you want in the Title field.
NOTE
You can repeat steps 2-3 for other flows in your project before closing the dialog.

4.

Save your changes and close the dialog in any of the following ways:
●

Press Return

●

Click OK

RESULT
The titles of the selected flows are changed to what you entered.
NOTE
This breaks the link between flow names in the Flows panel in Setup mode and the title shown in
the music area.
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Deleting flows
You can delete flows that you no longer need.
IMPORTANT
If you delete flows, all music for all instruments belonging to all players for the flows is also
deleted.

PROCEDURE
1.

Select the flows you want to delete in the Flows panel.

2.

Delete the flows in any of the following ways:
●

Press Backspace or Delete.

●

Click Delete Flow:

●

Right-click the flow and choose Delete Flow from the context menu.

Excluding flows from layouts
By default, every flow that you create is added to existing full score layouts or instrumental part
layouts. You can exclude flows that you do not want to show in a layout.
PROCEDURE
1.

On the Layouts panel, select a layout.

2.

On the Flows panel, deactivate the checkbox of the flow card for the flow that you want to
exclude.

RESULT
The flow is excluded from the layout.

Changing the Notation Options for flows
You can change the Notation Options for one or several flows.
PROCEDURE
1.

Optional: On the Flows panel, select a flow or all flows.

2.

Click Notation Options

3.

Optional: In the Notation Options dialog, you can change your flow selection if necessary.
Do one of the following:

.

●

Select one or several flows from the Flows list.

●

Click Select All.

4.

From the Select a Category pop-up menu, select a category.

5.

In the area on the right, make your changes.

6.

Click Apply.
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Layouts
Layouts define how the music in a flow is presented.
Dorico provides three types of layouts:
Full score
A full score layout includes by default all players and all flows in your project. You can
remove players and flows that you do not need.
Instrumental part
An instrumental part layout is automatically created when you add a player to your
project. You can add further players to the instrumental part layout. You can also
create empty instrumental part layouts and add players. By default, an instrumental
part layout contains all flows. You can exclude flows that you do not need.
Custom score
A custom score layout initially does not contain any players or flows. This allows you
to create your score manually and to add, for example, a layout that contains only
one flow instead of all flows.
RELATED LINKS
Excluding flows from layouts on page 82
Excluding players from full score layouts on page 66

Creating layouts
You can create multiple layouts for full scores and instrumental parts. You can also create
multiple custom score layouts.
PROCEDURE
●

At the bottom of the Layouts panel, select one of the following layout types:
●

Add Full Score Layout

●

Add Instrumental Part Layout

●

Add Custom Score Layout

RESULT
The layout is added to the list of layouts on the Layouts panel.
AFTER COMPLETING THIS TASK
You can assign players and flows to your layout.

Renaming layouts
You can change the name of a layout.
If you add an instrumental part layout to project, its default name is Empty part. The default
names of full score and custom score layouts are Full score and Custom score. If you add
several layouts, an incremental number is added to the default names.
PROCEDURE
1.

Do one of the following:
●

Double-click the name of the layout.

●

Right-click the name of the layout and from the context menu, select Rename.
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2.

Enter the new name

3.

Press Enter.

Switching layouts
If you have created several layouts, you can switch to another layout in every mode.
NOTE
You can only switch between layouts to which players are assigned.

PROCEDURE
●

In the middle of the toolbar, from the workspace controls, click Select Layout and select
one of the available layouts.

RESULT
The selected layout opens in the music area.

Sorting layouts
You can sort selected layouts on the Layouts panel.
PROCEDURE
1.

Click a layout card and keep the mouse button pressed.

2.

Drag the layout card to a different position on the panel.

3.

Release the mouse button.

RESULT
The layout is inserted at the selected position.

Deleting layouts
You can delete layouts from the list of layouts on the Layouts panel.
PROCEDURE
1.

Select the layout that you want to delete.

2.

Do one of the following:

3.

●

Click Delete Layout

●

Press Delete.

.

Right-click the layout and choose Delete Layout from the context menu.
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Layout Options
The Layout Options dialog provides multiple options that allow you to make changes that affect
the way the notation is laid out on pages of each layout.
You can change the physical properties of the layout, such as page size, staff size, or margins,
and the notation, such as note spacing or staff labeling.
NOTE
●

For project-wide changes that affect all layouts in your project, you can also make changes
in Engrave > Engraving Options.

●

You can save all options that you set in the layout options as default values for new
projects by activating Save as defaults for and selecting a layout type.

You can open Layout Options in the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options at the bottom of the Layouts panel:

●

Right-click an instrumental part or a full score in the Layouts panel and choose Layout
Options from the context menu.

Layout Options

The Layout Options dialog features a pop-up menu that allows you to select a category. Every
category provides subcategories with options that are displayed in the area to the right. A
Layouts section below the selectable categories lists all the layouts that are available in your
project.
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If you have not specified for which layout you want to make changes, the Layouts list and further
options at the bottom of the Layouts list allow you to select one or multiple layouts, groups of
layouts, or all layouts.
You can also select individual layouts in the following ways:
●

Ctrl/Cmd-click individual layouts in the list.

●

Shift-click multiple adjacent layouts in the list.

RELATED LINKS
Engraving Options on page 163

Page setup
The Page Setup category in the layout options allows you to determine basic page properties
which affect the way the notation is arranged on a page.

Bar numbers
The Bar Numbers category in the layout options allows you to determine how bar numbers are
displayed and positioned in each layout.

Note spacing
The Note Spacing category in the layout options allows you to determine options that affect the
way notes are aligned on staves.
TIP
Justifications of a final system in a flow that are determined by a percentage value are activated
by default. To deactivate this, deactivate Only justify final system in flow when more than.

Players
The Players category in the layout options allows you to determine options that affect the way
music is displayed for individual players.

Vertical spacing
The Vertical Spacing category in the layout options allows you to determine distances between
staves and systems.
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In Write mode, you can create your music. You can input notes and insert notations into your
score.

Project window in Write mode
The project window in Write mode contains the default toolbar, the music area, and the status
bar. It provides toolboxes and panels with the tools and functions that you need to write your
music.
To open Write mode, you have the following options:
●

Select Write on the toolbar.

●

Select Window > Write.

Toolboxes and panels in Write mode

The following panels and toolboxes are available:
1

Notes toolbox
Contains all tools that allow you to modify the note input.

2

Notes panel
Provides the note types, accidentals, slur, and articulations that are most commonly used
during note input.
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3

Properties panel
Contains quick access properties that are required to make specific modifications to the
notation.

4

Notations panel
Contains all the notation items that you can use for your music.

5

Notations toolbox
Allows you to select tools that determine which notation items are shown in the Notations
panel.

Notes toolbox
The tools in the notes toolbox allow you to modify the note input.
Dotted Notes
Adds/Removes rhythm dots to notes or chords.
Rests
Allows you to input rests of the duration that you select on the notes panel.
Chords
Allows you to add several notes at the same rhythmic position in order to build a
chord. This function prevents the caret from advancing automatically after inputting
a note.
Tuplets
Inserts a triplet bracket and the respective number of rests at the specified rhythmic
position. If the notes are beamed, no brackets are used. To use a different tuplet,
press the respective key command on your computer keyboard.
Grace Notes
Allows you to input grace notes at the current rhythmic position.
Insert
Inserts music instead of overwriting.
Lock to Duration
Uses the duration of existing music for note input via MIDI or computer keyboard.
This tool helps you to maintain the duration of notes while you change their pitches.
Force Duration
Always creates the explicit duration that you have specified on the notes panel. For
example, you can activate Force Duration to force the input of a dotted quarter
note on the second quarter beat of 4/4, where Dorico, by default, splits the note with
a tie.
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IMPORTANT
Any time signature changes or other edits to your music may lead to unexpected
results.
If you activated Force Duration during input, you can remove the restrictions
on how Dorico notates the music by selecting the affected passage of music and
selecting Edit > Reset Appearance.
Tie
Ties the note to be input to the previous note of the same pitch. When editing notes,
you can use this tool to tie together notes in different voices or to tie grace notes to
rhythmic notes.
To activate/deactivate Tie, press T.
Select
Activates/Deactivates mouse input.
RELATED LINKS
Activating rhythm dots on page 103
Rests on page 100
Inputting chords on page 96
Adding tuplets on page 104
Inputting grace notes on page 107
Activating/deactivating mouse input on page 97

Notes panel
The notes panel contains note durations, accidentals, slur, and articulations for inputting notes.
To show/hide the notes panel, click the disclosure arrow
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The upper part of the notes panel provides the note durations that you can input. Not all the
available note durations are visible by default. To see all note durations, click Show/Hide All
Notes

/

at the top or bottom of the note durations list.

In the middle part of the notes panel, you can activate accidentals and slurs.
At the bottom part of the notes panel, you can activate articulations.

Properties panel
The Properties panel in Write mode contains quick access properties that allow you to change
notes and notations during note input.
NOTE
If you need to change parts of notations, for example, the bow of a tied note, switch to Engrave
mode.

To show/hide the properties panel, click the disclosure arrow

/

Notes and Rests group of the Properties panel in Write mode

RELATED LINKS
Changing the properties of individual items in Write mode on page 121
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Notations panel
The Notations panel contains the notation items for your music.
Depending on the tool that you select in the notations toolbox, the choice of usable notations in
the Notations panel changes.
To show/hide the Notations panel, click the disclosure arrow below the notations toolbox.

Notations toolbox
The tools in the notations toolbox allow you to determine what notation items are shown in the
Notations panel.
Clefs
Opens sections in the Notations panel that allow you to select different clefs and
octave lines.
Key Signatures, Tonality Systems, and Accidentals
Opens sections in the Notations panel that allow you to specify and select key
signatures, and to select tonality systems and several types of accidentals.
Time Signatures (Meter)
Opens sections in the Notations panel that allow you to specify and select different
time signatures.
Tempo
Opens sections in the Notations panel that allow you specify and select different
tempos and tempo changes.
Dynamics
Opens sections in the Notations panel that allow you to specify and select different
dynamics.
Ornaments
Opens sections in the Notations panel that allow you to select different ornaments
and glissando lines.
Tremolos
Opens a section of the Notations panel that allows you to select and remove different
single-note and multi-note tremolos.
Bars and Barlines
Opens sections in the Notations panel that allow you to insert bars and to create
barlines.
Holds and Pauses
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Opens sections in the Notations panel that allow you to insert different types of
fermatas, breath marks, and caesuras.
Playing Techniques
Opens sections in the Notations panel that allow you to insert playing techniques for
various instrument groups.
Rehearsal Marks
Inserts a rehearsal mark at the selected note.
Text
Opens a popover that allows you to insert text at the selected rhythmic position.
Lyrics
Opens a popover above the selected note on the staff. This popover allows you to
input lyrics.
RELATED LINKS
Lyrics on page 113

Note input
There are several different ways to input notes.
To input notes, you can use any of the following methods, and switch between them at any time:
●

MIDI keyboard

●

Computer keyboard

●

Mouse or trackpad

TIP
A MIDI keyboard is the fastest way to input notes.
The procedures that you come across in this chapter are for active note input. Information
relating to note editing or the options that influence note input are handled in the notation
reference. In some cases, though, hints to editing processes may be given in this chapter.
RELATED LINKS
Notes on page 453

Introduction to inputting and editing
Dorico distinguishes the processes for inputting and editing music.
Whenever you see the caret, you are inputting new music. When you do not see the caret, you
are editing existing music.
You can switch back and forth between inputting and editing.
We recommend that you spend a moment to understand the difference between how Dorico
behaves if the caret is shown and if it is not. In the latter case, all editing functions operate on the
items that you have selected in the music area.
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Differentiating between inputting and editing your music
Depending on whether you input or you edit notes, the tools in the toolboxes and the panels
behave differently.
To input notes, the caret must be activated.
If the caret is activated, selecting tools or items in the notes toolbox and the notes panel affect
the note or chord that you are about to input: you specify the duration, rhythm dot, accidentals,
and articulations. Then you specify the pitch by clicking the note into the score, by pressing the
letter name of the note on your computer keyboard, or by playing the note or chord on your
MIDI keyboard.
If no notes or chords are selected in the music area and you select a duration from the notes
panel, either by pressing its key command or by clicking it with the mouse, mouse input is
activated. If you move the mouse pointer over the music, a shadow note is displayed to indicate
where the note will be input if you click.
To edit notes, one or more items must be selected in the music area. If one or more notes or
chords are selected in the music area, the notes toolbox and notes panel affect the selected
notes and chords: if you select a new duration from the notes panel, either by pressing its key
command or by clicking it with the mouse, the durations of the selected notes and chords are all
edited to match the chosen duration.
RELATED LINKS
Caret on page 98

Positioning of new items
The input position of new items depends on whether you input or edit music.
When you input music and the caret is activated, Dorico creates any note or notation at the
caret's rhythmic position.
When you edit music and one or more notes or chords are selected in the music area, Dorico
creates a new item at the position of the first selected item in the music area. If there is no
selection, the mouse pointer is loaded with the new item. The item is then created at the location
where you click.
EXAMPLE
Adding a Time Signature in Front of a Selected Note
If you want to add a 3/4 time signature in front of a specific note, you have the following options:
you can select the note, press Shift-M, enter 3/4, and press Enter. If no note is selected, select
Time Signature (Meter) in the notations toolbox. Then select 3/4 from the Common section,
move the mouse pointer to the position where you want to insert the time signature, and click.

Selecting/deselecting notes or notations
You can edit your music with or without selecting notes or notations in the toolboxes or panels.
If you select notes or notations in the toolboxes, they are inserted at the selected rhythmic
position in the music area. You can also click notations on the Notations panel and position them
on a staff.
To select notes or notations in the music area, you can do one of the following:
●

Click a note or notation.

●

Drag a marquee around multiple notes or notations.

To deselect any items, click anywhere outside the staves within the music area or press Ctrl/
Cmd-D.
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RELATED LINKS
Selecting multiple notes and notations on page 44

Starting note input
Dorico provides several methods to start inputting notes.
NOTE
You must specify the duration, accidentals, and articulations before specifying the pitch. This
applies to all input methods.
You can use any of the following methods to start note input:
●

Double-click the rhythmic position on the staff at which you want to begin inputting notes.

●

Select a note, chord, rest, or other item at the rhythmic position on the staff at which you
want to begin inputting notes, and press Return or press Shift-N.

●

Click a note duration in the Notes panel when no note is selected in the music area.

RELATED LINKS
Caret on page 98
Key commands in Dorico on page 10
Adding notes above and below existing notes on page 105

Inputting notes
Notes can be input into your project during step input, when note input is activated. You can
input notes with a computer keyboard, by clicking with a mouse pointer, or by playing notes in
from a MIDI keyboard.
PROCEDURE
1.

2.

Start note input in any of the following ways:
●

Press Shift-N.

●

Select the staff where you want to input notes and press Return.

●

Select the staff where you want to input notes and choose Write > Note Input.

●

Double-click the staff where you want to input notes.

Select the note value you want for your notes in one of the following ways:
●

Select the rhythmic value from the Notes panel on the left of the window.

●

Press the number that corresponds to the rhythmic value you want, such as 6 for
quarter notes, 5 for eighth notes, 7 for half notes, and so on.

3.

If required, activate a rhythm dot.

4.

If required, add an accidental.

5.

If required, add an articulation.

6.

Input the pitches you want in one of the following ways:
●

Press the letters on your keyboard that correspond to the notes you want:
A, B, C, D E, F, and G.

●

Click the staff on the lines or in the spaces where you want to input notes, and at the
rhythmic positions where you want them.
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TIP
A gray notehead appears when inputting with a mouse pointer to show you where
the note will be input.
●
7.

Play in the notes you want with a MIDI keyboard.

Finish inputting notes by pressing Esc or Return.

RELATED LINKS
Adding notes above and below existing notes on page 105

Inputting notes in Insert mode
When Insert mode is activated, you can input notes before existing notes without overriding
them. Insert mode allows you to move existing notes forward at the same time as inputting new
notes where they were before.
PROCEDURE
1.

In Write mode, start note input.

2.

Select the note value you want for your notes.

3.

Activate Insert mode in one of the following ways:
●

Press I

●

Click Insert in the Notes panel on the left of the window:

When Insert mode is activated, the caret shows V and inverted V shapes at the top and
bottom, as shown in this example:

4.

Input the pitches you want in one of the following ways:
●

Press the letters on your keyboard that correspond to the notes you want.

●

Click on the staff with a mouse pointer on the lines or in the spaces where you want
to input notes at the rhythmic position.
TIP
A gray notehead appears when inputting with a mouse pointer to show you where
the note will be input.

●
5.

Play in the notes you want with a MIDI keyboard.

Deactivate Insert mode in one of the following ways:
●

Press I again.

●

Select the Insert button again in the Notes panel on the left of the window.

RESULT
Notes are inserted before existing notes, without overriding any existing notes at rhythmic
positions after the caret. Any existing notes after the caret are pushed ahead.
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NOTE
You can deactivate Insert mode and immediately continue inputting notes as before.
Chords cannot be activated at the same time as Insert mode.

RELATED LINKS
Inputting notes on page 94

Inputting notes for players with multiple instruments
Note input for players who play multiple instruments follows the rules that apply for the default
note input. To see the notes that you input for the different instruments, you can start note input
in galley view.
PREREQUISITE
You have added a solo player who plays at least two instruments.
PROCEDURE
1.

In the status bar, from the view selector, select Galley View.

2.

Input your notes for all instruments, one after the other.

RELATED LINKS
View types on page 44

Inputting chords
Chords can be input during step input, when both note input and Chords are activated. You can
input notes with a computer keyboard, by clicking with a mouse pointer, or by playing notes in
from a MIDI keyboard.
PROCEDURE
1.

In Write mode, start note input.

2.

Select the note value you want for your notes.

3.

Activate Chords in one of the following ways:
●

Press Q

●

Click Chords in the Notes panel on the left of the window:

4.

When Chords is activated, a + sign appears at the top of the caret. This allows you to input
multiple notes at the same rhythmic position, according to the current position of the
caret.

5.

Input the pitches you want in one of the following ways:
●

Press the letters on your keyboard that correspond to the notes you want.
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NOTE
When Chords is activated, notes are input at the same rhythmic position and above
the previous note until you advance the caret manually. For example, if you press A
then E then A, a chord of A-E-A is input at the caret position.
●

Click on the staff with a mouse pointer on the lines or in the spaces where you want
to input notes at the rhythmic position.
TIP
A gray notehead appears when inputting with a mouse pointer to show you where
the note will be input.

●

Play in the notes you want with a MIDI keyboard.
NOTE
When Chords is activated, notes are input at the same rhythmic position and above
the previous note until you advance the caret manually.

6.

To deactivate Chords, do one of the following:
●

Press Q again.

●

Select the Chords button again in the Notes panel on the left of the window.

RESULT
Multiple notes are input at the caret position.
NOTE
You can deactivate Chords and immediately continue inputting notes as before, with a single
note at each rhythmic position and the caret advancing automatically to the next rhythmic
position.
Chords cannot be activated at the same time as Insert mode.

RELATED LINKS
Inputting notes on page 94
Adding notes above and below existing notes on page 105

Activating/deactivating mouse input
You can activate/deactivate mouse input.
PROCEDURE
●

In the Notes toolbox, do one of the following:
●

To activate mouse input, deactivate Select

●

To deactivate mouse input, activate Select .
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Activating/deactivating mouse input for all projects
You can activate/deactivate mouse input for all projects. This changes the default setting. You
can still activate/deactivate mouse input for an individual session.
PROCEDURE
1.

Click Edit > Preferences.

2.

In the Preferences dialog, select the General section.

3.

Activate/Deactivate Enable note input using the mouse.

4.

Click Apply.

Caret
The caret shows the rhythmic position at which notes, chords or notation items can be input.
A caret is a mark that is commonly used in proofreading of written text to denote the position
at which something should be inserted or added, for example, a missing letter or a word. In
software, the caret shows where something is inserted: you may also know the caret by the
names insertion point or cursor.
In Dorico, the caret is displayed as a vertical line that extends above and below the staff. If you
are inputting notes, the caret advances to the next rhythmic position automatically. If you are
inputting chords, the caret does not move on its own, and you must move it to the next rhythmic
position.
The caret changes its look depending on the tool or on the number of voices that you are using:
Insert
The caret shows V and inverted V shapes at the top and bottom.
Chords
The caret shows a plus symbol on the left at the top.
Lock to Duration
The caret line is dashed.
Grace Notes
The caret is smaller than the default caret.
Voices
If you input multiple voices, the caret shows:
●

a plus symbol on the left at the bottom

●

the number of the voice into which you are about to input notes

●

an up-stem note or a down-stem note to indicate the stem direction of the
voice

Activating/deactivating the caret
If you activate the caret, you can write music. If you deactivate the caret, you can edit your music.
To activate the caret, you have the following options:
●

Select a note or rest and press Shift-N or Return.

●

Double-click the rhythmic position on the staff at which you want to begin inputting notes.

To deactivate the caret, you have the following options:
●

Press Esc.
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●

Double-click anywhere outside the staves within the music area.

Moving the caret manually
When inputting chords, the caret does not move automatically. Therefore, you must move it
manually.
You can move the caret in the following ways:
●

Press Right Arrow and Left Arrow to move the caret to the next or previous rhythmic
position.

●

Press Ctrl/Cmd-Right Arrow and Ctrl/Cmd-Right Arrow to move the caret to the next or
previous bar.

●

Press Space to advance the caret to the next rhythmic position, according to the note
value currently selected.

●

Press Up Arrow and Down Arrow to move the caret to the staff above and the staff below.

●

Press Ctrl/Cmd-Up Arrow and Ctrl/Cmd-Down Arrow to move the caret to the top or
bottom staff in the system.

RELATED LINKS
Inputting chords on page 96

Rhythmic grid
The rhythmic grid shows the rhythmic divisions and subdivisions of the bar in which the caret is
located.

Rhythmic grid for eighth notes

The rhythmic grid is shown above the top staff, on which the caret is visible. Longer lines indicate
beat divisions, while shorter lines indicate subdivisions of the beat.
The rhythmic grid helps you to identify the following:
●

The exact input position when using the caret or the mouse

●

The amount by which the caret moves

●

The amount by which the duration of a note or of a selection of notes is modified

RELATED LINKS
Caret on page 98
Moving the caret manually on page 99

Changing the rhythmic grid resolution
You can change the resolution of the rhythmic grid.
The default grid resolution is set to eighth notes.
PROCEDURE
●

Do one of the following:
●

For a coarser grid resolution, select Write > Rhythmic Grid > Decrease Grid
Resolution or press the respective key command.
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●

For a finer grid resolution, select Write > Rhythmic Grid > Increase Grid
Resolution or press the respective key command.

Alternatively, you can do one of the following:
●

Select a grid resolution from the Rhythmic Grid Resolution selector on the status
bar.

●

Select Write > Rhythmic Grid and then select one of the available beat divisions.

RELATED LINKS
Status bar on page 43

Rests
Dorico provides several ways to input rests.
You have the following options:
●

While inputting notes, you can press Space or Right Arrow. These key commands move
the caret, and any gaps between notes are automatically filled with rests. You can select a
different duration on the notes panel.

●

If you activate Rests in the notes toolbox or press , (comma), only rests instead of
notes are input into the score. Dorico automatically discerns which rests are appropriate
according to the time signature that you selected.

●

If you activate Rests and Force Duration in the notes toolbox, or press , (comma) and
O, only rests of the duration that you selected on the notes panel are input into the score.

Inputting rests with the rests tool
You can input only rests if you activate the Rests tool.
PROCEDURE
1.

In the notes toolbox, activate Rests .

2.

Optional: On the notes panel, select a duration.

3.

Input a rest by doing one of the following:
●

Play a note on the MIDI keyboard.

●

Press a key from A to G on your computer keyboard.

RESULT
A rest of the selected duration is added to the score. If you add more than one rest, Dorico
automatically combines the rests to a rest of a different duration that makes sense in
combination with the input notes.

Inputting rests of a specified duration
You can force Dorico to input rests of a specified duration.
PROCEDURE
1.

2.

Do one of the following:
●

In the notes toolbox, activate Rests

●

Press , (comma) and O.

On the notes panel, select the duration.
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3.

Press any key on your MIDI or computer keyboard.

RESULT
The rest of the selected duration is input into your score.

Voices
You can input multiple voices in Dorico.
By default, each staff of an instrument only uses a single voice, but you can create more voices if
necessary.
Each voice has a nominal stem direction which determines the stem direction of notes where
multiple voices are present on the same staff. The voice that is created by default for each staff
of each instrument is an up-stem voice. When you start a new voice, you can choose whether it
should be nominally up-stem or down-stem.
Once you have created a voice somewhere on a staff, you can input notes into that voice
anywhere else on the same staff.
RELATED LINKS
Adding notes above and below existing notes on page 105

Inputting new voices
You can input multiple voices into your score.
PREREQUISITE
You have started note input. The caret is activated.
PROCEDURE
1.

Move the caret to the rhythmic position where you want to start inputting a voice.

2.

Press Shift-V.
The caret shows a plus symbol and a note with a specific stem direction. If you have
already input two voices, the caret additionally shows a number to indicate which voice
you are going to input next.

3.

Optional: Press Shift-V again to change the stem direction of the voice.

4.

Input notes for the voice.

Re-using existing voices
You can re-use existing voices to change or input notes.
PREREQUISITE
You have started note input. The caret is activated.
PROCEDURE
1.

Move the caret to the rhythmic position where you want to start inputting into an existing
voice.

2.

Press V to cycle through the existing voices.
The caret shows an up-stem or a down-stem note and additionally a number if you have
created several voices.

3.

Input notes for the voice.
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IMPORTANT
Existing notes in the voice are overwritten.

Selecting durations
You can select durations either from the notes panel or by using one of the assigned key
commands.
PREREQUISITE
If you want to change which durations are listed, click Show/Hide All Notes
or bottom of the notes list.

/

at the top

PROCEDURE
●

Do one of the following:
●

Activate one of the durations on the notes panel.

●

Press one of the respective key commands.

RELATED LINKS
Notes panel on page 89
Key commands in Dorico on page 10

Changing the duration of selected notes
You can shorten or lengthen the duration of selected notes.
PROCEDURE
1.

Select one or more notes.

2.

Activate a different duration on the notes panel or press its key command.
NOTE
Alternatively, you can press Shift-Alt-Left Arrow/Right Arrow to shorten or lengthen the
notes by the amount determined by the resolution of the rhythmic grid. If you want to
change the grid resolution, you can do one of the following:
●

Select a grid resolution from the Rhythmic Grid Resolution selector on the status
bar.

●

Select Write > Rhythmic Grid and select a grid resolution.

Forcing the duration of notes
Dorico automatically notates and beams appropriately, according to the current time signature
and their position in the bar.
For example, if you input a half note at the start of a 6/8 bar, it is notated as a dotted quarter
note tied to an eighth note. This is because, according to convention, 6/8 bars are subdivided
into two groups of three eighth notes. To reflect this for a half note (four eighth notes), Dorico
automatically divides the note to show the correct grouping.
If you want to specify how the durations of notes are notated, you can force their duration.
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PROCEDURE
1.

In Write mode, start note input.

2.

Activate Force Duration in one of the following ways:

3.

●

Press O

●

Click Force Duration in the Notes toolbox:

Input the notes you want.
You can deactivate Force Duration at any time by pressing O or clicking Force Duration in
the Notes toolbox.

RESULT
The notes you input are notated as their whole value, whatever their position in the bar.
NOTE
Notes that cross barlines are notated as tied notes.
You can change how notes are grouped in different contexts project-wide on the Note Grouping
page in Write > Notation Options.

RELATED LINKS
Inputting notes on page 94
Setting beaming within time signatures on page 247
Creating custom beam groupings for meters on page 262

Activating rhythm dots
The Dotted Notes tool allows you to add rhythm dots to notes.
PROCEDURE
1.

Do one of the following:
●

Press . (dot).

●

In the notes toolbox, activate Dotted Notes

.

NOTE
The tool remains activated until you either select a different note duration or deactivate it.
2.

Optional: Press Alt-. (dot) to increase the number of input dots.

Adding accidentals
You can add basic accidentals to individual notes during note input.

PROCEDURE
1.

To add an accidental, do one of the following:
●

On the notes panel, click Natural , Flat , or Sharp .

●

In Write mode, on the computer keyboard, press the respective key command.
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2.

Input a note.

RELATED LINKS
Key commands in Dorico on page 10

Adding articulations
You can add articulations to notes or chords during note input.
PROCEDURE
1.

To add an articulation, do one of the following:
●

On the keyboard, press the respective key command for a duration.

●

On the notes panel, activate one of the articulations buttons.

IMPORTANT
You can add an articulation of duration and an articulation of force to the same note
or chord. If you add a second articulation of the same type to a note or chord, the new
articulation replaces the existing one.
2.

Input a note.

Adding tuplets
NOTE
To add a triplet, you can also click Tuplets

.

PROCEDURE
1.

Start note input.

2.

Activate the tuplets function by pressing the respective key command on your computer
keyboard.

3.

Add the ratio for the tuplet you want. For example, enter 4:6 to input four notes in the
duration normally occupied by six.
NOTE
To add a triplet, you can enter either 3:2 or 3.

4.

Press Enter to close the tuplets popover.

5.

Input the notes you want.

6.

Optional: Deactivate tuplet input by pressing the respective key command on your
computer keyboard.

RELATED LINKS
Key commands in Dorico on page 10
Inputting notes on page 94
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Adding notes above and below existing notes
You can add notes above and below existing notes. You can multiple notes at the same time,
according to their intervals relative to the existing notes.
PROCEDURE
1.

Select the notes to which you want to add notes.

2.

Open the add intervals popover in any of the following ways:
●

Press Shift-I.

●

Choose Write > Add Intervals Popover.

3.

Enter the intervals of the notes you want, relative to your selected notes. For example,
enter -m3,4 to add notes a minor third below and a fourth above the selected notes.

4.

Press Return to close the popover.

RESULT
Notes are added to the selected notes according to the intervals you entered into the add
intervals popover.
RELATED LINKS
The add intervals popover on page 105
Changing the pitch of existing notes on page 460

The add intervals popover
The add intervals popover allows you to add notes above and below existing notes, and also
transpose existing notes.
Add intervals popover. A new command Write ▸ Add Intervals Popover has been added, with the
default key command Shift+I.
This popover makes much of the functionality provided by the Add Notes Above or Below and
Transpose dialogs accessible directly via the keyboard.
You can open the add intervals popover in Write mode in any of the following ways:
●

Press Shift-I.

●

Choose Write > Add Intervals Popover.

The table shows some example of how to structure your entry to transpose notes or add notes to
existing notes.
Enter:

To add or transpose notes:

t3 or t6

Transpose notes upwards

t-5 or t-3

Transpose notes downwards

3 or 3rd

Add notes a third above
NOTE
The ordinal suffix is not necessary but you can
include it if you wish.

-4 or -4th

Add notes a fourth below
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Enter:

To add or transpose notes:
NOTE
The ordinal suffix is not necessary but you can
include it if you wish.

3,6 or -3,3,4

Add multiple notes separated by commas but
no spaces.

3 all or -M2,m3 to all

Add notes above or below all notes in selected
chords.

-3 top or dim5 top

Add notes only to the top notes in chords.

aug4 bottom or -2 bottom

Add notes only the to bottom notes in chords.

p, per, or perf

Perfect interval

M, maj, or major

Major interval

m, min, or minor

Minor interval

d, dim, or diminished

Diminished interval

a, aug, or augmented

Augmented interval

diat or diatonic

Diatonic interval

t 3 8 qt

Transpose notes by mictrotonal intervals.
NOTE
The first number is the interval degree.
The second number is the number of
quartertones.

If you do not otherwise specify it, the interval will be calculated by adding or transposing notes
by the number of staff positions specified, e.g. in C major, if the selected note is a D natural and
you specify 3 to add a third above, the added note will be an F natural. You can specify the quality
of the interval by entering the interval you want before the interval.
If the selected material already includes chords, notes are added above the top note in the chord,
and added below the bottom note in the chord. You can add notes to all notes in selected chords
by including all or to all at the end of your entry.
RELATED LINKS
Adding notes above and below existing notes on page 105
Transposing existing notes using the add intervals popover on page 107
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Transposing existing notes using the add intervals popover
PROCEDURE
1.

Select the notes you want to transpose.

2.

Open the add intervals popover in any of the following ways:
●

Press Shift-I.

●

Choose Write > Add Intervals Popover.

3.

Enter the intervals of the transposition you want. For example, enter t3 to transpose the
notes up a third, or t-min6 to transpose the notes down a minor sixth.

4.

Press Return to close the popover.

RESULT
The selected notes are transposed by the degree specified.
RELATED LINKS
The add intervals popover on page 105

Inputting grace notes
The Grace Notes tool allows you to input grace notes instead of notes. You can input slashed
and unslashed grace notes.
PROCEDURE
1.

Do one of the following:
●

In the notes toolbox, activate Grace Notes

●

Press the respective key command.

.

2.

On the notes panel, select a duration.

3.

Optional: Press the respective key command in your language to change between slashed
and unslashed grace notes.
NOTE
The type of grace note that you input is displayed within the tool icon in the notes toolbox.
You can change the grace note type after note input.

4.

Input the grace note.

5.

Deactivate the Grace Notes tool to continue note input.

RELATED LINKS
Changing the grace note type on page 107
Key commands in Dorico on page 10

Changing the grace note type
When inputting grace notes, slashed grace notes are input by default. If you did not switch
between the different grace note types during note input, you can change the grace note type
after note input.
PROCEDURE
1.

Select the grace note.
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2.

Open the properties panel.

3.

In the Grace Notes group of the Properties panel, do one of the following:
●

Activate Unslashed

●

Activate Slashed

to change the grace note to an unslashed grace note.

to change the grace note to a slashed grace note.

Adding time signatures
When you add time signatures to your project, Dorico adds the barlines automatically at the
correct places.
PROCEDURE
1.

Select the first note or rest on the staff.

2.

Do one of the following:
●

Press Shift-M.
This opens a small popover on top of the staff.
Enter a typical time signature, such as 3/4 and press Enter.

●

In the notations toolbox, select Time Signatures (Meter) .
On the Notations panel, select one of the time signatures in the Common section or
create a custom time signature in the Create Time Signature section.

RELATED LINKS
Creating custom time signatures on page 108

Adding time signatures with a pickup
You can define a pickup, also known as anacrusis or upbeat, in combination with time signatures.
PROCEDURE
1.

Select the first note or rest on the staff.

2.

Press Shift-M.

3.

In the popover, enter a time signature, press , and enter the number of notes that you
want to input as pickup, for example 3/4,1.

RESULT
When you start inputting notes, a barline is inserted automatically after the pickup. All the notes
that follow, follow the set time signature.
RELATED LINKS
Creating custom time signatures on page 108

Creating custom time signatures
You can create custom time signatures.
PROCEDURE
1.

In the notations toolbox, select Time Signatures (Meter).

2.

On the Notations panel, open the Create Time Signature section.

3.

From the upper pop-up menu, select the type of time signature that you want to create.
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4.

In the top and bottom rows of input fields below the selected time signature, which show a
sample entry for a 4/4 time signature, you have the following options:
●

To create a regular time signature, input the numerator into the first top input field
and the denominator into the first bottom input field.

●

To create interchangeable, aggregate, or alternating time signatures, start inputting
the numerators and denominators into the leftmost top and bottom input fields and
continue input further to the right.
NOTE
You can use Tab/Shift-Tab to move back and forth between the input fields.

The resulting time signature is shown at the bottom of the section.
5.

Optional: Activate Pickup bar of and from the pop-up menu, select the pickup, also known
as anacrusis or upbeat, that you want to use.

6.

Click the displayed time signature.

7.

Optional: If you did not select a note or chord, you can move the mouse pointer to the
position where you want to insert the time signature and click.

RESULT
The time signature is inserted. All the notes that follow, follow the set time signature.
RELATED LINKS
Adding custom time signatures using the popover on page 109

Adding custom time signatures using the popover
In the popover on top of the staff, you can enter different custom time signatures by using
different key combinations on your computer keyboard.
Each of the custom time signatures that you can create on the notes panel in the Create Time
Signature section, can also be created by using the popover (Shift-M) and the keys on your
computer keyboard, as described in the following examples:
NOTE
Default time signatures are entered as follows: numerator, slash, denominator, for example: 3/8.

Time signatures with beat groupings
Enter the required numerators and plus symbols, then a slash and the denominator without
empty spaces. If you surround the numerators with brackets, these are added together and are
shown as one number.
EXAMPLE
Time Signatures with Beat Groupings
2+2+2+3/8 creates the following time signature:

Time Signatures with Beat Groupings That Are Added Together
[2+2+2+3]/8 creates the following time signature:
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Alternating time signatures
Enter a time signature, add an empty space, a plus symbol, an empty space, and then an
alternate time signature.
EXAMPLE
3/8 + 2/8 creates the following time signature:

Interchangeable time signatures
Enter a time signature, an empty space, and then another time signature in parentheses.
EXAMPLE
3/8 (2/8) creates the following time signature:

Aggregate time signatures
Enter a time signature, an empty space, a vertical bar, an empty space, and then another time
signature. The resulting displayed time signature is visually identical with the alternating time
signature, but it creates bars that have a length of both time signatures added together. The
bars are subdivided by a dashed barline where the first bar normally ends.
EXAMPLE
3/8 | 2/8 creates the following time signature:

The bars are subdivided as follows:

Text
Dorico allows you to add text that is attached to a particular position on a staff.
NOTE
To insert text that is independent of rhythmic positions and that is attached to a particular page,
you can add text frames on master pages in Engrave mode.
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Any text that you add to the score is automatically added above the staff to which it is attached,
in the default paragraph style and two and a half spaces from the outside of the staves.
RELATED LINKS
Adding text on page 112
Changing the position of added text on page 113
Text frames on page 148

Text Editor
The text editor allows you to add and format text.
The text editor opens in the following circumstances:
●

You add or change text that is attached to a staff.

●

You enter text within a text frame.

The text editor provides the following options:
Paragraph Style
Determines the appearance and alignment of the text for a whole paragraph.
NOTE
Text that is attached to a staff is always treated as a single paragraph.
Character Style
Determines the appearance of marked text.
NOTE
If you use one of the defined character styles in the text editor, the appearance that
is defined by the selected paragraph style is overridden.
Font
Allows you to change the font family of marked text.
Font Style
Allows you to change the font style of marked text.
Font Size
Allows you to change the size of marked text.
Font Stretch
Allows you to make marked text wider or narrower.
Baseline Shift
Allows you to gradually shift the baseline of marked text up or down.
Letter Spacing
Allows you to increase/decrease the space between the characters of marked text.
Word Spacing
Allows you to increase/decrease the space between the words of marked text.
Foreground Color
Allows you to change the foreground color of marked text.
Background Color
Allows you to change the background color of marked text.
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Align Left
Allows you to align text to the left relative to the rhythmic position of the text in
the score. For text in a text frame, the text is aligned along the left margin of a text
frame.
Align Center
Allows you to centers the text relative to the rhythmic position of the text in the
score. For text in a text frame, the text is centered between the left and right margins
of a text frame.
Align Right
Allows you to align text to the right relative to the rhythmic position of the text in
the score. For text in a text frame, the text is aligned along the right margin of a text
frame.
Justify
For text in a text frame, the space between words is adjusted so that each line spans
the full width of a text frame.
Underline
Allows you underline selected text.
Overline
Allows you to overline selected text.
Strikethrough
Allows you to strike through selected text.
Superscript
Allows you to position selected text higher than the text on the baseline.
Subscript
Allows you to position selected text lower than the text on the baseline.
RELATED LINKS
Adding text on page 112
Entering text in text frames on page 149
Paragraph styles on page 152
Character styles on page 155

Adding text
You can add text at a specified rhythmic position in the score.
PROCEDURE
1.

2.

Do one of the following:
●

Activate the caret and move it to the position where you want to add text.

●

Select a note or notation to determine a position.

Do one of the following:
●

Click Text

●

Press Shift-X.

●

Select Write > Create Text.

.

The text editor opens.
3.

Enter text.

4.

Optional: Format the text using the text editor options.
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5.

Close the text editor by doing one of the following:
●

Click anywhere outside the text editor.

●

Press Esc.

●

Press Ctrl/Cmd-Enter.

Inserting line breaks
You can insert line breaks while entering text into the score.
NOTE
Inserting line breaks only adds new lines, but no new paragraphs.

PROCEDURE
1.

Enter text.

2.

Press Enter.

RESULT
A new line is inserted. The cursor jumps to the beginning of the new line.

Changing the position of added text
You can position added text above or below the staves.
PREREQUISITE
The text editor is closed.
PROCEDURE
1.

Select the text.

2.

Choose between Above or Below for the Position property in the Text group of the
Properties panel.

RESULT
The text changes its position relative to the staff position where it was created.
AFTER COMPLETING THIS TASK
If you need to move the text to a different graphical position, you can drag the text manually in
Engrave mode.

Lyrics
Dorico allows you to input multiple lines of lyrics, chorus lyrics, and translations.
You can input lyrics above or below the staves. Using a popover and a set of key commands you
can input lyrics line by line and syllable by syllable.
All lyrics are automatically horizontally aligned with the notes to which they belong. Multiple lines
of lyrics are automatically vertically aligned.
You can designate whole lines or a selection of lyrics as a chorus line. You can also enter the
chorus directly using the popover. In the popover, the chorus is marked with the letter “c”. In the
score, the chorus is written in italics without a verse number. If the chorus follows several lines of
lyrics on the same staff, the chorus is centered vertically relative to the lines of lyrics.
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You can designate any existing lines, a selection of lyrics, or a chorus line as a translation. You
can also enter translations directly using the popover. In the popover, the translation is marked
with a verse number or a “c” and an asterisk (*). In the score, the translation is written in italics. If
you have multiple lines of lyrics, every translation line can be positioned below a line of lyrics.
If you need to make changes to the position of lyrics or if you want to activate/deactivate verse
numbers, Dorico provides several options in the Properties panel or on the Lyrics page in
Engrave > Engraving Options (key command Ctrl/Cmd-Shift-E) which allow you to: change
selected syllables, whole lines of lyrics, or make project-wide changes to how lines of lyrics are
aligned.
RELATED LINKS
Lyrics on page 425
Lyrics section on page 125

Key commands for inputting lyrics
Dorico provides several key commands that help you to input lyrics.
The following key commands are available by default:
Lyrics Key Commands
Task

Key Command

Add lyrics.

Shift-L

NOTE
Only available if you selected a note, a rest, or
a syllable.

Finish the current word and move to the next
note or chord.

Space

Finish the current syllable and move to the
next note or chord.

- (hyphen)

Add an extender line to indicate that a word is
sung over multiple notes.

Repeat Space as often as required.

Add several hyphens to indicate that a syllable
is sung over multiple notes.

Repeat - (hyphen) as often as required.

Increase/Decrease the line number.

Down Arrow/Up Arrow

Switch between lyric/chorus line and
translation line.

Alt-Down Arrow/Alt-Up Arrow

NOTE
The translation line shows an asterisk (*) in the
popover.

Move forwards/backwards from syllable to
syllable within lines of lyrics.
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Task

Key Command

Add spaces within a word or syllable.

Shift-Alt-Space

Add an elision

_ (underscore)

Forcing a hyphen within a single word or
syllable

Alt-- (hyphen)

Adding lyrics
You can add multiple lines of lyrics to a staff.
PROCEDURE
1.

Select the note or chord where you want to start adding lyrics.

2.

Do one of the following:
●

Press Shift-L.

●

Click Lyrics

.

A popover opens that shows you the line number for which you input the lyrics.
3.

Optional: Press Down Arrow/Up Arrow to specify the line number.

4.

Input the lyrics.

AFTER COMPLETING THIS TASK
Repeat the steps to add further lines of lyrics.

Adding chorus lines
You can add a chorus line.
NOTE
The default key commands for adding lyrics apply.

PROCEDURE
1.

Select the syllable of a line of lyrics, or a note or chord where you want to start adding the
chorus.

2.

Press Shift-L.

3.

In the popover that opens, press Up Arrow.
The popover now shows a “c” instead of a line number.

4.

Input the chorus.
NOTE
Alternatively, you can do one of the following:
●

Input a lyrics line and select a word or syllable. Then right-click the lyrics line, and
from the context menu, select Lyrics > Line > Chorus.

●

Left-click and drag a rectangle around the whole chorus line to select it, and activate
the Chorus property in the Lyrics group of the Properties panel.
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RESULT
A chorus line is added in italics. If you activated verse numbers on the Lyrics page in Engrave >
Engraving Options, the verse number is removed.
RELATED LINKS
Showing and hiding verse numbers on page 450
Lyrics section on page 125

Adding translations
You can add translations to lyrics and chorus lines.
NOTE
The default key commands for adding lyrics apply.

PROCEDURE
1.

Select the syllable of a line of lyrics or the note or chord where you want to start adding
translations.

2.

Press Shift-L to open the popover.

3.

Press Alt-Down Arrow/Up Arrow to switch from lyrics line to translation line.
NOTE
The translation line shows an asterisk (*).

4.

Input the translation.
NOTE
Alternatively, you can do one of the following:
●

Add a line of lyrics or a chorus line and select a syllable. Then right-click the line,
and from the context menu, select Lyrics > Translations > Line <line number>
Translation/Chorus Translation.

●

Add a line of lyrics or a chorus line and select a syllable or a whole line. Then activate
the Is translation property in the Lyrics group of the Properties panel.

RESULT
A translation line is added italics. If you added verse numbers on the Lyrics page in Engrave >
Engraving Options (key command Ctrl/Cmd-Shift-E), the verse number is removed.
RELATED LINKS
Showing and hiding verse numbers on page 450
Lyrics section on page 125

Changing lines of lyrics
You can change the line numbers of whole lines of lyrics. This also changes the position of the
lines of lyrics.
NOTE
To identify which line you are working on, select a syllable in the line of lyrics and check the Line
number property in the Properties panel. Alternatively, you can activate verse numbers on the
Lyrics page in Engrave > Engraving Options (key command Ctrl/Cmd-Shift-E).
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PROCEDURE
1.

Select a syllable within a line of lyrics.

2.

Right-click and from the context menu, select Lyrics > Line > Line <number of line>.
NOTE
Alternatively, left-click and drag a rectangle around the whole line, and select a number for
the Line number property in the Lyrics group of the Properties panel.

RESULT
The line of lyrics is moved to the selected position within a set of multiple lines. If you activated
verse number, the line of lyrics shows a different verse number.
RELATED LINKS
Showing and hiding verse numbers on page 450
Lyrics section on page 125

Moving syllables to different lines of lyrics
You can move selected syllables to different lines of lyrics.
NOTE
To identify which line you are working on, select a syllable in the line of lyrics and check the Line
number property in the Properties panel. Alternatively, you can activate verse numbers on the
Lyrics page in Engrave > Engraving Options (key command Ctrl/Cmd-Shift-E).

PROCEDURE
1.

Select a syllable within a line of lyrics.

2.

Select a number for the Line number property in the Lyrics group of the Properties panel.

RESULT
The syllable is moved to the selected line of lyrics. If the line of lyrics already contains a syllable,
that syllable is overwritten.
RELATED LINKS
Showing and hiding verse numbers on page 450
Lyrics section on page 125

Moving lines of lyrics to different lines
You can move whole lines of lyrics to different lines.
NOTE
To identify which line you are working on, select a syllable in the line of lyrics and check the Line
number property in the Properties panel. Alternatively, you can activate verse numbers on the
Lyrics page in Engrave > Engraving Options (key command Ctrl/Cmd-Shift-E).

PROCEDURE
1.

Select a syllable within a line of lyrics.

2.

Right-click the line, and from the context menu, select Lyrics > Line > Line <number of
line>.
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NOTE
Alternatively, left-click and drag a rectangle around the whole line, and select a number for
the Line number property in the Lyrics group of the Properties panel.

RESULT
The line of lyrics is moved to the selected line. If that line already contains a line of lyrics, the lines
are exchanged.
RELATED LINKS
Showing and hiding verse numbers on page 450
Lyrics section on page 125

Moving syllables to different lines
You can move selected syllables to different lines of lyrics.
NOTE
To identify which line you are working on, select a syllable in the line of lyrics and check the Line
number property in the Properties panel. Alternatively, you can activate verse numbers on the
Lyrics page in Engrave > Engraving Options (key command Ctrl/Cmd-Shift-E).

PROCEDURE
1.

Select a syllable within a line of lyrics.

2.

Select a number for the Line number property in the Lyrics group of the Properties panel.

RESULT
The syllable is moved to the selected line of lyrics. If the line of lyrics already contains a syllable,
that syllable is overwritten.
RELATED LINKS
Showing and hiding verse numbers on page 450
Lyrics section on page 125

Placing lyrics above or below staves
You can place one or several lines of lyrics, chorus lines, and translations above or below staves.
PROCEDURE
1.

Select a syllable within a line of lyrics.

2.

Right-click and from the context menu, select Lyrics > Placement > Above/Below.
NOTE
Alternatively, you can mark one or several whole lines, and choose between Above or
Below for the Line placement property in the Lyrics group of the Properties panel.

RELATED LINKS
Lyrics section on page 125
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Placing syllables above or below staves
You can place selected syllables from lyrics above or below staves.
PROCEDURE
1.

Select one or multiple syllables within a line of lyrics.

2.

Choose between Above or Below for the Line placement property in the Lyrics group of
the Properties panel.

RELATED LINKS
Lyrics section on page 125

Aligning syllables within lyrics
If syllables collide within a line of lyrics, you can change their alignment.
PROCEDURE
1.

In a line of lyrics, select one or more syllables that you want to align with the rest of the
text.

2.

Activate Lyric text alignment in the Lyrics group of the Properties panel.

3.

From the menu, select one of the alignment options.

RELATED LINKS
Lyrics section on page 125

Properties in Write mode
In Write mode, you can edit notes and notations and change the way your music is notated for
each flow.
If you want to edit individual items, you can use the properties panel that allows you to make
direct changes to selected items in the score. To make changes to the way Dorico notates your
music in general, you can use the Notation Options. You can set the Notation Options for all
flows or for each flow independently.
RELATED LINKS
Options in the Properties panel on page 121
Notation Options on page 119
Flows on page 80

Notation Options
The Notation Options dialog provides multiple options that allow you to make changes that
affect the way music is notated for each flow.
The changes that you can make affect the following:
●

Note and rest grouping, such as the handling of syncopated rhythms or of different
rhythms in different time signatures

●

Voices, such as the sharing of noteheads among voices or the order in which multiple
voices are tucked together

●

Accidentals, such as the handling of cautionary or courtesy accidentals

●

Transposition, such as the handling of key signatures in transposing instruments
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TIP
If you want to make direct changes to notes and notations, you can use the different options in
the Properties panel.
You can open Notation Options in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

The Notation Options dialog

The Notation Options dialog consists of the following items:
1

Category
Select a category from this menu to show the page containing all the relevant options for
the selected notation category.

2

Flows
Lists all the flows that are available in your project. You can select one, multiple, or all
flows. You can select multiple flows in the following ways:

3

●

Ctrl-click to select multiple flows

●

Shift-click to select multiple adjacent flows

Select All
Allows you to select all flows in the Flows list.

4

Save As Default
Saves all options that you set in Notation Options as default for new projects.

5

Section

120

Write mode
Note input
Pages are divided into sections, which can contain multiple options. The currently selected
option is highlighted. Click other options to choose them instead.
RELATED LINKS
Options in the Properties panel on page 121
Flows on page 80

Changing the Notation Options
You can change the Notation Options for one or several flows.
PROCEDURE
1.

In Write mode, select Write > Notation Options.

2.

In the Notation Options dialog, from the Flows list, select one, multiple, or all flows.

3.

From the Select a Category pop-up menu, select a category.

4.

In the area on the right, make your changes.

5.

Click Apply.

Options in the Properties panel
The Properties panel in Write mode provides options that allow you to edit notes and notations.
The options that are available on the Properties panel depend on the item that you select in your
score. Only properties relevant to the currently selected item are displayed. If you select multiple
different types of notation items, only properties that they have in common are displayed.
For example, if you select a note, at the very least the Common group and the Notes and Rests
group are displayed. If you select a tied note with an articulation, the Common group, the Notes
and Rests group, the Ties group, and the Articulations group are displayed. This shows you all
the options that you may want to change for that note.

Changing the properties of individual items in Write mode
You can change the properties of notes and notations.
NOTE
You can only change a complete note or a complete notation. To make changes to individual
parts of notes or notations, switch to Engrave mode, for example, if you want to change
the length of a note stem. To change notes and notations project-wide for your project, you
must edit the Notation Options, by choosing Write > Notation Options or by pressing Ctrl/
Cmd-Shift-N.

PROCEDURE
1.

Select a note or notation item in the score.

2.

Open the Properties panel in any of the following ways:

3.

●

Press Ctrl/Cmd-8

●

Click its disclosure arrow at the bottom of the window

Change the appropriate properties in the Properties panel.

RESULT
The complete note or notation item is changed. The changes are immediately displayed in the
music area.
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RELATED LINKS
Properties panel on page 90
Common section
The Common section of the properties panel is available for all items in the music area.
NOTE
If you select different types of items in the music area at the same time, only the Common
section is available for editing purposes.
Position
Shows the rhythmic position of a selected item, expressed as a number of quarter
note beats from the start of a flow.
Muted
If you activate this option, you can mute selected notes or chords during playback.
You can also mute any other notation that affects playback, such as dynamics.
Color
If you activate this option, you can change the color of a selected item. Click the box
to the right. In the Select Color dialog that opens, select one of the available basic
colors, pick a color from the screen, or specify a custom color.
Articulations section
In the Articulations section of the properties panel, you can edit the position and the visibility of
articulations.
NOTE
To edit an articulation, you must select the note to which the articulation belongs.
Placement
Allows you to change the placement of an articulation of a selected note. You can
decide whether you want the articulation placed on the notehead side or on the stem
side.
Hidden
Allows you to hide an articulation of a selected note. If an articulation is hidden, it
is still played back, but it is not visible in the score. You can instead show a signpost
that you can activate by selecting View > Signposts.
Pos. in tie chain
Allows you to specify whether an articulation of a tied note is positioned at the start
or end note in the tie chain.
Dynamics section
In the Dynamics section of the Properties panel, you can edit the position and change the style
of selected dynamics.

Common Options for All Dynamics
Placement
If you activate this option, you can place a selected dynamic above or below the staff.
Parenthesized
Adds parentheses to a selected dynamic.
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Prefix
Allows you to add or edit a custom prefix to a selected dynamic. For example, you
can add sempre before fortissimo (ff).
Suffix
Allows you to add or edit a custom suffix to a selected dynamic. For example, you can
add strongly after fortissimo (ff).
Show intensity marking
Only available for immediate or combined dynamics and for markings of force/
intensity of attack.
Dorico allows you to input a custom dynamic into your score, such as sempre or
strongly, if you combine it with another dynamic that is used as an intensifier. If
you activate/deactivate this option, the intensifier is shown/hidden.
Beat-relative position
Only available for immediate or combined dynamics and for markings of force/
intensity of attack.
Normally, the optical center of a dynamic is aligned with the rhythmic position of
the note or chord. If you activate this option, you can specify if you want to position
the dynamic at the end of the beat before that rhythmic position. In the case that
a dynamic is preceded by a crescendo or diminuendo, and there is no note or
chord at the rhythmic position at which the gradual dynamic ends, the dynamic is
automatically positioned at the end of the last beat that is affected by the gradual
dynamic. In this case, you can move the dynamic to the next rhythmic position.
The following options are available:
●

Before
Positions the dynamic at the end of the last beat.

●

After
Positions the dynamic to the next rhythmic position after the last beat.

Text alignment
Only available for immediate dynamics or combined dynamics and for markings of
force/intensity of attack.
If you activate this option, you can align a dynamic with the note to which it is
assigned. You have the following options:
●

Align optical center with notehead
The centers of the dynamic and the notehead are aligned.

●

Left-align with notehead
The dynamic starts at the start of the notehead.

Gradual Dynamics Options
Type
Allows you to select between Cresc. or dim. and Messa di voce as types of gradual
dynamics. Cresc. or dim. enables the Gradual style pop-up menu that allows you to
choose between different crescendo/diminuendo hairpins or text.
Gradual style
Only available if you activate Cresc. or dim. as type of gradual dynamic.
Allows you to select between hairpins, short text instructions, or hyphenated text
instructions.

123

Write mode
Note input
Hairpin line style
Only available if you select Hairpin from the Gradual style menu, or if you select
Messa di voce as type of gradual dynamic.
Allows you to select how you want the lines of a hairpin to be shown. You have the
following options:
●

Solid
Shows the hairpin with solid lines.

●

Dashed
Shows the hairpin with dashed lines.

●

Dotted
Shows the hairpin with dotted lines.

Niente
Adds niente to a crescendo, diminuendo, or messa di voce.
Niente style
Only available if you select Hairpin from the Gradual style menu or if you activate
Messa di voce as type of gradual dynamic.
If you activate this option, you can select one of the following styles for the selected
niente:
●

Circle on hairpin
Adds a small circle to the end of the diminuendo or to the start of the
crescendo.

●

Text
Adds an “n” to the end of the diminuendo or to the start of the crescendo.

Poco a poco (little by little)
Adds poco a poco to a crescendo, diminuendo, or messa di voce.
Abbreviate
Only available if you select a crescendo/diminuendo text style from the Gradual
style menu.
If you activate this option, the text for the selected crescendo/diminuendo is
abbreviated.
Messa di voce inflection
Only available if you activate Messa di voce as type of gradual dynamic.
The inflection point of a messa di voce is the point at which the first hairpin ends and
the second begins. The inflection point is determined automatically when the messa
di voce is created based on the rhythm of the notes in the span of the dynamic.
If you activate this option, you can adjust the rhythmic position of the inflection
point. The value in the left field specifies the primary rhythmic position, expressed
in fractions of quarter notes. The value in the right field allows you to specify a
secondary rhythmic position within a run of grace notes at the primary rhythmic
position.
Diminuendo style
Only available if you select cresc./dim. for a diminuendo from the Gradual style
menu.
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If you activate this option, you can select the text that you want to display
for a diminuendo and thus use the terms “diminuendo” and “decrescendo”
interchangeably.
NOTE
You can specify the default text appearance for a diminuendo in the engraving
options by selecting Engrave > Engraving Options > Dynamics > Appearance of
gradual reduction in dynamic.
Barline Interaction
If you activate this option, you can set a hairpin to stop before a barline or to
continue after a barline.
Continuation line style
Only available if you select cresc.... from the Gradual style menu.
If you activate this option, you can specify whether the line that indicates the
duration of the dynamic change is dashed or dotted.

Force/Intensity of Attack Options
rfz/sfz style
If you activate this option, you can decide whether you want to show markings of
force/intensity of attack with an ending “z” or not.

Combined Dynamics Options
Separator shown
If you activate this option, you can insert a separator between the combined
dynamics.
Separator
If you activate this option, you can specify the type of separator by selecting the one
you want from the menu.
Lyrics section
In the Lyrics section of the properties panel, you can make changes to selected syllables or
whole lines of lyrics.
Syllable type
Allows you to change the type of selected syllables.
Line placement
Allows you to move selected syllables above or below a staff.
Line number
Allows you to change the line number for selected syllables.
Chorus
If you activate this option, you can select syllables and designate them as chorus
lyrics that are centered vertically in relation to other preceding lines of lyrics. Chorus
lyrics are displayed in italics.
Is translation
If you activate this option, you can specify lines of lyrics as translations of song lyrics.
Translations are displayed in italics.
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Lyric text alignment
If you activate this option, you can align selected syllables horizontally in relation to
the noteheads. By default, syllables are centered below the notes.
RELATED LINKS
Placing lyrics above or below staves on page 118
Changing lines of lyrics on page 116
Moving lines of lyrics to different lines on page 117
Adding chorus lines on page 115
Adding translations on page 116
Aligning syllables within lyrics on page 119
Rehearsal marks section
In the Rehearsal Marks section of the properties panel, you can change the type of selected
rehearsal marks and the number or letter with which they should start.
Sequence type
If you activate this option, you can choose whether the selected rehearsal mark is
displayed as a letter, a number, or whether it shows the current bar number.
Index
If you selected Numbers or Letters as Sequence type and activate this option, you
can increase or decrease the number or the letter with which the selected rehearsal
mark should start.
Trills section
In the Trills section on the properties panel, you can change the placement and appearance of
selected trills and trill lines.
Placement
If you activate this option, you can move a trill above or below a staff.
Start speed
If you activate this option, you can specify how fast a trill starts. The trill line
automatically changes its form according to your setting.
End speed
If you activate this option, you can specify how fast a trill ends. The trill line
automatically changes its form according to your setting.
Has trill line
If you activate this option, you can specify if a trill has a trill line.
Start position
If you activate this option, you can specify if you want a trill to be positioned starting
at the notehead or at the accidental of the note.
Extra gap position
If you activate this option, you can specify if you want a gap position at the start or at
the end of the trill line.
Interval
If you activate this option, you can choose the number of half-steps between the two
notes of a trill.
Accidental position
If you activate this option and you are using an accidental as trill interval, you can
specify if you want the accidental to be placed above, below, or in line with the trill.
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Inside slurs, tuplets, and octave lines
If you activate this option, the selected trill is positioned inside slurs, tuplets, and
octave lines.
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Engrave mode allows you to manipulate and modify every item in your project. You can
determine how the pages of your project are formatted for later print or export.

Project window in Engrave mode
The project window in Engrave mode contains the default toolbar, the music area, and the
status bar. It provides panels with all the tools and functions that allow you to format the pages,
systems, and properties of individual notations in your score.
To open Engrave mode, you have the following options:
●

Select Engrave on the toolbar.

●

Select Window > Engrave

The panels are located on the left, right, and bottom of the project window and can be shown or
hidden.

Panels in Engrave mode

The following panels are available:
1

Formatting
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Allows you to insert and align different kinds of frames in pages. You can also make
changes to how a system is formatted on a page.
2

Properties
Contains quick access properties that allow you to make specific modifications to
individual parts of notes and notations.

3

Pages
Allows you to specify how the notation is formatted on pages. The way this is done is
based on the typical techniques as they are used in desktop publishing programs.

RELATED LINKS
Windows on page 36

Formatting panel
The formatting panel in Engrave mode allows you to insert different kinds of frames into pages
and to specify how these are aligned on a page. You can also make changes to how a system is
formatted on a page.
To show/hide the formatting panel, click the disclosure arrow

/

to the left of the music area.

The formatting panel is divided into the following sections:

Frames
The Frames section allows you to create new frames on a page and to specify the constraints
between the frames and the page margins. To make changes, activate this section.
Insert Music Frame
Allows you to insert a frame for which you can specify the layouts that you want to
show.
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NOTE
To specify which parts are visible in the default frame, you must edit the master
pages of the used master page set.
Insert Text Frame
Allows you to insert a frame into which you can enter text that you can format
according to your needs.
Insert Graphics Frame
Allows you to insert an frame that can contain an image or an illustration.
Constraints
Allows you to specify which sides of the frame you want to lock to the page margin.
RELATED LINKS
Frames on page 145
Master pages on page 133
Constraints on page 158

Properties panel
The properties panel in Engrave mode contains quick access properties that allow you to make
specific modifications to individual parts of notes and notations.
To show/hide the properties panel, click the disclosure arrow

/

below the music area.

The properties panel contains several sections. Whenever you select a note or notation, or part of
a note or notation, and open the properties panel, the properties panel displays the sections and
the respective options that you may require to edit the selected item.
EXAMPLE
If you select a note or rest, the Notes and Rests section becomes available in the properties
panel.

RELATED LINKS
Options in the Properties panel on page 164
Changing the properties of individual items in Engrave mode on page 164

Pages panel
The pages panel in Engrave mode provides several sections that allow you to specify how the
pages of your notation are formatted. The way this is done is based on the typical techniques as
they are used in desktop publishing programs.
To show/hide the pages panel, click the disclosure arrow
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Pages panel in Engrave mode

The pages panel is divided into the following sections:

Pages
Pages Display
Shows the pages in your layout with their page number. A highlighted page frame
indicates a selected page. Markings in the upper left and the bottom right corner
of the pages indicate that a page has overrides. Additional frames at the top or left
frames of the page indicate that master page changes have been applied.
Insert Pages

Allows you to insert pages into your layout before or after existing pages, based on a
selected master page.
Insert Page Number Change

Allows you to change the page numbers for pages in your layout.
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Insert Master Page Change

Allows you to assign a different master page to a selected page.
Swap with Previous Page

Moves a selected page to the position of the previous page.
Swap with Next Page

Moves a selected page to the position of the next page.
Remove Overrides

Removes all overrides on a selected page.

Master Pages
Master Pages Display
Shows the master page pairs that are used in your layout. A highlighted frame
indicates the selected master page. If you select a page in the Pages display, the
master pages display highlights the master page pair that is used for this page.
Current set
Shows the master page set that is in use and allows you to select a different master
page set.
New Master Page

Allows you to add a new master page to a master page set.
Edit Master Page

Opens the master page editor in which you can change the master page formats. To
close the master page editor, click Close Master Page Editor.
Rename Master Page

Allows you to rename a selected master page.
Delete Master Page

Deletes a selected master page.

Master Page Sets
Master Page Set List
Shows a list of available master page sets.
New Master Page Set
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Creates a new master page set based on the master page set that is selected in the
list. The new master page set is automatically added to the Current set menu in the
Master Pages section.
Rename Master Page Set

Allows you to rename the selected master page set.
Delete Master Page Set

Deletes a selected master page set from the list.

Master pages
Master pages in Dorico allow the same formatting to be applied to different pages in different
layouts.
NOTE
Page size and margins, page orientation, and staff size for full score and part layouts are
specified in Setup > Layout Options.
All pages in your score and parts inherit their layout formats from master pages. Whenever you
create or change anything on master pages, this is automatically reflected on the pages that use
these master pages. For example, if you insert a new frame on a master page, a corresponding
frame appears on all the pages that use that master frame.
In Dorico, master pages consist of page pairs. Every page pair has a left and a right master page,
so that if a page in your project falls on a left page, the formatting of the left page of the master
page pair is used, and if a page falls on a right page, the formatting of the right page of the
master page pair is used.
Dorico provides default master pages with page pairs for first (First) and subsequent (Default)
pages. This enables you to format first pages differently compared to subsequent pages. Page
pairs are contained in master page sets for full score and part layouts. Master page sets are
automatically applied to every score that you create.
If you want to change the master page sets or to change the format of the master pages, you can
do so in any of the following ways:
●

Create new master pages and master page sets.

●

Edit the default master pages in the master page sets using the master page editor.

●

Override individual master pages.

RELATED LINKS
Master page sets on page 133
Master page editor on page 137
Layout Options on page 85

Master page sets
In Dorico, master pages are provided as parts of master page sets. Master page sets group
master page formats together, so there is a master page for all possible situations in your
project.
The default master page sets contain predefined master pages for first page pairs (First) and
subsequent page pairs (Default). This ensures there is a master page format for the first page
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in each flow, whether that is on a right page or a left page, and a master page format for
subsequent pages in each flow on both right and left pages.
For every new project, the following default master page sets are available:
●

Default Full Score: master page set used for full score layouts

●

Default Part: master page set used for part layouts

You do not need to create or customize master page sets initially, as the default sets are applied
automatically when you create your score. If you find that you want or need to change the sets,
you can do any of the following:
●

Create new custom master page sets based on the default sets.

●

Change the default sets according to your requirements for the current project.

RELATED LINKS
Creating master page sets on page 134

Creating master page sets
You can create custom master page sets that are based on the sets provided by Dorico.
PROCEDURE
1.

Select one of the default master page sets by clicking it in the Master Page Sets section of
the Pages panel.

2.

Click New Master Page Set:

RESULT
A new master page set is created, based on the selected default master page set. It is added at
the bottom of the list of master page sets.

Renaming master page sets
You can edit the names of master page sets that you have created. You cannot rename the
default master page sets.
PROCEDURE
1.

Double-click the master page set that you want to rename in the Master Page Sets section
of the Pages panel.
NOTE
Alternatively, you can select the master page set and click Rename Master Page Set:

2.

Enter the new name you want.

3.

Press Enter.
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Deleting master page sets
You can delete master page sets that you no longer need, including the default master page sets.
PROCEDURE
1.

Select the master page set that you want to delete by clicking it in the Master Page Sets
section of the Pages panel.

2.

Click Delete Master Page Set:

Selecting master page sets
You can select a master page set to be applied to your score.
PROCEDURE
●

Select a master page set from the Current set menu in the Master Pages section of the
Pages panel.

Master page types
If you add a new master page to a master page set, you must specify the type of master page
that you want to add.
You can add the following types of master pages:
First
Creates a page pair that is used for the first page of music in a layout.
NOTE
If you create no First page pair, the first page in your layout uses the Default page
pair.
Default
Creates a default page pair that is used for each successive left and right pages
after the first page of a layout. Every master page set must always contain a Default
master page.
Custom
Creates a custom page pair that is appended after the Default master page in the
master page set. This allows you to create a different page format for final pages, for
example.
NOTE
If you insert a page to a layout using a custom master page, you create an override.
This means that if you insert a page in the middle or at the end of your layout
pages using a custom master page and then remove the override, that page is
automatically assigned the Default master page.

RELATED LINKS
Adding master pages on page 136
Master page overrides on page 138
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Adding master pages
You can add master pages to a master page set.
PROCEDURE
1.

Select a master page set to which you want to add master pages from the Current set
menu in the Master Pages section in the Pages panel.

2.

Click New Master Page:

3.

Enter a name for the new master page into the Name field in the New Master Page
dialog.

4.

Select the master page that you want to use as the basis from the Based on menu.
NOTE
Selecting (None) always creates a master page without any formatting but the page
margins.

5.

Choose one of the following master page types for your new master page:
●

First

●

Default

●

Custom

RELATED LINKS
Selecting master page sets on page 135

Renaming master pages
You can change the names of master pages.
PROCEDURE
1.

Select the master page set containing the master page you want to rename from the
Current set menu in the Master Pages section of the Pages panel.

2.

Click the master page pair that you want to rename in the Master Pages section.

3.

Click Rename Master Page:

4.

Enter the name you want in the Name field in the Rename Master Page dialog.

5.

Close the dialog and save the new name in any of the following ways:
●

Click OK

●

Press Return

Deleting master pages
You can delete master pages from master page sets.
NOTE
Master pages of the type Default cannot be deleted. Every master page set must contain at least
a Default master page.
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PROCEDURE
1.

Select the master page set from which you want to delete master pages from the Current
set menu in the Master Pages section of the Pages panel.

2.

Click the master page pair that you want to delete in the Master Pages section.

3.

Click Delete Master Page:

RESULT
The selected master page pair is deleted.
NOTE
You can undo this action immediately by in the following ways:
●

Press Ctrl/Cmd-Z

●

Choose Edit > Undo

Master page editor
The master page editor allows you to view and change the format of the master pages.
You can open the master page editor in the following ways:
●

Double-click a page pair in the Master Pages section of the Pages panel.

●

Select a page pair in the Master Pages section of the Pages panel and click Edit Master
Page:

You can change master pages in the master page editor in the following ways:
●

Insert and adjust music frames, text frames, and graphics frames in relation to other
frames and the page margins.

●

Assign frames to frame chains.

●

Specify the order in which frames display the notation.

●

Assign flows and players to frames.

Customizing master pages
You can customize master pages according to your needs.
NOTE
If you want to edit the page size and margins, page orientation, and staff size for full score and
part layouts, you must specify these in the layout options.

PROCEDURE
1.

Double-click a master page pair in the Master Pages section of the Pages panel.

2.

In the master page editor, change the layout of the selected master page pair. For
example, you can change the size and shape of frames.

3.

Click Close Master Page Editor to save your changes.
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RESULT
The selected master page pair is changed.
RELATED LINKS
Inserting frames into pages on page 145
Moving frames individually on page 146
Changing the size and shape of frames individually on page 146
Master page editor on page 137
Overriding master pages on page 139
Layout Options on page 85
Paragraph styles on page 152

Master page overrides
All pages of a project inherit their format from the master pages that are specified in the
appropriate master page sets. In some cases, it is also possible to change the format of
individual pages without affecting the underlying master pages or master page sets.
In Dorico, you can override the format of an individual page. For example, you may want to
override the formats for one of the following reasons:
●

To change the size of a music frame on an individual page

●

To insert an empty page

●

To change the page numbering

●

To include comments in the form of footnotes

●

To include small excerpts of music to show how a passage was reproduced in another
source

If you override the pages, they no longer automatically inherit changes that are made to the
master pages. Pages that have been overridden shown with a marking on them in the Pages
section of the Pages panel:
●

Master page overrides: marking shown in top left corner

●

Page number changes: marking shown in bottom right corner

To return the formatting of pages whose formats you have overridden to the master pages, you
must remove the overrides that you made.
NOTE
If you inserted a page in the middle or at the end of your layout using a custom master page and
remove the override, that page is automatically assigned the Default master page of the master
page set.
You can also change the master page used for individual pages. For example, you may want to
change the master page used for pages in a part that has a few pages with more staves than
usual. Or you might want to change the master page used for a score where the instrumentation
is significantly different for one flow and you want the format of those pages to be different.
Pages whose master page has been changed are shown with a marking on them in the Pages
section of the Pages panel:
●

Master page changes to the current page only: marking along top edge

●

Master page changes from the page onwards: marking shown along left edge and top
edge

Here are some examples of how the different overrides you can make to individual pages in
layouts are shown in the Pages section of the Pages panel in Engrave mode.
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Master page override Page number change Master page change
to current page only

Master page change
from selected page
onwards

RELATED LINKS
Overriding master pages on page 139
Removing individual master page changes on page 144
Removing all master page overrides on page 140

Overriding master pages
You can override master page settings on individual pages in your layout.
PROCEDURE
●

Do one of the following:
●

To edit the frames, on the formatting panel, activate the Frames section.
NOTE
If the Filter by Flow and the Filter by Player options cannot be edited, you must
edit the respective master page.

●

To insert, swap, and delete pages, and to change the page numbers, use the options
in the Pages section.

RESULT
As soon as a master page is overridden, the page icon in the Pages display shows a marking in
the upper left or bottom right corner.
RELATED LINKS
Master page overrides on page 138
Frames on page 145

Removing individual master page overrides
You can remove all overrides that you have made to individual pages in each layout, which
returns them to the master page format. Any pages in your layout that contain overrides are
shown with a colored triangle in their top left corner in the Pages section of the Pages panel.
PROCEDURE
1.

Open the layout whose master page overrides you want to remove in the music area.

2.

Select the pages whose overrides you want to remove in the Pages section of the Pages
panel in one of the following ways:

3.

●

Click a single page

●

Ctrl/Cmd-click multiple pages

Remove master page overrides in any of the following ways:
●

Right-click in the Pages section of the Pages panel and choose Remove Page
Overrides from the context menu

●

Click Remove Overrides:
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RESULT
Any overrides you made to the master page format on the selected pages are removed. Empty
pages that are considered overrides are removed completely.
RELATED LINKS
Master page overrides on page 138

Removing all master page overrides
You can remove all overrides that you have made to all pages in your layout, which returns them
to the master page format. Any pages in your layout that contain overrides are shown with a
colored triangle in their top left corner in the Pages section of the Pages panel.
PROCEDURE
1.

Open the layout whose master page overrides you want to remove in the music area.

2.

Right-click in the Pages section of the Pages panel, but not on any of the pages.

3.

Choose Remove All Page Overrides from the context menu.

RESULT
Any overrides you made to the master page format are removed from all pages in the layout
currently open in the music area. Empty pages that are considered overrides are removed
completely.
RELATED LINKS
Master page overrides on page 138

Inserting pages
You can insert empty pages or pages that use a different master page into each layout in your
project.
PROCEDURE
1.

Open the Insert Pages dialog in any of the following ways:
●

Right-click in the Pages section of the Pages panel and choose Insert Pages from
the context menu.

●

Click a page in the Pages section of the Pages panel and click Insert Pages:

2.

Enter a page number into the Number of pages to insert field.

3.

Select where you want to insert pages. For example, select After page and enter 8 to
insert pages after page 8.

4.

Select the master page that you want to assign to the inserted pages from the Use master
page menu.

5.

Click OK.
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Page number changes
The Page Number Change dialog allows you to change the page numbers shown on existing
pages in each layout. You can choose to show pages without page numbers or with different
numbering.
For example, you can change the number type to one of the available types:
●

Roman numeral: such as iii and iv

●

Number: such as 5 and 19

You can also change the visibility of page numbers. For example, you can hide page numbers on
introductory pages by setting their visibility to Not on first page.
When you insert page number changes, a marking is shown in the bottom right corner of the
page in the Pages section of the Pages panel. The new page number is also shown in each page
in the Pages section of the Pages panel, in the appropriate numeral style.
The Page Number Change dialog contains the following options:
From page
Select the page from which you want to change page numbers. The number
indicates its position within the layout.
The Displayed option shows you the number that the selected page currently has,
and how that number appears.
First page number
Enter the page number from which you want the selected page to start.
Sequence type
Select the type of number that the selected page and subsequent pages should have.
Visibility
Specify if a page number is shown or hidden. You can also specify that the page
number is hidden on the page where the page number change occurs.
Subordinate number type
Add a subordinate number to the page number and to specify a type.
Subordinate number
Enter the number from which you want the subordinate numbers to start.
RELATED LINKS
Inserting page number changes on page 141
Master page overrides on page 138

Inserting page number changes
You can change the page numbers of pages in each layout in your project. Inserting page
number changes allows you to change the page number shown, and also the page number style.
For example, you may want to use roman numerals such as ii and iv for front matter pages, and
numbers such as 1 and 3 for music pages.
NOTE
If you change the first page in the layout to an even number, it automatically becomes a lefthand page. This is because even numbered pages should always be on the left-hand page, and
odd numbered pages should always be on the right-hand page.
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PROCEDURE
1.

Open the layout whose page numbers you want to change in the music area.

2.

Select a page in the Pages section of the Pages panel.

3.

Open the Page Number Change dialog in any of the following ways:
●

Right-click and choose Insert Page Number Change from the context menu.

●

Click Insert Page Number Change:

4.

Enter the number of the page from which you want the page number change to start in
the From page field in the Page Number Change dialog. For example, if you want to
change the page number of your current page 3, enter 3.

5.

Enter the new page number that you want the selected page to have in the First page
number field. For example, if you want to change your current page 3 to page 5, enter 5.

6.

Select the numeral style you want from the following options for Sequence type:

7.

●

Number

●

Roman numeral

Click OK.

RESULT
The page number of the selected page is changed. All subsequent pages are changed
correspondingly until the next page number change or the end of the project, whichever comes
first.
NOTE
You can change other aspects of the appearance of page numbers in the Page Number Change
dialog. For example, you can show subordinate numbers as upper case letters or lower case
letters.

RELATED LINKS
Page number changes on page 141

Removing individual page number changes
You can remove individual page numbers changes made to the layout currently open in the
music area, and revert the page number for individual pages back to the default page number.
Any pages whose page number has been changed are shown with a marking in their bottom
right corner in the Pages section of the Pages panel.
PROCEDURE
1.

Open the layout whose page number changes you want to remove in the music area.

2.

Select pages in the Pages section of the Pages panel in one of the following ways:
●

Click a single page

●

Ctrl/Cmd-click multiple pages
NOTE
If no page is selected, all page number changes for all pages are removed.

3.

Right-click in the Pages section of the Pages panel.

4.

Choose Remove Page Number Change(s) from the context menu.
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RESULT
The page number change for the selected page in the layout currently open in the music area is
removed. The page number sequence is restored to the default page number sequence until the
next page number change or the end of the project, whichever comes first.
Any other pages with page number changes in the layout are unaffected.

Removing all page number changes
You can remove all page number changes made to the layout currently open in the music area,
and revert all pages to the default page numbers.
PROCEDURE
1.

Open the layout whose page number changes you want to remove in the music area.

2.

Right-click in the Pages section of the Pages panel, but not on any of the pages.

3.

Choose Remove All Page Number Changes from the context menu.

RESULT
All page number changes in the layout currently open in the music area are removed.
RELATED LINKS
Removing individual page number changes on page 142

Assigning master pages to pages
For every page in your layout, you can assign a different master page.
The selected master page set defines the master pages for every page in the layout. However,
you can change the master page assignment for one or more pages.
PROCEDURE
1.

Click the page for which you want to change the master page assignment in the Pages
section of the Pages panel.

2.

Click Insert Master Page Change:

3.

Optional: Change the start page for the master page change using the From page option.

4.

Select the master page that you want to assign from the Use master page menu.

5.

Choose one of the following options for Range:
●

Current Page Only
If you activate this option, only the selected page is assigned a different master
page.

●

From this Page Onwards
If you activate this option, the selected page and subsequent pages are assigned a
different master page.

6.

Click OK.
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Removing individual master page changes
You can remove master page changes for individual pages, which reverts them to the overall
master page format applied to the layout.
Any pages whose master page has been changed are shown with a marking along their top
edge, or along their top and left edges, in the Pages section of the Pages panel.
PROCEDURE
1.

Open the layout whose master page changes you want to remove in the music area.

2.

Select the pages whose master page changes you want to remove in the Pages section of
the Pages panel in one of the following ways:
●

Click a single page.

●

Ctrl/Cmd-click multiple pages.

NOTE
If no page is selected, all master page changes for all pages are removed.
3.

Right-click in the Pages section of the Pages panel.

4.

Choose Remove Master Page Change(s) from the context menu.

RESULT
All master page changes made on the selected pages are removed. The format of the selected
pages returns to the overall master page format applied to the layout.

Removing all master page changes
You can remove master page changes for all pages in the layout currently open in the music
area. Any pages whose master page has been changed are shown with a marking along their top
edge, or along their top and left edges, in the Pages section of the Pages panel.
PROCEDURE
1.

Open the layout whose master page changes you want to remove in the music area.

2.

Right-click in the Pages section of the Pages panel, but not on any of the pages.

3.

Choose Remove All Master Page Changes from the context menu.

RESULT
All master page changes on all pages in the layout currently open in the music area are removed.
All pages return to the master page format applied to the layout.

Swapping pages
You can swap pages that have overrides with adjacent pages.
PROCEDURE
1.

On the pages panel, in the Panels display, select a page with an override.
NOTE
A page with an override has a marking in the upper left corner.

2.

Do one of the following:
●

Right-click and from the context menu, select Swap with Previous Page or Swap
with Next Page.
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●

Click Swap with Previous Page

or Swap with Next Page

.

RESULT
The selected page exchanges the position with the previous or next page within the sequence of
pages in the layout.
RELATED LINKS
Master page overrides on page 138

Frames
Frames allow you to position your music, additional text, and graphics anywhere inside the
margins of a page.
Frames are rectangular boxes that can be positioned inside the page margins that have been
defined for a layout. In Engrave mode, you can see and adjust frames according to your needs.
For every project that you create, Dorico provides the following frames:
●

Music frames for the first and subsequent pages that show the music from a selected
layout

●

Text frames that allow you to enter text

●

Graphics frames that allow you to load images or illustrations in a variety of formats

For every frame, you can specify constraints that define the relationship between the sides of the
frame and the corresponding page margins.
RELATED LINKS
Flows on page 32
Layouts on page 32
Constraints on page 158

Inserting frames into pages
PROCEDURE
1.

In Engrave mode, activate Frames in the Formatting panel.

2.

Select the type of frame you want to insert by clicking one of the available options:
●

Insert Music Frame

●

Insert Text Frame

●

Insert Graphics Frame

3.

Click and drag to draw a frame of the size and shape you want on the page where you
want to insert a frame.

4.

Release the mouse button.

RESULT
The frame is inserted on the page.
AFTER COMPLETING THIS TASK
You can change the size of the frame or define its constraints. If you inserted a music frame, you
can determine which parts of your score you want to display in the frame. If you inserted a text
frame, you can enter text. If you inserted a graphics frame, you can load a graphic file.
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RELATED LINKS
Constraints on page 158
Music frames on page 146
Text frames on page 148
Graphics frames on page 158
Music frame selectors on page 160

Moving frames individually
PROCEDURE
●

Changing the size and shape of frames individually
PROCEDURE
●

Music frames
Music frames show the music from a selected layout and allow you to change the position and
order of music on a page. Dorico features master page music frames and layout music frames.

Master Page Music Frames
All notes and notation items that you input are automatically placed within master page music
frames. They are available by default on the master pages in the master page sets that Dorico
provides. You can create and edit master page music frames only in the master page editor. They
are configured as such that they are automatically repeated on all pages in your layout.
TIP
You can use different master page music frames for different players. To do this, you must create
separate identical master page music frames on the First and the Default master pages for left
and right pages. The following example shows two master page music frames on the left and
right pages of the First master page pair:
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Layout Music Frames
You can create and edit layout music frames only on individual pages in your layout. You can
insert layout music frames anywhere on a page in any kind of size and connect them with other
layout music frames by assigning them to the same layout frame chain.
TIP
Layout music frames allow you to insert small musical excerpts from a different flow within
footnotes, for example.
IMPORTANT
Layout music frames are considered overrides to master pages. If you remove all overrides on
layout pages, all your layout music frames are also removed.

Identifying Master Page Music Frames and Layout Music Frames
To differentiate between master page music frames and layout music frames, you can check the
following:
●

On the pages in your layout, the master page music frames never allow you to change the
assignment to individual flows or players. Those music frame selectors are grayed out and
can only be edited in the master page editor.

●

If you insert a layout music frame on a page, its Frame Chain selector by default shows
a frame chain that starts with an “L”. Master page music frames by default show a frame
chain that starts with an “M”.

RELATED LINKS
Frame chains on page 148
Master pages on page 133
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Master page overrides on page 138
Master page editor on page 137

Frame chains
A frame chain can be understood as a collection of music frames that show the music in a
predefined order.
Frame chains are automatically created when you create a music frame on a page. Since every
project in Dorico has at least one music frame, you already have at least one frame chain that
you can edit. The following types of frame chains can be created and edited:

Master Page Frame Chains
Master page frame chains can be created and fully edited only on master pages. Whenever
you create a music frame on a master page, you automatically start a frame chain. Frames are
automatically recreated and assigned to each subsequent page of a frame chain.
NOTE
To ensure that a score continues automatically on subsequent pages, the music frame must be
created at least on the First and Default master pages.

Layout Frame Chains
Layout frame chains can only be created and edited for layout music frames on individual
pages. If you create a layout music frame on a page in your layout, this layout music frame is
only displayed on that page, but starts its own frame chain. If you want the music frame to be
continued on subsequent pages, you must create this music frame on all pages in your notation
and assign all of these frames to the layout frame chain of the initial layout music frame.
RELATED LINKS
Music frames on page 146
Master pages on page 133
Layouts on page 32

Text frames
Text frames allow you to add text that is independent of rhythmic positions in the score. If you
add a text frame, the formatting of your layout pages is changed.

Text frame

RELATED LINKS
Inserting frames into pages on page 145
Entering text in text frames on page 149
Changing the default horizontal alignment of different text styles project-wide on page 377
Changing the horizontal alignment of text in text frames on page 149
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Entering text in text frames
You can enter text in text frames.
PROCEDURE
1.

Select the text frame into which you want to enter text.

2.

Open the text editor in one of the following ways:
●

Press Enter

●

Double-click within the text frame

3.

Enter the text you want.

4.

Optional: Format the text using options in the text editor.

5.

Close the text editor in any of the following ways:
●

Press Esc

●

Press Ctrl/Cmd-Enter

●

Click anywhere outside the text editor

RELATED LINKS
Text Editor on page 151

Inserting new paragraphs
You can insert new paragraphs while entering text into a text frame.
PROCEDURE
1.

Enter text.

2.

Press Enter.

RESULT
A new paragraph is inserted. The cursor jumps to the beginning of the new paragraph.

Inserting line breaks
You can insert line breaks while entering text into a text frame.
PROCEDURE
1.

Enter text.

2.

Press Shift-Enter.

RESULT
A new line is inserted. The cursor jumps to the beginning of the new line.

Changing the horizontal alignment of text in text frames
You can change the horizontal alignment of any text style in text frames, independently of the
paragraph style for that text.
If you change the alignment of text in text frames on master pages, the horizontal alignment of
text is changed on all pages that use those master page formats.
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NOTE
Changes to text in text frames on master pages cannot be reset.
If you change the alignment of text in text frames on individual pages, this change is
independent of the paragraph style for that text and also independent of the master page
format. You can later remove any overrides made on individual pages and revert them to the
master page format.
NOTE
Removing overrides removes all changes made to individual pages, not just changes to the
alignment of text in text frames.

PROCEDURE
1.

In Engrave mode, activate Frames in the Formatting panel.

2.

Select the text frame containing the text whose horizontal alignment you want to change.
NOTE
If you want to change the horizontal alignment of text on a master page, open the master
page editor and then select a text frame.

3.

4.

Open the text editor in one of the following ways:
●

Press Enter.

●

Double-click within the text frame.

Select the text in the text frame whose horizontal alignment you want to change.
TIP
You do not have to change the horizontal alignment of all text in the text frame.

5.

6.

Choose the horizontal alignment you want from the following options in the text editor:
●

Align Left

●

Align Center

●

Align Right

●

Justify

Close the text editor in any of the following ways:
●

Press Esc or Ctrl/Cmd-Enter.

●

Click anywhere outside the text editor.

RESULT
The alignment of the selected text is changed.
NOTE
You can change the alignment of text styles project-wide in the Paragraph Styles dialog.

RELATED LINKS
Paragraph styles on page 152
Customizing master pages on page 137
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Resetting changes to text in text frames on individual pages
If you override the paragraph style of text within text frames on individual pages, any changes
you later make to the paragraph style are not applied to the overridden text.
You can reset the changes you made to revert individual pages back to the master page format.
However, this removes all changes made to those pages.
NOTE
You cannot reset changes made to text in text frames on master pages.

RELATED LINKS
Removing individual master page overrides on page 139
Removing all master page overrides on page 140

Text Editor
The text editor allows you to add and format text.
The text editor opens in the following circumstances:
●

You add or change text that is attached to a staff.

●

You enter text within a text frame.

The text editor provides the following options:
Paragraph Style
Determines the appearance and alignment of the text for a whole paragraph.
NOTE
Text that is attached to a staff is always treated as a single paragraph.
Character Style
Determines the appearance of marked text.
NOTE
If you use one of the defined character styles in the text editor, the appearance that
is defined by the selected paragraph style is overridden.
Font
Allows you to change the font family of marked text.
Font Style
Allows you to change the font style of marked text.
Font Size
Allows you to change the size of marked text.
Font Stretch
Allows you to make marked text wider or narrower.
Baseline Shift
Allows you to gradually shift the baseline of marked text up or down.
Letter Spacing
Allows you to increase/decrease the space between the characters of marked text.
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Word Spacing
Allows you to increase/decrease the space between the words of marked text.
Foreground Color
Allows you to change the foreground color of marked text.
Background Color
Allows you to change the background color of marked text.
Align Left
Allows you to align text to the left relative to the rhythmic position of the text in
the score. For text in a text frame, the text is aligned along the left margin of a text
frame.
Align Center
Allows you to centers the text relative to the rhythmic position of the text in the
score. For text in a text frame, the text is centered between the left and right margins
of a text frame.
Align Right
Allows you to align text to the right relative to the rhythmic position of the text in
the score. For text in a text frame, the text is aligned along the right margin of a text
frame.
Justify
For text in a text frame, the space between words is adjusted so that each line spans
the full width of a text frame.
Underline
Allows you underline selected text.
Overline
Allows you to overline selected text.
Strikethrough
Allows you to strike through selected text.
Superscript
Allows you to position selected text higher than the text on the baseline.
Subscript
Allows you to position selected text lower than the text on the baseline.
RELATED LINKS
Adding text on page 112
Entering text in text frames on page 149
Paragraph styles on page 152
Character styles on page 155

Paragraph styles
In the Paragraph Styles dialog, you can change paragraph styles for text and create new styles.
You can later use different paragraph styles in different places in your project by choosing them
in the text editor.
You can open the Paragraph Styles dialog by choosing Engrave > Paragraph Styles in Engrave
mode.
The Paragraph Styles dialog lists the available paragraph styles and provides the following
options:
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New
Allows you to create a new style with default values.
New From Selection
Allows you to create a new style based on the style that you selected in the list of
styles.
Save As Default
Allows you to save a style as default style for other projects.
Revert To Factory
Only available for predefined styles in Dorico. If you have changed a predefined style,
this option allows you to restore the factory settings of the style.
Delete
Allows you to delete a style.
NOTE
You can only delete styles that are neither predefined nor used in the score.
Name
Allows you to specify the name for a style.
Parent
Allows you to select a style from which a new or a selected style inherits its
properties.
Font
Allows you to change the font family.
Style
Allows you to change the font style.
Size
Allows you to change the font size and to specify if the size is an absolute value or
relative to the staff.
Size in parts
Allows you to change the font size in parts and to specify if the size is an absolute
value or relative to the staff.
Stretch
Allows you to make the font wider or narrower.
Letter spacing
Allows you to increase/decrease the space between characters.
Word spacing
Allows you to increase/decrease the space between words.
Text decorations
Allows you to add lines to a style.
●

Underline
Draws a line under all text.

●

Overline
Draws a line over all text.
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Indentation
Allows you to specify extra space to the left of a paragraph.
First line indent
Allows you to add further indentation that only applies to the first line of each
paragraph.
Leading
Allows you to specify the amount of space between each line of text within a
paragraph in percent of the font size.
Gap after paragraph
Allows you to specify the space that is added between each paragraph.
Alignment
Allows you to specify how text in a paragraph is aligned.
●

Left-align
Aligns all text to the left, relative to the rhythmic position of the text in the
score. Within a text frame in Engrave mode, the text is aligned along the left
margin of the frame.

●

Center-align
Centers all text relative to the rhythmic position of the text in the score. Within
a text frame, the text is aligned relative to the left and right margins of the
frame.

●

Right-align
Aligns all text to the right, relative to the rhythmic position of the text in the
score. Within a text frame, the text is aligned along the right margin of the
frame.

●

Justify
Adjusts the space between words so that each line spans the full width of the
text frame.

●

Inside Edge
Allows you to align text towards the inside edge of odd- and even-numbered
pages. For example, in a book this is the edge closest to the binding.

●

Outside Edge
Allows you to align text towards the outside edge of odd- and even-numbered
pages. For example, in a book, this is the edge opposite to the binding.

Foreground color
Allows you to change the foreground color.
Background color
Allows you to change the background color.
Creating paragraph styles
You can create new paragraph styles.
PROCEDURE
1.

In Engrave mode, open the Paragraph Styles dialog by choosing Engrave > Paragraph
Styles.

2.

Click New.

3.

Enter a name for the style in the Name field.

4.

Optional: Select one of the available styles from the Parent menu.

154

Engrave mode
Frames
If you select a parent style, an activated slider is shown beside all the options that the new
style can inherit from the parent style. You can deactivate these if you want.
5.

Change the options you want for the new style.

6.

Click OK.

Creating paragraph styles based on other styles
You can create paragraph styles that are based on other styles.
PROCEDURE
1.

In Engrave mode, open the Paragraph Styles dialog by choosing Engrave > Paragraph
Styles.

2.

Select the style on which you want to base a new paragraph style from the list on the left
of the dialog.

3.

Click New From Selection.

4.

Enter a name for the new style in the Name field.

5.

Optional: Select a different style from the Parent menu.
All options from parent style are set automatically for the new style. All options show
deactivated sliders, which means that they are inherited from the parent style.

6.

Activate the sliders for the options that you want to override and make your changes.

7.

Click OK.

Deleting paragraph styles
You can delete paragraph styles.
PROCEDURE
1.

In Engrave mode, open the Paragraph Styles dialog by choosing Engrave > Paragraph
Styles.

2.

Select the style that you want to delete from the list on the left of the dialog.

3.

Click Delete.

4.

Click OK.

Character styles
The text editor allows you to choose from different character styles for text that you use in your
scores. In the Character Styles dialog, you can change these styles and create new styles.
To open the Character Styles dialog, in Engrave mode, select Engrave > Character Styles.
The Character Styles dialog lists the available character styles and provides the following
options:
New
Allows you to create a new style with default values.
New From Selection
Allows you to create a new style based on the style that you selected in the list of
styles.
Save As Default
Allows you to save a style as default style for other projects.
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Revert To Factory
Only available for predefined styles in Dorico. If you have changed a predefined style,
this option allows you to restore the factory settings of the style.
Delete
Allows you to delete a style.
NOTE
You can only delete styles that are neither predefined nor used in the score.
Name
Allows you to specify the name for a style.
Font
Allows you to change the font family.
Style
Allows you to change the font style.
Relative Size
Allows you to specify how the font size is scaled relative to the prevailing paragraph
style.
Stretch
Allows you to make the font wider or narrower.
Baseline shift
Allows you to gradually shift the text baseline up or down.
Letter spacing
Allows you to increase/decrease the space between characters.
Word spacing
Allows you to increase/decrease the space between words.
Text decorations
Allows you to add lines to a style.
●

Underline
Draws a line under all text.

●

Overline
Draws a line over all text.

●

Strikethrough
Strikes through all text.

Character alignment
●

Subscript
Positions text lower than the text on the baseline.

●

Superscript
Positions text higher than the text on the baseline.

Foreground color
Allows you to change the foreground color.
Background color
Allows you to change the background color.
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Creating character styles
You can create new character styles.
PROCEDURE
1.

In Engrave mode, select Engrave > Character Styles.

2.

In the Character Styles dialog, do one of the following:
●

Click New.

●

Select a style in the styles list and click New From Selection.
NOTE
This copies all the options from the selected style.

3.

In the Name field, enter a name for the style.

4.

Activate the sliders for the options that you want to change and make your changes.
IMPORTANT
Only options with activated sliders have an effect on the text. If you deactivate the sliders,
their settings are deleted.

5.

Click OK.

Deleting character styles
You can delete character styles.
PROCEDURE
1.

In Engrave mode, select Engrave > Character Styles.

2.

Select the style that you want to delete in the styles list.

3.

Click Delete.

4.

Click OK.

Moving text manually
In Engrave mode, you can manually move text that you added with the text editor in Write mode.
PROCEDURE
1.

Select the text that you want to move.

2.

Click and drag the text in any direction to the position you want.

3.

Release the mouse button.
NOTE
Alternatively, you can move the text by changing the X and Y values of the Offset option in
the Common group of the Properties panel.

RELATED LINKS
Text Editor on page 151
Common section on page 165
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Graphics frames
Graphics frames allow you to load images or illustrations into your score in a variety of formats.
You can load graphic files of the following formats:
●

.jpg, .jpeg

●

.png

●

.svg

Graphics frame

RELATED LINKS
Loading images into graphics frames on page 158

Loading images into graphics frames
You can load images from your computer or server into your score.
PROCEDURE
1.

Double-click in the graphics frame.

2.

In the dialog that opens, search for the file that you want to load.

3.

Click Open.

RESULT
The image is loaded into the frame.
RELATED LINKS
Graphics frames on page 158

Constraints
In Dorico, constraints define the relationship between the four sides of a frame and the
corresponding page margins.
For example, a music frame that fills the entire height and width of a page has constraints on
all four sides: All sides have an inset of zero, which means that the edges of the frames abut
the page margins. If you change the page size or the area that is defined by the page margin,
the edges of the frames still abut the page margins, but the frame grows or shrinks, as the
constraints lock the frame to the page margins.
NOTE
Page size and margins are specified in the layout options.
If you remove a constraint from one side of a frame, that is, you unlock that side from the page
margin, you can determine a fixed width or height that prevents the side to adjust if the page
size changes.
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EXAMPLE
If you have set a frame for a header, you may want the left and right sides to be locked to the left
and right margins of the page. For the top side of the frame, you may also want to lock it to the
top margin, but the height of the header should be fixed. In this case, you can remove the lock
to the bottom margin and specify a fixed height by moving the side of the frame or by entering a
value in one of the fields in the Properties panel.
In the Frames section of the formatting panel, you can define the constraints for all types of
frames that are available in Dorico. All new frames have active constraints on all sides by default.
You can unlock two sides of a frame to specify a fixed width or height. For example, if you
remove the lock to the top margin, you can also remove the lock to the left or right margin.
RELATED LINKS
Defining constraints on page 159
Layout Options on page 85

Defining constraints
You can determine on which sides of frames you want to apply constraints.
PROCEDURE
1.

On the formatting panel, activate the Frames section.

2.

In the music area, select the frame for which you want to edit the constraints.

3.

In the Frames section, below Constraints, click the lock
the frame that you want to change.

4.

Do one of the following:

that corresponds to the side of

●

Move the unlocked side to the required position.

●

In the Frames group of the Properties panel, enter a fixed value for Height or
Width.

RELATED LINKS
Constraints on page 158

Frame breaks
Frame breaks allow you to insert page turns for the players if you need to insert them in
particular places in the music.
Frame breaks are inserted in music frames. If you insert a frame break at a specific place in your
music, existing notation that follows it is moved to the next music frame in the frame chain.

Inserting frame breaks
You can insert frame breaks that allow you to insert page turns in a particular place in your
music.
PROCEDURE
1.

Select the note or notation item where you want to insert a frame break.
NOTE
If you select a clef, for example, the clef is placed at the end of the frame, and the notes
are moved to the start of the next music frame.
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2.

Do one of the following:
●

Press Shift-F.

●

Select Engrave > Format Music Frames > Frame Break.

RESULT
All notation after the frame break is moved to the next music frame.

Music frame selectors
If you activate Frames on the formatting panel, the music frames show several selectors that
allow you to change the visible notation.
Every music frame shows the following selectors:

NOTE
The Filter by Flow and the Filter by Player selectors of master page music frames can only be
edited on master pages.
1

Frame Chain
Allows you to select which frame chain the music frame should follow. Frames that start
with an “M” are master page music frames; frames that start with an “L” are layout music
frames.

2

Frame Order
If you have at least two music frames that follow the same frame chain on the same page,
you can use this option to specify in which order the music is flowed into the frames.

3

Filter by Flow
If you have several flows in your project, you can specify which flow you want to display in
this frame.

4

Filter by Player
If you have several players in your project, you can specify which player you want to
display in this frame.

If you click the frame, handles in each corner and in the middle of each side of the frame appear.
You can use these handles to drag the frame into several directions and thus change the frame
size. While you drag, numbers next to the handle indicate the horizontal and vertical values of
the frame.
If you define constraints for the frame, you can also use the options in the Frame group of the
Properties panel to specify the value of the frame.
RELATED LINKS
Assigning music frames to frame chains on page 161
Changing frame orders on pages on page 161
Assigning flows to frame chains on page 162
Assigning players to frame chains on page 162
Music frames on page 146
Frame chains on page 148
Constraints on page 158
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Assigning music frames to frame chains
You can assign a new music frame to an existing frame chain or change the assignment of a
music frame to a frame chain using the Frame Chain selector.
PREREQUISITE
If you assign a music frame to a layout frame chain, you must activate the Frames section on the
formatting panel.
NOTE
New music frames on a page always start a new frame chain, independent of what type they are.

PROCEDURE
1.

In the layout music frame or in the master page music frame, open Frame Chain
and select the frame chain that you want to use.

2.

Close the selector.

RESULT
The frame chain is assigned to the frame. All settings from the frame chain are applied to the
frame.
RELATED LINKS
Music frames on page 146
Music frame selectors on page 160
Frame chains on page 148

Unlinking music frames from frame chains
You can unlink music frames from frame chains.
PROCEDURE
1.

In the layout music frame or in the master page music frame, open Frame Chain
and click Unlink.

2.

Close the selector.

Changing frame orders on pages
If you have at least two music frames of the same type on a page, you can change in which frame
you want the notes to be input first.
PROCEDURE
1.

Select one of the music frames.

2.

In the frame, open Frame Order

3.

Close the selector.

and select the ordinal number for this frame.

RESULT
The frame exchanges the number with the number of the frame that used to be assigned the
selected ordinal number.
RELATED LINKS
Music frame selectors on page 160
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Assigning flows to frame chains
You can show different flows in different frame chains.
NOTE
You can assign flows only to master page music frames.

PROCEDURE
1.

On the pages panel, in the Master Pages section, double-click a master page pair to open
the master page editor.

2.

In the master page music frame, open Flows
want the music frame to display.

3.

Close the selector and the master page editor.

and select the flow that you

RESULT
The music frame shows the selected flow.
RELATED LINKS
Music frames on page 146
Music frame selectors on page 160
Frame chains on page 148

Assigning players to frame chains
You can show different players in different frame chains.
NOTE
You can assign players only to master page frame chains.

PROCEDURE
1.

On the pages panel, in the Master Pages section, double-click a master page pair to open
the master page editor.

2.

In the master page music frame, open Filter by Player
or players that you want the music frame to display.

3.

Close the selector and the master page editor.

and select the player

RELATED LINKS
Music frames on page 146
Music frame selectors on page 160
Frame chains on page 148

Properties in Engrave mode
In Engrave mode, you can edit notes, notations, or parts of them individually or project-wide.
If you want to edit notes or notations individually, you can use the properties panel that allows
you to make direct changes to selected items in the score. To change them project-wide, you can
use Engrave > Engraving Options |(key command Ctrl/Cmd-Shift-E).
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RELATED LINKS
Options in the Properties panel on page 164
Engraving Options on page 163

Engraving Options
The Engraving Options dialog provides multiple options that allow you to make project-wide
changes to the graphical appearance of the music.
The changes that you can make may affect, for example, the following properties of notation
items:
●

Line thickness

●

Distances

●

Positions

NOTE
You can save all options that you set in Engraving Options as default values for new projects by
clicking Save As Default.
TIP
If you want to make changes to individual notes, notations, or parts of them, you can use
properties in the Properties panel.
You can open Engraving Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Engraving Options dialog

The list on the left of the Engraving Options dialog contains the pages for each notation
category. All the options available for the category selected in the list are shown in the main area
of the dialog.
Pages with many options are divided into sections.
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Making project-wide changes in Engrave mode
You can make project-wide changes for notes and notations in Engraving Options.
NOTE
If you make changes and close the dialog without clicking Apply, you are prompted to save or
discard your changes.

PROCEDURE
1.

Choose Engrave > Engraving Options, or use the key command Ctrl/Cmd-Shift-E.

2.

Select a category from the list of notations.

3.

Look through the available settings, and choose your preferred options.

4.

Click Apply, then Close.

RESULT
The changes are immediately displayed in the music area.

Options in the Properties panel
The Properties panel in Engrave mode provides options that allow you to edit notes, notations,
and parts of them individually.
All the options that are available in the Properties panel in Write mode are also available in the
Properties panel in Engrave mode. Engrave mode, however, provides additional options that
allow you to edit notes, notations, and parts of them in more detail.
The options that are available in the Properties panel depend on the item that you select in your
score. This means that whenever you select a note or notation, or part of a note or notation, and
open the properties panel, the properties panel displays the sections and the respective options
that you may require to edit the selected item. If you select multiple different types of notation
items, only the sections are displayed that they have in common.
For example, if you select a note, at least the Common section and the Notes and Rests section
are displayed. If you select a tied note with an articulation, the following groups are displayed:
●

The Common group

●

The Notes and Rests group

●

The Ties group

●

The Articulations group

This shows you all the options that you may want to change for that note.

Changing the properties of individual items in Engrave mode
You can view and change the properties of notes, notations, or parts of them.
NOTE
To change notes and notations project-wide, you must use the Engraving Options dialog.

PROCEDURE
1.

Select a note, notation, or individual parts of them in the score.

2.

Open the properties panel.
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3.

Make your settings.

RESULT
The changes are immediately displayed in the music area.
RELATED LINKS
Engraving Options on page 163
Properties panel on page 130

Common section
The Common section of the properties panel is available for all items in the music area.
NOTE
If you select different types of items in the music area at the same time, only the Common
section is available for editing purposes.
Position
Shows the rhythmic position of a selected item, expressed as a number of quarter
note beats from the start of a flow.
Offset
If you activate this option, you can move a selected item horizontally or vertically
in fractions of spaces according to the value that you enter or select in the X and Y
fields. The X value moves the item horizontally, the Y value moves the item vertically.
Muted
If you activate this option, you can mute selected notes or chords during playback.
You can also mute any other notation that affects playback, such as dynamics.
Color
If you activate this option, you can change the color of a selected item. Click the box
to the right. In the Select Color dialog that opens, select one of the available basic
colors, pick a color from the screen, or specify a custom color.

Articulations section
In the Articulations section of the properties panel, you can edit the position and the visibility of
articulations.
NOTE
To edit an articulation, you must select the note to which the articulation belongs.
Placement
Allows you to change the placement of an articulation of a selected note. You can
decide whether you want the articulation placed on the notehead side or on the stem
side.
Hidden
Allows you to hide an articulation of a selected note. If an articulation is hidden, it
is still played back, but it is not visible in the score. You can instead show a signpost
that you can activate by selecting View > Signposts.
Pos. in tie chain
Allows you to specify whether an articulation of a tied note is positioned at the start
or end note in the tie chain.
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Offset Y
Allows you to move the articulation vertically according to the value that you enter or
select in the Spaces field.

Dynamics section
In the Dynamics section of the Properties panel, you can edit the position and change the style
of selected dynamics.

Common Options for All Dynamics
Start offset
If you activate this option, you can move a selected dynamic horizontally and
vertically in fractions of spaces according to the values that you enter or select in the
X and Y fields. The X value moves the dynamic horizontally, the Y value moves the
dynamic vertically. If you move an immediate dynamic, the entire symbol is moved. If
you move a gradual dynamic, its start is moved.
Placement
If you activate this option, you can place a selected dynamic above or below the staff.
Parenthesized
Adds parentheses to a selected dynamic.
Prefix
Allows you to add or edit a custom prefix to a selected dynamic. For example, you
can add sempre before fortissimo (ff).
Suffix
Allows you to add or edit a custom suffix to a selected dynamic. For example, you can
add strongly after fortissimo (ff).
Show intensity marking
Only available for immediate or combined dynamics and for markings of force/
intensity of attack.
Dorico allows you to input a custom dynamic into your score, such as sempre or
strongly, if you combine it with another dynamic that is used as an intensifier. If
you activate/deactivate this option, the intensifier is shown/hidden.
Beat-relative position
Only available for immediate or combined dynamics and for markings of force/
intensity of attack.
Normally, the optical center of a dynamic is aligned with the rhythmic position of
the note or chord. If you activate this option, you can specify if you want to position
the dynamic at the end of the beat before that rhythmic position. In the case that
a dynamic is preceded by a crescendo or diminuendo, and there is no note or
chord at the rhythmic position at which the gradual dynamic ends, the dynamic is
automatically positioned at the end of the last beat that is affected by the gradual
dynamic. In this case, you can move the dynamic to the next rhythmic position.
The following options are available:
●

Before
Positions the dynamic at the end of the last beat.

●

After
Positions the dynamic to the next rhythmic position after the last beat.
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Text alignment
Only available for immediate dynamics or combined dynamics and for markings of
force/intensity of attack.
If you activate this option, you can align a dynamic with the note to which it is
assigned. You have the following options:
●

Align optical center with notehead
The centers of the dynamic and the notehead are aligned.

●

Left-align with notehead
The dynamic starts at the start of the notehead.

Gradual Dynamics Options
End offset
If you activate this option, you can move the end of a selected dynamic horizontally
and vertically in fractions of spaces according to the values that you enter or select
in the X and Y fields. The X value moves the dynamic horizontally, the Y value moves
the dynamic vertically.
Type
Allows you to select between Cresc. or dim. and Messa di voce as types of gradual
dynamics. Cresc. or dim. enables the Gradual style pop-up menu that allows you to
choose between different crescendo/diminuendo hairpins or text.
Gradual style
Only available if you activate Cresc. or dim. as type of gradual dynamic.
Allows you to select between hairpins, short text instructions, or hyphenated text
instructions.
Hairpin line style
Only available if you select Hairpin from the Gradual style menu, or if you select
Messa di voce as type of gradual dynamic.
Allows you to select how you want the lines of a hairpin to be shown. You have the
following options:
●

Solid
Shows the hairpin with solid lines.

●

Dashed
Shows the hairpin with dashed lines.

●

Dotted
Shows the hairpin with dotted lines.

Niente
Adds niente to a crescendo, diminuendo, or messa di voce.
Niente style
Only available if you select Hairpin from the Gradual style menu or if you activate
Messa di voce as type of gradual dynamic.
If you activate this option, you can select one of the following styles for the selected
niente:
●

Circle on hairpin
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Adds a small circle to the end of the diminuendo or to the start of the
crescendo.
●

Text
Adds an “n” to the end of the diminuendo or to the start of the crescendo.

Poco a poco (little by little)
Adds poco a poco to a crescendo, diminuendo, or messa di voce.
Abbreviate
Only available if you select a crescendo/diminuendo text style from the Gradual
style menu.
If you activate this option, the text for the selected crescendo/diminuendo is
abbreviated.
Hairpin shown as continuation
Only available for adjacent hairpins that point in the same direction and that are
interrupted by an immediate dynamic.
If you activate this option, the hairpins are adjusted to be displayed as one hairpin.
Messa di voce inflection
Only available if you activate Messa di voce as type of gradual dynamic.
The inflection point of a messa di voce is the point at which the first hairpin ends and
the second begins. The inflection point is determined automatically when the messa
di voce is created based on the rhythm of the notes in the span of the dynamic.
If you activate this option, you can adjust the rhythmic position of the inflection
point. The value in the left field specifies the primary rhythmic position, expressed
in fractions of quarter notes. The value in the right field allows you to specify a
secondary rhythmic position within a run of grace notes at the primary rhythmic
position.
Hairpin open aperture
Only available if you select Hairpin from the Gradual style menu or if you select
Messa di voce as type of gradual dynamic.
If you activate this option, you can change the space between the lines at the open
end of a hairpin. If you select Messa di voce as type of dynamic, the space between
the lines at the position of the inflection is changed. In the Spaces field, you can
enter or select the size of the space.
NOTE
If you edit the Hairpin closed aperture option and its space exceeds the Spaces
value of the Hairpin open aperture option, the space for the open aperture
is automatically adjusted to ensure that it is always larger than the closed end
aperture. Thus, the two lines of the hairpin never appear completely parallel.
Hairpin closed aperture
Only available if you select Hairpin from the Gradual style menu or if you select
Messa di voce as type of gradual dynamic.
If you activate this option, you can change the space between the lines at the closed
end of a hairpin. If you select Messa di voce as type of dynamic, the space between
the lines at the position of the inflection is changed. In the Spaces field, you can
enter or select the size of the space.
NOTE
If you edit the Hairpin closed aperture option and its space exceeds the Spaces
value of the Hairpin open aperture option, the space for the open aperture
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is automatically adjusted to ensure that it is always larger than the closed end
aperture. Thus, the two lines of the hairpin never appear completely parallel.
Hairpin thickness
Only available if you select Hairpin as gradual style or if you select Messa di voce as
type of gradual dynamic.
If you activate this option, you can change the thickness of the hairpin lines in the
Spaces field.
Diminuendo style
Only available if you select cresc./dim. for a diminuendo from the Gradual style
menu.
If you activate this option, you can select the text that you want to display
for a diminuendo and thus use the terms “diminuendo” and “decrescendo”
interchangeably.
NOTE
You can specify the default text appearance for a diminuendo in the engraving
options by selecting Engrave > Engraving Options > Dynamics > Appearance of
gradual reduction in dynamic.
Barline Interaction
If you activate this option, you can set a hairpin to stop before a barline or to
continue after a barline.
Continuation line style
Only available if you select cresc.... from the Gradual style menu.
If you activate this option, you can specify whether the line that indicates the
duration of the dynamic change is dashed or dotted.
Continuation line dot size
Only available if you select cresc.... from the Gradual style menu and activate
Dotted as Continuation line style.
If you activate this option, you can change the size of the dots that are used for the
continuation line in the Spaces field.
Continuation line dot gap
Only available if you select cresc.... from the Gradual style menu and activate
Dotted as Continuation line style.
If you activate this option, you can change the size of the gaps between the dots that
are used for the continuation line in the Spaces field.

Force/Intensity of Attack Options
rfz/sfz style
If you activate this option, you can decide whether you want to show markings of
force/intensity of attack with an ending “z” or not.

Combined Dynamics Options
Separator shown
If you activate this option, you can insert a separator between the combined
dynamics.
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Separator
If you activate this option, you can specify the type of separator by selecting the one
you want from the menu.

Lyrics section
In the Lyrics section of the properties panel, you can make changes to selected syllables or
whole lines of lyrics.
Syllable type
Allows you to change the type of selected syllables.
Line placement
Allows you to move selected syllables above or below a staff.
Line number
Allows you to change the line number for selected syllables.
Chorus
If you activate this option, you can select syllables and designate them as chorus
lyrics that are centered vertically in relation to other preceding lines of lyrics. Chorus
lyrics are displayed in italics.
Is translation
If you activate this option, you can specify lines of lyrics as translations of song lyrics.
Translations are displayed in italics.
Lyric text alignment
If you activate this option, you can align selected syllables horizontally in relation to
the noteheads. By default, syllables are centered below the notes.
RELATED LINKS
Changing lines of lyrics on page 116
Moving lines of lyrics to different lines on page 117
Aligning syllables within lyrics on page 119

Rehearsal marks section
In the Rehearsal Marks section of the properties panel, you can change the type of selected
rehearsal marks and the number or letter with which they should start.
Sequence type
If you activate this option, you can choose whether the selected rehearsal mark is
displayed as a letter, a number, or whether it shows the current bar number.
Index
If you selected Numbers or Letters as Sequence type and activate this option, you
can increase or decrease the number or the letter with which the selected rehearsal
mark should start.

Trills section
In the Trills section on the properties panel, you can change the placement and appearance of
selected trills and trill lines.
Placement
If you activate this option, you can move a trill above or below a staff.
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Start speed
If you activate this option, you can specify how fast a trill starts. The trill line
automatically changes its form according to your setting.
End speed
If you activate this option, you can specify how fast a trill ends. The trill line
automatically changes its form according to your setting.
Has trill line
If you activate this option, you can specify if a trill has a trill line.
Start position
If you activate this option, you can specify if you want a trill to be positioned starting
at the notehead or at the accidental of the note.
Extra gap position
If you activate this option, you can specify if you want a gap position at the start or at
the end of the trill line.
Interval
If you activate this option, you can choose the number of half-steps between the two
notes of a trill.
Accidental position
If you activate this option and you are using an accidental as trill interval, you can
specify if you want the accidental to be placed above, below, or in line with the trill.
Start offset
If you activate this option, you can move the start of a selected trill horizontally and
vertically in fractions of spaces according to the values that you enter or select in the
X and Y fields. The X value moves the trill horizontally away from its starting point,
the Y value moves the trill vertically.
End offset X
If you activate this option, you can move the end of a selected trill line by the value
that you enter or select in the X field.
Inside slurs, tuplets, and octave lines
If you activate this option, the selected trill is positioned inside slurs, tuplets, and
octave lines.

Note spacing
The positions of notes relative to each other, and the automatic gaps between notes, is known
as note spacing. You can change note spacing values for each layout project-wide on the Note
Spacing page in Setup > Layout Options, and individually in Engrave mode.
●

Rhythmic spacing project-wide per layout in Layout Options

●

Rhythmic spacing: changing from a specified point in Engrave mode using the Engrave >
Note Spacing Change dialog (per layout, and per frame chain)

●

Rhythmic spacing/Note spacing: changing for individual rhythmic positions when Note
Spacing is activated in Engrave mode
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Adjusting note spacing at individual rhythmic positions in Engrave
mode
You can make adjustments to the note spacing at individual rhythmic positions in Engrave mode,
independently of your project-wide settings for note spacing.
NOTE
Moving notes graphically away from their rhythmic positions can be misleading for players
reading the music.
and to move individual notes graphically, you need to activate Note Spacing in the panel on the
left of the window in Engrave mode.
When Note Spacing is activated, dashed lines representing spacing columns and handles for
each spacing-significant item appear.

An example of the handles and dashed lines that appear when Note Spacing is activated.

Each rhythmic position that contains a significant item, such as noteheads, grace notes, and
rests, can be adjusted using the square handles. Square handles allow you to adjust the spacing
of the selected rhythmic position, which changes the position of everything at that rhythmic
position.
Selecting square handles direction above significant items, such as noteheads, causes a circular
handle to appear. Circular handles allow you to adjust the graphical position of that individual
item, independently of its rhythmic position.
When note spacing handles have been moved, their color changes to red.
NOTE
When Note Spacing is activated, you cannot make any selections or make other types of edits to
items in the current layout. To resume normal selection and editing, deactivate Note Spacing or
return to Write mode.
To make spacing adjustments to notes according to their rhythmic positions:
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the Formatting panel on the left of the window.

2.

Select one of the square handles on the dashed line at the rhythmic position whose
spacing you want to adjust.

3.

Adjust the spacing in the following ways:
●

Alt-Right Arrow to increase the space to the left of the rhythmic position of the
selected handle.
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●

Alt-Left Arrow to decrease the space to the left of the rhythmic position of the
selected handle.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
EXAMPLE

The red square handle has been nudged to the left,
decreasing the spacing to the left of its rhythmic
position.

Spacing adjustments can be made to rhythmic
positions in any rhythmic combination.

RELATED LINKS
Layout Options on page 85
Project-wide Engraving Options for notes on page 453

Adjusting the note spacing of individual notes, independently of their rhythmic
positions
You can change the graphical position of individual notes independently of their rhythmic
positions in Engrave mode.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the Formatting panel on the left of the window.

2.

Select the square handle at the rhythmic position of the note you want to move
graphically.

3.

Select the circular handle that appears beside the note.

4.

Move the note to the left or to the right using the following key commands:
●

Alt-Right Arrow

●

Alt-Left Arrow

173

Engrave mode
Note spacing
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The graphical position of the selected note is changed without changing the rhythmic spacing of
its rhythmic position.
EXAMPLE

Removing individual adjustments to note spacing
You can remove changes to note spacing in Engrave mode and restore note spacing handles to
their original default positions.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the Formatting panel on the left of the window.

2.

Select the handles you want to restore to their original position.

3.

Reset their positions in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.
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Print mode allows you to print your layouts or to export them as graphic files.

Project window in Print mode
The project window in Print mode contains the default toolbar and the print preview area as well
as panels and sections that provide all the tools and functions that allow you to prepare printing
or exporting your layouts.
To open Print mode, Ctrl/Cmdyou have the following options:
●

Select Print on the toolbar.

●

Select Window > Print

Panels and sections in Print mode

The following panels and sections are available:
1

Layouts panel
Shows a list of all layouts in your project and allows you to select what to print or export.

2

Print options panel
Contains options for printing or exporting your layouts.

3

OS X/macOS: OS X Dialogs section
Contains Mac OS-specific printing options.
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RELATED LINKS
Toolbar on page 37
Print preview area on page 41

Layouts panel
In Print mode, the Layouts panel shows a list of all layouts in your project and allows you to
select what to print or export.

1

Allows you to expand each layout to see its page size and its number of pages. This helps
you determine what kind of job type to use for each layout.
TIP
A layout with two pages might best be printed as 2-up, while a layout with five pages might
best be printed as spreads with the final page printed on a different paper size. A layout
with 12 pages might best be printed as a booklet.

2

Shows the number of copies to be printed.

The selected layouts are printed or exported when you click Print or Export.
NOTE
If you have selected multiple layouts, and some are set to print while others are set to export
graphics, the button reads Print and Export.
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Print options panel
The print options panel contains options for printing or exporting your layouts.

All the options that you set on the print options panel are saved with your project. The options
are divided into five sections:
Destination
Allows you to select a physical printer for printing or a file location for exporting a
graphics file. If you print your work, you can choose how many copies you want to
print. If you choose to export a graphics file, you can specify the format and directory
of the saved file.
Depending on the destination that you choose, the button at the bottom of the panel
switches to either Print or Export.
NOTE
If you have selected multiple layouts, and some are set to print while others are set
to export graphics, the button reads Print and Export.
Job Type
Allows you to choose the range of pages to be printed or exported and how they are
arranged.
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Page Setup
Allows you to set the paper size and orientation. You can specify the scale factor of
the image to be printed or exported.
Duplex Printing
Allows you to specify whether to print on one or on both sides of each sheet of
paper. This option is only available if you select Printer in the Destination section.
Annotations
Allows you to activate options that are often required by publishing houses or
printing bureaux, such as crop marks or a border around the printed image.

Printing your layouts
PROCEDURE
1.

On the Layouts panel, select the layout that you want to print.

2.

On the print options panel, in the Destination section, select Printer.

3.

Set the other print options as required.

4.

Click Print.

RELATED LINKS
Printing/exporting multiple layouts on page 183

Selecting a printer
For each layout, you can select a printer that is most useful to return appropriate results.
Dorico sets the default printer as designated by the operating system, unless you specify another
printer. In this case, the settings in the following sections can change:
●

In the Page Setup section, the list of available paper sizes lists only paper sizes that the
chosen printer provides.

●

In the Duplex Printing section, the option for automatic duplex printing is only available if
the chosen printer has this capability.

PROCEDURE
●

In the Destination section, select a printer from the pop-up menu.

RESULT
The printer pop-up-menu in the Destination section only shows the name of a printer if all of
the selected layouts are set to print to the same printer. If you select a new printer, all selected
layouts are set to print to that printer.
RELATED LINKS
Printing/exporting multiple layouts on page 183

Specifying the number of copies to be printed
For each layout, you can specify how many copies you want to print.
PROCEDURE
1.

On the Layouts panel, select a layout.
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2.

To change the number of copies, do one of the following:
●

Click + or - in the selected layout.

●

On the print options panel, in the Destination section, enter the number of copies
in the Copies field.

RESULT
If you have selected multiple layouts, the Copies field only shows a number if all of the selected
layouts are set to print the same number of copies. If you enter a new number of copies in the
Copies field, the number of copies that has been set for each selected layout is overridden.

Duplex printing
Dorico allows duplex printing, which means that you can print on both sides of each sheet of
paper.
If your printer supports automatic duplex printing, Dorico can use this capability. If your printer
can only print on one side of each sheet of paper, you can still use the duplex printing function.

Print on
One side only
Prints on one side of each sheet of paper.
Both sides manually
Prints on both sides of each sheet of paper. Use this option if you printer lacks an
automatic duplex printing capability. After all outward pages have been sent to the
printer, a message box informs you to turn over the stack of printed pages and put
them back into the printer. Then click OK to continue printing the inward pages.
Both sides automatically
Prints on both sides of each sheet of paper automatically. This option is only
available if your printer supports this type of printing.

Flip the Printed Image
The lower menus allow you to set how the printed image is flipped when printing on the reverse
side of the paper.
Flip Image for Reverse Side for Portrait Paper Feed
Determines how the image should be flipped when printing in portrait orientation.
●

Flip automatically allows the printer to use its default settings for printing
on the reverse side. If you find that the printer flips on a different edge than
expected, use one of the other options to correct this.

●

Flip long side sets the printer to flip the pages on the long edge.

●

Flip short side sets the printer to flip the pages on the short edge.

Flip Image for Reverse Side for Landscape Paper Feed
Determines how the image should be flipped when printing in landscape orientation.
●

Flip automatically allows the printer to use its default settings for printing
on the reverse side. If you find that the printer flips on a different edge than
expected, use one of the other options to correct this.

●

Flip long side sets the printer to flip the pages on the long edge.

●

Flip short side sets the printer to flip the pages on the short edge.
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RELATED LINKS
Setting up duplex printing on page 180

Setting up duplex printing
PROCEDURE
1.

2.

Select one of the available options from the Print on menu in the Duplex Printing section:
●

One side only

●

Both sides manually

●

Both sides automatically

Optional: Use the lower menus to select how the printed image is flipped when printing on
the reverse side of the paper.

RELATED LINKS
Duplex printing on page 179

Specifying Mac OS-specific printing options (OS X only)/(macOS only)
Dorico allows you to access the standard printing options of your operating system.
NOTE
If you use the standard printing options of your operating system, the settings on the print
options panel are ignored. Mac OS-specific print settings are not saved with your project. These
must be set each time you want to print, whereas the Dorico print options are always saved with
your project.

PROCEDURE
1.

On the Layouts panel, in the OS X Dialogs section, click Page Setup.

2.

In the dialog that opens, set the paper size.

3.

In the OS X Dialogs section, click Print.

4.

In the dialog that opens, set up the printing options.

Exporting your layouts as graphic files
PROCEDURE
1.

On the Layouts panel, select the layout that you want to export.

2.

On the print options panel, in the Destination section, select Graphics.

3.

Set the export options as required.

4.

Click Export.

RELATED LINKS
Specifying the output format of exported graphics on page 181

180

Print mode
Exporting your layouts as graphic files

Specifying the output format of exported graphics
You can export your layouts in various graphical output formats.
PREREQUISITE
In the Destination section, you have selected Graphics.
PROCEDURE
1.

From the File Format pop-up menu, select a file format.

2.

Specify a color mode.
●

Mono exports the graphic in black and white.

●

Color exports the graphic in full color.

NOTE
If you export a graphic file with a resolution of 72 dpi, it is recommended that you select
Color. If you select Mono, staff lines may disappear.
3.

Optional and for PNG and TIFF file formats only: From the Resolution pop-up menu, select
one of the dpi values.
NOTE
A resolution of 72 dpi is suitable for display on screen so that you can embed the graphic in
an e-mail or on a web page. If you choose 300 or 600 dpi, a high-resolution image is saved
that you can include as an illustration in a word processing or in a desktop publishing
document.

RELATED LINKS
Monochrome and color graphics processing on page 181
Embedding of fonts in PDF and SVG files on page 182

Monochrome and color graphics processing
Most musical scores are monochrome, that is, they use only black ink and are normally printed
on white or near-white paper. Some educational books occasionally use colors to highlight
particular notations, for example, to identify clefs, or to color notes according to their pitch. If
you export graphic files and print them with your own printer, you can leave Color selected in the
Destination section.
However, if you export graphic files in PDF format for direct printing on a platesetter or for
further production work in a page layout program, select Mono, unless your layout actually
contains colored elements. If you select Mono, Dorico uses a different color space for the
resulting PDF, ensuring that the printed image only uses black ink. If you choose Color, then
the black items in your layout are exported as rich black, that is, black produced by combining
multiple colored inks. This may cause problems in production when making color separations at
the pre-press stage.
Dorico specifies colors using the RGB color model, rather than the CMYK color model which is
used by platesetters and other professional printing machines. If you have colored objects in
your layouts and your layouts are printed professionally, you must post-process the graphic files
that are exported from Dorico in another graphics application to convert the colors from RGB to
CMYK.
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Embedding of fonts in PDF and SVG files
How fonts are handled in PDF and SVG (Scalable Vector Graphics) files mainly depends on the
fonts that you use in the project.
PDF Files
The music and text fonts that are supplied with Dorico, these and their sub-sets are
embedded in PDF files during the export. If you open the PDF files on a different
computer, they look the same, even if that computer does not have the fonts
installed that are used in the document. If you use different fonts, make sure that
these permit embedding.
SVG Files
SVG files do not embed fonts directly: some font characters, such as note heads,
articulations, and accidentals, are converted into outlines, so that they do not
depend on the font from which they are taken. Other font characters, such as time
signature and tuplet digits, are only encoded using references to the font from which
they are taken. The latter also applies to regular text, such as staff labels, tempo
instructions, and dynamics. This means that the SVG file looks incorrect if rendered
by a web browser on a computer that does not have the fonts installed. It depends
on the browser or the rendering software, and on the fonts that are installed on the
computer, how the SVG file appears.
To ensure that the SVG file appears correctly if embedded in a web page, you can
open the SVG file in an illustration program and convert all font characters to outline
paths, then re-export the SVG file and embed that file. Alternatively, you can use web
fonts to ensure that the necessary fonts are available on the web server.
SVG graphics that are exported from Dorico conform to the SVG Tiny 1.1
specification, which defines a subset of features in the full SVG specification.
For information about using web fonts with SVG, refer to the Steinberg Knowledge
Base: https://www.steinberg.net/en/support/knowledgebase_new.html

Specifying an export path
You can specify a path to a folder in which exported graphic files are saved and add information
to each exported file.
Dorico by default exports graphic files into the same folder as your project file. If you have not
saved your project yet, graphic files are saved in the default user folder of your operating system.
You can save the exported graphics in a different folder.
PROCEDURE
1.

In the Destination section, next to the Destination folder box, click Choose Folder.

2.

In the dialog, choose a directory and click Open.
The new path is inserted in the Destination folder field.

3.

Optionally, to include the date and time of export in the file names, activate Include date
in file name.
NOTE
Date and time are included in the ISO 8602 format, for example 2016-05-01-143723.

RESULT
Exported files are saved as follows:
<project name> <layout name> <date and time>.<file extension>.
Example: MyProject Soprano 2016-05-01-143723.pdf
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Printing/exporting multiple layouts
You can print or export several layouts at the same time.
PROCEDURE
1.

2.

On the Layouts panel, select the layouts that you want to print or export.
●

To select a range of layouts, press Shift and select the first and last layout of the
range.

●

To select individual layouts, press Ctrl/Cmd and select the layouts.

Click Print/Export/Print and Export.

RELATED LINKS
Selecting a printer on page 178

Layout page arrangements for printing/exporting
Dorico provides several page arrangements that you can use for printing/exporting your layouts.

Job Type
In the Job Type section, you can specify how you want the layouts to be printed/exported. On the
Job Type pop-up menu, the following job types are available:
Normal
Prints one page on each sheet of paper.
Spreads
Prints two pages side-by-side on each sheet of paper, with odd-numbered pages on
the right-hand side and even-numbered pages on the left-hand side.
2-up
Prints two pages side-by-side on each sheet of paper. The first page in the range is
printed on the left-hand side of the first sheet of paper.
Booklet
Prints two pages on each sheet of paper according to imposition requirements. This
means that if the paper is folded, the pages are laid out like a book.
NOTE
Booklets can only be printed using the complete range of pages. You cannot define
any page ranges.
NOTE
●

Depending on the job type that you choose, Dorico switches the orientation for you. The
changed orientation is immediately displayed in the music area. If this is not what you
want, you can override the orientation in the Page Setup section.

●

All of the job types allow printing either onto a single side of each sheet of paper or on
both sides of the paper.
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TIP
It is usual to print booklets, spreads, and 2-up onto paper in landscape orientation. Printing
one page to each sheet should typically use portrait orientation, unless the layout itself uses
landscape orientation.

Page Ranges
In the Job Type section, you can specify a range of pages to be printed/exported. You have the
following options:
All Pages
Allows you to print/export all pages of the selected layouts.
Page Range
Allows you to set a range of pages to be printed.

Printing/exporting a page range
You can specify a range of pages to be printed/exported.
By default, Dorico prints/exports all pages of the selected layouts. You can change this by
specifying a page range.
NOTE
Booklets can only be printed using the complete range of pages. You cannot define any page
ranges.

PROCEDURE
1.

In the Job Type section, select Page Range.

2.

Specify the first and last page of the range in the From and to fields.

3.

Click Print/Export/Print and Export.

Handling page sizes and paper sizes
Dorico handles page sizes and paper sizes differently.
For each layout in your project, you can define a page size in the layout options. This means that
you define the dimensions of the layout. For printing your layout, you must usually choose a
paper size that is provided by the printer that you are using.
Normally, the layout's page size and the printed paper size match. However, if you define a
layout with an unusual page size that is not supported by your printer, such as 10" x 13", one of
the standard page sizes for instrumental parts, you may have to print the layout onto a different
paper size. You can change the paper size in the Page Setup section according to your needs.
This has no effect on your layout's page size and therefore, does not affect the way the music is
laid out.
If you do not select a specific paper size, Dorico automatically chooses a paper size that is based
on your computer's locale settings. For example, if these are set to a European country, an
international ISO standard, such as A4 may be used. If they are set to a North American country,
one of the typical standards, such as US Letter may be used.
If you have defined a page size for your layout that is larger than a typical standard, Dorico
automatically chooses the next larger paper size, provided that your printer supports this. For
example, if the layout's page size is larger than A4/US Letter, A3/Tabloid is used.
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If you print to a different paper size than the layout's page size, Dorico automatically scales the
image to fit the paper. You can change this setting by specifying a custom scale factor in the
Page Setup section.
RELATED LINKS
Page setup on page 185

Page setup
For each layout to be printed or exported, you can specify different paper sizes and orientation
settings.
In the Page Setup section, you have the following options:
Paper Size
Allows you to select one of the available paper sizes. In addition, you can specify if
you want to print or export in Portrait

or Landscape

orientation.

Print odd final page on
For Spreads and 2-up job types only: If this is activated, you can select a different
paper size or orientation for the odd final page.
NOTE
This setting is useful if your layout has an odd number of pages and you choose to
print on A3 paper in landscape orientation. The first four pages fit onto two sheets
of A3, while the fifth page would occupy only the left-hand side of a third sheet. This
setting allows you to print the odd final page on A4 paper in portrait orientation.
Fit to Paper
Scales the layout to fit the paper.
Custom Scale
Allows you to define a different scale for the layout. In the Scale factor field, enter
the required percentage value.

Annotations
When printing/exporting your layouts for publication, you can include typical annotations.
Publishers and printing bureaux can use these to identify and register the printed image
correctly or to embed the exported graphic file into a desktop publishing application.
You can also allow Dorico to print or export any view options that you have activated in your
project.
NOTE
Crop marks and the border can only be printed if the page size is smaller than the paper size.
In the Annotations section, you have the following options:
Crop Marks
Adds short vertical and horizontal lines at each of the four corners of the page.
Border
Adds an outline around the edge of the page dimensions.
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Date and Time
Adds the date and time of printing at the bottom of each page.
Watermark
Adds large translucent text across the middle of each page. This is useful for
indicating that this version is a draft, proof, or perusal score. In the Watermark Text
field at the bottom of the section, you can enter the text that you want to show on
each page.
View options
Adds all active view options, such as signposts and note colors to the printout or
exported graphic.
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Accidentals

Accidentals show that the pitch of a note has been altered so that it does not conform to the
current prevailing key signature.
In music that has no key signatures, accidentals may be required for some or all notes,
depending on the notation convention in use.
Dorico provides comprehensive duration rules that determine when accidentals should be
shown, and also allows you to control how accidentals are arranged in complex chords.
RELATED LINKS
Adding accidentals on page 103

Inputting notes with accidentals
PROCEDURE
1.
2.

In Write mode, start note input.

Prepare a common accidental, such as natural ♮, sharp ♯, or flat ♭, in the following ways:
●

Click the button of the relevant accidental in the Notes panel on the left of the
window

●

Press 0 for natural

●

Press - for flat

●

Press = for sharp

Uncommon accidentals, such as double sharps and flats, or microtonal accidentals, can be
found in the Accidentals section of the Key Signatures panel on the right of the window.
3.

Enter notes with your selected accidental or accidentals in any of the following ways:
●

Press the corresponding letters on the computer keyboard. For example, press =–F
to input an F♯.

●

Click the staff positions of the pitches you want with the mouse

●

Play in the pitches you want on a MIDI keyboard.
NOTE
If you input notes via a MIDI device, Dorico automatically shows an accidental if
necessary. It selects a sharp, flat, or natural based on key signature and context. You
can later respell accidentals.

RELATED LINKS
Inputting notes on page 94
Respelling accidentals on page 193
Accidental selection during MIDI input on page 189
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Adding accidentals to existing notes
To add accidentals to notes that have already been input:
PROCEDURE
1.

In Write mode, select the note or notes you wish to change.

2.

Select the accidental you want in one of the following ways:
●

Click the corresponding button in the Notes panel

●

Press - for flat

●

Press = for sharp

●

Press 0 for natural

NOTE
Depending on the accidental duration system in place, subsequent accidentals for the
same note in the same register may not appear in the same bar.

RELATED LINKS
Accidental duration rules on page 196

Accidental selection during MIDI input
Dorico interprets MIDI data to create accidentals, and automatically determines the spelling of
accidentals according to preset rules.
Dorico automatically displays an accidental if one is required. It selects a sharp or flat based on
key signature and context.
The algorithm for this takes into account the key signature and the intervals between successive
notes and chords. Therefore Dorico prefers sharp accidentals in a key with sharps, and flats in
a key with flats. If you change an accidental’s spelling, Dorico follows your spelling preference
whenever that note is used again in the score.
In you input notes with accidentals outside the key signature, Dorico uses sharps if the figure is
rising, and flats if it is falling. The spelling is also calculated vertically, meaning a simpler interval
is produced where possible. For example, a major third rather than a diminished fourth.
Dorico may make retrospective changes to how it has spelled accidentals, depending on how
your input develops. For example, in C major, if you input a sequence of pitches C–E–G♯, but then
input a G♭, the G♯ is respelled as an A♭.
You can disable this setting in Note Input Options.
RELATED LINKS
Respelling accidentals on page 193

Disabling automatic accidental respelling
To turn off automatic respelling of accidentals, to prevent Dorico from making retrospective
changes to accidentals:
PROCEDURE
1.

Open Note Input Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-I in any mode.
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●

Choose Write > Note Input Options in Write mode.

2.

Click MIDI Input in the list at the left of the dialog.

3.

Deactivate Allow spelling of notes to be adjusted retrospectively.

4.

Click Apply, then Close.

Changing accidentals
To change the accidental of selected notes:
PROCEDURE
1.

In Write mode, select the notes whose accidental you want to change.

2.

Change the accidental in one of the following ways:
●

Click the button of the type of accidental that you want to use in the Notes panel

●

Press 0 to change the accidental to a natural

●

Press - to change the accidental to a flat

●

Press = to change the accidental to a sharp

RELATED LINKS
Adding accidentals on page 103
Key commands in Dorico on page 10

Deleting accidentals
PROCEDURE
1.

In Write mode, select the note whose accidental you want to delete.

2.

Deactivate the accidental in any of the following ways:
●

Click the button of the accidental in the Notes panel.

●

Press 0 to delete naturals.

●

Press - to delete flats.

●

Press = to delete sharps.

NOTE
If a note of the same pitch appears with an accidental earlier in the bar, but that accidental
has not been deleted, any subsequent notes of the same pitch assume that accidental
even if it does not appear by every notehead.

RELATED LINKS
Adding accidentals to existing notes on page 189
Key commands in Dorico on page 10
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Deleting accidentals from multiple notes
Deleting accidentals from multiple works in a similar way to deleting an accidental from an
individual note, but more information is required for a selection that includes different types of
accidentals.
PROCEDURE
1.

2.

3.

In Write mode, select the group of notes whose accidentals you want to delete.
●

If the notes follow each other consecutively: select the first note of the group, hold
down Shift, then select the last note of the group.

●

If the notes are separate with other notes in between: hold down Ctrl/Cmd and click
on each note you want to remove an accidental from individually.

For a selection including just one type of accidental, deactivate that accidental in one of the
following ways:
●

Click on the button of that accidental in the Notes panel

●

Press 0 to delete naturals

●

Press - to delete flats

●

Press = to delete sharps

For a selection including multiple types of accidentals, click natural in the Notes panel, or
press 0.
NOTE
Re-inputting an accidental over a selection of notes, where multiple accidentals are being
used, changes everything in that selection to the accidental you choose. For example, two
G♯s followed by two G♭s become four G♯s if you re-input a sharp. If you click on the sharp
button, or press =, twice more, all accidentals are deleted.
Therefore, to delete accidentals from a selection with multiple accidentals, it is
recommended that you input a natural by click on its button in the Notes panel, or by
pressing 0.

Individual changes to the appearance of accidentals
You can change the appearance of individual accidentals in further detail by using the Properties
panel at the bottom of the window.
For example, you can hide, show, or parenthesize individually selected accidentals.
You can hide and show the Properties panel in the following ways:
●

Press Ctrl/Cmd-8.

●

Click its disclosure arrow.

NOTE
Only options relevant to the selected items appear in the Properties panel. Options for
accidentals only appear if your selection contains only notes.
There are more options for accidentals in the Properties panel in Engrave mode than in Write
mode.

RELATED LINKS
Accidental duration rules on page 196
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Showing accidentals in parentheses individually
You can show individual accidentals in parentheses, and also hide or show accidentals
individually. For example, you can show an accidental in parentheses on subsequent notes in tie
chains that cross system breaks.
PROCEDURE
1.

Select the notes whose accidental appearance you want to change. You can do this in
Write mode and Engrave mode.
NOTE
You can only select individual noteheads within tie chains in Engrave mode.

2.

Activate the Accidental property in the Notes and Rests group of the Properties panel.

3.

Select one of the following options from the menu:
●

Show

●

Hide

●

Parenthesize
NOTE
Hiding accidentals does not affect the pitch of notes in playback.

RESULT
Accidentals on the selected notes are shown, hidden, or shown in parentheses, according to your
selection.
NOTE
If you find that you need to hide or show lots of accidentals in your project, it may be easier to
change the accidental duration rule for the project.

RELATED LINKS
Accidental duration rules on page 196

Project-wide Engraving Options for accidentals
Options for the appearance and positions of accidentals project-wide can be found on the
Accidentals page in Engraving Options.
The options on this page allow you to change the order of accidentals in chords and the precise
positioning of accidentals relative to noteheads and parentheses.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Accidentals in the page list on the left of the dialog.
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Respelling accidentals
You can change the enharmonic spelling of notes, so they are shown as their enharmonic
equivalents.
Dorico uses an algorithm that automatically decides the spelling of pitches, based on key
signature and context.
However, there are occasions when you might need to change how an accidental is spelled, such
as to show clearly the stepwise movement in a phrase, or to avoid altered unisons in a chord.
In Dorico, you can switch between each available enharmonic spelling, allowing you to see at
least three options for every pitch. There are always at least three options, as Dorico allows
enharmonic spellings to show up to two accidental glyphs.
As demonstrated in the examples, this means the same note can sometimes be spelled four
ways, if the original pitch can be spelled with the note name either two notes below or two notes
above, using a maximum of two accidental glyphs.
In the examples, B is a possible enharmonic spelling of G because a triple-flat uses a single
accidental glyph, whereas an F uses two accidental glyphs.
PROCEDURE
1.

In Write mode, select the notes you want to respell.

2.

Respell the selected notes upwards or downwards in any of the following ways:
●

Press Alt-= to respell upwards

●

Press Alt-- to respell downwards

●

Choose Write > Respell > Respell Using Note Name Above to respell upwards

●

Choose Write > Respell > Respell Using Note Name Below to respell downwards

RESULT
The enharmonic spelling of the selected notes is changed.
EXAMPLE

A G sharp

When respelled
downwards, the G sharp
becomes an F triplesharp

When respelled upwards, When respelled upwards
the G sharp becomes an again, the G sharp
A flat
becomes a B triple-flat

Altered unisons
Altered unisons occur when two or more notes of the same name in the same octave have
different accidentals in the same chord, for example D♯ and D♭.
In Dorico, this is notated with a split stem, sometimes known as a “cherry stalk” or a “tree”, which
allows both notes to appear with their corresponding accidental directly beside them.
You can choose to have altered unisons appear with a single stem: the noteheads appear directly
beside each other, and the two accidentals are shown beside each other to the left of the chord.
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EXAMPLE

A single stem altered unison

A split stem altered unison

Inputting altered unisons
To input a chord with two notes in the same octave, but with different accidentals:
PROCEDURE
1.

2.

Activate the Chords input tool in one of the following ways:
●

Click Chords in the Notes toolbox:

●

Press Q

Input the pitches you want in any of the following ways:
●

Press the corresponding letters on the computer keyboard, such as C, D, E and so
on.

●

Play in the pitches on a MIDI keyboard.

●

Click the staff positions of the pitches you want.

RESULT
Multiple notes are input at the same rhythmic position as a chord.
NOTE
If entering pitches by clicking with the mouse, you can put the same pitch into the chord twice by
clicking again on the same line.
If entering pitches with the keyboard, repeated notes are automatically input an octave above.
You can transpose it down an octave by selecting the note and pressing Ctrl/Cmd-Shift-Down
Arrow.

Changing how altered unisons appear individually
You can change how individual altered unisons appear, independently of your project-wide
settings and independently of other altered unisons in chords.
PROCEDURE
1.

Select the altered unison notes whose appearance you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the Split stem property in the Notes and Rests group of the Properties panel.

3.

Change the appearance of altered unisons by checking or unchecking the box beside the
property:
●

Check the box for split stems

●

Uncheck the box for single stems
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RESULT
The appearance of the selected altered unison notes is changed.
NOTE
The Split stem property applies to notes individually. You can have altered unisons appear
differently within the same chord by setting their properties independently.

Changing how altered unisons appear project-wide
You can change how altered unisons appear project-wide in the Altered unisons section of the
Accidentals page in Notation Options. They can appear either side-by-side or as split stems.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Accidentals from the Category menu.

3.

Choose one of the following options for Appearance of altered unisons in the Altered
unisons section:

4.

●

Single stem

●

Split stem

Click Apply, then Close.

Changing how chords with multiple altered unisons appear projectwide
You can change how split stem chords that contain multiple altered unisons appear projectwide in the Altered unisons section of the Accidentals page in Notation Options. Notes can be
allocated on one side of the original stem or on both sides of the original stem.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Accidentals from the Category menu.

3.

Choose one of the following options for Chords with multiple altered unisons in the
Altered unisons section:

4.

●

Allocate only to the left

●

Alternate between left and right

Click Apply, then Close.

Microtonal accidentals
Microtonal accidentals can be highly customized in Dorico.
The default tonality system can be found in the Key Signatures, Tonality Systems and
Accidentals panel on the right of the screen. In Write mode, the default is Equal temperament
(12-EDO). When this option is selected, the accidentals available at the bottom of the menu are
half-step (semitone) accidentals: sharp, flat, double flat, and so on.
To use microtonal accidentals:
1

Select the Equal temperament (24-EDO) tonality system in the Tonality Systems section
of the Key Signatures panel.
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2

Create a key signature in the flow.
NOTE
Even if you do not want to use a conventional key signature, you must create an open or
atonal key signature in order to use the microtonal accidentals.

You can also define your own tonality systems, custom key signatures, and accidentals.
RELATED LINKS
Inputting microtonal accidentals on page 196
Tonality systems on page 404

Inputting microtonal accidentals
Before you can input microtonal accidentals, you must first input an atonal key signature.
PROCEDURE
1.

2.

Open the key signatures popover in any of the following ways:
●

Press Shift+K

●

Choose Write > Create Key Signature

Enter atonal into the popover, and press Return to close the popover.

The open or atonal key signature appears in the music as a signpost, and microtonal
accidentals now appear in the Accidentals section of the Notations panel.
3.

Select the note or notes to which you want to apply a microtonal accidental.

4.

Click on the microtonal accidental you want to input in the Accidentals section of the Key
Signatures panel.

RESULT
The selected microtonal accidental appears beside the selected note or notes.
NOTE
Only one type of accidental can be added at a time.

Accidental duration rules
Accidental duration rules determine how long an accidental applies, for example within a bar, at
a different octave, or just for a single note.
Dorico allows you to use different accidental duration rules.
Common practice
In Dorico, this is the default accidental duration rule. In common practice, an
accidental applies for the duration of a bar and only to the pitch at which it is written;
each octave requires a separate accidental.
Second Viennese School
The Second Viennese School accidental duration rule requires writing every note with
an accidental, including naturals.
Modernist
The Modernist accidental duration rule states that only notes that have been altered
from the key signature show accidentals; naturals are not shown.
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RELATED LINKS
Common practice on page 198
Second Viennese School on page 200
Modernist on page 200

Changing the accidental duration rule
To change the accidental duration rule to the one most appropriate for your project:
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Accidentals from the Category menu.

3.

Select the flows in which you want to change the cancelation rule for double accidentals in
the list on the left of the dialog in the following ways:
●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
4.

5.

Choose one of the following options for Accidental duration rule in the Basic section:
●

Common Practice

●

Second Viennese School

●

Modernist

Click Apply, then Close.

RELATED LINKS
Common practice on page 198
Second Viennese School on page 200
Modernist on page 200

Canceling double accidentals
If a double sharp is canceled by a single sharp, or a double flat is canceled by a single flat, then
by default no natural sign is shown in front of the single sharp or single flat, as these accidentals
are unambiguous.
You can change how double accidentals are canceled project-wide in the Basic section of the
Accidentals page in Write > Notation Options.
●

Archaic shows a natural sign before new accidentals that come after double accidentals.

●

Modern replaces double accidentals immediately with a new accidental.
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EXAMPLE

Archaic cancelation puts a natural before a new
accidental after a double accidental.

Modern cancelation replaces the double accidental
with the new one, without showing a natural sign
first.

RELATED LINKS
Notation Options on page 119

Common practice
In common practice, an accidental affects all notes of the same pitch in the same octave within
the same bar, unless it is canceled by another accidental. If it is not canceled, it is automatically
canceled in the following bar.
NOTE
To ensure that the cancelation is unambiguous, it is customary to add a cautionary or courtesy
accidental to the first note of the same pitch in the following bar.
In Dorico, the common practice accidental duration rule is used by default. You can change the
accidental duration rule on the Accidentals page in Write > Notation Options.

Common practice rules
In common practice, the accidental of a note in one bar is automatically canceled in the following
bar. For example, in the key of G major, if an F♮ is in one bar, an F in the following bar shows a
sharp sign, even though the sharp is implied by the key signature.
When using the common practice accidental duration rule by default, Dorico also displays
cautionary accidentals. Cautionary accidentals, also known as “courtesy accidentals”, are
restatements of an earlier accidental. They are considered optional; that is, they are neither
explicit confirmations nor cancelations, but help to eliminate ambiguities.
Cautionary accidentals are shown in the following circumstances:
●

Subsequent notes within the same bar have the same note name in different octaves.

●

Subsequent notes in the following bar have the same note name in the same octave.

●

The first occurring note in the following bar has the same note name in any octave.

●

A tied note appears at the start of the next system and the accidental is held over a system
break.

●

Notes appear at the same staff position, but belong to another player when condensed.

●

Augmented/diminished or double-diminished/augmented intervals are identified within
the same bar.

For each of these situations, you can choose whether cautionary accidentals are shown in
parentheses, shown without parentheses, or not shown at all.
RELATED LINKS
Changing the accidental duration rule on page 197
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Showing and hiding cautionary accidentals on page 199
Canceling double accidentals (Common practice) on page 199

Canceling double accidentals (Common practice)
You can change the way double accidentals are canceled if you use the common practice
accidental duration rule.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Accidentals from the Category menu.

3.

Select the flows in which you want to change the cancelation rule for double accidentals in
the list on the left of the dialog in the following ways:
●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
4.

5.

Choose one of the following options for Single accidentals canceling double accidentals
in the Basic section:
●

Use archaic cancelation: double accidentals are canceled by a natural-sharp or a
natural-flat sign.

●

Use modern cancelation: double accidentals are canceled by a single sharp or a
single flat sign.

Click Apply, then Close.

Showing and hiding cautionary accidentals
You can show and hide cautionary accidentals, if you use the common practice accidental
duration rule.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Accidentals from the Category menu.

3.

Select the flows in which you want to show or hide cautionary accidentals in the list on the
left of the dialog in the following ways:
●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
4.

Choose the options that you want to apply to your project in the Cautionary (courtesy)
accidentals section.

5.

Click Apply, then Close.

RELATED LINKS
Common practice on page 198
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Second Viennese School
The accidental duration rule of the Second Viennese School states that an accidental applies
only to the note on which it is written. All notes show an accidental regardless of key signature,
including unaltered notes which show naturals.
This accidental duration rule was used by Schönberg and other composers of the Second
Viennese School.
You can change the accidental duration rule on the Accidentals page in Notation Options.

Restating accidentals after intervening change of pitch (Second Viennese
School)
If you use the Second Viennese School accidental duration rule, you can allow that an immediate
repetition of the same note, including those on either side of an intervening rest, within the same
bar does not require the accidental to be restated.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Accidentals from the Category menu.

3.

Select the flows in which you want to change the Second Viennese School rule for restating
accidentals in the list on the left of the dialog in the following ways:
●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
4.

Choose Restate after intervening change of pitch for Accidentals on immediate
repetitions of the same note within a bar in the Second Viennese School options
section.

5.

Click Apply, then Close.

Modernist
The Modernist accidental duration rule states that only notes that have been altered from the
key signature show accidentals. Naturals are not shown. However, accidentals that are shown
only apply to the notes on which they are written, as with the Second Viennese School.
You can change the accidental duration rule on the Accidentals page in Notation Options.
RELATED LINKS
Second Viennese School on page 200

Restating accidentals after intervening change of pitch (Modernist)
If you use the Modernist accidental duration rule, you can prevent accidentals from being shown
on an immediate repetition of a note of the same pitch within a bar.
NOTE
Charles Ives and Robert Crumb used this variation.

PROCEDURE
1.

In Write mode, choose Write > Notation Options.
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2.

Select Accidentals from the Category menu.

3.

Select the flows in which you want to change the Modernist rule for restating accidentals
in the list on the left of the dialog in the following ways:
●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
4.

Choose one of the following options for Accidental duration rule in the Basic section:
●

Common Practice

●

Second Viennese School

●

Modernist

5.

Choose Restate after intervening change of pitch for Accidentals on immediate
repetitions of the same note within a bar in the Modernist options section.

6.

Click Apply, then Close.

Preventing restatements of accidentals on repetitions of notes in beamed
groups
If you use the Modernist accidental duration rule, you can prevent accidentals from being shown
on a repetition of a note of the same pitch within the same beam group.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Accidentals from the Category menu.

3.

Select the flows in which you want to change the Modernist rule for restating accidentals
in the list on the left of the dialog in the following ways:
●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
4.

Choose Do not restate within a beamed group for Accidentals on repetitions of the
same note within a beamed group in the Modernist options section.

5.

Click Apply, then Close.

Stacking of accidentals
If multiple accidentals are required for a chord in a single voice, or for notes in multiple voices at
the same rhythmic position, they are stacked to the left of the chord in columns.
For chords with multiple accidentals, accidentals are generally stacked as follows:
1

The highest accidental is inserted in the first column immediately to the left of the notes.

2

The lowest accidental is added to the same column provided that it does not collide with
the first accidental.

3

The remaining highest and lowest accidentals are alternated in successive columns located
further left from the chord.

In Dorico, additional rules help to produce a stack of accidentals that uses as few columns as
possible. The following list contains some of the rules that are applied:
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●

Columns closer to the notes contain more accidentals than columns further from the
notes.

●

Accidentals on notes that are an octave apart are stacked in the same column. This also
applies to accidentals that are a sixth or more apart, depending on the combination of
accidentals.

●

Accidentals in the same column never collide. The minimum interval between accidentals
that are required to prevent collisions depends on the types of accidentals.

●

Accidentals that are a second apart are arranged in adjacent columns, with the higher
accidental in the right-hand column.

These rules minimize the amount of extra space that is required between successive notes or
chords and ensure that accidentals appear as close as possible to the noteheads to which they
apply. At the same time, they produce a contour that resembles a C-curve on the left-hand side of
the chord.

Stacking rules for dense chords
For dense chords with six or more accidentals within the span of an octave, accidentals are
stacked as follows:
1

The highest accidental is inserted in the first column to the left of the notes.

2

The next accidental on a note that is located at least a seventh below the highest note
is stacked into the same column. This continues with the remaining notes until no more
accidentals fit into the first column.

3

Steps 1 and 2 are repeated for the following columns until all accidentals are stacked.

4

The columns are grouped, interspersed, and re-stacked. This results in a stack with
alternating accidentals, reminiscent of the way accidentals are arranged in a key signature.

Stacking accidentals without interspersion
You can allow accidentals to be stacked without interspersion, so that the accidentals in the
columns describe a diagonal line sloping downwards to the left.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Accidentals in the page list.

3.

Choose Arrange stacks high to low for Order of accidental stacks in lattice
arrangement in the Stacking section.

4.

Click Apply, then Close.

Applying standard stacking rules to dense chords
To apply the standard accidental stacking rule for dense chords:
PROCEDURE
1.

In Engrave mode, select Engrave > Engraving Options.

2.

Select the Accidentals page.

3.

Activate Use zig-zag arrangement in the Close Position and Cluster Chords subcategory
of the Arrangement for dense chords with many accidentals section.

4.

Click Apply, then Close.
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NOTE
The standard rule produces a wider arrangement and more columns than the default zigzag arrangement that is used in Dorico for dense chords.

Kerning of accidental columns
Dorico applies kerning to accidental columns to ensure that the columns to the left of a chord
occupy as little horizontal space as possible.
In typography, kerning adjusts the space between individual characters to increase legibility. In
Dorico, as well as in music engraving in general, kerning allows accidentals to interlock.
EXAMPLE
If a low note is followed by a high note with an accidental, the accidental may be tucked above
the low note, to prevent the rhythmic spacing from being distorted.
Similarly, in the case of multiple columns of accidentals on a chord, the overall width of the stack
of accidentals is reduced if, for example, a flat in the second column is kerned underneath a
sharp in the first column belonging to a note a third higher. This also reduces the need to distort
rhythmic spacing to accommodate accidentals.
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Articulations are markings that are drawn above or below notes and chords. Articulations tell a
performer how to attack a note or how long a note should be relative to its notated duration.
In Dorico, articulations are defined as something that alters the way a note should be played, in a
way that is consistent across all instruments.
As instructions like bowing directions, harmonics, or tonguing apply to different instrument
groups, in Dorico such directions are defined as playing techniques, and can be found in the
Notations panel on the right of the window.
Articulations are categorized into three types:
●

Articulations of force: accent and marcato, which is sometimes called a strong accent.
Dorico shows these articulations at the start of a note or tie chain by default.

●

Articulations of duration: staccatissimo, staccato, tenuto, and staccato-tenuto, which is
sometimes called louré. If a note includes a tie or ties, Dorico shows these articulations
above the last note in the chain by default.

●

Articulations of stress: stress and unstress. Dorico shows these articulations at the start of
a note or tie chain by default.

You can find the articulations at the bottom of the Notes panel in Write mode.

Dorico positions articulations automatically on the notehead or stem side of notes and chords,
according to the musical context. A note or chord can display one of each of the three types of
articulations.
You can change the effect of articulations on playback, based both on the type of instrument and
the playback devices in use in the Note Dynamics section of the Dynamics page in Playback
Options. You can open Playback Options in the following ways:
●

Choose Play > Playback Options in Play mode

●

Press Ctrl/Cmd-Shift-Pin any mode

RELATED LINKS
Adding articulations on page 104
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Project-wide Engraving Options for articulations
Options for the appearance and placement of articulations project-wide can be found on the
Articulations page in Engraving Options.
The options on this page allow you to change the positions of articulations in detail, including
whether different articulations are shown above the staff or by the notehead, and the positions
of articulations relative to ties and slurs.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Articulations in the page list on the left of the dialog.

Inputting articulations during step input with the keyboard
To input notes with articulations during step input with the keyboard:
PROCEDURE
1.

In Write mode, start note input.

2.

Press the key commands for your preferred articulations.

3.

Enter the note or chord you want.

RESULT
The selected articulations are added to all notes that are input until the articulations are
deselected.
RELATED LINKS
Note input on page 92
Articulation input methods when using the keyboard on page 205

Articulation input methods when using the keyboard
You can input articulations by using the following key commands:
Press:

For articulation:

[

accent

'

marcato

Shift-[

stress

Shift-'

unstress

]

staccato

\

tenuto
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Press:

For articulation:

Shift-]

staccatissimo

Shift-\

combined tenuto and staccato

Adding articulations to existing notes with the keyboard
To add articulation to existing notes with the keyboard:
PROCEDURE
1.

In Write mode, select the note or notes to which you want to add articulations.

2.

Press the keys or key commands that correspond to your preferred articulations.

RELATED LINKS
Articulation input methods when using the keyboard on page 205

Inputting articulations during step input with the mouse
You can input notes with articulations during step input with the mouse.
PROCEDURE
1.

In Write mode, start note input.

2.

Click the articulations you want in the Notes panel on the left of the window.

3.

Click or play in the notes or chords you want.

RESULT
The selected articulations are added to all notes that are input until the articulations are
deselected.
RELATED LINKS
Note input on page 92

Adding articulations to existing notes with the mouse
To add articulations to existing notes with the mouse:
PROCEDURE
1.

In Write mode, select the note or notes to which you want to add articulation.

2.

Select the articulation you want in the Notes panel on the left of the window.

RESULT
The articulation is added to the selected note or notes.
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Copying articulations
Articulations are automatically included if you copy a note or notes, but they cannot be copied
and pasted independently of notes.
You can copy notes in the following ways:
●

Select the material you want to duplicate and press R. This repeats material directly after
itself.

●

Select the material you want to duplicate, choose Edit > Copy, then select where you want
to copy to and choose Edit > Paste.
NOTE
You can also use the standard key commands of your operating system for copying and
pasting: usually Ctrl/Cmd-C for copy, and Ctrl/Cmd-V for paste.

●

Select the material you want to duplicate, hold down Alt, then click with the mouse cursor
at the point the phrase should start.

Changing articulations
To change articulations for a selected note:
PROCEDURE
1.

In Write mode, select the note.

2.

Do one of the following:
●

On the Notes panel, activate the button for the articulation you want to add.

●

On the keyboard, press the respective key command.

RESULT
The new articulation is added. This replaces any existing articulation of the same type.
RELATED LINKS
Adding articulations on page 104

Deleting articulations
Individual articulation markings cannot be selected separately from their notehead in Write
mode, so articulations must be deleted by selecting the note or notes to which they are attached,
and deselecting the articulation.
PROCEDURE
1.

In Write mode, select the notes from which you want to delete articulation.

2.

Delete the articulation in any of the following ways:
●

Press the key command of the articulation you want to delete.

●

Click the button of the articulation you want to delete in the Notes panel.

RELATED LINKS
Articulation input methods when using the keyboard on page 205
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Positions of articulations
Articulations are placed on the notehead side by default, with the following exceptions:
●

In a single-voice context, marcato is always placed above the staff, regardless of the stem
direction of the note or chord on which it is used. In a multiple-voice context, marcato may
also be placed below the staff.

●

If multiple voices are active, articulations are placed at the end of the stem side of a note
or chord. This clarifies which articulations belong to the up-stemmed notes and which to
the down-stemmed notes.

●

If a note is placed on the middle staff line or on the space immediately on either side,
articulations that are less than a space in height are centered in the next unoccupied
space. This normally only applies to staccato and tenuto. If a note in the middle of the staff
has a staccato-tenuto articulation, the component parts of the articulation are split up and
placed in separate spaces.

●

If an articulation cannot fit within a staff space, or if the note is placed high or low on the
staff, the articulation is placed outside the staff.

●

If a note or chord is tied and the tie is placed above or below the notehead, articulations
that are placed on the notehead side of a note or chord are offset by an additional 1/4
space in order to avoid the end of the tie.

Articulations on the notehead side are always centered horizontally on the notehead. This
also applies to articulations on the stem side, except if the only articulation is a staccato or
staccatissimo. In this case, the articulation is centered on the stem.
RELATED LINKS
Changing the horizontal position of staccato marks project-wide on page 210
Changing the vertical gaps between articulations and other notation project-wide on page 209

Order of articulations
If notes or chords have several types of articulations, the order in which they are positioned is:
1

Articulations of duration are positioned closest to notes or stems.

2

Articulations of force are positioned outside articulations of duration.

3

Articulations of stress are positioned furthest from notes or stems.

Order of articulations in relation to slurs
Articulations of duration are positioned as follows:
●

Inside slurs that start or end on a note or chord with an articulation

●

Inside the curvature of a slur

●

Inside tuplet brackets

Articulations of force are positioned as follows:
●

Outside slurs that start or end on a note or chord with an articulation, except if they can be
positioned within the staff

●

Inside the curvature of a slur if they fit between the slur and the note or stem, to which
they belong, without colliding

●

Outside tuplet brackets
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Force and Stress articulations outside the end of the
slur.

Duration articulations inside the end of a slur.

Articulation tucking index property

Project-wide changes to the positions of articulations
The positions of articulations can be changed project-wide on the Articulations page in
Engraving Options.
RELATED LINKS
Individual changes to the positions of articulations on page 211

Changing the vertical gaps between articulations and other notation projectwide
To change the distances between articulations and noteheads/stems, or the gaps between
different articulations on the same note or chord in fractions of spaces:
For example, you might want to increase the distance between articulations if your score has lots
of stacked articulations, and they are hard to read.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Articulations in the page list.

3.

In the Vertical Position section, adjust the values for the vertical positions you want to
change for your project.

4.

Click Apply, then Close.

RESULT
The vertical position of articulations is changed project-wide, as shown by these examples.
EXAMPLE

Stacked articulations with default vertical spacing
settings.
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Changing the positions of articulations on tied notes project-wide
By default, articulations of force and stress are shown on the first note or chord of a chain of tied
notes, while articulations of duration are shown on the last note or chord.
To change the default position of articulations in tie chains:
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Articulations in the page list.

3.

In the Ties section, select one of the following positions for the articulation type that you
want to change:
●

Start of tie chain
Positions the articulation on the first note or chord of a chain of tied notes.

●

End of tie chain
Positions the articulation on the last note or chord of a chain of tied notes.

4.

Click Apply, then Close.

Changing the horizontal position of staccato marks project-wide
The horizontal position of most articulations is centered on a stem or a notehead. However, if a
staccato or staccatissimo is the only articulation, its horizontal position can also be half-centered
when they are placed on the stem side.
By default, staccato and staccatissimo articulations are centered on the stem when on the stem
side.
To change the default horizontal position of staccato and staccatissimo articulations when they
are on the stem side:
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Articulations in the page list.

3.

Choose from the following options for Horizontal position of staccato on the stem side
in the Horizontal Position section:

4.

●

Center on notehead

●

Center on stem

●

Half-center

Click Apply, then Close.

RESULT
Staccato marks are positioned project-wide according to the option selected.
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Individual changes to the positions of articulations
You can change the positions of articulations in Engrave mode by selecting them and moving
them, or by using properties in the Properties panel.

Moving individual articulations vertically
You can move individual articulations graphically upwards and downwards so they are closer to
or further away from notes.
PROCEDURE
1.

In Engrave mode, select the articulations that you want to move

2.

Move the articulations in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press AltDown Arrow to move them downwards.
TIP
If you want to move articulations by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag them upwards and downwards to the positions you want.

RELATED LINKS
Moving individual articulations vertically using the Properties panel on page 211

Moving individual articulations vertically using the Properties panel
You can move individual articulations graphically upwards and downwards using the Properties
panel so they are closer to or further away from notes.
PROCEDURE
1.

In Engrave mode, select the noteheads to which the articulations you want to move are
attached.

2.

Activate Offset Y property in the Articulations group of the Properties panel for the
articulation type that you want to move. For example, activate Offset Y under the
Articulations of force heading to move accents.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing the Offset Y value moves articulations upwards. Decreasing the Offset Y value moves
articulations downwards.

Changing the placement of articulations individually
You can change where individual articulations are placed.
PROCEDURE
1.

In Engrave mode, select the notes or chords whose articulation positions you want to
change.

2.

Activate the Placement property in the Articulations group of the Properties panel.
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3.

Select one of the following options from the menu:
●

Notehead side

●

Stem side

RESULT
The articulation is placed on the selected side of the notes or chords. If this would create
a collision with other markings (such as playing techniques), Dorico automatically makes
adjustments to make sure all markings are clear and legible.
RELATED LINKS
Moving individual articulations vertically on page 211

Changing the positions of articulations on tied notes individually
By default, articulations of force and stress are shown on the first note or chord of a chain of tied
notes, while articulations of duration are shown on the last note or chord.
PROCEDURE
1.

Select the tied note or tied notes whose articulation position you want to change. You can
do this in Write mode and Engrave mode.

2.

In the Articulations group of the Properties panel, activate the Pos. in tie chain option
for the articulation type that you want to change. For example, activate Pos. in tie chain
under the Articulations of force heading to change the position of accents.

3.

Choose one of the following options:
●

First note

●

Last note

Articulations in playback
Adding articulations to your score affects how notes sound in playback.
If you do not have a sample library, Dorico still changes how a note sounds in playback if you
have put an articulation on it. For example, a staccato causes a note to sound shorter than
normal, and an accent causes a note to sound louder than normal.
The Timings page in Play > Playback Options (key command Ctrl/Cmd-Shift-P), provides
options for the default effect of articulations of duration. The Dynamics page contains options
for articulations of force.
If you do have a sample, Dorico loads the specific sample for an articulation if such a sample is
included in your library for that instrument.
As the articulation applies to the whole note, the sample is triggered at the start of a note. This
includes notes that are tie chains.
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Bars indicate a usually regular segment of time according to the number of beats, which is
usually determined by the prevailing time signature. Bars are separated from other bars to the
left and the right by vertical barlines.
Bars are usually the same length and at the same position for all players, but in some music, bars
of different lengths may coincide, and there are situations where some players may have no bars
indicated at all.
Each bar has a number, allowing players to keep track of their place in the music and aiding
rehearsal. This is especially important in music for multiple players.
RELATED LINKS
Bar numbers on page 231

Inputting bars with the keyboard
Normally you do not need to create bars in Dorico, as they are created automatically as needed
when you input music.
However, you may want to add bars in advance if, for example, you are copying or arranging an
existing piece of music.
One way to add bars is by choosing a note value, such as a whole note when in a 4/4 time
signature, in the Notes panel in Write mode and by pressing Space repeatedly during step input.
Alternatively, you can input bars with the keyboard by using the bars and barlines popover in
Write mode. You can open the bars and barlines popover in the following ways:
●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The bars and barlines popover with an example
entry for inputting bars

The bars and barlines button in the Notations
toolbox

The bars and barlines popover for bars
Here are some examples of what to enter into the bars and barlines popover if you want to input
and delete bars, and what is input in the music as a result.
You can open the bars and barlines popover in Write mode in the following ways:
●

Press Shift-B.
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●

Choose Write > Create Bar or Barline.

Enter:

Result:

+2

Add two bars

+14

Add fourteen bars

–1

Delete one bar

–6

Delete six bars

rest

Add a bar rest

This list is not comprehensive: it is intended to illustrate how you can structure your entry to
input and delete bars, and input bar rests.
RELATED LINKS
The bars and barlines popover for barlines on page 224

Inputting bars during step input with the keyboard
You can input bars during step input with the keyboard.
PROCEDURE
1.

In Write mode, start note input.

2.

Open the bars and barlines popover in any of the following ways:
●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

3.

Enter + (plus), followed by the number of bars you want to add. For example, enter +2 to
add two bars.

4.

Press Return to close the popover.

RESULT
The number of bars specified is added from the caret position. If the caret is in the middle of the
bar, sufficient beats are added to ensure that the final bar created has the correct number of
beats.
The caret position stays at its previous position so you can continue inputting music from the
same position.
RELATED LINKS
Inputting bars during step input with the mouse on page 216

Adding bars into existing music with the keyboard
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The barline after which you want to add new bars.

●

The note or whole bar before which you want new bars to be added.

Open the bars and barlines popover in any of the following ways:
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●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

3.

Enter + (plus), followed by the number of bars you want to add. For example, enter +2 to
add two bars.

4.

Press Return to close the popover.

RESULT
The number of bars specified is added directly after a selected barline, and directly before a
selected note or bar.

Inputting bar rests during step input with the keyboard
For music in a single voice, you do not have to input bar rests. Bar rests appear in each new bar
automatically when you advance the caret by pressing Space or Right Arrow.
When inputting music in multiple voices, rests are normally created automatically when there
is a gap in the secondary voice. However, if the music is in strict counterpoint and you want the
secondary voice to begin with an explicit bar rest, you can create a bar rest during step input with
the keyboard.
PROCEDURE
1.

In Write mode, start note input.

2.

Select the appropriate secondary voice by pressing V until the voice direction indicator
shows the correct voice.

3.

Open the bars and barlines popover in any of the following ways:
●

Press Shift-B

●

Choose Write > Create Bar or Barline

4.

Enter rest into the popover to add a bar rest.

5.

Press Return to close the popover.

6.

Press Ctrl/Cmd-Right Arrow to advance the caret to the start of the next bar after the bar
rest.

RESULT
The bar rest is added at the caret position. If the caret position is within a bar that contains notes
for the selected voice, these notes are replaced by the bar rest.
RELATED LINKS
Inputting multiple voices during step input on page 708
Switching between voices during step input on page 708

Inputting bars with the mouse
You can input bars with the mouse using the Bars and Barlines panel on the right of the window
in Write mode.
You can open the Bars and Barlines panel by clicking Bars and Barlines in the Notations
toolbox:

In the panel, there are three sections:
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●

Insert Bars

●

Insert Bar Rest

●

Insert Barline

The panel can be hidden and shown in the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

Inputting bars during step input with the mouse
You can input bars during step input with the mouse.
PROCEDURE
1.

In Write mode, start note input.

2.

Using the Insert Bars section of the Bars and Barlines panel, select the number of bars
you want to add.
In the Insert Bars section, you can decide how many bars you want to add by entering
a number into the value field, or using the up and down arrows to increase or decrease
the number. The minimum number is 1. You can also select where they are input in your
project:
●

Start of Flow: bars are added at the beginning of the flow.

●

Start of Selection: bars are added from the selected note or rest. During step input,
bars are added from the caret position.

●

End of Flow: bars are added at the end of the flow.

NOTE
If you want the bars to be added from the caret position, make sure that you have selected
Start of Selection from the menu.
3.

Click Insert Bars.

RESULT
The number of bars specified is added.
RELATED LINKS
Inputting bars during step input with the keyboard on page 214

Adding bars into existing music with the mouse
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The barline after which you want to add new bars.

●

The note or whole bar before which you want new bars to be added.

Using the Insert Bars section of the Bars and Barlines panel, select the number of bars
you want to add.
In the Insert Bars section, you can decide how many bars you want to add by entering
a number into the value field, or using the up and down arrows to increase or decrease
the number. The minimum number is 1. You can also select where they are input in your
project:
●

Start of Flow: bars are added at the beginning of the flow.

216

Bars
Deleting bars

3.

●

Start of Selection: bars are added from the selected note or rest. During step input,
bars are added from the caret position.

●

End of Flow: bars are added at the end of the flow.

Click Insert Bars.

RESULT
The number of bars specified is added directly after a selected barline, and directly before a
selected note or bar.

Inputting bar rests during step input with the mouse
For music in a single voice, you do not have to input bar rests. Bar rests appear in each new bar
automatically when you advance the caret by pressing Space or Right Arrow.
When inputting music in multiple voices, rests are normally created automatically when there
is a gap in the secondary voice. However, if the music is in strict counterpoint and you want the
secondary voice to begin with an explicit bar rest, you can create a bar rest during step input with
the mouse.
PROCEDURE
1.

In Write mode, start note input.

2.

Click Insert Bar Rest in the Bars and Barlines panel.
You may need to click on the Insert Bar Rest section title to disclose this button.

3.

Continue inputting notes after the bar rest.

RESULT
The bar rest is added at the caret position. If the caret position is within a bar that contains notes
for the selected voice, these notes are replaced by the bar rest.

Deleting bars
You can delete bars from your project completely by using the bars and barlines popover.
PROCEDURE
1.

In Write mode, select the first bar you want to delete, or the first note or rest in that bar.

2.

Open the bars and barline popover in any of the following ways:
●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

3.

Enter – (minus), followed by the number of bars you want to delete into the popover. For
example, enter –1 to delete just the selected bar, or –6 to delete six bars, starting from the
selected bar.

4.

Press Return to close the popover.

RESULT
The number of bars specified is deleted. For example, if you enter –6, then the bar you selected
and the subsequent five bars are deleted.
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Deleting empty bars at the end of flows
You can delete any empty bars left at the ends of flows.
In Write mode, choose Write > Trim Flow to delete empty bars at the end of the current flow.

Deleting the contents of bars
You can delete just the contents of bars without deleting barlines or the bars themselves.
PROCEDURE
1.

Select the bars whose contents you want to delete by clicking on an empty part of the staff.
TIP
Notes, rests, and other objects are highlighted orange when selected.

2.

Delete the selected contents in any of the following ways:
●

Press Backspace.

●

Choose Edit > Delete.

RESULT
The contents of the selected bars are deleted.

Changing the length of bars
You can change the length of a bar so that its duration is longer or shorter.
You can change the length of a bar by changing its time signature. You can later hide the time
signature, for example, if you are writing music with an irregular meter and you require barlines
only to group material together, but not to imply any sense of meter.
RELATED LINKS
Changing time signatures on page 625
Hiding time signatures on page 628

Changing the width of empty bars
You can change the width of empty bars individually by activating Note Spacing in Engrave
mode.
With Note Spacing activated in Engrave mode, you can select a handle at the position of a
barline and use the following key commands to adjust the spacing of empty bars:
●

Alt-Right Arrow

●

Alt-Left Arrow

For example, if you select the handle of the barline on the right of a bar and nudge the handle
to the left, the bar appears thinner. If you select the barline on the right of a bar and nudge the
handle to the right, the bar appears wider.
RELATED LINKS
Note spacing on page 171
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Moving bar rest symbols
Although Dorico automatically positions rests in multiple voices to avoid collisions, you can move
bar rests vertically. For example, when you are using multiple voices.
PROCEDURE
1.

Select the bar rest symbol you want to move. You can do this in Write mode and Engrave
mode.
NOTE
You can only change the position of one bar rest symbol at a time.

2.

Activate Rest pos. in the Notes and Rests group of the Properties panel.

3.

Change the position by increasing or decreasing the value in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Position 0 is the middle line of the staff. The bar rest moves upwards when you increase the
value, and downwards when you decrease the value.
Deactivating Rest pos. restores the bar rest to its default position.

Splits in bars
You can split bars rhythmically by changing the number of beats in each bar, and visually by
splitting single bars across systems or page breaks, which may be required in music in an
irregular meter or in passages of polymeter.
You can split bars into two or more bars by changing the time signature, or by inserting a
barline.
The new time signature you add applies until the next existing time signature or the end of the
flow, whichever comes first.
If the new time signature does not fit completely into the given space, for example, if you wanted
to replace two 4/4 bars (eight quarter notes) with either two 3/4 bars or three 3/4 bars (either six
or nine quarter notes), then Dorico does not override your existing time signature. Instead, the
final bar is made shorter.
For example, inputting a 3/4 time signature two bars before an existing time signature of 5/4
creates two 3/4 bars and the equivalent of a 2/4 bar, as shown in this example.

However, if you activate Insert mode, then Dorico inserts time at the end of the final bar of the
new time signature to make sure the final bar is the correct length. For example, in the same
scenario as above but with Insert mode activated, two 4/4 bars become three 3/4 bars, with the
extra beat required to fill the third 3/4 bar added at the end of the phrase.
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Splitting bars by inputting new barlines
You can also split bars by inputting new barlines that are not normal (single) barlines anywhere
within a bar without affecting the time signature.
However, inputting a normal (single) barline anywhere within an existing bar resets the pattern
of the time signature from that point onwards.
For example, selecting the third quarter note (crotchet) in a 4/4 bar and inserting a new barline
causes a new 4/4 bar to start from the added barline. This leaves the equivalent of a 2/4 bar,
but without a time signature, to the left of the barline, but the bars to the right of the added
barline are in 4/4 and continue to be in 4/4 until the next time signature or the end of the flow,
whichever comes first.
You can see this shown in this example. After a normal (single) barline is added, a signpost
appears to show how it affects the time signature.

Two 4/4 bars with quarter notes.

Adding a normal barline halfway through the first
4/4 bar restarts the time signature from that point.

RELATED LINKS
Changing time signatures on page 625
Adding time signatures to existing music with the keyboard on page 620
Adding time signatures to existing music with the mouse on page 623
Adding barlines to existing music with the keyboard on page 225
Adding barlines to existing music with the mouse on page 226

Splitting bars across system or frame breaks
System breaks and frame breaks can be created at any point in the score, including in the middle
of bars.
PROCEDURE
1.

In Engrave mode, select an item in the bar, such as a notehead or a rest.

2.

Insert a system break or frame break in the following ways:
●

Press Shift-S to insert a system break.

●

Choose Engrave > Format Systems > System Break.

●

Click Insert System Break

●

Press Shift-F to insert a frame break.

●

Choose Engrave > Format Music Frames > Frame Break.

●

Click Insert Frame Break in the Format Systems section of the Formatting panel:
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RESULT
The system break or frame break is created immediately to the left of your selected item. Your
selected item is shown at the first rhythmic position on the next system.

Splitting bars by inputting new time signatures
You can split a bar into smaller bars by changing the time signature for those bars. For example,
if you want to change one 4/4 bar into two 2/4 bars.
The new time signature you add applies until the next existing time signature or the end of the
flow, whichever comes first.
Therefore, if you want your existing time signature to continue from a certain rhythmic position
in a flow, follow the following steps:
PROCEDURE
1.

Re-input your current time signature at the point you want to return to it after the section
you want to change.

2.

Input the new time signature at the rhythmic position you want it to start.

RESULT
The new time signature continues until the position of the next time signature you input in step
1.
If your new time signature does not fit completely in the space before the next existing time
signature, the final bar is made shorter. Your next existing time signature is not overridden.
However, extra beats are added before the next existing time signature if you have Insert mode
activated.
RELATED LINKS
Splits in bars on page 219
Changing time signatures on page 625

Combining bars
You can combine two or more bars into one, longer bar by deleting the barline between them to
combine them.
PROCEDURE
1.

In Write mode, select the barline you want to delete.

2.

Delete the barline in any of the following ways:
●

Press Backspace.

●

Choose Edit > Delete.

RESULT
The bars on either side of the deleted barline combine into one bar. The notes inside may be rebeamed if appropriate.
However, deleting a barline does not automatically change the time signature. To avoid
confusion, you may want to add a new time signature to reflect the new rhythmic duration of the
bar.
RELATED LINKS
Deleting barlines on page 227
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Barlines are vertical lines that cross staves in order to show how music is divided into bars,
according to the time signature.
There are a number of different types of barline that are used in different contexts:
Normal (Single)
A standard single barline that spans the entire height of the staff. For single-line
staves, the barline extends one space above and below the staff line by default.

Double
A double barline consists of two lines, both the width of single barlines, positioned
half a space apart by default. It is often used to denote significant changes in the
music, or to mark the placement of rehearsal marks, key signature changes, and
tempo changes.

Final
A final barline consists of two lines: one of normal width, the other thick. It marks
where the music ends.

Dashed
A dashed barline has the same thickness as a normal barline, but has gaps within it
to give it a dashed appearance. It is used to subdivide bars to make complex time
signatures easier to read, and to differentiate editorial barlines from ones originally
in the manuscript.

Tick
A tick barline is a short line that spans only the top line of the staff. It is useful when
notating plainsong, in which context it denotes a breath or short gap between
phrases, or other music with an unusual metrical structure.
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Short
A short barline spans the middle of the staff, which on a five-line staff is between
the second and fourth lines. On staves with fewer than fives lines, the short barline
is scaled proportionally. It is useful when notating plainsong, in which context it
denotes a longer gap between phrases than a tick barline.

Thick
A thick barline is half a space wide by default, so it is noticeably thicker than a normal
barline. This gives it a greater visual impact.

Start repeat
A start repeat line consists of a thick barline, followed by a normal barline, followed
by either:
●

two dots: one each in the middle two spaces of a five-line staff

●

four dots: one each in all four spaces of a five-line staff

It shows the start of a repeated section. It is used alongside end repeat lines, which
show the end of a repeated section.

End repeat
An end repeat line is the mirror of a start repeat line, so it consists of either two or
four dots, followed by a normal barline, followed by a thick barline. It shows the end
of a repeated section. It is used alongside start repeat lines, which show the start of a
repeated section.

Start and end repeat
This line combines the start repeat and end repeat barlines, with either two single
barlines with a single shared thick barline in the middle, or two thick barlines and
no single barlines. On either side, there are either two or four repeat dots. It is used
when a repeated section is immediately followed by another, separate repeated
section.

Inputting and changing barlines with the keyboard
You can input barlines using the bars and barlines popover.
You can open the bars and barlines popover in the following ways:
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●

Press Shift-B.

●

Choose Write > Create Bar or Barline.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The bars and barlines popover with an example
entry for a barline

The bars and barlines button in the Notations
toolbox

The bars and barlines popover for barlines
To create different barlines, you can enter text or symbols into the bars and barlines popover.
You can open the bars and barlines popover in Write mode by pressing Shift-B, or by choosing
Write > Create Bar or Barline.
Enter:

For barline:

|

Normal (Single)

||

Double

|]

Final

: or dashed

Dashed

‘ or tick

Tick

, or short

Short

thick

Thick

|: or start

Start repeat

:| or end

End repeat

:|: or :||: or end-start or endstart

End/start repeat

You can also add and delete bars using this popover.
RELATED LINKS
The bars and barlines popover for bars on page 213
Inputting bars during step input with the keyboard on page 214
Deleting bars on page 217

Inputting barlines during step input with the keyboard
PROCEDURE
1.

In Write mode, start note input.

2.

Open the bars and barlines popover in any of the following ways:
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●

Press Shift-B

●

Choose Write > Create Bar or Barline

3.

Enter the barline you want into the popover, for example || for a double barline.

4.

Press Return to close the popover.

RESULT
The barline is added at the caret position. Surrounding music automatically adjusts to
accommodate the barline. For example, note grouping, rests, and tied notes all adjust if
necessary.
RELATED LINKS
Inputting notes on page 94

Adding barlines to existing music with the keyboard
To add a barline to existing music with the keyboard:
PROCEDURE
1.

In Write mode, select the note or rest immediately to the right of where you want a barline
to appear.

2.

Open the bars and barlines popover in any of the following ways:
●

Press Shift-B

●

Choose Write > Create Bar or Barline

3.

Enter the barline you want into the popover, for example || for a double barline.

4.

Press Return to close the popover.

RESULT
The barline is added immediately to the left of the selected note or rest. Surrounding music
automatically adjusts to accommodate the barline. For example, note grouping, rests, and tied
notes all adjust if necessary.
RELATED LINKS
The bars and barlines popover for barlines on page 224

Changing the type of an existing barline with the keyboard
To change an existing barline to a different type with the keyboard:
PROCEDURE
1.

In Write mode, select the barline you want to change, or select the note immediately to the
right of it.

2.

Open the bars and barlines popover in any of the following ways:
●

Press Shift-B

●

Choose Write > Create Bar or Barline

3.

Enter the barline to which you want to change the selected barline into the popover.

4.

Press Return to close the popover.

RELATED LINKS
The bars and barlines popover for barlines on page 224
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Inputting and changing barlines with the mouse
You can input barlines with the mouse using the Bars and Barlines panel on the right of the
window in Write mode.
You can open the Bars and Barlines panel by clicking Bars and Barlines in the Notations
toolbox:

There are three sections in the panel:
●

Insert Bars

●

Insert Bar Rest

●

Insert Barline

You can hide and show the panel by clicking its disclosure arrow, or by pressing Ctrl/Cmd-9.

Inputting barlines during step input with the mouse
To input a barline during step input with the mouse:
PROCEDURE
1.

In Write mode, start note input.

2.

Input a barline in one of the following ways:
●

Select your preferred barline in the Bars and Barlines panel on the right of the
window.

●

Choose Write > Create Bar or Barline to open the bars and barlines popover, and
enter your preferred barline type into the popover. For example, enter || to input a
double barline.

RESULT
The barline is added at the caret position. Surrounding music automatically adjusts to
accommodate the barline. For example, note grouping, rests, and tied notes all adjust if
necessary.
RELATED LINKS
The bars and barlines popover for barlines on page 224
Inputting notes on page 94

Adding barlines to existing music with the mouse
To add a barline to existing music with the mouse:
PROCEDURE
1.

In Write mode, select the note or rest immediately to the right of where you want to input
a barline.

2.

Input a barline in one of the following ways:
●

Select your preferred barline in the Bars and Barlines panel

●

Choose Write > Create Bar or Barline to open the bars and barlines popover, and
enter your preferred barline type into the popover. For example, enter || to input a
double barline
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RESULT
The barline is added immediately to the left of the selected note or rest. Surrounding music
automatically adjusts to accommodate the barline. For example, note grouping, rests, and tied
notes all adjust if necessary.
RELATED LINKS
The bars and barlines popover for barlines on page 224

Changing the type of an existing barline with the mouse
To change an existing barline to a different type with the mouse:
PROCEDURE
1.

In Write mode, select the barline you want to change, or select the note immediately to the
right of it.

2.

Input a barline in one of the following ways:
●

Select your preferred barline in the Bars and Barlines panel

●

Choose Write > Create Bar or Barline to open the bars and barlines popover, and
enter your preferred barline type into the popover. For example, enter || to input a
double barline

RELATED LINKS
The bars and barlines popover for barlines on page 224

Deleting barlines
PROCEDURE
1.

In Write mode, select the barlines you want to delete.

2.

Delete the barlines in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The barline is deleted. The two bars either side of the barline combine into one bar, containing
the same number of beats but without changing the time signature.
To avoid confusion over the number of beats in the bar, you may want to add a new time
signature to reflect the new rhythmic duration of the bar.
RELATED LINKS
Adding time signatures to existing music with the keyboard on page 620
Adding time signatures to existing music with the mouse on page 623

Barline spacing
Options for the default spacing of barlines project-wide can be found on the Spacing Gaps page
in Engraving Options.
On Spacing Gaps page in Engraving Options, you can change project-wide values for the spaces
before and after barlines, and between barlines and other staff objects, such as clefs, time
signatures, or key signatures.
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You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

RELATED LINKS
Project-wide Engraving Options for barlines on page 229

Changing the rhythmic positions of barlines
You can only move barlines to new rhythmic positions after they have been input by inputting
new barlines at the positions you want.
PROCEDURE
1.

In Write mode, input a new barline of your preferred type at the position you want.

2.

Delete the barline from the old position.

RELATED LINKS
Adding barlines to existing music with the keyboard on page 225
Adding barlines to existing music with the mouse on page 226
Deleting barlines on page 227

Moving barlines graphically
You can adjust the spacing between barlines and neighboring notes, time signatures, key
signatures, or rests.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the panel on the left of the window.

2.

Select one of the handles at the rhythmic position of the barline, such as the one
highlighted in this example:

3.

Move the handle to the right or to the left using the following key commands:
●

Press Alt-Right Arrow.

●

Press Alt-Left Arrow.

NOTE
Note spacing handles cannot be moved using the mouse.

Barlines across staff groups
In order to make it easier to find a particular instrument within a score, barlines can extend
across instrumental and staff groups.

Using default staff groups
In the example on the left, the barline only appears on individual staves, which makes it much
harder to locate individual lines at a glance. In the example on the right, the barline continues
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across the instrumental groups in the score, which shows the instrument families as blocks and
makes finding an instrument much easier.

Barlines on individual staves

Barlines across instrumental groups

Barlines extend across staff groups when they are joined by a bracket. Which staves are included
in a bracket depends on the instrumentation and context, but usually staves for instruments
from the same family, such as woodwind or strings, are bracketed together.
By default, Dorico brackets staves according to their instrument family. This means that in a
project with only a few instruments the barline does not extend across the whole ensemble,
because all the instruments are from different families.
You can change the bracketing style according to the ensemble type in your project on the
Brackets and Braces page in Engrave > Engraving Options.

Making custom staff groups
You can also manually arrange your players into groups, which have their own bracket and
barline groupings.
If one or more players included in your group were previously in another group, any remaining
instruments in their previous group remain grouped.
You can select a single player and add it to its own group in order to have it appear separately,
which could be useful for showing a soloist separately from the remainder of the ensemble, for
example in a concerto.
RELATED LINKS
Changing bracket grouping according to ensemble type on page 265
Adding players to groups on page 79

Project-wide Engraving Options for barlines
Options for how barlines appear project-wide can be found on the Barlines page in Engraving
Options.
The options on this page allow you to change the appearance and thickness of barlines, and
which barlines are used in different contexts.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
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You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Barlines in the page list on the left of the dialog.
RELATED LINKS
Barline spacing on page 227

Changing the default barline at the ends of flows
You can choose which type of barline is placed automatically at the end of each flow.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Barlines from the Category menu.

3.

Select the flows in which you want to change the default barline in the list on the left of the
dialog in any of the following ways:
●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
4.

Select one of the following:
●

Final

●

Double

●

Normal

●

Dashed

●

Thick

●

No barline
TIP
The final barline can always be overridden individually by changing it to a different
type, although it cannot be deleted.

RELATED LINKS
Changing the type of an existing barline with the keyboard on page 225
Changing the type of an existing barline with the mouse on page 227
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Bar numbers provide a crucial reference point for music that has multiple players, and make the
chronological sequence of the music clear. They tell you where you are in the piece, and allow
players to co-ordinate themselves easily in rehearsals and concerts.
Bar numbers can also be useful when preparing parts and scores, as you can use bar numbers
and rehearsal marks to help you quickly compare a part to the score and check it is correct.
In Dorico, bar numbers appear automatically, following the most common practice of showing a
bar number at the start of each system in scores and parts by default.
However, sometimes it is useful to show bar numbers every bar, which is frequently done for
film music scores. You can also show bar numbers at a regular interval, such as every five bars,
however this can be misleading as it can give the impression that those bars are significant,
particularly if your bar number style includes an enclosure line.

Project-wide changes to the appearance of bar numbers
Different aspects of the appearance, frequency, and position of bar numbers can be changed
in three places in Dorico. Changes made in any of these places affect the appearance of bar
numbers project-wide.
The three places you can change the appearance of bar numbers are:
●

On the Bar Numbers page in Setup > Layout Options

●

On the Bar Numbers page in Engrave > Engraving Options

●

In the Engrave > Font Styles dialog

Layout Options
On the Bar Numbers page in Layout Options you can change the following aspects of bar
number appearance:
●

Bar number frequency

●

Placement above or below the staff

●

Distance from the staff and from other objects

●

Horizontal position: Centered on barline or Centered on bar

●

Enclosure type: None, Rectangular, or Circular

●

Whether bar numbers are hidden or shown at rehearsal marks.

●

Whether bar numbers are shown below the bottom staff.

You can change options for bar numbers for each instrument layout and full score layouts
independently of each other within the dialog.
You can open Layout Options in the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.
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Engraving Options
On the Bar Numbers page in Engraving Options you can change the case of letters in
subordinate bar numbers and the thickness and padding values for bar number enclosures.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Font Styles dialog
In the Engrave > Font Styles dialog, select Bar Number Font from the menu to change different
aspects of the font.
This is where you can change the size of bar numbers by increasing the font size.
NOTE
Changes made to font styles apply to the entire project, including parts.
The different aspects of the bar number font style that you can change are:
Font family
Sets the overall font style.
Size
Sets the size of bar numbers for all layouts in the project, meaning the size is the
same in the score and parts. Bar number size can be:
●

Absolute: always the set size, regardless of the staff size.

●

Staff-relative: the size of bar numbers is proportional to the staff size, which
means bar numbers appear smaller than the set value on smaller staves, and
larger than the set value on larger staves.

Style
This sets the bar number font appearance. The bar number font can be:
●

Regular

●

Italic (default)

●

Bold

●

Bold Italic

Underlined
The bar number font appears underlined if the box beside the Underlined activation
switch is checked.

Changing the bar number frequency
You can change how frequently bar numbers appear in each layout independently of other
layouts. For example, you can have bar numbers appear with different frequencies in the score
compared to individual parts.
PROCEDURE
1.

In Setup mode, choose Setup > Layout Options.

2.

Select Bar Numbers from the Category menu.

3.

Select the layouts in which you want to change the bar number frequency in the Layouts
list on the left of the dialog in the following ways:
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●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

For the Show bar numbers option, select one of the following:
●

Every system

●

Every n bars

●

Every bar

●

None

Selecting Every n bars activates the Interval value field below. You can change the value
for Interval in the following ways to change how frequently bar numbers are shown:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

For example, setting an interval value of ten means that bar numbers are shown every
tenth bar.

RELATED LINKS
Project-wide changes to the appearance of bar numbers on page 231

Changing the bar number font style
To change the font style used for bar numbers:
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Font Styles dialog.

2.

Select Bar Number Font from the Font style menu.

3.

Activate the switches beside the following options to change the corresponding aspects of
the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The bar number font style is changed project-wide.
RELATED LINKS
Project-wide changes to the appearance of bar numbers on page 231
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Changing bar number enclosure type
If you want bar numbers to be clearly distinguished, you may want them to appear enclosed
in a square or circular box. You can change the bar number enclosure type in each layout
independently of other layouts.
For example, you can have bar numbers appear with different enclosures in the score compared
to individual parts.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Bar Numbers from the Category menu.

3.

Select the layouts in which you want to change the bar number enclosure type in the
Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

5.

Choose one of the following options for Enclosure type:
●

None

●

Rectangular

●

Circular

Click Apply, then Close.

RESULT
Bar numbers in the selected layout are shown within your selected enclosure. The size of the
enclosure is relative to the font size of the bar numbers, but the size and shape of the enclosure
are also determined by your padding values.
EXAMPLE

Bar number with no enclosure

Bar number with rectangular
enclosure
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Changing bar number enclosure size and padding values
In the Enclosures section of the Bar Numbers page in Engrave > Engraving Options, there are
a number of options to control the shape and size of bar number enclosures.

Rectangular bar number enclosure
The default settings for a rectangular enclosure create an enclosure like this one. The minimum
height and minimum width are both 2 spaces, horizontal padding is half a space, and minimum
bottom and minimum top padding are both 1/8 of a space.

Adjusting the minimum values can help make bar number enclosures more consistent projectwide, as the default values can allow their size to vary significantly, depending on the size
and shape of the bar number inside. This might make a narrow bar number less obvious to a
conductor.
Increasing the Minimum width value to reduce the difference in size creates a more consistent
visual effect, as demonstrated in this example:

Bar numbers with rectangular enclosures, default
minimum width

Bar numbers with rectangular enclosures, minimum
width increased to 5

Minimum width
Sets a minimum value for how wide the enclosure appears, such as in this example
where the value has been increased from 2 to 6 spaces:

Minimum height
Sets a minimum value for how high the enclosure appears, such as in this example
where the value has been increased from 2 to 6 spaces:

Minimum horizontal padding
Sets a minimum value for the distance between the two sides of the enclosure and
the bar number within, such as in this example where the value has been increased
from 1/2 to 4 spaces:
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Minimum bottom padding
Sets a minimum value for the distance between the bottom line of the enclosure and
the bar number within, such as in this example where the value has been increased
from 1/8 to 2 spaces:

Minimum top padding
Sets a minimum value for the distance between the top line of the enclosure and the
bar number within, such as in this example where the value has been increased from
1/8 to 2 spaces:

Circular bar number enclosure
The default settings for a circular enclosure create an enclosure like this one. The minimum
diameter is 2 spaces, and the minimum padding is 1/6 of a space.

Minimum diameter
Sets a minimum value for the diameter of the enclosure, such as in this example,
where the value has been increased from 2 to 8 spaces:

Minimum padding
Sets a minimum value for the distance between the enclosure line and the bar
number within, such as in this example where the value has been increased from 1/6
to 1 space:
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All enclosures
Enclosure line thickness
This allows you to control how thick the enclosure line appears. The default is 1/8 of a
space. These examples demonstrate a thickness of 1/2 a space.

Changes to the positions of bar numbers
Changing the horizontal position of bar numbers
You can change the horizontal position of bar numbers in each layout independently of other
layouts. For example, you can have different horizontal bar number positions in the score
compared to individual parts.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Bar Numbers from the Category menu.

3.

Select the layouts in which you want to change from the list on the left of the dialog.

4.

Select the layouts in which you want to change the horizontal bar number position in the
Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
5.

For the Horizontal position option, select one of the following:
●

Centered on barline

●

Centered on bar

RESULT
Centered on barline shows bar numbers above barlines, at the top left of the bar.
Centered on bar shows bar numbers above the staff, in the middle of the bar.
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Changing the position of bar numbers relative to the staff
You can change the minimum value for how far away from the staff bar numbers appear in each
layout independently of other layouts. For example, you can position bar numbers differently in
the score compared to individual parts.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Bar Numbers from the Category menu.

3.

Select the layouts in which you want to change the minimum distance of bar numbers
relative to the staff in the Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

Change the value for Minimum distance from staff in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

The default value is 2 spaces.
RESULT
If you increase the value, bar numbers are positioned further away from other objects, either
above or below depending on your setting for Placement relative to staff. If you decrease the
value, bar numbers are positioned closer to the other objects.
However, this is the minimum distance away from the staff, so bar numbers may be positioned
further away than this to avoid collisions.
RELATED LINKS
Changing the placement of bar numbers relative to the staff on page 239

Changing the position of bar numbers relative to other objects
To change the minimum value for how far away from other objects bar numbers appear:
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Bar Numbers from the Category menu.

3.

Select the layouts for which you want to change the minimum distance of bar numbers
relative to other objects from the list on the left of the dialog. For example, you can have
bar numbers appear with different frequencies in the score compared to individual parts.
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4.

Change the value for Minimum distance from other objects in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

The default value is 3/4 of a space.
RESULT
If you increase the value, bar numbers are positioned further away from other objects, either
above or below depending on your setting for Placement relative to staff.
If you decrease the value, bar numbers are positioned closer to other objects.

Changing the placement of bar numbers relative to the staff
You can change the side of the staff on which bar numbers appear for each layout independently
of other layouts. For example, you can have bar numbers appear with different frequencies in
the score compared to individual parts.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Bar Numbers from the Category menu.

3.

Select the layouts in which you want to change the bar number placement in the Layouts
list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

For the Placement relative to staff option, select one of the following:
●

Above

●

Below

Moving bar numbers graphically
You can move individual bar numbers graphically without changing the rhythmic positions to
which they apply.
PROCEDURE
1.

In Engrave mode, select the bar numbers you want to move.

2.

Move the bar numbers in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
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NOTE
If you want to move bar numbers by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The selected bar numbers are moved graphically.
RELATED LINKS
Moving bar numbers graphically using the Properties panel on page 240
Adding bar number changes on page 240

Moving bar numbers graphically using the Properties panel
You can move bar numbers graphically without changing the rhythmic positions to which they
apply using the Properties panel.
PROCEDURE
1.

In Engrave mode, select the bar numbers you want to move graphically.

2.

Activate the following properties, individually or together, in the Time Signatures group of
the Properties panel:

3.

4.

●

Bar number X

●

Bar number Y

Change the values in the value fields in the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move bar numbers in the following ways:
●

Bar number X moves bar numbers horizontally: increasing the value moves them to
the right, decreasing the value moves them to the left.

●

Bar number Y moves bar numbers vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.

Bar numbers at multiple positions in systems
Bar numbers can currently only be shown at one position in the score.
Being able to show bar numbers at multiple positions, like tempo changes, is planned for future
versions.

Bar number changes
Adding bar number changes
To add a bar number change to the primary bar number sequence manually:
PROCEDURE
1.

In Write mode, select a note in the bar from which you want to change the bar numbers.
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NOTE
The dialog does not open if you select existing bar numbers or rests.
2.

Choose Edit > Bar Numbers > Add Bar Number Change, or right-click and choose Bar
Numbers > Add Bar Number Change from the context menu.

3.

In the dialog that opens, click Primary. This activates the Primary value field.

4.

Change the value in any of the following ways:

5.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Click OK or press Return to close the dialog.

RESULT
The primary bar number sequence changes, starting from the bar in which you selected a note.
The primary bar number sequence continues from the changed bar number until the next bar
number change, or until the end of the flow.

Deleting bar number changes
PROCEDURE
1.

Select the bar number changes you want to delete.

2.

Delete the bar number changes in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The bar number changes are deleted, and the original bar number sequence is restored. The
original bar number sequence continues until the next bar number change, or until the end of
the flow.

Subordinate bar numbers
Subordinate bar numbers are useful for organizing repeat endings, and for situations when the
music is being altered, but the original bar numbers cannot be changed.
For example, subordinate bar numbers can be used to show where music has been added if a
previous shorter version has already been rehearsed. In this situation, players have likely started
to associate certain parts of the piece with particular bar numbers, so if four bars need to be
added after bar 10, they would be numbered 10a to 10d, after which the bar number continues
from 11 exactly as it did before the new bars were added.
They might also be useful if you want different bar numbers for a repeat ending.
Subordinate bar numbers can be presented as either upper case letters or lower case letters, as
shown in these examples.

Lower case subordinate bar number.

Upper case subordinate bar number.
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RELATED LINKS
Changing the appearance of subordinate bar numbers on page 243

Adding subordinate bar numbers
To create a subordinate bar number sequence:
PROCEDURE
1.

Select a note in the bar where you want the subordinate bar numbers to start.
NOTE
The dialog does not open if you select existing bar numbers or rests.

2.

Open the Insert Bar Number Change dialog in any of the following ways:
●

Choose Edit > Bar Numbers > Add Bar Number Change.

●

Right-click and choose Bar Numbers > Add Bar Number Change from the context
menu.

3.

Click Subordinate. This activates the Subordinate value field.

4.

Change the value in the value field in any of the following ways:
●

Enter a number into the value field.

●

Click the arrows beside the value field.

The corresponding alphabetical letter is shown to the right of the value field. For example,
entering 1 into the value field is shown as a, 2 appears as b, and so on.
5.

Close the dialog in any of the following ways:
●

Press Return

●

Click OK

RESULT
The subordinate bar number sequence starts from the bar in which you selected a note. It has
the same bar number as the bar immediately before, but with subordinate alphabetical letters.
For example, if you start a subordinate bar number sequence from what was originally bar 5, the
sequence starts from 4a and continues until the next specified bar number change, or until the
end of the flow.

Returning to the primary bar number sequence
To return to the primary bar number sequence after a section of subordinate bar numbers:
PROCEDURE
1.

Select a note in the bar from which you want the primary bar number sequence to
continue.

2.

Choose Edit > Bar Numbers > Add Bar Number Change, or right-click and choose Bar
Numbers > Add Bar Number Change from the context menu.

3.

In the dialog that opens, click Continue primary.
Text appears below the value fields for Primary and Subordinate. For example, Primary
sequence will continue from bar 5.

4.

Save your changes and close the dialog in any of the following ways:
●

Press Return.

●

Click OK.
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RESULT
The primary bar number sequence resumes from the bar in which you selected a note.
TIP
Subordinate bar number changes do not have to be added in chronological order. You can enter
a return to the primary bar number sequence first, before adding the subordinate bar number
sequence.

Changing the appearance of subordinate bar numbers
Subordinate bar numbers can be presented as either lower case or upper case letters.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Bar Numbers in the page list.

3.

In the Sequence section, select how you want subordinate numbers to appear:
●

Lower case (default)

●

Upper case

Bar numbers in parts
Bar numbers can appear differently for some aspects in parts compared to the score.

Bar number frequency
You can choose how frequently bar numbers appear in each part independently of the score, and
independently of other parts.
To change the bar number frequency in parts, follow the procedure described in Changing the
bar number frequency. For step 3, select part layouts instead of the full score from the list on
the left of the dialog.

Minimum distance from staff and other objects
You can also set the minimum distance of bar numbers from the staff, and the minimum
distance of bar numbers from other objects, in each part independently of the score, and
independently of other parts.
This can be particularly useful if one part has a lot of notes far above or below the staff, and you
want to have bar numbers positioned further away for clarity.
To change the bar number position in parts, follow the procedure described in Changing bar
number position relative to the staff and Changing bar number position relative to other
objects. For step 3, select part layouts instead of the full score from the list on the left of the
dialog.

Horizontal position of bar numbers
You can set the horizontal position of bar numbers in each part independently of the score, and
independently of other parts.
This can be useful if you want bar numbers to be shown on every bar and centered on the bar in
the score, but not in the parts, as bar numbers are typically shown centered on the barline at the
start of each system.
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To change the horizontal position of bar numbers in parts, follow the procedure described in
Changing the horizontal position of bar numbers. For step 3, select part layouts instead of the
full score from the list on the left of the dialog.

Enclosure
You can set the enclosure type in each part independently of the score, and independently of
other parts.
However, changing the value for Enclosure line thickness changes the thickness of bar number
enclosures in all layouts in the project. Changing any padding values for rectangular enclosures
affects all layouts with rectangular enclosures, and changing any padding values for circular
enclosures affects all layouts with circular enclosures.
To change the enclosure type of bar numbers in parts, follow the procedure described in
Changing bar number enclosure type. For step 3, select part layouts instead of the full score
from the list on the left of the dialog.

Size
The size of bar numbers currently cannot be changed in the parts independently of the score.
The same font size applies to all layouts in the project.
RELATED LINKS
Changing the bar number frequency on page 232
Changing the position of bar numbers relative to the staff on page 238
Changing the position of bar numbers relative to other objects on page 238
Changing bar number enclosure type on page 234
Changing bar number enclosure size and padding values on page 235

Bar numbers in repeat endings
By default in Dorico, bar numbers continue through a repeat structure.
For example, in a repeat section ending at the end of bar 10, the bar number at the start of the
second time section is bar 11.

Changing bar numbers in repeat endings
You can change the bar numbers so that the second time section reflects the number of bars
played up to that point, rather than reflecting the number of bars on the page.
For example, if the first ten bars are repeated, then the bar number at the start of the second
time section is bar 21 instead of bar 11.
To do this, you can add in a bar number change at the start of the second time section. This can
be done in the same way as adding bar number changes.
RESULT
The bar number is changed from the start of the second time section until the next bar number
change, or until the end of the flow.
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EXAMPLE

Default bar numbers in a repeat ending.

Bar numbers changed to reflect total number of bars
played.

RELATED LINKS
Adding bar number changes on page 240

Pick-up bars
Pick-up bars, or “upbeat bars”, do not contribute to the bar number count. Bar numbers are
counted from the first full bar in the flow.
You can input pick-up bars with the keyboard and with the mouse.
As pick-up bars are a specified number of beats that lead into time signatures, and so are not
bars in their own right, how to input pick-up bars is included in the Time signatures chapter.
RELATED LINKS
Inputting pick-up bars with the keyboard on page 621
Inputting pick-up bars with the mouse on page 624
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A beam is a line that connects notes with tails together to show rhythmic groupings, which varies
according to the metrical structure of the current time signature.
This way of grouping notes helps performers calculate quickly exactly how to play their given
rhythm and helps them follow both their part and, if applicable, the conductor.
Over time, there have been many different accepted standards for how to present beams, so
Dorico offers a number of customizing options. These can be found on the Beams page in
Engraving Options. You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can find options that control how beams are grouped on the Beam Grouping page in
Notation Options. You can open Notation Options in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

Creating beams
If appropriate for the current meter and position in the bar, a beam is automatically formed
when there are two or more adjacent notes or chords that are an eighth note or shorter in
duration.
PROCEDURE
1.

In Write mode, start note input.

2.

Select a note duration that forms beams, such as the following:
●

Press 5 for eighth notes.

●

Press 4 for 16th notes.

●

Press 3 for 32nd notes.

You can also find these durations in the Notes panel.
3.

Input notes in any of the following ways:
●

Press the relevant keys for the pitches you want, such as A.

●

Play the pitches you want on a MIDI device.

●

Click in the staff at the positions of the pitches you want.

RESULT
Adjacent notes of these values automatically beam together, according to the time signature.
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RELATED LINKS
Inputting notes on page 94

Changing beam groups
You can control how notes are beamed in several different ways in Dorico.
●

You can set beaming defaults in each flow in your project separately in Notation Options.

●

You can set beam groups by controlling subdivisions of time signatures.

●

You can change beam groups individually using the Properties panel.

●

You can change beam groups individually by choosing functions from the Edit > Beaming
menu.

RELATED LINKS
Changing beam grouping defaults on page 247
Changing beamed groups individually on page 248
Setting beaming within time signatures on page 247

Changing beam grouping defaults
You can change the default beam grouping rules project-wide on the Beam Grouping page in
Notation Options.
Dorico has sophisticated underlying rules for producing beam groupings that follow the
accepted conventions of music theory, including crossing the half-bar in time signatures like 4/4,
beaming all eighth notes (quavers) together in 3/4, beam groups that include tuplets, and many
other situations.
There are alternative conventions for some of these rules, so you can change your default beam
grouping rules for each flow in your project independently on the Beam Grouping page in
Notation Options.
You can open Notation Options in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

Setting beaming within time signatures
Default beaming groups are determined by the time signature, which you can customize by
specifying the subdivision of beats within bars.
Dorico has default beaming settings for most time signatures, based on general conventions
and your chosen settings. For example, phrases are beamed in quarter notes when in 3/4, but in
dotted quarter notes when in 6/8.
For situations where you want to control the beaming pattern in more detail, you can input a
custom time signature with an explicit rhythmic subdivision. Dorico then automatically beams
phrases according to this subdivision. For example, entering [7]/8 into the time signatures
popover means all seven eighth notes are beamed together, whereas entering [2+2+3]/8
subdivides the seven eighth notes into two, then two, then three.
RELATED LINKS
Note and rest grouping on page 262
Creating custom beam groupings for meters on page 262
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Changing beamed groups individually
You can change which notes are beamed together individually, independently of your default
beam grouping settings for the current flow.
PROCEDURE
1.

Select the notes you want to beam together. You can do this in Write mode and Engrave
mode.

2.

Beam the selected notes together in any of the following ways:
●

Choose Edit > Beaming > Beam Together.

●

Right-click and choose Beaming > Beam Together from the context menu.

RELATED LINKS
Creating fanned beams on page 260

Showing stemlets in beam groups individually
You can show stemlets on rests in beam groups individually, independently of your default
setting for showing stemlets in the current flow.
PROCEDURE
1.

Select all notes in the beam in which you to show stemlets on rests.
For example, to show a stemlet on a rest between two notes, select both notes. To show a
stemlet on a rest at the end of a beamed phrase, select all notes in the beam and the rest.

2.

Show stemlets in any of the following ways:
●

Choose Edit > Beaming > Stemlets > Force Stemlet Beam.

●

Right-click and choose Beaming > Stemlets > Force Stemlet Beam from the
context menu.

RESULT
Stemlets are shown on rests according to your selection.
NOTE
If you later reset the beaming of the selected group, stemlets revert to your default setting for
the flow.
You can choose to show stemlets on rests in all beamed groups in each flow on the Beam
Grouping page in Write > Notation Options.
EXAMPLE

Stemlet with only the rest selected

Stemlet with notes either side
selected
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Removing stemlets from beam groups individually
You can remove stemlets from rests in beam groups individually, independently of your default
setting for showing stemlets in the current flow.
PROCEDURE
1.

Select a note in the beams from which you to remove stemlets on rests.

2.

Remove all stemlets from the selected beams in any of the following ways:
●

Choose Edit > Beaming > Stemlets > Suppress Stemlet Beam.

●

Right-click and choose Beaming > Stemlets > Suppress Stemlet Beam from the
context menu.

RESULT
Stemlets are removed from all rests in the selected beams.
NOTE
Removing stemlets from beams does not reset the selected beams to your default beam
grouping for the flow.
You can choose not to show stemlets on rests in all beam groups in each flow on the Beam
Grouping page in Write > Notation Options.
EXAMPLE

Beam group showing stemlets

Beam group with suppressed stemlets

RELATED LINKS
Resetting beam grouping on page 251

Splitting beam groups
You can split beams into two beam groups at specific rhythmic positions. You can also split
secondary beams within beamed groups.
PROCEDURE
1.
2.

Select the note to the right of where you want the split to occur.
●

Choose Edit > Beaming > Split Beam.

●

Right-click and choose Beaming > Split Beam from the context menu.

●

Choose Edit > Beaming > Split Secondary Beam.

●

Right-click and choose Beaming > Slit Secondary Beam from the context menu.

RESULT
The beam or secondary beam divides to the left of the selected note, but the notes either side of
the split remain grouped if there are at least two beam notes on each side that can be in a beam
group.
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NOTE
To unbeam the entire selection and give all notes in the group individual tails, you can make all
notes unbeamed.

RELATED LINKS
Unbeaming notes on page 250

Changing the direction of partial beams
Dorico automatically inputs a partial beam if one is required, however, you may wish to change
which side of a stem the partial beam appears.
PROCEDURE
1.

Select a note with a partial beam.
NOTE
This property cannot be activated on a note without a partial beam.

2.

Activate the Partial beam direction property in the Beaming group of the Properties
panel.

3.

Choose one of the following options:
●

Left

●

Right

RESULT
The partial beam appears on the corresponding side of the stem.
EXAMPLE

Partial beam direction Left.

Partial beam direction Right.

Unbeaming notes
You can separate all notes in a beamed group so that each note shows its own tail.
This can be useful when setting syllabic text with a fast rhythm.
PROCEDURE
1.

Select the notes you want to make unbeamed. You can do this in Write mode and Engrave
mode.

2.

Remove beaming from the selected notes in any of the following ways:
●

Choose Edit > Beaming > Make Unbeamed.

●

Right-click and choose Beaming > Make Unbeamed from the context menu.
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Resetting beam grouping
You can remove all changes made to the beam grouping of beams, notes, and chords.
PROCEDURE
1.

Select the notes whose beaming you want to reset. You can do this in Write mode and
Engrave mode.

2.

Reset the beaming in any of the following ways:
●

Choose Edit > Beaming > Reset Beaming.

●

Right-click and choose Beaming > Reset Beaming from the context menu.

RESULT
Beam grouping is reset to your default settings in Notation Options for the current flow and
time signature.

Beaming notes together
You can beam notes together manually that are not automatically beamed together.
To force notes that are not automatically grouped into a single beam:
PROCEDURE
1.

Select the notes you want to beam together.

2.

Choose Edit > Beaming > Beam Together.

RESULT
The selected notes are beamed together.
If there are notes either side of the new beam group that were previously beamed to part or
all of your selection, they either beam together as separate beams, or appear unbeamed. This
depends on how many notes are left either side in the bar, and the beam grouping settings for
the flow.

Beaming notes over barlines, system breaks, and frame breaks
Default settings keep beaming within bars, but you can force individual beams to cross barlines
as well as system breaks and frame breaks.
Beams by default stay within their bar, so to have a beam cross a barline you must force the
phrase to beam together.
This method works across system and frame breaks as well as barlines.
PROCEDURE
1.

Select all the notes you want to include in the beam. You can do this in Write mode and
Engrave mode.

2.

Beam the selected notes together in any of the following ways:
●

Choose Edit > Beaming > Beam Together.

●

Right-click and choose Beaming > Beam Together from the context menu.
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RESULT
The selected notes are beamed together, even if they cross barlines, system breaks, or frame
breaks.
NOTE
Even if part of the beamed group previously had a centered beam, the new beam is not centered.

RELATED LINKS
Beaming notes together on page 251

Beam placement relative to the staff
You can change the placement relative to the staff of the stems within beams, so that beams
appear on the other side of the staff to their default placement.
The default placement of beams relative to the staff is determined by the staff positions of the
notes within the beamed group.
This means that the note furthest from the middle line of the staff determines the placement of
the beam, although there are exceptions to this rule and other considerations that can influence
the placement of beams relative to the staff.
Changing the placement of beams relative to the staff involves changing the direction of the
stems in the beam, therefore Dorico categorizes changing the placement of beams relative to the
staff as a stem change.

Changing the placement of beams relative to the staff
To change which side of the staff a beam appears, you force the stem direction to change.
PROCEDURE
1.

Select one or more notes in the beamed phrases whose placement relative to the staff you
want to change. You can do this in Write mode or Engrave mode.

2.

Force the stem direction of notes in the selected beams in any of the following ways:
●

Choose Edit > Stem > Force Stem Up.

●

Right-click and choose Stem > Force Stem Up from the context menu.

●

Choose Edit > Stem > Force Stem Down.

●

Right-click and choose Stem > Force Stem Down from the context menu.

RESULT
The beam appears on the side of the staff that corresponds to its forced stem direction.

Removing beam placement changes
To undo changes to the placement of beams relative to the staff, you remove the stem direction
change. This reverts selected beams to their default placement.
PROCEDURE
1.

Select one or more notes in the beamed phrases whose placement change relative to the
staff you want to remove. You can do this in Write mode or Engrave mode.

2.

Remove beam placement changes in any of the following ways:
●

Choose Edit > Stem > Remove Forced Stem.
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●

Right-click and choose Stem > Remove Forced Stem from the context menu.

RESULT
The selected beams revert to their default placement relative to the staff.

Beam slants
The slant of a beam controls how steeply the beam deviates from horizontal, according to the
pitches of the notes within the beamed group.
●

When the last note of the phrase is higher than the first, the beam slants upwards.

●

When the last note is lower than the first, the beam slants downwards.

If the group makes a concave shape, where inner notes are closer to the beam than the outer
ones at either end of the beam, then the beaming is horizontal by default.
Beams are also horizontal if all the pitches are the same, or for certain patterns of repeated
pitches.

Changing the default settings for beam slants
You can change the default settings for all beam slants project-wide on the Beams and Notes
pages in Engraving Options.
When a beam is drawn inside the staff, each end of the beam (or, more accurately, the end of the
stem of the note at either end of the beam) must be snapped to a staff line position. A beam line
may sit on a staff line, be centered on a staff line, or hang from a staff line; these three positions
are described as “sit”, “straddle”, and “hang” respectively in Ted Ross's book “Teach Yourself the
Art and Practice of Music Engraving”, which is perhaps the authoritative book on the subject.
The amount by which a beam slants is typically determined by the interval between the first and
last note in the beamed group (provided the pattern of notes in the beam does not dictate a
horizontal beam instead), with smaller intervals requiring a shallower slant, and larger intervals a
steeper one.
However, the desired amount of slant is not the only factor that must be considered: the
innermost beam line should not come too close to the innermost notehead, and the beam itself
should if possible be positioned relative to the staff lines such that it does not form a wedge
(a tiny triangle formed by the horizontal staff line, the vertical stem and the angled line of the
slanted beam), which can cause problems in reproduction (in lithographic printing, such wedges
would be liable to fill in with ink, and even when using digital printing techniques wedges can still
look poor).
Determination of the amount of slant for a beam is therefore a balancing act that must weigh up
several factors: the desired amount of slant, valid snapping positions for each end of the beam,
ensuring a minimum distance between the note closest to the beam and the innermost beam
line, and avoiding wedges where possible.
You can specify settings for how beams appear in two places:
●

You can specify the minimum stem length for notes of different durations on the Notes
page in Engraving Options.

●

You can set ideal beam slants on the Beams page in Engraving Options.

PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click one of the following in the page list:
●

Beams
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●

Notes

3.

Change the options that apply to beam slants that apply to your project.

4.

Click Apply, then Close.

Changing beam slants individually
You can change individual beam slants in Engrave mode with the keyboard and mouse.
PROCEDURE
1.

In Engrave mode, select the square handle on one of the beam corners of the beams
whose slants you want to change.

2.

Change the slants by moving the handles in any of the following ways:

3.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.

●

Click and drag them upwards and downwards to the positions you want.

Optional: repeat steps 1 and 2 to change the positions of the other ends of the selected
beams.

RESULT
The slants of the selected beams are changed.
RELATED LINKS
Changing beam slants individually using the Properties panel on page 254

Changing beam slants individually using the Properties panel
You can change the slants, or angles, of beams using the Properties panel.
PROCEDURE
1.

Select notes in the beams whose slant you want to adjust. You can do this in Write mode
and Engrave mode.

2.

Activate the Beam direction property in the Beaming group of the Properties panel.

3.

Select one of the following options from the menu:
●

Flat

●

Up

●

Down

RESULT
The slant of the beams of the selected notes is changed.
NOTE
You can revert the slant of the selected beams at any time by deactivating the Beam direction
property in the Beaming group of the Properties panel.

RELATED LINKS
Changing beam slants individually on page 254
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Centered beaming
A centered beam is positioned between high and low notes within the same beamed group,
typically drawn in the middle of the staff.
Centered beams are sometimes known as “kneed” or “elbowed” beams. This example
demonstrates the sometimes angular shape that inspired these names:

These examples show the difference between a normal beam and a centered beam when a
beamed phrase spans a large pitch range.

A phrase with high and low notes with default
beaming.

The same phrase with high and low notes, but with a
centered beam.

RELATED LINKS
Creating centered beams on page 255
Changing the placement of beams relative to the staff on page 252

Creating centered beams
You can make beams appear in the middle of staves, with high notes above the beam and lower
notes below the beam.
As this action needs to change the direction of some stems in order to appear correctly, it is
located in the Stem submenu rather than Beaming in the Edit menu.
PROCEDURE
1.

Make sure all the notes you want to include in centered beams are beamed together.

2.

Create centered beams containing the selected notes in any of the following ways:
●

Choose Edit > Stem > Force Centered Beam.

●

Right-click and choose Stem > Force Centered Beam from the context menu.

RESULT
The beams are placed between the selected notes.
NOTE
Dorico automatically angles the beam based on the shape of the phrase, but you can change the
angles or slants of beams manually in Engrave mode.
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RELATED LINKS
Beaming notes together on page 251
Changing beam slants individually on page 254
Changing beam slants individually using the Properties panel on page 254

Removing centered beams
You can remove centered beams and revert beams to their default placements either above or
below the phrase.
PROCEDURE
1.

Select one or more notes within the centered beams that you want to revert to their
default placement. You can do this in Write mode and Engrave mode.

2.

Remove the centered beams in any of the following ways:
●

Choose Edit > Stem > Remove Centered Beam.

●

Right-click and choose Stem > Remove Centered Beam from the context menu.

Creating cross-staff beams
Cross-staff beams work in a similar way to normal beams, but allow a phrase covering a wide
pitch range to be shown on two staves.
PROCEDURE
1.

Input your whole chord on one staff.

2.

Select the notes that you want to move to another staff.

3.

Cross notes to other staves in the following ways:
●

Press N to cross notes to the staff above.

●

Press M to cross notes to the staff below.

●

Choose Edit > Cross Staff > Cross to Staff Above.

●

Choose Edit > Cross Staff > Cross to Staff Below.

RELATED LINKS
Crossing notes to other staves on page 462

Optimized spacing for cross-staff beams
Normally, we perceive the evenness of rhythmic spacing according to the distance between
noteheads. However, for cross-staff beams we perceive the distance between stems, rather than
the noteheads, to be making the music look even.
You can make stems evenly spaced, rather than noteheads, by activating the Use optimal
spacing for beams between staves option for layouts in your project that contain cross-staff
beams on the Note Spacing page in Layout Options.
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Default spacing: the distance between noteheads is
optimized.

Optimized spacing for cross-staff beaming: the
distance between stems is optimized

You can open Layout Options in the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

●

Click Layout Options in the Layouts panel in Setup mode:

Cross-staff beam placement in multiple staves
When instruments have three or more staves, there are multiple options for where cross-staff
beams can go. For example, the beam can be placed between the top and the middle staves, and
also between the middle and bottom staves.
If a beam only crosses two staves, the cross-staff beam goes between those two staves, as shown
in these examples:

A cross-staff beam across the upper two staves on
an instrument with three staves.

A cross-staff beam across the lower two staves on an
instrument with three staves.

If a beam crosses all three staves, the beam appears either between the upper two staves or the
lower two staves, depending on the notes within the beam.
These examples show how the beam of the same phrase moves when notes are crossed to
different staves:
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The beam is placed between the top two staves as
that shows the ledger lines clearly.

The beam is placed between the lower two staves, as
ledger lines for the third note are no longer needed.

Here are some further examples demonstrating how cross-staff beams are presented in Dorico:

Cross-staff beams: descending phrases starting with most notes on the top staff

Cross-staff beams: ascending phrases starting with most notes on the lowest staff

Beam corners
Beam corners can occur when a change of stem direction within a beam is combined with a
break in the secondary beam group. This can be at the end of a subdivision or at a change in
rhythmic speed.
These examples show that beam corners do not follow accepted rules regarding the order and
rhythmic meaning of secondary beams, and can be confusing for the reader.

Dorico avoids beam corners by analyzing the pitches and stems within a phrase, and
implementing stem directions that avoid a beam corner.
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Secondary beams
Secondary beams are the lines that are added between the primary beam and the notehead, as
the rhythmic division gets smaller.
The primary beam is the outermost beam line that joins all of the notes in the beamed group.
Depending on the durations of the notes in the beamed group, the primary beam may in fact be
two or more lines (that is, for notes of a 16th or shorter in duration).
Secondary beams are additional beam lines that join only some of the notes in the group, which
are broken in order to make the metrical groupings of the beam clearer.
Below is an example to demonstrate this:

A phrase of 64th notes, where the secondary beams are subdivided to show 16th and 8th note groups.

Per-flow options for how secondary beams should appear can be set on the Beam Grouping
page in Write > Notation Options.

Editing secondary beams
Secondary beams can be adjusted locally by using properties in the Properties panel at the
bottom of the window.
PROCEDURE
1.

When the selection consists of only one or more notes, you the Beaming section appears
in the Properties panel.

2.

Select the note to the right of where you want the beaming to change, and activate the
Split secondary beam property.

3.

Choose how many beam lines are shown from the menu beside the property.

RESULT
The beaming is changed according to your preference. This is applied immediately to the left of
the selected note.

Resetting secondary beam editing
Changes to secondary beams can be reset back to default by using the Properties panel at the
bottom of the window.
●

Switch off Split secondary beam in the Properties panel.

●

Alternatively, choose Edit > Beaming > Reset Beaming.

Tuplets within beams
The default setting for a tuplet in a beamed group with secondary beams is to split the secondary
beam and to show the tuplet with a bracket.
You can alter the appearance of the bracket by selecting the bracket and changing relevant
properties in the Tuplets group of the Properties panel.
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The default setting for a tuplet in a beamed group with only a primary beam is not to separate
the tuplet entirely, as the alternative is not as clear. This is demonstrated by this quaver tuplet
followed by two quavers. However, you can change this setting on the Beam Grouping page in
Notation Options.

RELATED LINKS
Tuplets on page 665
Individual changes to the appearance and position of tuplet numbers or ratios and tuplet
brackets on page 674

Fanned beams
Fanned, or “feathered”, beams show either an accelerando or rallentando by having multiple
beam lines either converging on, or diverging from, a single beam line at the other end.
A single beam can have multiple changes of direction within it.
The grouping can use either two or three beams, with three beams indicating a greater change
of speed than two beams.
The slowest part of the phrase is where the beams converge, and the fastest is where the beams
are the most spread out.

A fanned beam accelerando with three lines.

Creating fanned beams
You can create fanned beams across a group of any notes that can be beamed, such as eighth
notes, 16th notes, and 32nd notes.
PROCEDURE
1.

Select the notes you want to include in a fanned beam. You can do this in Write mode and
Engrave mode.

2.

Select one of the following options:
Choose Edit > Beaming > Create Fanned
Beam > Accelerando (Three Lines), or
Right-click and choose Beaming > Create
Fanned Beam > Accelerando (Three
Lines) from the context menu
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Choose Edit > Beaming > Create Fanned
Beam > Accelerando (Two Lines), or
Right-click and choose Beaming > Create
Fanned Beam > Accelerando (Two Lines)
from the context menu
Choose Edit > Beaming > Create Fanned
Beam > Rallentando (Three Lines), or
Right-click and choose Beaming > Create
Fanned Beam > Rallentando (Three Lines)
from the context menu
Choose Edit > Beaming > Create Fanned
Beam > Rallentando (Two Lines), or
Right-click and choose Beaming > Create
Fanned Beam > Rallentando (Two Lines)
from the context menu
TIP
Add a bracket above the staff with the relevant note duration symbol to clarify the
rhythmic duration of the fanned beam, if the fanned beam group makes the beat division
unclear.
NOTE
The durations of the notes you select are ignored when showing a fanned beam.

Changing the direction within fanned beams
You can change the direction of fanned beams within phrases to indicate tempo changes.
PROCEDURE
1.

In Engrave mode, select the notehead at each rhythmic position where you want to
change the direction of the fanned beam slope.
NOTE
You can select multiple positions within phrases, as shown in the example.

2.

Activate the Change fanned beam direction property in the Beaming group of the
Properties panel.

EXAMPLE

Fanned beam with multiple changes of direction
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Creating custom beam groupings for meters
If your music requires a different beam grouping for a particular meter than the default setting
for that time signature, you can specify your preferred beam grouping within the time signature.
You can choose whether or not the time signature shows this custom beam grouping or not.
PROCEDURE
1.

2.

Open the time signatures popover in any of the following ways:
●

Press Shift-M

●

Choose Write > Create Time Signature

Enter the division you want in square brackets into the popover.
For example, if you want a 7/8 time signature to be divided into 2+3+2, enter [2+3+2]/8
into the popover. If you want a 5/4 time signature to be divided into 2+3 rather than 3+2,
enter [2+3]/4 into the popover.

3.

Press Return to close the popover.

RESULT
The time signature appears either as a single number, such as 7/8, or showing the beat groups,
such as 2+3+2/8, depending on your preference for this option on the Time Signatures page of
Engrave > Engraving Options.
You can change the appearance of numerators in individual time signatures so that they show a
single number or beat groups, independently of your project-wide settings.
RELATED LINKS
Project-wide Engraving Options for time signatures on page 629
Changes to the appearance of time signatures on page 629

Default beam groupings according to meter
Notes are beamed differently in different time signatures, to make the meter clear and easily
readable.
For example, music in 3/4 is beamed in one group of six 8th notes, whereas music in 6/8 is
beamed in two groups, each the value of a dotted quarter note. Although these two time
signatures describe the same rhythmic value, the implicit meter within them is different and so
the beam grouping is different.
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Default beat boundaries in 3/4.

Default beam grouping in 6/8.

For irregular time signatures, like 5/8 or 7/8, Dorico beams notes by default according to the
most common practices for those signatures, as demonstrated below.
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Brackets and braces are thick straight and curved lines in the left-hand margin that show
instrument groupings.

Brackets
A bracket is a thick black line, the width of a beam, that groups staves together, most commonly
according to instrument family. It often has winged ends that point inwards towards the score.
It is always positioned directly to the left of a systemic barline. If secondary brackets and braces
are used in addition to a bracket, they are positioned further away from the start of the system to
allow space for the bracket.

An example of a bracket, connecting instruments in the string family. A sub-bracket connects the two violin
lines.

In Dorico, barlines join the same staves that are joined by brackets and braces, meaning that a
bracketed group of staves or a braced pair of staves appears with barlines extending across the
group.

Braces
A brace is a wavy (or curly) line that joins multiple staves belonging to the same instrument, for
example the piano or harp. If necessary, a brace can extend to three or more staves, although
two is most common.
The brace is also sometimes used instead of a sub-bracket to show groupings of identical
instruments within a family whose staves are joined by a bracket.
It is positioned outside the systemic barline, and if used in place of a sub-bracket, outside of the
bracket as well.
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An example of a brace, connecting the two staves of a piano.

RELATED LINKS
Barlines across staff groups on page 228

Changing bracket grouping according to ensemble type
One way to change which staves are included in brackets is to change the project-wide setting for
ensemble type, which can be found in the Approach section on the Brackets and Braces page in
Engraving Options.
The default setting is Orchestral. You should change this setting for projects for small
ensembles.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Brackets and Braces in the page list.

3.

In the Approach section, choose from the available options in the Ensemble type group:
●

No brackets: all staves appear separately.

●

Orchestral: staves are bracketed according to their instrument family (default
setting).

●

Small ensemble: all staves in the project are bracketed together.

●

Wind band: staves are bracketed according to their instrument type, for example
Flute 1 and Flute 2 would be bracketed together, but separately from other
woodwinds.

●

Big band: staves are bracketed according to instrument family, except for brass
instruments which are all bracketed according to instrument type. Rhythm section
instruments are bracketed together. Percussion and Timpani are bracketed
together.

●

British big band: staves are bracketed according to instrument family, except for
brass instruments which are all bracketed according to instrument type, although
horns and trumpets are bracketed together. Percussion and Timpani are bracketed
separately.

RELATED LINKS
Barlines across staff groups on page 228
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Creating player groups in Setup mode
Grouping players together means they are positioned together in the score, numbered
independently, and are bracketed together according to the ensemble type chosen on the
Brackets and Braces page in Engraving Options.
For example, if your project is for double choir (SATB/SATB), because all voices are in the same
family, they are joined by a single bracket by default. However, if you add each choir to its own
group, they are bracketed separately.
Similarly, you can create a group for an off-stage group of players in a large-scale work.
If the instruments were not already next to each other according to orchestral order, creating a
player group changes the order of players in the score project-wide.
PROCEDURE
1.

In Setup mode, select the players you want to group together from the list on the left.

2.

Click on the Add Group button at the bottom of the window.

3.

Alternatively, you can select a single player, click on the Add Group button, or right-click
and choose Add Player to Group > New Player Group. Then add other players to the
group by either:
●

Right-clicking on the player you want to add, and choosing, for example, Add Player
to Group > Group 1.

●

Clicking and dragging the player on top of the group. A blue line shows you where
in the group it will be placed.

Project-wide Engraving Options for brackets and braces
Options for the appearance of brackets and braces project-wide can be found on the Brackets
and Braces page in Engraving Options.
The options on the Brackets and Braces page allow you to change which instruments are
bracketed together, and change the design of brackets.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Changing appearance of bracket ends
There are three options for how bracket ends should appear in Dorico: Winged, Horizontal line,
or None.
To change the appearance of bracket ends project-wide:
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Brackets and Braces in the page list.

3.

In the Design section, choose from the available options in the Brackets end design
group:
●

Winged (default)
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●

Horizontal line

●

None

Secondary brackets (sub-brackets)
Secondary brackets can appear in two ways in Dorico: as a brace (positioned outside the bracket),
or as a sub-bracket.

Secondary bracket as a sub-bracket
By default, secondary brackets appear as sub-brackets: thin lines with square corners that extend
beyond the bracket.

You can change how thick the lines of sub-brackets are, and the distance between sub-brackets
and the systemic barline, in the Sub-brackets group of the Design section of the Brackets and
Braces page in Engrave > Engraving Options.

Secondary bracket as a brace
Secondary brackets can also appear as a brace instead of a sub-bracket if you prefer.

You can change the distance between braces and brackets, in the Sub-brackets group of the
Design section of the Brackets and Braces page in Engraving Options.
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Clefs and octave lines provide crucial information about which notes are desired, and how high
or low they should be.
Clefs define which staff line or space corresponds to which scale degree, and also help to
communicate the register of the notes on the staff. Octave lines allow notes to be written within
the staff when they are played sufficiently high or low to require many ledger lines.
In Dorico they are grouped together because they both affect the meaning of note positions on
the staff. In this way, octave lines could be considered to be temporary clef changes.

Clefs
Clefs are the symbol at the start of every system that give the notes on the staff context; that is,
the clef tells you which note of the scale applies to each line or space of the staff.
For example, the treble clef is also known as a “G clef”, because the spiral shape in the middle
centers around G, normally the one above middle C.

For staves with a treble clef, the note in the space above is an A, and the note in the space below
is an F, and so on.
The other common clefs are:
●

The bass clef, or F clef, in which two dots are shown either side of the line corresponding
to F, normally the F below middle C.
Middle C uses one ledger line below staves with treble clefs, and one ledger line above
staves with bass clefs.

●

The C clef, in which the bracket to the right of the clef’s thick vertical line meet at the line
that corresponds to C, normally middle C.

The C clef today is commonly used at two position on the staff:
●

On the middle line of the staff, commonly called the alto clef.

●

On the line above the middle line of the staff, commonly called the tenor clef.

All of these clefs are used to match the register of the instrument for which they are being used,
to minimize the number of ledger lines required.

The E below middle C shown in a treble clef.
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The E below middle C shown in a bass clef.

Clefs and octave lines
Clefs
In Dorico, clefs and octave lines can be found in the same section of the Notations panel on the
right of the window. The panel is divided into four sections, three of which are for clefs:
●

Common clefs: including treble, bass, alto, and tenor.

●

Uncommon clefs: including tab, French violin clef, treble clef octave above, treble clef
octave below, and so on.

●

Archaic clefs: including baritone bass clef, mezzo-soprano clef, and soprano clef, which
are not commonly used any more.

Inputting clefs with the keyboard
You can input clefs with the keyboard by using the clefs and octave lines popover in Write mode.
Clefs and octave lines are input using the same popover, as both affect the pitch and register of
notes on the staff.
You can open the clefs and octave lines popover in the following ways:
●

Press Shift-C.

●

Choose Write > Create Clef.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The clefs and octave lines popover with an example
entry for a clef

The clefs and octave lines button in the Notations
toolbox

The clefs and octave lines popover for clefs
Enter the following commands into the clefs and octave lines popover to create the different clefs
available.
You can open the clefs and octave lines popover in Write mode by pressing Shift-C, or by
choosing Write > Create Clef.
Enter:

For clef:

g or G or treble

Treble G clef

f or F or bass

Bass F clef

ct or CT or tenor

Tenor C clef

ca or CA or alto

Alto C clef

g8ba or G8ba or g8d or G8d or treble8ba or
treble8d

Treble G clef, octave below

g15ba or G15ba or g15d or G15d or
treble15ba or treble15d

Treble G clef, two octaves below

g8va or G8va or g8u or G8u or treble8va or
treble8u

Treble G clef, octave above
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Enter:

For clef:

g15ma or G15ma or g15u or G15u or
treble15ma or treble15u

Treble G clef, two octaves above

ca8ba or CA8ba or ca8d or CA8d or alto8ba
or alto8d

Alto C clef, octave below

ct8ba or CT8ba or ct8d or CT8d or tenor8ba
or tenor8d

Tenor C clef, octave below

f8ba or F8ba or f8d or F8d or bass8ba or
bass8d

Bass F clef, octave below

f15ba or F15ba or f15d or F15d or bass15ba
or bass15d

Bass F clef, two octaves below

f8va or F8va or f8u or F8u or bass8va or
bass8u

Bass F clef, octave above

f15ma or F15ma or f15u or F15u or bass15ma
or bass15u

Bass F clef, two octaves above

perc

Unpitched percussion

tab4

4-string tablature

tab6

6-string tablature

baritonebass

Baritone bass clef

baritone

Baritone clef

mezzo

Mezzo-soprano clef

soprano

Soprano G clef

subbass

Sub-bass clef

invisible

Invisible clef

NOTE
More clefs are available in the Clefs panel, including Indian drum clef and Percussion clef
(rectangular).

Inputting clefs during step input with the keyboard
To input clefs during step input with the keyboard:
PROCEDURE
1.

In Write mode, start note input.

2.

Open the clefs and octave lines popover in any of the following ways:
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●

Press Shift-C

●

Choose Write > Create Clef

3.

Enter the appropriate short-hand for your preferred clef into the popover, such as bass or
G8ba.

4.

Press Return to close the popover.

RESULT
The clef is added at the caret position, and applies to all notes on that staff until the next clef, or
the end of the flow. Note input continues after inputting the clef, so you can continue inputting
notes and clefs as required.
RELATED LINKS
The clefs and octave lines popover for clefs on page 269

Adding clefs to existing music with the keyboard
To add a clef to existing music with the keyboard:
PROCEDURE
1.

In Write mode, select the note from which you want a new clef to start.

2.

Open the clefs and octave lines popover in any of the following ways:
●

Press Shift-C

●

Choose Write > Create Clef

3.

Enter the appropriate short-hand for your preferred clef into the popover, such as treble
or f8ba.

4.

Press Return to close the popover.

RESULT
The clef is added directly before the selected notehead, and applies to all notes on that staff
until the next clef, or the end of the flow. Clefs cannot be added by selecting barlines or time
signatures, if they apply to multiple staves. Clefs can be added to barlines on single staves or
time signatures on single stave, and are added directly before the selected single-staff barline or
single-staff time signature.

Changing the type of an existing clef with the keyboard
To change the type of an existing clef with the keyboard:
PROCEDURE
1.

In Write mode, select the clef you want to change.

2.

Open the clefs and octave lines popover in any of the following ways:
●

Press Shift-C

●

Choose Write > Create Clef

3.

Enter the appropriate short-hand for your preferred clef into the popover, such as alto or
g8va.

4.

Press Return to close the popover.

RESULT
The clef is changed to the one you specified.
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Inputting clefs with the mouse
Clefs can be input with the mouse using the Clefs panel on the right of the window in Write
mode.
You can open this panel by clicking Clefs in the Notations toolbox:

You can also hide and show the panel by clicking on its disclosure arrow, or by pressing Ctrl/
Cmd-9.
In the Clefs panel, clefs are divided up into three sections:
1

Common clefs
These are the clefs you are most likely to need.

2

Uncommon clefs
These are less frequently used clefs, but still sometimes used.

3

Archaic clefs
These are clefs that are not commonly used any more.

Inputting clefs during step input with the mouse
To input clefs during step input with the mouse:
PROCEDURE
1.

In Write mode, start note input.

2.

Click the clef you want in the Clefs panel on the right of the window.

RESULT
The clef is added at the caret position, and applies to all notes on that staff until the next clef, or
the end of the flow. Note input continues after inputting the clef, so you can continue inputting
notes and clefs as you need.
RELATED LINKS
Inputting clefs with the mouse on page 272

Adding clefs to existing music with the mouse
To add a clef to existing music with the mouse:
PROCEDURE
1.

In Write mode, select the note from which you want a new clef to start.

2.

Click on your preferred clef in the Clefs panel on the right of the window.

RESULT
The clef is added directly before the selected notehead, and applies to all notes on that staff
until the next clef, or the end of the flow. A clef cannot be added by selecting a barline or time
signature, if it applies to multiple staves. A clef can be added to an individual barline or individual
time signature, and is added directly before a selected individual barline or individual time
signature.
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Changing the type of an existing clef with the mouse
PROCEDURE
1.

In Write mode, select the clef you want to change.

2.

Click on your preferred clef in the Clefs panel on the right of the window.

RESULT
The clef is changed to the one you specified.

Project-wide spacing gaps for clefs
You can change the minimum gaps between objects, including clefs, on the Spacing Gaps page
in Engraving Options.
Amongst the available values, the following minimum values directly relate to clefs:
●

Gap after barline before clef, key or time signature

●

Gap after initial clef

●

Gap to the left of clef, cancelation naturals or grace notes before note or barline

●

Gap after clef change

Other values may have an effect on the position of clefs, however they also affect other objects.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Moving clefs rhythmically
You can move clefs to new rhythmic positions after they have been input.
NOTE
You can change the default positions of clefs relative to notes or barlines by changing the
project-wide values for spacing gaps on the Spacing Gaps page in Engrave > Engraving
Options.

PROCEDURE
1.

Select the clefs you want to move.

2.

Move the clefs to the next or previous rhythmic position, according to the rhythmic grid
currently set, in the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left

●

Click and drag a clef to the position you want.
NOTE
Only one clef can be moved rhythmically at a time when using the mouse.

RESULT
The selected clefs are moved to new rhythmic positions. They take effect from their new
positions until the next clef, or the end of the flow, whichever comes first.
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NOTE
Clefs can only be moved along staves. If you want to move a clef across staves, you must first
delete the clef from its first position, then add a new clef to the staff you wanted to move it to.
NOTE
Only one clef can exist at each rhythmic position, except for clefs that only apply to single staves.
If a clef passes over another clef as part of its move, the existing clef is deleted.
If you moved clefs using the keyboard, you can undo the move to restore any clefs deleted in the
process.
However, if you moved clefs using the mouse, undoing the move does not restore any clefs
deleted in the process.
Moving clefs back to their previous positions later does not restore any clefs deleted when they
were moved previously. The deleted clefs must be re-input if necessary.

Moving clefs graphically
Clefs can be moved individually to new graphical positions in Engrave mode without affecting the
positions of any other items.
NOTE
You cannot change the positions of Note Spacing handles with the mouse, they can only be
moved using the keyboard.

PROCEDURE
1.

In Engrave mode, activate Note Spacing in the panel on the left of the window.

2.

Select the square handle above the clef you want to move, as shown in the example below.

3.

Once you have selected a square handle, a smaller circular handle appears beside the clef.

4.

Select the circular handle.

5.

Nudge the clef in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.
TIP
If you want to move clefs by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The clef is moved graphically to the right or to the left.
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RELATED LINKS
Moving clefs graphically using the Properties panel on page 275
Changes to note spacing in Engrave mode on page 461

Moving clefs graphically using the Properties panel
You can move clefs graphically using the Properties panel.
NOTE
Changing the value for the Spacing Offset property also affects the positions of notes, rests,
time signatures, and key signatures in the bars either side of the clef.

PROCEDURE
1.

In Engrave mode, select the clefs you want to move.

2.

Activate the Spacing Offset property in the Clefs group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The Spacing Offset property moves clefs in the following ways:
●

Increasing the Spacing Offset value moves clefs to the right.

●

Decreasing the Spacing Offset value moves clefs to the left.

Deleting clefs
PROCEDURE
1.

Select the clefs you want to delete.

2.

Delete the clefs in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected clefs are deleted. Any music on the staff is respelled according to the previous clef,
up until the next existing clef or the end of the flow.
NOTE
You cannot delete the initial clef in a flow. If you do not want any clef to appear on a staff, you
should input an invisible clef. See the links below for more information on how to do this.

RELATED LINKS
The clefs and octave lines popover for clefs on page 269
Inputting clefs with the mouse on page 272
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Hiding clefs
Clefs provide crucial information about which notes should be played, and should not be omitted
from the score. However, should you need to hide an individual clef, you can change its color so
that it cannot be seen in the score.
PROCEDURE
1.

Select the clef you want to hide.

2.

Activate the Color property in the Common group of the Properties panel. You can hide
and show this panel in the following ways:
●

Press Ctrl/Cmd-8

●

Click the disclosure arrow at the bottom of the window

3.

Click on the color square that is now shown beside the property. The default color is black.

4.

In the color dialog that appears, set the Opacity value to 0% in any of the following ways:
●
●

5.

Enter 0
Drag the slider all the way to the left

Press Return, or click OK to close the dialog.

RESULT
The clef is no longer visible in the score, however it can still be selected if you click on its position
in the staff, or if you use the arrow keys to navigate to it from elsewhere in the layout.
NOTE
This method does not change the spacing at the position of the clef. If you want no clef to appear
and also to adjust the spacing accordingly, you should input an invisible clef. See the links below
for more information on how to do this.

RELATED LINKS
The clefs and octave lines popover for clefs on page 269
Inputting clefs with the mouse on page 272

Changing the size of clef changes
The scale factor of clef changes project-wide can be changed on the Clefs page in Engraving
Options.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

The default Clef change scale factor is 2/3.
Increasing the scale factor makes clef changes appear larger, while decreasing the scale factor
makes clef changes appear smaller. However, the size of clefs at the start of each system is not
affected.
The smallest scale factor you can have that is above 0 is 1/8. There is no maximum limit, however
a scale factor of more than 30 causes a single clef to take up most of an A4 page, which is rarely
beneficial.
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Changing the position of clefs relative to grace notes
By default, clefs are not positioned between a note and its grace note. If you input the clef first,
or the grace note first, Dorico makes sure that the clef placement is correct.
However, in some circumstances you may want your clef to be positioned between a note and its
grace note. To do this:
PROCEDURE
1.

Select the clef whose position you want to change.

2.

Choose Edit > Clef Position > After Grace Notes, or right-click and choose Clef Position >
After Grace Notes from the context menu.

RESULT
The clef is positioned between a note and its grace note.
RELATED LINKS
Resetting the position of clefs relative to grace notes on page 277

Resetting the position of clefs relative to grace notes
To reset the position of a clef relative to grace notes after positioning it between a note and its
grace note:
PROCEDURE
1.

Select the clef whose position you want to change.

2.

Choose Edit > Clef Position > Reset Clef Position, or right-click and choose Clef
Position > Reset Clef Position from the context menu.

RESULT
The clef is positioned between a note and its grace note.

Transposing clefs
While most instruments produce notes at concert pitch, there are a number of instruments
that produce a note that is different to the one that is written. These instruments are known as
transposing instruments.
For example, two common orchestral transposing instruments are clarinet in B♭ and horn in F.
When a clarinet in B♯ plays a C, the sound produced is a B♯, one tone below. When a horn in F
plays a C, the sound produced is an F, a fifth below.
Other instruments that conventionally produce a pitch different to the one notated are: piccolo
(sounding an octave above written), double bass (sounding an octave below written), and
glockenspiel (sounding two octaves above written).
Dorico automatically handles these transpositions, which you can see taking effect if you input
notes into the staff of a transposing instrument, and then compare those notes in the full score
layout to how they appear in the part layout.
As all note information is stored in concert pitch and then transposed as necessary, you can
change instruments at any time, and the music is adjusted automatically to ensure the correct
result.
There are also clefs that specify that notes should be played in a different register to the one
notated. A number above the clef indicates notes should be played higher than notated, while
a number below the clef indicates notes should be played lower than notated. Apart from the
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treble clef 8 below, which is often used for tenor vocal parts and can be seen on the left of the
below examples, most of these are not frequently used.

Octave lines
Octave lines indicate where the notes played should be higher or lower than they appear in the
score or part.
Octave lines are horizontal lines, either dashed or dotted, with an italic numeral at the start that
indicates the number of pitches the phrase should be changed by, such as 8 for an octave and 15
for two octaves.
Octave lines that indicate notes should be played higher than notated are positioned above the
staff, while octave lines that indicate notes should be played lower than notated are positioned
below the staff.

A phrase shown (left to right): at pitch, with an octave above line, and with a two octaves above line with
default settings.

A phrase shown (left to right): at pitch, with an octave below line, and with a two octaves below line with
default settings.

In Dorico, the adjustment of pitches is done automatically when an octave line is present. There
is no need for you to change the register of the notes within the line.
Octave lines can be used for whole phrases, many phrases, or short sections, but they should
never confuse the contour of the music. As demonstrated below, if used excessively and for
inappropriate sections, the octave line can mask the shape of the original melody. However,
careful usage of octave lines can make music easier to read quickly as they can reduce the
number of ledger lines a player has to count. Nonetheless it is generally better to use a different
clef for a whole phrase if appropriate for that instrument, or to put an octave line above or below
the whole phrase in order to ensure the shape and register are clear to the player.

An angular phrase with no octave
lines.

The same phrase with lots of
octave lines, which distort the
overall shape of the phrase.

The same phrase again, but with
just two octave lines to reduce
ledger lines, but which do not
change the overall shape of the
phrase.

Wherever possible, they should remain completely horizontal. This means that they may take up
significant vertical space, as they should be positioned outside all other notations. However, they
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may be positioned within slurs and tuplet brackets if the slur or tuplet bracket is longer than the
octave line.
Octave lines can continue across system and page breaks. It is customary to show the numeral
again at the start of each system as a reminder, which is usually parenthesized, but the suffix
does not have to be included.

Inputting octave lines with the keyboard
You can input octave lines with the keyboard by using the clefs and octave lines popover in Write
mode. Clefs and octave lines are input using the same popover, as both affect the pitch and
register of notes on the staff.
To open the clefs and octave lines popover, press Shift-C (C for “clef”), or choose Write > Create
Clef.
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The clefs and octave lines popover with an example
entry for an octave line

The clefs and octave lines button in the Notations
toolbox

The clefs and octave lines popover for octave lines
Enter the following commands and symbols into the clefs and octave lines popover to create the
different octave lines available.
You can open the clefs and octave lines popover in Write mode by pressing Shift-C, or by
choosing Write > Create Clef.
Enter:

Result:

8va or 8 or 8u or 1u

Shift notes up by 1 octave.

15ma or 15 or 15u or 2u

Shift notes up by 2 octaves.

22ma or 22 or 22u or 3u

Shift notes up by 3 octaves.

8ba or 8vb or 8d or 1d

Shift notes down by 1 octave.

15ba or 15vb or 15d or 2d

Shift notes down by 2 octaves.

22ba or 22vb or 22d or 3d

Shift notes down by 3 octaves.

| or stop

End of octave line.

Inputting octave lines during step input with the keyboard
To input octave lines during step input with the keyboard:
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where the line should begin.

279

Clefs and octave lines
Octave lines
3.

Open the clefs and octave lines popover in any of the following ways:
●

Press Shift-C

●

Choose Write > Create Clef

4.

Enter the appropriate short-hand for your preferred octave line into the popover, such as
8va or 15d.

5.

Press Return to close the popover.

6.

Press Space to advance the caret and extend the octave line.
The octave line also extends automatically as you continue inputting notes.

7.

Stop any octave line by opening the clefs and octave lines popover again, and entering one
of the following:
●
●

|
stop

RESULT
The octave line is input from the caret position at its start, and ends at the caret position.
RELATED LINKS
The clefs and octave lines popover for octave lines on page 279

Adding octave lines to existing notes with the keyboard
You can add octave lines to existing notes with the keyboard.
PROCEDURE
1.

In Write mode, select the note or notes to which you want to add an octave line.

2.

Open the clefs and octave lines popover in any of the following ways:
●

Press Shift-C

●

Choose Write > Create Clef

3.

Enter the appropriate short-hand for your preferred octave line into the popover, such as
1u or 15ba.

4.

Press Return to close the popover.

RESULT
The octave line is added above your selection if it indicates notes should be played higher than
notated, or below your selection if it indicates note should be played lower than notated.
NOTE
You can also change the lengths of octave lines after they have been input.

RELATED LINKS
Lengthening and shortening octave lines with the keyboard on page 284

Inputting octave lines with the mouse
Octave lines can be input with the mouse using the Octave Lines section of the Clefs panel on
the right of the window in Write mode.
The Clefs panel is activated by selecting this button from the Notations toolbox on the right of
the window:
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Clicking on the disclosure arrow to show the Octave Lines section shows these options:

The top row has three options for octave lines that indicate music should be played higher than
written:
●

One octave up, or 8va

●

Two octaves up, or 15va

●

Three octaves up, or 22va

The middle row has three options for octave lines that indicate music should be played lower
than written:
●

One octave down, or 8ba

●

Two octaves down, or 15ba

●

Three octaves down, or 22ba

The bottom row has a loco line that indicates music should be played as written, which can be
useful for clarity when lots of octave transpositions are used.

Inputting octave lines during step input with the mouse
To input octave lines during step input with the mouse:
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where the line should begin.

3.

Click on the button of your preferred octave line in the Clefs panel on the right of the
window.

RESULT
The octave line is added at the caret position. However, if input using the mouse, an octave line
does not automatically extend as you continue inputting notes.
NOTE
You can also change the lengths of octave lines after they have been input.

RELATED LINKS
Lengthening and shortening octave lines with the mouse on page 284
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Adding octave lines to existing notes with the mouse
To add octave lines to existing notes with the mouse:
PROCEDURE
1.

In Write mode, select the note or notes to which you want to add an octave line.

2.

Click on the button of your preferred octave line in the Clefs panel on the right of the
window.
Alternatively, click on the button of your preferred octave line in the Clefs panel first, and
then click and drag to input an octave line and extend it to your preferred length.

Positions of octave lines
You can change the positions of octave lines by moving individual octave lines to different
rhythmic positions in Write mode, moving them to different graphical positions in Engrave mode,
and by changing the default positions of all octave lines project-wide.
You can move octave lines to new rhythmic positions in Write mode. They are positioned by
default according to your settings in Engraving Options.
You can move octave lines graphically in Engrave mode, however this does not change the
rhythmic positions to which they apply.
Project-wide settings for the default positions of octave lines can be set on the Octave Lines
page in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for octave lines on page 285

Moving octave lines rhythmically
You can move octave lines to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the octave lines you want to move.

2.

Move the octave lines to the next or previous notehead on the staff, while maintaining
their total durations, in the following ways:
●

Press Alt-Right Arrow to move them to the next notehead.

●

Press Alt-Left Arrow to move them to the previous notehead.

●

Click and drag it to the position you want.
NOTE
Only one octave line can be moved rhythmically at a time when using the mouse.

RESULT
The octave lines now apply to the notes at their new positions. If an octave line passes over
another octave line as part of its move, the existing line is unaffected as multiple octave lines can
exist at the same rhythmic position.
NOTE
Octave lines can only be moved along staves. If you want to move an octave line across staves,
you must first delete the octave line from its first position, then add a new octave line to the staff
you wanted to move it to.
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Moving octave lines graphically
You can move octave lines graphically without changing the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the octave lines you want to move.

2.

Move the octave lines in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
NOTE
If you want to move octave lines by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction to the positions you want.

RELATED LINKS
Moving octave lines graphically using the Properties panel on page 283

Moving octave lines graphically using the Properties panel
You can move octave lines graphically using the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the dynamics you want to move.

2.

Activate the following properties, individually or together, in the Octave Lines group of
the Properties panel:

3.

4.

●

Start X offset

●

End X offset

●

Y offset

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move dynamics in the following ways:
●

Start X offset moves the start of octave lines horizontally: increasing the value
moves the start of octave lines to the right, decreasing the value moves the start of
octave lines to the left.

●

End X offset moves the end hooks of octave lines horizontally: increasing the value
moves the end hooks of octave lines to the right, decreasing the value moves the
end hooks of octave lines to the left.

●

Y offset moves octave lines vertically: increasing the value moves them upwards,
decreasing the value moves them downwards.

283

Clefs and octave lines
Octave lines

Lengthening and shortening octave lines
You can change the length of octave lines after they have been input with the keyboard and with
the mouse.
When lengthening and shortening octave lines with the keyboard, you can lengthen and shorten
octave lines according to the rhythmic grid currently set, and by snapping the ends of octave
lines to the next or previous notehead.
When lengthening and shortening octave lines with the mouse, you can only lengthen and
shorten them by dragging the ends of octave lines to the next or previous notehead along the
staff.

Lengthening and shortening octave lines with the keyboard
You can lengthen and shorten octave lines after they have been input.
PROCEDURE
1.

In Write mode, select the octave lines you want to lengthen or shorten.

2.

Lengthen and shorten the selected octave lines using the following key commands:
●

Press Shift-Alt-Right Arrow to lengthen octave lines by the current rhythmic grid
value

●

Press Shift-Alt-Left Arrow to shorten octave lines by the current rhythmic grid
value

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to snap the end of a single octave line to the
next notehead

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to snap the end of a single octave line to the
previous notehead
NOTE
You can only lengthen or shorten octave lines by the current rhythmic grid value
when multiple octave lines are selected.

RELATED LINKS
Positions of octave lines on page 282

Lengthening and shortening octave lines with the mouse
You can lengthen and shorten octave lines after they have been input.
PROCEDURE
1.

In Write mode, select the octave line you want to lengthen or shorten.
NOTE
You can only lengthen or shorten one octave line at a time with the mouse.

2.

Select the circular handle at the end of the octave line.

3.

Click and drag the handle to noteheads to the right or left.

RESULT
The end of the selected octave line snaps to noteheads as you drag it along the staff.

284

Clefs and octave lines
Octave lines

Deleting octave lines
PROCEDURE
1.

In Write mode, select the octave lines you want to delete.

2.

Delete the octave lines in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected octave lines are deleted. Any music on the staff is shown at either concert pitch or
transposed pitch, depending on your current setting for the layout.
RELATED LINKS
The clefs and octave lines popover for clefs on page 269
Inputting clefs with the mouse on page 272

Changes to the appearance and placement of octave lines
The appearance and placement of octave lines can be changed project-wide on the Octave Lines
page in Engrave > Engraving Options, and individually using properties in the Properties panel
in Engrave mode.

Project-wide Engraving Options for octave lines
There are many options for how octave lines should appear on the Octave Lines page in
Engrave > Engraving Options.
The options on this page allow you to change the appearance of the numeral at the start of
octave lines, continuation lines, and continuation labels, and the position of octave lines relative
to accidentals, noteheads, and the staff.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Octave Lines in the page list on the left of the dialog.

Editing individual octave lines using the Properties panel
You can move and change the appearance of individual octave lines by using properties in the
Properties panel, without changing your project-wide settings on the Octave Lines page in
Engrave > Engraving Options.

Properties panel
The Properties panel is available in both Write mode and Engrave mode, but there are more
options available in Engrave mode than Write mode. These options are:
Placement
Choose whether an octave lines is placed Above or Below the staff.
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L position
Choose whether the numeral of an octave line is aligned with a Notehead or with an
Accidental.
L alignment
Choose whether the numeral of an octave is aligned:
●

Left: left end of the numeral aligned with the stem.

●

Center: numeral centered on stem.

●

Right: right end of the numeral aligned with the stem.

Start X offset
Increasing the value moves the start of octave lines to the right, decreasing the value
moves the start of octave lines to the left.
End X offset
Increasing the value moves the ends of octave lines to the right, decreasing the value
moves the end of octave lines to the left.
Y offset
Increasing the value moves octave lines upwards, decreasing the value moves octave
lines downwards.
Hook length
Increasing the value makes the hook at the end of octave lines longer, decreasing
the value makes the hook shorter.
Tucking index
Changing the value for the tucking index changes an octave line’s position in the
vertical stacking order. According to general convention, octave lines should be
placed outside all other objects, but there are some instances where they can go
inside other objects, for example, inside a slur if that slur is longer than the octave
line.
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Chord symbols describe the vertical harmony of the music at a specific moment.
They are commonly used in jazz and pop music, where players commonly improvise around
chord progressions.
Depending on the style of music, there are different conventions regarding how to present chord
names.

What makes up a chord?
Chord symbols consist of a root and a quality, with (optionally) intervals, alterations, and an
altered bass note.
The component parts of a chord symbol are as follows:
Root
The root note of the chord, expressed either as a note name or as a specific degree
of a scale.
Quality
What sort of chord it is, such as major, minor, diminished, augmented, halfdiminished, or with added notes (such as 6 or 9).
Interval
One or more added intervals (or “extensions”), such as a major seventh or ninth.
Alterations
For example, a sharpened 5th, flattened 9th, suspensions, or omissions.
Altered bass note
If the chord’s lowest pitch is not its root note, such as Cm7♭5/E♭.

Creating chord symbols
The appearance of chord symbols is determined by the options you can set on the Chord
Symbols page in Engrave > Engraving Options.
Creating chord symbols in Dorico uses the popover mechanic.
The short-hand you use in the popover to create the chord symbol does not determine the
appearance of the resulting chord symbol.
For example, you could choose to enter a C major chord as either C or Cmaj or CM, but in
each case the appearance of the resulting chord symbol is the same, as specified in Engraving
Options.
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RELATED LINKS
Project-wide Engraving Options for chord symbols on page 302

Inputting chord symbols
To input a chord symbol using the chord symbols popover:
PROCEDURE
1.

In Write mode, select the note or rest where you want the first chord symbol to appear.

2.

Open the chord symbols popover in any of the following ways:
●

Press Shift-Q

●

Choose Write > Create Chord Symbol

●

Click Chord Symbols in the Notations toolbox on the right of the window

3.

Type your desired chord symbol into the chord symbols popover using the computer
keyboard, or play the chord using your MIDI keyboard.

4.

Press Return to close the popover.

RESULT
The chord symbol specified is input.
RELATED LINKS
Inputting chord symbols with the computer keyboard on page 288
Inputting chord symbols with MIDI keyboard on page 294

Inputting chord symbols with the computer keyboard
All the different types of chord symbol can be input with the computer keyboard by using the
chord symbols popover in Write mode.
To open the chord symbols popover, press Shift-Q, or choose Write > Create Chord Symbol.
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The chord symbols popover with an example entry
for a chord symbol

The chord symbols button in the Notations toolbox

RELATED LINKS
Inputting chord symbols on page 288

The chord symbols popover
Here are some examples of what to enter into the chord symbols popover and the chord symbols
that are input as a result.
You can open the chord symbols popover in Write mode by pressing Shift-Q, or by choosing
Write > Create Chord Symbol.
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Enter:

For chord symbol roots:

English note names:

C, D♭, F♯, B, and so on

C, Db, F#, B, and so on
German note names:

C, D♭, F♯, B, and so on

C, Des, Fis, H, and so on
Fixed-do solfège:

C, D♭, F, F♯, B, and so on

do, reb, so, so#, ti, and so on
Nashville numbers representing scale degrees: Assuming C major:
1, 2b, 4#, 7, and so on

C, D♭, F♯, B, and so on

Enter:

For chord symbol quality:

maj, M, ma, or nothing after root

major

m, min, or mi

minor

dim, di, or o

diminished

aug, au, ag, or +

augmented

half-dim, halfdim, or hd

half-diminished

6/9, 69, or %

6/9

Enter:

For interval:

^7

major 7th

^

major 7th

^9

major 9th

maj9

major 9th

9maj7

major 9th

Enter:

For chord symbol alteration type:

b5, #9 and so on

alterations

add#11, addF#, addBb, and so on

added notes

sus4, sus9, and so on

suspensions
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Enter:

For chord symbol alteration type:

omit3, no7, and so on

omissions

Enter:

For altered bass note chord symbol:

G7,D

G7/D

Gmaj,B

G/B

Cmajb5/Eb

C(♭5)/E♭

Fmi/D#

Fm/D♯

Enter:

For polychord symbol:

G7;D

G7/D

G;E

G/E

Cmaj7|D

Cmaj7/D

Fmi|D#

Fm/D♯

Enter:

For chord symbol:

N.C., NC, no chord, or none

no chord

NOTE
The appearance of the resulting chord symbols in your project depends on the options you have
selected on the Chord Symbols page in Engrave > Engraving Options
This list is not comprehensive: it is intended to illustrate how you can structure your entry to
input different chord symbols.

Inputting roots with the computer keyboard
Roots are typed into the chord symbols popover.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Enter your desired root note into the popover. For example, C, do, or 1.

3.

Press Return to close the popover.

RESULT
The chord symbol specified is input.
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NOTE
The chord symbol may look different to what you typed into the popover. For example, entering
do may appear as “C” in the resulting chord symbol, depending on your settings on the Chord
Symbols page in Engrave > Engraving Options.

RELATED LINKS
Inputting chord symbols on page 288
The chord symbols popover on page 288

Inputting quality with the computer keyboard
The qualities of chords can be specified using the chord symbols popover.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Enter the root of your desired chord into the popover, such as E, followed by one of the
ways of expressing its quality. For example, Emaj or Ehalfdim.

3.

Press Return to close the popover.

RESULT
The chord symbol specified is input.
NOTE
The chord symbol may look different to what you typed into the popover. For example, entering
E+ may appear as “Eaug” in the resulting chord symbol, depending on your settings on the
Chord Symbols page in Engrave > Engraving Options.

RELATED LINKS
Inputting chord symbols on page 288
The chord symbols popover on page 288

Inputting intervals with the computer keyboard
A chord’s added interval can be specified using the chord symbols popover.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Enter the root of your desired chord into the popover, such as E, followed by one of the
ways of describing its added interval. For example, E^7 or Emaj9.

3.

Press Return to close the popover.

RESULT
The chord symbol specified is input.
NOTE
The chord symbol may look different to what you typed into the popover. For example, entering
Cmmaj7 may appear with parentheses as “Cm(maj7)” in the resulting chord symbol, depending
on your settings on the Chord Symbols page in Engrave > Engraving Options.
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RELATED LINKS
Inputting chord symbols on page 288
The chord symbols popover on page 288

Inputting alterations with the computer keyboard
A chord’s alteration can be specified using the chord symbols popover.
PROCEDURE
1.

In Write mode, open the chord symbols popover, as described in Inputting chord
symbols.

2.

Enter the root of your desired chord into the popover, such as E, followed by one of the
ways of expressing its alteration. For example, Eb5 or Eomit3.

3.

Press Return to close the popover.

RESULT
The chord symbol specified is input.
NOTE
The chord symbol may look different to what you typed into the popover. For example, entering
E#5b9 may appear as “E+5-9” in the resulting chord symbol, depending on your settings on the
Chord Symbols page in Engrave > Engraving Options.

RELATED LINKS
Inputting chord symbols on page 288
The chord symbols popover on page 288

Inputting altered bass notes with the computer keyboard
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Enter the root of your desired chord into the popover, such as C.

3.

Enter a / (forward slash) or , (comma) into the popover.

4.

Enter the altered bass note into the popover, such as E.

For example, the end result of steps 2 to 4 would be C/E.
5.

Press Return to close the popover.

RESULT
The chord symbol specified is added.
NOTE
The chord symbol may look different to what you typed into the popover. For example, entering
C/E may appear as “ConE”, depending on your settings on the Chord Symbols page in Engrave >
Engraving Options.

RELATED LINKS
Inputting chord symbols on page 288
The chord symbols popover on page 288
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Inputting a "no chord" symbol with computer keyboard
To indicate that no specific chord should be played at a given rhythmic position, “N.C.”, for “no
chord”, is shown. This can be entered into the chord symbols popover.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Enter one of the ways of expressing a no chord symbol into the popover. For example,
N.C. or no chord.

3.

Press Return to close the popover.

RESULT
A “no chord” symbol is added.
NOTE
The chord symbol may look different to what you typed into the popover. For example, entering
none may appear as “NC”, depending on your settings on the Chord Symbols page in Engrave >
Engraving Options.

RELATED LINKS
Inputting chord symbols on page 288
The chord symbols popover on page 288

Inputting "root only" or "bass only" chord symbols with computer keyboard
To indicate a chord should only consist of the root note:
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Enter the root only or bass only chord you want into the popover. For example, Cbass or
Gonly.

3.

Press Return to close the popover.

RESULT
The chord symbol specified is added.
RELATED LINKS
Inputting chord symbols on page 288
The chord symbols popover on page 288

Inputting polychords with computer keyboard
A polychord is where a single chord symbol describes two simultaneous chords.
PROCEDURE
1.

In Write mode, open the chord symbols popover.

2.

Enter the two chords you want to include in the polychord.

3.

Separate your two desired chords using the pipe character |, or semicolon ;. For example,
type D|C7 for a D major chord over a C7 chord.

4.

Press Return to close the popover.
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RESULT
The chord symbol specified is added.
NOTE
The chord symbol may look different to what you typed into the popover. For example, entering
D|C7 may result in two chords placed directly above other, or two chords placed side-by-side,
depending on your settings on the Chord Symbols page in Engrave > Engraving Options.

RELATED LINKS
Inputting chord symbols on page 288
The chord symbols popover on page 288

Inputting chord symbols with MIDI keyboard
You can play chords on your MIDI keyboard to input chord symbols when the chord symbol
popover is open.
Options for how Dorico interprets the notes you play on your keyboard can be found on the
Chord Symbols page in Write > Note Input Options (key command Ctrl/Cmd-Shift-I).
The options include:
●

Whether Dorico should consider the inversion in which you play a given chord, or write the
chord symbol as if it had been played in root position.

●

Whether Dorico should notate omissions: for example, if you play C and E, should it be
notated as “C” or “C(omit5)”.

●

How it should notate added notes and suspensions.

●

How it should handle complex enharmonic relationships between roots and altered bass
notes.

Examine these options carefully to make sure your settings suit your needs.

Inputting roots with MIDI keyboard
Once you have opened the chord symbols popover at the point you want to input a chord
symbol, there are two ways to make it clear which note should be the root of a chord when
inputting with a MIDI keyboard:
●

By first playing the root with one finger, and then playing the remaining notes of the chord
while still holding down the root.

●

By playing all the notes of the chord together, holding them down, then releasing them all
and replaying the root note.

TIP
To input a chord symbol that consists only of the root note, just play a single note.

Inputting altered bass notes with MIDI keyboard
Once you have opened the chord symbols popover at the point you want to input a chord
symbol, there are two ways to tell Dorico which note is the altered bass note of a chord when
inputting with a MIDI keyboard:
●

Play all notes of the chord together with the altered bass note at the bottom.

●

Play the chord and its altered bass note separately: hold down the keys for the chord, then
play the altered bass note while keeping the rest of the chord’s keys depressed.
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Inputting polychords with MIDI keyboard
PROCEDURE
1.

Play the first chord of the polychord with one hand.

2.

Keep the keys of your first chord depressed.

3.

Play the second chord with the other hand.

Navigation during chord symbol input
You can input multiple chord symbols without re-opening the popover each time, by navigating
through your score in the following ways for both computer keyboard and MIDI keyboard
inputting methods.

Navigating with a computer keyboard
Once you have opened the popover, you can move it to add chord symbols to other notes by
using the following key commands:
Space
Advance the popover to the next beat.
Shift+Space
Move the popover back to the previous beat.
Tab
Advance the popover to the start of the next bar.
Shift+Tab
Move the popover back to the start of the previous bar.
Left arrow/right arrow
Move the popover to one of the following positions, whichever is closest:
●

Previous note

●

Next note

●

Previous rest

●

Next rest

●

Previous rhythmic grid position

●

Next rhythmic grid position

Ctrl+left arrow/Ctrl+right arrow (Windows) or Command-left arrow/Command-right
arrow (Mac)
Move the popover to the previous/next chord symbol.
Backspace
Move the popover back to the previous chord symbol.

Navigating with a MIDI keyboard
When inputting chord symbols using a MIDI keyboard, by default the popover advances
automatically to the next beat after you play a chord. You can change this behavior using the
Advance during chord symbol input via MIDI input options on the MIDI Input page in Write >
Note Input Options.
Furthermore, you can define specific keys or buttons on your MIDI keyboard to trigger
different navigation behaviors, by using the MIDI Learn button on the Key Commands page
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in Preferences to assign specific keys to the Note Input > Advance Chord Symbol Input
commands.

The Preferences dialog, where you can set keys to command the different navigation parameters.

RELATED LINKS
Assigning navigation behaviors for chord symbols to MIDI keyboards on page 296

Assigning navigation behaviors for chord symbols to MIDI keyboards
You can assign specific keys or buttons on your MIDI keyboard to trigger different navigation
behaviors for chord symbols.
PROCEDURE
1.

Open Preferences in any of the following ways:
●

Press Ctrl/Cmd-, (comma).

●

Choose Dorico > Preferences (OS X).

●

Choose Edit > Preferences (Windows).

2.

Click Key Commands in the page list on the left of the dialog.

3.

Show the options under NoteInput > Advance Chord Symbol Input in the key command
list in any of the following ways:
●

Double-click each option.

●

Click the disclosure arrow beside each option.

4.

Click the parameter to which you want to assign a MIDI keyboard command from the
available behaviors under Advance Chord Symbol Input. For example, click Next Bar to
assign a key to move the chord symbols popover to the next bar.

5.

Click MIDI Learn:

6.

Press the key on your MIDI keyboard that you want to assign to the selected parameter.

7.

Click Add MIDI command.

8.

Click Apply, then Close.
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Editing existing chord symbols
PROCEDURE
1.

In Write mode, select the chord symbol you want to edit.

2.

Press Return, or double-click on the chord symbol.

3.

The popover opens, with the existing short-hand for the chord symbol inside.

4.

Edit the chord symbol in any of the following ways:

5.

●

Editing the existing short-hand in the popover.

●

Removing the existing short-hand in the popover and typing in an entirely new
chord symbol.

●

Playing in a new chord symbol using your MIDI keyboard.

Press Return to close the popover.

RESULT
The chord symbol is edited according to your most recent preference.

Transposing chord symbols
Chord symbols can be transposed, and appear at the appropriate transposed pitch when shown
on transposing instruments.

Transposing chord symbols
1

In Write mode, select the chord symbols you want to transpose.

2

Choose Write > Transpose.

3

Select what type of transposition you want in the dialog. The options available include:
●

Transpose by: transpose by either Quality or Number of Divisions

●

Direction: Up or Down

●

Number of octaves

●

Interval

●

Quality

Showing instrument at transposed pitch
Chord symbols can also appear at the appropriate transposed pitch for transposing instruments,
when their part is shown at Transposed Pitch rather than Concert Pitch.
To do this choose Edit > Transposed Pitch.
IMPORTANT
This changes the shown transposition for all transposing instruments in the layout.

Hiding chord symbols
To hide chord symbols in the current layout:
PROCEDURE
1.

Select the chord symbol or chord symbols you want to hide.
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2.

Activate the Hidden property in the Chord Symbols group of the Properties panel.

RESULT
A signpost appears in place of the chord symbol.
If you do not want to see these signposts, switch off View > Signposts > Chord Symbols.

Hiding the root and quality of chord symbols
To hide the root and quality of chord symbols in the current layout:
PROCEDURE
1.

Select the chord symbol or chord symbols whose root and quality you want to hide.

2.

Activate the Hide root and quality property in the Chord Symbols group of the Properties
panel.

3.

Check the box beside the activation switch.

RESULT
The root and quality of the selected chords symbols are hidden.

Positions of chord symbols
By default, chord symbols are centered horizontally on the middle of the front notehead in the
first voice column, at the rhythmic position to which they are attached.

Aligning chord symbols relative to notes and chords
You can choose whether chord symbol text should be left-aligned above the notehead, centeraligned above the notehead, or right-aligned above the notehead (though right-aligned typically
produces unclear results).
These settings can be found under Horizontal alignment of chord symbols on the Chord
Symbols page in Engraving Options.

This can also be overridden for an individual selected chord symbol, using the Horizontal
alignment property in the Chord Symbols group of the Properties panel.

Aligning chord symbols across the system
Chord symbols are aligned at the same vertical position across the width of the system by
default, but you can switch off Align chord symbols across width of system on the Chord
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Symbols page in Engraving Options if you prefer each chord symbol to be positioned above the
staff independently.
RELATED LINKS
Project-wide Engraving Options for chord symbols on page 302

Moving chord symbols rhythmically
You can move chord symbols to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the chord symbols you want to move.

2.

Move the chord symbols to new rhythmic positions, according to the rhythmic grid
currently set, in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the chord symbol to the right or to the left the position you want.
NOTE
Only one chord symbol can be moved rhythmically at a time when using the mouse.

RESULT
The selected chord symbols are moved to new rhythmic positions.
NOTE
Only one chord symbol can exist at each rhythmic position. If a chord symbol passes over
another chord symbol as part of its move, the existing chord symbol is deleted.
If you moved chord symbols using the keyboard, you can undo the move to restore any chord
symbols deleted in the process.
However, if you moved chord symbols using the mouse, undoing the move does not restore any
chord symbols deleted in the process.
Moving chord symbols back to their previous positions later does not restore any chord symbols
deleted when they were moved previously. The deleted chord symbols must be re-input if
necessary.

Moving chord symbols graphically
You can move chord symbols graphically without affect the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the chord symbols you want to move.

2.

Move the chord symbols in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
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NOTE
If you want to move chord symbols by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.
●

Click and drag them in any direction to the positions you want.

Moving chord symbols graphically using the Properties panel
You can move chord symbols graphically using the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the chord symbols you want to move.

2.

Activate the Start offset property in the Chord Symbols group of the Properties panel.

3.

The Start offset property has X and Y value fields. Change the values in the value fields in
any of the following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The property moves chord symbols in the following ways:
●

Start offset X moves chord symbols horizontally: increasing the value moves them
to the right, decreasing the value moves them to the left.

●

Start offset Y moves chord symbols vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.

Deleting chord symbols
To delete a chord symbol or chord symbols:
PROCEDURE
1.

In Write mode, select the chord symbols you want to delete.

2.

Delete the chord symbols in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected chord symbols are deleted.

Changing enharmonic spelling of chord symbols
You can respell a chord symbol for a transposing instrument in a transposing layout by editing
the chord symbol as normal.
PROCEDURE
1.

In Write mode, select the chord symbol you want to respell.

2.

Press Return, or double-click on the chord symbol.

3.

The popover opens, with the existing short-hand for the chord symbol inside.

4.

Change the root name of the chord, but leave other details as they were, such as quality,
interval, or alterations.
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For example, change just the root of "D♭maj13" from D♭ to C♯.
RESULT
The spelling of the chord symbol is altered for all instruments with the same transposition.

Resetting the enharmonic spelling of chord symbols
You can remove an enharmonic spelling override for a chord symbol for the current instrument,
or all instruments, by editing the chord symbol as usual.
PROCEDURE
1.

In Write mode, select the chord symbol you want to respell.

2.

Press Return key, or double-click on the chord symbol to open the popover.
●

To remove the enharmonic spelling override for a chord symbol for the instrument
above which the popover appears, type Alt+S into the chord symbol popover.

●

To remove all enharmonic spelling overrides for a chord symbol for all instruments,
type Shift+Alt+S into the popover.

Choosing above which staves chord symbols appear
By default, chord symbols appear above the staves belonging to rhythm section instruments,
such as keyboards, guitars, and bass guitars.
You can control where chord symbols appear from the Players panel in Setup mode.
PROCEDURE
1.

Select a player in the Players panel in Setup mode.

2.

Right-click to access the Chord Symbols context menu.

3.

Choose from: Show For All Instruments, Show For Rhythm Section Instruments, or
Hide For All Instruments.
NOTE
Chord symbols may optionally be shown between the two staves of grand staff
instruments, such as piano, by setting the Position of chord symbols on grand staff
instruments option in the Position group on the Chord Symbols page in Engraving
Options.

Choosing in which layouts chord symbols appear
By default, chord symbols appear both in full score and part layouts for rhythm section
instruments.
If chord symbols are not set to appear for any instrument in the current layout, signposts are
shown above the top staff.
To change in which layouts chord symbols are shown:
PROCEDURE
1.

Select a player in the Players panel in Setup mode.

2.

Right-click to access the Chord Symbols context menu.
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3.

Choose from the following options:
●

Show in Full Score and Parts

●

Show in Full Score Only

●

Show in Parts Only

Project-wide Engraving Options for chord symbols
Options for the appearance and position of all chord symbols project-wide can be found on the
Chord Symbols page in Engraving Options.
The options on the Chord Symbols page allow you to change the appearance of different types
of chords, and their default positions.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Chord Symbols in the page list on the left of the dialog.

Chord symbol appearance presets
There are many conventions for the appearance of chord symbols, so Dorico provides a choice of
preset conventions that you can use and edit.
The presets are found at the top of the Chord Symbols page in Engraving Options.
Chord symbol preset example

Chord symbol preset name
Boston

Brandt-Roemer

Indiana

Jazz Standards

Nashville
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Chord symbol preset example

Chord symbol preset name
New York

Japanese

Default

Default uses a set of symbols intended to be as unambiguous as possible (for example, avoiding
the use of symbols for major seventh, augmented, diminished, and half-diminished). This is the
preset that is chosen by default in new projects.
The presets simply choose specific combinations of the options on the Chord Symbols page.
You can adjust these options to suit your preferences.

Changing chord symbol font
How to change the text font used for chord symbols.
PROCEDURE
1.

Choose Engrave > Font Styles.

2.

Change the settings for one or all of the following styles:
●

Chord Symbols Altered Bass Separator Font

●

Chord Symbols Font

●

Chord Symbols Music Text Font

TIP
When using the option to show the word “on” instead of a slash or line to separate a chord
from its altered bass note, you can edit the font used for that word by editing the Chord
Symbols Altered Bass Separator Font.
NOTE
It is not advised to edit the Chord Symbols Music Text Font, which is set to Bravura Text
by default. This can only be set to a SMuFL-compliant font intended for use in text-based
applications.

Playback of chord symbols
Chord symbols are played back as sustained chords, with their duration taken from the gap
between one chord symbol and the next.
If the chord symbol was input using a MIDI keyboard, the chord plays back using the voicing that
was used to input the chord symbol.
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PROCEDURE
1.

Expand the chord track at the top of the event display in Play mode.

2.

Choose the playback device (VST instrument or MIDI device) that should be used, and
choose the channel or slot containing the desired sound. You can load a new sound
manually if you wish.

3.

Activate the speaker icon to enable playback.

Importing chord symbols from MusicXML
Chord symbols are imported from MusicXML files. However, chords that specify Neapolitan,
Italian, French, German, Pedal, Tristan and Other values for the kind element are ignored during
import, as there is no information to specify what notes these chord symbols are meant to
describe.
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Cues are passages of music shown in instrumental parts that are played by a different
instrument, usually to help orientate players before entries or solos following a significant
passage of rests.
Cues are also sometimes used to assist with co-ordination or tuning between players, or to
indicate material that the player may be asked to double.
In Dorico, it is quick and easy to input correctly-formatted cues using the cues popover. Cues are
automatically input into a new voice, with bar rests shown alongside cues to make sure it is clear
that the player reading the cue should not play the cued music. Clefs are automatically input in
cues as required, including restorative clefs.

A cue in a violin part showing music from a Bassoon 1 part

Dorico is the only scoring program to include dynamic cues that are linked to the original source
material, meaning cues are updated in real-time if the source material changes.
RELATED LINKS
Individual changes to the appearance and position of cues on page 316

General placement and notation conventions for cues
Cues are usually notated using notes of a smaller size than normal notes, with the name of the
instrument being cued indicated clearly at the start of the passage.
It is generally accepted that full-sized rests are also shown above or below cues, in order to
reinforce that the player reading the cue should not play these notes.
Cues may exclude some notations that would be present in the part of the source instrument.
However, cues may include slurs, articulations, and dynamics, as these often help the player
reading the cue to identify passages.
Depending on the register of the instrument being cued and the tessitura of each cue passage,
clef changes may also be needed at the start of cues.

Inputting cues
Cues are input using the cues popover. You can open the cues popover in Write mode by
selecting the lyrics button in the Notations toolbox, or by pressing Shift-L
When you start entering the name of an instrument that exists in your project into the cues
popover, a menu appears that shows candidate instruments that you can choose from to show in
the cue.
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The cues popover with an example entry showing the menu of candidate instruments.

NOTE
The menu of candidate instruments excludes the instrument into which you are inputting the
cue, as you cannot cue an instrument with its own music.
Each staff of grand staff instruments is listed separately, for example, Piano (a) and Piano (b).
Each unpitched percussion instrument is listed separately. If you have a drum set in your project,
each constituent instrument from the drum set appears as a candidate for cueing. For example,
you could show just the kick drum in a cue.
NOTE
You cannot use entire percussion kits in cues.
NOTE
If you directly input a cue at the same position as an existing cue, the new cue overrides the
existing cue, which is deleted. However, you can have multiple cues at the same rhythmic
positions if you create them in separate bars and move them or lengthen or shorten them later.
To input cues:
PROCEDURE
1.

2.

3.

In Write mode, select one of the following in the staff in which you want the cue to appear:
●

A note or rest at the position you want the cue to start

●

Multiple notes or rests spanning the duration you want the cue to last

Open the cues popover in any of the following ways:
●

Press Shift-U

●

Click Insert Cue in the Cues panel

●

Choose Write > Create Cue

Enter the first few letters of the instrument whose music you want to show in the cue.
The candidate instrument menu appears below the popover.

4.

Select the instrument whose music you want to show in the cue in any of the following
ways:
●

Use Up Arrow and Down Arrow to highlight it in the menu, then press Return

●

Click it in the menu

●

Enter full name of the instrument into the cues popover yourself, then press Return
twice
NOTE
If you do not enter the name of an instrument that exists in your project, no cue is
created.
If multiple instruments of the same type exist in your project, music from the first
player is input as the cue. For example, if you have Violin I and Violin II in your
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project and enter violin into the cues popover, music from the Violin I staff is
shown in the cue.

RESULT
A cue is input in the selected staff, showing the music of the instrument selected in the cues
popover.
If you are inputting cues in a full score layout in page view, the cue appears as a signpost by
default, showing the name of the source instrument.
NOTE
You can choose to show cues in full score layouts. You can also see the music in the cue in the
corresponding part layout, as cues are shown in part layouts by default.

RELATED LINKS
Hiding and showing cues in layouts on page 322
Cue suggestions on page 307
Inputting cues using cue suggestions on page 309
Lengthening and shortening cues on page 313
Moving cues on page 312

The Cues panel
You can open the Cues panel by clicking its button in the Notations toolbox:

This panel can be hidden and shown in the following ways:
●

Click its disclosure arrow

●

Press Ctrl/Cmd-9

There are two sections in the Cues panel:
Insert Cue
Contains the Insert Cue button which you can click to open the cues popover with
the mouse.
Suggest Cues
Allows you to generate cue suggestions based on how long players have been
resting.
RELATED LINKS
Cue suggestions on page 307

Cue suggestions
The Suggest Cues section of the Cues panel can help you determine good locations for cues in
your project. Dorico can find places in the current flow where players in the current layout have
not played for a certain span of time, which is 30 seconds by default.
The Suggest Cues section of the Cues panel is divided into the following sections that together
help you find useful places to input cues:
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Resting for
Specify the duration of resting period for players after which you want to input cues.
The resting period is specified in absolute time rather than in bars or beats. This is
because meters and tempi can change many times throughout a flow, and music
may be partially or completely meterless, whereas one second always has the same
duration.
Specifying an absolute time ensures consistency in the approach to finding places
where cues may be appropriate.
Rehearsal marks
Choose to consider or ignore rehearsal marks when determining the resting period.
Rehearsal marks often coincide with new sections or other landmarks in the music,
which may be obvious to players without needing extra cues. By default, rehearsal
marks are ignored as they do not always act as signposts for the musical structure.
Cues
Choose to consider or ignore cues that already exist between notes played by the
destination player when determining the resting period.
A cue that occurs immediately before an entry in the destination instrument is
always ignored and is never included as a suggested location, even if you choose to
consider cues.
However, orientation cues which serve to help the player keep their place during
extended rests, but do not immediately precede an entry, reset the timer if you
choose to consider cues.
Update
Click the Update button to recalculate cue suggestions based on your Resting for
duration and inclusion choices for rehearsal marks and cues.
The names of the flow and layout that were active when you last updated the list
of cue suggestions are shown below the Update button. This allows you to see at a
glance to which flow and layout the suggestions shown in the table apply.
Cue suggestions table
The list of suggested cues is presented in a table. The table has three columns:
●

Instr.: the destination instrument that has been resting for more than your
minimum specified duration

●

Bar: the bar containing the first entry of the destination instrument after its
rest period

●

Sec.: the length of time in seconds the destination instrument has been
resting before the entry shown in the Bar column

You can click each column title to arrange the table according to the values in that
column:
●

Instr.: click to show instruments with suggested cues in the order in which
they appear in the score

●

Bar: click to show entries in ascending order, earlier bars down to later bars

●

Sec.: click to the show the length of resting period in descending order,
longest period down to shortest period

Click on rows in the cue suggestions table to navigate directly to that location. By
default, an area with an equivalent rhythmic duration to 5-10 seconds prior to the
entry in the destination instrument is highlighted in red. The highlighted area is not
a specific recommendation for cue length, but it may be a good indication depending
on the musical context.
If you create a cue at a location suggestions in the cue suggestions table, that
suggestion is automatically removed from the list.
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You can click Ignore in the action bar at the bottom of the table to hide suggestions
where you do not think a cue is appropriate.
NOTE
If you later click Update and regenerate the list, hidden suggestions may reappear.
Highlight suggestions
Highlighted areas before entries in source instruments are shown when this box is
checked, and are not shown when the box is unchecked.
Playing instruments list
Contains the instruments that are playing in the 5-10 seconds prior to the entry in
the destination instrument currently selected in the cue suggestion table, to help you
determine which instrument to use as the source instrument of cues.

Inputting cues using cue suggestions
You can use the Suggest Cues section of the Cues panel in Write mode to find suitable places to
input cues. You can then input cues using the cues popover.
PROCEDURE
1.

In Write mode, open the layout into which you want to find suitable locations for cues in
the music area.
For example, suitable locations for cues are suggested for all instruments when the
full score layout is open in the music area, but only suitable locations for individual
instruments are suggested when a single part layout is open.

2.

Click Cues in the Notations toolbox to open the Cues panel:

3.

Change the value for Resting for in the Suggest Cues section of the Cues panel to specify
the resting period after which you want to input cues in any of the following ways:

4.

5.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Choose one of the following options for Rehearsal marks:
●

Consider

●

Ignore

Choose one of the following options for Cues:
●

Consider

●

Ignore

6.

Click Update.

7.

Click rows in the cue suggestion table to navigate directly to that position in the layout so
you can check the context of the cue suggestion.
Cue suggestions are highlighted for the equivalent rhythmic duration of 5-10 seconds.
You can choose not to see highlighted areas by unchecking the box beside Highlight
suggestions.

8.

9.

Select one of the following in the staff in which you want the cue to appear:
●

A note or rest at the position you want the cue to start

●

Multiple notes or rests spanning the duration you want the cue to last

Open the cues popover in any of the following ways:
●

Press Shift-U
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10.

●

Click Insert Cue in the Cues panel

●

Choose Write > Create Cue

Enter the first few letters of the instrument whose music you want to show in the cue.
The candidate instrument menu appears below the popover. You can use the Playing
instruments list to help select an appropriate source instrument for your cue.

11.

Select the instrument whose music you want to show in the cue in any of the following
ways:
●

Use Up Arrow and Down Arrow to highlight it in the candidate instrument menu,
then press Return

●

Click it in the candidate instrument menu

●

Enter full name of the instrument into the cues popover yourself, then press Return
twice
NOTE
If you do not enter the name of an instrument that exists in your project, no cue is
created.
If multiple instruments of the same type exist in your project, music from the first
player is input as the cue. For example, if you have Violin I and Violin II in your
project and enter violin into the cues popover, music from the Violin I staff is
shown in the cue.

RESULT
A cue is input in the selected staff, showing the music of the instrument selected in the cues
popover.
If you are inputting cues in a full score layout in page view, the cue appears as a signpost by
default, showing the name of the source instrument.
NOTE
You can choose to show cues in full score layouts. You can also see the music in the cue in the
corresponding part layout, as cues are shown in part layouts by default.

RELATED LINKS
Cue suggestions on page 307
Lengthening and shortening cues on page 313
Moving cues on page 312

Changing existing cues to rhythmic cues
Sometimes it is necessary only to provide rhythms in cues. For example, for passages where
many instruments play the same distinctive rhythm together.
Rhythmic cues are positioned above the staff, with all notes from the source instrument shown at
the same nominal pitch. Rhythmic cues do not show clef changes, accidentals, or ledger lines.
NOTE
Cues containing music from unpitched percussion source instruments are automatically input as
rhythmic cues.
You can change existing cues showing pitched material into rhythmic cues.
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PROCEDURE
1.

Select the cues you want to change to rhythmic cues. You can do this in Write mode and
Engrave mode.

2.

Activate the Rhythmic cue property in the Cues group of the Properties panel.

RESULT
The selected cues become rhythmic cues.
They are automatically positioned above the staff according to your setting for the Distance
from space above staff in the Rhythmic Cues section of the Cues page in Engrave > Engraving
Options.
NOTE
You can change rhythmic cues, including cues from unpitched percussion instruments that are
automatically input as rhythmic cues, into normal cues at any time by deactivating the Rhythmic
cue property.

RELATED LINKS
Inputting cues on page 305
Changing the text shown in cue labels individually on page 318
Changing the distance between rhythmic cues and the staff individually on page 320

Changing the octave of cues from octave transposing
instruments
You can change the octave in which cues are shown. For example, if the source instrument plays
in a significant different octave to the destination instrument, you may want to shift the octave so
the cue fits better in the staff of the source instrument.
PROCEDURE
1.

Open the layout in which you want to change the octave of cues in the music area.

2.

Select the cues whose octave you want to change. You can do this in Write mode and
Engrave mode.

3.

Activate the Octave shift property in the Cues group of the Properties panel.

4.

Change the value in the value field to change the number of octaves by which you want to
shift the cue in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

For example, 1 shifts the cue up one octave, and -1 shifts the cue down one octave.
RESULT
The octave of the selected cues is changed, according to the number you entered.
NOTE
If octave transpositions are shown in the cue labels, they are automatically updated to reflect any
change in octave.
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EXAMPLE

Cue with no octave change

Cue shifted down one octave

Including or excluding octave transpositions in cue labels
individually
By default, octave transpositions are included in cue labels when you shift the octaves at which
cues are shown. You can choose to include or exclude octave transpositions in cue labels
individually, independently of your project-wide setting for octave transpositions in cue labels.
PROCEDURE
1.

Select the cue labels in which you want to include or exclude octave transpositions. You
can do this in Write mode and Engrave mode.

2.

Activate the Show octave transposition property in the Cues group of the Properties
panel.

3.

Check or uncheck the box beside the property.
●

Check boxes to include octave transpositions in the selected cues.

●

Uncheck boxes to exclude octave transpositions from the selected cues.

RESULT
Octave transpositions are included in or excluded from the cue labels of the selected cues.
NOTE
You can choose to include octave transpositions in, or exclude octave transpositions from, cue
labels for all cues project-wide on the Cues page in Engrave > Engraving Options.

RELATED LINKS
Changing the information included in cue labels project-wide on page 315

Moving cues
You can move cues to new rhythmic positions after they have been input. This changes the
material shown in cues to reflect the material at the corresponding rhythmic positions in the
source instrument.
PROCEDURE
1.

In Write mode, select the cues you want to move.

2.

Move the cues, while maintaining their total durations, in the following ways:
●

Press Alt-Right Arrow to move multiple cues to the right according to the current
rhythmic grid, and single cues to the right depending on the rhythm in the source
instrument.
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●

Press Alt-Left Arrow to move multiple cues to the left according to the current
rhythmic grid, and single cues to the left depending on the rhythm in the source
instrument.

●

Click and drag the cue to the right or to the left, according to the rhythm in the
source instrument.
NOTE
Only one cue can be moved at a time when using the mouse.

RESULT
If a single cue is selected, it is moved to the right or to the left, depending on the rhythm in the
source instrument.
If multiples cues are selected, they are moved to the right or to the left according to the rhythmic
grid currently set.
RELATED LINKS
Overlapping cues on page 323
Hiding and showing cues in layouts on page 322

Lengthening and shortening cues
You can change the lengths of cues after they have been input. This changes the material shown
in cues to reflect the material at the corresponding rhythmic positions in the source instrument.
PROCEDURE
1.

In Write mode, select the cues you want to lengthen or shorten.
NOTE
You can only lengthen or shorten one cue at a time with the mouse.

2.

Lengthen and shorten the cues in any of the following ways:
●

Press Shift-Alt-Right Arrow to lengthen them by the current rhythmic grid value.

●

Press Shift-Alt-Left Arrow to shorten them by the current rhythmic grid value.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to snap the end of a single cue to the next
notehead of the source instrument.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to snap the end of a single cue to the previous
notehead of the source instrument.

●

Click and drag the circular handle at the end of a single cue to show noteheads to
the right or to the left.
NOTE
You can only lengthen or shorten cues by the current rhythmic grid value when
multiple cues are selected.

RESULT
The selected cues are lengthened or shortened.
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NOTE
You can lengthen cues so that they overlap with other existing cues, as multiple cues can exist at
the same rhythmic positions. However, their stem directions are not automatically adjusted so
you may need to change the stem directions of cues manually.

RELATED LINKS
Overlapping cues on page 323
Overriding default stem directions in single-voice cues on page 324

Deleting cues
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The cues you want to delete.

●

The signposts of cues not shown in the current layout that you want to delete.

Delete the cues in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected cues are deleted from all the layouts containing the affected instruments. For
example, deleting a cue in a piano part also deletes the cue from the piano staff in the full score
layout.
NOTE
Deleting cues does not delete notes from the original instrument.

Project-wide Engraving Options for cues
Options for the appearance, content, and positions of cues project-wide can be found on the
Cues page in Engraving Options.
The options on the Cues page allow you to change the size, appearance, placement, and precise
position of cues. You can also decide which notations are included in all cues, set the default
spacing of cues, and set the default staff position of rhythmic cues and cues from unpitched
source instruments.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Cues in the page list on the left of the dialog.

314

Cues
Project-wide Engraving Options for cues

Changing the information included in cue labels project-wide
You can change the information included as text in cue labels project-wide. Cue labels usually
indicate the source instrument from which the music is taken.
By default, cue labels in Dorico use abbreviated instrument names, exclude instrument
transpositions (or instrument pitches), include octave transpositions, and do not show an
addition label at the end of cues to indicate where players enter after cues.
Additional labels showing “Play” at the ends of cues are sometimes used in jazz scores, where it
can be customary not to show bar rests alongside cues. Showing additional labels at the ends of
cues can also be useful in film music, where cues are often included in parts as an option that the
player may be asked to play.
You can change these settings for all cues project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Cues in the page list.

3.

Change any of the following options in the Cue Labels section:

4.

●

Instrument name in label: full name or abbreviated name

●

Instrument pitch or transposition: include or exclude

●

Octave transposition: include or exclude

●

Additional label at end of cue: show an additional label or show no additional label

Click Apply, then Close.

RESULT
NOTE
You can change cue labels individually. For example, if two instruments are playing in unison,
you can change the cue label containing the unison material from one of the instruments to
include both instrument names.

RELATED LINKS
Changing the text shown in cue labels individually on page 318

Changing the default note spacing values for cues project-wide
Cues are normally spaced more tightly than the normal-sized music in the destination
instrument. You can determine by how much the rhythmic spacing of cues is tightened in each
layout on the Note Spacing page in Layout Options.

PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Note Spacing from the Category menu.

3.

Select the layouts in you want to change the rhythmic spacing in cues in the Layouts list
on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.
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●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

Change the value for Scale space for cues note by to change the percentage value in any
of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

By default, ideal rhythmic spacing is scaled to 70% for cues.
5.

Click Apply, then Close.

RESULT
The scale by which the rhythmic spacing of cues is tightened as a percentage of the rhythmic
spacing for normal notes is changed.
TIP
You can change settings for other layouts before closing the dialog.

RELATED LINKS
Note spacing on page 171

Individual changes to the appearance and position of cues
You can change the appearance and positions of individual cues and cue labels in each layout
independently of other layouts and without changing the source material.
Music in cues is dynamically linked to the source instrument. Any changes you make to the
source music is automatically shown in the cue, but the music cannot be selected in the cue. This
is to ensure cues are an accurate reflection of the notes being played by the cued instrument.
It is possible to make graphical changes to music in cues without affecting the source
instrument. For example, you can adjust the placement of slurs, the angles of glissando lines, or
lengthen and shorten stems in cues.
NOTE
Graphical changes to cues are layout-specific, meaning that if you make changes to cues in
layouts containing the source instrument or other instruments with the same cue, any changes
you make to one cue may affect the source instrument and other instruments with the same cue.
It is also possible to change the enharmonic spelling of notes in cues in Engrave mode in the
same way as changing the enharmonic spelling of normal notes. Respelling notes in cues does
not affect the spelling of notes in the source instrument, if you respell notes in cues in the part
layout of the cue. For example, you may want to change the enharmonic spelling of notes in cues
in transposing instrument layouts to avoid double accidentals.
NOTE
If you change the enharmonic spelling of notes in cues in a layout that also contains the source
instrument, the enharmonic spelling is changed in the source instrument.
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RELATED LINKS
Respelling accidentals on page 193
Slurs in Engrave mode on page 575
Lengthening and shortening stems individually on page 600

Changing the notations included in cues individually
It is often beneficial to include in cues some notations from the source instrument, as they can
help players identify the cued music more easily. However, only certain notations are included in
cues to avoid overloading players with too much information.
By default, Dorico includes the following notations in cues:
●

Slurs

●

Articulations

●

Ornaments

●

Playing techniques

●

Lyrics (if you are cueing vocal music)

NOTE
Not all playing techniques are included in cues. Playing techniques that only indicate important
information for the source instrument, such as bowing marks for string players, are not included
in cues.
It is not currently possible to change which playing techniques can be included in cues, but this is
planned for future versions.
To be included in cues, playing techniques must exist within the range of the cued material.
For example, pizzicato markings are not shown in cues if they are input before the first cued
note. However, pizzicato strings sound significantly different to bowed strings, so this is useful
information to include in cues.
Similarly, slurs must begin and end within the cued material to be included in cues.
NOTE
You can change the text shown in cue labels individually, allowing you to add such information
manually.
To change the notations included in individual cues, independently of your project-wide settings:
PROCEDURE
1.

Select the cue labels of the cues whose included notations you want to change. You can do
this in Write mode and Engrave mode.

2.

Activate the corresponding properties for the notations that you want to include in, or
exclude from, the selected cues in the Cues group of the Properties panel:

3.

●

Show articulations

●

Show slurs

●

Show dynamics

●

Show lyrics

●

Show playing techniques

●

Show ornaments

●

Show text

Check or uncheck the boxes beside each property.
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●

Check boxes to include the corresponding notations in the selected cues.

●

Uncheck boxes to exclude the corresponding notations from the selected cues.

RESULT
The different notations are included in or excluded from the selected cues.
NOTE
You can change which notations are included in all cues project-wide on the Cues page in
Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for cues on page 314
Changing the text shown in cue labels individually on page 318

Changing the text shown in cue labels individually
You can override the text shown in cue labels individually. For example, if two instruments are
playing in unison, you can change the cue label containing the unison material from one of the
instruments to include both instrument names.
You can also show additional labels at the ends of individual cues, even if your project-wide
setting is to show no additional labels at the ends of cues.
PROCEDURE
1.

Select the cue labels whose text you want to override. You can do this in Write mode and
Engrave mode.

2.

Activate the following properties, individually or together, in the Cues group of the
Properties panel:

3.

●

Start text: change the label at the start of cues

●

End text: change the label at the ends of cues

Enter the text you want to be shown in the corresponding cue labels into each property
value field.
For example, to indicate that two violinists are playing the same material but an octave
apart, you might enter Vln.I & Vln.II coll’ottava in the value field for Start text.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The cue labels of the selected cues are changed to show the text you entered.
You can revert the cue labels of the selected cues to their default text at any time by deactivating
the corresponding property.
NOTE
Deactivating properties permanently deletes any custom text entered.

318

Cues
Individual changes to the appearance and position of cues

Changing the note spacing of cues from specific points in layouts
You can have different note spacing values for cues in each layout by adding a note spacing
change event at the rhythmic position from which you want the note spacing of cues to change.
PROCEDURE
1.

In Engrave mode, open the layout in which you want to change the note spacing in cues at
specific points in the music area.

2.

Open the Note Spacing Change dialog by choosing Engrave > Note Spacing Change.

3.

Activate Scale space for cues notes by.

4.

Choose Change.

5.

Change the value in the value field to change the percentage value in any of the following
ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

By default, ideal rhythmic spacing is scaled to 70% for cues.
6.

Click OK to close the dialog and save your changes.

RESULT
The scale by which the rhythmic spacing of cues is tightened as a percentage of the rhythmic
spacing for normal notes is changed.
TIP
You can change also use the Note Spacing Change dialog to reset changes to note spacing you
have previous made in the current layout: choose Reset instead of Change in step 4.

RELATED LINKS
Note spacing on page 171

Changing the staff position of cues from unpitched source
instruments individually
You can change the staff positions of cues from unpitched source instruments individually,
independently of your project-wide setting for the staff position of cues from unpitched source
instruments.
By default, cues from unpitched source instruments are positioned on the middle lines of staves.
PROCEDURE
1.

Select the cue label of the cues from unpitched source instruments whose staff position
you want to change. You can do this in Write mode and Engrave mode.

2.

Activate the Unpitched notes pos. property in the Cues group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The value in the value field corresponds to a staff position. For example:
●
●

0 is the middle line of the staff
4 is the top line of the staff
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●

-4 is the bottom line of the staff

RESULT
The staff position of the selected cues is changed.
NOTE
You can change the default staff position of all cues from unpitched source instruments projectwide on the Cues page in Engrave > Engraving Options.
EXAMPLE

Unpitched cue on the middle line of the staff
(default)

Unpitched cue at a higher staff position

RELATED LINKS
Project-wide Engraving Options for cues on page 314

Changing the distance between rhythmic cues and the staff
individually
You can change the distance between individual rhythmic cues and the staff, independently of
your project-wide setting for the position of rhythmic cues.
PROCEDURE
1.

Select the cue label of the rhythmic cues whose distance from the staff you want to
change. You can do this in Write mode and Engrave mode.

2.

Activate the Distance property in the Cues group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The value in the value field corresponds to a position above the top line of the staff. For
example, entering 0 positions rhythmic cues in the space immediately above the top line in
the staff. Higher values increase the distance between rhythmic cues and the staff.

RESULT
The position of the selected cues is changed.
NOTE
You can change the default distance between all rhythmic cues and the top line of the staff
project-wide on the Cues page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for cues on page 314
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Changing the placement of cue labels relative to the staff
individually
You can change the placement of individual cue labels relative to the staff, independently of your
project-wide setting for cue label placement.
PROCEDURE
1.

Select the cue labels whose placement relative to the staff you want to change. You can do
this in Write mode and Engrave mode.

2.

Activate the Placement property in the Cues group of the Properties panel.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The placement of the selected cue labels relative to the staff is changed.
NOTE
You can revert the placement of the selected cue labels to your project-wide setting for cue label
placement at any time by deactivating the Placement property.
You can change the default placement relative to the staff for all cue labels project-wide on the
Cues page in Engrave > Engraving Options.

Moving cue labels graphically
You can change the graphical positions of cue labels individually.
PROCEDURE
1.

In Engrave mode, select the cue labels you want to move.

2.

Move the cue labels in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move cue labels by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction to the positions you want.

RESULT
The selected cue labels are moved to new graphical positions.

Moving cue labels graphically using the Properties panel
PROCEDURE
1.

In Engrave mode, select the cue labels you want to move.

2.

Activate the Offset property in the Cues group of the Properties panel.
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3.

4.

The Offset property has X and Y value fields. Change the values in the value fields in any
of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The property moves cue labels in the following ways:
●

Offset X moves cue labels horizontally: increasing the value moves them to the
right, decreasing the value moves them to the left.

●

Offset Y moves cue labels vertically: increasing the value moves them upwards,
decreasing the value moves them downwards.

RESULT
The selected cue labels are moved to new graphical positions.

Hiding and showing cues in layouts
You can input cues in any layout, but by default cues do not appear in full score layouts, as most
cues are only shown in instrumental parts. Cues signposts are shown in full score layouts by
default in page view.
If you are using galley view, the cued music appears in addition to cue signposts.
You can choose to hide or show cues in each layout in your project.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Players from the Category menu.

3.

Select the layouts in which you want to hide or show cues in the Layouts list on the left of
the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

Check or uncheck the box beside Show cues in the Cues section.
●

Check the box to show cues in the selected layouts

●

Uncheck the box to hide cues in the selected layouts

RESULT
All cues in the selected layouts are shown or hidden.
If cues are hidden, signposts are shown where they begin.

322

Cues
Overlapping cues
NOTE
You can hide individual cues in layouts where cues are shown, but you cannot show individual
cues in layouts where cues are hidden.

Hiding cues individually
You can hide individual cues in layouts in which you have chosen to show cues. For example,
if the music of a single player appears in multiple part layouts, you may want to hide cues in
certain layouts.
PROCEDURE
1.

Open the layout in which you want to hide individual cues in the music area.

2.

Select the cues you want to hide. You can do this in Write mode and Engrave mode.

3.

Activate the Hide property in the Cues group of the Properties panel.

RESULT
The selected cues are hidden.

Overlapping cues
Sometimes it is helpful to give players multiple consecutive cues so they can follow passages of
music more easily. Dorico allows cues to overlap in order to give you flexibility over how to give
useful information in cues to players.
However, the stem directions of cues are not automatically adjusted when they exist at the same
rhythmic position as other cues.
For example, if you want to show a melody passing from violin 1 to violin 2 and the cues for both
instruments are shown in up-stem voices by default, they both appear with up-stem notes.
You can override the default stem directions of cues individually to make overlapping cues easier
to read.

Default stem directions

The stem direction of the cue with lower notes has
been changed.

RELATED LINKS
Overriding default stem directions in single-voice cues on page 324

Stem directions in cues
Notes in cues normally have the same stem direction, as cues usually highlight lines containing
only one voice, and because cues shown by default with bar rests alongside them to indicate that
the player reading the cue should not play those notes.
However, if cues contain music in multiple voices, the original stem directions of the source
music are used instead.
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For single-voice cues, Dorico determines the default stem direction depending on the pitches in
the cue:
●

Most notes in the cue at positions below the middle line of the staff: stems point
downwards

●

Most notes in the cue at positions above the middle line of the staff: stems point upwards

RELATED LINKS
Overriding default stem directions in single-voice cues on page 324

Overriding default stem directions in single-voice cues
You can override the default stem directions of single-voice cues individually.
PROCEDURE
1.

Open the layout in which you want to override the default stem direction in cues in the
music area.

2.

Select the cue labels or cue signposts of the cues whose stem direction you want to
change. You can do this in Write mode and Engrave mode.

3.

Activate the Voice direction property in the Cues group of the Properties panel.

4.

Choose one of the following options:
●

Force stems up

●

Force stems down

RESULT
The stem direction of all notes in the selected cues is changed.
NOTE
You can revert the selected cues back to their default stem direction at any time by deactivating
the Voice direction property.

Ties starting before and ending after cues
If cues begin in the middle of sustained notes, ties are shown joining to the first note in cues.
Similarly, if cues end in the middle of sustained notes, ties are shown proceeding from the final
notes in cues.
For monophonic instruments, these ties are normally well-positioned by default. However, in
complex cases, such as cues involving chords, you may find that the positions of these ties may
require some adjustment.
Ties into and out of cues can all be edited in the same way as normal ties in Engrave mode.
RELATED LINKS
Changing the position and shape of ties individually on page 645
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Rests in cues
Rests are automatically shown within cues to show the total duration of bars. Full-sized bar rests
are also automatically shown either above or below cues to make it clear that notes in cues
should not be played.
If cues start or end in the middle of bars, they are padded with appropriate cue-sized rests up
to bar boundaries or up to the next played entry, whichever comes first. This ensures it is clear
to the player how the rhythm of the cue fits within the current time signature and in relation to
their existing material.
By default, full-sized bar rests also appear throughout cued passages. This makes it clear that the
performer should not play the cued notes.
You can choose to not to show bar rests alongside cues. For example, it may be appropriate not
to show bar rests during cues in some jazz scores, or in scores where the cues are provided as
potential passages for doubling.
Full-sized bar rests are automatically positioned appropriate to the stem direction of the notes in
the cue:
●

If cues use up-stem notes, bar rests are positioned below cued notes

●

If cues use down-stem notes, bar rests are positioned above the cued notes

NOTE
You can adjust the vertical position of full-sized bar rests individually using the Rest pos.
property in the Notes and Rests group of the Properties panel.

RELATED LINKS
Hiding and showing padding rests in cues on page 325
Hiding and showing bar rests in cues on page 326
Changing the vertical position of rests individually on page 563

Hiding and showing padding rests in cues
You can choose to hide or show padding rests around individual cues.
PROCEDURE
1.

Select the cue labels or cue signposts of the cues whose padding rests you want to hide or
show. You can do this in Write mode and Engrave mode.

2.

Activate the Hide rests around cue property in the Cues group of the Properties panel.

RESULT
Padding rests around the selected cues are hidden when the Hide rests around cue property is
activated.
NOTE
You can show padding rests around the selected cues again at any time by deactivating the Hide
rests around cue property.
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Hiding and showing bar rests in cues
You can choose to hide or show bar rests alongside all cues in each flow in your project.
PROCEDURE
1.

In Write mode, choose Write > Notation Options.

2.

Select Rests from the Category menu.

3.

Select the flows in which you want to hide or show bar rests in cues in the list on the left of
the dialog in the following ways:
●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

●

Click Select All.

By default, only the current flow is selected when you open the dialog.
4.

5.

Choose one of the following options for Bar rests in cues:
●

Show bar rests

●

Omit bar rests

Click Apply, then Close.

RESULT
Bar rests alongside cues are hidden or shown in all layouts in the selected flows in your project.
RELATED LINKS
Changing the vertical position of rests individually on page 563

Clef changes in cues
If the music for the source instrument is written in a different clef than is used by the destination
instrument, Dorico automatically inputs a clef change at the start of cues, and a restorative clef
change at the ends of cues.
This changes the clefs at the start of cues to the same clef used by the source instrument, and
changes the clef back to the clef used by the destination instrument at the end of the cue.
Clef changes at the start of cues are positioned differently to normal clef changes:
Cues starting at the beginning of bars
Clef changes appear to the right of barlines.
(Restorative clef changes at the ends of cues are positioned like normal clef
changes.)
Cues crossing system breaks
Original clefs of destination parts are shown in their usual positions at the start of
new systems.
Clefs required for cues appear immediately before the first note of the new system,
to the right of key signatures and time signatures
When multiple cues abut, clef changes are created as needed:
●

If two abutting cues use the same clef that is different than the clef in force on the
destination instrument, a single clef change appears at the start of the first cue, with a
restorative clef at the end of the second cue.

●

If cues overlap, and the second cue requires a different clef than the first, Dorico creates a
clef change at the start of the second cue.
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●

If two cues abut and the first cue uses a different clef than the destination instrument, and
the clef property for the second cue is set to None, then the clef change that restores the
destination instrument’s original clef appears at the end of the first cue.

You can override this automatic behavior for individual clefs. Dorico can show the following clefs
in cues:
●

Treble G clef

●

Bass F clef

●

Alto C clef

●

Tenor C clef

●

None

NOTE
If you select None, the clef of the destination instrument is used instead of the clef of the source
instrument.
Any clef changes that occur in the source instrument in the middle of cued passages are not
included in the cue on the destination instrument.

Changing the clef shown in individual cues
You can change the clefs shown in individual cues, independently of your project-wide settings
for clefs in cues on the Cues page in Engraving Options.
You can change the clef shown in each cue in each layout in which it appears. For example,
you can show a cue with a treble clef in the full score layout but with a bass F clef in the
corresponding part layout.
PROCEDURE
1.

Open the layout in which you want to change the clefs shown in cues in the music area.

2.

Select the cues whose clef you want to change. You can do this in Write mode and Engrave
mode.

3.

Activate one of the following properties in the Cues group of the Properties panel:

4.

●

Concert clef: shown in layouts using concert pitch

●

Transposed clef: shown in layouts using transposed pitch

Select one of the following clefs from the menu:
●

Treble G clef

●

Bass F clef

●

Alto C clef

●

Tenor C clef

●

None

The same clefs are available for each property.
RESULT
The clef shown in the selected cues is changed, according to your selection.
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Viewing options for cues
You can highlight cues and show cued material in a different color to normal notes in your
project to help you identify cues as you are working.
Choosing View > Highlight Cues shows bars containing cues with a translucent yellow highlight
behind them, and a translucent blue highlight behind the bars that are used as the sources for
cues.
As you zoom out, the highlights become more opaque, allowing you to get an overview both
of where cues have already been added, and which instruments are being used as cues. This is
especially useful when viewing the full score layout in galley view.
Choosing View > Note and Rest Colors > Cues shows cued material in gray, to remind you that
this material cannot be edited directly.
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Dynamics indicate the loudness of the music, and can be combined with other instructions to
give the performer a detailed understanding of how the music should be performed, while
leaving a lot of room for interpretation.
For example,  espressivo indicates that a passage should be played loudly but also with
expressive feeling.

While almost all expression text is written in italics, dynamics such as  and  use a bold italic
font.

Types of dynamics
Dorico categorizes dynamics into four groups.

Immediate dynamics
Immediate dynamics apply to the note to which they are attached until the next dynamic
marking, and indicate an immediate change from any previous dynamic. Immediate dynamics
include dynamic symbols, such as  or , and qualifying text, such as subito or molto.

Gradual dynamics and hairpins

Gradual dynamics are often shown as hairpins but can also be shown as cresc., cre-scen-do, dim.,
di-mi-nuen-do, and so on. They can have qualifying text, such as poco, molto, poco a poco, and
niente.
In Dorico, a hairpin can be shown as messa di voce, which shows a pair of hairpins. In some cases,
this is easier than having separate lines for each half of the pair.

Force/Intensity of attack

These dynamics, for example  and , indicate a note should have a stronger attack than is
usually expected for the dynamic, similar to an accent articulation.

Combined dynamics

Combined dynamics, such as  or –, specify a sudden change of dynamic.

Dorico has a combined dynamic maker, where you can create custom combined dynamics and
control the intensity of each dynamic in the pair. For example, you can make dynamics such as
, –, and .
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General placement conventions for dynamics
Dynamics are placed below the staff for instruments, where they can be read alongside the
notes, and above the staff for voices. This way, they do not clash with lyrics placed below the
staff, and are still close enough to the notes that they can be read simultaneously.

Immediate dynamics, such as  or , are centered on the notehead to which they apply. The
beginnings of gradual dynamics are centered on the notehead from which they begin, or
immediately after an immediate dynamic at the same position. The ends of gradual dynamics are
centered on the notehead at which they end, or immediately before an immediate dynamic at
the same position.
In Dorico, dynamics are positioned automatically relative to noteheads. You can change projectwide settings for how dynamics appear on the Dynamics page in Engraving Options, and you
can move individual dynamics graphically in Engrave mode.
RELATED LINKS
Project-wide Engraving Options for dynamics on page 356
Positions of dynamics on page 343
Moving dynamics graphically on page 345
Moving dynamics graphically using the Properties panel on page 346

General placement conventions for hairpins relative to barlines
In Dorico, the ends of hairpins align with the left edge of the note at the end of the hairpin.
Hairpins that end on the first note of a bar can extend across the preceding barline in certain
cases.
●

If there is not an immediate dynamic on the first note in the next bar.

●

If there is a time signature or key signature change at the barline which increases the gap
between the end of the current bar, and the first note in the new bar.

Dorico avoids hairpins overlapping barlines by a small amount, as this generally looks poor.
However, this may mean that the same dynamic phrase on two different staves appears
differently if one of the staves does not have the barline extending below it.

The ends of the two hairpins are not aligned despite their duration being identical as the lower is on the
bottom staff of the system.

RELATED LINKS
Changing the project-wide position of hairpins relative to barlines on page 330

Changing the project-wide position of hairpins relative to barlines
You can change whether all hairpins cross barlines when they end on the first note in the next
bar project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.
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2.

Click Dynamics in the page list.

3.

Disclose Advanced Options in the Gradual Dynamics section.

4.

Choose one of the following options for Hairpins ending at beginning of note at start of
bar:

5.

●

Do not cross barline

●

Allow to cross barline

Click Apply, then Close.

Inputting dynamics with the keyboard
You can input dynamics with the keyboard by using the dynamics popover.
You can open the dynamics popover in Write mode in the following ways:
●

Press Shift-D.

●

Choose Write > Create Dynamic.

You can enter any dynamic into the popover, during step input and later on. However, gradual
dynamics ending or starting niente cannot be input using the popover. They can only be input
using options in the Dynamics panel.
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The dynamics popover with an example entry for
dynamics

The dynamics button in the Notations toolbox

RELATED LINKS
Inputting niente hairpins on page 337
Adding expressive text to existing dynamics on page 338
Inputting voice-specific dynamics with the keyboard on page 341

The dynamics popover
The table shows some examples of what to enter into the dynamics popover and the dynamics
that are input into the music as a result.
You can open the dynamics popover in Write mode in the following ways:
●

Press Shift-D.

●

Choose Write > Create Dynamic.

Enter:

For dynamic or expression:
pianissimo: 

pp

piano: 

p

mezzo piano: 

mp

mezzo forte: 

mf
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Enter:

For dynamic or expression:
forte: 

f

fortissimo: 

ff

subito

subito or sub or sub.
possibile or poss or poss.

possibile

poco

poco

molto

molto

più or piu

più

meno

meno

mosso

mosso

crescendo: 

<

cresc. (text)

cresc

diminuendo: 

>

dim. (text)

dim

crescendo then diminuendo messa di voce:


<>

diminuendo then crescendo: 

><

sforzando: 

sfz

rinforzando: 

rfz

This list is not comprehensive and is only intended to illustrate how you can structure your entry
to input different types of dynamics.
TIP
Crescendo and diminuendo hairpins can be input directly into the score without the popover by
pressing Shift-, and Shift-..
The appearance of gradual dynamics can be changed project-wide in Engraving Options, or
individually by activating the Gradual style property in the Dynamics group of the Properties
panel, and selecting one of the available options.

Inputting expressive text into the dynamics popover
You can enter other expressions into the dynamics popover, such as espressivo or dolce, and
they appear in the correct italic font beside the dynamic.
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However, you must also enter an accompanying immediate dynamic, such as p or f, which you
can hide later.
RELATED LINKS
Inputting expressive text with the keyboard on page 334
Inputting niente hairpins on page 337
Hiding immediate dynamics on page 355
Changing the appearance of gradual dynamics individually on page 351

Inputting dynamics during step input with the keyboard
You can input dynamics during step input with the keyboard.
PROCEDURE
1.

In Write mode, start note input.

2.

Open the dynamics popover in any of the following ways:
●

Press Shift-D.

●

Choose Write > Create Dynamic.

3.

Enter the dynamic you want into the popover. For example, p, ff, or <f.

4.

Press Return to close the popover.

5.

Optional: if you enter an open-ended dynamic into the popover, such as p<, the hairpin
extends as you continue inputting notes, or if you advance the caret using Space or the
arrow keys.

6.

Stop the hairpin by opening the popover again and entering another immediate dynamic.
For example, f.

7.

Press Return to close the popover.

RESULT
The dynamic is input at the caret position.
NOTE
If you included hairpins or multiple dynamics in your popover, such as p<f>p, each dynamic and
hairpin lasts a quarter note (crotchet) by default. You can edit this duration using the handles on
each part of the dynamic phrase.

RELATED LINKS
Lengthening and shortening gradual dynamics and groups of dynamics on page 339
Inputting voice-specific dynamics with the keyboard on page 341

Adding dynamics to an existing note with the keyboard
PROCEDURE
1.

In Write mode, select the note to which you want to add a dynamic.

2.

Open the dynamics popover in any of the following ways:
●

Press Shift-D.

●

Choose Write > Create Dynamic.

3.

Enter the dynamics you want into the popover, such as p, mp, or molto f<.

4.

Press Return to close the popover.
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RESULT
The dynamic is added to the selected note.

Adding dynamics across multiple existing notes with the keyboard
PROCEDURE
1.

In Write mode, select the notes across which you want to add dynamics.

2.

Open the dynamics popover in any of the following ways:
●

Press Shift-D.

●

Choose Write > Create Dynamic.

3.

Enter the dynamics you want to use for the selection into the popover, for example, p<f>p.

4.

Press Return to close the popover.

RESULT
The dynamic phrase is evenly spread across your selected notes.
You can edit where each element is placed more precisely by clicking and dragging an individual
dynamic, or with a keyboard by ungrouping them and moving each dynamic individually. You can
later regroup them if you wish.
RELATED LINKS
Ungrouping dynamics and removing dynamics from groups on page 348
Grouping dynamics together on page 348
Moving dynamics rhythmically on page 345

Inputting expressive text with the keyboard
Expressive text adds further detail to a dynamic than simply its volume level, and can help guide
how a player performs a note or phrase.
In Dorico, expressive text, such as poco, molto, or subito, has to accompany an immediate
dynamic level, such as  or . Expressive text cannot be input on its own.
You can input expressive text with the keyboard by using the dynamics popover.
PROCEDURE
1.

In Write mode, select the note to which you want to add a dynamic with expressive text.

2.

Open the dynamics popover in any of the following ways:
●

Press Shift-D.

●

Choose Write > Create Dynamic.

3.

Enter your preferred dynamic and expressive text into the popover, separated by a space.
For example, f molto or p espressivo.

4.

Press Return to close the popover.

RESULT
The dynamic with expressive text is input.
NOTE
Some expressive text, such as molto, appears before immediate dynamics rather than after them,
even if you do not enter them in that order. This follows the generally accepted practice for
expressive text placement.
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You can hide immediate dynamics later if you only want to show expressive text.

RELATED LINKS
Inputting niente hairpins on page 337
Hiding immediate dynamics on page 355

Inputting dynamics with the mouse
Dynamics can be input with the mouse using the Dynamics panel.
The Dynamics panel is opened by clicking Dynamics in the Notations toolbox:

There are four sections in the Dynamics panel:
1
2
3
4

Immediate Dynamics: dynamics such as , , molto, and possibile.
Gradual Dynamics: dynamics such as , , molto, and poco.
Force/Intensity of Attack: dynamics such as  and .

Combined Dynamics: create your own combinations, such as .

RELATED LINKS
Inputting voice-specific dynamics with the mouse on page 342

Inputting dynamics during step input with the mouse
You can input dynamics during step input with the mouse.
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where you want to input the dynamic.

3.

Click Dynamics in the Notations toolbox to open the Dynamics panel:

4.

Click the dynamic you want in the Dynamics panel on the right of the window.
NOTE
Gradual dynamics are input with a default duration of a quarter note. You can change the
length of gradual dynamics later.
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RESULT
The selected dynamic is added at the caret position.
RELATED LINKS
Lengthening and shortening gradual dynamics and groups of dynamics on page 339
Inputting voice-specific dynamics with the mouse on page 342

Adding dynamics to an existing note with the mouse
You can add dynamics to an existing note.
NOTE
If you have set your preference for mouse input to Load cursor with item, complete the tasks in
this order: 2, 3, 1.

PROCEDURE
1.

In Write mode, select the note to which you want to add dynamics.

2.

Click Dynamics in the Notations toolbox to open the Dynamics panel:

3.

Click the dynamics you want.

RESULT
The dynamics you click are added to the selected note.

Adding gradual dynamics to existing notes with the mouse
You can add gradual dynamics to existing notes.
NOTE
If you have set your preference for mouse input to Load item at cursor, gradual dynamics are
only added to the single note on which you click. You then need to drag it longer if you want it to
appear across multiple notes.

PROCEDURE
1.

In Write mode, select the notes to which you want to add dynamics.

2.

Click Dynamics in the Notations toolbox to open the Dynamics panel:

3.

Click the gradual dynamic you want in the Immediate Dynamics section.
Alternatively, with nothing selected in the music area, click the gradual dynamic you want
in the Dynamics panel. Then click and drag to input the gradual dynamic and extend it to
the length you want.

RESULT
The gradual dynamic is added across the selection.
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TIP
You can also add a gradual dynamic to an individual note within the phrase to which you want to
add it, and drag it to your preferred length using the circular handles at each end.

RELATED LINKS
Lengthening and shortening gradual dynamics and groups of dynamics on page 339

Inputting expressive text with the mouse
Expressive text adds further detail to a dynamic than simply its volume level, and can help guide
how a player performs a note or phrase.
In Dorico, expressive text, such as poco, molto, or subito, has to accompany a dynamic level, such
as  or . Expressive text cannot be input on its own.
NOTE

If your preference is set to Load cursor with item, start at step 2. Then click on the note to which
you want to add a dynamic with expressive text.

PROCEDURE
1.

In Write mode, select the note to which you want to add a dynamic with expressive text.

2.

Click the dynamic level you want in the Immediate Dynamics section of the Dynamics
panel.
Do not deselect the dynamic.

3.

Click the expressive text or texts you want in the same Immediate Dynamics section of
the Dynamics panel.

RESULT
The dynamic with expressive text is input.
NOTE
Some expressive text, such as molto, appears in the score before the dynamic rather than after it.
This follows the generally accepted practice for expressive text placement.

Inputting niente hairpins
Adding niente markings at the start or end of a gradual dynamic indicates that the dynamic
should either increase from, or decrease to, silence.
This effect works very well on strings and singers with vowels, but it is not always possible for this
to be played literally, such as for singers on a word beginning with a consonant, and for reed and
brass instruments who have to achieve a certain air pressure before a note sounds.
Niente markings can be shown in two ways: as a circle at the end of a hairpin, and as text directly
before or after a hairpin. Both are possible in Dorico.
NOTE
You cannot input niente hairpins using the dynamics popover.
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NOTE
If your preference is set to Load cursor with item, start at step 2. Then click the note to which
you want to add the niente hairpin. The niente hairpin is input as a quarter note in duration, but
you can lengthen or shorten it later.

PROCEDURE
1.

In Write mode, select the notes across which you want to input the niente hairpin.

2.

Click the hairpin you want in the Gradual Dynamics section of the Dynamics panel.
Do not deselect the dynamic.

3.

Click niente in the same Gradual Dynamics section.

RESULT
The dynamic is input with a niente marking.
EXAMPLE

A niente shown as Circle on hairpin

A niente shown as Text

RELATED LINKS
Changing the appearance of niente hairpins on page 354
Lengthening and shortening gradual dynamics and groups of dynamics on page 339

Adding expressive text to existing dynamics
You can add expressive text to existing dynamics.
PROCEDURE
1.

Select the dynamics to which you want to add expressive text. You can do this in Write
mode and Engrave mode.

2.

Activate one of the following properties in the Dynamics group of the Properties panel:
●

Prefix: adds expressive text before the existing dynamic.

●

Suffix: adds expressive text after the existing dynamic.

3.

Enter the expressive text you want to add into the value field.

4.

Save your text in any of the following ways:
●

Press Return.

●

Click outside of the value field.

RESULT
The text you entered is added to the selected dynamics as expressive text.
You can remove any added expressive text later by deactivating the corresponding property.
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NOTE
Deactivating expressive text properties cannot be undone. Any text previously entered into the
value field is deleted, and must be re-entered later if required.

RELATED LINKS
Inputting niente hairpins on page 337

Changing dynamics during step input
You can make changes to existing dynamics during step input.
PROCEDURE
1.

2.

Reposition the caret so it is immediately to the left of the dynamic you want to change. You
can do this in any of the following ways:
●

Use the arrow keys on the keyboard.

●

Double-click the note to the left of the dynamic you want to change.

●

Select the note to the left of the dynamic you want to change and press Return.

Replace it with the new dynamic you want in any of the following ways:
●

Click the dynamic you want in the Dynamics panel.

●

Open the dynamics popover by pressing Shift-D, and enter the dynamic you want
into the popover.

Lengthening and shortening gradual dynamics and groups
of dynamics
You can change the length of gradual dynamics and groups of dynamics after they have been
input.
PROCEDURE
1.

In Write mode, select the gradual dynamics or groups of dynamics you want to lengthen
or shorten.

2.

Lengthen or shorten the gradual dynamics or groups of dynamics in any of the following
ways:
●

Press Shift-Alt-Right Arrow to lengthen dynamics by the current rhythmic grid
value.

●

Press Shift-Alt-Left Arrow to shorten dynamics by the current rhythmic grid value.

●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to snap the ends of dynamics to the next
rhythmic position.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to snap the ends of dynamics to the previous
rhythmic position.

●

Click and drag the circular handle at each end of the gradual dynamic or group of
dynamics.
NOTE
You can only lengthen or shorten one gradual dynamic or group of dynamics at a
time when using the mouse.
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RESULT
The phrase is lengthened or shortened proportionally, by lengthening or shortening the gradual
dynamics and moving any other type of dynamic. This retains the relative durations of the
gradual dynamics in the group
All key commands change the length of gradual dynamics or groups of dynamics by changing
the position of the end. The start position is not changed.

In the below examples, the  at the end moves two quarter notes to the right, but the  in the
middle only moves one quarter note to the right. This keeps the lengths of the gradual dynamics
equal.
EXAMPLE

Lengthened dynamic phrase

Original dynamic phrase

RELATED LINKS
Positions of dynamics on page 343
Ungrouping dynamics and removing dynamics from groups on page 348

Placement of dynamics
Default settings for the placement of dynamics in Dorico were designed to ensure that dynamics
are clear and legible.
You can make changes to your project-wide settings for the placement of dynamics on the
Dynamics page in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for dynamics on page 356

Placement of dynamics relative to the staff
The placement of dynamics relative to the staff varies, depending on their function. The are
different settings for instrumental staves, vocal staves, and grand staff instruments.
In general, dynamics should not be placed within the staff, as hairpins in particular become very
hard to read. They should also not be placed within tuplet brackets.
For instrumental staves, dynamics are placed below the staff.
For vocal staves, dynamics are placed above the staff so they do not conflict with lyrics below the
staff.
For grand staff instruments, such as piano or harp, dynamics are usually placed between the two
staves, but can be placed both above and below when each staff requires separate dynamics.

Changing the placement of dynamics relative to the staff
By default, dynamics are placed below the staff for instruments and above the staff for voices.
There may be circumstances when you need to change the placement of individual dynamics
relative to the staff, for example, if you want to have dynamics above and below the staff for
instruments in multiple voices.
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PROCEDURE
1.

Select the dynamics whose placement relative to the staff you want to change. You can do
this in Write mode and Engrave mode.

2.

Activate the Placement property in the Dynamics group of the Properties panel.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The placement of the selected dynamics is changed according to your selection.

Showing dynamics for each voice on a staff
You can input different dynamics into each voice independently when there are multiple voices
on the staff.
This allows you to show different dynamics for multiple voices on a staff, or to highlight an inner
melody voice in a piano texture
During step input, voice-specific dynamics are added to the voice indicated by the stem direction
shown beside the caret.
By default, dynamics apply to all voices on a staff if input without using the Alt key. If you want
each voice to have their own dynamic in playback as well as in the score, use the Alt key when
inputting dynamics for every voice on a staff.

Inputting voice-specific dynamics with the keyboard
You can input dynamics that are voice-specific with the keyboard.
PROCEDURE
1.

In Write mode, select the note to which you want to add a voice-specific dynamic.

2.

Open the dynamics popover in any of the following ways:
●

Press Shift-D.

●

Choose Write > Create Dynamic.

3.

Enter the dynamics you want, with any dynamic modifiers if desired, into the popover.

4.

Hold down Alt while pressing the Return key to close the popover.
The dynamics appear below the staff by default.

5.

Place the dynamic for the upper voice above the staff by selecting it and activating the
Placement property in the Dynamics group of the Properties panel.

6.

Choose one of the following options:
●

Above

●

Below

RESULT
The dynamics specified are input into the selected voice only. They are placed below the staff by
default, even if they are input into an up-stem voice.
You can change the placement of individual dynamics relative to the staff.
RELATED LINKS
Changing the placement of dynamics relative to the staff on page 340
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Inputting voice-specific dynamics with the mouse
You can input dynamics that are voice-specific with the mouse.
NOTE
If you have set your preference for mouse input to Load cursor with item, complete the tasks in
this order: 2, 3, 1.

PROCEDURE
1.

In Write mode, select the note to which you want to add a voice-specific dynamic.

2.

Hold down Alt.

3.

Click the dynamics you want in the Dynamics panel on the right of the window.

4.

Optional: click any dynamic modifiers you want in the Dynamics panel. You do not have to
hold down Alt to add dynamic modifiers.

Once you have input the dynamic level, such as , you can release Alt.

RESULT
The dynamics specified are input into the selected voice only. They are placed below the staff by
default, even if they are input into an up-stem voice.
You can change the placement of individual dynamics relative to the staff later.
RELATED LINKS
Changing the placement of dynamics relative to the staff on page 340

Spacing for gradual dynamics
To ensure that hairpins can always be clearly distinguished, Dorico by default gives hairpins a
minimum length of three spaces.
When hairpins are shorter than this, they can sometimes be confused with the accent articulation
mark. Therefore, if you add a hairpin to a note which would make the hairpin less than three
spaces long, the rhythmic spacing of the note is changed to ensure the hairpin meets this
minimum length.
You can change the project-wide settings for the minimum length of hairpins in Engrave >
Engraving Options, by disclosing Advanced Options under the Hairpins heading of the
Gradual Dynamics section of the Dynamics page.

Adjusting the spacing of gradual dynamics not attached to a notehead
If the start or end of a hairpin is not attached to a note, such as in the example, a messa di voce
pair of hairpins is created with two separate hairpins, rather than the combined option. Neither
of the open ends of the hairpins is attached to a specific notehead.

For example, if you wanted the dynamics peak of this example earlier in the middle bar, but not
at the notehead, you can change the rhythmic position of the open end of each hairpin. You
can use the following key commands to move the hairpin according to the rhythmic grid in the
bottom left of the window:
●

Ctrl/Cmd-Alt-Left Arrow
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●

Ctrl/Cmd-Alt-Right Arrow

NOTE
These key commands move the whole hairpin, not just one end.
You can adjust how hairpins appear distributed in a bar by activating Note Spacing on the left
of the window in Engrave mode. This causes dashed lines representing spacing columns, and
handles for each spacing-significant item, to appear.
NOTE
Adjusting note spacing affects the spacing in that bar for all staves.

RELATED LINKS
Changes to note spacing in Engrave mode on page 461
Note spacing on page 171

Gradual dynamics truncated by immediate dynamics
A hairpin is automatically truncated if an immediate dynamic is positioned within its range, either
before or after the hairpin is input.
The hairpin remains tied to its originally designated rhythmic positions, even if graphically it
appears shorter. This means that if the immediate dynamic that truncated it is ever deleted, the
hairpin extends either to its end, or up to the next immediate dynamic with its range.
The examples demonstrate a crescendo hairpin that is truncated by two dynamics, but the
hairpin extends to its total length as they are deleted. The dotted line shows the link between the
hairpin and the rhythmic position to which its end is attached.

RELATED LINKS
Lengthening and shortening gradual dynamics and groups of dynamics on page 339

Positions of dynamics
You can change the positions of dynamics by moving individual dynamics to different rhythmic
positions in Write mode, moving them to different graphical positions in Engrave mode, and by
changing the default positions of all dynamics project-wide.
You can move dynamics to different rhythmic positions in Write mode. They snap to noteheads
and are positioned by default according to your settings in Engraving Options.
You can move dynamics graphically in Engrave mode, however, this does not change the
rhythmic positions to which they are attached.
You can change project-wide settings for how far below the staff dynamics appear, and their
horizontal positions relative to beats, barlines, and system ends on the Dynamics page in
Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for dynamics on page 356

343

Dynamics
Positions of dynamics

Changing the horizontal position of dynamics relative to the beat
individually
You can individually select whether individual dynamics appear before or after the beat.
PROCEDURE
1.

Select the dynamics whose position relative to the beat you want to change. You can do
this in Write mode and Engrave mode.

2.

Activate the Beat-relative position property in the Dynamics group of the Properties
panel.

3.

Choose one of the following options:
●

Before

●

After

EXAMPLE

A dynamic positioned before the beat

A dynamic positioned after the beat

Changing the alignment of immediate dynamics relative to
noteheads individually

Immediate dynamics, such as  and , are usually horizontally aligned with the optical center
of noteheads. However, you can change the horizontal alignment of immediate dynamics
individually.
PROCEDURE
1.

Select the dynamics whose alignment relative to noteheads you want to change. You can
do this in Write mode and Engrave mode.

2.

Activate the Text alignment property in the Dynamics group of the Properties panel.

3.

Choose one of the following options:
●

Align optical center with notehead

●

Left-align with notehead

●

Align optical center with left of notehead

RESULT
The alignment of the selected immediate dynamics is changed.
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NOTE
You can change the horizontal alignment of all immediate dynamics project-wide in the
Horizontal Position section of the Dynamics page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for dynamics on page 356

Moving dynamics rhythmically
You can move dynamics to new rhythmic positions after they have been input.
NOTE
Dynamics can only be moved to existing noteheads and attach to those rhythmic positions.

PROCEDURE
1.

In Write mode, select the dynamics you want to move.

2.

Move the dynamics to the next or previous notehead on the staff in any of the following
ways:
●

Press Alt-Right Arrow to move them to the next notehead.

●

Alt-Left Arrow to move them to the previous notehead.

●

Click and drag the dynamic to the right or to the left to move it to different
noteheads.
NOTE
Only one dynamic can be moved rhythmically at a time when using the mouse.

RESULT
The selected dynamics are moved to next or previous noteheads.

Moving dynamics graphically
You can move dynamics graphically, without changing the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the dynamics you want to move.

2.

Move the dynamics in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them downwards.

●

Press Alt-Down Arrow to move them upwards.
TIP
If you want to move dynamics by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the dynamics in any direction to the positions you want.

345

Dynamics
Copying dynamics
RELATED LINKS
Moving dynamics graphically using the Properties panel on page 346

Moving dynamics graphically using the Properties panel
You can move dynamics graphically using the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the dynamics you want to move.

2.

Activate the following properties, individually or together, in the Dynamics group of the
Properties panel:

3.

4.

●

Start offset

●

End offset

Each property has X and Y value fields. Change the values in the value fields in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move dynamics in the following ways:
●

Start offset X moves immediate dynamics and the start of gradual dynamics
horizontally: increasing the value moves them to the right, decreasing the value
moves them to the left.

●

Start offset Y moves immediate dynamics and the start of gradual dynamics
vertically: increasing the value moves them upwards, decreasing the value moves
them downwards.

●

End offset X moves the end of gradual dynamics horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.

●

End offset Y moves the end of gradual dynamics vertically: increasing the value
moves them upwards, decreasing the value moves them downwards.

RELATED LINKS
Changing the appearance of gradual dynamics individually on page 351

Copying dynamics
Dynamics can be copied and pasted. You can select dynamics on a single staff to copy to another
single staff, or you can select dynamics across multiple staves to copy across the same number of
staves.
Alternatively, if you want to copy dynamics immediately after where they were originally input,
you can select them and press R.

Copying dynamics with the keyboard
You can copy dynamics to other rhythmic positions with the keyboard.
PROCEDURE
1.

In Write mode, select the dynamics you want to copy in one of the following ways:
●

Hold down the Ctrl/Cmd key and select each dynamic.

●

Select the passage that contains the dynamics and choose Edit > Filter > All
Dynamics.
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2.

●

Select the passage that contains the dynamics and choose Edit > Filter > Gradual
Dynamics.

●

Select the passage that contains the dynamics and choose Edit > Filter >
Immediate Dynamics.

Copy the dynamics in any of the following ways:
●

Press Ctrl/Cmd-C.

●

Choose Edit > Copy.

3.

Select the notehead at the rhythmic position to which you want to copy the dynamics.

4.

Paste the dynamics in any of the following ways:
●

Press Ctrl/Cmd-V.

●

Choose Edit > Paste.

RESULT
The selected dynamics are pasted to new rhythmic positions.
If you selected multiple dynamics at different rhythmic positions, their new positions reflect their
original rhythmic spacing.

Copying dynamics with the mouse
PROCEDURE
1.

Select the dynamics you want to copy in one of the following ways:
●

Hold down the Ctrl/Cmd key and select each dynamic.

●

Select the passage that contains the dynamics and choose Edit > Filter > All
Dynamics.

●

Select the passage that contains the dynamics and choose Edit > Filter > Gradual
Dynamics.

●

Select the passage that contains the dynamics and choose Edit > Filter >
Immediate Dynamics.

2.

Hold down Alt.

3.

Click the notehead to which you want to copy the selected dynamics.
TIP
You can repeat this multiple times as long as you keep the dynamics highlighted. Using
this method does not add the dynamics to the clipboard.

RESULT
The selected dynamics are copied to the selected note. You can select dynamics across multiple
staves, as their relative rhythmic positions are maintained.

Deleting dynamics
PROCEDURE
1.

In Write mode, select the dynamics you want to delete.

2.

Delete the dynamics in any of the following ways:
●

Press Backspace or Delete.
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●

Choose Edit > Delete.

Dynamics groups
Two or more dynamics are automatically grouped together if they immediately follow each
other horizontally on the staff, were input in sequence, and have gradual dynamics between the
immediate dynamics.
This means that they are aligned in a row, at the same vertical position, below or above the
staff, and can be moved and edited as a group. For example, the  in the middle of the example
on the left can be moved within the group, and the hairpins either side automatically adjust to
compensate.

A group of dynamics.

The same group of dynamics adjusts to compensate
when the # moves position.

All of the dynamics in a group are highlighted when any of the dynamics in the group are
selected.

RELATED LINKS
Dynamics linked between multiple staves on page 349

Grouping dynamics together
PROCEDURE
1.

In Write mode, select the dynamics you want to group together.

2.

Group the dynamics together in any of the following ways:
●

Choose Edit > Dynamics > Group Dynamics.

●

Right-click and choose Dynamics > Group Dynamics from the context menu.

Ungrouping dynamics and removing dynamics from groups
You can ungroup dynamics so that all dynamics in the group become ungrouped, and you can
remove only selected dynamics from groups while leaving any remaining dynamics that were not
selected in the group.
PROCEDURE
1.

In Write mode, select the dynamics you want to remove from groups.

2.

Ungroup the dynamics in one of the following ways:
●

Choose Edit > Dynamics > Ungroup Dynamics.
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●

Right-click and choose Dynamics > Ungroup Dynamics from the context menu.

●

Choose Edit > Dynamics > Remove from Group.

●

Right-click and choose Dynamics > Remove from Group from the context menu.

RESULT
If you ungroup dynamics, all dynamics in the group are ungrouped. This includes dynamics in
the group that were not included in your selection.
If you remove dynamics from groups, only the selected dynamics are removed from their
groups. Any unselected dynamics in the group remain grouped.

Dynamics linked between multiple staves
Identical dynamics at the same rhythmic position on multiple staves are linked together
automatically. This typically happens only when you copy and paste dynamics between staves.
Like grouped dynamics, if you select one dynamic in a linked group, all other dynamics in the
linked group appear highlighted.
If one linked dynamic is moved to a new rhythmic position, all linked dynamics move.

Three linked dynamics, with only the top dynamic
selected.

Moving just the top dynamic of the linked group
automatically moves all three to match its new
position.

If one linked dynamic is changed, for example, from  to , all dynamics linked to the changed
dynamic are also changed.

Three linked dynamics, with only the top dynamic
selected.
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Changing just the top dynamic of the linked group to
a different dynamic automatically changes the other
two so that they are all the same.
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If you group other dynamics to one of the linked dynamics, such as a hairpin, the hairpin is
added at the same position in all linked staves. Deleting one of these hairpins deletes all of them.
As shown in the examples, the hairpin is truncated by an existing dynamic in the first bar in the
third staff. If you delete such a dynamic, the hairpin extends to match the length of the one
originally input.

Three linked dynamics, where a hairpin added to
the top staff and grouped with the dynamics on that
staff has been automatically added to the staves
below.

Deleting the f at the end of the first bar in the third
staff causes the hairpin to extend to match the range
of the top staff.

Linking dynamics together
You can link dynamics that are not automatically linked together to allow simultaneous editing.
NOTE
Identical dynamics at the same rhythmic position on multiple staves are linked together
automatically. This typically happens only when you copy and paste dynamics between staves.

PROCEDURE
1.

In Write mode, select the dynamics you want to link together.

2.

Link the dynamics in any of the following ways:
●

Choose Edit > Dynamics > Link.

●

Right-click and choose Dynamics > Link from the context menu.

RELATED LINKS
Dynamics linked between multiple staves on page 349

Unlinking dynamics
You can unlink dynamics, including dynamics that were linked automatically.
PROCEDURE
1.

Select a dynamic from the linked group of dynamics you want to unlink.

2.

Unlink the whole linked group in any of the following ways:
●

Choose Edit > Dynamics > Unlink.

●

Right-click and choose Dynamics > Unlink from the context menu.

RELATED LINKS
Dynamics linked between multiple staves on page 349
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Individual changes to the appearance of dynamics
You can make changes to the appearance of dynamics individually, independently of your
project-wide settings for the appearance of dynamics.

Changing the appearance of gradual dynamics individually
You can change the appearance of gradual dynamics individually, independently of your projectwide settings. By default, gradual dynamics appear either as hairpins, or as text instructions such
as cresc. or dim..
In Engrave mode, hairpins can be selected individually. Selected hairpins are highlighted and
three adjustment handles appear at each end.
Gradual dynamics can be edited individually using handles in Engrave mode, and using
properties in the Properties panel at the bottom of the window.
You can adjust the length of hairpins and the width of the aperture at each end by selecting
these handles and moving them in the following ways:
●

Press Alt-Right Arrow to move handles to the right.

●

Press Alt-Left Arrow to move handles to the left.

●

Press Alt-Up Arrow to move handles upwards.

●

Press Alt-Down Arrow to move handles downwards.

●

Click and drag them to the positions you want.

Alternatively, you can change the appearance of gradual dynamics individually using the
Properties panel. Selecting hairpins in Engrave mode shows the following options in the
Dynamics group:
Start offset
Start offset X value moves immediate dynamics, and the start of gradual dynamics,
horizontally.
Start offset Y value moves immediate dynamics, and the start of gradual dynamics,
vertically.
End offset
End offset X value moves the end of gradual dynamics horizontally.
End offset Y value moves the end of gradual dynamics vertically.
Type
Choose how selected hairpins appear:
●

Cresc. or dim.: hairpin in one direction

●

Messa di voce: a pair of hairpins, crescendo and diminuendo

Gradual style
Choose how selected gradual dynamics should appear:
●

Hairpin

●

cresc./dim. without a continuation line

●

cresc… with a continuation line

●

cre-scen-do: text spread across the duration of the gradual dynamic

Hairpin line style
Choose the style of selected hairpin lines:
●

Solid
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●

Dashed

●

Dotted

Niente
Activate to show a niente mark at the closed end of gradual dynamics.
Niente style
Choose the style of niente marks on selected hairpins:
●

Circle on hairpin

●

Text

Poco a poco
Activate or deactivate poco a poco text.
Hairpin shown as continuation
Choose whether a series of three immediate dynamics has two hairpins, or one
hairpin that continues through the middle dynamic.

Separate hairpins.

Hairpins shown as continuation.

Hairpin thickness
Change the thickness of selected hairpin lines.
Hairpin open aperture/Hairpin closed aperture
Change the width of the open end of the hairpin, and the width of the closed end of
the hairpin. If the hairpin crosses a system break or multiple system breaks, you can
use these properties to widen or narrow each part of the hairpin separately. The two
properties, Hairpin open aperture and Hairpin closed aperture, apply to each end
of each segment, following the direction of the hairpin.
For example, if a diminuendo crosses a barline, the aperture at the left end of the
part of the hairpin on the new system is open and the aperture at the right end is
closed. This continues the volume change from loud to quiet, as shown in the below
example.

The diminuendo continues onto a new system:
A diminuendo that goes across a system break:
aperture at the left end is open, aperture at the right
aperture at the left end is open, aperture at the right
end is closed.
end is closed.

Deactivating any of these properties returns the selected hairpins to your project-wide settings.
RELATED LINKS
Project-wide Engraving Options for dynamics on page 356
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Changing the angle of hairpins
By default, hairpins are straight and are automatically adjusted to avoid collisions with other
objects, such as noteheads and slurs. You can change the angle of individual hairpins as required
for your music.
Each end of hairpins has three square handles in Engrave mode:
●

The middle handle changes the offset position of the corresponding end of the hairpin.

●

The two outer handles adjust the aperture width of the corresponding end of the hairpin.

A hairpin with the middle handle selected in Engrave mode.

PROCEDURE
1.

In Engrave mode, select the middle handles of the hairpins whose angle you want to
change.
Hairpins do not have to be the same direction, or in the same staff.

2.

Move handles up or down in any of the following ways:
●

Press Alt-Up Arrow and Alt-Down Arrow
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag handles in any direction to the positions you want.

●

For handles at the start of hairpins: activate the Start offset property in the
Dynamics group of the Properties panel, and change the Y value. Increasing the
value moves handles upwards, decreasing the value moves handles downwards.

●

For handles at the end of hairpins: activate the End offset property in the Dynamics
group of the Properties panel, and change the Y value. Increasing the value moves
handles upwards, decreasing the value moves handles downwards.

RESULT
The angle of the selected hairpins is changed. Each end can be moved independently of the
other.
NOTE
Changing only the start offset position with the keyboard or by activating the Start offset
property only changes the position of the hairpin relative to the staff, not its angle. You must
change the end offset position or activate the End offset property as well to change the angle of
hairpins.
Dragging handles with the mouse changes the angle straight away.

Changing the aperture width of hairpins individually
The change in volume indicated by individual hairpins is shown in the distance between the two
lines that make up hairpins at their apertures.
Hairpins typically have a closed end and an open end, although if the hairpin crosses a system or
frame break, the closed end can appear with a small gap.
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In Dorico, both of the two outer handles at each end of hairpins in Engrave mode can be used to
change the aperture width. These handles are linked and mirror each other: moving one handle
also moves the other handle by the same amount, but in the opposite direction. This ensures
that hairpins remain symmetrical.

A hairpin with the middle handle selected in Engrave mode. Each end has three square handles: the two
outer handles at each end change the aperture width of the hairpin.

To change the aperture width of hairpins individually:
PROCEDURE
1.

In Engrave mode, select one of the outer handles of the hairpins whose aperture width
you want to change.
Hairpins do not have to be the same direction, or in the same staff.

2.

Move the handles further apart or closer together in any of the following ways:
●

Press Alt-Up Arrow to move them further apart.

●

Press Alt-Down Arrow to move them closer together.
NOTE
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them upwards or downwards to your desired width.

●

For the open end of hairpins: activate the Hairpin open aperture property in the
Dynamics group of the Properties panel, and change the value. Increasing the value
makes apertures wider, decreasing the value makes apertures narrower.

●

For the closed end of hairpins: activate the Hairpin closed aperture property in the
Dynamics group of the Properties panel, and change the value. Increasing the value
makes apertures wider, decreasing the value makes apertures narrower.

RESULT
The apertures of the selected hairpins are changed.
NOTE
You can set minimum and maximum values for the width of hairpin apertures project-wide,
including for hairpins across system and page breaks, by disclosing Advanced Options under
the Hairpins heading of the Gradual Dynamics section of the Dynamics page.

Changing the appearance of niente hairpins
Niente hairpins can be shown in two ways: as a circle at the end of a hairpin, and as text directly
before or after a hairpin.
You can show niente hairpins in both ways in Dorico, and you can change how they appear
individually, independently of your project-wide setting for the appearance of niente hairpins.
PROCEDURE
1.

Select the hairpins whose niente style you want to change. You can do this in Write mode
and Engrave mode.
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2.

Activate Niente style in the Dynamics group of the Properties panel.

3.

Choose one of the following options:
●

Circle on hairpin

●

Text

RESULT
The niente style of the selected hairpins is changed.
NOTE
You can change how all niente hairpins appear project-wide in the Gradual Dynamics section of
the Dynamics page in Engrave > Engraving Options.
EXAMPLE

A niente shown as Circle on hairpin

A niente shown as Text

RELATED LINKS
Project-wide Engraving Options for dynamics on page 356

Showing dynamics in parentheses
PROCEDURE
1.

Select the dynamics you want to appear parenthesized. This can be done in Write mode
and Engrave mode.

2.

Activate Parenthesized in the Dynamics group of the Properties panel.

RESULT
The dynamics selected are shown in parentheses. Each dynamic is parenthesized individually.

Hiding immediate dynamics

You can hide immediate dynamics such as ♯ and ♯, for example, if you only want to show an
expressive text and not the immediate dynamic that accompanies it.
PROCEDURE
1.

Select the dynamics whose intensity markings you want to hide. This can be done in Write
mode and Engrave mode.

2.

Activate Hide intensity marking in the Dynamics group of the Properties panel.

RESULT
The selected immediate dynamics are hidden. Their positions are indicated by signposts.

355

Dynamics
Project-wide Engraving Options for dynamics
NOTE
You can show immediate dynamics again at any time by deactivating the Hide intensity
marking property.

RELATED LINKS
Inputting expressive text with the keyboard on page 334
Inputting expressive text with the mouse on page 337
Adding expressive text to existing dynamics on page 338

Project-wide Engraving Options for dynamics
Options for the appearance and position of dynamics project-wide can be found on the
Dynamics page in Engraving Options.
The options on the Dynamics page allow you to change the appearance of dynamics and
gradual dynamics, and their default positions relative to noteheads, barlines, and the ends of
systems.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Changes to the font styles used for dynamics
You can change different aspects of the fonts used for dynamics in the Edit Font Styles dialog in
Engrave mode.
The following fonts affect the appearance of dynamics:
●

Default Text Font: changes all font styles in the project, including dynamic modifiers.

●

Dynamic Text Font: changes the font for dynamic modifiers, including expressive text.

●

Dynamic Music Text Font: changes the font used for dynamic glyphs, such as  and .

Changes made to each font style apply to the entire project, including parts.

The different aspects of the font styles used for dynamics that you can change are:
Font family
This sets the overall font style.
Size
This sets the size of dynamics. Dynamic size can be:
●

Absolute: always the set size, regardless of the staff size.

●

Staff-relative: the size of dynamics is proportional to the staff size, which
means dynamics appear smaller than the set value on smaller staves, and
larger than the set value on larger staves.

Style
This sets the dynamic font appearance. The dynamic font can be:
●

Regular (default for Dynamic Music Text Font)

●

Italic (default for Dynamic Text Font)

●

Bold

●

Bold Italic
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Underlined
The dynamic font appears underlined if the box beside the Underlined activation
switch is checked.
RELATED LINKS
Changing the fonts used for dynamic modifiers on page 357
Changing the font used for dynamic glyphs on page 357

Changing the fonts used for dynamic modifiers
There are two fonts that you can change that affect dynamic modifiers.
●

The Default Text Font is the parent font for the whole project, so any changes you make
to this font affect all fonts that are linked to the font. This includes dynamic modifiers, but
also many other fonts.

●

The Dynamic Text Font is used for dynamic modifiers. Any changes you make to this font
affects all dynamic modifiers, including expressive text, but does not affect any other font
style.

PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Font Styles dialog.

2.

Select one of the following fonts from the Font style menu:

3.

4.

●

Default Text Font

●

Dynamic Text Font

Activate the switch beside the following options to change the corresponding aspects of
the selected font:
●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The default font used for dynamic modifiers or all fonts in your project is changed project-wide.
RELATED LINKS
Changes to the font styles used for dynamics on page 356

Changing the font used for dynamic glyphs
You can change the font used for dynamic glyphs. However, only specific fonts can be used.

The font used for dynamic glyphs, such as  or , have to be SMuFL-compliant. SMuFL stands
for Standard Music Font Layout.
These fonts are specifically designed to map thousands of the different symbols required for
music notation onto a standard layout. Therefore, Dorico looks for a particular symbol in a
specific place within the font, and if a non-SMuFL font is used, Dorico is unlikely to be able to find
the correct one.
SMuFL-compliant fonts include Bravura and November.
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PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Edit Font Styles dialog.

2.

Choose Dynamic Music Text Font from the Font style menu.

3.

Activate the switch beside the following options to change the corresponding aspects of
the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The font used for dynamic glyphs is changed project-wide.
RELATED LINKS
Changes to the font styles used for dynamics on page 356

Playback Options for dynamics
You can change settings for how dynamics are interpreted in playback by making adjustments to
the scale of the graphical curve on the Dynamics page in Playback Options dialog.
You can open the Playback Options dialog in any of the following ways:
●

Press Ctrl/Cmd-Shift-P in any mode.

●

Choose Play > Playback Options in Play mode.

You can then click Dynamics in the page list on the left of the dialog.

Dynamic Curve
At the top of the Dynamics page in Playback Options, there is a graph that maps a continuous
curve. This determines how dynamic volume increases across the range  to .
A dynamic curve power of 1 creates a straight line, producing a steady dynamic increase. The
difference between  and  is the same as between  and .

A dynamic curve power higher than 2 creates a curved line, producing a faster dynamic increase
in the middle of the range. The difference between  and  is much smaller than the
difference between  and .

The higher the dynamic curve power, the greater the contrast between dynamics in the middle of
the range, and the smaller the contrast between dynamics at the ends of the range.
If your project uses a wide range of dynamics, including dynamics such as  and , you
might want a lower curve power with larger differences between the extremes of the range.

If your project has a smaller range of dynamics, such as a minimum of  to a maximum of ,
you might prefer a higher curve power, so the differences between the dynamics in the middle of
the range are more discernible.
NOTE
Changing the dynamic curve affects the playback of all instruments in the project.
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Note dynamics
In the Note Dynamics section of the Dynamics page in Playback Options, you can set how
much the volume of notes in playback is affected by stresses and articulation marks.

Humanize
The Humanize option allows the dynamics of notes to vary randomly by the degree you set to
mimic the natural fluctuations in a live performance.

Sustaining and non-sustaining instruments
The volume settings for sustaining instruments and non-sustaining instruments vary in terms of
their control of gradual dynamics.

Sustaining instruments
Sustaining instruments include string, wind, and brass instruments, because they can hold a note
while being in control of its volume throughout.
Dorico applies gradual dynamics to these instruments in playback. You can control settings for
each software instrument by choosing Play > Expression Maps Setup and selecting software
instruments from the list on the left.

Non-sustaining instruments
Non-sustaining instruments, such as piano, harp, marimba, and most percussion instruments,
have no further control of the dynamic of notes after they have been struck. For this reason, nonsustaining software instruments tend to use note velocity for dynamics, because this is set at the
start of the note.
You can control settings for each software instrument by choosing Play > Expression Maps
Setup and selecting software instruments from the list on the left.

VST Expression Maps for volume types
If you are using a third party sound library, you may need to change or edit the expression map
to make instruments respond to gradual dynamics. Otherwise, the sound library uses velocity by
default.
The setup of the expression map for dynamics depends on how the instrument is configured.
Consult the documentation for the sound library for further information.
Dorico provides the following default expression maps:
●

CC11 Dynamics: dynamics produced by changing MIDI channel expression

●

Modulation Wheel Dynamics: dynamics produced by changing MIDI controller 1
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Fingerings can be added to music to give recommendations as to which fingers players should
use for notes. This can be useful for difficult or physically awkward passages of music where
certain fingering patterns make the notes much easier to play.
Fingerings are commonly added to music designed for players who are learning the instrument,
such as in educational music and exam syllabus editions of pieces.
They are most often used in keyboard music, as players can use all ten fingers to play notes.
However, fingerings can be useful for other instruments, for example, to indicate that string
players should change the finger used to stop the string while holding the note, or to instruct
wind players to use uncommon fingerings for particular notes in order to create a particular
sonic effect.
Dorico also provides fingerings for brass instruments. For example, you can specify which valves
players should depress for instruments such as trumpet and horn, and you can specify the horn
branch you want players to use for double horns.
Fingerings in Dorico use a bold roman font by default, following accepted conventions for the
appearance of fingerings. You can change the font used for fingerings project-wide on the
Fingering page in Engrave > Engraving Options.
RELATED LINKS
The fingerings popover on page 361
Changing the fingering font used for fingerings project-wide on page 365

General placement conventions for fingering
Fingerings are placed as close as possible to the notes to which they apply, so they can be read
easily and clearly by the performer.
In music for keyboards and other instruments that use two staves, it is accepted to place
fingerings for the right hand above the top staff, and the fingerings for the left hand below
bottom staff.
However, in dense contrapuntal music for instruments that use two staves, fingerings can be
placed between the staves to follow the direction of the voices to which they apply.

Adding fingerings to notes
Fingerings are associated with individual noteheads and so can only be added to existing
noteheads. Therefore, you cannot input fingerings during step input, and the popover does not
advance automatically.
NOTE
You can only add fingerings to notes at one rhythmic position at a time, and you can only input
the same number of fingerings as there are notes at each rhythmic position. For example, you
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can input three fingerings at the rhythmic position of a chord containing three notes, but only
one fingering at the rhythmic position of a single note.
Although they contain two numbers, substitution fingerings are considered one fingering,
meaning you can add substitution fingerings to single notes.

PROCEDURE
1.

In Write mode, select the notes to which you want to add fingering.
If you want to add fingerings to all notes in a chord, select all the notes in the chord.

2.

3.

Open the fingerings popover in any of the following ways:
●

Press Shift-F

●

Click Fingering in the Notations toolbox:

●

Choose Write > Create Fingerings

Enter the fingerings you want into the popover. For example, enter:
●
●
●

4.

3-2 for a substitution fingering from the third finger to the second finger
1,3,5 for a chord
12 to show the first two valves should be depressed on a valved brass instrument

Press Return to close the popover.

RESULT
The fingerings are added to the selected notes.
RELATED LINKS
Changing the rhythmic positions of substitution fingerings on page 363
Fingerings for valved brass instruments on page 372

The fingerings popover
Here are some examples of what to enter into the fingerings popover and the fingerings that are
input as a result.
For example, enter:

For fingerings:

1 or 2 or 3 and so on

Single fingerings for individual notes, including
for brass valve numbers and trombone slide
positions

12

Valved brass instruments

1,3,5

Single fingerings for each note in chords
NOTE
For keyboards, Dorico automatically orders
numbers appropriately according to the hand
playing the notes. The default is:
●

361

Right hand for the upper staff

Fingering
Adding fingerings to notes

For example, enter:

For fingerings:
●

Left hand for the lower staff

L2 or G2 or S5 or I2 or H2

Left hand fingerings

R5 or D5 or M5

Right hand fingerings

2343

Multiple fingerings for individual notes. For
example, for ornaments such as mordents or
turns

1,1

Single fingerings for multiple notes: enter
the same fingering number for two adjacent
notes.
For example, in keyboard music the thumb
may depress two keys simultaneously.
Alternative fingerings

2(3)

NOTE
You must use parentheses in the popover,
even if you choose to show alternative
fingerings in square brackets.

Editorial fingerings

[4]

NOTE
You must use square brackets in the popover,
even if you choose to show alternative
fingerings in parentheses.

1-3

Finger substitutions

T

Thumb indicator for string instruments.

This list is not comprehensive: it is intended to illustrate how you can structure your entries to
input different types of fingerings.
You can change the appearance and positions of each type of fingering on the Fingering page in
Engrave > Engraving Options.
NOTE
Finger substitutions are shown as immediate by default, but you can change the rhythmic
position of the substitution by changing the deferral duration.

RELATED LINKS
Project-wide Engraving Options for fingerings on page 365
Changing the rhythmic positions of substitution fingerings on page 363
Fingerings for valved brass instruments on page 372
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Changing the rhythmic positions of substitution fingerings
Substitution fingerings are shown as immediate by default, meaning that the substitution takes
place on the same note. You can change the rhythmic position at which individual substitutions
take place to indicate where players should change the finger used for the note.
PROCEDURE
1.

Select the substitution fingering whose deferred rhythmic position you want to change.

2.

Change the rhythmic position of the substitution in any of the following ways:
●

In Write mode, click and drag the circular handle to the right or to the left to the
position you want.

●

In Write mode and Engrave mode, activate the Substitution offset property in the
Fingering group of the Properties panel.
Change the rhythmic position of substitutions as fractions of a quarter note by
entering a value into the first value field, or by clicking the arrows beside the value
field. Increasing the value moves them to later positions, decreasing the value
moves them to earlier positions.
NOTE
The second value is for the grace note position at which substitutions occur.
Normally you do not need to set this value.

RESULT
The rhythmic position of the substitution fingering is changed.
Dorico automatically arranges deferred substitutions so they are ordered appropriately
alongside any fingerings that coincide with the substitution.
NOTE
You can only change the position of single substitution fingerings when dragging their handles
with the mouse. However, you can change the positions of multiple substitution fingerings when
using the Substitution offset property in the Fingering and Positions group of the Properties
panel.
Deferred substitutions are always shown with horizontal lines, even if you have chosen to show
immediate substitutions with slurs.

RELATED LINKS
The fingerings popover on page 361
Project-wide Engraving Options for fingerings on page 365

Changing existing fingerings
You can change the fingering numbers of existing fingerings using the Properties panel.
Alternatively, you can add replacement fingerings using the fingerings popover in the same way
as adding new fingerings.
PROCEDURE
1.

Select the fingerings you want to change. You can do this in Write mode and Engrave
mode.

2.

Enter the new fingering you want in the Finger or position value field in the Fingering
and Positions group of the Properties panel.
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RESULT
The number shown in the selected fingerings is changed.
RELATED LINKS
Adding fingerings to notes on page 360

Deleting fingerings
Because fingerings are intrinsically linked to noteheads, you cannot select fingerings separately
from noteheads and delete them. You must deactivate the Finger or position property for
selected notes.
PROCEDURE
1.

2.

Select the fingerings you want to delete in the following ways:
●

Hold Ctrl/Cmd and click the corresponding notes individually in Write mode.

●

Hold Ctrl/Cmd and click the fingerings individually in Engrave mode.

●

Hold Shift and select multiple adjacent notes in Write mode.

●

Make a marquee selection and choose Edit > Filter > Notes and Chords.

Deactivate the Finger or position property in the Fingering and Positions group of the
Properties panel.

RESULT
All fingerings are deleted from the selected notes or fingerings.

Project-wide changes to the appearance and placement of
fingerings
You can change the appearance and placement of all fingerings project-wide on the Fingering
page in Engraving Options. You can also change the font styles of the fonts used for fingerings
in the Font Styles dialog.

Font Styles dialog
In the Engrave > Font Styles dialog, you can change different aspects of the fonts used for
fingerings:
●

Fingering Font: used for bold fingerings

●

Fingering Text Font: used for plain fingerings

NOTE
Changes made to font styles apply to the entire project, including parts.
The different aspects of the fingering font styles that you can change are:
Font family
Sets the overall font style.
Size
Sets the size of fingerings for all layouts in the project, meaning the size is the same
in the score and parts. Fingering size can be:
●

Absolute: always the set size, regardless of the staff size.
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●

Staff-relative: the size of fingerings is proportional to the staff size, which
means fingerings appear smaller than the set value on smaller staves, and
larger than the set value on larger staves.

Style
This sets the font appearance. Fonts can be:
●

Regular (default for Fingering Text Font)

●

Italic

●

Bold (default for Fingering Font)

●

Bold Italic

Underlined
The fingering fonts appear underlined if the box beside the Underlined activation
switch is checked.
RELATED LINKS
Project-wide Engraving Options for fingerings on page 365

Project-wide Engraving Options for fingerings
Options for the appearance and positions of fingerings project-wide can be found on the
Fingering page in Engraving Options.
The options on this page allow you to change the font, size, appearance, placement, and precise
position of fingerings on standard notes and grace notes, including fine adjustments for the
different instrument groups.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Fingering in the page list on the left of the dialog.

Changing the fingering font used for fingerings project-wide
By default, fingerings are drawn in a bold, roman font that is similar in appearance to the digits
in time signatures. You can change the fingering font used for fingerings project-wide on the
Fingering page in Engraving Options.
This changes the font style used to draw fingering numbers, parentheses, and brackets.
NOTE
The thumb indicator, substitution lines and slurs, and brass valve separators are not changed.

PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Fingering in the page list.

3.

Choose one of the following options for Fingering appearance in the Design section:
●

Bold font

●

Plain font

365

Fingering
Project-wide changes to the appearance and placement of fingerings
4.

Click Apply, then Close.

RESULT
The font style used for fingerings project-wide is changed.
NOTE
You can change different aspects of the font style used in the Engrave > Font Styles dialog.
Bold fingerings use the Fingering Font.
Plain fingerings use the Fingering Text Font.

RELATED LINKS
Changing the fingering font styles on page 366

Changing the fingering font styles
You can change the font styles used for fingerings.

PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Font Styles dialog.

2.

Select the fingering font style you want to change from the Font style menu:

3.

4.

●

Fingering Font

●

Fingering Text Font

●

Fingering Text Italic Font

●

Fingering Horn Branch Accidental Font

●

Fingering Horn Branch Alto Text Font

●

Fingering Horn Branch Text Font

Activate the switches beside the following options to change the corresponding aspects of
the font:
●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The selected fingering font style is changed project-wide.
RELATED LINKS
Project-wide changes to the appearance and placement of fingerings on page 364
Project-wide Engraving Options for fingerings on page 365

Changing the appearance of cautionary fingerings project-wide
Cautionary fingerings remind players fingerings specified at previous rhythmic positions still
apply notes that are still sounding. Dorico automatically shows cautionary fingerings when you
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add other fingerings at rhythmic positions where notes previously given fingerings are still
sounding
By default, cautionary fingerings are shown enclosed in parentheses. You can choose to show
cautionary fingerings without parentheses or not show cautionary fingerings at all project-wide.

Cautionary fingering shown in parentheses (default)

NOTE
You cannot change the appearance of cautionary fingerings individually.

PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Fingering in the page list.

3.

Choose one of the following options for Cautionary fingering appearance in the
Alternative, Editorial and Cautionary section:

4.

●

Do not show

●

Show fingering only

●

Show fingering in parentheses

Click Apply, then Close.

RESULT
The appearance of cautionary accidentals is changed project-wide.

Changing the appearance of slide positions for brass instruments
You can choose to use Arabic or Roman numerals to indicate slide positions for slide brass
instruments, such as trombones. By default, Dorico uses Arabic numerals for slide positions.
NOTE
You must enter slide positions using Arabic numerals into the fingerings popover, even if you
have chosen to show slide positions with Roman numerals in your project.

PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Fingering in the page list.

3.

Choose one of the following options for Trombone slide position appearance in the
Brass section:

4.

●

Arabic numerals

●

Roman numerals

Click Apply, then Close.

RESULT
The numerals used for slide positions on slide brass instruments is changed project-wide.
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RELATED LINKS
Adding fingerings to notes on page 360

Individual changes to the appearance and placement of
fingerings
You can change the appearance and placement of fingerings individually, independently of you
project-wide settings on the Fingering page in Engraving Options.
You can select individual fingerings in Write mode and Engrave mode and activate properties
in the Fingering group of the Properties panel, however there are more properties available in
Engrave mode than Write mode.
NOTE
In Write mode, you cannot select fingerings independently of the noteheads to which they apply,
but in Engrave mode you can select fingerings without selecting their noteheads as well.

Showing individual fingerings in italics
Fingerings are normally shown in a bold, non-italic font, however you can show individual
fingerings in italics.
PROCEDURE
1.

In Engrave mode, select the fingerings you want to show in italics.

2.

Activate the Italic property in the Fingering group of the Properties panel.

RESULT
The selected fingerings are shown in a bold italic font if your project-wide setting for fingerings is
a bold font, and in a plain italic font if your project-wide setting for fingerings is a plain font.
NOTE
Bold italic fingerings look very similar to tuplet numbers, which may be confusing.

Changing the placement of fingerings relative to the staff
individually
Dorico automatically follows conventions for fingering placement, however you can change the
placement of fingerings relative to the staff individually, independently of your project-wide
setting for fingering placement relative to the staff.
According to conventions, keyboard instrument fingering is positioned above the right-hand
staff, and below the left-hand staff. String and brass instrument fingering is always positioned
above the staff.
PROCEDURE
1.

Select the fingerings whose position relative to the staff you want to change. You can do
this in Write mode and Engrave mode.

2.

Activate the Staff-relative position property in the Fingering and Positions group of the
Properties panel.

3.

Choose one of the following options:
●

Above
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●

Below

RESULT
The position of the selected fingerings relative to the staff is changed.
NOTE
You can change the placement of all fingerings project-wide to follow stem directions on the
Fingering page in Engrave > Engraving Options.
This can be useful in complex contrapuntal music where fingering may not be clear if it is only
placed above the top staff and below the bottom staff.

RELATED LINKS
Project-wide Engraving Options for fingerings on page 365

Changing the position of individual fingerings relative to slurs,
octave lines, and tuplet brackets
By default, fingerings are positioned inside the arcs of slurs, but outside the starts or ends of
slurs. You can change the position of fingerings relative to individual slurs, independently of your
project-wide settings.
PROCEDURE
1.

In Engrave mode, select the fingerings whose position relative to slurs you want to
change.

2.

Activate the Slur-relative position property in the Fingering and Positions group of the
Properties panel.

3.

Choose one of the following options:
●

Inside

●

Outside

RESULT
The position of the selected fingerings relative to slurs, octave lines, and tuplet brackets is
changed.
NOTE
If fingerings also coincide with the first note or last note of slurs, fingerings are positioned
outside all of these notations.
You can change the position of all fingerings relative to slurs project-wide on the Fingering page
in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for fingerings on page 365
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Showing horn branch indicators
You can indicate the branch notes should be played on for double horns and triple horns by
adding branch indicators as prefixes to horn fingerings. Some publications simply indicate T for
thumb, while others more explicitly indicate which branch is to be used by specifying its pitch.
PROCEDURE
1.

Select the horn fingerings to which you want to add branch indicators. You can do this in
Write mode and Engrave mode.
NOTE
You can only add branch indicators to notes belonging to horns in F.

2.

Activate the Horn branch property in the Fingering and Positions group of the Properties
panel.

3.

Select the horn branch you want from the menu:
●

F

●

B flat

●

F alto

●

E flat alto

●

Thumb trigger

RESULT
Branch indicators are added to the selected fingerings.
You can change the appearance of branch indicators in the Horn Branch Indicators section of
the Fingering page in Engrave > Engraving Options.
NOTE
Dorico does not ascertain the validity of branch indicators.

RELATED LINKS
Adding fingerings to notes on page 360
Project-wide Engraving Options for fingerings on page 365

Moving fingerings graphically
You can move fingerings graphically, and independently of the noteheads to which they apply,
with the keyboard and mouse in Engrave mode.
NOTE
Fingerings cannot be moved to different rhythmic positions as they are intrinsic parts of notes. If
you want to move fingerings to other noteheads, delete the existing fingerings and input them
again on the noteheads to which you wanted to move them.

PROCEDURE
1.

In Engrave mode, select the fingerings you want to move graphically.

2.

Move them in any of the following ways:
●

Alt-Right Arrow

●

Alt-Left Arrow
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●

Alt-Up Arrow

●

Alt-Down Arrow
NOTE
If you want to move fingerings by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag fingerings in any direction to the positions you want.

RELATED LINKS
Moving fingerings graphically using the Properties panel on page 371
Resetting the positions of fingerings individually on page 371

Moving fingerings graphically using the Properties panel
You can move fingerings graphically, and independently of the noteheads to which they apply,
using the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the fingerings you want to move graphically.

2.

Activate the Offset property in the Fingering and Positions group of the Properties panel.

3.

The Offset property has X and Y value fields. Change the values in the value fields in any
of the following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The Offset property moves fingerings in the following ways:
●

Offset X moves fingerings horizontally: increasing the value moves them to the
right, decreasing the value moves them to the left.

●

Offset Y moves fingerings vertically: increasing the value moves them upwards,
decreasing the value moves them downwards.

RELATED LINKS
Moving fingerings graphically on page 370
Resetting the positions of fingerings individually on page 371

Resetting the positions of fingerings individually
You can reset the positions of fingerings whose graphical positions you have moved.
PROCEDURE
1.

In Engrave mode, select the fingerings whose positions you want to reset.

2.

Reset their positions in any of the following ways:
●

Choose Edit > Reset Position

●

Deactivate the Offset property in the Fingering and Positions group of the
Properties panel
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Fingerings for valved brass instruments
For instruments like trumpet and horn, fingering is used to show which valves need to be
depressed to produce a specific note. For example, to play C♯ on a trumpet, the first two valves
must be depressed.
You can enter fingerings for valved brass instruments into the fingerings popover as numbers
without any separation. For example, enter 12 for a C♯ on a trumpet.
By default, Dorico automatically stacks fingerings added to notes on brass instrument staves
vertically, and inserts a dot between the numbers.
You can change the appearance of fingerings for valved brass instruments in the Brass section of
the Fingering page in Engrave > Engraving Options.
For example, you can show fingerings for valved brass instruments in a single row or stacked
vertically. You can also change the appearance of a separator or show no separator.
RELATED LINKS
The fingerings popover on page 361
Adding fingerings to notes on page 360

Showing fingering shifts for string instruments
An angled line can be used to indicate the direction of movement when string players have to
shift position on the fingerboard to play a higher note or a lower note with the same finger as
the previous note.
PREREQUISITE
Specify that the notes between which you want to show shift indicators are both played on the
same string.
NOTE
Shift indicators are shown whether the notes at each end have explicit fingerings or not.

PROCEDURE
1.

Select the notes or fingerings in string instrument staves from which you want to indicate
a fingering shift. You can do this in Write mode and Engrave mode.

2.

Activate the Indicate shift to next note property in the Fingering and Positions group of
the Properties panel.

RESULT
Shift indicators are shown positioned between the selected notes and the notes that immediately
follow them.
You can change the length, thickness, angle, and placement of shift indicators in the String
Fingering Shifts section of the Fingering page in Engrave > Engraving Options.
RELATED LINKS
Specifying on which string individual notes are played (string instruments only) on page 459
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Changing the direction of string fingering shift indicators
individually
You can change the direction of individual string fingering shift indicators, if they are shown
pointing in the opposite direction to the one you expected.
PROCEDURE
1.

Select the shift indicators whose direction you want to change. You can do this in Write
mode and Engrave mode.

2.

Activate the Shift direction property in the Fingering and Positions group of the
Properties panel.

3.

Choose one of the following options:
●

Up

●

Down

RESULT
The direction of the selected shift indicators is changed.

Importing fingerings from MusicXML files
Fingerings that are specified using the fingering element in MusicXML files, that is are imported
by Dorico.
For example, MusicXML files exported from Finale typically represent fingerings in the correct
way, however Sibelius does not.
Therefore Dorico cannot import fingerings from MusicXML files exported by Sibelius.
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Front matter in Dorico is a broad term that covers all information included before the first bar of
music in scores.
Front matter includes musical information often added on pages before the first pages of scores,
such as:
●

Performance instructions

●

Contents

●

Instrumentation list

Front matter also includes information above the music on the first page of scores, such as:
●

Dedications

●

Titles

●

Subtitles

●

Composers

As all information in your project that is not the music must be added within frames, which are
input and edited in Engrave mode, lots of relevant information for front matter is included in
Engrave mode topics.

Master pages in Engrave mode
Master pages in Dorico allow the same formatting to be applied to different pages in different
layouts.
You can customize the default master pages and master page sets in your project. You can also
create new master pages based on existing master pages or create completely new master
pages.

Master page sets in Engrave mode
Master page sets group master page formats together, so there is a master page for all possible
situations in your project.
RELATED LINKS
Master pages on page 133
Master page sets on page 133
Paragraph styles on page 152
Master page types on page 135
Adding master pages on page 136
Customizing master pages on page 137
Renaming master pages on page 136
Deleting master pages on page 136
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Project information used in default master pages
An efficient way of ensuring all text information in the different layouts in your project is
consistent is to use tokens that link to information for the current project entered in the Project
Info dialog.
NOTE
Tokens, which are also known as “wildcards”, are codes that insert text from elsewhere, and that
text is updated automatically if its source is changed.
The default master pages include tokens, so that any information you include for each flow in the
File > Project Info dialog is automatically shown. For example, the Default Full Score master
page set shows the following information for each flow:
●

Composer

●

Lyricist

●

Title

NOTE
These tokens are linked to the project information for each flow by default. If you only enter
information for Project in the Project Info dialog, no text is shown.

Multiple flows on a single page
If there are multiple music frames on a single page, the title at the top of the page is taken from
the flow in the music frame at the top of the page.
For example, if you have Flow 1 followed by Flow 2 on the same page, the title at the top is Flow
1.
If you want to specify the flow title at the top of the page, change the title token to, for example,
{@Flow2Title@}.
You can see the flow number of each flow in the Flows panel in Setup mode.
RELATED LINKS
Flow names and flow titles on page 80

Adding dedications in master pages
Dedications are usually shown above titles in scores. They generally use a smaller font size than
titles, and are shown in italics.
In Dorico, dedications are not shown in scores and parts by default, even if you enter a
dedication in the Dedication field in the Project Info dialog.
You can open the Project Info dialog by choosing File > Project Info.
If you want to show dedications in your scores and parts, you must input them manually.
PROCEDURE
1.

In Engrave mode, select the master page set containing the master page format to which
you want to add a dedication from the Current set menu in the Master Pages section of
the Pages panel.
For example, if you want to add a dedication above the titles in scores, select Default Full
Score.
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2.

Double-click on the master page to which you want to add a dedication. For example, if
you are using the default master pages, double-click First.

3.

In the master page editor, activate Frames in the Formatting panel.

4.

Select the title text frame.

5.

Open the text editor in one of the following ways:
●

Press Return.

●

Double-click within the text frame.

6.

Position the caret at the left end of the title token.

7.

Press Return to input a new line above the title token.

8.

Enter one of the following tokens in the new line above the title token:
●
●

9.

10.

{@flowDedication@}: shows the dedication for the flow.
{@projectDedication@}: shows the dedication for the whole project.

Change the text style of the dedication in any of the following ways:
●

Create a new paragraph style for dedications, and select it from the Paragraph
Style menu in the text editor.

●

Change the font size in the text editor.

●

Change the character style in the text editor.

Close the text editor in any of the following ways:
●

Press Esc or Ctrl/Cmd-Enter.

●

Click anywhere outside the text editor.

RESULT
A dedication is shown above the title of all pages that use the selected master page format, if a
dedication is entered into the appropriate fields in the Project Info dialog.
RELATED LINKS
Creating paragraph styles on page 154
Text Editor on page 151

Changing the text in running headers in master pages
The Default Part master page set shows the part name at the top left of the first pages in flows,
and also shows the part name centered at the top of subsequent pages as a running header.
You can change the text shown in running headers, for example, if you want to include the flow
title as well.
PROCEDURE
1.

In Engrave mode, select the master page set containing the master page whose running
header text you want to change from the Current set menu in the Master Pages section
of the Pages panel.
For example, if you want to change the running header text in parts, select Default Parts.

2.

Double-click on the master page whose running header text you want to change. For
example, if you are using the default master pages, double-click Default.

3.

In the master page editor, activate Frames in the Formatting panel.

4.

Select the header text frame at the top of the page.

5.

Open the text editor in one of the following ways:
●

Press Return.
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●
6.

Double-click within the text frame.

Change the header text and add extra text, or delete the header text, as you want.
For example, to show both the part name and the flow title in the header text separated by
a dash, enter - {@flowTitle@} after the part name token in the text frame.

7.

Close the text editor in any of the following ways:
●

Press Esc.

●

Press Ctrl/Cmd-Enter.

●

Click anywhere outside the text editor.

RESULT
The running header text is changed for all layouts that use the selected master page format.
EXAMPLE

Text added to the text frame in the master page
editor.

An example of how the added text appears in
individual part layouts.

Individual changes to the formatting of pages
You can add new frames, and change the shape and size of existing frames, on individual pages
independently of master page formats.
For example, you may want to include project information on the first page of the first flow in the
project, but not on subsequent flows.
RELATED LINKS
Frames on page 145
Inserting frames into pages on page 145
Moving frames individually on page 146
Changing the size and shape of frames individually on page 146

Changing the default horizontal alignment of different text
styles project-wide
You can change the default alignment of each text style available in the Paragraph Styles dialog.
This changes the alignment of that text style wherever it is used in the project, but the alignment
can also be manually overridden in individual text frames.
PROCEDURE
1.

In Engrave mode, open the Paragraph Styles dialog by choosing Engrave > Paragraph
Styles.

2.

Select the text style whose default alignment you want to change from the list on the left
of the dialog.

3.

Choose one of the following Alignment options:
●

Left-align

●

Center-align

●

Right-align
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●

Justify

●

Inside edge

●

Outside edge

RESULT
The default alignment of the selected text style is changed.
NOTE
You can change other aspects of text styles in the Paragraph Styles dialog.

RELATED LINKS
Paragraph styles on page 152
Changing the horizontal alignment of text in text frames on page 149

Changing the vertical alignment of text in text frames
You can change the vertical alignment of text in text frames.
You can do this on master pages, which changes the alignment of the selected text on all pages
that use the master page format, and on individual pages, which only changes the alignment of
the selected text on that page.
NOTE
If you want to change the vertical alignment of text on master pages, first open the master page
editor.

PROCEDURE
1.

In Engrave mode, activate Frames in the Formatting panel.

2.

Select the frames whose text vertical alignment you want to change.

3.

Select one of the following options from the Vertical alignment menu in the Text group
of the Properties panel:
●

Top

●

Center

●

Bottom

RESULT
The vertical alignment of text in the selected text frames is changed.
NOTE
Changing the vertical alignment of text does not override its paragraph style. Any changes
you make later to the paragraph styles of text whose vertical alignment has been changed are
applied to the text.

RELATED LINKS
Customizing master pages on page 137
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Grace notes are small notes that are intended to be played quickly. They are scaled-down
versions of normal noteheads, and are commonly shown with a slash through their stem.
Grace notes with slashed stems are known as acciaccaturas and are often played very fast. Grace
notes without slashed stems are known as appoggiaturas and are often played slower than
acciaccaturas.
In Baroque music, appoggiaturas are often understood to last for a specific duration, based on
the rhythmic value of the notehead to which they are attached and the meter.
Grace notes do not take up space rhythmically, as they are intended to be squeezed into the
space before the notehead to which they are attached, which is the notehead immediately to
their right.
There can be multiple grace notes before a notehead. If there are two or more grace notes
attached to the same notehead, and they have a rhythmic value that shows a flag on the stem,
such as eighth notes and sixteenth notes, they can be beamed together.
In Dorico, grace notes are scaled to 3/5 the size of a normal notehead by default.

General placement conventions for grace notes
Grace notes are always positioned before a notehead, even if they are intended to be played on
the beat rather than before the beat.
They appear stem up by default, except when there are multiple voices with grace notes in a
single staff, in which case grace notes in the lower voices appear stem down.
Grace notes are normally placed after a barline so they can be positioned directly before the
notehead to which they are attached. However, groups of three or more grace notes can be
placed before the barline so that the note of the first beat in the bar is not pushed too far from
the barline.
Articulation and accidentals can be added to grace notes. Adding accidentals causes their
spacing to readjust so that the accidentals are clearly legible, similar to normal notes. Articulation
can be added to grace notes wherever it is most clearly legible, which is most likely outside the
staff. Dorico automatically places articulation on the stem-side of grace notes, and outside the
staff if the stem or beam is within the staff.
Grace note stem slashes should always appear at the beginning of a grace note beam, if multiple
grace notes can be joined by a single beam at the same rhythmic position. If there is a single
grace note, the slash appears across the stem, and its flag if applicable, and extends either side
of the stem.
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RELATED LINKS
Positioning grace notes before barlines on page 380

Grace note placement in staves with multiple voices
According to accepted notation convention, grace notes appear stem up by default when there is
only one voice in a staff, even if the notehead to which they are attached is stem down.
However, when there are multiple voices in the staff, all notes in the upper voices appear stem
up and all notes in the lower voices appear stem down, including all grace notes. This adjustment
happens automatically in Dorico.

NOTE
You can also override the stem direction of grace notes in multiple voices and change their
directions individually if necessary.

RELATED LINKS
Changing the stem direction of grace notes individually on page 386
Slur placement relative to grace notes on page 566

Positioning grace notes before barlines
Grace notes by default are positioned directly before the notehead to which they apply, including
for the first note in a bar.
However, groups of three or more grace notes can be placed before the barline so that the note
of the first beat in the bar is not pushed too far from the barline.
PROCEDURE
1.

Select the grace notes that you want to reposition before barlines. You can do this in Write
mode and Engrave mode.

2.

Activate the Grace note before barline property in the Grace Notes group of the
Properties panel.

RESULT
The selected grace notes are repositioned before the barline.
NOTE
This property can only be activated for grace notes that immediately follow a barline.

Inputting grace notes with the keyboard
Grace notes are input like normal notes, and can have any rhythmic note value. Like normal
notes, they can only be input during note input.
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where you want to input grace notes.
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3.

Press /, and the number for the rhythmic duration you want. For example, press 5 to input
eighth notes.
TIP
These can be selected in any order.

4.

Enter or play in the pitches you want.

5.

Press / again to stop inputting grace notes, and return to inputting normal notes.

RESULT
The pitches you enter are input as grace notes at the caret position.
If you are inputting grace notes after previously inputting normal notes, the rhythmic duration of
the grace notes is the same as the last input normal note. You can change the rhythmic duration
in the same way as for normal notes.
There is no limit to the number of grace notes that can exist at the same rhythmic position.
RELATED LINKS
Inputting notes on page 94

Inputting grace notes with the mouse
Grace notes are input like normal notes, and can have any rhythmic note value. Like normal
notes, they can only be input during note input.
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where you want to input grace notes.

3.

Click Grace Notes in the Notes toolbox:

You can also select the rhythmic duration you want in the Notes panel.
TIP
These can be selected in any order.
4.

Click in or play in the pitches you want.

5.

Click on the grace notes button again to stop inputting grace notes, and return to
inputting normal notes.

RESULT
The pitches you click in are input as grace notes at the caret position.
If you are inputting grace notes after previously inputting normal notes, the rhythmic duration of
the grace notes is the same as the last input normal note. You can change the rhythmic duration
in the same way as for normal notes.
There is no limit to the number of grace notes that can exist at the same rhythmic position.
RELATED LINKS
Inputting notes on page 94
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Changing the pitch of grace notes
The pitch of grace notes can be changed after they have been input in the same ways as for
normal notes.
PROCEDURE
1.

In Write mode, select the grace notes whose pitch you want to change.

2.

Change the pitch of the grace notes in any of the following ways:
●

Press Alt-Up Arrow to transpose grace notes up one pitch.

●

Press Ctrl/Cmd-Alt-Up Arrow to transpose grace notes up one octave.

●

Press Alt-Down Arrow to transpose grace notes down one pitch.

●

Press Ctrl/Cmd-Alt-Down Arrow to transpose grace notes down one octave.

Adding accidentals and articulation to grace notes
Accidentals and articulation can be added to grace notes in the same ways as they can be added
to normal notes.
You can input grace notes instead of normal notes during note input in the following ways:
●

Press /.

●

Click the grace notes button in the Notes panel:

RELATED LINKS
Adding accidentals to existing notes on page 189
Inputting notes with accidentals on page 188
Inputting articulations during step input with the keyboard on page 205
Inputting articulations during step input with the mouse on page 206

Slurs on grace notes
Slurs can be used on grace notes in the same ways as they can be used on normal notes.
You can adjust the position and shape of slurs on grace notes individually by changing the stem
direction of a grace note, changing the direction of a slur, and using the slur handles in Engrave
mode to adjust the position of a slur in finer detail.
RELATED LINKS
Inputting slurs during step input on page 568
Adding slurs to existing notes on page 568
Slur placement relative to grace notes on page 566
Slurs in Engrave mode on page 575
Changing the shape of slurs individually on page 575
Short slurs that cover large pitch ranges on page 578
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Moving grace notes rhythmically
You can move grace notes to different rhythmic positions on the staff after they have been input.
PROCEDURE
1.

In Write mode, select the grace notes you want to move.

2.

Move the selected grace notes in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

RESULT
The selected grace notes are moved to the right or to the left along the staff, according to the
rhythmic grid currently set.
RELATED LINKS
Changes to note spacing in Engrave mode on page 461

Deleting grace notes
PROCEDURE
1.

In Write mode, select the grace notes you want to delete.

2.

Delete the grace notes in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected grace notes are deleted. If other grace notes remain at the rhythmic position, their
positions are automatically adjusted.

Project-wide changes to the position of grace notes
You can change the default position of grace notes relative to the notehead to which they apply
in the Grace Notes section of the Notes page in Engraving Options.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Increasing the value for the minimum distance to the right of the rightmost grace note moves
grace notes further from the notehead to which they apply. Decreasing the value moves them
closer to the notehead to which they apply.

A grace note with the default minimum value of half
a space between it and the notehead to its right.
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A grace note with an increased value of 1.5 spaces
between it and the notehead to its right.
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You can also adjust the position of grace notes for each layout project-wide by changing the
note spacing scale factor for grace notes. This setting can be found on the Note Spacing page in
Layout Options. You can open Layout Options in the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

Decreasing the note spacing scale value for grace notes decreases the gap between multiple
grace notes at the same rhythmic position.

Three grace notes with long durations, with the
default note spacing scale of 70%.

Three grace notes with long durations, with a
decreased note spacing scale of 20%.

Position of slurs relative to grace notes
The position of slurs relative to grace notes can be set in the Grace Notes section of the Slurs
page in Engraving Options.
Included in this section are options for the position of slurs relative to grace notes in multiple
voices.
RELATED LINKS
Slur placement relative to grace notes on page 566

Project-wide changes to the position of grace note beams
You can make project-wide changes to the position of grace note beams in the staff.

Position of grace note beams in the staff
Like all beams, grace note beams should ideally follow the accepted standards for beam
placement relative to staff lines, in order to avoid wedges. However, because grace notes are
smaller than normal notes, this can lead to extreme slants in grace note beams.
In Dorico, you can change how grace note beam slants are positioned project-wide in the
Vertical Position section of the Beams page in Engraving Options.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Beam slants in two-note groups of beamed grace notes
If there are two grace notes that cover a wide pitch range joined by a beam at the same rhythmic
position,the angle of the beam can appear very steep.
You can choose whether the beam slant in such cases is left unchanged, or whether shallower
slants are used, in the Slants section of the Beams page in Engraving Options.
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Project-wide changes to the appearance of grace notes
You can make project-wide changes to the appearance of grace notes in terms of their size, stem
length, and slash design.

Grace note size
Grace notes are smaller versions of normal noteheads, and are scaled-down by a ratio that is set
by default to 3/5 of a normal note.
You can change this ratio by increasing or decreasing the value for Grace note scale factor in
the Grace Notes section of the Notes page in Engrave > Engraving Options.

Grace note stem length
Grace notes are scaled-down notes, so the default stem length of grace notes is determined by
your project-wide settings for the stem length of all notes.
These can be set in the Stems section of the Notes page in Engraving Options.

Grace note slash design
The precise measurements of each part of grace note stem slashes can be set in the Grace
Notes section of the Notes page in Engraving Options.
In this section you can:
●

Change the thickness of grace note stem slashes.

●

Change the default length of grace note stem slashes.

●

Change the position of grace note stem slashes relative to the end of the stem.

Individual changes to the appearance of grace notes
You can make changes to the appearance of grace notes individually, such as changing the
appearance of grace note stems.
You can change the appearance of grace notes using properties in the Grace Notes group of the
Properties panel at the bottom of the window. More properties are available in Engrave mode
than in Write mode.
For beamed grace note groups, you can also change the grace note beam using properties in the
Beaming group of the Properties panel.
RELATED LINKS
Beaming on page 246
Changing beam groups on page 247
Changing beam slants individually using the Properties panel on page 254

Changing the type of grace notes individually
There are two types of grace note: one has a stem slash, the other does not have a stem slash.
Grace notes with slashed stems, known as acciaccaturas, are often played with a shorter duration
than grace notes without slashed stems, known as appoggiaturas.
In Dorico, grace notes appear with slashed stems by default.
You can change the type of grace notes individually.
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PROCEDURE
1.

Select the grace notes whose type you want to change. You can do this in Write mode and
Engrave mode.

2.

Choose one of the following options for the Grace note type property in the Grace Notes
group of the Properties panel:
●

Slashed stem

●

Unslashed stem

RESULT
The type of grace note for the selected grace notes is changed.
This process can be repeated at any time if you want to change grace notes back to their original
type.

Changing the stem direction of grace notes individually
Following accepted conventions, grace notes in Dorico are stem up by default in any clef,
regardless of the stem direction of the note to which they apply. The stem directions of grace
notes are changed automatically when there are multiple voices in a staff.
You can also change the stem direction of individual grace notes manually.
PROCEDURE
1.

Select the grace notes whose stem directions you want to change. You can do this in Write
mode and Engrave mode.

2.

Change the stem direction of the selected grace notes in any of the following ways:
●

Choose Edit > Stem > Force Stem Down.

●

Right-click and choose Stem > Force Stem Down from the context menu.

●

Choose Edit > Stem > Force Stem Up.

●

Right-click and choose Stem > Force Stem Up from the context menu.

Removing grace note stem direction changes
You can remove changes to the stem direction of grace notes.
PROCEDURE
1.

Select the grace notes whose stem direction changes you want to remove.

2.

Remove the stem direction change in any of the following ways:
●

Choose Edit > Stem > Remove Forced Stem.

●

Right-click and choose Stem > Remove Forced Stem from the context menu.

RESULT
The grace note stems revert to their default directions.
Alternatively, you can remove a stem direction change individually by forcing its stem in the
opposite direction.

386

Grace notes
Individual changes to the appearance of grace notes
RELATED LINKS
Changing the stem direction of grace notes individually on page 386

Changing the stem length of grace notes individually
You can make individual changes to the length of grace note stems.
PROCEDURE
1.

In Engrave mode, select the stems of the grace notes whose the stem lengths you want to
change.

2.

Change the grace note stem length in any of the following ways:
●

Press Alt-Up Arrow to move the ends of stems upwards.

●

Press Alt-Down Arrow to move the ends of stems downwards.

●

Click and drag the ends of stems upwards or downwards to the lengths you want.

RESULT
Moving the end of an up-stem grace note upwards lengthens the grace note stem, and moving
the end of an up-stem grace note downwards shortens the grace note stem.
Moving the end of a down-stem grace note upwards shortens the grace note stem, and moving
the end of a down-stem grace note downwards lengthens the grace note stem.
RELATED LINKS
Project-wide changes to the appearance of grace notes on page 385

Changing the position of slashes on grace note stems individually
You can change the positions of grace note slashes individually, independently of your projectwide settings for the positions of grace note slashes.
PROCEDURE
1.

In Engrave mode, select the grace notes whose slash positions you want to change.

2.

Activate the following properties, individually or together, in the Grace Notes group of the
Properties panel:

3.

4.

●

Slash inset from stem tip

●

Slash offset to right

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties change the position of grace note slashes in the following ways:
●

Slash inset from stem tip moves grace note slashes vertically: increasing the value
moves them further from the tips of stems, decreasing the value moves them closer
to the tips of stems.

●

Slash offset to right moves grace note slashes horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.
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RELATED LINKS
Project-wide changes to the appearance of grace notes on page 385
Changing the length of grace note slashes individually on page 388

Changing the length of grace note slashes individually
You can change the length of slashes on grace note stems individually, independently of your
project-wide setting for the length of grace note slashes.
PROCEDURE
1.

In Engrave mode, select the grace notes whose slash length you want to change.

2.

Activate the following properties, individually or together, in the Grace Notes group of the
Properties panel.
●

Slash length

●

Slash protrusion from beam (beamed grace notes only)

NOTE
Grace note slashes seem to disappear when you activate the Slash length property. This
is because activating the property resets the value to 0.
3.

4.

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties change the length of grace note slashes in the following ways:
●

Increasing the value for Slash length lengthens grace note slashes.

●

Decreasing the value for Slash length shortens grace note slashes.

●

Increasing the value for Slash protrusion from beam increases how far slashes
extend beyond grace note beams.

●

Decreasing the value for Slash protrusion from beam decreases how far slashes
extend beyond grace note beams.

RELATED LINKS
Changing the position of slashes on grace note stems individually on page 387
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Different notations are used to show where the established rhythmic flow of the music is
interrupted, either with a moment of repose or a short silence, before continuing. The most
subtle effect is produced by a tenuto mark, with more significant effects denoted with holds and
pauses.
The duration of the break or hold does not need to be specified, and so significant room for
interpretation is left, even though the different styles of holds and pauses normally indicate
larger or smaller breaks.

Types of holds and pauses
There are three types of holds and pauses in Dorico, and they can all be input, moved, and
deleted in the same ways.
Fermatas
Fermatas indicate that a note should be held for longer than its notated length,
which applies to the whole ensemble.
They are also known as “pauses” and informally sometimes called “birds’ eyes”.
Breath marks
These show where a player should breathe, or suggest how the music should be
phrased to create a similar effect.
Caesuras
These indicate that a note should be sustained for its full value, then be followed by a
break in sound before continuing.

Types of fermata
There are eight types of fermata available in Dorico.
Fermata

Description

Very short fermata ()

A pause, indicating a note should be held only
a fraction longer than the rhythm indicates.

Short fermata ()

A pause, indicating a note should be held a
little bit longer than the rhythm indicates.

Short fermata (Henze) ()

A pause, indicating a note should be held a
little bit longer than the rhythm indicates, as
used by Hans Werner Henze.

Fermata ()

A pause, indicating a note should be held for
longer than the rhythm indicates.
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Fermata

Description

Long fermata ()

A pause, indicating a note should be held quite
a lot longer than the rhythm indicates.

Long fermata (Henze) ()

A pause, indicating a note should be held quite
a lot longer than the rhythm indicates, as used
by Hans Werner Henze.

Very long fermata ()

A pause, indicating a note should be held for
much longer than the rhythm indicates.

Curlew (Britten) ()

A pause, indicating a note or rest should be
held until the next synchronization point in
asynchronous music, as used by Benjamin
Britten.

The fermatas can be divided into two styles, which should not both be used in the same score
because they overlap:
Style:

Very short
fermata

Short
fermata

Fermata

Long fermata Very long
fermata

Normal:
Henze:

N/A

N/A

RELATED LINKS
The holds and pauses popover on page 392
Changing the appearance or duration of existing holds and pauses on page 396

Types of breath marks
There are four types of breath marks available in Dorico.
●

Comma-like ()

●

Tick-like ()

●

Upbow-like ()

●

Salzedo ()

All indicate the same idea: showing where a player should take a breath, or create a musical
effect like a breath.
RELATED LINKS
The holds and pauses popover on page 392
Changing the appearance or duration of existing holds and pauses on page 396
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Types of caesura
There are four types of caesura available in Dorico, each of which indicate a break in sound.
Caesura

Description

Caesura ()

Two diagonal slashes.

Thick caesura ()

Two thick diagonal slashes.

Short caesura ()

Two straight, vertical slashes.

Curved caesura ()

Two curved diagonal slashes.

All four caesuras indicate the same effect, but different types are often needed for different
styles of musical scores.
If you intend to communicate a specific length of hold or gap with each type of caesura, consider
adding a legend, as different players may interpret these symbols differently.
RELATED LINKS
The holds and pauses popover on page 392
Changing the appearance or duration of existing holds and pauses on page 396

General placement conventions for holds and pauses
Holds and pauses are always placed above the staff. For staves with multiple voices, fermatas can
be placed inverted below the staff.

Fermatas
Fermatas are positioned centered on noteheads, regardless of the note’s stem direction.
Because fermatas affect the overall tempo of the piece, all players must be able to see where
this happens. As such, fermatas are added to all staves at the same rhythmic position, or the
rhythmic position of the note, chord, or rest that corresponds with the end of the fermata,
including over a bar rest if a staff has no notes in that bar.
You can change the ideal distance between fermatas and the staff on the Holds and Pauses
page in Engrave > Engraving Options.

Breath marks
Breath marks are placed above the top line of the staff, at the end of the note to which they
apply; that is, they appear just before the following note.
Breath marks apply only to the staff to which they were added, as they do not affect the overall
tempo, but instead only indicate to a single player or group of players a good place to break their
line in order to breathe.
You can change the ideal distance between breath marks and the staff, and between breath
marks and the next note or rest, on the Holds and Pauses page in Engrave > Engraving
Options.

Caesuras
Caesuras are positioned at the top of the staff, with the top staff line passing through the
middle of the caesura and the bottom of the caesura resting on the second staff line. They are
commonly placed at the end of a bar, before the barline.
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Caesuras are automatically added to all staves at the same rhythmic position, immediately to the
left of the notehead or barline to which they were input. They are not linked to noteheads, and
adjust note spacing to create a clear gap.
You can change the size of the gap to the right of caesuras on the Holds and Pauses page in
Engrave > Engraving Options.

Inputting holds and pauses with the keyboard
You can input holds and pauses with the keyboard by using the holds and pauses popover in
Write mode.
You can open the holds and pauses popover in Write mode in the following ways:
●

Press Shift-H.

●

Choose Write > Create Hold or Pause.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The holds and pauses popover with an example
entry for a hold or pause

The holds and pauses button in the Notations
toolbox

The holds and pauses popover
Enter the following commands or symbols into the holds and pauses popover to create the
different holds and pauses available.
You can open the holds and pauses popover in Write mode in the following ways:
●

Press Shift-H.

●

Choose Write > Create Hold or Pause.

Enter:

For hold or pause:

fermata

Fermata ()

fermataverylong

Very long fermata ()

fermatalong

Long fermata ()

fermatashort

Short fermata ()

fermataveryshort

Very short fermata ()

fermatashorthenze

Short fermata (Henze) ()

fermatalonghenze

Long fermata (Henze) ()

curlew

Curlew (Britten) ()

caesura or //

Caesura ()
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Enter:

For hold or pause:

caesurathick

Thick caesura ()

caesuracurved

Curved caesura ()

caesurashort

Short caesura ()

breathmarkcomma or comma or ,

Breath mark (Comma-like) ()

breathmarktick

Breath mark (Tick-like) ()

breathmarkupbow

Breath mark (Upbow-like) ()

breathmarksalzedo

Breath mark (Salzedo) ()

NOTE
The Curlew mark was originally devised by Benjamin Britten for “Curlew River”, a parable for
church performance inspired by Japanese Noh theater. It indicates that a player should hold a
note or a rest until a synchronization point in asynchronous music.

RELATED LINKS
Inputting holds and pauses during step input with the keyboard on page 393
Adding holds and pauses to existing notes with the keyboard on page 394

Inputting holds and pauses during step input with the keyboard
You can input holds and pauses with the keyboard during step input.
PROCEDURE
1.

In Write mode, start note input.

2.

Open the holds and pauses popover in any of the following ways:
●

Press Shift-H.

●

Choose Write > Create Hold or Pause.

3.

Enter your preferred hold or pause into the popover. For example, fermata or caesura.

4.

Press Return to close the popover.

RESULT
The specified hold or pause is added at the caret position. Note input continues if you only press
Return once.
NOTE
Pressing Return twice to close the popover stops note input.
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Adding holds and pauses to existing notes with the keyboard
You can add holds and pauses to existing notes with the keyboard.
PROCEDURE
1.

In Write mode, select the note to which you want to add a hold or pause.
NOTE
You can only add one hold or pause to one note at a time.

2.

Open the holds and pauses popover in any of the following ways:
●

Press Shift-H

●

Choose Write > Create Hold or Pause

3.

Enter the hold or pause you want into the popover. For example, fermata for a standard
curved pause mark.

4.

Press Return to close the popover.

RESULT
Fermatas appear above the selected note, and above all notes or rests at that rhythmic position,
or the rhythmic position of the note, chord, or rest that corresponds with the end of the fermata
on every staff. The fermata may then be a note or rest earlier in the bar.
Breath marks only appear to the right of the selected note or notes.
Caesuras appear to the left of the selected note, and on all staves at that same rhythmic position.

Inputting holds and pauses with the mouse
Holds and pauses can be input with the mouse using the Holds and Pauses panel on the right of
the window.
The Holds and Pauses panel is opened by clicking Holds and Pauses in the Notations toolbox on
the right of the window in Write mode:

There are three sections in the Holds and Pauses panel:
1

Fermatas

2

Breath Marks

3

Caesuras

Inputting caesuras at the correct position with the mouse
Caesuras are commonly placed at the end of a bar, before a barline. In Dorico, caesuras should
be attached to the note immediately after the position you want it to appear, as then Dorico can
automatically position them correctly.
If you input caesuras with your mouse input preference set to Load cursor with item, you must
click the first note in the next bar for a caesura to appear before the barline. You can also click
directly on the barline.
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A correctly input caesura. The dashed guidelines
are attached to the notehead after the barline,
meaning the caesura is correctly positioned before
the barline.

An incorrectly input caesura. By clicking to the left of
the barline, the caesura is attached to the last eighth
note in the bar.

When input correctly, the dashed guidelines link the caesura to the notehead immediately after
the barline.
If your dashed guidelines do not link the caesura to the notehead immediately after the barline,
delete the caesura and re-input it. Caesuras can cause spacing issues when input incorrectly.

Inputting holds and pauses during step input with the mouse
You can input holds and pauses with the mouse during step input.
PROCEDURE
1.

In Write mode, start note input.

2.

Click the hold or pause you want in the Holds and Pauses panel on the right of the
window.

RESULT
The hold or pause is input at the caret position.

Adding holds and pauses to existing notes with the mouse
You can add holds and pauses to existing notes with the mouse:
PROCEDURE
1.

In Write mode, select the note to which you want to add a hold or pause.
NOTE
You can only add one hold or pause to one note at a time.

2.

Click on your preferred hold or pause in the Holds and Pauses panel on the right of the
window.

RESULT
Fermatas appear above the selected note, and above all notes or rests at that rhythmic position,
or the rhythmic position of the note, chord, or rest that corresponds with the end of the fermata
on every staff. The fermata may then be a note or rest earlier in the bar.
Breath marks only appear to the right of the selected note or notes.
Caesuras appear to the left of the selected note, and on all staves at that same rhythmic position.
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Changing the appearance or duration of existing holds and
pauses
You can change the appearance or duration of existing holds and pauses, for example, you can
change a short fermata into a long fermata. You cannot change the type of an existing hold or
pause, for example, you cannot change a fermata into a caesura.
PROCEDURE
1.

In Write mode, select the holds or pauses whose appearance or duration you want to
change.
NOTE
Only select multiple holds and pauses of the same type. For example, select only fermatas
or only caesuras.

2.

Change the appearance or duration of the holds or pauses in one of the following ways:
●

Open the holds and pauses popover by pressing Shift-H and enter your preferred
appearance or duration into the popover.

●

Click your preferred appearance or duration in the Holds and Pauses panel on the
right of the window.

●

Select your preferred appearance or duration from the appropriate menu for your
selected holds or pauses in the Holds and Pauses group of the Properties panel:
Fermata duration, Caesura appearance, or Breath mark appearance.
NOTE
These menus only appear when the corresponding type of holds or pauses is
selected. If your selection includes different types of holds and pauses, for example,
fermatas and caesuras, no menu is shown.
The Curlew (Britten) fermata is not included in the Fermata duration menu, as it
only applies to individually selected notes.

RESULT
The appearance or duration of the selected holds or pauses is changed.
NOTE
If you want to change the type of a hold or pause, you should delete the existing hold or pause
and input a new one of your preferred type.

RELATED LINKS
The holds and pauses popover on page 392
Inputting holds and pauses with the keyboard on page 392
Inputting holds and pauses with the mouse on page 394

Positions of holds and pauses
You can change the positions of holds and pauses by moving individual holds and pauses to
different rhythmic positions in Write mode, moving them to different graphical positions in
Engrave mode, and by changing the default positions of all holds and pauses project-wide.
You can move holds and pauses to different rhythmic positions in Write mode. They are
positioned by default according to your preferences in Engraving Options.
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You can move holds and pauses graphically in Engrave mode, however, this does not change the
rhythmic positions to which they are attached.
Project-wide settings for the default positions of holds and pauses, and values for the minimum
gaps around holds and pauses, can be set on the Holds and Pauses page in Engrave >
Engraving Options.
RELATED LINKS
Project-wide Engraving Options for holds and pauses on page 401

Moving holds and pauses rhythmically
You can move holds and pauses to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the holds and pauses you want to move.

2.

Move the holds or pauses according to the rhythmic grid currently set in any of the
following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the hold or pause to the right or to the left.
NOTE
Only one hold or pause can be moved rhythmically at a time when using the mouse.

RESULT
The selected holds and pauses are moved to new rhythmic positions, as well as all other hold or
pause markings of the same type at the same rhythmic position even if their position does not
appear to move.
For example, if one staff has a bar rest, the rhythmic position of the hold or pause moves, but the
hold or pause still appears above the rest.
NOTE
Only one hold or pause can exist at each rhythmic position. If a hold or pause passes over
another hold or pause as part of its move, the existing hold or pause is deleted.
If you moved holds and pauses using the keyboard, you can undo the move to restore any holds
and pauses deleted in the process.
However, if you moved holds and pauses using the mouse, undoing the move does not restore
any holds and pauses deleted in the process.
Moving holds and pauses back to their previous positions later does not restore any holds and
pauses deleted when they were moved previously. The deleted holds and pauses must be reinput if necessary.

Moving holds and pauses graphically
You can move holds and pauses graphically without changing the rhythmic positions to which
they apply.
PROCEDURE
1.

In Engrave mode, select the holds and pauses you want to move.

2.

Move the holds and pauses in any of the following ways:
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●

Alt-Right Arrow

●

Alt-Left Arrow

●

Alt-Up Arrow

●

Alt-Down Arrow
TIP
If you want to move holds and pauses by larger increments, you can press Ctrl/Cmd
as well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the holds and pauses in any direction to the positions you want.

RELATED LINKS
Moving fermatas graphically using the Properties panel on page 398

Moving fermatas graphically using the Properties panel
You can move fermatas graphically using the Properties panel. You cannot move any other type
of hold or pause using the Properties panel.
PROCEDURE
1.

In Engrave mode, select the fermatas you want to move.

2.

Activate the Start offset property in the Holds and Pauses group of the Properties panel.

3.

The Start offset property has X and Y value fields. Change the values in the value fields in
any of the following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The Start offset property moves fermatas in the following ways:
●

Start offset X moves fermatas horizontally: increasing the value moves them to the
right, decreasing the value moves them to the left.

●

Start offset Y moves fermatas vertically: increasing the value moves them upwards,
decreasing the value moves them downwards.

Deleting holds and pauses
PROCEDURE
1.

In Write mode, select the holds and pauses you want to delete.
NOTE
All fermatas or caesuras at the same rhythmic position are also selected when at least one
fermata or caesura is selected.

2.

Delete the holds and pauses in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected holds and pauses are deleted.
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All fermatas or caesuras at the same rhythmic position are deleted, but only the selected breath
marks are deleted.

Changing the placement of fermatas relative to the staff
Fermatas are normally placed above the staff; however, you can change the placement of
fermatas relative to the staff individually.
PROCEDURE
1.

In Engrave mode, select the fermatas whose placement relative to the staff you want to
change.

2.

Activate the Placement property in the Holds and Pauses group of the Properties panel.

3.

Choose one of the following options:
●

Above

●

Below

Changing the number of fermatas per staff
You can change the maximum number of fermatas that appear in each staff when there are
multiple voices in a staff.
PROCEDURE
1.

Select a fermata or multiple fermatas. You can do this in Write mode and Engrave mode.

2.

Activate the Max. fermatas per staff property in the Holds and Pauses group of the
Properties panel.

3.

Select one of the following options from the menu:
●

One per voice

●

One per each side of staff: one above and one below

●

One per staff

RESULT
The number of fermatas shown at the selected positions is changed.
NOTE
You can also set the maximum number of fermatas that can appear in a single staff project-wide.

RELATED LINKS
Project-wide Engraving Options for holds and pauses on page 401

Positioning fermatas on barlines
Fermatas can be individually positioned over a barline instead of over a note, to indicate a gap
before the start of the following bar.
PROCEDURE
1.

Select the fermata you want to position over the barline.

2.

Activate the Attach to barline property in the Holds and Pauses group of the Properties
panel.
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NOTE
This property can be deactivated, returning the fermata to its default position above the
notehead closest to the rhythmic position to which it is attached on every staff.

RESULT
The fermata is positioned above the barline, appearing only above staves that are not joined by
the barline. Depending on the instrumentation, this may mean it only appears at the top of the
system.

Copying holds and pauses
Holds and pauses can be selected and copied independently of noteheads.
PROCEDURE
1.

In Write mode, select the hold or pause you want to copy.

2.

Copy the hold or pause in any of the following ways:
●

Press Ctrl/Cmd-C.

●

Choose Edit > Copy.

3.

Select the notes or rests where you want to paste it.

4.

Paste the hold or pause in any of the following ways:
●

Press Ctrl/Cmd-V.

●

Choose Edit > Paste.

Alternatively, you can select the fermata, breath mark, or caesura you want to copy, hold
down the Alt key, and click on a note or rest at the rhythmic position where you want to
copy it. This copies the selected fermata, breath mark, or caesura without adding it to your
clipboard.
NOTE
You can only copy the number of holds or pauses originally selected. For example, if you
copy a single hold or pause, only a single hold or pause is pasted, even if pasted to a
selection of notes.
Breath marks can only be copied to notes currently selected. Fermatas and caesuras can
be copied to notes or rests on all staves at the same rhythmic position as the selected
note.

Multiple holds and pauses at the same rhythmic position
Only one type of fermata can exist at the same rhythmic position. For example, you cannot have
a short fermata on one staff and a long fermata at the same rhythmic position on another staff.
However, a Britten curlew can be used at the same rhythmic position as another kind of fermata,
but it cannot exist simultaneously with any breath mark. This is the only exception in Dorico.
Caesuras can co-exist with any type of breath mark, but you cannot have a caesura and a fermata
at the same rhythmic position.
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Project-wide Engraving Options for holds and pauses
Options for the positions of holds and pauses project-wide can be found on the Holds and
Pauses page in Engraving Options.
The options on this page allow you to change the default positions and placement of holds and
pauses, including the placement of fermatas in multi-voice contexts.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Holds and Pauses in the page list on the left of the dialog.

Changes to fermatas on single staves
Changing the type of fermata or caesura on one staff automatically changes the type on all
staves at that rhythmic position, as a pause at one particular moment can only be of one
duration.
However, if you override a particular fermata on one staff, for example, by changing it to a
Britten curlew or a breath mark, changing the fermata on another staff does not change that
overridden staff. Deleting the overridden fermata reverts that staff to match the other staves.
In these examples, changing a fermata to a breath mark changes the marking for only that staff.
That note is not affected when the type of fermata on the other staves at that rhythmic position
is changed.

The bottom staff was overridden
The fermata was changed to
to show a breath mark instead of a a very short fermata, but the
fermata.
bottom staff is exempt as it was
overridden to show a breath mark.

Deleting the breath mark from the
bottom staff returns it to showing
the fermata currently chosen for
that rhythmic position.

Holds and pauses in playback
Holds and pauses do not currently have an effect in playback, but this is planned for future
versions.
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Key signatures are the markings that show the current key of music by indicating which notes in
the scale for that key are sharpened or flattened.
This saves space, as by indicating which notes are generally going to be sharp or flat in the music
in one group at the start of each system, these notes do not need an accidental beside them
every time they occur.
Traditionally, accidentals are organized following the pattern of the circle of fifths, which is
different for sharp keys and flat keys.
In Dorico, key signatures exist within the overarching tonality system for your project. The two
tonality systems that come as standard in Dorico are 12-EDO and 24-EDO.
Once you have selected or created a tonality system for your project, you can then create custom
key signatures and custom accidentals within that tonality system.
RELATED LINKS
General placement conventions for key signatures on page 402
Tonality systems on page 404

General placement conventions for key signatures
Over time, the placement and appearance of key signatures has come to follow conventions to
ensure they are always understood. Dorico follows these conventions automatically.
The order in which accidentals are shown in key signatures is different for sharp keys and flat
keys.
●

For sharps: F♯, C♯, G♯, D♯, A♯, E♯, B♯.

●

For flats: B♭, E♭, A♭, D♭, G♭, C♭, F♭.

Accidentals are arranged automatically in these orders in Dorico for all standard Western key
signatures. There is an accepted pattern for the placement of accidentals in a key signature, so
that they fit inside the staff according to the current clef. The pattern of accidentals is the same in
all clefs, apart from the tenor clef.
Clef:

Arrangement of sharps:

Treble

Bass
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Clef:

Arrangement of sharps:

Arrangement of flats:

Alto

Tenor

For custom, non-standard key signatures, the order in which accidentals appear in the key
signature can be determined in the Edit Custom Key Signature dialog.
A key signature should be shown at the start of a piece and at the start of subsequent
movements, if applicable, even if the music carries straight on.
They should be placed after clefs, but before time signatures.

The correct placement of key signatures: between a clef and time signature.

Unlike time signatures, key signatures appear on every system in both the full score and parts,
even if the key signature has not changed.
If a key signature change occurs during a piece or movement, it should be placed immediately
after a barline. It is customary to have a double barline where a key signature change takes
place, and this is the default setting in Dorico for all keys.

A key signature applies until the end of a movement, the end of a piece, or until a key signature
change if one occurs before the end of a movement or the end of a piece.
RELATED LINKS
Custom key signatures on page 410

Types of key signatures
There are four types of key signatures in Dorico, which can all be input, moved, and deleted in
the same ways.
The four types are:
●

Major

●

Minor

●

Open key, or atonal

●

No key signature (for specific instruments, such as horn or percussion)
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Major key signatures and minor key signatures
The key signature for a major key appears the same as the key signature for its relative minor,
and vice versa. For example, B♭ major has two flats in its key signature. This is the same number
of flats in the key signature for G minor, which is the relative minor key to B♭ major. The
difference between the two is that music in G minor has sharpened Fs, as the seventh degree of
the scale is raised in minor keys.

A B flat major scale following a B flat major key
signature

A G minor scale following a G minor key signature

Open key signature
Although an open, or “atonal”, key signature appears the same as a C major key signature or
an A minor key signature, as none of these three show any accidentals, an open key signature
behaves differently.
In an open key signature, the spelling of accidentals is based on the current direction of the
music: if the music is rising, sharps are preferred, whereas if the music is falling, flats are
preferred. There is no hierarchy of pitches in an open key signature, so the same pitch might be
spelled differently each time it appears depending on its context, even within a few bars.
In a C major or A minor key signature, accidentals are spelled based on the context of the major
or minor tonality implied. For example, in C major, sharps are preferred, whether the music is
going up or going down. Similarly, in A minor, G♯ is preferred, whether the music is going up or
going down, as G♯ is the leading note in A minor.

No key signature
Some instruments are accustomed to seeing no key signatures in their parts, no matter the
overall key of the piece. These instruments include timpani, percussion, horn, trumpet, and
sometimes the harp. If you have input the No key sig version of these instruments, then no
key signature is shown in their parts, even if they are a transposing instrument such as horn or
trumpet.
Any pitch can be input into these instruments, and they show accidentals if needed.

Tonality systems
The term “tonality system” is used in Dorico to encompass three crucial elements that together
make up the concept of tonality.
The three elements that make up tonality systems are:
●

A number of equal divisions of the octave. For example, standard Western scales with
semitone steps have 12-EDO.

●

A set of accidentals. This allows you to notate how a note is raised or lowered. This can be
a traditional set of accidentals, a set selected from the wide variety available, or a custom
set of accidentals of your own design.

●

A key signature. This can be a traditional Western key signature, or a custom key signature
of your own design.

EDO stands for Equal Division of the Octave, that is, how many equal pieces an octave is divided
into. With EDO, you can map non-conventional Western pitches on to the seven note names AG, and create a coherent notation to express that. With Dorico you can create any number of
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divisions of an octave, spread across the seven notes of the scale in any way. You can also design
custom key signatures and custom accidentals for each tonality system.
Traditional Western harmony is based on Equal temperament, another method used to describe
tonality systems, or 12-EDO, as the traditional scale from C-C is made up of twelve steps spread
across the seven notes in the scale.
The 12-EDO Edit Tonality System dialog shows how these steps are divided across the intervals
in the scale. There, you can see how many steps are given to each interval. For example, between
A and B there are two steps, but between B and C there is one step. This is because in 12-EDO,
each step represents a semitone, and there are two semitones between A and B according to
standard equal temperament, but only one semitone between B and C.
To have the smallest step in the tonality system be a quarter-tone rather than a semitone, the
octave must be divided into twice as many equal divisions as 12-EDO. Therefore, to be able to
use quarter-tone accidentals in a project, you must choose the Equal temperament (24-EDO)
tonality system for the project.
Although you can divide the octave into any number of divisions you like, to be able to show a
standard Western key signature, the number of equal divisions in the octave must be divisible by
12.
There is no limit to how you can divide the octave. For example, Turkish music is traditionally
divided in 53-EDO, the division of which is usually spread across the notes A-A with the following
number of divisions for each interval: 9-4-9-9-9-4-9.
RELATED LINKS
Custom tonality systems on page 405

Custom tonality systems
You can use a tonality system other than 12-EDO or 24-EDO, or edit either of those two tonality
systems.
You can create custom tonality systems and edit existing tonality systems in the Edit Tonality
System dialog.
The Edit Tonality System dialog can be found in the Key Signatures, Tonality Systems, and
Accidentals panel on the right of the window in Write mode. You can open this panel by clicking
Key Signatures, Tonality Systems, and Accidentals in the Notations toolbox:

The Tonality System section shows the tonality systems already available in your project. Dorico
offers two systems by default: Equal temperament (12-EDO) and Equal temperament (24EDO).

There are two buttons at the bottom of this section:
●

New Tonality System: create a new tonality system

●

Edit Tonality System: edit an existing tonality system
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Clicking either of these buttons opens the Edit Tonality System dialog.
RELATED LINKS
Edit Tonality System dialog on page 406
Custom divisions of the octave on page 407
Custom accidentals on page 407
Custom key signatures on page 410

Edit Tonality System dialog
You can create custom tonality systems and edit existing tonality systems in the Edit Tonality
System dialog.

There are four sections in the Edit Tonality System dialog:
●

Name: create a name for a new tonality system, or edit the name if you are editing an
existing tonality system.

●

Divisions: specify how many divisions of the octave you want assigned to each interval.

●

Accidentals: see the accidentals currently available for the selected tonality system.
The two buttons at the bottom allow you to edit existing accidentals, and to create new
accidentals.

●

Key Signatures: see the key signatures currently available for the selected tonality system.
The two buttons at the bottom allow you to edit existing key signatures, and to create new
key signatures.

Once you have decided on the number of divisions your octave has, and how many divisions
are assigned to each interval, in the Divisions section of the dialog, you can assign existing and
custom accidentals for each raising or lowering delta you want to notate in the Accidentals
section of the dialog.
You can then arrange these accidentals into a key signature in the Key Signatures section of the
dialog.
When you have finished editing your new tonality system, click OK or press Return to save the
changes you have made to your tonality system and close the Edit Tonality System dialog.
RELATED LINKS
Custom tonality systems on page 405
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Custom divisions of the octave
You can change the number of divisions of the octave for an existing tonality system, or create a
new tonality system with as many divisions of the octave as you like.
In the Division section of the Edit Tonality System dialog, you can change the number of
divisions assigned to each interval by changing the values in each value field in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The total number of divisions of an octave, which is shown at the top of the section, is updated
automatically as you change the number of divisions.

The Divisions section of the Edit Tonality System dialog, as it appears when editing the existing 12-EDO
tonality system.

In Equal temperament, or 12-EDO, the total number of divisions is 12. There are 2 divisions
between A and B, 1 division between B and C, 2 between C and D, and so on. This follows the
standard Western pattern which you can also see in the pattern of white and black keys on a
keyboard.
Although you can divide the octave into any number of divisions, the number of equal divisions
in the octave must be divisible by 12 to be able to show a standard Western key signature in
Dorico.
When you have finished changing the equal divisions per octave for your tonality system, you can
create custom accidentals and custom key signatures.
Click OK or press Return to save the changes you have made to your tonality system, and close
the Edit Tonality System dialog.
RELATED LINKS
Custom accidentals on page 407
Custom key signatures on page 410
Edit Tonality System dialog on page 406

Custom accidentals
You can create custom accidentals for both existing tonality systems and new tonality systems.
You can edit and create custom accidentals in the Accidentals section of the Edit Tonality
System dialog.
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The Accidentals section of the Edit Tonality System dialog, as it appears when editing the existing 12-EDO
tonality system.

NOTE
You can edit any accidental that is included in either of the default tonality systems that come
with Dorico. New tonality systems start with a natural accidental, which you can edit or delete.
Clicking on either the New Accidental button or the Edit Accidental button opens the Edit
Accidental dialog:

There are four sections in the Edit Accidental dialog:
1

Name: enter a name for your accidental.

2

Pitch delta: set a value for what effect this accidental has on notes to which it is added. For
example, a pitch delta of 2 raises notes by two equal divisions of the octave.

3

Accidental component selector: choose components to add to your accidental. You can add
different types of component by clicking on the respective tab titles. In the above example,
Glyph is selected.
●

Glyphs: such as ♮ or ♯. You can use different styles of glyphs by selecting different
fonts and different ranges from the menus. Click Add Glyph to add the selected
glyph to the accidental.
NOTE
A full list of the different ranges of glyphs is available on the SMuFL website.

●

Text: including numbers and other text. You can use numbers and text from the
available Preset text list, or select any font available from the menu and enter your
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preferred text into the text box at the bottom. Click Add Text to add the selected
text, or input text, to the accidental.
●

4

Graphic: load a new graphic file, or select an existing graphic from the Select
existing list. Most image formats are supported. You can see a preview of the
graphic in the Preview box. Click Add Graphic to add the selected graphic to the
accidental.

Editor: arrange and edit the component or components that make up your accidental.
Components can be arranged and edited using the following options:
●

X offset: increasing the value moves components to the right, decreasing the value
moves components to the left.

●

Y offset: increasing the value moves components up, decreasing the value moves
components down.

●

X scale: increasing the value increases the width of graphics only.

●

Y scale: increasing the value increases the size of the component. For graphics only,
increasing the value increases the height of the graphic.

●

Attachment from: select an attachment point for the component on the left,
to which the component to its right attaches. To ensure good legibility, it is
recommended that you select an attachment point on the right edge of the
component on the left.

●

Attachment to: select an attachment point for the component on the right,
which it uses to attach to the component to its left. To ensure good legibility,
it is recommended that you select an attachment point on the left edge of the
component on the right.

There are eight attachment points for glyphs and graphics, and eleven for text, due to the extra
space required for letters that go below the baseline. The example diagram helps you visualize
how these points relate to accidental components.

The attachment points, as labeled in the above example, are named in the Edit Accidental dialog
as follows:
1

Top Left

2

Top Middle

3

Top Right

4

Middle Left

5

Middle Right

6

Baseline Left (text only)

7

Baseline Middle (text only)

8

Baseline Right (text only)

9

Bottom Left

10

Bottom Middle

11

Bottom Right

When you have finished editing your new accidental, click OK or press Return to close the Edit
Accidental dialog. This saves the changes you have made to your accidental, and returns you to
the Edit Tonality System dialog, where you can create more new accidentals.
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RELATED LINKS
Edit Tonality System dialog on page 406

Custom key signatures
You can create new custom key signatures for both existing tonality systems and new tonality
systems, and edit the key signatures of new tonality systems.
You can edit and create custom key signatures in the Key Signatures section of the Edit Tonality
System dialog.

The Key Signatures section of the Edit Tonality System dialog, as it appears when creating or editing
custom tonality systems.

NOTE
If you edit one of the default tonality systems that come with Dorico, no key signatures are
available to edit in this section. However, you can create new key signatures within one of the
default tonality systems.
Clicking on either the New Key Signature button or the Edit Key Signature button opens the
Edit Custom Key Signature dialog:

There are five sections in the Edit Custom Key Signature dialog:
1

Name: enter a name for your key signature.

2

Clef: see how your key signature appears in treble clef, bass clef, alto clef, and tenor clef.
You can edit your key signature in any of these clefs.
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3

Root: choose the base note of your key signature.

4

Accidentals: select accidentals that you have added or created in your tonality system
to add to the key signature. Click Add Accidental to Key Signature to add the selected
accidental to the key signature.

5

Editor: arrange accidentals in your preferred order using the Order arrow buttons, and
change their position in the staff using the Note arrow buttons and Octave arrow buttons.

When you have finished editing your new key signature, click OK or press Return to close
the Edit Custom Key Signature dialog. This saves the changes you have made to your key
signature, and returns you to the Edit Tonality System dialog, where you can create more new
key signatures.
RELATED LINKS
Edit Tonality System dialog on page 406

Inputting key signatures with the keyboard
You can input key signatures with the keyboard by using the key signatures popover in Write
mode.
You can open the key signatures popover in Write mode in the following ways:
●

Press Shift-K.

●

Choose Write > Create Key Signature.

The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The key signatures popover with an example entry
for a key signature

The key signatures button in the Notations toolbox

The key signatures popover
The table shows some examples of what to enter into the key signatures popover and what is
input in the music as a result.
You can open the key signatures popover in Write mode in the following ways:
●

Press Shift-K.

●

Choose Write > Create Key Signature.

For example, enter:

For key signature:

open or atonal

Open or atonal key signature

C or D or Eb or Ab and so on

Major keys (capital letters)

g or d or f# or bb and so on

Minor keys (lowercase letters)

3s or 2# and so on

Number of sharps (assumes the major key for
that many sharps)
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For example, enter:

For key signature:

4f or 5b and so on

Number of flats (assumes the major key for
that many flats)

This list is not comprehensive: it is intended to illustrate how you can structure your entry to
input different types of key signature.

Inputting key signatures during step input with the keyboard
You can input key signatures during step input with the keyboard.
PROCEDURE
1.

In Write mode, start note input.

2.

Open the key signatures popover in any of the following ways:

3.

●

Press Shift-K.

●

Choose Write > Create Key Signature.

Enter the key signature you want into the popover, such as g for G minor or 3s for 3
sharps.
NOTE
Entering 3s creates a key signature of A major, rather than F♯ minor.

4.

Press Return to close the popover.

RESULT
The key signature is added at the caret position, even if this is in the middle of a bar. However,
it is preferable to input a change of key signature at a barline, so you may want to move it to a
more appropriate position later.
All subsequently input notes follow the input key signature, until the next existing key signature
or the end of the flow, whichever comes first. If playing in notes using a MIDI keyboard,
accidentals are spelled according to the key signature.
RELATED LINKS
The key signatures popover on page 411
Project-wide spacing gaps for key signatures on page 419
Accidental selection during MIDI input on page 189

Adding key signatures to existing music with the keyboard
You can add key signatures to existing music with the keyboard.
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The barline where you want a new key signature to start.

●

A notehead or rest immediately to the right of the position where you want a new
key signature to start.

Open the key signatures popover in any of the following ways:
●

Press Shift-K

●

Choose Write > Create Key Signature
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3.

Enter the key signature you want into the popover, such as f for F minor or 4f for 4 flats.
NOTE
Entering 4f creates a key signature of A♭ major, rather than F minor.

4.

Press Return to close the popover.

RESULT
The key signature is added immediately to the right of a barline, or immediately to the left of a
selected note, even if this is in the middle of an existing bar. However, it is preferable to input a
change of key signature at a barline.
All subsequent bars follow the input key signature, until the next existing key signature or the
end of the flow, whichever comes first.
RELATED LINKS
The key signatures popover on page 411

Inputting key signatures on single staves with the keyboard
By default, key signatures apply to the whole score. However, there are certain situations where
some parts require their own key signature, independently of the rest of the ensemble.
You can input a key signature to only a single staff with the keyboard, both during step input and
later to existing music.
PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline where you want an independent key signature to start, or
select a notehead or rest immediately to the right of the position where you want an
independent key signature to start.

Open the key signatures popover in any of the following ways:
●

Press Shift-K

●

Choose Write > Create Key Signature

3.

Enter the key signature you want into the popover, such as F or 4b.

4.

Hold down the Alt key while pressing Return to close the popover.

RESULT
Holding down the Alt key inputs the key signature only on the selected staff.
It behaves just like any other key signature. All subsequent notes on the staff follow the input key
signature, until the next existing key signature or the end of the flow, whichever comes first.
NOTE
An individual key signature on a single staff is not intended for transposing instruments.
Transpositions of notes and key signatures are done automatically for transposing instruments,
but you can check the transpositions by choosing Edit > Transposed Pitch to see your current
layout with transposed pitches, rather than concert pitches.
You can also open the part of a transposing instrument and compare it to the concert pitch
score.
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RELATED LINKS
The key signatures popover on page 411

Inputting key signatures with the mouse
Key signatures can be input with the mouse using the Key Signatures, Tonality Systems, and
Accidentals panel.
You can open the Key Signatures, Tonality Systems, and Accidentals panel by clicking its
button in the Notations toolbox in Write mode:

This panel can be hidden and shown in the following ways:
●

Press Ctrl/Cmd-9.

●

Click its disclosure arrow.

There are five sections in the Key Signatures, Tonality Systems, and Accidentals panel:
Tonality System
Select tonality systems to use and create new tonality systems.
Used in This Flow
Contains all the key signatures currently used in the flow.
Key Signatures
Create key signatures by choosing whether it is major or minor, and changing the
number of sharps or flats.
Custom Key Signatures
Contains any custom key signatures you have created for the currently selected
tonality system.
Accidentals
Contains all accidentals available in the currently selected tonality system.
NOTE
The order in which you should follow steps for inputting key signatures with the mouse depends
on your preferences for Creating items with the mouse in the Editing section of the General
page in Preferences.
You can open Preferences in the following ways:
●

Press Ctrl/Cmd-,

●

Choose Dorico > Preferences

RELATED LINKS
Key Signatures section on page 415
Inputting key signatures during step input with the mouse on page 415
Adding key signatures to existing music with the mouse on page 416
Inputting key signatures on single staves with the mouse on page 416
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Key Signatures section
You can use the Key Signatures section in the Key Signatures, Tonality Systems, and
Accidentals panel to create and input custom key signatures.
The Key Signatures section can be shown and hidden by clicking the section title, which has a
disclosure arrow beside it.
The Key Signatures section has three parts:
1

Two buttons at the top, where you can select either Major or Minor for your key signature.

2

Two buttons on the right: one points up, the other points down.

3

●

The button pointing up is the More Sharps/Fewer Flats button. Each time you
click on this button, one sharp accidental is added to the key signature, or one flat
accidental is removed from the key signature.

●

The button pointing down is the Fewer Sharps/More Flats button. Each time you
click on this button, one sharp accidental is removed from the key signature, or one
flat accidental is added to the key signature.

The button showing how the key signature looks on a staff. Click this button to input the
key signature it displays. If nothing in the project is selected, the key signature is loaded
onto the cursor.

The Key Signatures section of the Key Signatures, Tonality Systems, and Accidentals panel.

Inputting key signatures during step input with the mouse
You can input key signatures during step input with the mouse.
PROCEDURE
1.

In Write mode, start note input.

2.

Create the key signature you want using the Key Signatures design editor in the Key
Signatures, Tonality Systems, and Accidentals panel.
Alternatively, if you have already previously used the key signature you want to input in
the project, you can find it in the Used in This Flow section.

3.

Click the key signature you want.

RESULT
The key signature is added at the caret position, even if this is in the middle of a bar. However,
it is preferable to input a change of key signature at a barline, so you may want to move it to a
more appropriate position later.
All subsequently input notes follow the input key signature, until the next existing key signature
or the end of the flow, whichever comes first. If playing in notes using a MIDI keyboard,
accidentals are spelled according to the key signature.
RELATED LINKS
Project-wide spacing gaps for key signatures on page 419
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Inputting key signatures with the mouse
Accidental selection during MIDI input on page 189

Adding key signatures to existing music with the mouse
You can add key signatures to existing music with the mouse.
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The barline where you want a new key signature to start.

●

A notehead or rest immediately to the right of the position where you want a new
key signature to start.

Create the key signature you want using the Key Signatures design editor in the Key
Signatures, Tonality Systems, and Accidentals panel, and then click on it to input the key
signature.
Alternatively, if you have already previously used the key signature you want to input in
the project, you can click on it in the Used in This Flow section.

RESULT
The key signature is added immediately to the right of a barline, or immediately to the left of a
selected note, even if this is in the middle of an existing bar. However, it is preferable to input a
change of key signature at a barline.
All subsequent bars follow the input key signature, until the next existing key signature or the
end of the flow, whichever comes first.

Inputting key signatures on single staves with the mouse
By default, key signatures apply to the whole score. However, there are certain situations where
some parts require their own key signature, independently of the rest of the ensemble.
You can input a key signature to only a single staff with the mouse, both during step input and
later to existing music.
PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline where you want an independent key signature to start, or
select a notehead or rest immediately to the right of the position where you want an
independent key signature to start.

Create the key signature you want using the Key Signatures design editor in the Key
Signatures, Tonality Systems, and Accidentals panel.
NOTE
You can skip this step if the key signature you want to input is already available in the
Used in This Flow section.

3.

Hold down Alt.

4.

Click the key signature you want.

RESULT
Holding down Alt inputs the key signature only on the selected staff.
It behaves just like any other key signature. All subsequent notes on the staff follow the input key
signature, until the next existing key signature or the end of the flow, whichever comes first.
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NOTE
An individual key signature on a single staff is not intended for transposing instruments.
Transpositions of notes and key signatures are done automatically for transposing instruments,
but you can check the transpositions by choosing Edit > Transposed Pitch to see your current
layout with transposed pitches, rather than concert pitches.
You can also open the part of a transposing instrument and compare it to the concert pitch
score.

Changing key signatures
You can change key signatures to different key signatures after they have been input.
If you want to input a key signature change where there is no existing key signature, follow the
procedure for inputting a new key signature. It is customary to change the key signature if there
is a change of key in the music. This should be done at a barline, as this is clearest for players.
You can change the default barline at key signature changes in the Key Signatures section of the
Barlines page in Engrave > Engraving Options.
RELATED LINKS
Inputting key signatures with the keyboard on page 411
Inputting key signatures with the mouse on page 414
Project-wide Engraving Options for barlines on page 229

Changing key signatures with the keyboard
You can change an existing key signature with the keyboard.
PROCEDURE
1.

2.

3.

In Write mode, select one of the following:
●

The key signature you want to change.

●

The barline immediately to the left of the key signature you want to change.

●

A notehead or rest immediately to the right of the key signature you want to
change.

Open the key signatures popover in any of the following ways:
●

Press Shift-K

●

Choose Write > Create Key Signature

Enter the key signature you want into the popover. For example, g for G minor or 3s for 3
sharps.
A key signature of 3 sharps is treated as A major, rather than F♯ minor.

4.

Press Return to close the popover.

RESULT
The key signature is changed according to what you entered into the popover.
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Changing key signatures with the mouse
You can change an existing key signature with the mouse.
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The key signature you want to change.

●

The barline immediately to the left of the key signature you want to change.

●

A notehead or rest immediately to the right of the key signature you want to
change.

Create the key signature you want using the Key Signatures design editor in the Key
Signatures, Tonality Systems, and Accidentals panel.
If you have already previously used the key signature you want to input in the project, you
can find it in the Used in This Flow section.

3.

Click the key signature you want.

RESULT
The key signature is changed.

Visibility of key signatures
Key signatures cannot be hidden. If you do not want to see a key signature, you can input an
open key signature.
If you want to hide a key signature because one appears for an instrument that usually does not
have a key signature, such as timpani or horn, you can switch that instrument to the No key sig
version.
RELATED LINKS
Adding key signatures to existing music with the keyboard on page 412
Adding key signatures to existing music with the mouse on page 416
The key signatures popover on page 411

Deleting key signatures
You can delete key signatures completely.
PROCEDURE
1.

2.

In Write mode, select any of the following that you want to delete:
●

Key signatures

●

The key signature signposts of key signatures with no accidentals in the current
layout.

Delete the key signatures in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected key signatures are deleted from the score. Notes in the bars after their previous
positions are not changed, but may show accidentals if the previous key signature in the score
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indicates a different pitch for a note, up until the next existing key signature or the end of the
flow.
NOTE
If you delete the only key signature in the flow, your music appears in an open key, but with
accidentals shown as necessary.

Positions of key signatures
You can change the positions of key signatures by moving individual key signatures to different
rhythmic positions in Write mode, moving them to different graphical positions in Engrave mode,
and by changing the default positions of all key signatures project-wide.
You can move key signatures to new rhythmic positions in Write mode. They are positioned
according to your settings on the Key Signatures and Spacing Gaps pages in Engraving
Options.
You can move key signatures graphically in Engrave mode, but this does not change their
rhythmic positions.
If you want to adjust the default position of key signatures relative to notes or barlines, you
must change the project-wide values for spacing gaps on the Spacing Gaps page in Engrave >
Engraving Options.
Key signatures in Dorico appear in the correct position by default. However, you can change their
graphical positions individually should you find it necessary to do so.
RELATED LINKS
Project-wide spacing gaps for key signatures on page 419
Moving key signatures graphically on page 420

Project-wide spacing gaps for key signatures
You can change the minimum gaps between objects, including key signatures.
Among the available values on the Spacing Gaps page in Engraving Options, the following
minimum values directly relate to key signatures:
●

Gap after barline before clef, key or time signature

●

Gap after cancelation naturals

●

Gap after key signature

●

Gap after end repeat barline

NOTE
Other values may have an effect on the position of key signatures, but they also affect other
objects.
On the Key Signatures page in Engraving Options, you can change the following gaps:
●

Gap between accidentals in key signatures

●

Gap between cancelation naturals

You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.
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Moving key signatures rhythmically
You can move key signatures to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the key signatures you want to move.

2.

Move the selected key signatures according to the rhythmic grid currently set in any of the
following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the key signature to the right or to the left to the position you want.
NOTE
Only one key signature can be moved rhythmically at a time when using the mouse.

RESULT
The key signatures are moved to new rhythmic positions. They take effect from their new
positions until the next key signature, or the end of the flow, whichever comes first.
NOTE
Key signatures can only be moved along the staff. If you want to move an individual key
signature across staves, you must first delete the individual key signature from its first position,
then add a new individual key signature to the staff you wanted to move it to.
NOTE
Only one key signature can exist at each rhythmic position, except for key signatures that only
apply to single staves. If a key signature passes over another key signature as part of its move,
the existing key signature is deleted and replaced by the key signature being moved.
If you moved key signatures using the keyboard, you can undo the move to restore any key
signatures deleted in the process.
However, if you moved key signatures using the mouse, undoing the move does not restore any
key signatures deleted in the process.
Moving key signatures back to their previous positions later does not restore any key signatures
deleted when they were moved previously. The deleted key signatures must be re-input if
necessary.

Moving key signatures graphically
You can make individual changes to the graphical position of key signatures without affecting the
positions of any other items.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the panel on the left of the window.

2.

Select the square handle above the key signature you want to move. A smaller circular
handle appears beside the key signature.
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3.

Select the circular handle.

4.

Nudge the graphical position of the key signature in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move key signatures by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The key signature is moved graphically.
NOTE
You cannot change the position of Note Spacing handles with the mouse, they can only be
moved using the keyboard.

RELATED LINKS
Changes to note spacing in Engrave mode on page 461
Moving key signatures graphically using the Properties panel on page 421

Moving key signatures graphically using the Properties panel
You can move key signatures graphically using the Properties panel.
NOTE
Changing the Spacing Offset value also affects the positions of time signatures and whole bar
rests in the bar immediately after the moved key signature.

PROCEDURE
1.

In Engrave mode, select the key signatures you want to move.

2.

Activate the Spacing Offset property in the Key Signatures group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The Spacing Offset property moves key signatures in the following ways:
●

Increasing the Spacing Offset value moves key signatures to the right.

●

Decreasing the Spacing Offset value moves key signatures to the left.

RESULT
The graphical positions of the selected key signatures is changed.
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NOTE
Cancelation naturals, if shown in your project, are repositioned with the subsequent key
signature when using the Spacing Offset property. They can also be moved graphically,
independently of the subsequent key signature and without affect the spacing of any other item,
by activating the Cancelation naturals X offset property.
●

Increasing the Cancelation naturals X offset value moves cancelation naturals to the
right.

●

Decreasing the Cancelation naturals X offset value moves cancelation naturals to the
left.

Project-wide Engraving Options for key signatures
Options for the appearance of key signatures project-wide can be found on the Key Signatures
page in Engraving Options.
The options on this page allow you to change the key signature cancelation style, spacing gaps
between accidentals in key signatures, and the type of barline at key signature changes.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Key Signatures in the page list on the left of the dialog.

Transposing key signatures with selections
You can transpose the key signature along with a selection if the key signature is selected as well
as the notes.
PROCEDURE
1.

Make a selection that includes both a key signature change and notes. You can do this in
the following ways:
●

Hold down Ctrl/Cmd and select everything you want to transpose.

●

Make a marquee selection by clicking and dragging the mouse pointer over
everything you want to include. A highlighted square shows you what will be
included in the selection when you release the mouse.

2.

Choose Write > Transpose. The Transpose dialog appears.

3.

Set your preferred settings for your transposition, including interval and quality.

4.

Make sure that the Transpose key signatures box is checked.
It is checked automatically if your selection includes a key signature.

5.

Click OK to close the dialog.

RESULT
All notes and key signatures within the selection are transposed by the degree you set in the
dialog.
NOTE
If a key signature included in the transposed selection applies to all staves, then it is transposed
on all staves in the layout, even if your selection did not include all staves.
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Individual key signatures (key signatures added to single staves only using the Alt key) are
transposed if included in a selection, but this does not affect any other staff in the layout.

Enharmonic equivalent key signatures
Dorico generally transposes to a key with the same type of accidental as the previous key when
transposing music. If transposing for an instrument, Dorico generally transposes to a key with
the same type of accidental as the current concert pitch key.
However, there are some instances where you might prefer to transpose to a key with a different
type of accidental as it has fewer accidentals than the enharmonic equivalent key.
For example, C♯ major has seven sharps, whereas the enharmonic equivalent key of D♭ major
only has five flats. This means the player has to remember the accidentals for fewer notes.

Transposing to an enharmonic equivalent key with fewer accidentals can have the added benefit
of improving readability by avoiding double sharps or double flats. For example, transposing
music from F♯ to G♯ requires the leading note to be spelled as an F, but transposing to A♭ instead
means the leading note is G♮.

By default, Dorico selects an enharmonic equivalent key signature if it has fewer accidentals.
However, you can switch off this preference by deactivating the Prefer enharmonic equivalent
key signatures with fewer accidentals option in the Transposition section of the Accidentals
page in Notation Options.
You can open Notation Options in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

How transposing instruments are affected by key signatures
If there is a key signature in the full score, it is transposed for a transposing instrument by the
same degree as the transposing interval for the instrument. For example, in a project in E major,
a B♭ clarinet part has a key of F♯ major, as a B♭ clarinet sounds a whole tone below its notated
pitch.

Instruments that do not show a key signature
Some instruments are accustomed to seeing no key signatures in their parts, no matter the
overall key of the piece. These instruments include timpani, percussion, horn, trumpet, and
sometimes the harp. If you have input the No key sig version of these instruments, then no
key signature is shown in their parts, even if they are a transposing instrument such as horn or
trumpet.
You can still transpose music in the staves of these instruments, but they show accidentals as
necessary, instead of showing a key signature.
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Cautionary key signatures
When a key signature change occurs at a system break, either in the score or in a part, the new
key signature is shown at the end of the first system as well as at the start of the new system.
This is sometimes considered a “cautionary key signature”, as players can easily get used to
seeing the key signature at the start of the system and therefore may miss a change of key
signature if it is not conspicuously shown at the end of systems.
In Dorico, as key signature changes occur at the barline, the key signature at the end of a system
is the key signature itself, rather than a cautionary.
If the music is separate enough that you do not want to see a key signature at the end of a
system and you cannot change where the system break occurs, then you might want to separate
the music by creating a new flow at the point of the system break.
RELATED LINKS
Flows on page 80
Creating flows on page 80
Formatting panel on page 129

Multiple key signatures
You can have multiple key signatures simultaneously by inputting each one onto a single staff.
You do not have to input multiple simultaneous key signatures if you have transposing
instruments in your score. Dorico handles instrument transpositions automatically.
You can check the transposition of transposing instruments by choosing Edit > Transposed
Pitch to see the music in your layout at written pitch rather than concert pitch.
Alternatively, you can open the individual part layout of a transposing instrument and compare it
to the full score.
RELATED LINKS
Inputting key signatures on single staves with the keyboard on page 413
Inputting key signatures on single staves with the mouse on page 416
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In Dorico, the term lyrics is used to represent all text that is sung by singers.
To differentiate sung text from any other forms of text that often appears in musical scores,
other forms of text are referred to as performance instructions, tempos, dynamics, etc.
In Dorico, lyrics have been designed so that it is simple to go back and make changes to lyrics
without having to re-input new lyrics each time.
For example, if you advance the lyrics popover to the next note by pressing Space instead of
- when inputting multisyllabic words, you can later change syllables to different syllable types
individually, so that they show or don’t show hyphens.
When inputting lyrics, there are a number of key commands that you can use to switch between
lyric lines, to change on which side of the staff lyrics are input, and to switch the lyric style
between normal lyrics, chorus lyrics, and translation lyrics.
In the Edit > Filter > Lyrics menu, there are a number of options that allow you to select each
lyric type and lyric line separately.
Lyrics are divided into the following lyric types in Dorico:
Lyric lines
Lyric lines contain normal lyrics, and can be shown with verse numbers.
Chorus lines
Chorus lines contain lyrics in an italic font and are positioned in the middle of lyric
lines, for example, if there were two lyric lines, a chorus line appears between lyric
Line 1 and Line 2.
Chorus lines are not assigned verse numbers.
Lyric line translations
Lyric line translations show the text in lyric lines or chorus lines in different
languages. They are positioned directly below the lyric line or chorus line of which
they are a translation.
Lyric line translations are not assigned verse numbers, as they are counted as part of
the lyric line or chorus line of which they are a translation.
RELATED LINKS
Lyrics on page 113
Lyrics section on page 170
Inputting lyrics on page 426
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General placement conventions for lyrics
Lyrics are generally placed below the staff to which they apply, and are positioned so that they
align horizontally with their corresponding notehead.
A regular font is generally used for normal lyrics, and an italic font is generally used for chorus
lyrics and translation lyrics in order to differentiate them.
The horizontal spacing of lyrics should be wide enough so that each word or syllable does not
overlap with the words or syllables either side. However, in order to achieve legibility for lyrics,
the rhythmic spacing of notes sometimes needs to be adjusted.
To avoid the rhythmic adjustment of notes to accommodate lyrics distorting the appearance of
rhythms extensively, Dorico has programmed the positioning of lyrics to allow the alignment of
some lyrics relative to their corresponding notes to be adjusted.
For example, if a long, single-syllable word on a long note follows another long, single-syllable
word on a short note, the second word is moved a little to the right to give both words enough
space.

A short note followed by a long note, where the horizontal position of the lyrics has been automatically
adjusted for legibility.

RELATED LINKS
Positions of lyrics on page 432
Project-wide changes to the appearance of lyrics on page 449

Inputting lyrics
Lyrics are input by entering text into the lyrics popover.
You can open the lyrics popover in Write mode in the following ways:
●

Press Shift-L.

●

Choose Write > Create Lyrics.

●

Click Lyrics in the Notations toolbox:

The number shown on the left hand side of the lyrics popover indicates the lyric line into which
the lyric is input, and what type of lyric is being input. For example, a c is shown when you are
inputting chorus lines.

The lyrics popover can be advanced to the next note in the staff, so you do not need to open the
popover for every note.
To input lyrics:
PROCEDURE
1.

In Write mode, select the first note to which you want to input lyrics.

2.

Open the lyrics popover in any of the following ways:
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●

Press Shift-L

●

Choose Write > Create Lyrics

●

Click Lyrics in the Notations toolbox:

3.

Enter the word or syllable you want to add to the selected note into the popover.

4.

Advance the popover to the next note in one of the following ways:
●

Press Space if you entered a complete word, or the final syllable in a multi-syllabic
word.

●

Press - if you entered one syllable of a multi-syllabic word.

5.

Continue entering words and syllables into the popover for the rest of the notes to which
you want to add lyrics.

6.

Press Return or Esc to close the popover.
NOTE
The popover closes automatically when you reach the last note in the staff.

RESULT
The text you enter into the popover is input as lyrics.
If you advance the popover to the next note by pressing -, a hyphen appears after the lyric last
input. This is used to input multi-syllabic words across multiple notes.
If you advance the popover by pressing Space, a gap appears after the lyric last input. This is
used for single-syllable words or for the final syllable in multi-syllabic words.
NOTE
You can later change whether a gap or a hyphen appears between lyrics by changing their
syllable type.

RELATED LINKS
Changing the syllable type of existing lyrics on page 447
Inputting multiple lyric lines on page 427
Inputting lyric lines above the staff on page 430
Inputting chorus lines on page 428
Inputting lyric line translations on page 429
Changes to the type and placement of lyric lines on page 440
Positions of lyric hyphens and lyric extender lines on page 434

Inputting multiple lyric lines
You can input multiple lyric lines at the same rhythmic position by giving each lyric line a
different lyric line number.
TIP
You do not have to input the first lyric line to input lyrics in subsequent lines. For example, you
can input lyrics as Line 2 before inputting lyrics in Line 1.
To input multiple lyric lines at the same position:
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PROCEDURE
1.

In Write mode, select the first note to which you want to input multiple lyric lines.

2.

Open the lyrics popover in one of the ways described in Inputting lyrics.

3.

Press Down Arrow until the number shown on the left hand side of the popover matches
the lyric line number that you want to input. For example, this is how the lyrics popover
appears when inputting a second lyric line:

TIP
You can press Up Arrow and Down Arrow to switch between different line numbers at
any point, and as many times as you need.
4.

Type the word or syllable you want to add to the selected note into the popover.

5.

Advance the popover to the next note in one of the following ways:
●

Press Space if you typed in a complete word, or the final syllable in a multi-syllabic
word.

●

Press - if you typed in one syllable of a multi-syllabic word.

6.

Continue typing words and syllables into the popover for the rest of the notes to which you
want to add lyrics.

7.

Press Return or Esc to close the popover.
NOTE
The popover closes automatically when you reach the last note in the staff.

RESULT
The text you enter into the popover is input as lyrics in the lyric line number corresponding to the
number shown on the left hand side of the popover.
RELATED LINKS
Inputting lyrics on page 426
Changes to the type and placement of lyric lines on page 440
Changing the line number of lyric lines on page 441

Inputting chorus lines
Chorus lines use an italic font and are automatically positioned below the staff. If multiple lyric
lines exist at the same position as a chorus line, it is positioned in the middle of the other lyric
lines.
To input chorus lines:
PROCEDURE
1.

In Write mode, select the first note to which you want to input a chorus line.

2.

Open the lyrics popover in one of the ways described in Inputting lyrics.

3.

Press Up Arrow so that a c is shown on the left hand side of the popover. This is how the
lyrics popover appears when inputting chorus lines:

4.

Type the word or syllable you want to add to the selected note into the popover.
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5.

Advance the popover to the next note in one of the following ways:
●

Press Space if you typed in a complete word, or the final syllable in a multi-syllabic
word.

●

Press - if you typed in one syllable of a multi-syllabic word.

6.

Continue typing words and syllables into the popover for the rest of the notes to which you
want to add chorus lyrics.

7.

Press Return or Esc to close the popover.
NOTE
The popover closes automatically when you reach the last note in the staff.

RESULT
The text you enter into the popover is input as a chorus line.
NOTE
The position of chorus lines changes, depending on the number of lyric lines that exist at the
same rhythmic position.
You can also show lyrics in italic font in normal lyric lines instead of inputting lyrics as chorus
lines.

RELATED LINKS
Inputting lyrics on page 426
Changing lyric lines to chorus lines on page 444
Showing lyrics in italic font on page 447

Inputting lyric line translations
Each lyric line can have its own lyric line translation. Lyric line translations are not given their
own verse numbers, as they are included in the verse number of the line of which they are a
translation.
To input lyric line translations:
PROCEDURE
1.

In Write mode, select the first note to which you want to input a lyric line translation.

2.

Open the lyrics popover in one of the ways described in Inputting lyrics.

3.

Press Alt-Down Arrow so that a * is shown beside the lyric line number to which you want
to add a lyric line translation on the left hand side of the popover. This is how the lyrics
popover appears when inputting a lyric line translation to lyric Line 1:

4.

Type the word or syllable you want to add to the selected note into the popover.

5.

Advance the popover to the next note in one of the following ways:
●

Press Space if you typed in a complete word, or the final syllable in a multi-syllabic
word.

●

Press - if you typed in one syllable of a multi-syllabic word.

6.

Continue typing words and syllables into the popover for the rest of the notes to which you
want to add translation lyrics.

7.

Press Return or Esc to close the popover.
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NOTE
The popover closes automatically when you reach the last note in the staff.

RESULT
The text you enter into the popover is input as translation lyrics for the lyric line number
corresponding to the number shown on the left hand side of the popover.
RELATED LINKS
Inputting lyrics on page 426
Changes to the type and placement of lyric lines on page 440
Changing lyric lines to lyric line translations on page 445

Inputting lyric lines above the staff
In some cases, it is necessary to place lyrics above the staff. For example, if a vocal line that is
usually in unison is divided for a few bars, with a different rhythm in each line.
Lyric lines above the staff can be input in addition to lyric lines below the staff.
To input lyric lines above the staff:
PROCEDURE
1.

In Write mode, select the first note to which you want to input a lyric line above the staff.

2.

Open the lyrics popover in one of the ways described in Inputting lyrics.

3.

Press Shift-Up Arrow to input lyrics above the staff.
TIP
You can press Shift-Up Arrow and Shift-Down Arrow to switch between lyric lines above
the staff and below the staff at any point, and as many times as you need.

4.

Type the word or syllable you want to add to the selected note into the popover.

5.

Advance the popover to the next note in one of the following ways:
●

Press Space if you typed in a complete word, or the final syllable in a multi-syllabic
word.

●

Press - if you typed in one syllable of a multi-syllabic word.

6.

Continue typing words and syllables into the popover for the rest of the notes to which you
want to add lyrics above the staff.

7.

Press Return or Esc to close the popover.
NOTE
The popover closes automatically when you reach the last note in the staff.

RESULT
The text you enter into the popover is input as lyrics above the staff for the lyric line number
corresponding to the number shown on the left hand side of the popover.
RELATED LINKS
Inputting lyrics on page 426
Changing the placement of lyric lines relative to the staff on page 442
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Inputting multiple lyric lines above the staff
You can input multiple lyric lines at the same rhythmic position above the staff by first selecting a
lyric line number, and then inputting it above the staff. Lyric lines above the staff can be input in
addition to lyric lines below the staff.
TIP
You do not have to input the first lyric line above the staff to input lyrics in subsequent lines
above the staff. For example, you can input lyrics as Line 2 before inputting lyrics in Line 1.
To input multiple lyric lines at the same position above the staff:
PROCEDURE
1.

In Write mode, select the first note to which you want to input a lyric line above the staff.

2.

Open the lyrics popover in one of the ways described in Inputting lyrics.

3.

Press Down Arrow until the number shown on the left hand side of the popover matches
the lyric line number that you want to input. For example, this is how the lyrics popover
appears when inputting a second lyric line:

4.

Press Shift-Up Arrow to input lyrics above the staff.

5.

Type the word or syllable you want to add to the selected note into the popover.

6.

Advance the popover to the next note in one of the following ways:
●

Press Space if you typed in a complete word, or the final syllable in a multi-syllabic
word.

●

Press - if you typed in one syllable of a multi-syllabic word.

7.

Continue typing words and syllables into the popover for the rest of the notes to which you
want to add lyrics above the staff.

8.

Press Return or Esc to close the popover.
NOTE
The popover closes automatically when you reach the last note in the staff.

RESULT
The text you enter into the popover is input as lyrics above the staff for the lyric line number
corresponding to the number shown on the left hand side of the popover.
RELATED LINKS
Inputting lyrics on page 426
Inputting multiple lyric lines on page 427
Inputting lyric lines above the staff on page 430
Changing the placement of lyric lines relative to the staff on page 442

Changing the text of existing lyrics
To change the text of lyrics after they have been input:
PROCEDURE
1.

In Write mode, select the lyric you want to change.
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NOTE
You can only change one lyric at a time.
2.

Open the lyrics popover in any of the following ways:
●

Press Return

●

Double click on the note you want to change.

●

Press Shift-L

●

Click Lyrics in the Notations toolbox:

●

Choose Write > Create Lyrics

3.

Replace the existing text in the lyrics popover with your preferred text for the selected
lyric.

4.

If you want to change following lyrics as well, advance the popover to the next note in one
of the following ways:

5.

●

Press Space if you typed in a complete word, or the final syllable in a multi-syllabic
word.

●

Press - if you typed in one syllable of a multi-syllabic word.

Press Return or Esc to close the popover when you have finished changing lyrics.
NOTE
The popover closes automatically when you reach the last note in the staff.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440
Inputting lyrics on page 426

Positions of lyrics
You can move lyrics to different rhythmic positions in Write mode. They are positioned by default
according to your chosen options on the Lyrics page in Engraving Options.
Dorico has programmed the positioning of lyrics to avoid you needing to make further
adjustments. If you find you need to move lyrics, they can be moved graphically in Engrave
mode, however, this does not change the rhythmic positions to which they are attached.
NOTE
The horizontal position of lyrics is automatically adjusted in Dorico to minimize changes to
the rhythmic spacing of notes. Syllables are moved by small amounts either left or right to
accommodate longer syllables without distorting the appearance of note rhythms.
Moving lyrics graphically in Engrave mode overrides the automatic spacing for the selected lyrics.
If you move a lyric whose position was automatically re-adjusted, the rhythmic spacing at that
rhythmic position might change.
Project-wide settings for the default position of lyrics can be set on the Lyrics page in Engraving
Options.
The default settings for lyrics in Engraving Options are optimized for scores with comfortable
spacing. If your project requires note spacing to be narrower, with less room for each note, you
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should try changing the settings on the Lyrics page in Engraving Options to achieve a clearly
legible result without the need for lots of editing in Engrave mode.
For scores that have less horizontal space, the following changes often improve the appearance
of lyrics and rhythmic space:
●

Making minimum gaps smaller, such as the minimum gap between lyrics and hyphens, in
the Hyphens section of the Lyrics page in Engraving Options.

●

Increasing the amount that lyrics can be adjusted by in the Spacing section of the Lyrics
page in Engraving Options.

Rules for syllables
The number of notes that are sung with syllables or words determines how the lyrics are
positioned:
●

Single syllables, that is, whole words or parts of longer words that are sung on only one
note, are centered on that note.

●

Melismata, which are syllables or words that are sung on more than one note, are leftaligned with the left side of the first note.

Rules for lines of lyrics
If a line of lyrics is missing across the width of a whole system, no additional gap is left between
the remaining lines of lyrics.
EXAMPLE
If you have three lines of lyrics, but on one system, there is no second line of lyrics, the third line
of lyrics is moved upwards, closer to the first line of lyrics. If on a subsequent system, there is no
first line, but the second and third lines of lyrics are shown, the second and third lines of lyrics
are moved upwards. The second line of lyrics takes the place of the first line.
RELATED LINKS
Project-wide Engraving Options for lyrics on page 450

Moving lyrics rhythmically
You can move lyrics after they have been input.
PROCEDURE
1.

In Write mode, select the lyrics you want to move.

2.

Use the following key commands to move lyrics left or right, according to the rhythmic grid
currently set:
●

Alt-Right Arrow

●

Alt-Left Arrow

●

NOTE
Lyrics cannot be moved rhythmically with the mouse.

RESULT
The selected lyrics are moved to the left or right by the duration of the rhythmic grid.
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Moving lyrics graphically
You can move lyrics graphically without changing the rhythmic positions to which they apply.
NOTE
Moving lyrics graphically in Engrave mode overrides the automatic spacing of the selected lyrics.
If you move a lyric whose position was automatically re-adjusted, the rhythmic spacing at that
rhythmic position might change.

PROCEDURE
1.

In Engrave mode, select the lyrics you want to move.

2.

Move the selected lyrics in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move lyrics by larger increments, you can press Ctrl/Cmd as well as
the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the lyrics to the right or to the left.

RESULT
The selected lyrics are moved to the right or the left.
NOTE
Lyrics cannot be moved upwards or downwards, as their vertical position is determined by their
lyric line number and your project-wide settings in Engrave > Engraving Options.
You can change the line number of lyric lines, and the placement of lyric lines relative to the staff,
using options in the Edit > Lyrics menu. You can also change the position of lyrics relative to
the staff, other lyric lines, and to other objects for all lyrics project-wide in the Vertical Position
section of the Lyrics page in Engraving Options.

RELATED LINKS
Changing the line number of lyric lines on page 441
Changing the placement of lyric lines relative to the staff on page 442

Positions of lyric hyphens and lyric extender lines
Lyric hyphens indicate that individual lyrics are syllables within multi-syllabic words, for example,
“Hal-le-lu-jah”. Lyric extender lines indicate that individual lyrics extend across multiple notes.
Dorico automatically inputs and positions lyric hyphens when you advance the lyrics popover
by pressing - between syllables, and lyric extender lines when you advance the lyrics popover
multiple times after an entry.

Moving lyric extender lines
You can move lyric extender lines horizontally.
PROCEDURE
1.

In Engrave mode, select the lyric extender lines that you want to move.
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2.

Move the lyric extender lines in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move lyric extender lines by larger increments, you can press Ctrl/
Cmd as well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them to the right or to the left to the positions you want.

RESULT
The selected lyric extender lines are moved to the left or the right.
NOTE
The start handles of lyric extender lines are attached to the lyric from which they extend. If you
move that lyric, the position of the lyric extender line start handles moves correspondingly.
Lyric extender lines cannot be moved upwards or downwards, as their vertical position is
determined by their lyric line number and your project-wide settings in Engrave > Engraving
Options.
You can change the position of lyric extender lines relative to lyrics and to the ends of systems
for all lyric extender lines project-wide in the Extender Lines section of the Lyrics page in
Engraving Options.

RELATED LINKS
Lengthening and shortening lyric extender lines on page 435
Positions of lyric hyphens and lyric extender lines on page 434

Lengthening and shortening lyric extender lines
Lyric extender lines can be lengthened and shortened by moving the handles at each end in
Engrave mode.
Moving the handle on the left end of lyric extender lines moves the start of the line, and moving
the handle on the right end of lyric extender lines moves the end of the line.

Lyric extender line handles can be moved independently of each other, allowing you to lengthen
and shorten lyric extender lines. For example, moving the end handle of a lyric extender line
to the right without changing the position of the start lyric extender line handle makes the line
longer.
NOTE
The start handles of lyric extender lines are attached to the lyric from which they extend. If you
move that lyric, the position of the lyric extender line start handles moves correspondingly.

PROCEDURE
1.

In Engrave mode, select the square handles at one of the following positions on the lyric
extender lines you want to lengthen or shorten:
●

The start of lyric extender lines.

●

The end of lyric extender lines.
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2.

Move the selected handles left or right in the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the handles to the right or to the left.

RELATED LINKS
Positions of lyric hyphens and lyric extender lines on page 434
Lengthening and shortening lyric extender lines using the Properties panel on page 436

Lengthening and shortening lyric extender lines using the
Properties panel
Lyric extender lines can be lengthened and shortened by moving the handles at each end
independently of each other using the Properties panel in Engrave mode.
PROCEDURE
1.

2.

3.

4.

In Engrave mode, select one of the following for the lyric extender lines that you want to
lengthen or shorten:
●

The lyric extender lines.

●

The lyrics from which the lines extend.

Activate the following properties, individually or together, in the Lyrics group of the
Properties panel:
●

Line Start X

●

Line End X

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move lyric extender lines in the following ways:
●

Line Start X: increasing the value moves the starts of lyric extender lines to the
right, decreasing the value moves the starts of lyric extender lines to the left.

●

Line End X: increasing the value moves the ends of lyric extender lines to the right,
decreasing the value moves the ends of lyric extender lines to the left.

RELATED LINKS
Positions of lyric hyphens and lyric extender lines on page 434
Lengthening and shortening lyric extender lines on page 435

Moving lyric hyphens
You can move lyric hyphens horizontally.
PROCEDURE
1.

In Engrave mode, select the lyric hyphens that you want to move.

2.

Move the lyric hyphens in any of the following ways:
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●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move lyric hyphens by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them to the right or to the left to the positions you want.

RESULT
The selected lyric hyphens are moved to the left or the right.
NOTE
The start handles and end handles of lyric hyphens are attached to the lyrics on each side. If you
move either of those lyrics, the positions of the lyric hyphen handles move correspondingly.
Lyric hyphens cannot be moved upwards or downwards, as their vertical position is determined
by their lyric line number and your project-wide settings in Engrave > Engraving Options.
You can change the position of lyric hyphens relative to lyrics and to other hyphens for all lyric
hyphens project-wide in the Hyphens section of the Lyrics page in Engraving Options.

RELATED LINKS
Lengthening and shortening lyric hyphens on page 437
Positions of lyric hyphens and lyric extender lines on page 434

Lengthening and shortening lyric hyphens
Lyric hyphens can be lengthened and shortened by moving the handles at each end in Engrave
mode.
Lengthening and shortening lyric hyphens does not change the size or shape of the hyphen
itself, instead you can increase or decrease the distance between the handles in which hyphens
can appear.
Depending on your settings for the minimum gap between hyphens in the Handles section of
the Lyrics page in Engrave > Engraving Options, lengthening or shortening lyric hyphens can
cause more or fewer hyphens to appear in the space.
Moving the handle on the left end of lyric hyphens moves the start of the line, and moving the
handle on the right end of lyric hyphens moves the end of the line.

Lyric hyphen handles can be moved independently of each other, allowing you to lengthen and
shorten lyric hyphens. For example, moving the end handle of a lyric hyphen to the right without
changing the position of the start lyric hyphen handle makes the space that can be occupied by
hyphens longer.
NOTE
The start handles and end handles of lyric hyphens are attached to the lyrics on each side. If you
move either of those lyrics, the positions of the lyric hyphen handles move correspondingly.
To lengthen and shorten lyric hyphens with the mouse or keyboard:
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PROCEDURE
1.

2.

In Engrave mode, select the square handles at one of the following positions on the lyric
hyphens you want to lengthen or shorten:
●

The start of lyric hyphens.

●

The end of lyric hyphens.

Move the selected handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the handles to the right or to the left.

RELATED LINKS
Positions of lyric hyphens and lyric extender lines on page 434
Lengthening and shortening lyric hyphens using the Properties panel on page 438

Lengthening and shortening lyric hyphens using the Properties
panel
Lyric hyphens can be lengthened and shortened by moving the handles at each end
independently of each other using the Properties panel in Engrave mode.
PROCEDURE
1.

2.

3.

4.

In Engrave mode, select one of the following for the lyric hyphens that you want to
lengthen or shorten:
●

The lyric hyphens.

●

The lyrics from which the hyphens extend.

Activate the following properties, individually or together, in the Lyrics group of the
Properties panel:
●

Line Start X

●

Line End X

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move lyric hyphens in the following ways:
●

Line Start X: increasing the value moves the start handles of lyric hyphens to the
right, decreasing the value moves the start handles of lyric hyphens to the left.

●

Line End X: increasing the value moves the end handles of lyric hyphens to the
right, decreasing the value moves the end handles of lyric hyphens to the left.

RESULT
The space between lyrics that can be filled with lyric hyphens is increased or decreased. Lyric
hyphens are centered in the space between their start handles and end handles.
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NOTE
If the distance between the handles is increased enough to show two hyphens in the space, the
position of the original hyphen is changed to accommodate more hyphens.

RELATED LINKS
Positions of lyric hyphens and lyric extender lines on page 434
Lengthening and shortening lyric hyphens on page 437

Deleting lyric lines
You can delete whole lines of lyrics.
PROCEDURE
1.

In Write mode, select one of the following:
●

The whole project by pressing -A, or by choosing Edit > Select All.

●

The whole staff containing the lyric line you want to delete by selecting the first note
in the staff, holding down Shift, and selecting the last note in the staff.

●

The whole staff containing the lyric line you want to delete by selecting the first note
in the staff and choosing Edit > Select To End Of System or Edit > Select To End Of
Flow.

●

Multiple staves containing the lyric line you want to delete by selecting one whole
staff at the top of the range of staves from which you want to delete the lyric line,
holding down Shift, and selecting the staff at the bottom of the range of staves
from which you want to delete the lyric lines.
NOTE
You can also select the bottom staff in the range, hold down Shift, and select the
top staff in the range.

2.

3.

Choose Edit > Filter > Lyrics and select the type of lyric line you want to delete from the
following options:
●

All lyrics

●

Line 1

●

Line 2

●

Line 3

●

Line 4

●

Line 5

●

Above staff

●

Below staff

●

Chorus

●

Translation

Press Backspace or Delete, or choose Edit > Delete.

RESULT
The selected lyrics are deleted.
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Deleting lyrics individually
You can delete individually selected lyrics.
PROCEDURE
1.

In Write mode, select the lyrics you want to delete.

2.

Press Backspace or Delete, or choose Edit > Delete.

RESULT
The selected lyrics are deleted.

Changes to the type and placement of lyric lines
You can change the type and placement of whole lyric lines and individually selected lyrics after
they have been input. You can use the lyric filters to selected lyrics across your project quickly.
For example, if you input lyrics in Line 3 but later want to change those lyrics to Line 4, and input
different lyrics as Line 3. You can change your current Line 3 into Line 4, and then input a new
line of lyrics as Line 3. The spacing is automatically adjusted to show lyric lines in the correct
order.

Filtering lyrics
The following filters are available in the Edit > Filter > Lyrics menu:
All lyrics
Selects all types of lyrics in the current selection, with any lyric line number and
placed both above and below the staff.
Line 1
Selects only Line 1 lyrics in the current selection, including Line 1 below the staff and
Line 1 above the staff.
Line 2
Selects only Line 2 lyrics in the current selection, including Line 2 below the staff and
Line 2 above the staff.
Line 3
Selects only Line 3 lyrics in the current selection, including Line 3 below the staff and
Line 3 above the staff.
Line 4
Selects only Line 4 lyrics in the current selection, including Line 4 below the staff and
Line 4 above the staff.
Line 5
Selects only Line 5 lyrics in the current selection, including Line 5 below the staff and
Line 5 above the staff.
Above Staff
Selects all lyrics above the staff in the current selection. You can use this filter in
addition to the other filters. For example, you can filter first by line number, and then
filter again by placement relative to the staff.
Below Staff
Selects all lyrics below the staff in the current selection. You can use this filter in
addition to the other filters. For example, you can filter first by line number, and then
filter again by placement relative to the staff.
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Chorus
Selects all chorus lyrics in the current selection.
Translations
Selects all translation lyrics in the current selection.

Making different types of selection
You can filter lyrics from any selection you can make in the project, for example, you can select
three bars and filter the lyric just in those three bars.
Some larger selections you can make include the following:
Select the whole project
To select everything in the project, press -A, or choose Edit > Select All.
Select everything in a single staff
You can select everything in a single staff in the following ways:
●

Select the first note in the staff, hold down Shift, and select the last note in the
staff.

●

Select the first note in the staff and choose Edit > Select To End Of System or
Edit > Select To End Of Flow.

Select everything in multiple adjacent staves
To select multiple staves, select one whole staff at the top of the range of staves you
want to select, hold down Shift, and select the staff at the bottom of the range of
staves you want to select.
NOTE
You can also select the bottom staff in the range, hold down Shift, and select the top
staff in the range.

Changing the line number of lyric lines
You can change the lyric line number of whole lyric lines after they have been input.
PROCEDURE
1.

In Write mode, select a lyric in the line whose lyric line number you want to change. It can
be above or below the staff.
NOTE
You can also make a selection and use the lyric filters to select different lyric lines
according to their line numbers.

2.

Select the line number to which you want to change the selected lyric line in any of the
following ways:
●

Choose Edit > Lyrics > Line > Line 1.

●

Right-click and choose Lyrics > Line > Line 1 from the context menu.

●

Choose Edit > Lyrics > Line > Line 2.

●

Right-click and choose Lyrics > Line > Line 2 from the context menu.

●

Choose Edit > Lyrics > Line > Line 3.

●

Right-click and choose Lyrics > Line > Line 3 from the context menu.

●

Choose Edit > Lyrics > Line > Line 4.

●

Right-click and choose Lyrics > Line > Line 4 from the context menu.
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●

Choose Edit > Lyrics > Line > Line 5.

●

Right-click and choose Lyrics > Line > Line 5 from the context menu.

RESULT
The whole lyric line of the selected lyric is changed.
NOTE
If other lyric lines exist at the same position, the position of the selected lyric line may be
changed. For example, if there were two lyric lines and you changed lyric Line 1 to lyric Line 3, it
now appears below lyric Line 2.
If a lyric line with the same number already exists at the same position on the same side of the
staff, the two lines switch. For example, if there is already a lyric line 1 at the rhythmic position
where you want to change lyric Line 2 to lyric Line 1, then the existing lyric Line 1 becomes lyric
Line 2 to accommodate your most recent preference.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440

Changing the line number of individual lyrics
You can change the line number individually selected lyrics after they have been input.
PROCEDURE
1.

Select the individual lyrics whose line number you want to change. You can do this in Write
mode and Engrave mode.

2.

Change the value for the Lyric number property in the Lyrics group of the Properties
panel to correspond with the line number you want in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

RESULT
The line number of the selected lyrics is changed.
NOTE
If other lyric lines exist at the same position, the position of the selected lyrics may be changed.
For example, if there were two lyric lines and you changed lyrics in lyric Line 1 to Line 3, they now
appear below lyric Line 2.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440

Changing the placement of lyric lines relative to the staff
You can change the placement of lyric lines relative to the staff after they have been input. The
placement of lyric lines can be changed for whole lyric lines, and for individually selected lyrics.
PROCEDURE
1.

In Write mode, select a lyric in the lines whose placement relative to the staff you want to
change.
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NOTE
You can also make a selection and use the lyric filters to select different lyric lines
according to their line numbers, and to select lyric lines according to their position relative
to the staff.
2.

Select the placement relative to the staff you want in any of the following ways:
●

Choose Edit > Lyrics > Placement > Above Staff.

●

Right-click and choose Lyrics > Placement > Above Staff from the context menu.

●

Choose Edit > Lyrics > Placement > Below Staff.

●

Right-click and choose Lyrics > Placement > Below Staff from the context menu.

RESULT
The placement relative to the staff of the whole lyric lines of the selected lyrics is changed.
NOTE
If other lyric lines with the same lyric line number exist at the same position on the side of the
staff to which you want to change your current selection, the two lines switch sides. For example,
if there is already a lyric Line 2 above the staff at the position you want to change the placement
of lyric Line 2 below the staff, then the existing lyrics above the staff are placed below the staff to
accommodate your most recent preference.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440
Changing the line number of lyric lines on page 441

Changing the placement of individual lyrics relative to the staff
You can change the placement of individual lyrics relative to the staff after they have been input.
PROCEDURE
1.

Select the lyrics whose placement relative to the staff you want to change. You can do this
in Write mode and Engrave mode.

2.

Choose one of the following options for the Line placement property in the Lyrics group
of the Properties panel:
●

Above

●

Below

RESULT
The placement relative to the staff of the selected individual lyrics is changed.
NOTE
If other lyric lines with the same lyric line number already exist at the same position on the same
side of the staff, the two lines collide. To avoid this, you may want to change the lyric line number
of one of the lyric lines, or change their placement relative to the staff using the Edit > Lyrics >
Placement menu, as described above, which avoids collisions.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440
Changing the line number of lyric lines on page 441
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Changing lyric lines to chorus lines
You can change whole lyric lines into chorus lines after they have been input.
PROCEDURE
1.

In Write mode, select a lyric in the line that you want to change to a chorus line. It can be
above or below the staff.
NOTE
You can also make a selection and use the lyric filters to select different lyric lines
according to their lyric line number and lyric type.

2.

Change the selected lyric lines to chorus lines in any of the following ways:
●

Choose Edit > Lyrics > Line > Chorus.

●

Right-click and choose Lyrics > Line > Chorus from the context menu.

RESULT
The whole lyric line of the selected lyric is changed to a chorus line.
NOTE
If other chorus lines already exist at the same position on the same side of the staff, the two lines
switch. For example, if there is already a chorus line below the staff at the position you want to
change lyric Line 1 below the staff into a chorus line below the staff, then the existing chorus line
becomes lyric Line 1 to accommodate your most recent preference.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440
Showing lyrics in italic font on page 447
Changing the line number of lyric lines on page 441

Changing individual lyrics into chorus lyrics
You can change individual lyrics into chorus lyrics after they have been input.

PROCEDURE
1.

Select the lyrics you want to change into chorus lyrics. You can do this in Write mode and
Engrave mode.

2.

Check the box beside the Chorus property in the Lyrics group of the Properties panel.

RESULT
The selected individual lyrics are changed to chorus lyrics.
NOTE
If other chorus lines exist at the same position on the side of the staff to which you want to
change your current selection to chorus lines, the two lines collide. To avoid this, you may want
to change the lyrics into chorus lyrics using the Edit > Lyrics > Placement menu, which avoids
collisions.
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NOTE
Turning lyric lines into chorus lyric lines changes both their placement and appearance as chorus
lines are shown in an italic font, and placed in the middle of other lyric lines.
You can show lyrics in an italic font without changing their lyric type or placement.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440
Showing lyrics in italic font on page 447
Changing the line number of lyric lines on page 441

Changing lyric lines to lyric line translations
You can change whole lyric lines can be changed to lyric line translations after they have been
input.
PROCEDURE
1.

In Write mode, select a lyric in the line that you want to change to a lyric line translation. It
can be above or below the staff.
NOTE
You can also make a selection and use the lyric filters to select different lyric lines
according to their lyric line number and lyric type.

2.

Select the line number of which you want the selected lyric line to become in any of the
following ways:
●

Choose Edit > Lyrics > Translations > Line 1 Translation.

●

Right-click and choose Lyrics > Translations > Line 1 Translation from the context
menu.

●

Choose Edit > Lyrics > Translations > Line 2 Translation.

●

Right-click and choose Lyrics > Translations > Line 2 Translation from the context
menu.

●

Choose Edit > Lyrics > Translations > Line 3 Translation.

●

Right-click and choose Lyrics > Translations > Line 3 Translation from the context
menu.

●

Choose Edit > Lyrics > Translations > Line 4 Translation.

●

Right-click and choose Lyrics > Translations > Line 4 Translation from the context
menu.

●

Choose Edit > Lyrics > Translations > Line 5 Translation.

●

Right-click and choose Lyrics > Translations > Line 5 Translation from the context
menu.

●

Choose Edit > Lyrics > Translations > Chorus Translation.

●

Right-click and choose Lyrics > Translations > Chorus Translation from the context
menu.

RESULT
The selected lyric lines become lyric translation lines of the lyric line number specified.
NOTE
If a lyric line translation already exists for the same line number at the same position on
the same side of the staff, the two lines switch. For example, if there is already a lyric Line 1
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translation at the same rhythmic position where you want to change lyric Line 2 into lyric Line
1 translation, then the existing lyric line translation becomes lyric Line 2 to accommodate your
most recent preference.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440
Showing lyrics in italic font on page 447

Changing individual lyrics to translation lyrics
You can change individual lyrics into translation lyrics after they have been input.
PROCEDURE
1.

Select the lyrics you want to change into translation lyrics. You can do this in Write mode
and Engrave mode.

2.

Check the box beside the Is translation property in the Lyrics group of the Properties
panel.

RESULT
The selected lyrics become translation lyrics of the same lyric line number that they were
previously. For example, selecting lyrics in Line 2 and activating the Is translation property turns
them into translation lyrics for lyric Line 2.
NOTE
If other chorus lines exist at the same position on the side of the staff to which you want to
change your current selection to chorus lines, the two lines collide. To avoid this, you may want
to change the lyrics into chorus lyrics using the Edit > Lyrics > Placement menu, as described
above, which avoids collisions.
NOTE
Turning lyric lines into lyric line translations changes both their placement and appearance: lyric
line translations are placed below the lyric line of which they are a translation, are shown in an
italic font, and are not given their own verse number if verse numbers are shown as they are
counted as part of the lyric line of which they are a translation.
You can also show lyrics in an italic font without changing their lyric type or placement.

RELATED LINKS
Changes to the type and placement of lyric lines on page 440
Showing lyrics in italic font on page 447

Individual changes to the appearance and placement of
lyrics
The appearance and placement of lyrics can be changed individually using properties in the
Lyrics group of the Properties panel.
Most properties in the Lyrics group of the Properties panel are available in Write mode and
Engrave mode, however there are more properties available in Engrave mode.
You can change the appearance and position of lyrics project-wide by changing the font used
for lyrics, and by selecting and changing options on the Lyrics page in Engrave > Engraving
Options.
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RELATED LINKS
Project-wide changes to the appearance of lyrics on page 449
Changing the lyrics font style on page 451

Changing the syllable type of existing lyrics
You can indicate the syllable type for each lyric as you input them by which key you press to
advance the popover: press Space if you typed in a complete word, or the final syllable in a multisyllabic word, and press - if you typed in one syllable of a multi-syllabic word.
These two keys tell Dorico what type of syllable that lyric is:
●

A whole word if it comes after a gap, and is followed by a gap.

●

The first syllable in a multi-syllabic word if it comes after a gap, but is followed by a
hyphen.

●

A middle syllable in a multi-syllabic word if it comes after a hyphen, and is followed by a
hyphen.

●

The last syllable in a multi-syllabic word if it comes after a hyphen, but is followed by a gap.

To change the syllable type of lyrics after they have been input:
PROCEDURE
1.

Select the lyrics whose syllable type you want to change. You can do this in Write mode
and Engrave mode.

2.

Select one of the following options from the Syllable type menu in the Lyrics group of the
Properties panel:
●

Whole Word: no hyphens are shown either side of lyrics. Extender lines can be
shown after lyrics.

●

Start: shows hyphens after lyrics, which can be continuation hyphens depending on
the distance before the next lyric in the same lyric line.

●

Middle: shows hyphens after lyrics, which can be continuation hyphens depending
on the distance before the next lyric in the same lyric line.

●

End: Extender lines can be shown after lyrics.
NOTE
Changing the syllable type to Middle or End does not automatically show hyphens
before the syllable. To show a hyphen before a lyric, you should change the syllable
type of the lyric immediately preceding it to either Start or Middle.

RELATED LINKS
Inputting lyrics on page 426

Showing lyrics in italic font
To show lyrics in an italic font without changing their lyric type or position:
PROCEDURE
1.

Select the lyrics you want to show in an italic font. You can do this in Write mode and
Engrave mode.

2.

Activate the Italic property in the Lyrics group of the Properties panel.
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RESULT
The selected lyrics are shown in an italic font.
NOTE
If you want to show lyrics in an italic font because they are intended to be either chorus lyrics or
translation lyrics, you should change their lyric type.
If you want all normal lyric lines to appear in an italic font project-wide, you can change the font
style of the Lyrics Font.

RELATED LINKS
Changing lyric lines to chorus lines on page 444
Changing lyric lines to lyric line translations on page 445
Changing the lyrics font style on page 451

Changing the alignment of lyrics relative to notes
By default, the center of lyrics are aligned horizontally with noteheads. You cannot change this
project-wide, as the horizontal position of lyrics is automatically adjusted in Dorico to minimize
changes to the rhythmic spacing of notes.
NOTE
Changing the alignment of lyrics manually overrides the automatic spacing for the selected lyrics.
If you change the alignment of a lyric whose position was automatically re-adjusted, the rhythmic
spacing at that rhythmic position might change.
If you find that you need to override the alignment of lyrics:
PROCEDURE
1.

Select the lyrics whose alignment you want to change. You can do this in Write mode and
Engrave mode.

2.

Activate the Lyric text alignment property in the Lyrics group of the Properties panel.

3.

Select one of the following options from the menu:
●

Left

●

Center

●

Right

RESULT
The alignment of the selected lyrics is changed according to your selection.

Showing East Asian elision slurs individually
You can show and not show East Asian elision slurs for individually selected lyrics, independently
of your project-wide setting in Engraving Options.
PROCEDURE
1.

Select the lyrics on which you want to show East Asian elision slurs. You can do this in
Write mode and Engrave mode.

2.

Activate the Show East Asian elision slur property in the Lyrics group of the Properties
panel.
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3.

Check the box beside the activation switch to show East Asian elision slurs on the selected
lyrics.
NOTE
Only activating the Show East Asian elision slur property means East Asian elision slurs
are not shown. The box beside the activation switch must be checked as well in order to
show East Asian elision slurs.

RESULT
East Asian elision slurs are shown on the selected lyrics when the box beside the Show East
Asian elision slur is checked.
NOTE
You can choose to show East Asian elision slurs project-wide on the Lyrics page in Engrave >
Engraving Options.

RELATED LINKS
Showing East Asian elision slurs project-wide on page 451

Project-wide changes to the appearance of lyrics
Different aspects of the appearance, position, and spacing of lyrics can be changed on the Lyrics
page in Engrave > Engraving Options, and in the Engrave > Font Styles dialog.

Changing the lyrics font style
In the Engrave > Font Styles dialog, you can select the Lyrics Font from the menu and change
different aspects of the font.
Changes made to the font style apply to the entire project, including parts.
The different aspects of the lyrics font style that you can change are:
Font family
This sets the overall font style.
Size
This sets the size of lyrics. Lyric size can be:
●

Absolute: always the set size, regardless of the staff size.

●

Staff-relative: the size of lyrics is proportional to the staff size, which means
lyrics appear smaller than the set value on smaller staves, and larger than the
set value on larger staves.

Style
This sets the lyrics font appearance. The lyrics font can be:
●

Regular (default)

●

Italic

●

Bold

●

Bold Italic

Underlined
The lyrics font appears underlined if the box beside the Underlined activation switch
is checked.
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RELATED LINKS
Project-wide Engraving Options for lyrics on page 450

Project-wide Engraving Options for lyrics
Options for the appearance and placement of lyrics project-wide can be found on the Lyrics page
in Engraving Options.
The options on this page allow you to change the default appearance and positions of lyrics, and
the appearance and positions of lyric hyphens and lyric extender lines.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Lyrics in the page list on the left of the dialog.

Showing and hiding verse numbers
You can choose to show verse numbers or not show verse numbers project-wide in the Verse
Numbers section of the Lyrics page in Engraving Options.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Lyrics in the page list.

3.

Choose one of the following options for the Verse numbers for each line of lyrics option
in the Verse Numbers section:

4.

●

Show verse numbers

●

Do not show verse numbers

Click Apply, then Close.

RESULT
Verse numbers are either shown or not shown project-wide, according to your selection.

Changing the appearance of verse numbers
You can change how verse numbers appear in the Verse Numbers section of the Lyrics page in
Engraving Options.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Lyrics in the page list.

3.

Choose one of the following options for the Punctuation for verse numbers option in the
Verse Numbers section:

4.

●

Append period (full stop)

●

Do not append period (full stop)

Click Apply, then Close.
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RESULT
Verse numbers are either shown with a period or not shown with a period project-wide,
according to your selection.

Showing East Asian elision slurs project-wide
East Asian elision slurs are used to show that two or more characters in East Asian languages are
part of the same lyric.
To show East Asian elision slurs project-wide:
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Lyrics in the page list.

3.

Choose one of the following options in the East Asian Lyrics section:
●

Show

●

Do not show

RESULT
East Asian elision slurs are either shown or not shown project-wide, according to your selection.
RELATED LINKS
Project-wide Engraving Options for lyrics on page 450

Changing the lyrics font style
To change the font style used for lyrics:
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Font Styles dialog.

2.

Choose Lyrics Font from the Font style menu.

3.

Activate the switch beside the following options to change the corresponding aspects of
the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The lyrics font style is changed project-wide.
RELATED LINKS
Project-wide changes to the appearance of lyrics on page 449
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Changing the lyric line translation font style
To change the font style used for lyric line translations:
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Font Styles dialog.

2.

Choose Lyrics translation Font from the Font style menu.

3.

Activate the switch beside the following options to change the corresponding aspects of
the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The lyric line translation font style is changed project-wide.
RELATED LINKS
Project-wide changes to the appearance of lyrics on page 449
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Notes are shapes that are positioned on staves to indicate musical pitches. Notes are most
commonly shown with oval-shaped, round noteheads, however there are many different designs
of noteheads that can be used.
RELATED LINKS
Project-wide Engraving Options for notes on page 453
Changing notehead design project-wide on page 453
Changing the notehead design of individual noteheads on page 456
The add intervals popover on page 105
Adding notes above and below existing notes on page 105

Project-wide changes to the appearance of noteheads
Project-wide Engraving Options for notes
There are a number of options for the appearance of notes and noteheads project-wide that you
can choose from on the Notes page in Engraving Options.
The options on this page allow you to change the design, appearance, and positions of
noteheads, ledger lines, stem flags, and rhythm dots. You can also change the size of grace notes
relative to normal notes.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Notes in the page list on the left of the dialog.

Changing notehead design project-wide
You can make project-wide changes to the notehead design.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Notes in the page list.

3.

Select one of the following options for the Notehead design option in the Noteheads
section:
●

Default noteheads (smaller than Larger noteheads)

●

Larger noteheads (Default)
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●

Note names

●

Figurenotes© colors

NOTE
This does not change the notehead design of noteheads whose design you have changed
individually.

RESULT
The notehead design of all notes project-wide is changed.
NOTE
You can also change the notehead design of individual noteheads, for example, so that selected
notes appear with slash noteheads or diamond noteheads.

RELATED LINKS
Changing the notehead design of individual noteheads on page 456

Showing different shaped noteheads for each degree of the scale
To show each degree of the scale with a different notehead design project-wide:
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Notes in the page list.

3.

Select one of the following options for the Shaped noteheads based on scale degree
option in the Noteheads section:
●

Walker 4-shape

●

Walker 7-shape

●

Funk 7-shape

●

Aikin 7-shape

RESULT
The notehead design of all noteheads project-wide is changed to show a different notehead
design for each degree of the scale, depending on your selection.
NOTE
This does not override the notehead design of noteheads whose design you have changed
individually.

RELATED LINKS
Changing the notehead design of individual noteheads on page 456

Showing note names in noteheads
To show the note name as a letter in all noteheads project-wide:
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Notes in the page list.
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3.

Select Note names for the Notehead design option in the Noteheads section.
NOTE
This does not change the notehead design of noteheads whose design you have changed
individually.

RESULT
The notehead design of all noteheads not overridden individually is changed to show the note
name inside noteheads.
NOTE
To be able to read the letter name inside noteheads, you may need to increase the staff size of
your project.

RELATED LINKS
Changing the notehead design of individual noteheads on page 456

Individual changes to the appearance of noteheads
The appearance and position of noteheads can be changed individually, and independently of
your settings in Engrave > Engraving Options.
RELATED LINKS
Project-wide changes to the appearance of noteheads on page 453

Available notehead designs
The following different notehead designs are currently available in the Edit > Notehead menu.
Notehead design appearance

Notehead design name
Aikin 7-shape noteheads
Circle X noteheads
Circled noteheads
Default noteheads
Default noteheads (large)
Diamond noteheads
Funk 7-shape noteheads
Large arrow down noteheads
Large arrow up noteheads
Large circled noteheads
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Notehead design appearance

Notehead design name
Muted slash noteheads
Old-style diamond noteheads
Pitch name noteheads
Plus noteheads
Slash noteheads
Slashed noteheads (bottom left to top right)
Slashed noteheads (top left to bottom right)
Triangle down noteheads
Triangle up noteheads
Walker 4-shape noteheads
Walker 7-shape noteheads
White diamond noteheads
Wide diamond noteheads
With X noteheads
X noteheads

Changing the notehead design of individual noteheads
To change the notehead design of individually selected noteheads:
PROCEDURE
1.

Select the noteheads whose notehead design you want to change. You can do this in Write
mode and Engrave mode.

2.

Choose Edit > Notehead, or right-click and choose Notehead from the context menu,
then select the notehead design you want from the options available.
For example, you can change the notehead design of the selected notes to X noteheads in
the following ways:
●

Choose Edit > Notehead > X Notehead.

●

Right-click and choose Notehead > X Notehead from the context menu.

RESULT
The notehead design of the selected notes is change according to your selection.
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NOTE
You can also change the notehead design for all noteheads project-wide.

RELATED LINKS
Changing notehead design project-wide on page 453

Changing the size of notes individually
You can change the size of notes individually.
NOTE
You can change the size of all notes project-wide by changing the notehead design on the Notes
page in Engrave > Engraving Options.
NOTE
If you want to change the size of notes because you want them to be grace notes, or because you
want them to be cues, you should input them as either grace notes or cues.

PROCEDURE
1.

Select the notes whose size you want to change. You can do this in Write mode and
Engrave mode.

2.

Activate the Scale property in the Common group of the Properties panel.

3.

Select one of the following options from the menu:
●

Normal

●

Grace

●

Cue

●

Cue grace

RELATED LINKS
Inputting grace notes with the keyboard on page 380
Inputting grace notes with the mouse on page 381
Inputting cues on page 305

Changing the custom scale size of individual notes
You can change the size of notes according to a custom scale if you want to change the size
of notes to a size other than the options available in the Scale property menu in the Common
group of the Properties panel.
NOTE
If you want to change the size of notes because you want them to be grace notes, or because you
want them to be cues, you should input them as either grace notes or cues.

PROCEDURE
1.

Select the notes whose custom scale size you want to change. You can do this in Write
mode and Engrave mode.

2.

Activate the Custom Scale property in the Common group of the Properties panel.
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NOTE
The Custom Scale property changes the size of notes according to a percentage change.
If you have also activated the Scale property, the percentage change is based on the
selected size option for the Scale property.
3.

Change the size of the selected notes by changing the scale percentage value of the
Custom Scale property in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

RELATED LINKS
Inputting grace notes with the keyboard on page 380
Inputting grace notes with the mouse on page 381
Inputting cues on page 305

Changing the width of ledger lines individually
You can change the width of ledger lines for individually selected ledger lines in Engrave mode.
You can also change the width of all ledger lines project-wide on the Notes page in Engrave >
Engraving Options.
To change the width of individually selected ledger lines:
PROCEDURE
1.

In Engrave mode, select the notes whose ledger line width you want to change.

2.

Activate the Ledger line property in the Notes and Rests group of the Properties panel.

3.

Change the width of the selected ledger lines by changing the values of the following
properties:
●

Ledger line L: increasing the value makes the left side of ledger lines longer,
decreasing the value makes the left side of ledger lines shorter.

●

Ledger line R: increasing the value makes the right side of ledger lines longer,
decreasing the value makes the right side of ledger lines shorter.

RESULT
The width of ledger lines of the selected notes is changed according to the values set.
RELATED LINKS
Project-wide changes to the appearance of noteheads on page 453

Changing the consolidation of rhythm dots individually
You can change how rhythm dots in multiple voices are consolidated for individually selected
notes in Engrave mode. You can also change how rhythm dots in multiple voices are
consolidated for all notes project-wide on the Notes page in Engrave > Engraving Options.
To change how rhythm dots in multiple voices are consolidated for individually selected notes:
PROCEDURE
1.

In Engrave mode, select the notes whose rhythm dot consolidation you want to change.

2.

Activate the Rhythm dot consolidation property in the Notes and Rests group of the
Properties panel.
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3.

Select one of the following options from the menu:
●

None

●

Allowed

●

Unisons only

●

Aggressive

RESULT
The consolidation of rhythm dots for the selected notes is changed according to your selection.
RELATED LINKS
Project-wide changes to the appearance of noteheads on page 453

Specifying on which string individual notes are played
(string instruments only)
You can specify on which string individually selected notes are played when notes are in the
staves of string instruments, such as violins or cellos. Many notes can be played on multiple
strings, depending on where along its length the string is stopped.
PROCEDURE
1.

Select the notes whose assigned string you want to change. You can do this in Write mode
and Engrave mode.
NOTE
If selecting multiple notes at once, it is best to select notes only in staves of the same
instrument type. For example, selecting multiple Cs in the Violin 1 and Violin 2 staves.

2.

Activate the String property in the Notes and Rests group of the Properties panel.

3.

Select your preferred string from the available options in the menu. The string number for
the instrument is shown, followed by the fundamental pitch and its octave number of that
string in parentheses. For example, the lowest cello string is expressed as 4 (C2).
NOTE
The options available in the menu depends on the selected pitches and the instrument.

RESULT
The string on which the selected notes are played is changed.
NOTE
If you subsequently change the pitches of notes, the String property is automatically unset for all
notes that no longer be played on their specified string.

Inputting notes
Notes can be input into your project during step input, when note input is activated. You can
input notes with a computer keyboard, by clicking with a mouse pointer, or by playing notes in
from a MIDI keyboard.
Notes can also be input as chords during step input.
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Changing the pitch of existing notes
Inputting notes with Insert mode activated allows you to input notes without overriding any
existing notes that come after the current rhythmic position of the caret.
How the duration of notes is notated is automatically determined by Dorico automatically adjusts
the notation of notes based on the time signature and position in the bar. You can force the
duration of notes if you want to specify how notes are notated.
RELATED LINKS
Inputting notes on page 94
Inputting chords on page 96
Inputting notes in Insert mode on page 95
Forcing the duration of notes on page 102
The add intervals popover on page 105
Adding notes above and below existing notes on page 105

Changing the pitch of existing notes
You can change the pitch of notes after they have been input.
PROCEDURE
1.

In Write mode, select the notes whose pitches you want to change.

2.

Raise or lower the pitches of the selected notes in the following ways:
●

Press Alt-Up Arrow to move notes up one staff position.

●

Press Alt-Down Arrow to move notes down one staff position.

●

Press Shift-Alt-Up Arrow to transpose notes up a semitone.

●

Press Shift-Alt-Down Arrow to transpose notes down a semitone.

RESULT
The pitches of the selected notes are changed.
NOTE
You can press Alt-Up Arrow and Alt-Down Arrow to change the staff positions of notes in
percussion kits using grid and five-line staff presentation types. However, this also changes the
instrument playing the note.

RELATED LINKS
Adding notes above and below existing notes on page 105
The add intervals popover on page 105

Deleting notes
PROCEDURE
1.

In Write mode, select the notes you want to delete.

2.

Delete the notes in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected notes are deleted from your project.
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Positions of notes
Dynamics at the rhythmic positions of deleted notes are not deleted.
If a slur began or ended on a deleted note, the slur is automatically repositioned to the next or
previous notehead. If only one note is left under a slur, the slur is automatically deleted.
Octave lines are not deleted or repositioned.
Holds and pauses are not deleted, but may be repositioned to be over whole bar rests if you
delete all notes in a bar.

Positions of notes
You can move notes to different rhythmic positions after they have been input in Write mode,
and you can adjust the graphical positions of notes by editing note spacing.
You can also cross notes to other staves for grand staff instruments, such as piano and harp.
RELATED LINKS
Note spacing on page 171
Moving grace notes rhythmically on page 383
The add intervals popover on page 105
Adding notes above and below existing notes on page 105

Moving notes rhythmically
You can move notes to different rhythmic positions along staves.
PROCEDURE
1.

In Write mode, select the notes you want to move.

2.

Move the selected notes to the right or to the left in the following ways, according to the
rhythmic grid currently set:
●

Press Alt-Right Arrow

●

Press Alt-Left Arrow

RESULT
The selected notes are moved to new rhythmic positions. If you selected multiple adjacent notes,
they are moved together as a block.
NOTE
If any of your selected notes collide with other notes in the same staff and at the same rhythmic
position that are in the same voice as your selected notes, the existing notes are deleted and
replaced with your selected notes.
You can undo moving notes immediately afterward, which restores any notes deleted in the
process.
However, moving notes back to their previous positions later does not restore any notes deleted
when they were moved previously. The deleted notes must be re-input if necessary.

Changes to note spacing in Engrave mode
Notes are automatically positioned rhythmically when they are input, according to their rhythmic
duration and position relative to other notes.
Moving notes graphically away from their rhythmic position can be misleading for players
reading the music. However, you can make graphical adjustments to the positions of notes
according to their rhythmic positions in Engrave mode.
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Positions of notes
RELATED LINKS
Adjusting note spacing at individual rhythmic positions in Engrave mode on page 172
Layout Options on page 85
Project-wide Engraving Options for notes on page 453

Crossing notes to other staves
You can cross notes so that they appear on other staves to the staff into which they were input
for grand staff instruments, without changing the staff to which they are attached.
For example, in phrases that cover a wide pitch range there can be some notes in a beam that fit
best in a staff with a treble clef, but other notes in the beam fit better in a staff with a bass clef.

Notes all in the upper staff of a grand staff instrument

You can cross some notes to the staff above or to the staff below to create cross-staff beams.
This can also reduce the number of notes with ledger lines in phrases.

Notes spanning both staves of a grand staff instrument

PROCEDURE
1.

Select the notes you want to cross to another staff. You can do this in Write mode and
Engrave mode.
NOTE
You can only cross notes to other staves in grand staff instruments.

2.

Cross the notes to other staves in the following ways:
●

Press N to cross notes to the staff above

●

Press M to cross notes to the staff below

●

Choose Edit > Cross Staff > Cross to Staff Above

●

Choose Edit > Cross Staff > Cross to Staff Below

RESULT
The notes are shown in a different staff.
NOTE
When crossing notes to a staff that already contains notes, the stem direction of the existing
notes in the staff may change. This is due to how multiple voices at the same rhythmic position
are handled.
Therefore, you may need to change the stem direction of notes manually.
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RELATED LINKS
Creating cross-staff beams on page 256
Crossing notes to staves with existing notes in other voices on page 712
General placement conventions for notes in multiple voices on page 706
Changing the stem direction of notes individually on page 601

Transposing notes
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Arpeggio signs are vertical lines that indicate chords should be played “spread” so that the notes
in the chord are played very quickly, one after another. Arpeggio signs are normally shown with
wavy lines similar to trill extension lines.
Arpeggiated chords can be played in two directions:
●

Upwards, starting from the bottom note in the chord

●

Downwards, starting from the top note in the chord

In Dorico, there are three types of arpeggio signs:
●

Up arpeggio: a vertical wavy line that indicates chords should be arpeggiated from the
bottom note upwards

●

Down arpeggio: a vertical wavy line that indicates chords should be arpeggiated from the
top note downwards

●

Non arpeggio: a bracket with straight lines that indicates all notes in the chord should be
played together, with no arpeggiation

Default up arpeggio

Default down arpeggio

Default non arpeggio

You can show arpeggio signs with different ends in Dorico. By default, up arpeggios are shown
with nothing at the top end, because chords are most commonly arpeggiated upwards. Down
arpeggios are shown with an arrow at the bottom by default.
Both up arpeggios and down arpeggios can be shown with one of three ends:
●

Nothing

●

Arrow

●

Swash

Up arpeggio with nothing at the
end

Up arpeggio with an arrow at the
end

Up arpeggio with a swash at the
end

It is accepted practice to show up arpeggios with an arrow at the top if down arpeggios are also
used in the same piece of music.
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General placement conventions for arpeggio signs
Arpeggio signs are positioned to the left of the notes to which they apply, but should not be
positioned between notes and accidentals. They should also always appear within the same bar
as the notes to which they apply, and not on the other side of the barline.
Dorico makes automatic adjustments to note spacing and staff spacing to accommodate
arpeggio signs and ensure they are positioned correctly.
Arpeggio signs should cover the whole vertical range of all notes in the chord to which they
apply, and protrude slightly at each end. However, they do not need to cover the stems of notes.
Dorico automatically creates the lengths of arpeggio signs to cover the notes in chords, and
adjusts their lengths if the notes in chords change or are deleted.
If an arpeggiated chord spans two staves, such as in a piano part, its arpeggio sign can extend
across both staves.
RELATED LINKS
Project-wide Engraving Options for arpeggio signs on page 473

Inputting arpeggio signs with the keyboard
You can input arpeggio signs with the keyboard using the ornaments popover. You can input
arpeggio signs during step input and later on by adding arpeggio signs to existing notes.

Inputting arpeggio signs during step input with the keyboard
PROCEDURE
1.

In Write mode, start note input.

2.

If required, activate Chords in one of the following ways:

3.

●

Press Q.

●

Click Chords in the Notes panel on the left of the window:

Open the ornaments popover in any of the following ways:
●

Press Shift-O

●

Choose Write > Create Ornament

4.

Enter the arpeggio sign you want into the popover, such as arpup for an up arpeggio or
arpdown for a down arpeggio.

5.

Press Return to close the popover.

RESULT
The arpeggio sign specified is input at the caret position. Its length is adjusted automatically so
that it spans the range of all notes in the staff at that rhythmic position.
RELATED LINKS
The ornaments popover on page 486
Inputting notes on page 94
Inputting chords on page 96
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Adding arpeggio signs to existing notes with the keyboard
PROCEDURE
1.

In Write mode, select one of the following:
●

A note to which you want to add an arpeggio sign

●

A note in a chord or multiple notes in a chord to which you want to add an arpeggio
sign
NOTE
You can only add one arpeggio sign to one note or chord at a time.

2.

Open the ornaments popover in any of the following ways:
●

Press Shift-O

●

Choose Write > Create Ornament

3.

Enter the arpeggio sign you want into the popover. For example, arp for an up arpeggio
sign or nonarp for a non arpeggio sign.

4.

Press Return to close the popover.

RESULT
The arpeggio sign specified is input to the left of the selected note or chord. Its length is adjusted
automatically so that it spans the range of all notes in the staff at that rhythmic position.

Inputting cross-staff and cross-voice arpeggio signs with the
keyboard
You can input arpeggio signs between notes in different voices, and between notes in different
staves that belong to the same instrument, such as piano or harp.
PROCEDURE
1.

In Write mode, select one of the following in one of the voices or staves to which you want
to add an arpeggio sign:
●

A single note

●

Multiple notes in a chord

2.

Hold down the Ctrl/Cmd key.

3.

Select one of the following in the other voice or staff at the same rhythmic position as your
selection in step 1:

4.

●

A single note

●

Multiple notes in a chord

Open the ornaments popover in any of the following ways:
●

Press Shift-O

●

Choose Write > Create Ornament

5.

Enter the arpeggio sign you want into the popover. For example, arp for an up arpeggio
sign or nonarp for a non arpeggio sign.

6.

Press Return to close the popover.

RESULT
The arpeggio sign specified is input across the selected notes. Its length is adjusted automatically
so that it spans the range of all notes in the staff at that rhythmic position.
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NOTE
You cannot create cross-staff arpeggio signs between different instruments.

Inputting arpeggio signs with the mouse
You can input arpeggio signs with the mouse by clicking on the arpeggio signs you want in the
Ornaments panel during step input and later on by adding ornaments to existing notes.
You can open the Ornaments panel by clicking Ornaments in the Notations toolbox on the right
of the window in Write mode:

The different sections in the Ornaments panel are:
●

Baroque and Classical

●

Arpeggiation

●

Glissandi

Adding arpeggio signs to existing notes with the mouse
PROCEDURE
1.

In Write mode, select one of the following:
●

A note to which you want to add an arpeggio sign

●

A note in a chord or multiple notes in a chord to which you want to add an arpeggio
sign

NOTE
You can only add one arpeggio sign to one note or chord at a time.
2.

Click on the arpeggio sign you want in the Arpeggiation section of the Ornaments panel
on the right of the window.

RESULT
The arpeggio sign specified is input to the left of the selected note or chord. Its length is adjusted
automatically so that it spans the range of all notes in the staff at that rhythmic position.
NOTE
If your preference is set to Load cursor with item, complete these steps in the reverse order.

Inputting cross-staff and cross-voice arpeggio signs with the mouse
You can input arpeggio signs between notes in different voices, and between notes in different
staves that belong to the same instrument, such as piano or harp.
PROCEDURE
1.

In Write mode, select one of the following in one of the voices or staves to which you want
to add an arpeggio sign:
●

A single note

●

Multiple notes in a chord
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2.

Hold down the Ctrl/Cmd key.

3.

Select one of the following in the other voice or staff at the same rhythmic position as your
selection in step 1:

4.

●

A single note

●

Multiple notes in a chord

Click on the arpeggio sign you want in the Arpeggiation section of the Ornaments panel
on the right of the window.

RESULT
The arpeggio sign specified is input across the selected notes. Its length is adjusted automatically
so that it spans the range of all notes in the staff at that rhythmic position.
NOTE
You cannot create cross-staff arpeggio signs between different instruments.
You cannot create cross-staff and cross-voice arpeggio signs if your preference is set to Load
cursor with item.

Changing the type of arpeggio signs
You can change the type of existing arpeggio signs.
PROCEDURE
1.

Select the arpeggio signs whose type you want to change. You can do this in Write mode
and Engrave mode.

2.

Select one of the following options from the menu beside the Arpeggio type property in
the Arpeggios group of the Properties panel:
●

Non arpeggio

●

Up arpeggio

●

Down arpeggio

RESULT
The type of the selected arpeggios is changed, according to your selection.
RELATED LINKS
Arpeggio signs on page 464

Deleting arpeggio signs
PROCEDURE
1.

In Write mode, select the arpeggio signs you want to delete.

2.

Delete the arpeggio signs in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected arpeggio signs are deleted.
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Lengths of arpeggio signs
Dorico automatically adjusts the length of arpeggio signs when the pitches of the notes in the
voices to which the sign applies change, or when you add notes to the chords or delete notes
from the chords.
You can change how far arpeggio signs extend beyond the outer notes in all chords project-wide
on the Arpeggio Signs page in Engrave > Engraving Options. You can set different values for
when notes are on staff lines and in staff spaces.
RELATED LINKS
Project-wide Engraving Options for arpeggio signs on page 473

Lengthening and shortening arpeggio signs graphically
You can lengthen and shorten individual arpeggio signs graphically.
PROCEDURE
1.

In Engrave mode, select the square handles at one end of the arpeggio signs you want to
lengthen or shorten.

2.

Lengthen and shorten the arpeggio signs by moving the handles in the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
NOTE
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag them upwards or downwards to the positions you want.

RESULT
The selected arpeggio signs are lengthened or shortened graphically.
NOTE
You can change how far arpeggio signs extend beyond the outer notes in all chords project-wide
on the Arpeggio Signs page in Engrave > Engraving Options.

RELATED LINKS
Lengthening and shortening arpeggio signs graphically using the Properties panel on page
469
Project-wide Engraving Options for arpeggio signs on page 473

Lengthening and shortening arpeggio signs graphically using the
Properties panel
You can lengthen and shorten arpeggio signs graphically using the Properties panel in Engrave
mode.
PROCEDURE
1.

In Engrave mode, select the arpeggio signs you want to lengthen or shorten.

2.

Activate the following properties, individually or together, in the Arpeggios group of the
Properties panel:
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3.

4.

●

Top Y offset

●

Bottom Y offset

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties lengthen and shorten arpeggio signs in the following ways:
●

Top Y offset moves the handles at the top of arpeggio signs: increasing the value
moves them upwards, decreasing the value moves them downwards.

●

Bottom Y offset moves the handles at the bottom of arpeggio signs: increasing the
value moves them upwards, decreasing the value moves them downwards.

RESULT
Moving the top handles of arpeggio signs upwards and the bottom handles of arpeggio signs
downwards makes arpeggio signs longer.
Moving the top handles of arpeggio signs downwards and the bottom handles of arpeggio signs
upwards makes arpeggio signs shorter.

Positions of arpeggio signs
You can change the positions of arpeggio signs by moving individual arpeggio signs to different
rhythmic positions in Write mode, moving them to different graphical positions in Engrave mode,
and by changing the default positions of all arpeggio signs project-wide.
You can move arpeggio signs to different rhythmic positions in Write mode. They are positioned
by default according to your preferences in Engraving Options.
You can move arpeggio signs graphically in Engrave mode, however, this does not change the
rhythmic positions to which they are attached.
Project-wide settings for the default positions of arpeggio signs can be set on the Arpeggio
Signs page in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for arpeggio signs on page 473

Moving arpeggio signs rhythmically
You can move arpeggio signs to new rhythmic positions after they have been input.
NOTE
You cannot move arpeggio signs rhythmically with the mouse.

PROCEDURE
1.

In Write mode, select the arpeggio signs you want to move.

2.

Move the arpeggio signs left or right in the following ways:
●

Press Alt-Right Arrow

●

Press Alt-Left Arrow
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RESULT
Arpeggio signs are moved left or right, according to the rhythmic grid currently set. If no notes
exist at the next rhythmic position according to the rhythmic grid, the arpeggio sign is not
shown. If you continue moving it right or left, it is shown again beside the next note at a rhythmic
position that can be reached according to the rhythmic grid currently set.
You can change the rhythmic grid if you want to move arpeggio signs to notes at other rhythmic
positions.
NOTE
Only one arpeggio sign can exist at each rhythmic position. If an arpeggio sign in your selection
passes over another arpeggio sign as part of its move, the existing arpeggio sign is deleted.
You can undo moving arpeggio signs immediately afterward. However, simply moving arpeggio
signs back to their previous positions later does not restore any arpeggio signs deleted when
they were moved previously. The deleted arpeggio signs must be re-input if necessary.

Moving arpeggio signs graphically
You can move arpeggio signs graphically without changing the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the arpeggio signs you want to move.

2.

Move the arpeggio signs in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
NOTE
If you want to move arpeggio signs by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the arpeggio signs in any direction to the positions you want.

RELATED LINKS
Lengthening and shortening arpeggio signs graphically on page 469
Moving arpeggio signs graphically using the Properties panel on page 471

Moving arpeggio signs graphically using the Properties panel
You can move arpeggio signs graphically using the Properties panel in Engrave mode, without
changing the rhythmic positions to which they apply.
PROCEDURE
1.

In Engrave mode, select the arpeggio signs you want to move.

2.

Activate the X offset property in the Arpeggios group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The X offset property moves arpeggio signs in the following ways:
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●

Increasing the value moves arpeggio signs to the right.

●

Decreasing the value moves arpeggio signs to the left.

RESULT
The selected arpeggio signs are moved to the right or to the left, according to your changes.
RELATED LINKS
Lengthening and shortening arpeggio signs graphically using the Properties panel on page
469

Individual changes to the appearance and position of
arpeggio signs
You can make changes to the appearance and position of individual arpeggio signs,
independently of your project-wide settings in Engraving Options.
RELATED LINKS
Project-wide Engraving Options for arpeggio signs on page 473

Showing arpeggio signs before grace notes
By default, arpeggio signs are positioned immediately to the left of the notes to which they apply,
and so are positioned between normal notes and grace notes.
PROCEDURE
1.

Select the arpeggio signs you want to show before grace notes. You can do this in Write
mode and Engrave mode.

2.

Activate the Arpeggio before grace notes property in the Arpeggios group of the
Properties panel.

RESULT
The selected arpeggio signs are now shown before grace notes.

Changing the appearance of the ends of arpeggio signs individually
Downwards arpeggio signs have an arrowhead at the bottom of the line by default, but upwards
arpeggio signs have no arrowhead by default. You can change the appearance of the ends of
arpeggio signs individually.
PROCEDURE
1.

Select the arpeggio signs whose ends you want to change. They do not have to be in the
same direction. You can do this in Write mode and Engrave mode.
NOTE
You cannot change the ends of non arpeggio signs.

2.

Activate the Sign end property in the Arpeggios group of the Properties panel.

3.

Select the end you want from the menu:
●

Nothing

●

Arrow
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●

Swash

RESULT
The appearance of the ends of the selected arpeggio signs is changed.
NOTE
You can change the appearance of the ends of all arpeggio signs project-wide on the Arpeggio
Signs page in Engrave > Engraving Options.
EXAMPLE

Up arpeggio with nothing at the
end

Up arpeggio with an arrow at the
end

Up arpeggio with a swash at the
end

Project-wide Engraving Options for arpeggio signs
Options for the appearance and positions of arpeggio signs project-wide can be found on the
Arpeggio Signs page in Engraving Options.
The options on this page allow you to change the design, appearance, and precise positions of
arpeggio signs.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Arpeggio Signs in the page list on the left of the dialog.

Arpeggio signs in playback
You can find options to control the playback of all arpeggio signs project-wide in the Arpeggio
Signs section of the Timing page in Playback Options.
For example, you can control whether arpeggiation starts on the beat or ends on the beat, and
the speed of arpeggiation.
You can set a default arpeggio length, expressed as a fraction of a quarter note at 120bpm. It can
be helpful to set arpeggio lengths using this measurement instead of defining arpeggios as a
fraction of their notated rhythm, as arpeggios in very slow music would play back much slower
than most people would intend.
As well as setting a default length for arpeggios, you can also set minimum and maximum values
for the length of arpeggios, expressed as a fraction of the notated value of the arpeggio. This is
to ensure all notes within arpeggios can be heard within their notated duration.
You can open Playback Options in the following ways:
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●

Choose Play > Playback Options in Play mode

●

Press Ctrl/Cmd-Shift-P in any mode

NOTE
You can also use properties in the Arpeggios Playback group of the Properties panel to override
the default playback options for individual arpeggio signs.

RELATED LINKS
Changing the playback of arpeggio signs relative to the beat individually on page 474

Changing the playback of arpeggio signs relative to the beat
individually
You change whether individual arpeggio signs are played before their notated position or after
their notated position, independently of your project-wide settings for the playback of arpeggio
signs relative to the beat.
PROCEDURE
1.

Select the arpeggios who playback relative to the beat you want to change. You can do this
in Write mode and Engrave mode.

2.

Activate the Playback position property in the Arpeggios Playback group of the
Properties panel.

3.

Choose one of the following options:
●

Start on beat

●

Ends on beat

RESULT
The playback of the selected arpeggios relative to the beat is changed.
NOTE
You can change the playback of all arpeggios relative to the beat project-wide on the Timing
page in Play > Playback Options.
EXAMPLE

Arpeggio ending on the beat

Arpeggio starting on the beat

RELATED LINKS
Arpeggio signs in playback on page 473
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Changing the playback duration of arpeggios individually
You can change the duration of arpeggios, independently of your project-wide settings for the
playback of arpeggios on the Timing page in Playback Options.
The duration of arpeggios is expressed as a fraction of the notated rhythm of chords. For
example, an arpeggio on a quarter note chord with a note offset value of 1/2 lasts an eighth
note, whereas with a note offset value of 1/8 it lasts a 32nd note.
PROCEDURE
1.

Select the arpeggio signs whose playback offset you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the Note offset property in the Arpeggios Playback group of the Properties
panel.

3.

Change the value in the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Save your new value in the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The playback duration of the selected arpeggios is changed. This overrides your project-wide
settings for the duration of arpeggios for the selected arpeggios.
EXAMPLE

Arpeggiated chord with a note offset value of 1/8

RELATED LINKS
Arpeggio signs in playback on page 473
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Arpeggiated chord with a note offset value of 1/2

Glissando lines

Glissando lines indicate a continuous transition between two notes. They can have straight lines
or wavy lines, and can be shown with a text indication or as a line without text.
There are different conventions regarding the playing techniques for glissando and portamento.
Glissando lines may indicate that a chromatic scale should be played between the two notes,
either rising or falling in a series of semitones, whereas portamento lines indicate a smooth,
continuous glide between the two notes.
Some people understand glissando lines to indicate a chromatic scale should be played between
the two notes, either rising or falling in a series of semitones, and portamento lines to indicate a
smooth, continuous glide between the two notes.
However, the terms glissando and portamento may be used interchangeably in other cases.
Both glissando lines and portamento lines can be input in Dorico, and you can easily change their
style after they have been input.

An example of the different glissando line styles and glissando text available in Dorico

General placement conventions for glissando lines
Glissando lines are positioned between noteheads and must accurately match the interval
between the pitches. The endpoints of glissando lines must be directly beside noteheads but not
directly touching them.
Glissando lines must not collide with accidentals, but should instead stop short so the accidental
can be clearly read. Dorico automatically positions glissandi so they do not collide with
accidentals.
Usually, glissando lines join two adjacent noteheads because they indicate a gradual but
constant change in pitch between those two notes, but they can also cross multiple notes.
Glissando lines can cross system breaks and page breaks. If text is shown for glissando lines that
span across a system break or page break, then that text is shown on every part of the glissando
line.
By default, the start position and end position of each segment matches the original start point
and end point of the whole glissando line.
In Dorico, you cannot edit glissando lines individually in Engrave mode. However, you can
make detailed adjustments to the positions of glissando lines on the Glissando Lines page in
Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for glissando lines on page 484
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Inputting glissando lines with the keyboard
PROCEDURE
1.

In Write mode, select the note from which you want a glissando line to start.
NOTE
You cannot input glissando lines during step input.

2.

3.

Open the ornaments popover in any of the following ways:
●

Press Shift-O.

●

Choose Write > Create Ornament.

Enter the style of glissando line you want into the popover:
●
●

4.

gliss for a straight glissando line.
glisswavy for a wavy glissando line.

Press Return to close the popover.

RESULT
The glissando line specified is input. It starts from the selected note and ends at the next note in
the staff, even if this crosses rests.
NOTE
You cannot input a glissando line on the last note in a staff.

RELATED LINKS
The ornaments popover on page 486

Inputting glissando lines with the mouse
NOTE
If your mouse input preference is set to Load cursor with item, complete these steps in the
reverse order.

PROCEDURE
1.

In Write mode, select the note from which you want a glissando line to start.
NOTE
You cannot input glissando lines during step input.

2.

Click the style of glissando line you want in the Ornaments panel:
●

Glissando (Straight)

●

Glissando (Wavy)

477

Glissando lines
Inputting glissando lines between non-adjacent notes
RESULT
The glissando line specified is input. It starts from the selected note and ends at the next note in
the staff, even if this crosses rests.
NOTE
You cannot input a glissando line on the last note in a staff.

RELATED LINKS
Inputting ornaments with the mouse on page 487

Inputting glissando lines between non-adjacent notes
PREREQUISITE
If using the mouse, your preference must be set to Create item at selection. If your preference
is set to Load cursor with item in Preferences, the glissando line is only input between the note
you click on and the note immediately following it.
PROCEDURE
1.

In Write mode, select the two notes you want to join with a glissando line.
TIP
The two notes can be in different voices.

2.

Input a glissando line in any of the following ways:
●
●

Open the ornaments popover and enter the style of glissando you want, such as
gliss.
Click on the style of glissando you want in the Ornaments panel.

RESULT
The style of glissando specified is input between the selected notes.
NOTE
The glissando does not automatically adjust around any notes or rests between the selected
notes. If glissando text is shown, it may collide with notes or rests, so you may need to make
further adjustments, such as not showing glissando text for this glissando line.

RELATED LINKS
Inputting glissando lines with the keyboard on page 477
Inputting glissando lines with the mouse on page 477
Changing the glissando text of individual glissando lines on page 483
Preferences on page 51

Inputting glissando lines across empty bars
For very long glissandi that extend across multiple bars, you may not want to show pitches at the
start of each bar to indicate that performers should not emphasize pitches during the course of
the glissando, or that performers should play the glissando at their own speed.
PROCEDURE
1.

In Write mode, select the two notes you want to join with a glissando line.
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NOTE
There should only be implicit rests between the two notes.
2.

Input a glissando line in any of the following ways:
●
●

Open the ornaments popover and enter the style of glissando you want, such as
gliss.
Click the style of glissando you want in the Ornaments panel.

3.

Select the note at the start of the glissando line.

4.

Activate the Ends voice property in the Notes and Rests group of the Properties panel to
hide rests between the note and the end of the bar.

5.

Optional: If the note at the end of the glissando line is not at the start of the bar, select it.

6.

Optional: Activate the Starts voice property in the Notes and Rests group of the
Properties panel to hide rests between the start of the bar and the note.

RESULT
A glissando line is input between the selected notes, and implicit rests between them are hidden.
EXAMPLE

A glissando line across multiple bars with no rests shown between the two notes

RELATED LINKS
Inputting glissando lines with the keyboard on page 477
Inputting glissando lines with the mouse on page 477
Showing rest colors on page 560
Turning explicit rests into implicit rests on page 562

Deleting glissando lines
PROCEDURE
1.

In Write mode, select the glissando lines you want to delete.

2.

Delete the glissando lines in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected glissando lines are deleted.

479

Glissando lines
Positions of glissando lines

Positions of glissando lines
Glissando lines are positioned between notes according to your settings on the Glissando Lines
page in Engraving Options. You can adjust the graphical positions and the angles of individual
glissando lines in Engrave mode.
NOTE
You cannot move glissando lines rhythmically. If you want to change the rhythmic positions of
glissando lines, you must delete them from their original positions and input new glissando lines
at the new positions you want.

RELATED LINKS
Inputting glissando lines with the keyboard on page 477
Inputting glissando lines with the mouse on page 477
Deleting glissando lines on page 479
Changing the default angles of glissando lines project-wide on page 481
Changing the angles of glissando lines individually on page 482

Moving glissando lines graphically
You can move individual glissando lines, and segments of glissando lines that cross system and
frame breaks, graphically without changing the rhythmic positions to which they apply.
PROCEDURE
1.

2.

In Engrave mode, select the one of the following that you want to move:
●

Whole glissando lines.

●

Segments of glissando lines that cross system or frame breaks.

Move the glissando lines in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
NOTE
If you want to move glissando lines by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the glissando lines in any direction to the positions you want.

RELATED LINKS
Moving glissando lines graphically using the Properties panel on page 480
Changing the angles of glissando lines individually on page 482

Moving glissando lines graphically using the Properties panel
You can move individual glissando lines, and segments of glissando lines that cross system and
frame breaks, graphically using properties in the Glissando Lines group of the Properties panel
in Engrave mode.
Because you can move each end of glissando lines independently of the other end using the
Properties panel, you can use these properties to adjust the angles and graphical lengths of
individual glissando lines.
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NOTE
Moving glissando lines graphically does not change the rhythmic positions to which they apply.

PROCEDURE
1.

2.

3.

4.

In Engrave mode, select the one of the following that you want to move:
●

Whole glissando lines.

●

Segments of glissando lines that cross system or frame breaks.

Activate the following properties, individually or together, in the Glissando Lines group of
the Properties panel:
●

Start offset

●

End offset

Each property has X and Y value fields. Change the values in the value fields in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move glissando lines in the following ways:
●

Start offset X moves the start of glissando lines horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.

●

Start offset Y moves the start of glissando lines vertically: increasing the value
moves them upwards, decreasing the value moves them downwards.

●

End offset X moves the end of glissando lines horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.

●

End offset Y moves the end of glissando lines vertically: increasing the value moves
them upwards, decreasing the value moves them downwards.

RELATED LINKS
Changing the angles of glissando lines individually on page 482

Changing the default angles of glissando lines project-wide
In Dorico, the endpoints of glissando lines are automatically positioned beside noteheads. When
glissando lines cover a small pitch range, the angle of the line can be quite shallow.
You can change the values for the minimum spans of glissando lines covering a small pitch range
in different contexts project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Glissando Lines in the page list.

3.

Change the values for the positions of glissando lines in the contexts relevant to your
project in the Vertical Position section.
For example, you can increase the minimum span of glissando lines between notes in the
same staff space.

4.

Click Apply, then Close.

RESULT
The default positions and angles of glissando lines are changed.
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NOTE
You can make graphical adjustments to the positions of individual glissando lines in Engrave
mode.

RELATED LINKS
Positions of glissando lines on page 480

Changing the angles of glissando lines individually
You can adjust the angles of individual glissando lines in Engrave mode by moving the handles at
each end of glissando lines.
You can move the handles at the ends of glissando lines in Engrave mode in any direction, which
changes their graphical lengths.
PROCEDURE
1.

In Engrave mode, select the square handles at one end of the glissando lines whose angles
you want to change.

2.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Alt-Left Arrow to move them to the left.

●

Alt-Up Arrow to move them upwards.

●

Alt-Down Arrow to move them downwards.
NOTE
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●
3.

Click and drag the handles in any direction to the positions you want.

Optional: Repeat steps 1 and 2 for the handles at the other end of the glissando lines.

RESULT
The angles of the selected glissando lines are changed.
NOTE
You can also use the Start offset and End offset properties in the Glissando Lines group of the
Properties panel in Engrave mode to adjust the angles and graphical lengths of glissando lines.

RELATED LINKS
Moving glissando lines graphically using the Properties panel on page 480

Individual changes to the appearance of glissando lines
You can make changes to the appearance of individual glissando lines, independently of your
project-wide settings in Engraving Options.
RELATED LINKS
Project-wide Engraving Options for glissando lines on page 484
Positions of glissando lines on page 480
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Changing the style of glissando lines individually
Glissandi can be shown as straight lines or wavy lines. You can change the glissando line style of
glissando lines individually.
PROCEDURE
1.

Select the glissando lines whose style you want to change. You can do this in Write mode
and Engrave mode.

2.

Activate the Glissando style property in the Glissando Lines group of the Properties
panel.

3.

Choose the style you want from the following options:
●

Straight line

●

Wavy line

RESULT
The glissando line style is changed for the selected glissando lines. You can deactivate the
Glissando style property at any time to return the glissando line style to your project-wide
settings.
NOTE
You can choose which style you want to use for all glissando lines project-wide on the Glissando
Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for glissando lines on page 484

Changing the glissando text of individual glissando lines
Glissandi can be shown with text or without text. You can change the glissando line text of
glissando lines individually.
PROCEDURE
1.

Select the glissando lines whose text you want to change. You can do this in Write mode
and Engrave mode.

2.

Activate the Glissando text property in the Glissando Lines group of the Properties panel.

3.

Select one of the following options from the menu:
●

Gliss

●

Port

●

No text
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RESULT
The text shown on the selected glissando lines is changed according to your selection.
NOTE
You can choose the text you want shown on all glissando lines project-wide on the Glissando
Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for glissando lines on page 484

Changing when glissando text is shown individually
Glissando text is not shown automatically when glissando lines are too short to accommodate
the text. You can choose to show text on individual glissando lines always, or only if there is
sufficient space.
PROCEDURE
1.

Select the glissando lines whose setting for when text is shown you want to change. You
can do this in Write mode and Engrave mode.

2.

Activate the Glissando text shown property in the Glissando Lines group of the
Properties panel.

3.

Choose one of the following options:
●

Show if sufficient space

●

Always show

RESULT
If Show if sufficient space is chosen, glissando line text is not shown if the glissando line is too
short.
If Always show is chosen, glissando line text is always shown, even if the glissando line is short.

Project-wide Engraving Options for glissando lines
Options for the appearance and positions of glissando lines project-wide can be found on the
Glissando Lines page in Engraving Options.
The options on this page allow you to change the style, appearance, and thickness of glissando
lines. You can also set precise positions for the endpoints of glissando lines relative to noteheads.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Glissando Lines in the page list on the left of the dialog.
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Ornaments are markings that indicate multiple notes should be played in addition to the notated
pitch. They are used to decorate music, particularly Baroque and Classical styles.
The style of Baroque music in particular is highly decorated with trills and other ornaments.
Over time, specific ways of notating how notes should be decorated by a performer have
developed and different ornament symbols indicate different patterns of decorative notes.
Nonetheless, ornaments give some freedom to performers to embellish music in their own way.
Dorico offers a range of ornament symbols to allow you to notate different styles of ornaments.
The term “ornaments” covers a wide range of decorative notes, including:
●

Mordents

●

Trills

●

Turns

●

Grace notes

●

Acciaccaturas

●

Appoggiaturas

In Dorico, the term “ornaments” refers to ornament symbols and trill glyphs that are input above
notes, some of which are shown in this example.

Some of the ornaments available in Dorico

RELATED LINKS
Grace notes on page 379

General placement conventions for ornaments
Ornaments, including trills, are placed above the notes to which they apply. They are only placed
below the staff when there are multiple voices in the staff.
Ornaments and trills are positioned outside of slurs by default. Similarly, they are positioned
further from noteheads than all articulations.
The center of ornaments should be aligned with the center of the notehead to which they apply.
Trills are aligned differently: the left of the start of trill glyphs should align with the left edge of
the notehead to which the trill applies.
Dorico automatically positions ornaments correctly according to their type, and attaches them to
their notehead.
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You can change the default positions and styles of ornaments and trills on the Ornaments page
in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for ornaments on page 496
Changing the position of ornaments relative to slurs on page 494

Inputting ornaments with the keyboard
You can input ornaments with the keyboard using the ornaments popover. You can input
ornaments during step input and later on by adding ornaments to existing notes.

The ornaments popover
Enter the following commands into the ornaments popover to create the different ornaments,
glissando lines, and arpeggio signs available.
You can open the ornaments popover in Write mode in the following ways:
●

Press Shift-O.

●

Choose Write > Create Ornament.

Enter:

For ornament, glissando line, or arpeggio
sign:

tr or trill

Trill ()

shorttr

Short trill ()

turn

Turn ()

mor or mordent

Mordent ()

invturn or invertedturn

Inverted turn ()

gliss

Straight glissando line

glisswavy

Wavy glissando line

arp or arpup or arpeggioup

Up arpeggio sign

arpdown or arpeggiodown

Down arpeggio sign

nonarp or nonarpeggio

Non arpeggio sign

Other ornaments are available in the Ornaments panel.
RELATED LINKS
Inputting ornaments with the mouse on page 487
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Inputting ornaments during step input with the keyboard
PROCEDURE
1.

In Write mode, start note input.

2.

Open the ornaments popover in any of the following ways:
●

Press Shift-O

●

Choose Write > Create Ornament

3.

Enter the ornament you want into the popover, such as trill for a trill or mor for a
mordent.

4.

Press Return to close the popover.

RESULT
The ornament specified is input at the caret position. Trills last the duration of the rhythmic value
of the note input at the caret position.
RELATED LINKS
Inputting notes on page 94

Adding ornaments to existing notes with the keyboard
PROCEDURE
1.

In Write mode, select one of the following:
●

The note to which you want to add an ornament

●

The note or notes across which you want to add a trill
NOTE
You can only add one ornament to one note at a time.

2.

Open the ornaments popover in any of the following ways:
●

Press Shift-O

●

Choose Write > Create Ornament

3.

Enter the ornament you want into the popover, such as trill for a trill or mor for a
mordent.

4.

Press Return to close the popover.

RESULT
The ornament specified is input above the selected note. Trills are input above the first selected
note, with an extender line across any subsequent notes also selected.

Inputting ornaments with the mouse
You can input ornaments with the mouse by clicking on the ornaments you want in the
Ornaments panel during step input and later on by adding ornaments to existing notes.
You can open the Ornaments panel by clicking Ornaments in the Notations toolbox on the right
of the window in Write mode:
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The different sections in the Ornaments panel are:
●

Baroque and Classical

●

Arpeggiation

●

Glissandi

Inputting ornaments during step input with the mouse
PROCEDURE
1.

In Write mode, start note input.

2.

Click the ornament you want in the Baroque and Classical section of the Ornaments
panel on the right of the window.

RESULT
The ornament is input at the caret position.
RELATED LINKS
Inputting notes on page 94

Adding ornaments to existing notes with the mouse
PROCEDURE
1.

In Write mode, select the note to which you want to add an ornament.
NOTE
You can only add one ornament to one note at a time.

2.

Click on the ornament you want in the Baroque and Classical section of the Ornaments
panel on the right of the window.

RESULT
The ornament is input above the selected note.
NOTE
If your preference is set to Load cursor with item, complete these steps in the reverse order.

Changing the intervals of ornaments
You can change the intervals of ornaments, both above and below the notated pitch, to indicate
which pitches should be played in the ornament. For some ornaments you can only change the
interval in one direction, for example, you can only change the interval above short trills and
below mordents.
PROCEDURE
1.

Select the ornaments whose intervals you want to change. You can do this in Write mode
and Engrave mode.

2.

Activate the appropriate property or properties for the selected ornaments in the
Ornaments group of the Properties panel:
●

Interval above
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●

Interval below

For trills, activate the Interval property in the Trills group of the Properties panel.
3.

4.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

The properties change the accidental shown above or below ornaments in the following
ways:
●

0 or 4 and above: no accidental

●

1: flat

●

2: natural

●

3: sharp

RESULT
The interval of the selected ornaments is changed.
NOTE
Some ornaments do not show accidentals either above or below, depending on their type.
You can change the position of ornament accidentals relative to trills individually, or for all trills
project-wide on the Ornaments page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for ornaments on page 496

Changing the position of ornament accidentals relative to trills
individually
To change where ornament accidentals, which indicate the interval of trills, are positioned
relative to trills:
PROCEDURE
1.

Select the trills whose ornament accidental position you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the Accidental position property in the Trills group of the Properties panel.

3.

Select one of the following options from the menu:
●

Above
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●

Below

●

On the right

RESULT
The position of ornament accidentals relative to the selected trills is changed.
NOTE
You can change the position of ornament accidentals relative to all trills project-wide on the
Ornaments page in Engrave > Engraving Options.

Lengthening and shortening trills rhythmically
You can lengthen and shorten trills after they have been input in Write mode with the keyboard
and with the mouse. Multiple ornaments can exist at the same rhythmic position, so you can
lengthen and shorten trills to noteheads that already have ornaments.
PROCEDURE
1.

In Write mode, select the trills you want to lengthen or shorten.

2.

Lengthen and shorten the trills in any of the following ways:
●

Shift-Alt-Right Arrow to lengthen trills by the current rhythmic grid value

●

Shift-Alt-Left Arrow to shorten trills by the current rhythmic grid value

●

Ctrl/Cmd-Shift-Alt-Right Arrow to snap the end of a trill to the next rhythmic
position

●

Ctrl/Cmd-Shift-Alt-Left Arrow to snap the end of a trill to the previous rhythmic
position
NOTE
You can only lengthen or shorten trills by the current rhythmic grid value when
multiple octave lines are selected.

●

Click and drag the circular handle at the end of the trill to noteheads to the right or
to the left.
NOTE
You can only lengthen or shorten one trill at a time with the mouse.

RESULT
The selected trills are lengthened or shortened to noteheads to the right or to the left.
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NOTE
You can make graphical changes to the lengths of trill extension lines in Engrave mode.

RELATED LINKS
Moving ornaments rhythmically on page 492
Moving trills graphically using the Properties panel on page 493

Hiding the extension lines of individual trills
PROCEDURE
1.

Select the trills whose extension lines you want to hide. You can do this in Write mode and
Engrave mode.

2.

Activate the Has trill line property in the Trills group of the Properties panel.

RESULT
When the box beside the property is unchecked, trill extension lines are not shown for the
selected trills.
When the box beside the property is checked, trill extension lines are shown for the selected
trills.
Deactivating the property returns the selected trills to your project-wide settings.
NOTE
You can choose whether trill extension lines are shown or not shown for all trills project-wide on
the Ornaments page in Engrave > Engraving Options.

Deleting ornaments
PROCEDURE
1.

In Write mode, select the ornaments you want to delete.

2.

Delete the ornaments in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected ornaments are deleted.

Positions of ornaments
You can change the positions of ornaments by moving individual ornaments to different
rhythmic positions in Write mode, moving them to different graphical positions in Engrave mode,
and by changing the default positions of all ornaments project-wide.
You can move ornaments to different rhythmic positions in Write mode. They are positioned by
default according to your preferences in Engraving Options.
You can move ornaments graphically in Engrave mode, however this does not change the
rhythmic positions to which they are attached.
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Project-wide settings for the default positions of ornaments can be set on the Ornaments page
in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for ornaments on page 496

Moving ornaments rhythmically
You can move ornaments to new rhythmic positions.
PROCEDURE
1.

In Write mode, select the ornaments you want to move.

2.

Move the ornaments in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the ornament to the right or to the left to snap it to different rhythmic
positions.
NOTE
Only one ornament can be moved at a time when using the mouse.

RESULT
A single ornament is moved to the next or previous notehead on that staff.
Multiple ornaments are moved according to the rhythmic grid currently set.
RELATED LINKS
Moving ornaments graphically on page 492

Moving ornaments graphically
You move ornaments graphically without changing the rhythmic positions to which they apply.
PROCEDURE
1.

In Engrave mode, select the ornaments you want to move.

2.

Move the ornaments in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
NOTE
If you want to move ornaments by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the ornaments in any direction to the positions you want.

RELATED LINKS
Moving ornaments graphically using the Properties panel on page 493
Moving trills graphically using the Properties panel on page 493
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Moving ornaments graphically using the Properties panel
You can move ornaments graphically using the Properties panel in Engrave mode.
NOTE
See Moving trills graphically using the Properties panel to move trills, as they are moved in a
different way to other ornaments due to the extender lines.

PROCEDURE
1.

In Engrave mode, select the ornaments you want to move.

2.

Activate the Offset property in the Common group of the Properties panel.

3.

Each property has X and Y value fields. Change the values in the value fields in any of the
following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move ornaments in the following ways:
●

Offset X moves ornaments horizontally: increasing the value moves them to the
right, decreasing the value moves them to the left.

●

Offset Y moves ornaments vertically: increasing the value moves them upwards,
decreasing the value moves them downwards.

RELATED LINKS
Moving trills graphically using the Properties panel on page 493

Moving trills graphically using the Properties panel
You can move trills graphically using the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the trills you want to move.

2.

Activate the following properties, individually or together, in the Trills group of the
Properties panel:

3.

4.

●

Start offset

●

End offset X

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move trills in the following ways:
●

Start offset X moves whole trills horizontally: increasing the value moves them to
the right, decreasing the value moves them to the left.

●

Start offset Y moves whole trills vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.

●

End offset X moves the ends of trill extension lines horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.
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Individual changes to the appearance and position of
ornaments
You can make changes to the appearance and position of individual ornaments, independently of
your project-wide settings in Engraving Options.
RELATED LINKS
Project-wide Engraving Options for ornaments on page 496

Changing the placement of ornaments relative to the staff
Ornaments are usually placed above the staff, but they are placed below the staff for down-stem
voices when there are multiple voices in the staff. You can change the placement of ornaments
individually.
PROCEDURE
1.

Select the ornaments whose placement relative to the staff you want to change. You can
do this in Write mode and Engrave mode.

2.

Activate the Placement property in the corresponding group of the Properties panel for
the selected ornaments:

3.

●

Ornaments

●

Trills

Choose one of the following options:
●

Above

●

Below

RESULT
The placement of the selected ornaments is changed according to your selection.

Changing the position of ornaments relative to slurs
Ornaments are positioned outside of slurs by default. You can change the position of ornaments
relative to slurs individually.
PROCEDURE
1.

In Engrave mode, select the ornaments whose slur-relative position you want to change.

2.

Activate the Slur-relative position property in the corresponding group of the Properties
panel for the selected ornaments:

3.

●

Ornaments

●

Trills

Choose one of the following options:
●

Inside

●

Outside

RESULT
The selected ornaments are positioned either inside or outside of slurs, according to your
selection.
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Changing the start position of trills individually
You can change whether the start positions of individual trills are aligned with the notehead or
with its accidental.
PROCEDURE
1.

Select the trills whose start position you want to change. You can do this in Write mode
and Engrave mode.

2.

Activate the Start position property in the Trills group of the Properties panel.

3.

Choose one of the following options:
●

Notehead

●

Accidental

RESULT
The start position of the selected trills is changed, according to your selection.
NOTE
You can change the start position of trills project-wide on the Ornaments page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide Engraving Options for ornaments on page 496

Changing the speed of trills
You can indicate different speeds of trills, and indicate a different speed at the end compared to
the start, by changing the height and frequency of the waves in their extension lines.
PROCEDURE
1.

Select the trills whose speed you want to change. You can do this in Write mode and
Engrave mode.

2.

Activate either or both of the following properties in the Trills group of the Properties
panel:
●

Start speed

●

End speed
NOTE
You can activate just Start speed to have the same speed throughout the extension
lines of the selected trills.

3.

Select one of the following options for each property:
●

Slow

●

Normal

●

Fast

RESULT
The speed of the selected trills is changed, according to your selections.
If only Start speed is activated, the speed of the whole trill extension line is changed.
If only End speed is activated, the speed of the end half of the trill extension line is changed.
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EXAMPLE

A trill extension line starting slow and ending fast

Project-wide Engraving Options for ornaments
Options for the appearance and positions of ornaments project-wide can be found on the
Ornaments page in Engraving Options.
The options on this page allow you to change the position of trills relative to accidentals,
noteheads, and trill extension lines. You can also set the minimum distance between ornaments
and the staff and noteheads.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Ornaments in the page list on the left of the dialog.
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Page numbers are used to give each page a unique number, and indicate its position relative to
other pages. Just as in newspapers and books, musical scores and parts use page numbers to
make sure the music stays in the correct order.
Page number changes may be necessary if projects contain multiple movements, where
each movement must be saved as a separate file. To make sure the page numbers continue
seamlessly from movement to movement, you would normally need to change the page number
at the start of each file.
However, because you can have multiple flows in each project in Dorico, you should not need to
change page numbers in most cases.
Page numbers in Dorico use token text to ensure the number is correct.
NOTE
You must have a text frame containing the page number token on every page on which you want
page numbers to be shown.
The default master pages contain text frames with page number tokens.
You can change the position of page number text frames in the master page editor, which
changes the position of page numbers on all pages that use that master page. You can also
move page number text frames on individual pages by overriding the master page.
You can change the default page numbers. For example, if you want to have four pages of front
matter before the first page of music in the score, but you want the first page of music in the
score to be shown as page 1, you can change the page number of the first page of music.
Page numbers are layout-specific in Dorico, meaning you can change the page numbers in each
layout independently of the others. For example, you can change the page numbers in the score
but show the default page numbers in the parts.
You can also change the type of number used to show page numbers in each layout. For
example, if you want the front matter to use Roman numerals but the music pages to use
numbers, you can change the type of number at the same time as you change the page number.
RELATED LINKS
Page number changes on page 141
Inserting page number changes on page 141
Master page overrides on page 138
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Page number changes
You can insert page number changes to pages in each layout independently of other layouts. You
can also remove any page number changes you have inserted from individual pages or all pages
in each layout.
RELATED LINKS
Master page overrides on page 138
Page number changes on page 141
Inserting page number changes on page 141
Removing individual page number changes on page 142
Removing all page number changes on page 143

Moving page numbers in master pages
To change where page numbers are shown, you must move the text frames that contain page
numbers. The most efficient way to do this is to move the text frames containing page numbers
in master page formats.
PROCEDURE
1.

In Engrave mode, double-click a master page pair whose page number position you want
to change in the Master Pages section of the Pages panel.

2.

In the master page editor, select the text frames that contain page numbers.

3.

Move the text frames in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move text frames by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●
4.

Click and drag them in any direction to the position you want.

Click Close Master Page Editor to save your changes.

Moving page numbers in master pages using the Properties
panel
To change where page numbers are shown, you must move the text frames that contain page
numbers. The most efficient way to do this is to move the text frames containing page numbers
in master page formats.
PROCEDURE
1.

In Engrave mode, double-click a master page pair whose page number position you want
to change in the Master Pages section of the Pages panel.

2.

In the master page editor, select the text frames that contain page numbers.

3.

Change the values for the Left and Top properties in the Frames group of the Properties
panel in any of the following ways:
●

Enter values into the value fields.
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●
4.

5.

Click the arrows beside the value fields.

The properties move the text frames in the following ways:
●

Left moves rehearsal marks horizontally: increasing the value moves them to the
right, decreasing the value moves them to the left.

●

Top moves rehearsal marks vertically: increasing the value moves them upwards,
decreasing the value moves them downwards.

Click Close Master Page Editor to save your changes.

Page number font style
You can change different aspects of the page number font style to change the appearance of
page numbers project-wide.
You can open the Font Styles dialog by choosing Engrave > Font Styles in Engrave mode.
In the Font Styles dialog, select Page Number Font from the menu to change different aspects
of the font.
Changes to the font style apply to the entire project, including parts.
Font family
Sets the overall font style.
Size
Sets the size of page numbers. The page number size can be:
●

Absolute: always the set size, regardless of the staff size

●

Staff-relative: proportional to the staff size. Page numbers appear smaller
than the set value on smaller staves, and larger than the set value on larger
staves.

NOTE
You can set different page number sizes for full score layouts and part layouts in the
Engrave > Paragraph Styles dialog. However, you must make sure the text frames
that contain page numbers are the correct size to display them.
Style
Sets the page number font appearance. The page number font can be:
●

Regular

●

Italic

●

Bold (default)

●

Bold Italic

Underlined
The page number font appears underlined if the box beside the Underlined
activation switch is checked.
RELATED LINKS
Changing the size of page numbers on page 503
Paragraph styles on page 152

499

Page numbers
Changes to the default horizontal alignment of page numbers

Changing the page number font style
You can change the font style used for page numbers project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Font Styles dialog.

2.

Select Page Number Font from the Font style menu.

3.

Activate the switches beside the following options to change the corresponding aspects of
the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The page number font style is changed project-wide.

Changes to the default horizontal alignment of page
numbers
You can change the default alignment of page numbers project-wide.
You can set the default alignment of page numbers in the Paragraph Styles dialog.
This changes the alignment of that page numbers wherever they are used in the project, but the
alignment can also be manually overridden in individual text frames.
RELATED LINKS
Changing the default horizontal alignment of different text styles project-wide on page 377

Individual changes to the horizontal alignment of page
numbers
You can change the horizontal alignment of individual page numbers, independently of the page
numbers paragraph style.
Because page numbers exist inside text frames, you can change their horizontal alignment in the
same way as for any other text in text frames.
RELATED LINKS
Changing the horizontal alignment of text in text frames on page 149
Paragraph styles on page 152

Changing the page number numeral style project-wide
You can make project-wide changes to the numeral style of page numbers.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.
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●

Choose Setup > Layout Options in Setup mode.

2.

Select Page Setup from the Category menu.

3.

Select the layouts whose page number numeral style you want to change in the Layouts
list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

5.

Select one of the following options from the Use menu in the Initial Page Number
section:
●

Number

●

Roman numeral

Click Apply, then Close.

RESULT
The page number numeral style is changed project-wide in the selected layouts.
You can change settings for other layouts before closing the dialog.

Changing the page number numeral style for individual pages
PROCEDURE
1.

Open the layout whose page number numeral style you want to change in the music area.

2.

Select a page in the Pages section of the Pages panel.

3.

Open the Page Number Change dialog in any of the following ways:
●

Right-click and choose Insert Page Number Change from the context menu

●

Click Insert Page Number Change:

4.

Enter the number of the page from which you want to change the page number numeral
style in the From page field in the Page Number Change dialog. For example, if you want
to change the page number numeral style from page 1, enter 1.

5.

Select the numeral style you want from the following options for Sequence type:

6.

●

Number

●

Roman numeral

Click OK.

RESULT
The page number numeral style is changed until the next page number change or the end of the
project, whichever comes first.
RELATED LINKS
Inserting page number changes on page 141
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Showing page numbers project-wide
You can change when page numbers are shown for each layout independently of other layouts.
For example, you can show page numbers on every page in the score but hide page numbers on
the first page in the parts.
NOTE
To show page numbers, there must be a text frame containing the page number token. The
default master page formats for first pages do not contain text frames containing page number
tokens, so you must add these if you want to show page numbers on first pages in your project
that use the default master page formats.

PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Page Setup from the Category menu.

3.

Select the layouts in which you want to change when page numbers are shown in the
Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

5.

Select one of the following options from the Visibility menu in the Initial Page Number
section:
●

Always shown

●

Always hidden

●

Not on first page

Click Apply, then Close.

RESULT
When page numbers are shown is changed project-wide in the selected layouts.
You can change settings for other layouts before closing the dialog.

Showing page numbers on individual pages
You can change when page numbers are shown on individual pages, independently of your
project-wide setting for showing page numbers for each layout.
NOTE
To show page numbers, there must be a text frame containing the page number token. The
default master page formats for first pages do not contain text frames containing page number
tokens, so you must add these if you want to show page numbers on first pages in your project
that use the default master page formats.
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PROCEDURE
1.

Open the layout in which you want to change when page numbers are shown in the music
area.

2.

Select a page in the Pages section of the Pages panel.

3.

Open the Page Number Change dialog in any of the following ways:
●

Right-click and choose Insert Page Number Change from the context menu

●

Click Insert Page Number Change:

4.

Enter the number of the page from which you want to change when page numbers are
shown in the From page field in the Page Number Change dialog. For example, if you
want to hide page numbers from page 4, enter 4.

5.

Select when page numbers are shown from the following options for Visibility:

6.

●

Always shown

●

Always hidden

●

Not on first page

Click OK.

RESULT
When page numbers are shown is changed until the next page number change with a different
visibility or the end of the project, whichever comes first.
RELATED LINKS
Inserting page number changes on page 141

Changing the size of page numbers
You can set different sizes for page numbers in full score layouts and part layouts. The size of
page numbers can be absolute or staff-relative.
PROCEDURE
1.

In Engrave mode, choose Engrave > Paragraph Styles to open the Paragraph Styles
dialog.

2.

Select Page Number from the list on the left.

3.

Activate the following options as required:

4.

5.

6.

●

Size

●

Size in parts

Change the page number size by changing the values for each option in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

Choose one of the following options for each page number size:
●

Staff-relative

●

Absolute

Click OK to save your changes and close the dialog.
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RESULT
The sizes of page numbers in full score layouts and part layouts in your project are changed.
Staff-relative page numbers appear larger in layouts with larger staff sizes, and smaller in layouts
with smaller staff sizes.
Absolute page numbers always appear with the set size, regardless of staff size.
RELATED LINKS
Page number font style on page 499
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Pedal lines indicate to a performer which piano pedals they should use, and can also give
performance instructions, such as how far they should be depressed.
Dorico has the most comprehensive support for piano pedal lines of any scoring software.
You can easily create pedaling for the sustain, una corda and sostenuto pedals, with support for
modern sustain pedaling techniques, including changing the pedal level over the course of a
single pedal instruction.

General placement conventions for pedal lines
Pedal lines should be placed below the bottom staff, even if there are only notes in the upper,
right hand staff. They should be positioned outside of all other notations, including octave lines,
slurs, and articulation.
When one pedal is used, it should be placed as close to the bottom of the staff as possible, while
remaining outside of all other notations.
When multiple pedals are used simultaneously, they should be organized below the bottom of
the staff as follows:
1

Sustain pedal, or damper pedal: closest to the staff

2

Sostenuto pedal, or middle pedal: below the sustain pedal line

3

Una corda pedal, or soft pedal: furthest from the staff

The beginning of the glyph or text that indicates the start position of pedal lines should be
aligned with the note to which they apply.
If using a hook to indicate the end of a pedal line, the hook should be aligned with the note or
rhythmic position to which it applies.
You can choose options for how pedal lines should appear project wide on the Pedal Lines page
in Engrave > Engraving Rules.
RELATED LINKS
Project-wide Engraving Options for pedal lines on page 514

Inputting pedal lines with the keyboard
You can input pedal lines using the same popover as for playing techniques, as both affect the
sound produced by the instrument.
You can open the playing techniques popover by pressing Shift-P (P for “pedal” or “playing
technique”), or by choosing Write > Playing Technique.
You can do this based either on the range of selected notes, or during step input.
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.
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The playing techniques popover with an example
entry for a pedal line

The playing techniques button in the Notations
toolbox, which includes pedal lines

The playing techniques popover for pedal lines
Enter the following commands and symbols into the playing techniques popover for the different
pedal lines available.
You can open the playing techniques popover in Write mode in the following ways:
●

Press Shift-P.

●

Choose Write > Playing Technique.

Enter:

For pedal line:

ped

Sustain pedal line

1/4

Set sustain pedal level to 1/4

1/2

Set sustain pedal level to 1/2

3/4

Set sustain pedal level to 3/4

1

Fully depress sustain pedal

^ or notch or retake

Retake in sustain pedal line

nonotch

Remove retake in sustain pedal line

*

Stop sustain pedal line

sost

Sostenuto pedal line

s*

Stop sostenuto pedal line

unacorda

Una corda pedal line

u*

Stop una corda pedal line

Inputting pedal lines during step input with the keyboard
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where the line should begin.

3.

Open the playing techniques popover in any of the following ways:
●

Press Shift-P

●

Choose Write > Create Playing Technique
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4.

Enter the appropriate short-hand for the pedal line you want into the popover, such as ped
for a sustain pedal line.

5.

Press Return to close the popover.

6.

Press Space to advance the caret and extend the pedal line. The pedal line also extends
automatically as you continue inputting notes.

7.

To stop the pedal line, open the playing techniques popover again (key command Shift-P),
and enter the appropriate short-hand to end your pedal line into the popover, such as * to
stop a sustain pedal line. The pedal line ends at the caret position.

8.

Press Return to close the popover.

RESULT
The pedal line starts at the caret position, and ends at the caret position.
RELATED LINKS
Inputting notes on page 94
The playing techniques popover for pedal lines on page 506

Inputting retakes and pedal level changes during step input with
the keyboard
Retakes and pedal level changes can be created during step input.
TIP
Retakes and pedal level changes can also be assigned to a rhythmic position before pedal lines or
notes are input. They are shown when the pedal line passes their rhythmic position.

PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where the retake or pedal level change should
appear.

3.

Open the playing techniques popover in any of the following ways:
●

Press Shift-P

●

Choose Write > Create Playing Technique

4.

Enter the appropriate short-hand for the retake or pedal level change you want into the
popover, such as ^ or retake for a retake.

5.

Press Return to close the popover.

RESULT
The retake or pedal level change is input at the caret position.
EXAMPLE

From left to right by notehead: Ped. text, retake, one quarter depressed, half depressed, three quarters
depressed, fully depressed, line end hook.
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RELATED LINKS
The playing techniques popover for pedal lines on page 506

Adding pedal lines to existing notes with the keyboard
To create a pedal line of a particular duration for a selected passage of existing music:
PROCEDURE
1.

In Write mode, select the notes to which the pedal line should apply.

2.

Open the playing techniques popover in any of the following ways:
●

Press Shift-P

●

Choose Write > Create Playing Technique

3.

Enter the appropriate short-hand for the pedal line you want into the popover, such as
sost for a sostenuto pedal line.

4.

Press Return to close the popover.

RELATED LINKS
The playing techniques popover for pedal lines on page 506

Adding retakes and pedal level changes to existing notes with the
keyboard
To create a pedal line of a particular duration for a selected passage of music:
PROCEDURE
1.

In Write mode, select an item at the rhythmic position to which a retake or pedal level
change should apply.

2.

Open the playing techniques popover in any of the following ways:
●

Press Shift-P

●

Choose Write > Create Playing Technique

3.

Enter the appropriate short-hand for the retake or pedal level change you want into the
popover, such as ^ or retake for a retake.

4.

Press Return to close the popover.

RELATED LINKS
The playing techniques popover for pedal lines on page 506

Inputting pedal lines with the mouse
Pedal lines can be input with the mouse by clicking options in the Keyboard section of the
Playing Techniques panel in Write mode.
The Playing Techniques panel is opened by clicking this button in the Notations toolbox:

Opening the Keyboard section shows these options:
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The buttons on the first row create new pedal lines. They buttons are, left to right: sustain pedal,
sostenuto pedal, and una corda pedal.
The buttons on the second row add retakes and changes of pedal level to an existing pedal line.
The buttons are, left to right: a retake, one-quarter depressed, half-depressed, three-quarters
depressed, and fully depressed.
Pedal lines can be input with the mouse to existing notes or existing staves, but not during step
input.
There are two ways to add pedal lines to existing notes or existing staves with the mouse:
●

Select the notes to which the pedal line should apply, then click the button of the pedal line
you want to input in the Keyboard section of the Playing Techniques panel

●

With nothing selected, click the pedal line you want to input in the Keyboard section of
the Playing Techniques panel, then click and drag in the score to create a pedal line and
extend it to the required duration.

Inputting retakes or pedal level changes with the mouse
A pedal retake indicates where a player should lift the pedal, to dampen the piano’s strings and
clear the resonance before depressing the pedal again. A pedal level change indicates a change
to how far the pedal should be depressed.
To input a retake or pedal level change:
1

Create a pedal line.

2

Select an item in the staff to which the pedal line applies, at the rhythmic position where
the retake or pedal level change should take effect.

3

Click the relevant retake or pedal level change button in the Keyboard section of the
Playing Techniques panel.

Or, if nothing is selected in the score, you can:
1

Select the relevant retake or pedal level change button in the Keyboard section of the
Playing Techniques panel.

2

Click on the pedal line at the rhythmic position where the retake or pedal level change
should take effect.

Alternatively, you can right-click on an item at the rhythmic position where the retake or pedal
level change should take effect, and choose from the following options:
1

Pedal Lines > Add Retake

2

Pedal Lines > Add Change to One Quarter Depressed

3

Pedal Lines > Add Change to Half Depressed

4

Pedal Lines > Add Change to Three Quarters Depressed

5

Pedal Lines > Add Change to Fully Depressed
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EXAMPLE

From left to right by notehead: Ped. text, retake, one quarter depressed, half depressed, three quarters
depressed, fully depressed, line end hook.

RELATED LINKS
Inputting pedal lines with the mouse on page 508

Positions of pedal lines
You can change the positions of pedal lines by moving individual pedal lines to different rhythmic
positions in Write mode, moving them to different graphical positions in Engrave mode, and by
changing the default positions of all pedal lines project-wide.
You can move pedal lines to different rhythmic positions in Write mode. They are positioned by
default according to your preferences in Engraving Options.
You can move pedal lines graphically in Engrave mode, however this does not change the
rhythmic positions to which they are attached.
NOTE
You cannot move retakes or pedal level changes rhythmically. You must remove them and input
a new retake or pedal level change at the position you want.
Project-wide settings for the default position of pedal lines, and values for the minimum
distances between pedal lines and staves, pedal lines and other pedal lines, and the positioning
of pedal lines relative to noteheads, can be set on the Pedal lines page in Engrave > Engraving
Options.
RELATED LINKS
Project-wide Engraving Options for pedal lines on page 514

Moving pedal lines rhythmically
You move pedal lines to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the pedal lines you want to move.

2.

Move the pedal lines to noteheads to the right and to the left in the following ways:
●

Press Alt-Right Arrow to move them to the notehead to the right.

●

Press Alt-Left Arrow to move them to the notehead to the left.

●

Click and drag the pedal line to the position you want.
NOTE
Only one pedal line can be moved rhythmically at a time when using the mouse.
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RESULT
A single pedal line is moved to the next or previous notehead on that staff.
Multiple pedal lines are moved according to the rhythmic grid currently set.
NOTE
Pedal lines can only be moved along a staff. If you want to move a pedal line across staves, you
must first delete the pedal line from its first position, then add a new pedal line to the staff you
wanted to move it to.

RELATED LINKS
Lengthening and shortening pedal lines on page 513
Types and levels of retakes and pedal level changes on page 520

Moving pedal lines graphically
You can move pedal lines graphically without changing the rhythmic positions to which they
apply. You can also move each end of pedal lines independently of the other end by moving their
handles.
PROCEDURE
1.

2.

In Engrave mode, select one of the following:
●

The pedal lines you want to move.

●

The start or end handles of the pedal lines whose ends you want to move.

Move the pedal lines or handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the right.

●

Press Alt-Up Arrow to move whole pedal lines upwards.

●

Press Alt-Down Arrow to move whole pedal lines downwards.
TIP
If you want to move pedal lines or handles by larger increments, you can press Ctrl/
Cmd as well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the pedal lines or handles in any direction to the positions you want.

RESULT
The selected pedal lines are moved to new graphical positions.
NOTE
You can move multiple pedal lines together but only upwards or downwards.
You can move handles on multiple pedal lines together but only left or right.

RELATED LINKS
Lengthening and shortening pedal lines on page 513
Types and levels of retakes and pedal level changes on page 520
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Moving pedal lines graphically using the Properties panel
You can move pedal lines graphically using the Properties panel in Engrave mode. You can also
use these properties to lengthen and shorten pedal lines graphically, as the properties can be
changed independently of each other.
PROCEDURE
1.

In Engrave mode, select the pedal lines you want to move.

2.

Activate the following properties, individually or together, in the Pedal Lines group of the
Properties panel:

3.

4.

●

Start X offset

●

End X offset

●

Y offset

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move pedal lines in the following ways:
●

Start X offset moves the start of pedal lines horizontally: increasing the value
moves the start of pedal lines to the right, decreasing the value moves the start of
pedal lines to the left.

●

End X offset moves the end hooks of pedal lines horizontally: increasing the value
moves the end hooks of pedal lines to the right, decreasing the value moves the end
hooks of pedal lines to the left.

●

Y offset moves pedal lines vertically: increasing the value moves them upwards,
decreasing the value moves them downwards.

RELATED LINKS
Types and levels of retakes and pedal level changes on page 520

Moving retakes and pedal level changes graphically using the
Properties panel
You can move retakes and pedal level changes graphically using the Properties panel in Engrave
mode.
PROCEDURE
1.

In Engrave mode, select the retakes or pedal level changes you want to move.

2.

Activate the X offset property in the Pedal Line Retakes group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The X offset property moves retakes and pedal level changes in the following ways:
●

Increasing the X offset value moves retakes and pedal level changes to the right.

●

Decreasing the X offset value moves retakes and pedal level changes to the left.

RELATED LINKS
Types and levels of retakes and pedal level changes on page 520
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Lengthening and shortening pedal lines
You can lengthen or shorten pedal lines after they have been input so they apply to more or
fewer notes.
PROCEDURE
1.

In Write mode, select the pedal lines you want to lengthen or shorten.

2.

Lengthen or shorten the pedal lines in any of the following ways:
●

Press Ctrl/Cmd-Shift-Alt-Right Arrow to move the end of a single pedal line to the
next notehead.

●

Press Ctrl/Cmd-Shift-Alt-Left Arrow to move the end of a single pedal line to the
previous notehead.

●

Press Shift-Alt-Right Arrow to lengthen them by the current rhythmic grid value.

●

Press Shift-Alt-Left Arrow to shorten them by the current rhythmic grid value.

●

Click and drag the circular handle at the end of the pedal line to position you want.
NOTE
Only one pedal line can be lengthened or shortened at a time when using the
mouse.

RESULT
The selected pedal lines are lengthened or shortened.
NOTE
You can only lengthen or shorten multiple pedal lines according to the rhythmic grid currently
set.

RELATED LINKS
Positions of pedal lines on page 510
Moving pedal lines rhythmically on page 510
Moving pedal lines graphically on page 511
Moving pedal lines graphically using the Properties panel on page 512

Deleting pedal lines
To delete pedal lines:
PROCEDURE
1.

In Write mode, select the pedal lines you want to delete.

2.

Delete the pedal lines in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The pedal line is deleted, or pedal lines are deleted.
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Removing retakes or pedal level changes with the keyboard
To remove a retake or pedal level change for the sustain pedal:
PROCEDURE
1.

Select the note at the rhythmic position of the retake or pedal level change.

2.

Open the playing techniques popover in any of the following ways:

3.

●

Press Shift-P

●

Choose Write > Create Playing Technique

Type nonotch into the popover to remove the retake or pedal level change at that
position, either in step input or at the rhythmic position of the selected note.
NOTE
nonotch must be spelled as one word, without a space.

4.

Press Return to close the popover.

RESULT
The selected retake or pedal level change is removed, and the pedal line returns to its previous
level.
RELATED LINKS
The playing techniques popover for pedal lines on page 506

Removing retakes or pedal level changes with the mouse
To remove a retake or pedal level change:
PROCEDURE
1.

Select the note at the rhythmic position of the retake or pedal level change.

2.

Right-click, and choose Pedal Lines > Remove Retake.

RESULT
The selected retake or pedal level change is removed, and the pedal line returns to its previous
level.

Project-wide Engraving Options for pedal lines
Options for the appearance and position of pedal lines project-wide can be found on the Pedal
Lines page in Engraving Options.
The options on this page allow you to change the symbol shown at the start of each type of pedal
line, the appearance of pedal line symbols on subsequent systems, the appearance of pedal
continuation lines, and the design of retake notches. You can also set precise values for the
positions between pedal lines and the staff or other objects.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.
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You can then click Pedal Lines in the page list on the left of the dialog.

Individual changes to the appearance of pedal lines
You can move and change the appearance of individual pedal lines by using properties in
the Properties panel, independently of your project-wide settings on the Pedal Lines page in
Engraving Options.
To open the Properties panel, either click its disclosure arrow at the bottom of the window, or
press Ctrl/Cmd-8.
In Engrave mode, you can select each segment of a sustain pedal independently, and set
properties independently for each segment.
NOTE
If you find you need to change the appearance of lots of pedal lines, it may be more efficient
to change the corresponding project-wide settings on the Pedal Lines page in Engrave >
Engraving Options.

RELATED LINKS
Project-wide Engraving Options for pedal lines on page 514

Changing the position of pedal lines relative to grace notes
individually
You can change the start position and end position of individual pedal lines relative to grace
notes.
PROCEDURE
1.

Select the pedal lines whose position relative to grace notes you want to change. You can
do this in Write mode and Engrave mode.

2.

Activate the following properties, as appropriate for your selected pedal lines, in the Pedal
Lines group of the Properties panel:

3.

●

Starts before grace notes

●

Ends before grace notes

Check or uncheck the boxes beside the activation switches.

RESULT
When the boxes beside the activation switches are checked, the corresponding parts of pedal
lines are positioned before grace notes.
When the boxes beside the activation switches are not checked, the corresponding parts of pedal
are positioned following grace notes.
NOTE
You can adjust the precise position of pedal lines in further detail by moving them graphically in
Engrave mode.
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EXAMPLE

Pedal line starting and ending before grace notes

Pedal line starting and ending after grace notes

RELATED LINKS
Project-wide Engraving Options for pedal lines on page 514
Moving pedal lines graphically using the Properties panel on page 512

Changing the start sign appearance of individual pedal lines
PROCEDURE
1.

Select the pedal lines whose start sign appearance you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the Sign appearance property.

3.

Select one of the following options from the menu:
●

Ped. Glyph

●

Ped Glyph

●

P Glyph

●

Symbol

●

Ped Text

●

Hook

RESULT
The start sign appearance of the selected pedal lines is changed.
NOTE
You can revert the selected pedal lines back to your project-wide setting for start sign
appearance at any time by deactivating the Sign appearance property.
You can change the default start sign appearance for all pedal lines project-wide on the Pedal
Lines page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for pedal lines on page 514

Changing the type of hook at the start and end of pedal lines
individually
You can change the type of hook shown at the start and end of pedal lines individually.
You can only change the start hook type of pedal lines that have a hook as their start sign.
PROCEDURE
1.

Select the pedal lines whose hook type you want to change. You can do this in Write mode
and Engrave mode.

516

Pedal lines
Individual changes to the appearance of pedal lines
2.

3.

Activate the following properties, individually or together, in the Pedal Lines group of the
Properties panel:
●

Line start hook

●

Line end hook

Select one of the following options from the menus for each property:
●

No Hook

●

Vertical Hook

●

Slant Hook

●

Inverse Hook

RESULT
The hook type at the start and end of the selected pedal lines is changed, according to your
selections.

Changing the length of pedal lines hooks individually
You can change the length of hooks shown at the start and ends of pedal lines individually,
independently of the other end and independently of your project-wide settings for hook length.
This only applies to pedal lines that have a hook as their start sign.
PROCEDURE
1.

In Engrave mode, select the pedal lines whose hook lengths you want to change.

2.

Activate the following properties, individually or together, in the Pedal Lines group of the
Properties panel:

3.

4.

●

Start hook length

●

End hook length

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties change the lengths of pedal line hooks in the following ways:
●

Increasing the values makes hooks longer.

●

Decreasing the values makes hooks shorter.

RESULT
The hook lengths for the selected pedal lines are changed.
NOTE
You can revert the hook lengths of the selected pedal lines back to your project-wide setting for
hook length at any time by deactivating the corresponding properties.
NOTE
You can change the default hook length for all pedal lines project-wide by changing the value for
Hook length in the Design section of the Pedal Lines page in Engrave > Engraving Options.
This value applies to hooks at the start and end of pedal lines.
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Changing the continuation line type of pedal lines individually
PROCEDURE
1.

Select the pedal lines whose continuation line type you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the Continuation type property in the Pedal Lines group of the Properties panel.

3.

Select one of the following continuation types from the menu:
●

Line

●

Sign at End

●

Sign at End and Dashed Line

●

None

RESULT
The continuation line type of the selected pedal lines is changed.
NOTE
You can change the continuation type for all pedal lines project-wide on the Pedal Lines page in
Engrave > Engraving Options. You can choose different continuation types for each pedal, for
example, you can have a line for sustain pedal lines and just a sign at the end for una corda pedal
lines.

Changing the lengths of dashes in dashed pedal continuation lines individually
You can change the lengths of dashes in individual pedal continuation lines, independently of
your settings on the Pedal Lines page in Engraving Options. This only applies to pedal lines that
have dashed continuation lines.
PROCEDURE
1.

In Engrave mode, select the pedal lines with dashed continuation lines whose dash length
you want to change.

2.

Activate the Dash length property in the Pedal Lines group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The Dash length property changes the length of dashes in the following ways:
●

Increasing the value makes dashes longer.

●

Decreasing the value makes dashes shorter.

RESULT
The dash length in the dashed continuation lines of the selected pedal lines is changed.
NOTE
This overrides any changes you have made to the Dash gap length property.
You can change the default dash length for all dashed pedal continuation lines project-wide
by disclosing Advanced Options in the Design section of the Pedal Lines page in Engrave >
Engraving Options.
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Changing the lengths of gaps in dashed pedal continuation lines individually
You can change the length of the gaps between dashes in individual pedal continuation lines,
independently of your settings on the Pedal Lines page in Engraving Options. This only applies
to pedal lines that have dashed continuation lines.
PROCEDURE
1.

In Engrave mode, select the pedal lines with dashed continuation lines whose gap length
you want to change.

2.

Activate the Dash gap length property in the Pedal Lines group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The Dash gap length property changes the length of the gaps between dashes in the
following ways:
●

Increasing the value makes gaps longer.

●

Decreasing the value makes gaps shorter.

RESULT
The gap length in the dashed continuation lines of the selected pedal lines is changed.
NOTE
This overrides any changes you have made to the Dash length property.
You can change the default dash length for all dashed pedal continuation lines project-wide
by disclosing Advanced Options in the Design section of the Pedal Lines page in Engrave >
Engraving Options.

Changing the line thickness of pedal lines individually
PROCEDURE
1.

In Engrave mode, select the pedal lines whose continuation line thickness you want to
change.

2.

Activate the Line width property in the Pedal Lines group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The Line width property changes the width of the selected pedal lines in the following
ways:
●

Increasing the value makes pedal continuation lines thicker.

●

Decreasing the value makes pedal continuation lines thinner.

RESULT
The thickness of the selected pedal continuation lines is changed.
NOTE
You can change the default thickness for all pedal continuation lines project-wide in the Design
section of the Pedal Lines page in Engrave > Engraving Options.
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Showing individual pedal line continuation signs in parentheses
Pedal line continuation signs are shown by default at the start of new systems when pedal lines
continue across system breaks. You can choose to show individual pedal line continuation signs
in parentheses or without parentheses.
PROCEDURE
1.

Select the pedal lines whose continuation sign appearance you want to change. You can do
this in Write mode and Engrave mode.

2.

Activate the Show continuation sign in parentheses property in the Pedal Lines group of
the Properties panel.

3.

Check the box beside the activation switch.

RESULT
When the box beside the activation switch is checked, continuation signs are shown in
parentheses.
When the box beside the activation switch is not checked, continuation signs are not shown in
parentheses.
NOTE
You can choose the default appearance of all continuation signs project-wide on the Pedal Lines
page in Engrave > Engraving Options.

Types and levels of retakes and pedal level changes
You can change the type of pedal line retakes and the pedal levels at each pedal line retake after
they have been input.
When a pedal line is selected in Engrave mode, handles appear on the start and end of the pedal
lines, and on any retakes or pedal level changes in the line. These allow you to move each part of
the pedal line independently, and to change the pedal levels at the start, end, and at each retake
or pedal level change.

There are two handles for the start of the pedal line, three for retakes and pedal lifts, and three
for the end of the pedal line.
You can move each handle with the keyboard, with the mouse, and using the Properties panel.
This is because each handle corresponds to a property in either the Pedal Lines group or the
Pedal Line Retakes group of the Properties panel.
NOTE
Pedal levels cannot be lower than 0 or higher than 1.
1 is fully depressed.
0 is not depressed.

Start of pedal lines
There are two handles at the start of pedal lines.
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●

The left of the two handles moves the start point of the pedal line: you can move this
handle to the right and to the left.

●

The right of the two handles changes the start pedal level of the pedal line: you can move
this handle upwards and downwards. This changes the angle of the pedal continuation
line in relation to the next pedal retake or life, or the end of the pedal line.

Pedal level changes and retakes

●

The left handle changes the pedal level before the retake: you can move this handle
upwards and downwards.

●

The right handle changes the pedal level after the retake: you can move this handle
upwards and downwards.

●

The handle below the center of the pedal level change or retake notch corresponds to the
position of the pedal level change or retake: you can move this handle to the right or to the
left.

End of pedal lines

●

The handle at the tip of the end hook changes the hook length: you can move this handle
upwards and downwards.

●

The handle to the right of the end hook changes the pedal level at the end of the pedal
line: you can move this handle upwards and downward.

●

The handle below the end hook moves the end point of the pedal line: you can move this
handle to the right and to the left.

RELATED LINKS
Moving pedal lines graphically using the Properties panel on page 512

Changing the type of pedal line retakes
You can change existing retakes to pedal level changes, and you can change pedal level changes
to retakes. For example, if you do not want the pedal to be released completely between the old
and new levels, change the type to Change Level instead of Retake.
PROCEDURE
1.

In Engrave mode, select the retake or pedal level change whose type you want to change.

2.

Activate the Retake type property in the Pedal Line Retakes group of the Properties
panel.

3.

Choose the type you want from the following options:
●

Retake
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●

Change Level

RESULT
The type of pedal line retake is changed.
NOTE
The appearance of the new type of pedal line retake depends on the pedal levels already set on
each side. For example, a retake notch may only be shown on one side of the retake if the pedal
level on the other side is set to 0.

Changing the start level of pedal lines
PROCEDURE
1.

In Engrave mode, select the right handle of the start sign of the pedal line whose start
level you want to change.

2.

Move the start level upwards and downwards in the following ways:
●

Alt-Up Arrow

●

Alt-Down Arrow

●

-Alt-Up Arrow to change the level to 0

●

-Alt-Down Arrow to change the level to 1

●

Click and drag the handle upwards or downwards to the start level you want

RESULT
The start level of the selected pedal line is changed.
RELATED LINKS
Types and levels of retakes and pedal level changes on page 520

Changing the start level of pedal lines using the Properties panel
PROCEDURE
1.

In Engrave mode, select the pedal line whose start level you want to change.

2.

Activate the Start level property in the Pedal Lines group of the Properties panel.

3.

Change the start level by changing value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

For example, 1 is fully depressed and 0 is not depressed.
RESULT
The start level of the selected pedal line is changed.
RELATED LINKS
Types and levels of retakes and pedal level changes on page 520
Inputting pedal lines with the mouse on page 508
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Changing pedal levels at retakes and pedal level changes
You can change both the start level and end level of pedal lines at retakes and pedal level
changes.
The end level is the pedal level immediately before the retake or pedal level change occurs, and
the start level is the pedal level immediately after the retake or pedal level change occurs.
PROCEDURE
1.

2.

3.

In Engrave mode, select one of the following handles of the retake or pedal level change
whose start level or end level you want to change:
●

Select the left handle to change the end pedal level

●

Select the right handle to change the start pedal level

Move the start level upwards and downwards in the following ways:
●

Alt-Up Arrow

●

Alt-Down Arrow

●

-Alt-Up Arrow to change the level to 0

●

-Alt-Down Arrow to change the level to 1

●

Click and drag the handle upwards or downwards to the start level you want

If required, repeat steps 1 and 2 for the other handle.

RESULT
The pedal levels of the selected retake or pedal level change are changed.
RELATED LINKS
Types and levels of retakes and pedal level changes on page 520

Changing pedal levels at retakes and pedal level changes using the
Properties panel
You can change both the start level and end level of pedal lines at retakes and pedal level
changes.
The end level is the pedal level immediately before the retake or pedal level change occurs, and
the start level is the pedal level immediately after the retake or pedal level change occurs.
PROCEDURE
1.

In Engrave mode, select the retake or pedal level change whose start level you want to
change.

2.

Activate the following properties, individually or together, in the Pedal Line Retakes
group of the Properties panel:

3.

●

Start level at retake

●

End level at retake

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

For example, 1 is fully depressed and 0 is not depressed.
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RESULT
The pedal levels of the selected retake or pedal level change are changed.
RELATED LINKS
Types and levels of retakes and pedal level changes on page 520

Changing the end level of pedal lines
PROCEDURE
1.

In Engrave mode, select the right handle of the end hook of the pedal line whose end level
you want to change.

2.

Move the end level upwards and downwards in the following ways:
●

Alt-Up Arrow

●

Alt-Down Arrow

●

-Alt-Up Arrow to change the level to 0

●

-Alt-Down Arrow to change the level to 1

●

Click and drag the handle upwards or downwards to the end level you want

RESULT
The end level of the selected pedal line is changed.
RELATED LINKS
Types and levels of retakes and pedal level changes on page 520

Changing the end level of pedal lines using the Properties panel
PROCEDURE
1.

In Engrave mode, select the pedal line whose end level you want to change.

2.

Activate the End level property in the Pedal Lines group of the Properties panel.

3.

Change the start level by changing value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

For example, 1 is fully depressed and 0 is not depressed.
RESULT
The end level of the selected pedal line is changed.
RELATED LINKS
Types and levels of retakes and pedal level changes on page 520

Start and restorative text in pedal lines
All types of pedal line can be shown with text as their start signs, instead of glyphs or hooks.
You can override the text shown at the start of pedal lines that have text start signs, you can
change the continuation text shown at the start of new systems, and you can override the
restorative text shown at the end of una corda pedal lines.
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Overriding the start text shown in pedal lines
You can override the default text shown at the start of pedal lines that use text as their start sign.
PROCEDURE
1.

Select the pedal lines whose start text you want to override. You can do this in Write mode
and Engrave mode.

2.

Activate the Text property in the Pedal Lines group of the Properties panel.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The text shown at the start of the selected pedal lines is changed.
NOTE
You can revert the text to the default start text at any time by deactivating the Text property.
Deactivating the property permanently deletes any custom text entered.

Overriding the continuation shown in pedal lines
You can override the default text shown at the start of new systems when pedal lines cross
system breaks. This only applies to pedal lines that use text as their start sign.
PROCEDURE
1.

Select the pedal lines whose continuation text you want to override. You can do this in
Write mode and Engrave mode.

2.

Activate the Continuation text property in the Pedal Lines group of the Properties panel.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The continuation text shown at the start of new systems for the selected pedal lines is changed.
NOTE
You can revert the text to the default continuation text at any time by deactivating the
Continuation text property. Deactivating the property permanently deletes any custom text
entered.

Overriding the restorative text shown in una corda pedal lines
The equivalent to the final pedal lift for una corda pedal lines is the indication to return to tre
corda. You can override the tre corde text shown at the end of una corda pedal lines.
PROCEDURE
1.

Select the una corda pedal lines whose restoration text you want to override. You can do
this in Write mode and Engrave mode.

525

Pedal lines
Pedal lines in playback
2.

Activate the Restorative text property in the Pedal Lines group of the Properties panel.

3.

Enter the text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The restorative text shown at the ends of the selected una corda pedal lines is changed.
NOTE
You can revert the text to the default restorative text at any time by deactivating the Restorative
text property. Deactivating the property permanently deletes any custom text entered.

Pedal lines in playback
Pedal lines are automatically played back in Dorico.
The three piano pedals send MIDI controllers as follows:
●

sustain pedal lines send MIDI controller 64 (Sustain).

●

sostenuto pedal lines send MIDI controller 66 (Sostenuto).

●

una corda pedal lines send MIDI controller 67 (Soft Pedal).

Some specialised piano VST instruments, such as Pianoteq and Garritan CFX Concert Grand,
support partial depression of the sustain pedal. Consult the manufacturer’s documentation for
more information.

Playback Options
You can find options for how Dorico plays pedaling on the Pedal Lines page in Play > Playback
Options (key command Ctrl/Cmd-Shift-P).
You can control:
●

The speed of the initial pedal depression.

●

The speed of a retake in the middle of a pedal line.

●

The speed of the final pedal release.

●

Whether the initial depression and the retake should be played before or after the onset of
the notes or chords at that rhythmic position.

Importing pedal lines from MusicXML files
Sustain pedal lines are imported from MusicXML files. MusicXML can only describe the sustain
pedal, and it cannot describe changes in pedal depression level.
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The term “playing techniques” covers a wide range of instructions intended to tell a player either
how they should modify the sound of the note or notes they are playing, or change the way they
are playing.
This can be by changing their playing technique, such as changing their embouchure or
changing the position of their bow, or by modifying their instrument, such as adding a mute or
depressing a pedal.
In Dorico, playing techniques can be expressed as symbols or as text. All available playing
techniques can be found in the Playing Techniques panel in Write mode, organized by
instrument family.

Some of the different playing techniques in Dorico.

General placement conventions for playing techniques
Playing techniques, both playing technique texts and playing technique symbols, are placed
above the staff. For voices, they are placed above the staff and below dynamics.
When there are multiple voices in a single staff, playing techniques for the up-stem voices are
placed above the staff and playing techniques for the down-stem voices are placed below the
staff.

An example of the placement of playing techniques when there are two voices in the same staff.

Playing technique texts use a plain font, neither bold nor italic, so they are not confused with
expressive text and dynamics.

Inputting playing techniques with the keyboard
You can input playing techniques by using the playing techniques popover in Write mode.
You can open the playing techniques popover in Write mode by pressing Shift-P (P for “pedal” or
“playing technique”), or by choosing Write > Playing Technique.
You can do this based either on the range of selected notes, or during step input.
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.
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The playing techniques popover with an example
entry for a playing technique.

The playing techniques button in the Notations
toolbox

The playing techniques popover
Here are some examples of what to enter into the playing techniques popover, and the playing
techniques that are input as a result.
You can open the playing techniques popover in Write mode by pressing Shift-P, or by choosing
Write > Create Playing Technique.
Enter:

For playing technique:

vibrato

Vibrato

senza vibrato

Senza vibrato (no vibrato)

nat

Naturale (nat.)

strong air pressure

Strong air pressure

double-tongue

Double-tongue

downbow

Down bow

upbow

Up bow

sul pont

Sul ponticello

sul tasto

Sul tasto

pst

Poco sul tasto

pizz

Pizzicato

spicc

Spiccato

arco

Arco

tongue click

Tongue click (Stockhausen)

finger click

Finger click (Stockhausen)

motor on

Vibraphone motor on

motor off

Vibraphone motor off

open

Open

damp

Damp
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Enter:

For playing technique:

damp large

Damp (large)

full barre

Full barré

half barre

Half barré

strum up

Strum up

strum down

Strum down

lh

Left hand

rh

Right hand

This list is not comprehensive: it is intended to illustrate how you can structure your entry to
input different types of playing techniques.
NOTE
As playing techniques correspond to specific samples, they must be input as described.

Inputting playing techniques during step input with the keyboard
To input playing techniques during step input with the keyboard:
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where the playing technique should be input.

3.

Open the playing techniques popover in any of the following ways:
●

Press Shift-P

●

Choose Write > Create Playing Technique

4.

Type the appropriate short-hand for the playing technique you want into the popover,
such as vibrato or tongue click.

5.

Press Return to close the popover.

RESULT
The playing technique specified is input at the caret position.

Adding playing techniques to existing notes with the keyboard
To add playing techniques to existing notes and music with the keyboard:
PROCEDURE
1.

In Write mode, select the note to which the playing technique should be added.
NOTE
Playing techniques can only be added to one note at a time.

2.

Open the playing techniques popover in any of the following ways:

529

Playing techniques
Inputting playing techniques with the mouse
●

Press Shift-P

●

Choose Write > Create Playing Technique

3.

Type the appropriate short-hand for the playing technique you want into the popover,
such as sul pont or au talon.

4.

Press Return to close the popover.

RESULT
The playing technique specified is added to the selected note.

Inputting playing techniques with the mouse
Playing techniques can be input with the mouse by clicking options in the different sections of
the Playing Techniques panel in Write mode.
The Playing Techniques panel is opened by clicking this button in the Notations toolbox on the
right of the window:

The different sections in the Playing Techniques panel are:
●

Common

●

Wind

●

Brass

●

Untuned Percussion

●

Tuned Percussion

●

Keyboard

●

Choral

●

Strings

●

Other

Each section contains playing technique texts and playing technique symbols appropriate for
that instrument family. If you are not sure what a symbol represents, you can hover your mouse
pointer over each option to show their names.

Inputting playing techniques during step input with the mouse
To input playing techniques during step input with the mouse:
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where the playing technique should be input.

3.

Select the playing technique you want from the options available in the Playing
Techniques panel on the right of the window.

RESULT
The playing technique selected is input at the caret position. It is input at the caret position even
if your preference is set to Load cursor with item.

530

Playing techniques
Positions of playing techniques

Adding playing techniques to existing notes with the mouse
To add playing techniques to existing notes and music with the mouse:
PROCEDURE
1.

In Write mode, select the note to which the playing technique should be added.
NOTE
Playing techniques can only be added to one note at a time.

2.

Click the playing technique you want in the Playing Techniques panel.

RESULT
The playing technique selected is added to the selected note.
NOTE
If your preference is set to Load cursor with item, complete these steps in the reverse order.
If you want to add the same playing technique to multiple notes, check the box for Allow
multiple items to be created with the mouse in the Editing section in Preferences, so that you
do not have to reselect the playing technique for each note.

Positions of playing techniques
You can change the positions of playing techniques by moving individual playing techniques
to different rhythmic positions in Write mode, moving them to different graphical positions in
Engrave mode, and by changing the default positions of all playing techniques project-wide.
You can move playing techniques to different rhythmic positions in Write mode. They are
positioned by default according to your preferences in Engraving Options.
You can move playing techniques graphically in Engrave mode, however this does not change
the rhythmic positions to which they are attached.
Project-wide settings for the default position of playing techniques can be set on the Playing
Techniques page in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for playing techniques on page 534

Moving playing techniques rhythmically
You can move playing techniques to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the playing techniques you want to move.

2.

Move the playing techniques in any of the following ways:
●

Press Alt-Right Arrow

●

Alt-Left Arrow

●

Click and drag the playing technique to the right or to the left to the notehead you
want.
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NOTE
Only one playing technique can be moved rhythmically at a time when using the
mouse.

RESULT
A single playing technique is moved to the next or previous notehead on that staff.
Multiple playing techniques are moved according to the rhythmic grid currently set.

Moving playing techniques graphically
You can move playing techniques graphically without changing the rhythmic positions to which
they apply.
PROCEDURE
1.

In Engrave mode, select the playing techniques you want to move.

2.

Move the playing techniques in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move playing techniques by larger increments, you can press Ctrl/
Cmd as well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the playing techniques in any direction to the positions you want.

RELATED LINKS
Moving playing techniques graphically using the Properties panel on page 532

Moving playing techniques graphically using the Properties panel
You can move playing techniques graphically using the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the playing techniques you want to move.

2.

Activate the Start offset property in the Playing Techniques group of the Properties
panel.

3.

The Start offset property has X and Y value fields. You can enter values into the value
fields in the following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move playing techniques in the following ways:
●

Start offset X moves playing techniques horizontally: increasing the value moves
them to the right, decreasing the value moves them to the left.

●

Start offset Y moves playing techniques vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.
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Changing placement of playing techniques relative to the
staff
To change the placement of playing techniques relative to the staff:
PROCEDURE
1.

Select the playing technique or playing techniques whose placement you want to change.
This can be done in Write mode and Engrave mode.

2.

Activate the Placement property in the Playing Techniques group of the Properties panel.

3.

Choose between:
●

Above

●

Below

RESULT
The placement of the playing technique or playing techniques is changed to either above or
below the staff.

Deleting playing techniques
To delete playing techniques:
PROCEDURE
1.

In Write mode, select the playing techniques you want to delete.

2.

Delete the playing techniques in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected playing techniques are deleted.

Adding alternative text to playing techniques
To show alternative or additional text above or alongside playing techniques:
PROCEDURE
1.

Select the playing techniques to which you want to add alternative text. You can do this in
Write mode and Engrave mode.

2.

Activate the Alternative text property in the Playing Techniques group of the Properties
panel.

3.

Enter the alternative text you want into the value field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The alternative text you entered into the value field is shown directly after playing technique text,
and directly above playing technique symbols.
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EXAMPLE

Alternative text added to playing technique text.

Alternative text added to playing technique symbol.

Project-wide Engraving Options for playing techniques
Options for the appearance and positions of playing techniques can be found on the Playing
Techniques page in Engraving Options.
The options on this page allow you to change the placement of playing techniques above the
staff, the arrangement of multiple playing techniques at the same rhythmic positions, and
playing technique continuation styles.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Playing Techniques in the page list on the left of the dialog.

Playing techniques in playback
Each playing technique you can create in Write mode corresponds to a technique that you can
map in the Expression Maps editor. You can open the Expression Maps editor by choosing
Play > Expression Maps.
The Expression Maps editor shows you which playing techniques can currently be applied to
each software instrument, which are shown in a list on the left of the dialog. This list includes
combined playing techniques, which allows multiple playing techniques to be applied to notes
simultaneously.
You can edit existing techniques, and create new combinations of playing techniques in the
Techniques section of the dialog. For example, you can combine “Pizzicato” and “Muted” to allow
the pizzicato and muted techniques to be applied to the same note.
When you input a playing technique in Write mode, that playing technique is looked for by the
expression map. If it cannot be found, the playing technique applied either remains the same as
the previous technique or reverts to the natural technique.
You can see which playing techniques are being applied in the Playing Techniques lane, which
can be shown by expanding individual instruments in Play mode.
TIP
If you have input a playing technique but cannot hear a change in the sound, that could be
because you are using a combination of playing techniques that the expression map is not
expecting. For example, if you input a new playing technique without canceling an existing
playing technique, the expression map cannot process the two playing techniques together if the
expression map does not have an entry for those two techniques combined.
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To avoid playing technique clashes, input a “naturale”, or “nat.”, playing technique to return
the software instrument to its natural state. New playing techniques can then be input without
clashes.
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Rehearsal marks are an ordered sequence of letters or numbers, which along with bar numbers,
provide a reference point for music that has multiple players, and make the chronological
sequence of the music clear.
They tell you where you are in the piece, and allow players to co-ordinate themselves easily in
rehearsals and concerts. As you can have greater control over where rehearsal marks appear, as
opposed to bar numbers, rehearsal marks can also be used to indicate significant changes in the
music.
Rehearsal marks can be added and deleted easily in Dorico, and the ordered sequence
automatically adjusts to ensure there are no gaps or duplicate rehearsal marks.
They can also be useful when preparing parts and scores, as you can use bar numbers and
rehearsal marks to help you quickly compare a part to the score and check it is correct.

General placement conventions for rehearsal marks
As rehearsal marks are intended to be seen easily, they should be positioned conspicuously in
the score: they should use a non-italic bold type that is relatively large, and be positioned above
the system and outside the music. Rehearsal marks should not be positioned below the system.

They should be positioned above barlines. Although you can input rehearsal marks at rhythmic
positions within a bar, this is not recommended. Depending on the style of music and the context
in which it is used, it may be helpful to input a double barline beneath each rehearsal mark.
In order to ensure they are conspicuous, and are not easily confused with bar numbers if you are
using numbers for rehearsal marks, they should be shown in an enclosure.
The placement of rehearsal marks relative to the music is discretionary, but they are most helpful
to players when they coincide with a change in the music, such as a tempo change or a change
in texture. They are also helpful when placed at point in the music where players are likely to
start from in order to rehearse a specific section, such as a significant solo entry or the start of a
difficult passage. In general, it is good to place rehearsal marks at regular intervals as well as at
significant moments: every 5-20 bars reduces the amount of bars players need to count before or
after a rehearsal mark.
If a rehearsal mark coincides with a tempo change, the tempo text should be positioned to the
right of the rehearsal mark. However, if space is tight, the text can be position above or below
the rehearsal mark. The position of the rehearsal mark should remain clear: it should not be
moved away from the barline to which it applies, otherwise its position could be misunderstood.
Dorico automatically adjusts spacing to keep a rehearsal mark at the correct position.
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Inputting rehearsal marks
Rehearsal marks can be input in Write mode with the mouse and the keyboard.
NOTE
If using the mouse with your mouse input preference set to Create item at selection, follow
these steps in the given order.
If your preference is for Load cursor with item, follow the steps in the reverse order.

PROCEDURE
1.

2.

In Write mode, select one of the following:
●

A barline at the position where you want to input a rehearsal mark.

●

A note, whole bar rest, or object that begins at the rhythmic position where you
want to input a rehearsal mark.

Input a rehearsal mark in one of the following ways:
●

Press Shift-A.

●

Choose Write > Create Rehearsal Mark.

●

Click Rehearsal Marks in the Notations toolbox:

RESULT
A rehearsal mark is input at a selected barline, or at the rhythmic position of the start of a note,
a rest, or an object. Only one rehearsal mark can be input at a time, even if multiple items are
selected.
The order of rehearsal marks is updated automatically, so they can be input at any time and in
any order. This procedure can be followed to input rehearsal marks between existing rehearsal
marks, and before existing rehearsal marks.

Positions of rehearsal marks
You can change the positions of rehearsal marks by moving individual rehearsal marks to
different rhythmic positions in Write mode, moving them to different graphical positions in
Engrave mode, and by changing the default positions of all rehearsal marks project-wide.
You can move rehearsal marks to different rhythmic positions in Write mode. They are
positioned by default according to your preferences in Engraving Options.
You can move rehearsal marks graphically in Engrave mode, however this does not change the
rhythmic positions to which they are attached.
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Project-wide settings for the default position of rehearsal marks, and values for the minimum
distances between rehearsal marks and staves, and rehearsal marks and other items, can be set
on the Rehearsal Marks page in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for rehearsal marks on page 542

Moving rehearsal marks rhythmically
You can move rehearsal marks to new rhythmic positions.
PROCEDURE
1.

In Write mode, select the rehearsal mark you want to move.

2.

Move the rehearsal mark in any of the following ways:
●

Press Alt-Right Arrow to snap it to the next barline.

●

Press Alt-Left Arrow to snap it to the previous barline.

●

Click and drag it to the right or to the left to snap it to the next or previous barline.

RESULT
The selected rehearsal mark is moved to the next or previous barline.
NOTE
You can only move one rehearsal mark rhythmically at a time when using the mouse.
You can move multiple rehearsal marks together if using the keyboard, but they are moved
according to the rhythmic grid currently set instead of snapping to barlines.

Moving rehearsal marks graphically
You can move rehearsal marks graphically, without changing their rhythmic positions.
PROCEDURE
1.

In Engrave mode, select the rehearsal marks you want to move.

2.

Move the rehearsal marks in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Alt-Left Arrow to move them to the left.

●

Alt-Up Arrow to move them upwards.

●

Alt-Down Arrow to move them downwards.
TIP
If you want to move rehearsal marks by larger increments, you can press Ctrl/Cmd
as well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction to the positions you want.

RESULT
The graphical positions of the selected rehearsal marks are changed.
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NOTE
You can reset the graphical positions of rehearsal marks at any time by deactivating the Start X
offset property in the Rehearsal Marks group of the Properties panel.

RELATED LINKS
Moving rehearsal marks graphically using the Properties panel on page 539

Moving rehearsal marks graphically using the Properties panel
You can move rehearsal marks graphically using the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the rehearsal marks you want to move.

2.

Activate the Start offset property in the Rehearsal Marks group of the Properties panel.

3.

The Start offset property has X and Y value fields. Change the values in the value fields in
any of the following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The Start offset property moves rehearsal marks in the following ways:
●

Start offset X moves rehearsal marks horizontally: increasing the value moves them
to the right, decreasing the value moves them to the left.

●

Start offset Y moves rehearsal marks vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.

Deleting rehearsal marks
To delete rehearsal marks:
PROCEDURE
1.

In Write mode, select the rehearsal marks you want to delete.

2.

Delete the rehearsal marks in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected rehearsal marks are deleted.

Changing the order of rehearsal marks
By default, the rehearsal mark sequence resets at the start of each flow. If you want the
rehearsal mark sequence to continue across flows, you can change the index position of a
rehearsal mark.
Changing the index position changes the shown number or letter. For example, index position 1
appears as a rehearsal mark of A or 1, position 2 appears as B or 2, and so on.
You may also want to change the index position of a rehearsal mark to avoid showing a letter
that could easily be confused with another letter or another number, such as I or J.
To change the index position of an individual rehearsal mark:
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PROCEDURE
1.

Select the rehearsal mark whose index position you want to change. This can be done in
Write mode and Engrave mode.

2.

Activate the Index property in the Rehearsal Marks group of the Properties panel at the
bottom of the window.

3.

Change the value in the value field to correspond with the number or letter you want to be
shown in one of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The selected rehearsal mark changes according to the index value now set, and its sequence
type.
If its sequence type is Letters, it shows a letter. If its sequence type is Numbers, it shows a
number.
Any subsequent rehearsal marks in the same sequence follow the new index automatically. For
example, if you changed a rehearsal mark from A to P, the next rehearsal mark would change
from B to Q.
NOTE
If you want to change the rehearsal mark sequence, for example if you want rehearsal mark C to
appear as rehearsal mark 3, you need to change the sequence type before changing the index
position.

RELATED LINKS
Changing the rehearsal mark sequence type on page 540

Changing the rehearsal mark sequence type
Rehearsal marks can be shown as a letter, a number, or show the bar number. You can choose
which type of sequence should be used project-wide on the Rehearsal Marks page in Engraving
Options.
In Dorico, if required you can have all three sequences simultaneously. For example, you might
want to have the main sequence of rehearsal marks showing letters, but have a secondary
sequence of numbers to mark different moments, perhaps entry points for a solo line, and also
have prominent bar numbers within those sections highlighted.
To change the sequence type of an individual rehearsal mark, and to create secondary rehearsal
mark sequences:
PROCEDURE
1.

Select the rehearsal mark whose sequence type you want to change. This can be done in
Write mode and Engrave mode.

2.

Activate the Sequence type property in the Rehearsal Marks group of the Properties
panel at the bottom of the window.

3.

Change the sequence type by selecting one of the following options:
●

Letters

●

Numbers

●

Bar numbers
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RESULT
The selected rehearsal mark now displays a letter, a number, or the bar number, according to
your selection.
If it is the first rehearsal mark in either the letters sequence or the numbers sequence in the flow,
it shows either A or 1. If there are already rehearsal marks in either the letters sequence or the
numbers sequence in the flow, it shows the next letter or number according to the index.
NOTE
You can change the index of a rehearsal mark sequence independently of other rehearsal mark
sequences. However, the bar numbers sequence cannot be changed using this method.

RELATED LINKS
Project-wide Engraving Options for rehearsal marks on page 542
Adding bar number changes on page 240

Adding suffixes and prefixes to rehearsal marks individually
Prefixes and suffixes can be added to rehearsal marks project-wide on the Rehearsal Marks
page in Engrave > Engraving Options. They can also be added to rehearsal marks individually.
PROCEDURE
1.

Select the rehearsal mark or rehearsal marks to which you want to add a prefix or suffix.
You can do this in Write mode or Engrave mode.

2.

Activate one of the following properties in the Rehearsal Marks group of the Properties
panel:
●

Prefix

●

Suffix

3.

Enter the prefix or suffix you want to add into the corresponding value field to where you
want the text to be shown.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The text you entered into the value field is added to the selected rehearsal marks as a prefix or a
suffix.

Showing rehearsal marks at multiple positions
Rehearsal marks are system objects, and so can be shown above the first bracket of selected
instrument families.
To choose where system objects should appear:
PROCEDURE
1.

2.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

Select Staves and Systems from the Category menu.
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3.

Select the layouts in which you want to change the position of system objects in the
Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

In the System Objects section, activate the box beside each instrument family group
above which you want system objects, including rehearsal marks, to appear.

RESULT
System objects appear above the top staff in each bracketed group you select, if a bracketed
group for that instrument family is included in the selected layouts.
System objects include rehearsal marks, but also include other items, such as tempo markings.
NOTE
Your chosen ensemble style for brackets affects where system objects appear.

RELATED LINKS
Changing bracket grouping according to ensemble type on page 265

Project-wide Engraving Options for rehearsal marks
Options for the appearance and position of rehearsal marks project-wide can be found on the
Rehearsal Marks page in Engraving Options.
For example, you can change the sequence type of rehearsal marks, their default positions, and
whether they are shown in enclosures.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Rehearsal Marks in the page list on the left of the dialog.
RELATED LINKS
Rehearsal mark enclosure size and padding values on page 544

Changes to the rehearsal mark font style
You can change different aspects of the font used for rehearsal marks. This changes the font in
all rehearsal marks project-wide.
In the Engrave > Font Styles dialog, select Rehearsal Mark Font from the menu to change
different aspects of the font.
Changes made to the font style apply to the entire project, including parts.
The different aspects of the rehearsal mark font style that you can change are:
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Font family
Sets the overall font style.
Size
Sets the size of rehearsal marks. Rehearsal mark size can be:
●

Absolute: always the set size, regardless of the staff size.

●

Staff-relative: the size of rehearsal marks is proportional to the staff size,
which means rehearsal marks appear smaller than the set value on smaller
staves, and larger than the set value on larger staves.

Style
Sets the rehearsal mark font appearance. The rehearsal mark font can be:
●

Regular

●

Italic

●

Bold (default)

●

Bold Italic

Underlined
The rehearsal mark font appears underlined if the box beside the Underlined
activation switch is checked.
RELATED LINKS
Project-wide Engraving Options for rehearsal marks on page 542

Changing the rehearsal mark font style
To change the font style used for rehearsal marks:
PROCEDURE
1.

In Engrave mode, choose Engrave > Font Styles to open the Font Styles dialog.

2.

Select Rehearsal Mark Font from the Font style menu.

3.

Activate the switches beside the following options to change the corresponding aspects of
the font:

4.

●

Font family

●

Size

●

Style

●

Underlined

Click OK to save your changes and close the dialog.

RESULT
The rehearsal mark font style is changed project-wide.
RELATED LINKS
Changes to the rehearsal mark font style on page 542

Changing the rehearsal mark enclosure type
Rehearsal marks are usually shown in an enclosure, which can be a rectangle or a circle.
To change the enclosure type for rehearsal marks:
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PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Rehearsal Marks in the page list.

3.

Choose one of the following options for Enclosure type in the Enclosure section:
●

Rectangle

●

Circle

●

No enclosure

RESULT
Rehearsal marks in your project are shown within your chosen enclosure. The size of the
enclosure is relative to the font size of the rehearsal marks, but the size and shape of the
enclosure are also determined by your padding values.
EXAMPLE

Rehearsal mark in a rectangular
enclosure

Rehearsal mark in a circular
enclosure

Rehearsal mark with no enclosure

Rehearsal mark enclosure size and padding values
In the Enclosures section of the Rehearsal Marks page in Engrave > Engraving Options, there
are a number of options to control the shape and size of rehearsal mark enclosures.

Rectangle rehearsal mark enclosure
The default settings for a rectangle enclosure create an enclosure like this one. The minimum
height and minimum width are both 4 spaces, horizontal padding (left and right) is 3/4 of a
space, and minimum bottom and minimum top padding are both 1/8 of a space.

Minimum width
This sets a minimum value for how wide the enclosure should appear, such as in this
example where the value has been increased from 4 to 8 spaces:

Minimum height
This sets a minimum value for how high the enclosure should appear, such as in this
example where the value has been increased from 4 to 8 spaces:
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Minimum horizontal padding
This sets a minimum value for the distance between the two sides of the enclosure
and the rehearsal mark within, such as in this example where the value has been
increased from 3/4 to 3 spaces:

Minimum top padding
This sets a minimum value for the distance between the top line of the enclosure
and the rehearsal mark within, such as in this example where the value has been
increased from 1/2 to 2 spaces:

Minimum bottom padding
This sets a minimum value for the distance between the bottom line of the enclosure
and the rehearsal mark within, such as in this example where the value has been
increased from 1/8 to 2 spaces:

Circular bar number enclosure
The default settings for a circular enclosure create an enclosure like this one. The minimum
diameter is 4 spaces, and the minimum padding is 1/4 of a space.

Minimum diameter
This sets a minimum value for the diameter of the enclosure, such as in this example,
where the value has been increased from 4 to 8 spaces:

Minimum padding
This sets a minimum value for the distance between the enclosure line and the
rehearsal mark within, such as in this example where the value has been increased
from 1/4 to 2 spaces:
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All enclosures
Enclosure line thickness
This allows you to control how thick the enclosure line should appear, for both
rectangle and circle enclosures. The default is 1/8 of a space. The below examples
demonstrate a thickness of 1/2 a space.
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Repeat endings are also sometimes known as volta lines, or as 1st and 2nd endings.
For music with repeated passages, repeat endings show which bars are played at the end of each
repetition, with different endings each time if required.
Dorico allows you to create repeat endings for any number of repeats.

RELATED LINKS
Adding additional endings on page 548

Inputting repeat endings
There is no popover for repeat endings: they can only be input using the Repeat Structures
panel on the right of the window in Write mode.
You can open the Repeat Structures panel by clicking Repeat Structures in the Notations
toolbox:

PROCEDURE
1.

In Write mode, select the bars that you want to include in the first ending.
You can select a single note or rest in each bar to include those bars in the first ending.

2.

Click Create Repeat Ending in the Repeat Endings section of the Repeat Structures
panel.

RESULT
The first ending segment is created, covering the bars in which you selected notes, with a second
ending segment created in the bar immediately following the first ending.
An end repeat barline is created at the end of the first ending if none exists already.
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Adding additional endings
You can have more than two possible endings in each repeat ending structure by adding repeats.
PROCEDURE
1.

In Write mode, select the bars that you want to include in the second ending, starting with
the first bar with the open second-time bracket.

2.

Click Add Section To Repeat Ending in the Repeat Endings section of the Repeat
Structures panel.

NOTE
If increasing the number of endings makes the repeat ending collide with any part of
another repeat ending, the other repeat ending is deleted. However, its repeat barlines are
not deleted.

RESULT
The existing second ending segment now ends with a closed line, with an end repeat barline
created if necessary.
A new, third ending segment is added in the bar after the last bar in the second ending.
You can repeat this process as many times as required.
EXAMPLE

Default repeat ending structure with two endings

Repeat ending structure with additional third ending

Changing the number of endings using the Properties panel
You can increase the number of endings included in a repeat ending structure individually using
the Properties panel.
PROCEDURE
1.

Select the repeat endings whose number of endings you want to change. You can do this
in Write mode and Engrave mode.

2.

Activate the No. endings property in the Repeat Endings group of the Properties panel.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

NOTE
If increasing the number of endings makes the repeat ending collide with any part of
another repeat ending, the other repeat ending is deleted. However, its repeat barlines are
not deleted.
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RESULT
Increasing the value increases the number of repeats.
Decreasing the value decreases the number of repeats.
NOTE
This does not automatically input or reposition repeat barlines. You can input repeat barlines as
appropriate manually.

Changing the total number of repeats in repeat endings
By default, each segment in repeat endings is played once, so each segment shows a single digit
corresponding to the time through the music on which each ending is played. You can increase
the total number of repeats for individual repeat endings.
PROCEDURE
1.

Select the repeat endings whose total number of repeats you want to change. You can do
this in Write mode and Engrave mode.

2.

Activate the No. times played property in the Repeat Endings group of the Properties
panel.

3.

Change the number of repeats you want by changing the value in the value field in any of
the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

NOTE
You cannot have fewer repeats than the number of segments.

RESULT
The total number of repeats in the selected repeat endings is changed. This is updated
automatically in the layout.
By default, Dorico prefers to add any repeats not already assigned to specific segments to the
final closed segment.
NOTE
Once you have set the total number of repeats, you can then change which segment is used for
each repeat.

RELATED LINKS
Changing the segments used for each repeat in repeat endings on page 549

Changing the segments used for each repeat in repeat endings
You can control how the number of repeats is divided across the different segments in individual
repeat endings.
PROCEDURE
1.

In Engrave mode, select an individual segment from the repeat ending structure whose
number of repeats you want to change.

2.

Activate the Times played for segment property in the Repeat Endings group of the
Properties panel.
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3.

Enter the number of each repeat that you want to include in the selected segment.
For example, for a repeat ending with six repeats, you can enter 4,5,6 for the second
segment.

RESULT
The number of repeats included in the selected segment is changed.
EXAMPLE

The default distribution of repeats

The customized distribution of repeats

Project-wide Engraving Options for repeat endings
Options controlling the design, default position, and display of number of times played can be
found on the Repeat Endings page in Engraving Options..
The options on this page allow you to change the ends of repeat ending lines, the appearance of
numbers and hooks, and the default position of repeat endings.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Repeat Endings in the page list on the left of the dialog.

Changing above which staves repeat endings appear
Repeat endings are system-attached items and appear above selected instruments. There is also
an option to show repeat endings below the bottom staff of the system.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Staves and Systems from the Category menu.

3.

Select the layouts in which you want to change above which staves repeat endings appear
in the Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.
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By default, the layout currently open in the music area is selected when you open the
dialog.
4.

In the System Objects section, check the boxes for the instrument families above which
you want system objects, including repeat ending lines, to appear in the selected layouts.

RESULT
System objects appear above the top staff in each bracketed group you select, if a bracketed
group for that instrument family is included in the selected layouts.
System objects include rehearsal marks, but also include other items, such as tempo markings.
NOTE
Your selected ensemble style for brackets affects where system objects appear.

RELATED LINKS
Changing bracket grouping according to ensemble type on page 265

Lengthening and shortening final segments in repeat
endings with the keyboard
You can increase and decrease the number of bars included in the final segment of repeat
endings by lengthening and shortening them with the keyboard.
PROCEDURE
1.

In Write mode, select the repeat endings whose final segments you want to lengthen or
shorten.

2.

Change the lengths of the final segments in the following ways:
●

Press Shift-Alt-Right Arrow to lengthen the final segment.

●

Press Shift-Alt-Left Arrow to shorten the final segment.

RESULT
The final segments of the selected repeat endings are lengthened or shortened by snapping to
the next or previous barline.
NOTE
You can only change the length of the last segment in repeat endings using the keyboard. You
can change the lengths of inner segments using the mouse.
This does not automatically input or reposition repeat barlines. You need to input repeat barlines
as appropriate manually.

RELATED LINKS
Lengthening and shortening segments in repeat endings with the mouse on page 552
Moving repeat endings graphically using the Properties panel on page 554

551

Repeat endings
Lengthening and shortening segments in repeat endings with the mouse

Lengthening and shortening segments in repeat endings
with the mouse
You can increase and decrease the number of bars included in each segment of repeat endings
by lengthening and shortening them with the mouse.
You can lengthen and shorten inner repeat ending segments as well as final repeat ending
segments when using the mouse.
PROCEDURE
1.

In Write mode, select the repeat ending you want to lengthen or shorten.

2.

Select the circular handle at the right-hand end of the segment you want to lengthen or
shorten.

The selected handle in the middle has a thicker line

3.

Click and drag the handle to the right or to the left to snap it to the next or previous
barline.
NOTE
Segments must contain at least one bar.

4.

Optional: Repeat steps 1 to 3 for each segment in the repeat ending.

RESULT
The selected segment is lengthened or shortened.
NOTE
This does not automatically input or reposition repeat barlines. You need to input repeat barlines
as appropriate manually.

RELATED LINKS
Moving repeat endings graphically using the Properties panel on page 554

Positions of repeat endings
You can change the positions of repeat endings by moving individual repeat endings to different
rhythmic positions in Write mode, moving them to different graphical positions in Engrave mode,
and by changing the default positions of all repeat endings project-wide.
You can move repeat endings to different rhythmic positions in Write mode. They are positioned
by default according to your preferences in Engraving Options.
You can move repeat endings graphically in Engrave mode, however this does not change the
rhythmic positions to which they are attached.
You can set project-wide options for the appearance and position of repeat endings on the
Repeat Endings page in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for repeat endings on page 550
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Moving repeat endings rhythmically
You can move repeat endings to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the repeat endings you want to move.

2.

Move the repeat endings to the next or previous bar in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the repeat endings to the right or to the left.

RESULT
The selected repeat endings are moved to the next or previous bar.
NOTE
This does not automatically input or reposition repeat barlines. You must input repeat barlines
manually as appropriate.
NOTE
Only one repeat ending can exist at each rhythmic position. If any part of a selected repeat
ending collides with any part of another repeat ending as part of its move, the other repeat
ending is deleted.
However, its repeat barlines are not deleted.
NOTE
If you moved repeat endings using the keyboard, you can undo the move to restore any repeat
endings deleted in the process.
However, if you moved repeat endings using the mouse, undoing the move does not restore any
repeat endings deleted in the process.
Moving repeat endings back to their previous positions later does not restore any repeat endings
deleted when they were moved previously. The deleted repeat endings must be re-input if
necessary.

RELATED LINKS
Positions of repeat endings on page 552

Moving repeat endings graphically
You can move repeat endings graphically without changing their rhythmic positions.
PROCEDURE
1.

2.

In Engrave mode, select one of the following that you want to move:
●

Whole repeat endings

●

Individual repeat ending segments

Move the repeat endings or segments in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.
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●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move repeat endings and segments by larger increments, you
can press Ctrl/Cmd as well as the standard key command, for example, Ctrl/
Cmd-Alt-Left Arrow.

●

Click and drag the selected repeat endings or segments in any direction to the
positions you want.

RESULT
The graphical positions of the selected repeat endings or repeat ending segments are changed.
NOTE
You can reset the graphical positions of repeat endings at any time by deactivating the Start
X offset, End X offset, and Y offset properties in the Repeat Endings group of the Properties
panel.

RELATED LINKS
Moving repeat endings rhythmically on page 553
Lengthening and shortening final segments in repeat endings with the keyboard on page 551
Individual changes to the appearance of repeat endings on page 555
Moving repeat endings graphically using the Properties panel on page 554

Moving repeat endings graphically using the Properties panel
You can move repeat endings graphically using the Properties panel.
PROCEDURE
1.

In Engrave mode, select the repeat ending segments that you want to move.

2.

Activate the following properties, individually or together, in the Repeat Endings group of
the Properties panel:

3.

4.

●

Start X offset

●

End X offset

●

Y offset

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move repeat ending segments in the following ways:
●

Start X offset moves the start of repeat ending segments horizontally: increasing
the value moves the start of repeat ending segments to the right, decreasing the
value moves the start of repeat ending segments to the left.

●

End X offset moves the end of repeat ending segments horizontally: increasing the
value moves the end of repeat ending segments to the right, decreasing the value
moves the end of repeat ending segments to the left.

●

Y offset moves repeat ending segments vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.
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Deleting repeat endings
PROCEDURE
1.

In Write mode, select the repeat endings you want to delete.

2.

Delete the repeat endings in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected repeat endings are deleted.
NOTE
Any repeat barlines input as part of the deleted repeat endings are not deleted automatically.

RELATED LINKS
Deleting barlines on page 227

Individual changes to the appearance of repeat endings
You can change the appearance of individual repeat endings, independently of your project-wide
settings on the Repeat Endings page in Engraving Options.
In Engrave mode, each segment in repeat endings has two square handles.

You can select these handles in the following ways:
●

Select the repeat ending or segment and press Tab to cycle through handles until the one
you want to move is selected.

●

Click the handle.

Once selected, you can move handles to new graphical positions in the same ways as moving
whole repeat endings graphically.
RELATED LINKS
Project-wide Engraving Options for repeat endings on page 550
Moving repeat endings graphically on page 553
Moving repeat endings graphically using the Properties panel on page 554

Changing the text shown in repeat endings
You can override the text shown in individual segments in repeat endings.
PROCEDURE
1.

In Engrave mode, select the segments whose text you want to change.

2.

Activate the Custom text property in the Repeat Endings group of the Properties panel.

3.

Enter the new text you want into the value field.
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RESULT
The text shown in the selected segments is changed.
NOTE
You can revert the text back to the default setting at any time by deactivating the Custom text
property.

Changing the appearance of individual final repeat ending segments
You can change the appearance of the lines in the final segments of repeat endings
independently of your project-wide settings in Engraving Options.
PROCEDURE
1.

Select the repeat endings whose final segment appearance you want to change. You can
do this in Write mode and Engrave mode.

2.

Activate the End of line property in the Repeat Endings group of the Properties panel.

3.

Select one of the following options from the menu:
●

Open, short

●

Open, up to barline

●

Closed

RESULT
The end of the line of the final segment in the selected repeat endings is changed according to
your selection.
NOTE
You can change the appearance of final segments in all repeat endings project-wide in the
Segments section of the Repeat Endings page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for repeat endings on page 550

Changing the hook length of individual repeat endings
You can change the length of the hooks in repeat endings individually, independently of your
project-wide settings.
PROCEDURE
1.

In Engrave mode, select the repeat endings whose hook lengths you want to change.

2.

Activate the Hook length property in the Repeat Endings group of the Properties panel.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing the value makes repeat ending hooks longer.
Decreasing the value makes repeat ending hooks shorter.
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Importing and exporting repeat endings in MusicXML files
RELATED LINKS
Project-wide Engraving Options for repeat endings on page 550

Importing and exporting repeat endings in MusicXML files
Repeat endings are imported from MusicXML files and exported in MusicXML files.
However, segments in the middle of sets of endings cannot have an open right-hand end,
despite this being technically possible to represent in MusicXML.
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Rests are markings that indicate no note is played for the rhythmic value indicated by the rest.
Each note duration has an equivalent rest, for example, a quarter note rest is different to a
sixteenth note rest.
All notes and rests within a bar must add up to the duration of the bar.
The table shows some examples of notes and the rests with the equivalent rhythmic value.
Note

Rest

Dorico automatically fills the gaps between notes with rests of the appropriate duration. These
are known as implicit rests, because they are implied by the gaps between the notes. Dorico
notates implicit rests according to the current time signature, for example, different implicit rests
are shown in 6/8 compared to 4/4.
Therefore, it is not necessary to input rests in Dorico as implicit rests are automatically shown
around the notes that you input. You can turn implicit rests into explicit rests by forcing their
duration to be fixed.

A quarter note input at the fourth eighth note of the bar with different implicit rests at the beginning of the
bar in different time signatures

Explicit rests are rests that are explicitly entered during note input by forcing their duration, or
rests that were explicitly created by way of importing a MusicXML file. Explicit rests cannot be
suppressed when using the Starts voice and Ends voice properties to hide rests before the first
note in voices and after the last note in voices.
You can show rest colors to see which rests are implicit and which are explicit in your project.
RELATED LINKS
Forcing the positions and durations of rests on page 560
Turning explicit rests into implicit rests on page 562
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General placement conventions for rests
Hiding rests after the last note in voices on page 715
Hiding rests before the first note in voices on page 715
Showing rest colors on page 560

General placement conventions for rests
Rests should be positioned at the rhythmic position at the start of their duration, and not in the
middle of beats as this can cause confusion over when the rest begins and ends. Rests should be
aligned with other items at the same rhythmic position.
The only exception is whole bar rests, which are positioned at the visual center of bars. This way,
they are clearly distinguishable from half note and whole note rests that are followed by notes in
the same bar.
Rests stay within the staff wherever possible. They do not move above or below the staff when
the notes around them are very high or very low.
However, in staves with multiple voices, rests are placed higher in the staff, or above the staff, for
up-stem voices and lower in the staff, or below the staff, for down-stem voices.

An example of rest positions in a multi-voice context

Rests in multiple voices should not overlap. You can consolidate rests so that only one is shown
when multiple voices have a rest of the same duration at the same rhythmic position.
The precise vertical positioning of rests is limited, as their detailed shapes require specific
positions relative to staff lines and staff spaces.
RELATED LINKS
Deleting rests on page 561
Turning explicit rests into implicit rests on page 562

Project-wide Notation Options for rests
There are a number of options for how rests are positioned, notated, and when rests are shown
project-wide that you can choose from on the Rests page in Notation Options.
For example, you can change whether bar rests are shown in additional voices, when dotted
rests are permitted, and the default positions of rests in different contexts.
You can open Notation Options in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

You can then choose Rests from the Category menu.

Project-wide Engraving Options for rests
Options for the appearance of rests project-wide can be found on the Rests page in Engraving
Options.
The options on this page allow you to change the style, appearance, and precise position of rests,
including multi-bar rests.
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Forcing the positions and durations of rests
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Rests in the page list on the left of the dialog.

Forcing the positions and durations of rests
Dorico automatically notates rests as appropriate, according to their position in the bar and the
time signature. If you want rests to have specific durations regardless of their rhythmic position,
you can force their duration and position.
PROCEDURE
1.

Select the rests whose position and duration you want to force. You can do this in Write
mode and Engrave mode.

2.

Activate the Force position and duration property in the Notes and Rests group of the
Properties panel.

RESULT
The selected rests become explicit rests. Rests with forced durations and positions can be
notated as required. If moved, they keep the same notation.
EXAMPLE

Default quarter note rest

The same rest shown as two eighth note rests with
forced durations.

Showing rest colors
You can show implicit rests and explicit rests in different colors.
PROCEDURE
●

To show rest colors, choose View > Note and Rest Colors > Implicit Rests.
●

A tick is shown beside the Implicit Rests option in the menu when rest colors are
shown.

●

No tick is shown beside the Implicit Rests option in the menu when rest colors are
not shown.

RESULT
Rests in your project appear gray if they are implicit, and appear black if they are explicit.
For example, this can be useful to help diagnose why rests do not disappear when you activate
the Starts voice and Ends voice properties, as these properties only hide implicit rests.
Once you have identified rests as explicit rests, you can delete them. The implicit rests that
replace them now respect the Starts voice and Ends voice properties.
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EXAMPLE

Rests colored black, as they appear without implicit
rests shown

Rests colored gray to show implicit rests

RELATED LINKS
Deleting rests on page 561

Visibility of rests
You can hide implicit rests by activating the Starts voice and Ends voice properties in the Notes
and Rests group of the properties panel.
These properties suppress all rests before the note or after the note, up to the start or the end of
the flow.
You can also suppress implicit rests in any gaps between different voices that might occur in the
middle of a flow, using the same properties.
NOTE
This requires you to set Ends voice on the last note of the first voice, and Starts voice on the first
note of the second voice, if the gap between those notes spans multiple barlines.

RELATED LINKS
Hiding rests before the first note in voices on page 715
Hiding rests after the last note in voices on page 715

Deleting rests
You can delete both implicit rests and explicit rests.
NOTE
If you want to delete rests because multiple rests of the same duration appear at the same
position as a result of having multiple voices in the staff, you can choose to consolidate these
rests in the Rest position section of the Rests page in Notation Options.

PROCEDURE
1.

In Write mode, select the rests you want to delete in one of the following ways:
●

Hold down Ctrl/Cmd and select each rest individually.

●

Select a whole staff from which you want to delete all rests by selecting the first note
in the staff, holding down Shift, and selecting the last note in the staff.

●

Select a whole staff from which you want to delete all rests by selecting the first note
in the staff and choosing Edit > Select To End Of System or Edit > Select To End Of
Flow.

●

Multiple staves from which you want to delete all rests by selecting one whole staff
at the top of the range of staves from which you want to delete all rests, holding
down Shift, and selecting the staff at the bottom of the range of staves from which
you want to delete all rests.
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NOTE
You can also select the bottom staff in the range, hold down Shift, and select the
top staff in the range.
●
2.

Make a marquee selection that contains all the rests you want to delete.

Choose Edit > Remove Rests.

RESULT
All rests in the selection are deleted. This is done by setting the properties for Starts voice and
Ends voice in the Notes and Rests group of the Properties panel so that no rests are shown
where you removed them.
NOTE
You can undo deleting rests immediately.
You can also show rests again later by selecting the notes or rests immediately to the left or right
of deleted rests and deactivating the corresponding Starts voice or Ends voice properties in the
Notes and Rests group of the Properties panel.

RELATED LINKS
Rests on page 558
Showing rest colors on page 560
Visibility of rests on page 561
Hiding rests before the first note in voices on page 715
Hiding rests after the last note in voices on page 715
Project-wide Notation Options for rests on page 559

Turning explicit rests into implicit rests
Implicit rests and explicit rests behave differently. For example, you can hide implicit rests can
be hidden using the Properties panel, whereas you cannot hide explicit rests or rests with forced
durations.
You may want to turn explicit rests into implicit rests so you can activate the Starts voice and
Ends voice properties in the Notes and Rests group of the Properties panel to hide rests in
multi-voice contexts.
PROCEDURE
1.

In Write mode, select the explicit rests you want to turn into implicit rests.

2.

Turn the selected explicit rests into implicit rests in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected explicit rests are now implicit rests. You can check this by showing rest colors.
RELATED LINKS
Showing rest colors on page 560
Hiding rests after the last note in voices on page 715
Hiding rests before the first note in voices on page 715
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Changing the vertical position of rests individually
You can change the vertical position of rests individually, for example, if you want to change the
staff line from which a whole bar rest hangs. You can also show multiple rests for each voice in
the staff individually.
NOTE
You cannot change the vertical position of rests using the mouse.

PROCEDURE
1.

Select the rests whose vertical positions you want to change, or rests at the rhythmic
positions where you want to see rests for every voice. You can do this in Write mode and
Engrave mode.

2.

Activate the Rest pos. property.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increasing the value moves rests upwards. Decreasing the value moves rests downwards.
If there are multiple voices in the staff with rests of the same duration, multiple rests are now
shown.

Changes to the horizontal position of individual rests
The horizontal position of rests, and the spacing around them, can be changed in Engrave mode
when Note Spacing is activated, in the same ways changing the position of notes.
RELATED LINKS
Note spacing on page 171
Adjusting note spacing at individual rhythmic positions in Engrave mode on page 172
Adjusting the note spacing of individual notes, independently of their rhythmic positions on page
173
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Slurs are tapered, curved lines that join notes to indicate articulation and phrasing.
They are not to be confused with ties, which look superficially similar, but which join notes of the
same pitch to indicate that they should be played as a single note. In that sense, ties are part of
rhythmic notation, while slurs are considered articulation.
Depending on context and the instrument to which they apply, slurs can have additional
meanings to simply marking phrases.
For example, for wind players, a slur indicates that all the notes in the phrase should be played in
the same breath and without re-tonguing or re-articulating any notes.
For string players, a slur indicates that all the notes in the phrase should be played legato and
under one bow.
For singers, slurs indicate that more than one note is sung to the same syllable.

General placement conventions for slurs
Where a slur is placed relative to the staff depends on the appearance of the notes within the
slur.

Slur direction
A slur on a single staff always curves upwards, unless all of the notes under the slur are stem-up,
in which case it curves downwards.

Examples of the slur direction changing according to the stem direction

You can set your preference for whether slurs follow the stem direction, or always appear above
notes, on the Slurs page in Engrave > Engraving Options.
NOTE
It is only standard for slurs always to appear above notes in jazz scores, where a slur is
sometimes treated as an articulation and so positioning it above the staff is preferred.

Slurs between unbeamed notes
In Dorico, slurs between unbeamed notes appear between their stems, and the default setting is
for them to attach a short distance from the end of the stem.
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You can change where a slur attaches to a stem by adjusting the Vertical offset from end of
stem option on the Slurs page in Engraving Options.

Slur position relative to tie chains
The convention for slur position relative to tie chains is different for modern use and historical
editions.
Modern practice is for slurs to start from the first note in a tie chain, and end on the last note in a
tie chain.

Slur ending on the last note of a tie chain.

Slur starting from the first note in a tie chain.

However, for historical editions you might want slurs to end on the first note in a tie chain, and
start from the last note in a tie chain. Both of these changes save vertical space, as shorter slurs
do not extend as far above or below a staff.

Slur starting from the last note in a tie chain.

Slur ending on the first note in a tie chain.

You can choose whether ties start from the first or last note in a tie chain, and end on the first
or last note in a tie chain, on the Slurs page in Engrave > Engraving Options. This applies to all
slurs project-wide.
RELATED LINKS
Changing the position of slurs relative to tie chains individually on page 565

Changing the position of slurs relative to tie chains individually
You can change the position of individual slurs relative to tie chains, independently of your
project-wide setting for the position of slurs relative to tie chains.
PROCEDURE
1.

Select the slurs whose position relative to tie chains you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the following properties in the Slurs group of the Properties panel:

3.

●

Start pos. in tie chain

●

End pos. in tie chain

Choose one of the following options for each property:
●

First note
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●

Last note

Slur placement relative to grace notes
Slurs that start from a grace note, or over multiple grace notes, and attach directly to the next
standard note have special placement rules.
These rules are:
●

Slurs connect noteheads rather than stems.

●

Slurs are scaled to match the proportions of grace notes.

●

Slurs must not obscure ledger lines.

●

Slurs are placed above notes, if they would collide with the accidental of a standard note
when placed below the notes.

You can adjust the values for the different parameters of the special placement rules. For
example, you can change the vertical and horizontal offsets for the right-hand end of a grace
note slur relative to the standard, full-sized notehead to which it is attached, in the Grace Notes
section of the Slurs page in Engrave > Engraving Options.
NOTE
These rules do not apply if a slur attaches to a standard note at any rhythmic position beyond the
note immediately after the grace note.
Grace notes only appear stem down by default when there are multiple voices in a staff. When
there is only one voice in a staff, grace notes appear stem up by default, even if the notehead to
which they are attached is stem down. Therefore in Dorico, slurs appear below the grace note
and curve downwards by default.

Automatic changes to the curvature direction of slurs on grace notes in multi-voice contexts

You can change the automatic placement of grace note slurs by changing the stem direction of
a grace note, changing the direction of a slur, and using the slur handles in Engrave mode to
adjust the position of a slur in finer detail.
RELATED LINKS
Changing the curvature direction of slurs individually on page 583
Changing the stem direction of grace notes individually on page 386

Slur position relative to staff lines
Slur endpoints should not touch staff lines, and Dorico handles this automatically.
In addition, the high point of the arc curves should not stop on a staff line; however, Dorico does
not yet automatically prevent this happening.
This is the convention because a slur whose arc peaks on a staff line can create the appearance
of a triangular wedge between the staff line and the curve of the slur.
If a slur stops on a staff line, you can adjust its height so that it peaks either above or below the
staff.
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You can set a value for the minimum distance between slur endpoints and staff lines on the Slurs
page of Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for slurs on page 575
Changing the height of slurs individually on page 580

Slur endpoint position relative to other items
You can change the default positions of slur endpoints relative to noteheads, stems,
articulations, ties and other slurs, and staff lines.

Slur endpoints relative to noteheads and stems
The default position of slur endpoints relative to noteheads is 1/2 space above a notehead in a
space on the staff, and 1/4 space above a notehead on a line on the staff.
Vertical and horizontal offsets for the ends of slurs can be set in the Endpoint Positioning
section of the Slurs page in Engraving Options. However, you may also need to reduce the value
for Minimum gap inside slur curvature to avoid collisions, as endpoints cannot be closer to
noteheads than the value of this option.
NOTE
This value affects all collisions, so you should check how changing this affects other areas in your
project.

Slur endpoints relative to articulations
By default, articulations of force and stress go above the slur, and articulations of duration go
below the ends of a slur, which automatically raises the endpoints.
You can position slur endpoints closer to articulations by reducing the value for Minimum gap
inside slur curvature to avoid collisions in the Avoiding Collisions section of the Slurs page in
Engraving Options.
NOTE
Changing this value affects the position of slur endpoints project-wide. You may find it more
appropriate to move slur endpoints relative to articulations individually in Engrave mode.

Slur endpoints relative to ties and other slurs
The default position of slur endpoints is 1/4 space above an existing slur that starts or ends on
the same note.
You can change this by increasing or decreasing the value for Minimum vertical gap between
two slurs starting or ending on the same note, found under Vertical Positioning in the
Avoiding Collisions section of the Slurs page in Engraving Options.
To make slurs appear closer to tied notes, you can adjust the values for slur endpoint position
relative to noteheads.

Slur endpoints relative to staff lines
The default position of slur endpoints relative to staff lines is 1/4 space above or below, to ensure
the start and end points do not touch the staff line.
You can change this by increasing or decreasing the value for Minimum distance between slur
endpoint and staff line, found under Vertical Positioning in the Avoiding Collisions section of
the Slurs page in Engraving Options.
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Inputting slurs during step input
RELATED LINKS
Project-wide Engraving Options for slurs on page 575
Slurs in Engrave mode on page 575

Inputting slurs during step input
You can input slurs directly during step input.
PROCEDURE
1.

In Write mode, start note input.

2.

Start a slur from the currently selected note in any of the following ways:
●

Press S.

●

Click Slur in the Notes panel:

3.

Input the notes you want. The slur extends automatically, even if there are rests between
the notes you input.

4.

Press Shift-S to end the slur on the currently selected note.

RELATED LINKS
Inputting notes on page 94

Adding slurs to existing notes
You can add slurs to notes after they have been input. You can add slurs to multiple staves at the
same time.
PROCEDURE
1.

In Write mode, select the notes to which you want to add slurs.
If you only select one note, the slur connects that note to the next note on the staff.

2.

Add a slur in any of the following ways:
●

Press S.

●

Click Slur in the Notes panel:

Alternatively, click Slur in the Notes panel first, and then click and drag to input a
slur and extend it to your preferred length.
RESULT
The selected notes are connected by slurs. If you select notes in multiple staves, for example, if
you select two notes in one staff and two notes in another staff, two slurs are input. They connect
the notes in each selected staff.

Inputting cross-staff slurs
In grand staff instruments, such as piano and harp, sometimes a phrase starts on one staff and
ends on the other, and should be joined by a slur.
You can input slurs that start on one staff and end on another staff.
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PROCEDURE
1.

In Write mode, select the note where you want the slur to start.

2.

Ctrl/Cmd-click the note where you want the slur to end. Only those two notes should be
selected.

3.

Input a slur in any of the following ways:
●

Press S.

●

Click Slur in the Notes panel:

RESULT
A slur is added spanning the notes selected. It is placed either above or below the group of
notes, depending on the stem direction within the selection. This can be across two or more
staves.
NOTE
You can also change the curvature direction of individual slurs.

RELATED LINKS
Changing the curvature direction of slurs individually on page 583

Inputting cross-voice slurs
Cross-voice slurs are slurs that start in one voice but end in a different voice.
Dorico positions cross-voice slurs in the same way as it positions standard slurs, so their
appearance may be the same as standard slurs. However, cross-voice slurs do not behave in the
same way when you move, lengthen, or shorten them.
A cross-voice slur cannot be lengthened if the next note in the same voice as the one the slur
started or ended in is too far away. It also cannot be shortened if noteheads under the slur are in
a different voice to the one the slur started or ended in.
Similarly, a cross-voice slur cannot be moved if the next note in the same voice as the one the
slur started or ended in is too far away, in either direction.
The different voices can be on the same staff, or on different staves.
PROCEDURE
1.

In Write mode, select the note from which you want the slur to start, in any voice.

2.

Hold Ctrl/Cmd and click the note on which you want the slur to end, in any voice.

3.

Input a slur in any of the following ways:
●

Press S.

●

Click Slur in the Notes panel:

RESULT
A cross-voice slur is added spanning the notes selected. It is placed either above or below the
notes, depending on the stem direction within the selection.
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Nested slurs
Nested slurs are two or more slurs used simultaneously, where the overarching slur shows the
structure of the phrase and the inner slurs show the articulation within the phrase. They are also
known as “slurs within slurs”.
Depending on your settings on the Slurs page in Engrave > Engraving Options, inner slurs may
appear on the opposite side of the staff to the outer slur.

A phrase with nested slurs.

You can increase or decrease the project-wide value for the Minimum vertical gap between
two slurs starting or ending on the same note setting, in the Avoiding Collisions section of
the Slurs page of Engraving Options.
Nested slurs can be added in the same way as ordinary slurs, and Dorico makes automatic
adjustments to their positioning to avoid collisions if you have not activated the Disable auto
curve adjustment property in the Properties panel in Engrave mode.
RELATED LINKS
Inputting nested slurs during step input on page 570
Adding nested slurs to existing notes on page 571
Deactivating slur collision avoidance for individual slurs on page 587

Inputting nested slurs during step input
You can input nested slurs directly during step input.
PROCEDURE
1.

In Write mode, start note input.

2.

Start two slurs from the currently selected note in any of the following ways:
●

Press S twice.

●

Click Slur twice in the Notes panel:

One slur is the inner slur, the other slur is the outer slur.
3.

Input the notes you want. The slurs extend automatically as you continue inputting notes,
even if there are rests between the notes you input.

4.

Press Shift-S once to end the inner slur on the currently selected note.

5.

Continue inputting notes.

6.

Press Shift-S then again to end the outer slur on the currently selected note.
NOTE
You can also start another inner slur by pressing S before ending the outer slur.
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Adding nested slurs to existing notes
You can add slurs to existing notes that are nested within another slur.
PROCEDURE
1.

In Write mode, select the notes you want to include in the outer slur.

2.

Press S.

3.

Select the notes within the outer slur that you want to place under an inner slur.

4.

Press S.
NOTE
You can follow these steps in any order, as Dorico automatically adjusts slurs so that
shorter slurs are positioned within longer slurs, and makes sure they do not collide.
Slur collisions are not automatically avoided if you activate the Disable auto curve
adjustment property in the Slurs group of the Properties panel for individual notes.

RELATED LINKS
Slur collision avoidance on page 586

Moving slurs
You can move slurs to new rhythmic positions after they have been input.
They are positioned according to your project-wide settings on the Slurs page in Engraving
Options.
PROCEDURE
1.

In Write mode, select the slurs you want to move.
NOTE
Only move one slur can be moved rhythmically at a time when using the mouse.

2.

Move the whole slurs to the next or previous noteheads on the staff in any of the following
ways:
●

Press Alt-Right Arrow to move them to the next notehead on the staff.

●

Press Alt-Left Arrow to move them to the previous notehead on the staff.

●

Click and drag the slur to the right or to the left.

RESULT
The slurs are moved to the next or previous noteheads on the staff.
NOTE
The rhythmic duration of slurs is usually maintained. However, depending on the rhythms they
cross as they move, slurs may end up covering longer or shorter durations than before they were
moved.
You can adjust the shape and position of individual slurs graphically in Engrave mode.

RELATED LINKS
Slurs in Engrave mode on page 575
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Lengthening and shortening slurs
You can change the length of slurs rhythmically after they have been input.
PROCEDURE
1.

In Write mode, select the slur you want to make longer or shorter.
NOTE
You cannot lengthen or shorten multiple slurs at the same time.

2.

Lengthen and shorten the slur in any of the following ways:
●

Press Shift-Alt-Right Arrow to move the right end of the slur to the next notehead
in the staff.

●

Press Shift-Alt-Left Arrow to move the right end of the slur to the previous
notehead in the staff.

●

Click and drag the right end or left end of the slur to the next or previous notehead.

RESULT
The slur is lengthened or shortened.
RELATED LINKS
Moving slurs on page 571
Slurs in Engrave mode on page 575

Slur segments
A standard slur consists of one segment. You can make more elaborate shapes with slurs with
multiple segments.
Adding more segments to a slur by default creates evenly spaced waves within its length.
Therefore, having more segments makes each wave shorter.

Slur with eight segments

In Engrave mode, you can move each segment graphically, independently of the other segments
in the slur, as each segment has its own set of five square handles. This can allow you to drag a
slur into unusual and complicated shapes using the mouse, or by nudging with the arrow keys.
NOTE
You may find that you need more segments than there are curves in your planned shape, as in
many cases you need a segment for each significant change of angle.
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An unusual slur shape created using five segments.

The same slur, showing the positions of the handles
of all five segments.

Changing the number of segments in individual slurs
You can change the number of segments in individual slurs.
PROCEDURE
1.

In Engrave mode, select the slurs whose number of segments you want to change.

2.

Activate the Number of segments property in the Slurs group of the Properties panel.

3.

Change the value in the value field to increase or decrease the number of segments in any
of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The number of segments in the selected slurs is changed.

Deleting slurs
PROCEDURE
1.

In Write mode, select the slurs you want to delete.

2.

Delete the slurs in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected slurs are deleted.

Linked slurs across multiple staves
Slurs of the same duration at the same rhythmic position on multiple staves are linked together
automatically. This happens only when you copy and paste slurs between staves, or enter them
simultaneously.
If slurs are linked, that means moving one slur in the linked group moves any slurs linked to it in
the same way. Similarly, lengthening or shortening a slur in a linked group lengthens or shortens
any slurs linked to it in the same way.
However, deleting one slur in a linked group only deletes the slur selected, not the whole group.
Linked slurs appear highlighted when any slur in the linked group is selected.
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You can also manually link and unlink slurs.
RELATED LINKS
Adding slurs to existing notes on page 568
Linking slurs together on page 574
Unlinking slurs on page 574

Linking slurs together
Dorico automatically links slurs of the same duration at the same rhythmic positions together
automatically. However, you can also link slurs together manually.
PROCEDURE
1.

In Write mode, select the slurs you want to link together.
NOTE
Only slurs that have the same duration and start at the same position can be linked
together.

2.

Link the selected slurs together in any of the following ways:
●

Choose Edit > Slurs > Link.

●

Right-click and choose Slurs > Link from the context menu.

RELATED LINKS
Linked slurs across multiple staves on page 573

Unlinking slurs
You can unlink slurs manually that were previously automatically linked together.
PROCEDURE
1.

In Write mode, select a slur from each linked group you no longer want to be linked.

2.

Unlink the whole linked group of slurs in any of the following ways:
●

Choose Edit > Slurs > Unlink.

●

Right-click and choose Slurs > Unlink from the context menu.

RESULT
All slurs linked to the selected slurs are unlinked.
RELATED LINKS
Linked slurs across multiple staves on page 573
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Project-wide Engraving Options for slurs
Options for the position, placement, and appearance of slurs project-wide can be found on the
Slurs page in Engraving Options.
The options on this page allow you to change the direction, style, height, and thickness of slurs.
You can also set precise values for the positions of slurs relative to noteheads, stems, grace
notes, and ties.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Slurs in the page list on the left of the dialog.

Slurs in Engrave mode
In Engrave mode, each slur has five square handles that can be moved separately. When using
slur handles to edit slurs in Engrave mode, each handle adjusts the corresponding part of the
slur.
NOTE
However, this may also affect the positions of other slur handles.
For example, moving the left endpoint moves the left end of a slur, but the rest of the handles
stay in their existing positions. However, moving the right control point also causes the slur
height handle to move. This gives you fine control over the shape of ties, while ensuring the end
result remains curved and smooth.

You can move these handles to change the shape of slurs with the keyboard, with the mouse,
and by using properties in the Slurs group of the Properties panel.
RELATED LINKS
Slur shoulder offset on page 581
Slur height on page 580

Changing the shape of slurs individually
You can change the shape of individual slurs by moving their handles to different positions. This
only changes the appearance of slurs, and does not change the rhythmic positions to which they
are attached.
PROCEDURE
1.

In Engrave mode, select the slur handles whose position you want to change in any of the
following ways:
●

Select a whole slur and press Tab to cycle through the handles until the one you
want to move is selected.
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2.

●

Click the handle you want to move.

●

Ctrl/Cmd-click individual handles on multiple slurs.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the handles in any direction to the positions you want.

RELATED LINKS
Slur height on page 580
Slur shoulder offset on page 581

Changing the shape of slurs individually using the Properties panel
You can change the shape of individual slurs by moving their handles using the Properties panel.
This only changes the appearance of slurs, and does not change the rhythmic positions to which
they are attached.
PROCEDURE
1.

2.

3.

4.

In Engrave mode, select the slur handle whose position you want to change in any of the
following ways:
●

Select a whole slur and press Tab to cycle through the handles until the one you
want to move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd-click individual handles on multiple slurs.

Activate the following properties, individually or together, in the Slurs group of the
Properties panel:
●

Start offset: left endpoint of slurs

●

End offset: right endpoint of slurs

●

Start handle offset: left control point of slurs

●

End handle offset: right control point of slurs

Each property has X and Y value fields. Change the values in the value fields in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move slur handles in the following ways:
●

Start offset X moves the left endpoints of slurs horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.

●

Start offset Y moves the left endpoints of slurs vertically: increasing the value
moves them upwards, decreasing the value moves them downwards.

●

End offset X moves the right endpoints of slurs horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.
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●

End offset Y moves the right endpoints of slurs vertically: increasing the value
moves them upwards, decreasing the value moves them downwards.

●

Start handle offset X moves the left control points of slurs horizontally: increasing
the value moves them to the right, decreasing the value moves them to the left.

●

Start handle offset Y moves the left control points of slurs vertically: increasing the
value moves them upwards, decreasing the value moves them downwards.

●

End handle offset X moves the right control points of slurs horizontally: increasing
the value moves them to the right, decreasing the value moves them to the left.

●

End handle offset Y moves the right control points of slurs vertically: increasing the
value moves them upwards, decreasing the value moves them downwards.

RELATED LINKS
Slur height on page 580
Slur shoulder offset on page 581

Changing the shape of multi-segment slurs individually
Each segment of multi-segment slurs, such as S-shaped slurs, can be edited independently in
Engrave mode. The inner control point works in parallel with the corresponding inner control
point of the neighboring segment to ensure a smooth and symmetrical shape.
The outer control points for each segment in S-shaped slurs, the ones closest to the tapered
ends, can be moved independently.
The inner control points, the ones closest to the center of a slur, can be moved independently
on the vertical axis, but their movement on the horizontal axis is mirrored by the corresponding
inner control point on the adjacent segment.
This is designed to avoid tight corners, so that multi-segment slurs are always as smoothly
curved as possible.
NOTE
You can move slur handles in S-shaped slurs in the same ways as for any other slur.
EXAMPLE

RELATED LINKS
Slurs in Engrave mode on page 575
Changing the shape of slurs individually on page 575
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Changing the angle or rotation of slurs individually without
affecting their shape
You can change the angle or rotation of slurs individually without affecting their shape.
This is useful, for example, if you want one end of a slur to start higher after a system break than
its default position, you can change the rotation of the slur while keeping all slur handles on the
slur in the same positions relative to each other.
PROCEDURE
1.

In Engrave mode, select an endpoint on the slurs whose angle you want to change.
NOTE
You can select individual handles on multiple slurs by holding down Ctrl/Cmd and clicking.

2.

Hold down Alt and click and drag the endpoints to the positions you want.
You cannot use the keyboard to change the angles of individual slurs.

RESULT
The angle or rotation of the selected slurs is changed without affect their shape.
EXAMPLE

Moving endpoints without holding Alt

Moving endpoints while holding Alt

Short slurs that cover large pitch ranges
When short slurs span large pitch ranges, they are significantly rotated to compensate. This can
make the ends of short slurs appear too angular.
You can move the control point handles of slurs to improve their curves, as shown in the
example slur in the middle.
The example on the right shows handles have been moved poorly, making the curve far too
angular.
In the bottom row, you can see how the handles have been placed to create the curve of each
example slur.

Short slur spanning a large pitch
range, without adjustment

The same slur with some shape
adjustment, making the curve
smoother
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Default slur handle placement

Slur handle placement to create
the slur above

Slur handle placement to create
the slur above

TIP
When adjusting curve ends, the best results are achieved using the following guidelines:
●

The control point at the lower end of the slur does not extend outside the width of the slur,
as marked by its neighboring endpoint.

●

The control point at the higher end of the slur does not form an angle greater than 90
degrees relative to the endpoints. You can use the dashed guidelines to help you judge
this.

You can adjust the shape of curve ends in short slurs in three ways:
●

Project-wide, by increasing the value for Offset shoulders by fraction of half length of
short slur, found by disclosing Advanced Options in the Design section of the Slurs page
in Engrave > Engraving Options.

●

Individually, by activating the Start handle offset and End handle offset properties in the
Properties panel, and changing their X value fields.

●

Individually, by moving the handles of slurs in Engrave mode.

RELATED LINKS
Slurs in Engrave mode on page 575
Project-wide Engraving Options for slurs on page 575
Changing the shape of slurs individually using the Properties panel on page 576
Changing the shape of slurs individually on page 575

Changing the thickness of slurs individually
You can change the thickness of individual slurs, independently of your project-wide settings for
the thickness of slurs.
You can change the thickness of the middle of slurs independently of the ends of slurs.
PROCEDURE
1.

In Engrave mode, select the slurs whose thickness you want to change.

2.

Activate the following properties, individually or together, in the Slurs group of the
Properties panel:

3.

●

End thickness

●

Middle thickness

Change the values in the value fields in any of the following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

RESULT
Increasing the values makes the corresponding part of the selected slurs thicker.
Decreasing the values makes the corresponding part of the selected slurs thinner.

579

Slurs
Slur height
NOTE
You can revert the thickness of the slurs to your default settings at any time by deactivating the
corresponding properties.

Slur height
Slur height is how far above or below notes slurs extend vertically.
You can change values for the heights of all slurs project-wide on the Slurs page in Engraving
Options. You can also change the height of individual slurs in Engrave mode.
Increasing the height of slurs makes them extend further from the staff. This gives them a
rounder shape, which takes up more vertical space. Where vertical space is limit, a balance must
be found between how curved slurs are, which can help readability for players, and ensuring
staves do not overlap.

A long slur with default height

A long slur with increased height

A long flat slur with default height

A long flat slur with increased height

NOTE
You can change the project-wide settings for the height of short slurs, short flat slurs, long slurs,
and long flat slurs by disclosing Advanced Options in the Design section of the Slurs page in
Engrave > Engraving Options.

RELATED LINKS
Changing the height of slurs individually on page 580
Project-wide Engraving Options for slurs on page 575

Changing the height of slurs individually
You can change the height of individual slurs by moving their slur height handles, which is the
middle handle on slurs in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the slur height (middle) handle of the slurs whose height you want
to change.

2.

Move the slur height handles in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
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TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.
●

Click and drag the handles upwards or downwards to the height you want.

RESULT
The height of the selected slurs is changed.
NOTE
To maintain a visually pleasing and symmetrical curve when changing the height of a slur
manually, you may need to move the slur height handle to the right or to the left by a small
amount, as well as upwards or downwards.

Slur shoulder offset
Slur shoulders affect the angles of the curves of slurs as they taper towards an endpoint, as the
tapered ends often approach noteheads at a steeper angle than that of a slur’s arch.
Increasing the shoulder offset makes the onset of the curve shallower, whereas decreasing the
shoulder offset makes the onset steeper.

A long slur with default shoulder
offset of 1/5

A long slur with increased
shoulder offset of 1

A long slur with decreased
shoulder offset (-1/5)

You can change the project-wide settings for the shoulder offset of slurs and the shoulder offset
of flat slurs by changing the values of the following options, found by disclosing Advanced
Options in the Design section of the Slurs page in Engraving Options.
●

Offset shoulders by fraction of half length of short slur

●

Offset shoulders by fraction of half length of long slur

●

Offset shoulders by fraction of half length of flat slur

You can adjust the shoulders of individual slurs in Engrave mode.
RELATED LINKS
Changing the shoulder offset of slurs individually on page 581
Changing the shoulder offset of slurs individually using the Properties panel on page 582

Changing the shoulder offset of slurs individually
You can adjust the shoulders of individual slurs by moving their control point handles. You can
move each control point independently of the other one.
PROCEDURE
1.

In Engrave mode, select one of the control point handles of the slurs whose shoulders you
want to adjust.
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NOTE
You can select individual handles on multiple slurs.
2.

Move the handles in any of the following ways:
●

Press Alt-Up Arrow to move them to the right.

●

Press Alt-Down Arrow to move them to the left.

●

Press Alt-Right Arrow to move them upwards

●

Press Alt-Left Arrow to move them upwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●
3.

Click and drag the handles in any direction to the positions you want.

Optional: Repeat steps 1 and 2 for the other control point handles.

RESULT
The shoulder offset of the selected slurs is changed.
RELATED LINKS
Slur shoulder offset on page 581
Project-wide Engraving Options for slurs on page 575

Changing the shoulder offset of slurs individually using the
Properties panel
You can change the shoulder offset of individual slurs by using the Properties panel.
PROCEDURE
1.

In Engrave mode, select the slurs whose shoulder offset you want to change.

2.

Activate the following properties, individually or together, in the Slurs group of the
Properties panel:

3.

4.

●

Start handle offset

●

End handle offset

Each property has X and Y value fields. Change the values in the value fields in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move slur handles in the following ways:
●

Start handle offset X moves the left control points of slurs horizontally: increasing
the value moves them to the right, decreasing the value moves them to the left.

●

Start handle offset Y moves the left control points of slurs vertically: increasing the
value moves them upwards, decreasing the value moves them downwards.

●

End handle offset X moves the right control points of slurs horizontally: increasing
the value moves them to the right, decreasing the value moves them to the left.

●

End handle offset Y moves the right control points of slurs vertically: increasing the
value moves them upwards, decreasing the value moves them downwards.
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RESULT
The shoulder offset of the selected slurs is changed.
RELATED LINKS
Project-wide Engraving Options for slurs on page 575
Changing the shoulder offset of slurs individually on page 581

Slur curvature direction
You can change the curvature direction of individual slurs, independently of your project-wide
settings for slur curvature.
The following options for slur curvature direction are available when you activate the Direction
property in the Slurs group of the Properties panel:
Up
Forces slurs to curve upwards, and appear above notes.

Down
Forces slurs to curve downwards, and appear below notes.

Up/Down (mirrored S-shape)
Forces slurs to comprise of two segments: the first curves upwards, the second
curves downwards in a mirrored S-shape. It is typically used when phrases start in
the lower staff and end in the upper staff, for example, in piano parts.

Down/Up (S-shape)
Forces slurs to comprise of two segments: the first curves downwards, the second
curves upwards in an S-shape. It is typically used when phrases start in the upper
staff and end in the lower staff, for example, in piano parts.

NOTE
The precise shapes of slurs, and each slur segment, can be further adjusted in Engrave mode
using the square handles on each slur.

RELATED LINKS
Slurs in Engrave mode on page 575
Changing the shape of slurs individually on page 575

Changing the curvature direction of slurs individually
You can make individual changes to the curvature direction of slurs.
PROCEDURE
1.

Select the slurs whose curvature direction you want to change. You can do this in Write
mode and Engrave mode.
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2.

Activate the Direction property in the Slurs group of the Properties panel.

3.

Choose one of the following options:
●

Up

●

Down

●

Up/Down (mirrored S-shape)

●

Down/Up (S-shape)

RESULT
The curvature direction of the selected slurs is changed.
NOTE
You can adjust the precise shapes of slurs, and each slur segment, in Engrave mode using the
handles on each slur.

RELATED LINKS
Slur curvature direction on page 583
Slurs in Engrave mode on page 575

Slur styles
Activating the Style property in the Slurs group of the Properties panel allows you to change the
style of slurs individually.
Choose from the following options:
Solid
The slur appears as a tapered solid line. It is thinner at the ends and thicker in the
middle.
This is the default style for slurs.
Dashed
The slur appears as a tapered dashed line.
Dotted
The slur appears as a dotted line. The dots are the same size and the same distance
apart over the whole length of the slur.
Half-dashed start
The first half of the slur appears as a dashed line, the second half as a solid line. It is
used to denote that a slur was written incompletely in the source in critical editions.
Half-dashed end
The first half of the slur appears as a solid line, the second half as a dashed line. It is
used to denote that a slur was written incompletely in the source in critical editions.
Editorial
Slurs appear as a solid black line, but with a smaller vertical line intersecting the line
exactly halfway along its length. It is used to show that slurs have been added by the
editor and were not present in the original source.
NOTE
The precise parameters of each of these options can be set project-wide in Engrave > Engraving
Options. For example, you can change the height and width of the notch in Editorial slurs, the
sizes of dots and dashes, and the sizes of the gaps between dots and dashes.
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RELATED LINKS
Changing the style of slurs individually on page 585

Changing the style of slurs individually
You can change the style of slurs individually after they have been input.
PROCEDURE
1.

Select the slurs whose style you want to change. You can do this in Write mode and
Engrave mode.

2.

Activate the Style property in the Slurs group of the Properties panel.

3.

Select one of the following options from the menu:
●

Solid

●

Dashed

●

Dotted

●

Half-dashed start

●

Half-dashed end

●

Editorial

RELATED LINKS
Slur styles on page 584

Changing individual slurs to flat slurs (Curvature style)
Although they are not often used as standard, some publishers use flat slurs in order to reduce
the vertical space occupied by slurs. You can change individual slurs to flat slurs, independently
of your project-wide setting for slur style.
Short slurs, that is, slurs between only a few notes, can look odd as flat slurs, so it may not be
appropriate to select the flat curvature style project-wide. However, it would likewise be unusual
only to use flat slurs once or twice in a project.
NOTE
You can change the project-wide slur style on the Slurs page in Engrave > Engraving Options

PROCEDURE
1.

Select the slurs whose curvature style you want to change. You can do this in Write mode
and Engrave mode.

2.

Activate the Curvature style property in the Slurs group of the Properties panel.

3.

Choose one of the following options:
●

Curved

●

Flat

NOTE
It is best to avoid changing curvature style for only one or two slurs in a project. A better
effect may be to modify them rather than changing curvature style, for example, making
an individual slur thicker or thinner, adjusting the shoulder offset of slurs, or adjusting its
height using the slur height handle in Engrave mode.
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RESULT
The style of the selected slurs is changed.
NOTE
You can change the style of all slurs project-wide in the Design section of the Slurs page in
Engrave > Engraving Options

RELATED LINKS
Changing the thickness of slurs individually on page 579
Changing the height of slurs individually on page 580
Changing the shoulder offset of slurs individually on page 581
Project-wide Engraving Options for slurs on page 575

Slur collision avoidance
By default, Dorico automatically adjusts the shape and position of slurs to avoid collisions with
items under their arc.
This means that if a notehead under a slur is either higher than the others under a slur curving
upwards, or lower than the others under a slur curving downwards, the curvature of the slur is
adjusted to avoid the collision and keep the notehead under the slur.
In the Avoiding Collisions section of the Slurs page in Engrave > Engraving Options you can
choose options for how slurs are adjusted to collisions.

Slur with collision avoidance activated (default)

Slur with collision avoidance deactivated

Collision avoidance for cross-staff slurs
In the Avoiding Collisions section of the Slurs page in Engrave > Engraving Options, there is
an option to activate or deactivate collision avoidance for cross-staff slurs.
Due to the increased complexity in positioning slurs across staves, this setting tries to avoid
collisions but further manual adjustment in Engrave mode may be required.
NOTE
This setting does not apply to S-shaped slurs between staves; these slurs do not perform any
collision avoidance.

Slurs bisecting flat accidentals
According to conventions in published music, slurs can bisect the stems of flat accidentals, but
not sharps or naturals, to save vertical space.
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You can choose not to allow slurs to bisect flat signs, or alter the amount of the stems of flat
signs slurs can bisect, on the Slurs page in Engraving Options.
RELATED LINKS
Deactivating slur collision avoidance for individual slurs on page 587
Project-wide Engraving Options for slurs on page 575

Deactivating slur collision avoidance for individual slurs
You can stop individual slurs automatically adjusting to avoid collisions, independently of your
project-wide setting for slur collision avoidance.
PROCEDURE
1.

In Engrave mode, select the slurs for which you want to deactivate collision avoidance.

2.

Activate the Disable auto curve adjustment property in the Slurs group of the Properties
panel.

RESULT
Slur collision avoidance is deactivated for the selected slurs when the Disable auto curve
adjustment property is activated.
RELATED LINKS
Slur collision avoidance on page 586

Slurs over system and frame breaks
Slurs automatically cross system breaks and frame breaks.
A system or frame break divides slurs into two halves. The end of the first half of the slur, and the
start of the second half of the slur, are both positioned one space vertically outside the staff by
default.
If multiple slurs cross the same system break or frame break, such as if a phrase split by a break
contains nested slurs, the ends of the slurs are stacked automatically and spaced a minimum of
half a space apart vertically.

The end of a system showing the first half of a slur;
the end on the right shows a continuation to the
next system.

The start of the next system showing the second half
of a slur; the end on the left shows a continuation
from the previous system.

In Engrave mode, each half of a slur can be moved separately using the square handles on each
segment. This allows you to adjust the start and end height of each half of a slur independently
on each system.
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Slurs in playback
Slurs trigger the legato playing technique in playback. By default, this increases the length of the
MIDI notes without affecting the notation of the music.
Slurred notes sound for 102 % of the length indicated by their notated rhythm, as opposed to
non-slurred notes which sound for 85 % of their notated rhythm.
The final note of a slur sounds for 85% of its notated rhythm, as there is no slur after it and so the
legato technique is no longer required.
These values can be edited on the Timing page in Play > Playback Options.
The below example shows how MIDI note length, the lighter blue rectangle, is increased when
slurs are used. The first three notes are non-slurred, so the MIDI length rectangle is shorter than
the line of the notated rhythm. The last four notes are slurred, so the MIDI length is longer than
the notated length in order to create the legato, slurred sound. However, the last note of the
slurred group is not longer, as the last note of a slurred phrase is treated like a normal, nonslurred note.

A phrase in a piano staff

The same phrase in the piano roll in Play mode
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Staff labels are used to identify staves in music containing multiple players. Usually, staff labels
indicate the instrument or instruments currently playing the music in the staff or staves to which
they apply.
Staff labels are positioned to the left of systems, before the initial barline of each system.
It is usual to show instrument names in full in the staff labels for the first systems in each flow,
and abbreviated instruments names in the staff labels of subsequent systems. Using abbreviated
instrument names in staff labels allows you to save horizontal space and include more music in
each system.

Examples of staff labels on the first system in a flow

In Dorico, staff labels use the instrument names set for each instrument in the Edit Instrument
Names dialog. In the dialog, you can specify single and plurals names for each instrument, and
single and plural abbreviations for each instrument.
You do not need to number instruments manually, as Dorico automatically numbers instruments
when there are multiple players of the same type playing instruments of the same type.
For players holding multiple instruments, the staff label shows the instrument they are currently
playing automatically.
NOTE
Staff labels do not show all instruments held by players, for example, in the staff label for the first
system. You should include a comprehensive instrumentation list that includes any doubling at
the front of your score.
Dorico includes the instrument transposition, or instrument pitch, in staff labels for transposing
instruments by default. Transposing instruments are instruments whose sounding pitch is
different to the notated pitch.
You can change when instrument transpositions, or instrument pitches, are shown in staff
labels. You can also change whether the instrument transposition is shown before or after the
instrument name in staff labels.
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RELATED LINKS
Player and instrument names on page 62
Numbering instruments on page 61
Instruments on page 68
Groups on page 78
Changing the orchestral order of players on page 66
Changing instrument names on page 65
Edit Instrument Names dialog on page 63

Instrument names in staff labels
Staff labels use the instrument names set for each instrument. Staff labels can show long
instrument names and short instrument names, depending on your settings on the Staves and
Systems page in Layout Options.
●

Full staff labels use long instrument names.

●

Abbreviated staff labels use short instrument names.

You can change the instrument names for each instrument in the Edit Instrument Names
dialog in Setup mode.
NOTE
Changing instrument names does not change the layout name shown at the top of each part
layout, as that uses the layout name of the player. You can change the layout name in Setup
mode.
It is usual to number instruments when there are multiple players holding the same type of
instrument. For example, if there are four horn players in an orchestra, they are usually called
Horn 1, Horn 2, Horn 3, and Horn 4.
In Dorico, instruments are automatically numbered. This also applies to players holding multiple
instruments. For example, if an ensemble contains two flute players and a piccolo player, but the
second flute is also holding a piccolo, then the instruments are numbered in the following way:
●

Flute 1

●

Flute 2 & Piccolo 1

●

Piccolo 2

You can move individual instruments to different players if you want to change which numbered
instruments are held by each player. For example, if you wanted the second flute to double
second piccolo rather than first piccolo, you can move the piccolo parts around so that the
second flute is Flute 2 & Piccolo 2.
RELATED LINKS
Player and instrument names on page 62
Numbering instruments on page 61
Changing instrument names on page 65
Edit Instrument Names dialog on page 63
Changing layout names on page 64
Moving instruments between players on page 71

590

Staff labels
Changing the length of names shown in staff labels project-wide

Changing the length of names shown in staff labels projectwide
By default in full score layouts, full staff labels are shown on the first system of each flow, using
long instrument names, and show abbreviated staff labels, using short instrument names, on
subsequent systems. By default, staff labels in part layouts are not shown on any systems.
You can change the length of instrument names depending on their context on the Staves and
Systems page in Layout Options.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Staves and Systems from the Category menu.

3.

Select the layouts whose staff label name lengths you want to change in the Layouts list
on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

5.

6.

Select one of the following options from the Staff labels on first system menu:
●

Full

●

Abbreviated

●

None

Select one of the following options from the Staff labels on subsequent systems menu:
●

Full

●

Abbreviated

●

None

Click Apply, then Close.

RESULT
The staff labels are changed project-wide in the selected layouts, according to your selections.
You can change settings for other layouts before closing the dialog.
NOTE
You can change long instrument names and short instrument names in the Edit Instrument
Names dialog.

RELATED LINKS
Changing instrument names on page 65
Edit Instrument Names dialog on page 63
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Changing the length of names shown in staff labels at
specific positions
You can change the length of names in staff labels at specific points, independently of your
project-wide settings on the Staves and Systems page in Layout Options.
The project-wide settings for staff labels apply to each flow, not the whole project. For example,
if you want to show full staff labels on the first system in the first flow in your project, but do not
want to show full staff labels on the first system of subsequent flows, you can change the staff
labels at the start of each subsequent flow individually.
Similarly, it is often not necessary to show any staff labels in choral music, if the parts are clear
from the context. However, if a few systems in a project contain more complicated parts, solo
lines, or divisi lines, you may want to show staff labels on those systems only.
PROCEDURE
1.

In Engrave mode, select a note or rest at the position where you want to change the staff
labels. For example, to change the staff labels at the start of a new flow, select the first
note or rest in the flow.

2.

Insert a system break in one of the following ways:
●

Press Shift-S

●

Choose Engrave > Format Systems > Insert System Break

●

Click Insert System Break in the Format Systems section of the Formatting panel:

3.

Select the system break signpost.

4.

Activate the Staff labels property in the Format group of the Properties panel.

5.

Select one of the following options from the menu:
●

Full

●

Abbreviated

●

None

RESULT
The length of the instrument names shown in the staff labels at the position of the system break
are changed, according to your selection.
NOTE
The horizontal spacing is automatically adjusted so the system fills the width of the music frame.
EXAMPLE

Full staff labels shown

No staff labels shown
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Showing and hiding instrument transpositions in staff
labels
Transposing instruments, such as Horn in F and Clarinet in B♭, are commonly shown with their
transposition (or “pitch”) as part of their instrument name or layout name.
You can choose to show or hide instrument transpositions (or “instrument pitches”) in staff
labels project-wide for each layout in your project. For example, you could hide instrument
transpositions in staff labels in the full score but show them in the part.
NOTE
Depending on the options set for Show transposition in the Edit Instrument Names dialog
for each transposing instrument, they may show transpositions in staff labels even if you have
chosen to hide transpositions in staff labels in their layout.
Dorico sets common transposing instruments to follow the layout options set, including
instruments like Clarinet in ♭ and Trumpet in ♭.

To reduce the risk of confusion, uncommon transposing instruments, such as Clarinet in A or
Trumpet in E, are set to show their transposition in staff labels always.
You can change the option for Show transposition to Follow Layout Options in the Edit
Instrument Names dialog for each instrument.

PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Staves and Systems from the Category menu.

3.

Select the layouts in which you want to show or hide instrument transpositions in staff
labels in the Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

5.

Check or uncheck the box beside Show instrument pitch in staff labels.
●

Checking the box shows instrument transpositions in staff labels

●

Unchecking the box hides instrument transpositions in staff labels

Click Apply, then Close.

RESULT
Instrument transpositions are shown or hidden in staff labels project-wide in the selected
layouts.
You can change settings for other layouts before closing the dialog.
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Showing instrument transpositions before or after instrument names in full staff labels
RELATED LINKS
Changing instrument names on page 65
Edit Instrument Names dialog on page 63

Showing instrument transpositions before or after
instrument names in full staff labels
You can change the position of instrument transpositions in staff labels. They can be shown
before instrument names and after instrument names in each layout independently of other
layouts.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Staves and Systems from the Category menu.

3.

Select the layouts whose instrument transposition position you want to change in the
Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
4.

5.

Choose one of the following options for Position of instrument pitch in full staff labels:
●

Start

●

End

Click Apply, then Close.

RESULT
The position of instrument transpositions relative to instrument names is changed project-wide
in the selected layouts.
TIP
You can change settings for other layouts before closing the dialog.

RELATED LINKS
Edit Instrument Names dialog on page 63
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Staff labels for percussion kits
The staff labels shown for percussion kit staves depends on how kits are presented in your
project. Kits can be presented as 5-line staves, grids, and as single-line instruments.
Percussion kit presentation
type:

Staff label:

5-line staff

Single instrument name using
the instrument name of the
percussion kit

Grid

Multiple instrument names:
one for each kit instrument,
positioned at the staff
position of the corresponding
instrument

Example:

Staff labels for grids use a
smaller font and a different
paragraph style than normal
staff labels
Single-line instruments

Multiple instrument names:
one for each kit instrument,
positioned beside the
corresponding single-line staff
Staff labels for single-line
instruments use the same font
as for normal staff labels

You can change the player names, layout names, and instrument names of percussion kits in the
same ways as for other players and instruments.
However, to change the staff labels for percussion kits, you must change kit instrument names in
different ways for percussion kits, depending on your percussion kit presentation type:
●

5-line staff: open the Edit Instrument Names dialog from the Players panel in Setup
mode, or use the Name field in the Edit Percussion Kit dialog, to change the name of the
kit

●

Grid: open the Edit Instrument Names dialog from inside the Edit Percussion Kit dialog
in Setup mode to change the names of individual instruments

●

Single-line instruments: open the Edit Instrument Names dialog from inside the Edit
Percussion Kit dialog in Setup mode to change the names of individual instruments

The same instrument name fields and options are available for kit instruments as for normal
instruments.
NOTE
Smaller staff labels for each line in grid presentations use the Staff labels (percussion grid)
paragraph style. You can edit this paragraph style in the Engrave > Paragraph Styles dialog.
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Staff labels for percussion kits
RELATED LINKS
Edit Instrument Names dialog on page 63
Changing instrument names on page 65
Changing layout names on page 64
Changing player names on page 64
Edit Percussion Kit dialog on page 71
Changing the presentation type of percussion kits on page 688
Paragraph styles on page 152
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Stems

Stems are vertical lines that extend from noteheads that are a half note or shorter in duration. In
combination with notehead design, they allow the duration of each note to be clearly identified.
For example, quarter notes and eighth notes both have solid black noteheads and stems, but
eighth notes also have flags on their stems. 16th notes have two flags, 32nd notes have three
flags, and so on.

Notes with stems, ranging from a half note (minim) on the left to a 128th note (semihemidemisemiquaver) on
the right

The stems of notes and chords may be directed upwards or downwards, depending on the
conventions of music engraving and the context of the music. For example, in choral music on
two staves, stems in the soprano and tenor lines point up, and stems in the alto and bass lines
point down.
Notes on the middle line of the staff can be notated with their stems pointing up or pointing
down. In Dorico, the stems of notes on the middle lines of staves point down by default, but their
stem direction is automatically changed according to the notes around them.

Notes on the middle line stem up

Notes on the middle line stem down

You can change the default stem direction for notes on the middle lines of staves, and turn off
automatic adjustments of stem directions for notes on the middle lines of staves, on the Notes
page in Engraving Options.
RELATED LINKS
Project-wide Engraving Options for stems on page 597
Changing the stem direction of notes on the middle lines of staves by context on page 599
Changing the default stem direction of notes on the middle lines of staves on page 599

Project-wide Engraving Options for stems
Options for the appearance of stems project-wide can be found on the Notes page in Engraving
Options.
The options on this page allow you to change the design, collision avoidance, length, and
width of stems. You can also set when stems are stem-up or stem-down, and when stems are
shortened in various contexts.
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Project-wide Engraving Options for stems
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Notes in the page list on the left of the dialog.
RELATED LINKS
Project-wide Engraving Options for tremolos on page 663

Changing the design of stem flags project-wide
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Notes in the page list.

3.

Choose one of the following options for Flag design in the Stems section:

4.

●

Default flags

●

Straight flags

Click Apply, then Close.

RESULT
The design of all flags project-wide is changed.
EXAMPLE

Default flags

Straight flags

Changing the lengths of stems project-wide
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Notes in the page list.

3.

Change the values for any or all of the following options in the Stems section as
appropriate for your project:

4.

●

Default stem length

●

Shortened stem length for quarter (crotchet) and longer

●

Shortened stem length for eighth (quaver)

●

Shortened stem length for 16th (semiquaver) and shorter)

●

Minimum stem length for note with flag

●

Minimum stemlet length for beamed rest

Change the values in the value fields in any of the following ways:
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5.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

Click Apply, then Close.

Changing the thickness of stems project-wide
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Notes in the page list.

3.

Change the value for Stem thickness in the Stems section in any of the following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

Click Apply, then Close.

Changing the stem direction of notes on the middle lines of staves
by context
The stems of notes on the middle lines of staves can point upwards or downwards. You can
choose whether the stem direction is determined by the stem directions of the notes around
notes on the middle lines of staves, or always use the default direction.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Notes in the page list.

3.

Choose one of the following options for Stem direction for notes on the middle line of
the staff under the Stem Directions heading in the Stems section:

4.

●

Determine by context

●

Use default direction

Click Apply, then Close.

RELATED LINKS
Changing the default stem direction of notes on the middle lines of staves on page 599

Changing the default stem direction of notes on the middle lines of
staves
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Notes in the page list.

3.

Choose one of the following options for Default stem direction for notes on the middle
line of the staff under the Stem Directions heading in the Stems section:
●

Up

●

Down
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4.

Click Apply, then Close.

Stem lengths
The lengths of stems are created by default in Dorico, according to accepted standards for the
appearance of stems of notes at different positions on staves.
If you find that you need to adjust the lengths of stems, you can lengthen and shorten them in
Engrave mode.
You can later reset any changes you make to the lengths of stems and revert them to your
project-wide settings for stem length.
RELATED LINKS
Changing the lengths of stems project-wide on page 598

Lengthening and shortening stems individually
You can lengthen and shorten the stems of individual notes.
PROCEDURE
1.

In Engrave mode, select the stems you want to lengthen or shorten.

2.

Lengthen and shorten the stems in any of the following ways:
●

Press Alt-Up Arrow to make stems longer.

●

Press Alt-Down Arrow to make stems shorter.
NOTE
If you want to move lengthen and shorten stems by larger increments, you
can press Ctrl/Cmd as well as the standard key command, for example, Ctrl/
Cmd-Alt-Up Arrow.

●

Click and drag the square handles at the ends of the stems upwards or downwards
to the length you want.
NOTE
If multiple stems are selected, clicking and dragging one square handle in the
selection lengthens and shortens all selected stems by the same amount.

RESULT
The selected stems are lengthened or shortened according to their stem direction. For example,
lengthening a down-stem note by pressing Alt-Up Arrow makes the end of the stem move
downwards, away from the notehead.
RELATED LINKS
Lengthening and shortening stems individually using the Properties panel on page 601
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Lengthening and shortening stems individually using the Properties
panel
You can lengthen and shorten stems by specific values using the Properties panel in Engrave
mode.
PROCEDURE
1.

In Engrave mode, select the noteheads whose stems you want to lengthen or shorten.

2.

Activate the Stem length adjustment property in the Notes and Rests group of the
Properties panel.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
Increase the value makes stems longer. Decreasing the value makes stems shorter.

Resetting the lengths of individual stems
You can reset the lengths of stems to revert them back to your project-wide settings for stem
length.
PROCEDURE
1.

In Engrave mode, select the stems whose length you want to reset.

2.

Deactivate the Stem length adjustment property in the Notes and Rests group of the
Properties panel.

Stem directions in multi-voice contexts
When there are multiple voices on a single staff, the direction of stems is determined by the stem
direction of the voice. For example, the stems of all notes in Up-stem voice 1 point upwards and
the stems of all notes in Down-stem voice 1 point downwards.
This stem direction is followed even if the stems of notes would normally point in the other
direction, based on their position in the staff.
When there are only notes in one voice for at least a whole bar, Dorico automatically changes the
directions of stems so they point in their normal direction for their pitch.
RELATED LINKS
Automatic changes to stem directions when only one voice contains notes on page 713
General placement conventions for notes in multiple voices on page 706

Changing the stem direction of notes individually
You can change the stem direction of any note.
PROCEDURE
1.

Select the notes whose stem direction you want to change. You can do this in Write mode
and Engrave mode.

2.

Change the stem direction in any of the following ways:
●

Choose Edit > Stem > Force Stem Up
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●

Right-click and choose Stem > Force Stem Up from the context menu

●

Choose Edit > Stem > Force Stem Down

●

Right-click and choose Stem > Force Stem Down from the context menu

RESULT
The stem direction of the selected notes is changed.
NOTE
This does not change the voice to which notes belong.
EXAMPLE

Stems pointing in the same direction but in different
voices

Stems in the same direction and in the same voice

RELATED LINKS
Changing the voices of existing notes on page 709

Removing stem direction changes
You can remove changes to the directions of stems to revert them to their default stem
directions.
PROCEDURE
1.

Select the notes whose stem direction changes you want to remove.

2.

Remove stem direction changes in any of the following ways:
●

Choose Edit > Stem > Remove Forced Stem

●

Right-click and choose Stem > Force Stem Up from the context menu

RESULT
All stem direction changes for the selected notes are removed. The stems of the selected notes
revert to their default directions.

Hiding stems
Stemless noteheads are not yet supported in Dorico, however they are planned for future
versions. You can make stems short so they cannot be seen in the staff.
PROCEDURE
1.

2.

In Engrave mode, select one of the following, depending on how you want to hide stems:
●

With the keyboard or mouse: select the stems you want to hide

●

Using the Properties panel: select the noteheads whose stems you want to hide

Hide the stems in the following ways:
●

Press Alt-Down Arrow until the stems cannot be seen
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NOTE
To shorten the stem by larger increments, press Ctrl/Cmd as well.
●

Click and drag the stems towards the notehead until they cannot be seen

●

Activate the Stem length adjustment property in the Notes and Rests group of
the Properties panel, and set the value to -3

RESULT
Stems are shortened so that they do not extend beyond the notehead.
NOTE
If you later change the pitch of notes whose stems you have hidden using this method, their
stems may become partially visible. This is because stem length is automatically adjusted
depending on the position of notes in the staff. You can repeat these steps at any time to adjust
the stem length again.

RELATED LINKS
Lengthening and shortening stems individually on page 600
Lengthening and shortening stems individually using the Properties panel on page 601

Split stems for altered unisons
Split stems, also know as a “cherry stalks” or a “trees”, can be used in chords containing altered
unisons. They show the main body of the chord as normal, but with a stem branch coming off the
main stem that connects noteheads in altered unisons to the chord.

Split stem chord

You can choose to show altered unisons with split stems or with single stems project-wide on the
Accidentals page in Notation Options.
You can open Notation Options by in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

RELATED LINKS
Altered unisons on page 193
Changing how altered unisons appear project-wide on page 195
Changing how altered unisons appear individually on page 194
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Tempo marks

Tempo marks indicate how fast music should be played, often with a combination of text
instructions and metronome marks.
Text instructions are traditionally expressed in Italian, such as largo or allegretto, but these days
other languages are widely accepted. The text instruction can express simply how fast the music
should be played, but can also suggest its character too. For example, grave means slow but also
solemn and sad, and vivo means fast but also lively and possibly bouncy and sprightly.
Metronome marks show the speed by indicating how many beats should be played per minute,
or “bpm”. The more beats per minute, the faster the music. Metronome marks can be precise,
such as  = 176, or can indicate an acceptable range, such as  = 152-176. They can also be shown
in parentheses, which can be useful if the metronome mark is intended to be a guide rather than
an expectation.
A tempo mark can show just text, or just a metronome mark, or a combination of the two.
Tempo marks use a bold font with a large point size, so they are conspicuous on the page. They
do not usually use an italic font.

Types of tempo marks
There are four types of tempo mark in Dorico, although they can all be input, moved, and deleted
in the same ways.
The four types are:
Absolute Tempo Change
These indicate a defined change in tempo, and are often shown with a metronome
mark.
Gradual Tempo Change
These indicate a change in tempo over a defined period of time, such as rallentando
(slowing down) or accelerando (speeding up).
Relative Tempo Change
These indicate a change in tempo that is relative to the previous tempo, such as
mosso (movement). They often include modifiers that qualify the change, such as
poco meno mosso (a little less movement), and are not defined by a metronome mark.
You can set a relative metronome mark change as a percentage of the previous
metronome mark.
Reset Tempo
These return the tempo to the previous tempo, such as A tempo, or a previously
defined tempo, such as Tempo primo (return to the first tempo of the piece).
RELATED LINKS
The Tempo panel on page 607
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General placement conventions for tempo marks
As tempo marks usually apply to all players, they automatically apply to all staves. They always
appear above the top staff in the score, but can also be shown at multiple positions in the score.
They should be positioned above notation, such as slurs, ties, and octave lines, and are often
aligned with rehearsal marks to ensure they can be read quickly and easily.
Tempo marks should be aligned with either a time signature, or the notehead or rest at the
rhythmic position to which they apply. For example, if there is a notehead with an accidental at
the rhythmic position of a tempo mark, the tempo mark should align with the accidental.
If a repeat mark occurs mid-system and is not treated as a barline, tempo marks should align
with the repeat mark.
When a tempo mark includes both text and a metronome mark, the text should appear first,
followed by the metronome mark. When horizontal space is tight, the metronome mark may be
positioned below the tempo mark text.

Inputting tempo marks with the keyboard
You can input tempo marks with the keyboard by using the tempo popover in Write mode.
You can open the tempo popover by pressing Shift-T (T for “tempo”), or by choosing Write >
Create Tempo.
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The tempo popover with an example entry for a
tempo

The tempo button in the Notations toolbox

The tempo popover
Here are some examples of what to enter into the tempo popover, and the tempo marks that are
input as a result.
You can open the tempo popover in Write mode by pressing Shift-T), or by choosing Write >
Create Tempo.
Enter:

For tempo mark:

Adagio

Adagio

Presto  = 176

Presto q = 176 or Presto q=176
Largo (q = 52) or Largo (q=52)

Largo ( = 52)

q = 96=112 or q=96-112 or 6 = 96-112 or
6=96-112
h = 60 or h=60 or 7 = 60 or 7=60
e = 120 or e=120 or 5 = 120 or 5=120
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Enter:

For tempo mark:

e. = 90 or e.=90 or 5. = 90 or 5.=90

 = 90
rit.

rit. or rit
accel. or accel

accel.

più

più

meno

meno

Faster, with energy

Faster, with energy

This list is not comprehensive: it is intended to illustrate how you can structure your entry to
input different types of tempo marks.
NOTE
The tempo popover is case-sensitive. If you want your tempo mark to start with a capital letter,
you must type a capital letter into the popover.

RELATED LINKS
Types of tempo marks on page 604

Inputting tempo marks during step input with the keyboard
To input tempo marks during step input with the keyboard:
PROCEDURE
1.

In Write mode, start note input.

2.

Open the tempo popover in any of the following ways:
●

Press Shift-T

●

Choose Write > Create Tempo

3.

Enter the tempo you want into the popover, such as q=72 or Allegretto.

4.

Press Return to close the popover.

RESULT
The tempo mark specified is input at the caret position.

Adding tempo marks to existing music with the keyboard
To add tempo marks to existing music with the keyboard:
PROCEDURE
1.

In Write mode, select a barline, notehead, or rest at the rhythmic position where you want
to add a tempo mark.

2.

Open the tempo popover in any of the following ways:
●

Press Shift-T

●

Choose Write > Create Tempo
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3.

Enter the tempo you want into the popover, such as q=72 or Allegretto.

4.

Press Return to close the popover.

RESULT
The tempo mark specified is added at the rhythmic position of the selected barline, notehead, or
rest.

Inputting tempo marks with the mouse
Tempo marks can be input with the mouse using the Tempo panel on the right of the window in
Write mode.
You can open the Tempo panel by clicking Tempo in the Notations toolbox:

The panel can be hidden and shown using its disclosure arrow, or by pressing Ctrl/Cmd-9.
The order in which you should follow steps for inputting tempo marks with the mouse depends
on your preferences for the Creating items with the mouse option, in the Editing section of the
General page in Dorico > Preferences (key command Ctrl/Cmd-,).

The Tempo panel
The different types of tempo marks can be found in the five sections of the Tempo panel in Write
mode.

Used in This Flow
Any tempo marks already used in the flow are shown in this section, including custom tempo
marks added using the tempo popover.

Absolute Tempo Change
This section has a range of tempos with both an Italian tempo indication, and a metronome
mark. You can choose later whether the metronome mark is shown for individual tempo marks.
You can narrow the range shown in the list by adjusting the range of the sliding bar at the top.

Gradual Tempo Change
These indicate a change in tempo over a defined period of time, such as rallentando or
accelerando.
Gradual tempo changes can have modifiers added to them. Modifiers are shown are the top of
the section in boxes.
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Relative Tempo Change
These indicate a change in tempo that is relative to the previous tempo, such as mosso
(movement, or “with movement”). They often include modifiers that qualify the change, such as
poco meno mosso (a little less movement), and are not defined by a metronome mark.
Relative tempo changes can have modifiers added to them. Modifiers are shown are the top of
the section in boxes.
You can later set a relative metronome mark change as a percentage of the previous metronome
mark for individual tempo marks.

Reset Tempo
These return the tempo to the previous tempo, such as A tempo, or a previously defined tempo,
such as Tempo primo.

RELATED LINKS
Types of tempo marks on page 604

Inputting tempo marks during step input with the mouse
To input tempo marks during step input with the mouse:
PROCEDURE
1.

In Write mode, start note input.

2.

Click on a tempo mark from the available options in the Tempo panel.
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3.

If you want, you can select a modifier from the available options.
NOTE
Modifiers can only be added to a Gradual Tempo Change or a Relative Tempo Change.

RESULT
The tempo mark specified is input at the caret position.

Adding tempo marks to existing music with the mouse
To add tempo marks to existing music with the mouse:
PROCEDURE
1.

In Write mode, select a barline, notehead, or rest at the rhythmic position where you want
to add a tempo mark.

2.

Click on a tempo mark from the available options in the Tempo panel.

3.

If you want, you can select a modifier from the available options.
NOTE
Modifiers can only be added to a Gradual Tempo Change or a Relative Tempo Change.

RESULT
The tempo mark specified is added at the rhythmic position of the selected barline, notehead, or
rest.

Positions of tempo marks
You can change the positions of tempo marks by moving individual tempo marks to different
rhythmic positions in Write mode, moving them to different graphical positions in Engrave mode,
and by changing the default positions of all tempo marks project-wide.
You can move tempo marks to different rhythmic positions in Write mode. They are positioned
by default according to your preferences in Engraving Options.
You can move tempo marks graphically in Engrave mode, however this does not change the
rhythmic positions to which they are attached.
Project-wide settings for the default position and appearance of tempo marks can be set on the
Tempo page in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for tempo marks on page 611

Moving tempo marks rhythmically
You can move tempo marks to new rhythmic positions after they have been input.
PROCEDURE
1.

In Write mode, select the tempo marks you want to move.

2.

Move tempo marks according to the rhythmic grid currently set in any of the following
ways:
●

Press Alt-Right Arrow to move them to the right.
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●

Press Alt-Left Arrow to move them to the left.

●

Click and drag the tempo mark to the right or to the left to the position you want.
NOTE
Only one tempo mark can be moved at a time when using the mouse.

RESULT
The selected tempo marks are moved according to the rhythmic grid currently set.
NOTE
Only one tempo mark can exist at each rhythmic position. If a tempo mark in your selection
passes over another tempo mark as part of its move, the existing tempo mark is deleted.
If you moved tempo marks using the keyboard, you can undo the move to restore any tempo
marks deleted in the process.
However, if you moved tempo marks using the mouse, undoing the move does not restore any
tempo marks deleted in the process.
Moving tempo marks back to their previous positions later does not restore any tempo marks
deleted when they were moved previously. The deleted tempo marks must be re-input if
necessary.

Moving tempo marks graphically
You can move tempo marks graphically without changing the rhythmic positions to which they
apply.
PROCEDURE
1.

In Engrave mode, select the tempo marks you want to move.

2.

Move the tempo marks in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
NOTE
If you want to move tempo marks by larger increments, you can press Ctrl/Cmd as
well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the tempo marks in any direction the positions you want.

RELATED LINKS
Moving tempo marks graphically using the Properties panel on page 610

Moving tempo marks graphically using the Properties panel
You can move tempo marks graphically using the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the tempo marks you want to move.
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2.

Activate the Start offset property in the Tempo group of the Properties panel.

3.

The Start offset property has X and Y value fields. Change the values in the value fields in
any of the following ways:

4.

●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The property moves rehearsal marks in the following ways:
●

Start offset X moves tempo marks horizontally: increasing the value moves them to
the right, decreasing the value moves them to the left.

●

Start offset Y moves tempo marks vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.

Deleting tempo marks
PROCEDURE
1.

In Write mode, select the tempo marks you want to delete.

2.

Delete the tempo marks in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected tempo marks are deleted.

Project-wide Engraving Options for tempo marks
Options for the appearance of tempo marks project-wide can be found on the Tempo page in
Engraving Options.
The options on this page allow you to change the appearance of tempo marks, and their
position relative to the staff, time signature changes, and other items. You can also change the
appearance, thickness, and position relative to barlines of continuation lines for gradual tempo
marks.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Tempo in the page list on the left of the dialog.

Individual changes to the appearance of tempo marks
There are a number of options to change how tempo marks appear individually that you can
activate in the Tempo group of the Properties panel at the bottom of the window.
You can open the Properties panel in the following ways:
●

Press Ctrl/Cmd-8.

●

Click its disclosure arrow.
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You can activate some of these properties in both Write mode and Engrave mode. However,
there are more options available in Engrave mode.
If you change your mind at any time, deactivating any of these properties returns tempo
marks to the project-wide settings for that aspect of the tempo, which you can set on the Time
Signatures page in Engrave > Engraving Options.

Changing which tempo mark components are shown, and how they
appear
Tempo marks can include different components in different combinations, depending on your
preference or the requirements for different projects.
You can activate properties that correspond to the different components in the Tempo group of
the Properties panel. These tempo mark properties can be activated in any combination:
●

Text shown: text is shown when activated, text is hidden when deactivated.

●

Metronome mark shown: metronome marks are shown when activated, metronome
marks are hidden when deactivated.

●

Parenthesized: metronome marks are shown in parentheses when activated, metronome
marks are not shown in parentheses when deactivated. Approximate metronome marks
can also be shown in parentheses by activating this property.

●

Is approximate: metronome marks are shown as approximate when activated,
metronome marks are shown as absolute when deactivated.
NOTE
Activating the Is approximate property reveals two further properties that apply
specifically to approximate tempo marks:
●

Approximate appearance: choose how the approximate metronome marks appear
from the available options, for example, c. or circa.

●

Show equals sign: an equals sign is shown when the box beside the activation
switch is checked. An equals sign is not shown when the box beside the activation
switch is not checked.

To change the components included in individual tempo marks:
PROCEDURE
1.

Select the tempo marks whose components you want to change. You can do this in Write
mode and Engrave mode.

2.

Activate any of the following properties in the Tempo group of the Properties panel:
●

Text shown

●

Metronome mark shown

●

Parenthesized

●

Is approximate

●

Approximate appearance (only available if Is approximate is activated)

●

Show equals sign (only available if Is approximate is activated)

RESULT
The selected tempo marks change to include the corresponding components.
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NOTE
If none of these properties is activated, no tempo mark is shown in the music. Instead, a signpost
is shown at the position of the tempo mark.

Changing the tempo text shown
You can change the text of existing tempo marks individually.
PROCEDURE
1.

Select the tempo marks whose tempo text you want to change. You can do this in Write
mode and Engrave mode.

2.

Enter the tempo text you want into the value field for the Text property in the Tempo
group of the Properties panel.

3.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The tempo text for the selected tempo marks is changed.

Changing the abbreviation text for tempo marks
To change the tempo text abbreviation of tempo marks:

PROCEDURE
1.

Select the tempo marks whose tempo text abbreviation you want to change. You can do
this in Write mode and Engrave mode.

2.

Activate the Abbreviation property in the Tempo group of the Properties panel.

3.

Enter the abbreviated tempo text you want into the value field.

RESULT
The abbreviated text for the selected tempo marks is changed.
You can switch between showing abbreviated tempo text and full tempo text.
RELATED LINKS
Switching between abbreviated tempo text and full tempo text on page 613

Switching between abbreviated tempo text and full tempo text
You can switch between showing abbreviated text and full tempo text for individual tempo
marks.
PROCEDURE
1.

Select the tempo marks whose shown text you want to change.

2.

Activate the Abbreviate property in the Tempo group of the Properties panel.

3.

Check the box beside the activation switch.
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RESULT
When the box beside the activation switch is checked, abbreviated tempo text is shown.
When the box beside the activation switch is not checked, or the property is deactivated, full
tempo text is shown.

Changing the metronome mark value
The metronome mark value tells you how fast the music should be played, by giving a speed
indication in beats per minute, or “bpm”. For example, a bpm of 60 means a beat happens every
second.
To change the metronome mark value:
PROCEDURE
1.

Select the tempo marks whose metronome mark values you want to change. You can do
this in Write mode and Engrave mode.

2.

Change the value for the Tempo (bpm) property in the Tempo group of the Properties
panel in any of the following ways:

3.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The metronome mark value is changed for the selected tempo marks, even if no metronome
mark component is shown for those tempo marks.
RELATED LINKS
Changing which tempo mark components are shown, and how they appear on page 612

Showing the metronome mark value as a range
You can show the metronome mark value as a range. This can be helpful to show that multiple
speeds are acceptable.
PROCEDURE
1.

Select the tempo mark or tempo marks whose metronome mark values you want to show
as a range. You can do this in Write mode and Engrave mode.

2.

Activate the Tempo range (bpm) property in the Tempo group of the Properties panel.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

NOTE
The minimum metronome mark value of the range is set by the value set for the Tempo
(bpm) property.

RESULT
The maximum tempo, expressed as beats per minute, for the selected tempo marks is changed.
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Time signatures indicate the meter, and apply to all bars from where they first appear until a
subsequent change of time signature is found. Meter describes the rhythmic pulse of music, and
its division into beats and bars.
A time signature is made up of two parts, and can be described using the terms used in
mathematics to describe fractions: numerator on top, and denominator underneath.
The numerator specifies the number of multiples of the duration specified by the denominator.
The denominator doubles for every halving of the beat duration: 1 is a whole note (breve), 2 is a
half note (minim), 4 is a quarter note (crotchet) and so on.
For example, a 4/4 time signature tells you the bar is made up of four beats, and each of those
beats is a quarter note in length. 4/2 would be four half notes in a bar, and 4/8 would be four 8th
notes in a bar. 3/4 and 6/8 both contain six 8th notes, but it is understood that a 3/4 bar contains
three quarter note beats, whereas a 6/8 bar contains two dotted quarter note beats.
The numerator is always one or more numbers, and can either show the total number of beats
in the bar, or show how the total duration of the bar is divided into beats: for example, a 7/8 bar
could appear in the following two ways:

Numerator shown as a single number for the whole
bar.

Numerator showing the beat groups in the bar.

The denominator can appear as a number, like 4 or 8, as a notehead showing the equivalent
duration, or not at all.

Denominator shown as a number.

No denominator shown.
Denominator shown as a
notehead (beat length).

If shown as a notehead, it can either show the length of each beat in the bar, or the note
duration for the bar (see the below examples). When showing the beat length, the numerator
may be changed; in the below example, the numerator 6 in the 6/8 time signature becomes a 2
to reflect the two dotted quarter note beats that make up a 6/8 bar.
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Denominator notehead showing the beat length in a
6/8 bar.

Denominator showing the note duration in a 6/8 bar.

Bars are rhythmic groups, divided according to the time signature, and they make following the
music much more practical.
Notes are beamed differently in different time signatures, again to make the meter clear and
easily readable.
RELATED LINKS
Default beam groupings according to meter on page 262
Create Time Signature section on page 622
Creating custom beam groupings for meters on page 262

General placement and appearance conventions for time
signatures
Over time, the placement and appearance of time signatures has developed conventions to
ensure they are always understood. Dorico follows these conventions automatically.

Appearance conventions
A time signature should fill the height of the staff. There is a risk it may not be seen if it is any
smaller than this. The size of time signatures on staves with fewer than five lines should be the
same as that of a time signature on a five line staff.

Time signatures use a unique, heavy font that ensures they stand out against staff lines, and are
instantly recognizable.
For some types of music, particularly film music, it is typical to use large time signatures that
span several staves. Dorico does not yet support large time signatures, however this is planned
for future versions.

Placement conventions
A time signature should be shown at the start of a piece and at the start of subsequent
movements, if applicable, even if the music carries straight on.
They should be placed after clefs and key signatures.
If a time signature change occurs during a piece or movement, it should be placed immediately
after a barline. Dorico automatically inserts a barline before a time signature change if it occurs
in the middle of an existing bar.
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A time signature applies until the end of a movement or the end of a piece, or until a time
signature change if one occurs before the end of a movement or the end of a piece.

Types of time signature
There are different types of time signature, which can be used to indicate various and complex
meters.
Simple and compound
A simple time signature is one where each beat is divided by two into equal groups
of notes, such as 4/4 or 2/8. A compound time signature is one where each beat is
divided by three into equal groups of dotted notes, such as 6/8 or 9/4.

Irregular and additive
An irregular time signature is one that cannot be divided into equal groups of notes,
for example 5/4 or 7/8. Because the numerator is odd, these time signatures must be
divided into unequal beat groups. An additive time signature is one that shows how
the beat groups should be organized, for example instead of 7/8 you could show an
additive time signature of 2+3+2/8.

Alternating
An alternating time signature indicates a regular pattern that switches every bar
between two or more time signatures, in the order they are shown in the alternating
time signature. For example, for a phrase with twelve 8th notes that needs to be
emphasized 3+3+2+2+2, an alternating time signature of 6/8+3/4 might allow the two
meters to be read more clearly.

Interchangeable
An interchangeable time signature indicates a set of time signatures at the start of
the piece that can be used during the piece, for example 3/4–2/4. There does not
have to be a fixed pattern of how the time signatures are used, unlike alternating
time signatures. They can have different types of separator in Dorico, which can be
set project-wide and can also be changed individually.

Aggregate
An aggregate time signature is one that shows two or more time meters within the
same bar, for example 2/4+3/8+5/4. Dorico automatically inputs dashed barlines to
show the divisions between each meter.
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Open
An open time signature has no restrictions on meter, beaming, or beats. Any number
of notes can be added, with any beaming. In Dorico, an open time signature can be
shown in either of these two ways, or without any signature.

Non-power of two
A non-power of two time signature is one such as 5/6, which indicates five sextuplet
notes lasting for a whole note (semibreve). Examples of time signatures like this can
be found in the music of Adès.
Some composers, such as Boulez, have written fractional time signatures. Dorico does not
currently support these.
RELATED LINKS
Changes to the appearance of time signatures on page 629

Inputting time signatures with the keyboard
You can input time signatures can be input with the keyboard by using the time signatures
popover in Write mode.
You can open the time signatures popover by pressing Shift-M (M for “meter”), or by choosing
Write > Create Time Signature.
The icon on the left-hand side of the popover matches the corresponding button in the Notations
toolbox on the right of the window.

The time signatures popover with an example entry
for a time signature

The time signatures button in the Notations toolbox

The time signatures popover
The table shows some examples of what to enter into the time signatures popover, and the time
signatures that are input into the music as a result.
You can open the time signatures popover in Write mode by pressing Shift-M (M for “meter”), or
by choosing Write > Create Time Signature.
For example, enter:

For time signature:

2/4 or 6/8 or 3/4 or 5/4 and so on

Simple time signatures: 2/4, 6/8, 3/4, 5/4 and
so on

4/4,1.5 or 6/8,2 and so on

Time signatures with a pick-up: such as a 4/4
bar with a dotted quarter note pick-up, or a 6/8
bar with pick-up of two eighth notes.

6/8 + 3/4

Alternating time signatures, such as 6/8+3/4.
The spaces either side of the plus sign are
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For example, enter:

For time signature:
important to include when typing into the
popover.

c

Common time, the equivalent of 4/4

cutc or ¢

Cut common time, the equivalent of 2/2

X or x

Open meter

3+2+2/8 or 3+2/4 and so on

Additive time signature with explicit beat
grouping.

[2+3+2]/8

Specify beat grouping, but don’t show it: for
example, typing this example into the popover
shows a time signature of 7/8, but beaming is
grouped into 2+3+2 eighth notes.

2/4|6/8

Aggregate time signature: a dashed barline is
shown in the bar to show the division between
the different meters.

2/4 (6/8) or 2/4 / 6/8 or 2/4 = 6/8 or
2/4 – 6/8

Interchangeable time signature, with different
styles: parenthesized, slash, equals sign, and
dashed. The spaces between numbers and
parentheses, and either side of slashes, equals
signs, and dashes are important to include
when typing into the popover.

This list is not comprehensive: it is intended to illustrate how you can structure your entry to
input different time signatures.

Inputting time signatures during step input with the keyboard
To input time signatures during step input with the keyboard:
PROCEDURE
1.

In Write mode, start note input.

2.

Open the time signatures popover in any of the following ways:
●

Press Shift-M

●

Choose Write > Create Time Signature

3.

Enter the time signature you want into the popover, such as 3/4 or [2+2+3]/8.

4.

Press Return to close the popover.

RESULT
The time signature is added at the caret position, even if this is in the middle of an existing bar.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first.
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Adding time signatures to existing music with the keyboard
To add time signatures to existing music with the keyboard:
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The barline where you want a new time signature to start

●

A notehead or rest immediately to the right of the position where you want a new
time signature to start

Open the time signatures popover in any of the following ways:
●

Press Shift-M

●

Choose Write > Create Time Signature

3.

Enter the time signature you want into the popover, such as 3/4 or [2+2+3]/8.

4.

Press Return to close the popover.

RESULT
The time signature is added immediately to the right of a barline, or immediately to the left of a
selected note, even if this is in the middle of an existing bar.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first.

Inputting time signatures on single staves with the keyboard
By default, time signatures apply to the whole score. However, there are some situations that
require some parts to have their own time signature, independently of the rest of the ensemble.
You can input time signatures on single staves with the keyboard, both during step input and by
adding them later to existing music.
PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline where you want an independent time signature to start, or
select a notehead or rest immediately to the right of the position where you want an
independent time signature to start.

Open the time signatures popover in any of the following ways:
●

Press Shift-M

●

Choose Write > Create Time Signature

3.

Enter the time signature you want into the popover, such as 3/4 or [2+2+3]/8.

4.

Hold down the Alt key while pressing Return to close the popover.

RESULT
Holding down the Alt key inputs the time signature only on the selected staff.
It behaves just like any other time signature: all subsequent bars on the staff follow the input
time signature, until the next existing time signature or the end of the flow, whichever comes
first.
NOTE
Adding different time signatures to different staves can be used to create polymetric music: that
is, music with multiple simultaneous meters. However, the relationship between the beat lengths
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in each time signature is fixed across all staves in your project. For example, if you have a time
signature of 4/4 and on a different stave, you have a time signature of 6/8, then one quarter note
in the 4/4 time signature equals one quarter note in the 6/8 time signature.

RELATED LINKS
Inputting notes on page 94

Inputting pick-up bars with the keyboard
To input an upbeat or pick-up bar with the keyboard, you need to input a new time signature that
includes the upbeat.
PROCEDURE
1.

2.

3.

In Write mode, select one of the following:
●

The barline where you want a time signature with a pick-up to start.

●

A notehead or rest immediately to the right of the position where you want a new
time signature to start.

Open the time signatures popover in any of the following ways:
●

Press Shift-M

●

Choose Write > Create Time Signature

Enter the time signature you want into the popover, followed immediately by a comma,
and then the number of beats you want in your pick-up. For example, entering 4/4,1 into
the popover creates a 4/4 time signature with one quarter note upbeat.
The number after the comma indicates multiples of the rhythmic unit specified by the
denominator of the time signature. For example, 4/4,0.75 creates a dotted 8th note
upbeat, whereas 6/8,2 would create an upbeat of two 8th notes.

4.

Press Return to close the popover.

RESULT
The time signature with pick-up is input immediately to the right of a barline, or immediately to
the left of a selected note, even if this is in the middle of an existing bar. Although commonly
used at the start of a work, in Dorico, time signatures with pick-ups can be input anywhere in the
score.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first.

Inputting time signatures with the mouse
Time signatures can be input with the mouse using the Time Signatures panel on the right of
the window in Write mode, where there are common time signatures ready to use. There is also
a Create Time Signature section to create uncommon time signatures.
You can open the Time Signatures panel by clicking Time Signatures in the Notations toolbox:

The panel can be hidden and shown using its disclosure arrow (key command Ctrl/Cmd-9).
The different sections in the Time Signatures panel are:
●

Used In This Flow: any time signatures already used in the current flow are shown in this
section.
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●

Common: common time signatures, such as 4/4, 3/4, 6/8, and 7/8, are shown in this
section.

●

Create Time Signature: you can design your own time signatures in this section, including
alternating time signatures and aggregate time signatures.

The order in which you should follow steps for inputting time signatures with the mouse
depends on your preferences for the Creating items with the mouse option, in the Editing
section of the General page in Dorico > Preferences (key command Ctrl/Cmd-,).

Create Time Signature section
In the Time Signatures panel on the right of the window, there is a Create Time Signature
section where you can create uncommon time signatures. This section can be shown and hidden
by clicking on the section title, which has a disclosure arrow beside it.
There are four parts of the Create Time Signature section:
1

The menu where you can choose what type of time signature you can to input:
●

Regular

●

Interchangeable

●

Aggregate

●

Alternating

2

Spaces for up to four time signatures. For a Regular time signature, you can only specify
one time signature, however for the other three types you can include up to four.

3

An option to include a pick-up bar, with three available options:

4

●

1/2 beat

●

1 beat

●

2 beats

The button at the bottom, which you click on to input the time signature. If nothing in the
project is selected, the time signature is loaded onto the cursor.

The Create Time Signature section of the Time Signatures panel.

Inputting time signatures during step input with the mouse
To input time signatures during step input with the mouse:
PROCEDURE
1.

In Write mode, start note input.

2.

Click on a time signature from the available options in the Time Signatures panel, or use
the Create Time Signature section to create your own.

RESULT
The time signature is added at the caret position, even if this is in the middle of an existing bar.
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All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first.
RELATED LINKS
Inputting notes on page 94
Create Time Signature section on page 622

Adding time signatures to existing music with the mouse
To add time signatures to existing music with the mouse:
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The barline where you want a new time signature to start.

●

A notehead or rest immediately to the right of the position where you want a new
time signature to start.

Click on a time signature from the available options in the Time Signatures panel, or use
the Create Time Signature section to create your own.

RESULT
The time signature is added immediately to the right of a barline, or immediately to the left of a
selected note, even if this is in the middle of an existing bar.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first.
NOTE
Follow these steps in the above order if your mouse input preference is set to Create item at
selection.
If your preference is for Load cursor with item, follow the steps in the reverse order. However,
even with this preference the time signature is added at the caret position during step input.

RELATED LINKS
Create Time Signature section on page 622

Inputting time signatures on single staves with the mouse
By default, time signatures apply to the whole score. However, there are some situations that
require some parts to have their own time signature, independently of the rest of the ensemble.
You can input time signatures on single staves with the mouse, both during step input and by
adding them later to existing music.
PROCEDURE
1.

2.

In Write mode, do one of the following:
●

Start note input.

●

Select an existing barline where you want an independent time signature to start, or
select a notehead or rest immediately to the right of the position where you want an
independent time signature to start.

Hold down Alt.
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3.

Click on a time signature from the available options in the Time Signatures panel, or use
the Create Time Signature section to create your own.

RESULT
Holding down Alt inputs the time signature only on the selected staff.
It behaves just like any other time signature: all subsequent bars on the staff follow the input
time signature, until the next existing time signature or the end of the flow, whichever comes
first.
NOTE
Follow these steps in the above order if your mouse input preference is set to Create item at
selection.
If your preference is for Load cursor with item, follow the steps in the reverse order.

RELATED LINKS
Create Time Signature section on page 622

Inputting pick-up bars with the mouse
To input an upbeat or pick-up bar with the mouse, you need to input a new time signature that
includes your preferred upbeat.
NOTE
Follow these steps in the above order if your mouse input preference is set to Create item at
selection.
If your preference is for Load cursor with item, start at Step 2, and complete Step 1 at the end.
Clicking on the Create Time Signature button after creating your time signature loads it onto
the mouse pointer. You can then click the time signature into your score where you want it.

PROCEDURE
1.

In Write mode, select one of the following:
●

The barline where you want a time signature with a pick-up to start.

●

A notehead or rest immediately to the right of the position where you want a new
time signature to start.

2.

Use the Create Time Signature section to create the time signature you want the pick-up
to attach to.

3.

Activate the Pickup bar of option at the bottom and choose one of the following options:
●

1/2 beat

●

1 beat

●

2 beats

NOTE
Not all pick-up bar lengths are possible using this method. For example, a single 8th note
upbeat in 6/8 cannot be produced by any of these three options. In such cases, the upbeat
should be input with the keyboard using the time signatures popover.
4.

You should see your time signature shown at the bottom of the section.
When you hover the mouse pointer over it, you can see this is a button.

5.

Click the button to input your time signature with a pick-up.
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RESULT
The time signature with pick-up is input immediately to the right of a barline, or immediately to
the left of a selected note, even if this is in the middle of an existing bar. Although commonly
used at the start of a work, in Dorico, time signatures with pick-ups can be input anywhere in the
score.
All subsequent bars follow the input time signature, until the next existing time signature or the
end of the flow, whichever comes first.
RELATED LINKS
Inputting pick-up bars with the keyboard on page 621

Changing time signatures
To change an existing time signature:
PROCEDURE
1.

In Write mode, select the time signature you want to change.

2.

Change the time signature in any of the following ways:
●

Press Shift-M.
Enter the new time signature you want into the popover, and press Enter.

●

Click Time Signature (Meter) in the Notations toolbox to open the Time Signatures
panel:
.
Click one of the time signatures in the Common section of the Time Signatures
panel. Alternatively, create a time signature in the Create Time Signature section.

RELATED LINKS
Creating custom beam groupings for meters on page 262

Positions of time signatures
Time signatures in Dorico appear in the correct positions by default. However, you can change
the positions of time signatures individually should you find it necessary to do so.
RELATED LINKS
Project-wide spacing gaps for time signatures on page 625
Moving time signatures rhythmically on page 626
Moving time signatures graphically on page 627

Project-wide spacing gaps for time signatures
You can change the minimum gaps between objects, including time signatures, on the Spacing
Gaps page in Engraving Options.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

The following minimum values that relate to time signatures are:
●

Gap after barline before clef, key or time signature
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●

Gap after key signature

●

Gap after mid-system time signature

Other values may have an effect on the position of time signatures, however, they also affect
other objects.

Moving time signatures rhythmically
You can move time signatures to new rhythmic positions after they have been input.
NOTE
You can only move time signatures rhythmically using the keyboard.
NOTE
Time signatures can only be moved along staves.
If you want to move an individual time signature across staves, you must first delete the
individual time signature from its first position, then add a new individual time signature to the
staff you wanted to move it to.
If you want to adjust the default position of time signatures relative to notes or barlines, you
must change the project-wide values for spacing gaps on the Spacing Gaps page in Engrave >
Engraving Options.
PROCEDURE
1.

In Write mode, select the time signatures you want to move.

2.

Move the time signatures according to the rhythmic grid currently set in any of the
following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

RESULT
The time signature takes effect from its new position until the next existing time signature, or the
end of the flow.
NOTE
Only one time signature can exist at each rhythmic position, except for time signatures that only
apply to single staves. If the time signature passes over another time signature as part of its
move, the selected time signature that you are moving is replaced by the existing time signature.
If you moved time signatures using the keyboard, you can undo the move to restore any time
signatures deleted in the process.
However, if you moved time signatures using the mouse, undoing the move does not restore any
time signatures deleted in the process.
Moving time signatures back to their previous positions later does not restore any time
signatures deleted when they were moved previously. The deleted time signatures must be reinput if necessary.

RELATED LINKS
Project-wide spacing gaps for time signatures on page 625
Moving time signatures graphically on page 627
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Moving time signatures graphically
Time signatures can be moved individually to new graphical positions in Engrave mode without
affecting the positions of any other items.
PROCEDURE
1.

In Engrave mode, activate Note Spacing in the panel on the left of the window.

2.

Select the square handle above the time signature you want to move, as shown in the
example below.

3.

Once you have selected a square handle, a smaller circular handle appears beside the time
signature.

4.

Select the circular handle.

5.

Nudge the time signature in any of the following ways:
●

Press Alt-Right Arrow to move it to the right.

●

Press Alt-Left Arrow to move it to the left.
TIP
If you want to move time signatures by larger increments, you can press Ctrl/Cmd
as well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

RESULT
The time signature is moved graphically to the left or to the right.
NOTE
You cannot change the position of Note Spacing handles with the mouse, they can only be
moved using the keyboard.

RELATED LINKS
Changes to note spacing in Engrave mode on page 461

Moving time signatures graphically using the Properties panel
Time signatures can be moved graphically using the Properties panel in Engrave mode.
NOTE
Changing the value for the Spacing Offset property also affects the positions of whole bar rests
in the bar immediately after the selected time signature.

PROCEDURE
1.

In Engrave mode, select the time signatures you want to move.
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2.

Activate the Spacing Offset property in the Time Signatures group of the Properties
panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The Spacing Offset property moves time signatures in the following ways:
●

Increasing the Spacing Offset value moves time signatures to the right.

●

Decreasing the Spacing Offset value moves time signatures to the left.

RELATED LINKS
Changes to note spacing in Engrave mode on page 461

Hiding time signatures
To hide a time signature without deleting it from the project:
PROCEDURE
1.

Select the time signature you want to hide. This can be done in Write mode and Engrave
mode.

2.

Activate the Hide time signature property in the Time Signatures group of the Properties
panel.

3.

Check the box beside the activation switch.

RESULT
A signpost is shown at the position of the time signature so it is never lost, meaning you can
always find it again. However, the signpost is not printed by default.
You can choose to print time signature signposts if you activate View options in the
Annotations section of the print options panel on the right of the window in Print mode.
You can deactivate the Hide time signature property at any time and the original time signature
reappears.
NOTE
Hidden time signatures do not take up any rhythmic space, so hiding or re-showing a time
signature affects rhythmic spacing.

Hiding time signature signposts
To hide and show time signature signposts in any mode, choose View > Signposts > Time
Signatures.
RESULT
Signposts for time signatures no longer appear in the project. You can show them again at any
time by choosing View > Signposts > Time Signatures again. If a tick appears beside Time
Signatures in this menu, then time signature signposts are shown in the project.
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Deleting time signatures
To delete a time signature completely from the score:
PROCEDURE
1.

2.

In Write mode, select one of the following:
●

The time signatures you want to delete.

●

The signposts of hidden time signatures you want to delete.

Delete the time signatures in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The time signature is deleted from the score. Bars after its previous position are re-barred
according to the previous time signature in the score, up until the next time signature or the end
of the flow.
If you delete the only time signature in the flow, your music appears in an open meter, but with
all the same rhythmic values.

Changes to the appearance of time signatures
You can change the appearance of all time signatures project-wide on the Time Signatures
page in Engraving Options. You can also change the appearance of individual time signatures,
independently of your project-wide settings.
You can change the appearance of time signatures individually by using properties in the
Properties panel at the bottom of the window.
You can activate some of these properties in both Write mode and Engrave mode, however there
are more options available in Engrave mode.
NOTE
If you change your mind at any time, you can deactivate any of these properties to revert time
signatures to your project-wide settings for the corresponding aspect of the time signature.

RELATED LINKS
Project-wide Engraving Options for time signatures on page 629

Project-wide Engraving Options for time signatures
Options for the appearance of time signatures project-wide can be found on the Time
Signatures page in Engraving Options.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Choosing how numerators appear project-wide
In the Design section of the Time Signatures page in Engraving Options, there are two options
for the default appearance of numerator style project-wide:
●

Show single number
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●

Show beat groups

Choosing how denominators appear project-wide
Also in the Design section, there are two options for the default appearance of denominator
style project-wide:
●

Show single number

●

Show note duration

●

Show nothing

NOTE
You cannot choose both the denominator Show nothing option and the numerator Show beat
groups option simultaneously. In this situation, the default number denominator is shown.

Choosing how denominator notes appear (if used) project-wide
You can also choose how denominator notes appear in the Design section, if the denominator
style Show note duration is used:
●

Show beat length

●

Show note duration

Choosing how interchangeable time signatures are separated project-wide
Also in the Design section, there are six options for the default appearance of interchangeable
time signatures project-wide:
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●

Parentheses

●

(Square) brackets

●

Equals sign

●

Slash

●

Space

●

Hyphen

Choosing how open meter time signatures appear project-wide
Again in the Design section, there are three options for the default appearance of open meter
signatures project-wide:
●

None (this example shows the signpost that automatically appears)

●

X (default)

●

N (Penderecki’s symbol)
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Choosing how large the gaps are between time signatures, separators,
and parentheses
In the Gaps section of the Time Signatures page in Engraving Options, you can set values for
the following gaps:
●

Gap between alternating time signature and separator

●

Gap between interchangeable time signatures (if a space rather than a separator is used)

●

Gap between a time signature and its parentheses

●

Gap between a time signature and its brackets

RELATED LINKS
Time signatures on page 615

Changing the numerator style of time signatures individually
You can choose whether the numerators of individual time signatures show the total number
of beats in each bar, or the subdivision of beats in each bar, independently of your project-wide
setting for the appearance of numerators.
PROCEDURE
1.

Select the time signatures whose numerator style you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the Numerator style property in the Time Signatures group of the Properties
panel.

3.

Choose one of the following options:
●

Number, such as 7/8

●

Beat group, such as 2+2+3/8

RESULT
The numerator style of the selected time signatures is changed.
NOTE
You can change the numerator style of all time signatures project-wide on the Time Signatures
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for time signatures on page 629

Changing the denominator style of time signatures individually
You can change the denominator style of individual time signatures, independently of your
project-wide setting for the appearance of denominators.
PROCEDURE
1.

Select the time signatures whose denominator style you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the Denominator style property in the Time Signatures group of the Properties
panel.

3.

Choose one of the following options:
●

Show single number

●

Show note duration
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●

Show nothing

RESULT
The denominator style of the selected time signatures is changed.
NOTE
You can change the denominator style of all time signatures project-wide on the Time
Signatures page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for time signatures on page 629

Changing the open meter style of time signatures individually
The Open style property in the Time Signatures group of the Properties panel is automatically
activated when you input open meter signatures. You can change the open meter style of
individual time signatures, independently of your project-wide setting for the appearance of
open meters.
PROCEDURE
1.

Select the open meter time signatures whose open meter style you want to change. You
can do this in Write mode and Engrave mode.

2.

Choose one of the following options for the Open style property in the Time Signatures
group of the Properties panel:
●

None (Empty)

●

X (default)

●

N (Penderecki’s symbol)

RESULT
The open meter style of the selected time signatures is changed.
NOTE
You can change the style of all open meter time signatures project-wide on the Time Signatures
page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for time signatures on page 629

Changing the separator style of interchangeable time signatures
individually
You can change the separator shown in the middle of individual interchangeable time signatures,
independently of your project-wide setting for the separator used in interchangeable time
signatures.
PROCEDURE
1.

Select the interchangeable time signatures whose separator you want to change. You can
do this in Write mode and Engrave mode.
The Separator property in the Time Signatures group of the Properties panel is
automatically activated for interchangeable time signatures.
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2.

Select one of the following options from the Separator property menu:
●

Parentheses

●

Brackets (square)

●

Equals sign

●

Slash

●

Space

●

Hyphen

RESULT
The separator style of the selected interchangeable time signatures is changed.
NOTE
Although they might look similar to interchangeable time signatures, aggregate time
signatures behave differently. Aggregate time signatures are separated by a “+” sign, whereas
interchangeable time signatures can be shown with six different separators but not a “+” sign.
Therefore, although you can activate this property and choose from the available options for
aggregate time signatures, the property only affects the appearance of interchangeable time
signature separators, and not the appearance of aggregate time signature separators.

RELATED LINKS
Project-wide Engraving Options for time signatures on page 629
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A tie is a curved line that joins two notes of the same pitch, and a tie chain can be created by
joining multiple, adjacent notes with a sequence of ties.
Each sequence of tie chains, whether the tie chain joins two notes together or ten notes
together, represents a single note with the duration of all the tied notes combined. A performer
plays the notes as one note, without re-striking, re-blowing, or re-bowing the note at any point
within the rhythmic duration of the tie chain.
In Dorico, most of the ties are created automatically. Rhythms are notated according to the
prevailing beat grouping which is normally set by the time signature. Therefore, notes that
cannot or should not be notated using a single duration are automatically drawn as separate tied
notes.

General placement conventions for ties
Ties join two noteheads together, meaning the ends of ties should be positioned close to the
noteheads to which they are attached.
Ties are curved lines, and the direction of the curve usually follows the stem direction of the
notes: if notes are stem-up, ties curve downwards; if notes are stem-down, ties curve upwards.
NOTE
If there are multiple voices in the staff, all ties in up-stem voices curve upwards and all ties in
down-stem voices curve downwards.
There are two main conventions for the placement of the ends of ties relative to noteheads. One
convention places the ends of ties outside noteheads, meaning above or below them, ideally
positioned at the horizontal center of noteheads. The other convention places the ends of ties
between noteheads, ideally positioned at the vertical center of noteheads.
You can see the difference between these two conventions in the below examples.

A tie outside noteheads.

A tie between noteheads.

The placement of ties is often automatically adjusted in Dorico so that neither of the end points
of ties, nor the apex of tie curves, starts on a staff line or ends on a staff line. If this happens, it
can cause the shape of ties to appear distorted, which can make the music harder to read.
To avoid this, Dorico can change the vertical position of ties slightly, and make small changes to
the curvature of ties. These changes are small, however you can see in the below examples how
the placement of ties is subtly different depending on the position of notes relative to staff lines.
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A tie outside noteheads.

When transposed one note down, the tie appears
with a steeper curve to avoid reaching its apex on
the staff line.

A tie between noteheads, with the ends slightly
When transposed up, the ends of the tie are now
above the vertical center of the noteheads to avoid
positioned at the vertical center of the notehead, as
the tie appearing too close to the staff line at its ends there is not staff line with which it could collide.
or apex.

Wherever possible, clef changes should not be positioned in the middle of a tie chain. Changing
the clef changes the position of the tied note in the staff, which could easily cause a performer to
misread the tie as a slur and play two different notes. Clef changes can be input in the middle of
tie chains in Dorico, however it is best to position clef changes either before a whole tie chain, or
after a whole tie chain.
Ties can look distorted, or can even be easily missed, when they are very short. You can change
the minimum length of ties when they are within a single system on the Ties page in Engrave >
Engraving Options.
NOTE
Although they look very similar to slurs, ties and slurs are not the same. Ties affect the behavior
of notes differently to slurs.

RELATED LINKS
Ties versus slurs on page 637
Inputting ties during step input on page 637
Project-wide Engraving Options for ties on page 644

Positions of ties
In Dorico, the positions of ties are determined according to horizontal and vertical positioning
rules.

Horizontal positioning rules
The ends of ties are positioned as close as possible to the notes that they join while avoiding
collisions with other notations.

Vertical positioning rules
The ends and the middle of the tie curvatures avoid abutting staff lines.

Chains of tied notes
In some cases, ties are extended over several bars.
This occurs if you input a note that is longer than a whole note in a 4/4 time signature, for
example.
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The ties are then displayed as a chain of tied notes, which is often referred to as a tie chain.

Ties versus slurs
Ties and slurs look superficially similar but differ in meaning.
Ties indicate that a note should not be re-struck. They are used to join notes of the same pitch
together. For example, ties can be used to extend notes across multiple bars. Although multiple
notes can be included in a single tie chain, each tie in the chain only joins one notehead to the
next notehead in the staff.
Ties can be used in conjunction with articulation, however articulation on tied notes only affects
the attack at the start of the tie chain and the release at the end of the tie chain.

Two long notes tied together.

Slurs indicate articulation, such as bowing or breathing, and normally group notes of different
pitches. Slurs can join two noteheads together with any number of pitches in between. They
often indicate the shaping of phrases.
Slurs can also be used in conjunction with articulation. Unlike ties, articulation within slurs can
affect the sound throughout the phrase. For example, staccato articulations on repeated notes of
the same pitch within a slur indicate that notes should be played on a stringed instrument using
the same bow direction, but stopping the bow between each note.

A phrase with notes grouped together by slurs.

Applied rules for changed tied notes
Dorico applies specific rules when you make changes to tied notes.
Dorico automatically adjusts the tied notes for you in the following circumstances:
●

If you change the pitch of a tied note, which includes adding or removing an accidental,
the change is applied to all the notes that are tied together.

●

If you add or remove an articulation, the articulation is added only to the start or the end
of the tie chain as appropriate, for example, to the last note for an articulation of duration
or to the first note for an articulation of force.

RELATED LINKS
Changing the positions of articulations on tied notes project-wide on page 210
Changing the positions of articulations on tied notes individually on page 212

Inputting ties during step input
Ties can be input manually during step input to join two notes of the same pitch.
In general, Dorico creates ties automatically as required. If you specify a rhythmic duration that
cannot be notated with a single note value, Dorico automatically creates chains of tied notes
where necessary.
For example, if you want to input a tie between two quarter notes across a barline, you can
simply input a half note at the rhythmic position where you want to input the first quarter note:
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Dorico automatically splits the half note into two quarter notes, one on each side of the barline,
and joins them with a tie.
In the following cases, you must input ties manually:
●

If you later want to change the duration, and want to join it with a tie to the following note
to make it longer.

●

If the notes that should be tied together are not rhythmically adjacent: for example, if the
notes are separated by intervening notes of a different pitch.

●

If the notes that should be tied together are in different voices.

●

If you want a grace note to be tied to a note that is not a grace note.

To input ties during step input:
PROCEDURE
1.

In Write mode, start note input.

2.

Input the note that you want at the start of the tie.

3.

Start a tie in one of the following ways:
●

Press T

●

Click Tie in the Notes toolbox:

4.

Position the caret at the position you want to input the note at the end of the tie.

5.

Input the note that you want at the end of the tie.
NOTE
The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

RESULT
The two notes input are joined by a tie.
NOTE
Depending on the current time signature and your settings on the Note Grouping page in
Write > Notation Options, inputting a tie between two notes may instead create a note of a
different duration. For example, inputting a tie between the first two quarter notes in a 4/4 time
signature creates a minim.
You can override your note grouping settings and fix your notated rhythm in the following ways:
●

Press O

●

Click Force Duration in the Notes toolbox:

Dorico then notates your input notes with the rhythmic durations specified, as long as they can
fit inside the bar.

RELATED LINKS
Moving the caret manually on page 99
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Adding ties to existing notes
To join existing notes together with a tie:
PROCEDURE
1.

In Write mode, select the note from which you want a tie to start.

2.

Input a tie in one of the following ways:
●

Press T

●

Click Tie in the Notes toolbox:

NOTE
The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

RESULT
The selected note is joined by a tie to the next note of the same pitch in the same staff.
NOTE
Depending on the current time signature and your settings on the Note Grouping page in
Write > Notation Options, inputting a tie between two notes may instead create a note of a
different duration. For example, inputting a tie between the first two quarter notes in a 4/4 time
signature creates a minim.
You can override your note grouping settings and fix your notated rhythm in the following ways:
●

Press O

●

Click Force Duration in the Notes toolbox:

Dorico then notates your input notes with the rhythmic durations specified, as long as they can
fit inside the bar.

Ties in other contexts
Usually, ties join two notes of the same pitch in the same staff. However, ties can also cross
system breaks and frame breaks, clef changes, or time signature changes. These types of ties are
all positioned automatically in Dorico.
Ties can also join non-adjacent notes, notes in different voices or notes in different staves
together. These types of ties must be input manually in Dorico.

Ties across system breaks and page breaks
The ends of ties that cross system breaks are automatically positioned in Dorico.
Their vertical position remains the same, as both ends are centered on the noteheads to which
they are attached. Their behavior also remains the same: selecting one note in a tie chain that
crosses a system break or page break in Write mode selects all notes in the tie chain.
The horizontal space for the ends of ties shown to the left of notes at the start of new systems or
new pages may not be sufficient to show an ideal tie curve.
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You can adjust the spacing of notes at the start of systems and pages to give the ends of ties
more space. In Engrave mode, activate Note Spacing and nudge the handle beside the note in
the tie chain at the start of a new system or new page to the right using Alt-Right Arrow, or to
the left using Alt-Left Arrow.

The start of a tie chain before a system break.

The end of the same tie chain after a system break.

Tied notes with accidentals across system breaks and page breaks
The ends of ties for tied notes with accidentals across system breaks and page breaks are also
automatically positioned.
As tied notes in Dorico are treated as one note notated to fit in time signatures, cautionary
accidentals on new systems or new pages are not shown by default. If you choose to show
accidentals beside notes in tie chains at the start of new systems or pages, the position of the
notes is changed to accommodate accidentals. However, as described in the section above, this
automatic position may not leave sufficient room for the end of the tie to the left of the notes to
be shown with an ideal curve.

The start of a tie chain before a system break.

The end of the same tie chain, with a cautionary
accidental shown in parentheses.

Ties across time signature changes
Ties are automatically positioned between notes that span a change of time signature. If ties
crossing a time signature change are joining notes mostly in the middle of a staff, the top or
bottom of time signature changes are partially obscured by the ties. However, as ties are curved,
the time signature is unlikely to be completely obscured.

Cross-clef ties
Ties are automatically positioned between notes that span a change of clef. Ties across clef
changes are not horizontal, as the same pitch is positioned differently in each clef.
The result of cross-clef ties is likely to be visually and musically confusing, as they may be
misread as slurs, so you may want to consider moving the change of clef to either before the tied
note or after the tied note.

Ties between non-adjacent notes
You can input ties between notes of the same pitch that are not directly beside each other.
This can be useful when inputting ties between multiple notes before a chord, as shown in the
examples below.
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Notes leading into a chord notated Notes leading into a chord notated Multiple grace notes before a
as a series of tied chords.
as tied non-adjacent notes.
chord with ties between nonadjacent notes.

Ties between different voices
You can input ties between notes of the same pitch in different voices.

Ties between notes on different staves
You can input ties between notes of the same pitch in different staves.

Laissez vibrer ties
Laissez vibrer ties are short ties that indicate a note should be left to ring, and should not be
stopped. They extend a small amount to the right of the note to which they apply, but do not
connect to another note.
You can show laissez vibrer ties on any note. You can edit laissez vibrer ties in Engrave mode like
any other tie.
RELATED LINKS
Inputting ties between non-adjacent notes on page 641
Inputting ties between notes in different voices on page 642
Inputting ties between notes in different staves on page 642
Individual changes to the appearance of accidentals on page 191

Inputting ties between non-adjacent notes
You can input ties between notes that are not rhythmically adjacent manually.
PROCEDURE
1.

In Write mode, select the two notes that you want to tie together.
NOTE
The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

2.

Input a tie in one of the following ways:
●

Press T

●

Click Tie in the Notes toolbox

.

RESULT
A tie is input. The tie joins the two selected notes together.
RELATED LINKS
Inputting ties during step input on page 637
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Inputting ties between notes in different voices
You can input ties between notes that are not in the same voice manually.
PROCEDURE
1.

In Write mode, select the two notes that you want to tie together.
NOTE
The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

2.

Input a tie in one of the following ways:
●

Press T

●

Click Tie in the Notes toolbox

.

RESULT
A tie is input. The tie joins two selected notes together.
RELATED LINKS
Inputting ties during step input on page 637

Inputting ties between notes in different staves
You can input ties between notes that are not in the same staff manually.
PROCEDURE
1.

In Write mode, select the two notes that you want to tie together.
NOTE
The second note must be the same pitch as the first note. If the second note is a different
pitch to the first note, no tie is input.

2.

Input a tie in one of the following ways:
●

Press T

●

Click Tie in the Notes toolbox

.

RESULT
A tie is input. The tie joins two selected notes together.
RELATED LINKS
Inputting ties during step input on page 637

Showing laissez vibrer ties
PROCEDURE
1.

Select the notes on which you want to show a laissez vibrer tie. You can do this in Write
mode and Engrave mode.

2.

Activate the Laissez vibrer tie property in the Notes and Rests group of the Properties
panel.

642

Ties
Deleting ties
RESULT
A laissez vibrer tie is shown on the selected notes. It is positioned automatically.
You can edit the length and shape of laissez vibrer ties individually in Engrave mode.
RELATED LINKS
Changing the position and shape of ties individually on page 645

Showing cautionary accidentals beside notes in tie chains
To show a cautionary accidental beside subsequent notes in tie chains, for example, after a
system break:
PROCEDURE
1.

In Engrave mode, select the noteheads beside which you want to show a cautionary
accidental.

2.

Activate the Accidental property in the Notes and Rests group of the Properties panel.

3.

Select one of the following options from the menu:
●

Hide

●

Show

●

Parenthesize

Deleting ties
Deleting ties from tie chains removes all ties in the tie chain. If you want to remove single ties
from longer tie chains, you can split the tie chain.
To delete all ties from tie chains:
PROCEDURE
1.

In Write mode, select the tie chains from which you want to delete all ties.

2.

Delete all ties in the tie chain in one of the following ways:
●

Press U.

●

Click Scissors in the Notes toolbox:

RESULT
All ties in the selected tie chains are deleted. Notes previously in the tie chain remain at their
rhythmic positions.
RELATED LINKS
Splitting tie chains on page 644
Changing the duration of selected notes on page 102
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Splitting tie chains
To split tie chains without removing all ties from tie chains:
PROCEDURE
1.

In Write mode, select the tie chain you want to split.

2.

Start note input in one of the following ways:
●

Press Shift-N.

●

Press Return.

●

Choose Write > Note Input.

●

Double-click the tie chain.

3.

Position the caret at the rhythmic position where you want to split the tie chain.

4.

Split the tie chain in one of the following ways:

5.

●

Press U

●

Click Scissors in the Notes toolbox:

Optional: if you want to split the same tie chain in multiple places, move the caret to the
next rhythmic position where you want to split the tie chain in one of the following ways:
●

Use Right Arrow and Left Arrow to move the caret left or right, according to the
rhythmic grid currently set

●

Press Space to advance the caret to the next rhythmic position, according to the
note value currently selected

RESULT
The tie chain is split at the caret position.

Positions of articulations relative to tie chains
The positions of articulations relative to tie chains depends on the type of articulation. You can
change the positions of articulations relative to tie chains project-wide and for individual tie
chains.
RELATED LINKS
Positions of articulations on page 208
Changing the positions of articulations on tied notes project-wide on page 210
Changing the positions of articulations on tied notes individually on page 212

Project-wide Engraving Options for ties
Options for the position, placement, and appearance of ties project-wide can be found on the
Ties page in Engraving Options.
The options on this page allow you to change the default curvature, shape, and appearance of
ties, and their positions relative to noteheads and other ties in tie chains.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

644

Ties
Changing the position and shape of ties individually
●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Ties in the page list on the left of the dialog.

Changing the position and shape of ties individually
Each tie has five square handles that can be moved separately. You can move each handle
separately to change the appearance and shape of individual ties.

A tie in Engrave mode.

However, moving one handle may also affect the position of other handles.
For example, moving the left endpoint moves the left end of a tie, but the rest of the handles
stay in their existing positions. However, moving the left control point also causes the tie height
handle to move.
This gives you fine control over the shape of ties while ensuring that the end result remains
curved and smooth.
PROCEDURE
1.

2.

In Engrave mode, select the tie handles whose positions you want to move. You can select
tie handles in any of the following ways:
●

Select a whole tie and press Tab to cycle through its handles until the one you want
to move is selected.

●

Click the handle you want to move.

●

Ctrl/Cmd-Click individual handles on multiple ties.

Move the tie handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the tie handles in any direction to the positions you want.

RESULT
The positions of the selected tie handles is changed, which changes the shape of the
corresponding ties.
NOTE
You can reset the positions of tie handles at any time by deactivating the properties in the Ties
group of the Properties panel that correspond to the moved handles.

RELATED LINKS
Changing the position and shape of ties individually using the Properties panel on page 646
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Changing the position and shape of ties individually using the
Properties panel
You can change the position and shape of ties using the Properties panel.
PROCEDURE
1.

In Engrave mode, select the ties whose position or shape you want to change.

2.

Activate the following properties, individually or together, in the Ties group of the
Properties panel:

3.

4.

●

Start offset: left endpoint

●

End offset: right endpoint

●

Start handle offset: left control point

●

End handle offset: right control point

Each property has X and Y value fields. Change the values in the value fields in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties change the positions of tie handles in the following ways:
●

Start offset X moves left endpoints horizontally: increasing the value moves them
to the right, decreasing the value moves them to the left.

●

Start offset Y moves left endpoints vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.

●

End offset X moves right endpoints horizontally: increasing the value moves them
to the right, decreasing the value moves them to the left.

●

End offset Y moves right endpoints vertically: increasing the value moves them
upwards, decreasing the value moves them downwards.

●

Start handle offset X moves left control points horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.

●

Start handle offset Y moves left control points vertically: increasing the value
moves them upwards, decreasing the value moves them downwards.

●

End handle offset X moves right control points horizontally: increasing the value
moves them to the right, decreasing the value moves them to the left.

●

End handle offset Y moves right control points vertically: increasing the value
moves them upwards, decreasing the value moves them downwards.

RELATED LINKS
Changing the position and shape of ties individually on page 645

Changing the curvature direction of ties individually
You can change the curvature direction of individual ties. In Write mode this applies to whole tie
chains, but in Engrave mode you can change the style of each tie within tie chains separately.
PROCEDURE
1.

Select the ties whose curvature direction you want to change. You can do this in Write
mode and Engrave mode.

2.

Activate the Direction property in the Ties group of the Properties panel.

3.

Choose one of the following options:
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●

Up

●

Down

RESULT
The curvature direction of the selected ties is changed.
NOTE
You can adjust the precise shapes of tie chains, and of each tie within tie chains, in Engrave mode
using the square handles on each tie.

Tie shoulder offset
Tie shoulders affect the angles of the curves of ties as they taper towards an endpoint, as the
tapered ends often approach noteheads at a steeper angle than that of a tie’s arch.
Increasing the shoulder offset makes the onset of the curve shallower, whereas decreasing the
shoulder offset makes the onset steeper.
You can change the project-wide settings for the offset of tie shoulders by changing the value for
the following options under the Advanced Options disclosure arrow in the Design section of the
Ties page in Engrave > Engraving Options:
●

Shoulders are offset by [X]% of half the length of a short tie

●

Shoulders are offset by [X]% of half the length of a long tie

A long tie with default shoulder offset (1/10)

A long slur with increased shoulder offset (3/4)

You can change the shoulder offset of ties individually by moving their handles in Engrave mode.
●

Moving tie offset handles further apart reduces the shoulder offset.

●

Moving tie offset handles closer together increase the shoulder offset.

RELATED LINKS
Project-wide Engraving Options for ties on page 644
Changing the shoulder offset of ties individually on page 647

Changing the shoulder offset of ties individually
PROCEDURE
1.

In Engrave mode, select one of the control point handles of the ties whose shoulders you
want to adjust.
NOTE
You can select individual handles on multiple ties.
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2.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the handles in any direction to the positions you want.

RESULT
The shoulder offset of the selected ties is changed.
RELATED LINKS
Project-wide Engraving Options for ties on page 644
Tie shoulder offset on page 647
Changing the shoulder offset of ties individually on page 647

Changing the shoulder offset of ties individually using the
Properties panel
You can change the tie shoulder offset of individual ties by using properties in the Ties group of
the Properties panel in Engrave mode.
PROCEDURE
1.

In Engrave mode, select the ties whose shoulder offset you want to change.

2.

Activate the following properties, individually or together, in the Ties group of the
Properties panel:

3.

4.

●

Start handle offset

●

End handle offset

Each property has X and Y value fields. Change the values in the value fields in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move tie handles in the following ways:
●

Start handle offset X moves the left control points of ties horizontally: increasing
the value moves them to the right, decreasing the value moves them to the left.

●

Start handle offset Y moves the left control points of ties vertically: increasing the
value moves them upwards, decreasing the value moves them downwards.

●

End handle offset X moves the right control points of ties horizontally: increasing
the value moves them to the right, decreasing the value moves them to the left.

●

End handle offset Y moves the right control points of ties vertically: increasing the
value moves them upwards, decreasing the value moves them downwards.

RESULT
The shoulder offset of the selected ties is changed.
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RELATED LINKS
Project-wide Engraving Options for ties on page 644
Tie shoulder offset on page 647
Changing the shoulder offset of ties individually on page 647

Tie height
You can change values for the heights of all short ties and long ties project-wide by disclosing
Advanced Options in the Design section of the Ties page in Engraving Options. You can also
change the height of individual ties in Engrave mode.
Increasing the height of ties makes them extend further from the staff, giving them a rounder
shape and meaning they take up more vertical space. Ties generally do not need to be as curved
as slurs, as they join notes of the same pitch instead of arching over or above a range of pitches.
Where vertical space is tight, a balance needs to be found between how curved ties are and
ensuring staves do not overlap.

A long tie with default height

A long tie with increased height

Changing the height of ties individually
PROCEDURE
1.

In Engrave mode, select the tie height (middle) handle of the ties whose height you want
to change.

2.

Change the height of the selected ties in any of the following ways:
●

Press Alt-Up Arrow to move the handles upwards.

●

Press Alt-Down Arrow to move the handles downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Up Arrow.

●

Click and drag the handles upwards or downwards to the heights you want.

RELATED LINKS
Project-wide Engraving Options for ties on page 644

Tie styles
There are different styles of tie available in Dorico, which can be used to indicate different
meanings.
Solid
Ties are shown as tapered solid lines: thinner at the ends and thicker in the middle
(default).
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Dashed
Ties are shown as tapered dashed lines: thinner at the ends and thicker in the
middle.

Dotted
Ties are shown as dotted lines. The dots are the same size and the same distance
apart over the whole length of the tie.

Half-dashed start
The first half of ties appear as dashed lines, the second half as solid lines. Used to
denote that a tie was written incompletely in the source in critical editions.

Half-dashed end
The first half of ties appear as solid lines, the second half as dashed lines. Used to
denote that a tie was written incompletely in the source in critical editions.

Editorial
Ties appear as solid black lines, but with a smaller vertical line intersecting them
exactly halfway along its length. Used to show that tie have been added by the editor
and were not present in the source.

Changing the style of ties individually
You can change the style of ties individually. In Write mode this applies to whole tie chains, but in
Engrave mode you can change the style of each tie within tie chains separately.
PROCEDURE
1.

Select the ties whose style you want to change. You can do this in Write mode and Engrave
mode.

2.

Activate the Style property in the Ties group of the Properties panel.

3.

Select one of the following options from the menu:
●

Solid

●

Dashed

●

Dotted

●

Half-dashed start

●

Half-dashed end

●

Editorial

RESULT
The style of the selected ties is changed, according to your selection.
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NOTE
The precise parameters of each of these options can be set project-wide in Engrave > Engraving
Options. For example, you can change the height and width of the notch in Editorial ties, the
sizes of dots and dashes in ties, and the sizes of the gaps between dots and dashes.

Changing the thickness of dashed and dotted ties individually
You can change thickness of dashed and dotted ties as whole tie chains and as individual ties.
You can also change the thickness of all dashed ties and dotted ties project-wide on the Ties
page in Engraving Options.
PROCEDURE
1.

Select the dashed and dotted tie chains whose thickness you want to change.
NOTE
You can select whole tie chains in Write mode and Engrave mode.
You can select individual ties in Engrave mode.

2.

Activate the Dash/dot property in the Ties group of the Properties panel.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

RESULT
The thickness the selected dashed and dotted ties or dashed and dotted tie chains is changed.
Increasing the value makes dashes and dots thicker. Decreasing the value makes dashes and
dots thinner.
RELATED LINKS
Project-wide Engraving Options for ties on page 644

Changing the size of gaps in dashed and dotted ties individually
You can change the sizes of gaps in dashed and dotted ties for individual tie chains and
individual ties. You can also change the sizes of the gaps between dashes and dots in all dashed
ties and dotted ties project-wide on the Ties page in Engraving Options.
PROCEDURE
1.

Select the dashed or dotted tie chains whose gap sizes you want to change.
NOTE
You can select whole tie chains in Write mode and Engrave mode.
You can only select individual ties in Engrave mode.

2.

Activate the Gap property in the Ties group of the Properties panel.

3.

Change the value in the value field in any of the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.
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RESULT
The size of the gaps between dashes or dots for the selected ties or tie chains is changed.
Increasing the value makes the gaps between dashes or dots larger. Decreasing the value makes
the gaps between dashes and dots smaller.
RELATED LINKS
Project-wide Engraving Options for ties on page 644

Changing styles of tie chains individually
You can change the style of all ties within tie chains.
PROCEDURE
1.

In Write mode, select a note, a chord, or a tie within a tie chain.
This selects all notes, chords, and ties that are part of the same chain.

2.

Activate the Style property in the Ties group of the Properties panel.

3.

From the pop-up menu, select one of the available styles.

4.

Optional: If you selected one of the dashed/dotted styles, activate Dash/dot and enter or
select a value in the Spaces field.

RESULT
The appearance of all ties in the tie chain is changed.

Changing styles of individual ties within tie chains
You can change the styles of individual ties within a tie chain.
PROCEDURE
1.

In Engrave mode, select a tie.

2.

Activate the Style property in the Ties group of the Properties panel.

3.

From the pop-up menu, select one of the available styles.

4.

Optional: If you selected one of the dashed/dotted styles, activate Dash/dot and enter or
select a value in the Spaces field.

RESULT
The appearance of the selected tie is changed. All other ties in the chain remain unaffected.

Directions of tie curvatures
The direction of tie curvatures is different depending on note stem direction, the number of
notes in chords, and the number of voices in the staff.
The direction of the curvature of a tie is determined by many factors, including the following:
●

The stem direction of the note or chord at each end of the tie

●

The number of voices that are active on the staff

●

The number of notes in the chord at each end of the tie

Tied single notes in single-voice contexts
If a single voice is active and a tie joins two single notes, the direction of the ties is determined by
the stem directions of the notes at either end of the tie.
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●

If the stem directions match, the tie curves away from the notes and is positioned on the
notehead side.

●

If the stem directions differ, the tie curves upwards by default.

Tied chords in single-voice contexts
If a tie joins two chords, the direction of the ties is determined by the number of tied notes in the
chords.
●

For an even number, the ties are equally split between curving towards the notehead end
and curving towards the stem end.

●

For an uneven number, the majority of ties curve towards the notehead end.

Tied notes in multiple-voice contexts
Ties are positioned on the stem side and are curved as follows:
●

For up-stemmed voices, the ties curve upwards.

●

For down-stemmed voices, the ties curve downwards.

●

For overlapping or interlocking pitches of multiple voices, the rules for tied chords in onevoice pieces of music are used. All notes in all voices are treated as if they belong to a
single voice.

Changing curvature directions between notes of different stem
directions
You can specify that a tie between two notes of different stem directions curves away from the
middle staff line.
By default, the direction of the curvature is upwards.
PROCEDURE
1.

In Engrave mode, select Engrave > Engraving Options.

2.

Select the Ties category.

3.

In the Ties Direction subcategory, in the Curvature direction for ties when stem
directions differ section, select Ties curve away from staff.

4.

Click Apply.

Changing curvature directions in tie chains
You can change the curvature direction of all ties within a tie chain.
PROCEDURE
1.

In Write mode, select a note, a chord, or a tie within a tie chain.
This selects all notes, chords, and ties that are part of the same chain.

2.

Activate the Direction property in the Ties group of the Properties panel.

3.

Select one of the following options:
●

Up

●

Down

RESULT
The direction of all ties in the chain of tied notes is changed.
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Changing curvature directions of individual ties
You can change the curvature direction of individual ties within a tie chain.
PROCEDURE
1.

In Engrave mode, select a tie.

2.

Activate the Direction property in the Ties group of the Properties panel.

3.

Select one of the following options:
●

Up

●

Down

RESULT
The direction of the tie is changed. All other ties in the chain remain unaffected.
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Tremolos are thick, slanted lines that cross individual stems or are positioned between multiple
stems. They are used to indicate that notes should be repeated, either individual notes or
sequences of multiple notes.
Using tremolo strokes instead of notating each notehead you want can save horizontal space in
scores and make fast passages easier to read.
The number of tremolo strokes used indicates both how many times players should repeat
notes, and how fast they should be. In measured tremolos, for example, one tremolo stroke on
the stem of a quarter note indicates two eighth notes should be played, whereas three tremolo
strokes on the stem of a quarter note indicates eight 32nd notes should be played.

Quarter note with one stroke single-note tremolo
and its equivalent notation

Quarter note with three strokes single-note tremolo
and its equivalent notation

There are different types of tremolo:
Measured tremolos
The number of tremolo strokes corresponds to a precise rhythm in the prevailing
tempo and meter.
Unmeasured tremolos
There is no link between the number of strokes and rhythm, instead unmeasured
tremolos should be played as fast as possible, whatever the tempo.
Single-note tremolos
Individual notes are repeated.

Multi-note tremolos
Multiple notes, usually two, are played in sequence similar to a trill.

Tuplet tremolos
Multiple notes in tuplets are played in sequence.
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Tremolos in tie chains
By default, all notes in tie chains are shown with tremolo strokes when single-note tremolos are
added to tie chains. Deleting tremolo strokes from tied notes removes tremolo strokes from all
notes in tie chains.
In Dorico, tremolos are considered measured by default, so the number of tremolo strokes
shown is automatically adjusted on subsequent notes in tie chains as required. For example,
if an eighth note with two tremolo strokes is tied to a quarter note, the quarter note should
have three tremolo strokes. This is because tremolo strokes function like beams, so two tremolo
strokes and an eighth note stem flag is the equivalent of three tremolo strokes.
However, there may be instances where you want all notes to have the same number of tremolo
strokes, whatever their duration. You may also want to start tremolos partway through tie
chains, or stop tremolos partway through tie chains.
You can change the number of tremolo strokes shown on individual notes independently in
Engrave mode.
RELATED LINKS
Changing the number of single-note tremolo strokes on individual notes in tie chains on page
656

Changing the number of single-note tremolo strokes on individual
notes in tie chains
PROCEDURE
1.

In Engrave mode, select the noteheads of the notes whose number of tremolo strokes you
want to change.

2.

Activate the Single stem tremolo property in the Notes and Rests group of the
Properties panel.

3.

Select one of the following options from the menu:
●

None

●

One stroke

●

Two strokes

●

Three strokes

●

Buzz roll

RESULT
The number of tremolo strokes shown on the selected notes is changed.
EXAMPLE

The default number of tremolo strokes in a tie chain
where the second note is longer than the first

The number of tremolo strokes on the second note
has been changed to match the first

RELATED LINKS
Changing the number of tremolo strokes of existing tremolos on page 660

656

Tremolos
General placement conventions for tremolos

General placement conventions for tremolos
Single-note tremolos are positioned on note stems, whereas multi-note tremolos are positioned
between the stems of two or more notes.
When multi-note tremolos cross three or more notes, the tremolo strokes are positioned in the
middle of all the notes.
Tremolo strokes are slightly thinner than beams, so that the gaps between strokes is large
enough and the number of strokes can be instantly recognized.
Tremolo strokes should not collide with ledger lines or stem flags. Dorico automatically positions
tremolo strokes to ensure such collisions are avoided.
Tremolo strokes in the staff are positioned so that they are at least one staff space clear of
noteheads, and at valid positions relative to staff lines and staff spaces. This means that tremolo
strokes may not move every time you change the pitch of notes, as demonstrated in this
example.

The positions of the tremolo strokes on the first two notes and the last two notes are the same, although the
pitches are all different

In Dorico, the angle of single-note tremolo strokes is always the same, no matter the direction of
the phrase.
The angles of multi-note tremolos are determined by the positions of the ends of the stems
to which the multi-note tremolos apply. You can change the angles of multi-note tremolos
individually by moving the position of the stems at each end.
You can change values for the default positions of tremolo strokes project-wide on the Tremolos
page in Engrave > Engraving Options.
RELATED LINKS
Moving multi-note tremolo strokes graphically using the Properties panel on page 663
Project-wide Engraving Options for tremolos on page 663

Inputting tremolos
Tremolos can only be input by clicking buttons in the Tremolos section of the Repeat Structures
panel on the right of the window in Write mode.
Tremolos are included in the Repeat Structures panel because they indicate that notes should
be repeated, either individually as single-note tremolos or in sequences as multi-note tremolos.

The Tremolos section of the Repeat Structures panel
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Inputting single-note tremolos
PROCEDURE
1.

In Write mode, select the notes on which you want to input single-note tremolos.

2.

Click the button with the numbers of single-note tremolo strokes you want in the
Tremolos section of the Repeat Structures panel. For example, click Two Strokes Singlenote Tremolo to input single-note tremolos with two strokes:

RESULT
Single-note tremolos are input on the selected notes with the number of tremolo strokes
specified.
EXAMPLE

Single-note tremolos with two tremolo strokes

RELATED LINKS
Deleting tremolo strokes on page 660

Inputting multi-note tremolos
PROCEDURE
1.

In Write mode, select one of the following:
●

Pairs of adjacent notes between which you want to input multi-note tremolos

●

Individual notes on which you want to input multi-note tremolos
NOTE
You cannot input multi-note tremolos on notes that are not immediately followed by
another note.

2.

Click the button with the numbers of multi-note tremolo strokes you want in the Tremolos
section of the Repeat Structures panel. For example, click Three Strokes Multi-note
Tremolo to input multi-note tremolos with three strokes:

RESULT
Multi-note tremolos with the number of tremolo strokes specified are input between selected
individual notes and the notes immediately after them, or between selected pairs of notes.
NOTE
The appearance of multi-note half note tremolos depends on your choice on the Tremolos page
in Engrave > Engraving Options.
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EXAMPLE

Multi-note tremolos with three tremolo strokes

RELATED LINKS
Deleting tremolo strokes on page 660
Changing the appearance of multi-note half note tremolos project-wide on page 664

Inputting multi-note tremolos across tuplets
You can input multi-note tremolos across more than two notes if they are tuplets. This indicates
that the notes in the tuplet should be repeated in the notated sequence.
PROCEDURE
1.

In Write mode, select the tuplets across which you want to input multi-note tremolos.
TIP
You can select whole tuplets, including their brackets, or just the noteheads in the tuplets.

2.

Click the button with the numbers of multi-note tremolo strokes you want in the Tremolos
section of the Repeat Structures panel. For example, click Three Strokes Multi-note
Tremolo to input multi-note tremolos with three strokes:

RESULT
Multi-note tremolos are input across the selected tuplets, with the tremolo strokes positioned in
the center of all notes in the tuplet. The tuplet bracket is deleted, and a signpost is shown at the
start of each tuplet indicating its ratio.
NOTE
The appearance of multi-note half note tremolos depends on your choice on the Tremolos page
in Engrave > Engraving Options.
EXAMPLE

Multi-note tremolos with three tremolo strokes across tuplets

RELATED LINKS
Changing the appearance of multi-note half note tremolos project-wide on page 664
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Changing the number of tremolo strokes of existing
tremolos
PROCEDURE
1.

In Write mode, select the tremolos whose number of tremolo strokes you want to change.
The corresponding buttons to the numbers of tremolo strokes included in your selection
are shown as selected in the Tremolos section of the Repeat Structures panel.
NOTE
Select single-note tremolos and multi-note tremolos separately.

2.

Click the button with the numbers of tremolo strokes you want in the Tremolos section
of the Repeat Structures panel. For example, click Two Strokes Single-note Tremolo to
input single-note tremolos with two strokes, or click Three Strokes Multi-note Tremolo to
input multi-note tremolos with three strokes:

Two Strokes Single-note Tremolo

Three Strokes Multi-note Tremolo

RESULT
The number of strokes in the tremolos on the selected notes is changed.
RELATED LINKS
Changing the number of single-note tremolo strokes on individual notes in tie chains on page
656
Deleting tremolo strokes on page 660

Deleting tremolo strokes
PROCEDURE
1.

In Write mode, select the notes whose tremolo strokes you want to delete.

2.

Click the appropriate buttons in the Tremolos section of the Repeat Structures panel for
the types of tremolos selected:
●

Remove Single-note tremolo

●

Remove Multi-note tremolo

RESULT
If you click Remove Single-note tremolo, single-note tremolo strokes are deleted.
If you click Remove Multi-note tremolo, multi-note tremolo strokes are deleted.
Both types of tremolo strokes are deleted if you click both buttons.
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EXAMPLE

Notes with single-note tremolos
and multi-note tremolo

Notes with multi-note tremolo
deleted but single-note tremolos
remain

Notes with both multi-note
tremolo and single-note tremolos
deleted

Moving notes with tremolos rhythmically
You can move notes with single-note tremolos and multi-note tremolos to new rhythmic
positions in the same ways as moving normal notes. However, if you move multi-note tremolos
across barlines, the tremolo strokes are deleted automatically.
NOTE
You can undo moving tremolos immediately, which restores any multi-note tremolo strokes
deleted in the process.
However, simply moving multi-note tremolos back to their previous positions later does not
restore any multi-note tremolo strokes deleted when they were moved previously. The deleted
multi-note tremolo strokes must be re-input if necessary.
You can move single-note tremolos to new rhythmic positions and across barlines without
affecting their tremolo strokes. The notes are automatically respelled as tie chains if required, in
the same ways that normal notes are.
NOTE
If tie chains with single-note tremolos contain notes of different durations, the number of
tremolo strokes on each note in the tie chain is different. You can change the number of tremolo
strokes shown on each note in tie chains individually.

RELATED LINKS
Positions of notes on page 461
Changing the number of single-note tremolo strokes on individual notes in tie chains on page
656

Positions of tremolo strokes
Dorico automatically positions tremolo strokes correctly relative to noteheads and staff lines.
However, if you find you need to change the positions of tremolo strokes, you can move
individual tremolos graphically in Engrave mode.
You can move tremolo strokes upwards and downwards along their stems in Engrave mode. You
cannot move tremolo strokes to the right or left.
NOTE
When you first move tremolo strokes graphically, they may appear to move in the wrong
direction or by a larger increment than you expected. This is because their positions are reset
when you override those positions by moving them.
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You can also change the positions of tremolo strokes for all tremolos project-wide on the
Tremolos page in Engrave > Engraving Options.
RELATED LINKS
Project-wide Engraving Options for tremolos on page 663

Moving tremolo strokes graphically
PROCEDURE
1.

In Engrave mode, select the tremolo strokes you want to move.

2.

Move the tremolo strokes in any of the following ways:
●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
NOTE
If you want to move tremolo strokes by larger increments, you can press Ctrl/Cmd
as well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the tremolo strokes upwards and downwards to the positions you
want.

Moving multi-note tremolo strokes also changes the length of the stems to which they are
attached.
RESULT
The selected tremolo strokes are moved upwards or downwards.
RELATED LINKS
Project-wide Engraving Options for tremolos on page 663

Moving single-note tremolo strokes graphically using the Properties
panel
PROCEDURE
1.

In Engrave mode, select the noteheads whose single-note tremolo strokes you want to
move.

2.

Activate the Tremolo Y property in the Notes and Rests group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The property moves single-note tremolo strokes in the following ways:
●

Increasing the value moves single-note tremolo strokes upwards.

●

Decreasing the value moves single-note tremolo strokes signs downwards.

RELATED LINKS
Project-wide Engraving Options for tremolos on page 663
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Moving multi-note tremolo strokes graphically using the Properties
panel
You can move multi-note tremolo strokes graphically using the Properties panel. You can also
change the angles of multi-note tremolo strokes using the same method, as each end of multinote tremolo strokes is moved independently.
PROCEDURE
1.

In Engrave mode, select the noteheads at the beginning of the multi-note tremolos whose
strokes you want to move.

2.

Activate the Start Y offset property in the Beaming group of the Properties panel.

3.

Change the value in the value field in any of the following ways:

4.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The property moves the left end of multi-note tremolo strokes in the following ways:
●

Increasing the value moves the left end of multi-note tremolo strokes upwards.

●

Decreasing the value moves the left end of multi-note tremolo strokes signs
downwards.

5.

Select the noteheads at the ends of the multi-note tremolos whose strokes you want to
move.

6.

Activate the End Y offset property in the Beaming group of the Properties panel.

7.

Change the value in the value field in any of the following ways:

8.

●

Enter a value into the value field.

●

Click the arrows beside the value field.

The property moves the right end of multi-note tremolo strokes in the following ways:
●

Increasing the value moves the right end of multi-note tremolo strokes upwards.

●

Decreasing the value moves the right end of multi-note tremolo strokes signs
downwards.

RELATED LINKS
Project-wide Engraving Options for tremolos on page 663

Project-wide Engraving Options for tremolos
Options for the appearance and positions of tremolos project-wide can be found on the
Tremolos page in Engraving Options.
The options on this page allow you to change the appearance of tremolo strokes, and their
positions relative to the ends of stems, stem flags, noteheads, and beams.
Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Tremolos in the page list on the left of the dialog.
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RELATED LINKS
Project-wide Engraving Options for stems on page 597

Changing the appearance of multi-note half note tremolos projectwide
There are multiple accepted ways of notating multi-note half note tremolos. You can change how
multi-note half note tremolos are notated project-wide.
PROCEDURE
1.

In Engrave mode, choose Engrave > Engraving Options.

2.

Click Tremolos in the page list.

3.

Choose one of the following options for the Appearance of half note (minim) tremolos
option in the Multi-note Tremolos section:

4.

●

All lines join stems

●

Outermost line joins stems

●

No lines join stems (default)

Click Apply, then Close.

RESULT
The appearance of all multi-note half note tremolos project-wide is changed, according to your
preference.

Tremolos in playback
You can control the playback of unmeasured tremolos by specifying the minimum number of
tremolo strokes that are interpreted as unmeasured tremolos on the Timings page in Playback
Options. This considers both the number of tremolo strokes and the number of beam lines that
would be used for the note.
For example, if the option is set to require three tremolo strokes, an eighth note (quaver) with
two tremolo strokes is played as unmeasured, because the single beam of the eighth note is
included in the calculation.
You can also specify the default length of notes in unmeasured tremolos. You express the
duration of notes as a fraction of the length of a quarter note (crotchet) played at 120 quarters
per minute.
For example, to change the value in the value field to set the default length to 0.5 seconds,
enter 1 into the value field, or click the arrows beside the value field to change the value, for the
Default unmeasured tremolo length option in the Tremolos section on the Timings page in
Playback Options.
TIP
If you hover your mouse pointer over either of the arrows beside the value field for the Default
unmeasured tremolo length option, a small box appears that displays the current fraction as a
decimal.
The number of tremolo strokes determines the note value of the repeated notes. For example,
one stroke indicates an eighth note, two strokes indicate a 16th note, and so on.
You can open Playback Optionsby choosing Play > Playback Options in Play mode, or by
pressing Ctrl/Cmd-Shift-P in any mode.
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Tuplets indicate where a beat is divided into a different number of subdivisions than is usually
expected according to the current meter. They can be used to fit more notes or fewer notes in a
beat than usually exist in a beat, according to the usual pattern of subdivision.

A 4/4 bar with the standard subdivision of four
quarter notes.

A 4/4 bar with a subdivision of six triplet quarter
notes in the space of four regular quarter notes.

A 6/8 bar with the standard subdivision of eight
eighth notes.

A 6/8 bar with a subdivision of four duplet eighth
notes in the space of six regular eighth notes.

Because these subdivisions are not standard but tuplet notes use the same rhythmic notation as
normal notes, tuplets must be clearly marked to show that their rhythmic duration is different.
In the above examples, the triplet quarter notes are shown under a bracket with the number 3.
The duplet eighth notes do not need to have a bracket as they are joined by a beam, which has a
number 2 beside it.
Tuplets in Dorico can be shown with a tuplet bracket, with a tuplet bracket and a tuplet number
or ratio, or with a tuplet bracket and a tuplet number or ratio and a note indicating the note
value of the tuplet.

General placement conventions for tuplets
Tuplet brackets and tuplet numbers or ratios are generally placed on the stem side of notes.
When tuplets are shown with a tuplet beam, a tuplet bracket is not always necessary but can be
shown in addition to a tuplet number or ratio.
According to convention, tuplet brackets and tuplet numbers or ratios are always placed above
the staff for vocal staves, so they do not come between notes and lyrics.
Tuplet brackets should be placed as close to notes as possible without colliding with other
notation, such as slurs or articulation. Slurs are usually placed inside tuplet brackets if the slur
is shorter than the tuplet bracket. If a slur is longer than a tuplet bracket, the slur can be placed
outside the tuplet bracket.
The horizontal position of tuplet brackets should allow it to be immediately obvious which notes
are included in the bracket. They should not extend so far that notes following the tuplet appear
to be included.
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A tuplet clearly showing the three quarter notes
included in the triplet.

With an extended tuplet bracket, the duration of the
triplet is now unclear.

Inputting tuplets with the keyboard
Tuplets are input like normal notes, and so can only be input during note input.
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where you want to input tuplets.

3.

Open the tuplets popover in any of the following ways:

4.

●

Press ;

●

Choose Write > Create Tuplet

Enter the tuplet you want into the popover as a ratio, such as 3:2. Dorico continues
inputting tuplets of the same ratio until told to stop.
TIP
You can advance the caret using Space to continue inputting tuplets of the same ratio at
later rhythmic positions.

5.

Press Return to close the popover and enter the tuplet.

6.

Enter or play in the pitches you want.

7.

Stop inputting tuplets in one of the following ways:
●

Press Shift-; to return to inputting normal notes.

●

Move the caret with the arrow keys to return to inputting normal notes.

●

Press Esc to stop note input completely.

NOTE
If you want to input a different type of tuplet immediately after inputting tuplets, you must
stop the first type of tuplet before inputting the second type. If you do not stop the first
type, the second type is input as a nested tuplet.

RESULT
The pitches you type in or play in are input as tuplets, starting from the caret position.
RELATED LINKS
The tuplets popover on page 666
Inputting notes on page 94

The tuplets popover
You can input tuplets with the keyboard by using the tuplets popover in Write mode. It can only
be opened during step input.
You can open the tuplets popover when note input is activated by pressing ;, or by choosing
Write > Create Tuplet.
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Tuplets are often described in ratios, such as 3:2, so the tuplets popover uses this key to be
memorable.
The icon on the left-hand side of the popover matches the corresponding button in the Notes
toolbox on the right of the window.

The tuplets popover with an example entry for a
tuplet

The tuplets button in the Notes toolbox

When inputting tuplets with the keyboard, Dorico continues inputting notes as the specified
tuplet until any of the following happens:
●

You press Shift-; to return to inputting normal notes

●

You move the caret with the arrow keys

●

You stop note input

Here are some examples of what to enter into the tuplets popover, and the tuplets that are input
as a result.
Enter:

For tuplet type:

3 or 3:2

Triplet, three notes in the space of two.

3:4

Triplet, three notes in the space of four.

5:4

Quintuplet, five notes in the space of four.

5:2

Quintuplet, five notes in the space of two.

7:4

Septuplet, seven notes in the space of four.

7:2

Septuplet, seven notes in the space of two.

2:3

Duplet, two notes in the space of three, often
used in compound meters.

5:6

Quintuplet, five notes in the space of six, often
used in compound meters.

NOTE
The duration of each note in the tuplet, and the total duration of the tuplet, depends on the note
value selected when you open the popover. The ratio specified relates to the selected note value.
This list is not comprehensive: it is intended to illustrate how you can structure your entry to
input different tuplets.
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Inputting nested tuplets with the keyboard
Nested tuplets are tuplets within larger tuplets.

An example of nested tuplets.

You can input nested tuplets in new, empty staves, or select an existing tuplet and input a nested
tuplet within it.
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where you want to input nested tuplets.

3.

Open the tuplets popover in any of the following ways:
●

Press ;

●

Choose Write > Create Tuplet

4.

If inputting nested tuplets in an empty staff, enter the ratio for the outer tuplet into the
popover, such as 3:2.

5.

Press Return to close the popover and enter the outer tuplet.
NOTE
You can skip steps 4 and 5 if you are inputting nested tuplets to existing tuplets.

6.

Open the tuplets popover again.

7.

Enter the ratio for the inner tuplet into the popover, such as 5:4.

8.

Press Return to close the popover and enter the inner tuplet.

9.

Enter or play in the pitches you want.

10.

Stop inputting tuplets in one of the following ways:
●

Press Shift-; to return to inputting normal notes.

●

Move the caret with the arrow keys to return to inputting normal notes.

●

Press Esc to stop note input completely.

RESULT
The pitches you type in or play in are input as nested tuplets, starting from the caret position.
They continue as the specified nested tuplet until stopped in one of the ways described above.

Inputting tuplets with the mouse
Tuplets are input like normal notes, and so can only be input during note input.
NOTE
When inputting with the mouse, only triplets can be input and they can only be input one at a
time. You can input all other tuplets and nested tuplets by using the tuplets popover with the
keyboard.

PROCEDURE
1.

In Write mode, start note input.
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2.

Position the caret at the rhythmic position where you want to input a triplet.

3.

Select the note value of the triplet in the Notes toolbox. For example, if you want to input a
triplet of three eighth notes in the space of two normal eighth notes, select the eighth note
button.

4.

Click Tuplets in the Notes toolbox:

5.

Click in or play in the pitch or pitches you want.

RESULT
The pitches you click in are input as a triplet at the caret position. Repeat these steps to input
more triplets.
RELATED LINKS
Inputting tuplets with the keyboard on page 666
Inputting nested tuplets with the keyboard on page 668
Inputting notes on page 94

Inputting nested tuplets with the mouse
Nested tuplets are tuplets within larger tuplets.

An example of nested tuplets.

You can input nested tuplets in new, empty staves, or select an existing tuplet and input a nested
tuplet within it.
NOTE
When inputting with the mouse, only triplets can be input and they can only be input one at a
time. You can input all other tuplets and nested tuplets by using the tuplets popover with the
keyboard.

PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret at the rhythmic position where you want to input a nested triplet.

3.

If inputting a nested triplet in an empty staff, select the note value of the outer triplet in
the Notes toolbox. For example, if you want to input a triplet of three quarter notes in the
space of two normal quarter notes, select the quarter note button.

4.

Click Tuplets in the Notes toolbox:

NOTE
You can skip steps 3 and 4 if you are inputting a nested triplet to existing an existing
tuplet.
5.

Select the note value of the inner triplet in the Notes toolbox. For example, if you want to
input a triplet of three eighth notes in the space of two eighth notes in the outer triplet,
select the eighth note button.
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6.

Click Tuplets in the Notes toolbox again.

7.

Click in or play in the pitch or pitches you want.

RESULT
The pitches you type in or play in are input as a nested triplet at the caret position.
RELATED LINKS
Inputting tuplets with the keyboard on page 666
Inputting nested tuplets with the keyboard on page 668

Changing the pitch of tuplets
The pitch of tuplets can be changed after they have been input like any other note.
PROCEDURE
1.

In Write mode, select the tuplets whose pitch you want to change.

2.

Use the following key commands to change the pitch:
●

Alt-Up Arrow to transpose tuplets up one note

●

Ctrl/Cmd-Alt-Up Arrow to transpose tuplets up one octave

●

Alt-Down Arrow to transpose tuplets down one note

●

Ctrl/Cmd-Alt-Down Arrow to transpose tuplets down one octave

Adding accidentals and articulation to tuplets
Accidentals and articulation can be added to tuplets in the same ways as they can be added to
normal notes.
Simply press / and type your preferred tuplet ratio into the tuplets popover, or click Tuplets in
the Notes panel, to input tuplets instead of normal notes.

The tuplets button

Articulation is positioned between noteheads or stems and tuplet brackets, so they are closer to
the notes than tuplet brackets or tuplet numbers or ratios.
RELATED LINKS
Adding accidentals to existing notes on page 189
Inputting notes with accidentals on page 188
Inputting articulations during step input with the keyboard on page 205
Inputting articulations during step input with the mouse on page 206

Adding slurs to tuplets
Slurs can be added to tuplets in the same ways as they can be added to normal notes.
RELATED LINKS
Inputting slurs during step input on page 568
Adding slurs to existing notes on page 568
Slurs in Engrave mode on page 575
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Moving tuplets rhythmically
You can move tuplets to different rhythmic positions after they have been input.
NOTE
Tuplets cannot be moved rhythmically using the mouse.

PROCEDURE
1.

In Write mode, select the tuplets you want to move.
NOTE
A tuplet number or ratio, or a tuplet bracket must be included in the selection if you want
the notes to stay a tuplet. If a tuplet number or ratio, or a tuplet bracket is not selected,
the notes become normal notes of their rhythmic value.

2.

Move the selected tuplets in any of the following ways:
●

Alt-Right Arrow

●

Alt-Left Arrow

RESULT
The selected tuplets move to the right or to the left along the staff according to the rhythmic grid
currently set.
If a tuplet number, tuplet ratio, or tuplet bracket is included in the selection, the whole tuplet is
moved along the staff. If it crosses a barline, the tuplet is automatically adjusted to compensate,
as demonstrated in the examples. However, it is not adjusted at the mid-point of bars, where it is
convention to split tuplets to show the beat division. You may want to change this manually.
EXAMPLE

Deleting tuplets
PROCEDURE
1.

In Write mode, select the tuplets you want to delete.
TIP
To delete an entire tuplet and all the notes within it, select all the noteheads and either the
tuplet bracket, or tuplet number or ratio.

2.

Delete the tuplets in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected tuplets are deleted.
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Selecting just the notes deletes the notes, but not the tuplet. Selecting just the tuplet bracket
or tuplet number or ratio deletes the tuplet, but not all of the notes. How many notes remain
depends on their rhythmic values.

Tuplet beams
Tuplet beams join notes in tuplets that can be joined with beams just like non-tuplet beams. You
can make the same changes to tuplet beams that you can make to any other beam.
RELATED LINKS
Beaming on page 246
Tuplets within beams on page 259
Beaming notes together on page 251
Unbeaming notes on page 250
Splitting beam groups on page 249
Changing the direction of partial beams on page 250
Changing beam slants individually on page 254

Tuplet brackets
Tuplet brackets show the duration of triplets that are not joined by beams, such as triplet quarter
notes, by showing the notes within the tuplet under a bracket.
You can change the precise positions and shapes of tuplet brackets individually in Engrave mode.
Each tuplet bracket has four handles that can be moved graphically.

The two upper handles set the position of the left end and the right end of the tuplet bracket.
These handles can be moved independently of each other to create angled tuplet brackets,
even if you have set tuplet brackets to be Always horizontal on the Tuplets page in Engrave >
Engraving Options.
The two lower handles set the length of the tuplet bracket hooks. Moving either of these handles
changes the length of both hooks.

Moving tuplet brackets graphically
You can move tuplets numbers or ratios and tuplet brackets graphically without changing the
rhythmic positions to which they apply.
PROCEDURE
1.

2.

In Engrave mode, select any of the following that you want to move:the tuplet brackets,
tuplet numbers, or tuplet ratios you want to move.
●

Tuplet brackets

●

Tuplet numbers

●

Tuplet ratios

Move the tuplet brackets in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.
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●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move tuplet brackets by larger increments, you can press Ctrl/Cmd
as well as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag them in any direction to the positions you want.

RESULT
The selected tuplet brackets, tuplet numbers, or tuplet ratios are moved to a new graphical
positions, without changing their rhythmic positions.

Moving tuplet brackets graphically using the properties panel
You can move tuplet brackets graphically using the Properties panel. As you can change values
for the properties for each end of tuplet brackets independently of each other, you can also use
the properties to change the angles of tuplet brackets.
PROCEDURE
1.

2.

3.

4.

In Engrave mode, select one of the following that you want to move:
●

Tuplet brackets

●

Tuplet numbers

●

Tuplet ratios

Activate the following properties, individually or together, in the Tuplets group of the
Properties panel:
●

Start offset

●

End offset

Each property has X and Y value fields. Change the values in the value fields in any of the
following ways:
●

Enter values into the value fields.

●

Click the arrows beside the value fields.

The properties move tuplet brackets, tuplet numbers, and tuplet ratios in the following
ways:
●

Start offset X: increasing the value moves the left end of tuplet brackets to the
right, decreasing the value moves the left end of tuplet brackets to the left.

●

Start offset Y: increasing the value moves the left end of tuplet brackets upwards,
decreasing the value moves the left end of tuplet brackets downwards.

●

End offset X: increasing the value moves the right end of tuplet brackets to the
right, decreasing the value moves the right end of tuplet brackets to the left.

●

End offset Y: increasing the value moves the right end of tuplet brackets upwards,
decreasing the value moves the right end of tuplet brackets downwards.

●

Hook length: increasing the value makes tuplet bracket hooks longer, decreasing
the value makes tuplet bracket hooks shorter.
NOTE
Tuplet bracket hooks of the same tuplet cannot be different lengths.
Both Start offset and End offset properties have the same effect on tuplet numbers
and tuplet ratios. Their X values both move tuplet numbers and ratios horizontally,
and their Y values both move tuplet numbers and ratios vertically.
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Changing the angles of tuplet brackets individually
You can change the angles of individual tuplet brackets by moving the square handles on each
corner of tuplet brackets to new graphical positions independently.
PROCEDURE
1.

In Engrave mode, select the square handle on one of the corners of the tuplet brackets
whose angles you want to change.

2.

Move the handles in any of the following ways:
●

Press Alt-Right Arrow to move them to the right.

●

Press Alt-Left Arrow to move them to the left.

●

Press Alt-Up Arrow to move them upwards.

●

Press Alt-Down Arrow to move them downwards.
TIP
If you want to move handles by larger increments, you can press Ctrl/Cmd as well
as the standard key command, for example, Ctrl/Cmd-Alt-Left Arrow.

●

Click and drag the handles in any direction to the positions you want.

RELATED LINKS
Moving tuplet brackets graphically on page 672
Changing whether tuplet brackets are angled or horizontal individually on page 677
Tuplet brackets on page 672

Individual changes to the appearance and position of tuplet
numbers or ratios and tuplet brackets
You can change the appearance and positions of tuplet numbers, tuplet numbers, and tuplet
ratios, independently of your project-wide settings.

Changing the appearance of tuplet numbers and ratios individually
To change which tuplet number or ratio is shown for individual tuplets:
PROCEDURE
1.

Select the tuplet brackets of the tuplets whose tuplet number or ratio you want to change.
You can do this in Write mode and Engrave mode.
NOTE
The Tuplets group of the Properties panel is only shown if you selected tuplet brackets. It
is not shown if you select notes within the tuplet, or notes within the tuplet and the tuplet
bracket.

2.

Activate the Number property in the Tuplets group of the Properties panel.

3.

Select one of the following options:
●

None

●

Number
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●

Ratio

●

Ratio+note

RESULT
The tuplet number or ratio shown for the selected tuplets is changed according to your selection.
deactivating the property returns selected tuplets to your project-wide settings for number or
ratio.
NOTE
You can change which tuplet number or ratio appears on all tuplets project-wide in the Number
and Ratio section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for tuplets on page 677

Changing the position of tuplet numbers and ratios individually
You can change the horizontal positions of tuplet numbers and ratios in individual tuplet
brackets.
PROCEDURE
1.

Select the tuplet brackets whose tuplet number or ratio positions you want to change. You
can do this in Write mode and Engrave mode.

2.

Activate the Center property in the Tuplets group of the Properties panel.

3.

Select one of the following options:
●

Visual: positions tuplet numbers or ratios at the visual center of the tuplet beam or
tuplet bracket.

●

Rhythmic: positions tuplet numbers or ratios at the rhythmic center of the tuplet
beam or tuplet bracket, which may be visually off-center.

RESULT
The position of the tuplet numbers or ratios for the selected tuplets is changed according to your
selection.
deactivating the property returns selected tuplets to your project-wide settings for tuplet number
or ratio horizontal position.
NOTE
You can change the horizontal position of tuplet numbers or ratios on all tuplets project-wide in
the Number and Ratio section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Tuplet brackets on page 672
Changing the angles of tuplet brackets individually on page 674
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Changing the placement of tuplet brackets relative to the staff
To change the placement of tuplets relative to the staff or staves:
PROCEDURE
1.

Select the tuplet brackets whose placement you want to change. You can do this in Write
mode and Engrave mode.

2.

Activate the Placement property in the Tuplets group of the Properties panel.

3.

Select one of the following options:
●

Above

●

Below

●

Cross-stave above

●

Cross-stave below

RESULT
The placement of the selected tuplet brackets is changed according to your selection.
deactivating the property returns selected tuplets to their default placement.
NOTE
You can change the placement of all tuplet brackets for vocal staves project-wide in the
Placement section of the Tuplets page in Engrave > Engraving Options.

Changing the rhythmic end positions of tuplet brackets
To change the end positions of tuplet brackets rhythmically relative to notes individually:
PROCEDURE
1.

Select the tuplet brackets whose end positions you want to change. You can do this in
Write mode and Engrave mode.

2.

Activate the End position property in the Tuplets group of the Properties panel.

3.

Select one of the following options:
●

End at right-hand side of final note

●

End immediately before following note

●

End at position of final tuplet division
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RESULT
The end position for the selected tuplet brackets is changed according to your selection.
deactivating the property returns selected tuplets to your project-wide settings for tuplet bracket
end position.
NOTE
You can change the horizontal position of tuplet numbers or ratios on all tuplets project-wide in
the Horizontal Position section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Changing the angles of tuplet brackets individually on page 674
Project-wide Engraving Options for tuplets on page 677

Changing whether tuplet brackets are angled or horizontal
individually
You can change whether individual tuplet brackets appear angled or horizontal.
PROCEDURE
1.

Select the tuplet brackets whose angle you want to change. This can be done in Write
mode and Engrave mode.

2.

Activate the Can slope property in the Tuplets group of the Properties panel.

3.

Select one of the following options:
●

Check the box beside the activation switch to allow the selected tuplet brackets to
appear angled.

●

Leave the box beside the activation switch unchecked to force the selected tuplet
brackets to appear horizontal.

RESULT
The selected tuplet brackets appears angled if the box if checked, and appear horizontal if the
box is not checked.
deactivating the property returns selected tuplets to your project-wide settings for angled
brackets.
NOTE
You can change whether tuplet brackets appear angled or horizontal on all tuplets project-wide
in the Brackets section of the Tuplets page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for tuplets on page 677
Changing the angles of tuplet brackets individually on page 674

Project-wide Engraving Options for tuplets
Options for the appearance of tuplets, tuplet brackets, and tuplet numbers or ratios project-wide
can be found on the Tuplets page in Engraving Options.
The options on this page allow you to change the appearance and angles of tuplet brackets,
and the position of tuplet brackets, tuplet numbers, and tuplet ratios relative to the staff and
noteheads.
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Many options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

You can then click Tuplets in the page list on the left of the dialog.
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The term “unpitched percussion” covers all percussion instruments that are not tuned to specific
pitches. This includes instruments such as bass drum, guiro, maracas, cymbals, and shakers.
Dorico provides comprehensive support for unpitched percussion notation, with flexible options
for combining music for multiple instruments into kits that can then be displayed differently in
different layouts.
There are different percussion kit presentation types in Dorico which are layout-specific, meaning
you can present percussion kits using one presentation type in the score and another in the
percussion part.
You can also customize and create new playing technique-specific noteheads for unpitched
percussion. This allows you to express how players should play notes by using different
noteheads for different playing techniques on each instrument in percussion kits.
RELATED LINKS
Percussion kits versus individual percussion instruments on page 679
Percussion kit presentation types on page 687
Playing technique-specific noteheads for unpitched percussion instruments on page 689

Percussion kits versus individual percussion instruments
Percussion kits allow you to show multiple unpitched percussion instruments held by a single
player at the same time in different ways. Multiple percussion instruments not combined into kits
are shown on a single line that only shows the instrument currently being played by default.
To show multiple unpitched percussion instruments held by a single player at the same time,
they must be combined into a percussion kit, for example, a drum set instrument. A drum set
consists of a number of separate instruments mounted together on a frame, and is typically
written on a regular five-line staff. Each instrument has its own position on the staff, and
sometimes its own notehead type. Similarly, a pair of bongos is a percussion kit consisting of the
two bongo drums, typically written on a grid with two lines: the smaller drum shown on the top
line, and the larger drum shown on the bottom line.
Showing individual percussion instruments separately can be appropriate if a player only has one
or two percussion instruments. However, combining percussion instruments into a kit gives you
more flexibility over the presentation of music, which you can vary in each layout independently.
Kits also give you greater control over the labeling of instruments.
If instrument changes are enabled on the Players page in Setup > Layout Options, Dorico
changes from one instrument to the next, just as it does for pitched instruments.
NOTE
Kit instruments in player cards in the Players panel in Setup mode are colored green, whereas
individual percussion instruments not part of percussion kits are colored the same light blue as
all other instruments.
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RELATED LINKS
Percussion kits on page 680

Project-wide Engraving Options for unpitched percussion
Options for the appearance and position of percussion legends and ghost notes project-wide can
be found on the Percussion page in Engraving Options.
You can open Engraving Options in the following ways:
●

Press Ctrl/Cmd-Shift-E in any mode.

●

Choose Engrave > Engraving Options in Engrave mode.

Project-wide Notation Options for unpitched percussion
Options for how notes in percussion kits are notated project-wide can be found on the
Percussion page in Notation Options.
For example, you can choose to notate all notes in a percussion kit in a single voice rather than in
multiple voices on the Percussion page of Write > Notation Options.
You can open Notation Options in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

Percussion kits
You can create percussion kits in Setup mode. You can combine existing unpitched percussion
instruments into kits, add empty kits and add unpitched percussion instruments to the empty kit,
and you can import existing kits you have previously exported and saved.
You can move percussion instruments between players, without affecting any music already
added to that instrument.
NOTE
If the instrument you want to move is combined into a percussion kit, you must first remove the
instrument from the kit before you can move it to another player.
You can change individual percussion instruments like any other instrument. However, you can
only changed unpitched percussion instruments to other unpitched percussion instruments, and
you can only change the percussion instruments in kits within the Edit Percussion Kit dialog.
RELATED LINKS
Edit Percussion Kit dialog on page 71
Adding empty percussion kits to players on page 69
Adding instruments to percussion kits on page 73
Combining individual percussion instruments into kits on page 70
Changing instruments in percussion kits on page 74
Importing percussion kits on page 681
Removing individual instruments from percussion kits on page 77
Moving instruments between players on page 71
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Exporting percussion kits
You can export percussion kits as library files. This allows you to use kits again without having to
create them from scratch.
PROCEDURE
1.

In Setup mode, expand the player card of the player whose percussion kit you want to
export in the Players panel.

2.

Click the arrow in the instrument label of the percussion kit.

3.

Choose Edit Percussion Kit from the context menu to open the Edit Percussion Kit
dialog.

4.

Click Export Kit at the bottom of the dialog.

5.

Enter a name for the library file and select a location on your computer to save it.

6.

Save the file in any of the following ways:
●

Press Return.

●

Click Save.

RESULT
The kit is exported and saved as a library file.
NOTE
You can later import the library file into other projects to reuse the percussion kit.

Importing percussion kits
You can import library files containing percussion kits you have exported and saved previously.
This allows you to use kits again without having to create them from scratch.
PROCEDURE
1.

Add a new solo player in the Players panel in Setup mode.

2.

Open the instrument picker in any of the following ways:
●

Select the empty player and press Shift-I.

●

Click the plus symbol in the empty player card:

●

Right-click the empty player and choose Add Instrument to Player from the
context menu.

3.

Click Import Kit in the instrument picker.

4.

Select the library file of the percussion kit you want to import from its location on your
computer.

5.

Import the selected library file in any of the following ways:
●

Press Return.

●

Click Open.

RESULT
The selected library file is imported as a percussion kit. It is assigned to the player from whose
card you opened the instrument picker.
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Note input for percussion kits
Inputting music for unpitched percussion instruments works differently than for pitched
instruments. You can use any of the usual methods for unpitched percussion input, but using a
MIDI keyboard or a computer keyboard is most efficient.
In the Note Input section of the General page in Preferences you can find options relating to
note input for percussion.
There is one set of options for input onto five-line staves, and another set of options for input
onto grids and individual instruments.
The main choice affects input via MIDI keyboards and computer keyboards.
Use percussion map
A percussion map defines which MIDI notes produce which sound for a particular
patch in a sound library. For example, in General MIDI percussion, C2 (note 36)
produces bass drum, and D2 (note 38) produces snare drum, and so on.
If you know a particular mapping well, you may find it helpful to use the mapping
directly for input.
Use staff position
This option uses the staff position defined in the Edit Percussion Kit dialog. For
example, on a drum set, the bass drum is normally positioned in the bottom space of
the staff, while the snare drum is positioned in the third space from the bottom.
You can think of staff positions relative to what they would be when using a treble G
clef (F4 and C5 respectively) or using a bass F clef (A2 and E3 respectively).
You can choose which clef is used to interpret staff positions for five-line staves:
●

Treble G clef

●

Bass F clef

When you select Use staff position, you can designate one octave of your MIDI keyboard to
input playing techniques.
By default, the Input techniques from MIDI key option is set to MIDI note 48, which is C3, the
C one octave below middle C (C4 = MIDI note 60). You can click the MIDI learn button and then
play a note on your MIDI keyboard to change the starting pitch. Assuming a starting pitch of C3,
ascending notes operate as follows:
●

C3 (48): Previous playing technique

●

C♯3 (49): Next playing technique

●

D3 (50): First mapped playing technique

●

E♭3 (51): Second mapped playing technique

●

E3 (52): Third mapped playing technique

And so on, up to:
●

B3 (59): Tenth mapped playing technique

In general, it is recommended that you set Use staff position for percussion input.
Use percussion map is only normally useful when you are inputting notes onto a drum set and
you have already memorized the General MIDI percussion map.
RELATED LINKS
Preferences on page 51
Edit Percussion Kit dialog on page 71
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Inputting notes in percussion kits
You can input notes on percussion instruments within kits using any presentation type in
the same ways as inputting notes on pitched instruments. However, the caret is smaller
when inputting notes in percussion kits than when inputting music on the staves of pitched
instruments.
Instead of occupying the whole height of the staff, the caret in percussion kits is positioned at a
particular staff position.
The name of the percussion instrument currently selected by the caret, and playing technique if
applicable, is shown above the staff, directly above the rhythmic grid display.

Inputting notes on instruments with five-line staff kit presentation

PROCEDURE
1.

In Write mode, select an item in the percussion kit into which you want to input notes, at
the rhythmic position from which you want to input notes.

2.

Start note input in any of the following ways:

3.

4.

●

Press Shift-N.

●

Press Return.

●

Choose Write > Note Input.

●

Double-click the staff.

Move the caret up and down to input notes on different instruments by pressing the
following keys:
●

Press Up Arrow to move it up.

●

Press Down Arrow to move it down.

Select an appropriate playing technique for the instrument currently selected by the caret
before inputting notes.
●

Press Shift-Alt-Up Arrow to cycle upwards through playing techniques.

●

Press Shift-Alt-Down Arrow to cycle downwards through playing techniques.

●

Play the pitch for the playing technique you want on a MIDI keyboard.
NOTE
You can define MIDI pitches for playing techniques on the General page in
Preferences.

5.

Input notes in the following ways:
●

Five-line staff presentation type: Press letters on a computer keyboard or play notes
on a MIDI keyboard, corresponding to staff positions for the clef set in Preferences.
For example, press B to input notes for the instrument assigned to the middle line
of a five-line staff when Treble G clef is set

●

Grid and single-line instruments presentation types: Press the letter of any note
name A to G on a computer keyboard or play any note on a MIDI keyboard to input
notes for the instrument on whose line the caret is currently positioned
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NOTE
Notes played on MIDI keyboards are interpreted differently, depending on whether
Use percussion map or Use staff position is set for the different kit presentation
types on the General page in Preferences.

6.

●

Any kit presentation type: Click the staff on the lines or in the spaces where you
want to input notes, and at the rhythmic positions where you want them.

●

Any kit presentation type: Press Y to input notes for the instrument and playing
technique shown above the rhythmic grid.

Finish inputting notes by pressing Esc or Return.

RELATED LINKS
Note input for percussion kits on page 682
Changing the playing techniques of existing notes on percussion kit staves on page 684
Preferences on page 51

Changing the playing techniques of existing notes on percussion kit
staves
You can change the playing techniques of notes after they have been input by cycling through
the available playing techniques for the instruments to which the notes belong.
PROCEDURE
1.

In Write mode, select the notes whose playing technique you want to change.
NOTE
The current playing technique is shown above the rhythmic grid if you select a single note.
It is not shown if you select multiple notes.

2.

Cycle through the available playing techniques for the selected instruments in the
following ways:
●

Press Shift-Alt-Up Arrow to cycle upwards.

●

Press Shift-Alt-Down Arrow to cycle downwards.

RESULT
The playing techniques of the selected notes are changed.
RELATED LINKS
Inputting notes in percussion kits on page 683
Defining how combinations of articulations and single-note tremolos sound in playback on page
703

Default note selection during step input for percussion kits
During step input in percussion kits, you can use the letters you press on a computer keyboard
correspond to staff positions for kits using the five-line staff presentation type. For example, you
can press F to input a note on the F space or line.
You can set the Input notes onto kit or grid option in Preferences to Use staff position.
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If you have the staff positions set relative to Treble G clef, then F could mean either the bottom
space in the staff or the top line in the staff. In a standard drum set, this would mean either the
kick drum in the bottom space, or the ride cymbal on the top line.
When inputting notes in pitched instruments, Dorico chooses the lower or upper possible staff
position based on which is closer to the current position of the caret.
However, when inputting notes in percussion kits, Dorico chooses the staff position of the note
with the same stem direction as the last input note, rather than the staff position that is closest
to the current position of the caret. This makes it easier to input common note patterns used in
percussion kits.
For example, inputting kick drum and snare drum notes on a standard drum set is a common
pattern. The kick drum is in the bottom space, and the snare drum is two spaces above: five staff
positions away from the bottom space, and four staff positions away from the top line.
You can press F for the kick drum and C for the snare drum.
The default stem direction behavior for inputting notes in kits in Dorico means that you can
alternate pressing F and C, and the notes are input at the positions of the kick drum and snare
drum, even though the top line is the closer position after inputting a snare drum note.
This is because the kick drum uses the same stem direction, and therefore voice, as the snare
drum.

NOTE
Dorico automatically changes the directions of stems according to the positions of notes in the
staff when only one voice in the staff contains notes, regardless of their voice.

RELATED LINKS
Automatic changes to stem directions when only one voice contains notes on page 713

Showing notes in percussion instruments as ghost notes
You can show notes in percussion instruments as ghost notes. Ghost notes are shown in
parentheses.
PROCEDURE
1.

Selected the unpitched percussion notes that you want to show as ghost notes. You can do
this in Write mode and Engrave mode.

2.

Activate the Ghost note property in the Notes and Rests group of the Properties panel.

RESULT
The noteheads of the selected notes are shown in parentheses.
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Notations on notes in percussion kits
You can add notations to notes and use different rhythms in percussion kits in the same ways as
for normal notes, however they may behave differently.

Articulations
You can add articulations to percussion instruments in all kit presentation types in the same ways
as for other instruments.
However, in grid and five-line staff presentations, any articulations you add apply to all
instruments in the same voice that have notes at that rhythmic position. For example, if both
a snare drum and tom-tom note are at the same rhythmic position, and you add an accent,
the accent is added to both instruments because they are both shown in the same down-stem
voice by default. You can see the accent applied to each note if you switch to the single-line
instruments presentation type.

Tuplets
When working in the grid and five-line staff kit presentation types, tuplets are added to all
instruments in the same voice.
You can switch to the single-line instruments presentation type to input cross-rhythms on each
instrument separately. When you switch back to the grid or five-line staff kit presentation types,
Dorico attempts to resolve the rhythmic conflicts.
●

Conflicting tuplets: One tuplet is moved into an extra voice for the duration of the conflict

●

Tuplet notes in one instrument and non-tuplet notes in another instrument starting at
the same rhythmic position: The non-tuplet note is displayed as if it were part of the
tuplet. This is because the note onset is at the same position as the start of the tuplet, so it
sounds the same as the original notation.

●

Tuplet notes in one instrument and non-tuplet notes in another instrument that do not
start at the same rhythmic position, or other non-tuplet notes start part-way through the
tuplet: Non-tuplet notes are moved into an extra voice for the duration of the conflict.
NOTE
Deleting a tuplet from grid and five-line staff kit presentation types deletes the tuplet from
all instruments whose notes contribute to the same shared voice.

Crossing notes to other instruments
You can cross notes between percussion instruments in the same ways as for normal notes when
using the single-line instruments kit presentation type, or when players hold multiple individual
percussion instruments that are not combined into a kit.
You cannot cross notes to other instruments when using the grid or five-line staff kit
presentation types.

Playing techniques
You can input playing techniques, such as + for closed and o for open hi-hat, during step input
and add them later to existing notes in the same ways as for other instruments. You can use the
playing techniques popover or click any of the playing techniques in the Playing Techniques
panel in Write mode.
Playing techniques are only added to the instrument to which the note you select belongs, even if
there are other instruments in the same voice.
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Percussion stickings
Dorico does not yet have a dedicated feature for showing percussion stickings.
However, you can add lyrics as an approximation in all kit presentation types:
●

Grid and five-line staff presentation types: Select a note in the instrument in which you
want to show stickings.

●

Single-line instruments presentation type: Input lyrics directly into instruments in which
you want to show stickings.

RELATED LINKS
Inputting articulations during step input with the keyboard on page 205
Inputting articulations during step input with the mouse on page 206
Inputting tuplets with the keyboard on page 666
Inputting tuplets with the mouse on page 668
Crossing notes to other staves on page 462
Inputting playing techniques with the keyboard on page 527
Inputting playing techniques with the mouse on page 530

Dynamics in percussion kits
Unlike other items, dynamics are not shared between the grid and five-line staff presentation
types, and the single-line instruments presentation type. Any dynamics added to instruments
in the single-line instruments presentation type do not appear when you switch to either grid
presentation or five-line staff presentation.
Therefore, you can add dynamics in the grid and five-line staff presentation types independently
of the single-line instruments presentation type.
RELATED LINKS
Inputting dynamics with the keyboard on page 331
Inputting dynamics with the mouse on page 335

Percussion kit presentation types
You can show percussion kits in three different presentation types, which can be different in each
layout in your project.
5-line staff
Kit instruments are shown on a five-line staff. You can determine which instruments
are shown on each line and in each space of the staff. A single staff label containing
the name of the kit is shown.
The numbers down the left-hand side of the editing area correspond to staff
positions: for example, position 0 is the middle line of the five-line staff, position 1 is
the space immediately above the middle staff line, position –2 is the line below the
middle staff line, and so on.
Bold black lines show the five staff lines, while gray lines above and below the staff
show nominal staff line positions. Each instrument is shown on its staff position.
Grid
Kit instruments are shown on a grid, with each instrument on its own line. However,
you can customize how large the gaps between each line are. Staff labels are shown
for each instrument in a smaller font than normal staff labels.
The numbers down the right-hand side of the editing area correspond to the number
of staff spaces between each instrument line. By default, all instruments in a grid are
two spaces apart.
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The order in which the instruments are listed matches the order in which they
appear in the score.
Each instrument in a grid shows its own staff label by default, aligned vertically with
its own line, but you can group adjacent instruments together and show a single
label for each group.
Single-line instruments
Kit instruments are shown as individual instruments with their own lines. Normalsized staff labels are shown for each instrument.
The editing area lists all of the instruments in the order in which they appear in the
score.

5-line staff presentation

Grid presentation

Single-line instruments
presentation

Multiple instruments held by the same player are vertically spaced according to the ideal
distances defined on the Vertical Spacing page in Setup > Layout Options.
RELATED LINKS
Changing the presentation type of percussion kits on page 688
Staff labels for percussion kits on page 595

Changing the presentation type of percussion kits
You can change the presentation type of percussion kits in each layout independently of other
layouts. For example, you can use a 5-line staff in the score but a grid in the percussion part.
PROCEDURE
1.

Open Layout Options in any of the following ways:
●

Press Ctrl/Cmd-Shift-L in any mode.

●

Choose Setup > Layout Options in Setup mode.

2.

Select Players from the Category menu.

3.

Select the layouts in which you want to change the percussion kit presentation type in the
Layouts list on the left of the dialog in the following ways:
●

Click Select All.

●

Click Select All Full Score Layouts.

●

Click Select All Part Layouts.

●

Click Select All Custom Score Layouts.

●

Ctrl-click individual flows.

●

Shift-click adjacent flows.

By default, the layout currently open in the music area is selected when you open the
dialog.
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4.

5.

In the Percussion section, choose one of the following options for percussion kit
presentation for each percussion kit in your project:
●

5-line Staff

●

Grid

●

Single-line Instruments

Click Apply, then Close.

RESULT
The presentation type is changed for the corresponding percussion kits in the selected layouts.
NOTE
You can have different presentation types for different percussion kits in the same layout.

Playing technique-specific noteheads for unpitched
percussion instruments
You can specify playing techniques for unpitched percussion instruments by using different
noteheads, positioning notes in spaces directly above or below the line on which notes are
normally written, or by adding articulations or single-note tremolos.
You can use these in addition to adding playing techniques in the same ways as adding playing
techniques to pitched instruments.
For example, you can add open and closed techniques for hi-hats using the playing techniques
popover or by clicking the playing techniques you want in the Playing Techniques panel.
You can edit the set of playing technique-specific noteheads defined for each percussion
instrument in the Edit Percussion Playing Techniques dialog, which you can open in the
following ways:
●

For individual percussion instruments: Expand the card of the player holding the
instrument in the Players panel in Setup mode, click the arrow in the instrument label, and
choose Edit Percussion Playing Techniques from the context menu

●

For percussion instruments that are part of percussion kits: open the Edit Percussion Kit
dialog by clicking the arrow in the kit instrument label in the Players panel in Setup mode,
select the instrument whose playing techniques you want to edit in the main editing area,
and click Edit Percussion Playing Techniques

At the top of the Edit Percussion Playing Techniques dialog are the main playing techniquespecific noteheads currently defined for this percussion instrument, showing the notehead
set and the staff position corresponding to this playing technique as applicable. Normally,
percussion instruments define at least the Natural playing technique, which is usually shown
using the default notehead set.
You can add new playing technique-specific noteheads for unpitched percussion instruments,
and you can define how combinations of articulations and tremolo strokes behave in playback.

Three different snare drum playing technique-specific noteheads followed by two clash cymbal playing
technique-specific noteheads.

All of these settings are saved in the percussion instrument within your project, and you can
export them from one project and import them into others.
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NOTE
Overrides for articulations and tremolos are not currently respected in playback, but this is
planned for future versions.

RELATED LINKS
Edit Percussion Kit dialog on page 71
Defining how combinations of articulations and single-note tremolos sound in playback on page
703
Exporting percussion kits on page 681
Importing percussion kits on page 681

Creating new playing technique-specific noteheads for unpitched
percussion instruments
You can define new playing technique-specific noteheads for unpitched percussion instruments
individually, which are saved for that type of percussion instrument in your project. You can
also export playing technique-specific noteheads from your project and import them into other
projects.
PROCEDURE
1.

In Setup mode, open the Edit Percussion Playing Techniques dialog in the following
ways:
●

For an individual percussion instrument: Expand the card of the player holding the
instrument in the Players panel, click the arrow in the instrument label, and choose
Edit Percussion Playing Techniques from the context menu.

●

For percussion instruments that are part of percussion kits: Open the Edit
Percussion Kit dialog by clicking the arrow in the kit instrument label in the Players
panel, select the instrument whose playing techniques you want to edit in the main
editing area, and click Edit Percussion Playing Techniques.

2.

Click Add Playing Technique:

3.

Select the playing technique you want to create in the dialog that opens.

4.

Click OK to add the selected playing technique to the list at the top of the dialog.

5.

Select the notehead you want for the playing technique from the Notehead set menu.
NOTE
Leave Notehead set as (Unset) to use the default notehead set as defined on the Notes
page in Engrave > Engraving Options.

6.

Choose one of the following options for Staff position:
●

Below

●

Line

●

Above

RESULT
A new playing technique-specific notehead is added to the selected unpitched percussion
instrument.
RELATED LINKS
Inputting playing techniques with the keyboard on page 527

690

Unpitched percussion
Playing technique-specific noteheads for unpitched percussion instruments
Inputting playing techniques with the mouse on page 530
Defining how combinations of articulations and single-note tremolos sound in playback on page
703

Overriding the appearance of playing technique-specific noteheads
It may be necessary to override the appearance of playing technique-specific noteheads in order
to disambiguate the notes for one instrument from another if they share a staff position in fiveline staff kit presentations.
PROCEDURE
1.

In Setup mode, expand the card of the player holding the kit whose playing techniquespecific noteheads you want to override in the Players panel.

2.

Click the arrow in the kit instrument label and choose Edit Percussion Kit from the context
menu to open the Edit Percussion Kit dialog.

3.

Select the instrument whose noteheads you want to override in the main editing area of
the dialog.

4.

Click Edit Noteheads.
The Override Percussion Noteheads dialog that opens lists the playing technique-specific
noteheads defined for the selected instrument in the Edit Percussion Playing Techniques
dialog, and shows which notehead type is mapped for each technique.

Override Percussion Noteheads dialog for a snare drum

5.

Click in the Notehead Override column for the appropriate playing technique and select a
new notehead type from the menu to override its notehead.

6.

Click OK to save your changes.

RESULT
The playing technique-specific notehead is overridden for the selected instrument in five-line
staff kit presentations.
NOTE
This does not affect the appearance of playing technique-specific noteheads in grid and singleline instrument kit presentation types.

RELATED LINKS
Defining how combinations of articulations and single-note tremolos sound in playback on page
703
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Percussion legends
When using the five-line presentation type, it can be helpful to use percussion legends to show
which instruments are represented on the staff, or to remind players which instruments to play
at certain points.
You can change the default position of percussion legends in the Percussion Legends section of
the Percussion page in Engrave > Engraving Options.
You can change the placement and appearance of percussion legends individually using
properties in the Percussion Legends group of the Properties panel.
You can change various aspects of the paragraph style for percussion legends, such as the font
size and style, in the Engrave > Paragraph Styles dialog.
Percussion legends appear as signposts if there are no instruments sounding at their position, or
when using the grid or individual instruments presentation type. You can choose to hide or show
percussion legend signposts.
RELATED LINKS
Paragraph styles on page 152
Project-wide Engraving Options for unpitched percussion on page 680
Project-wide Notation Options for unpitched percussion on page 680
Hiding and showing percussion legend signposts on page 695

Adding percussion legends to five-line staff kit presentations
PROCEDURE
1.

In Write mode, select an item on the staff at the rhythmic position where you want to add
a percussion legend.

2.

Choose one of the following, depending on the type of percussion legend you want:
●

Edit > Percussion > Legend for All Instruments

●

Edit > Percussion > Legend for Sounding Instruments

RESULT
A percussion legend is added above the staff. It lists instruments in the order in which they
appear in the five-line staff, from highest down to lowest.

Lengthening and shortening the range for sounding instrument
percussion legends
You can change the rhythmic range of sounding instrument percussion legends to include
more or fewer instruments in the legend, according to the instruments playing at the rhythmic
positions included in the range.
PROCEDURE
1.

In Write mode, select the sounding instrument percussion legend whose range you want
to lengthen or shorten.

2.

Lengthen and shorten the range in the following ways, according to the rhythmic grid
currently set:
●

Press Shift-Alt-Right Arrow to lengthen the range.

●

Press Shift-Alt-Left Arrow to shorten the range.
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●

Click and drag the circular handle at the right end of the percussion legend to the
right or to the left.

RESULT
The rhythmic range covered by the selected sounding instrument percussion legend is changed.
The instruments included in the percussion legend is automatically updated, according to the
instruments playing within the range.

Changing the percussion legend type
You can change the type of percussion legends so they show all instruments or only sounding
instruments in five-line staff presentations.
PROCEDURE
1.

Select the percussion legends whose type you want to change. You can do this in Write
mode and Engrave mode.

2.

Activate the Legend Type property in the Percussion Legend group of the Properties
panel.
NOTE
The property is already activated for sounding instrument percussion legends.

3.

Choose one of the following options:
●

Legend

●

Sounding Instruments

RESULT
The legend type of the selected legends is changed.

Showing short instrument names in percussion legends
Percussion legends use full instrument names by default, but you can choose to use short names
in percussion legends.
PROCEDURE
1.

Select the percussion legends whose instrument name lengths you want to change. You
can do this in Write mode and Engrave mode.

2.

Activate the Use short names property in the Percussion Legends group of the
Properties panel.

RESULT
Short instrument names are shown in the selected percussion legends.
NOTE
You can show full instrument names again in percussion legends at any time by deactivating the
Use short names property.
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Changing the text shown in percussion legends
By default, percussion legends show the instrument names of percussion instruments in five-line
staff presentations, stacked vertically. You can change the text shown in percussion legends to
show custom text.
PROCEDURE
1.

In Engrave mode, select the percussion legends whose text you want to change to custom
text.

2.

Activate the Custom Text property in the Percussion Legend group of the Properties
panel.

3.

Enter the custom text you want shown in the selected percussion legends into the value
field.

4.

Save your changes in any of the following ways:
●

Press Return.

●

Click anywhere outside the value field.

RESULT
The text shown in the selected percussion legends is changed.

Changing the placement of percussion legends relative to the staff
By default, percussion legends are shown above the staff but you can change their placement so
they are shown below the staff.
PROCEDURE
1.

Select the percussion legends whose placement relative to the staff you want to change.
You can do this in Write mode and Engrave mode.

2.

Activate the Placement property in the Percussion Legend group of the Properties panel.

3.

Choose one of the following options:
●

Above

●

Below

RESULT
The placement of the selected percussion legends relative to the staff is changed.
NOTE
You can revert percussion legends to their default placement relative to the staff at any time by
deactivating the Placement property.
You can change the default position of percussion legends in the Percussion Legends section of
the Percussion page in Engrave > Engraving Options.

RELATED LINKS
Project-wide Engraving Options for unpitched percussion on page 680
Project-wide Notation Options for unpitched percussion on page 680
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Deleting percussion legends
PROCEDURE
1.

In Write mode, select the percussion legends you want to delete.
NOTE
Make sure no notes beneath the percussion legends are included in your selection, unless
you want to delete them as well.

2.

Delete the percussion legends in any of the following ways:
●

Press Backspace or Delete.

●

Choose Edit > Delete.

RESULT
The selected percussion legends are deleted.

Hiding and showing percussion legend signposts
Percussion legends appear as signposts if there are no instruments sounding at their position, or
when using grid and single-line instrument presentation types.
Choose View > Signposts > Percussion Legends to hide and show percussion legend signposts.
RESULT
Percussion legend signposts are shown when a tick is shown beside Percussion Legends in the
menu, and hidden when no tick is shown beside the option.

Voices in percussion kits
Dorico automatically combines music into a smaller number of voices when multiple percussion
instruments are presented in a five-line staff or as a grid.
By default, music is combined into one up-stem voice and one down-stem voice.
Alternatively, you can choose to notate all notes in a percussion kit in a single voice when the kit
is defined as a drum set on the Percussion page of Write > Notation Options. This convention is
used less frequently for orchestral percussion.
You can also override this option for individual percussion kits, and for individual notes in
percussion kits.
Notes in the same voice cannot be notated using different durations and are notated using ties
by default instead. You can eliminate the use of ties by choosing to truncate longer notes so that
only their onsets appear on the Percussion page of Notation Options.
If one of the instruments in a percussion kit has a tuplet rhythm, other instruments can share the
voice if their notation is compatible, such as if the tuplet structure is the same, or if they have a
single note that coincides with the start of the tuplet, in which case the single non-tuplet note is
notated as the same duration of the first note of the tuplet.
If the music of the different instruments in the same voice is incompatible, Dorico dynamically
creates another voice and notates the remaining music in that voice until the music is compatible
again.
RELATED LINKS
Project-wide Notation Options for unpitched percussion on page 680
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Notation Options on page 119

Defining percussion kits as drum sets
You can define individual percussion kits as drum sets. Drum sets follow your project-wide
setting for voicing in drum sets with five-line staff presentations.
PROCEDURE
1.

In Setup mode, expand the card of the player holding the kit you want to define as a drum
set in the Players panel.

2.

Click the arrow in the kit instrument label and choose Edit Percussion Kit from the context
menu to open the Edit Percussion Kit dialog.

3.

Check the box for Drum set in the top right of the dialog.

4.

Click Apply, then Close.

RESULT
The selected percussion kit is defined as a drum set. The arrangement of voices for instruments
in the kit when using the five-line staff presentation type follows your project-wide setting on the
Percussion page in Write > Notation Options.
NOTE
If you no longer want a percussion kit to be defined as a drum set, you can uncheck the box for
Drum set in the Edit Percussion Kit dialog for that kit at any time.

RELATED LINKS
Notation Options on page 119

Changing the voice of individual notes in percussion kits
You can override the default voice for individual notes in percussion kits, including drum sets.
PROCEDURE
1.

Select the notes whose voice you want to override. You can do this in Write mode and
Engrave mode.

2.

Change the voice of the selected notes in the following ways:
●

Choose the voice you want by choosing an option from Edit > Percussion > Change
Voice.

●

Right-click and choose the voice you want by choosing an option from Percussion >
Change Voice.

NOTE
For example, to change the selected notes to the second down-stem voice, choose Edit >
Percussion > Change Voice > Down-stem Voice 2.
You can choose a new voice for notes in percussion kits in the same submenu. For
example, choose Edit > Percussion > Change Voice > Extra Down-stem Voice.

RESULT
The voice of the selected notes is changed, independently of the default voice for their
instrument and independently of your setting for voices in drum sets.
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NOTE
You can reset the voice of individual notes by selecting them and choosing Edit > Percussion >
Change Voice > Reset Note Destination Voice, or right-clicking and choosing Percussion >
Change Voice > Reset Note Destination Voice from the context menu.

Specifying the stem directions and voices of unpitched percussion
instruments in kits
You can specify the stem direction for each instrument in individual percussion kits. You can
also set which voice they are in for their current stem direction, allowing you to control which
instruments share voices in percussion kits.
PROCEDURE
1.

In Setup mode, expand the card of the player holding the kit whose instrument stem
directions and voices you want to specify in the Players panel.

2.

Click the arrow in the kit instrument label and choose Edit Percussion Kit from the context
menu to open the Edit Percussion Kit dialog.

3.

Select an instrument whose stem direction and voice you want to specify.

4.

Choose the stem direction you want for the selected instrument for Stem direction and
voice:

5.

●

Up-stem

●

Down-stem

Specify the voice you want by changing the value for Stem direction and voice in any of
the following ways:
●

Enter a value into the value field.

●

Click the arrows beside the value field.

NOTE
You do not have to change the voice number if you are switching between up-and downstem voices as the number corresponds to the voice number for each stem direction. For
example, Up-stem Voice 1 and Down-stem Voice 1 are different voices.
6.

Click Apply, then Close.

RESULT
The default stem direction and voice of the selected instrument is changed.
TIP
You can change the stem direction and voice of all instruments in the kit before closing the
dialog.

Percussion maps for the playback of unpitched percussion
Unpitched percussion instruments are played back using patches that map unpitched sounds
onto different MIDI notes. The pitches required to produce different unpitched sounds vary

697

Unpitched percussion
Percussion maps for the playback of unpitched percussion
by device, sample library, manufacturer, and so on, and have no connection to the position of
percussion instruments on five-line staves.
Here are some examples of unpitched percussion instruments from the General MIDI percussion
map:
●

Bass drum: C2 (MIDI note 36, two octaves below middle C)

●

Kick drum: D2 (MIDI note 38)

●

Closed hi-hat: F♯2 (MIDI note 42)

●

Cowbell: G♯3 (MIDI note 56)

●

Open triangle: A5 (MIDI note 81)

Dorico uses percussion maps to connect the written representation of notes and playing
techniques for percussion instruments to the samples required to play those sounds back.
NOTE
A percussion map describes which unpitched percussion instruments and their playing
techniques are present in a particular patch, and how to play them back. For example, describing
which MIDI note to play, and if another MIDI note is needed as a keyswitch to trigger particular
playing techniques.
A set of percussion maps for the unpitched percussion patches that are part of the HALion
Symphonic Orchestra and HALion Sonic SE factory libraries is provided with Dorico. They are
automatically chosen when you add percussion instruments to your project.
You can define custom percussion maps for third-party sound libraries or MIDI devices in the
Percussion Maps dialog, in order to obtain correct playback.
RELATED LINKS
Percussion Maps dialog on page 698
Importing percussion maps on page 702
Exporting percussion maps on page 701

Percussion Maps dialog
You can define custom percussion maps for third-party sound libraries or MIDI devices in the
Percussion Maps dialog, in order to obtain correct playback.
You can open the Percussion Maps dialog by choosing Play > Percussion Maps in Play mode.
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The Percussion Maps dialog

The Percussion Maps dialog is divided into four sections:
●

List of percussion maps available in the current project on the left of the dialog

●

Percussion Map section

●

Drum Kit Note Map section

●

Edit Drum Kit Note section

Percussion Map section
In the Percussion Map section of the Percussion Maps dialog you can specify the display Name
for the percussion map that appears in the Endpoint Setup dialog.
NOTE
The Endpoint Setup dialog is where you set which percussion map Dorico uses for each channel
on your VST instrument or MIDI output device.
You can enter any content in the ID field.
You can choose one of the options for Map defines sounds for, as appropriate for the current
percussion map:
Multiple instruments
Choose this if the patch for which you are creating a map contains many different
percussion instruments, such as the General MIDI drum map.
Individual instrument
Choose this if the patch for which you are creating a map contains only a single
percussion instrument, perhaps with multiple playing techniques for that
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instrument. For example, a snare drumline patch in Virtual Drumline or another
specialist sample library.

Drum Kit Note Map section
This section lists all MIDI notes from 0 to 127. You can specify which combination of unpitched
instrument and playing technique is produced by each note.

Edit Drum Kit Note section
This section at the bottom of the dialog allows you to specify data in different fields for the MIDI
note selected in the Drum Kit Note Map section:
Name
The display name for the specific combination of instrument and technique. You may
choose to input whatever name is used in the manufacturer’s documentation for
your VST instrument or MIDI output device.
Instrument
Select an instrument for the MIDI note selected in the Drum Kit Note Map section
from a list of all the unpitched percussion instruments you can create in Dorico.
Techniques
Select a playing technique to apply to the instrument selected in the Instrument
field from a list of all the playing techniques you can create in Dorico.
Keyswitches
Specify the MIDI note number of the key you want to use as a keyswitch if this sound
requires another MIDI note to be played to trigger this specific combination of
instrument and playing techniques.
NOTE
Keyswitches are not compulsory.

Defining custom percussion maps
You must define custom percussion maps in order to obtain correct playback when using thirdparty sound libraries or MIDI devices. You can create new, empty percussion maps, or create
custom percussion maps based on existing maps that you have duplicated.
PROCEDURE
1.

Open the Percussion Maps dialog by choosing Play > Percussion Maps.

2.

Create a new custom percussion map in any of the following ways:

3.

●

Empty map: Click Add Percussion Map:

●

New map based on an existing percussion map: Select the map on which you want
to base your custom map in the list on the left of the dialog, and click Duplicate.

Click Lock Info to unlock fields in the Percussion Map section of the dialog.

Locked

4.

Unlocked

Enter the display name you want for the percussion map in the Name field in the
Percussion Map section.
This name appears in the Endpoint Setup dialog.
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5.

Enter any unique identification name in the ID field in the Percussion Map section.
It can useful to include the instrument and sound library for which you created the map,
as well as your name, in the identification name for percussion maps. For example,
xmap.paulsmith.hso.cowbell.

6.

Choose one of the following options for Map defines sounds for in the Percussion Map
section, as appropriate for the current percussion map:
●

Multiple instruments

●

Individual instrument

7.

Click Show all in the Drum Kit Note Map section to show unmapped notes.

8.

Select the row corresponding to the MIDI note for which you want to create a new
mapping in the Drum Kit Note Map section.

9.

Select the instrument that corresponds to the sound produced by the selected MIDI note
from the list in the dialog that opens when you click this button beside the Instrument
field in the Edit Drum Kit Note section:

10.

Click OK.

11.

Select the appropriate playing techniques for the sound produced by the selected
MIDI note from the list in the dialog that opens when you click this button beside the
Techniques field in the Edit Drum Kit Note section:

For example, hold down Ctrl/Cmd and click Buzz roll and Rim.
12.

Click OK.

13.

Enter the display name you want for this combination of instrument and playing technique
in the Name field in the Edit Drum Kit Note section.

14.

Specify the MIDI note number of the keyswitch if this sound requires one in the
Keyswitches field in the Edit Drum Kit Note section.

15.

Click Apply.

16.

Optional: Repeat these steps for each MIDI note until you have created all the required
mappings for your project.

17.

Click OK to save your changes and close the dialog.

RESULT
Your new percussion map is created. You can export the percussion map if you want to use it in
other projects.
NOTE
Once you have created your percussion map, you must apply it to the VST instrument or MIDI
device that provides the patch corresponding to the percussion map.

RELATED LINKS
Percussion maps for the playback of unpitched percussion on page 697
Exporting percussion maps on page 701

Exporting percussion maps
PROCEDURE
1.

Open the Percussion Maps dialog by choosing Play > Percussion Maps.
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2.

Click Export Library.

3.

Enter a name for the library file and select a location on your computer to save it.

4.

Export the file in any of the following ways:
●

Press Return.

●

Click Save.

Importing percussion maps
PROCEDURE
1.

Open the Percussion Maps dialog by choosing Play > Percussion Maps.

2.

Click Import Library.

3.

Select the percussion map file you want to import from its location on your computer.

4.

Import the file in any of the following ways:
●

Press Return.

●

Click Open.

Linking percussion maps to VST instruments and MIDI devices
Once you have created percussion maps, you must apply them to the VST instrument or MIDI
device that provides the patch corresponding to each percussion map.

PROCEDURE
1.

In Play mode, click this button for the VST instrument or MIDI device to which you want to
link a percussion map:

2.

In the Endpoint Setup dialog that opens, select a percussion map in the Percussion map
column for the channel in which your percussion patch has been loaded.
NOTE
You can check into which channel your percussion patch is loaded in the VST Instrument
Window, which you open by clicking this button:

RESULT
The selected percussion map is linked to the percussion patch loaded into the corresponding
channel.
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Defining how combinations of articulations and single-note
tremolos sound in playback
You can define specific playback behaviors for particular combinations of articulations and
single-note tremolos in playing technique-specific noteheads for unpitched percussion
instruments.
PROCEDURE
1.

In Setup mode, open the Edit Percussion Playing Techniques dialog in any of the
following ways:
●

For an individual percussion instrument: Expand the card of the player holding the
instrument in the Players panel in Setup mode, click the arrow in the instrument
label, and choose Edit Percussion Playing Techniques from the context menu.

●

For percussion instruments that are part of percussion kits: Open the Edit
Percussion Kit dialog by clicking the arrow in the kit instrument label in the Players
panel in Setup mode, select the instrument whose playing techniques you want to
edit in the main editing area, and click Edit Percussion Playing Techniques.

2.

Select the playing technique-specific notehead whose playback behaviors you want to
define in the list at the top of the dialog.

3.

Click Add Technique in the action bar at the bottom left of the dialog:

4.

Click Choose Playing Technique beside the Playing technique field:

5.

Select the playing technique you want from the list in the dialog that opens.
You can select multiple playing techniques by holding down Ctrl/Cmd and clicking the
playing techniques you want.

6.

Choose one of the following options:
●

Replace: Allows you to use this playing technique instead of the default playing
technique defined for this combination of notehead and staff position.

●

Add: Allows you to add this playing technique on top of the default playing
technique defined for this combination of notehead and staff position.

7.

Choose any articulations and a tremolo stroke that you want from the available options.

8.

Save your changes and close the dialog in any of the following ways:
●

Press Return.

●

Click OK.

RESULT
The behavior of the selected playing technique in playback is changed.
RELATED LINKS
Creating new playing technique-specific noteheads for unpitched percussion instruments on
page 690
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Unpitched percussion in Play mode
Unpitched percussion instruments are handled differently in Play mode than pitched
instruments. Instead of showing the usual piano roll view, the onset of each note on each
percussion instrument is shown.
You can expand each instrument in a kit at the left end of the track header in order to assign that
particular instrument to another playback endpoint. For example, you can assign instruments to
another channel on the same VST instrument or MIDI output device, or to a different device.
NOTE
The endpoint must have an appropriate selected percussion map.
Notes can be moved in Play mode by dragging them to the rhythmic position you want.
NOTE
It is not currently possible to drag notes from one percussion instrument to another, or to
change their duration within Play mode.

RELATED LINKS
Percussion maps for the playback of unpitched percussion on page 697

Unpitched percussion import from MIDI files
You can import information about unpitched percussion from MIDI files.
When importing MIDI files, Dorico optionally interprets music for tracks set to use channel 10
as drum sets if the Interpret channel 10 as General MIDI percussion option is set in the MIDI
Import Options dialog.
NOTE
The MIDI Import Options opens automatically when you open MIDI files in Dorico.
This is the only condition under which Dorico interprets any music in MIDI files as percussion.

Unpitched percussion import from MusicXML files
Unpitched percussion music can be expressed in a number of ways in MusicXML, and all
applications take different approaches to what data is exported, and how it is encoded.
Therefore, the results of importing MusicXML into Dorico may vary considerably.
Dorico identifies each instrument in kits explicitly, and then combines them dynamically onto
five-line staves.
Other scoring applications and MusicXML have a different approach to how unpitched
percussion music is represented. For example, a drum set is effectively notated as pitched notes
on a five-line staff, and annotated with additional information to help identify which instrument
corresponds to each staff position.
Because of these different approaches, mapping information between the MusicXML
representation and the Dorico representation can be challenging, so Dorico employs heuristics
to improve the quality of results.
Typically, drum set instruments in MusicXML files exported from both Sibelius and Finale are
imported quite cleanly into Dorico.
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Results are particularly good, and more likely to be imported correctly, if the voicing of the
drum set is consistent, such as consistently notating the snare drum in a down-stem voice. If the
voicing changes from bar to bar, it is possible that some notes are not identified correctly, or not
imported at all.
Other kinds of percussion that are notated on five-line staves produce more variable results.
Finale tends to include information about which percussion instrument maps onto each
staff position, but Sibelius does not. As a result, you may find that Dorico chooses different
instruments than you might expect, but you can change instruments using the Edit Percussion
Kit dialog.
RELATED LINKS
Edit Percussion Kit dialog on page 71
Changing instruments in percussion kits on page 74
Adding instruments to percussion kits on page 73

Universal Indian Drum Notation
Dorico supports the Universal Indian Drum Notation system developed by Keda Music Ltd.
Universal Indian Drum Notation has been designed primarily for tabla, but can also be applied to
other Indian drums with two heads, such as nagara, dhol, dholak, mrindangam, and pakhawaj.
An Indian drum clef is automatically added to the staff when you add tabla instruments to
players.

You can input Indian drum clefs by clicking Indian drum clef in the Uncommon Clefs section of
the Clefs panel.
RELATED LINKS
Adding instruments to players on page 68
Inputting clefs with the mouse on page 272
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Generally, each staff contains a single musical line in a single voice that can be read left to right
along the staff. When multiple, independent lines need to be shown in a single staff, each line
can be given its own voice.
The most common use for showing multiple voices in a single staff is in vocal music, when the
soprano and alto lines are often shown in a single staff, and the tenor and bass lines are shown
in a single staff. Showing each vocal line in its own voice helps to separate the lines, making the
music easier to read and making the shape of each melodic line clear.
In Dorico, you can create as many voices as you like in each staff. Each voice is assigned a color,
which you can see if you can turn on voice colors. This can be helpful to track which notes are in
which voices in music with lots of overlapping musical lines.

Voice colors shown.

Voices in Dorico are divided into up-stem voices and down-stem voices. Stems of notes in
up-stem voices point upwards, while stems of notes in down-stem voices point downwards.
However, in bars where only one voice contains notes, stem directions are automatically changed
to the directions they would have if there were only one voice in the staff.
Following most notation conventions, rests are shown in bars for all voices that have notes in
the bar. If two or more voices have a rest of the same rhythmic duration at the same rhythmic
position, that rest is consolidated: instead of showing two identical rests, only one is shown.
RELATED LINKS
Automatic changes to stem directions when only one voice contains notes on page 713
Project-wide Notation Options for voices on page 707
Project-wide Notation Options for rests on page 559
Adding notes above and below existing notes on page 105

General placement conventions for notes in multiple voices
Notes are usually placed directly above each other and at the same horizontal position, so that it
is immediately clear which notes should be played together.
When there are three or more voices in a single staff, some notes need to be positioned slightly
to one side in a different voice column to ensure the division of notes across the voices is clear.
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Interlocking notes in different voices can be positioned in two ways:
1

Notehead to notehead, which allows noteheads to overlap partially. This order often takes
up less horizontal space then positioning notes stem to stem, as notes can overlap.

2

Stem to stem, which does not allow noteheads to overlap. This order keeps notes in
different voices separate.

You can choose how interlocking notes in different voices are positioned project-wide on the
Voices page in Write > Notation Options.
Dorico positions notes by default with the noteheads partially overlapping, in order to minimize
the horizontal space they occupy and maintain the clarity of the rhythm.
The order and position of notes in different voices is also automatically adjusted so that each
rhythmic position uses as little horizontal space as possible, while remaining clear and legible. In
the below examples, you can see how the voice column for some voices changes as more voices
are added.

RELATED LINKS
Project-wide Notation Options for voices on page 707

Project-wide Notation Options for voices
There are a number of options for how notes in multiple voices are positioned project-wide that
you can choose from on the Voices page in Notation Options.
The options on this page allow you to change the position and order of notes in multi-voice
contexts, and choose when notes in different voices can overlap noteheads.
The options are accompanied by musical examples to demonstrate how each option affects the
appearance of your music.
You can open Notation Options in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

You can then select Voices from the Category menu.
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Inputting multiple voices during step input
By default, notes are input into the first up-stem voice, as indicated by the symbol of an up-stem
quarter note beside the caret.
To input notes into other voices:
PROCEDURE
1.

In Write mode, start note input.

2.

Position the caret on the staff to which you want to input multiple voices, at the rhythmic
position the multiple voices should start.

3.

Create a new voice in one of the following ways:
●

Press Shift-V.

●

Choose Write > Create Voice.

NOTE
You can repeat this step if the first new voice added is not the voice into which you want
to input notes. For example, in a staff with nothing input, creating a new voice once allows
you to input notes into the first down-stem voice, but creating a new twice allows you to
input notes into the second up-stem voice.
4.

When a new voice is added, a + sign appears beside the symbol of a quarter note beside
the caret. A number is also shown if the new voice is not the first voice with the stem
direction indicated by the quarter note symbol.

5.

Input the pitches you want as you would normally.

RESULT
Notes are input into a new voice, as indicated by the caret symbol.
RELATED LINKS
Inputting notes on page 94
Adding notes above and below existing notes on page 105

Switching between voices during step input
You can switch between voices as you input notes during step input. However, you must have
already created at least one new voice in the staff.
PROCEDURE
1.

In Write mode, start note input.

2.

Switch between voices in one of the following ways:

3.

●

Press V.

●

Choose Write > Next Voice.

Continue inputting notes as normal.
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RESULT
The quarter note symbol beside the caret changes to indicate which voice is currently selected.
Any notes input are input into the voice indicated by this symbol.
You can switch between voices as often as you like.
EXAMPLE

The caret when inputting notes into the first up-stem The caret when inputting notes into the first downvoice.
stem voice.

Adding voices to existing music
To add new notes in a new voice to a staff with existing notes:
PROCEDURE
1.

In Write mode, select the staff to which you want to add new notes in a new voice.

2.

Start note input.

3.

Create a new voice in one of the following ways:

4.

●

Press Shift-V

●

Choose Write > Create Voice

Input the notes you want in the new voice.

RESULT
Notes are input into a new voice, as indicated by the caret symbol. The stem directions of existing
notes at the same rhythmic position are changed automatically as necessary.
RELATED LINKS
Inputting multiple voices during step input on page 708
Swapping the contents of voices on page 711
Swapping the order of voices on page 711
Adding notes above and below existing notes on page 105

Changing the voices of existing notes
To change the voice of existing notes:
PROCEDURE
1.

In Write mode, select the notes whose voice you want to change.

2.

Change the voice in one of the following ways:
●

Choose Edit > Voices > Change Voice and select an existing voice, or a new voice if
there is only one voice in the staff currently.

●

Right-click, choose Voices > Change Voice, and select an existing voice, or a new
voice if there is only one voice in the staff currently, from the context menu.
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RESULT
The voice of the selected notes is changed. The directions of stems for the selected notes and
other notes in the staff may be changed, and implicit rests may be added.
RELATED LINKS
Implicit rests in multi-voice contexts on page 714

Pasting notes into different voices
To copy notes and paste them into a new staff, but into a different voice to their original voice:
PROCEDURE
1.

In Write mode, select the notes you want to copy.

2.

Copy the notes in one of the following ways:
●

Press Ctrl/CmdC

●

Choose Edit > Copy

●

Right-click and choose Copy from the context menu.

3.

Select the staff to which you want to paste the notes, at the position from which you want
the selection to be start.

4.

Paste the notes into a new voice in one of the following ways:
●

Choose Edit > Paste Into Voice and select an existing voice or a new voice into
which you want to paste the notes.

●

Right-click, choose Paste Into Voice, and select an existing voice or a new voice into
which you want to paste the notes from the context menu.

Showing voice colors
To show noteheads in each voice with a different color in your project, choose View > Note and
Rest Colors > Voice Colors.
RESULT
Each voice in your project is shown with differently colored noteheads, according to the voice
they are in.
NOTE
You can turn off voice colors by choosing View > Note and Rest Colors > None.

Deleting unused voices
You can create as many voices as you want in each staff. Any unused voices are automatically
deleted when you close a project, but voices cannot be manually deleted once created.
If you later want to input notes in a voice you had previously created but was automatically
deleted when you closed the project previously, you can create a new voice at any time and at
any rhythmic position.
RELATED LINKS
Inputting multiple voices during step input on page 708
Adding voices to existing music on page 709
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Swapping the contents of voices
To swap the contents of selected voices:
PROCEDURE
1.

In Write mode, select the notes in two voices that you want to swap.
NOTE
You must select notes in two voices. You cannot select notes in just one voice, or in three
or more voices.

2.

Swap the contents in one of the following ways:
●

Choose Edit > Voices > Swap Voice Contents

●

Right-click and choose Voices > Swap Voice Contents from the context menu.

RESULT
The contents of the voices are swapped. For example, the notes previously in Up-stem voice 1 are
now in Down-stem voice 1, and the notes previously in Down-stem voice 1 are now in Up-stem
voice 1.
NOTE
Depending on the pitches involved in the swap and their stem directions, the notes may now
overlap. Dorico automatically positions notes with the noteheads partially overlapping, in order
to minimize the horizontal space they occupy and maintain the clarity of the rhythm. However,
if you find that you need to change this arrangement, you can change the order of voices or
change the voice column index.
EXAMPLE

An E in the up-stem voice, an F in the down-stem
voice.

Now the E is in the down-stem voice, and the F is in
the up-stem voice.

RELATED LINKS
Swapping the order of voices on page 711
Changing the voice column index of notes individually on page 713

Swapping the order of voices
Dorico automatically positions notes with the noteheads partially overlapping, in order to
minimize the horizontal space they occupy and maintain the clarity of the rhythm.
To swap the order in which voices are positioned horizontally:
PROCEDURE
1.

Select the notes whose order you want to change. You can do this in Write mode and
Engrave mode

2.

Swap the order in one of the following ways:
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●

Choose Edit > Voices > Swap Voice Order

●

Right-click and choose Voices > Swap Voice Order from the context menu.

RESULT
The order of the selected notes is changed.
NOTE
Swapping the order of notes automatically activated the Voice column index property in the
Notes and Rests group of the Properties panel. If you later swap the contents of notes whose
order has been previously swapped, their positions may not be as expected. deactivating the
Voice column index property reverts notes to your project-wide settings for note order.
EXAMPLE

Interlocking notes in opposing voices positioned
notehead to notehead.

Interlocking notes in opposing voices positioned
stem to stem.

Crossing notes to staves with existing notes in other voices
When you cross notes to staves that already contain notes, the stem direction of the existing
notes may change. This is due to how multiple voices at the same rhythmic position are handled.
For example, if notes in Up-stem voice 1 in the upper staff of a piano part are crossed to the
lower staff, when there are already notes in the Up-stem voice 1 in the lower staff. In this
situation, the notes from the two staves are not combined, but are instead treated as two voices
in a multi-voice context.

Two piano staves, each with notes in a single upstem voice.

When the notes in the upper staff are crossed to the
lower staff, the stem direction of the notes already in
the lower staff changes so they point up.

You can change the stem direction of the notes originally in the lower staff in the following ways:
●

Select the notes originally in the lower staff and change their voice to another voice, such
as Down-stem voice 1.

●

Select the notes originally in the lower staff and change their stem direction.

Alternatively, you could move the notes in the upper staff permanently to the lower staff by
copying them, then pasting them into the lower staff in a different voice to the notes already in
the lower staff.
RELATED LINKS
Changing the voices of existing notes on page 709
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Changing the voice column index of notes individually
Pasting notes into different voices on page 710
Creating cross-staff beams on page 256

Changing the voice column index of notes individually
The voice column index is used to determine the positions of notes when multiple columns are
needed. For example, when notes are in multiple voices and cannot be placed directly above
each other vertically, and instead must partially overlap.
The Voice column index property in the Notes and Rests group of the Properties panel is
automatically activated when you swap the order of voices manually. You can deactivate the
property at any time.
You can activate this property to change the index number, and therefore the horizontal order,
of individually selected notes.
TIP
You can change the order of notes in multiple voices project-wide on the Voices page in Write >
Notation Options. You can also change the minimum gaps between notes in different voices in
the Voices section of the Notes page in Engrave > Engraving Options.
You can move notes graphically in Engrave mode. You can move notes individually and
independently of everything else at that rhythmic position, or move everything at the same
rhythmic position.
RELATED LINKS
Swapping the order of voices on page 711
Project-wide Notation Options for voices on page 707
Notation Options on page 119
Engraving Options on page 163

Automatic changes to stem directions when only one voice
contains notes
By default, notes are first input into Up-stem voice 1, and Dorico treats notes as the only voice in
the staff until you input more voices.
This means that when there is only one voice in the staff, the stems of notes are positioned both
up and down, depending on the position of the notes in the staff.
When there are multiple voices in a staff and all voices contain notes, the stem direction of notes
is determined by the stem direction of their voice. For example, notes in Up-stem voice 1 and
Up-stem voice 2 point upwards, and notes in Down-stem voice 1 and Down-stem voice 2 point
downwards.
NOTE
The order in which notes appear between different up-stem voices and different down-stem
voices depends on their pitch, and your settings on the Voices page in Write > Notation
Options. You can also change the voice column index of notes individually.
When there are multiple voices in a staff but not all voices contain notes or rests, the stem
direction of notes may not follow the stem direction of their voice but instead are positioned as
if there is only one voice in the staff. For example, if a staff contains Up-stem voice 1 and Downstem voice 1 but only Down-stem voice 1 contains notes or rests, then the stems of notes in
Down-stem voice 1 may point upwards, depending on the position of the notes in the staff.
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If you later input notes into other voices, the stem direction of notes changes. For example, if you
input notes into Up-stem voice 1 in a bar where there were previously only notes in Down-stem
voice 1, the stems of all notes in Down-stem voice 1 at rhythmic positions where there are now
voices in Up-stem voice 1 point downwards.

Notes in Up-stem voice 1 shown in Notes in Down-stem voice 1
blue.
shown in purple. As Down-stem
voice 1 is the only voice to contain
notes in this bar, the stems point
upwards despite being in a downstem voice due to their position in
the staff.

When both Up-stem voice 1
and Down-stem voice 1 contain
notes in the same bar, the stem
direction is automatically changed.

Showing rests or implicit rests in empty voices forces the stem direction of notes to follow the
stem direction of their voice.
RELATED LINKS
Project-wide Notation Options for voices on page 707
Changing the voice column index of notes individually on page 713
Implicit rests in multi-voice contexts on page 714
Notation Options on page 119

Implicit rests in multi-voice contexts
In Dorico, implicit rests are shown automatically to fill in rhythmic positions around notes.
The same is true for notes when there are multiple voices in the staff. However, in these contexts
you may want more control over when and where rests are shown.
Usually, rests or notes are shown for whole bars when voices contain at least one note in the bar.
This helps make the rhythmic position every note in all voices in the bar immediately clear.
When there are multiple voices in a staff, implicit rests are shown in every bar in which there are
notes in more than one voice, of any duration.
You can choose when rests are shown when there are multiple voices in a number of different
contexts project-wide on the Rests page in Notation Options. You can open Notation Options
in the following ways:
●

Press Ctrl/Cmd-Shift-N in any mode.

●

Choose Write > Notation Options in Write mode.

●

Choose Setup > Notation Options in Setup mode.

You can also hide rests before the first note in voices and after the last note in voices individually.
As this is done by activating properties in the Properties panel, rests before voices and after
voices that have been hidden can be shown again at any time by deactivating the corresponding
property.

A phrase with multiple voices showing implicit rests.
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Voices
Automatic changes to stem directions when only one voice contains notes
Rests can also be deleted permanently.
NOTE
The only way to undo deleting rests is to do so immediately by pressing Ctrl/Cmd-Z, or by
choosing Edit > Undo.

RELATED LINKS
Project-wide Notation Options for rests on page 559
Hiding rests before the first note in voices on page 715
Hiding rests after the last note in voices on page 715
Deleting rests on page 561

Hiding rests before the first note in voices
If the first note in a voice starts part of the way through a bar, rests are shown before the note
from the previous barline by default so that its rhythmic position is clear.
However, there may be occasions when you do not want to show rests before the first note in a
voice when there are multiple voices in the staff.
For example, it can be useful to hide rests when a voice is being used to show passing notes
within a bar that otherwise contains a single melodic line.

An example of a second voice being used to notate passing notes.

To hide rests before the first note in voices:
PROCEDURE
1.

Select the first note in the voices before which you want to hide rests. You can do this in
Write mode and Engrave mode.

2.

Activate the Starts voice property in the Notes and Rests group of the Properties panel.
NOTE
This property cannot be activated for notes that are not the first note in a voice in the
selected staff.

RESULT
When the Starts voice property is activated, rests are not shown before the selected notes, up to
the previous barline.
The property can be deactivated at any time, which shows rests again.
RELATED LINKS
Deleting rests on page 561

Hiding rests after the last note in voices
If the last note in a voice ends part of the way through a bar, rests are shown after the note and
until the next barline by default.
However, there may be occasions when you do not want to show rests after the last note in a
voice when there are multiple voices in the staff.
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For example, it can be useful to hide rests when a voice is being used to show passing notes
within a bar that otherwise contains a single melodic line.

An example of a second voice being used to notate passing notes.

To hide rests after the last note in voices:
PROCEDURE
1.

Select the last note in the voices after which you want to hide rests. You can do this in
Write mode and Engrave mode.

2.

Activate the Ends voice property in the Notes and Rests group of the Properties panel.

3.

Select the rhythmic position at which point the selected voices are ended from the
following options:
●

Immediately

●

After barline

NOTE
This property cannot be activated for notes that are immediately followed by another note
in the same voice in the selected staff.

RESULT
When the Ends voice property is activated, rests are not shown after that the selected notes,
according to your selection.
The property can be deactivated at any time, which shows rests again.
RELATED LINKS
Deleting rests on page 561

Showing multiple rests of the same rhythmic value at the same
rhythmic position in multiple voices
You can choose whether all rests are shown in every voice or whether only one rest is shown for
all voices in the Rest positioning section of the Rests page in Notation Options.
NOTE
You cannot change the position of rests by clicking and dragging them with the mouse.
You can show multiple rests of the same rhythmic value at the same rhythmic position when
there are multiple voices in the staff.
PROCEDURE
1.

Select the rests at the rhythmic positions where you want to see rests for every voice. You
can do this in Write mode and Engrave mode.

2.

Activate the Rest pos. property.

3.

If required, select each rest and change their position by changing the value in the value
field in any of the following ways:
●

Enter a value into the value field.
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●

Click the arrows beside the value field.

RESULT
Increasing the value moves rests upwards. Decreasing the value moves rests downwards.
When the default position of rests is changed, multiple rests are shown at that rhythmic position
if there are multiple voices in the staff.
RELATED LINKS
Notation Options on page 119

Rhythm dot consolidation
You can change how rhythm dots in multiple voices are consolidated project-wide.
In the Rhythm Dots section of the Notes page in Engrave > Engraving Options, you can choose
how rhythm dots in multiple voices are consolidated project-wide from the following options:
●

Preferred

●

Allowed

●

Allowed only for unisons

●

Disallowed

Changing the consolidation of rhythm dots individually
You can also change how rhythm dots in multiple voices are consolidated individually. See
Changing the consolidation of rhythm dots individually for more information.
RELATED LINKS
Project-wide changes to the appearance of noteheads on page 453
Project-wide Engraving Options for notes on page 453
Changing the consolidation of rhythm dots individually on page 458
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articulation
(1) Symbols that are used to indicate how a note should be played, typically affecting their onset
(attack), release, or duration. (2) In sample libraries, more generally referring to any playing
technique.
attachment
The rhythmic position at which an item, such as a clef, dynamic, rehearsal mark, and so on, is
found in the music.
bar
A span of music comprising a specific number of beats, as defined by the prevailing time
signature, whose boundaries are indicated by bar lines.
caret
The vertical line that extends above and below the stave and indicates the rhythmic position at
which a note or chord can be input. See also rhythmic grid.
channel
Roughly analogous to a staff. In MIDI, a channel is a means to disambiguate which note,
controller, or other data should be played by which sound on which device. In Dorico, notes on
a single staff may be played by different channels, depending on which playing techniques are
provided by the patch assigned to each channel. See also MIDI, patch.
chord
Two or more notes of the same duration that start at the same rhythmic position and share a
stem.
column
All of the notes and chords that start at the same rhythmic position are considered to be in the
same global column, that is, across all of the staves in the system, for the purposes of spacing
the music. If there are notes or chords in multiple voices starting at the same rhythmic position
within a given staff, this may result in multiple voice columns, with notes or chords in some
voices being offset horizontally from notes or chords in other voices.
disclosure arrow
Small arrow that is shown on all edges of the main window in Dorico. It allows you to show and
hide the toolbar and panels individually.
EDO
An abbreviation for Equal Division of the Octave, a unit used particularly in microtonal music to
describe how an octave can be divided into equal parts for the purposes of defining a microtonal
scale or tuning system. Traditional Western European music uses 12-EDO, that is, each octave is
divided into 12 equal semitones or half-steps, and music that uses equal quarter-tones uses 24EDO.
Engrave mode
A workspace that allows you to make fine graphical adjustments and to adjust the page layout
and the format of the system. See also modes.
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engraving options
Options that affect the graphical appearance of the notation, including choice of symbols, line
thicknesses, distances, and so on. These options are common to a whole project and apply to all
flows and layouts.
ensemble
A predefined list of players, each holding instruments that are often used together, such as
string quartet, wind quintet, brass quintet, string ensemble, double woodwinds, etc. Ensembles
can be added to your project in Setup mode.
family
Instruments of a similar kind that are typically bracketed together in a score, such as woodwind,
brass, percussion, and strings.
flow
A complete span of music of any scope, for example, a movement, song, piece, scene, number,
act, cue, example, or exercise, that contains music assigned to players.
formatting
The act of determining the number of bars in a system, the number of systems on a page, and
the distances between staves and systems. Dorico formats your music automatically, but allows
you to adjust the formatting directly in Engrave mode.
fragment
Part of an item. For example, a note or chord contains many fragments: each notehead, each
group of rhythm dots, each accidental, the tip of the stem, and the beam are all fragments. In
Write mode, when you select an item, the entire item, including all of its fragments, is selected
and is affected by any edit that you make. In Engrave mode, however, you can select each
fragment individually to tweak its position or appearance. See also item.
frame
A rectangular container for music, text, or graphics on a page.
full score
A score comprising all of the music for all of the players and their instruments, typically laid
out in a specific order. The order used varies according to the ensemble for which the music
is written. In full scores for orchestra, the players are typically ordered from the highest wind
instrument at the top of the page, for example, piccolo, to the lowest string instrument at the
bottom of the page, for example, contrabass, with brass, keyboards, voices, and percussion in
between.
galley view
Music for one or more flows laid out as a single, infinitely wide system.
grace notes
Sometimes called arhythmic notes, grace notes are added as ornaments or embellishments
and are printed smaller than normal notes. Grace notes are not counted towards the number
of beats in a bar. When performed, they steal from the duration of either the preceding or the
following rhythmic notes. In common practice, an acciaccatura is a grace note with a slashed
stem, which is to be played as quickly as possible, either immediately before or at the rhythmic
position of the note or chord that follows it; an appoggiatura is a grace note that is written
without a slash across its stem. It is to be played as half of the written duration of the note or
chord that follows it.
group
A collection of players that comprises either a subset of the main ensemble, for example, a
choir within an orchestra, or a separate group, for example, an off-stage brass group or second
orchestra. Each group of players is labeled separately in the full score and is grouped and
numbered together in the instrument order. See also player.
hairpin
A gradual increase or reduction in the dynamic level, that is, a crescendo or diminuendo,
indicated using a pair of angled lines that diverge from or converge to a single point.
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horizontal justification
The alignment of musical content to the left and right edges of the frame. Typically all the staves
in a system, and all of the systems on a page, occupy the same width. Different music in different
staves is spaced differently. Therefore, to ensure that all of the staves are the same width, any
remaining space that is left over after the music is spaced is distributed evenly between all of
the columns in the system. Sometimes the final system of a flow is not fully justified, that is, it is
allowed to end midway across the width of the frame. See also frame, justification.
instrument
Anything that requires one or more staves in order to communicate its musical content, whether
it is an instrument that is blown, struck, bowed, shaken, or otherwise coaxed into making sound.
An instrument is also a human voice, a computer triggering samples, or a tape recording.
item
Generic term for any note, rest, chord, notation, or other selectable object that appears in the
score in Dorico. See also fragment.
justification
The alignment of musical content to the edges of the frame, both horizontally and vertically. See
also frame, horizontal justification, vertical justification.
layout
A page-based presentation of the music for one or more players in one or more flows, for
example, a full score or an instrumental part.
layout options
Options that affect the setup of an individual layout, such as page and staff size. See also layout.
lock duration
Functionality that allows you to change the pitches of existing music while retaining existing
rhythms.
lyric
Any text – whether a whole word or individual syllable – that is intended to be sung or spoken
by an individual singer or group of singers. Lyrics are shown at each rhythmic position where a
new word or syllable begins. Typically, lyrics are found below the stave, but sometimes above the
stave, for example, in the case of a short score.
measure
See bar.
MIDI
An abbreviation for Musical Instrument Digital Interface, a standard for how electronic musical
instruments, computers, and virtual instruments can connect to and communicate with each
other. MIDI data can be sent to one of 16 channels, which allow either a specific instrument, or
a specific patch on a specific instrument, to receive and respond to the data. See also channel,
patch.
modes
Selectable workspaces in the project window that represent different phases in the workflow of
preparing a score.
multi-bar rest
A series of empty bars in which a player is resting, that is, the player does not play his or her
instrument. This is typically shown in a part as a single bar, with the number of bars' rest written
above or sometimes below the stave. Instead of a normal bar rest symbol, a multi-bar rest
normally shows an H-bar, which is a horizontal line with the same thickness as a bar rest, but
with vertical lines at each end. In some older published scores, a multi-bar rest of up to nine bars
in length is shown using a combination of double whole and whole rests.
MusicXML
A file format designed to allow the interchange and archiving of music notation data in an open
and non-proprietary way. It is useful for exchanging scores between different music applications.
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music area
The main part of the window in Setup, Write, and Engrave mode where you input and edit your
music.
notation options
Options that affect the way the music is notated, particularly concerning how notes and rests are
grouped according to meter, rules for the extent of accidentals, and options for transposition.
These options can be set independently for each flow.
page break
The forced termination of a page of music at a particular rhythmic position, typically, though
not always, at a barline. Dorico creates page breaks automatically, but you can adjust them in
Engrave mode, for example, to ensure a convenient page turn in a part.
page view
Music for one or more flows laid out on a page of a fixed width and height, as it appears when
printed.
panel
Wide palettes of tools on the left, right, and bottom edges of the window that are available in all
modes, but their content varies in each mode.
part
The music belonging to the instruments played by one or more players, shown on its own
rather than in a full score. Performers who do not need to see the music belonging to the whole
ensemble play from parts so they only have to read the music they play themselves. See also full
score.
patch
An older term for a discrete sound on a MIDI device or virtual instrument. See also channel, MIDI.
Play mode
A workspace that allows you to assign VST instruments, to adjust the mix, to apply automation,
and to tweak note data. See also modes.
player
A musician who plays one or more instruments. Players are defined as either solo players or
section players. See also solo player, section player.
plug-in
A software program that can operate within another software program. Dorico supports
the following kinds of plug-ins: VST instruments and effects, which are used to produce and
manipulate the playback of your music; and script plug-ins, written in a programming language
called Lua, that can automate repetitive tasks or even extend the functionality of Dorico in new
and interesting ways.
print preview area
The main part of the window in Print mode where you can see a preview of what is going to be
printed or exported as a graphic. See also Print mode.
Print mode
A workspace that allows you to print to your printer, export to PDF, and export to other graphics
files. See also modes.
project
A Dorico document.
properties
The characteristics of items in your project – such as the direction of a slur, the horizontal
placement of a tempo marking, the precise shape of a tie – that can be edited via the properties
panel.
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rhythmic grid
Ruler markings showing beat divisions and subdivisions that appear above the bar in which the
caret is currently located. See also caret.
score
See full score, part, project.
section player
Multiple musicians who all play the same instrument and read from the same part layout, for
example, Violin I. Section players may not play multiple different instruments, but can divide. See
also player.
Setup mode
A workspace that allows you to add players, to assign instruments to those players, to create
flows, and to assign players and flows to layouts. See also modes.
solo player
An individual musician who can play one or more instruments, for example, flute 3 doubling
piccolo. See also player.
space
The distance between the center of two adjacent staff lines, the main unit of measurement used
in music engraving. For example, a notehead is normally one space tall. Practically all items in the
score are scaled in proportion to the size of a space.
spacing
The act of determining the horizontal distance between successive columns in order to format
the music. Horizontal spacing takes the following main considerations into account: the actual
graphical shape and size of the notes, rhythm dots, accidentals, and so on, and the ideal
horizontal distance defined for a given note value. When sufficient music has been spaced such
that no further music can fit in the available width, the system is considered full, and the result is
then horizontally justified.
spelling
The way in which a note of a given pitch is specified by a letter name plus an accidental. For
example, assuming the conventional 12-EDO pitch system, MIDI note 61 can be spelled as C♯,
D♭, B�. The same pitch is normally spelled a certain way in a given key: for example, MIDI note 61
would normally be spelled as C♯ in D major, but as D♭ in Ab major. See also EDO, MIDI.
system break
The forced termination of a system of music at a particular rhythmic position, typically, though
not always, at a barline. Dorico creates system breaks automatically, but you can adjust them in
Engrave mode.
system item
A notation that applies to all instruments in a system, for example, a tempo instruction, rehearsal
mark, key signature, or time signature. Some system items, such as key and time signatures,
are shown on every staff, while others, such as tempo and rehearsal marks, are normally shown
above the top staff in the system, and in large ensembles also above one or more staves further
down in the system.
system view
Music for one or more flows that is laid out as if on a page of the defined width but with variable
height, with each successive system laid out to the right of its predecessor.
token
A code used in a text string that is automatically replaced by a piece of information from
elsewhere in the project, such as the title of the current flow, the name of the player, or the page
number.
transport
Encompasses all options related to playback and recording.
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tuplet
Sometimes called an irrational rhythm or a countermetric rhythm, a tuplet is a rhythm that is
performed at a fraction of its normal written duration. For example, a triplet is three notes of a
given note value played in the time it would normally take to play two notes of that note value;
each note is two-thirds as long as it would normally be.
vertical justification
The alignment of musical content to the top and bottom edges of the frame. Typically, a music
frame is laid out such that the top line of the top staff of the top system is positioned at or near
the top of the page. The bottom line of the bottom staff of the bottom system is positioned at
or near the bottom of the page. If the ideal height of the music in the frame is less than the
available height, the remainder is distributed evenly between the systems, and if the remainder
is larger, it is further distributed evenly between the staves within the systems. If the remainder
is especially large, then the music may not be justified at all, since it may be preferable to leave a
larger gap at the bottom of the frame than to have exceptionally wide gaps between the staves.
See also frame, justification.
voice
A series of notes, chords, rests, and other notations that are normally played by the same
instrument. Most instruments are typically monophonic, that is, they only play a single note
at once, so most music is written in a single voice. When a single voice is active on a stave, the
stems of notes and chords point in their natural directions, down for notes above the middle
staff line, up for notes below the middle staff line, and either up or down according to context
for notes on the middle staff line. Music for keyboard, guitar, and pitched percussion more
commonly uses multiple voices on the same staff, in which case all notes and chords that belong
to a given voice are shown with stems pointing in the same direction: the upper voice typically
has all stems pointing up, while the lower voice typically has all stems pointing down. Dorico
allows as many voices as are needed to be input onto a single stave, and lays them out and
spaces them automatically.
Write mode
A workspace that allows you to input music and other notations. See also modes.
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project-wide engraving options 205

accidental duration rules 196
changing 197
common practice 198
Modernist 200
Second Viennese School 200
accidentals 188
adding 103
adding notes with 188
adding to existing notes 189
altered unisons 193
changing 190
changing the duration rule 197
deleting 190
duration rules 196
enharmonic respelling 193
hide, show, parenthesize 191
individual changes to 191
microtonal 195
selection during midi input 189
add intervals popover 105
altered unisons
split stem 603
anacrusis
starting your score with an 108
arpeggio signs 464
changing ends appearance 472
changing type 468
deleting 468
general placement conventions 465
inputting with the keyboard 465
inputting with the mouse 467
lengthening and shortening 469
moving 470
moving rhythmically 470
ornaments popover 486
playback 473
project-wide engraving options 473
showing before grace notes 472
articulations 204
adding 104, 205
changing 207
changing the positions 208
copying 207
deleting 207
individual changes to the positions of 211
inputting with the keyboard 205
key commands 205
playback 212
project-wide changes to the positions of 209

B
bar numbers 231
changing appearance project-wide 231
changing enclosure type 234
changing font style 233
changing frequency 232
changing horizontal position 237
changing placement relative to staff 239
changing position relative to other objects 238
changing position relative to staff 238
font style 231
multiple positions in systems 240
parts 243
pick-up bars 245
repeat endings 244
sequence changes 240
subordinate 241
barlines 222
across staff groups 228
changing spacing 227
changing type with the keyboard 225
changing type with the mouse 227
default end barline 230
deleting 227
inputting with the keyboard 223
inputting with the mouse 226
popover 224
project-wide engraving options 229
bars 213
changing length 218
changing width 218
combining 221
deleting 217
deleting contents 218
divisions 219
inputting with the keyboard 213
inputting with the mouse 215
moving bar rest 219
popover 213
splits in 219
splitting across system and frame breaks 220
splitting into multiple bars 221
beaming 246
adjusting beam angle 254
adjusting beam slant 254
beam corners 258
beam slant 253
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centered beams 255
changing grouping defaults 247
changing grouping individually 248
changing placement relative to the staff 252
creating 246
cross-staff across multiple staves 257
cross-staff beams 256
fanned beams 260
grouping 247
grouping according to meter 262
notes together 251
over barlines, system breaks, and frame breaks
251
placement relative to the staff 252
removing placement changes 252
removing stemlets individually 249
reset grouping 251
secondary beams 259
setting within time signatures 247
showing stemlets individually 248
splitting 249
tuplets 259
unbeaming 250
borders
adding to layouts 185
brackets and braces 264
appearance 266
grouping by ensemble 265
player groups 266

inputting with the keyboard 269
inputting with the mouse 272
moving graphically 274
moving rhythmically 273
project-wide spacing gaps 273
relative to grace notes 277
color graphics 181
constraints
defining 159
courtesy accidentals
hiding 199
showing 199
crop marks
adding to layouts 185
cues 305
changing to rhythmic 310
inputting 305
overlapping 323
popover 305
rhythmic 310
suggest cues section of the cues panel 307
suggestions 307
curvatures
changing for individual ties 654
changing for tie chains 653

D
date and time
adding to layouts 185
direction
individual tie curvatures 654
tie curvatures in tie chains 653
double accidentals
canceling 199
duplex printing 179
durations
forcing 102
selecting 102
dynamics 329
adding expressive text 338
changing appearance individually 351
changing placement relative to staff 340
copying 346
deleting 347
general placement conventions 330
gradual dynamic spacing 342
grouping 348
hairpins relative to barlines 330
input with keyboard 331
input with mouse 335
inputting niente hairpins 337
inputting with keyboard 333
linking 349
moving 343
placement 340
placement relative to staff 340
positions of 343
project-wide engraving options 356
types of 329
voice-specific 341

C
caret
activating 98
deactivating 98
moving manually 99
moving on the rhythmic grid 99
types 98
cautionary accidentals
hiding 199
showing 199
character styles 155
deleting 157
chord symbols 287
appearance presets 302
changing appearance 302
creating 287
deleting 300
enharmonic spelling 300
hiding 297, 298
importing from XML 304
inputting 288
playback 303
project-wide engraving options 302
transposing 297
chords
moving the caret 99
chorus lines
adding to lyrics 115
clefs 268
changing size 276
deleting 275
hiding 276
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edit percussion playing techniques dialog 689
Engrave mode
opening 128
engraving options 163
ensembles 67
adding 67
adding to groups 79
export
adding borders 185
adding crop marks 185
adding date and time 185
adding watermarks 185
arranging layout pages 183
color graphics 181
monochrome graphics 181
specifying a page range 184
specifying the output format 181
specifying the path 182

glissando lines 476
adjusting angles individually 480
changing angles 481
changing style 483
changing text 483
changing when text is shown 484
deleting 479
general placement conventions 476
inputting across empty bars 478
inputting between non-adjacent notes 478
inputting with the keyboard 477
inputting with the mouse 477
ornaments popover 486
positions 480
project-wide engraving options 484
global notation settings 164
grace notes 379
accidentals 382
articulation 382
changing appearance individually 385
changing appearance project-wide 385
changing pitch 382
changing position project-wide 383
changing slash length individually 388
changing slash position individually 387
changing the type 107
changing type individually 385
deleting 383
general placement conventions 379
inputting 107
inputting with the keyboard 380
inputting with the mouse 381
moving rhythmically 383
gradual dynamics
spacing 342
groups 31, 78
adding 78
adding ensembles 79
adding players 79
assigning players 79
changing the name of 78
deleting 79
moving players to another group 79
removing players 80
renaming 78

F
files

opening 35
filters
lyrics 440
fingerings
project-wide engraving options 365
flows 32, 80
assigning to frame chains 162
changing the name of 81
changing the notation options 82
changing the title of 81
creating 80
deleting 82
excluding from layouts 82
excluding players 67
names 80
renaming 80, 81
titles 80
frame breaks
inserting 159
frame chains
assigning flows 162
assigning players 162
for pages in a layout 148
on master pages 148
selecting for music frames 161
frame orders
changing 161
frames 145
defining constraints 159
for graphics 158
for music 146
for text 148
inserting into pages 145
front matter 374
changing text in running headers 376
full score
excluding players from layout 66
full screen mode
activating 49

H
holds and pauses 389
changes to fermatas 401
changing position project-wide 401
copying 400
deleting 398
general placement conventions 391
inputting with the keyboard 392
inputting with the mouse 394
moving graphically 397
moving rhythmically 397
multiple at same rhythmic position 400
over barlines 399
playback 401
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popover 392
project-wide engraving options 401

types of 403

L

I

layout
changing to a different 84
layout frame chains 148
layout names
changing 64
layout options 85
layouts 32
adding empty pages 140
adding pages with other formatting 140
arranging pages for export 183
arranging pages for printing 183
changing the name of 83
creating 83
deleting 84
displaying several in project window 38
excluding flows 82
exporting as graphic files 180
exporting several 183
in Print mode 176
in Setup mode 57, 83
printing 178
printing several 183
renaming 83
scaling 185
selecting 37
selecting a page range 183
selecting job types 183
sorting 84
switching 84
view types 44
lyrics 425
adding 115
adding chorus lines 115
adding translations 116
aligning syllables 119
changes to the type and placement of 440
changing line number 441
changing lyrics to chorus 444
changing lyrics to translations 445
changing placement relative to the staff 442
changing the line number 116
changing verse number appearance 450
filters 440
key commands 114
lengthening and shortening lyric extender lines
435, 436
lyric extender lines 434
lyric hyphens 434
moving lines to different lines 117
moving lyric extender lines 434, 436
placing 118
placing syllables 119
project-wide engraving options 450
showing and hiding verse numbers 450

individual players
adding 59
inputting notes 94
insertion point 98
instrument names
changing 65
in the score 589
instrument pitches
showing before or after instrument names 594
showing or hiding in staff labels 593
instrument transpositions
showing before or after instrument names 594
showing or hiding in staff labels 593
instrumental parts
including players 67
instruments 31, 68
adding 68
adding multiple 69
changing the instrument name of 65
deleting 71
names 62

J
job types
selecting 183

K
key commands
defining 51
key signatures 402
cancelation style 422
cautionary 424
changing 417
changing graphical position individually 420
creating custom accidentals 407
creating custom key signatures 410
creating custom octave divisions 407
creating custom tonality systems 405
deleting 418
enharmonic equivalent 423
general placement conventions 402
hiding 418
inputting with the keyboard 411
inputting with the mouse 414
Key Signatures section 415
moving graphically 420
moving rhythmically 419, 420
multiple 424
panel 414
popover 411
project-wide engraving options 422
project-wide spacing gaps 419
tonality systems 404
transpose dialog 422
transposing with selection 422

M
master page changes 138
master page editor 137
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master page frame chains 148
master page overrides 138
removing from all pages 140
removing from individual pages 139
master page sets 133
creating 134
deleting 135
renaming 134
selecting 135
master pages 133
adding 136
assigning to pages 143
changing text in running headers 376
deleting 136
editing 137
editing in the master page editor 137
overriding 138
removing changes on all pages 144
removing changes on individual pages 144
renaming 136
reverting changes on all pages 144
reverting changes on individual pages 144
sets 133
types 135
MIDI files
importing 35
Mixer window 36
modes 30
monochrome graphics 181
music area 40
selecting a different view 50
zoom settings 45
music frames
assigning to frame chains 161
selectors 160
MusicXML
importing 35

adding articulations 104
adding intervals above and below existing notes
105
adding rhythm dots 103
articulations 89
available notehead designs 455
beaming over barlines, systems breaks, and frame
breaks 251
beaming together 251
changing custom scale size individually 457
changing enharmonic spelling 193
changing ledger line width 458
changing notehead design individually 456
changing notehead design project-wide 453
changing size individually 457
changing the duration 102
changing the pitch of 460
editing individual parts 164
editing individual properties 164
editing selected 121
entering 92
input methods 94
inputting 92, 94, 459
inputting grace notes 107
modifying 88
moving graphically 172, 461
moving rhythmically 461
note spacing 172, 461
positioning with the rhythmic grid 99
project-wide engraving options 453
selecting 93
slurs 89
transposing 460
transposing using the add intervals popover 107
types 89

O

N

octave lines 278
deleting 285
editing individually 285
inputting with the keyboard 279
inputting with the mouse 280
lengthening and shortening 284
moving 282
positions 282
project-wide engraving options 285
options
engraving 163
layout 85
notation 119
orientation
changing 185
ornaments 485
changing interval 488
changing placement relative to the staff 494
changing position of accidentals relative to trills
489
changing position relative to slurs 494
changing start position of trills 495
changing trill speed 495
deleting 491
general placement conventions 485

nested tuplets
inputting with the keyboard 668
inputting with the mouse 669
notation
zoom settings 45
notation options 119
changing for flows 82
notation settings
global 164
of selected notes and notations 121
notations
editing individual parts 164
editing individual properties 164
editing selected 121
selecting 93
note and rest grouping
according to meter 262
note values
forcing 102
selecting 102
notes 453
accidentals 89
adding accidentals 103
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hiding trill extension lines 491
inputting with the keyboard 486
inputting with the mouse 487
lengthening and shortening trills 490
moving 491
moving graphically 492
moving rhythmically 492
ornaments popover 486
positions of 491
project-wide engraving options 496

inputting with the keyboard 505
inputting with the mouse 508
level changes 520
overriding text 524
playback 526
popover 506
project-wide engraving options 514
retakes 520
percussion 679
percussion kit presentation types 687
percussion kits
changing gap sizes in grid presentation types 77
changing positions of instruments within 76
dynamics in 687
staff labels 595
percussion maps 697
creating new percussion maps 700
defining custom percussion maps 700
percussion maps dialog 697, 698
pick-up
starting your score with a 108
pitch
changing 460
player names
changing 64
players 31, 59
adding individual players 59
adding section players 60
adding solo players 59
adding to groups 79
assigning to frame chains 162
assigning to groups 79
changing position in score 66
changing the instrument name of 65
changing the layout name of 64
changing the orchestral order of 66
changing the player name of 64
copying 61
deleting 66
duplicating 61
excluding from flows 67
excluding from full score 66
including in instrumental parts 67
moving between groups 79
names 62
numbering instruments 61
removing from groups 80
renaming 64, 64, 65
playing techniques 527
adding alternative text 533
changing placement relative to staff 533
deleting 533
general placement conventions 527
inputting with the keyboard 527
inputting with the mouse 530
moving 531
playback 534
project-wide engraving options 534
preferences 51
print
adding borders 185
adding crop marks 185
adding date and time 185

P
page number change dialog 141
page numbers 497
changes 498
changing 141
changing position on page 498, 498
changing the number of 141
changing the style of 141
inserting change in sequence 141
moving in master pages 498
moving using the Properties panel 498
removing all changes 143
removing individual changes 142
page ranges
exporting 184
printing 184
selecting 183
page sizes 184
page view
page arrangements 45
pages
arranging in the music area 45
assigning master pages 143
inserting frames 145
swapping 144
panels 42
flows 58
formatting 129
hiding 37, 49
hiding individual panels 50
layouts in Print mode 176
layouts in Setup mode 57
notations 91
notes 89
pages 130
players 55
print options 177
properties in Engrave mode 130
properties in Write mode 90
showing 37
paper sizes 184
determining 185
paragraph styles 152
creating 154
creating based on other styles 155
deleting 155
pedal lines 505
changing individually 515
deleting 513
editing in Engrave mode 520
importing from MusicXML files 526
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adding watermarks 185
arranging layout pages 183
duplex printing 179
specifying a page range 184
Print mode
opening 175
print preview 41
print preview area 41
printer
selecting for layout 178
specifying the number of copies 178
project start area 39
project templates 34
project window 36
Engrave mode 128
opening several 49
Print mode 175
Setup mode 54
Write mode 87
project-wide settings 164
projects 30
opening multiple windows 49
opening recent projects 35
starting 34
Steinberg Hub 33
templates 34
viewing in full screen mode 49
properties
of individual parts of notes and notations 164

changing vertical position 563
deleting 561
forcing position and duration 560
general placement conventions 559
hiding 561
inputting with the Rests tool 100
project-wide engraving options 559
project-wide notation options 559
showing colors 560
showing for multiple voices 563
specifying a duration 100
turning explicit into implicit 562
rhythm dots
adding to notes 103
rhythmic grid
changing the resolution 99

S
section players
adding 60
selection tools 44
moving the view 44
selecting multiple notes and notations 44
selectors
in music frames 160
Setup mode
opening 54
slurs 564
changing number of segments 573
changing position relative to tie chains individually
565
changing shoulder offset individually 581
changing shoulder offset using the Properties
panel 582
changing thickness individually 579
collision avoidance 586
cross-staff 568
cross-voice 569
curvature direction 583
deleting 573
general placement conventions 564
height 580
inputting across staves 568
inputting across voices 569
inputting during step input 568
linking across staves 573
nested slurs 570
over system and frame breaks 587
playback 588
project-wide engraving options 575
segments 572
shoulder offset 581
styles 584
within slurs 570
solo players
adding 59
staff labels 589
changing length at specific positions 592
changing length project-wide 591
changing position of pitches relative to instrument
names 594

R
rehearsal marks 536
changing appearance project-wide 542
changing enclosure type 543
changing font style 543
changing order 539
changing sequence type 540
deleting 539
enclosure size 544
font style 542
general placement conventions 536
moving 537
padding values 544
project-wide engraving options 542
showing at multiple positions 541
repeat endings 547
adding endings 548
changing appearance individually 555
changing appearance of final segments
individually 556
changing appearance project-wide 550
changing hook length individually 556
changing text shown individually 555
changing total number of repeats 549
creating 547
moving 552
MusicXML files 557
positions of 552
project-wide engraving options 550
showing above instruments 550
rests 558
changing horizontal position 563
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changing position of transpositions relative to
instrument names 594
instrument names 590
percussion kits 595
showing or hiding instrument pitches 593
showing or hiding instrument transpositions 593
status bar 43
view types 44
staves
placing lyric syllables 119
placing lyrics 118
Steinberg Hub 33
stems 597
altered unisons 603
changing default stem direction for middle line
599
changing direction individually 601
changing flag design project-wide 598
changing length project-wide 598
direction in multi-voice contexts 601
lengthening and shortening 600
lengths 600
project-wide engraving options 597
removing direction changes 602
resetting length individually 601
split 603
syllables
changing the verse number 117
moving to different lines 118

changing the styles of 652
ties 635
adding to existing notes 639
changing curve direction 646
changing height individually 649
changing height with the keyboard 580
changing individual curvature directions 654
changing individual ties in tie chains 652
changing position and shape individually 645
changing position and shape using the properties
panel 646
changing shoulder offset individually 647
changing shoulder offset using the Properties
panel 648
changing style 650
curvature directions 652
default curvature directions between notes of
different stem directions 653
deleting all ties 643
general placement conventions 635
height 649
in other contexts 639
inputting between different voices 642, 642
inputting between non-adjacent notes 641
inputting during step input 637
laissez vibrer 642
positions of 636
project-wide engraving options 644
shoulder offset 647
splitting tie chains 644
tie chains 636
ties versus slurs 637
time signatures 615
adding 108
changing 625
changing appearance of 629
changing position graphically 627
Create Time Signature section 622
creating custom 108
creating custom beam grouping 262
deleting 629
general placement conventions 616
hiding 628
inputting with the keyboard 618
inputting with the mouse 621
moving graphically using the Properties panel 627
popover 618
positions 625
project-wide engraving options 629
project-wide spacing gaps 625
specifying beam grouping 247
types of 617
toolbar 37
workspace options 37
toolboxes 43
notations 91
notes 88
translations
adding to lyrics 116
Transport window 36
transpose dialog 422
transposing notes 107

T
tabs
closing 47
closing all 47
creating groups of 47
displaying different layouts 46
displaying different views 46
hiding 37
moving to other tab groups 48
moving to other windows 48
ordering on tab bar 48
showing 37
splitting into groups 47
switching 48
templates 34
tempo marks 604
changing appearance individually 611
changing appearance project-wide 611
changing metronome mark value 614
changing tempo text 613
deleting 611
general placement conventions 605
inputting with the keyboard 605
inputting with the mouse 607
moving rhythmically 609
popover 605
positions 609
project-wide engraving options 611
Tempo panel 607
types of 604
tie chains 635
changing the curvature direction 653
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tremolos 655
moving graphically 662
moving multi-note tremolos graphically 663
moving single-note tremolos graphically 662
positions 661
trills 485
changing position of accidentals 489
changing speed 495
changing start position 495
hiding extension lines 491
lengthening and shortening 490
triplets 665
tuplets 665
accidentals 670
adding 104
adding slurs to 670
articulation 670
beams 672
brackets 672
changing bracket angle 677
changing pitch 670
changing placement relative to the staff 676
changing tuplet bracket end position rhythmically
676
changing tuplet number or ratio 674
changing tuplet number or ratio position 675
deleting 671
editing brackets 674
editing individually 672
general placement conventions 665
individual changes to 674
inputting nested with the keyboard 668
inputting nested with the mouse 669
inputting with the keyboard 666
inputting with the mouse 668
moving brackets graphically 672
moving brackets graphically using the Properties
panel 673
moving rhythmically 671
popover 666
project-wide engraving options 677

staff labels 595
voices in kits 695
upbeat
starting your score with an 108

V
voices 706
adding to existing music 709
automatic stem direction 713
changing 709
changing voice column index 713
deleting 710
general placement conventions 706
hiding rests at the end of 715
hiding rests at the start of 715
implicit rests in multi-voice contexts 714
inputting 101
inputting during step input 708
pasting into different 710
project-wide notation options 707
re-using existing voices 101
rhythm dot consolidation 717
showing colors 710
swapping contents 711
swapping order 711
switching between 708

W
watermarks
adding to layouts 185
workspace
changing 37
changing the preferences 51
workspaces 30
Write mode
opening 87

U
unpitched percussion 679, 682
creating new percussion maps 700
default note selection during step input 684
defining custom percussion maps 700
engraving options 680
indian drum notation 705
inputting notes in kits 683
kit presentation types 687
kits versus individual instruments 679
maps for playback 697
MIDI import 704
MusicXML import 704
notation options 680
parenthesizing notes 685
percussion kits 680
percussion legends 692
percussion maps dialog 698
playing techniques 689
showing notes as ghost notes 685
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