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Improvements

Dorico Version History

August 2017

This version contains the following improvements and issue resolutions.

Chord symbols

If you need to customize the appearance of chord symbols above and beyond the
dozens of options provided in Engraving Options — for example, if you need to
tighten the spacing of one or two chord symbols in a passage with rapid changes
of harmony, or if you want to use a particular convention that is not directly
supported — you can now both edit how a specific chord symbol should look by
default in your project (and save this as the default for future projects) and override

the appearance of an individual chord symbol.

Before you start editing chord symbols with either of these graphical editors, do
take the time to check that the appearance you want is not achievable via
Engraving Options: if it is, then changing a couple of options there will save you a

lot of time.

Changing the default appearance of a chord symbol in your project. To adjust the
appearance of all instances of a specific kind of chord symbol in your project, click
the Edit button in the Project Default Appearances section at the bottom of the
Chord Symbols page of Engraving Options to open the Project Default Chord
Symbol Appearances dialog.

Project Dofault Chord Symbal Appearances
Enter a chord symbol: Editing: Am3({#11)

Fma(#11)

s

Single Cverrides N zoom:—{ ) Select: | Previous || Mext

| saveaspefault | | Resetto Factary | i Apply Close. |
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On the left-hand side of the dialog are two lists of chord symbols: Project Default
Appearances lists the chord symbols whose default appearance has been
overridden in the project; and Single Overrides lists the individual chord symbols
that have been edited.

To change the default appearance of a particular chord symbol so that it will
appear exactly as you wish whenever you create it, specify it by typing into the box
at the top left-hand corner of the dialog and click the + button, which adds it to the
Project Default Appearances list.

If you have overridden the appearance of an individual chord symbol in your
project, you can promote that override to become a default for new chord symbols

in your project by selecting it in the Single Overrides list and click the button.
Selecting a chord symbol in the Single Overrides list will show it on the right-hand
side of the dialog, but you will not be able to edit it from here: to edit it without
promoting it to becoming the default appearance for that chord symbol in your
project, instead leave this dialog and double-click the chord symbol in Engrave

mode.

To save the chord symbols in the Project Default Appearances list such that they
will become the default appearances for those chord symbols in newly-created
projects, click the Save as Default button at the bottom left-hand corner of the
dialog.

If you have made edits since opening your project but you want to return to your
previous saved defaults, click Reset to Saved Defaults. If you do not have any
saved defaults, the button will instead read Reset to Factory, and clicking this will
remove all user-saved defaults.

If you hold Ctrl (Windows) or Alt (Mac), the Save as Default button will change to
Remove Saved Defaults if you have previously saved some default chord symbol

appearances; likewise, the Reset to Saved Defaults button will change to Reset

to Factory.

The controls in the right-hand side of the dialog for editing chord symbols are
common to editing default chord symbol appearances and overriding individual
chord symbols, and are described below.

Editing the appearance of individual chord symbols. To adjust the appearance of
an individual chord symbol, switch to Engrave mode and double-click the chord
symbol. In the dialog that appears, you can make fine adjustments to the position
and size of the individual components that comprise the chord symbol.
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L ] Edit Chord Symbol Appearance

Editing: Cdim7add#7

X offser: | 0.88 F: 1 ResetXoffset | Scale: | 100.00 ﬂ* Reset Scale

voftset: [000 [ | Resetvoffset

[ cancet | oK |

The large editing area can be zoomed in and out using the slider directly below;
you can click on each component of the chord symbol (e.g. root, root accidental,
quality, interval, alterations, etc.), or use the Previous/Next buttons to change the

selection, or use the left and right arrow keys to change the selection.

When a component is selected, you can adjust its position relative to the
component to its left either by clicking and dragging with the mouse, or using the X
offset and Y offset controls, or holding Alt and using the arrow keys. Notice that
any components to the right of the component you have selected also move: this is
because the components are attached to each other, to ensure a good layout
when using a different font.

You can also adjust the relative size of each component by adjusting the Scale
value, or by dragging the handle at the top right-hand corner of the border around
the selected component.

You can also substitute the selected component with other compatible
components (e.g. replace maj7 with A) by clicking another component from the

row of alternative components at the bottom of the dialog.

When you override the appearance of an individual chord symbol, all of the
components in the chord symbol are duplicated so that any edits you make to
these components in the Project Default Chord Symbol Appearance dialog or
edits you make in Engraving Options will not affect the overridden chord symbol.
Components that exist either because you have created them or because they are
used by an overridden chord symbol appear with a red triangle in the top corner in
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the row of alternative components. Components that are not currently in use by any
chord symbol in the project also show a delete icon: clicking this will delete the
component from the project.

In the Project Default Chord Symbol Appearance dialog, if you want to change
the default appearance of a given individual component (e.g. maj7) such that it will
be changed for all chord symbols in the current project, select it in the list of
compatible components, and click the pencil icon to edit it. Any changes you make
to this component will be reflected in all chord symbols that use it.

If you would instead like to create a new component based on a current one, for
example for use in a single chord symbol that is in a particularly tightly-spaced
passage, then click the + button to create a new component based on the
selected one. This new component will then be used only in the current chord
symbol.

L ] Edit Composite Component
Mame: | comp.chordsymbol kadd. 7. kSharp

m Text Graphic Composite

Font: | Bravura w |

Range: [ Standard accidentals (12-EDO) ~ |

b | 4§ « | B
fc | Bb | Bb | B8 | B4

( ) I |

Zoom:—{_} Select: | Previous || West | Delete Setected ]
Xoffser: | 128 I:- Xscale: | 100.00 F Artachment from: | Baseline Right e
Yoffiet: |03 | vscale: [100.00 |  Atachmentto: | Baseline Left w

‘Add Glyph
Cancel | BUIS

When editing an individual component, you can add any glyph from any font
installed on your computer, add a string of text, include a graphic (SVG format is
recommended, to ensure optimal appearance when printed or exported to a
graphics format), or even use one of the existing symbols used elsewhere in

Dorico, in any combination.

The relative positioning of each sub-component you add in this dialog is
determined by the Attachment from and Attachment to menus below the large
editor: for example, if you attach the bottom right-hand corner of one sub-
component to the top left-hand corner of the next, then X offset and Y offset of
zero will result in the bottom right-hand corner of the first attachment touching the

Page 6 Steinberg Media Technologies GmbH



Dorico Version History

@ steinberg

top left-hand corner of the second. When using text or glyphs, it is recommended
to attach the Baseline Right attachment of the left-hand component to the
Baseline Left attachment of the right-hand component to ensure sensible default
positioning.

Resetting the appearance of edited chord symbols. To reset a chord symbol you
have edited in Engrave mode back to its default appearance as specified by the
current settings in Engraving Options, select the chord symbol and choose Edit »
Reset Appearance.

Showing chord symbols above the top staff. By default, chord symbols appear
above the staves belonging to the players whose instruments are set to show
chord symbols, which you can determine by right-clicking on a player’s card in the
Players panel in Setup mode and choosing the desired option from the Chord
Symbols submenu in the context menu. In some types of scores, however, such as
piano-vocal pieces, it is instead desirable to show chord symbols above the top
staff, whatever it happens to be on each system (because e.g. the vocal line may
be hidden during an intro or instrumental break). To allow this, a new option has
been added to the Staves and Systems page of Layout Options that allows you
to choose between showing chord symbols Above specific players’ staves (the
default) or Above top staff of system.

Transposing chord symbols. Write » Transpose includes a new option, Keep
chord symbol appearance overrides, switched off by default. A chord symbol
with an overridden appearance cannot be transposed, so you can choose either to
retain the overridden appearance, or you can choose to reset its appearance so
that it can be correctly transposed.

Successive identical chord symbols with altered bass notes. When Dorico hides
the part of the chord symbol before the altered bass note for a series of chord
symbols that differ only by their altered bass notes, it now takes notice of whether a
chord symbol is hidden, so a hidden chord symbol within the range for which only
the altered bass note should be shown will be ignored. It is also now possible to
set the Hide root and quality property independently for chord symbols on
different staves.

Signposts for chord symbols. If the chord symbol visibility settings for the players in
the layout are set such that chord symbols do not appear on any staff, signposts
are now shown above the top staff.

Selecting chord symbols. In common with other system-attached items, chord
symbols are no longer selected when clicking or Shift+clicking in the staff. Chord
symbols can be selected via marquee selection or via Edit » Select All (and can be
filtered in or out of the selection as usual).
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Dynamics
The special bold italic letters for immediate dynamics, combined dynamics, and
dynamics of force all now use a new dedicated font style, Dynamic music text
font, in new projects, allowing you to change the font used for dynamics

independently of the main music font.

Example projects
Several example projects are now included with Dorico. When you run the
application for the first time, the example projects will appear in the list of recent
projects in the Steinberg Hub window. If you would like to open any of the example

projects but they do not appear in the list of recent projects, you can find them
here:

= Windows: C:\Users\Public\Documents\Dorico Example Projects
= Mac: /Users/Shared/Dorico Example Projects

Flows

Importing flows from MIDI and MusicXML files. When importing flows from MIDI
and MusicXML files that do not specify a title, the title of the new flow will be based
on the filename of the imported file, rather than the default “Flow 1".

Navigating between flows. Selecting a flow in the Flows panel in Setup mode now
navigates to the first bar of that flow.

Importing MIDI files
= Tempo events are now imported when importing MIDI files.
= When mapping a track in a MIDI file onto a transposing instrument, Dorico now

prefers the most common transposition for that instrument (e.g. Clarinet in Bb
rather than Clarinet in A).

Pedal lines
A new option Case for full text at start and end of line has been added to the
Una Corda Pedal group of the Design section of the Pedal Lines page of
Engraving Options, allowing you to choose between using title case, sentence
case, or lower case for the una corda and tre corde text at the start and end of an

una corda pedal line.

Playback

Marcato articulations. It is now possible to edit the default playback duration of
marcato articulations on the Timings page of Play » Playback Options.
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Gradual tempo changes. It is now possible to set the Final tempo % property for
gradual tempo changes, allowing you to specify the amount by which the tempo
should change.

Repeat endings

Showing repeat endings below the bottom staff of the system. To show repeat
endings below the bottom staff of the system in addition to showing them above
the top staff of the system and the other staves specified on the Staves and
Systems page of Layout Options, switch on the new option Additionally show
repeat endings below bottom staff.

Setting times played for the final segment. It is now possible for the final segment
of a repeat ending to not be the final one played: for example, if the first segment
should be played on the first and third times through, with a jump to another part of
the score at the end of the third time, and the second segment should be played
only on the second time through, you can now show 1.3. in the first segment and 2.

in the second segment.

Tempo

It is now possible to type a tempo range into the Shift+T popover, e.g. q=100-
120, and Dorico will automatically display the tempo range correctly.

Vertical spacing

A new option Justify staves when frame with single system is above this
threshold has been added to the Vertical Justification group on the Vertical
Spacing page of Layout Options.

If you have a score that only has one system per page on most systems (e.g. an
orchestral score), then it is desirable to justify the distances between staves within
the system as there won't ever be any space between systems. However, if you
have a score that mostly has more than one system per page but occasionally has
only one (e.g. a small chamber group), then it can look strange if the distances
between staves are justified on some pages but not others, simply because the
page happens to cross the threshold specified for Justify distance between
staves and systems when page is at least n% full.

If you are working on such a score that sometimes shows one and sometimes
shows two systems per page, try switching off the new Justify staves when frame
with single system is above this threshold option as you may find this produces
a more consistent justification throughout the project.
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ID # Component Issue
STEAM-6465 Audlio export  The choice between exporting in WAV or MP3 format has been reinstated.
STEAM-6619 Audio export  Only those flows selected for export in the Audio Export dialog will now be exported.
STEAM-6455 Brackets and ~ When using the Wind band bracketing approach, system objects now once again appear
braces only above the first bracket for a given family.
Chord Chord symbols are no longer incorrectly transposed by edits made in Write » Add Notes
STEAM-6407
symbols Above or Below.
Chord Polychords with stacked alterations on both the upper and lower chord now show the
STEAM-6425 .
symbols correct stack of alterations on both chords.
Chord symbols now correctly appear selected after creation via the popover, and after
STEAM-6434 Chord . . . . . .
operations like moving a multiple selection. Other instances of the same chord symbol on
STEAM-6507 symbols ] o ]
other staves are also now drawn in blue to indicate that they are linked.
Chord Chord symbols are now correctly auditioned when selected, provided the chord track is
STEAM-6459 ) X
symbols routed to an appropriate output in Play mode (Mac only).
. The behavior of dragging dynamics to grace note positions in Write mode has been
STEAM-6262 Dynamics )
improved.
. Dragging the start handle of a hairpin in Write mode now correctly adjusts the duration of
STEAM-6408 Dynamics - . o
the hairpin, rather than moving the entire item.
. When pasting dynamics at the same rhythmic position as dynamics on another staff, they
STEAM-6409 Dynamics : . ) . . .
will now only be linked if their properties are equivalent.
. Setting the aperture of a hairpin to 0 could under rare circumstances cause a crash. This
STEAM-6435 Dynamics
problem has now been resolved.
. It is now possible to create a hairpin by clicking and dragging it when it starts at the same
STEAM-6438 Dynamics . o . .
position as an existing immediate dynamic.
Pasting part of a dynamic group no longer incorrectly offsets the position of subsequent
STEAM-6487 Dynamics g P . y group g y P q
dynamics in other groups.
. Adjusting the prefix or suffix of an immediate dynamic now updates the rhythmic spacing
STEAM-6569 Dynamics . .
immediately.
STEAM-6663 Dynamics Cutting part of a dynamic group to the clipboard no longer pastes in the wrong position.
STEAM-6685 Engrave If a ste.zm is dragged to the opposite side of the note in Engrave mode, when you stop
mode dragging, the handle now draws at the end of the stem.
Using Split Flow or Duplicate Flow in a project with one or more empty-handed players
STEAM-6530 Flows (i.e. players with no instruments assigned) will no longer cause the project to be corrupted
and unable to be reopened.
Multiple flows with the same name can now be exported correctly via the Export Flows
STEAM-6628 Flows

dialog.

Dorico Version History
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ID # Component Issue
STEAM-6652 Flows Split Flow now works correctly for music that includes notes crossed to different staves.
Exporting flows is now more resilient to invalid characters in the names of flows and layouts
STEAM-6662 Flows ] i
in the project.
Dynamics of force (e.g. sffz) are now correctly imported when importing a flow from
STEAM-6682 Flows . .
another Dorico project.
STEAM-6512 Instrument Under rare circumstances, the letter case of instrument change labels could change
changes unpredictably when opening the project. This problem has now been resolved.
Key . i i )
STEAM-5938 . Tonality systems saved as defaults for new projects now work correctly in new projects.
signatures
Key . . . . .
STEAM-6448 ) Edits made in the Edit Tonality Systems dialog are now properly undoable.
signatures
STEAM-6453 Key Signposts for Eey signatures ?n trans.posing inst.ruments that .don’t show key signatures
signatures now correctly include the accidental in the key signature root if necessary.
Key Key signatures in user-defined tonality systems that do not use any accidentals now show
STEAM-6629 ) i
signatures a signpost that reads Custom.
o The names of accidentals in the Interval Calculator in Write » Transpose are now
STEAM-6446 Localization
correctly translated.
r A number of inconsistencies between the default key commands in the localized versions
STEAM-6462 Localization )
of Dorico have been resolved.
Multi-bar . . - e
STEAM-6440 ; Multi-bar rests are once again correctly split in layouts with instrument changes.
rests
Multi-bar Multi-bar rests at the end of the system will no longer cause grace notes at the start of the
STEAM-6480 .
rests next system to be drawn incorrectly.
STEAM-6486 Multi-bar System objects (such as tempo and rehearsal marks) no longer have a different horizontal
rests position relative to the start of the bar when coinciding with the start of a multi-bar rest.
MusicXML Dorico will no longer crash when attempting to import a MusicXML file with an incorrectly
STEAM-6443 i . . .
import positioned time signature.
MusicXML Dorico can now correctly open MusicXML files (and files of other types) whose extensions
STEAM-6659 ) )
import are not in lower case.
MusicXML Chord symbols in MusicXML files whose position is specified using the offset element are
STEAM-6675 ) . N
import now imported at the correct positions.
Note )
STEAM-6488 . A syncopated pattern of short-n x long-short notes can now span an entire bar of 12/8.
grouping
STEAM-5102 Note input The behavior of deleting bars when tuplets cross barlines has been improved.
STEAM-6431 When inputting using a MIDI keyboard and the option to allow Dorico to retrospectively
Note input change the spelling of notes is set, the produced spellings have been improved in a
STEAM-6432

number of situations.

Dorico Version History
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ID # Component Issue
Certain edits, such as pasting or changing voice, that involved setting two or more
STEAM-6437 Note input properties on a note would not always cause the display of the score to be updated
correctly until another edit was made. This problem has now been resolved.
Copying and pasting ornaments and playing techniques from one project to another now
STEAM-6495  Note input Pying anc pasting paying feennid one prel
always ensures that the pasted ornaments and playing techniques appear correctly.
. When starting a new voice, the choice of octave now always uses the clef's hot spot to
STEAM-6525 Note input ) . . .
determine the octave of the new note, rather than the octave of the previously active voice.
. Note spacing adjustments made in Engrave mode on columns that do not contain notes,
STEAM-6496 Note spacing e )
e.g. for a hairpin that does not start at the start of a note, are now applied correctly.
Rhythm dots on stem-down split stem cluster chords no longer sometimes collide with the
STEAM-6454 Notes
noteheads.
When multiple rhythm dots have to be shifted vertically in multi-voice situations, dots are
STEAM-6587 Notes ) ) . . . . - .
no longer shifted if they can stay in their default position without colliding with another dot.
Clicking Save as Default in the Notation Options and Layout Options dialogs now
STEAM-6447 Options correctly updates the respective options for newly-created flows and layouts in the current
project, as well as new projects.
Lock System and Lock Frame now work correctly once again when invoked with a
STEAM-6151 Page layout . . .
selection of a single item.
. Different types of pedal lines (e.g. sustain and una corda) at the same rhythmic positions
STEAM-6414 Pedal lines )
are now spaced independently.
. Pedal lines now draw correctly when one staff of a grand staff instrument is hidden
STEAM-6617 Pedal lines o
because it is empty.
Projects containing many chord symbols should both open more quickly and respond to
Performance certain large edits (such as changing Layout Options or Engraving Options) more
quickly.
STEAM-6456 Performance Edit » Select All is no longer very slow when View » Attachment Lines is switched on.
STEAM-6464 Performance  The speed of opening projects has been improved.
A note selected in Write mode is now immediately editable when switching to Play mode,
STEAM-6415 Play mode . . .
rather than requiring you to first reselect it.
The chord symbol track and playing technique lanes no longer disappear when expandin
STEAM-6436  Play mode Y and praying feehniq ger disapp panding
and collapsing tracks in Play mode.
Adding an accent to a note played pizzicato will no longer cause that note to be played
STEAM-6444 Playback
back arco.
Successive grace notes of the same pitch now play back correctly, without cutting each
STEAM-6457 Playback
other off.
Using undo after changing the settings in Playback Options no longer sometimes causes
STEAM-6458 Playback

a crash.

Dorico Version History
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ID # Component Issue
Some of the GM patches in HALion Sonic SE 2 were set to use the wrong VST
STEAM-6463 Playback ) .
Expression Map by default and would not play back. This problem has been resolved.
STEAM-6586 Plavback Relative and gradual tempo changes now correctly take into account the beat unit of the
aybac
STEAM-6645 4 prevailing tempo.
Instruments that use note velocity for dynamics now correctly respond to changes to the
STEAM-6604 Playback . ) . .
Dynamic curve setting on the Dynamics page of Playback Options.
Repeat Dorico no longer crashes when you create a repeat ending that crosses one or more
STEAM-6450 . )
endings instrument changes.
Repeat The last segment of a repeat ending line with the Open, short appearance now correctly
STEAM-6489 . o )
endings obeys the end X offset specified in Properties.
R t It is now possible to set properties on segments of repeat ending lines that span
STEAM-6676 ' oo _ P Prop 9 P 9 P
endings instrument changes.
Double whole note (breve) rests are now correctly positioned relative to a single-line
STEAM-6365 Rests i
percussion staff.
Setting the Hide time signature property now applies to all layouts. This will not affect
STEAM-6485 Time existing projects in which the property is already set: select the time signature and use Edit
signatures > Reset Appearance to unset the property, and then set it again to make it take effect in
all layouts.
Choosing the light weight for tuplet numbers on the Tuplets page of Engraving Options
STEAM-6473 Tuplets g 9 g P P pag g avp
once again produces the expected numbers, rather than apparently random characters.
. Under some circumstances, opening a project that was saved using one of the zoom levels
STEAM-5825 User interface i . o ) ) )
that fits the page width or height in the viewport could crash. This has now been fixed.
STEAM-6442 User interface  Clicking outside a popover now correctly dismisses the popover once more.
’ The Save as Default button in Layout Options is now correctly enabled only when the
STEAM-6523 User interface ) . .
right kind of layout is selected, and only one such layout is selected.
The page margin controls no longer incorrectly disappear when returning to the Page
STEAM-6536 User interface Pag 9 9 d . PP . 9 N
Setup page from another page of the Layout Options dialog.
) Under some circumstances, closing a document window via the close button in the title
STEAM-6625 User interface . )
bar when a popover is open could cause a crash. This problem has been resolved.
Vertical The distances between systems no longer change unexpectedly for systems that contain
STEAM-6502 . .
spacing staves with instrument changes.
Vertical A problem whereby systems could be unevenly justified, causing them to end up too close
ertica
STEAM-6513 i to the system above or below, has been resolved. The appearance of projects affected by
spacing

this problem will be changed when opening them in Dorico 1.1.10.

Dorico Version History
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New features

Dorico Version History

June 2017

This version contains the following improvements and issue resolutions.

Chord symbols

Creating chord symbols. To create a chord symbol, select the note or rest where
you want the first chord symbol to appear, and choose Write » Create Chord

Symbol, or use the key command Shift+Q, or click the button in the right-
hand toolbox in Write mode.

The chord symbol popover will appear, into which you can type the desired chord
symbol using the computer keyboard, or play it using your MIDI keyboard.

Inputting chord symbols using the computer keyboard. Chord symbols consist of a
root, quality, optional interval, optional alterations, and optional altered bass note.

Each of these elements can be entered in the popover as follows:

* Root: English note names (e.g. C, Db, F#, B); German note names (e.g. C, Des,
Fis, H); fixed-do solfége (e.g. do, reb, so#, ti); Nashville numbers representing
scale degrees (e.g. assuming C major, 1, 2b, 4#, 7).

= Quality: major can be specified by typing nothing following the root, or by
typing maj, M, or ma; minor can be typed as m, min, or mi; diminished can be
typed as dim, di, or 0; augmented can be typed as aug, au, ag, or +; half-
diminished can be typed as half-dim, halfdim, or hd; 6/9 can be typed as 6/9,
69, or %.

= Interval: chords with extensions and major seventh can be typed as e.g. A7,
A9, etc. (M on its own is interpreted as major seventh). You can also type e.g.
maj9 or 9maj7 for chords with extensions beyond the major seventh.

= Alterations: alterations can be typed as e.g. #5, b9, etc.; added notes can be
typed as e.g. add#11 or addF#; suspensions can be typed as e.g. sus4;
omissions can be typed as omit3, no7, etc.

= Altered bass notes: these can be specified in the same way as root notes,
separated from the preceding main chord symbol by typing /, e.g. Cm7b5/Eb.

The specific shorthand you use in the popover to create the chord symbol does not
directly influence the precise appearance of the resulting chord symbol: this is
determined instead by the prevailing options set on the Chord Symbols page of
Engraving Options. For example, you could choose to enter a C major chord as
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either “C” or “Cmaj” or “CM”, but in each case the appearance of the resulting
chord symbol will be the same, as specified in Engraving Options.

Dorico can handle polychords, where a single chord symbol describes two
simultaneous chords: in the popover, simply separate the two chords using the
pipe character |. For example, type D|C7 for a D major chord over a C7 chord.

To input a “no chord” symbol, type N.C., NC, no chord, or none into the popover.
For a chord symbol that consists only of the root note, type e.g. Cbass or Gonly
into the popover.

Inputting chord symbols using your MIDI keyboard. When the chord symbol
popover is open, you can play a chord on your MIDI keyboard to input a chord
symbol. Options for how Dorico interprets the notes you play on your keyboard are
found on the Chord Symbols page of Write » Note Input Options, and include
choices over things like whether Dorico should consider the inversion in which you
play a given chord, or should always write the chord symbol as if it had been
played in root position; whether Dorico should notate omissions (e.g. if you play C
and E, should it be notated as C or C(omit5)); how it should notate added notes
and suspensions; how it should handle complex enharmonic relationships between
root and altered bass notes; and so on. You should examine these options carefully
as the default settings will not suit every user.

To input a chord symbol with an altered bass note, simply play the chord with the
altered bass note at the bottom. Alternatively, you can play the chord and its
altered bass note separately: hold down the keys for the chord, then while the keys
are depressed, play the altered bass note.

To tell Dorico the root of the chord to be input, either first play the root with one
finger and then play the remaining notes of the chord while holding down the root,
or play all the notes of the chord together, hold them down, then release and replay
the root note.

To input a polychord, play one chord with one hand, then while those keys are

depressed, play the second chord with the other hand.

To input a chord symbol that consists only of the root note, simply play only a
single note.

Navigation during chord symbol input. When the chord symbol popover is open,
hitting Space will advance the popover to the next beat. You can also move the
popover using the following key commands:

= Ctrl+left/right arrow (Windows) or Command-left/right arrow (Mac):
previous/next chord symbol.
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= Tab: start of next bar.

= Shift+Tab: start of previous bar.

= Space: next beat.

= Shift+Space: previous beat.

= Left/right arrow: previous/next note/rest or rhythmic grid position, whichever is
closer.

= Backspace: previous chord symbol.

When inputting chord symbols using a MIDI keyboard, by default the popover
advances automatically to the next beat after you play a chord. You can change this
behaviour using the Advance during chord symbol input via MIDI input option
on the MIDI Input page of Note Input Options.

Furthermore, you can define specific keys or buttons on your MIDI keyboard to
trigger different navigation behaviours, by using the MIDI Learn button on the Key
Commands page of Preferences to assign specific keys to the Note Input »
Advance Chord Symbol Input commands.

Editing an existing chord symbol. To edit an existing chord symbol, simply select it
and hit Return or double-click it in Write mode: the popover will open, with the
shorthand for the chord symbol ready to be edited. You can either edit the existing
chord symbol by editing the shorthand, clear the popover and type an entirely new
chord symbol, or play a new chord symbol on your MIDI keyboard.

Transposition of chord symbols. One or more selected chord symbols can be
transposed using Write » Transpose. Chord symbols also appear at the
appropriate transposed pitch when shown on transposing instruments and Edit »
Transposed Pitch is chosen.

Changing the enharmonic spelling of chord symbols. To respell a chord symbol for
a transposing instrument in a transposing layout, simply edit the chord symbol as
normal: if you change, for example, the root of Dbmaj13 from Db to C# without
changing the quality, interval or alterations, the spelling of the chord symbol will be
altered for all instruments with the same transposition.

To remove an enharmonic spelling override for a chord symbol on the current
instrument, edit the chord symbol as usual and type Alt+S into the chord symbol
popover; to remove all enharmonic spelling overrides for a chord symbol, type
Shift+Alt+S into the popover.

Choosing above which staves chord symbols appear. By default, chord symbols
appear above the staves belonging to rhythm section instruments (e.g. keyboards,
guitars, bass guitars, etc.), but you can control this from the Players panel in Setup
mode. Select a player, then right-click to access the Chord Symbols context
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menu, and choose Show For All Instruments, Show For Rhythm Section
Instruments, or Hide For All Instruments.

Chord symbols may optionally be shown between the two staves of grand staff
instruments, such as piano, by setting the Position of chord symbols on grand
staff instruments option in the Position group on the Chord Symbols page of
Engraving Options.

Choosing in which layouts chord symbols appear. By default, chord symbols
appear both in full score and part layouts. To change this, switch to Setup mode,
select the player in question in the Players panel, right-click to access the Chord
Symbols context menu, and choose Show in Full Score and Parts, Show in Full
Score Only, or Show in Parts Only.

Hiding individual chord symbols. To hide an individual chord symbol in the current
layout, select the chord symbol and set the Hidden property in the Chord
Symbols group in the Properties panel. A signpost is shown in place of the chord
symbol. If you do not want to see these signposts, switch off View » Signposts »
Chord Symbols.

Positioning chord symbols. Chord symbols are centered horizontally on the middle
of the front notehead in the first voice column at the rhythmic position to which they
are attached. You can instead choose to left-align chord symbols with the left-hand
side of the front notehead in the first voice column (or even right-align them, though
this typically produces unclear results) by setting Horizontal alignment of chord
symbols on the Chord Symbols page of Engraving Options. This can also be
overridden for an individual selected chord symbol using the Horizontal alignment
property in the Chord Symbols group of the Properties panel.

Chord symbols are aligned at the same vertical position across the width of the
system by default, but you can switch off Align chord symbols across width of
system on the Chord Symbols page of Engraving Options if you prefer each
chord symbol to be positioned above the staff independently.

Moving chord symbols. In Write mode, dragging a chord symbol or moving it with
Alt+left/right will attach it to a new rhythmic position; be aware that moving a chord
symbol to the same position as an existing chord symbol will delete the existing

chord symbol at that position.

In Engrave mode, dragging a chord symbol or nudging it with Alt+arrow keys will
not change the rhythmic position to which the chord symbol is attached.

Chord symbol appearance presets. Because there are many conventions for the
appearance of chord symbols, Dorico provides a choice of different preset
conventions that you can use as-is or as the basis of your own preferred
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appearance. The presets are found at the top of the Chord Symbols page of
Engraving Options, and are as follows:

Boston

Bbmaj7(s)/F (%)
J Brandt- Roe:ir/F‘

BbAL/F Bbm () ¥

Indiana
Japanese

:.:11 b7An11

g

Jazz Standard z %“
BbMaj7:s/F Bbmaj71d'

K

Ross

A further preset, simply called Default, is also provided, which uses a set of
symbols intended to be as unambiguous as possible, avoiding the use of symbols
for major seventh, augmented, diminished, and half-diminished, using standard
accidentals, and so on. This is the preset that is chosen by default in new projects.

The presets simply choose specific combinations of the options on the Chord
Symbols page, and you can further adjust these options to suit your preferences.

Changing the font used for chord symbols. To change the text font used for chord
symbols, choose Engrave » Font Styles, and edit Chord symbols font. It is not
advised to edit the Chord symbols music text font, which is set to Bravura Text
by default; this can only be set to a SMuFL-compliant font intended for use in text-
based applications. When using the option to show the word on instead of a slash
or line to separate a chord from its altered bass note, you can edit the font used for
that word by editing the Chord symbols altered bass separator font.

Playback of chord symbols. To include chord symbols in playback, go to Play
mode and expand the chord track at the top of the event display. Choose the
playback device (VST instrument or MIDI device) that should be used, and switch
on the speaker icon to enable playback. Chord symbols are played back as

sustained chords, the duration being taken from the gap between one chord

Page 18 Steinberg Media Technologies GmbH



Dorico Version History

@ steinberg

symbol and the next. If the chord symbol was input using a MIDI keyboard, the

chord will play back using the voicing that was used to input the chord symbol.

MusicXML import. Chord symbols are imported from MusicXML files, but chords
that specify Neapolitan, Italian, French, German, Pedal, Tristan and Other
values for the kind element are ignored during import, as there is no information to

specify what notes these chord symbols are meant to describe.

Enharmonic spelling during MIDI step input

Enharmonic spelling refers to the choice of note name and accidental to describe a
note of a given pitch, normally according to the current key center or tonality — for
example, whether a note should be spelled as F# or Gb. When inputting notes from
a MIDI keyboard, there is no way to directly specify the desired spelling, so Dorico

works out the optimal spelling using a sophisticated algorithm.

The algorithm takes into consideration the current key signature, the intervals
between the next and previous notes or chords, and the intervals between the
notes of chords. If you choose to respell a note (using Write » Respell » Respell
Using Note Name Above/Below), Dorico will also take that choice into
consideration, and will use that spelling for further notes of that pitch.

Broadly speaking, Dorico will prefer to notate notes outside the key signature using
sharps if the figure is rising, and using flats if the figure is falling. When determining
the spelling of a note, if one spelling will produce a simpler interval (for example, a

major third rather than a diminished fourth), it will overall prefer the simpler interval.

When inputting onto a grand staff instrument such as piano, Dorico will also use
the context provided by any music already entered on the other staff: by way of
example, Dorico will normally prefer Bb over A, but if this note is input into the
right-hand staff of a piano, and the left-hand staff includes an F# at that rhythmic
position, Dorico will spell the note on the right-hand staff as A since this produces

a simpler interval between the notes in the two staves.

As you input notes using your MIDI keyboard, you may notice that Dorico
automatically respells previous notes or chords as you continue inputting: for
example, if you input, in the key of C major, E followed by G#, Dorico will spell the
second note as G#, but if you then input Gk, Dorico will respell the G# as Ab,
because that spelling makes more sense in the context. If you want to prevent
Dorico from making retrospective changes to notes you have already input, switch
off Allow spelling of notes to be adjusted retrospectively on the MIDI Input
page of Note Input Options.
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Piano pedal lines

Dorico now has the most comprehensive support for piano pedal lines of any
scoring software. You can easily create pedaling for the sustain, una corda and
sostenuto pedals, with support for modern sustain pedaling techniques, including
changing the pedal level over the course of a single pedal instruction.

Creating pedal lines with the mouse. Pedal lines can be created from the
Keyboard section of the Playing Techniques panel in Write mode.

Keyboard

"ﬁb‘ Soﬁ. una corda

The items on the first row create a new pedal line for the sustain, sostenuto or una
corda pedals respectively. Either select the notes to which the pedal line should
apply and click the relevant button, or, with nothing selected, click the relevant
button and then click and drag in the score to create a pedal line and extend it to

the desired duration.

The items on the second row can be used to add retakes and changes of pedal
level (to one-quarter depressed, half-depressed, three-quarters depressed, and
fully depressed, respectively) to an existing pedal line: ensure that nothing is
selected, click the relevant button, then click on the pedal line at the rhythmic

position at which you want the retake or change of pedal level to be created.

Creating pedal lines with the keyboard. You can also create pedal lines using the
Shift+P popover, either based on the range of selected notes, or during step input.

To create a pedal line of a particular duration, first select the notes to which the
pedal line should apply, then type Shift+P and enter ped for the sustain pedal,
sost for the sostenuto pedal, or unacorda for the una corda pedal.

To create a pedal line during step input, position the caret at the rhythmic position
where the line should begin, then type Shift+P and enter the appropriate
shorthand for the desired pedal line. You can then extend the pedal line simply by
advancing the caret with Space. When you want to stop the pedal line, type
Shift+P again and enter * to stop a sustain pedal line, s* to stop a sostenuto pedal
line, or u* to stop an una corda pedal line.

You can also add retakes and changes of pedal level while inputting a pedal line in
step input: when the caret is at the position at which you want it to appear, type
Shift+P and enter N for a retake, 1/4 for a change of level to one-quarter
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depressed, 1/2 for half-depressed, 3/4 for three-quarters depressed, or 1 for fully

depressed.

To edit the start position of a pedal line once it has been created, select the pedal
line and type Alt+left/right to snap the whole line to the previous or next rhythmic
position, or type Shift+Alt+left/right to snap the end of the line to the previous or
next rhythmic position.

Engraving Options. A comprehensive set of options to determine the appearance
and positioning of pedal lines can be found on the new Pedal Lines page of
Engraving Options. This includes options for which symbol should be shown at
the start of each kind of pedal line, what should be shown for continuing lines at
the start of a new system, the height and width of the retake notch, whether
gradual changes of pedal level should be shown using a dashed or solid line, and
many other options besides.

Properties. The appearance of an individual pedal line can also be overridden by
selecting it and adjusting the properties in the new Pedal Lines group in the
Properties panel. Among other things, you can specify whether the start and end of
a pedal line should be positioned before or after grace notes using the Starts
before grace notes and Ends before grace notes properties.

In Engrave mode, you can select each segment of a sustain pedal independently,
and thus set properties independently. Selecting a retake or change of pedal level
in a sustain pedal line will show the Pedal Line Retakes group of properties,
which allows you to specify the pedal depression level before the retake (End level
at retake) and the pedal depression level following the retake (Start level at
retake). If the pedal should not be released altogether between the old and new
levels, change Retake type to Change Level instead of Retake.

Editing pedal lines in Engrave mode. When a pedal line is selected in Engrave
mode, the following handles appear to allow fine graphical editing:

At the start of the pedal line, the leftmost handle can be dragged left and right to
move the start of the line horizontally; and the handle to the left of the start of the
continuation line can be dragged up and down to change the start pedal level.

At a retake, the handle to the left of the retake notch can be dragged up and down
to change the pedal level before the retake, while the handle to the right of the
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retake notch changes the pedal level after the retake; the handle below the center
of the notch can be dragged left and right to move the whole retake horizontally.

At the end of the pedal line, the handle at the tip of the hook can be dragged up
and down to change the hook length; the handle to the right can be dragged up
and down to change the final pedal level; and the handle below the hook can be
dragged left and right to move the end of the line horizontally.

Overriding start and restorative text. For pedal lines that use a text indication rather
than a symbol, as una corda pedal lines do, for example, or as sustain pedal lines
do if you choose to use plain Ped. text rather than the ornate symbol, you can
override the text shown at the start of the pedal line by editing the Text property,
the text shown at the start of the next system by editing the Continuation text
property, and, for una corda pedal lines, the tre corde text shown at the end of the
pedal line by editing the Restorative text property.

Playback. Pedal lines are automatically played back. Sustain pedal lines send MIDI
controller 64 (Sustain), sostenuto pedal lines send MIDI controller 66 (Sostenuto),
and una corda pedal lines send MIDI controller 67 (Soft Pedal). Some VST
instruments (such as Pianoteq and Garritan CFX Concert Grand) support partial
depression of the sustain pedal — consult the manufacturer’'s documentation for

more details.

Options for how Dorico plays pedaling are found on the new Pedal Lines page of
Playback Options. You can control the speed of the initial pedal depression, the
speed of a retake in the middle of a pedal line, and the speed of the final pedal
release, and you can also specify whether the initial depression and the retake
should be played before or after the onset of the notes or chords at that rhythmic
position.

MusicXML import. Sustain pedal lines are imported from MusicXML files.
MusicXML can only describe the sustain pedal, and it cannot describe changes in
pedal depression level.

Repeat endings

Dorico now supports the notation of repeat endings, sometimes known as volta
lines, or as 1st and 2nd endings. Playback of repeat ending lines is not yet
supported, but is planned for a future update.

Creating repeat endings. To create a repeat ending, select the bars that will form
the first ending, then click the button to create a first ending from the Repeat
Endings section of the Repeat Structures panel on the right-hand side in Write
mode. The first ending segment will be created, covering the selected bars, with a

second ending segment created in the bar immediately following the first ending; a
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suitable end repeat barline will be created at the end of the first ending if one is not
already present. To add a repeat to the second ending, select the bars that will
form the second ending, and click the button to add an additional ending from the
Repeat Endings section: the existing second ending segment will become a
closed line, with an end repeat barline created if necessary, and a third ending
segment will be added in the bar following the second ending. This process can be
repeated as often as required.

Changing the number of times played. By default, each segment in the set of
repeat endings is played once, and so will show a single digit corresponding to the
time through the music on which each ending is played. To tell Dorico that an
ending should be played more than once — for example, that the first ending should
be played on the first three times through — set the No. times played property in
the Repeat Endings group in the Properties panel to the number of repetitions to
be played. The number shown under the relevant ending segment will automatically
be updated, following the options defined in Engraving Options. It is not
necessary to set this property on every segment, as Dorico will do its best to
calculate how many times a segment should be played if the property is set
inconsistently (it will prefer to add any unused repetitions to the final closed ending
segment); it will enforce that the total number of times played must be greater than

or equal to the number of segments.

Changing the text shown in a segment. If you need to override the text displayed in
a specific ending segment, you can set the Custom text property in the Repeat
Endings group in the Properties panel.

Engraving Options. Options controlling the design, default position, and display of
number of times played can be found on the new Repeat Endings page of
Engraving Options.

Choosing where repeat endings appear. Repeat endings are system-attached
items and appear above the instruments chosen in the System Objects section of
the Staves and Systems page of Layout Options.

Editing repeat endings in Write mode. Repeat endings can be dragged from bar to
bar in Write mode by selecting any segment and dragging left or right, or using
Alt+left/right arrow. Each segment can be made to include more or fewer bars by
selecting the handle at the start or end of each segment and dragging left or right.

Editing repeat endings in Engrave mode. In Engrave mode, the exact horizontal
position of the hooks at the start and end of each segment of the repeat ending
can be adjusted, the position of each segment relative to the staff, and the length
of the hooks can all be edited both by nudging or dragging the appropriate
handles, or using the properties in the Repeat Endings group.
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MusicXML import and export. Repeat endings are imported from MusicXML files,
with the limitation that the segments in the middle of a set of endings cannot have
an open right-hand end, despite this being technically possible to represent in
MusicXML. Repeat endings are also now included when exporting MusicXML files.

Editing in Write mode

It is now possible to edit the rhythmic position and, where appropriate, the duration
of items in Write mode, and it is also easier to create items with the mouse.

Creating with the mouse. You can now create and set the length of an item in a
single operation with the mouse: with nothing in the score selected, click the item
you want to create (such as an octave line) in the relevant panel, then click on the
staff where you want the item to be created, and keep the mouse button held down

while you drag the item to the desired duration.

Editing with the mouse. Selected items with duration (such as slurs, hairpins, pedal
lines, octave lines, trills, and so on) now show circular handles at their starts and
ends. Dragging the start handle snaps the rhythmic position of the start of the item,
leaving the end position in the same place (i.e. it lengthens and shortens the
duration of the item); dragging the end handle snaps the rhythmic position of the
end of the item, leaving the start position in the same place. To snap the item to a
new rhythmic position without editing its length, drag the main body of the item

rather than either of its handles.

Editing with key commands. You can use the key commands Alt+left/right arrow to
snap the selected item to the previous/next rhythmic position, and for items that
have duration you can shorten or lengthen their duration with the key commands
Shift+Alt+left/right arrow; add Ctrl to snap to or shorten or lengthen by the
current rhythmic grid duration rather than the next logical position.

Editing dynamics. Grouped dynamics can now be edited with the mouse: where a
group begins or ends with a hairpin, a circular handle appears corresponding that
can be dragged to a new rhythmic position; a similar handle also appears at the
point where the type of dynamic changes in a messa di voce hairpin, allowing you
to snap that inflection point to a new rhythmic position. Dragging the dynamic at
the start or end of the group will scale the positions of the other dynamics
proportional to the overall length of the group. Imnmediate or combined dynamics in
the middle of a group of gradual dynamics can also be dragged to new positions,
which will automatically shorten or lengthen the surrounding gradual dynamics

appropriately.

Creating items with the mouse. If you prefer using the mouse for input and editing
to using the keyboard, new options in the Editing group of the General page of
Preferences can make using Dorico more comfortable for you. When Allow
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multiple items to be created with the mouse is set, you can create multiple
items from any of the panels in Write mode without having to reselect the item
each time. Under Creating items with the mouse, you can also choose whether
Dorico should automatically create items at the position of the current selection
(the default), or whether you want it to always load the cursor so that you can click

to place the item.

Attachment lines. To make it clear to which rhythmic positions items are attached,
a dark red dotted line is drawn from the left-hand side of each selected item (and,
for items that have duration, such as slurs, hairpins, octave lines, pedal lines, and
so on, from the right-hand side too) to the middle of the staff at the attachment
position. This can be disabled by switching off View » Attachment Lines.

Editing note spacing

You can now edit the note or rhythmic spacing of your music in Engrave mode. To
enable these spacing adjustments, activate the switch in the Note Spacing section
of the left-hand panel in Engrave mode, and dashed lines representing spacing
columns and handles for each spacing-significant item will appear. When the
columns and handles are visible, you cannot make any selections or edits to items
in the current layout: deactivate the switch on the Note Spacing section or switch

to Write mode to resume normal selection and editing.
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Spacing adjustments and graphical adjustments. You can make two kinds of
adjustments to the horizontal position of notes and chords, grace notes, rests,
clefs, key signatures, time signatures, barlines, and so on: spacing adjustments,
which increase or decrease the amount of rhythmic space to the left and right of
the item, and which affect the whole spacing column (i.e. all items that start at that
rhythmic position across all staves); and graphical adjustments, which move a
selected item on a single staff only, in a way that does not affect the spacing of
other items. To make a spacing adjustment, select a square handle, hold Alt and
use the left and right arrow keys to adjust in small increments, and add Ctrl
(Windows) or Command (Mac) to adjust in larger increments. To make a graphical
adjustment, first select the square handle above the staff, then select the circular
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handle that appears on the middle staff line, and use the same key commands. You
can switch between selecting related square and circular handles by hitting Tab.

When you make a spacing adjustment to a primary rhythmic position, both the
square handle itself and the dashed line representing the spacing column are
colored red.

When you make a graphical adjustment to an item, a horizontal red line is drawn
joining the item’s circular handle to its original position (i.e. the position at which it
is still considered to be for the purposes of spacing).

Adjusting secondary voice columns. When multiple voices are active at the same
rhythmic position, you can adjust the position of each voice column independently.
A square handle appears for each voice column, allowing you to make spacing and
graphical adjustments for the notes in that column independently of the first
column. If you find that you need to make an adjustment to a voice that is currently
sharing a voice column with another voice, you can move it into its own voice
column using the Voice column index property, which will allow spacing and
graphical adjustments independently of other columns.

Navigating between handles. You can navigate between handles using the arrow
keys. Hold Shift to make a multiple selection of handles. Press Tab to switch
between the square handles for adjusting spacing and the circular handles for
adjusting graphical offsets.

Adjusting multiple items at once. Select multiple handles either via marquee
selection or using Shift+arrow keys, and then use the key commands to make
spacing or graphical adjustments to all the selected handles at the same time.

Removing adjustments. To remove a single spacing or graphical adjustment, select
the handle and hit Delete; if the item has both a spacing and graphical adjustment,
both adjustments will be removed. To remove only a graphical adjustment, select
the item in Write mode and choose Edit » Reset Position. To remove spacing
adjustments over a larger region, select one or more handles in the region you want
to remove them, then choose Engrave » Note Spacing » Reset Layout (which
removes all spacing adjustments in the current layout), Reset Selected Frames
(which removes all spacing adjustments in the music frames in which one or more
handles are currently selected), or Reset Selected Systems (which removes all
spacing adjustments in the system or systems in which one or more handles are
currently selected).

Locking the system. When you make any spacing or graphical adjustment to an
item, the system on which you are making the adjustment is locked: Dorico will

create a system break at the start of the adjusted system (if one does not exist
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already) and at the start of the following system. This ensures that making spacing
adjustments does not cause the casting-off of your layout to change.

System fullness indicator. When editing note spacing, a new indicator in the right-
hand page margin shows you at a glance how full each system is, expressed both
as a percentage, and as the number of spaces occupied out of the total number of
available spaces (which is measured from the start of rhythmic space to the right of
the initial clef and signatures to the final systemic barline). When a system is too
empty, the indicator is colored purple; when it is more than 70% full it is colored
green; and when a system is over-full (more than 1000%), it is colored red.

Indenting the system. Two large square handles appear at either end of each
system: on the left-hand side, aligned with the top staff line of the top staff, and at
the right-hand side, aligned with the bottom staff line of the bottom staff. These
handles allow you to indent either end of the system from the frame, using the
same key commands for the other types of handles. Unlike editing the spacing
within a system, indenting either end of the system does not lock the system, so
the casting off can change.

Properties. It is also possible to specify spacing and graphical adjustments for
items outside of the dedicated tool in Engrave mode using the Properties panel.
You can make spacing adjustments for most non-note items using the Spacing
offset property found in that item’s property group, and graphical adjustments
using the Offset X property found in the Common group. For notes, spacing
adjustments are made using the Voice column spacing offset property, and
graphical adjustments are made using the Voice column X offset property, both of
which are found in the new Note Spacing group.

Adjusting the position of a bar rest. Unlike other rests and notes, bar rests do not
show handles, but it is possible to adjust the horizontal position of a bar rest
relative to its bar using the Offset X property in the Common group of the
Properties panel.

Filters

Selection filters are used to narrow down a selection of notes and other items in
your project, based on criteria that you specify. A new Edit » Filter submenu has
been added, containing filters that select or deselect items of different kinds. To
use a filter, first select multiple items — for example, by clicking in a blank part of a
bar to select all notes and other items in that bar, then extending the selection by
holding Shift and clicking in another bar in the same or another staff — then choose
the filter corresponding to the item you want to remain selected, or to the item you

want to remove from the selection.
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Whether a filter will leave only the chosen item selected or will deselect the chosen

item is determined by whether Select Only or Deselect Only is chosen at the top
of the Edit » Filter submenu.

The following filters are available:

Notes and Chords: selects or deselects notes, grace notes, and tuplets
Grace Notes: selects or deselects only grace notes

Rests: selects or deselects explicit rests, explicit bar rests, and implicit rests
Voices submenu: allows you to select or deselect all items belonging to either
All Up-Stem Voices, All Down-stem Voices, or if your selection encompasses
only a single staff, material in any of the numbered voices on the staff.

All Dynamics: selects or deselects immediate (including combined and force)
dynamics and gradual dynamics (including hairpins, messa di voce, cresc./dim.
lines)

Immediate Dynamics: selects or deselects immediate dynamics only
Gradual Dynamics: selects or deselects gradual dynamics only

All Tempos: selects or deselects all immediate, relative and gradual tempos
Immediate Tempos: selects or deselects immediate tempos (e.g. Andante)
only

Relative Tempos: selects or deselects relative tempos (e.g. a tempo) only
Gradual Tempos: selects or deselects gradual tempos (e.g. rit./accel.) only
Arpeggio Signs

Chord Symbols

Clefs

Glissando Lines

Holds and Pauses

Key Signatures

Lyrics

Octave Lines

Ornaments and Trills

Pedal Lines

Playing Techniques

Rehearsal Marks

Slurs

Text: i.e. Shift+X text events

Time Signatures

Tuplets: selects tuplet brackets/numbers (but not the notes within them)

All Breaks: selects or deselects frame and system breaks

Frame Breaks: selects or deselects frame breaks only

System Breaks: selects or deselects system breaks only
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Play mode
Editing played or notated durations. The event display in Play mode now
allows you to display and edit either the played durations or the notated

durations of notes. A new pair of buttons (shown on the right) have been

added to the Play mode toolbox to switch between these two modes.

When viewing played durations, the main body of each note in the piano roll

display represents the played duration, including all intrinsic playback effects (such
as shortening a note due to a staccato articulation, or lengthening it due to a slur),
while the notated duration is shown as a thin line at the bottom of each note event.
When viewing notated durations, this arrangement is reversed: the played duration
is shown as a thin line at the bottom of each note event, whereas the main body of

the note represents the notated duration.

Editing played durations. When editing the start position or duration of notes in the
event display, the event display is now updated in real-time as you edit, rather than
only after you release the mouse. Notes whose playback duration have been edited
show up in a darker color in the piano roll display.

To remove any edits made to the played durations of notes back to their default
start position and length, select the affected notes and choose Play » Reset
Playback Overrides.

Editing notated durations. When editing notated durations, you can move notes
earlier and later in time by selecting them and dragging them left and right, which
snaps them to positions described by the current rhythmic grid value.

Notes can also be dragged up and down to change their pitch (or you can use
Alt+up/down arrow, or Ctrl+Alt+up/down arrow, as you would in Write mode).

You can also change the durations of notes by selecting them and dragging the
right-hand end of any selected note. As with moving notes earlier later in time, note
durations are snapped according to the current rhythmic grid value.

Finally, notes can be cut and pasted in the event display. When pasting, the
destination rhythmic position will be determined by the position of the playhead.

Voices in the event display. All voices for each instrument are now shown in a
single track.

Ruler. The ruler at the top of the event display in Play mode now shows bar and
beat divisions for the prevailing time signature.

Scrolling, zooming and navigating. There have been significant improvements to
the user experience of working with the event display in Play mode:
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= The disclosure state of each track in the event display is now persistent when
switching away from and back to Play mode during a single editing session (it is
not yet persisted when saving and reopening the project, but this is planned).

* You can now scroll and zoom the event display with two-finger gestures if you
have a multi-touch trackpad.

= Horizontal scroll and zoom of the event display is constrained, so that you
cannot scroll off the start or end of the flow, or zoom out such that the flow does
not occupy the whole width of the window.

= When expanding a track in the event display, the piano roll view is now centered
on the range of notes played by that instrument.

= When the pointer is over the vertical piano keyboard display at the left of the
event display for a track, Shift+mouse wheel scrolls the piano roll vertically.

= The thresholds for clicking either end of or the body of a note in the event
display have been adjusted, so it's easier to select the note by clicking on it, and
the mouse pointer updates as it hovers over the parts of a note to show what

will happen when you click there.

Playing technique display. To visualize how Dorico maps playing techniques onto
the various keyswitches and articulations provided by the VST Expression Map in
use for an instrument, when you expand an instrument'’s track in Play mode you will
now see an additional informational lane, which shows which regions will be played
by different switches within the current VST Expression Map. Hover over a region

of the lane for a tool tip containing more detailed information.

Support for MIDI output devices
Dorico can now play back through any connected MIDI output devices. A new
MIDI Instruments section has been added to the right-hand panel in Play mode,
allowing you to add any of your MIDI devices in a similar manner to adding a new
VST instrument. Once a MIDI device has been added, you can choose to route
playback from any instrument in your project to the MIDI device by editing the
settings in the relevant track header on the left-hand side of the event display in

Play mode.

A new MIDI button has been added to the toolbar in the Mixer, allowing you to
show a MIDI fader for each instrument. Each MIDI fader sends MIDI controller 7
(Volume), and the pan slider above the fader sends MIDI controller 10 (Pan). You
cannot solo or mute MIDI faders.
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Flows

Duplicate an existing flow. You can make a copy of a flow in your project — for
example, to revise the music while maintaining the current state as a separate flow
— by selecting the flow in the Flows panel in Setup mode, then choosing Duplicate

Flow from the context menu.

Splitting an existing flow. You can split an existing flow into two by selecting a note
or other item at the point at which you want the flow to be split, and choosing Write
» Split Flow.

Importing flows from another Dorico project. You can now import one or more
flows from another Dorico project into the active project by choosing File » Import
» Flows. You will be prompted to choose the source Dorico project that contains
the flow or flows you want to import. A dialog appears in which you can choose
which flow or flows to import from the source project, and you can also choose
how Dorico should handle assigning the music in the imported flow or flows to
players in the destination project:

= Create All New Players will create a new player in the destination project for
every player assigned to the flow or flows in the source project, and will also
create new part layouts as needed for those players.

= Merge with Existing Players Where Possible will attempt to assign the music
in the imported flows to existing players. It will use an existing player provided it
has the same instruments or a superset of the instruments of the player in the

imported flow.

Importing a flow from a MusicXML file. When a Dorico project is open, choosing
File » Import » MusicXML will import the music from that MusicXML file as a new
flow in the active project. If you want to open the MusicXML file as a new project
instead, choose File » Open and open the MusicXML file that way instead. As
with importing one or more flows from another Dorico project, after you choose the
source MusicXML file to import, a dialog appears in which you can choose how
Dorico should handle assigning the music in the imported file to players in the
destination project.
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Accidentals

It is now possible to make fine adjustments to the horizontal position of an
individual accidental using the new Accidental X offset property, which appears in
the Notes and Rests group of the Properties panel in Engrave mode.

Arpeggio signs

Playback. Arpeggio signs now play back, and options to control this playback are
found in the new Arpeggio Signs group on the Timing page of Playback
Options. You can control whether the arpeggiation should start or end on the beat,
the speed of arpeggiation, and the maximum percentage of the written duration of
the chord that can used to accommodate the arpeggio. The new Arpeggios
Playback group in the Properties panel also allows you to override the default

playback options for an individual arpeggio sign.

Engrave mode. It is now possible to move an arpeggio sign left or right relative to
the chord to which it belongs, either by nudging it with Alt+left/right, dragging it
with the mouse, or adjusting the X offset property in Engrave mode.

Barlines

Two new options have been added to the Barlines page of Engraving Options:

= Barline length for single-line instruments allows you to specify by how many
spaces the barline should extend above and below the single staff line,
assuming it does not join with another staff above or below.

= Barline at end of system coinciding with start repeat allows you to choose
between showing a single or double barline at the end of one system when a

start repeat barline appears at the start of the next.

Beams

Splitting a beamed group. A new Edit » Beaming » Split Beam command has
been added, which splits an existing beam group into separate groups at the
positions of the selected notes. The command formerly called Break Beam is now
called Make Unbeamed, to make clear what it actually does.

Beam slants for concave shapes. New options for determining when beams should
be horizontal, rather than slanting up or down, have been added to the Advanced
Options section within the Slants group on the Beams page of Engraving
Options.
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When determining whether a beamed group of three or more different pitches
should be considered concave (i.e. that the notes in the middle of the beamed
group are closer to the beam than the notes at the ends of the beamed group), you
can now determine whether a group should be considered concave when the inner
note closest to the beam is strictly closer than the notes at the ends of the beamed
group, or whether it can be at the same staff position as the notes at the ends of
the beamed group. By default, inner notes at the same staff position as the notes at
the ends of the beamed group will cause the beam to be horizontal, which was not
the case previously; to restore the previous behavior, set Inner note at same
position as outer note to Do not treat as concave.

By default, for a beamed group to be considered to have a concave shape, the
inner note closest to the beam must be closer than the note at each end of the
beam, i.e. closer (or at the same position as) both outer notes. If you would prefer
the group to be treated as a concave shape if the inner note is closer than only one
of the outer notes, set Inner note closer to the beam than one but not both
outer notes to Treat as concave.

Stem shortening. When note stems point outside the staff, which happens
especially when multiple voices are active, stems are shortened as notes approach
the outer lines and spaces. It is now possible to control the positions on the staff at
which the shortening starts and stops, using the new options below the Stem
Shortening heading in the Stems group on the Notes page of Engraving Options.

In The Art and Practice of Music Engraving, Ted Ross recommends that the stem
length of beamed eighth notes (quavers) should be shortened by a quarter of a
space for a horizontal beam, and by half a space for a slanted beam. Dorico no
longer does this by default in new projects, as it makes the default stem lengths for
beamed eighths shorter in comparison to unbeamed notes, but if you want to
restore this behavior, set Stem shortening for beamed groups to Shorten
beamed stems.

Finally, it is now possible to specify the minimum stem length separately for notes

of different durations: quarter notes (crotchets) and longer; eighth notes (quavers);
and 16th notes (semiquavers) and shorter. The interaction of the desired minimum
stem length, shortening according to staff position, and the snapping of beam lines

to valid sit/straddle/hang positions according to their ideal slants is complex.

Brackets and braces

A new option When only one staff of braced group is shown has been added to
the Design group of the Brackets and Braces page of Engraving Options. When
set to Draw brace, a brace will be drawn spanning a single staff if only one staff of

a grand staff instrument such as a piano is shown on that system; when set to Do
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not draw brace, a brace will only be drawn if both staves of the grand staff

instrument are shown on that system.

Casting off

A new Casting Off section has been added to the Staves and Systems page of
Layout Options, providing options to influence how Dorico casts off your music.
Casting off is the process of determining how many and which bars appear on
each system, and how many systems appear on each page. The new options in
this section are as follows:

= Fixed number of bars per system: fixes the number of bars on the system,
regardless of their width. Multi-bar rests and complete bars with open meter are
counted as a single bar; if a bar with open meter is split across a system break,
each portion either side of the system break is counted as a single bar. Fixing
the number of bars per system is not appropriate for all kinds of music, but it is
often done in music for session recording, as fixing (say) four bars per system
typically allows enough room for annotations, cues, and other material to be
written in by the player in the session.

* Fixed number of systems per frame: fixes the number of systems in each
music frame; since a music frame normally occupies almost the full height of the
page, this option therefore normally determines the number of systems on each
page. Fixing the number of systems per frame is most often done in instrumental
parts, where it is typical for there to be 10 or 11 systems per page.

= Scale number of systems by frame height: allows Dorico to reduce the fixed
number of systems in the frame proportionally with the height of the music
frame. This is useful if you generally want to have, say, 10 systems per page, but
because the first page of your part includes material such as the title, composer,
instrument name, etc., the height available for music is reduced compared to
subsequent pages, and when using this option, Dorico can put eight or nine
systems in this first frame instead.

In addition, the existing option Allow open bars to be split across system
breaks has been moved from the Note Spacing page of Layout Options.

Clefs

French violin clef. The French violin clef (a G clef positioned on the bottom line of
the staff, and where that bottom line represents G4, i.e. the G above middle C) has
been added to the Uncommon Clefs section of the Clefs and Octave Lines

panel.

Coloring clefs. It is now possible to change the color of clef changes using the
Color property in the Common group of the Properties panel.
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Copy and paste

A new Edit » Paste Into Voice submenu has been added, making it possible to
paste a selection consisting of notes and other items all belonging to a single voice
into another voice, either one of the existing voices on the destination staff (in
which case the pasted material will be merged with any existing material in the

existing voice), or a new up-stem or down-stem voice.

Dynamics

Dorico automatically groups abutting dynamics together when you create them,
and grouped dynamics are aligned at the same vertical position below or above the
staff, moving together if a note or other item protruding from the staff requires them
to be moved from their default position to avoid a collision.

When you paste an individual dynamic or a group of dynamics from one staff to
another, at the same rhythmic position, the dynamics are linked between those
staves, which means that if you edit one of the dynamics on one staff, the other
instances of that dynamic on the other staves with which it is linked will

automatically update.

It is now possible to control both how dynamics are grouped and how dynamics
are linked between staves. Select one or more dynamics, and use the appropriate
item from the Edit » Dynamics submenu, which can also be found in the context

menu:

= Group Dynamics: groups the selected dynamics together; if any of the
selected dynamics are already part of a group, then the groups are combined
into a single larger group.

= Ungroup Dynamics: breaks the group of any selected dynamics; the group will
be removed altogether.

= Remove From Group: removes only the selected dynamic or dynamics from
the group, leaving the rest of the group intact.

= Link: links selected dynamics on multiple staves together, provided they are
compatible, i.e. that they are at the same rhythmic position, and they are the
same kind of dynamic (you cannot link, for example, p and f).

= Unlink: unlinks the selected dynamics such that they are no longer linked to
dynamics on other staves. If the selected dynamic is part of a group, the group
itself is unlinked from the other staves, and can then be further edited

independently.

To show which dynamics are grouped and linked, when you select a dynamic, any
other dynamics that are part of the same group or are linked to dynamics on
another staff are drawn in blue, while the selected dynamic is drawn in the normal

orange selection color.
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Engrave mode

When editing frames, it is no longer possible to select any of the items within a

music frame, for consistency with the other special editing tools in Engrave mode.

It is now possible to use marquee selection for each of the special editing tools in
Engrave mode, which makes it easier to select multiple frames, or multiple staff
spacing handles, or multiple note spacing handles.

It is also now possible to navigate between frame handles using the arrow keys
when editing frames in Engrave mode. Press Tab to switch between selecting
either the whole frame, whose outline is now shown using a bolder line when
selected, and selecting individual handles, which are shown as filled in when
selected.

Fonts

The Noto Sans JP font family is now installed along with Dorico, and is used as the
default font family for text in new projects created in the Japanese language version
of Dorico.

A new Default text font family option has been added to the General page of
Preferences, which is set to Academico for all languages except Japanese, for
which it is set to Noto Sans JP. Changing this option will change the font used by
the Default text font font style and the Default text paragraph style, from which all
of the other font, paragraph and character styles in your project inherit the font.

Font styles

Font styles are used to define the appearance of various notations within Dorico:
they are distinct from paragraph and character styles, which are used for text that
you type into text frames or directly into the music using the Shift+X text tool. Font
styles are used for things like lyrics, tempo marks, the text drawn in the middle of a
glissando line, playing techniques, and so on.

For font families that include extended styles or weights (such as condensed, light,
semibold, etc.) can now be chosen in the Engrave » Font Styles dialog, enabling
the use of any weight or style of any font on your computer for items like lyrics.

When opening projects created in earlier versions, Dorico will attempt to map the
bold and italic flags that were used to choose bold, italic, or bold italic styles of the
chosen font onto the most appropriate weight and style of the font. Note that in
previous versions it was possible to choose a weight of a font that was not actually
available, in which case the operating system would have synthesized a font style
(e.g. if a bold weight was not available, choosing the bold option would cause a
bold font to be generated on demand), which often looks poor. If a font style in an
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older project requests a font weight that is not available, that font style will now be
set to use the regular or normal weight of that font instead.

Beware that Windows and macOS approach font naming in very different, and
largely incompatible, ways. On Windows, the list of accessible styles is hardcoded
to regular, italic, bold, and bold italic, which means that fonts with extended styles
instead appear in the font menu as separate fonts — for example, Adobe’s Minion
Pro font has regular and condensed widths, and on Windows these will appear as
separate families, Minion Pro and Minion Pro Cond. On macQOS, by contrast, a
font like Minion Pro will appear as a single font family, with all the extended styles
listed in the Style menu alongside regular, italic, bold, and bold italic. When moving
projects between Windows and macOS computers, be aware that if you use one
of the extended styles of a given font, you may need to edit the font style on the

destination platform to ensure the expected style is used.

Instrument changes

Multi-staff instruments. When a player has a combination of instruments assigned
that includes both single- and multi-staff instruments, the option Allow individual
staves of multi-staff instruments to be hidden (on the Vertical Spacing page of
Layout Options) is now better integrated with hiding empty staves. When one or
more staves of a multi-staff instrument are hidden, Dorico now correctly determines
which staff or staves should be shown based on which staff next has any music
written, to try to reduce the number of redundant changes from one staff to another

on different systems.

Vertical position of labels. A new option Minimum distance above items outside
staff for instrument change labels has been added to the Instrument Changes
page of Engraving Options, controlling the vertical gap that Dorico should leave
when an instrument change label is pushed away from the staff by an item
protruding above the staff.

Key commands
You can now use your MIDI keyboard to trigger commands within Dorico. Ensure
that you have a project open, then open the Preferences dialog and go to the Key
Commands page. For the command to which you want to assign a MIDI trigger,
click MIDI Learn, then play the note or chord or hit the button or pad that you want
to be mapped to this command, and click Add MIDI Command to save the new

trigger. Rotary controls and faders are not currently supported.

Key signatures
Signposts for key signatures. Key signatures that show no accidentals, such as a
key signature of C major or A minor, or a change to such a key in a project in which
cancellation naturals at key changes are not shown, now appear as signposts. To
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hide these signposts, switch off View » Signposts » Key Signatures. Note that
to copy and paste a key signature, or a passage of music including a key signature,
the signpost must be visible and selected to be included in the copy and paste

operations.

Naturals in custom key signatures. Custom key signatures can now include natural

accidentals if needed.

Lyrics
A new option Systems on which verse numbers appear has been added to the
Verse Numbers group on the Lyrics page of Engraving Options, allowing you to
specify whether verse numbers should be shown at the start of each line of lyrics

only on the first system, or on all systems, as sometimes done in hymnals.

MIDI import
Instrument detection. The mapping of tracks in imported MIDI files onto

instruments has now been significantly improved.

Clean lengths. The import of note durations has been significantly improved: notes
that overlap or are separated by a small amount are now notated as abutting, rather
than overlapping or separated by rests of very short durations. The detection and
quantization of tuplet rhythms has also been significantly improved.

MusicXML import
A new MusicXML Import page has been added to the Preferences dialog,
allowing you to choose what information should be retained when opening a
MusicXML file as a new project or when importing it as a new flow into an existing
project.

Now that it is possible for you to choose what information is retained, Dorico now
retains less information by default: explicit rests are not imported, meaning that rest
grouping will use Dorico’s defaults; explicit accidentals are not imported, meaning
that which notes show accidentals will be determined by the prevailing notation
options; forced durations are not imported, meaning that how notes are broken up
into tie chains will be determined by the prevailing notation options; and rest
positioning is not imported, meaning that rests will be vertically positioned relative
to the staff according to the prevailing notation options.

Navigation
A new Edit » Go To submenu has been added, containing some basic commands
for navigating around your project. Go To Bar, with the default key command
Ctrl+G (Windows) or Command-G (Mac), allows you to navigate to a bar within

Dorico Version History Page 38 Steinberg Media Technologies GmbH



Dorico Version History

@ steinberg

one of the flows in your project. Go To Previous Flow and Go To Next Flow
navigate to the start of the previous or next flow.

Note input

The perceived latency of input via MIDI keyboard is now much lower: the notes that
you play on your keyboard are now echoed back to you immediately, rather than
being played back at a fixed length after the note has been input. The echoed note
may be transposed depending on the transposition of the instrument onto whose
staff you are inputting, and the current state of the Write » Input Pitch options.

Note spacing

The option Minimum distance between adjacent rhythmic items on the
Spacing Gaps page of Engraving Options now has a different effect than in

previous versions.

Previously the value specified by this option was almost never used in practice,
because it was applied from the left-hand side of one spacing column and the left-
hand side of the next: because almost all spacing columns contain an item wider
than this minimum (e.g. a notehead), in fact the distance between two items at
adjacent rhythmic positions was a tiny value, around 1/20 of a space. This meant
that, for all intents and purposes, that successive columns could practically touch.
This was particularly noticeable, for example, with tightly-spaced notes on ledger

lines, as the ledger lines would appear to touch.

Now, the value is applied from the right-hand extent of one spacing column to the
left-hand extent of the next, which ensures that successive rhythmic items — such

as tightly-spaced notes on ledger lines — no longer appear to touch.

Options

Dorico’s five options dialogs — Layout Options, Notation Options, Note Input
Options, Engraving Options, and Playback Options — all provide buttons to save
the current set of options as the defaults for new projects.

A suite of improvements in this update allow you to reset back to your saved
defaults if you have made changes in the dialog that you later decide you want to
discard; reset back to the factory defaults (i.e. ignoring your saved defaults); and
remove your saved defaults so that new projects created thereafter will use the
factory defaults.

A new button Reset to Saved Defaults appears in the button bar at the bottom of
each dialog; this button will read Reset to Factory if you have not yet saved any
default settings for that dialog. If you have saved user defaults but want to reset to
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the factory defaults instead, you can hold Ctrl (Windows) or Command (Mac) and
click the button (which will instead say Reset to Factory while the Ctrl/Command
key is held down).

To remove saved defaults, if saved user defaults are found, holding Ctrl/Command
will cause the Save as Default button to read Remove Saved Defaults instead,
and clicking that button will delete the saved user defaults.

Ornaments

The naming of the default ornaments shown in the Baroque and Classical section
of the Ornaments panel has been corrected. av, which was previously named
“mordent”, is now named “short trill"; av, which was previously named “inverted

mordent”, is now named “mordent”.

The ornaments shown in Clavier-Biichlein vor Wilhelm Friedemann Bach by J.S.
Bach have also been added to the Baroque and Classical section of the
Ornaments panel, together with the Haydn ornament, the long schleifer ornament,

and a few of the more common ornaments used by Couperin.

Page layout

Copying frames between pages. When editing a pair of master pages, you can
now copy the layout from the left-hand page to the right-hand page or vice versa
by clicking the appropriate L->R or R<-L button in the toolbar at the top of the
master page editor.

Furthermore, you can also copy any selected frame or frames to other pages in

your layout as follows:

= Enable the frame editing tool by clicking the switch at the top of the Frames
section of the left-hand panel in Engrave mode.

= Select the frame or frames you want to copy to another page.

= Select the page or pages to which you want the selected frames to be copied in
the Pages panel on the right-hand side. Select multiple pages using Ctrl+click.

= Right-click in the Pages panel to show the context menu, and choose Copy
Selected Frames to Selected Pages.

Moving page overrides. It is now possible to move multiple selected overridden
pages in the Pages panel in Engrave mode and move them earlier or later, which
swaps the selected range of overridden pages with the pages immediately to their
left or right. To move a range of pages by a larger distance, right-click the Pages
panel and choose Move Pages from the context menu to open a simple dialog
from which you can choose the page before or after which the selection of pages
should be moved to.
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Disabling automatic adjustment of staff spacing. If you would prefer Dorico never
to adjust the distances between staves and systems from the ideal values specified
in Layout Options, switch off the new Automatically resolve collisions between
adjacent staves and systems option in the Minimum Gaps section of the
Vertical Spacing page.

Improved vertical justification. When justifying the gaps between systems, Dorico
now considers whether the distance between successive systems is already larger
than the ideal distance specified on the Vertical Spacing page of Layout Options,
and if so, it prefers to add the remaining unjustified space between systems that

currently have smaller gaps, to produce an overall more even result.

Playback

Score following during playback. Dorico now automatically moves the music to
keep the playhead in view during playback in Setup, Write and Engrave modes.

VST 2.x plug-ins. The process of whitelisting VST 2.x plug-ins so that they can be
used with Dorico has been simplified. Firstly, in addition to the default
vst2whitelist.txt file that is included with your Dorico installation, listing those VST
2.x plug-ins that Steinberg have qualified for use with Dorico, a second
vst2whitelist.txt file can now be loaded from a user-specific location that will not
be overwritten if you subsequently update or reinstall Dorico. When Dorico starts
up, it reads both the default whitelist file and your user-specific whitelist file to build

up the list of whitelisted plug-ins.

If you want to whitelist any VST 2.x plug-ins that are not included on the default

whitelist, you should place your own vst2whitelist.txt file here:

»  Win: C:\Users\username\AppData\Roaming\Steinberg\VSTAudioEngine_64
* Mac: /Users/username/Library/Preferences/VSTAudioEngine

Secondly, the vst2whitelist.txt file now need contain only the filename of the VST
plug-in to be whitelisted, minus its file extension (.dIl on Windows and .vst on
Mac), with the name of each plug-in on its own line in the text file.

Dynamics playback. Playback sounds in the HALion Sonic SE library provided with
Dorico that use VST Note Expression for dynamics (including saxophone, choir,
and others) now use MIDI controller 11 (Expression) by default, which allows them
to play dynamics until Dorico supports VST Note Expression, which is planned for

a future update.
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Playing techniques

Creating playing techniques. It is now possible to input a playing technique either
via the Shift+P popover or the Playing Techniques panel while the caret is visible:
the chosen playing technique will appear immediately after it is input, rather than

only appearing once a note or chord has been input at that rhythmic position.

Additional playing techniques. Some new playing techniques are available in new
projects, including m.d./m.s. (mano destra/mano sinistra) in the Keyboard section,
text versions of the common mutes in the Brass section, con bocca chiusa in the

Vocal section, and air/Aeolian/key clicks in the Wind section.

Rests

It is now possible to nudge a selected rest up or down by a small amount using the
Offset Y property in the Common group of Properties, which appears only in
Engrave mode. For dotted rests, only the main rest shape will be affected by the
offset, so the rhythm dot or dots will remain in the space in which they are currently
positioned. If you need to move a rest by one or more whole spaces, use the Rest
pos. property in the Notes and Rests group instead: when using this property,
rhythm dots will snap to the space closest to the rest.

Selections

Where two or more items overlap, or are superimposed, it is now possible to select
each item in turn by hold Alt+Shift and clicking.

Slurs

= A new Tied Notes group has been added to the Slurs page of Engraving
Options, with options to determine whether slurs should start or end on the first
or last note in the tie chain. These options can also be overridden for an
individual slur by setting the Start pos. on tie chain or End pos. on tie chain
properties as appropriate.

= A new option Slurs starting on the last note or ending on the first note of a
beamed group has been added to the Endpoint Positioning group of the
Slurs page of Engraving Options, allowing you to specify whether slur
endpoints should be positioned as if the notes are unbeamed (in which case the
slur endpoint will be positioned closer to the notehead) or as if they are beamed
(in which case it will be positioned closer to the stem tip).

*= When adjusting the position of either end of a slur in Engrave mode with the
mouse, you can hold Alt to rotate the slur instead of moving only the selected
endpoint, which maintains the slur's shape.

= The calculation used for Maximum angle for slurs is now relative to a

horizontal slur, rather than relative to the angle between the first and last note
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under the slur. A new option Maximum angle for cross-staff slurs has also
been added, set to a larger angle by default.

Staff labels
A new option Minimum indent for systems with staff labels has been added to
the Staves and Systems page of Layout Options. When a system is set to show
staff labels, now the indent of the system is determined by the width of the widest
staff label or the value of this option, whichever is the wider; if this is the first
system, then the value of Indent first system of flow is then added on top. In this
way, it is possible to obtain a uniform indent for each system even when the staff
labels change.

Staves
A new Custom Staff Size dialog has been added to the Edit » Staff Size
submenu, allowing you to change the size of the staves belonging to a player to
any percentage scale factor. Select any note or chord in any of the staves

belonging to the player whose staves you want to resize, then open this dialog.

Custom Staff Size

Default staff size:  4.96pt staff = 7.0mm staff

Rastral size: ‘SizeS{G.Omm} v

Scale factor: %

New staff size:  4.27pt staff = 6.0mm staff

Choose one of the preset sizes from the Rastral size menu, or specify a custom
scale percentage. The resulting staff size is shown in the preferred unit of
measurement (as specified in Preferences). Click OK and the sizes of all the staves
belonging to the instruments held by that player are updated.

Text
System text. It is now possible to create text items that will appear at the system
object positions defined on the Players page of Layout Options, and in all layouts,
by choosing Write » Create System Text, which has the default key command
Shift+Alt+X. System-attached text also splits multi-bar rests.

Font size in part layouts. Each paragraph style can now optionally define a
separate size for part layouts.

Time signatures
Inserting time signatures. When adding a time signature with Insert mode switched
on, time is inserted before any later time signature to ensure that the bar prior to
the later time signature is always the correct length.
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Dashed barlines in aggregate time signatures. When creating an aggregate time
signature, where a sequence of time signatures exists within a single bar, you can
choose whether the subdivisions within the bar should be separated with a dashed
barline when creating the time signature in the Shift+M popover. To show the
dashed barline, separate each time signature with | (pipe); to hide the dashed
barline, instead use : (colon). By way of example, 4/4|3/4 will show a dashed
barline, while 2/4:3/4 will not.

Tokens

It is now possible to use tokens that correspond to specific flows inside text
frames. For example, to show the title of the third flow, use the token
{@flow3title@}. To find out what number to insert in the token, look at the Flows
panel in Setup mode, which shows the flow number in the bottom right-hand
corner of the block corresponding to each flow.

Tuplets

A new Repeated Tuplets group has been added to the Tuplets page of
Engraving Options, containing new options that allow the tuplet ratio and bracket
for successive identical tuplets to be hidden automatically. To hide such tuplets,
set Successive tuplets of the same unit and ratio to Hide ratio and bracket;
the tuplet ratio and bracket of repeated tuplets will then be hidden after the number
of tuplets specified in Number of repeated tuplets before ratio and bracket can
be hidden have been encountered. The final option in this group allows you to
specify whether tuplets should continue to be hidden if the pattern of repeated
tuplets is broken, for example by a rest or notes not part of the tuplet pattern.

User interface

= Anew View » Zoom » Custom Zoom dialog has been added, with key
command Alt+Z (also accessible by clicking the little magnifying glass icon in
the status bar, next to the button showing the current zoom level), allowing you
to quickly zoom to any magnification. Type Alt+Z to open the dialog, type the
desired zoom level (or use the up and down arrows to increase or decrease the

current zoom level in increments of 25%), and hit Return to confirm the change.

= The operation of the hand tool has been improved: when using the hand tool to
move the music around on the screen, the selection is not changed, which
makes it practical to use the hand tool to make a selection that ends outside the
current view.

= When attempting to open a project that is already open, a window belonging to
that project is now brought to the front.
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* An extra page has been added to the end of the guided tour for each mode,
telling you how to view it again. If you would like to review the guided tour for
any of Dorico’s five modes, simply choose Help » Guided Tour.

= Window » Previous Mode is now implemented, allowing you to quickly toggle
between the current mode and the previously chosen mode. You can also
assign a key command to this function in Preferences for quicker access.

= A new option Double-click in Setup or Engrave mode switches to Write
mode has been added to the General page of Preferences. Switch this option
off if you would prefer that double-clicking within a music frame in Setup or
Engrave mode should not switch to Write mode and start note input.

= |t is now possible to assign key commands to the three special editing modes in
Engrave mode, i.e. frame editing (Edit, Edit Frames), staff spacing (Engrave,
Edit Staff Spacing), and note spacing (Edit, Edit Note Spacing).

= Properties that properly apply only to music in a specific frame chain are no
longer misleadingly shown as if they apply when viewing music in galley view.

* |tis now possible to use comma (,) as a decimal separator in the spin controls
that display spaces in fractional values in the Properties panel and the options
dialogs.

Voices

New options have been added to the Edit » Voice submenu:

= Swap Voice Contents swaps the voices used by the notes and chords in the
selection.

= Change Voice allows you to change the voice used by the notes and chords in
the selection, listing the voices already in use on the staff (in which case the
selected notes and chords will be merged into the existing notes and chords of
that voice), and allowing you to change notes into a new up-stem or down-stem
voice as needed.

Both editing operations affect only the first selected instrument: if you select music
from multiple instruments, the remaining instruments’ music will be unaffected.

Furthermore, Swap Voice Order (which changes the graphical order of opposing
two voices, allowing you to position them either head-to-head or stem-to-stem as
you wish) has been moved from the Edit » Stem submenu to the Edit » Voice

submenu.
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Performance

Deleting and reordering flows in Setup mode is now significantly faster.

Installation

When downloading Dorico via the Steinberg Download Assistant, Dorico is now
delivered as three separate packages for your convenience: the main application
installer, the HALion Sonic SE plug-in and its content, and the HALion Symphonic
Orchestra content. It is still strongly recommended that all three packages should
be installed on your computer for correct operation of Dorico. Even if you already
have HALion Sonic SE or HALion Symphonic Orchestra installed, it is
recommended that you run the installers provided with Dorico, as they may include
required updates to the plug-ins or content. Your existing installation will be
detected and updated to avoid duplicating the content on your system.

Troubleshooting

A new option Help » Create Diagnostic Report has been added, which creates
an archive called Dorico Diagnostics.zip and saves it to your desktop. If you are
encountering any technical problems when using Dorico relating to the application
crashing, or problems with audio and playback devices, please consider including
the Dorico Diagnostics.zip file when you contact support or when you post your
query to the user forum, as this archive contains useful information that may allow

Steinberg staff to diagnose and resolve your problem more quickly.
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ID # Component Issue
A ] Copying and pasting music with arpeggio signs now correctly retains the arpeggio signs in
STEAM-5488 .fPeQQlO pying p . 9 peggio sig y peggio sig
signs the pasted material.
A ] Arpeggio signs are no longer incorrectly removed when using the Change Instrument
STEAM-5549 ‘fPGQQ/O peggio sig . 9 Yy . ¢} g
signs feature to change one instrument held by a player into another.
A ] Adding a cross-staff arpeggio sign in situations where either or both staves include notes
STEAM-5800 99’ necing & eros pegglo =19 | ,
signs in multiple voices now correctly creates the arpeggio across all voices.
. . Articulations no longer incorrectly avoid ties that are on the opposite side of the notehead
STEAM-5896 Articulations ) )
to the articulations themselves.
Bar numbers drawn at the start of the system no longer incorrectly move horizontally when
STEAM-5118 Bar numbers .
a start repeat barline appears at the start of the system.
. Special barlines no longer show a redundant time signature signpost if they do not also
STEAM-5332 Barlines . ) . .
coincide with a change of time signature.
STEAM-6172 Barlines Start repeat barlines at the start of the flow now draw as expected in galley view.
. Adding a barline (e.g. a double or start repeat barline) with an existing barline selected no
STEAM-6224 Barlines )
longer causes the new barline to be added one bar later than expected.
Adding bars via the Shift+B popover now correctly considers the prevailing alternating
STEAM-4768 Bars . ) .
time signature, if any.
Deleting bars via the Shift+B popover now correctly considers any ongoing octave lines,
STEAM-5705 Bars . .
lyrics, and grouped dynamics.
When deleting bars via the Shift+B popover, a time or key signature at the beginning of
STEAM-6163 Bars ' . . .
the first bar to be deleted, that time or key signature is no longer deleted.
If the caret is positioned in the middle of a bar when deleting bars via the Shift+B popover,
STEAM-6267 Bars : . . " .
the bar in which the caret is positioned is now completely deleted.
Bracket d  Creating, deleting or otherwise editing a player group in Setup mode now correctl
STEAM-5592 ey 9 9 . 9Py . N p P g
braces updates the brackets and braces in the score immediately.
. The handles that appear in Engrave mode for hairpins have been improved, such that they
STEAM-4751 Dynamics . .
follow the mouse more closely during drag operations.
. Cutting and pasting dynamics that are part of a group now works more reliably, with the
STEAM-5295 Dynamics .
dynamics offset correctly when pasted.
STEAM-5295 Dynamics Cutting and pasting dynamics that are linked together now works more reliably.
Using Alt+click to repeatedly copy dynamics no longer results in duplicate dynamics bein
STEAM-5761 Dynamics 9 P y copy sy o P Y o
created.
. Dynamics at grace note rhythmic positions now track the mouse pointer correctly when
STEAM-5971 Dynamics

dragging them in Engrave mode.
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ID # Component Issue
When entering dynamics into the Shift+D popover while the caret is visible, advancing the
STEAM-6123 Dynamics popover with Space will now correctly only extend a hairpin if it was the final dynamic
entered into the popover.
STEAM-4813 Flows Adding more than 79 flows to a single project no longer causes a crash (Windows only).
Attempting to set the Grace note before barline property on a grace note at the very start
STEAM-6169 Grace notes .
of the flow no longer causes Dorico to crash.
Holds and Fermatas on barlines now draw in the correct position relative to barlines on single-line
STEAM-5731 o
pauses percussion instruments.
Holds and Fermatas on barlines are now positioned correctly if the barline results from a local time
STEAM-5732 ) i n )
pauses signature (i.e. one specific to a single staff).
STEAM-5733 Holds and The option Gap to right of caesura in the Horizontal Position group of the Holds and
pauses Pauses page of Engraving Options now works as expected.
STEAM-6104 Holds and Reset Position now takes effect inmediately for a selected fermata, caesura or breath
pauses mark, rather than only appearing to take effect after another nearby edit.
STEAM-6117 Holds and A problem whereby a fermata over a barline could drift further and further away from the
pauses staff during editing in galley view has been resolved.
Holds and - . . . -
STEAM-6147 Fermatas positioned on barlines now break multi-bar rests in the correct position.
pauses
Inst t A redundant key signature no longer appears if the point at which an instrument change
STEAM-5644 o umen ey sie gerapp P 9
changes occurs coincides with a key change.
Inst ; Changing between a multi-staff instrument and a single-staff instrument no longer
nstrumen
STEAM-5686 " “ unnecessarily shows a clef if one of the staves is hidden because it is empty, and it shows
changes
g the same clef as the existing staff.
Inst , When an instrument change occurs at the end of a system, the required clef change and, if
nstrumen
STEAM-5757 h the transposition of the new instrument is different, the required key signature now
changes
g correctly appear.
inst , If all the notes belonging to an instrument in a given system have been crossed to another
nstrumen
STEAM-5758 h staff, and the option to allow some staves belonging to an instrument to be hidden is
changes
o enabled, the destination staff is now shown correctly, so that the notes appear.
STEAM-5765 Instrument A problem whereby redundant instrument change labels would appear during note input
changes close to the point at which the instrument transition occurs has been resolved.
STEAM-5777 Instrument When one staff of a grand staff instrument is hidden and the single staff shown changes
changes from one system to the next, Dorico no longer shows redundant clef changes.
Key It is now possible to add microtonal accidentals when using a traditional Western key
STEAM-4787 ) ) ) ) o
signatures signature, provided the current tonality system’s EDO value is divisible by 12.
Key Under rare circumstances, deleting a key signature on a single staff could cause a crash.
STEAM-6301 . .
signatures This problem has now been resolved.
Layouts whose names have not been explicitly overridden will now correctly update when
STEAM-5859 Layouts the instruments attached to their associated players are changed after a project has been

saved and reopened.
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ID # Component Issue
o Some key commands that were defined in the English version of Dorico but were missing
STEAM-5928 Localization . .
from the localized versions have now been restored.
o The names of font, paragraph and character styles are now correctly translated in the
STEAM-6221 Localization - )
relevant editing dialogs.
Lo When running in a language other than English, OS-provided dialogs such as Open and
STEAM-6289 Localization
Save are now fully translated (Mac only).
. In rare circumstances, dragging a lyric hyphen could cause Dorico to crash. This problem
STEAM-6268 Lyrics
has now been resolved.
. Lyric extender lines and hyphens now draw in the correct positions if they cross a system
STEAM-6269 Lyrics . . .
break in the middle of a bar, or in open meter.
STEAM-4171 MIDI import The detection and quantization of tuplets in MIDI files has been significantly improved.
. The Mixer window now correctly updates immediately in response to changes to players
STEAM-5285 Mixer . .
and instruments made in Setup mode.
Multi-bar Multi-bar rests will no longer collide with key signatures or time signatures at either end of
STEAM-6217 L
rests the bar when spacing is tight.
Multi-bar ) . . . o
STEAM-6347 " Multi-bar rests are now positioned correctly above single-line percussion instruments.
rests
Multi-bar A double or other special barline in the middle of a bar now correctly causes a multi-bar
STEAM-6369 .
rests rest to be split.
STEAM-4892 MusicXML . . S . '
) Numbered instruments are now imported more intelligently from MusicXML files.
STEAM-5807 import
STEAM-6089 MusicXML The Ends voice property is no longer set on the final note in each voice in an imported
import MusicXML file, which could cause rests not to appear when adding more music at the end.
L Navigating with the right arrow in galley view no longer sometimes fails to navigate onto a
STEAM-5706 Navigation
rest.
L Navigating with the up and down arrows in a single-staff layout in galley view will no longer
STEAM-5710 Navigation ] ) ] )
sometimes incorrectly navigate horizontally.
. Using chord mode to add notes to existing notes and chords no longer incorrectly removes
STEAM-1995 Note input ) . .
articulations that were originally present.
. Using Alt+left/right to move notes by the current rhythmic grid resolution now handles
STEAM-4869 Note input
tuplets correctly.
Inputting a rest by playing a note or chord on a MIDI keyboard with rest input engaged
STEAM-5234 Note input after having previously input a chord now correctly inputs a rest, rather than the note or
chord played.
. Creating octave lines, gradual tempos, and gradual dynamics based on the selection now
STEAM-5571 Note input ) . . .
always produces a line of the expected duration at the rhythmic start of the selection.
. Step input from a MIDI keyboard no longer causes a crash when inputting into a score
STEAM-5678 Note input

using a tonality system other than 12-EDO.
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ID # Component Issue
Changing the order of players in Setup mode is now correctly reflected in the order in
STEAM-5805 Note input which staves are visited when you move the caret up and down between staves in galley
view.
Changes made to the order of players and instruments in Setup mode are now correctly
STEAM-5805 Note input reflected in the order in which staves are navigated by the caret during note input in galley
view.
. Double-clicking a note above the top of the top staff or below the bottom staff in the
STEAM-5950 Note input
system now shows the caret correctly.
Deleting a tuplet with an expanding ratio (e.g. 2:3 rather than 3:2) no longer incorrectl
STEAM-5952  Note input 9.8 TP panding ratio (e.g ) no long Y
deletes any adjacent tuplets.
| Moving the caret left now always correctly navigates to the nearest rhythmic grid position,
STEAM-6041 Note input . .
rather than to the last note in the voice.
Copying and pasting system and frame breaks, and note spacing changes, from one layout
STEAM-6234  Note input pying and pasting sy axs pacing ehang y
to another now retains the relevant properties in the new copies.
. Using a MIDI keyboard to input notes in a layout-specific music frame would previously
STEAM-6246 Note input ) ) .
ignore the accidentals played on the keyboard. This problem has now been resolved.
. Using a MIDI keyboard to input into a layout-specific frame chain (rather than the main
STEAM-6246 Note input : : . . .
music frame chain from the master page) now inputs notes with accidentals correctly.
. Using Alt+up/down arrow to change the pitch of notes in a frame chain with a player filter
STEAM-6319 Note input )
applied now works correctly.
When copying and pasting notes that use a different notehead type, the changed
STEAM-5812 Noteheads } ) i i
notehead type is now correctly retained in the pasted material.
It is now possible to set the stem direction of a note in a project created by importing a
STEAM-5843 Notes : . ) ) N S
MusicXML file directly, without first removing its forced stem direction.
. It is now possible to nudge octave lines using Alt and the arrow keys (or use Ctrl+Alt for
STEAM-5720 Octave lines )
larger steps) in Engrave mode.
. Under rare circumstances it was possible for dotted octave lines of a certain length to
STEAM-6078 Octave lines Lo .
draw as solid lines. This problem has been resolved.
Changing an existing glissando line from drawing with a straight line to drawing with a
STEAM-5878 Ornaments ) ) ) ) )
wiggly line now correctly immediately updates the appearance of the line.
Setting the Space size property on a system or frame break now results in the initial value
STEAM-4497 Page layout ) . . .
(of 4.96pt, equivalent to a 7mm/0.28" staff) taking effect immediately.
STEAM-5535 Page | ; Editing the Wait for next frame/system break properties for a selected frame or system
age layou
STEAM-5911 ge break now causes the casting-off of the layout to be updated immediately.
STEAM-5624 ) " . . .
Page layout Changing the order of frames within a chain of music frames now works reliably.
STEAM-5826
Deleting a flow in a project with multiple flows no longer sometimes causes all music in a
STEAM-5669 Page layout layout to stop drawing, if one of the music frame chains in the layout was set to show only

the flow that has subsequently been deleted.
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Under some circumstances, changing the vertical position of a rest could incorrectly cause
STEAM-5755 Page layout the staff spacing to widen, or dynamics to move unnecessarily. These problems have been

resolved.

Under rare circumstances, it was possible for Dorico to crash when changing the frame
STEAM-5819 Page layout . . . .

chain to which a music frame belongs. This problem has been resolved.

Inserting blank pages before the page containing the first page of a flow no longer
STEAM-5910 Page layout i g pag Pag .g . Pag , g

sometimes causes the start of the flow to be missing from the music frame chain.

Locking the contents of a single music frame containing music from multiple flows now
STEAM-5923 Page layout

works correctly.

Attempting to lock a system or frame with a system or frame break signpost selected will
STEAM-5930 Page layout

no longer cause a crash.

Lock System will no longer lock the wrong system if you select a clef, key signature, or time
STEAM-6151 Page layout ) .

signature at the end of the system to specify the end of the system to be locked.

After adjusting staff spacing, undo now correctly only undoes the last spacing adjustment,
STEAM-6311 Page layout . . .

rather than clearing spacing adjustments.

Under some circumstances, deleting an item that causes the casting-off of the music to
STEAM-6317 Page layout ) ) o ) L

change, then undoing that deletion, would not return to the original casting off. This is fixed.

When your computer is connected to wifi, Dorico no longer polls the available networks
STEAM-5760 Performance . . . -

every 10 seconds, which can in some circumstances result in high network latency.

When a note is partially scrolled out of view in the event display in Play mode, it no longer
STEAM-5963 Play mode ) . . L . .

incorrectly shows a border at its left-hand side, making it appear it starts at that position.

Changing the settings in an instrument'’s track header no longer incorrectly causes the
STEAM-6063 Play mode . .

event display to scroll back to the beginning.

A problem whereby the ports in the chosen audio device could become disconnected,
AD-244 Playback ] .

causing no sound to be heard on playback, has been fixed.

When choosing a different audio device in the Device Setup dialog, the list of sample
STEAM-4803 Playback ) . .

rates is now correctly updated to show the sample rates supported by the active device.

If you attempt to choose an audio device that is currently unavailable in Device Setup,
STEAM-4806 Playback Dorico will no longer incorrectly show you that this device is chosen, instead showing you

the device that is actually in use.

Articulations such as staccato, accent etc. now only affect notes in the voice to which they
STEAM-5553 Playback

belong.
STEAM-5718 Playback Short appoggiaturas before dotted notes now play back with the correct length.

Grace notes before the beat now always correctly truncate the preceding rhythmic note in
STEAM-5719 Playback

playback.

Short (unmeasured) grace notes that coincide with a change of tempo now play back with
STEAM-5727 Playback

the correct length.

Notes played as keyswitches defined in expression maps for octave-transposing
STEAM-5748 Playback

instruments are no longer themselves incorrectly transposed by one or more octaves.
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Measured two-note tremolos now play back with the correct duration for notes of an eighth
STEAM-5749 Playback . .
(quaver) and shorter in duration.
When multiple projects are open, the playhead now only moves in the project that is
STEAM-5756 Playback )
playing back.
The playhead no longer incorrectly jumps back to the start of the system it has just finished
STEAM-5837 Playback . .
playing before proceeding to the next system.
Hitting the button to rewind to the beginning in the Transport during playback now
STEAM-5407 Playback
correctly restarts playback from the start of the flow.
STEAM-5851 Plavback Notes with tremolos or arpeggio signs within slurs no longer sometimes fail to play back
aybac.
STEAM-5802 A correctly because of the Playback Options to humanize the start positions of notes.
After changing the endpoint for an instrument in Play mode, manually assigning an
STEAM-5982 Playback endpoint for a newly-created instrument would result in no playback. This problem has now
been fixed.
Players and instruments added to your project after you have overridden the VST
STEAM-5982 Playback instrument or MIDI output used by an existing instrument in your project will now be played
back correctly.
MIDI program changes defined as actions in VST Expression Maps are now output
STEAM-6072 Playback )
correctly during playback.
Program changes arising from switches in VST Expression Maps are now output before all
STEAM-6128 Playback . "
notes at that rhythmic position.
If you start playback immediately after selecting a note, that note no longer sometimes
STEAM-6290 Playback i
incorrectly holds on after playback has started.
Single letters such as | or A at the end of an instrument’s name will no longer incorrectly be
STEAM-5747 Players ) .
interpreted as a Roman numeral and converted into a number.
STEAM-4942 Playing Changing the properties of one or more selected playing techniques now correctly
techniques updates the appearance of the playing technique across its whole range.
o When entering playing techniques using the Shift+P popover during note input (i.e. when
ayin
STEAM-4943 ' ;‘:I g the caret is visible), the chosen playing technique now appears immediately after
echniques
P confirming the popover, rather than after a note has been input at that rhythmic position.
Playi Text playing techniques are no longer incorrectly scaled to a smaller size when attached to
STEAM-5768 V'Y praying feehniq 9 Y
techniques grace note positions.
When selecting multiple layouts to be printed or to be exported as graphics, all pages of all
STEAM-5389  Printing g mutipe fay >P P S 9rap Pag
selected layouts are now correctly printed or exported under all circumstances.
L. Rests are no longer incorrectly printed in color when the View options to show Voice
STEAM-5791 Printing L X
colors or Implicit rests are switched on.
STEAM-5561 Rests Setting the color of a bar rest via Properties now correctly updates the score immediately.
Changing the number of empty bars at the end of a flow no longer incorrectly causes the
STEAM-5701 Rests

tacet al fine multi-bar rest to disappear if shown.
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. Using Shift+left/right arrow to extend block selections now works in any music frame
STEAM-5680 Selections . . . .
chain, not only the main music frame chain from the master page.
. Select All now works correctly in any music frame chain, not only the main music frame
STEAM-6320 Selections .
chain from the master page.
Setting the End offset property for a single-segment slur no longer incorrectly also sets
STEAM-5746 Slurs
the End handle offset property.
It is no longer possible to create zero-length slurs (for example, by selecting multiple notes
STEAM-5832 Slurs of the same chord and hitting S), which can cause the placement of other items, like
articulations, to be incorrect.
It is no longer possible to create linked slurs across multiple staves that do not start and
STEAM-6134 Slurs . -
end at the same rhythmic position.
Changing the Staff labels paragraph style now correctly updates the appearance of the
STEAM-5101  Staff labels gng paragraph s yup PP
staff labels in the score.
Tempo marks are now correctly aligned at the start of a bar with a special barline but no
STEAM-4614 Tempo . )
time signature.
If a tempo item’s properties are set such that no printable text will appear (e.g. the text is
STEAM-5693 Tempo o ) i
empty, and the metronome mark is hidden), a signpost will now always appear.
STEAM-6113 Tempo Tempo marks are no longer sometimes incorrectly offset to the right in galley view.
Double-clicking a text item in Setup or Engrave mode now switches to Write mode before
STEAM-5552 Text . "
opening the editing popover.
Changing the name of a player in Setup mode now correctly immediately updates any text
STEAM-5856  Text R - praye P Y yup y
items in the score that are using the {@playerName@} token.
Changing a font style now correctly shows the effect on any styles that inherit from it
STEAM-5875 Text ) ) i )
without having to confirm and reopen the Font Styles dialog.
Time If a bar is split either side of a system break, the time signature no longer incorrectly draws
STEAM-5786 )
signatures at the start of the second system.
T The signpost text that appears for an aggregate time signature now correctly shows the
ime
STEAM-5890 anat broken pipe character that indicates the dashed barline subdivisions between the different
signatures
9 time signatures.
- The Pick-up bar of control in the Create Time Signature section of the Time Signatures
ime
STEAM-6020 nat panel now correctly creates a pick-up bar using the beat length of the time signature to be
signatures
g created, not a fixed quarter note (crotchet) beat length.
STEAM-5745 Tremolos Strokes on one-note tremolos no longer sometimes draw too close to the notehead.
The ratio for a hidden tuplet number shown in the signpost now matches the ratio that will
STEAM-5696 Tuplets . . .
be shown when the tuplet number is shown, rather than its lowest common denominator.
If tuplets are hidden by way of the options in Engraving Options, an appropriate signpost
STEAM-5704  Tuplets P ywey P graving &p ppropriate signp

will now always appear.
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ID # Component Issue
STEAM-2201 User intert All items in Dorico’s panels now draw at the correct high-resolution pixel density on high-
ser interface
STEAM-1786 DPI or Retina displays. Previously some panel items were still drawing in low resolution.
. The Expression Maps dialog now correctly shows which expression map is loaded when
STEAM-5299 User interface . oo .
the dialog opens by selecting it in the left-hand list.
To make it clear that you cannot transpose up or down when transposing by a unison, but
STEAM-5517 User interface  rather can only transpose by a quality, e.g. augmented or diminished, the Up and Down
buttons are now disabled in Write » Transpose when transposing by a unison.
. Entering or exiting full screen mode by clicking the green traffic light button in the window
STEAM-5604 User interface . . .
title bar now correctly updates the checked state of the View » Full Screen menu item.
Key commands edited in the Preferences dialog when only the Hub window is open rather
STEAM-5614 User interface  than a project window now correctly take effect immediately, rather than only taking effect
when a project window is opened.
STEAM-5715 ) The Expression Maps dialog now shows the correct information for the initially selected
User interface . .
STEAM-6095 expression map when the dialog opens.
. The guided tour is now correctly triggered for the mode a project opens in, rather than
STEAM-5717 User interface » . .
waiting until the user changes mode to trigger the tour.
. The spin box showing the chosen channel in the track header in Play mode is now wide
STEAM-5793 User interface .
enough to show channel numbers higher than 9.
Under some circumstances it was possible for changes made in one options dialog to be
STEAM-5891 User interface  incorrectly applied to another open project, if the corresponding options dialog was also
open for that project. This problem has been resolved.
) It is now possible to use undo and redo (and other key commands) while a modeless
STEAM-5892 User interface . . o
options dialog is in focus.
. Moving the focus between the two panes of a horizontally or vertically split view now
STEAM-5898 User interface . . .
correctly updates the state of Dorico’'s menus immediately.
Changing the selected layouts and flows in Layout Options and Notation Options
STEAM-5901 User interface  respectively now always ensures that the option values shown in the dialog reflect the
current selection of layouts or flows.
. When you remove a player from a flow in Setup mode, you will now be prompted that
STEAM-5984 User interface ) ) ) ) . . .
completing this operation will delete the player's music, and ask you to confirm the action.
Some minor problems with assigning playing techniques in the Expression Maps dialo
STEAM-6135 User interface P gning piaying . P P ¢
have been resolved.
) Repeated key commands that include a modifier (e.g. holding down Alt+left arrow) are no
STEAM-6166 User interface i ) ) I
longer sometimes interpreted as if the modifier is not held down (Mac only).
. Dragging a tab from one group to another within the project window (i.e. with a horizontal
STEAM-6191 User interface . . ) . . .
or vertical split) now correctly activates the tab immediately after the drag is completed.
. Dorico will no longer crash if you attempt to undo with the Steinberg Hub window in focus,
STEAM-6206 User interface . . i ) .
or if the current tab in the project window does not contain a layout.
. Attempting to save default options from one of Dorico’s options dialogs will no longer
STEAM-6250 User interface

crash if the user application data folder is non-writable.
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ID # Component Issue
. Enabling editing of frames, staff spacing, or note spacing, or switching back into Engrave
STEAM-6281 User interface ; . . .
mode with one of these tools active, now correctly clears any selection from Write mode.
. When deleting a flow from the Flows panel in Setup mode, Dorico no longer incorrectly
STEAM-6283 User interface o o ] .
changes the selection in the panel, making it appear as if the wrong flow will be deleted.
. Moving one or more players up or down in the custom player order list on the Players
STEAM-6349 User interface . o
page of Layout Options now always keeps the selected players in view.
. A problem whereby some items could move further and further away from the staff while
STEAM-5795 Views L N .
the music is being edited in galley view has been resolved.
. It is no longer possible to set a non-percentage zoom level (such as zooming to page width
STEAM-5926 Views

or height) in galley view.
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Improvements

February 2017

This version contains the following improvements and issue resolutions.

Accidentals

Accidentals are now listed in the Accidentals section of the Key Signatures and
Accidentals panel in Write mode in order of ascending pitch delta (i.e. accidentals
that lower the pitch are listed before those that raise the pitch).

Auto-backup

Bar

Dorico now makes a backup copy of your project each time you save it. By default,
backups are stored in a folder called Backup Projects inside your chosen save
location (which is, by default, a folder called Dorico Projects in your user
account’s documents folder). A subfolder inside the backup location is created for
each project, and each time you save, that version is timestamped and placed in
that location. To conserve disk space, Dorico will keep only five backups of each
project by default, with the oldest backup being deleted as each new backup is
created. You can change the number of backup projects saved by setting Number
of backups per project in the Files group of the General page of Preferences.

To open a backup project, simply open it in the usual way, either by choosing it
from the File » Open dialog or by double-clicking it in Windows Explorer or the
Finder. Dorico will open the backup project as if it were a new, untitled project, so

that you can choose where to save it and what to call it.

numbers

A new option Position bar numbers at start of system after clef and key
signature has been added to the Bar Numbers page of Layout Options,
switched off by default. When switched on, if a bar number would appear at the
start of the system, it will be positioned immediately to the right of the preamble at

the start of the system, rather than aligned with the initial systemic barline.

Barlines

Dorico Version History

A new thick barline type has been added. It can be created from the Barlines
section of the Bars and Barlines panel in Write mode, or by typing thick into the
Shift+B popover.
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Brackets and braces
Two new options have been added to the Brackets and Braces page of
Engraving Options:

= Brace distance from systemic barline allows you to control the default
distance of the brace from the initial systemic barline.

= Brace distance from bracket allows you to control the default distance of the
brace from the thick bracket line, if the Secondary bracket appearance option

is set to Brace.

Clefs
The Shift+C popover for adding clefs now accepts French names for common
clefs: sol for treble G clef, fa for bass F clef, utb for baritone clef, ut4 for tenor clef,

ut3 for alto clef, ut2 for mezzo soprano clef, and ut1 for soprano clef.

Color
More items in the score can now have their colors changed via the Properties
panel: slurs, tuplet brackets, ornaments, arpeggios, playing techniques, and holds

and pauses.

Dynamics
It is now possible to create forzando dynamics with higher intensities than fz by

typing e.g. fffz into the Shift+D popover.

Grace notes

» The interpretation of grace notes during playback has been improved. An
unslashed grace note of an eighth (quaver) or longer in duration will by default
be interpreted as a so-called long appoggiatura (as described in Robert
Donington’s The Interpretation of Early Music), being played on the beat of the
rhythmic note it precedes, and taking half of its duration (or half of its undotted
duration, if the rhythmic note is dotted). An unslashed grace note of a 16th
(semiquaver) or shorter in duration will be interpreted as a so-called short
appoggiatura, being played on the beat of the rhythmic note it precedes, but
being played as short as possible.

= A new group of options has been added to the Timing page of Playback
Options, allowing you to specify whether single unslashed grace notes should
be played back as a long appoggiatura, and the threshold for the written
duration of the grace note below which it should be played back as a short
appoggiatura. You can also specify the exact duration of a short appoggiatura,
expressed as a fraction of the duration of a quarter note (crotchet) played at

120 quarters per minute, i.e. 0.5 seconds.
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= A new option Horizontal offset from stem has been added to the Grace
notes section of the Notes page of Engraving Options, allowing you to specify
the default horizontal offset of the grace note slash relative to the note stem.

Hub window
A new Tutorials tab has been added to the left-hand pane in the Hub window,
which provides a list of the latest videos added to the Dorico YouTube channel.
There are now many useful tutorial videos available to help you learn how to use
the software.

A new Videos button has also been added at the top of the Hub window, which

links directly to the Dorico YouTube channel.

Instruments

The following changes have been made to transposing woodwind and brass

instruments:

* All common (and some uncommon) horn transpositions are now provided, with
variants both with and without key signatures.

= Bass in Bb and Eb now have variants that show a bass clef either at transposed
pitch or at concert pitch.

= Sousaphone in Bb and Eb now have variants that show a treble clef at
transposed pitch.

= Variants of euphonium in Bb, baritone horn in Bb and tenor trombone in Bb that
show bass clef at concert pitch without an octave transposition have been
added.

* Piccolo in Db, soprano flute, contrabass flute, tenor trumpet in Eb, bass trumpet
in C (also known as valve trombone), alphorn in F#, cornett (or zink) in C and D

have all been added.

An organ instrument that uses only two staves (manuals only) and an SATB choir
set up for two staves have also been added.

Lyrics
A new option Punctuation for verse numbers has been added to the Lyrics page
of Engraving Options, allowing you to specify whether verse numbers should be
appended with a period (full stop).

Players
The option Uses custom player order on the Players page of Layout Options is
now fully functional, and allows you to change the order of players in one layout
from the order specified in the Players panel in Setup mode.
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Popovers

Except for the Shift+K key signatures and Shift+T tempo popovers, all the

popovers in Write mode are now case insensitive.

Printing

A new option Collate copies has been added to the right-hand panel in Print
mode, switched on by default. When switched on, Dorico will print all pages of
each copy of each layout to be printed in sequence; when switched off, Dorico will
print the desired number of copies of the first page, then the desired number of

copies of the second page, and so on.

Project Info

The File » Project Info dialog now defaults to showing you the information for the
current flow, rather than the entire project. If you select a flow in the Flows panel in
Setup mode, if you invoke the dialog either from the File menu or from the right-
click context menu, the dialog will open to the page for the first selected flow. If no
flows are selected in Setup mode, the dialog will instead open to the page for the
current flow you are editing, which is denoted by the flow whose name is shown in
the document title bar.

Rests

Dorico automatically fills the gaps between notes with rests of the appropriate
duration. These are known as implicit rests, because they are implied by the gaps
between the notes. Rests that are explicitly entered during note input using Force
Duration, or rests that were explicitly created by way of importing a MusicXML file,
are known as explicit rests. Explicit rests cannot be suppressed using the Starts
voice and Ends voice properties. Dorico 1.0.30 introduces new tools for working
with rests.

First, a new command Edit » Remove Rests has been added, which will set the
Starts voice and Ends voice properties appropriately such that any rests in the
selection are removed. If you see extra rests arising from secondary voices that you
would prefer did not appear, simply select them individually, or select a range of
bars containing rests that you would prefer did not appear, and choose Edit »
Remove Rests.

Second, a new option View » Note and Rest Colors » Implicit Rests has been
added. When switched on, implicit rests will be colored gray in the score. Explicit
rests will continue to be shown in black when this option is switched on.

This option can be useful in diagnosing why, for example, a rest does not disappear
when you set the Starts voice or Ends voice property on a nearby note: once you
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identify a rest as an explicit rest, you can delete it, and the implicit rest that
replaces it will respect the Starts voice or Ends voice property.

It is also now possible to suppress implicit rests before the first note in a voice by
setting Starts voice on the first note in that voice, which will suppress all rests
before that note to the start of the flow. You can also suppress implicit rests after
the last note in a voice by setting Ends voice on the last note in that voice, which
will suppress all rests after that voice. It is also possible to suppress implicit rests
in any gaps between different voices that might occur in the middle of a flow,
though this will require you to set Ends voice on the last note of the first voice, and
Starts voice on the first note of the second voice, if the gap between those notes

spans multiple barlines.

Tempo

A new Circa appearance option has been added to the Absolute Changes group
on the Tempo page of Engraving Options, allowing you to choose whether a
metronome mark that shows an approximate tempo should show the equals sign
between the note value and the approximate indication.

Text

A new option Position of text relative to other items has been added to the Text
page of Engraving Options, which is set to Avoid collisions in new projects. This
option allows Dorico to move text items vertically to avoid collisions with other
items. This will not be enabled by default in existing projects, since you may have
already moved text items to avoid collisions, but you can enable it if you want to.

Tremolos

A new group of options has been added to the Timing page of Playback Options
to control the playback of unmeasured tremolos. You can specify the minimum
number of tremolo strokes that will be interpreted as unmeasured in playback. This
considers both the number of tremolo strokes and the number of beam lines that
would be used for the note; for example, if the option is set to require three tremolo
strokes, an eighth note (quaver) with two tremolo strokes will be played as
unmeasured, because the eighth note’s single beam is included in the calculation.

You can also specify the default length of the notes in an unmeasured tremolo,
expressed as a fraction of the length of a quarter note (crotchet) played at 120

quarters per minute, i.e. 0.5 seconds in length.
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Issues resolved

ID # Issue

Audio export: A problem that would result in exported audio files being exported to the correct length but
STEAM-5226 ending up either mostly or completely silent if the project had been played back completely before

exporting audio has been resolved.

Accidentals: Attempting to add a new glyph to an accidental definition without a glyph selected in the list
STEAM-5537

of glyphs no longer causes a crash.

Accidentals: The accidentals in the Accidentals section of the Key Signatures and Accidentals panel
STEAM-5413 now stick on during note input in the same way as the accidentals in the notes panel on the left-hand side

of the window.

STEAM-5496 &

Arpeggio signs: The spacing of arpeggio signs relative to cross-staff notes has been improved. In
particular, if two cross-staff arpeggio signs exist at the same rhythmic position on different instruments,
each arpeggio sign will now be offset only by the width of the accidentals etc. on the instrument to which

STEAM-5457 . ) . . . .
the arpeggio sign applies, rather than the width of accidentals on all instruments that have arpeggio signs
at that rhythmic position.

A jo signs: A io signs no | ove slightly to the left or right while dragging them in Engra

STEAM-5490 rpeggio signs: Arpeggio signs no longer move slightly e left or right while dragging them in Engrave
mode.

STEAM-5485 Arpeggio signs: The length of cross-voice arpeggio signs is now correctly updated when the pitches of
the notes changes sufficiently that the highest or lowest note is now in a different voice.

Arpeggio signs: The length of cross-staff arpeggio signs no dates correctly after the distance

STEAM-5475 peggio sig 9 peggio sig W up y I
between staves changes.

STEAM-5112 Articulations: The appropriate properties are now displayed in the Articulations of duration group of the
Properties panel depending on whether a tenuto is present.

STEAM-5617 Audio export: Exporting to WAV will now always use the sample rate used by the current audio device;
exporting to MP3 will always export at 44.1kHz.

Bars: In rare circumstances, it was possible for deleting bars using the Shift+B popover to cause Dorico

STEAM-5695 i
to crash. This problem has been resolved.

Beams: Beam direction is no longer affected by the staff positions of rests within the beamed group,

STEAM-5573 .
unless stemlets are in use.

STEAM-5518 Dynamics: A problem that prevented immediate dynamics immediately following a gradual dynamic (a
crescendo or diminuendo) from playing back correctly has been resolved.

D ics: Typi .g. f cresc. into the Shift+D dynamics lo} ill no | discard the specified

STEAM-5503 ynamics yp.mg eg |r.1 e ynamics popover will no longer discard the specifie
gradual dynamic when popover is closed.

Dynamics: Typing sf or sfz into the popover will now set the rfz/sfz style property as appropriate, so the

STEAN-5685 y res: yping ' pop yleé property pprop
dynamic will match the popover input.

STEAM-5494 Exporting graphics: A problem whereby graphics would not be correctly exported if the name of the layout
to be exported contained one or more characters that are illegal in filenames has been resolved.

Exporting graphics: PDFs exported with the Mono option set are now always correctly exported in a true

STEAM-5567 porting grap p p y y exp
monochrome color space.

Layouts: Empty part layouts numbered higher than 10 are now correctly renamed when assigning players

STEAM-5500 y Pty p y 9 y gning play

to them.
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ID # Issue
STEAM-5476 Layouts: Changes made to player groups in the Players panel are now reflected immediately in the open
layout, instead of incorrectly requiring the layout to be closed and opened again.
STEAM-5464 Lyrics: Attempting to start lyric input with the final barline selected will no longer cause a crash.
Lyrics: A problem whereby lyrics could sometimes be pasted out of order when copying and pastin
STEAM-5619 yr p w . y lyn u I p u wi pying pasting
between flows or projects has been resolved.
STEAM-4954 Mixer: Mute/Solo buttons now work correctly in the Mixer, and new buttons have been added to clear all
STEAM-4994 Mute and Solo states.
Mixer: The state of the insert and send slots in the Mixer, including whether each is enabled or disabled, is
STEAM-4993 . ) )
now correctly saved and restored when saving and reopening a project.
STEAM-5085 Mixer: The Mixer now correctly updates in response to changes in the project, for example adding or
removing players and instruments, without requiring that the window be closed and reopened.
Mixer: The responsiveness of the faders in the Mixer has been improved. It is no longer possible to move
STEAM-5621 the faders with a two-fingered swipe gesture, but it is still possible to use a sideways swipe gesture to
scroll the Mixer window.
STEAM-5610 Mixer: The Mixer is no longer forced to be on top of all other windows (Windows only).
Mixer: It is now possible to route signal from any instrument output to the global effects channel;
STEAM-5482 . | ) . . .
previously, this routing would only work for the default HALion Sonic SE 2 plug-in.
Multi-bar rests: Gradual tempo changes (such as rit./accel.) no longer cause multi-bar rests to break
STEAM-5635 )
incorrectly.
Multi-bar rests: Deleting music from a part layout in which two or more instruments are included and multi-
STEAM-5602 o
bar rests are enabled no longer causes a crash under certain circumstances.
STEAM-5798 Note input: When selecting notes in instruments whose sounds require a transposition of one or more
octaves in playback (e.g. double bass, bass guitar), the correct octave transposition is now applied.
Note input: You can now correctly override the choice of octave for the first note of a chord when
STEAM-5481 . . . . .
inputting a chord using the computer keyboard in step input.
Note input: It is now possible to set key commands for double sharp and double flat accidentals that can
STEAM-5577 ) . . .
be used to specify those accidentals during note input.
Note input: The initial duration chosen when note input starts will only be taken from the selected note if a
STEAM-5600 single note is selected; if there are multiple notes and rests selected, or if the selected rest is longer than
a quarter note (crotchet) in duration, the initial duration chosen will be a quarter note (crotchet).
Note input: Switching on Lock Durations during note input now correctly switches off rests, tuplets, or
STEAM-5487 )
grace notes, if any of those tools were engaged.
STEAM-5543 Notation options: Some options from the Notation Options dialog were not correctly applied to new
flows or new projects after having been saved as defaults; this problem has now been resolved.
STEAM-5596 Ornaments: When selecting a mordent or turn and editing it by clicking another ornament type in the
Ornaments panel in Write mode, the correct button now shows as selected in the panel after the edit.
STEAM-5460 Playback: Dorico no longer crashes if it attempts to play notes lower than MIDI note 0.
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ID # Issue
Playback: Starting playback in a large project is now considerably faster. This also reduces the time it
STEAM-5522 i
takes to open larger projects.
STEAM-5456 Playback: A problem that would cause the playback of legato (either triggered by slurs or the legato
playing technique) to be overridden, so that there is no audible legato effect, has been resolved.
STEAM-5367 Playback: The nat. playing technique now correctly resets all other active playing techniques.
Playback: Grace notes at the same position in multiple voices or instruments are now correctly played at
STEAM-5498 .
the same time.
Playback: Only those flows assigned to the current layout are played back, in the order in which they are
STEAM-5533 listed in the Flows panel in Setup mode, rather than relying on the presence of a full score layout (the
absence of which would previously have caused there to be no playback at all).
Playback: Audio devices with ampersand characters in their names can now be chosen correctly in the
STEAM-5638 . )
Device Setup dialog.
STEAM-5396 Playback: Keyswitch notes are now correctly cleared when playback stops, so that starting playback again
does not sometimes result in Dorico playing the wrong technique.
Playback: Keyswitch notes and MIDI controllers are now correctly chased when starting playback from the
STEAM-5721 )
middle of a flow.
STEAM-5595 Playback: When opening an existing project, the correct playback data for the current layout is now set up
immediately, and switching the Flow drop-down in Play mode correctly updates the event display.
ADLOB1 Playback: A problem whereby Waves NX plug-ins would not load or correctly display their user interface
has been resolved.
STEAM-5750 Playback: Reverb send level is now correctly set post-fader rather than pre-fader.
Players: When changing between two instruments with different numbers of staves held by the same
STEAM-5647 player, if the option to allow one staff of a multi-staff instrument to be hidden if empty is enabled, Dorico
no longer shows both staves of the two-staff instrument unless both contain music.
STEAN-5616 Players: Certain edits to music at or near a transition between different instruments held by the same
player can no longer cause the following system to disappear temporarily.
Players: Changing the instrument held by a player no longer causes any arpeggio signs written for the
STEAM-5549 )’ ' ging y a play! g y arpeggio sig
original instrument to be lost.
STEAM-5711 Players: Under rare circumstances it was possible for Dorico to crash when moving a player from one
group to another in Setup mode. This has now been resolved.
Printing: It is no longer necessary to switch on the View options checkbox in the Annotations section of
STEAM-5640 ) ) . . .
the print options panel to print colored objects in color.
STEAM-5615 Printing: Typing a page number into the To spin control to determine the page range and then hitting Tab
to move the focus to another control no longer causes a crash under some circumstances (Mac only).
STEAM-5716 Printing: Reopening a project that was last saved with Print mode active will now correctly show the print
preview immediately, without requiring you to switch to a different mode and back again.
STEAM-5656 Properties: A problem whereby selecting a bar containing a playing technique that is otherwise empty

could cause Dorico to crash has been resolved.
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ID # Issue
Rests: Under some circumstances, bar rests that appear when notes that had been crossed to an
STEAM-5563 otherwise empty staff from the staff above or below could appear at the wrong vertical position. This has
now been resolved.
STEAM-5478 Rests: Deleting a tuplet containing rests now always correctly renotates the rests that remain.
STEAM-4875 Rests: Under some circumstances, removing the Starts voice property from the first note in a tuplet would
not cause any suppressed rests earlier in the tuplet to reappear right away. This has now been resolved.
STEAM-5538 Staff spacing: Edits to staff spacing are no longer incorrectly removed if the layout whose staff has been
edited has been viewed in galley view during the current editing session.
Text: A problem whereby double-clicking a text item to edit it would not work in certain circumstances
involving music in multiple frame chains has been resolved.
STEAM-5323 Time signatures: A problem whereby setting the Ends interchangeable property on a time signature
would not immediately cause the following bars to be redrawn correctly has been resolved.
Time signatures: Deleting and recreating a time signature change within an interchangeable range will
STEAM-5090 . . .
now have the correct effect on the time signatures that come after it.
Time signatures: Rests are now correctly grouped according to the instrument-specific time signature, if
STEAM-5470 i
one Is present.
STEAM-5609 Transposing: Making a selection of music at the beginning of a flow that starts with a C major or A minor
key signature will now correctly allow that key signature to be transposed.
Tremolos: When selecting a tremolo with four strokes, the correct button now shows as selected in the
STEAM-5527 . .
Tremolos panel in Write mode.
Tremolos: The playback of measured tremolos has been improved, such that the number of tremolo
STEAM-5564 strokes now determines the note value of the repeated notes (one stroke = eighth note, two strokes =
16th note, etc.), instead of simply dividing the written note value by two, four, etc.
STEAM-5510 Voices: When you use Edit » Stem » Swap Voice Order to swap the order of two voices, the resultant
Voice column index values now appear correctly in the Properties panel.
User interface: The keyboard focus is now always returned to the main document area after clicking any of
STEAM-5474 the buttons in the right-hand panels in Write mode, so that all key commands operate on the music as
expected without having to click into the music area again.
STEAM-5471 User interface: A problem whereby the scrollbars in the right-hand panels in Write mode could either
appear the wrong height (Mac and Windows), or too wide (Windows only), has been resolved.
STEAM-3033 User interface: It is now possible to assign key commands to key combinations that normally act as dead
keys producing combining diacritics, such as Alt+E (Mac only).
User interface: The way scroll bars appear in Dorico’s panels has been revamped to ensure that they only
STEAM-4934
appear when necessary.
User interface: Changes to key commands now take effect immediately, even if no project window is
STEAM-5614
open.
User interface: Changing the selection of layouts in Layout Options without having made any changes to
STEAM-5692

any of the options no longer incorrectly prompts that there are unsaved changes.
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ID # Issue
STEAM-5605 User interface: When running in full screen, menus that pop up from buttons (e.g. in the status bar at the

bottom of the window) no longer appear too high, as if the Dock were visible (Mac only).

User interface: When attempting to open many projects at the same time, Dorico no longer sometimes
STEAM-5620

crashes.

User interface: Audio devices with an ampersand (&) in their name now appear correctly in the Device
STEAM-5638 .

Setup dialog.

Localisation: Dorico will now start correctly if your user account name uses Japanese or other CJK
STEAM-5574 ) )

Unicode characters (Windows only).
STEAM-5471 L. ) . . - _
STEAM-5321 Localisation: Several issues related to assigning key commands using specific key combinations on

French, German, ltalian, Japanese and Russian keyboards have been resolved.
STEAM-5590

Localisation: The key command Ctrl+A (Windows) or Command-A (Mac) was missing from the default

sets of key commands in languages other than English; this has now been resolved.

Performance: A problem whereby commands (e.g. notes input in quick succession) could be executed in
STEAM-5585 )

the wrong order or skipped has been resolved.

Performance: The speed of note input and editing in projects containing multiple flows has been
STEAM-5629 o i

significantly increased.

Performance: The speed of note input and editing in flows that have a lot of trailing empty bars has been
STEAM-5579

significantly increased.
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This version contains the following improvements and issue resolutions.

Performance improvements

Building on the improvements in Dorico 1.0.10, this update includes further
significant improvements to the performance and reliability of Print mode. For
example, selecting multiple layouts in Print mode is now considerably faster.

Arpeggio signs

A new Arpeggiation section has been added to the Ornaments panel in Write
mode, allowing the creation of arpeggio signs indicating upwards and downwards
arpeggiation, as well as a non arpeggio bracket line indicating that a chord should
not be arpeggiated.

To create an arpeggio sign on a chord in a single voice, select any notehead in the
chord, and either select the desired arpeggio sign from the Ornaments panel, or
type Shift+O to open the ornaments popover, in which you can type arp (or
arpeggio) for an upwards arpeggio, arpdown (or arpeggiodown) for a
downwards arpeggio, or nonarp (or nonarpeggio) for a non arpeggio sign. Dorico
will create the arpeggio line spanning all of the notes in the chord. Dorico will not
create an arpeggio sign if only a single note exists in the selected voice. Arpeggio
signs can also be created during note input in chord mode using the ornaments

popover.

To create an arpeggio sign that spans chords in multiple voices (e.g. across both
staves of a piano or harp instrument), select any notehead in the first voice, then
hold Ctrl (Windows) or Command (Mac) and select any notehead in the second
voice, then create the arpeggio sign either using the panel or the popover, as

described above.

Dorico will automatically adjust the length of the arpeggio sign as the pitches of the
notes in the voices to which the sign belongs change, or as notes are added to or
deleted from the chords, and will automatically delete the arpeggio sign when only

a single note remains at that rhythmic position in that voice.

By default, any grace notes at the same rhythmic position as an arpeggio sign will
be positioned to the left of the arpeggio sign. To make the arpeggio sign appear to
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the left of the grace notes, select the arpeggio sign and set the Arpeggio before
grace notes property in the Properties panel.

Downwards arpeggio signs have an arrowhead at the bottom of the line by default,
but upwards arpeggio signs have no arrowhead by default. Arpeggio signs can
alternatively show a Couperin-style swash at their top or bottom. To override an
individual arpeggio sign, select it and open the Properties panel, then set the Sign
end property. The length of arpeggio signs can also be adjusted on a case-by-
case basis in Engrave mode.

Options controlling the default appearance of arpeggio signs have been added to
the new Arpeggio Signs page of Engraving Options.

Arpeggio signs do not yet have any effect in playback, but this is planned for a
future update.

Brackets and braces

A new option Additional vertical protrusion beyond top or bottom of staff has
been added to the Design group on the Brackets and Braces page of Engraving
Options, allowing the thick vertical line of the bracket to be lengthened slightly if
needed to ensure a good join with the chosen bracket tip glyphs in the current
music font.

Instruments

A keyless timpani instrument type, i.e. a timpani that does not use a key signature
and instead shows accidentals for each note as required, has been added and can
be chosen from the instrument picker.

Key commands

» |t is now possible to change the default key commands for changing the pitch of
notes (Alt+up/down arrow to move by step, Shift+Alt+up/down arrow to move
by chromatic step, and Ctrl+Alt+up/down arrow to move by octave). These
commands can now be found in the NoteEdit category.

* |t is also now possible to assign key commands for Edit » Stem » Force Stem
Up, Force Stem Down and Remove Forced Stem. These commands can now

be found in the Edit category.

Lyrics

A new ltalic property has been added to the Lyrics group in the Properties panel,
allowing any non-italic lyric to be made italic if necessary, for example for
occasional words in a different language, or vocalizations interspersed within the
text.
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Music fonts

Dorico now reads the JSON metadata files for SMuFL-compliant fonts from the

locations recommended by the SMuFL specification:

= Windows: C:\Program Files\Common Files\SMuFL\Fonts\
= Mac: /Library/Application Support/SMuFL/Fonts/

Dorico will load the JSON file if it is named fontname.json (e.g. Bravura.json) and
located inside a folder called fontname (e.g. Bravura) in the appropriate path for
the operating system.

If Dorico can load the JSON metadata file correctly, then the font will appear in the
list of available music fonts in Engrave » Music Fonts.

Note input

To create a time signature or key signature that applies only to the staff on which
the caret is currently located, enter the time signature or key signature into the
Shift+M or Shift+K popover as usual, and type Alt+Return (instead of Return
alone) to confirm the item to be created.

Notes

A new option Stem direction for notes on the middle line of the staff has been
added to the Stems group on the Notes page of Engraving Options, allowing you
to choose whether Dorico should use musical context (i.e. the staff positions of
notes preceding and following the notes on the middle line of the staff) or a fixed
default to determine the stem direction of notes on the middle line of the staff.

Ornaments

A new option Horizontal gap between trill marking and trill extension line has
been added to the Trills group on the Ornaments page of Engraving Options,
allowing you to determine the distance between the #- sign and the extension line

to its right.

Page layout

A new Rastral size menu has been added to the Space Size group on the Page
Setup page of Layout Options, allowing the specification of staff size according to
the rastral sizes used in traditional music engraving. The largest size is Size 0
(9.2mm or 0.36"), and the smallest size in Size 8 (3.7mm or 0.15"), and the default
staff size in a new project is now Size 3 (7mm or 0.28"). It is naturally still possible
to choose any custom size, as before, by editing the Space size value directly.
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Two new options have been added to the Hide Empty Staves group on the
Vertical Spacing page of Layout Options:

= Allow individual staves of multi-staff instruments to be hidden: When
switched on, Dorico will allow (say) the left-hand staff of a piano instrument to
be hidden on a system on which it has no music; when switched off, the piano
will only be hidden on a system if both staves can be hidden.

* Players excluded from hide empty staves: This provides a list of all of the
players in the current layout, and allows you to specify a list of players that
should never be hidden, even if their staves are empty throughout a system.

Playback

= A new Playback Options dialog has been added to the Play menu. This dialog
contains options to determine how Dorico should interpret specific markings
during playback, such as the percentage by which the written duration of notes
should be extended under a slur or when encountering a /egato playing
technique, by how much the dynamic should be increased when playing an
accent or marcato articulation, and so on. The dialog also includes an initial set
of options for beat stress (the amount by which the dynamic should be
increased on primary and secondary beats in the current meter) and for
humanization of dynamic level and note start position.

= Single- and multiple-note tremolos now play back. Measured single-note and alll
multiple-note tremolos are played back directly by rendering additional note
events, while unmeasured single-note tremolos can be played back using
unmeasured tremolo samples if they are provided by the VST Expression Map in
use for the instrument.

= Slurs and the /egato playing technique are now played back by extending the
duration of all but the last note under a slur.

= Grace notes now play back. Any number of slashed and unslashed grace notes
at present all play back immediately before the rhythmic note they precede,
stealing time from the preceding rhythmic note. Playback of a single unslashed
grace note, taking half the written duration of the rhythmic note that follows, and
stealing time from that following rhythmic note, will be added in a future update.

= A new option Show playhead when stopped has been added to the Play
group on the General page of Preferences. When switched on, the playhead
(vertical green line) will appear both during playback and when stopped; when
switched off, the playhead will appear only during playback.

Preferences
The General page of Preferences has been organized into groups of related
options.
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Rests
A new option Bar rests in additional voices has been added to the new Rests in
additional voices group on the Rests page of Notation Options. In new projects,
this option is set to Omit bar rests, which means that when an additional voice
(typically a down-stem voice) stops, any subsequent bars in which that voice has
no notes or chords prior to its reappearance will not be padded with bar rests. This
reduces the number of occasions you would have to search backwards through
the music to set the Ends voice property on the last note in the voice, which might
be dozens or even hundreds of bars earlier.

If you would prefer that Dorico continue to pad all intervening bars with bar rests,
set the new option to Show bar rests, which will also be the value chosen in any
projects created in versions of Dorico earlier than 1.0.20.

Furthermore, when this new option is set to Omit bar rests, bar rests no longer
appear in bars where the only notes and chords present have been crossed from
another staff.

In addition, a new option Allow dotted rests equal to the length of a compound
beat has been added to the Compound Time Signatures group on the Rests
page of Notation Options. When set to Allow dotted rests, a rest of a dotted
quarter (dotted crotchet) in 6/8 will be rendered as a single dotted quarter rest; if it
is set to Split at beat subdivisions, it will be rendered as a quarter (crotchet) rest
followed by an eighth (quaver) rest.

Finally, it is now possible to create explicit bar rests during note input. Either click
the new Insert Bar Rest button in the Bars and Barlines panel in Write mode, or
type rest into the Shift+B popover.

Templates
The Brass band template has been improved, with corrected staff labels for the
cornet and horn instruments, and appropriate clefs for the trombones.

Tempo
It is now possible to control the appearance of absolute and gradual tempo
changes independently in Engrave » Font Styles. Absolute, relative and reset
tempo markings use the Immediate tempo text font style, while gradual tempo
changes used the Gradual tempo text font style.

Views
When changing view type from galley view to page view, or vice versa, if there is a
selection, Dorico now attempts to center the selected item or items in the new

view.
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Issues resolved

The following table lists all issues that have been resolved in this version:

ID #

Issue

STEAM-5344

Copy and paste: Notes within tuplets that have been created with Force Durations set now retain their
forced duration when pasted.

STEAM-5269

Copy and paste: Using R to repeat a selection no longer sometimes pastes items (such as dynamics) in
the wrong location.

STEAM-5414

Dynamics: Dynamics between the two staves of a keyboard instrument are now correctly centered. The
option Allow dynamics between braced staves to violate minimum distance by n spaces has been
removed from the Dynamics page of Engraving Options.

STEAM-5403

Holds and pauses: Caesuras at the end of a bar now cause multi-bar rests to break at the bar in which
they appear, rather than at the following bar.

STEAM-5391

Holds and pauses: Caesuras that precede a change of time signature or key signature no longer cause
the time or key signature to be spaced incorrectly relative to the barline.

STEAM-5380

Instrument changes: ltems that apply to the whole system, such as tempo markings, rehearsal marks, etc.,

now appear correctly above the top staff when the top staff uses instrument changes.

STEAM-5352

Key signatures and accidentals: Setting a non-Western accidental on a note no longer incorrectly also
sets the same accidental on the note in transposing layouts; now, the accidental is only set in transposing

layouts if the relative offset between the concert and transposed pitch notes are identical.

STEAM-5341

Key signatures and accidentals: Notes with non-Western accidentals now behave correctly when

repitched, and do not continue to show the same accidental even if the offset of the pitch changes.

STEAM-5162

Key signatures and accidentals: The rule that every tonality system must have an accidental type that fulfils
the role of the natural (i.e. does not change the pitch) is now enforced, and it is no longer possible to
delete any built-in accidental type, or any accidental type that is in use in the project.

STEAM-5383

Key signatures and accidentals: Accidentals types that contain graphics now display correctly in the
Accidentals section of the Key signatures and accidentals panel in Write mode.

STEAM-5347

Key signatures and accidentals: The option Notes following a change of key signature that shows
cancellation naturals on the Accidentals page of Notation Options now works as expected. This option
only takes effect if Dorico will show cancellation naturals at a change of key, as determined by the two

options immediately above this one in the dialog.

STEAM-5338

Key signatures and accidentals: A problem whereby instruments that don’t show a key signature (e.g.
Horn in F) would under some circumstances not show the required accidentals on some notes in extreme

keys (i.e. key signatures of 7 sharps or flats) has been fixed.

STEAM-5264

Key signatures and accidentals: Cancellation naturals now appear if necessary at changes of key arising
from changing between instruments with different transpositions.

STEAM-5192

Key signatures and accidentals: Changes of key that occur in the middle of a bar now correctly take effect

on the notes that follow the key signature before the end of the bar.

STEAM-5274

Key signatures and accidentals: When importing MusicXML files that use other accidentals than the
standard 12-EDO or 24-EDO accidentals, Dorico now automatically creates an appropriate tonality

system in the resulting project.

STEAM-5426

Layouts: Custom layout names are now correctly preserved when re-opening saved projects.
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ID # Issue
MusicXML import: Dorico no longer crashes when encountering a MusicXML file that specifies an invalid
STEAM-5255
number for slur elements.
STEAM-5074 MusicXML import: Dorico no longer fails to open compressed MusicXML (.mxl) files that contain internal
filenames that use extended Unicode characters.
Navigation: Using up/down arrow to navigate to the staff above/below from a selected bar rest no longer
STEAM-5354 . .
sometimes skips over the next staff.
Navigation: Using Ctrl+up/down arrow to navigate to the system above/below now works correctly, for
STEAM-5318 )
any number of staves in the system.
Note input: Specifying that the next note to be input should explicitly be above or below the previous note
STEAM-3035 .
now works more reliably.
Note input: Moving the caret to the staff above/below with up/down arrow now correctly takes into
STEAM-5351 account whether the caret is at a tuplet position on the original staff, and moves to an appropriate position
on the destination staff.
Note input: When inputting notes into transposing instruments in a transposing layout, notes are no longer
STEAM-5430 T i poSINg Insirtiments posing &y 9
sometimes input in successively higher octaves for no discernible reason.
Note spacing: Tempo markings are no longer considered when determining the width of multi-bar rests,
STEAM-5359 unless another tempo marking in a later bar would collide with a previous tempo marking, preventing some
multi-bar rests from being made much wider than necessary.
STEAM-5402 Notes: Augmentation dots are no longer hardwired to be drawn using Bravura, so if you choose to use
another music font via Engrave » Music Fonts, you will see the appropriate glyph from the new font.
Notes: Pairs of opposing voices where notes in both the left- and right-hand columns show an accidental
STEAM-5163 on the same staff position, and where the note in the right-hand column closest to a note in the left-hand
column is at an adjacent staff position, are no longer offset by an unexpectedly large distance.
Notes: Syncopated patterns of the form short-dotted long (e.g. quarter-dotted half in 4/4) are now
STEAM-4989 notated according to the options set in Notation Options regardless of whether or not the dotted long
note is also tied out of the bar.
Page layout: Changing the master page set of a layout on the Page Setup page of Layout Options is
STEAM-5357 now reflected immediately in the display in the Master Pages section of the right-hand panel in Engrave
mode.
STEAM-5187 Page layout: Under rare circumstances, staff labels would sometimes fail to update after undoing an edit
that results in the point at which an instrument change occurs changing. This has now been resolved.
STEAM-5287 Playback: Dynamics are no longer ignored during playback if the flow begins with a rest.
STEAM-5394 Playback: Multiple dynamics on the same note are now played back more sensibly.
STEAM-5369 Playback: Accents now play back correctly when notes with accents alternate with notes without accents.
STEAM-5371 Playback: Playing techniques on the very first note of the flow now play back correctly.
AD-269 Playback: Typing Command-Q while a VST plug-in window is in focus no longer incorrectly quits the VST

audio engine, resulting in Dorico itself hanging upon exit.
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ID # Issue
AD-253 Playback: A problem whereby the VST audio engine could crash when used on a computer with on-board
Realtek sound hardware has been fixed (Windows only).
AD-260 Playback: When reopening a saved project that uses Kontakt, a burst of static is no longer sometimes
emitted as the project loads (Mac only).
STEAM-5401 Rests: It is now possible to set properties, including the staff position, of bar rests correctly once more.
Selections: Edit » Select All now selects only the music in the current flow, not across all flows in the
STEAM-5356 .
project.
STEAM-5385 Slurs: Slurs are no longer temporarily incorrectly positioned if Edit » Reset Appearance is invoked when
both the slur itself and the notes at either end of the slur are selected.
Staff spacing: Using Alt+click-drag to drag a staff containing one or more instrument changes now works
STEAM-5399
correctly.
Staff spacing: Copy Staff Spacing will now work even if the user has not made any adjustments to the
STEAM-5370 .
staff spacing on the source page.
Text: Pasting text terminated by a null character (e.g. from a text block in Finale) into Dorico will no longer
STEAM-5406 . )
cause the project to become corrupted when saving.
STEAM-4963 Text: Changing the stretch for text in a text item or text frame now correctly changes the shape of the
characters themselves, rather than merely the distance between characters (Mac only).
STEAM-4971 Text: Changing the stretch for text in a text item or text frame now displays correctly on screen and is
reproduced correctly both when printing and when exporting PDF graphics (Windows only).
STEAM-5358 Text: Changing the point size of multiple selected paragraphs using the controls in the text editing
popover now works correctly, rather than changing the size of only the first selected paragraph.
Text: The size of the text editor is no longer incorrect when editing a text item belonging to a staff that
STEAM-5434 )
uses a non-default staff size.
STEAM-5177 Ties: When Tie endpoint positioning in chords is set to Outermost ties above/below noteheads,
others between, Dorico no longer sometimes incorrectly offsets the wrong tie in multi-voice contexts.
STEAM-5395 User interface: Message boxes spawned from one of Dorico’s options dialogs no longer cause the
options dialog itself to disappear behind the main project window (Windows only).
STEAM-5381 User interface: It is no longer possible under some circumstances to show more than one instance of the
Layout Options or Notation Options dialog for a given score simultaneously.
User interface: The color picker dialog no longer increases in height slightly with each invocation within a
STEAM-5263 .
session (Mac only).
User interface: It is no longer possible to click the various Save as Default buttons in the Layout Options
STEAM-5392 and Notation Options dialogs when more than one layout or flow respectively is selected; being able to
do this in earlier versions could result in the saved options data being incomplete or inconsistent.
User interface: Menu items that can be checked to show their state now correctly show the assigned key
STEAM-4527 .
command, if any.
Dorico will no longer fail to start if the user’s saved layout options data is incomplete or inconsistent;
STEAM-5393

instead, the data will simply be ignored.
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ID # Issue

Dorico will no longer crash on start-up if it is unable to create the user's chosen default project save
STEAM-5360 fold
older.
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This version contains the following improvements and issue resolutions.

This maintenance update introduces the following improvements:

Performance improvements

= The speed of note input, and undoing note input, has been substantially
increased.

= The speed of changing the pitch of a selection of notes using Alt+up/down
arrow has been substantially increased.

= The speed of adding and removing players in Setup mode has been
substantially increased.

= Unnecessary screen redraws during editing operations have been eliminated,
providing a substantial improvement in the speed of redraw during editing
operations.

= The speed of creating a new project from a template has been substantially
increased.

= The speed of entering and working within Print mode has been substantially
increased.

Articulations

A new group of options Slurs on the Articulations page of Engraving Options
allow you to determine whether articulations of force (accent, marcato) or
articulations of stress (stress, unstress) should be positioned inside or outside slur
endpoints.

A new option Position of tenuto relative to tied notes has been added to the
Ties group on the Articulations page of Engraving Options, allowing you to
choose whether tenuto articulations should be positioned on the first or last note of
a chain of tied notes by default. An additional property has also been added to
allow this default to be overridden for an individual tenuto.

Beams

A new option has been added to the Advanced Options section of the Slants
group on the Beams page of Engraving Options, allowing you to specify whether
beams containing repeated patterns of pitches should be allowed to have slants, or
should always be horizontal.
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Brackets and braces

A new option has been added to the Approach group on the Brackets and
Braces page of Engraving Options, allowing you to specify whether groups

consisting of a single staff should show a bracket.

Two new choices have been added to the Ensemble type option in the same
group: British brass band (which provides separate bracketing groups for
cornets; flugelhorn; tenor horns; baritone horns; trombone and bass trombone;
euphonium; and percussion), and Big band (which provides separate bracketing
groups for saxophones; trumpets; trombone and bass trombone; and rhythm

section).

Key signatures and accidentals

* Instruments with (no key) in their names (e.g. French horn, timpani, etc.) are
now correctly created with no key signatures, and instead show accidentals on
every note as necessary.

= An open or atonal key signature can now be created via the Shift+K popover by
typing open or atonal.

= |t is now possible to change the enharmonic spelling of notes in part layouts
independently of the full score layout.

Licensing

When using a time-limited or trial license, Dorico will now report the time remaining
in the license at start-up, every 10 days, and every day during the final five days of

the license period.

Lyrics

New Minimum distance from other items option in the Vertical Position section
of the Lyrics page in Engraving Options provides a small amount of padding
between items protruding outside the staff and the closest edge of the innermost

line of lyrics.

New option to show or hide elision slurs on lyrics in Japanese and other East Asian
languages by default, in the East Asian Lyrics section of the Lyrics page in
Engraving Options. In addition, there is a new property to override this default

setting for an individual lyric.

Note input and editing

* A new scissors tool (shortcut U) has been added. Outside of note input, the
scissors tool will remove any ties in the selected notes and chords. Inside note
input, the scissors tool will cut any sounding notes in the voice indicated on the
caret that are sounding at the current caret position.
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A new option Play notes during note input and selection has been added to
the General page of Preferences.

New Write » Input Pitch submenu allows you to choose between inputting in
Written Pitch or Sounding Pitch, which is useful when inputting into
transposing instruments or when copying instrumental parts.

Page layout

The Edit » Breaks and Edit » Note Spacing menus have been removed, with
their functions moved to the Engrave menu, in recognition of the fact that
system and frame breaks can only be created in Engrave mode. New Edit »
Format Systems and Edit » Format Music Frames submenus have been
added, containing not only System Break and Frame Break, but also Lock
Frame, Lock System, Make Into System, and Make Into Frame.

The default key command for system break is now Shift+S, and for frame break
it is now Shift+F.

Playback

A new option Suspend audio device in background has been added to the
General page of Preferences, switched off by default. When switched on, this
option releases the audio device when Dorico loses focus, unless it is playing
back at the time, in which case Dorico retains ownership of the audio devices
so that playback can continue.

Basic playback of changes in playing techniques has now been implemented for
HALion Symphonic Orchestra, allowing playback of e.g. pizz. and arco
instructions.

The Mixer window now labels each fader with the plug-in output channel and
the short instrument name, and each fader is also color-coded using the same
colors used in the track header for each instrument in Play mode.

The playhead is now shown in Play mode, and it moves through the music
during playback.

Selections

Navigating around the music with the arrow keys in Write mode has now been
substantially improved.

Use Tab and Shift-Tab to select the next/previous barline in Write mode.

It is possible to start navigation in Write mode without the mouse: simply press
any arrow key, which will select the first item closest to the top left corner of the
view.

Extending the selection by holding Shift and using the arrow keys now works
more reliably; hold Ctrl (Windows) or Command (Mac) to extend the selection
by a bar at a time.
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= Clicking within the staff but not on a note or other item now selects all of the
music in that bar on that staff; hold Shift and click on another item or a blank
part of the same or another to extend the selection.

= New Edit » Select to End of System and Edit » Select to End of Flow menu
items, to quickly extend the selection on the selected staff or staves to the end
of the system or the end of the flow, respectively. In addition, Edit » Select All
now works as expected.

* Holding Ctrl (Windows) or Command (Mac) while making a marquee selection
now adds to an existing selection; holding Ctrl+Alt (Windows) or
Command+Opt (Mac) while making a marquee selection now subtracts from
an existing selection.

* The middle mouse button can now be used instead of Shift to toggle between
the default action when clicking and dragging, i.e. between moving the view or
making a marquee selection.

= Dragging a marquee selection over a barline will no longer select the barline.

Time signatures

Hidden time signatures are now shown using signposts, which allows them to be
selected for copying and pasting, or for deletion. A new View > Signposts » Time
Signatures menu item allows you to choose whether or not signposts for hidden
time signatures should be displayed.

Transposing

A new Write » Transpose dialog has been added, allowing the selected music or,
if there is no selection, the entire flow to be transposed. Transposition can be
specified either by quality of interval (e.g. major, minor, perfect, augmented,
diminished) or by number of divisions of the octave. The dialog will not allow illegal
transpositions that would result in notes that cannot be notated (e.g. sharper than a
triple sharp, or flatter than a triple sharp, or using a microtonal accidental that does
not exist in the current tonality system).

In addition, a new Write » Add Notes Above or Below dialog has been added,
allowing the addition of notes of a given interval above or below the selected notes,
providing a quick way of building chords over an extended passage of music.

Tuplets

Tuplets now show signposts if the tuplet ratio number/string is hidden, which
allows them to be selected for copying and pasting, or for deletion. A new View »
Signposts > Tuplets menu item allows you to choose whether or not signposts for
hidden tuplets should be displayed.
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Vertical spacing
A new Staff Spacing section has been added to the left-hand panel in Engrave
mode, allowing you to edit the vertical spacing of the music when switched on.
Staves can be dragged with the mouse by clicking anywhere in the staff itself, or in
the handle at the left-hand side of the system. The whole system can be dragged
by clicking in the colored stripe immediately above the top staff in the system.

Hold Alt while dragging a staff or system to also adjust the distance between all of
the staves and systems below the staff or system being dragged, when there is no

further room at the bottom of the music frame.

Use the up/down arrow keys to select the handles at the left-hand side of the
system; use Tab to cycle between selecting handles for systems and handles for
staves. Hold Shift and use up/down arrow to extend the selection to the handle
above/below.

Nudge the selected staff, staves and/or systems using Alt+up/down arrow, and
add Ctrl (Windows) or Command (Mac) to nudge in larger steps.

Use Alt+J/K to nudge the selected staff, staves and/or system such that the
distance between all of the staves and systems below the staves being nudged will
also change, once there is no further room at the bottom of the music frame.

When a staff or system has an overridden position, its handle or the colored stripe
will be colored red. To remove a specific override, select the relevant handle and
click Delete.

To specify an exact distance, click on the numeric read-out in the left-hand margin,
which allows the entry of a specific measurement, using the preferred units of

measurement as determined in Preferences.

To clear all overrides in the selected frame, choose Engrave > Reset Staff
Spacing.

To copy the staff spacing from one page to other pages within the layout, click
Copy Staff Spacing in the Staff Spacing section of the left-hand panel. A dialog
appears in which you can choose the source page and range of destination pages.
The staff spacing will be copied if the destination page has the same number of
systems each containing the same number of staves as the source page.

If the layout of music within the music frame changes because the music is cast off
again, any staff spacing overrides for that passage of music will be removed.

Voices
= The option Gap between adjacent noteheads in different voices in the
Voices section of the Notes page of the Engraving Options dialog now
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respects negative values, allowing notes a second apart in opposing voices to
be positioned more closely together.

= New Edit » Voice submenu, containing options to change the default stem
direction of the voice of the selected note, or if note input is active, to change
the default stem direction of the voice indicated on the caret.

VST Expression Maps

= A new dialog Play » VST Expression Maps has been added, allowing you to
create and edit expression maps to determine how changes in playing
technique should be handled by the chosen virtual instrument.

= VST Expression Maps for Cubase can be imported into your project via Play »
VST Expression Maps.

= A new Endpoint Setup dialog has been added, accessed via each entry in the
VST Instruments panel in Play mode, allowing you to specify which expression
map is used by each channel on the chosen VST instrument.

Issues resolved

The following table lists all issues that have been resolved in this version:

ID # Issue
STEAM-4712 Bars: Using the Shift+B popover to delete bars now also adjusts the position of any time signatures and

key signatures that are affected by the deletion of bars preceding them.
STEAM-5129 Beaming: The behaviour of Edit » Beaming » Beam Together has been improved such that any selection

that includes a tied note at its start or end will produce the expected beaming.

Beaming: A problem whereby rests under beams could be positioned incorrectly under some
STEAM-5040 , )

circumstances has been fixed.
STEAM-5003 Brackets and braces: The options to show sub-brackets and to draw sub-brackets using braces on the

Brackets and Braces page of Engraving Options now work as expected.

Brackets and braces: Organ instruments with three staves now correctly show a brace spanning the
STEAM-5094 )

upper two manual staves, leaving the pedal staff unbracketed.

Brackets and braces: Groups of players created in the Players panel in Setup mode now have separate
STEAM-4997

brackets.
STEAM-4981 Brackets and braces: Staff labels now draw correctly even when partially out of the viewport.

Brackets and braces: Long staff labels are now automatically wrapped if they exceed half the width of the
STEAM-5050 .

music frame.

Brackets and braces: Instruments whose names have been overridden are no longer automatically
STEAM-5099

numbered.

Brackets and braces: Saving and reloading a project in which there are multiple groups of players no
STEAM-5119 9 98 pro) ple grotips ot pay

longer incorrectly changes the order of players on reloading.
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ID # Issue

Copy and paste: Copying and pasting individual dynamics from within a larger group of dynamics will now
STEAM-4944 create new groups containing only the selected dynamics, rather than all of the dynamics from the original

groups.
STEAM-4948 Copy and paste: ltems of different types that are either specific to staves or voices are now mapped

consistently when pasting, so that they don't end up on different staves than expected.
STEAM-5085 Copy and paste: Attempting to paste an implicit rest followed by an explicit rest no longer causes a crash.
STEAM-5007 Copy and paste: When copying and pasting a selection that includes one or more empty instruments, the

destination passage will also offset the appropriate number of empty instruments.
STEAM-5027, Copy and paste: It is now possible to copy from e.g. the right-hand staff of a piano instrument to the left-
STEAM-5041 hand staff, provided the source selection contains only material from a single staff.

Copy and paste: When copying and pasting dynamics, the pasted dynamics are now correctly left
STEAM-5030 Py p pying p g dy p Y y

selected.
STEAM-4837 Copy and paste: Pasting material that includes dynamics or slurs into other staves at the same rhythmic

’ position now result in the pasted dynamics and slurs becoming linked to the dynamics and slurs on the

STEAM-4839

source staves.
STEAM-5086 Dynamics: Attempting to set the color of a selected hairpin in Engrave mode no longer causes a crash.
STEAM-4911 Holds and pauses: It is now possible to add a fermata to the final barline of a flow written in open meter.
STEAM-5181 Holds and pauses: A transitory spacing problem that could result in adding a caesura not resulting in

space being added immediately has been fixed.
STEAM-5145 Holds and pauses: Fermatas attached to barlines now always draw correctly in galley view.

Holds and pauses: Fermatas attached to barlines no longer sometimes cause a bar number at the start of
STEAM-5116 )

the system to move incorrectly.

Instrument changes: Instrument change warning labels now appear correctly when the new instrument
STEAM-5171 ) .

starts playing on the following system

Instrument changes: Instrument changes that occur near the start of the flow are now snapped to the start
STEAM-5167 of the flow if the first instrument held by the player doesn't play at all before the new instrument starts

playing.
STEAM-5160 Instrument changes: The light blue staff labels in galley view are now shown on each instrument, rather

than for each player, making it easier to identify which staff is for which instrument held by each player.

Key commands: Key commands shown in tool tips are now correctly updated when key commands are
STEAM-5131 :

edited.

Key commands: Setting a key command in the global context now correctly reports if there is a conflict
STEAM-4672 ) L

with the same key combination in another context.

Key signatures and accidentals: Attempting to create a new accidental type in the Edit Tonality System
STEAM-4985

dialog no longer causes a crash if an existing accidental is not already selected.
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ID # Issue

Key signatures and accidentals: The Edit Key Signature dialog now correctly uses the bass F clef rather
STEAM-5095 .

than the baritone F clef.
STEAM-5057 Key signatures and accidentals: Custom key signatures that use a newly-created accidental type are now

shown correctly in the Custom Key Signatures section of the Key Signatures panel in Write mode.
STEAM-5194 Key signatures and accidentals: Custom key signatures now show the name supplied by the user as a

tool tip when hovering over their button in the Key Signatures panel.

Key signatures and accidentals: Custom key signatures now transpose correctly in layouts set to
STEAM-5136 } ) .

transposing pitch rather than concert pitch.

Key signatures and accidentals: Repitching notes now works correctly in key signatures that have been
STEAM-5028 chosen because they show one fewer sharp or flat than the enharmonic equivalent for transposing

instruments.
STEAM-5070 Layout Options: Saving layout options as the defaults for future projects no longer causes new layouts to

have either the wrong players and flows or no players and flows at all to be attached to them by default.
STEAM-4986 Layout Options: The option Use optical spacing for beams between staves on the Note Spacing page

of Layout Options is now switched on by default in part layouts in new projects.
STEAM-5130 Layout Options: If the saved layout options refer to a non-default set of master pages that is not available

in the new project, Dorico no longer crashes when creating the project.

Lyrics: Lyrics assigned to different voices but with the same line number now have the same vertical
STEAM-5001 o,

position.

Lyrics: Lyric extender lines and hyphens now stop correctly before the systemic barline at the end of the
STEAM-5107

system.

Multi-bar rests: Grace notes positioned before a barline now draw correctly if the bar to which they are
STEAM-5065 . ) )

attached becomes consolidated into a multi-bar rest.
STEAM-5093 Multi-bar rests: Fermatas now correctly cause multi-bar rests to break.

MusicXML import: Key signatures in MusicXML files that specify a number of fifths but no mode now
STEAM-5237 )

import correctly.
STEAM-4812 Note input and editing: Using Space to advance a hairpin past a tuplet no longer engages sticky tuplet

input, causing subsequent music to be overwritten unexpectedly.

Note input and editing: It is now possible to create a tied note longer in duration than a maxima, or 64
STEAM-5138

quarter notes (crotchets).

Note input and editing: When using Lock to Duration, the caret now correctly advances to the end of the
STEAM-5002 . . . .

last note in the voice whose notes are being repitched.
STEAM-4760 Note input and editing.: It i.s nOV\.I possible to play chords on your MIDI keyboard when inputting ties with T

or when Lock to Duration is active.

Note input and editing: The first note input via the mouse can now have an accidental and a rhythm dot if
STEAM-5072

chosen from the panel.

Note input and editing: Double-clicking to start note input in galley view now always shows the caret at
STEAM-5078

the correct location.
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ID # Issue
STEAM-5179 Note input and editing: MIDI step-time input now correctly compensates for the octave transposition of
the instrument (e.g. piccolo, double bass, guitar, tenor voice), if any.
Page layout: Graphics placed in graphics frames on master pages are now correctly saved and loaded
STEAM-5188 a9e fayou: raphics p grap pag d
with the project.
Page layout: A problem that prevented text frames from being deleted in some circumstances has been
STEAM-5083 )
fixed.
Page layout: Using the formatting commands (e.g. make into system/frame, lock system/frame) in one
STEAM-5092 ) .
layout no longer incorrectly removes formatting from other layouts.
STEAM-4984 Page layout: You can now remove overrides from all pages in the layout by clicking the Remove
Overrides button in the Pages section of the right-hand panel in Engrave mode with no pages selected.
Playback: Dorico will now load sounds into all 16 channels of each instance of HALion Sonic SE, rather
STEAM-4886 ) i . .
than leaving the final channel in each instance empty.
Playback: Dorico now compensates correctly for HALion patches that are transposed by one or more
STEAM-4496 .
octaves (e.g. double bass, bass guitar).
Playback: The playback of hairpins has been improved such that immediate dynamics at either or both
STEAM-4792 o
ends of the hairpin are now properly respected.
Playback: Attempting to open another project when the Mixer window is already open for the current
STEAM-4988 i )
project no longer causes Dorico to hang.
Playback: The default voice count for HALion Sonic SE in new projects has been increased from 128 to
STEAM-4955
512.
STEAM-4998 Print mode: A problem whereby staff lines or other lines could appear the wrong thickness on the second
and subsequent pages of exported PDFs has been fixed.
STEAM-5098 Print mode: Exporting graphics files from multiple layouts in a single operation no longer causes a crash.
STEAM-5042 Print mode: The default dots per inch (dpi) value for exported graphics is now 150dpi instead of 72dpi.
STEAM-5097 Print mode: Exporting multiple graphics no longer prompts separately to overwrite any found files: you can
simply confirm that you want to overwrite all existing files at once.
STEAM-5195 Print mode: The Watermark text in the Annotations section of the print options panel will no longer be
cleared incorrectly in the event that multiple selected layouts have conflicting values.
STEAM-5219 Print mode: Attempting to overwrite a graphics file that is locked by the filesystem (e.g. because it is open
in another application) will no longer cause a crash.
Properties: It is no longer possible to set the values for dot diameter, dash length, and gaps between dots
STEAM-4834 .
and dashes for ties and slurs to zero.
STEAM-5063 Properties: Properties for X and Y offset for force and combined dynamics now appear correctly.
STEAM-4570 Rehearsal marks: Rehearsal marks are now correctly centered above double and repeat barlines.
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ID # Issue

Rehearsal marks: If the option to position rehearsal marks at the start of the system is chosen, the
STEAM-4570 . . . .

rehearsal marks are now correctly left-aligned with the systemic barline.
STEAM-5035 Rests: Rests that have properties set on them, e.g. to force a specific duration or to set a particular staff

position, are now positioned in a manner consistent with other rests that don't have properties set.
STEAM-5204, ) . . .

Rests: It is now possible to select all individual rests in Engrave mode.
STEAM-4848

Selection: A problem whereby the marquee rectangle could be left behind if you hit Esc during a marquee
STEAM-4979 ) )

selection has been fixed.

Slurs: A problem that prevented slurs starting in one voice and ending in another from being created
STEAM-5143 )

correctly has been fixed.

Tempo: The Shift+T popover for tempo input is now much more flexible and will allow a much wider set of
STEAM-4953 Y

terms to be input.

Text: Edit » Reset Appearance now clears any changes of font, size, and other typographical control in a
STEAM-5015 .

selected text item.

Text: A problem whereby some Japanese fonts were truncated during text editing has been fixed (Mac
STEAM-5142

only).
STEAM-5061 Text: Creating a new text frame on a master page now sets the default paragraph style correctly.

Text: It is now possible to jump to the name of a specific font in the list of fonts in the text editor popover
STEAM-4975 ; ' .

by typing the first letter or two of its name.

Text: Text frames that are too full now correctly truncate the text within the frame, rather than allowing the
STEAM-5055 .

text to flow outside the frame.

Text: Copying and pasting text into Dorico from another application no longer causes the formatting of the
STEAM-5043 Y PP 9 9

text in the frame to be messed up.

Text: It is now possible to use the Unicode Hex Input input method to input extended Unicode characters
STEAM-5044 . ) . .

into the text editor within Dorico (Mac only).

Text: Paragraph styles in newly-created projects now inherit many of their settings from the Default Text

paragraph style, making it possible to quickly change the main text font in use in your project by editing the

Default Text paragraph style.
STEAM-5154 Time signatures: Newly-created time signatures now correctly show that they are selected after creation.

User interface: The Layout Options, Notation Options, and Engraving Options dialogs now remember
STEAM-5207 which page you were last looking at when you opened the dialog, and show that page when the dialog is

reopened.

User interface: A read-out of the current page size using the user's preferred measurement unit has been
STEAM-5208 .

added to the Page Setup page of Layout Options.

User interface: The view type selector in the status bar no longer gets out of sync with the actual view
STEAM-5182 o

used when switching layout.

User interface: When switching between modes, the state of the Hide/Restore Panels button on the
STEAM-4656

toolbar correctly reflects which panels will be shown or hidden when clicked for that mode.
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ID # Issue

User interface: Dorico no longer crashes when you right-click on a tab and choose to create either a
STEAM-5081 . . )

vertical or horizontal spilit.

User interface: Dorico no longer allows the Mixer or Transport windows to be shown as full screen
STEAM-4978 )

windows (Mac only).
STEAM-4956 User interface: The buttons on the toolbar to hide or show the Mixer and Transport windows now correctly

reflect whether or not the Mixer and Transport windows are actually shown.

User interface: When closing the final project window and the Steinberg Hub is set not to reappear, the
STEAM-4908 )

menus no longer disappear (Mac only).

User interface: New Write » Create Voice and Next Voice menu items, intended to make the Shift+V
STEAM-4528 . . .

and V key commands for use in note input more discoverable.

Zoom: The behaviour of zooming in when the selected item is close to the edge of the viewport has been
STEAM-4039 i

improved.

Zoom: A problem whereby Dorico could crash when switching window mode when the zoom level is set
STEAM-5166 .

to Whole page has been fixed.

Platform support: Dorico now uses DirectWrite to render all text and glyphs in its user interface, which
STEAM-5089 should resolve the problem with icons appearing stretched or out of proportion until Dorico is restarted

(Windows only).
STEAM-4992 Localization: The names of templates that appear in the Steinberg Hub are now localised.

Localization: Typing characters that require the use of the Alt modifier (e.g. [, ] and |) into popovers now
STEAM-5305 yPing ! q (e.g- [ 1 and |) into pop

works correctly on non-English keyboards.
STEAM-5312 Localization: A number of problems with keys that produced accented characters when specifying key

commands in the Key Commands page of Preferences have been fixed.

Localization: The handling of key commands in the Japanese language version of Dorico has been
STEAM-4893

overhauled.
STEAM-5310 Localization: Changing the keyboard language on the Key Commands page of Preferences now takes

effect immediately, rather than requiring a restart of Dorico.
STEAM-5313, Localization: The default key commands for French, Spanish, ltalian, and Portuguese have been revised in
STEAM-5314 relation to the various keyboard handling fixes.
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Dorico 1.0.0

October 2016

Initial release version.
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Known issues and solutions

Frequently asked questions

Answers to frequently asked questions about Dorico can be found online in the

Dorico forum.

Knowledge base

For the latest information about issues and solutions you may encounter when
running Dorico, please consult the Knowledge Base.

Entering the eLicenser Activation Code (Mac only)

When you first run Dorico and are prompted to enter your Activation Code, you
may find that after you have successfully activated your Soft-eLicenser, you must
quit and restart Dorico for the application to detect that it is fully licensed.

Key commands to transpose notes by an octave (Windows only)

The Intel Graphics Adaptor drivers used by many Windows computers define a
default key command to flip the screen by 90, 180 and 270 degrees via a shortcut
Ctrl+Alt+up/down/left/right arrows.

Ctrl+Alt+up/down option conflicts with the key commands in Dorico note input for
transposing notes by an octave.

For information about how to disable the default Intel Graphics Adaptor key
command, consult the Knowledge Base.

Audio export

No progress dialog appears on Mac during audio export. A busy cursor will appear
for the duration of the export operation. Check that the operation has completed
successfully before you try to play back the exported audio file. You can verify that
the export has completed successfully by checking the file size of the exported file:
if it is reported as O bytes, the file is still locked for writing.
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